 All Classes
AbstractDynaQLQueryBuilder
AbstractDynaQueryBuilder
AbstractHttpAuthenticator
AbstractHttpCurrentAccountAccessor
AbstractMessageProcessor
AbstractQLQueryBuilder
Account
AcegiCacheManager
AcegiCacheManagerImpl
Actor
Authenticator
Authorizer
AutoForm
AutoFormElement
AutoFormFilter
AutoFormGroup
AutoFormProfileHelper
CaptchaProcessor
CategoryAccessor
CategoryBackBean
CategoryFilter
CategoryManager
ControlFilter
CurrentAccountAccessor
DBFilterInvocationDefinitionSource
DBMethodDefinitionSource
DataTable
DataTableColumn
DataTableFilter
DataTableProfileHelper
DatasetFilter
DefaultCategoryManager
DefaultResourceManager
DefaultRoleManager
DefaultRoleResourceManager
DefaultUserManager
DefaultUserRoleManager
DictionaryDatasetListener
DictionaryFactory
DiligentMenuFactory
DiligentMenuHelper
DropDownInitializor
DynaAutoSQLQueryBuilder
DynaSQLQueryBuilder
Favorite
Field
FieldSet
FilterAccessor
FilterSecurityInterceptor
FilterUtils
FrameStyleUtils
HQLQueryBuilder
HibernateDaoUtils
IBatisQueryBuilder
JCaptchaImageProcessor
LazyMenuFactory
LazyMenuHelper
ListableAuthorizer
MarmotAuthenticationManager
MarmotDictionaryFactory
MarmotMenuFactory
MarmotMethodAccessDeniedException
MarmotMethodSecurityInterceptor
MarmotSecurityViewModel
MenuElement
MenuFactory
MenuItem
Message
MessageProcessor
MessageReceiver
OutlookBarFilter
PaginationSupport
Permission
PermissionAccessor
PermissionBackBean
Preference
PreferenceCategory
PreferenceDefinition
PreferenceHandler
PreferenceUtils
PreferencesExprContextMap
PropertiesInfo
ProxyBackBean
ProxyUser
QL
QLUtils
Query
QueryBuilder
QueryCategory
QueryDatasetListener
QueryParameter
QuerySQL
QuerySort
QueryTemplateField
QueryUserCategory
QueryWhere
ResCategory
Resource
ResourceBackBean
ResourceCache
ResourceCategory
ResourceCategoryService
ResourceDefinitionSource
ResourceDetails
ResourceManager
ResourceService
Role
RoleBackBean
RoleManager
RoleRes
RoleResourceManager
SQLQueryBuilder
SecurityExprHandler
SecurityResource
SecurityUtils
SecurityUtils
SecurityViewModel
ServiceUtil
SimpleFilter
StandardQueryBuilder
TabSetFilter
User
UserBackBean
UserManager
UserRole
UserRoleManager
UserRoleService
UserService


Constant Field Values

Contents
  • org.marmot.*
org.marmot.*

org.marmot.framework.menu.domain.MenuItem
public static final int | MENU_ITEM | 0
public static final int | SEPERATOR | 1

org.marmot.framework.message.domain.Actor
public static final int | GROUP | 1
public static final int | PERSON | 0

org.marmot.security.cache.ResourceCache
public static final String | RESOURCE_CONTROL | "control"
public static final String | RESOURCE_METHOD | "method"
public static final String | RESOURCE_URL | "url"

org.marmot.security.filter.FilterAccessor
public static final String | CATEGORY_CONTROLS | "Controls"
public static final String | CATEGORY_DATASETS | "Datasets"
public static final String | CATEGORY_DIRECTORY | "Directory"
public static final String | CATEGORY_URL | "URL"

org.marmot.security.service.PaginationSupport
public static final int PAGESIZE 30

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

Deprecated API

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help

PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Exceptions
  • Errors

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Overview

PREV NEXT FRAMES NO FRAMES

Marmot Core API

Packages
org.marmot.framework.dict.domain | 数据字典工厂相关的域模型对象.
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view |
org.marmot.framework.dorado | Marmot Framework提供的Dorado扩展.
org.marmot.framework.main | 应用主框架的相关实现.
org.marmot.framework.menu.domain | 动态菜单工厂相关的域模型对象.
org.marmot.framework.menu.factory | 动态菜单工厂的接口及相关实现.
org.marmot.framework.menu.view | 动态菜单工厂的视图层实现.
org.marmot.framework.message.domain | 实时消息功能相关的域模型对象.
org.marmot.framework.message.manager | 实时消息功能的的管理类和维护类.
org.marmot.framework.preference | 系统属性功能的扩展接口及相关实现.
org.marmot.framework.preference.domain | 系统属性功能相关的域模型对象.
org.marmot.framework.preference.manager |
org.marmot.framework.profile.domain |
org.marmot.framework.profile.view |
org.marmot.framework.query.builder |
org.marmot.framework.query.domain |
org.marmot.framework.query.view |
org.marmot.framework.security | 权限功能的扩展接口及相关实现.
org.marmot.framework.security.captcha |
org.marmot.framework.util | Marmot Framework的工具类.
org.marmot.security.cache |
org.marmot.security.core |
org.marmot.security.definition |
org.marmot.security.domain |
org.marmot.security.dorado |
org.marmot.security.exception |
org.marmot.security.filter |
org.marmot.security.intercept.method |
org.marmot.security.intercept.method.aopalliance |
org.marmot.security.intercept.web |
org.marmot.security.manager |
org.marmot.security.service |
org.marmot.security.util |
org.marmot.security.view |

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Field

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dict.domain
Class Field

java.lang.Object
    extended by org.marmot.framework.dict.domain.Field
All Implemented Interfaces:
Serializable
public class Field
extends Object
implements Serializable

字段描述信息的域模型

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
Field()
Method Summary
String | getDefaultValue()
String | getDescription()
String | getDropDownMeta()
String | getDropDownScript()
String | getDropDownType()
String | getId()
String | getLabel()
int | getMaxLength()
String | getName()
String | getPattern()
Map | getProperties()
String | getSetId()
Integer | getSortOrder()
String | getType()
boolean | isReadOnly()
boolean | isRequired()
boolean | isVisible()
void | setDefaultValue(String defaultValue)
void | setDescription(String description)
void | setDropDownMeta(String dropDownMeta)
void | setDropDownScript(String dropDownScript)
void | setDropDownType(String dropDownType)
void | setId(String id)
void | setLabel(String label)
void | setMaxLength(int maxLength)
void | setName(String name)
void | setPattern(String pattern)
void | setProperties(Map properties)
void | setReadOnly(boolean readOnly)
void | setRequired(boolean required)
void | setSetId(String setId)
void | setSortOrder(Integer sortOrder)
void | setType(String type)
void | setVisible(boolean visible)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Field

public Field()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getDescription

public String getDescription()

setDescription

public void setDescription(String description)

getDropDownMeta

public String getDropDownMeta()

setDropDownMeta

public void setDropDownMeta(String dropDownMeta)

getDropDownType

public String getDropDownType()

setDropDownType

public void setDropDownType(String dropDownType)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)

getName

public String getName()

setName

public void setName(String name)

getType

public String getType()

setType

public void setType(String type)

getMaxLength

public int getMaxLength()

setMaxLength

public void setMaxLength(int maxLength)

isReadOnly

public boolean isReadOnly()

setReadOnly

public void setReadOnly(boolean readOnly)

isRequired

public boolean isRequired()

setRequired

public void setRequired(boolean required)

getSortOrder

public Integer getSortOrder()

setSortOrder

public void setSortOrder(Integer sortOrder)

getProperties

public Map getProperties()

setProperties

public void setProperties(Map properties)

isVisible

public boolean isVisible()

setVisible

public void setVisible(boolean visible)

getSetId

public String getSetId()

setSetId

public void setSetId(String setId)

getDefaultValue

public String getDefaultValue()

setDefaultValue

public void setDefaultValue(String defaultValue)

getDropDownScript

public String getDropDownScript()

setDropDownScript

public void setDropDownScript(String dropDownScript)

getPattern

public String getPattern()

setPattern

public void setPattern(String pattern)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FieldSet

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dict.domain
Class FieldSet

java.lang.Object
    extended by org.marmot.framework.dict.domain.FieldSet
All Implemented Interfaces:
Serializable
public class FieldSet
extends Object
implements Serializable

字段描述信息集合的域模型

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
FieldSet()
Method Summary
List | getFields()
String | getId()
String | getName()
String | getTitle()
String | getUserId()
void | setFields(List fields)
void | setId(String id)
void | setName(String name)
void | setTitle(String title)
void | setUserId(String userId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldSet

public FieldSet()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getName

public String getName()

setName

public void setName(String name)

getFields

public List getFields()

setFields

public void setFields(List fields)

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)

getTitle

public String getTitle()

setTitle

public void setTitle(String title)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.dict.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.dict.domain

数据字典工厂相关的域模型对象.

See:
Description

Class Summary
Field | 字段描述信息的域模型
FieldSet | 字段描述信息集合的域模型

Package org.marmot.framework.dict.domain Description

数据字典工厂相关的域模型对象.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


DictionaryFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dict.factory
Interface DictionaryFactory

All Known Implementing Classes:
MarmotDictionaryFactory
public interface DictionaryFactory

数据字典信息的采集工厂接口.

Author:
Benny Bao

Method Summary
FieldSet | getFieldSet(Account account, String fieldSetName) 根据帐号信息和集合名返回一个数据字典中的字段信息集合.
Field | getFieldSet(Account account, String fieldSetName, String fieldName) 根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.

Method Detail

getFieldSet

public FieldSet getFieldSet(Account account,
                            String fieldSetName)
                     throws Exception
根据帐号信息和集合名返回一个数据字典中的字段信息集合.

Parameters:
account - 帐号
fieldSetName - 集合名
Returns:
字段信息集合
Throws:
Exception

getFieldSet

public Field getFieldSet(Account account,
                         String fieldSetName,
                         String fieldName)
                  throws Exception
根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.

Parameters:
account - 帐号
fieldSetName - 集合名
Returns:
字段描述信息对象
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MarmotDictionaryFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dict.factory
Class MarmotDictionaryFactory

java.lang.Object
    extended by org.marmot.framework.dict.factory.MarmotDictionaryFactory
All Implemented Interfaces:
DictionaryFactory
public class MarmotDictionaryFactory
extends Object
implements DictionaryFactory

默认的数据字典工厂的实现类.

Author:
Benny Bao

Constructor Summary
MarmotDictionaryFactory()
Method Summary
FieldSet | getFieldSet(Account account, String fieldSetName) 根据帐号信息和集合名返回一个数据字典中的字段信息集合.
Field | getFieldSet(Account account, String fieldSetName, String fieldName) 根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.
void | setDictionaryManager(org.marmot.framework.dict.manager.DictionaryManager dictionaryManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MarmotDictionaryFactory

public MarmotDictionaryFactory()
Method Detail

setDictionaryManager

public void setDictionaryManager(org.marmot.framework.dict.manager.DictionaryManager dictionaryManager)

getFieldSet

public FieldSet getFieldSet(Account account,
                            String fieldSetName)
                     throws Exception
Description copied from interface: DictionaryFactory
根据帐号信息和集合名返回一个数据字典中的字段信息集合.

Specified by:
getFieldSet in interface DictionaryFactory
Parameters:
account - 帐号
fieldSetName - 集合名
Returns:
字段信息集合
Throws:
Exception

getFieldSet

public Field getFieldSet(Account account,
                         String fieldSetName,
                         String fieldName)
                  throws Exception
Description copied from interface: DictionaryFactory
根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.

Specified by:
getFieldSet in interface DictionaryFactory
Parameters:
account - 帐号
fieldSetName - 集合名
Returns:
字段描述信息对象
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.dict.factory

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.dict.factory

数据字典工厂的接口及相关实现.

See:
Description

Interface Summary
DictionaryFactory 数据字典信息的采集工厂接口.

Class Summary
MarmotDictionaryFactory 默认的数据字典工厂的实现类.

Package org.marmot.framework.dict.factory Description

数据字典工厂的接口及相关实现.

Overview Package Class Use Tree Deprecated Index Help


DictionaryDatasetListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dict.view
Class DictionaryDatasetListener

java.lang.Object
    extended by com.bstek.dorado.data.AbstractDatasetListener
        extended by org.marmot.framework.dict.view.DictionaryDatasetListener
All Implemented Interfaces:
com.bstek.dorado.data.DatasetListener, EventListener
public class DictionaryDatasetListener
extends com.bstek.dorado.data.AbstractDatasetListener

Constructor Summary
DictionaryDatasetListener()
Method Summary
void | afterCreateFields(com.bstek.dorado.data.Dataset dataset)
boolean | beforeCreateFields(com.bstek.dorado.data.Dataset dataset)
protected com.bstek.dorado.data.Field | createField(com.bstek.dorado.data.Dataset dataset, FieldSet fieldSet, Field field)
protected FieldSet | getFieldSet(com.bstek.dorado.data.Dataset dataset)
protected com.bstek.dorado.view.data.validate.ValidatorFactory | getValidatorFactory()
protected void | initBaseField(com.bstek.dorado.data.Field fieldControl, Field field)
protected void | initViewField(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.data.ViewField viewField, Field field) 根据数据字典信息初始化一个Dorado中的ViewField对象.
void | setDictionaryFactory(DictionaryFactory dictionaryFactory)
Methods inherited from class com.bstek.dorado.data.AbstractDatasetListener
afterLoadData, afterUpdateData, beforeLoadData, beforeUpdateData, onInit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DictionaryDatasetListener

public DictionaryDatasetListener()
Method Detail

setDictionaryFactory

public void setDictionaryFactory(DictionaryFactory dictionaryFactory)

getValidatorFactory

protected com.bstek.dorado.view.data.validate.ValidatorFactory getValidatorFactory()
                                                                            throws Exception
Throws:
Exception

getFieldSet

protected FieldSet getFieldSet(com.bstek.dorado.data.Dataset dataset)
                        throws Exception
Throws:
Exception

createField

protected com.bstek.dorado.data.Field createField(com.bstek.dorado.data.Dataset dataset,
                                                  FieldSet fieldSet,
                                                  Field field)

initBaseField

protected void initBaseField(com.bstek.dorado.data.Field fieldControl,
                             Field field)
                      throws Exception
Throws:
Exception

initViewField

protected void initViewField(com.bstek.dorado.view.ViewModel viewModel,
                             com.bstek.dorado.view.data.ViewField viewField,
                             Field field)
                      throws Exception
根据数据字典信息初始化一个Dorado中的ViewField对象.

Parameters:
viewModel - dorado中视图模型对象
viewField - dorado的字段对象
field - 用于包装数据字典信息的字段对象
Throws:
Exception

beforeCreateFields

public boolean beforeCreateFields(com.bstek.dorado.data.Dataset dataset)
                           throws Exception
Throws:
Exception

afterCreateFields

public void afterCreateFields(com.bstek.dorado.data.Dataset dataset)
                       throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.dict.view

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.dict.view

Class Summary
DictionaryDatasetListener


org.marmot.framework.dorado

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.dorado

Marmot Framework提供的Dorado扩展.

See:
Description

Class Summary
PreferencesExprContextMap
SecurityExprHandler

Package org.marmot.framework.dorado Description

Marmot Framework提供的Dorado扩展.


PreferencesExprContextMap

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dorado
Class PreferencesExprContextMap

java.lang.Object
    extended by com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
        extended by org.marmot.framework.dorado.PreferencesExprContextMap
All Implemented Interfaces:
Map
public class PreferencesExprContextMap
extends com.bstek.dorado.common.rtexpr.impl.AbstractContextMap

Nested Class Summary
Nested classes inherited from class java.util.Map
Map.Entry
Constructor Summary
PreferencesExprContextMap()
Method Summary
 Object get(Object key)
Methods inherited from class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
clear, containsKey, containsValue, entrySet, equals, isEmpty, keySet, put, putAll, remove, size, values
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
hashCode

Constructor Detail

PreferencesExprContextMap

public PreferencesExprContextMap()
Method Detail

get

public Object get(Object key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SecurityExprHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.dorado
Class SecurityExprHandler

java.lang.Object
    extended by org.marmot.framework.dorado.SecurityExprHandler
public class SecurityExprHandler
extends Object

Author:
Benny Bao

Constructor Summary
SecurityExprHandler()
Method Summary
Account | getCurrentAccount()
boolean | isAuthorized(Object resource)
boolean | isDisabled(Object resource)
boolean | isEnabled(Object resource)
boolean | isIgnored(Object resource)
boolean | isNotAuthorized(Object resource)
boolean | isReadOnly(Object resource)
boolean | isVisible(Object resource)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SecurityExprHandler

public SecurityExprHandler()
Method Detail

getCurrentAccount

public Account getCurrentAccount()

isAuthorized

public boolean isAuthorized(Object resource)

isNotAuthorized

public boolean isNotAuthorized(Object resource)

isReadOnly

public boolean isReadOnly(Object resource)

isVisible

public boolean isVisible(Object resource)

isEnabled

public boolean isEnabled(Object resource)

isDisabled

public boolean isDisabled(Object resource)

isIgnored

public boolean isIgnored(Object resource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FrameStyleUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.main
Class FrameStyleUtils

java.lang.Object
    extended by org.marmot.framework.main.FrameStyleUtils
public abstract class FrameStyleUtils
extends Object

用于辅助处理框架风格的工具类.

Author:
Benny Bao

Method Summary
static String | getPageRoot() 获取当前框架风格的路径.
static void | setPageRoot(String pageRoot, int scope) 设置当前框架风格的路径.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

setPageRoot

public static void setPageRoot(String pageRoot,
                               int scope)
设置当前框架风格的路径.

设置当前风格时,可以通过scope参数来指定该设置的作用返回. scope的取值范围参考com.bstek.dorado.common.DoradoContext,共有以下三种选择:

  • DoradoContext.REQUEST
  • DoradoContext.SESSION
  • DoradoContext.APPLICATION

Parameters:
pageRoot -
scope -

getPageRoot

public static String getPageRoot()
获取当前框架风格的路径. 框架将自动按照REQUEST、SESSION、APPLICATION的顺序来判断并确定当前用户使用的框架风格.

Returns:
框架风格的路径.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.main

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.main

应用主框架的相关实现.

See:
Description

Class Summary
FrameStyleUtils 用于辅助处理框架风格的工具类.

Package org.marmot.framework.main Description

应用主框架的相关实现.


Favorite

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.domain
Class Favorite

java.lang.Object
    extended by org.marmot.framework.menu.domain.MenuElement
        extended by org.marmot.framework.menu.domain.Favorite
All Implemented Interfaces:
Serializable
public class Favorite
extends MenuElement
implements Serializable

收藏项的域模型

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
Favorite()
Method Summary
String | getUserId()
void | setUserId(String userId)
Methods inherited from class org.marmot.framework.menu.domain.MenuElement
getDescription, getDisableIcon, getIcon, getId, getLabel, getMeta1, getMeta2, getMeta3, getPath, getSortOrder, setDescription, setDisableIcon, setIcon, setId, setLabel, setMeta1, setMeta2, setMeta3, setPath, setSortOrder
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Favorite

public Favorite()
Method Detail

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MenuElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.domain
Class MenuElement

java.lang.Object
    extended by org.marmot.framework.menu.domain.MenuElement
Direct Known Subclasses:
Favorite, MenuItem
public abstract class MenuElement
extends Object

菜单元素模型的抽象类.

Author:
Benny Bao

Constructor Summary
MenuElement()
Method Summary
String | getDescription()
String | getDisableIcon()
String | getIcon()
String | getId()
String | getLabel()
String | getMeta1()
String | getMeta2()
String | getMeta3()
String | getPath()
int | getSortOrder()
void | setDescription(String description)
void | setDisableIcon(String disableIcon)
void | setIcon(String icon)
void | setId(String id)
void | setLabel(String label)
void | setMeta1(String meta1)
void | setMeta2(String meta2)
void | setMeta3(String meta3)
void | setPath(String path)
void | setSortOrder(int sortOrder)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MenuElement

public MenuElement()
Method Detail

getDescription

public String getDescription()

setDescription

public void setDescription(String description)

getDisableIcon

public String getDisableIcon()

setDisableIcon

public void setDisableIcon(String disableIcon)

getIcon

public String getIcon()

setIcon

public void setIcon(String icon)

getId

public String getId()

setId

public void setId(String id)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)

getMeta1

public String getMeta1()

setMeta1

public void setMeta1(String meta1)

getMeta2

public String getMeta2()

setMeta2

public void setMeta2(String meta2)

getMeta3

public String getMeta3()

setMeta3

public void setMeta3(String meta3)

getPath

public String getPath()

setPath

public void setPath(String path)

getSortOrder

public int getSortOrder()

setSortOrder

public void setSortOrder(int sortOrder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MenuItem

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.domain
Class MenuItem

java.lang.Object
    extended by org.marmot.framework.menu.domain.MenuElement
        extended by org.marmot.framework.menu.domain.MenuItem
All Implemented Interfaces:
Serializable
public class MenuItem
extends MenuElement
implements Serializable

菜单项的域模型.

Author:
Benny Bao
See Also:
Serialized Form

Field Summary
static int | MENU_ITEM
static int | SEPERATOR
Constructor Summary
MenuItem()
Method Summary
String | getParentItemId()
int | getSubItemCount()
List | getSubItems()
int | getType()
boolean | isEnabled()
boolean | isVisible()
void | setEnabled(boolean enabled)
void | setParentItemId(String parentItemId)
void | setSubItemCount(int subItemCount)
void | setSubItems(List subItems)
void | setType(int type)
void | setVisible(boolean visible)
Methods inherited from class org.marmot.framework.menu.domain.MenuElement
getDescription, getDisableIcon, getIcon, getId, getLabel, getMeta1, getMeta2, getMeta3, getPath, getSortOrder, setDescription, setDisableIcon, setIcon, setId, setLabel, setMeta1, setMeta2, setMeta3, setPath, setSortOrder
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MENU_ITEM

public static final int MENU_ITEM
See Also:
Constant Field Values

SEPERATOR

public static final int SEPERATOR
See Also:
Constant Field Values
Constructor Detail

MenuItem

public MenuItem()
Method Detail

getSubItems

public List getSubItems()

setSubItems

public void setSubItems(List subItems)

isVisible

public boolean isVisible()

setVisible

public void setVisible(boolean visible)

isEnabled

public boolean isEnabled()

setEnabled

public void setEnabled(boolean enabled)

getParentItemId

public String getParentItemId()

setParentItemId

public void setParentItemId(String parentItemId)

getSubItemCount

public int getSubItemCount()

setSubItemCount

public void setSubItemCount(int subItemCount)

getType

public int getType()

setType

public void setType(int type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.menu.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.menu.domain

动态菜单工厂相关的域模型对象.

See:
Description

Class Summary
Favorite | 收藏项的域模型
MenuElement | 菜单元素模型的抽象类.
MenuItem | 菜单项的域模型.

Package org.marmot.framework.menu.domain Description

动态菜单工厂相关的域模型对象.


DiligentMenuFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.factory
Interface DiligentMenuFactory

All Superinterfaces:
MenuFactory
All Known Implementing Classes:
MarmotMenuFactory
public interface DiligentMenuFactory
extends MenuFactory

勤快的动态菜单工厂的接口. 此处的"勤快的"取"懒装载"的反义,意指每次返回菜单项时都会从持久层中取出整个子菜单结构，即取出最底层的子菜单项.

Author:
Benny Bao

Methods inherited from interface org.marmot.framework.menu.factory.MenuFactory
getFavoritiesOfAccount, getMenuItems

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LazyMenuFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.factory
Interface LazyMenuFactory

All Superinterfaces:
MenuFactory
All Known Implementing Classes:
MarmotMenuFactory
public interface LazyMenuFactory
extends MenuFactory

懒装载的动态菜单工厂的接口. 意指每次返回菜单项时进取出第一层的子菜单项.

Author:
Benny Bao

Methods inherited from interface org.marmot.framework.menu.factory.MenuFactory
getFavoritiesOfAccount, getMenuItems

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MarmotMenuFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.factory
Class MarmotMenuFactory

java.lang.Object
    extended by org.marmot.framework.menu.factory.MarmotMenuFactory
All Implemented Interfaces:
DiligentMenuFactory, LazyMenuFactory, MenuFactory
public class MarmotMenuFactory
extends Object
implements LazyMenuFactory, DiligentMenuFactory

默认的动态菜单工厂的实现类.

Author:
Benny Bao

Constructor Summary
MarmotMenuFactory()
Method Summary
List | getFavoritiesOfAccount(Account account) 根据某帐号返回其所有收藏项的集合.
List | getMenuItems(String parentItemId) 根据父菜单项的id返回子菜单项的集合.
void | setFavoriteManager(org.marmot.framework.menu.manager.FavoriteManager favoriteManager)
void | setMenuManager(org.marmot.framework.menu.manager.MenuManager menuManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MarmotMenuFactory

public MarmotMenuFactory()
Method Detail

setMenuManager

public void setMenuManager(org.marmot.framework.menu.manager.MenuManager menuManager)

setFavoriteManager

public void setFavoriteManager(org.marmot.framework.menu.manager.FavoriteManager favoriteManager)

getMenuItems

public List getMenuItems(String parentItemId)
                  throws Exception
Description copied from interface: MenuFactory
根据父菜单项的id返回子菜单项的集合.

如果传入的父菜单项的id为null,将表示返回顶层的菜单项集合.

Specified by:
getMenuItems in interface MenuFactory
Parameters:
parentItemId - 父菜单项的id返
Returns:
菜单项的集合
Throws:
Exception

getFavoritiesOfAccount

public List getFavoritiesOfAccount(Account account)
                            throws Exception
Description copied from interface: MenuFactory
根据某帐号返回其所有收藏项的集合.

Specified by:
getFavoritiesOfAccount in interface MenuFactory
Parameters:
account - 帐号
Returns:
收藏项的集合
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MenuFactory

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.factory
Interface MenuFactory

All Known Subinterfaces:
DiligentMenuFactory, LazyMenuFactory
All Known Implementing Classes:
MarmotMenuFactory
public interface MenuFactory

菜单工厂的接口.

Author:
Benny Bao

Method Summary
List | getFavoritiesOfAccount(Account account) 根据某帐号返回其所有收藏项的集合.
List | getMenuItems(String parentItemId) 根据父菜单项的id返回子菜单项的集合.

Method Detail

getMenuItems

public List getMenuItems(String parentItemId)
                  throws Exception
根据父菜单项的id返回子菜单项的集合.

如果传入的父菜单项的id为null,将表示返回顶层的菜单项集合.

Parameters:
parentItemId - 父菜单项的id返
Returns:
菜单项的集合
Throws:
Exception

getFavoritiesOfAccount

public List getFavoritiesOfAccount(Account account)
                            throws Exception
根据某帐号返回其所有收藏项的集合.

Parameters:
account - 帐号
Returns:
收藏项的集合
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.menu.factory

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.menu.factory

动态菜单工厂的接口及相关实现.

See:
Description

Interface Summary
DiligentMenuFactory | 勤快的动态菜单工厂的接口.
LazyMenuFactory | 懒装载的动态菜单工厂的接口.
MenuFactory | 菜单工厂的接口.

Class Summary
MarmotMenuFactory 默认的动态菜单工厂的实现类.

Package org.marmot.framework.menu.factory Description

动态菜单工厂的接口及相关实现.


DiligentMenuHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.view
Class DiligentMenuHelper

java.lang.Object
    extended by org.marmot.framework.menu.view.AbstractMenuHelper
        extended by org.marmot.framework.menu.view.DiligentMenuHelper
public class DiligentMenuHelper
extends org.marmot.framework.menu.view.AbstractMenuHelper

用于创建一次性装载的菜单控件的辅助类.

Author:
Benny Bao

Constructor Summary
DiligentMenuHelper()
Method Summary
protected com.bstek.dorado.view.control.MenuItem | generateMenuItemControl(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, MenuItem menuItem)
protected com.bstek.dorado.view.control.tree.TreeNode | generateTreeNodeControl(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, MenuItem menuItem)
static DiligentMenuHelper | getInstance() 返回DiligentMenuHelper的实例.
protected MenuFactory | getMenuFactory()
List | getMenuItems(String parentItemId) 根据父菜单项的id返回子菜单项模型的集合.
List | getMenuItems(String parentItemId, int depth) 根据父菜单项的id返回包含了指定深度信息的子菜单项模型的集合.
void | mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer) 将根菜单模型融合进指定的菜单控件或菜单项中.
void | mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, int depth) 将根菜单模型中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.
void | mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, List menuItems) 将给定的菜单项模型集合融合进指定的菜单控件或菜单项中.
void | mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, List menuItems, int depth) 将给定的菜单项模型集合中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.
void | mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, String parentItemId) 将给定的菜单模型融合进指定的菜单控件或菜单项中.
void | mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, String parentItemId, int depth) 将给定的菜单模型中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.
void | mergeTabSet(com.bstek.dorado.view.control.tabset.TabSet tabSet) 将根菜单模型融合进指定的多页标签控件中.
void | mergeTabSet(com.bstek.dorado.view.control.tabset.TabSet tabSet, List menuItems) 将给定的菜单项模型集合融合进指定的多页标签控件中.
void | mergeTabSet(com.bstek.dorado.view.control.tabset.TabSet tabSet, String parentItemId) 将给定的菜单模型融合进指定的多页标签控件中.
void | mergeTree(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, int expandDepth) 将根菜单模型融合进指定的树节点中.
void | mergeTree(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, List menuItems, int expandDepth) 将给定的菜单项模型集合融合进指定的树节点中.
void | mergeTree(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, String parentItemId, int expandDepth) 将给定的菜单模型融合进指定的树节点中.
void | setMenuFactory(MenuFactory menuFactory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DiligentMenuHelper

public DiligentMenuHelper()
Method Detail

getMenuFactory

protected MenuFactory getMenuFactory()

setMenuFactory

public void setMenuFactory(MenuFactory menuFactory)

getInstance

public static DiligentMenuHelper getInstance()
返回DiligentMenuHelper的实例.

Returns:

getMenuItems

public List getMenuItems(String parentItemId)
                  throws Exception
根据父菜单项的id返回子菜单项模型的集合.

如果传入的父菜单项的id为null,将表示返回顶层的菜单项模型集合.

即使DiligentMenuHelper中注入的MenuFactory是LazyMenuFactory的实现类, 此方法也能够保证返回的菜单项全部包含最深层的叶子信息。

Parameters:
parentItemId - 父菜单项的id
Returns:
菜单项的集合
Throws:
Exception

getMenuItems

public List getMenuItems(String parentItemId,
                         int depth)
                  throws Exception
根据父菜单项的id返回包含了指定深度信息的子菜单项模型的集合.

如果传入的父菜单项的id为null,将表示返回顶层的菜单项模型集合.

此方法仅在DiligentMenuHelper中注入的MenuFactory是LazyMenuFactory的实现类时才有效. 此方法会根据depth参数的数值利用LazyMenuFactory装载指定深度的菜单项.

Parameters:
parentItemId - 父菜单项的id
depth - 要装在子菜单信息的深度,如果指定此参数的数值为-1将表示要装载所有的子菜单项,即装载到叶子信息。
Returns:
Throws:
Exception

mergeMenu

public void mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer)
               throws Exception
将根菜单模型融合进指定的菜单控件或菜单项中.

Parameters:
menuItemContainer - 菜单控件或菜单项
Throws:
Exception

mergeMenu

public void mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                      String parentItemId)
               throws Exception
将给定的菜单模型融合进指定的菜单控件或菜单项中.

Parameters:
menuItemContainer - 菜单控件或菜单项
parentItemId - 根菜单项模型的id
Throws:
Exception

mergeMenu

public void mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                      List menuItems)
               throws Exception
将给定的菜单项模型集合融合进指定的菜单控件或菜单项中.

Parameters:
menuItemContainer - 菜单控件或菜单项
menuItems - 菜单项模型集合
Throws:
Exception

mergeMenu

public void mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                      int depth)
               throws Exception
将根菜单模型中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.

Parameters:
menuItemContainer - 菜单控件或菜单项
depth - 要处理的子菜单项模型的最大深度
Throws:
Exception

mergeMenu

public void mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                      String parentItemId,
                      int depth)
               throws Exception
将给定的菜单模型中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.

Parameters:
menuItemContainer - 菜单控件或菜单项
parentItemId - 根菜单项模型的id
depth - 要处理的子菜单项模型的最大深度
Throws:
Exception

mergeMenu

public void mergeMenu(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                      List menuItems,
                      int depth)
               throws Exception
将给定的菜单项模型集合中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.

Parameters:
menuItemContainer - 菜单控件或菜单项
menuItems - 菜单项模型集合
depth - 要处理的子菜单项模型的最大深度
Throws:
Exception

mergeTree

public void mergeTree(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                      int expandDepth)
               throws Exception
将根菜单模型融合进指定的树节点中.

Parameters:
parentTreeNode - 树节点
expandDepth - 节点预展开的深度
Throws:
Exception

mergeTree

public void mergeTree(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                      String parentItemId,
                      int expandDepth)
               throws Exception
将给定的菜单模型融合进指定的树节点中.

Parameters:
parentTreeNode - 树节点
parentItemId - 根菜单项模型的id
expandDepth - 节点预展开的深度
Throws:
Exception

mergeTree

public void mergeTree(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                      List menuItems,
                      int expandDepth)
               throws Exception
将给定的菜单项模型集合融合进指定的树节点中.

Parameters:
parentTreeNode - 树节点
menuItems - 菜单项模型集合
expandDepth - 节点预展开的深度
Throws:
Exception

mergeTabSet

public void mergeTabSet(com.bstek.dorado.view.control.tabset.TabSet tabSet)
                 throws Exception
将根菜单模型融合进指定的多页标签控件中.

Parameters:
tabSet - 多页标签控件
Throws:
Exception

mergeTabSet

public void mergeTabSet(com.bstek.dorado.view.control.tabset.TabSet tabSet,
                        String parentItemId)
                 throws Exception
将给定的菜单模型融合进指定的多页标签控件中.

Parameters:
tabSet - 多页标签控件
parentItemId - 根菜单项模型的id
Throws:
Exception

mergeTabSet

public void mergeTabSet(com.bstek.dorado.view.control.tabset.TabSet tabSet,
                        List menuItems)
                 throws Exception
将给定的菜单项模型集合融合进指定的多页标签控件中.

Parameters:
tabSet - 多页标签控件
menuItems - 菜单项模型集合
Throws:
Exception

generateMenuItemControl

protected com.bstek.dorado.view.control.MenuItem generateMenuItemControl(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                                                                         MenuItem menuItem)

generateTreeNodeControl

protected com.bstek.dorado.view.control.tree.TreeNode generateTreeNodeControl(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                                                                              MenuItem menuItem)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LazyMenuHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.menu.view
Class LazyMenuHelper

java.lang.Object
    extended by org.marmot.framework.menu.view.AbstractMenuHelper
        extended by org.marmot.framework.menu.view.LazyMenuHelper
public class LazyMenuHelper
extends org.marmot.framework.menu.view.AbstractMenuHelper

用于创建支持懒装载的菜单控件的辅助类.

Author:
Benny Bao

Constructor Summary
LazyMenuHelper()
Method Summary
protected com.bstek.dorado.view.control.MenuItem | generateMenuItemControl(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer, MenuItem menuItem)
protected com.bstek.dorado.view.control.tree.TreeNode | generateTreeNodeControl(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, MenuItem menuItem)
List | getFavorities() 返回当前登录用户的个人收藏项的集合.
static LazyMenuHelper | getInstance() 返回LazyMenuHelper的实例.
protected MenuFactory | getMenuFactory()
List | getMenuItems(String parentItemId) 根据父菜单项的id返回子菜单项模型的集合.
void | initFavoriteMenuItem(com.bstek.dorado.view.control.Menu menu, com.bstek.dorado.view.control.MenuItem favoriteItem) 将给定的菜单项初始化为收藏夹菜单.
void | initFavoriteTreeNode(com.bstek.dorado.view.control.tree.Tree tree, com.bstek.dorado.view.control.tree.TreeNode favoriteNode) 将给定的树节点初始化为收藏夹节点.
void | initMenu(com.bstek.dorado.view.control.Menu menu) 初始化给定的菜单控件.
void | initMenu(com.bstek.dorado.view.control.Menu menu, List menuItems, com.bstek.dorado.view.control.MenuItemContainer menuItemContainer) 初始化给定的菜单控件.
void | initMenu(com.bstek.dorado.view.control.Menu menu, String parentItemId) 初始化给定的菜单控件.
void | initMenu(com.bstek.dorado.view.control.Menu menu, String parentItemId, com.bstek.dorado.view.control.MenuItemContainer menuItemContainer) 初始化给定的菜单控件.
void | initMenuForOutlookBar(com.bstek.dorado.view.control.Menu menu) 初始化用于绑定OutlookBar的菜单控件.
void | initMenuForOutlookBar(com.bstek.dorado.view.control.Menu menu, List menuItems) 初始化用于绑定OutlookBar的菜单控件.
void | initMenuForOutlookBar(com.bstek.dorado.view.control.Menu menu, String parentItemId) 初始化用于绑定OutlookBar的菜单控件.
void | initTree(com.bstek.dorado.view.control.tree.Tree tree, int expandDepth) 将给定树状列表控件初始化为导航菜单树.
void | initTree(com.bstek.dorado.view.control.tree.Tree tree, List menuItems, com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, int expandDepth) 将给定树状列表控件初始化为导航菜单树.
void | initTree(com.bstek.dorado.view.control.tree.Tree tree, String parentItemId, int expandDepth) 将给定树状列表控件初始化为导航菜单树.
void | initTree(com.bstek.dorado.view.control.tree.Tree tree, String parentItemId, com.bstek.dorado.view.control.tree.TreeNode parentTreeNode, int expandDepth) 将给定树状列表控件初始化为导航菜单树.
void | setMenuFactory(LazyMenuFactory menuFactory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LazyMenuHelper

public LazyMenuHelper()
Method Detail

getMenuFactory

protected MenuFactory getMenuFactory()

setMenuFactory

public void setMenuFactory(LazyMenuFactory menuFactory)

getInstance

public static LazyMenuHelper getInstance()
返回LazyMenuHelper的实例.

Returns:

getMenuItems

public List getMenuItems(String parentItemId)
                  throws Exception
根据父菜单项的id返回子菜单项模型的集合.

如果传入的父菜单项的id为null,将表示返回顶层的菜单项模型集合.

Parameters:
parentItemId - 根菜单项模型的id
Returns:
菜单项的集合
Throws:
Exception

getFavorities

public List getFavorities()
                   throws Exception
返回当前登录用户的个人收藏项的集合.

Returns:
Throws:
Exception

initMenu

public void initMenu(com.bstek.dorado.view.control.Menu menu)
              throws Exception
初始化给定的菜单控件.

此方法将利用菜单工厂取出根菜单项模型,并将它们创建为菜单控件根菜单项.

Parameters:
menu - 菜单控件
Throws:
Exception

initMenu

public void initMenu(com.bstek.dorado.view.control.Menu menu,
                     String parentItemId)
              throws Exception
初始化给定的菜单控件.

此方法将利用菜单工厂取出某菜单项模型下的子菜单项模型,并将它们创建为菜单控件根菜单项.

Parameters:
menu - 菜单控件
parentItemId - 父菜单项的id
Throws:
Exception

initMenu

public void initMenu(com.bstek.dorado.view.control.Menu menu,
                     String parentItemId,
                     com.bstek.dorado.view.control.MenuItemContainer menuItemContainer)
              throws Exception
初始化给定的菜单控件.

此方法将利用菜单工厂取出某菜单项模型下的子菜单项模型,并将它们创建到菜单控件中指定的菜单项下.

Parameters:
menu - 菜单控件
parentItemId - 根菜单项模型的id
menuItemContainer - 菜单控件中的某菜单项
Throws:
Exception

initMenu

public void initMenu(com.bstek.dorado.view.control.Menu menu,
                     List menuItems,
                     com.bstek.dorado.view.control.MenuItemContainer menuItemContainer)
              throws Exception
初始化给定的菜单控件.

此方法将根据menuItems参数中包含的子菜单项模型在给定的菜单项中创建子菜单项.

Parameters:
menu - 菜单控件
menuItems - 根菜单项模型的id
menuItemContainer - 菜单控件中的某菜单项
Throws:
Exception

initMenuForOutlookBar

public void initMenuForOutlookBar(com.bstek.dorado.view.control.Menu menu)
                           throws Exception
初始化用于绑定OutlookBar的菜单控件.

此方法将利用菜单工厂取出根菜单项模型,并将它们创建为菜单控件根菜单项.

Parameters:
menu - 菜单控件
Throws:
Exception

initMenuForOutlookBar

public void initMenuForOutlookBar(com.bstek.dorado.view.control.Menu menu,
                                  String parentItemId)
                           throws Exception
初始化用于绑定OutlookBar的菜单控件.

此方法将利用菜单工厂取出某菜单项模型下的子菜单项模型,并将它们创建为菜单控件根菜单项.

Parameters:
menu - 菜单控件
parentItemId - 根菜单项模型的id
Throws:
Exception

initMenuForOutlookBar

public void initMenuForOutlookBar(com.bstek.dorado.view.control.Menu menu,
                                  List menuItems)
                           throws Exception
初始化用于绑定OutlookBar的菜单控件.

此方法将根据menuItems参数中包含的子菜单项模型在给定的菜单项中创建子菜单项.

Parameters:
menu - 菜单控件
menuItems - 子菜单项模型的集合
Throws:
Exception

initFavoriteMenuItem

public void initFavoriteMenuItem(com.bstek.dorado.view.control.Menu menu,
                                 com.bstek.dorado.view.control.MenuItem favoriteItem)
                          throws Exception
将给定的菜单项初始化为收藏夹菜单.

Parameters:
menu - 菜单控件
favoriteItem - 将要初始化为收藏夹的菜单项
Throws:
Exception

initTree

public void initTree(com.bstek.dorado.view.control.tree.Tree tree,
                     int expandDepth)
              throws Exception
将给定树状列表控件初始化为导航菜单树.

此方法将利用菜单工厂取出根菜单项模型,并将它们创建为导航菜单树的根节点.

Parameters:
tree - 树状列表控件
expandDepth - 节点预展开的深度
Throws:
Exception

initTree

public void initTree(com.bstek.dorado.view.control.tree.Tree tree,
                     String parentItemId,
                     int expandDepth)
              throws Exception
将给定树状列表控件初始化为导航菜单树.

此方法将利用菜单工厂取出某菜单下的子菜单项模型,并将它们创建为导航菜单树的根节点.

Parameters:
tree - 树状列表控件
parentItemId - 根菜单项模型的id
expandDepth - 节点预展开的深度
Throws:
Exception

initTree

public void initTree(com.bstek.dorado.view.control.tree.Tree tree,
                     String parentItemId,
                     com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                     int expandDepth)
              throws Exception
将给定树状列表控件初始化为导航菜单树.

此方法将利用菜单工厂取出某菜单下的子菜单项模型,并将它们创建到导航菜单树的指定节点下.

Parameters:
tree - 树状列表控件
parentItemId - 根菜单项模型的id
parentTreeNode - 导航菜单树中的某个树节点
expandDepth - 节点预展开的深度
Throws:
Exception

initTree

public void initTree(com.bstek.dorado.view.control.tree.Tree tree,
                     List menuItems,
                     com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                     int expandDepth)
              throws Exception
将给定树状列表控件初始化为导航菜单树.

此方法将根据menuItems参数中包含的子菜单项模型在给定的树节点中创建子节点.

Parameters:
tree - 树状列表控件
menuItems - 子菜单项模型的集合
parentTreeNode - 导航菜单树中的某个树节点
expandDepth - 节点预展开的深度
Throws:
Exception

initFavoriteTreeNode

public void initFavoriteTreeNode(com.bstek.dorado.view.control.tree.Tree tree,
                                 com.bstek.dorado.view.control.tree.TreeNode favoriteNode)
                          throws Exception
将给定的树节点初始化为收藏夹节点.

Parameters:
tree - 树状列表控件
favoriteNode - 将要初始化为收藏夹的树节点
Throws:
Exception

generateMenuItemControl

protected com.bstek.dorado.view.control.MenuItem generateMenuItemControl(com.bstek.dorado.view.control.MenuItemContainer menuItemContainer,
                                                                         MenuItem menuItem)

generateTreeNodeControl

protected com.bstek.dorado.view.control.tree.TreeNode generateTreeNodeControl(com.bstek.dorado.view.control.tree.TreeNode parentTreeNode,
                                                                              MenuItem menuItem)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.menu.view

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.menu.view

动态菜单工厂的视图层实现.

See:
Description

Class Summary
DiligentMenuHelper | 用于创建一次性装载的菜单控件的辅助类.
LazyMenuHelper | 用于创建支持懒装载的菜单控件的辅助类.

Package org.marmot.framework.menu.view Description

动态菜单工厂的视图层实现.


Actor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.message.domain
Class Actor

java.lang.Object
    extended by org.marmot.framework.message.domain.Actor
All Implemented Interfaces:
Serializable
public class Actor
extends Object
implements Serializable

消息参与者的域模型.

消息参与者既可以是单个用户也可以用户组,通过type属性来加以识别.

Author:
Benny Bao
See Also:
Serialized Form

Field Summary
static int | GROUP
static int | PERSON
Constructor Summary
Actor()
Method Summary
String | getDescription()
String | getEmail()
String | getId()
String | getMeta1()
String | getMeta2()
String | getMeta3()
String | getName()
int | getType()
void | setDescription(String description)
void | setEmail(String email)
void | setId(String id)
void | setMeta1(String meta1)
void | setMeta2(String meta2)
void | setMeta3(String meta3)
void | setName(String name)
void | setType(int type)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PERSON

public static final int PERSON
See Also:
Constant Field Values

GROUP

public static final int GROUP
See Also:
Constant Field Values
Constructor Detail

Actor

public Actor()
Method Detail

getDescription

public String getDescription()

setDescription

public void setDescription(String description)

getId

public String getId()

setId

public void setId(String id)

getMeta1

public String getMeta1()

setMeta1

public void setMeta1(String meta1)

getMeta2

public String getMeta2()

setMeta2

public void setMeta2(String meta2)

getMeta3

public String getMeta3()

setMeta3

public void setMeta3(String meta3)

getName

public String getName()

setName

public void setName(String name)

getType

public int getType()

setType

public void setType(int type)

getEmail

public String getEmail()

setEmail

public void setEmail(String email)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Message

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.message.domain
Class Message

java.lang.Object
    extended by org.marmot.framework.message.domain.Message
All Implemented Interfaces:
Serializable
public class Message
extends Object
implements Serializable

消息的域模型.

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
Message()
Method Summary
String | getId()
String | getMessage()
String | getSender()
String | getSenderName()
Date | getSendTime()
String | getTitle()
boolean | isSendEmail()
void | setId(String id)
void | setMessage(String message)
void | setSendEmail(boolean sendEmail)
void | setSender(String sender)
void | setSenderName(String senderName)
void | setSendTime(Date sendTime)
void | setTitle(String title)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Message

public Message()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getMessage

public String getMessage()

setMessage

public void setMessage(String message)

getSender

public String getSender()

setSender

public void setSender(String sender)

getSendTime

public Date getSendTime()

setSendTime

public void setSendTime(Date sendTime)

getSenderName

public String getSenderName()

setSenderName

public void setSenderName(String senderName)

getTitle

public String getTitle()

setTitle

public void setTitle(String title)

isSendEmail

public boolean isSendEmail()

setSendEmail

public void setSendEmail(boolean sendEmail)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageReceiver

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.message.domain
Class MessageReceiver

java.lang.Object
    extended by org.marmot.framework.message.domain.MessageReceiver
All Implemented Interfaces:
Serializable
public class MessageReceiver
extends Object
implements Serializable

消息接受者的域模型.

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
MessageReceiver()
Method Summary
String | getId()
Message | getMessage()
Date | getNotifyTime()
Date | getReadTime()
Date | getReceivedTime()
String | getReceiver()
boolean | isRead()
boolean | isReceived()
void | setId(String id)
void | setMessage(Message message)
void | setNotifyTime(Date notifyTime)
void | setRead(boolean read)
void | setReadTime(Date readTime)
void | setReceived(boolean received)
void | setReceivedTime(Date receivedTime)
void | setReceiver(String receiver)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MessageReceiver

public MessageReceiver()
Method Detail

isRead

public boolean isRead()

setRead

public void setRead(boolean read)

isReceived

public boolean isReceived()

setReceived

public void setReceived(boolean received)

getId

public String getId()

setId

public void setId(String id)

getMessage

public Message getMessage()

setMessage

public void setMessage(Message message)

getReceiver

public String getReceiver()

setReceiver

public void setReceiver(String receiver)

getReadTime

public Date getReadTime()

setReadTime

public void setReadTime(Date readTime)

getReceivedTime

public Date getReceivedTime()

setReceivedTime

public void setReceivedTime(Date receivedTime)

getNotifyTime

public Date getNotifyTime()

setNotifyTime

public void setNotifyTime(Date notifyTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.message.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.message.domain

实时消息功能相关的域模型对象.

See:
Description

Class Summary
Actor | 消息参与者的域模型.
Message | 消息的域模型.
MessageReceiver | 消息接受者的域模型.

Package org.marmot.framework.message.domain Description

实时消息功能相关的域模型对象.


AbstractMessageProcessor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.message.manager
Class AbstractMessageProcessor

java.lang.Object
    extended by org.marmot.framework.message.manager.AbstractMessageProcessor
All Implemented Interfaces:
MessageProcessor
public abstract class AbstractMessageProcessor
extends Object
implements MessageProcessor

抽像的实时消息处理器. 其中已实现消息收发的基本逻辑.

Author:
Benny Bao

Constructor Summary
AbstractMessageProcessor()
Method Summary
Collection | getNewMessages(String receiver) 返回所有当前消息参与者本人尚未接收的信息.
Collection | getUnreadMessages(String receiver) 返回所有当前消息参与者本人未读的信息.
protected void | sendMail(Message message, Actor sender, Collection receivers) 向所有消息接收者发送EMail.
void | sendMessage(Message message, Actor sender, Set receivers) 发送消息
void | setMessageManager(org.marmot.framework.message.manager.MessageManager messageManager)
void | setMessageReadMark(MessageReceiver messageReceiver) 将某个消息标记为已读.
void | setMessageReceivedMark(MessageReceiver messageReceiver) 将某个消息标记为已接收.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.marmot.framework.message.manager.MessageProcessor
getActor, getChildActors, getRootActors, getSelf

Constructor Detail

AbstractMessageProcessor

public AbstractMessageProcessor()
Method Detail

setMessageManager

public void setMessageManager(org.marmot.framework.message.manager.MessageManager messageManager)

sendMail

protected void sendMail(Message message,
                        Actor sender,
                        Collection receivers)
                 throws Exception
向所有消息接收者发送EMail.

Parameters:
message -
sender -
receivers -
Throws:
Exception

sendMessage

public void sendMessage(Message message,
                        Actor sender,
                        Set receivers)
                 throws Exception
Description copied from interface: MessageProcessor
发送消息

Specified by:
sendMessage in interface MessageProcessor
Parameters:
message -
sender -
receivers -
Throws:
Exception

getNewMessages

public Collection getNewMessages(String receiver)
Description copied from interface: MessageProcessor
返回所有当前消息参与者本人尚未接收的信息.

Specified by:
getNewMessages in interface MessageProcessor
Parameters:
receiver -
Returns:
MessageReceiver的集合.

getUnreadMessages

public Collection getUnreadMessages(String receiver)
Description copied from interface: MessageProcessor
返回所有当前消息参与者本人未读的信息.

Specified by:
getUnreadMessages in interface MessageProcessor
Parameters:
receiver -
Returns:
MessageReceiver的集合.

setMessageReceivedMark

public void setMessageReceivedMark(MessageReceiver messageReceiver)
Description copied from interface: MessageProcessor
将某个消息标记为已接收.

Specified by:
setMessageReceivedMark in interface MessageProcessor
Parameters:
messageReceiver -

setMessageReadMark

public void setMessageReadMark(MessageReceiver messageReceiver)
Description copied from interface: MessageProcessor
将某个消息标记为已读.

Specified by:
setMessageReadMark in interface MessageProcessor
Parameters:
messageReceiver -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MessageProcessor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.message.manager
Interface MessageProcessor

All Known Implementing Classes:
AbstractMessageProcessor
public interface MessageProcessor

实时消息处理器的接口.

Author:
Benny Bao

Method Summary
Actor | getActor(String actorId) 根据id返回参与者对象.
List | getChildActors(String parentActorId) 根据父参与者的id返回子参与者的集合.
Collection | getNewMessages(String receiver) 返回所有当前消息参与者本人尚未接收的信息.
List | getRootActors() 返回根消息参与者的集合.
Actor | getSelf() 返回当前消息参与者本人.
Collection | getUnreadMessages(String receiver) 返回所有当前消息参与者本人未读的信息.
void | sendMessage(Message message, Actor sender, Set receivers) 发送消息
void | setMessageReadMark(MessageReceiver messageReceiver) 将某个消息标记为已读.
void | setMessageReceivedMark(MessageReceiver messageReceiver) 将某个消息标记为已接收.

Method Detail

getRootActors

public List getRootActors()
                   throws Exception
返回根消息参与者的集合.

Returns:
Actor的集合.
Throws:
Exception

getChildActors

public List getChildActors(String parentActorId)
                    throws Exception
根据父参与者的id返回子参与者的集合.

Parameters:
parentActorId - 父参与者的id.
Returns:
Actor的集合.
Throws:
Exception

getActor

public Actor getActor(String actorId)
               throws Exception
根据id返回参与者对象.

Parameters:
actorId -
Returns:
参与者对象.
Throws:
Exception

getSelf

public Actor getSelf()
              throws Exception
返回当前消息参与者本人.

Returns:
参与者对象.
Throws:
Exception

sendMessage

public void sendMessage(Message message,
                        Actor sender,
                        Set receivers)
                 throws Exception
发送消息

Parameters:
message -
sender -
receivers -
Throws:
Exception

getNewMessages

public Collection getNewMessages(String receiver)
返回所有当前消息参与者本人尚未接收的信息.

Parameters:
receiver -
Returns:
MessageReceiver的集合.

setMessageReceivedMark

public void setMessageReceivedMark(MessageReceiver messageReceiver)
将某个消息标记为已接收.

Parameters:
messageReceiver -

getUnreadMessages

public Collection getUnreadMessages(String receiver)
返回所有当前消息参与者本人未读的信息.

Parameters:
receiver -
Returns:
MessageReceiver的集合.

setMessageReadMark

public void setMessageReadMark(MessageReceiver messageReceiver)
将某个消息标记为已读.

Parameters:
messageReceiver -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.message.manager

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.message.manager

实时消息功能的的管理类和维护类.

See:
Description

Interface Summary
MessageProcessor 实时消息处理器的接口.

Class Summary
AbstractMessageProcessor 抽像的实时消息处理器.

Package org.marmot.framework.message.manager Description

实时消息功能的的管理类和维护类.


org.marmot.framework.preference

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.preference

系统属性功能的扩展接口及相关实现.

See:
Description

Class Summary
PreferenceUtils

Package org.marmot.framework.preference Description

系统属性功能的扩展接口及相关实现.


PreferenceUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.preference
Class PreferenceUtils

java.lang.Object
    extended by org.marmot.framework.preference.PreferenceUtils
public abstract class PreferenceUtils
extends Object

Constructor Summary
PreferenceUtils()
Method Summary
static void | clearCache()
static boolean | getBoolean(String property)
static boolean | getBoolean(String property, boolean defaultValue)
static double | getDouble(String property)
static double | getDouble(String property, double defaultValue)
static int | getInt(String property)
static int | getInt(String property, int defaultValue)
static long | getLong(String property)
static long | getLong(String property, long defaultValue)
static String | getString(String property)
static String | getString(String property, String defaultValue)
static void | setBoolean(String property, boolean value)
static void | setDouble(String property, double value)
static void | setInt(String property, int value)
static void | setLong(String property, long value)
static void | setPreferenceHandler(PreferenceHandler handler)
static void | setString(String property, String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreferenceUtils

public PreferenceUtils()
Method Detail

setPreferenceHandler

public static void setPreferenceHandler(PreferenceHandler handler)

clearCache

public static void clearCache()

getString

public static String getString(String property)

getString

public static String getString(String property,
                               String defaultValue)

setString

public static void setString(String property,
                             String value)

getInt

public static int getInt(String property)

getInt

public static int getInt(String property,
                         int defaultValue)

setInt

public static void setInt(String property,
                          int value)

getLong

public static long getLong(String property)

getLong

public static long getLong(String property,
                           long defaultValue)

setLong

public static void setLong(String property,
                           long value)

getDouble

public static double getDouble(String property)

getDouble

public static double getDouble(String property,
                               double defaultValue)

setDouble

public static void setDouble(String property,
                             double value)

getBoolean

public static boolean getBoolean(String property)

getBoolean

public static boolean getBoolean(String property,
                                 boolean defaultValue)

setBoolean

public static void setBoolean(String property,
                              boolean value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.preference.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.preference.domain

系统属性功能相关的域模型对象.

See:
Description

Class Summary
Preference
PreferenceCategory
PreferenceDefinition

Package org.marmot.framework.preference.domain Description

系统属性功能相关的域模型对象.


Preference

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.preference.domain
Class Preference

java.lang.Object
    extended by org.marmot.framework.preference.domain.Preference
All Implemented Interfaces:
Serializable
public class Preference
extends Object
implements Serializable

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
Preference()
Preference(String userId, String name, String value)
Method Summary
String | getId()
String | getName()
String | getUserId()
String | getValue()
void | setId(String id)
void | setName(String name)
void | setUserId(String userId)
void | setValue(String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Preference

public Preference()

Preference

public Preference(String userId,
                  String name,
                  String value)
Method Detail

getName

public String getName()

setName

public void setName(String name)

getValue

public String getValue()

setValue

public void setValue(String value)

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)

getId

public String getId()

setId

public void setId(String id)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PreferenceCategory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.preference.domain
Class PreferenceCategory

java.lang.Object
    extended by org.marmot.framework.preference.domain.PreferenceCategory
All Implemented Interfaces:
Serializable
public class PreferenceCategory
extends Object
implements Serializable

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
PreferenceCategory()
Method Summary
String | getDescription()
String | getId()
List | getPreferenceDefinitions()
int | getSortOrder()
void | setDescription(String description)
void | setId(String id)
void | setPreferenceDefinitions(List preferenceDefinitions)
void | setSortOrder(int sortOrder)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreferenceCategory

public PreferenceCategory()
Method Detail

getDescription

public String getDescription()

setDescription

public void setDescription(String description)

getId

public String getId()

setId

public void setId(String id)

getSortOrder

public int getSortOrder()

setSortOrder

public void setSortOrder(int sortOrder)

getPreferenceDefinitions

public List getPreferenceDefinitions()

setPreferenceDefinitions

public void setPreferenceDefinitions(List preferenceDefinitions)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreferenceDefinition

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.preference.domain
Class PreferenceDefinition

java.lang.Object
    extended by org.marmot.framework.preference.domain.PreferenceDefinition
All Implemented Interfaces:
Serializable
public class PreferenceDefinition
extends Object
implements Serializable

Author:
Benny Bao
See Also:
Serialized Form

Constructor Summary
PreferenceDefinition()
Method Summary
String | getCategoryId()
String | getDataType()
String | getDescription()
String | getDropDownMeta()
String | getDropDownScript()
String | getDropDownType()
String | getEditorType()
String | getName()
int | getSortOrder()
boolean | isOverwritable()
void | setCategoryId(String categoryId)
void | setDataType(String dataType)
void | setDescription(String description)
void | setDropDownMeta(String dropDownMeta)
void | setDropDownScript(String dropDownScript)
void | setDropDownType(String dropDownType)
void | setEditorType(String editorType)
void | setName(String name)
void | setOverwritable(boolean overwritable)
void | setSortOrder(int sortOrder)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PreferenceDefinition

public PreferenceDefinition()
Method Detail

getCategoryId

public String getCategoryId()

setCategoryId

public void setCategoryId(String categoryId)

getDataType

public String getDataType()

setDataType

public void setDataType(String dataType)

getDescription

public String getDescription()

setDescription

public void setDescription(String description)

getDropDownMeta

public String getDropDownMeta()

setDropDownMeta

public void setDropDownMeta(String dropDownMeta)

getDropDownType

public String getDropDownType()

setDropDownType

public void setDropDownType(String dropDownType)

getEditorType

public String getEditorType()

setEditorType

public void setEditorType(String editorType)

getName

public String getName()

setName

public void setName(String name)

isOverwritable

public boolean isOverwritable()

setOverwritable

public void setOverwritable(boolean overwritable)

getSortOrder

public int getSortOrder()

setSortOrder

public void setSortOrder(int sortOrder)

getDropDownScript

public String getDropDownScript()

setDropDownScript

public void setDropDownScript(String dropDownScript)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.preference.manager

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.preference.manager

Interface Summary
PreferenceHandler


PreferenceHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.preference.manager
Interface PreferenceHandler

public interface PreferenceHandler

Method Summary
void | clearCache(Account account)
boolean | containsProperty(Account account, String property)
String | getString(Account account, String property)
void | setString(Account account, String property, String value)

Method Detail

clearCache

public void clearCache(Account account)

containsProperty

public boolean containsProperty(Account account,
                                String property)

getString

public String getString(Account account,
                        String property)

setString

public void setString(Account account,
                      String property,
                      String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AutoForm

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.domain
Class AutoForm

java.lang.Object
    extended by org.marmot.framework.profile.domain.AutoForm
All Implemented Interfaces:
Serializable
public class AutoForm
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
AutoForm()
Method Summary
String | getDefaultControlWidth()
int | getDefaultElementMargin()
String | getDefaultLabelWidth()
String | getFormName()
String | getGroupLayout()
List | getGroups()
String | getGroupType()
String | getHeight()
String | getId()
String | getUserId()
String | getWidth()
void | setDefaultControlWidth(String defaultControlWidth)
void | setDefaultElementMargin(int defaultElementMargin)
void | setDefaultLabelWidth(String defaultLabelWidth)
void | setFormName(String formName)
void | setGroupLayout(String groupLayout)
void | setGroups(List groups)
void | setGroupType(String groupType)
void | setHeight(String height)
void | setId(String id)
void | setUserId(String userId)
void | setWidth(String width)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoForm

public AutoForm()
Method Detail

getFormName

public String getFormName()

setFormName

public void setFormName(String formName)

getGroups

public List getGroups()

setGroups

public void setGroups(List groups)

getId

public String getId()

setId

public void setId(String id)

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)

getDefaultControlWidth

public String getDefaultControlWidth()

setDefaultControlWidth

public void setDefaultControlWidth(String defaultControlWidth)

getDefaultLabelWidth

public String getDefaultLabelWidth()

setDefaultLabelWidth

public void setDefaultLabelWidth(String defaultLabelWidth)

getDefaultElementMargin

public int getDefaultElementMargin()

setDefaultElementMargin

public void setDefaultElementMargin(int defaultElementMargin)

getHeight

public String getHeight()

setHeight

public void setHeight(String height)

getWidth

public String getWidth()

setWidth

public void setWidth(String width)

getGroupLayout

public String getGroupLayout()

setGroupLayout

public void setGroupLayout(String groupLayout)

getGroupType

public String getGroupType()

setGroupType

public void setGroupType(String groupType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AutoFormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.domain
Class AutoFormElement

java.lang.Object
    extended by org.marmot.framework.profile.domain.AutoFormElement
All Implemented Interfaces:
Serializable
public class AutoFormElement
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
AutoFormElement()
Method Summary
int | getColSpan()
String | getControlAlign()
String | getControlHeight()
String | getControlStyle()
String | getControlVAlign()
String | getControlWidth()
String | getCustomControlId()
String | getDropDownMeta()
String | getDropDownScript()
String | getDropDownType()
String | getField()
String | getId()
String | getLabelAlign()
String | getLabelStyle()
String | getLabelVAlign()
String | getName()
int | getRowSpan()
String | getType()
boolean | isShowLabel()
boolean | isVisible()
void | setColSpan(int colSpan)
void | setControlAlign(String controlAlign)
void | setControlHeight(String controlHeight)
void | setControlStyle(String controlStyle)
void | setControlVAlign(String controlVAlign)
void | setControlWidth(String controlWidth)
void | setCustomControlId(String customControlId)
void | setDropDownMeta(String dropDownMeta)
void | setDropDownScript(String dropDownScript)
void | setDropDownType(String dropDownType)
void | setField(String field)
void | setId(String id)
void | setLabelAlign(String labelAlign)
void | setLabelStyle(String labelStyle)
void | setLabelVAlign(String labelVAlign)
void | setName(String name)
void | setRowSpan(int rowSpan)
void | setShowLabel(boolean showLabel)
void | setType(String type)
void | setVisible(boolean visible)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoFormElement

public AutoFormElement()
Method Detail

getCustomControlId

public String getCustomControlId()

setCustomControlId

public void setCustomControlId(String customControlId)

getColSpan

public int getColSpan()

setColSpan

public void setColSpan(int colSpan)

getControlHeight

public String getControlHeight()

setControlHeight

public void setControlHeight(String controlHeight)

getControlWidth

public String getControlWidth()

setControlWidth

public void setControlWidth(String controlWidth)

getField

public String getField()

setField

public void setField(String field)

getId

public String getId()

setId

public void setId(String id)

getName

public String getName()

setName

public void setName(String name)

getRowSpan

public int getRowSpan()

setRowSpan

public void setRowSpan(int rowSpan)

getType

public String getType()

setType

public void setType(String type)

isVisible

public boolean isVisible()

setVisible

public void setVisible(boolean visible)

getControlAlign

public String getControlAlign()

setControlAlign

public void setControlAlign(String controlAlign)

getControlVAlign

public String getControlVAlign()

setControlVAlign

public void setControlVAlign(String controlVAlign)

getLabelAlign

public String getLabelAlign()

setLabelAlign

public void setLabelAlign(String labelAlign)

getLabelVAlign

public String getLabelVAlign()

setLabelVAlign

public void setLabelVAlign(String labelVAlign)

isShowLabel

public boolean isShowLabel()

setShowLabel

public void setShowLabel(boolean showLabel)

getDropDownMeta

public String getDropDownMeta()

setDropDownMeta

public void setDropDownMeta(String dropDownMeta)

getDropDownType

public String getDropDownType()

setDropDownType

public void setDropDownType(String dropDownType)

getDropDownScript

public String getDropDownScript()

setDropDownScript

public void setDropDownScript(String dropDownScript)

getControlStyle

public String getControlStyle()

setControlStyle

public void setControlStyle(String controlStyle)

getLabelStyle

public String getLabelStyle()

setLabelStyle

public void setLabelStyle(String labelStyle)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutoFormGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.domain
Class AutoFormGroup

java.lang.Object
    extended by org.marmot.framework.profile.domain.AutoFormGroup
All Implemented Interfaces:
Serializable
public class AutoFormGroup
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
AutoFormGroup()
Method Summary
int | getColumnCount()
String | getDefaultControlWidth()
int | getElementMargin()
List | getElements()
String | getHeight()
String | getId()
String | getLabel()
String | getLabelWidth()
String | getName()
String | getWidth()
boolean | isExpanded()
boolean | isShowBevel()
boolean | isVisible()
void | setColumnCount(int columnCount)
void | setDefaultControlWidth(String defaultControlWidth)
void | setElementMargin(int elementMargin)
void | setElements(List elements)
void | setExpanded(boolean expanded)
void | setHeight(String height)
void | setId(String id)
void | setLabel(String label)
void | setLabelWidth(String labelWidth)
void | setName(String name)
void | setShowBevel(boolean showBevel)
void | setVisible(boolean visible)
void | setWidth(String width)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoFormGroup

public AutoFormGroup()
Method Detail

getColumnCount

public int getColumnCount()

setColumnCount

public void setColumnCount(int columnCount)

getElements

public List getElements()

setElements

public void setElements(List elements)

isExpanded

public boolean isExpanded()

setExpanded

public void setExpanded(boolean expanded)

getId

public String getId()

setId

public void setId(String id)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)

getName

public String getName()

setName

public void setName(String name)

isVisible

public boolean isVisible()

setVisible

public void setVisible(boolean visible)

getDefaultControlWidth

public String getDefaultControlWidth()

setDefaultControlWidth

public void setDefaultControlWidth(String defaultControlWidth)

getLabelWidth

public String getLabelWidth()

setLabelWidth

public void setLabelWidth(String labelWidth)

getElementMargin

public int getElementMargin()

setElementMargin

public void setElementMargin(int elementMargin)

getHeight

public String getHeight()

setHeight

public void setHeight(String height)

isShowBevel

public boolean isShowBevel()

setShowBevel

public void setShowBevel(boolean showBevel)

getWidth

public String getWidth()

setWidth

public void setWidth(String width)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.domain
Class DataTable

java.lang.Object
    extended by org.marmot.framework.profile.domain.DataTable
All Implemented Interfaces:
Serializable
public class DataTable
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
DataTable()
Method Summary
List | getColumns()
int | getFixedColumn()
String | getId()
int | getRowHeight()
String | getTableName()
String | getUserId()
boolean | isColumnDraggable()
boolean | isReadOnly()
boolean | isShowFilterBar()
boolean | isShowFooter()
void | setColumnDraggable(boolean columnDraggable)
void | setColumns(List columns)
void | setFixedColumn(int fixedColumn)
void | setId(String id)
void | setReadOnly(boolean readOnly)
void | setRowHeight(int rowHeight)
void | setShowFilterBar(boolean showFilterBar)
void | setShowFooter(boolean showFooter)
void | setTableName(String tableName)
void | setUserId(String userId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataTable

public DataTable()
Method Detail

getColumns

public List getColumns()

setColumns

public void setColumns(List columns)

getFixedColumn

public int getFixedColumn()

setFixedColumn

public void setFixedColumn(int fixedColumn)

getId

public String getId()

setId

public void setId(String id)

getTableName

public String getTableName()

setTableName

public void setTableName(String tableName)

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)

isShowFilterBar

public boolean isShowFilterBar()

setShowFilterBar

public void setShowFilterBar(boolean showFilterBar)

isColumnDraggable

public boolean isColumnDraggable()

setColumnDraggable

public void setColumnDraggable(boolean columnDraggable)

isReadOnly

public boolean isReadOnly()

setReadOnly

public void setReadOnly(boolean readOnly)

isShowFooter

public boolean isShowFooter()

setShowFooter

public void setShowFooter(boolean showFooter)

getRowHeight

public int getRowHeight()

setRowHeight

public void setRowHeight(int rowHeight)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataTableColumn

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.domain
Class DataTableColumn

java.lang.Object
    extended by org.marmot.framework.profile.domain.DataTableColumn
All Implemented Interfaces:
Serializable
public class DataTableColumn
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
DataTableColumn()
Method Summary
String | getDropDownMeta()
String | getDropDownScript()
String | getDropDownType()
String | getEditorType()
String | getField()
String | getId()
String | getLabel()
int | getLevel()
String | getName()
String | getRendererType()
String | getType()
int | getWidth()
boolean | isFilterable()
boolean | isGroupable()
boolean | isReadOnly()
boolean | isResizable()
boolean | isVisible()
void | setDropDownMeta(String dropDownMeta)
void | setDropDownScript(String dropDownScript)
void | setDropDownType(String dropDownType)
void | setEditorType(String editorType)
void | setField(String field)
void | setFilterable(boolean filterable)
void | setGroupable(boolean groupable)
void | setId(String id)
void | setLabel(String label)
void | setLevel(int level)
void | setName(String name)
void | setReadOnly(boolean readOnly)
void | setRendererType(String rendererType)
void | setResizable(boolean resizable)
void | setType(String type)
void | setVisible(boolean visible)
void | setWidth(int width)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataTableColumn

public DataTableColumn()
Method Detail

getEditorType

public String getEditorType()

setEditorType

public void setEditorType(String editorType)

getRendererType

public String getRendererType()

setRendererType

public void setRendererType(String rendererType)

getName

public String getName()

setName

public void setName(String name)

getId

public String getId()

setId

public void setId(String id)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)

isVisible

public boolean isVisible()

setVisible

public void setVisible(boolean visible)

getWidth

public int getWidth()

setWidth

public void setWidth(int width)

getField

public String getField()

setField

public void setField(String field)

isFilterable

public boolean isFilterable()

setFilterable

public void setFilterable(boolean filterable)

isGroupable

public boolean isGroupable()

setGroupable

public void setGroupable(boolean groupable)

isReadOnly

public boolean isReadOnly()

setReadOnly

public void setReadOnly(boolean readOnly)

isResizable

public boolean isResizable()

setResizable

public void setResizable(boolean resizable)

getLevel

public int getLevel()

setLevel

public void setLevel(int level)

getType

public String getType()

setType

public void setType(String type)

getDropDownMeta

public String getDropDownMeta()

setDropDownMeta

public void setDropDownMeta(String dropDownMeta)

getDropDownType

public String getDropDownType()

setDropDownType

public void setDropDownType(String dropDownType)

getDropDownScript

public String getDropDownScript()

setDropDownScript

public void setDropDownScript(String dropDownScript)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.profile.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.profile.domain

Class Summary
AutoForm
AutoFormElement
AutoFormGroup
DataTable
DataTableColumn


AutoFormProfileHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.view
Class AutoFormProfileHelper

java.lang.Object
    extended by org.marmot.framework.profile.view.AutoFormProfileHelper
public class AutoFormProfileHelper
extends Object

Constructor Summary
AutoFormProfileHelper()
Method Summary
protected void | bindAutoFormProfileMenu(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.control.autoform.AutoForm autoFormControl)
void | deleteAutoForm(String profileKey)
boolean | enableProfileMaintainDialog()
AutoForm | findAutoForm(String profileKey)
protected AutoForm | getAutoForm(String userId, String profileKey)
org.marmot.framework.profile.manager.AutoFormProfileManager | getAutoFormProfileManager()
protected void | initFormGroup(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.control.autoform.AutoForm autoFormControl, com.bstek.dorado.view.control.autoform.FormGroup groupControl, AutoFormGroup group)
void | initProfileSupportedAutoForm(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.control.autoform.AutoForm autoFormControl, String profileKey)
protected void | saveAutoForm(String userId, AutoForm autoForm)
void | setAutoFormProfileManager(org.marmot.framework.profile.manager.AutoFormProfileManager autoFormProfileManager)
void | storeAutoForm(AutoForm autoForm)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoFormProfileHelper

public AutoFormProfileHelper()
Method Detail

getAutoFormProfileManager

public org.marmot.framework.profile.manager.AutoFormProfileManager getAutoFormProfileManager()

setAutoFormProfileManager

public void setAutoFormProfileManager(org.marmot.framework.profile.manager.AutoFormProfileManager autoFormProfileManager)

findAutoForm

public AutoForm findAutoForm(String profileKey)

getAutoForm

protected AutoForm getAutoForm(String userId,
                               String profileKey)
Parameters:
userId -
profileKey -
Returns:

deleteAutoForm

public void deleteAutoForm(String profileKey)

storeAutoForm

public void storeAutoForm(AutoForm autoForm)
Parameters:
autoForm -

saveAutoForm

protected void saveAutoForm(String userId,
                            AutoForm autoForm)

enableProfileMaintainDialog

public boolean enableProfileMaintainDialog()

initProfileSupportedAutoForm

public void initProfileSupportedAutoForm(com.bstek.dorado.view.ViewModel viewModel,
                                         com.bstek.dorado.view.control.autoform.AutoForm autoFormControl,
                                         String profileKey)
                                  throws Exception
Parameters:
viewModel -
autoFormControl -
profileKey -
Throws:
Exception

initFormGroup

protected void initFormGroup(com.bstek.dorado.view.ViewModel viewModel,
                             com.bstek.dorado.view.control.autoform.AutoForm autoFormControl,
                             com.bstek.dorado.view.control.autoform.FormGroup groupControl,
                             AutoFormGroup group)
                      throws Exception
Parameters:
viewModel -
autoFormControl -
groupControl -
group -
Throws:
Exception

bindAutoFormProfileMenu

protected void bindAutoFormProfileMenu(com.bstek.dorado.view.ViewModel viewModel,
                                       com.bstek.dorado.view.control.autoform.AutoForm autoFormControl)
                                throws Exception
Parameters:
viewModel -
autoFormControl -
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DataTableProfileHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.profile.view
Class DataTableProfileHelper

java.lang.Object
    extended by org.marmot.framework.profile.view.DataTableProfileHelper
public class DataTableProfileHelper
extends Object

Constructor Summary
DataTableProfileHelper()
Method Summary
protected void | bindDataTableProfileMenu(com.bstek.dorado.view.control.table.DataTable tableControl)
void | deleteDataTable(String profileKey)
boolean | enableProfileMaintainDialog() 是否启用DataTable高级属性配置窗口
DataTable | findDataTable(String profileKey)
protected DataTable | getDataTable(String userId, String profileKey)
org.marmot.framework.profile.manager.DataTableProfileManager | getDataTableProfileManager()
void | initProfileSupportedDataTable(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.control.table.DataTable tableControl, String profileKey)
protected void | saveDataTable(String userId, DataTable dataTable)
void | setDataTableProfileManager(org.marmot.framework.profile.manager.DataTableProfileManager dataTableProfileManager)
void | storeDataTable(DataTable dataTable)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataTableProfileHelper

public DataTableProfileHelper()
Method Detail

getDataTableProfileManager

public org.marmot.framework.profile.manager.DataTableProfileManager getDataTableProfileManager()

setDataTableProfileManager

public void setDataTableProfileManager(org.marmot.framework.profile.manager.DataTableProfileManager dataTableProfileManager)

findDataTable

public DataTable findDataTable(String profileKey)

getDataTable

protected DataTable getDataTable(String userId,
                                 String profileKey)
Parameters:
userId -
profileKey -
Returns:

deleteDataTable

public void deleteDataTable(String profileKey)

storeDataTable

public void storeDataTable(DataTable dataTable)

saveDataTable

protected void saveDataTable(String userId,
                             DataTable dataTable)
Parameters:
userId -
dataTable -

enableProfileMaintainDialog

public boolean enableProfileMaintainDialog()
是否启用DataTable高级属性配置窗口

Returns:

initProfileSupportedDataTable

public void initProfileSupportedDataTable(com.bstek.dorado.view.ViewModel viewModel,
                                          com.bstek.dorado.view.control.table.DataTable tableControl,
                                          String profileKey)
                                   throws Exception
Parameters:
viewModel -
tableControl -
profileKey -
Throws:
Exception

bindDataTableProfileMenu

protected void bindDataTableProfileMenu(com.bstek.dorado.view.control.table.DataTable tableControl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.profile.view

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.profile.view

Class Summary
AutoFormProfileHelper
DataTableProfileHelper


AbstractDynaQLQueryBuilder

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class AbstractDynaQLQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
        extended by org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
All Implemented Interfaces:
QueryBuilder
Direct Known Subclasses:
AbstractQLQueryBuilder, DynaSQLQueryBuilder
public abstract class AbstractDynaQLQueryBuilder
extends AbstractDynaQueryBuilder

Constructor Summary
AbstractDynaQLQueryBuilder()
Method Summary
protected void | buildOrderByClause(QL ql, com.bstek.dorado.data.Dataset dataset, Query query)
protected QL | buildQL(com.bstek.dorado.data.Dataset dataset, Query query)
protected void | buildWhereClause(QL ql, com.bstek.dorado.data.Dataset dataset, Query query)
protected void | buildWhereClauseSection(QL ql, com.bstek.dorado.data.Dataset dataset, QueryWhere where, Object compareValue)
protected String | getParameterName(String fieldName)
protected String | getParameterSection(String fieldName)
protected void | getWhereClauseSection(QL ql, StringBuffer whereClause, String fieldName, String fieldType, String compareOp, Object compareValue)
void | initParameters(QL ql, com.bstek.dorado.data.ParameterSet parameters)
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
evaluateExpression, execute, getTableOfField, internalExecute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.marmot.framework.query.builder.QueryBuilder
shouldExecute

Constructor Detail

AbstractDynaQLQueryBuilder

public AbstractDynaQLQueryBuilder()
Method Detail

buildQL

protected QL buildQL(com.bstek.dorado.data.Dataset dataset,
                     Query query)

buildWhereClause

protected void buildWhereClause(QL ql,
                                com.bstek.dorado.data.Dataset dataset,
                                Query query)

buildWhereClauseSection

protected void buildWhereClauseSection(QL ql,
                                       com.bstek.dorado.data.Dataset dataset,
                                       QueryWhere where,
                                       Object compareValue)

getWhereClauseSection

protected void getWhereClauseSection(QL ql,
                                     StringBuffer whereClause,
                                     String fieldName,
                                     String fieldType,
                                     String compareOp,
                                     Object compareValue)

getParameterName

protected String getParameterName(String fieldName)

getParameterSection

protected String getParameterSection(String fieldName)

buildOrderByClause

protected void buildOrderByClause(QL ql,
                                  com.bstek.dorado.data.Dataset dataset,
                                  Query query)

initParameters

public void initParameters(QL ql,
                           com.bstek.dorado.data.ParameterSet parameters)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractDynaQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class AbstractDynaQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
All Implemented Interfaces:
QueryBuilder
Direct Known Subclasses:
AbstractDynaQLQueryBuilder, DynaAutoSQLQueryBuilder
public abstract class AbstractDynaQueryBuilder
extends Object
implements QueryBuilder

Constructor Summary
AbstractDynaQueryBuilder()
Method Summary
protected Object | evaluateExpression(com.bstek.dorado.common.rtexpr.CompiledText compiledText)
void | execute(com.bstek.dorado.data.Dataset dataset, Query query)
protected String | getTableOfField(com.bstek.dorado.data.Dataset dataset, String fieldName)
protected abstract void | internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.marmot.framework.query.builder.QueryBuilder
shouldExecute

Constructor Detail

AbstractDynaQueryBuilder

public AbstractDynaQueryBuilder()
Method Detail

evaluateExpression

protected Object evaluateExpression(com.bstek.dorado.common.rtexpr.CompiledText compiledText)

getTableOfField

protected String getTableOfField(com.bstek.dorado.data.Dataset dataset,
                                 String fieldName)

execute

public void execute(com.bstek.dorado.data.Dataset dataset,
                    Query query)
Specified by:
execute in interface QueryBuilder

internalExecute

protected abstract void internalExecute(com.bstek.dorado.data.Dataset dataset,
                                        Query query)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractQLQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class AbstractQLQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
        extended by org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
            extended by org.marmot.framework.query.builder.AbstractQLQueryBuilder
All Implemented Interfaces:
QueryBuilder
Direct Known Subclasses:
HQLQueryBuilder, IBatisQueryBuilder
public class AbstractQLQueryBuilder
extends AbstractDynaQLQueryBuilder

Constructor Summary
AbstractQLQueryBuilder()
Method Summary
protected QL | buildQL(com.bstek.dorado.data.Dataset dataset, Query query)
QL | buildQL(Query query)
void | internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildOrderByClause, buildWhereClause, buildWhereClauseSection, getParameterName, getParameterSection, getWhereClauseSection, initParameters
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
evaluateExpression, execute, getTableOfField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractQLQueryBuilder

public AbstractQLQueryBuilder()
Method Detail

shouldExecute

public boolean shouldExecute(com.bstek.dorado.data.Dataset dataset,
                             Query query)

internalExecute

public void internalExecute(com.bstek.dorado.data.Dataset dataset,
                            Query query)
Specified by:
internalExecute in class AbstractDynaQueryBuilder

buildQL

public QL buildQL(Query query)

buildQL

protected QL buildQL(com.bstek.dorado.data.Dataset dataset,
                     Query query)
Overrides:
buildQL in class AbstractDynaQLQueryBuilder
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynaAutoSQLQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class DynaAutoSQLQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
        extended by org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
All Implemented Interfaces:
QueryBuilder
public class DynaAutoSQLQueryBuilder
extends AbstractDynaQueryBuilder

Constructor Summary
DynaAutoSQLQueryBuilder()
Method Summary
protected int | buildMatchRule(com.bstek.dorado.data.db.AutoSqlDataset dataset, QueryWhere where, Object compareValue, int level)
protected void | buildMatchRules(com.bstek.dorado.data.db.AutoSqlDataset dataset, Query query)
void | internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
evaluateExpression, execute, getTableOfField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynaAutoSQLQueryBuilder

public DynaAutoSQLQueryBuilder()
Method Detail

shouldExecute

public boolean shouldExecute(com.bstek.dorado.data.Dataset dataset,
                             Query query)

internalExecute

public void internalExecute(com.bstek.dorado.data.Dataset dataset,
                            Query query)
Specified by:
internalExecute in class AbstractDynaQueryBuilder

buildMatchRules

protected void buildMatchRules(com.bstek.dorado.data.db.AutoSqlDataset dataset,
                               Query query)

buildMatchRule

protected int buildMatchRule(com.bstek.dorado.data.db.AutoSqlDataset dataset,
                             QueryWhere where,
                             Object compareValue,
                             int level)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynaSQLQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class DynaSQLQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
        extended by org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
            extended by org.marmot.framework.query.builder.DynaSQLQueryBuilder
All Implemented Interfaces:
QueryBuilder
public class DynaSQLQueryBuilder
extends AbstractDynaQLQueryBuilder

Constructor Summary
DynaSQLQueryBuilder()
Method Summary
protected String | getTableOfField(com.bstek.dorado.data.Dataset dataset, String fieldName)
void | internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildOrderByClause, buildQL, buildWhereClause, buildWhereClauseSection, getParameterName, getParameterSection, getWhereClauseSection, initParameters
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
evaluateExpression, execute
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynaSQLQueryBuilder

public DynaSQLQueryBuilder()
Method Detail

shouldExecute

public boolean shouldExecute(com.bstek.dorado.data.Dataset dataset,
                             Query query)

internalExecute

public void internalExecute(com.bstek.dorado.data.Dataset dataset,
                            Query query)
Specified by:
internalExecute in class AbstractDynaQueryBuilder

getTableOfField

protected String getTableOfField(com.bstek.dorado.data.Dataset dataset,
                                 String fieldName)
Overrides:
getTableOfField in class AbstractDynaQueryBuilder
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HQLQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class HQLQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
        extended by org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
            extended by org.marmot.framework.query.builder.AbstractQLQueryBuilder
                extended by org.marmot.framework.query.builder.HQLQueryBuilder
All Implemented Interfaces:
QueryBuilder
public class HQLQueryBuilder
extends AbstractQLQueryBuilder

Constructor Summary
HQLQueryBuilder()
Methods inherited from class org.marmot.framework.query.builder.AbstractQLQueryBuilder
buildQL, buildQL, internalExecute, shouldExecute
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildOrderByClause, buildWhereClause, buildWhereClauseSection, getParameterName, getParameterSection, getWhereClauseSection, initParameters
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
evaluateExpression, execute, getTableOfField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HQLQueryBuilder

public HQLQueryBuilder()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IBatisQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class IBatisQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.AbstractDynaQueryBuilder
        extended by org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
            extended by org.marmot.framework.query.builder.AbstractQLQueryBuilder
                extended by org.marmot.framework.query.builder.IBatisQueryBuilder
All Implemented Interfaces:
QueryBuilder
public class IBatisQueryBuilder
extends AbstractQLQueryBuilder

Constructor Summary
IBatisQueryBuilder()
Method Summary
protected  void getWhereClauseSection(QL ql, StringBuffer whereClause, String fieldName, String fieldType, String compareOp, Object compareValue)
Methods inherited from class org.marmot.framework.query.builder.AbstractQLQueryBuilder
buildQL, buildQL, internalExecute, shouldExecute
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildOrderByClause, buildWhereClause, buildWhereClauseSection, getParameterName, getParameterSection, initParameters
Methods inherited from class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
evaluateExpression, execute, getTableOfField
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IBatisQueryBuilder

public IBatisQueryBuilder()
Method Detail

getWhereClauseSection

protected void getWhereClauseSection(QL ql,
                                     StringBuffer whereClause,
                                     String fieldName,
                                     String fieldType,
                                     String compareOp,
                                     Object compareValue)
Overrides:
getWhereClauseSection in class AbstractDynaQLQueryBuilder
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.query.builder

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.query.builder

Interface Summary
QueryBuilder

Class Summary
AbstractDynaQLQueryBuilder
AbstractDynaQueryBuilder
AbstractQLQueryBuilder
DynaAutoSQLQueryBuilder
DynaSQLQueryBuilder
HQLQueryBuilder
IBatisQueryBuilder
QL
QLUtils
SQLQueryBuilder
StandardQueryBuilder


QL

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class QL

java.lang.Object
    extended by org.marmot.framework.query.builder.QL
public class QL
extends Object

Constructor Summary
QL()
Method Summary
Map | getDataTypes()
StringBuffer | getOrderByClause()
String | getOrderByClauseString()
String[] | getParameterNames()
Map | getParameters()
Object[] | getParameterValues()
StringBuffer | getWhereClause()
String | getWhereClauseString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QL

public QL()
Method Detail

getWhereClause

public StringBuffer getWhereClause()

getOrderByClause

public StringBuffer getOrderByClause()

getParameters

public Map getParameters()

getDataTypes

public Map getDataTypes()

getWhereClauseString

public String getWhereClauseString()

getOrderByClauseString

public String getOrderByClauseString()

getParameterNames

public String[] getParameterNames()

getParameterValues

public Object[] getParameterValues()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QLUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class QLUtils

java.lang.Object
    extended by org.marmot.framework.query.builder.QLUtils
public abstract class QLUtils
extends Object

Constructor Summary
QLUtils()
Method Summary
static org.marmot.framework.query.builder.WordDescriptor | findPrevOrderByKeyword(String statement, int from)
static org.marmot.framework.query.builder.WordDescriptor | findPrevWord(String statement, int from)
static void | replaceClauses(com.bstek.dorado.data.db.SqlDataset dataset, QL ql)
static void | replaceClauses(com.bstek.dorado.data.db.SqlDataset dataset, String whereClause, String orderByClause)
static String | replaceClauses(String statement, QL ql)
static String | replaceClauses(String statement, String whereClause, String orderByClause)
static String | replaceOrderByClause(String statement, String orderByClause)
static String | replaceWhereClause(String statement, String whereClause)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QLUtils

public QLUtils()
Method Detail

findPrevWord

public static org.marmot.framework.query.builder.WordDescriptor findPrevWord(String statement,
                                                                             int from)

findPrevOrderByKeyword

public static org.marmot.framework.query.builder.WordDescriptor findPrevOrderByKeyword(String statement,
                                                                                int from)

replaceWhereClause

public static String replaceWhereClause(String statement,
                                        String whereClause)

replaceOrderByClause

public static String replaceOrderByClause(String statement,
                                          String orderByClause)

replaceClauses

public static String replaceClauses(String statement,
                                    String whereClause,
                                    String orderByClause)

replaceClauses

public static String replaceClauses(String statement,
                                    QL ql)

replaceClauses

public static void replaceClauses(com.bstek.dorado.data.db.SqlDataset dataset,
                                  String whereClause,
                                  String orderByClause)

replaceClauses

public static void replaceClauses(com.bstek.dorado.data.db.SqlDataset dataset,
                                  QL ql)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Interface QueryBuilder

All Known Implementing Classes:
AbstractDynaQueryBuilder, SQLQueryBuilder, StandardQueryBuilder
public interface QueryBuilder

Method Summary
void | execute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)

Method Detail

shouldExecute

public boolean shouldExecute(com.bstek.dorado.data.Dataset dataset,
                             Query query)

execute

public void execute(com.bstek.dorado.data.Dataset dataset,
                    Query query)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SQLQueryBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class SQLQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.SQLQueryBuilder
All Implemented Interfaces:
QueryBuilder
public class SQLQueryBuilder
extends Object
implements QueryBuilder

Constructor Summary
SQLQueryBuilder()
Method Summary
void | execute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SQLQueryBuilder

public SQLQueryBuilder()
Method Detail

shouldExecute

public boolean shouldExecute(com.bstek.dorado.data.Dataset dataset,
                             Query query)
Specified by:
shouldExecute in interface QueryBuilder

execute

public void execute(com.bstek.dorado.data.Dataset dataset,
                    Query query)
Specified by:
execute in interface QueryBuilder
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StandardQueryBuilder

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.builder
Class StandardQueryBuilder

java.lang.Object
    extended by org.marmot.framework.query.builder.StandardQueryBuilder
All Implemented Interfaces:
QueryBuilder
public class StandardQueryBuilder
extends Object
implements QueryBuilder

Constructor Summary
StandardQueryBuilder()
Method Summary
void | execute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StandardQueryBuilder

public StandardQueryBuilder()
Method Detail

shouldExecute

public boolean shouldExecute(com.bstek.dorado.data.Dataset dataset,
                             Query query)
Specified by:
shouldExecute in interface QueryBuilder

execute

public void execute(com.bstek.dorado.data.Dataset dataset,
                    Query query)
Specified by:
execute in interface QueryBuilder
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.query.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.query.domain

Class Summary
Query
QueryCategory
QueryParameter
QuerySort
QuerySQL
QueryTemplateField
QueryUserCategory
QueryWhere


Query

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class Query

java.lang.Object
    extended by org.marmot.framework.query.domain.Query
All Implemented Interfaces:
Serializable
public class Query
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
Query()
Method Summary
String | getCategory()
String | getId()
List | getParameters()
String | getQueryName()
List | getSorts()
List | getSqls()
String | getType()
String | getUserId()
List | getWheres()
void | setCategory(String category)
void | setId(String id)
void | setParameters(List parameters)
void | setQueryName(String queryName)
void | setSorts(List sorts)
void | setSqls(List sqls)
void | setType(String type)
void | setUserId(String userId)
void | setWheres(List wheres)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Query

public Query()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getQueryName

public String getQueryName()

setQueryName

public void setQueryName(String queryName)

getParameters

public List getParameters()

setParameters

public void setParameters(List parameters)

getWheres

public List getWheres()

setWheres

public void setWheres(List wheres)

getSorts

public List getSorts()

setSorts

public void setSorts(List sorts)

getSqls

public List getSqls()

setSqls

public void setSqls(List sqls)

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)

getType

public String getType()

setType

public void setType(String type)

getCategory

public String getCategory()

setCategory

public void setCategory(String category)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


QueryCategory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QueryCategory

java.lang.Object
    extended by org.marmot.framework.query.domain.QueryCategory
All Implemented Interfaces:
Serializable
public class QueryCategory
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
QueryCategory()
Method Summary
String | getCategory()
String | getDefaultQueryId()
List | getTemplateFields()
void | setCategory(String category)
void | setDefaultQueryId(String defaultQueryId)
void | setTemplateFields(List templateFields)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryCategory

public QueryCategory()
Method Detail

getCategory

public String getCategory()

setCategory

public void setCategory(String category)

getDefaultQueryId

public String getDefaultQueryId()

setDefaultQueryId

public void setDefaultQueryId(String defaultQueryId)

getTemplateFields

public List getTemplateFields()

setTemplateFields

public void setTemplateFields(List templateFields)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryParameter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QueryParameter

java.lang.Object
    extended by org.marmot.framework.query.domain.QueryParameter
All Implemented Interfaces:
Serializable
public class QueryParameter
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
QueryParameter()
Method Summary
String | getId()
String | getParamName()
String | getParamType()
String | getParamValue()
Query | getQuery()
void | setId(String id)
void | setParamName(String paramName)
void | setParamType(String paramType)
void | setParamValue(String paramValue)
void | setQuery(Query query)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryParameter

public QueryParameter()
Method Detail

getParamType

public String getParamType()

setParamType

public void setParamType(String paramType)

getId

public String getId()

setId

public void setId(String id)

getParamName

public String getParamName()

setParamName

public void setParamName(String paramName)

getParamValue

public String getParamValue()

setParamValue

public void setParamValue(String paramValue)

getQuery

public Query getQuery()

setQuery

public void setQuery(Query query)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuerySort

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QuerySort

java.lang.Object
    extended by org.marmot.framework.query.domain.QuerySort
All Implemented Interfaces:
Serializable
public class QuerySort
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
QuerySort()
Method Summary
String | getFieldDescription()
String | getFieldName()
String | getId()
Query | getQuery()
String | getTableName()
boolean | isDesc()
void | setDesc(boolean desc)
void | setFieldDescription(String fieldDescription)
void | setFieldName(String fieldName)
void | setId(String id)
void | setQuery(Query query)
void | setTableName(String tableName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuerySort

public QuerySort()
Method Detail

isDesc

public boolean isDesc()

setDesc

public void setDesc(boolean desc)

getFieldName

public String getFieldName()

setFieldName

public void setFieldName(String fieldName)

getId

public String getId()

setId

public void setId(String id)

getTableName

public String getTableName()

setTableName

public void setTableName(String tableName)

getFieldDescription

public String getFieldDescription()

setFieldDescription

public void setFieldDescription(String fieldDescription)

getQuery

public Query getQuery()

setQuery

public void setQuery(Query query)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QuerySQL

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QuerySQL

java.lang.Object
    extended by org.marmot.framework.query.domain.QuerySQL
All Implemented Interfaces:
Serializable
public class QuerySQL
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
QuerySQL()
Method Summary
String | getId()
Query | getQuery()
String | getSortClause()
String | getWhereClause()
void | setId(String id)
void | setQuery(Query query)
void | setSortClause(String sortClause)
void | setWhereClause(String whereClause)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QuerySQL

public QuerySQL()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getWhereClause

public String getWhereClause()

setWhereClause

public void setWhereClause(String whereClause)

getQuery

public Query getQuery()

setQuery

public void setQuery(Query query)

getSortClause

public String getSortClause()

setSortClause

public void setSortClause(String sortClause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryTemplateField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QueryTemplateField

java.lang.Object
    extended by org.marmot.framework.query.domain.QueryTemplateField
public class QueryTemplateField
extends Object

Constructor Summary
QueryTemplateField()
Method Summary
String | getDropDownMeta()
String | getDropDownScript()
String | getDropDownType()
String | getFieldLabel()
String | getFieldName()
String | getFieldType()
String | getId()
QueryCategory | getQueryCategory()
int | getSortOrder()
String | getTableName()
void | setDropDownMeta(String dropDownMeta)
void | setDropDownScript(String dropDownScript)
void | setDropDownType(String dropDownType)
void | setFieldLabel(String fieldLabel)
void | setFieldName(String fieldName)
void | setFieldType(String fieldType)
void | setId(String id)
void | setQueryCategory(QueryCategory queryCategory)
void | setSortOrder(int sortOrder)
void | setTableName(String tableName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryTemplateField

public QueryTemplateField()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getFieldLabel

public String getFieldLabel()

setFieldLabel

public void setFieldLabel(String fieldLabel)

getFieldName

public String getFieldName()

setFieldName

public void setFieldName(String fieldName)

getFieldType

public String getFieldType()

setFieldType

public void setFieldType(String fieldType)

getDropDownMeta

public String getDropDownMeta()

setDropDownMeta

public void setDropDownMeta(String dropDownMeta)

getDropDownType

public String getDropDownType()

setDropDownType

public void setDropDownType(String dropDownType)

getQueryCategory

public QueryCategory getQueryCategory()

setQueryCategory

public void setQueryCategory(QueryCategory queryCategory)

getSortOrder

public int getSortOrder()

setSortOrder

public void setSortOrder(int sortOrder)

getTableName

public String getTableName()

setTableName

public void setTableName(String tableName)

getDropDownScript

public String getDropDownScript()

setDropDownScript

public void setDropDownScript(String dropDownScript)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryUserCategory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QueryUserCategory

java.lang.Object
    extended by org.marmot.framework.query.domain.QueryUserCategory
All Implemented Interfaces:
Serializable
public class QueryUserCategory
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
QueryUserCategory()
Method Summary
QueryCategory | getCategory()
String | getDefaultQueryId()
String | getUserId()
void | setCategory(QueryCategory category)
void | setDefaultQueryId(String defaultQueryId)
void | setUserId(String userId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryUserCategory

public QueryUserCategory()
Method Detail

getCategory

public QueryCategory getCategory()

setCategory

public void setCategory(QueryCategory category)

getDefaultQueryId

public String getDefaultQueryId()

setDefaultQueryId

public void setDefaultQueryId(String defaultQueryId)

getUserId

public String getUserId()

setUserId

public void setUserId(String userId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QueryWhere

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.domain
Class QueryWhere

java.lang.Object
    extended by org.marmot.framework.query.domain.QueryWhere
All Implemented Interfaces:
Serializable
public class QueryWhere
extends Object
implements Serializable

See Also:
Serialized Form

Constructor Summary
QueryWhere()
Method Summary
String | getBracketAfter()
String | getBracketBefore()
String | getCompareOp()
String | getCompareValue()
String | getDisplayCompareValue()
String | getFieldDescription()
String | getFieldName()
String | getFieldType()
String | getId()
String | getLogicOp()
Query | getQuery()
String | getTableName()
String | isBracketAfter()
String | isBracketBefore()
void | setBracketAfter(String bracketAfter)
void | setBracketBefore(String bracketBefore)
void | setCompareOp(String compareOp)
void | setCompareValue(String compareValue)
void | setDisplayCompareValue(String displayCompareValue)
void | setFieldDescription(String fieldDescription)
void | setFieldName(String fieldName)
void | setFieldType(String fieldType)
void | setId(String id)
void | setLogicOp(String logicOp)
void | setQuery(Query query)
void | setTableName(String tableName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryWhere

public QueryWhere()
Method Detail

isBracketAfter

public String isBracketAfter()

setBracketAfter

public void setBracketAfter(String bracketAfter)

isBracketBefore

public String isBracketBefore()

setBracketBefore

public void setBracketBefore(String bracketBefore)

getCompareOp

public String getCompareOp()

setCompareOp

public void setCompareOp(String compareOp)

getCompareValue

public String getCompareValue()

setCompareValue

public void setCompareValue(String compareValue)

getFieldDescription

public String getFieldDescription()

setFieldDescription

public void setFieldDescription(String fieldDescription)

getFieldName

public String getFieldName()

setFieldName

public void setFieldName(String fieldName)

getId

public String getId()

setId

public void setId(String id)

getLogicOp

public String getLogicOp()

setLogicOp

public void setLogicOp(String logicOp)

getTableName

public String getTableName()

setTableName

public void setTableName(String tableName)

getQuery

public Query getQuery()

setQuery

public void setQuery(Query query)

getBracketAfter

public String getBracketAfter()

getBracketBefore

public String getBracketBefore()

getFieldType

public String getFieldType()

setFieldType

public void setFieldType(String fieldType)

getDisplayCompareValue

public String getDisplayCompareValue()

setDisplayCompareValue

public void setDisplayCompareValue(String displayCompareValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.query.view

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.query.view

Class Summary
QueryDatasetListener


QueryDatasetListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.query.view
Class QueryDatasetListener

java.lang.Object
    extended by com.bstek.dorado.data.AbstractDatasetListener
        extended by org.marmot.framework.query.view.QueryDatasetListener
All Implemented Interfaces:
com.bstek.dorado.data.DatasetListener, EventListener
public class QueryDatasetListener
extends com.bstek.dorado.data.AbstractDatasetListener

Constructor Summary
QueryDatasetListener()
Method Summary
protected void | applyQuery(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | beforeLoadData(com.bstek.dorado.data.Dataset dataset)
protected Query | parseQuery(com.bstek.dorado.data.ParameterSet parameters)
void | setQueryBuilders(List queryBuilders)
void | setQueryManager(org.marmot.framework.query.manager.QueryManager queryManager)
Methods inherited from class com.bstek.dorado.data.AbstractDatasetListener
afterCreateFields, afterLoadData, afterUpdateData, beforeCreateFields, beforeUpdateData, onInit
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

QueryDatasetListener

public QueryDatasetListener()
Method Detail

setQueryManager

public void setQueryManager(org.marmot.framework.query.manager.QueryManager queryManager)

setQueryBuilders

public void setQueryBuilders(List queryBuilders)

beforeLoadData

public boolean beforeLoadData(com.bstek.dorado.data.Dataset dataset)
                       throws Exception
Throws:
Exception

applyQuery

protected void applyQuery(com.bstek.dorado.data.Dataset dataset,
                          Query query)

parseQuery

protected Query parseQuery(com.bstek.dorado.data.ParameterSet parameters)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractHttpAuthenticator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Class AbstractHttpAuthenticator

java.lang.Object
    extended by org.marmot.framework.security.AbstractHttpAuthenticator
All Implemented Interfaces:
Authenticator
public abstract class AbstractHttpAuthenticator
extends Object
implements Authenticator

支持获取HttpServletRequest对象的Authenticator抽象实现类.

Author:
Benny Bao

Constructor Summary
AbstractHttpAuthenticator()
Method Summary
protected  javax.servlet.http.HttpServletRequest getRequest()
返回当前线程对应的HttpServletRequest对象.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.marmot.framework.security.Authenticator
login, logout

Constructor Detail

AbstractHttpAuthenticator

public AbstractHttpAuthenticator()
Method Detail

getRequest

protected javax.servlet.http.HttpServletRequest getRequest()
返回当前线程对应的HttpServletRequest对象.

Returns:
HttpServletRequest对象.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractHttpCurrentAccountAccessor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Class AbstractHttpCurrentAccountAccessor

java.lang.Object
    extended by org.marmot.framework.security.AbstractHttpCurrentAccountAccessor
All Implemented Interfaces:
CurrentAccountAccessor
public abstract class AbstractHttpCurrentAccountAccessor
extends Object
implements CurrentAccountAccessor

支持获取HttpServletRequest对象的CurrentAccountAccessor抽象实现类.

Author:
Benny Bao

Constructor Summary
AbstractHttpCurrentAccountAccessor()
Method Summary
protected  javax.servlet.http.HttpServletRequest getRequest()
返回当前线程对应的HttpServletRequest对象.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.marmot.framework.security.CurrentAccountAccessor
getCurrentAccount, isLoggedIn

Constructor Detail

AbstractHttpCurrentAccountAccessor

public AbstractHttpCurrentAccountAccessor()
Method Detail

getRequest

protected javax.servlet.http.HttpServletRequest getRequest()
返回当前线程对应的HttpServletRequest对象.

Returns:
HttpServletRequest对象.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Account

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Class Account

java.lang.Object
    extended by org.marmot.framework.security.Account
public class Account
extends Object

Constructor Summary
Account(String id)
Method Summary
Object | getAttribute(String key)
String | getId()
String | getName()
String | getPersonId()
void | setAttribute(String key, Object value)
void | setName(String name)
void | setPersonId(String personId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Account

public Account(String id)
Method Detail

getId

public String getId()

getPersonId

public String getPersonId()

setPersonId

public void setPersonId(String personId)

getAttribute

public Object getAttribute(String key)

setAttribute

public void setAttribute(String key,
                         Object value)

getName

public String getName()

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Authenticator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Interface Authenticator

All Known Implementing Classes:
AbstractHttpAuthenticator
public interface Authenticator

登录功能的接口

Author:
Benny Bao

Method Summary
void | login(String user, String password, Object attributies) 登录系统.
void | logout() 注销

Method Detail

login

public void login(String user,
                  String password,
                  Object attributies)
           throws Exception
登录系统. 如果登录失败应抛出异常,否则框架会认为系统登录成功.

Parameters:
user - 用户名
password - 口令
attributies - 附加的登录信息
Throws:
Exception

logout

public void logout()
            throws Exception
注销

Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Authorizer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Interface Authorizer

public interface Authorizer

权限验证器的接口.

Author:
Benny Bao

Method Summary
 boolean isAuthorized(Account account, Object resource)
根据传入的帐号信息和资源项进行权限验证,并返回逻辑值表示该帐号是否有权访问这一资源.

Method Detail

isAuthorized

public boolean isAuthorized(Account account,
                            Object resource)
根据传入的帐号信息和资源项进行权限验证,并返回逻辑值表示该帐号是否有权访问这一资源.

Parameters:
account - 帐号.
resource - 资源项.
Returns:
是否有权访问.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CurrentAccountAccessor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Interface CurrentAccountAccessor

All Known Implementing Classes:
AbstractHttpCurrentAccountAccessor
public interface CurrentAccountAccessor

用于获取系统当前登录信息的类的接口.

Author:
Benny Bao

Method Summary
Account | getCurrentAccount() 返回系统当前登录者的帐号信息.
boolean | isLoggedIn() 返回系统当前是否已登录.

Method Detail

isLoggedIn

public boolean isLoggedIn()
返回系统当前是否已登录.

Returns:
是否已登录.

getCurrentAccount

public Account getCurrentAccount()
返回系统当前登录者的帐号信息.

Returns:
Account
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListableAuthorizer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Interface ListableAuthorizer

public interface ListableAuthorizer

Method Summary
 Set getAuthorizedResources(Account account, Object parentResource)
根据某父资源项返回所有已授权给指定帐号的子资源项的集合.

Method Detail

getAuthorizedResources

public Set getAuthorizedResources(Account account,
                                  Object parentResource)
根据某父资源项返回所有已授权给指定帐号的子资源项的集合.

Parameters:
account - 帐号.
parentResource - 父资源项
Returns:
子资源项的集合.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.security

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.security

权限功能的扩展接口及相关实现.

See:
Description

Interface Summary
Authenticator | 登录功能的接口
Authorizer | 权限验证器的接口.
CurrentAccountAccessor | 用于获取系统当前登录信息的类的接口.
ListableAuthorizer |

Class Summary
AbstractHttpAuthenticator | 支持获取HttpServletRequest对象的Authenticator抽象实现类.
AbstractHttpCurrentAccountAccessor | 支持获取HttpServletRequest对象的CurrentAccountAccessor抽象实现类.
Account |
SecurityUtils |

Package org.marmot.framework.security Description

权限功能的扩展接口及相关实现.


SecurityUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security
Class SecurityUtils

java.lang.Object
    extended by org.marmot.framework.security.SecurityUtils
public class SecurityUtils
extends Object

Constructor Summary
SecurityUtils()
Method Summary
static Account | getCurrentAccount()
static String | getCurrentAccountId()
static String | getCurrentPersonId()
static SecurityUtils | getInstance()
static boolean | isAuthorized(Object resource)
static boolean | isLoggedIn()
void | setAuthorizer(Authorizer authorizer)
void | setCurrentAccountAccessor(CurrentAccountAccessor currentAccountAccessor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SecurityUtils

public SecurityUtils()
Method Detail

setCurrentAccountAccessor

public void setCurrentAccountAccessor(CurrentAccountAccessor currentAccountAccessor)

setAuthorizer

public void setAuthorizer(Authorizer authorizer)

getInstance

public static SecurityUtils getInstance()

isLoggedIn

public static boolean isLoggedIn()

getCurrentAccount

public static Account getCurrentAccount()

getCurrentAccountId

public static String getCurrentAccountId()

getCurrentPersonId

public static String getCurrentPersonId()

isAuthorized

public static boolean isAuthorized(Object resource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CaptchaProcessor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security.captcha
Interface CaptchaProcessor

All Known Implementing Classes:
JCaptchaImageProcessor
public interface CaptchaProcessor

验证码处理器的接口.

Author:
Benny Bao

Method Summary
void | outputCaptcha(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 向response中输出验证码的人机识别测试信息(completely automated public Turing test to tell computers and humans apart).
boolean | validateCaptcha(javax.servlet.http.HttpServletRequest request, String captchaCode) 验证captchaCode参数中的信息是否与之前输出的人机识别测试信息相匹配.

Method Detail

outputCaptcha

public void outputCaptcha(javax.servlet.http.HttpServletRequest request,
                          javax.servlet.http.HttpServletResponse response)
                   throws Exception
向response中输出验证码的人机识别测试信息(completely automated public Turing test to tell computers and humans apart).

Parameters:
request -
response -
Throws:
Exception

validateCaptcha

public boolean validateCaptcha(javax.servlet.http.HttpServletRequest request,
                               String captchaCode)
验证captchaCode参数中的信息是否与之前输出的人机识别测试信息相匹配.

Parameters:
request -
captchaCode - 用户填写的验证码
Returns:
是否通过验证
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JCaptchaImageProcessor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.security.captcha
Class JCaptchaImageProcessor

java.lang.Object
    extended by org.marmot.framework.security.captcha.JCaptchaImageProcessor
All Implemented Interfaces:
CaptchaProcessor
public class JCaptchaImageProcessor
extends Object
implements CaptchaProcessor

Constructor Summary
JCaptchaImageProcessor()
Method Summary
int | getCharNumber()
String | getChars()
int | getHeight()
protected com.octo.captcha.service.image.ImageCaptchaService | getImageCaptchaService()
String | getImageType()
int | getMaxFontSize()
int | getMinFontSize()
int | getWidth()
void | outputCaptcha(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 向response中输出验证码的人机识别测试信息(completely automated public Turing test to tell computers and humans apart).
void | setCharNumber(int charNumber)
void | setChars(String chars)
void | setHeight(int height)
void | setImageType(String imageType)
void | setMaxFontSize(int maxFontSize)
void | setMinFontSize(int minFontSize)
void | setWidth(int width)
boolean | validateCaptcha(javax.servlet.http.HttpServletRequest request, String captchaCode) 验证captchaCode参数中的信息是否与之前输出的人机识别测试信息相匹配.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JCaptchaImageProcessor

public JCaptchaImageProcessor()
Method Detail

getImageType

public String getImageType()

setImageType

public void setImageType(String imageType)

getChars

public String getChars()

setChars

public void setChars(String chars)

getHeight

public int getHeight()

setHeight

public void setHeight(int height)

getWidth

public int getWidth()

setWidth

public void setWidth(int width)

getMaxFontSize

public int getMaxFontSize()

setMaxFontSize

public void setMaxFontSize(int maxFontSize)

getMinFontSize

public int getMinFontSize()

setMinFontSize

public void setMinFontSize(int minFontSize)

getCharNumber

public int getCharNumber()

setCharNumber

public void setCharNumber(int charNumber)

getImageCaptchaService

protected com.octo.captcha.service.image.ImageCaptchaService getImageCaptchaService()
                                                                             throws Exception
Throws:
Exception

outputCaptcha

public void outputCaptcha(javax.servlet.http.HttpServletRequest request,
                          javax.servlet.http.HttpServletResponse response)
                   throws Exception
Description copied from interface: CaptchaProcessor
向response中输出验证码的人机识别测试信息(completely automated public Turing test to tell computers and humans apart).

Specified by:
outputCaptcha in interface CaptchaProcessor
Parameters:
request -
response -
Throws:
Exception

validateCaptcha

public boolean validateCaptcha(javax.servlet.http.HttpServletRequest request,
                               String captchaCode)
Description copied from interface: CaptchaProcessor
验证captchaCode参数中的信息是否与之前输出的人机识别测试信息相匹配.

Specified by:
validateCaptcha in interface CaptchaProcessor
Parameters:
request -
captchaCode - 用户填写的验证码
Returns:
是否通过验证
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.security.captcha

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.security.captcha

Interface Summary
CaptchaProcessor 验证码处理器的接口.

Class Summary
JCaptchaImageProcessor


DropDownInitializor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.util
Class DropDownInitializor

java.lang.Object
    extended by org.marmot.framework.util.DropDownInitializor
public class DropDownInitializor
extends Object

Constructor Summary
DropDownInitializor()
Method Summary
static void initDropDown(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.Element element, String dropDownType, String dropDownMeta, String dropDownScript)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DropDownInitializor

public DropDownInitializor()
Method Detail

initDropDown

public static void initDropDown(com.bstek.dorado.view.ViewModel viewModel,
                                com.bstek.dorado.view.Element element,
                                String dropDownType,
                                String dropDownMeta,
                                String dropDownScript)
                         throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HibernateDaoUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.framework.util
Class HibernateDaoUtils

java.lang.Object
    extended by org.marmot.framework.util.HibernateDaoUtils
public abstract class HibernateDaoUtils
extends Object

Constructor Summary
HibernateDaoUtils()
Method Summary
static org.hibernate.criterion.SimpleExpression | createBooleanCriteria(String property, String filterExpression)
static org.hibernate.criterion.SimpleExpression | createDateCriteria(String property, String filterExpression)
static org.hibernate.criterion.SimpleExpression | createDoubleCriteria(String property, String filterExpression)
static org.hibernate.criterion.SimpleExpression | createLongCriteria(String property, String filterExpression)
static org.hibernate.criterion.SimpleExpression | createStringCriteria(String property, String filterExpression)
static org.marmot.view.Page | getOrderedPage(org.springframework.orm.hibernate3.HibernateTemplate hibernateTemplate, org.hibernate.criterion.DetachedCriteria detachedCriteria, List orders, int startIndex, int maxResult)
static org.marmot.view.Page | getPage(org.springframework.orm.hibernate3.HibernateTemplate hibernateTemplate, org.hibernate.criterion.DetachedCriteria detachedCriteria, int startIndex, int maxResult)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HibernateDaoUtils

public HibernateDaoUtils()
Method Detail

getPage

public static org.marmot.view.Page getPage(org.springframework.orm.hibernate3.HibernateTemplate hibernateTemplate,
                                           org.hibernate.criterion.DetachedCriteria detachedCriteria,
                                           int startIndex,
                                           int maxResult)

getOrderedPage

public static org.marmot.view.Page getOrderedPage(org.springframework.orm.hibernate3.HibernateTemplate hibernateTemplate,
                                                  org.hibernate.criterion.DetachedCriteria detachedCriteria,
                                                  List orders,
                                                  int startIndex,
                                                  int maxResult)

createStringCriteria

public static org.hibernate.criterion.SimpleExpression createStringCriteria(String property,
                                                                            String filterExpression)

createBooleanCriteria

public static org.hibernate.criterion.SimpleExpression createBooleanCriteria(String property,
                                                                             String filterExpression)

createLongCriteria

public static org.hibernate.criterion.SimpleExpression createLongCriteria(String property,
                                                                          String filterExpression)

createDoubleCriteria

public static org.hibernate.criterion.SimpleExpression createDoubleCriteria(String property,
                                                                            String filterExpression)

createDateCriteria

public static org.hibernate.criterion.SimpleExpression createDateCriteria(String property,
                                                                          String filterExpression)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.framework.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.framework.util

Marmot Framework的工具类.

See:
Description

Class Summary
DropDownInitializor
HibernateDaoUtils

Package org.marmot.framework.util Description

Marmot Framework的工具类.


AcegiCacheManager

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.cache
Interface AcegiCacheManager

All Known Implementing Classes:
AcegiCacheManagerImpl
public interface AcegiCacheManager

cache管理

Author:
cac, william

Method Summary
ResourceDetails | getAuthorityFromResourceCache(String resString) 根据资源串获取可以访问该资源的ResourceDetails信息
org.acegisecurity.userdetails.UserDetails | getAuthorityFromUserCache(String username) 根据username获取可以访问该资源的UserDetails信息
List | getComponents() 获取所有的Component资源
List | getFunctions() 获取所有的Funtion资源
List | getResStrings() 获取所有的url资源
List | getUrlResStrings() 获取所有的url资源
void | initResourceCache() 初始化resourceCache
void | initUserCache() 初始化userCache
void | modifyResourceInCache(Resource resource, String orgResourcename) 修改resource信息时,更新系统缓存中的权限资源信息
void | modifyUserInCache(User user, String orgUsername) 修改User时更改userCache?
void | refreshResourceCache() 刷新resourceCache
void | refreshUserCache() 刷新userCache
void | removeResourceInCache(String resourcename) 删除resource信息时,更新系统缓存中的权限资源信息
void | removeUserInCache(String orgUsername) 删除User时更改userCache?

Method Detail

initUserCache

public void initUserCache()
初始化userCache

initResourceCache

public void initResourceCache()
初始化resourceCache

refreshUserCache

public void refreshUserCache()
刷新userCache

refreshResourceCache

public void refreshResourceCache()
刷新resourceCache

modifyUserInCache

public void modifyUserInCache(User user,
                              String orgUsername)
修改User时更改userCache?

removeUserInCache

public void removeUserInCache(String orgUsername)
删除User时更改userCache?

modifyResourceInCache

public void modifyResourceInCache(Resource resource,
                                  String orgResourcename)
                           throws Exception
修改resource信息时,更新系统缓存中的权限资源信息

Parameters:
resource -
orgResourcename -
Throws:
Exception

removeResourceInCache

public void removeResourceInCache(String resourcename)
                           throws Exception
删除resource信息时,更新系统缓存中的权限资源信息

Throws:
Exception

getResStrings

public List getResStrings()
获取所有的url资源

getUrlResStrings

public List getUrlResStrings()
获取所有的url资源

getFunctions

public List getFunctions()
获取所有的Funtion资源

getComponents

public List getComponents()
获取所有的Component资源

getAuthorityFromResourceCache

public ResourceDetails getAuthorityFromResourceCache(String resString)
根据资源串获取可以访问该资源的ResourceDetails信息

getAuthorityFromUserCache

public org.acegisecurity.userdetails.UserDetails getAuthorityFromUserCache(String username)
根据username获取可以访问该资源的UserDetails信息

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AcegiCacheManagerImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.cache
Class AcegiCacheManagerImpl

java.lang.Object
    extended by org.springframework.dao.support.DaoSupport
        extended by org.springframework.orm.hibernate3.support.HibernateDaoSupport
            extended by org.marmot.security.cache.AcegiCacheManagerImpl
All Implemented Interfaces:
AcegiCacheManager, org.springframework.beans.factory.InitializingBean
public class AcegiCacheManagerImpl
extends org.springframework.orm.hibernate3.support.HibernateDaoSupport
implements AcegiCacheManager

cache管理

Author:
cac, william

Constructor Summary
AcegiCacheManagerImpl()
Method Summary
void | authResourceInCache(Role role) Role授予资源时更改resourceCache
void | authRoleInCache(User user) User授予角色时更改userCache
ResourceDetails | getAuthorityFromResourceCache(String resString) 根据资源串获取资源
org.acegisecurity.userdetails.UserDetails | getAuthorityFromUserCache(String username) 根据username获取可以访问该资源的UserDetails信息
List | getComponents() 获取所有的Component资源
List | getFunctions() 获取所有的Funtion资源
ResourceCache | getResourceCache()
List | getResStrings() 获取所有的url资源
List | getUrlResStrings() 获取所有的url资源
org.acegisecurity.providers.dao.UserCache | getUserCache()
UserRoleService | getUserRoleService()
void | initResourceCache() 初始化resourceCache
void | initUserCache() 初始化userCache
void | modifyResourceInCache(Resource resource, String orgResourcename) 修改Resource时更改resourceCache
void | modifyRoleInCache(Role role, String orgRolename) 修改Role时同时修改userCache和resourceCache
void | modifyUserInCache(User user, String orgUsername) 修改User时更改userCache
void | refreshResourceCache() 刷新resourceCache
void | refreshUserCache() 刷新userCache
void | removeResourceInCache(String resourcename) 删除Resource时删除resourceCache
void | removeUserInCache(String orgUsername) 删除User时更改userCache
void | setResourceCache(ResourceCache resourceCache)
void | setUserCache(org.acegisecurity.providers.dao.UserCache userCache)
void | setUserRoleService(UserRoleService userRoleDao)
Methods inherited from class org.springframework.orm.hibernate3.support.HibernateDaoSupport
checkDaoConfig, convertHibernateAccessException, createHibernateTemplate, getHibernateTemplate, getSession, getSession, getSessionFactory, releaseSession, setHibernateTemplate, setSessionFactory
Methods inherited from class org.springframework.dao.support.DaoSupport
afterPropertiesSet, initDao
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AcegiCacheManagerImpl

public AcegiCacheManagerImpl()
Method Detail

setUserCache

public void setUserCache(org.acegisecurity.providers.dao.UserCache userCache)

getUserCache

public org.acegisecurity.providers.dao.UserCache getUserCache()

getResourceCache

public ResourceCache getResourceCache()

setResourceCache

public void setResourceCache(ResourceCache resourceCache)

removeUserInCache

public void removeUserInCache(String orgUsername)
删除User时更改userCache

Specified by:
removeUserInCache in interface AcegiCacheManager

modifyUserInCache

public void modifyUserInCache(User user,
                              String orgUsername)
修改User时更改userCache

Specified by:
modifyUserInCache in interface AcegiCacheManager

removeResourceInCache

public void removeResourceInCache(String resourcename)
                           throws Exception
删除Resource时删除resourceCache

Specified by:
removeResourceInCache in interface AcegiCacheManager
Throws:
Exception

modifyResourceInCache

public void modifyResourceInCache(Resource resource,
                                  String orgResourcename)
                           throws Exception
修改Resource时更改resourceCache

Specified by:
modifyResourceInCache in interface AcegiCacheManager
Parameters:
resource -
orgResourcename -
Throws:
Exception

modifyRoleInCache

public void modifyRoleInCache(Role role,
                              String orgRolename)
修改Role时同时修改userCache和resourceCache

authRoleInCache

public void authRoleInCache(User user)
User授予角色时更改userCache

authResourceInCache

public void authResourceInCache(Role role)
                         throws Exception
Role授予资源时更改resourceCache

Throws:
Exception

initUserCache

public void initUserCache()
初始化userCache

Specified by:
initUserCache in interface AcegiCacheManager

refreshUserCache

public void refreshUserCache()
Description copied from interface: AcegiCacheManager
刷新userCache

Specified by:
refreshUserCache in interface AcegiCacheManager

initResourceCache

public void initResourceCache()
初始化resourceCache

Specified by:
initResourceCache in interface AcegiCacheManager

refreshResourceCache

public void refreshResourceCache()
Description copied from interface: AcegiCacheManager
刷新resourceCache

Specified by:
refreshResourceCache in interface AcegiCacheManager

getUrlResStrings

public List getUrlResStrings()
获取所有的url资源

Specified by:
getUrlResStrings in interface AcegiCacheManager

getFunctions

public List getFunctions()
获取所有的Funtion资源

Specified by:
getFunctions in interface AcegiCacheManager

getResStrings

public List getResStrings()
Description copied from interface: AcegiCacheManager
获取所有的url资源

Specified by:
getResStrings in interface AcegiCacheManager

getComponents

public List getComponents()
获取所有的Component资源

Specified by:
getComponents in interface AcegiCacheManager

getAuthorityFromUserCache

public org.acegisecurity.userdetails.UserDetails getAuthorityFromUserCache(String username)
Description copied from interface: AcegiCacheManager
根据username获取可以访问该资源的UserDetails信息

Specified by:
getAuthorityFromUserCache in interface AcegiCacheManager

getAuthorityFromResourceCache

public ResourceDetails getAuthorityFromResourceCache(String resString)
根据资源串获取资源

Specified by:
getAuthorityFromResourceCache in interface AcegiCacheManager

getUserRoleService

public UserRoleService getUserRoleService()

setUserRoleService

public void setUserRoleService(UserRoleService userRoleDao)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.cache

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.cache

Interface Summary
AcegiCacheManager | cache管理
ResourceDetails | 提供资源信息

Class Summary
AcegiCacheManagerImpl | cache管理
ResourceCache | Caches Resource objects using a Spring IoC defined EHCACHE.
SecurityResource | ResourceDetails的实现类


ResourceCache

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.cache
Class ResourceCache

java.lang.Object
    extended by org.marmot.security.cache.ResourceCache
public class ResourceCache
extends Object

Caches Resource objects using a Spring IoC defined EHCACHE.

Author:
cac, william

Field Summary
static String | RESOURCE_CONTROL
static String | RESOURCE_METHOD
static String | RESOURCE_URL
Constructor Summary
ResourceCache()
Method Summary
ResourceDetails | getAuthorityFromCache(String resString)
net.sf.ehcache.Cache | getCache()
List | getComponents()
List | getFunctions()
List | getResStrings()
List | getUrlResStrings()
void | putAuthorityInCache(ResourceDetails resourceDetails)
void | removeAuthorityFromCache(String resString)
void | setCache(net.sf.ehcache.Cache cache)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

RESOURCE_URL

public static final String RESOURCE_URL
See Also:
Constant Field Values

RESOURCE_METHOD

public static final String RESOURCE_METHOD
See Also:
Constant Field Values

RESOURCE_CONTROL

public static final String RESOURCE_CONTROL
See Also:
Constant Field Values
Constructor Detail

ResourceCache

public ResourceCache()
Method Detail

setCache

public void setCache(net.sf.ehcache.Cache cache)

getCache

public net.sf.ehcache.Cache getCache()

getAuthorityFromCache

public ResourceDetails getAuthorityFromCache(String resString)

putAuthorityInCache

public void putAuthorityInCache(ResourceDetails resourceDetails)

removeAuthorityFromCache

public void removeAuthorityFromCache(String resString)

getResStrings

public List getResStrings()

getUrlResStrings

public List getUrlResStrings()

getFunctions

public List getFunctions()

getComponents

public List getComponents()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceDetails

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.cache
Interface ResourceDetails

All Superinterfaces:
Serializable
All Known Implementing Classes:
SecurityResource
public interface ResourceDetails
extends Serializable

提供资源信息

Author:
cac, william

Method Summary
org.acegisecurity.GrantedAuthority[] | getAuthorities() 返回属于该resource的authorities
String | getResString() 资源串
String | getResType() 资源类型,如URL,FUNCTION,CONTROL

Method Detail

getResString

public String getResString()
资源串

getResType

public String getResType()
资源类型,如URL,FUNCTION,CONTROL

getAuthorities

public org.acegisecurity.GrantedAuthority[] getAuthorities()
返回属于该resource的authorities

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SecurityResource

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.cache
Class SecurityResource

java.lang.Object
    extended by org.marmot.security.cache.SecurityResource
All Implemented Interfaces:
ResourceDetails, Serializable
public class SecurityResource
extends Object
implements ResourceDetails

ResourceDetails的实现类

Author:
cac, william
See Also:
Serialized Form

Constructor Summary
SecurityResource(String resString, String resType, org.acegisecurity.GrantedAuthority[] authorities)
Method Summary
boolean | equals(Object rhs)
org.acegisecurity.GrantedAuthority[] | getAuthorities() 返回属于该resource的authorities
String | getResString() 资源串
String | getResType() 资源类型,如URL,FUNCTION,CONTROL
int | hashCode()
protected void | setAuthorities(org.acegisecurity.GrantedAuthority[] authorities)
void | setResString(String resString)
void | setResType(String resType)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SecurityResource

public SecurityResource(String resString,
                        String resType,
                        org.acegisecurity.GrantedAuthority[] authorities)
Method Detail

equals

public boolean equals(Object rhs)

hashCode

public int hashCode()

getResString

public String getResString()
Description copied from interface: ResourceDetails
资源串

Specified by:
getResString in interface ResourceDetails

setResString

public void setResString(String resString)

getAuthorities

public org.acegisecurity.GrantedAuthority[] getAuthorities()
Description copied from interface: ResourceDetails
返回属于该resource的authorities

Specified by:
getAuthorities in interface ResourceDetails

getResType

public String getResType()
Description copied from interface: ResourceDetails
资源类型,如URL,FUNCTION,CONTROL

Specified by:
getResType in interface ResourceDetails

setResType

public void setResType(String resType)

setAuthorities

protected void setAuthorities(org.acegisecurity.GrantedAuthority[] authorities)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MarmotAuthenticationManager

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.core
Class MarmotAuthenticationManager

java.lang.Object
    extended by org.marmot.security.core.MarmotAuthenticationManager
public class MarmotAuthenticationManager
extends Object

Constructor Summary
MarmotAuthenticationManager()
Method Summary
void | authenticate(String username, String password) ACEGI权限判断以及权限系统环境初始化设置
boolean | authentication(Role role, String resource)
boolean | authentication(String user, String resource)
org.acegisecurity.AuthenticationManager | getAcegiAuthenticationManager()
org.acegisecurity.ui.AuthenticationDetailsSource | getAuthenticationDetailsSource()
ResourceCache | getResourceCache()
ResourceDefinitionSource | getResourceDefinitionSource()
org.acegisecurity.providers.dao.UserCache | getUserCache()
UserService | getUserService()
boolean | isAllowIfResourceNotGranted()
boolean | isAllowPublicInvocations()
void | setAcegiAuthenticationManager(org.acegisecurity.AuthenticationManager acegiAuthenticationManager)
void | setAllowIfResourceNotGranted(boolean allowIfResourceNotGranted)
void | setAllowPublicInvocations(boolean rejectPublicInvocations)
void | setAuthenticationDetailsSource(org.acegisecurity.ui.AuthenticationDetailsSource authenticationDetailsSource)
void | setResourceCache(ResourceCache resourceCache)
void | setResourceDefinitionSource(ResourceDefinitionSource resourceDefinitionSource)
void | setUserCache(org.acegisecurity.providers.dao.UserCache userCache)
void | setUserService(UserService userService)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MarmotAuthenticationManager

public MarmotAuthenticationManager()
Method Detail

getAuthenticationDetailsSource

public org.acegisecurity.ui.AuthenticationDetailsSource getAuthenticationDetailsSource()

setAuthenticationDetailsSource

public void setAuthenticationDetailsSource(org.acegisecurity.ui.AuthenticationDetailsSource authenticationDetailsSource)

getAcegiAuthenticationManager

public org.acegisecurity.AuthenticationManager getAcegiAuthenticationManager()

setAcegiAuthenticationManager

public void setAcegiAuthenticationManager(org.acegisecurity.AuthenticationManager acegiAuthenticationManager)

authenticate

public void authenticate(String username,
                         String password)
                  throws Exception
ACEGI权限判断以及权限系统环境初始化设置

Parameters:
username -
password -
Throws:
Exception

authentication

public boolean authentication(String user,
                              String resource)

authentication

public boolean authentication(Role role,
                              String resource)

isAllowIfResourceNotGranted

public boolean isAllowIfResourceNotGranted()

setAllowIfResourceNotGranted

public void setAllowIfResourceNotGranted(boolean allowIfResourceNotGranted)

isAllowPublicInvocations

public boolean isAllowPublicInvocations()

setAllowPublicInvocations

public void setAllowPublicInvocations(boolean rejectPublicInvocations)

getResourceCache

public ResourceCache getResourceCache()

setResourceCache

public void setResourceCache(ResourceCache resourceCache)

getUserCache

public org.acegisecurity.providers.dao.UserCache getUserCache()

setUserCache

public void setUserCache(org.acegisecurity.providers.dao.UserCache userCache)

getUserService

public UserService getUserService()

setUserService

public void setUserService(UserService userService)

getResourceDefinitionSource

public ResourceDefinitionSource getResourceDefinitionSource()

setResourceDefinitionSource

public void setResourceDefinitionSource(ResourceDefinitionSource resourceDefinitionSource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.core

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.core

Class Summary
MarmotAuthenticationManager


org.marmot.security.definition

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.definition

Class Summary
ResourceDefinitionSource 在resourceCache中保存每个方法对应的ResourceDetails


ResourceDefinitionSource

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.definition
Class ResourceDefinitionSource

java.lang.Object
    extended by org.marmot.security.definition.ResourceDefinitionSource
public class ResourceDefinitionSource
extends Object

在resourceCache中保存每个方法对应的ResourceDetails

Author:
william

Constructor Summary
ResourceDefinitionSource()
Method Summary
Collection | getControlAuthorities(String resString)
boolean | isMatch(String url, String resString)
boolean | isUseAntPath()
protected Collection | lookupAttributes(String resString)
void | setAcegiCacheManager(AcegiCacheManager acegiCacheManager)
void | setUseAntPath(boolean useAntPath)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceDefinitionSource

public ResourceDefinitionSource()
Method Detail

setAcegiCacheManager

public void setAcegiCacheManager(AcegiCacheManager acegiCacheManager)

getControlAuthorities

public Collection getControlAuthorities(String resString)

lookupAttributes

protected Collection lookupAttributes(String resString)

isMatch

public boolean isMatch(String url,
                       String resString)

isUseAntPath

public boolean isUseAntPath()

setUseAntPath

public void setUseAntPath(boolean useAntPath)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.domain

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.domain

Class Summary
ProxyUser | Proxyuser generated by hbm2java
ResCategory | ResPermistype generated by hbm2java
Resource | Resource generated by hbm2java
ResourceCategory | RescType generated by hbm2java
Role | Role generated by hbm2java
RoleRes | RolePermi generated by hbm2java
User | User generated by hbm2java
UserRole | UserRole generated by hbm2java


ProxyUser

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class ProxyUser

java.lang.Object
    extended by org.marmot.security.domain.ProxyUser
All Implemented Interfaces:
Serializable
public class ProxyUser
extends Object
implements Serializable

Proxyuser generated by hbm2java

See Also:
Serialized Form

Constructor Summary
ProxyUser()
ProxyUser(String id)
Method Summary
Date | getActiveTime()
Date | getDormantTime()
String | getId()
Role | getRole()
User | getUserByProxyUserId()
User | getUserByUserId()
void | setActiveTime(Date activeTime)
void | setDormantTime(Date dormantTime)
void | setId(String id)
void | setRole(Role role)
void | setUserByProxyUserId(User userByProxyUserId)
void | setUserByUserId(User userByUserId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyUser

public ProxyUser()

ProxyUser

public ProxyUser(String id)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getUserByUserId

public User getUserByUserId()

setUserByUserId

public void setUserByUserId(User userByUserId)

getRole

public Role getRole()

setRole

public void setRole(Role role)

getUserByProxyUserId

public User getUserByProxyUserId()

setUserByProxyUserId

public void setUserByProxyUserId(User userByProxyUserId)

getActiveTime

public Date getActiveTime()

setActiveTime

public void setActiveTime(Date activeTime)

getDormantTime

public Date getDormantTime()

setDormantTime

public void setDormantTime(Date dormantTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ResCategory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class ResCategory

java.lang.Object
    extended by org.marmot.security.domain.ResCategory
All Implemented Interfaces:
Serializable
public class ResCategory
extends Object
implements Serializable

ResPermistype generated by hbm2java

See Also:
Serialized Form

Constructor Summary
ResCategory()
ResCategory(String id)
ResCategory(String id, ResourceCategory category, Resource resource)
Method Summary
ResourceCategory | getCategory()
String | getId()
Resource | getResource()
void | setCategory(ResourceCategory category)
void | setId(String id)
void | setResource(Resource resource)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResCategory

public ResCategory()

ResCategory

public ResCategory(String id)

ResCategory

public ResCategory(String id,
                   ResourceCategory category,
                   Resource resource)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getCategory

public ResourceCategory getCategory()

setCategory

public void setCategory(ResourceCategory category)

getResource

public Resource getResource()

setResource

public void setResource(Resource resource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Resource

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class Resource

java.lang.Object
    extended by org.marmot.security.domain.Resource
All Implemented Interfaces:
Serializable
public class Resource
extends Object
implements Serializable

Resource generated by hbm2java

See Also:
Serialized Form

Constructor Summary
Resource()
Resource(String id)
Method Summary
String | getDescn()
String | getId()
String | getName()
List | getResCategorys()
String | getResString()
String | getResType()
List | getRoleRess()
int | getSortOrder()
boolean | getStatusFlag()
void | setDescn(String descn)
void | setId(String id)
void | setName(String name)
void | setResCategorys(List resCategorys)
void | setResString(String resString)
void | setResType(String resType)
void | setRoleRess(List roleRess)
void | setSortOrder(int sortOrder)
void | setStatusFlag(boolean statusFlag)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Resource

public Resource()

Resource

public Resource(String id)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getName

public String getName()

setName

public void setName(String name)

getResType

public String getResType()

setResType

public void setResType(String resType)

getResString

public String getResString()

setResString

public void setResString(String resString)

getDescn

public String getDescn()

setDescn

public void setDescn(String descn)

getSortOrder

public int getSortOrder()

setSortOrder

public void setSortOrder(int sortOrder)

getStatusFlag

public boolean getStatusFlag()

setStatusFlag

public void setStatusFlag(boolean statusFlag)

getRoleRess

public List getRoleRess()

setRoleRess

public void setRoleRess(List roleRess)

getResCategorys

public List getResCategorys()

setResCategorys

public void setResCategorys(List resCategorys)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceCategory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class ResourceCategory

java.lang.Object
    extended by org.marmot.security.domain.ResourceCategory
All Implemented Interfaces:
Serializable
public class ResourceCategory
extends Object
implements Serializable

RescType generated by hbm2java

See Also:
Serialized Form

Constructor Summary
ResourceCategory()
ResourceCategory(String id)
Method Summary
String | getCategoryType()
String | getDescn()
String | getId()
String | getLabel()
String | getMeta1()
String | getMeta2()
String | getMeta3()
String | getName()
String | getParentId()
List | getResCategorys()
List | getResourceCategorys()
int | getSortOrder()
int | getSubItemCount()
String | getViewString()
void | setCategoryType(String categoryType)
void | setDescn(String descn)
void | setId(String id)
void | setLabel(String label)
void | setMeta1(String meta1)
void | setMeta2(String meta2)
void | setMeta3(String meta3)
void | setName(String name)
void | setParentId(String parentId)
void | setResCategorys(List resCategorys)
void | setResourceCategorys(List resourceCategorys)
void | setSortOrder(int sortOrder)
void | setSubItemCount(int subItemCount)
void | setViewString(String view)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceCategory

public ResourceCategory()

ResourceCategory

public ResourceCategory(String id)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getParentId

public String getParentId()

setParentId

public void setParentId(String parentId)

getResourceCategorys

public List getResourceCategorys()

setResourceCategorys

public void setResourceCategorys(List resourceCategorys)

getResCategorys

public List getResCategorys()

setResCategorys

public void setResCategorys(List resCategorys)

getName

public String getName()

setName

public void setName(String name)

getDescn

public String getDescn()

setDescn

public void setDescn(String descn)

getSortOrder

public int getSortOrder()

setSortOrder

public void setSortOrder(int sortOrder)

getSubItemCount

public int getSubItemCount()

setSubItemCount

public void setSubItemCount(int subItemCount)

getMeta1

public String getMeta1()

setMeta1

public void setMeta1(String meta1)

getMeta2

public String getMeta2()

setMeta2

public void setMeta2(String meta2)

getMeta3

public String getMeta3()

setMeta3

public void setMeta3(String meta3)

getViewString

public String getViewString()

setViewString

public void setViewString(String view)

getCategoryType

public String getCategoryType()

setCategoryType

public void setCategoryType(String categoryType)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Role

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class Role

java.lang.Object
    extended by org.marmot.security.domain.Role
All Implemented Interfaces:
Serializable
public class Role
extends Object
implements Serializable

Role generated by hbm2java

See Also:
Serialized Form

Constructor Summary
Role()
Role(String id)
Method Summary
String | getDescn()
String | getId()
String | getLabel()
String | getName()
List | getProxyUsers()
List | getRoleRess()
List | getUserRoles()
void | setDescn(String descn)
void | setId(String id)
void | setLabel(String label)
void | setName(String name)
void | setProxyUsers(List proxyUsers)
void | setRoleRess(List roleRess)
void | setUserRoles(List userRoles)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Role

public Role()

Role

public Role(String id)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getName

public String getName()

setName

public void setName(String name)

getDescn

public String getDescn()

setDescn

public void setDescn(String descn)

getUserRoles

public List getUserRoles()

setUserRoles

public void setUserRoles(List userRoles)

getProxyUsers

public List getProxyUsers()

setProxyUsers

public void setProxyUsers(List proxyUsers)

getRoleRess

public List getRoleRess()

setRoleRess

public void setRoleRess(List roleRess)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleRes

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class RoleRes

java.lang.Object
    extended by org.marmot.security.domain.RoleRes
All Implemented Interfaces:
Serializable
public class RoleRes
extends Object
implements Serializable

RolePermi generated by hbm2java

See Also:
Serialized Form

Constructor Summary
RoleRes()
RoleRes(String id, Role role)
Method Summary
String | getId()
String | getProperty()
Resource | getResource()
Role | getRole()
void | setId(String id)
void | setProperty(String property)
void | setResource(Resource resource)
void | setRole(Role role)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RoleRes

public RoleRes()

RoleRes

public RoleRes(String id,
               Role role)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getRole

public Role getRole()

setRole

public void setRole(Role role)

getResource

public Resource getResource()

setResource

public void setResource(Resource resource)

getProperty

public String getProperty()

setProperty

public void setProperty(String property)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


User

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class User

java.lang.Object
    extended by org.marmot.security.domain.User
All Implemented Interfaces:
Serializable
public class User
extends Object
implements Serializable

User generated by hbm2java

See Also:
Serialized Form

Constructor Summary
User()
Method Summary
String | getDescn()
String | getId()
String | getLoginid()
String | getName()
String | getPasswd()
List | getProxyusersForProxyuserId()
List | getProxyusersForUserId()
boolean | getStatusFlag()
List | getUserRoles()
boolean | isRoot()
void | setDescn(String descn)
void | setId(String id)
void | setLoginid(String loginid)
void | setName(String name)
void | setPasswd(String passwd)
void | setProxyusersForProxyuserId(List proxyusersForProxyUserId)
void | setProxyusersForUserId(List proxyusersForUserId)
void | setRoot(boolean root)
void | setStatusFlag(boolean statusFlag)
void | setUserRoles(List userRoles)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

User

public User()
Method Detail

getId

public String getId()

setId

public void setId(String id)

getLoginid

public String getLoginid()

setLoginid

public void setLoginid(String loginid)

getPasswd

public String getPasswd()

setPasswd

public void setPasswd(String passwd)

getStatusFlag

public boolean getStatusFlag()

setStatusFlag

public void setStatusFlag(boolean statusFlag)

getDescn

public String getDescn()

setDescn

public void setDescn(String descn)

isRoot

public boolean isRoot()

setRoot

public void setRoot(boolean root)

getProxyusersForUserId

public List getProxyusersForUserId()

setProxyusersForUserId

public void setProxyusersForUserId(List proxyusersForUserId)

getUserRoles

public List getUserRoles()

setUserRoles

public void setUserRoles(List userRoles)

getProxyusersForProxyuserId

public List getProxyusersForProxyuserId()

setProxyusersForProxyuserId

public void setProxyusersForProxyuserId(List proxyusersForProxyUserId)

getName

public String getName()

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserRole

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.domain
Class UserRole

java.lang.Object
    extended by org.marmot.security.domain.UserRole
All Implemented Interfaces:
Serializable
public class UserRole
extends Object
implements Serializable

UserRole generated by hbm2java

See Also:
Serialized Form

Constructor Summary
UserRole()
UserRole(String id)
UserRole(String id, User user, Role role)
Method Summary
String | getId()
Role | getRole()
User | getUser()
void | setId(String id)
void | setRole(Role role)
void | setUser(User user)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UserRole

public UserRole()

UserRole

public UserRole(String id)

UserRole

public UserRole(String id,
                User user,
                Role role)
Method Detail

getId

public String getId()

setId

public void setId(String id)

getUser

public User getUser()

setUser

public void setUser(User user)

getRole

public Role getRole()

setRole

public void setRole(Role role)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MarmotSecurityViewModel

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.dorado
Class MarmotSecurityViewModel

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
        extended by com.bstek.dorado.view.DefaultViewModel
            extended by org.marmot.framework.dorado.MarmotViewModel
                extended by org.marmot.security.dorado.MarmotSecurityViewModel
All Implemented Interfaces:
com.bstek.dorado.view.Element, com.bstek.dorado.view.EventSupported, com.bstek.dorado.view.ViewModel
public class MarmotSecurityViewModel
extends org.marmot.framework.dorado.MarmotViewModel

提供权限过滤功能的视图模型实现类(继承自MarmotViewModel)

Author:
William Jiang

Field Summary
Fields inherited from class com.bstek.dorado.view.ViewModelSupport
controls, datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_REPORT, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
MarmotSecurityViewModel()
Method Summary
protected static org.springframework.beans.factory.BeanFactory | getBeanFactory()
FilterUtils | getfilterUtils()
protected void | initControl(com.bstek.dorado.view.control.Control control)
protected void | initDataset(com.bstek.dorado.view.data.ViewDataset dataset)
Methods inherited from class org.marmot.framework.dorado.MarmotViewModel
doLoadData, getAutoForm, getAutoFormProfileHelper, getDataset, getDataTable, getDataTableProfileHelper, getPredefinedDatasetProcessors, getQueryDatasetListener, getQueryManager, initClientGlobalVars, initProfileSupportedAutoForm, initProfileSupportedDataTable
Methods inherited from class com.bstek.dorado.view.ViewModelSupport
addEventHandler, checkAccess, clientGlobalVars, constructControl, constructDataset, createControl, createControl, createDataset, createDataset, doLoadData, doUpdateData, doUpdateData, eventHandlers, finalize, getClientType, getConfig, getConfigName, getControl, getControls, getDatasets, getDefaultSkin, getEventHandler, getNamespace, getRole, getRoleConfigs, getSkin, getState, getTag, handleRPC, handleUpdate, init, initControls, initDatasets, initLookupFields, isControlLazyLoad, isSafe, loadEventConfig, prepareDatasets, properties, removeControl, removeDataset, removeEventHandler, setClientType, setConfig, setConfigName, setControlLazyLoad, setNamespace, setRole, setSafe, setSkin, setTag, updateData
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MarmotSecurityViewModel

public MarmotSecurityViewModel()
Method Detail

getBeanFactory

protected static org.springframework.beans.factory.BeanFactory getBeanFactory()

getfilterUtils

public FilterUtils getfilterUtils()
                           throws Exception
Throws:
Exception

initControl

protected void initControl(com.bstek.dorado.view.control.Control control)
                    throws Exception
Throws:
Exception

initDataset

protected void initDataset(com.bstek.dorado.view.data.ViewDataset dataset)
                    throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.dorado

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.dorado

Class Summary
MarmotSecurityViewModel | 提供权限过滤功能的视图模型实现类(继承自MarmotViewModel)
SecurityViewModel | 提供权限过滤功能的视图模型实现类(继承自DynaViewModel)


SecurityViewModel

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.dorado
Class SecurityViewModel

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
        extended by com.bstek.dorado.view.DefaultViewModel
            extended by com.bstek.dorado.view.impl.DynaViewModel
                extended by org.marmot.security.dorado.SecurityViewModel
All Implemented Interfaces:
com.bstek.dorado.view.Element, com.bstek.dorado.view.EventSupported, com.bstek.dorado.view.ViewModel
public class SecurityViewModel
extends com.bstek.dorado.view.impl.DynaViewModel

提供权限过滤功能的视图模型实现类(继承自DynaViewModel)

Author:
William Jiang

Field Summary
Fields inherited from class com.bstek.dorado.view.ViewModelSupport
controls, datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_REPORT, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
SecurityViewModel()
Method Summary
protected static org.springframework.beans.factory.BeanFactory | getBeanFactory()
FilterUtils | getFilterUtils()
protected void | initControl(com.bstek.dorado.view.control.Control control)
protected void | initDataset(com.bstek.dorado.view.data.ViewDataset dataset)
Methods inherited from class com.bstek.dorado.view.ViewModelSupport
addEventHandler, checkAccess, clientGlobalVars, constructControl, constructDataset, createControl, createControl, createDataset, createDataset, doLoadData, doLoadData, doUpdateData, doUpdateData, eventHandlers, finalize, getClientType, getConfig, getConfigName, getControl, getControls, getDataset, getDatasets, getDefaultSkin, getEventHandler, getNamespace, getRole, getRoleConfigs, getSkin, getState, getTag, handleRPC, handleUpdate, init, initClientGlobalVars, initControls, initDatasets, initLookupFields, isControlLazyLoad, isSafe, loadEventConfig, prepareDatasets, properties, removeControl, removeDataset, removeEventHandler, setClientType, setConfig, setConfigName, setControlLazyLoad, setNamespace, setRole, setSafe, setSkin, setTag, updateData
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SecurityViewModel

public SecurityViewModel()
Method Detail

getBeanFactory

protected static org.springframework.beans.factory.BeanFactory getBeanFactory()

getFilterUtils

public FilterUtils getFilterUtils()
                           throws Exception
Throws:
Exception

initControl

protected void initControl(com.bstek.dorado.view.control.Control control)
                    throws Exception
Throws:
Exception

initDataset

protected void initDataset(com.bstek.dorado.view.data.ViewDataset dataset)
                    throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MarmotMethodAccessDeniedException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.exception
Class MarmotMethodAccessDeniedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.springframework.core.NestedRuntimeException
                    extended by org.acegisecurity.AcegiSecurityException
                        extended by org.acegisecurity.AccessDeniedException
                            extended by org.marmot.security.exception.MarmotMethodAccessDeniedException
All Implemented Interfaces:
Serializable
public class MarmotMethodAccessDeniedException
extends org.acegisecurity.AccessDeniedException

See Also:
Serialized Form

Constructor Summary
MarmotMethodAccessDeniedException(String message, Throwable t)
Methods inherited from class org.springframework.core.NestedRuntimeException
contains, getCause, getMessage, getRootCause, printStackTrace, printStackTrace
Methods inherited from class java.lang.Throwable
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

MarmotMethodAccessDeniedException

public MarmotMethodAccessDeniedException(String message,
                                         Throwable t)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.exception

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.exception

Exception Summary
MarmotMethodAccessDeniedException


AutoFormFilter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class AutoFormFilter

java.lang.Object
    extended by org.marmot.security.filter.AutoFormFilter
All Implemented Interfaces:
CategoryFilter, ControlFilter
public class AutoFormFilter
extends Object
implements CategoryFilter, ControlFilter

Author:
William Jiang

Constructor Summary
AutoFormFilter()
Method Summary
Map | getColumnProperties()
FilterAccessor | getFilterAccessor()
Map | getFormProperties()
Map | getGroupProperties()
ResourceCategory | initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initProperties()
boolean | isAutoCreateColumns()
void | setAutoCreateColumns(boolean autoCreateColumns)
void | setColumnProperties(Map columnProperties)
void | setFilterAccessor(FilterAccessor categoryAccessor)
void | setFormProperties(Map formProperties)
void | setGroupProperties(Map groupProperties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoFormFilter

public AutoFormFilter()
Method Detail

initProperties

public void initProperties()

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Specified by:
initCategory in interface CategoryFilter
Throws:
Exception

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Specified by:
initControl in interface ControlFilter
Throws:
Exception

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryAccessor)

getFormProperties

public Map getFormProperties()

setFormProperties

public void setFormProperties(Map formProperties)

getGroupProperties

public Map getGroupProperties()

setGroupProperties

public void setGroupProperties(Map groupProperties)

isAutoCreateColumns

public boolean isAutoCreateColumns()

setAutoCreateColumns

public void setAutoCreateColumns(boolean autoCreateColumns)

getColumnProperties

public Map getColumnProperties()

setColumnProperties

public void setColumnProperties(Map columnProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CategoryFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Interface CategoryFilter

All Known Implementing Classes:
AutoFormFilter, DatasetFilter, DataTableFilter, OutlookBarFilter, SimpleFilter, TabSetFilter
public interface CategoryFilter

Author:
William Jiang

Method Summary
 ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)

Method Detail

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ControlFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Interface ControlFilter

All Known Implementing Classes:
AutoFormFilter, DatasetFilter, DataTableFilter, OutlookBarFilter, SimpleFilter, TabSetFilter
public interface ControlFilter

Method Summary
 void initControl(Object object, String viewPrefix)

Method Detail

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class DatasetFilter

java.lang.Object
    extended by org.marmot.security.filter.DatasetFilter
All Implemented Interfaces:
CategoryFilter, ControlFilter
public class DatasetFilter
extends Object
implements CategoryFilter, ControlFilter

Author:
William Jiang

Constructor Summary
DatasetFilter()
Method Summary
Map | getDatasetProperties()
Map | getFieldProperties()
FilterAccessor | getFilterAccessor()
ResourceCategory | initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initProperties()
void | setDatasetProperties(Map formProperties)
void | setFieldProperties(Map groupProperties)
void | setFilterAccessor(FilterAccessor categoryAccessor)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DatasetFilter

public DatasetFilter()
Method Detail

initProperties

public void initProperties()

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Specified by:
initCategory in interface CategoryFilter
Throws:
Exception

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Specified by:
initControl in interface ControlFilter
Throws:
Exception

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryAccessor)

getDatasetProperties

public Map getDatasetProperties()

setDatasetProperties

public void setDatasetProperties(Map formProperties)

getFieldProperties

public Map getFieldProperties()

setFieldProperties

public void setFieldProperties(Map groupProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataTableFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class DataTableFilter

java.lang.Object
    extended by org.marmot.security.filter.DataTableFilter
All Implemented Interfaces:
CategoryFilter, ControlFilter
public class DataTableFilter
extends Object
implements CategoryFilter, ControlFilter

Author:
William Jiang

Constructor Summary
DataTableFilter()
Method Summary
Map | getColumnProperties()
FilterAccessor | getFilterAccessor()
Map | getGroupColumnProperties()
Map | getTableProperties()
ResourceCategory | initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initProperties()
boolean | isAutoCreateColumns()
void | setAutoCreateColumns(boolean autoCreateColumns)
void | setColumnProperties(Map columnProperties)
void | setFilterAccessor(FilterAccessor categoryAccessor)
void | setGroupColumnProperties(Map columnProperties)
void | setTableProperties(Map tableProperties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataTableFilter

public DataTableFilter()
Method Detail

initProperties

public void initProperties()

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Specified by:
initCategory in interface CategoryFilter
Throws:
Exception

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Specified by:
initControl in interface ControlFilter
Throws:
Exception

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryAccessor)

getGroupColumnProperties

public Map getGroupColumnProperties()

setGroupColumnProperties

public void setGroupColumnProperties(Map columnProperties)

getTableProperties

public Map getTableProperties()

setTableProperties

public void setTableProperties(Map tableProperties)

isAutoCreateColumns

public boolean isAutoCreateColumns()

setAutoCreateColumns

public void setAutoCreateColumns(boolean autoCreateColumns)

getColumnProperties

public Map getColumnProperties()

setColumnProperties

public void setColumnProperties(Map columnProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterAccessor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class FilterAccessor

java.lang.Object
    extended by org.marmot.security.filter.FilterAccessor
public class FilterAccessor
extends Object

Author:
William Jiang

Field Summary
static String | CATEGORY_CONTROLS
static String | CATEGORY_DATASETS
static String | CATEGORY_DIRECTORY
static String | CATEGORY_URL
Constructor Summary
FilterAccessor()
Method Summary
ResourceCategory | asyncCategory(ResourceCategory category, boolean async)
boolean | authentication(String resString)
ServiceUtil | getServiceUtil()
Resource | initResource(ResourceCategory category, String resString, String name)
void | initResourceCategory(ResourceCategory category, Resource resource)
void | setServiceUtil(ServiceUtil daoManager)
void | updateCategory(ResourceCategory category)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CATEGORY_DIRECTORY

public static final String CATEGORY_DIRECTORY
See Also:
Constant Field Values

CATEGORY_URL

public static final String CATEGORY_URL
See Also:
Constant Field Values

CATEGORY_DATASETS

public static final String CATEGORY_DATASETS
See Also:
Constant Field Values

CATEGORY_CONTROLS

public static final String CATEGORY_CONTROLS
See Also:
Constant Field Values
Constructor Detail

FilterAccessor

public FilterAccessor()
Method Detail

getServiceUtil

public ServiceUtil getServiceUtil()

setServiceUtil

public void setServiceUtil(ServiceUtil daoManager)

initResource

public Resource initResource(ResourceCategory category,
                             String resString,
                             String name)

initResourceCategory

public void initResourceCategory(ResourceCategory category,
                                 Resource resource)

updateCategory

public void updateCategory(ResourceCategory category)

asyncCategory

public ResourceCategory asyncCategory(ResourceCategory category,
                                      boolean async)

authentication

public boolean authentication(String resString)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class FilterUtils

java.lang.Object
    extended by org.marmot.security.filter.FilterUtils
public class FilterUtils
extends Object

Author:
William Jiang

Constructor Summary
FilterUtils()
Method Summary
ResourceCategory | asyncCategory(ResourceCategory category, boolean async)
Map | getControlsMap()
CategoryFilter | getDefaultCategoryFilter()
ControlFilter | getDefaultControlFilter()
FilterAccessor | getFilterAccessor()
ResourceCategory | initCategory(String type, com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initResourceCategory(ResourceCategory category, Resource resource)
void | setControlsMap(Map controlsMap)
void | setDefaultCategoryFilter(CategoryFilter defaultFilter)
void | setDefaultControlFilter(ControlFilter defaultControlFilter)
void | setFilterAccessor(FilterAccessor categoryHelper)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FilterUtils

public FilterUtils()
Method Detail

initCategory

public ResourceCategory initCategory(String type,
                                     com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Throws:
Exception

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Throws:
Exception

asyncCategory

public ResourceCategory asyncCategory(ResourceCategory category,
                                      boolean async)
                               throws Exception
Throws:
Exception

initResourceCategory

public void initResourceCategory(ResourceCategory category,
                                 Resource resource)

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryHelper)

getControlsMap

public Map getControlsMap()

setControlsMap

public void setControlsMap(Map controlsMap)

getDefaultCategoryFilter

public CategoryFilter getDefaultCategoryFilter()

setDefaultCategoryFilter

public void setDefaultCategoryFilter(CategoryFilter defaultFilter)

getDefaultControlFilter

public ControlFilter getDefaultControlFilter()

setDefaultControlFilter

public void setDefaultControlFilter(ControlFilter defaultControlFilter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OutlookBarFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class OutlookBarFilter

java.lang.Object
    extended by org.marmot.security.filter.OutlookBarFilter
All Implemented Interfaces:
CategoryFilter, ControlFilter
public class OutlookBarFilter
extends Object
implements CategoryFilter, ControlFilter

Author:
William Jiang

Constructor Summary
OutlookBarFilter()
Method Summary
FilterAccessor | getFilterAccessor()
Map | getGroupProperties()
Map | getOutlookBarProperties()
ResourceCategory | initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initProperties()
void | setFilterAccessor(FilterAccessor categoryAccessor)
void | setGroupProperties(Map groupProperties)
void | setOutlookBarProperties(Map outlookbarProperties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutlookBarFilter

public OutlookBarFilter()
Method Detail

initProperties

public void initProperties()

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Specified by:
initCategory in interface CategoryFilter
Throws:
Exception

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Specified by:
initControl in interface ControlFilter
Throws:
Exception

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryAccessor)

getGroupProperties

public Map getGroupProperties()

setGroupProperties

public void setGroupProperties(Map groupProperties)

getOutlookBarProperties

public Map getOutlookBarProperties()

setOutlookBarProperties

public void setOutlookBarProperties(Map outlookbarProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.filter

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.filter

Interface Summary
CategoryFilter
ControlFilter

Class Summary
AutoFormFilter
DatasetFilter
DataTableFilter
FilterAccessor
FilterUtils
OutlookBarFilter
PropertiesInfo
SimpleFilter
TabSetFilter


PropertiesInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class PropertiesInfo

java.lang.Object
    extended by org.marmot.security.filter.PropertiesInfo
public class PropertiesInfo
extends Object

Constructor Summary
PropertiesInfo()
Method Summary
String | getAuthFailureValue()
String | getAuthLabel()
String | getAuthSuccessValue()
void | setAuthFailureValue(String authFailureValue)
void | setAuthLabel(String authLabel)
void | setAuthSuccessValue(String authSuccessValue)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertiesInfo

public PropertiesInfo()
Method Detail

getAuthFailureValue

public String getAuthFailureValue()

setAuthFailureValue

public void setAuthFailureValue(String authFailureValue)

getAuthLabel

public String getAuthLabel()

setAuthLabel

public void setAuthLabel(String authLabel)

getAuthSuccessValue

public String getAuthSuccessValue()

setAuthSuccessValue

public void setAuthSuccessValue(String authSuccessValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class SimpleFilter

java.lang.Object
    extended by org.marmot.security.filter.SimpleFilter
All Implemented Interfaces:
CategoryFilter, ControlFilter
public class SimpleFilter
extends Object
implements CategoryFilter, ControlFilter

Constructor Summary
SimpleFilter()
Method Summary
FilterAccessor | getFilterAccessor()
Map | getProperties()
ResourceCategory | initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parent, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initProperties()
void | setFilterAccessor(FilterAccessor categoryAccessor)
void | setProperties(Map properties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleFilter

public SimpleFilter()
Method Detail

initProperties

public void initProperties()

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parent,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Specified by:
initCategory in interface CategoryFilter
Throws:
Exception

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryAccessor)

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Specified by:
initControl in interface ControlFilter
Throws:
Exception

getProperties

public Map getProperties()

setProperties

public void setProperties(Map properties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabSetFilter

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.filter
Class TabSetFilter

java.lang.Object
    extended by org.marmot.security.filter.TabSetFilter
All Implemented Interfaces:
CategoryFilter, ControlFilter
public class TabSetFilter
extends Object
implements CategoryFilter, ControlFilter

Author:
William Jiang

Constructor Summary
TabSetFilter()
Method Summary
FilterAccessor | getFilterAccessor()
Map | getTabProperties()
Map | getTabsetProperties()
ResourceCategory | initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
void | initControl(Object object, String viewPrefix)
void | initProperties()
void | setFilterAccessor(FilterAccessor categoryAccessor)
void | setTabProperties(Map tabProperties)
void | setTabsetProperties(Map tabsetProperties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TabSetFilter

public TabSetFilter()
Method Detail

initProperties

public void initProperties()

initCategory

public ResourceCategory initCategory(com.bstek.dorado.utils.xml.XmlNode node,
                                     ResourceCategory parentCategory,
                                     ResourceCategory viewCategory,
                                     boolean async)
                              throws Exception
Specified by:
initCategory in interface CategoryFilter
Throws:
Exception

initControl

public void initControl(Object object,
                        String viewPrefix)
                 throws Exception
Specified by:
initControl in interface ControlFilter
Throws:
Exception

getFilterAccessor

public FilterAccessor getFilterAccessor()

setFilterAccessor

public void setFilterAccessor(FilterAccessor categoryAccessor)

getTabProperties

public Map getTabProperties()

setTabProperties

public void setTabProperties(Map tabProperties)

getTabsetProperties

public Map getTabsetProperties()

setTabsetProperties

public void setTabsetProperties(Map tabsetProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DBMethodDefinitionSource

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.intercept.method
Class DBMethodDefinitionSource

java.lang.Object
    extended by org.marmot.security.intercept.method.DBMethodDefinitionSource
All Implemented Interfaces:
org.acegisecurity.intercept.method.MethodDefinitionSource, org.acegisecurity.intercept.ObjectDefinitionSource
public class DBMethodDefinitionSource
extends Object
implements org.acegisecurity.intercept.method.MethodDefinitionSource

在resourceCache中保存每个方法对应的ResourceDetails

Author:
cac, william

Constructor Summary
DBMethodDefinitionSource()
Method Summary
org.acegisecurity.ConfigAttributeDefinition | getAttributes(Object object)
Iterator | getConfigAttributeDefinitions()
static boolean | isMatch(Class clszz, Method mi, String methodString) Return if the given method name matches the mapped name.
protected org.acegisecurity.ConfigAttributeDefinition | lookupAttributes(Class clszz, Method mi) 从resourceCache中获取当前方法对应的ResourceDetailsResourceDetails 最后返回由Role Name 组装成的ConfigAttributeDefinition(@link ConfigAttributeDefinition)
void | setAcegiCacheManager(AcegiCacheManager acegiCacheManager)
boolean | supports(Class clazz)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DBMethodDefinitionSource

public DBMethodDefinitionSource()
Method Detail

setAcegiCacheManager

public void setAcegiCacheManager(AcegiCacheManager acegiCacheManager)

getAttributes

public org.acegisecurity.ConfigAttributeDefinition getAttributes(Object object)
Specified by:
getAttributes in interface org.acegisecurity.intercept.ObjectDefinitionSource

supports

public boolean supports(Class clazz)
Specified by:
supports in interface org.acegisecurity.intercept.ObjectDefinitionSource

lookupAttributes

protected org.acegisecurity.ConfigAttributeDefinition lookupAttributes(Class clszz,
                                                                       Method mi)
从resourceCache中获取当前方法对应的ResourceDetailsResourceDetails 最后返回由Role Name 组装成的ConfigAttributeDefinition(@link ConfigAttributeDefinition)

See Also:
AbstractMethodDefinitionSource.lookupAttributes(java.lang.reflect.Method)

getConfigAttributeDefinitions

public Iterator getConfigAttributeDefinitions()
Specified by:
getConfigAttributeDefinitions in interface org.acegisecurity.intercept.ObjectDefinitionSource

isMatch

public static boolean isMatch(Class clszz,
                              Method mi,
                              String methodString)
Return if the given method name matches the mapped name. The default implementation checks for "xxx" and "xxx" matches.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.intercept.method

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.intercept.method

Class Summary
DBMethodDefinitionSource 在resourceCache中保存每个方法对应的ResourceDetails


MarmotMethodSecurityInterceptor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.intercept.method.aopalliance
Class MarmotMethodSecurityInterceptor

java.lang.Object
    extended by org.acegisecurity.intercept.AbstractSecurityInterceptor
        extended by org.acegisecurity.intercept.method.aopalliance.MethodSecurityInterceptor
            extended by org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor
All Implemented Interfaces:
org.aopalliance.aop.Advice, org.springframework.context.ApplicationEventPublisherAware, org.springframework.beans.factory.InitializingBean, org.aopalliance.intercept.Interceptor, org.springframework.context.MessageSourceAware, org.aopalliance.intercept.MethodInterceptor
public class MarmotMethodSecurityInterceptor
extends org.acegisecurity.intercept.method.aopalliance.MethodSecurityInterceptor

Field Summary
Fields inherited from class org.acegisecurity.intercept.AbstractSecurityInterceptor
logger, messages
Constructor Summary
MarmotMethodSecurityInterceptor()
Method Summary
 Object invoke(org.aopalliance.intercept.MethodInvocation arg0)
Methods inherited from class org.acegisecurity.intercept.method.aopalliance.MethodSecurityInterceptor
getObjectDefinitionSource, getSecureObjectClass, obtainObjectDefinitionSource, setObjectDefinitionSource
Methods inherited from class org.acegisecurity.intercept.AbstractSecurityInterceptor
afterInvocation, afterPropertiesSet, beforeInvocation, getAccessDecisionManager, getAfterInvocationManager, getAuthenticationManager, getRunAsManager, isAlwaysReauthenticate, isRejectPublicInvocations, isValidateConfigAttributes, setAccessDecisionManager, setAfterInvocationManager, setAlwaysReauthenticate, setApplicationEventPublisher, setAuthenticationManager, setMessageSource, setRejectPublicInvocations, setRunAsManager, setValidateConfigAttributes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MarmotMethodSecurityInterceptor

public MarmotMethodSecurityInterceptor()
Method Detail

invoke

public Object invoke(org.aopalliance.intercept.MethodInvocation arg0)
              throws Throwable
Throws:
Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.intercept.method.aopalliance

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.intercept.method.aopalliance

Class Summary
MarmotMethodSecurityInterceptor


DBFilterInvocationDefinitionSource

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.intercept.web
Class DBFilterInvocationDefinitionSource

java.lang.Object
    extended by org.acegisecurity.intercept.web.AbstractFilterInvocationDefinitionSource
        extended by org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
All Implemented Interfaces:
org.acegisecurity.intercept.web.FilterInvocationDefinitionSource, org.acegisecurity.intercept.ObjectDefinitionSource
public class DBFilterInvocationDefinitionSource
extends org.acegisecurity.intercept.web.AbstractFilterInvocationDefinitionSource

Author:
cac, william

Constructor Summary
DBFilterInvocationDefinitionSource()
Method Summary
Iterator | getConfigAttributeDefinitions()
boolean | isConvertUrlToLowercaseBeforeComparison()
boolean | isMatch(String url, String resString)
boolean | isUseAntPath()
org.acegisecurity.ConfigAttributeDefinition | lookupAttributes(String url) 返回当前URL对应的ROLE
void | setAcegiCacheManager(AcegiCacheManager acegiCacheManager)
void | setConvertUrlToLowercaseBeforeComparison(boolean convertUrlToLowercaseBeforeComparison)
void | setUseAntPath(boolean useAntPath)
Methods inherited from class org.acegisecurity.intercept.web.AbstractFilterInvocationDefinitionSource
getAttributes, supports
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DBFilterInvocationDefinitionSource

public DBFilterInvocationDefinitionSource()
Method Detail

setAcegiCacheManager

public void setAcegiCacheManager(AcegiCacheManager acegiCacheManager)

lookupAttributes

public org.acegisecurity.ConfigAttributeDefinition lookupAttributes(String url)
返回当前URL对应的ROLE

See Also:
AbstractFilterInvocationDefinitionSource.lookupAttributes(java.lang.String)

isMatch

public boolean isMatch(String url,
                       String resString)

getConfigAttributeDefinitions

public Iterator getConfigAttributeDefinitions()

setConvertUrlToLowercaseBeforeComparison

public void setConvertUrlToLowercaseBeforeComparison(boolean convertUrlToLowercaseBeforeComparison)

isConvertUrlToLowercaseBeforeComparison

public boolean isConvertUrlToLowercaseBeforeComparison()

isUseAntPath

public boolean isUseAntPath()

setUseAntPath

public void setUseAntPath(boolean useAntPath)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FilterSecurityInterceptor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.intercept.web
Class FilterSecurityInterceptor

java.lang.Object
    extended by org.acegisecurity.intercept.AbstractSecurityInterceptor
        extended by org.marmot.security.intercept.web.FilterSecurityInterceptor
All Implemented Interfaces:
org.springframework.context.ApplicationEventPublisherAware, javax.servlet.Filter, org.springframework.beans.factory.InitializingBean, org.springframework.context.MessageSourceAware
public class FilterSecurityInterceptor
extends org.acegisecurity.intercept.AbstractSecurityInterceptor
implements javax.servlet.Filter

针对url进行权限控制

Author:
William Jiang

Field Summary
Fields inherited from class org.acegisecurity.intercept.AbstractSecurityInterceptor
messages
Constructor Summary
FilterSecurityInterceptor()
Method Summary
void | destroy() Not used (we rely on IoC container lifecycle services instead)
void | doFilter(javax.servlet.ServletRequest request, javax.servlet.ServletResponse response, javax.servlet.FilterChain chain) 将当前请求的url与session中当前登录用户经过授权的资源进行比对判断是否有访问权限 Method that is actually called by the filter chain.
org.acegisecurity.intercept.web.FilterInvocationDefinitionSource | getObjectDefinitionSource()
Class | getSecureObjectClass()
void | init(javax.servlet.FilterConfig config) Not used (we rely on IoC container lifecycle services instead)
void | invoke(org.acegisecurity.intercept.web.FilterInvocation fi)
boolean | isObserveOncePerRequest() Indicates whether once-per-request handling will be observed.
org.acegisecurity.intercept.ObjectDefinitionSource | obtainObjectDefinitionSource()
void | setObjectDefinitionSource(org.acegisecurity.intercept.web.FilterInvocationDefinitionSource newSource)
void | setObserveOncePerRequest(boolean observeOncePerRequest)
Methods inherited from class org.acegisecurity.intercept.AbstractSecurityInterceptor
afterInvocation, afterPropertiesSet, beforeInvocation, getAccessDecisionManager, getAfterInvocationManager, getAuthenticationManager, getRunAsManager, isAlwaysReauthenticate, isRejectPublicInvocations, isValidateConfigAttributes, setAccessDecisionManager, setAfterInvocationManager, setAlwaysReauthenticate, setApplicationEventPublisher, setAuthenticationManager, setMessageSource, setRejectPublicInvocations, setRunAsManager, setValidateConfigAttributes
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FilterSecurityInterceptor

public FilterSecurityInterceptor()
Method Detail

destroy

public void destroy()
Not used (we rely on IoC container lifecycle services instead)

Specified by:
destroy in interface javax.servlet.Filter

doFilter

public void doFilter(javax.servlet.ServletRequest request,
                     javax.servlet.ServletResponse response,
                     javax.servlet.FilterChain chain)
              throws IOException,
                     javax.servlet.ServletException
将当前请求的url与session中当前登录用户经过授权的资源进行比对判断是否有访问权限 Method that is actually called by the filter chain. Simply delegates to the invoke(FilterInvocation) method.

Specified by:
doFilter in interface javax.servlet.Filter
Parameters:
request - the servlet request
response - the servlet response
chain - the filter chain
Throws:
IOException - if the filter chain fails
javax.servlet.ServletException - if the filter chain fails

getObjectDefinitionSource

public org.acegisecurity.intercept.web.FilterInvocationDefinitionSource getObjectDefinitionSource()

getSecureObjectClass

public Class getSecureObjectClass()

init

public void init(javax.servlet.FilterConfig config)
          throws javax.servlet.ServletException
Not used (we rely on IoC container lifecycle services instead)

Specified by:
init in interface javax.servlet.Filter
Throws:
javax.servlet.ServletException - never thrown

invoke

public void invoke(org.acegisecurity.intercept.web.FilterInvocation fi)
            throws IOException,
                   javax.servlet.ServletException
Throws:
IOException
javax.servlet.ServletException

isObserveOncePerRequest

public boolean isObserveOncePerRequest()
Indicates whether once-per-request handling will be observed. By default this is true, meaning the FilterSecurityInterceptor will only execute once-per-request. Sometimes users may wish it to execute more than once per request, such as when JSP forwards are being used and filter security is desired on each included fragment of the HTTP request.

Returns:
true (the default) if once-per-request is honoured, otherwise false if FilterSecurityInterceptor will enforce authorizations for each and every fragment of the HTTP request.

obtainObjectDefinitionSource

public org.acegisecurity.intercept.ObjectDefinitionSource obtainObjectDefinitionSource()

setObjectDefinitionSource

public void setObjectDefinitionSource(org.acegisecurity.intercept.web.FilterInvocationDefinitionSource newSource)

setObserveOncePerRequest

public void setObserveOncePerRequest(boolean observeOncePerRequest)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.intercept.web

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.intercept.web

Class Summary
DBFilterInvocationDefinitionSource |
FilterSecurityInterceptor | 针对url进行权限控制


CategoryManager

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Interface CategoryManager

All Known Implementing Classes:
DefaultCategoryManager
public interface CategoryManager

Method Summary
void | deleteCategory(ResourceCategory category)
void | deleteResourceCategory(String cetegoryId, String resourceId)
ResourceCategory | getCategory(String id)
List | getCategorys(String parentId)
ResCategory | getResourceCategory(String cetegoryId, String resourceId)
List | getResources(String categoryId)
void | saveCategory(ResourceCategory category)
void | saveResourceCategory(ResCategory category)
void | updateCategory(ResourceCategory category)

Method Detail

getCategory

public ResourceCategory getCategory(String id)

getResources

public List getResources(String categoryId)

saveCategory

public void saveCategory(ResourceCategory category)

saveResourceCategory

public void saveResourceCategory(ResCategory category)

updateCategory

public void updateCategory(ResourceCategory category)

deleteCategory

public void deleteCategory(ResourceCategory category)

getCategorys

public List getCategorys(String parentId)

getResourceCategory

public ResCategory getResourceCategory(String cetegoryId,
                                       String resourceId)

deleteResourceCategory

public void deleteResourceCategory(String cetegoryId,
                                   String resourceId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultCategoryManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Class DefaultCategoryManager

java.lang.Object
    extended by org.marmot.security.manager.DefaultCategoryManager
All Implemented Interfaces:
CategoryManager
public class DefaultCategoryManager
extends Object
implements CategoryManager

Constructor Summary
DefaultCategoryManager()
Method Summary
void | deleteCategory(ResourceCategory category)
void | deleteResourceCategory(String cetegoryId, String resourceId)
ResourceCategory | getCategory(String id)
List | getCategorys(String parentId)
ResourceCategoryService | getCategoryService()
ResCategory | getResourceCategory(String cetegoryId, String resourceId)
List | getResources(String categoryId)
void | saveCategory(ResourceCategory category)
void | saveResourceCategory(ResCategory category)
void | setCategoryService(ResourceCategoryService categoryManager)
void | updateCategory(ResourceCategory category)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultCategoryManager

public DefaultCategoryManager()
Method Detail

deleteCategory

public void deleteCategory(ResourceCategory category)
Specified by:
deleteCategory in interface CategoryManager

getCategory

public ResourceCategory getCategory(String id)
Specified by:
getCategory in interface CategoryManager

saveCategory

public void saveCategory(ResourceCategory category)
Specified by:
saveCategory in interface CategoryManager

updateCategory

public void updateCategory(ResourceCategory category)
Specified by:
updateCategory in interface CategoryManager

getCategorys

public List getCategorys(String parentId)
Specified by:
getCategorys in interface CategoryManager

getCategoryService

public ResourceCategoryService getCategoryService()

setCategoryService

public void setCategoryService(ResourceCategoryService categoryManager)

getResourceCategory

public ResCategory getResourceCategory(String cetegoryId,
                                       String resourceId)
Specified by:
getResourceCategory in interface CategoryManager

deleteResourceCategory

public void deleteResourceCategory(String cetegoryId,
                                   String resourceId)
Specified by:
deleteResourceCategory in interface CategoryManager

getResources

public List getResources(String categoryId)
Specified by:
getResources in interface CategoryManager

saveResourceCategory

public void saveResourceCategory(ResCategory category)
Specified by:
saveResourceCategory in interface CategoryManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultResourceManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Class DefaultResourceManager

java.lang.Object
    extended by org.marmot.security.manager.DefaultResourceManager
All Implemented Interfaces:
ResourceManager
public class DefaultResourceManager
extends Object
implements ResourceManager

Constructor Summary
DefaultResourceManager()
Method Summary
void | changeStatus(Resource resource)
void | deleteResource(Resource resource)
List | getAllResources(Map map)
Resource | getResource(String id)
ServiceUtil | getServiceUtil()
void | saveResource(Resource resource)
void | setServiceUtil(ServiceUtil daoManager)
void | updateResource(Resource resource)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultResourceManager

public DefaultResourceManager()
Method Detail

deleteResource

public void deleteResource(Resource resource)
Specified by:
deleteResource in interface ResourceManager

getAllResources

public List getAllResources(Map map)
Specified by:
getAllResources in interface ResourceManager

getResource

public Resource getResource(String id)
Specified by:
getResource in interface ResourceManager

saveResource

public void saveResource(Resource resource)
Specified by:
saveResource in interface ResourceManager

updateResource

public void updateResource(Resource resource)
                    throws Exception
Specified by:
updateResource in interface ResourceManager
Throws:
Exception

getServiceUtil

public ServiceUtil getServiceUtil()

setServiceUtil

public void setServiceUtil(ServiceUtil daoManager)

changeStatus

public void changeStatus(Resource resource)
Specified by:
changeStatus in interface ResourceManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultRoleManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Class DefaultRoleManager

java.lang.Object
    extended by org.marmot.security.manager.DefaultRoleManager
All Implemented Interfaces:
RoleManager
public class DefaultRoleManager
extends Object
implements RoleManager

Constructor Summary
DefaultRoleManager()
Method Summary
void | deleteRole(Role role)
List | getAllRoles()
Role | getRole(String id)
UserRoleService | getUserRoleService()
void | saveRole(Role role)
void | setUserRoleService(UserRoleService userRoleDao)
void | updateRole(Role role)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultRoleManager

public DefaultRoleManager()
Method Detail

getUserRoleService

public UserRoleService getUserRoleService()

setUserRoleService

public void setUserRoleService(UserRoleService userRoleDao)

saveRole

public void saveRole(Role role)
Specified by:
saveRole in interface RoleManager

updateRole

public void updateRole(Role role)
Specified by:
updateRole in interface RoleManager

deleteRole

public void deleteRole(Role role)
Specified by:
deleteRole in interface RoleManager

getRole

public Role getRole(String id)
Specified by:
getRole in interface RoleManager

getAllRoles

public List getAllRoles()
Specified by:
getAllRoles in interface RoleManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultRoleResourceManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Class DefaultRoleResourceManager

java.lang.Object
    extended by org.marmot.security.manager.DefaultRoleResourceManager
All Implemented Interfaces:
RoleResourceManager
public class DefaultRoleResourceManager
extends Object
implements RoleResourceManager

Constructor Summary
DefaultRoleResourceManager()
Method Summary
void | addRole(String resourceId, String roleId)
void | deleteRoleResource(RoleRes roleResc)
void | deleteRoleResource(String roleId, String resourceId)
List | getAllRoles(Map map)
List | getResourceRoles(String resourceId)
RoleRes | getRoleResource(String roleId, String resourceId)
List | getRoleResources(String roleId)
ServiceUtil | getServiceUtil()
void | initByTemplate(Collection destRoles, Collection templateRoles)
void | removeAllWithSubItems(String roleId, ResourceCategory category)
void | removeRole(String resourceId, String roleId)
void | saveAllWithSubItems(String roleId, ResourceCategory category)
void | saveRoleResource(RoleRes roleResc)
void | setServiceUtil(ServiceUtil daoManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultRoleResourceManager

public DefaultRoleResourceManager()
Method Detail

getServiceUtil

public ServiceUtil getServiceUtil()

setServiceUtil

public void setServiceUtil(ServiceUtil daoManager)

addRole

public void addRole(String resourceId,
                    String roleId)
Specified by:
addRole in interface RoleResourceManager

removeRole

public void removeRole(String resourceId,
                       String roleId)
Specified by:
removeRole in interface RoleResourceManager

getResourceRoles

public List getResourceRoles(String resourceId)
Specified by:
getResourceRoles in interface RoleResourceManager

getRoleResources

public List getRoleResources(String roleId)
Specified by:
getRoleResources in interface RoleResourceManager

getAllRoles

public List getAllRoles(Map map)
Specified by:
getAllRoles in interface RoleResourceManager

deleteRoleResource

public void deleteRoleResource(RoleRes roleResc)
Specified by:
deleteRoleResource in interface RoleResourceManager

saveRoleResource

public void saveRoleResource(RoleRes roleResc)
Specified by:
saveRoleResource in interface RoleResourceManager

initByTemplate

public void initByTemplate(Collection destRoles,
                           Collection templateRoles)
Specified by:
initByTemplate in interface RoleResourceManager

removeAllWithSubItems

public void removeAllWithSubItems(String roleId,
                                  ResourceCategory category)
Specified by:
removeAllWithSubItems in interface RoleResourceManager

saveAllWithSubItems

public void saveAllWithSubItems(String roleId,
                                ResourceCategory category)
Specified by:
saveAllWithSubItems in interface RoleResourceManager

getRoleResource

public RoleRes getRoleResource(String roleId,
                               String resourceId)
Specified by:
getRoleResource in interface RoleResourceManager

deleteRoleResource

public void deleteRoleResource(String roleId,
                               String resourceId)
Specified by:
deleteRoleResource in interface RoleResourceManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultUserManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Class DefaultUserManager

java.lang.Object
    extended by org.marmot.security.manager.DefaultUserManager
All Implemented Interfaces:
UserManager
public class DefaultUserManager
extends Object
implements UserManager

Constructor Summary
DefaultUserManager()
Method Summary
void | changePwd(User currentUser, String oldPwd, String newPwd)
void | changeRoot(User user)
void | changeStatus(User user)
void | deleteUser(User user)
List | getAllUsers()
org.acegisecurity.providers.encoding.PasswordEncoder | getPasswordEncoder()
User | getUser(String id)
UserRoleService | getUserRoleService()
void | saveUser(User user)
void | setPasswordEncoder(org.acegisecurity.providers.encoding.PasswordEncoder passwordEncoder)
void | setUserRoleService(UserRoleService userRoleDao)
void | updateUser(User user)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultUserManager

public DefaultUserManager()
Method Detail

getUserRoleService

public UserRoleService getUserRoleService()

setUserRoleService

public void setUserRoleService(UserRoleService userRoleDao)

getPasswordEncoder

public org.acegisecurity.providers.encoding.PasswordEncoder getPasswordEncoder()

setPasswordEncoder

public void setPasswordEncoder(org.acegisecurity.providers.encoding.PasswordEncoder passwordEncoder)

saveUser

public void saveUser(User user)
Specified by:
saveUser in interface UserManager

updateUser

public void updateUser(User user)
Specified by:
updateUser in interface UserManager

deleteUser

public void deleteUser(User user)
Specified by:
deleteUser in interface UserManager

changePwd

public void changePwd(User currentUser,
                      String oldPwd,
                      String newPwd)
               throws Exception
Specified by:
changePwd in interface UserManager
Throws:
Exception

changeRoot

public void changeRoot(User user)
Specified by:
changeRoot in interface UserManager

changeStatus

public void changeStatus(User user)
Specified by:
changeStatus in interface UserManager

getAllUsers

public List getAllUsers()
Specified by:
getAllUsers in interface UserManager

getUser

public User getUser(String id)
Specified by:
getUser in interface UserManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultUserRoleManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Class DefaultUserRoleManager

java.lang.Object
    extended by org.marmot.security.manager.DefaultUserRoleManager
All Implemented Interfaces:
UserRoleManager
public class DefaultUserRoleManager
extends Object
implements UserRoleManager

Constructor Summary
DefaultUserRoleManager()
Method Summary
UserRole | addUserRole(String userId, String roleId)
void | delete(Object entity)
void | deleteRole(Role role)
List | findAll(Class entity)
Object | get(Class entity, String id)
List | getAllRoles(User user)
List | getAllRolesByUserId(String userId)
List | getGrantedRolesByUserId(String userId)
List | getGrantedUsersByRoleId(String roleId)
List | getProxyRoles(User user)
List | getProxyUsers(User user)
List | getRoleTemplates(String notInRoles)
List | getUnGrantedRolesByUserId(String userId, Map parameters)
List | getUnGrantedUsersByRoleId(String roleId, Map parameters)
List | getUnProxyUsers(User user)
UserRoleService | getUserRoleService()
void | proxyRoles(User user, User proxyTargetUser, Collection roles, Date activeTime, Date dormantTime)
void | removeProxyUser(User user, User proxyTargetUser)
void | removeProxyUser(User user, User proxyTargetUser, Role role)
void | removeUserRole(String userId, String roleId)
void | save(Object entity)
void | saveOrUpdate(Object entity)
void | saveRole(Role role)
void | setUserRoleService(UserRoleService userRoleManager)
void | update(Object entity)
void | updateRole(Role role)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultUserRoleManager

public DefaultUserRoleManager()
Method Detail

getUserRoleService

public UserRoleService getUserRoleService()

setUserRoleService

public void setUserRoleService(UserRoleService userRoleManager)

get

public Object get(Class entity,
                  String id)

findAll

public List findAll(Class entity)

delete

public void delete(Object entity)

save

public void save(Object entity)

update

public void update(Object entity)

saveOrUpdate

public void saveOrUpdate(Object entity)

saveRole

public void saveRole(Role role)

updateRole

public void updateRole(Role role)

deleteRole

public void deleteRole(Role role)

addUserRole

public UserRole addUserRole(String userId,
                            String roleId)
Specified by:
addUserRole in interface UserRoleManager

removeUserRole

public void removeUserRole(String userId,
                           String roleId)
Specified by:
removeUserRole in interface UserRoleManager

getRoleTemplates

public List getRoleTemplates(String notInRoles)
Specified by:
getRoleTemplates in interface UserRoleManager

getUnGrantedUsersByRoleId

public List getUnGrantedUsersByRoleId(String roleId,
                                      Map parameters)
Specified by:
getUnGrantedUsersByRoleId in interface UserRoleManager

getGrantedUsersByRoleId

public List getGrantedUsersByRoleId(String roleId)
Specified by:
getGrantedUsersByRoleId in interface UserRoleManager

getUnGrantedRolesByUserId

public List getUnGrantedRolesByUserId(String userId,
                                      Map parameters)
Specified by:
getUnGrantedRolesByUserId in interface UserRoleManager

getGrantedRolesByUserId

public List getGrantedRolesByUserId(String userId)
Specified by:
getGrantedRolesByUserId in interface UserRoleManager

getProxyUsers

public List getProxyUsers(User user)
                   throws Exception
Specified by:
getProxyUsers in interface UserRoleManager
Throws:
Exception

getProxyRoles

public List getProxyRoles(User user)
                   throws Exception
Specified by:
getProxyRoles in interface UserRoleManager
Throws:
Exception

getUnProxyUsers

public List getUnProxyUsers(User user)
                     throws Exception
Throws:
Exception

getAllRolesByUserId

public List getAllRolesByUserId(String userId)
                         throws Exception
Throws:
Exception

getAllRoles

public List getAllRoles(User user)
                 throws Exception
Specified by:
getAllRoles in interface UserRoleManager
Throws:
Exception

removeProxyUser

public void removeProxyUser(User user,
                            User proxyTargetUser)
Specified by:
removeProxyUser in interface UserRoleManager

removeProxyUser

public void removeProxyUser(User user,
                            User proxyTargetUser,
                            Role role)

proxyRoles

public void proxyRoles(User user,
                       User proxyTargetUser,
                       Collection roles,
                       Date activeTime,
                       Date dormantTime)
Specified by:
proxyRoles in interface UserRoleManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.manager

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.manager

Interface Summary
CategoryManager
ResourceManager
RoleManager
RoleResourceManager
UserManager
UserRoleManager

Class Summary
DefaultCategoryManager
DefaultResourceManager
DefaultRoleManager
DefaultRoleResourceManager
DefaultUserManager
DefaultUserRoleManager


ResourceManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Interface ResourceManager

All Known Implementing Classes:
DefaultResourceManager
public interface ResourceManager

Method Summary
void | changeStatus(Resource resource)
void | deleteResource(Resource resource)
List | getAllResources(Map map)
Resource | getResource(String id)
void | saveResource(Resource resource)
void | updateResource(Resource resource)

Method Detail

saveResource

public void saveResource(Resource resource)

updateResource

public void updateResource(Resource resource)
                    throws Exception
Throws:
Exception

deleteResource

public void deleteResource(Resource resource)

getResource

public Resource getResource(String id)

getAllResources

public List getAllResources(Map map)

changeStatus

public void changeStatus(Resource resource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Interface RoleManager

All Known Implementing Classes:
DefaultRoleManager
public interface RoleManager

Method Summary
void | deleteRole(Role role)
List | getAllRoles()
Role | getRole(String id)
void | saveRole(Role role)
void | updateRole(Role role)

Method Detail

saveRole

public void saveRole(Role role)

updateRole

public void updateRole(Role role)

deleteRole

public void deleteRole(Role role)

getRole

public Role getRole(String id)

getAllRoles

public List getAllRoles()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleResourceManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Interface RoleResourceManager

All Known Implementing Classes:
DefaultRoleResourceManager
public interface RoleResourceManager

Method Summary
void | addRole(String resourceId, String roleId)
void | deleteRoleResource(RoleRes roleResc)
void | deleteRoleResource(String roleId, String resourceId)
List | getAllRoles(Map map)
List | getResourceRoles(String resourceId)
RoleRes | getRoleResource(String roleId, String resourceId)
List | getRoleResources(String roleId)
void | initByTemplate(Collection destRoles, Collection templateRoles)
void | removeAllWithSubItems(String roleId, ResourceCategory category)
void | removeRole(String resourceId, String roleId)
void | saveAllWithSubItems(String roleId, ResourceCategory category)
void | saveRoleResource(RoleRes roleResc)

Method Detail

getRoleResource

public RoleRes getRoleResource(String roleId,
                               String resourceId)

deleteRoleResource

public void deleteRoleResource(String roleId,
                               String resourceId)

saveRoleResource

public void saveRoleResource(RoleRes roleResc)

deleteRoleResource

public void deleteRoleResource(RoleRes roleResc)

addRole

public void addRole(String resourceId,
                    String roleId)

removeRole

public void removeRole(String resourceId,
                       String roleId)

getResourceRoles

public List getResourceRoles(String resourceId)

getRoleResources

public List getRoleResources(String roleId)

getAllRoles

public List getAllRoles(Map map)

initByTemplate

public void initByTemplate(Collection destRoles,
                           Collection templateRoles)

saveAllWithSubItems

public void saveAllWithSubItems(String roleId,
                                ResourceCategory category)

removeAllWithSubItems

public void removeAllWithSubItems(String roleId,
                                  ResourceCategory category)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Interface UserManager

All Known Implementing Classes:
DefaultUserManager
public interface UserManager

Method Summary
void | changePwd(User currentUser, String oldPwd, String newPwd)
void | changeRoot(User user)
void | changeStatus(User user)
void | deleteUser(User user)
List | getAllUsers()
User | getUser(String id)
void | saveUser(User user)
void | updateUser(User user)

Method Detail

saveUser

public void saveUser(User user)

updateUser

public void updateUser(User user)

deleteUser

public void deleteUser(User user)

changePwd

public void changePwd(User currentUser,
                      String oldPwd,
                      String newPwd)
               throws Exception
Throws:
Exception

changeRoot

public void changeRoot(User user)

changeStatus

public void changeStatus(User user)

getAllUsers

public List getAllUsers()

getUser

public User getUser(String id)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserRoleManager

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.manager
Interface UserRoleManager

All Known Implementing Classes:
DefaultUserRoleManager
public interface UserRoleManager

Method Summary
UserRole | addUserRole(String userId, String roleId)
List | getAllRoles(User user)
List | getGrantedRolesByUserId(String userId)
List | getGrantedUsersByRoleId(String roleId)
List | getProxyRoles(User user)
List | getProxyUsers(User user)
List | getRoleTemplates(String notInRoles)
List | getUnGrantedRolesByUserId(String userId, Map map)
List | getUnGrantedUsersByRoleId(String roleId, Map map)
void | proxyRoles(User currentUser, User proxyTargetUser, Collection roles, Date activeTime, Date dormantTime)
void | removeProxyUser(User currentUser, User proxyTargetUser)
void | removeUserRole(String userId, String roleId)

Method Detail

addUserRole

public UserRole addUserRole(String userId,
                            String roleId)

removeUserRole

public void removeUserRole(String userId,
                           String roleId)

getUnGrantedRolesByUserId

public List getUnGrantedRolesByUserId(String userId,
                                      Map map)

getGrantedRolesByUserId

public List getGrantedRolesByUserId(String userId)

getProxyUsers

public List getProxyUsers(User user)
                   throws Exception
Throws:
Exception

getProxyRoles

public List getProxyRoles(User user)
                   throws Exception
Throws:
Exception

getAllRoles

public List getAllRoles(User user)
                 throws Exception
Throws:
Exception

getUnGrantedUsersByRoleId

public List getUnGrantedUsersByRoleId(String roleId,
                                      Map map)

getGrantedUsersByRoleId

public List getGrantedUsersByRoleId(String roleId)

getRoleTemplates

public List getRoleTemplates(String notInRoles)

removeProxyUser

public void removeProxyUser(User currentUser,
                            User proxyTargetUser)

proxyRoles

public void proxyRoles(User currentUser,
                       User proxyTargetUser,
                       Collection roles,
                       Date activeTime,
                       Date dormantTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.service

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.service

Class Summary
PaginationSupport
ResourceCategoryService
ResourceService
ServiceUtil
UserRoleService
UserService


PaginationSupport

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.service
Class PaginationSupport

java.lang.Object
    extended by org.marmot.security.service.PaginationSupport
public class PaginationSupport
extends Object

Author:
william

Field Summary
static int PAGESIZE
Constructor Summary
PaginationSupport(List items, int totalCount)
PaginationSupport(List items, int totalCount, int startIndex)
PaginationSupport(List items, int totalCount, int pageSize, int startIndex)
Method Summary
int[] | getIndexes()
List | getItems()
int | getNextIndex()
int | getPageSize()
int | getPreviousIndex()
int | getStartIndex()
int | getTotalCount()
void | setIndexes(int[] indexes)
void | setItems(List items)
void | setPageSize(int pageSize)
void | setStartIndex(int startIndex)
void | setTotalCount(int totalCount)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PAGESIZE

public static final int PAGESIZE
See Also:
Constant Field Values
Constructor Detail

PaginationSupport

public PaginationSupport(List items,
                         int totalCount)

PaginationSupport

public PaginationSupport(List items,
                         int totalCount,
                         int startIndex)

PaginationSupport

public PaginationSupport(List items,
                         int totalCount,
                         int pageSize,
                         int startIndex)
Method Detail

getItems

public List getItems()

setItems

public void setItems(List items)

getPageSize

public int getPageSize()

setPageSize

public void setPageSize(int pageSize)

getTotalCount

public int getTotalCount()

setTotalCount

public void setTotalCount(int totalCount)

getIndexes

public int[] getIndexes()

setIndexes

public void setIndexes(int[] indexes)

getStartIndex

public int getStartIndex()

setStartIndex

public void setStartIndex(int startIndex)

getNextIndex

public int getNextIndex()

getPreviousIndex

public int getPreviousIndex()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ResourceCategoryService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.service
Class ResourceCategoryService

java.lang.Object
    extended by org.springframework.dao.support.DaoSupport
        extended by org.springframework.orm.hibernate3.support.HibernateDaoSupport
            extended by org.marmot.security.service.ResourceCategoryService
All Implemented Interfaces:
org.springframework.beans.factory.InitializingBean
public class ResourceCategoryService
extends org.springframework.orm.hibernate3.support.HibernateDaoSupport

Author:
william

Field Summary
Fields inherited from class org.springframework.dao.support.DaoSupport
logger
Constructor Summary
ResourceCategoryService()
Method Summary
void | delete(ResourceCategory category)
ResourceCategory | getCategory(String id)
List | getCategorys(String parentId)
void | save(ResourceCategory category)
void | update(ResourceCategory category)
Methods inherited from class org.springframework.orm.hibernate3.support.HibernateDaoSupport
checkDaoConfig, convertHibernateAccessException, createHibernateTemplate, getHibernateTemplate, getSession, getSession, getSessionFactory, releaseSession, setHibernateTemplate, setSessionFactory
Methods inherited from class org.springframework.dao.support.DaoSupport
afterPropertiesSet, initDao
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceCategoryService

public ResourceCategoryService()
Method Detail

getCategorys

public List getCategorys(String parentId)

getCategory

public ResourceCategory getCategory(String id)

save

public void save(ResourceCategory category)

update

public void update(ResourceCategory category)

delete

public void delete(ResourceCategory category)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.service
Class ResourceService

java.lang.Object
    extended by org.springframework.dao.support.DaoSupport
        extended by org.springframework.orm.hibernate3.support.HibernateDaoSupport
            extended by org.marmot.security.service.ResourceService
All Implemented Interfaces:
org.springframework.beans.factory.InitializingBean
public class ResourceService
extends org.springframework.orm.hibernate3.support.HibernateDaoSupport

Field Summary
Fields inherited from class org.springframework.dao.support.DaoSupport
logger
Constructor Summary
ResourceService()
Method Summary
 Resource getResourceByResString(String resString)
Methods inherited from class org.springframework.orm.hibernate3.support.HibernateDaoSupport
checkDaoConfig, convertHibernateAccessException, createHibernateTemplate, getHibernateTemplate, getSession, getSession, getSessionFactory, releaseSession, setHibernateTemplate, setSessionFactory
Methods inherited from class org.springframework.dao.support.DaoSupport
afterPropertiesSet, initDao
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceService

public ResourceService()
Method Detail

getResourceByResString

public Resource getResourceByResString(String resString)
                                throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServiceUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.service
Class ServiceUtil

java.lang.Object
    extended by org.springframework.dao.support.DaoSupport
        extended by org.springframework.orm.hibernate3.support.HibernateDaoSupport
            extended by org.marmot.security.service.ServiceUtil
All Implemented Interfaces:
org.springframework.beans.factory.InitializingBean
Direct Known Subclasses:
UserRoleService
public class ServiceUtil
extends org.springframework.orm.hibernate3.support.HibernateDaoSupport

Author:
william

Field Summary
Fields inherited from class org.springframework.dao.support.DaoSupport
logger
Constructor Summary
ServiceUtil()
Method Summary
void | delete(Object entity)
List | find(String query)
List | find(String query, Object parameter)
List | findAll(Class entity)
List | findAllByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)
List | findByNamedParam(String query, String[] parameters, String[] values)
List | findByNamedParam(String query, String parameter, String value)
List | findByNamedQuery(String namedQuery)
List | findByNamedQuery(String query, Object parameter)
List | findByNamedQuery(String query, Object[] parameters)
PaginationSupport | findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)
PaginationSupport | findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria, int startIndex)
PaginationSupport | findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria, int pageSize, int startIndex)
Object | get(Class entity, Serializable id)
int | getCountByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)
Object | load(Class entity, Serializable id)
void | persist(Object entity)
void | save(Object entity)
void | saveOrUpdate(Object entity)
void | update(Object entity)
Methods inherited from class org.springframework.orm.hibernate3.support.HibernateDaoSupport
checkDaoConfig, convertHibernateAccessException, createHibernateTemplate, getHibernateTemplate, getSession, getSession, getSessionFactory, releaseSession, setHibernateTemplate, setSessionFactory
Methods inherited from class org.springframework.dao.support.DaoSupport
afterPropertiesSet, initDao
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ServiceUtil

public ServiceUtil()
Method Detail

save

public void save(Object entity)

saveOrUpdate

public void saveOrUpdate(Object entity)

persist

public void persist(Object entity)

update

public void update(Object entity)

delete

public void delete(Object entity)

load

public Object load(Class entity,
                   Serializable id)

get

public Object get(Class entity,
                  Serializable id)

findAll

public List findAll(Class entity)

findByNamedQuery

public List findByNamedQuery(String namedQuery)

findByNamedQuery

public List findByNamedQuery(String query,
                             Object parameter)

findByNamedParam

public List findByNamedParam(String query,
                             String[] parameters,
                             String[] values)

findByNamedParam

public List findByNamedParam(String query,
                             String parameter,
                             String value)

findByNamedQuery

public List findByNamedQuery(String query,
                             Object[] parameters)

find

public List find(String query)

find

public List find(String query,
                 Object parameter)

findPageByCriteria

public PaginationSupport findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)

findPageByCriteria

public PaginationSupport findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria,
                                            int startIndex)

findPageByCriteria

public PaginationSupport findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria,
                                            int pageSize,
                                            int startIndex)

findAllByCriteria

public List findAllByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)

getCountByCriteria

public int getCountByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserRoleService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.service
Class UserRoleService

java.lang.Object
    extended by org.springframework.dao.support.DaoSupport
        extended by org.springframework.orm.hibernate3.support.HibernateDaoSupport
            extended by org.marmot.security.service.ServiceUtil
                extended by org.marmot.security.service.UserRoleService
All Implemented Interfaces:
org.springframework.beans.factory.InitializingBean
public class UserRoleService
extends ServiceUtil

Author:
William Jiang

Constructor Summary
UserRoleService()
Method Summary
List | getGrantedRolesByUserId(String userId) 获取指定用户的角色列表
List | getGrantedUsersByRoleId(String roleId) 获取已经授予该角色的用户列表
List | getProxyRoles(User user)
List | getProxyUsers(User user)
List | getRolesByUser(User user, boolean loadProxy)
List | getUnGrantedRolesByUserId(String userId, Map parameters) 获取不属于指定用户的所有角色列表
List | getUnGrantedUsersByRoleId(String roleId, Map parameters) 获取不属于指定角色的所有用户
List | getUsersByRole(Role role, boolean loadProxy)
void | removeRoleProxyUser(String userId, String roleId)
void | removeUserProxyRole(String userId, String roleId)
Methods inherited from class org.marmot.security.service.ServiceUtil
delete, find, find, findAll, findAllByCriteria, findByNamedParam, findByNamedParam, findByNamedQuery, findByNamedQuery, findByNamedQuery, findPageByCriteria, findPageByCriteria, findPageByCriteria, get, getCountByCriteria, load, persist, save, saveOrUpdate, update
Methods inherited from class org.springframework.orm.hibernate3.support.HibernateDaoSupport
checkDaoConfig, convertHibernateAccessException, createHibernateTemplate, getHibernateTemplate, getSession, getSession, getSessionFactory, releaseSession, setHibernateTemplate, setSessionFactory
Methods inherited from class org.springframework.dao.support.DaoSupport
afterPropertiesSet, initDao
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UserRoleService

public UserRoleService()
Method Detail

getUnGrantedUsersByRoleId

public List getUnGrantedUsersByRoleId(String roleId,
                                      Map parameters)
获取不属于指定角色的所有用户

Parameters:
roleId -
parameters -
Returns:

getGrantedUsersByRoleId

public List getGrantedUsersByRoleId(String roleId)
获取已经授予该角色的用户列表

Parameters:
roleId -
Returns:

getUnGrantedRolesByUserId

public List getUnGrantedRolesByUserId(String userId,
                                      Map parameters)
获取不属于指定用户的所有角色列表

Parameters:
userId -
parameters -
Returns:

getGrantedRolesByUserId

public List getGrantedRolesByUserId(String userId)
获取指定用户的角色列表

Parameters:
userId -
Returns:

getRolesByUser

public List getRolesByUser(User user,
                           boolean loadProxy)

getUsersByRole

public List getUsersByRole(Role role,
                           boolean loadProxy)

removeUserProxyRole

public void removeUserProxyRole(String userId,
                                String roleId)

removeRoleProxyUser

public void removeRoleProxyUser(String userId,
                                String roleId)

getProxyUsers

public List getProxyUsers(User user)
                   throws Exception
Throws:
Exception

getProxyRoles

public List getProxyRoles(User user)
                   throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserService

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.service
Class UserService

java.lang.Object
    extended by org.marmot.security.service.UserService
All Implemented Interfaces:
org.acegisecurity.userdetails.UserDetailsService
public class UserService
extends Object
implements org.acegisecurity.userdetails.UserDetailsService

Author:
william

Constructor Summary
UserService()
Method Summary
UserRoleService | getUserRoleService()
User | loadSecurityUserByUsername(String username)
org.acegisecurity.userdetails.UserDetails | loadUserByUsername(String username)
void | setUserRoleService(UserRoleService daoManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UserService

public UserService()
Method Detail

loadSecurityUserByUsername

public User loadSecurityUserByUsername(String username)

loadUserByUsername

public org.acegisecurity.userdetails.UserDetails loadUserByUsername(String username)
                                                             throws org.acegisecurity.userdetails.UsernameNotFoundException,
                                                                    org.springframework.dao.DataAccessException
Specified by:
loadUserByUsername in interface org.acegisecurity.userdetails.UserDetailsService
Throws:
org.acegisecurity.userdetails.UsernameNotFoundException
org.springframework.dao.DataAccessException

getUserRoleService

public UserRoleService getUserRoleService()

setUserRoleService

public void setUserRoleService(UserRoleService daoManager)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.util

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.util

Class Summary
SecurityUtils 权限验证工具类


SecurityUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.util
Class SecurityUtils

java.lang.Object
    extended by org.marmot.security.util.SecurityUtils
public class SecurityUtils
extends Object

权限验证工具类

Author:
william

Method Summary
static boolean | authentication(Role role, String resource)
static boolean | authentication(String user, Object resource)
static boolean | authentication(String user, String resource) 判断系统账号对指定资源是否具有访问权限
static User | getCurrentUser() 返回当前已登录到权限系统的的系统账号。
static void | login(String account, String password) 登录。
static void | logout() 登出,并清空权限系统中登陆用户的信息。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

login

public static void login(String account,
                         String password)
                  throws Exception
登录。如登录失败则抛出异常。

Parameters:
password -
Throws:
Exception

logout

public static void logout()
登出,并清空权限系统中登陆用户的信息。

getCurrentUser

public static User getCurrentUser()
返回当前已登录到权限系统的的系统账号。

authentication

public static boolean authentication(String user,
                                     Object resource)

authentication

public static boolean authentication(String user,
                                     String resource)
判断系统账号对指定资源是否具有访问权限

Parameters:
user -
resource -
Returns:

authentication

public static boolean authentication(Role role,
                                     String resource)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CategoryAccessor

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class CategoryAccessor

java.lang.Object
    extended by org.marmot.security.view.CategoryAccessor
public class CategoryAccessor
extends Object

Author:
William Jiang

Constructor Summary
CategoryAccessor()
Method Summary
FilterUtils | getFilterUtils()
DiligentMenuHelper | getMenuHelper()
ServiceUtil | getServiceUtil()
int | loadMenu(String categoryId, String menuId)
int | loadView(ResourceCategory viewCategory, boolean async)
void | removeAllCategory(ResourceCategory category)
void | setFilterUtils(FilterUtils categoryUtils)
void | setMenuHelper(DiligentMenuHelper menuHelper)
void | setServiceUtil(ServiceUtil daoManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CategoryAccessor

public CategoryAccessor()
Method Detail

getServiceUtil

public ServiceUtil getServiceUtil()

setServiceUtil

public void setServiceUtil(ServiceUtil daoManager)

getMenuHelper

public DiligentMenuHelper getMenuHelper()

setMenuHelper

public void setMenuHelper(DiligentMenuHelper menuHelper)

removeAllCategory

public void removeAllCategory(ResourceCategory category)
                       throws Exception
Throws:
Exception

loadMenu

public int loadMenu(String categoryId,
                    String menuId)
             throws Exception
Throws:
Exception

loadView

public int loadView(ResourceCategory viewCategory,
                    boolean async)
             throws Exception
Throws:
Exception

getFilterUtils

public FilterUtils getFilterUtils()

setFilterUtils

public void setFilterUtils(FilterUtils categoryUtils)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CategoryBackBean

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class CategoryBackBean

java.lang.Object
    extended by org.marmot.security.view.CategoryBackBean
public class CategoryBackBean
extends Object

Author:
William Jiang

Constructor Summary
CategoryBackBean()
Method Summary
Object | changeCategoryPosition(Map dataSetMap, Object parameter)
Object | deleteResource(Map dataSetMap, Object parameter)
void | getCategory(org.marmot.view.DataSet dataSet)
CategoryAccessor | getCategoryAccessor()
CategoryManager | getCategoryManager()
void | getCategorys(org.marmot.view.DataSet dataSet)
ResourceManager | getResourceManager()
void | getResources(org.marmot.view.DataSet dataSet)
Object | insertResource(Map dataSetMap, Object parameter)
Object | removeAllCategory(Map dataSetMap, Object parameter)
Object | removeCategory(Map dataSetMap, Object parameter)
Object | saveByMenu(Object parameter)
Object | saveByView(Map dataSetMap, Object parameters)
Object | saveCategory(Map dataSetMap, Object parameter)
void | setCategoryAccessor(CategoryAccessor categoryHelper)
void | setCategoryManager(CategoryManager categoryManager)
void | setResourceManager(ResourceManager resourceManager)
Object | updateCategory(Map dataSetMap, Object parameter)
Object | updateResource(Map dataSetMap, Object parameter)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CategoryBackBean

public CategoryBackBean()
Method Detail

getCategoryAccessor

public CategoryAccessor getCategoryAccessor()

setCategoryAccessor

public void setCategoryAccessor(CategoryAccessor categoryHelper)

getCategorys

public void getCategorys(org.marmot.view.DataSet dataSet)
                  throws Exception
Throws:
Exception

getResources

public void getResources(org.marmot.view.DataSet dataSet)
                  throws Exception
Throws:
Exception

getCategory

public void getCategory(org.marmot.view.DataSet dataSet)
                 throws Exception
Throws:
Exception

removeCategory

public Object removeCategory(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

saveCategory

public Object saveCategory(Map dataSetMap,
                           Object parameter)
                    throws Exception
Throws:
Exception

updateCategory

public Object updateCategory(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

removeAllCategory

public Object removeAllCategory(Map dataSetMap,
                                Object parameter)
                         throws Exception
Throws:
Exception

saveByMenu

public Object saveByMenu(Object parameter)
                  throws Exception
Throws:
Exception

saveByView

public Object saveByView(Map dataSetMap,
                         Object parameters)
                  throws Exception
Throws:
Exception

changeCategoryPosition

public Object changeCategoryPosition(Map dataSetMap,
                                     Object parameter)
                              throws Exception
Throws:
Exception

insertResource

public Object insertResource(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

updateResource

public Object updateResource(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

deleteResource

public Object deleteResource(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

getResourceManager

public ResourceManager getResourceManager()

setResourceManager

public void setResourceManager(ResourceManager resourceManager)

getCategoryManager

public CategoryManager getCategoryManager()

setCategoryManager

public void setCategoryManager(CategoryManager categoryManager)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.marmot.security.view

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.marmot.security.view

Class Summary
CategoryAccessor
CategoryBackBean
Permission
PermissionAccessor
PermissionBackBean
ProxyBackBean
ResourceBackBean
RoleBackBean
UserBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Permission

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class Permission

java.lang.Object
    extended by org.marmot.security.view.Permission
public class Permission
extends Object

Author:
William Jiang

Constructor Summary
Permission()
Method Summary
String | getCategoryType()
String | getDescn()
String | getId()
String | getLabel()
String | getName()
String | getParentId()
String | getResourceFlags()
String | getResourceIds()
String | getResourceLabels()
Map | getResources()
int | getSubItemCount()
String | getViewString()
void | setCategoryType(String viewControlType)
void | setDescn(String descn)
void | setId(String id)
void | setLabel(String label)
void | setName(String name)
void | setParentId(String parentId)
void | setResourceFlags(String resoruceFlags)
void | setResourceIds(String resourceIds)
void | setResourceLabels(String resoruceLabels)
void | setResources(Map resources)
void | setSubItemCount(int subItems)
void | setViewString(String view)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Permission

public Permission()
Method Detail

getResources

public Map getResources()

setResources

public void setResources(Map resources)

getId

public String getId()

setId

public void setId(String id)

getParentId

public String getParentId()

setParentId

public void setParentId(String parentId)

getName

public String getName()

setName

public void setName(String name)

getDescn

public String getDescn()

setDescn

public void setDescn(String descn)

getViewString

public String getViewString()

setViewString

public void setViewString(String view)

getCategoryType

public String getCategoryType()

setCategoryType

public void setCategoryType(String viewControlType)

getLabel

public String getLabel()

setLabel

public void setLabel(String label)

getResourceFlags

public String getResourceFlags()

setResourceFlags

public void setResourceFlags(String resoruceFlags)

getResourceIds

public String getResourceIds()

setResourceIds

public void setResourceIds(String resourceIds)

getSubItemCount

public int getSubItemCount()

setSubItemCount

public void setSubItemCount(int subItems)

getResourceLabels

public String getResourceLabels()

setResourceLabels

public void setResourceLabels(String resoruceLabels)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionAccessor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class PermissionAccessor

java.lang.Object
    extended by org.marmot.security.view.PermissionAccessor
public class PermissionAccessor
extends Object

Author:
William Jiang

Constructor Summary
PermissionAccessor()
Method Summary
CategoryManager | getCategoryManager()
List | packPermissions(String role, List categorys)
void | setCategoryManager(CategoryManager categoryManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PermissionAccessor

public PermissionAccessor()
Method Detail

getCategoryManager

public CategoryManager getCategoryManager()

setCategoryManager

public void setCategoryManager(CategoryManager categoryManager)

packPermissions

public List packPermissions(String role,
                            List categorys)
                     throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PermissionBackBean

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class PermissionBackBean

java.lang.Object
    extended by org.marmot.security.view.PermissionBackBean
public class PermissionBackBean
extends Object

Author:
William Jiang

Constructor Summary
PermissionBackBean()
Method Summary
CategoryManager | getCategoryManager()
void | getCategorys(org.marmot.view.DataSet dataSet)
PermissionAccessor | getPermissionAccessor()
ResourceManager | getResourceManager()
RoleManager | getRoleManager()
RoleResourceManager | getRoleResourceManager()
void | getRoleTemplates(org.marmot.view.DataSet dataSet)
UserRoleManager | getUserRoleManager()
Object | grantedAll(Map dataSetMap, Object parameter)
Object | initByTemplate(Map dataSetMap, Object parameters) 根据角色模板初始化选中的角色列表权限信息
Object | saveAll(Map dataSetMap, Object parameter)
void | setCategoryManager(CategoryManager categoryManager)
void | setPermissionAccessor(PermissionAccessor permissionHelper)
void | setResourceManager(ResourceManager resourceManager)
void | setRoleManager(RoleManager roleManager)
void | setRoleResourceManager(RoleResourceManager roleResourceManager)
void | setUserRoleManager(UserRoleManager userRoleManager)
Object | unGrantedAll(Map dataSetMap, Object parameter)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PermissionBackBean

public PermissionBackBean()
Method Detail

getUserRoleManager

public UserRoleManager getUserRoleManager()

getPermissionAccessor

public PermissionAccessor getPermissionAccessor()

setPermissionAccessor

public void setPermissionAccessor(PermissionAccessor permissionHelper)

getCategorys

public void getCategorys(org.marmot.view.DataSet dataSet)
                  throws Exception
Throws:
Exception

saveAll

public Object saveAll(Map dataSetMap,
                      Object parameter)
               throws Exception
Throws:
Exception

unGrantedAll

public Object unGrantedAll(Map dataSetMap,
                           Object parameter)
                    throws Exception
Throws:
Exception

grantedAll

public Object grantedAll(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

getRoleTemplates

public void getRoleTemplates(org.marmot.view.DataSet dataSet)
                      throws Exception
Throws:
Exception

initByTemplate

public Object initByTemplate(Map dataSetMap,
                             Object parameters)
                      throws Exception
根据角色模板初始化选中的角色列表权限信息

Parameters:
dataSetMap -
Returns:
Throws:
Exception

getRoleResourceManager

public RoleResourceManager getRoleResourceManager()

setRoleResourceManager

public void setRoleResourceManager(RoleResourceManager roleResourceManager)

getCategoryManager

public CategoryManager getCategoryManager()

setCategoryManager

public void setCategoryManager(CategoryManager categoryManager)

setUserRoleManager

public void setUserRoleManager(UserRoleManager userRoleManager)

getResourceManager

public ResourceManager getResourceManager()

setResourceManager

public void setResourceManager(ResourceManager resourceManager)

getRoleManager

public RoleManager getRoleManager()

setRoleManager

public void setRoleManager(RoleManager roleManager)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyBackBean

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class ProxyBackBean

java.lang.Object
    extended by org.marmot.security.view.ProxyBackBean
public class ProxyBackBean
extends Object

Constructor Summary
ProxyBackBean()
Method Summary
Object | addProxyUser(Map dataSetMap, Object parameter)
void | getProxyRoles(org.marmot.view.DataSet dataSet)
void | getProxyUsers(org.marmot.view.DataSet dataSet)
void | getUnProxyRoles(org.marmot.view.DataSet dataSet)
void | getUnProxyUsers(org.marmot.view.DataSet dataSet)
UserManager | getUserManager()
UserRoleManager | getUserRoleManager()
void | loadProperties(org.marmot.view.DataSet dataSet)
Object | removeProxyUser(Map dataSetMap, Object parameter)
void | setUserManager(UserManager userManager)
void | setUserRoleManager(UserRoleManager userRoleManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyBackBean

public ProxyBackBean()
Method Detail

getUserManager

public UserManager getUserManager()

setUserManager

public void setUserManager(UserManager userManager)

getUserRoleManager

public UserRoleManager getUserRoleManager()

setUserRoleManager

public void setUserRoleManager(UserRoleManager userRoleManager)

loadProperties

public void loadProperties(org.marmot.view.DataSet dataSet)
                    throws Exception
Throws:
Exception

getProxyUsers

public void getProxyUsers(org.marmot.view.DataSet dataSet)
                   throws Exception
Throws:
Exception

getProxyRoles

public void getProxyRoles(org.marmot.view.DataSet dataSet)
                   throws Exception
Throws:
Exception

getUnProxyUsers

public void getUnProxyUsers(org.marmot.view.DataSet dataSet)
                     throws Exception
Throws:
Exception

getUnProxyRoles

public void getUnProxyRoles(org.marmot.view.DataSet dataSet)
                     throws Exception
Throws:
Exception

removeProxyUser

public Object removeProxyUser(Map dataSetMap,
                              Object parameter)
                       throws Exception
Throws:
Exception

addProxyUser

public Object addProxyUser(Map dataSetMap,
                           Object parameter)
                    throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceBackBean

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class ResourceBackBean

java.lang.Object
    extended by org.marmot.security.view.ResourceBackBean
public class ResourceBackBean
extends Object

Author:
William Jiang

Constructor Summary
ResourceBackBean()
Method Summary
Object | addRole(Map dataSetMap, Object parameter)
Object | changeStatus(Map dataSetMap, Object parameter)
void | getAllRoles(org.marmot.view.DataSet dataSet)
AcegiCacheManager | getCacheManager()
void | getRescRoles(org.marmot.view.DataSet dataSet)
ResourceManager | getResourceManager()
void | getResources(org.marmot.view.DataSet dataSet)
RoleResourceManager | getRoleResourceManager()
Object | insertResource(Map dataSetMap, Object parameter)
Object | refreshResourceCache(Object parameter)
Object | refreshUserCache(Object parameter)
Object | removeResource(Map dataSetMap, Object parameter)
Object | removeRole(Map dataSetMap, Object parameter)
void | setCacheManager(AcegiCacheManager cacheManager)
void | setResourceManager(ResourceManager resourceManager)
void | setRoleResourceManager(RoleResourceManager roleResourceManager)
Object | updateResource(Map dataSetMap, Object parameter)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceBackBean

public ResourceBackBean()
Method Detail

getCacheManager

public AcegiCacheManager getCacheManager()

setCacheManager

public void setCacheManager(AcegiCacheManager cacheManager)

getResourceManager

public ResourceManager getResourceManager()

setResourceManager

public void setResourceManager(ResourceManager resourceManager)

getRoleResourceManager

public RoleResourceManager getRoleResourceManager()

setRoleResourceManager

public void setRoleResourceManager(RoleResourceManager roleResourceManager)

getResources

public void getResources(org.marmot.view.DataSet dataSet)
                  throws Exception
Throws:
Exception

getAllRoles

public void getAllRoles(org.marmot.view.DataSet dataSet)
                 throws Exception
Throws:
Exception

getRescRoles

public void getRescRoles(org.marmot.view.DataSet dataSet)
                  throws Exception
Throws:
Exception

removeResource

public Object removeResource(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

insertResource

public Object insertResource(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

updateResource

public Object updateResource(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

changeStatus

public Object changeStatus(Map dataSetMap,
                           Object parameter)
                    throws Exception
Throws:
Exception

addRole

public Object addRole(Map dataSetMap,
                      Object parameter)
               throws Exception
Throws:
Exception

removeRole

public Object removeRole(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

refreshResourceCache

public Object refreshResourceCache(Object parameter)
                            throws Exception
Throws:
Exception

refreshUserCache

public Object refreshUserCache(Object parameter)
                        throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RoleBackBean

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class RoleBackBean

java.lang.Object
    extended by org.marmot.security.view.RoleBackBean
public class RoleBackBean
extends Object

Author:
William Jiang

Constructor Summary
RoleBackBean()
Method Summary
Object | addUserRole(Map dataSetMap, Object parameter)
void | getAllRoles(org.marmot.view.DataSet dataSet)
void | getGrantedUsers(org.marmot.view.DataSet dataSet)
RoleManager | getRoleManager()
void | getUnGrantedUsers(org.marmot.view.DataSet dataSet)
UserRoleManager | getUserRoleManager()
Object | insertRole(Map dataSetMap, Object parameter)
Object | removeRole(Map dataSetMap, Object parameter)
Object | removeUserRole(Map dataSetMap, Object parameter)
void | setRoleManager(RoleManager roleManager)
void | setUserRoleManager(UserRoleManager userRoleManager)
Object | updateRole(Map dataSetMap, Object parameter)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RoleBackBean

public RoleBackBean()
Method Detail

getRoleManager

public RoleManager getRoleManager()

setRoleManager

public void setRoleManager(RoleManager roleManager)

getUserRoleManager

public UserRoleManager getUserRoleManager()

setUserRoleManager

public void setUserRoleManager(UserRoleManager userRoleManager)

getAllRoles

public void getAllRoles(org.marmot.view.DataSet dataSet)
                 throws Exception
Throws:
Exception

getUnGrantedUsers

public void getUnGrantedUsers(org.marmot.view.DataSet dataSet)
                       throws Exception
Throws:
Exception

getGrantedUsers

public void getGrantedUsers(org.marmot.view.DataSet dataSet)
                     throws Exception
Throws:
Exception

removeRole

public Object removeRole(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

insertRole

public Object insertRole(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

updateRole

public Object updateRole(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

addUserRole

public Object addUserRole(Map dataSetMap,
                          Object parameter)
                   throws Exception
Throws:
Exception

removeUserRole

public Object removeUserRole(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserBackBean

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.marmot.security.view
Class UserBackBean

java.lang.Object
    extended by org.marmot.security.view.UserBackBean
public class UserBackBean
extends Object

Author:
William Jiang

Constructor Summary
UserBackBean()
Method Summary
Object | addUserRole(Map dataSetMap, Object parameter)
Object | changePwd(Map dataSetMap, Object parameter)
Object | changeRoot(Map dataSetMap, Object parameter)
Object | changeStatus(Map dataSetMap, Object parameter)
void | getAllUsers(org.marmot.view.DataSet dataSet)
AcegiCacheManager | getCacheManager()
void | getGrantedRoles(org.marmot.view.DataSet dataSet)
void | getUnGrantedRoles(org.marmot.view.DataSet dataSet)
UserManager | getUserManager()
UserRoleManager | getUserRoleManager()
Object | insertUser(Map dataSetMap, Object parameter)
Object | modifyUserInCache(Object parameter)
Object | refreshUserCache(Object parameter)
Object | removeUser(Map dataSetMap, Object parameter)
Object | removeUserRole(Map dataSetMap, Object parameter)
void | setCacheManager(AcegiCacheManager cacheManager)
void | setUserManager(UserManager userManager)
void | setUserRoleManager(UserRoleManager userRoleManager)
Object | updateUser(Map dataSetMap, Object parameter)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UserBackBean

public UserBackBean()
Method Detail

getCacheManager

public AcegiCacheManager getCacheManager()

setCacheManager

public void setCacheManager(AcegiCacheManager cacheManager)

getUserManager

public UserManager getUserManager()

setUserManager

public void setUserManager(UserManager userManager)

getUserRoleManager

public UserRoleManager getUserRoleManager()

setUserRoleManager

public void setUserRoleManager(UserRoleManager userRoleManager)

getAllUsers

public void getAllUsers(org.marmot.view.DataSet dataSet)
                 throws Exception
Throws:
Exception

getUnGrantedRoles

public void getUnGrantedRoles(org.marmot.view.DataSet dataSet)
                       throws Exception
Throws:
Exception

getGrantedRoles

public void getGrantedRoles(org.marmot.view.DataSet dataSet)
                     throws Exception
Throws:
Exception

removeUser

public Object removeUser(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

insertUser

public Object insertUser(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

updateUser

public Object updateUser(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

changePwd

public Object changePwd(Map dataSetMap,
                        Object parameter)
                 throws Exception
Throws:
Exception

changeRoot

public Object changeRoot(Map dataSetMap,
                         Object parameter)
                  throws Exception
Throws:
Exception

changeStatus

public Object changeStatus(Map dataSetMap,
                           Object parameter)
                    throws Exception
Throws:
Exception

addUserRole

public Object addUserRole(Map dataSetMap,
                          Object parameter)
                   throws Exception
Throws:
Exception

removeUserRole

public Object removeUserRole(Map dataSetMap,
                             Object parameter)
                      throws Exception
Throws:
Exception

modifyUserInCache

public Object modifyUserInCache(Object parameter)

refreshUserCache

public Object refreshUserCache(Object parameter)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Generated Documentation (Untitled)

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Overview

All Classes

Packages
org.marmot.framework.dict.domain
org.marmot.framework.dict.factory
org.marmot.framework.dict.view
org.marmot.framework.dorado
org.marmot.framework.main
org.marmot.framework.menu.domain
org.marmot.framework.menu.factory
org.marmot.framework.menu.view
org.marmot.framework.message.domain
org.marmot.framework.message.manager
org.marmot.framework.preference
org.marmot.framework.preference.domain
org.marmot.framework.preference.manager
org.marmot.framework.profile.domain
org.marmot.framework.profile.view
org.marmot.framework.query.builder
org.marmot.framework.query.domain
org.marmot.framework.query.view
org.marmot.framework.security
org.marmot.framework.security.captcha
org.marmot.framework.util
org.marmot.security.cache
org.marmot.security.core
org.marmot.security.definition
org.marmot.security.domain
org.marmot.security.dorado
org.marmot.security.exception
org.marmot.security.filter
org.marmot.security.intercept.method
org.marmot.security.intercept.method.aopalliance
org.marmot.security.intercept.web
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.util
org.marmot.security.view


PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
org.marmot.framework.dict.domain, org.marmot.framework.dict.factory, org.marmot.framework.dict.view, org.marmot.framework.dorado, org.marmot.framework.main, org.marmot.framework.menu.domain, org.marmot.framework.menu.factory, org.marmot.framework.menu.view, org.marmot.framework.message.domain, org.marmot.framework.message.manager, org.marmot.framework.preference, org.marmot.framework.preference.domain, org.marmot.framework.preference.manager, org.marmot.framework.profile.domain, org.marmot.framework.profile.view, org.marmot.framework.query.builder, org.marmot.framework.query.domain, org.marmot.framework.query.view, org.marmot.framework.security, org.marmot.framework.security.captcha, org.marmot.framework.util, org.marmot.security.cache, org.marmot.security.core, org.marmot.security.definition, org.marmot.security.domain, org.marmot.security.dorado, org.marmot.security.exception, org.marmot.security.filter, org.marmot.security.intercept.method, org.marmot.security.intercept.method.aopalliance, org.marmot.security.intercept.web, org.marmot.security.manager, org.marmot.security.service, org.marmot.security.util, org.marmot.security.view

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap (implements java.util.Map)
      • class org.marmot.framework.dorado.PreferencesExprContextMap
    • class com.bstek.dorado.data.AbstractDatasetListener (implements com.bstek.dorado.data.DatasetListener)
      • class org.marmot.framework.dict.view.DictionaryDatasetListener
      • class org.marmot.framework.query.view.QueryDatasetListener
    • class org.marmot.framework.query.builder.AbstractDynaQueryBuilder (implements org.marmot.framework.query.builder.QueryBuilder)
      • class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
        • class org.marmot.framework.query.builder.AbstractQLQueryBuilder
          • class org.marmot.framework.query.builder.HQLQueryBuilder
          • class org.marmot.framework.query.builder.IBatisQueryBuilder
        • class org.marmot.framework.query.builder.DynaSQLQueryBuilder
      • class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
    • class org.acegisecurity.intercept.web.AbstractFilterInvocationDefinitionSource (implements org.acegisecurity.intercept.web.FilterInvocationDefinitionSource)
      • class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
    • class org.marmot.framework.security.AbstractHttpAuthenticator (implements org.marmot.framework.security.Authenticator)
    • class org.marmot.framework.security.AbstractHttpCurrentAccountAccessor (implements org.marmot.framework.security.CurrentAccountAccessor)
    • class org.marmot.framework.menu.view.AbstractMenuHelper
      • class org.marmot.framework.menu.view.DiligentMenuHelper
      • class org.marmot.framework.menu.view.LazyMenuHelper
    • class org.marmot.framework.message.manager.AbstractMessageProcessor (implements org.marmot.framework.message.manager.MessageProcessor)
    • class org.acegisecurity.intercept.AbstractSecurityInterceptor (implements org.springframework.context.ApplicationEventPublisherAware, org.springframework.beans.factory.InitializingBean, org.springframework.context.MessageSourceAware)
      • class org.marmot.security.intercept.web.FilterSecurityInterceptor (implements javax.servlet.Filter)
      • class org.acegisecurity.intercept.method.aopalliance.MethodSecurityInterceptor (implements org.aopalliance.intercept.MethodInterceptor)
        • class org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor
    • class org.marmot.framework.security.Account
    • class org.marmot.framework.message.domain.Actor (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.AutoForm (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.AutoFormElement (implements java.io.Serializable)
    • class org.marmot.security.filter.AutoFormFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.framework.profile.domain.AutoFormGroup (implements java.io.Serializable)
    • class org.marmot.framework.profile.view.AutoFormProfileHelper
    • class org.marmot.security.view.CategoryAccessor
    • class org.marmot.security.view.CategoryBackBean
    • class org.springframework.dao.support.DaoSupport (implements org.springframework.beans.factory.InitializingBean)
      • class org.springframework.orm.hibernate3.support.HibernateDaoSupport
        • class org.marmot.security.cache.AcegiCacheManagerImpl (implements org.marmot.security.cache.AcegiCacheManager)
        • class org.marmot.security.service.ResourceCategoryService
        • class org.marmot.security.service.ResourceService
        • class org.marmot.security.service.ServiceUtil
          • class org.marmot.security.service.UserRoleService
    • class org.marmot.security.filter.DatasetFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.framework.profile.domain.DataTable (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.DataTableColumn (implements java.io.Serializable)
    • class org.marmot.security.filter.DataTableFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.framework.profile.view.DataTableProfileHelper
    • class org.marmot.security.intercept.method.DBMethodDefinitionSource (implements org.acegisecurity.intercept.method.MethodDefinitionSource)
    • class org.marmot.security.manager.DefaultCategoryManager (implements org.marmot.security.manager.CategoryManager)
    • class org.marmot.security.manager.DefaultResourceManager (implements org.marmot.security.manager.ResourceManager)
    • class org.marmot.security.manager.DefaultRoleManager (implements org.marmot.security.manager.RoleManager)
    • class org.marmot.security.manager.DefaultRoleResourceManager (implements org.marmot.security.manager.RoleResourceManager)
    • class org.marmot.security.manager.DefaultUserManager (implements org.marmot.security.manager.UserManager)
    • class org.marmot.security.manager.DefaultUserRoleManager (implements org.marmot.security.manager.UserRoleManager)
    • class org.marmot.framework.util.DropDownInitializor
    • class org.marmot.framework.dict.domain.Field (implements java.io.Serializable)
    • class org.marmot.framework.dict.domain.FieldSet (implements java.io.Serializable)
    • class org.marmot.security.filter.FilterAccessor
    • class org.marmot.security.filter.FilterUtils
    • class org.marmot.framework.main.FrameStyleUtils
    • class org.marmot.framework.util.HibernateDaoUtils
    • class org.marmot.framework.security.captcha.JCaptchaImageProcessor (implements org.marmot.framework.security.captcha.CaptchaProcessor)
    • class org.marmot.security.core.MarmotAuthenticationManager
    • class org.marmot.framework.dict.factory.MarmotDictionaryFactory (implements org.marmot.framework.dict.factory.DictionaryFactory)
    • class org.marmot.framework.menu.factory.MarmotMenuFactory (implements org.marmot.framework.menu.factory.DiligentMenuFactory, org.marmot.framework.menu.factory.LazyMenuFactory)
    • class org.marmot.framework.menu.domain.MenuElement
      • class org.marmot.framework.menu.domain.Favorite (implements java.io.Serializable)
      • class org.marmot.framework.menu.domain.MenuItem (implements java.io.Serializable)
    • class org.marmot.framework.message.domain.Message (implements java.io.Serializable)
    • class org.marmot.framework.message.domain.MessageReceiver (implements java.io.Serializable)
    • class org.marmot.security.filter.OutlookBarFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.security.service.PaginationSupport
    • class org.marmot.security.view.Permission
    • class org.marmot.security.view.PermissionAccessor
    • class org.marmot.security.view.PermissionBackBean
    • class org.marmot.framework.preference.domain.Preference (implements java.io.Serializable)
    • class org.marmot.framework.preference.domain.PreferenceCategory (implements java.io.Serializable)
    • class org.marmot.framework.preference.domain.PreferenceDefinition (implements java.io.Serializable)
    • class org.marmot.framework.preference.PreferenceUtils
    • class org.marmot.security.filter.PropertiesInfo
    • class org.marmot.security.view.ProxyBackBean
    • class org.marmot.security.domain.ProxyUser (implements java.io.Serializable)
    • class org.marmot.framework.query.builder.QL
    • class org.marmot.framework.query.builder.QLUtils
    • class org.marmot.framework.query.domain.Query (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryCategory (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryParameter (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QuerySort (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QuerySQL (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryTemplateField
    • class org.marmot.framework.query.domain.QueryUserCategory (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryWhere (implements java.io.Serializable)
    • class org.marmot.security.domain.ResCategory (implements java.io.Serializable)
    • class org.marmot.security.domain.Resource (implements java.io.Serializable)
    • class org.marmot.security.view.ResourceBackBean
    • class org.marmot.security.cache.ResourceCache
    • class org.marmot.security.domain.ResourceCategory (implements java.io.Serializable)
    • class org.marmot.security.definition.ResourceDefinitionSource
    • class org.marmot.security.domain.Role (implements java.io.Serializable)
    • class org.marmot.security.view.RoleBackBean
    • class org.marmot.security.domain.RoleRes (implements java.io.Serializable)
    • class org.marmot.framework.dorado.SecurityExprHandler
    • class org.marmot.security.cache.SecurityResource (implements org.marmot.security.cache.ResourceDetails)
    • class org.marmot.framework.security.SecurityUtils
    • class org.marmot.security.util.SecurityUtils
    • class org.marmot.security.filter.SimpleFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.framework.query.builder.SQLQueryBuilder (implements org.marmot.framework.query.builder.QueryBuilder)
    • class org.marmot.framework.query.builder.StandardQueryBuilder (implements org.marmot.framework.query.builder.QueryBuilder)
    • class org.marmot.security.filter.TabSetFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.springframework.core.NestedRuntimeException
            • class org.acegisecurity.AcegiSecurityException
              • class org.acegisecurity.AccessDeniedException
                • class org.marmot.security.exception.MarmotMethodAccessDeniedException
    • class org.marmot.security.domain.User (implements java.io.Serializable)
    • class org.marmot.security.view.UserBackBean
    • class org.marmot.security.domain.UserRole (implements java.io.Serializable)
    • class org.marmot.security.service.UserService (implements org.acegisecurity.userdetails.UserDetailsService)
    • class com.bstek.dorado.view.ViewModelSupport (implements com.bstek.dorado.view.ViewModel)
      • class com.bstek.dorado.view.DefaultViewModel
        • class com.bstek.dorado.view.impl.DynaViewModel
          • class org.marmot.security.dorado.SecurityViewModel
        • class org.marmot.framework.dorado.MarmotViewModel
          • class org.marmot.security.dorado.MarmotSecurityViewModel

Interface Hierarchy

  • interface org.marmot.security.cache.AcegiCacheManager
  • interface org.marmot.framework.security.Authenticator
  • interface org.marmot.framework.security.Authorizer
  • interface org.marmot.framework.security.captcha.CaptchaProcessor
  • interface org.marmot.security.filter.CategoryFilter
  • interface org.marmot.security.manager.CategoryManager
  • interface org.marmot.security.filter.ControlFilter
  • interface org.marmot.framework.security.CurrentAccountAccessor
  • interface org.marmot.framework.dict.factory.DictionaryFactory
  • interface org.marmot.framework.security.ListableAuthorizer
  • interface org.marmot.framework.menu.factory.MenuFactory
    • interface org.marmot.framework.menu.factory.DiligentMenuFactory
    • interface org.marmot.framework.menu.factory.LazyMenuFactory
  • interface org.marmot.framework.message.manager.MessageProcessor
  • interface org.marmot.framework.preference.manager.PreferenceHandler
  • interface org.marmot.framework.query.builder.QueryBuilder
  • interface org.marmot.security.manager.ResourceManager
  • interface org.marmot.security.manager.RoleManager
  • interface org.marmot.security.manager.RoleResourceManager
  • interface java.io.Serializable
    • interface org.marmot.security.cache.ResourceDetails
  • interface org.marmot.security.manager.UserManager
  • interface org.marmot.security.manager.UserRoleManager
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


The front page has been relocated.Please see:
Frame version
Non-frame version.


Serialized Form

Class org.marmot.framework.message.domain.Actor extends Object implements Serializable

serialVersionUID: -387720842312601231l

Serialized Fields

id

String id

name

String name

type

int type

description

String description

email

String email

meta1

String meta1

meta2

String meta2

meta3

String meta3

Class org.marmot.framework.profile.domain.AutoForm extends Object implements Serializable

serialVersionUID: 3255399508598312007l

Serialized Fields

id

String id

userId

String userId

formName

String formName

groupType

String groupType

groupLayout

String groupLayout

width

String width

height

String height

defaultLabelWidth

String defaultLabelWidth

defaultControlWidth

String defaultControlWidth

defaultElementMargin

int defaultElementMargin

groups

List groups

Class org.marmot.framework.profile.domain.AutoFormElement extends Object implements Serializable

serialVersionUID: -3039196965903659198l

Serialized Fields

id

String id

type

String type

name

String name

visible

boolean visible

rowSpan

int rowSpan

colSpan

int colSpan

field

String field

showLabel

boolean showLabel

labelAlign

String labelAlign

labelVAlign

String labelVAlign

labelStyle

String labelStyle

controlAlign

String controlAlign

controlVAlign

String controlVAlign

controlStyle

String controlStyle

controlWidth

String controlWidth

controlHeight

String controlHeight

dropDownType

String dropDownType

dropDownMeta

String dropDownMeta

dropDownScript

String dropDownScript

customControlId

String customControlId

Class org.marmot.framework.profile.domain.AutoFormGroup extends Object implements Serializable

serialVersionUID: -6349903517223387047l

Serialized Fields

id

String id

name

String name

label

String label

columnCount

int columnCount

expanded

boolean expanded

showBevel

boolean showBevel

visible

boolean visible

width

String width

height

String height

labelWidth

String labelWidth

defaultControlWidth

String defaultControlWidth

elementMargin

int elementMargin

elements

List elements

Class org.marmot.framework.profile.domain.DataTable extends Object implements Serializable

serialVersionUID: -6542773993982317874l

Serialized Fields

id

String id

userId

String userId

tableName

String tableName

fixedColumn

int fixedColumn

readOnly

boolean readOnly

showFilterBar

boolean showFilterBar

showFooter

boolean showFooter

columnDraggable

boolean columnDraggable

rowHeight

int rowHeight

columns

List columns

Class org.marmot.framework.profile.domain.DataTableColumn extends Object implements Serializable

serialVersionUID: -6403255585820600648l

Serialized Fields

id

String id

name

String name

level

int level

type

String type

label

String label

field

String field

width

int width

visible

boolean visible

readOnly

boolean readOnly

rendererType

String rendererType

editorType

String editorType

dropDownType

String dropDownType

dropDownMeta

String dropDownMeta

dropDownScript

String dropDownScript

resizable

boolean resizable

filterable

boolean filterable

groupable

boolean groupable

Class org.marmot.framework.menu.domain.Favorite extends MenuElement implements Serializable

serialVersionUID: 6683168723070432504l

Serialized Fields

userId

String userId

Class org.marmot.framework.dict.domain.Field extends Object implements Serializable

serialVersionUID: -4339261734995616065l

Serialized Fields

id

String id

setId

String setId

name

String name

label

String label

type

String type

visible

boolean visible

readOnly

boolean readOnly

required

boolean required

defaultValue

String defaultValue

maxLength

int maxLength

pattern

String pattern

dropDownType

String dropDownType

dropDownMeta

String dropDownMeta

dropDownScript

String dropDownScript

sortOrder

Integer sortOrder

description

String description

properties

Map properties

Class org.marmot.framework.dict.domain.FieldSet extends Object implements Serializable

serialVersionUID: -3678795529099808239l

Serialized Fields

id

String id

name

String name

userId

String userId

title

String title

fields

List fields

Class org.marmot.security.exception.MarmotMethodAccessDeniedException extends org.acegisecurity.AccessDeniedException implements Serializable

serialVersionUID: 5462621930212717095l

Class org.marmot.framework.menu.domain.MenuItem extends MenuElement implements Serializable

serialVersionUID: -7378314476446713649l

Serialized Fields

parentItemId

String parentItemId

type

int type

visible

boolean visible

enabled

boolean enabled

subItemCount

int subItemCount

subItems

List subItems

Class org.marmot.framework.message.domain.Message extends Object implements Serializable

serialVersionUID: 8082045204152524862l

Serialized Fields

id

String id

title

String title

message

String message

sender

String sender

senderName

String senderName

sendTime

Date sendTime

sendEmail

boolean sendEmail

Class org.marmot.framework.message.domain.MessageReceiver extends Object implements Serializable

serialVersionUID: 9142049438869756058l

Serialized Fields

id

String id

message

Message message

receiver

String receiver

receivedTime

Date receivedTime

received

boolean received

notifyTime

Date notifyTime

readTime

Date readTime

read

boolean read

Class org.marmot.framework.preference.domain.Preference extends Object implements Serializable

serialVersionUID: 8085445754185345732l

Serialized Fields

id

String id

userId

String userId

name

String name

value

String value

Class org.marmot.framework.preference.domain.PreferenceCategory extends Object implements Serializable

serialVersionUID: 5914626207274487895l

Serialized Fields

id

String id

description

String description

sortOrder

int sortOrder

preferenceDefinitions

List preferenceDefinitions

Class org.marmot.framework.preference.domain.PreferenceDefinition extends Object implements Serializable

serialVersionUID: -212372733118953787l

Serialized Fields

name

String name

categoryId

String categoryId

description

String description

dataType

String dataType

editorType

String editorType

sortOrder

int sortOrder

dropDownType

String dropDownType

dropDownMeta

String dropDownMeta

dropDownScript

String dropDownScript

overwritable

boolean overwritable

Class org.marmot.security.domain.ProxyUser extends Object implements Serializable

serialVersionUID: 4926471031773238757l

Serialized Fields

id

String id

activeTime

Date activeTime

dormantTime

Date dormantTime

userByUserId

User userByUserId

role

Role role

userByProxyUserId

User userByProxyUserId

Class org.marmot.framework.query.domain.Query extends Object implements Serializable

serialVersionUID: 1205890228428902613l

Serialized Fields

id

String id

userId

String userId

category

String category

queryName

String queryName

type

String type

parameters

List parameters

wheres

List wheres

sorts

List sorts

sqls

List sqls

Class org.marmot.framework.query.domain.QueryCategory extends Object implements Serializable

serialVersionUID: 7131994921697941744l

Serialized Fields

category

String category

defaultQueryId

String defaultQueryId

templateFields

List templateFields

Class org.marmot.framework.query.domain.QueryParameter extends Object implements Serializable

serialVersionUID: -6000406948690244895l

Serialized Fields

id

String id

query

Query query

paramName

String paramName

paramValue

String paramValue

paramType

String paramType

Class org.marmot.framework.query.domain.QuerySort extends Object implements Serializable

serialVersionUID: 4993352530483397505l

Serialized Fields

id

String id

query

Query query

tableName

String tableName

fieldName

String fieldName

fieldDescription

String fieldDescription

desc

boolean desc

Class org.marmot.framework.query.domain.QuerySQL extends Object implements Serializable

serialVersionUID: -6469606652985970607l

Serialized Fields

id

String id

query

Query query

whereClause

String whereClause

sortClause

String sortClause

Class org.marmot.framework.query.domain.QueryUserCategory extends Object implements Serializable

serialVersionUID: 6444127348540853029l

Serialized Fields

userId

String userId

category

QueryCategory category

defaultQueryId

String defaultQueryId

Class org.marmot.framework.query.domain.QueryWhere extends Object implements Serializable

serialVersionUID: -1684198681685839130l

Serialized Fields

id

String id

query

Query query

tableName

String tableName

fieldName

String fieldName

fieldDescription

String fieldDescription

fieldType

String fieldType

compareOp

String compareOp

compareValue

String compareValue

displayCompareValue

String displayCompareValue

bracketBefore

String bracketBefore

bracketAfter

String bracketAfter

logicOp

String logicOp

Class org.marmot.security.domain.ResCategory extends Object implements Serializable

serialVersionUID: -4949259264234664464l

Serialized Fields

id

String id

category

ResourceCategory category

resource

Resource resource

Class org.marmot.security.domain.Resource extends Object implements Serializable

serialVersionUID: 2422733924286020573l

Serialized Fields

id

String id

name

String name

resType

String resType

resString

String resString

descn

String descn

sortOrder

int sortOrder

statusFlag

boolean statusFlag

roleRess

List roleRess

resCategorys

List resCategorys

Class org.marmot.security.domain.ResourceCategory extends Object implements Serializable

serialVersionUID: 1524831897163168600l

Serialized Fields

id

String id

name

String name

label

String label

descn

String descn

sortOrder

int sortOrder

subItemCount

int subItemCount

parentId

String parentId

viewString

String viewString

categoryType

String categoryType

meta1

String meta1

meta2

String meta2

meta3

String meta3

resourceCategorys

List resourceCategorys

resCategorys

List resCategorys

Class org.marmot.security.domain.Role extends Object implements Serializable

serialVersionUID: -576408114725058901l

Serialized Fields

id

String id

name

String name

label

String label

descn

String descn

userRoles

List userRoles

proxyUsers

List proxyUsers

roleRess

List roleRess

Class org.marmot.security.domain.RoleRes extends Object implements Serializable

serialVersionUID: 8742365663667000096l

Serialized Fields

id

String id

role

Role role

resource

Resource resource

property

String property

Class org.marmot.security.cache.SecurityResource extends Object implements Serializable

serialVersionUID: 1l

Serialized Fields

resString

String resString

resType

String resType

authorities

org.acegisecurity.GrantedAuthority[] authorities

Class org.marmot.security.domain.User extends Object implements Serializable

serialVersionUID: -6734820009059049872l

Serialized Fields

id

String id

name

String name

loginid

String loginid

passwd

String passwd

statusFlag

boolean statusFlag

descn

String descn

root

boolean root

proxyusersForUserId

List proxyusersForUserId

userRoles

List userRoles

proxyusersForProxyUserId

List proxyusersForProxyUserId

Class org.marmot.security.domain.UserRole extends Object implements Serializable

serialVersionUID: 3086357145743342727l

Serialized Fields

id

String id

user

User user

role

Role role

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


A-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

A

AbstractDynaQLQueryBuilder - class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder.
AbstractDynaQLQueryBuilder() - Constructor for class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
AbstractDynaQueryBuilder - class org.marmot.framework.query.builder.AbstractDynaQueryBuilder.
AbstractDynaQueryBuilder() - Constructor for class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
AbstractHttpAuthenticator - class org.marmot.framework.security.AbstractHttpAuthenticator.
支持获取HttpServletRequest对象的Authenticator抽象实现类.
AbstractHttpAuthenticator() - Constructor for class org.marmot.framework.security.AbstractHttpAuthenticator
AbstractHttpCurrentAccountAccessor - class org.marmot.framework.security.AbstractHttpCurrentAccountAccessor.
支持获取HttpServletRequest对象的CurrentAccountAccessor抽象实现类.
AbstractHttpCurrentAccountAccessor() - Constructor for class org.marmot.framework.security.AbstractHttpCurrentAccountAccessor
AbstractMessageProcessor - class org.marmot.framework.message.manager.AbstractMessageProcessor.
抽像的实时消息处理器.
AbstractMessageProcessor() - Constructor for class org.marmot.framework.message.manager.AbstractMessageProcessor
AbstractQLQueryBuilder - class org.marmot.framework.query.builder.AbstractQLQueryBuilder.
AbstractQLQueryBuilder() - Constructor for class org.marmot.framework.query.builder.AbstractQLQueryBuilder
Account - class org.marmot.framework.security.Account.
Account(String) - Constructor for class org.marmot.framework.security.Account
AcegiCacheManager - interface org.marmot.security.cache.AcegiCacheManager.
cache管理
AcegiCacheManagerImpl - class org.marmot.security.cache.AcegiCacheManagerImpl.
cache管理
AcegiCacheManagerImpl() - Constructor for class org.marmot.security.cache.AcegiCacheManagerImpl
Actor - class org.marmot.framework.message.domain.Actor.
消息参与者的域模型.
Actor() - Constructor for class org.marmot.framework.message.domain.Actor
Authenticator - interface org.marmot.framework.security.Authenticator.
登录功能的接口
Authorizer - interface org.marmot.framework.security.Authorizer.
权限验证器的接口.
AutoForm - class org.marmot.framework.profile.domain.AutoForm.
AutoForm() - Constructor for class org.marmot.framework.profile.domain.AutoForm
AutoFormElement - class org.marmot.framework.profile.domain.AutoFormElement.
AutoFormElement() - Constructor for class org.marmot.framework.profile.domain.AutoFormElement
AutoFormFilter - class org.marmot.security.filter.AutoFormFilter.
AutoFormFilter() - Constructor for class org.marmot.security.filter.AutoFormFilter
AutoFormGroup - class org.marmot.framework.profile.domain.AutoFormGroup.
AutoFormGroup() - Constructor for class org.marmot.framework.profile.domain.AutoFormGroup
AutoFormProfileHelper - class org.marmot.framework.profile.view.AutoFormProfileHelper.
AutoFormProfileHelper() - Constructor for class org.marmot.framework.profile.view.AutoFormProfileHelper
addProxyUser(Map, Object) - Method in class org.marmot.security.view.ProxyBackBean
addRole(String, String) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
addRole(String, String) - Method in interface org.marmot.security.manager.RoleResourceManager
addRole(Map, Object) - Method in class org.marmot.security.view.ResourceBackBean
addUserRole(String, String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
addUserRole(String, String) - Method in interface org.marmot.security.manager.UserRoleManager
addUserRole(Map, Object) - Method in class org.marmot.security.view.RoleBackBean
addUserRole(Map, Object) - Method in class org.marmot.security.view.UserBackBean
afterCreateFields(Dataset) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
applyQuery(Dataset, Query) - Method in class org.marmot.framework.query.view.QueryDatasetListener
asyncCategory(ResourceCategory, boolean) - Method in class org.marmot.security.filter.FilterAccessor
asyncCategory(ResourceCategory, boolean) - Method in class org.marmot.security.filter.FilterUtils
authResourceInCache(Role) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
Role授予资源时更改resourceCache
authRoleInCache(User) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
User授予角色时更改userCache
authenticate(String, String) - Method in class org.marmot.security.core.MarmotAuthenticationManager
ACEGI权限判断以及权限系统环境初始化设置
authentication(String, String) - Method in class org.marmot.security.core.MarmotAuthenticationManager
authentication(Role, String) - Method in class org.marmot.security.core.MarmotAuthenticationManager
authentication(String) - Method in class org.marmot.security.filter.FilterAccessor
authentication(String, Object) - Static method in class org.marmot.security.util.SecurityUtils
authentication(String, String) - Static method in class org.marmot.security.util.SecurityUtils
判断系统账号对指定资源是否具有访问权限
authentication(Role, String) - Static method in class org.marmot.security.util.SecurityUtils
Overview Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V


B-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

B

beforeCreateFields(Dataset) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
beforeLoadData(Dataset) - Method in class org.marmot.framework.query.view.QueryDatasetListener
bindAutoFormProfileMenu(ViewModel, AutoForm) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
bindDataTableProfileMenu(DataTable) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
buildMatchRule(AutoSqlDataset, QueryWhere, Object, int) - Method in class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
buildMatchRules(AutoSqlDataset, Query) - Method in class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
buildOrderByClause(QL, Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildQL(Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildQL(Query) - Method in class org.marmot.framework.query.builder.AbstractQLQueryBuilder
buildQL(Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractQLQueryBuilder
buildWhereClause(QL, Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
buildWhereClauseSection(QL, Dataset, QueryWhere, Object) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


C-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

C

CATEGORY_CONTROLS - Static variable in class org.marmot.security.filter.FilterAccessor
CATEGORY_DATASETS - Static variable in class org.marmot.security.filter.FilterAccessor
CATEGORY_DIRECTORY - Static variable in class org.marmot.security.filter.FilterAccessor
CATEGORY_URL - Static variable in class org.marmot.security.filter.FilterAccessor
CaptchaProcessor - interface org.marmot.framework.security.captcha.CaptchaProcessor.
验证码处理器的接口.
CategoryAccessor - class org.marmot.security.view.CategoryAccessor.
CategoryAccessor() - Constructor for class org.marmot.security.view.CategoryAccessor
CategoryBackBean - class org.marmot.security.view.CategoryBackBean.
CategoryBackBean() - Constructor for class org.marmot.security.view.CategoryBackBean
CategoryFilter - interface org.marmot.security.filter.CategoryFilter.
CategoryManager - interface org.marmot.security.manager.CategoryManager.
ControlFilter - interface org.marmot.security.filter.ControlFilter.
CurrentAccountAccessor - interface org.marmot.framework.security.CurrentAccountAccessor.
用于获取系统当前登录信息的类的接口.
changeCategoryPosition(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
changePwd(User, String, String) - Method in class org.marmot.security.manager.DefaultUserManager
changePwd(User, String, String) - Method in interface org.marmot.security.manager.UserManager
changePwd(Map, Object) - Method in class org.marmot.security.view.UserBackBean
changeRoot(User) - Method in class org.marmot.security.manager.DefaultUserManager
changeRoot(User) - Method in interface org.marmot.security.manager.UserManager
changeRoot(Map, Object) - Method in class org.marmot.security.view.UserBackBean
changeStatus(Resource) - Method in class org.marmot.security.manager.DefaultResourceManager
changeStatus(User) - Method in class org.marmot.security.manager.DefaultUserManager
changeStatus(Resource) - Method in interface org.marmot.security.manager.ResourceManager
changeStatus(User) - Method in interface org.marmot.security.manager.UserManager
changeStatus(Map, Object) - Method in class org.marmot.security.view.ResourceBackBean
changeStatus(Map, Object) - Method in class org.marmot.security.view.UserBackBean
clearCache() - Static method in class org.marmot.framework.preference.PreferenceUtils
clearCache(Account) - Method in interface org.marmot.framework.preference.manager.PreferenceHandler
containsProperty(Account, String) - Method in interface org.marmot.framework.preference.manager.PreferenceHandler
createBooleanCriteria(String, String) - Static method in class org.marmot.framework.util.HibernateDaoUtils
createDateCriteria(String, String) - Static method in class org.marmot.framework.util.HibernateDaoUtils
createDoubleCriteria(String, String) - Static method in class org.marmot.framework.util.HibernateDaoUtils
createField(Dataset, FieldSet, Field) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
createLongCriteria(String, String) - Static method in class org.marmot.framework.util.HibernateDaoUtils
createStringCriteria(String, String) - Static method in class org.marmot.framework.util.HibernateDaoUtils
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


D-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

D

DBFilterInvocationDefinitionSource - class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource.
DBFilterInvocationDefinitionSource() - Constructor for class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
DBMethodDefinitionSource - class org.marmot.security.intercept.method.DBMethodDefinitionSource.
在resourceCache中保存每个方法对应的ResourceDetails
DBMethodDefinitionSource() - Constructor for class org.marmot.security.intercept.method.DBMethodDefinitionSource
DataTable - class org.marmot.framework.profile.domain.DataTable.
DataTable() - Constructor for class org.marmot.framework.profile.domain.DataTable
DataTableColumn - class org.marmot.framework.profile.domain.DataTableColumn.
DataTableColumn() - Constructor for class org.marmot.framework.profile.domain.DataTableColumn
DataTableFilter - class org.marmot.security.filter.DataTableFilter.
DataTableFilter() - Constructor for class org.marmot.security.filter.DataTableFilter
DataTableProfileHelper - class org.marmot.framework.profile.view.DataTableProfileHelper.
DataTableProfileHelper() - Constructor for class org.marmot.framework.profile.view.DataTableProfileHelper
DatasetFilter - class org.marmot.security.filter.DatasetFilter.
DatasetFilter() - Constructor for class org.marmot.security.filter.DatasetFilter
DefaultCategoryManager - class org.marmot.security.manager.DefaultCategoryManager.
DefaultCategoryManager() - Constructor for class org.marmot.security.manager.DefaultCategoryManager
DefaultResourceManager - class org.marmot.security.manager.DefaultResourceManager.
DefaultResourceManager() - Constructor for class org.marmot.security.manager.DefaultResourceManager
DefaultRoleManager - class org.marmot.security.manager.DefaultRoleManager.
DefaultRoleManager() - Constructor for class org.marmot.security.manager.DefaultRoleManager
DefaultRoleResourceManager - class org.marmot.security.manager.DefaultRoleResourceManager.
DefaultRoleResourceManager() - Constructor for class org.marmot.security.manager.DefaultRoleResourceManager
DefaultUserManager - class org.marmot.security.manager.DefaultUserManager.
DefaultUserManager() - Constructor for class org.marmot.security.manager.DefaultUserManager
DefaultUserRoleManager - class org.marmot.security.manager.DefaultUserRoleManager.
DefaultUserRoleManager() - Constructor for class org.marmot.security.manager.DefaultUserRoleManager
DictionaryDatasetListener - class org.marmot.framework.dict.view.DictionaryDatasetListener.
DictionaryDatasetListener() - Constructor for class org.marmot.framework.dict.view.DictionaryDatasetListener
DictionaryFactory - interface org.marmot.framework.dict.factory.DictionaryFactory.
数据字典信息的采集工厂接口.
DiligentMenuFactory - interface org.marmot.framework.menu.factory.DiligentMenuFactory.
勤快的动态菜单工厂的接口.
DiligentMenuHelper - class org.marmot.framework.menu.view.DiligentMenuHelper.
用于创建一次性装载的菜单控件的辅助类.
DiligentMenuHelper() - Constructor for class org.marmot.framework.menu.view.DiligentMenuHelper
DropDownInitializor - class org.marmot.framework.util.DropDownInitializor.
DropDownInitializor() - Constructor for class org.marmot.framework.util.DropDownInitializor
DynaAutoSQLQueryBuilder - class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder.
DynaAutoSQLQueryBuilder() - Constructor for class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
DynaSQLQueryBuilder - class org.marmot.framework.query.builder.DynaSQLQueryBuilder.
DynaSQLQueryBuilder() - Constructor for class org.marmot.framework.query.builder.DynaSQLQueryBuilder
delete(Object) - Method in class org.marmot.security.manager.DefaultUserRoleManager
delete(ResourceCategory) - Method in class org.marmot.security.service.ResourceCategoryService
delete(Object) - Method in class org.marmot.security.service.ServiceUtil
deleteAutoForm(String) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
deleteCategory(ResourceCategory) - Method in interface org.marmot.security.manager.CategoryManager
deleteCategory(ResourceCategory) - Method in class org.marmot.security.manager.DefaultCategoryManager
deleteDataTable(String) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
deleteResource(Resource) - Method in class org.marmot.security.manager.DefaultResourceManager
deleteResource(Resource) - Method in interface org.marmot.security.manager.ResourceManager
deleteResource(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
deleteResourceCategory(String, String) - Method in interface org.marmot.security.manager.CategoryManager
deleteResourceCategory(String, String) - Method in class org.marmot.security.manager.DefaultCategoryManager
deleteRole(Role) - Method in class org.marmot.security.manager.DefaultRoleManager
deleteRole(Role) - Method in class org.marmot.security.manager.DefaultUserRoleManager
deleteRole(Role) - Method in interface org.marmot.security.manager.RoleManager
deleteRoleResource(RoleRes) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
deleteRoleResource(String, String) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
deleteRoleResource(String, String) - Method in interface org.marmot.security.manager.RoleResourceManager
deleteRoleResource(RoleRes) - Method in interface org.marmot.security.manager.RoleResourceManager
deleteUser(User) - Method in class org.marmot.security.manager.DefaultUserManager
deleteUser(User) - Method in interface org.marmot.security.manager.UserManager
destroy() - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
Not used (we rely on IoC container lifecycle services instead)
doFilter(ServletRequest, ServletResponse, FilterChain) - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
将当前请求的url与session中当前登录用户经过授权的资源进行比对判断是否有访问权限 Method that is actually called by the filter chain.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


E-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

E

enableProfileMaintainDialog() - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
enableProfileMaintainDialog() - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
是否启用DataTable高级属性配置窗口
equals(Object) - Method in class org.marmot.security.cache.SecurityResource
evaluateExpression(CompiledText) - Method in class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
execute(Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
execute(Dataset, Query) - Method in interface org.marmot.framework.query.builder.QueryBuilder
execute(Dataset, Query) - Method in class org.marmot.framework.query.builder.SQLQueryBuilder
execute(Dataset, Query) - Method in class org.marmot.framework.query.builder.StandardQueryBuilder
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


F-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

F

Favorite - class org.marmot.framework.menu.domain.Favorite.
收藏项的域模型
Favorite() - Constructor for class org.marmot.framework.menu.domain.Favorite
Field - class org.marmot.framework.dict.domain.Field.
字段描述信息的域模型
Field() - Constructor for class org.marmot.framework.dict.domain.Field
FieldSet - class org.marmot.framework.dict.domain.FieldSet.
字段描述信息集合的域模型
FieldSet() - Constructor for class org.marmot.framework.dict.domain.FieldSet
FilterAccessor - class org.marmot.security.filter.FilterAccessor.
FilterAccessor() - Constructor for class org.marmot.security.filter.FilterAccessor
FilterSecurityInterceptor - class org.marmot.security.intercept.web.FilterSecurityInterceptor.
针对url进行权限控制
FilterSecurityInterceptor() - Constructor for class org.marmot.security.intercept.web.FilterSecurityInterceptor
FilterUtils - class org.marmot.security.filter.FilterUtils.
FilterUtils() - Constructor for class org.marmot.security.filter.FilterUtils
FrameStyleUtils - class org.marmot.framework.main.FrameStyleUtils.
用于辅助处理框架风格的工具类.
find(String) - Method in class org.marmot.security.service.ServiceUtil
find(String, Object) - Method in class org.marmot.security.service.ServiceUtil
findAll(Class) - Method in class org.marmot.security.manager.DefaultUserRoleManager
findAll(Class) - Method in class org.marmot.security.service.ServiceUtil
findAllByCriteria(DetachedCriteria) - Method in class org.marmot.security.service.ServiceUtil
findAutoForm(String) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
findByNamedParam(String, String[], String[]) - Method in class org.marmot.security.service.ServiceUtil
findByNamedParam(String, String, String) - Method in class org.marmot.security.service.ServiceUtil
findByNamedQuery(String) - Method in class org.marmot.security.service.ServiceUtil
findByNamedQuery(String, Object) - Method in class org.marmot.security.service.ServiceUtil
findByNamedQuery(String, Object[]) - Method in class org.marmot.security.service.ServiceUtil
findDataTable(String) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
findPageByCriteria(DetachedCriteria) - Method in class org.marmot.security.service.ServiceUtil
findPageByCriteria(DetachedCriteria, int) - Method in class org.marmot.security.service.ServiceUtil
findPageByCriteria(DetachedCriteria, int, int) - Method in class org.marmot.security.service.ServiceUtil
findPrevOrderByKeyword(String, int) - Static method in class org.marmot.framework.query.builder.QLUtils
findPrevWord(String, int) - Static method in class org.marmot.framework.query.builder.QLUtils
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


G-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

G

GROUP - Static variable in class org.marmot.framework.message.domain.Actor
get(Object) - Method in class org.marmot.framework.dorado.PreferencesExprContextMap
get(Class, String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
get(Class, Serializable) - Method in class org.marmot.security.service.ServiceUtil
getAcegiAuthenticationManager() - Method in class org.marmot.security.core.MarmotAuthenticationManager
getActiveTime() - Method in class org.marmot.security.domain.ProxyUser
getActor(String) - Method in interface org.marmot.framework.message.manager.MessageProcessor
根据id返回参与者对象.
getAllResources(Map) - Method in class org.marmot.security.manager.DefaultResourceManager
getAllResources(Map) - Method in interface org.marmot.security.manager.ResourceManager
getAllRoles() - Method in class org.marmot.security.manager.DefaultRoleManager
getAllRoles(Map) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
getAllRoles(User) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getAllRoles() - Method in interface org.marmot.security.manager.RoleManager
getAllRoles(Map) - Method in interface org.marmot.security.manager.RoleResourceManager
getAllRoles(User) - Method in interface org.marmot.security.manager.UserRoleManager
getAllRoles(DataSet) - Method in class org.marmot.security.view.ResourceBackBean
getAllRoles(DataSet) - Method in class org.marmot.security.view.RoleBackBean
getAllRolesByUserId(String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getAllUsers() - Method in class org.marmot.security.manager.DefaultUserManager
getAllUsers() - Method in interface org.marmot.security.manager.UserManager
getAllUsers(DataSet) - Method in class org.marmot.security.view.UserBackBean
getAttribute(String) - Method in class org.marmot.framework.security.Account
getAttributes(Object) - Method in class org.marmot.security.intercept.method.DBMethodDefinitionSource
getAuthFailureValue() - Method in class org.marmot.security.filter.PropertiesInfo
getAuthLabel() - Method in class org.marmot.security.filter.PropertiesInfo
getAuthSuccessValue() - Method in class org.marmot.security.filter.PropertiesInfo
getAuthenticationDetailsSource() - Method in class org.marmot.security.core.MarmotAuthenticationManager
getAuthorities() - Method in interface org.marmot.security.cache.ResourceDetails
返回属于该resource的authorities
getAuthorities() - Method in class org.marmot.security.cache.SecurityResource
getAuthorityFromCache(String) - Method in class org.marmot.security.cache.ResourceCache
getAuthorityFromResourceCache(String) - Method in interface org.marmot.security.cache.AcegiCacheManager
根据资源串获取可以访问该资源的ResourceDetails信息
getAuthorityFromResourceCache(String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
根据资源串获取资源
getAuthorityFromUserCache(String) - Method in interface org.marmot.security.cache.AcegiCacheManager
根据username获取可以访问该资源的UserDetails信息
getAuthorityFromUserCache(String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
getAuthorizedResources(Account, Object) - Method in interface org.marmot.framework.security.ListableAuthorizer
根据某父资源项返回所有已授权给指定帐号的子资源项的集合.
getAutoForm(String, String) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
getAutoFormProfileManager() - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
getBeanFactory() - Static method in class org.marmot.security.dorado.MarmotSecurityViewModel
getBeanFactory() - Static method in class org.marmot.security.dorado.SecurityViewModel
getBoolean(String) - Static method in class org.marmot.framework.preference.PreferenceUtils
getBoolean(String, boolean) - Static method in class org.marmot.framework.preference.PreferenceUtils
getBracketAfter() - Method in class org.marmot.framework.query.domain.QueryWhere
getBracketBefore() - Method in class org.marmot.framework.query.domain.QueryWhere
getCache() - Method in class org.marmot.security.cache.ResourceCache
getCacheManager() - Method in class org.marmot.security.view.ResourceBackBean
getCacheManager() - Method in class org.marmot.security.view.UserBackBean
getCategory() - Method in class org.marmot.framework.query.domain.Query
getCategory() - Method in class org.marmot.framework.query.domain.QueryCategory
getCategory() - Method in class org.marmot.framework.query.domain.QueryUserCategory
getCategory() - Method in class org.marmot.security.domain.ResCategory
getCategory(String) - Method in interface org.marmot.security.manager.CategoryManager
getCategory(String) - Method in class org.marmot.security.manager.DefaultCategoryManager
getCategory(String) - Method in class org.marmot.security.service.ResourceCategoryService
getCategory(DataSet) - Method in class org.marmot.security.view.CategoryBackBean
getCategoryAccessor() - Method in class org.marmot.security.view.CategoryBackBean
getCategoryId() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getCategoryManager() - Method in class org.marmot.security.view.CategoryBackBean
getCategoryManager() - Method in class org.marmot.security.view.PermissionAccessor
getCategoryManager() - Method in class org.marmot.security.view.PermissionBackBean
getCategoryService() - Method in class org.marmot.security.manager.DefaultCategoryManager
getCategoryType() - Method in class org.marmot.security.domain.ResourceCategory
getCategoryType() - Method in class org.marmot.security.view.Permission
getCategorys(String) - Method in interface org.marmot.security.manager.CategoryManager
getCategorys(String) - Method in class org.marmot.security.manager.DefaultCategoryManager
getCategorys(String) - Method in class org.marmot.security.service.ResourceCategoryService
getCategorys(DataSet) - Method in class org.marmot.security.view.CategoryBackBean
getCategorys(DataSet) - Method in class org.marmot.security.view.PermissionBackBean
getCharNumber() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getChars() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getChildActors(String) - Method in interface org.marmot.framework.message.manager.MessageProcessor
根据父参与者的id返回子参与者的集合.
getColSpan() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getColumnCount() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getColumnProperties() - Method in class org.marmot.security.filter.AutoFormFilter
getColumnProperties() - Method in class org.marmot.security.filter.DataTableFilter
getColumns() - Method in class org.marmot.framework.profile.domain.DataTable
getCompareOp() - Method in class org.marmot.framework.query.domain.QueryWhere
getCompareValue() - Method in class org.marmot.framework.query.domain.QueryWhere
getComponents() - Method in interface org.marmot.security.cache.AcegiCacheManager
获取所有的Component资源
getComponents() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
获取所有的Component资源
getComponents() - Method in class org.marmot.security.cache.ResourceCache
getConfigAttributeDefinitions() - Method in class org.marmot.security.intercept.method.DBMethodDefinitionSource
getConfigAttributeDefinitions() - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
getControlAlign() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getControlAuthorities(String) - Method in class org.marmot.security.definition.ResourceDefinitionSource
getControlHeight() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getControlStyle() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getControlVAlign() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getControlWidth() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getControlsMap() - Method in class org.marmot.security.filter.FilterUtils
getCountByCriteria(DetachedCriteria) - Method in class org.marmot.security.service.ServiceUtil
getCurrentAccount() - Method in class org.marmot.framework.dorado.SecurityExprHandler
getCurrentAccount() - Method in interface org.marmot.framework.security.CurrentAccountAccessor
返回系统当前登录者的帐号信息.
getCurrentAccount() - Static method in class org.marmot.framework.security.SecurityUtils
getCurrentAccountId() - Static method in class org.marmot.framework.security.SecurityUtils
getCurrentPersonId() - Static method in class org.marmot.framework.security.SecurityUtils
getCurrentUser() - Static method in class org.marmot.security.util.SecurityUtils
返回当前已登录到权限系统的的系统账号。
getCustomControlId() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getDataTable(String, String) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
getDataTableProfileManager() - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
getDataType() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getDataTypes() - Method in class org.marmot.framework.query.builder.QL
getDatasetProperties() - Method in class org.marmot.security.filter.DatasetFilter
getDefaultCategoryFilter() - Method in class org.marmot.security.filter.FilterUtils
getDefaultControlFilter() - Method in class org.marmot.security.filter.FilterUtils
getDefaultControlWidth() - Method in class org.marmot.framework.profile.domain.AutoForm
getDefaultControlWidth() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getDefaultElementMargin() - Method in class org.marmot.framework.profile.domain.AutoForm
getDefaultLabelWidth() - Method in class org.marmot.framework.profile.domain.AutoForm
getDefaultQueryId() - Method in class org.marmot.framework.query.domain.QueryCategory
getDefaultQueryId() - Method in class org.marmot.framework.query.domain.QueryUserCategory
getDefaultValue() - Method in class org.marmot.framework.dict.domain.Field
getDescn() - Method in class org.marmot.security.domain.Resource
getDescn() - Method in class org.marmot.security.domain.ResourceCategory
getDescn() - Method in class org.marmot.security.domain.Role
getDescn() - Method in class org.marmot.security.domain.User
getDescn() - Method in class org.marmot.security.view.Permission
getDescription() - Method in class org.marmot.framework.dict.domain.Field
getDescription() - Method in class org.marmot.framework.menu.domain.MenuElement
getDescription() - Method in class org.marmot.framework.message.domain.Actor
getDescription() - Method in class org.marmot.framework.preference.domain.PreferenceCategory
getDescription() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getDisableIcon() - Method in class org.marmot.framework.menu.domain.MenuElement
getDisplayCompareValue() - Method in class org.marmot.framework.query.domain.QueryWhere
getDormantTime() - Method in class org.marmot.security.domain.ProxyUser
getDouble(String) - Static method in class org.marmot.framework.preference.PreferenceUtils
getDouble(String, double) - Static method in class org.marmot.framework.preference.PreferenceUtils
getDropDownMeta() - Method in class org.marmot.framework.dict.domain.Field
getDropDownMeta() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getDropDownMeta() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getDropDownMeta() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getDropDownMeta() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getDropDownScript() - Method in class org.marmot.framework.dict.domain.Field
getDropDownScript() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getDropDownScript() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getDropDownScript() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getDropDownScript() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getDropDownType() - Method in class org.marmot.framework.dict.domain.Field
getDropDownType() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getDropDownType() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getDropDownType() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getDropDownType() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getEditorType() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getEditorType() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getElementMargin() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getElements() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getEmail() - Method in class org.marmot.framework.message.domain.Actor
getFavorities() - Method in class org.marmot.framework.menu.view.LazyMenuHelper
返回当前登录用户的个人收藏项的集合.
getFavoritiesOfAccount(Account) - Method in class org.marmot.framework.menu.factory.MarmotMenuFactory
getFavoritiesOfAccount(Account) - Method in interface org.marmot.framework.menu.factory.MenuFactory
根据某帐号返回其所有收藏项的集合.
getField() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getField() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getFieldDescription() - Method in class org.marmot.framework.query.domain.QuerySort
getFieldDescription() - Method in class org.marmot.framework.query.domain.QueryWhere
getFieldLabel() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getFieldName() - Method in class org.marmot.framework.query.domain.QuerySort
getFieldName() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getFieldName() - Method in class org.marmot.framework.query.domain.QueryWhere
getFieldProperties() - Method in class org.marmot.security.filter.DatasetFilter
getFieldSet(Account, String) - Method in interface org.marmot.framework.dict.factory.DictionaryFactory
根据帐号信息和集合名返回一个数据字典中的字段信息集合.
getFieldSet(Account, String, String) - Method in interface org.marmot.framework.dict.factory.DictionaryFactory
根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.
getFieldSet(Account, String) - Method in class org.marmot.framework.dict.factory.MarmotDictionaryFactory
getFieldSet(Account, String, String) - Method in class org.marmot.framework.dict.factory.MarmotDictionaryFactory
getFieldSet(Dataset) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
getFieldType() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getFieldType() - Method in class org.marmot.framework.query.domain.QueryWhere
getFields() - Method in class org.marmot.framework.dict.domain.FieldSet
getFilterAccessor() - Method in class org.marmot.security.filter.AutoFormFilter
getFilterAccessor() - Method in class org.marmot.security.filter.DataTableFilter
getFilterAccessor() - Method in class org.marmot.security.filter.DatasetFilter
getFilterAccessor() - Method in class org.marmot.security.filter.FilterUtils
getFilterAccessor() - Method in class org.marmot.security.filter.OutlookBarFilter
getFilterAccessor() - Method in class org.marmot.security.filter.SimpleFilter
getFilterAccessor() - Method in class org.marmot.security.filter.TabSetFilter
getFilterUtils() - Method in class org.marmot.security.dorado.SecurityViewModel
getFilterUtils() - Method in class org.marmot.security.view.CategoryAccessor
getFixedColumn() - Method in class org.marmot.framework.profile.domain.DataTable
getFormName() - Method in class org.marmot.framework.profile.domain.AutoForm
getFormProperties() - Method in class org.marmot.security.filter.AutoFormFilter
getFunctions() - Method in interface org.marmot.security.cache.AcegiCacheManager
获取所有的Funtion资源
getFunctions() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
获取所有的Funtion资源
getFunctions() - Method in class org.marmot.security.cache.ResourceCache
getGrantedRoles(DataSet) - Method in class org.marmot.security.view.UserBackBean
getGrantedRolesByUserId(String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getGrantedRolesByUserId(String) - Method in interface org.marmot.security.manager.UserRoleManager
getGrantedRolesByUserId(String) - Method in class org.marmot.security.service.UserRoleService
获取指定用户的角色列表
getGrantedUsers(DataSet) - Method in class org.marmot.security.view.RoleBackBean
getGrantedUsersByRoleId(String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getGrantedUsersByRoleId(String) - Method in interface org.marmot.security.manager.UserRoleManager
getGrantedUsersByRoleId(String) - Method in class org.marmot.security.service.UserRoleService
获取已经授予该角色的用户列表
getGroupColumnProperties() - Method in class org.marmot.security.filter.DataTableFilter
getGroupLayout() - Method in class org.marmot.framework.profile.domain.AutoForm
getGroupProperties() - Method in class org.marmot.security.filter.AutoFormFilter
getGroupProperties() - Method in class org.marmot.security.filter.OutlookBarFilter
getGroupType() - Method in class org.marmot.framework.profile.domain.AutoForm
getGroups() - Method in class org.marmot.framework.profile.domain.AutoForm
getHeight() - Method in class org.marmot.framework.profile.domain.AutoForm
getHeight() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getHeight() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getIcon() - Method in class org.marmot.framework.menu.domain.MenuElement
getId() - Method in class org.marmot.framework.dict.domain.Field
getId() - Method in class org.marmot.framework.dict.domain.FieldSet
getId() - Method in class org.marmot.framework.menu.domain.MenuElement
getId() - Method in class org.marmot.framework.message.domain.Actor
getId() - Method in class org.marmot.framework.message.domain.Message
getId() - Method in class org.marmot.framework.message.domain.MessageReceiver
getId() - Method in class org.marmot.framework.preference.domain.Preference
getId() - Method in class org.marmot.framework.preference.domain.PreferenceCategory
getId() - Method in class org.marmot.framework.profile.domain.AutoForm
getId() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getId() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getId() - Method in class org.marmot.framework.profile.domain.DataTable
getId() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getId() - Method in class org.marmot.framework.query.domain.Query
getId() - Method in class org.marmot.framework.query.domain.QueryParameter
getId() - Method in class org.marmot.framework.query.domain.QuerySQL
getId() - Method in class org.marmot.framework.query.domain.QuerySort
getId() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getId() - Method in class org.marmot.framework.query.domain.QueryWhere
getId() - Method in class org.marmot.framework.security.Account
getId() - Method in class org.marmot.security.domain.ProxyUser
getId() - Method in class org.marmot.security.domain.ResCategory
getId() - Method in class org.marmot.security.domain.Resource
getId() - Method in class org.marmot.security.domain.ResourceCategory
getId() - Method in class org.marmot.security.domain.Role
getId() - Method in class org.marmot.security.domain.RoleRes
getId() - Method in class org.marmot.security.domain.User
getId() - Method in class org.marmot.security.domain.UserRole
getId() - Method in class org.marmot.security.view.Permission
getImageCaptchaService() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getImageType() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getIndexes() - Method in class org.marmot.security.service.PaginationSupport
getInstance() - Static method in class org.marmot.framework.menu.view.DiligentMenuHelper
返回DiligentMenuHelper的实例.
getInstance() - Static method in class org.marmot.framework.menu.view.LazyMenuHelper
返回LazyMenuHelper的实例.
getInstance() - Static method in class org.marmot.framework.security.SecurityUtils
getInt(String) - Static method in class org.marmot.framework.preference.PreferenceUtils
getInt(String, int) - Static method in class org.marmot.framework.preference.PreferenceUtils
getItems() - Method in class org.marmot.security.service.PaginationSupport
getLabel() - Method in class org.marmot.framework.dict.domain.Field
getLabel() - Method in class org.marmot.framework.menu.domain.MenuElement
getLabel() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getLabel() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getLabel() - Method in class org.marmot.security.domain.ResourceCategory
getLabel() - Method in class org.marmot.security.domain.Role
getLabel() - Method in class org.marmot.security.view.Permission
getLabelAlign() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getLabelStyle() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getLabelVAlign() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getLabelWidth() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getLevel() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getLogicOp() - Method in class org.marmot.framework.query.domain.QueryWhere
getLoginid() - Method in class org.marmot.security.domain.User
getLong(String) - Static method in class org.marmot.framework.preference.PreferenceUtils
getLong(String, long) - Static method in class org.marmot.framework.preference.PreferenceUtils
getMaxFontSize() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getMaxLength() - Method in class org.marmot.framework.dict.domain.Field
getMenuFactory() - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
getMenuFactory() - Method in class org.marmot.framework.menu.view.LazyMenuHelper
getMenuHelper() - Method in class org.marmot.security.view.CategoryAccessor
getMenuItems(String) - Method in class org.marmot.framework.menu.factory.MarmotMenuFactory
getMenuItems(String) - Method in interface org.marmot.framework.menu.factory.MenuFactory
根据父菜单项的id返回子菜单项的集合.
getMenuItems(String) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
根据父菜单项的id返回子菜单项模型的集合.
getMenuItems(String, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
根据父菜单项的id返回包含了指定深度信息的子菜单项模型的集合.
getMenuItems(String) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
根据父菜单项的id返回子菜单项模型的集合.
getMessage() - Method in class org.marmot.framework.message.domain.Message
getMessage() - Method in class org.marmot.framework.message.domain.MessageReceiver
getMeta1() - Method in class org.marmot.framework.menu.domain.MenuElement
getMeta1() - Method in class org.marmot.framework.message.domain.Actor
getMeta1() - Method in class org.marmot.security.domain.ResourceCategory
getMeta2() - Method in class org.marmot.framework.menu.domain.MenuElement
getMeta2() - Method in class org.marmot.framework.message.domain.Actor
getMeta2() - Method in class org.marmot.security.domain.ResourceCategory
getMeta3() - Method in class org.marmot.framework.menu.domain.MenuElement
getMeta3() - Method in class org.marmot.framework.message.domain.Actor
getMeta3() - Method in class org.marmot.security.domain.ResourceCategory
getMinFontSize() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getName() - Method in class org.marmot.framework.dict.domain.Field
getName() - Method in class org.marmot.framework.dict.domain.FieldSet
getName() - Method in class org.marmot.framework.message.domain.Actor
getName() - Method in class org.marmot.framework.preference.domain.Preference
getName() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getName() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getName() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getName() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getName() - Method in class org.marmot.framework.security.Account
getName() - Method in class org.marmot.security.domain.Resource
getName() - Method in class org.marmot.security.domain.ResourceCategory
getName() - Method in class org.marmot.security.domain.Role
getName() - Method in class org.marmot.security.domain.User
getName() - Method in class org.marmot.security.view.Permission
getNewMessages(String) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
getNewMessages(String) - Method in interface org.marmot.framework.message.manager.MessageProcessor
返回所有当前消息参与者本人尚未接收的信息.
getNextIndex() - Method in class org.marmot.security.service.PaginationSupport
getNotifyTime() - Method in class org.marmot.framework.message.domain.MessageReceiver
getObjectDefinitionSource() - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
getOrderByClause() - Method in class org.marmot.framework.query.builder.QL
getOrderByClauseString() - Method in class org.marmot.framework.query.builder.QL
getOrderedPage(HibernateTemplate, DetachedCriteria, List, int, int) - Static method in class org.marmot.framework.util.HibernateDaoUtils
getOutlookBarProperties() - Method in class org.marmot.security.filter.OutlookBarFilter
getPage(HibernateTemplate, DetachedCriteria, int, int) - Static method in class org.marmot.framework.util.HibernateDaoUtils
getPageRoot() - Static method in class org.marmot.framework.main.FrameStyleUtils
获取当前框架风格的路径.
getPageSize() - Method in class org.marmot.security.service.PaginationSupport
getParamName() - Method in class org.marmot.framework.query.domain.QueryParameter
getParamType() - Method in class org.marmot.framework.query.domain.QueryParameter
getParamValue() - Method in class org.marmot.framework.query.domain.QueryParameter
getParameterName(String) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
getParameterNames() - Method in class org.marmot.framework.query.builder.QL
getParameterSection(String) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
getParameterValues() - Method in class org.marmot.framework.query.builder.QL
getParameters() - Method in class org.marmot.framework.query.builder.QL
getParameters() - Method in class org.marmot.framework.query.domain.Query
getParentId() - Method in class org.marmot.security.domain.ResourceCategory
getParentId() - Method in class org.marmot.security.view.Permission
getParentItemId() - Method in class org.marmot.framework.menu.domain.MenuItem
getPasswd() - Method in class org.marmot.security.domain.User
getPasswordEncoder() - Method in class org.marmot.security.manager.DefaultUserManager
getPath() - Method in class org.marmot.framework.menu.domain.MenuElement
getPattern() - Method in class org.marmot.framework.dict.domain.Field
getPermissionAccessor() - Method in class org.marmot.security.view.PermissionBackBean
getPersonId() - Method in class org.marmot.framework.security.Account
getPreferenceDefinitions() - Method in class org.marmot.framework.preference.domain.PreferenceCategory
getPreviousIndex() - Method in class org.marmot.security.service.PaginationSupport
getProperties() - Method in class org.marmot.framework.dict.domain.Field
getProperties() - Method in class org.marmot.security.filter.SimpleFilter
getProperty() - Method in class org.marmot.security.domain.RoleRes
getProxyRoles(User) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getProxyRoles(User) - Method in interface org.marmot.security.manager.UserRoleManager
getProxyRoles(User) - Method in class org.marmot.security.service.UserRoleService
getProxyRoles(DataSet) - Method in class org.marmot.security.view.ProxyBackBean
getProxyUsers() - Method in class org.marmot.security.domain.Role
getProxyUsers(User) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getProxyUsers(User) - Method in interface org.marmot.security.manager.UserRoleManager
getProxyUsers(User) - Method in class org.marmot.security.service.UserRoleService
getProxyUsers(DataSet) - Method in class org.marmot.security.view.ProxyBackBean
getProxyusersForProxyuserId() - Method in class org.marmot.security.domain.User
getProxyusersForUserId() - Method in class org.marmot.security.domain.User
getQuery() - Method in class org.marmot.framework.query.domain.QueryParameter
getQuery() - Method in class org.marmot.framework.query.domain.QuerySQL
getQuery() - Method in class org.marmot.framework.query.domain.QuerySort
getQuery() - Method in class org.marmot.framework.query.domain.QueryWhere
getQueryCategory() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getQueryName() - Method in class org.marmot.framework.query.domain.Query
getReadTime() - Method in class org.marmot.framework.message.domain.MessageReceiver
getReceivedTime() - Method in class org.marmot.framework.message.domain.MessageReceiver
getReceiver() - Method in class org.marmot.framework.message.domain.MessageReceiver
getRendererType() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getRequest() - Method in class org.marmot.framework.security.AbstractHttpAuthenticator
返回当前线程对应的HttpServletRequest对象.
getRequest() - Method in class org.marmot.framework.security.AbstractHttpCurrentAccountAccessor
返回当前线程对应的HttpServletRequest对象.
getResCategorys() - Method in class org.marmot.security.domain.Resource
getResCategorys() - Method in class org.marmot.security.domain.ResourceCategory
getResString() - Method in interface org.marmot.security.cache.ResourceDetails
资源串
getResString() - Method in class org.marmot.security.cache.SecurityResource
getResString() - Method in class org.marmot.security.domain.Resource
getResStrings() - Method in interface org.marmot.security.cache.AcegiCacheManager
获取所有的url资源
getResStrings() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
getResStrings() - Method in class org.marmot.security.cache.ResourceCache
getResType() - Method in interface org.marmot.security.cache.ResourceDetails
资源类型,如URL,FUNCTION,CONTROL
getResType() - Method in class org.marmot.security.cache.SecurityResource
getResType() - Method in class org.marmot.security.domain.Resource
getRescRoles(DataSet) - Method in class org.marmot.security.view.ResourceBackBean
getResource() - Method in class org.marmot.security.domain.ResCategory
getResource() - Method in class org.marmot.security.domain.RoleRes
getResource(String) - Method in class org.marmot.security.manager.DefaultResourceManager
getResource(String) - Method in interface org.marmot.security.manager.ResourceManager
getResourceByResString(String) - Method in class org.marmot.security.service.ResourceService
getResourceCache() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
getResourceCache() - Method in class org.marmot.security.core.MarmotAuthenticationManager
getResourceCategory(String, String) - Method in interface org.marmot.security.manager.CategoryManager
getResourceCategory(String, String) - Method in class org.marmot.security.manager.DefaultCategoryManager
getResourceCategorys() - Method in class org.marmot.security.domain.ResourceCategory
getResourceDefinitionSource() - Method in class org.marmot.security.core.MarmotAuthenticationManager
getResourceFlags() - Method in class org.marmot.security.view.Permission
getResourceIds() - Method in class org.marmot.security.view.Permission
getResourceLabels() - Method in class org.marmot.security.view.Permission
getResourceManager() - Method in class org.marmot.security.view.CategoryBackBean
getResourceManager() - Method in class org.marmot.security.view.PermissionBackBean
getResourceManager() - Method in class org.marmot.security.view.ResourceBackBean
getResourceRoles(String) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
getResourceRoles(String) - Method in interface org.marmot.security.manager.RoleResourceManager
getResources(String) - Method in interface org.marmot.security.manager.CategoryManager
getResources(String) - Method in class org.marmot.security.manager.DefaultCategoryManager
getResources(DataSet) - Method in class org.marmot.security.view.CategoryBackBean
getResources() - Method in class org.marmot.security.view.Permission
getResources(DataSet) - Method in class org.marmot.security.view.ResourceBackBean
getRole() - Method in class org.marmot.security.domain.ProxyUser
getRole() - Method in class org.marmot.security.domain.RoleRes
getRole() - Method in class org.marmot.security.domain.UserRole
getRole(String) - Method in class org.marmot.security.manager.DefaultRoleManager
getRole(String) - Method in interface org.marmot.security.manager.RoleManager
getRoleManager() - Method in class org.marmot.security.view.PermissionBackBean
getRoleManager() - Method in class org.marmot.security.view.RoleBackBean
getRoleResource(String, String) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
getRoleResource(String, String) - Method in interface org.marmot.security.manager.RoleResourceManager
getRoleResourceManager() - Method in class org.marmot.security.view.PermissionBackBean
getRoleResourceManager() - Method in class org.marmot.security.view.ResourceBackBean
getRoleResources(String) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
getRoleResources(String) - Method in interface org.marmot.security.manager.RoleResourceManager
getRoleRess() - Method in class org.marmot.security.domain.Resource
getRoleRess() - Method in class org.marmot.security.domain.Role
getRoleTemplates(String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getRoleTemplates(String) - Method in interface org.marmot.security.manager.UserRoleManager
getRoleTemplates(DataSet) - Method in class org.marmot.security.view.PermissionBackBean
getRolesByUser(User, boolean) - Method in class org.marmot.security.service.UserRoleService
getRootActors() - Method in interface org.marmot.framework.message.manager.MessageProcessor
返回根消息参与者的集合.
getRowHeight() - Method in class org.marmot.framework.profile.domain.DataTable
getRowSpan() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getSecureObjectClass() - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
getSelf() - Method in interface org.marmot.framework.message.manager.MessageProcessor
返回当前消息参与者本人.
getSendTime() - Method in class org.marmot.framework.message.domain.Message
getSender() - Method in class org.marmot.framework.message.domain.Message
getSenderName() - Method in class org.marmot.framework.message.domain.Message
getServiceUtil() - Method in class org.marmot.security.filter.FilterAccessor
getServiceUtil() - Method in class org.marmot.security.manager.DefaultResourceManager
getServiceUtil() - Method in class org.marmot.security.manager.DefaultRoleResourceManager
getServiceUtil() - Method in class org.marmot.security.view.CategoryAccessor
getSetId() - Method in class org.marmot.framework.dict.domain.Field
getSortClause() - Method in class org.marmot.framework.query.domain.QuerySQL
getSortOrder() - Method in class org.marmot.framework.dict.domain.Field
getSortOrder() - Method in class org.marmot.framework.menu.domain.MenuElement
getSortOrder() - Method in class org.marmot.framework.preference.domain.PreferenceCategory
getSortOrder() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
getSortOrder() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getSortOrder() - Method in class org.marmot.security.domain.Resource
getSortOrder() - Method in class org.marmot.security.domain.ResourceCategory
getSorts() - Method in class org.marmot.framework.query.domain.Query
getSqls() - Method in class org.marmot.framework.query.domain.Query
getStartIndex() - Method in class org.marmot.security.service.PaginationSupport
getStatusFlag() - Method in class org.marmot.security.domain.Resource
getStatusFlag() - Method in class org.marmot.security.domain.User
getString(String) - Static method in class org.marmot.framework.preference.PreferenceUtils
getString(String, String) - Static method in class org.marmot.framework.preference.PreferenceUtils
getString(Account, String) - Method in interface org.marmot.framework.preference.manager.PreferenceHandler
getSubItemCount() - Method in class org.marmot.framework.menu.domain.MenuItem
getSubItemCount() - Method in class org.marmot.security.domain.ResourceCategory
getSubItemCount() - Method in class org.marmot.security.view.Permission
getSubItems() - Method in class org.marmot.framework.menu.domain.MenuItem
getTabProperties() - Method in class org.marmot.security.filter.TabSetFilter
getTableName() - Method in class org.marmot.framework.profile.domain.DataTable
getTableName() - Method in class org.marmot.framework.query.domain.QuerySort
getTableName() - Method in class org.marmot.framework.query.domain.QueryTemplateField
getTableName() - Method in class org.marmot.framework.query.domain.QueryWhere
getTableOfField(Dataset, String) - Method in class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
getTableOfField(Dataset, String) - Method in class org.marmot.framework.query.builder.DynaSQLQueryBuilder
getTableProperties() - Method in class org.marmot.security.filter.DataTableFilter
getTabsetProperties() - Method in class org.marmot.security.filter.TabSetFilter
getTemplateFields() - Method in class org.marmot.framework.query.domain.QueryCategory
getTitle() - Method in class org.marmot.framework.dict.domain.FieldSet
getTitle() - Method in class org.marmot.framework.message.domain.Message
getTotalCount() - Method in class org.marmot.security.service.PaginationSupport
getType() - Method in class org.marmot.framework.dict.domain.Field
getType() - Method in class org.marmot.framework.menu.domain.MenuItem
getType() - Method in class org.marmot.framework.message.domain.Actor
getType() - Method in class org.marmot.framework.profile.domain.AutoFormElement
getType() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getType() - Method in class org.marmot.framework.query.domain.Query
getUnGrantedRoles(DataSet) - Method in class org.marmot.security.view.UserBackBean
getUnGrantedRolesByUserId(String, Map) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getUnGrantedRolesByUserId(String, Map) - Method in interface org.marmot.security.manager.UserRoleManager
getUnGrantedRolesByUserId(String, Map) - Method in class org.marmot.security.service.UserRoleService
获取不属于指定用户的所有角色列表
getUnGrantedUsers(DataSet) - Method in class org.marmot.security.view.RoleBackBean
getUnGrantedUsersByRoleId(String, Map) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getUnGrantedUsersByRoleId(String, Map) - Method in interface org.marmot.security.manager.UserRoleManager
getUnGrantedUsersByRoleId(String, Map) - Method in class org.marmot.security.service.UserRoleService
获取不属于指定角色的所有用户
getUnProxyRoles(DataSet) - Method in class org.marmot.security.view.ProxyBackBean
getUnProxyUsers(User) - Method in class org.marmot.security.manager.DefaultUserRoleManager
getUnProxyUsers(DataSet) - Method in class org.marmot.security.view.ProxyBackBean
getUnreadMessages(String) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
getUnreadMessages(String) - Method in interface org.marmot.framework.message.manager.MessageProcessor
返回所有当前消息参与者本人未读的信息.
getUrlResStrings() - Method in interface org.marmot.security.cache.AcegiCacheManager
获取所有的url资源
getUrlResStrings() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
获取所有的url资源
getUrlResStrings() - Method in class org.marmot.security.cache.ResourceCache
getUser() - Method in class org.marmot.security.domain.UserRole
getUser(String) - Method in class org.marmot.security.manager.DefaultUserManager
getUser(String) - Method in interface org.marmot.security.manager.UserManager
getUserByProxyUserId() - Method in class org.marmot.security.domain.ProxyUser
getUserByUserId() - Method in class org.marmot.security.domain.ProxyUser
getUserCache() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
getUserCache() - Method in class org.marmot.security.core.MarmotAuthenticationManager
getUserId() - Method in class org.marmot.framework.dict.domain.FieldSet
getUserId() - Method in class org.marmot.framework.menu.domain.Favorite
getUserId() - Method in class org.marmot.framework.preference.domain.Preference
getUserId() - Method in class org.marmot.framework.profile.domain.AutoForm
getUserId() - Method in class org.marmot.framework.profile.domain.DataTable
getUserId() - Method in class org.marmot.framework.query.domain.Query
getUserId() - Method in class org.marmot.framework.query.domain.QueryUserCategory
getUserManager() - Method in class org.marmot.security.view.ProxyBackBean
getUserManager() - Method in class org.marmot.security.view.UserBackBean
getUserRoleManager() - Method in class org.marmot.security.view.PermissionBackBean
getUserRoleManager() - Method in class org.marmot.security.view.ProxyBackBean
getUserRoleManager() - Method in class org.marmot.security.view.RoleBackBean
getUserRoleManager() - Method in class org.marmot.security.view.UserBackBean
getUserRoleService() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
getUserRoleService() - Method in class org.marmot.security.manager.DefaultRoleManager
getUserRoleService() - Method in class org.marmot.security.manager.DefaultUserManager
getUserRoleService() - Method in class org.marmot.security.manager.DefaultUserRoleManager
getUserRoleService() - Method in class org.marmot.security.service.UserService
getUserRoles() - Method in class org.marmot.security.domain.Role
getUserRoles() - Method in class org.marmot.security.domain.User
getUserService() - Method in class org.marmot.security.core.MarmotAuthenticationManager
getUsersByRole(Role, boolean) - Method in class org.marmot.security.service.UserRoleService
getValidatorFactory() - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
getValue() - Method in class org.marmot.framework.preference.domain.Preference
getViewString() - Method in class org.marmot.security.domain.ResourceCategory
getViewString() - Method in class org.marmot.security.view.Permission
getWhereClause() - Method in class org.marmot.framework.query.builder.QL
getWhereClause() - Method in class org.marmot.framework.query.domain.QuerySQL
getWhereClauseSection(QL, StringBuffer, String, String, String, Object) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
getWhereClauseSection(QL, StringBuffer, String, String, String, Object) - Method in class org.marmot.framework.query.builder.IBatisQueryBuilder
getWhereClauseString() - Method in class org.marmot.framework.query.builder.QL
getWheres() - Method in class org.marmot.framework.query.domain.Query
getWidth() - Method in class org.marmot.framework.profile.domain.AutoForm
getWidth() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
getWidth() - Method in class org.marmot.framework.profile.domain.DataTableColumn
getWidth() - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
getfilterUtils() - Method in class org.marmot.security.dorado.MarmotSecurityViewModel
grantedAll(Map, Object) - Method in class org.marmot.security.view.PermissionBackBean
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


H-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

H

HQLQueryBuilder - class org.marmot.framework.query.builder.HQLQueryBuilder.
HQLQueryBuilder() - Constructor for class org.marmot.framework.query.builder.HQLQueryBuilder
HibernateDaoUtils - class org.marmot.framework.util.HibernateDaoUtils.
HibernateDaoUtils() - Constructor for class org.marmot.framework.util.HibernateDaoUtils
hashCode() - Method in class org.marmot.security.cache.SecurityResource
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


I-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

I

IBatisQueryBuilder - class org.marmot.framework.query.builder.IBatisQueryBuilder.
IBatisQueryBuilder() - Constructor for class org.marmot.framework.query.builder.IBatisQueryBuilder
init(FilterConfig) - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
Not used (we rely on IoC container lifecycle services instead)
initBaseField(Field, Field) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
initByTemplate(Collection, Collection) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
initByTemplate(Collection, Collection) - Method in interface org.marmot.security.manager.RoleResourceManager
initByTemplate(Map, Object) - Method in class org.marmot.security.view.PermissionBackBean
根据角色模板初始化选中的角色列表权限信息
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.AutoFormFilter
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in interface org.marmot.security.filter.CategoryFilter
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.DataTableFilter
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.DatasetFilter
initCategory(String, XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.FilterUtils
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.OutlookBarFilter
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.SimpleFilter
initCategory(XmlNode, ResourceCategory, ResourceCategory, boolean) - Method in class org.marmot.security.filter.TabSetFilter
initControl(Control) - Method in class org.marmot.security.dorado.MarmotSecurityViewModel
initControl(Control) - Method in class org.marmot.security.dorado.SecurityViewModel
initControl(Object, String) - Method in class org.marmot.security.filter.AutoFormFilter
initControl(Object, String) - Method in interface org.marmot.security.filter.ControlFilter
initControl(Object, String) - Method in class org.marmot.security.filter.DataTableFilter
initControl(Object, String) - Method in class org.marmot.security.filter.DatasetFilter
initControl(Object, String) - Method in class org.marmot.security.filter.FilterUtils
initControl(Object, String) - Method in class org.marmot.security.filter.OutlookBarFilter
initControl(Object, String) - Method in class org.marmot.security.filter.SimpleFilter
initControl(Object, String) - Method in class org.marmot.security.filter.TabSetFilter
initDataset(ViewDataset) - Method in class org.marmot.security.dorado.MarmotSecurityViewModel
initDataset(ViewDataset) - Method in class org.marmot.security.dorado.SecurityViewModel
initDropDown(ViewModel, Element, String, String, String) - Static method in class org.marmot.framework.util.DropDownInitializor
initFavoriteMenuItem(Menu, MenuItem) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
将给定的菜单项初始化为收藏夹菜单.
initFavoriteTreeNode(Tree, TreeNode) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
将给定的树节点初始化为收藏夹节点.
initFormGroup(ViewModel, AutoForm, FormGroup, AutoFormGroup) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
initMenu(Menu) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化给定的菜单控件.
initMenu(Menu, String) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化给定的菜单控件.
initMenu(Menu, String, MenuItemContainer) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化给定的菜单控件.
initMenu(Menu, List, MenuItemContainer) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化给定的菜单控件.
initMenuForOutlookBar(Menu) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化用于绑定OutlookBar的菜单控件.
initMenuForOutlookBar(Menu, String) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化用于绑定OutlookBar的菜单控件.
initMenuForOutlookBar(Menu, List) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
初始化用于绑定OutlookBar的菜单控件.
initParameters(QL, ParameterSet) - Method in class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
initProfileSupportedAutoForm(ViewModel, AutoForm, String) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
initProfileSupportedDataTable(ViewModel, DataTable, String) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
initProperties() - Method in class org.marmot.security.filter.AutoFormFilter
initProperties() - Method in class org.marmot.security.filter.DataTableFilter
initProperties() - Method in class org.marmot.security.filter.DatasetFilter
initProperties() - Method in class org.marmot.security.filter.OutlookBarFilter
initProperties() - Method in class org.marmot.security.filter.SimpleFilter
initProperties() - Method in class org.marmot.security.filter.TabSetFilter
initResource(ResourceCategory, String, String) - Method in class org.marmot.security.filter.FilterAccessor
initResourceCache() - Method in interface org.marmot.security.cache.AcegiCacheManager
初始化resourceCache
initResourceCache() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
初始化resourceCache
initResourceCategory(ResourceCategory, Resource) - Method in class org.marmot.security.filter.FilterAccessor
initResourceCategory(ResourceCategory, Resource) - Method in class org.marmot.security.filter.FilterUtils
initTree(Tree, int) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
将给定树状列表控件初始化为导航菜单树.
initTree(Tree, String, int) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
将给定树状列表控件初始化为导航菜单树.
initTree(Tree, String, TreeNode, int) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
将给定树状列表控件初始化为导航菜单树.
initTree(Tree, List, TreeNode, int) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
将给定树状列表控件初始化为导航菜单树.
initUserCache() - Method in interface org.marmot.security.cache.AcegiCacheManager
初始化userCache
initUserCache() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
初始化userCache
initViewField(ViewModel, ViewField, Field) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
根据数据字典信息初始化一个Dorado中的ViewField对象.
insertResource(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
insertResource(Map, Object) - Method in class org.marmot.security.view.ResourceBackBean
insertRole(Map, Object) - Method in class org.marmot.security.view.RoleBackBean
insertUser(Map, Object) - Method in class org.marmot.security.view.UserBackBean
internalExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractDynaQueryBuilder
internalExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractQLQueryBuilder
internalExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
internalExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.DynaSQLQueryBuilder
invoke(MethodInvocation) - Method in class org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor
invoke(FilterInvocation) - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
isAllowIfResourceNotGranted() - Method in class org.marmot.security.core.MarmotAuthenticationManager
isAllowPublicInvocations() - Method in class org.marmot.security.core.MarmotAuthenticationManager
isAuthorized(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isAuthorized(Account, Object) - Method in interface org.marmot.framework.security.Authorizer
根据传入的帐号信息和资源项进行权限验证,并返回逻辑值表示该帐号是否有权访问这一资源.
isAuthorized(Object) - Static method in class org.marmot.framework.security.SecurityUtils
isAutoCreateColumns() - Method in class org.marmot.security.filter.AutoFormFilter
isAutoCreateColumns() - Method in class org.marmot.security.filter.DataTableFilter
isBracketAfter() - Method in class org.marmot.framework.query.domain.QueryWhere
isBracketBefore() - Method in class org.marmot.framework.query.domain.QueryWhere
isColumnDraggable() - Method in class org.marmot.framework.profile.domain.DataTable
isConvertUrlToLowercaseBeforeComparison() - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
isDesc() - Method in class org.marmot.framework.query.domain.QuerySort
isDisabled(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isEnabled(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isEnabled() - Method in class org.marmot.framework.menu.domain.MenuItem
isExpanded() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
isFilterable() - Method in class org.marmot.framework.profile.domain.DataTableColumn
isGroupable() - Method in class org.marmot.framework.profile.domain.DataTableColumn
isIgnored(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isLoggedIn() - Method in interface org.marmot.framework.security.CurrentAccountAccessor
返回系统当前是否已登录.
isLoggedIn() - Static method in class org.marmot.framework.security.SecurityUtils
isMatch(String, String) - Method in class org.marmot.security.definition.ResourceDefinitionSource
isMatch(Class, Method, String) - Static method in class org.marmot.security.intercept.method.DBMethodDefinitionSource
Return if the given method name matches the mapped name.
isMatch(String, String) - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
isNotAuthorized(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isObserveOncePerRequest() - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
Indicates whether once-per-request handling will be observed.
isOverwritable() - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
isRead() - Method in class org.marmot.framework.message.domain.MessageReceiver
isReadOnly() - Method in class org.marmot.framework.dict.domain.Field
isReadOnly(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isReadOnly() - Method in class org.marmot.framework.profile.domain.DataTable
isReadOnly() - Method in class org.marmot.framework.profile.domain.DataTableColumn
isReceived() - Method in class org.marmot.framework.message.domain.MessageReceiver
isRequired() - Method in class org.marmot.framework.dict.domain.Field
isResizable() - Method in class org.marmot.framework.profile.domain.DataTableColumn
isRoot() - Method in class org.marmot.security.domain.User
isSendEmail() - Method in class org.marmot.framework.message.domain.Message
isShowBevel() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
isShowFilterBar() - Method in class org.marmot.framework.profile.domain.DataTable
isShowFooter() - Method in class org.marmot.framework.profile.domain.DataTable
isShowLabel() - Method in class org.marmot.framework.profile.domain.AutoFormElement
isUseAntPath() - Method in class org.marmot.security.definition.ResourceDefinitionSource
isUseAntPath() - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
isVisible() - Method in class org.marmot.framework.dict.domain.Field
isVisible(Object) - Method in class org.marmot.framework.dorado.SecurityExprHandler
isVisible() - Method in class org.marmot.framework.menu.domain.MenuItem
isVisible() - Method in class org.marmot.framework.profile.domain.AutoFormElement
isVisible() - Method in class org.marmot.framework.profile.domain.AutoFormGroup
isVisible() - Method in class org.marmot.framework.profile.domain.DataTableColumn
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


J-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

J

JCaptchaImageProcessor - class org.marmot.framework.security.captcha.JCaptchaImageProcessor.
JCaptchaImageProcessor() - Constructor for class org.marmot.framework.security.captcha.JCaptchaImageProcessor
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


L-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

L

LazyMenuFactory - interface org.marmot.framework.menu.factory.LazyMenuFactory.
懒装载的动态菜单工厂的接口.
LazyMenuHelper - class org.marmot.framework.menu.view.LazyMenuHelper.
用于创建支持懒装载的菜单控件的辅助类.
LazyMenuHelper() - Constructor for class org.marmot.framework.menu.view.LazyMenuHelper
ListableAuthorizer - interface org.marmot.framework.security.ListableAuthorizer.
load(Class, Serializable) - Method in class org.marmot.security.service.ServiceUtil
loadMenu(String, String) - Method in class org.marmot.security.view.CategoryAccessor
loadProperties(DataSet) - Method in class org.marmot.security.view.ProxyBackBean
loadSecurityUserByUsername(String) - Method in class org.marmot.security.service.UserService
loadUserByUsername(String) - Method in class org.marmot.security.service.UserService
loadView(ResourceCategory, boolean) - Method in class org.marmot.security.view.CategoryAccessor
login(String, String, Object) - Method in interface org.marmot.framework.security.Authenticator
登录系统.
login(String, String) - Static method in class org.marmot.security.util.SecurityUtils
登录。
logout() - Method in interface org.marmot.framework.security.Authenticator
注销
logout() - Static method in class org.marmot.security.util.SecurityUtils
登出,并清空权限系统中登陆用户的信息。
lookupAttributes(String) - Method in class org.marmot.security.definition.ResourceDefinitionSource
lookupAttributes(Class, Method) - Method in class org.marmot.security.intercept.method.DBMethodDefinitionSource
从resourceCache中获取当前方法对应的ResourceDetailsResourceDetails 最后返回由Role Name 组装成的ConfigAttributeDefinition(@link ConfigAttributeDefinition)
lookupAttributes(String) - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
返回当前URL对应的ROLE
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


M-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

M

MENU_ITEM - Static variable in class org.marmot.framework.menu.domain.MenuItem
MarmotAuthenticationManager - class org.marmot.security.core.MarmotAuthenticationManager.
MarmotAuthenticationManager() - Constructor for class org.marmot.security.core.MarmotAuthenticationManager
MarmotDictionaryFactory - class org.marmot.framework.dict.factory.MarmotDictionaryFactory.
默认的数据字典工厂的实现类.
MarmotDictionaryFactory() - Constructor for class org.marmot.framework.dict.factory.MarmotDictionaryFactory
MarmotMenuFactory - class org.marmot.framework.menu.factory.MarmotMenuFactory.
默认的动态菜单工厂的实现类.
MarmotMenuFactory() - Constructor for class org.marmot.framework.menu.factory.MarmotMenuFactory
MarmotMethodAccessDeniedException - exception org.marmot.security.exception.MarmotMethodAccessDeniedException.
MarmotMethodAccessDeniedException(String, Throwable) - Constructor for class org.marmot.security.exception.MarmotMethodAccessDeniedException
MarmotMethodSecurityInterceptor - class org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor.
MarmotMethodSecurityInterceptor() - Constructor for class org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor
MarmotSecurityViewModel - class org.marmot.security.dorado.MarmotSecurityViewModel.
提供权限过滤功能的视图模型实现类(继承自MarmotViewModel)
MarmotSecurityViewModel() - Constructor for class org.marmot.security.dorado.MarmotSecurityViewModel
MenuElement - class org.marmot.framework.menu.domain.MenuElement.
菜单元素模型的抽象类.
MenuElement() - Constructor for class org.marmot.framework.menu.domain.MenuElement
MenuFactory - interface org.marmot.framework.menu.factory.MenuFactory.
菜单工厂的接口.
MenuItem - class org.marmot.framework.menu.domain.MenuItem.
菜单项的域模型.
MenuItem() - Constructor for class org.marmot.framework.menu.domain.MenuItem
Message - class org.marmot.framework.message.domain.Message.
消息的域模型.
Message() - Constructor for class org.marmot.framework.message.domain.Message
MessageProcessor - interface org.marmot.framework.message.manager.MessageProcessor.
实时消息处理器的接口.
MessageReceiver - class org.marmot.framework.message.domain.MessageReceiver.
消息接受者的域模型.
MessageReceiver() - Constructor for class org.marmot.framework.message.domain.MessageReceiver
mergeMenu(MenuItemContainer) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将根菜单模型融合进指定的菜单控件或菜单项中.
mergeMenu(MenuItemContainer, String) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单模型融合进指定的菜单控件或菜单项中.
mergeMenu(MenuItemContainer, List) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单项模型集合融合进指定的菜单控件或菜单项中.
mergeMenu(MenuItemContainer, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将根菜单模型中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.
mergeMenu(MenuItemContainer, String, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单模型中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.
mergeMenu(MenuItemContainer, List, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单项模型集合中深度小于depth参数值的子菜单项模型融合进指定的菜单控件或菜单项中.
mergeTabSet(TabSet) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将根菜单模型融合进指定的多页标签控件中.
mergeTabSet(TabSet, String) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单模型融合进指定的多页标签控件中.
mergeTabSet(TabSet, List) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单项模型集合融合进指定的多页标签控件中.
mergeTree(TreeNode, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将根菜单模型融合进指定的树节点中.
mergeTree(TreeNode, String, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单模型融合进指定的树节点中.
mergeTree(TreeNode, List, int) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
将给定的菜单项模型集合融合进指定的树节点中.
modifyResourceInCache(Resource, String) - Method in interface org.marmot.security.cache.AcegiCacheManager
修改resource信息时,更新系统缓存中的权限资源信息
modifyResourceInCache(Resource, String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
修改Resource时更改resourceCache
modifyRoleInCache(Role, String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
修改Role时同时修改userCache和resourceCache
modifyUserInCache(User, String) - Method in interface org.marmot.security.cache.AcegiCacheManager
修改User时更改userCache?
modifyUserInCache(User, String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
修改User时更改userCache
modifyUserInCache(Object) - Method in class org.marmot.security.view.UserBackBean
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


O-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

O

OutlookBarFilter - class org.marmot.security.filter.OutlookBarFilter.
OutlookBarFilter() - Constructor for class org.marmot.security.filter.OutlookBarFilter
obtainObjectDefinitionSource() - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
org.marmot.framework.dict.domain - package org.marmot.framework.dict.domain
数据字典工厂相关的域模型对象.
org.marmot.framework.dict.factory - package org.marmot.framework.dict.factory
数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view - package org.marmot.framework.dict.view
org.marmot.framework.dorado - package org.marmot.framework.dorado
Marmot Framework提供的Dorado扩展.
org.marmot.framework.main - package org.marmot.framework.main
应用主框架的相关实现.
org.marmot.framework.menu.domain - package org.marmot.framework.menu.domain
动态菜单工厂相关的域模型对象.
org.marmot.framework.menu.factory - package org.marmot.framework.menu.factory
动态菜单工厂的接口及相关实现.
org.marmot.framework.menu.view - package org.marmot.framework.menu.view
动态菜单工厂的视图层实现.
org.marmot.framework.message.domain - package org.marmot.framework.message.domain
实时消息功能相关的域模型对象.
org.marmot.framework.message.manager - package org.marmot.framework.message.manager
实时消息功能的的管理类和维护类.
org.marmot.framework.preference - package org.marmot.framework.preference
系统属性功能的扩展接口及相关实现.
org.marmot.framework.preference.domain - package org.marmot.framework.preference.domain
系统属性功能相关的域模型对象.
org.marmot.framework.preference.manager - package org.marmot.framework.preference.manager
org.marmot.framework.profile.domain - package org.marmot.framework.profile.domain
org.marmot.framework.profile.view - package org.marmot.framework.profile.view
org.marmot.framework.query.builder - package org.marmot.framework.query.builder
org.marmot.framework.query.domain - package org.marmot.framework.query.domain
org.marmot.framework.query.view - package org.marmot.framework.query.view
org.marmot.framework.security - package org.marmot.framework.security
权限功能的扩展接口及相关实现.
org.marmot.framework.security.captcha - package org.marmot.framework.security.captcha
org.marmot.framework.util - package org.marmot.framework.util
Marmot Framework的工具类.
org.marmot.security.cache - package org.marmot.security.cache
org.marmot.security.core - package org.marmot.security.core
org.marmot.security.definition - package org.marmot.security.definition
org.marmot.security.domain - package org.marmot.security.domain
org.marmot.security.dorado - package org.marmot.security.dorado
org.marmot.security.exception - package org.marmot.security.exception
org.marmot.security.filter - package org.marmot.security.filter
org.marmot.security.intercept.method - package org.marmot.security.intercept.method
org.marmot.security.intercept.method.aopalliance - package org.marmot.security.intercept.method.aopalliance
org.marmot.security.intercept.web - package org.marmot.security.intercept.web
org.marmot.security.manager - package org.marmot.security.manager
org.marmot.security.service - package org.marmot.security.service
org.marmot.security.util - package org.marmot.security.util
org.marmot.security.view - package org.marmot.security.view
outputCaptcha(HttpServletRequest, HttpServletResponse) - Method in interface org.marmot.framework.security.captcha.CaptchaProcessor
向response中输出验证码的人机识别测试信息(completely automated public Turing test to tell computers and humans apart).
outputCaptcha(HttpServletRequest, HttpServletResponse) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


P-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

P

PAGESIZE - Static variable in class org.marmot.security.service.PaginationSupport
PERSON - Static variable in class org.marmot.framework.message.domain.Actor
PaginationSupport - class org.marmot.security.service.PaginationSupport.
PaginationSupport(List, int) - Constructor for class org.marmot.security.service.PaginationSupport
PaginationSupport(List, int, int) - Constructor for class org.marmot.security.service.PaginationSupport
PaginationSupport(List, int, int, int) - Constructor for class org.marmot.security.service.PaginationSupport
Permission - class org.marmot.security.view.Permission.
Permission() - Constructor for class org.marmot.security.view.Permission
PermissionAccessor - class org.marmot.security.view.PermissionAccessor.
PermissionAccessor() - Constructor for class org.marmot.security.view.PermissionAccessor
PermissionBackBean - class org.marmot.security.view.PermissionBackBean.
PermissionBackBean() - Constructor for class org.marmot.security.view.PermissionBackBean
Preference - class org.marmot.framework.preference.domain.Preference.
Preference() - Constructor for class org.marmot.framework.preference.domain.Preference
Preference(String, String, String) - Constructor for class org.marmot.framework.preference.domain.Preference
PreferenceCategory - class org.marmot.framework.preference.domain.PreferenceCategory.
PreferenceCategory() - Constructor for class org.marmot.framework.preference.domain.PreferenceCategory
PreferenceDefinition - class org.marmot.framework.preference.domain.PreferenceDefinition.
PreferenceDefinition() - Constructor for class org.marmot.framework.preference.domain.PreferenceDefinition
PreferenceHandler - interface org.marmot.framework.preference.manager.PreferenceHandler.
PreferenceUtils - class org.marmot.framework.preference.PreferenceUtils.
PreferenceUtils() - Constructor for class org.marmot.framework.preference.PreferenceUtils
PreferencesExprContextMap - class org.marmot.framework.dorado.PreferencesExprContextMap.
PreferencesExprContextMap() - Constructor for class org.marmot.framework.dorado.PreferencesExprContextMap
PropertiesInfo - class org.marmot.security.filter.PropertiesInfo.
PropertiesInfo() - Constructor for class org.marmot.security.filter.PropertiesInfo
ProxyBackBean - class org.marmot.security.view.ProxyBackBean.
ProxyBackBean() - Constructor for class org.marmot.security.view.ProxyBackBean
ProxyUser - class org.marmot.security.domain.ProxyUser.
Proxyuser generated by hbm2java
ProxyUser() - Constructor for class org.marmot.security.domain.ProxyUser
ProxyUser(String) - Constructor for class org.marmot.security.domain.ProxyUser
packPermissions(String, List) - Method in class org.marmot.security.view.PermissionAccessor
parseQuery(ParameterSet) - Method in class org.marmot.framework.query.view.QueryDatasetListener
persist(Object) - Method in class org.marmot.security.service.ServiceUtil
proxyRoles(User, User, Collection, Date, Date) - Method in class org.marmot.security.manager.DefaultUserRoleManager
proxyRoles(User, User, Collection, Date, Date) - Method in interface org.marmot.security.manager.UserRoleManager
putAuthorityInCache(ResourceDetails) - Method in class org.marmot.security.cache.ResourceCache
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


Q-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

Q

QL - class org.marmot.framework.query.builder.QL.
QL() - Constructor for class org.marmot.framework.query.builder.QL
QLUtils - class org.marmot.framework.query.builder.QLUtils.
QLUtils() - Constructor for class org.marmot.framework.query.builder.QLUtils
Query - class org.marmot.framework.query.domain.Query.
Query() - Constructor for class org.marmot.framework.query.domain.Query
QueryBuilder - interface org.marmot.framework.query.builder.QueryBuilder.
QueryCategory - class org.marmot.framework.query.domain.QueryCategory.
QueryCategory() - Constructor for class org.marmot.framework.query.domain.QueryCategory
QueryDatasetListener - class org.marmot.framework.query.view.QueryDatasetListener.
QueryDatasetListener() - Constructor for class org.marmot.framework.query.view.QueryDatasetListener
QueryParameter - class org.marmot.framework.query.domain.QueryParameter.
QueryParameter() - Constructor for class org.marmot.framework.query.domain.QueryParameter
QuerySQL - class org.marmot.framework.query.domain.QuerySQL.
QuerySQL() - Constructor for class org.marmot.framework.query.domain.QuerySQL
QuerySort - class org.marmot.framework.query.domain.QuerySort.
QuerySort() - Constructor for class org.marmot.framework.query.domain.QuerySort
QueryTemplateField - class org.marmot.framework.query.domain.QueryTemplateField.
QueryTemplateField() - Constructor for class org.marmot.framework.query.domain.QueryTemplateField
QueryUserCategory - class org.marmot.framework.query.domain.QueryUserCategory.
QueryUserCategory() - Constructor for class org.marmot.framework.query.domain.QueryUserCategory
QueryWhere - class org.marmot.framework.query.domain.QueryWhere.
QueryWhere() - Constructor for class org.marmot.framework.query.domain.QueryWhere
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


R-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

R

RESOURCE_CONTROL - Static variable in class org.marmot.security.cache.ResourceCache
RESOURCE_METHOD - Static variable in class org.marmot.security.cache.ResourceCache
RESOURCE_URL - Static variable in class org.marmot.security.cache.ResourceCache
ResCategory - class org.marmot.security.domain.ResCategory.
ResPermistype generated by hbm2java
ResCategory() - Constructor for class org.marmot.security.domain.ResCategory
ResCategory(String) - Constructor for class org.marmot.security.domain.ResCategory
ResCategory(String, ResourceCategory, Resource) - Constructor for class org.marmot.security.domain.ResCategory
Resource - class org.marmot.security.domain.Resource.
Resource generated by hbm2java
Resource() - Constructor for class org.marmot.security.domain.Resource
Resource(String) - Constructor for class org.marmot.security.domain.Resource
ResourceBackBean - class org.marmot.security.view.ResourceBackBean.
ResourceBackBean() - Constructor for class org.marmot.security.view.ResourceBackBean
ResourceCache - class org.marmot.security.cache.ResourceCache.
Caches Resource objects using a Spring IoC defined EHCACHE.
ResourceCache() - Constructor for class org.marmot.security.cache.ResourceCache
ResourceCategory - class org.marmot.security.domain.ResourceCategory.
RescType generated by hbm2java
ResourceCategory() - Constructor for class org.marmot.security.domain.ResourceCategory
ResourceCategory(String) - Constructor for class org.marmot.security.domain.ResourceCategory
ResourceCategoryService - class org.marmot.security.service.ResourceCategoryService.
ResourceCategoryService() - Constructor for class org.marmot.security.service.ResourceCategoryService
ResourceDefinitionSource - class org.marmot.security.definition.ResourceDefinitionSource.
在resourceCache中保存每个方法对应的ResourceDetails
ResourceDefinitionSource() - Constructor for class org.marmot.security.definition.ResourceDefinitionSource
ResourceDetails - interface org.marmot.security.cache.ResourceDetails.
提供资源信息
ResourceManager - interface org.marmot.security.manager.ResourceManager.
ResourceService - class org.marmot.security.service.ResourceService.
ResourceService() - Constructor for class org.marmot.security.service.ResourceService
Role - class org.marmot.security.domain.Role.
Role generated by hbm2java
Role() - Constructor for class org.marmot.security.domain.Role
Role(String) - Constructor for class org.marmot.security.domain.Role
RoleBackBean - class org.marmot.security.view.RoleBackBean.
RoleBackBean() - Constructor for class org.marmot.security.view.RoleBackBean
RoleManager - interface org.marmot.security.manager.RoleManager.
RoleRes - class org.marmot.security.domain.RoleRes.
RolePermi generated by hbm2java
RoleRes() - Constructor for class org.marmot.security.domain.RoleRes
RoleRes(String, Role) - Constructor for class org.marmot.security.domain.RoleRes
RoleResourceManager - interface org.marmot.security.manager.RoleResourceManager.
refreshResourceCache() - Method in interface org.marmot.security.cache.AcegiCacheManager
刷新resourceCache
refreshResourceCache() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
refreshResourceCache(Object) - Method in class org.marmot.security.view.ResourceBackBean
refreshUserCache() - Method in interface org.marmot.security.cache.AcegiCacheManager
刷新userCache
refreshUserCache() - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
refreshUserCache(Object) - Method in class org.marmot.security.view.ResourceBackBean
refreshUserCache(Object) - Method in class org.marmot.security.view.UserBackBean
removeAllCategory(ResourceCategory) - Method in class org.marmot.security.view.CategoryAccessor
removeAllCategory(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
removeAllWithSubItems(String, ResourceCategory) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
removeAllWithSubItems(String, ResourceCategory) - Method in interface org.marmot.security.manager.RoleResourceManager
removeAuthorityFromCache(String) - Method in class org.marmot.security.cache.ResourceCache
removeCategory(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
removeProxyUser(User, User) - Method in class org.marmot.security.manager.DefaultUserRoleManager
removeProxyUser(User, User, Role) - Method in class org.marmot.security.manager.DefaultUserRoleManager
removeProxyUser(User, User) - Method in interface org.marmot.security.manager.UserRoleManager
removeProxyUser(Map, Object) - Method in class org.marmot.security.view.ProxyBackBean
removeResource(Map, Object) - Method in class org.marmot.security.view.ResourceBackBean
removeResourceInCache(String) - Method in interface org.marmot.security.cache.AcegiCacheManager
删除resource信息时,更新系统缓存中的权限资源信息
removeResourceInCache(String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
删除Resource时删除resourceCache
removeRole(String, String) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
removeRole(String, String) - Method in interface org.marmot.security.manager.RoleResourceManager
removeRole(Map, Object) - Method in class org.marmot.security.view.ResourceBackBean
removeRole(Map, Object) - Method in class org.marmot.security.view.RoleBackBean
removeRoleProxyUser(String, String) - Method in class org.marmot.security.service.UserRoleService
removeUser(Map, Object) - Method in class org.marmot.security.view.UserBackBean
removeUserInCache(String) - Method in interface org.marmot.security.cache.AcegiCacheManager
删除User时更改userCache?
removeUserInCache(String) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
删除User时更改userCache
removeUserProxyRole(String, String) - Method in class org.marmot.security.service.UserRoleService
removeUserRole(String, String) - Method in class org.marmot.security.manager.DefaultUserRoleManager
removeUserRole(String, String) - Method in interface org.marmot.security.manager.UserRoleManager
removeUserRole(Map, Object) - Method in class org.marmot.security.view.RoleBackBean
removeUserRole(Map, Object) - Method in class org.marmot.security.view.UserBackBean
replaceClauses(String, String, String) - Static method in class org.marmot.framework.query.builder.QLUtils
replaceClauses(String, QL) - Static method in class org.marmot.framework.query.builder.QLUtils
replaceClauses(SqlDataset, String, String) - Static method in class org.marmot.framework.query.builder.QLUtils
replaceClauses(SqlDataset, QL) - Static method in class org.marmot.framework.query.builder.QLUtils
replaceOrderByClause(String, String) - Static method in class org.marmot.framework.query.builder.QLUtils
replaceWhereClause(String, String) - Static method in class org.marmot.framework.query.builder.QLUtils
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


S-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

S

SEPERATOR - Static variable in class org.marmot.framework.menu.domain.MenuItem
SQLQueryBuilder - class org.marmot.framework.query.builder.SQLQueryBuilder.
SQLQueryBuilder() - Constructor for class org.marmot.framework.query.builder.SQLQueryBuilder
SecurityExprHandler - class org.marmot.framework.dorado.SecurityExprHandler.
SecurityExprHandler() - Constructor for class org.marmot.framework.dorado.SecurityExprHandler
SecurityResource - class org.marmot.security.cache.SecurityResource.
ResourceDetails的实现类
SecurityResource(String, String, GrantedAuthority[]) - Constructor for class org.marmot.security.cache.SecurityResource
SecurityUtils - class org.marmot.framework.security.SecurityUtils.
SecurityUtils() - Constructor for class org.marmot.framework.security.SecurityUtils
SecurityUtils - class org.marmot.security.util.SecurityUtils.
权限验证工具类
SecurityViewModel - class org.marmot.security.dorado.SecurityViewModel.
提供权限过滤功能的视图模型实现类(继承自DynaViewModel)
SecurityViewModel() - Constructor for class org.marmot.security.dorado.SecurityViewModel
ServiceUtil - class org.marmot.security.service.ServiceUtil.
ServiceUtil() - Constructor for class org.marmot.security.service.ServiceUtil
SimpleFilter - class org.marmot.security.filter.SimpleFilter.
SimpleFilter() - Constructor for class org.marmot.security.filter.SimpleFilter
StandardQueryBuilder - class org.marmot.framework.query.builder.StandardQueryBuilder.
StandardQueryBuilder() - Constructor for class org.marmot.framework.query.builder.StandardQueryBuilder
save(Object) - Method in class org.marmot.security.manager.DefaultUserRoleManager
save(ResourceCategory) - Method in class org.marmot.security.service.ResourceCategoryService
save(Object) - Method in class org.marmot.security.service.ServiceUtil
saveAll(Map, Object) - Method in class org.marmot.security.view.PermissionBackBean
saveAllWithSubItems(String, ResourceCategory) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
saveAllWithSubItems(String, ResourceCategory) - Method in interface org.marmot.security.manager.RoleResourceManager
saveAutoForm(String, AutoForm) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
saveByMenu(Object) - Method in class org.marmot.security.view.CategoryBackBean
saveByView(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
saveCategory(ResourceCategory) - Method in interface org.marmot.security.manager.CategoryManager
saveCategory(ResourceCategory) - Method in class org.marmot.security.manager.DefaultCategoryManager
saveCategory(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
saveDataTable(String, DataTable) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
saveOrUpdate(Object) - Method in class org.marmot.security.manager.DefaultUserRoleManager
saveOrUpdate(Object) - Method in class org.marmot.security.service.ServiceUtil
saveResource(Resource) - Method in class org.marmot.security.manager.DefaultResourceManager
saveResource(Resource) - Method in interface org.marmot.security.manager.ResourceManager
saveResourceCategory(ResCategory) - Method in interface org.marmot.security.manager.CategoryManager
saveResourceCategory(ResCategory) - Method in class org.marmot.security.manager.DefaultCategoryManager
saveRole(Role) - Method in class org.marmot.security.manager.DefaultRoleManager
saveRole(Role) - Method in class org.marmot.security.manager.DefaultUserRoleManager
saveRole(Role) - Method in interface org.marmot.security.manager.RoleManager
saveRoleResource(RoleRes) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
saveRoleResource(RoleRes) - Method in interface org.marmot.security.manager.RoleResourceManager
saveUser(User) - Method in class org.marmot.security.manager.DefaultUserManager
saveUser(User) - Method in interface org.marmot.security.manager.UserManager
sendMail(Message, Actor, Collection) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
向所有消息接收者发送EMail.
sendMessage(Message, Actor, Set) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
sendMessage(Message, Actor, Set) - Method in interface org.marmot.framework.message.manager.MessageProcessor
发送消息
setAcegiAuthenticationManager(AuthenticationManager) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setAcegiCacheManager(AcegiCacheManager) - Method in class org.marmot.security.definition.ResourceDefinitionSource
setAcegiCacheManager(AcegiCacheManager) - Method in class org.marmot.security.intercept.method.DBMethodDefinitionSource
setAcegiCacheManager(AcegiCacheManager) - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
setActiveTime(Date) - Method in class org.marmot.security.domain.ProxyUser
setAllowIfResourceNotGranted(boolean) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setAllowPublicInvocations(boolean) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setAttribute(String, Object) - Method in class org.marmot.framework.security.Account
setAuthFailureValue(String) - Method in class org.marmot.security.filter.PropertiesInfo
setAuthLabel(String) - Method in class org.marmot.security.filter.PropertiesInfo
setAuthSuccessValue(String) - Method in class org.marmot.security.filter.PropertiesInfo
setAuthenticationDetailsSource(AuthenticationDetailsSource) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setAuthorities(GrantedAuthority[]) - Method in class org.marmot.security.cache.SecurityResource
setAuthorizer(Authorizer) - Method in class org.marmot.framework.security.SecurityUtils
setAutoCreateColumns(boolean) - Method in class org.marmot.security.filter.AutoFormFilter
setAutoCreateColumns(boolean) - Method in class org.marmot.security.filter.DataTableFilter
setAutoFormProfileManager(AutoFormProfileManager) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
setBoolean(String, boolean) - Static method in class org.marmot.framework.preference.PreferenceUtils
setBracketAfter(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setBracketBefore(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setCache(Cache) - Method in class org.marmot.security.cache.ResourceCache
setCacheManager(AcegiCacheManager) - Method in class org.marmot.security.view.ResourceBackBean
setCacheManager(AcegiCacheManager) - Method in class org.marmot.security.view.UserBackBean
setCategory(String) - Method in class org.marmot.framework.query.domain.Query
setCategory(String) - Method in class org.marmot.framework.query.domain.QueryCategory
setCategory(QueryCategory) - Method in class org.marmot.framework.query.domain.QueryUserCategory
setCategory(ResourceCategory) - Method in class org.marmot.security.domain.ResCategory
setCategoryAccessor(CategoryAccessor) - Method in class org.marmot.security.view.CategoryBackBean
setCategoryId(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setCategoryManager(CategoryManager) - Method in class org.marmot.security.view.CategoryBackBean
setCategoryManager(CategoryManager) - Method in class org.marmot.security.view.PermissionAccessor
setCategoryManager(CategoryManager) - Method in class org.marmot.security.view.PermissionBackBean
setCategoryService(ResourceCategoryService) - Method in class org.marmot.security.manager.DefaultCategoryManager
setCategoryType(String) - Method in class org.marmot.security.domain.ResourceCategory
setCategoryType(String) - Method in class org.marmot.security.view.Permission
setCharNumber(int) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
setChars(String) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
setColSpan(int) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setColumnCount(int) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setColumnDraggable(boolean) - Method in class org.marmot.framework.profile.domain.DataTable
setColumnProperties(Map) - Method in class org.marmot.security.filter.AutoFormFilter
setColumnProperties(Map) - Method in class org.marmot.security.filter.DataTableFilter
setColumns(List) - Method in class org.marmot.framework.profile.domain.DataTable
setCompareOp(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setCompareValue(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setControlAlign(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setControlHeight(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setControlStyle(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setControlVAlign(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setControlWidth(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setControlsMap(Map) - Method in class org.marmot.security.filter.FilterUtils
setConvertUrlToLowercaseBeforeComparison(boolean) - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
setCurrentAccountAccessor(CurrentAccountAccessor) - Method in class org.marmot.framework.security.SecurityUtils
setCustomControlId(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setDataTableProfileManager(DataTableProfileManager) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
setDataType(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setDatasetProperties(Map) - Method in class org.marmot.security.filter.DatasetFilter
setDefaultCategoryFilter(CategoryFilter) - Method in class org.marmot.security.filter.FilterUtils
setDefaultControlFilter(ControlFilter) - Method in class org.marmot.security.filter.FilterUtils
setDefaultControlWidth(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setDefaultControlWidth(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setDefaultElementMargin(int) - Method in class org.marmot.framework.profile.domain.AutoForm
setDefaultLabelWidth(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setDefaultQueryId(String) - Method in class org.marmot.framework.query.domain.QueryCategory
setDefaultQueryId(String) - Method in class org.marmot.framework.query.domain.QueryUserCategory
setDefaultValue(String) - Method in class org.marmot.framework.dict.domain.Field
setDesc(boolean) - Method in class org.marmot.framework.query.domain.QuerySort
setDescn(String) - Method in class org.marmot.security.domain.Resource
setDescn(String) - Method in class org.marmot.security.domain.ResourceCategory
setDescn(String) - Method in class org.marmot.security.domain.Role
setDescn(String) - Method in class org.marmot.security.domain.User
setDescn(String) - Method in class org.marmot.security.view.Permission
setDescription(String) - Method in class org.marmot.framework.dict.domain.Field
setDescription(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setDescription(String) - Method in class org.marmot.framework.message.domain.Actor
setDescription(String) - Method in class org.marmot.framework.preference.domain.PreferenceCategory
setDescription(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setDictionaryFactory(DictionaryFactory) - Method in class org.marmot.framework.dict.view.DictionaryDatasetListener
setDictionaryManager(DictionaryManager) - Method in class org.marmot.framework.dict.factory.MarmotDictionaryFactory
setDisableIcon(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setDisplayCompareValue(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setDormantTime(Date) - Method in class org.marmot.security.domain.ProxyUser
setDouble(String, double) - Static method in class org.marmot.framework.preference.PreferenceUtils
setDropDownMeta(String) - Method in class org.marmot.framework.dict.domain.Field
setDropDownMeta(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setDropDownMeta(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setDropDownMeta(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setDropDownMeta(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setDropDownScript(String) - Method in class org.marmot.framework.dict.domain.Field
setDropDownScript(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setDropDownScript(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setDropDownScript(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setDropDownScript(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setDropDownType(String) - Method in class org.marmot.framework.dict.domain.Field
setDropDownType(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setDropDownType(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setDropDownType(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setDropDownType(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setEditorType(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setEditorType(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setElementMargin(int) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setElements(List) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setEmail(String) - Method in class org.marmot.framework.message.domain.Actor
setEnabled(boolean) - Method in class org.marmot.framework.menu.domain.MenuItem
setExpanded(boolean) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setFavoriteManager(FavoriteManager) - Method in class org.marmot.framework.menu.factory.MarmotMenuFactory
setField(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setField(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setFieldDescription(String) - Method in class org.marmot.framework.query.domain.QuerySort
setFieldDescription(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setFieldLabel(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setFieldName(String) - Method in class org.marmot.framework.query.domain.QuerySort
setFieldName(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setFieldName(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setFieldProperties(Map) - Method in class org.marmot.security.filter.DatasetFilter
setFieldType(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setFieldType(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setFields(List) - Method in class org.marmot.framework.dict.domain.FieldSet
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.AutoFormFilter
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.DataTableFilter
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.DatasetFilter
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.FilterUtils
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.OutlookBarFilter
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.SimpleFilter
setFilterAccessor(FilterAccessor) - Method in class org.marmot.security.filter.TabSetFilter
setFilterUtils(FilterUtils) - Method in class org.marmot.security.view.CategoryAccessor
setFilterable(boolean) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setFixedColumn(int) - Method in class org.marmot.framework.profile.domain.DataTable
setFormName(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setFormProperties(Map) - Method in class org.marmot.security.filter.AutoFormFilter
setGroupColumnProperties(Map) - Method in class org.marmot.security.filter.DataTableFilter
setGroupLayout(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setGroupProperties(Map) - Method in class org.marmot.security.filter.AutoFormFilter
setGroupProperties(Map) - Method in class org.marmot.security.filter.OutlookBarFilter
setGroupType(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setGroupable(boolean) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setGroups(List) - Method in class org.marmot.framework.profile.domain.AutoForm
setHeight(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setHeight(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setHeight(int) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
setIcon(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setId(String) - Method in class org.marmot.framework.dict.domain.Field
setId(String) - Method in class org.marmot.framework.dict.domain.FieldSet
setId(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setId(String) - Method in class org.marmot.framework.message.domain.Actor
setId(String) - Method in class org.marmot.framework.message.domain.Message
setId(String) - Method in class org.marmot.framework.message.domain.MessageReceiver
setId(String) - Method in class org.marmot.framework.preference.domain.Preference
setId(String) - Method in class org.marmot.framework.preference.domain.PreferenceCategory
setId(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setId(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setId(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setId(String) - Method in class org.marmot.framework.profile.domain.DataTable
setId(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setId(String) - Method in class org.marmot.framework.query.domain.Query
setId(String) - Method in class org.marmot.framework.query.domain.QueryParameter
setId(String) - Method in class org.marmot.framework.query.domain.QuerySQL
setId(String) - Method in class org.marmot.framework.query.domain.QuerySort
setId(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setId(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setId(String) - Method in class org.marmot.security.domain.ProxyUser
setId(String) - Method in class org.marmot.security.domain.ResCategory
setId(String) - Method in class org.marmot.security.domain.Resource
setId(String) - Method in class org.marmot.security.domain.ResourceCategory
setId(String) - Method in class org.marmot.security.domain.Role
setId(String) - Method in class org.marmot.security.domain.RoleRes
setId(String) - Method in class org.marmot.security.domain.User
setId(String) - Method in class org.marmot.security.domain.UserRole
setId(String) - Method in class org.marmot.security.view.Permission
setImageType(String) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
setIndexes(int[]) - Method in class org.marmot.security.service.PaginationSupport
setInt(String, int) - Static method in class org.marmot.framework.preference.PreferenceUtils
setItems(List) - Method in class org.marmot.security.service.PaginationSupport
setLabel(String) - Method in class org.marmot.framework.dict.domain.Field
setLabel(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setLabel(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setLabel(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setLabel(String) - Method in class org.marmot.security.domain.ResourceCategory
setLabel(String) - Method in class org.marmot.security.domain.Role
setLabel(String) - Method in class org.marmot.security.view.Permission
setLabelAlign(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setLabelStyle(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setLabelVAlign(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setLabelWidth(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setLevel(int) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setLogicOp(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setLoginid(String) - Method in class org.marmot.security.domain.User
setLong(String, long) - Static method in class org.marmot.framework.preference.PreferenceUtils
setMaxFontSize(int) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
setMaxLength(int) - Method in class org.marmot.framework.dict.domain.Field
setMenuFactory(MenuFactory) - Method in class org.marmot.framework.menu.view.DiligentMenuHelper
setMenuFactory(LazyMenuFactory) - Method in class org.marmot.framework.menu.view.LazyMenuHelper
setMenuHelper(DiligentMenuHelper) - Method in class org.marmot.security.view.CategoryAccessor
setMenuManager(MenuManager) - Method in class org.marmot.framework.menu.factory.MarmotMenuFactory
setMessage(String) - Method in class org.marmot.framework.message.domain.Message
setMessage(Message) - Method in class org.marmot.framework.message.domain.MessageReceiver
setMessageManager(MessageManager) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
setMessageReadMark(MessageReceiver) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
setMessageReadMark(MessageReceiver) - Method in interface org.marmot.framework.message.manager.MessageProcessor
将某个消息标记为已读.
setMessageReceivedMark(MessageReceiver) - Method in class org.marmot.framework.message.manager.AbstractMessageProcessor
setMessageReceivedMark(MessageReceiver) - Method in interface org.marmot.framework.message.manager.MessageProcessor
将某个消息标记为已接收.
setMeta1(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setMeta1(String) - Method in class org.marmot.framework.message.domain.Actor
setMeta1(String) - Method in class org.marmot.security.domain.ResourceCategory
setMeta2(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setMeta2(String) - Method in class org.marmot.framework.message.domain.Actor
setMeta2(String) - Method in class org.marmot.security.domain.ResourceCategory
setMeta3(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setMeta3(String) - Method in class org.marmot.framework.message.domain.Actor
setMeta3(String) - Method in class org.marmot.security.domain.ResourceCategory
setMinFontSize(int) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
setName(String) - Method in class org.marmot.framework.dict.domain.Field
setName(String) - Method in class org.marmot.framework.dict.domain.FieldSet
setName(String) - Method in class org.marmot.framework.message.domain.Actor
setName(String) - Method in class org.marmot.framework.preference.domain.Preference
setName(String) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setName(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setName(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setName(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setName(String) - Method in class org.marmot.framework.security.Account
setName(String) - Method in class org.marmot.security.domain.Resource
setName(String) - Method in class org.marmot.security.domain.ResourceCategory
setName(String) - Method in class org.marmot.security.domain.Role
setName(String) - Method in class org.marmot.security.domain.User
setName(String) - Method in class org.marmot.security.view.Permission
setNotifyTime(Date) - Method in class org.marmot.framework.message.domain.MessageReceiver
setObjectDefinitionSource(FilterInvocationDefinitionSource) - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
setObserveOncePerRequest(boolean) - Method in class org.marmot.security.intercept.web.FilterSecurityInterceptor
setOutlookBarProperties(Map) - Method in class org.marmot.security.filter.OutlookBarFilter
setOverwritable(boolean) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setPageRoot(String, int) - Static method in class org.marmot.framework.main.FrameStyleUtils
设置当前框架风格的路径.
setPageSize(int) - Method in class org.marmot.security.service.PaginationSupport
setParamName(String) - Method in class org.marmot.framework.query.domain.QueryParameter
setParamType(String) - Method in class org.marmot.framework.query.domain.QueryParameter
setParamValue(String) - Method in class org.marmot.framework.query.domain.QueryParameter
setParameters(List) - Method in class org.marmot.framework.query.domain.Query
setParentId(String) - Method in class org.marmot.security.domain.ResourceCategory
setParentId(String) - Method in class org.marmot.security.view.Permission
setParentItemId(String) - Method in class org.marmot.framework.menu.domain.MenuItem
setPasswd(String) - Method in class org.marmot.security.domain.User
setPasswordEncoder(PasswordEncoder) - Method in class org.marmot.security.manager.DefaultUserManager
setPath(String) - Method in class org.marmot.framework.menu.domain.MenuElement
setPattern(String) - Method in class org.marmot.framework.dict.domain.Field
setPermissionAccessor(PermissionAccessor) - Method in class org.marmot.security.view.PermissionBackBean
setPersonId(String) - Method in class org.marmot.framework.security.Account
setPreferenceDefinitions(List) - Method in class org.marmot.framework.preference.domain.PreferenceCategory
setPreferenceHandler(PreferenceHandler) - Static method in class org.marmot.framework.preference.PreferenceUtils
setProperties(Map) - Method in class org.marmot.framework.dict.domain.Field
setProperties(Map) - Method in class org.marmot.security.filter.SimpleFilter
setProperty(String) - Method in class org.marmot.security.domain.RoleRes
setProxyUsers(List) - Method in class org.marmot.security.domain.Role
setProxyusersForProxyuserId(List) - Method in class org.marmot.security.domain.User
setProxyusersForUserId(List) - Method in class org.marmot.security.domain.User
setQuery(Query) - Method in class org.marmot.framework.query.domain.QueryParameter
setQuery(Query) - Method in class org.marmot.framework.query.domain.QuerySQL
setQuery(Query) - Method in class org.marmot.framework.query.domain.QuerySort
setQuery(Query) - Method in class org.marmot.framework.query.domain.QueryWhere
setQueryBuilders(List) - Method in class org.marmot.framework.query.view.QueryDatasetListener
setQueryCategory(QueryCategory) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setQueryManager(QueryManager) - Method in class org.marmot.framework.query.view.QueryDatasetListener
setQueryName(String) - Method in class org.marmot.framework.query.domain.Query
setRead(boolean) - Method in class org.marmot.framework.message.domain.MessageReceiver
setReadOnly(boolean) - Method in class org.marmot.framework.dict.domain.Field
setReadOnly(boolean) - Method in class org.marmot.framework.profile.domain.DataTable
setReadOnly(boolean) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setReadTime(Date) - Method in class org.marmot.framework.message.domain.MessageReceiver
setReceived(boolean) - Method in class org.marmot.framework.message.domain.MessageReceiver
setReceivedTime(Date) - Method in class org.marmot.framework.message.domain.MessageReceiver
setReceiver(String) - Method in class org.marmot.framework.message.domain.MessageReceiver
setRendererType(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setRequired(boolean) - Method in class org.marmot.framework.dict.domain.Field
setResCategorys(List) - Method in class org.marmot.security.domain.Resource
setResCategorys(List) - Method in class org.marmot.security.domain.ResourceCategory
setResString(String) - Method in class org.marmot.security.cache.SecurityResource
setResString(String) - Method in class org.marmot.security.domain.Resource
setResType(String) - Method in class org.marmot.security.cache.SecurityResource
setResType(String) - Method in class org.marmot.security.domain.Resource
setResizable(boolean) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setResource(Resource) - Method in class org.marmot.security.domain.ResCategory
setResource(Resource) - Method in class org.marmot.security.domain.RoleRes
setResourceCache(ResourceCache) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
setResourceCache(ResourceCache) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setResourceCategorys(List) - Method in class org.marmot.security.domain.ResourceCategory
setResourceDefinitionSource(ResourceDefinitionSource) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setResourceFlags(String) - Method in class org.marmot.security.view.Permission
setResourceIds(String) - Method in class org.marmot.security.view.Permission
setResourceLabels(String) - Method in class org.marmot.security.view.Permission
setResourceManager(ResourceManager) - Method in class org.marmot.security.view.CategoryBackBean
setResourceManager(ResourceManager) - Method in class org.marmot.security.view.PermissionBackBean
setResourceManager(ResourceManager) - Method in class org.marmot.security.view.ResourceBackBean
setResources(Map) - Method in class org.marmot.security.view.Permission
setRole(Role) - Method in class org.marmot.security.domain.ProxyUser
setRole(Role) - Method in class org.marmot.security.domain.RoleRes
setRole(Role) - Method in class org.marmot.security.domain.UserRole
setRoleManager(RoleManager) - Method in class org.marmot.security.view.PermissionBackBean
setRoleManager(RoleManager) - Method in class org.marmot.security.view.RoleBackBean
setRoleResourceManager(RoleResourceManager) - Method in class org.marmot.security.view.PermissionBackBean
setRoleResourceManager(RoleResourceManager) - Method in class org.marmot.security.view.ResourceBackBean
setRoleRess(List) - Method in class org.marmot.security.domain.Resource
setRoleRess(List) - Method in class org.marmot.security.domain.Role
setRoot(boolean) - Method in class org.marmot.security.domain.User
setRowHeight(int) - Method in class org.marmot.framework.profile.domain.DataTable
setRowSpan(int) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setSendEmail(boolean) - Method in class org.marmot.framework.message.domain.Message
setSendTime(Date) - Method in class org.marmot.framework.message.domain.Message
setSender(String) - Method in class org.marmot.framework.message.domain.Message
setSenderName(String) - Method in class org.marmot.framework.message.domain.Message
setServiceUtil(ServiceUtil) - Method in class org.marmot.security.filter.FilterAccessor
setServiceUtil(ServiceUtil) - Method in class org.marmot.security.manager.DefaultResourceManager
setServiceUtil(ServiceUtil) - Method in class org.marmot.security.manager.DefaultRoleResourceManager
setServiceUtil(ServiceUtil) - Method in class org.marmot.security.view.CategoryAccessor
setSetId(String) - Method in class org.marmot.framework.dict.domain.Field
setShowBevel(boolean) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setShowFilterBar(boolean) - Method in class org.marmot.framework.profile.domain.DataTable
setShowFooter(boolean) - Method in class org.marmot.framework.profile.domain.DataTable
setShowLabel(boolean) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setSortClause(String) - Method in class org.marmot.framework.query.domain.QuerySQL
setSortOrder(Integer) - Method in class org.marmot.framework.dict.domain.Field
setSortOrder(int) - Method in class org.marmot.framework.menu.domain.MenuElement
setSortOrder(int) - Method in class org.marmot.framework.preference.domain.PreferenceCategory
setSortOrder(int) - Method in class org.marmot.framework.preference.domain.PreferenceDefinition
setSortOrder(int) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setSortOrder(int) - Method in class org.marmot.security.domain.Resource
setSortOrder(int) - Method in class org.marmot.security.domain.ResourceCategory
setSorts(List) - Method in class org.marmot.framework.query.domain.Query
setSqls(List) - Method in class org.marmot.framework.query.domain.Query
setStartIndex(int) - Method in class org.marmot.security.service.PaginationSupport
setStatusFlag(boolean) - Method in class org.marmot.security.domain.Resource
setStatusFlag(boolean) - Method in class org.marmot.security.domain.User
setString(String, String) - Static method in class org.marmot.framework.preference.PreferenceUtils
setString(Account, String, String) - Method in interface org.marmot.framework.preference.manager.PreferenceHandler
setSubItemCount(int) - Method in class org.marmot.framework.menu.domain.MenuItem
setSubItemCount(int) - Method in class org.marmot.security.domain.ResourceCategory
setSubItemCount(int) - Method in class org.marmot.security.view.Permission
setSubItems(List) - Method in class org.marmot.framework.menu.domain.MenuItem
setTabProperties(Map) - Method in class org.marmot.security.filter.TabSetFilter
setTableName(String) - Method in class org.marmot.framework.profile.domain.DataTable
setTableName(String) - Method in class org.marmot.framework.query.domain.QuerySort
setTableName(String) - Method in class org.marmot.framework.query.domain.QueryTemplateField
setTableName(String) - Method in class org.marmot.framework.query.domain.QueryWhere
setTableProperties(Map) - Method in class org.marmot.security.filter.DataTableFilter
setTabsetProperties(Map) - Method in class org.marmot.security.filter.TabSetFilter
setTemplateFields(List) - Method in class org.marmot.framework.query.domain.QueryCategory
setTitle(String) - Method in class org.marmot.framework.dict.domain.FieldSet
setTitle(String) - Method in class org.marmot.framework.message.domain.Message
setTotalCount(int) - Method in class org.marmot.security.service.PaginationSupport
setType(String) - Method in class org.marmot.framework.dict.domain.Field
setType(int) - Method in class org.marmot.framework.menu.domain.MenuItem
setType(int) - Method in class org.marmot.framework.message.domain.Actor
setType(String) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setType(String) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setType(String) - Method in class org.marmot.framework.query.domain.Query
setUseAntPath(boolean) - Method in class org.marmot.security.definition.ResourceDefinitionSource
setUseAntPath(boolean) - Method in class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
setUser(User) - Method in class org.marmot.security.domain.UserRole
setUserByProxyUserId(User) - Method in class org.marmot.security.domain.ProxyUser
setUserByUserId(User) - Method in class org.marmot.security.domain.ProxyUser
setUserCache(UserCache) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
setUserCache(UserCache) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setUserId(String) - Method in class org.marmot.framework.dict.domain.FieldSet
setUserId(String) - Method in class org.marmot.framework.menu.domain.Favorite
setUserId(String) - Method in class org.marmot.framework.preference.domain.Preference
setUserId(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setUserId(String) - Method in class org.marmot.framework.profile.domain.DataTable
setUserId(String) - Method in class org.marmot.framework.query.domain.Query
setUserId(String) - Method in class org.marmot.framework.query.domain.QueryUserCategory
setUserManager(UserManager) - Method in class org.marmot.security.view.ProxyBackBean
setUserManager(UserManager) - Method in class org.marmot.security.view.UserBackBean
setUserRoleManager(UserRoleManager) - Method in class org.marmot.security.view.PermissionBackBean
setUserRoleManager(UserRoleManager) - Method in class org.marmot.security.view.ProxyBackBean
setUserRoleManager(UserRoleManager) - Method in class org.marmot.security.view.RoleBackBean
setUserRoleManager(UserRoleManager) - Method in class org.marmot.security.view.UserBackBean
setUserRoleService(UserRoleService) - Method in class org.marmot.security.cache.AcegiCacheManagerImpl
setUserRoleService(UserRoleService) - Method in class org.marmot.security.manager.DefaultRoleManager
setUserRoleService(UserRoleService) - Method in class org.marmot.security.manager.DefaultUserManager
setUserRoleService(UserRoleService) - Method in class org.marmot.security.manager.DefaultUserRoleManager
setUserRoleService(UserRoleService) - Method in class org.marmot.security.service.UserService
setUserRoles(List) - Method in class org.marmot.security.domain.Role
setUserRoles(List) - Method in class org.marmot.security.domain.User
setUserService(UserService) - Method in class org.marmot.security.core.MarmotAuthenticationManager
setValue(String) - Method in class org.marmot.framework.preference.domain.Preference
setViewString(String) - Method in class org.marmot.security.domain.ResourceCategory
setViewString(String) - Method in class org.marmot.security.view.Permission
setVisible(boolean) - Method in class org.marmot.framework.dict.domain.Field
setVisible(boolean) - Method in class org.marmot.framework.menu.domain.MenuItem
setVisible(boolean) - Method in class org.marmot.framework.profile.domain.AutoFormElement
setVisible(boolean) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setVisible(boolean) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setWhereClause(String) - Method in class org.marmot.framework.query.domain.QuerySQL
setWheres(List) - Method in class org.marmot.framework.query.domain.Query
setWidth(String) - Method in class org.marmot.framework.profile.domain.AutoForm
setWidth(String) - Method in class org.marmot.framework.profile.domain.AutoFormGroup
setWidth(int) - Method in class org.marmot.framework.profile.domain.DataTableColumn
setWidth(int) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
shouldExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.AbstractQLQueryBuilder
shouldExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
shouldExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.DynaSQLQueryBuilder
shouldExecute(Dataset, Query) - Method in interface org.marmot.framework.query.builder.QueryBuilder
shouldExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.SQLQueryBuilder
shouldExecute(Dataset, Query) - Method in class org.marmot.framework.query.builder.StandardQueryBuilder
storeAutoForm(AutoForm) - Method in class org.marmot.framework.profile.view.AutoFormProfileHelper
storeDataTable(DataTable) - Method in class org.marmot.framework.profile.view.DataTableProfileHelper
supports(Class) - Method in class org.marmot.security.intercept.method.DBMethodDefinitionSource
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


T-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

T

TabSetFilter - class org.marmot.security.filter.TabSetFilter.
TabSetFilter() - Constructor for class org.marmot.security.filter.TabSetFilter
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


U-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

U

User - class org.marmot.security.domain.User.
User generated by hbm2java
User() - Constructor for class org.marmot.security.domain.User
UserBackBean - class org.marmot.security.view.UserBackBean.
UserBackBean() - Constructor for class org.marmot.security.view.UserBackBean
UserManager - interface org.marmot.security.manager.UserManager.
UserRole - class org.marmot.security.domain.UserRole.
UserRole generated by hbm2java
UserRole() - Constructor for class org.marmot.security.domain.UserRole
UserRole(String) - Constructor for class org.marmot.security.domain.UserRole
UserRole(String, User, Role) - Constructor for class org.marmot.security.domain.UserRole
UserRoleManager - interface org.marmot.security.manager.UserRoleManager.
UserRoleService - class org.marmot.security.service.UserRoleService.
UserRoleService() - Constructor for class org.marmot.security.service.UserRoleService
UserService - class org.marmot.security.service.UserService.
UserService() - Constructor for class org.marmot.security.service.UserService
unGrantedAll(Map, Object) - Method in class org.marmot.security.view.PermissionBackBean
update(Object) - Method in class org.marmot.security.manager.DefaultUserRoleManager
update(ResourceCategory) - Method in class org.marmot.security.service.ResourceCategoryService
update(Object) - Method in class org.marmot.security.service.ServiceUtil
updateCategory(ResourceCategory) - Method in class org.marmot.security.filter.FilterAccessor
updateCategory(ResourceCategory) - Method in interface org.marmot.security.manager.CategoryManager
updateCategory(ResourceCategory) - Method in class org.marmot.security.manager.DefaultCategoryManager
updateCategory(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
updateResource(Resource) - Method in class org.marmot.security.manager.DefaultResourceManager
updateResource(Resource) - Method in interface org.marmot.security.manager.ResourceManager
updateResource(Map, Object) - Method in class org.marmot.security.view.CategoryBackBean
updateResource(Map, Object) - Method in class org.marmot.security.view.ResourceBackBean
updateRole(Role) - Method in class org.marmot.security.manager.DefaultRoleManager
updateRole(Role) - Method in class org.marmot.security.manager.DefaultUserRoleManager
updateRole(Role) - Method in interface org.marmot.security.manager.RoleManager
updateRole(Map, Object) - Method in class org.marmot.security.view.RoleBackBean
updateUser(User) - Method in class org.marmot.security.manager.DefaultUserManager
updateUser(User) - Method in interface org.marmot.security.manager.UserManager
updateUser(Map, Object) - Method in class org.marmot.security.view.UserBackBean
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J L M O P Q R S T U V


V-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V

V

validateCaptcha(HttpServletRequest, String) - Method in interface org.marmot.framework.security.captcha.CaptchaProcessor
验证captchaCode参数中的信息是否与之前输出的人机识别测试信息相匹配.
validateCaptcha(HttpServletRequest, String) - Method in class org.marmot.framework.security.captcha.JCaptchaImageProcessor
Overview Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J L M O P Q R S T U V


 org.marmot.framework.dict.domain
Classes
Field
FieldSet


org.marmot.framework.dict.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.dict.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.dict.domain.Field (implements java.io.Serializable)
    • class org.marmot.framework.dict.domain.FieldSet (implements java.io.Serializable)
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.marmot.framework.dict.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.dict.domain

Packages that use org.marmot.framework.dict.domain
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view |

Classes in org.marmot.framework.dict.domain used by org.marmot.framework.dict.factory
Field
字段描述信息的域模型
FieldSet
字段描述信息集合的域模型

Classes in org.marmot.framework.dict.domain used by org.marmot.framework.dict.view
Field
字段描述信息的域模型
FieldSet
字段描述信息集合的域模型

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.dict.domain.Field

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.dict.domain.Field

Packages that use Field
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view |

Uses of Field in org.marmot.framework.dict.factory

Methods in org.marmot.framework.dict.factory that return Field
Field | DictionaryFactory.getFieldSet(Account account, String fieldSetName, String fieldName) 根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.
Field | MarmotDictionaryFactory.getFieldSet(Account account, String fieldSetName, String fieldName)

Uses of Field in org.marmot.framework.dict.view

Methods in org.marmot.framework.dict.view with parameters of type Field
protected com.bstek.dorado.data.Field | DictionaryDatasetListener.createField(com.bstek.dorado.data.Dataset dataset, FieldSet fieldSet, Field field)
protected void | DictionaryDatasetListener.initBaseField(com.bstek.dorado.data.Field fieldControl, Field field)
protected void | DictionaryDatasetListener.initViewField(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.data.ViewField viewField, Field field) 根据数据字典信息初始化一个Dorado中的ViewField对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.dict.domain.FieldSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.dict.domain.FieldSet

Packages that use FieldSet
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view |

Uses of FieldSet in org.marmot.framework.dict.factory

Methods in org.marmot.framework.dict.factory that return FieldSet
FieldSet | DictionaryFactory.getFieldSet(Account account, String fieldSetName) 根据帐号信息和集合名返回一个数据字典中的字段信息集合.
FieldSet | MarmotDictionaryFactory.getFieldSet(Account account, String fieldSetName)

Uses of FieldSet in org.marmot.framework.dict.view

Methods in org.marmot.framework.dict.view that return FieldSet
protected  FieldSet DictionaryDatasetListener.getFieldSet(com.bstek.dorado.data.Dataset dataset)

Methods in org.marmot.framework.dict.view with parameters of type FieldSet
protected  com.bstek.dorado.data.Field DictionaryDatasetListener.createField(com.bstek.dorado.data.Dataset dataset, FieldSet fieldSet, Field field)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.dict.factory
Interfaces
DictionaryFactory
Classes
MarmotDictionaryFactory


org.marmot.framework.dict.factory Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.dict.factory

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.dict.factory.MarmotDictionaryFactory (implements org.marmot.framework.dict.factory.DictionaryFactory)

Interface Hierarchy

  • interface org.marmot.framework.dict.factory.DictionaryFactory


Uses of Package org.marmot.framework.dict.factory

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.dict.factory

Packages that use org.marmot.framework.dict.factory
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view |

Classes in org.marmot.framework.dict.factory used by org.marmot.framework.dict.factory
DictionaryFactory
数据字典信息的采集工厂接口.

Classes in org.marmot.framework.dict.factory used by org.marmot.framework.dict.view
DictionaryFactory
数据字典信息的采集工厂接口.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.dict.factory.DictionaryFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.dict.factory.DictionaryFactory

Packages that use DictionaryFactory
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dict.view |

Uses of DictionaryFactory in org.marmot.framework.dict.factory

Classes in org.marmot.framework.dict.factory that implement DictionaryFactory
 class MarmotDictionaryFactory
默认的数据字典工厂的实现类.

Uses of DictionaryFactory in org.marmot.framework.dict.view

Methods in org.marmot.framework.dict.view with parameters of type DictionaryFactory
 void DictionaryDatasetListener.setDictionaryFactory(DictionaryFactory dictionaryFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.dict.factory.MarmotDictionaryFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.dict.factory.MarmotDictionaryFactory

No usage of org.marmot.framework.dict.factory.MarmotDictionaryFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.dict.view
Classes
DictionaryDatasetListener


org.marmot.framework.dict.view Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.dict.view

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.data.AbstractDatasetListener (implements com.bstek.dorado.data.DatasetListener)
      • class org.marmot.framework.dict.view.DictionaryDatasetListener


Uses of Package org.marmot.framework.dict.view

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.dict.view

No usage of org.marmot.framework.dict.view

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.dict.view.DictionaryDatasetListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.dict.view.DictionaryDatasetListener

No usage of org.marmot.framework.dict.view.DictionaryDatasetListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.dorado
Classes
PreferencesExprContextMap
SecurityExprHandler


org.marmot.framework.dorado Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.dorado

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap (implements java.util.Map)
      • class org.marmot.framework.dorado.PreferencesExprContextMap
    • class org.marmot.framework.dorado.SecurityExprHandler


Uses of Package org.marmot.framework.dorado

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.dorado

No usage of org.marmot.framework.dorado

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.dorado.PreferencesExprContextMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.dorado.PreferencesExprContextMap

No usage of org.marmot.framework.dorado.PreferencesExprContextMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.dorado.SecurityExprHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.dorado.SecurityExprHandler

No usage of org.marmot.framework.dorado.SecurityExprHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.main
Classes
FrameStyleUtils


org.marmot.framework.main Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.main

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.main.FrameStyleUtils


Uses of Package org.marmot.framework.main

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.main

No usage of org.marmot.framework.main

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.main.FrameStyleUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.main.FrameStyleUtils

No usage of org.marmot.framework.main.FrameStyleUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.menu.domain
Classes
Favorite
MenuElement
MenuItem


org.marmot.framework.menu.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.menu.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.menu.domain.MenuElement
      • class org.marmot.framework.menu.domain.Favorite (implements java.io.Serializable)
      • class org.marmot.framework.menu.domain.MenuItem (implements java.io.Serializable)


Uses of Package org.marmot.framework.menu.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.menu.domain

Packages that use org.marmot.framework.menu.domain
org.marmot.framework.menu.domain 动态菜单工厂相关的域模型对象.

Classes in org.marmot.framework.menu.domain used by org.marmot.framework.menu.domain
MenuElement
菜单元素模型的抽象类.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.menu.domain.Favorite

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.menu.domain.Favorite

No usage of org.marmot.framework.menu.domain.Favorite

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.menu.domain.MenuElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.menu.domain.MenuElement

Packages that use MenuElement
org.marmot.framework.menu.domain 动态菜单工厂相关的域模型对象.

Uses of MenuElement in org.marmot.framework.menu.domain

Subclasses of MenuElement in org.marmot.framework.menu.domain
class | Favorite 收藏项的域模型
class | MenuItem 菜单项的域模型.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.menu.domain.MenuItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.menu.domain.MenuItem

No usage of org.marmot.framework.menu.domain.MenuItem

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.menu.factory
Interfaces
DiligentMenuFactory
LazyMenuFactory
MenuFactory
Classes
MarmotMenuFactory


org.marmot.framework.menu.factory Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.menu.factory

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.menu.factory.MarmotMenuFactory (implements org.marmot.framework.menu.factory.DiligentMenuFactory, org.marmot.framework.menu.factory.LazyMenuFactory)

Interface Hierarchy

  • interface org.marmot.framework.menu.factory.MenuFactory
    • interface org.marmot.framework.menu.factory.DiligentMenuFactory
    • interface org.marmot.framework.menu.factory.LazyMenuFactory


Uses of Package org.marmot.framework.menu.factory

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.menu.factory

Packages that use org.marmot.framework.menu.factory
org.marmot.framework.menu.factory | 动态菜单工厂的接口及相关实现.
org.marmot.framework.menu.view | 动态菜单工厂的视图层实现.

Classes in org.marmot.framework.menu.factory used by org.marmot.framework.menu.factory
DiligentMenuFactory
勤快的动态菜单工厂的接口.
LazyMenuFactory
懒装载的动态菜单工厂的接口.
MenuFactory
菜单工厂的接口.

Classes in org.marmot.framework.menu.factory used by org.marmot.framework.menu.view
LazyMenuFactory
懒装载的动态菜单工厂的接口.
MenuFactory
菜单工厂的接口.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.menu.factory.DiligentMenuFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.menu.factory.DiligentMenuFactory

Packages that use DiligentMenuFactory
org.marmot.framework.menu.factory 动态菜单工厂的接口及相关实现.

Uses of DiligentMenuFactory in org.marmot.framework.menu.factory

Classes in org.marmot.framework.menu.factory that implement DiligentMenuFactory
 class MarmotMenuFactory
默认的动态菜单工厂的实现类.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.menu.factory.LazyMenuFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.menu.factory.LazyMenuFactory

Packages that use LazyMenuFactory
org.marmot.framework.menu.factory | 动态菜单工厂的接口及相关实现.
org.marmot.framework.menu.view | 动态菜单工厂的视图层实现.

Uses of LazyMenuFactory in org.marmot.framework.menu.factory

Classes in org.marmot.framework.menu.factory that implement LazyMenuFactory
 class MarmotMenuFactory
默认的动态菜单工厂的实现类.

Uses of LazyMenuFactory in org.marmot.framework.menu.view

Methods in org.marmot.framework.menu.view with parameters of type LazyMenuFactory
 void LazyMenuHelper.setMenuFactory(LazyMenuFactory menuFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.menu.factory.MarmotMenuFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.menu.factory.MarmotMenuFactory

No usage of org.marmot.framework.menu.factory.MarmotMenuFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.menu.factory.MenuFactory

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.menu.factory.MenuFactory

Packages that use MenuFactory
org.marmot.framework.menu.factory | 动态菜单工厂的接口及相关实现.
org.marmot.framework.menu.view | 动态菜单工厂的视图层实现.

Uses of MenuFactory in org.marmot.framework.menu.factory

Subinterfaces of MenuFactory in org.marmot.framework.menu.factory
interface | DiligentMenuFactory 勤快的动态菜单工厂的接口.
interface | LazyMenuFactory 懒装载的动态菜单工厂的接口.

Classes in org.marmot.framework.menu.factory that implement MenuFactory
 class MarmotMenuFactory
默认的动态菜单工厂的实现类.

Uses of MenuFactory in org.marmot.framework.menu.view

Methods in org.marmot.framework.menu.view that return MenuFactory
protected MenuFactory | DiligentMenuHelper.getMenuFactory()
protected MenuFactory | LazyMenuHelper.getMenuFactory()

Methods in org.marmot.framework.menu.view with parameters of type MenuFactory
 void DiligentMenuHelper.setMenuFactory(MenuFactory menuFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.menu.view
Classes
DiligentMenuHelper
LazyMenuHelper


org.marmot.framework.menu.view Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.menu.view

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.menu.view.AbstractMenuHelper
      • class org.marmot.framework.menu.view.DiligentMenuHelper
      • class org.marmot.framework.menu.view.LazyMenuHelper


Uses of Package org.marmot.framework.menu.view

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.menu.view

Packages that use org.marmot.framework.menu.view
org.marmot.framework.menu.view | 动态菜单工厂的视图层实现.
org.marmot.security.view |

Classes in org.marmot.framework.menu.view used by org.marmot.framework.menu.view
DiligentMenuHelper
用于创建一次性装载的菜单控件的辅助类.
LazyMenuHelper
用于创建支持懒装载的菜单控件的辅助类.

Classes in org.marmot.framework.menu.view used by org.marmot.security.view
DiligentMenuHelper
用于创建一次性装载的菜单控件的辅助类.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.menu.view.DiligentMenuHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.menu.view.DiligentMenuHelper

Packages that use DiligentMenuHelper
org.marmot.framework.menu.view | 动态菜单工厂的视图层实现.
org.marmot.security.view |

Uses of DiligentMenuHelper in org.marmot.framework.menu.view

Methods in org.marmot.framework.menu.view that return DiligentMenuHelper
static DiligentMenuHelper DiligentMenuHelper.getInstance()
返回DiligentMenuHelper的实例.

Uses of DiligentMenuHelper in org.marmot.security.view

Methods in org.marmot.security.view that return DiligentMenuHelper
 DiligentMenuHelper CategoryAccessor.getMenuHelper()

Methods in org.marmot.security.view with parameters of type DiligentMenuHelper
 void CategoryAccessor.setMenuHelper(DiligentMenuHelper menuHelper)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.menu.view.LazyMenuHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.menu.view.LazyMenuHelper

Packages that use LazyMenuHelper
org.marmot.framework.menu.view 动态菜单工厂的视图层实现.

Uses of LazyMenuHelper in org.marmot.framework.menu.view

Methods in org.marmot.framework.menu.view that return LazyMenuHelper
static LazyMenuHelper LazyMenuHelper.getInstance()
返回LazyMenuHelper的实例.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.message.domain
Classes
Actor
Message
MessageReceiver


org.marmot.framework.message.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.message.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.message.domain.Actor (implements java.io.Serializable)
    • class org.marmot.framework.message.domain.Message (implements java.io.Serializable)
    • class org.marmot.framework.message.domain.MessageReceiver (implements java.io.Serializable)


Uses of Package org.marmot.framework.message.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.message.domain

Packages that use org.marmot.framework.message.domain
org.marmot.framework.message.domain | 实时消息功能相关的域模型对象.
org.marmot.framework.message.manager | 实时消息功能的的管理类和维护类.

Classes in org.marmot.framework.message.domain used by org.marmot.framework.message.domain
Message
消息的域模型.

Classes in org.marmot.framework.message.domain used by org.marmot.framework.message.manager
Actor
消息参与者的域模型.
Message
消息的域模型.
MessageReceiver
消息接受者的域模型.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.message.domain.Actor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.message.domain.Actor

Packages that use Actor
org.marmot.framework.message.manager 实时消息功能的的管理类和维护类.

Uses of Actor in org.marmot.framework.message.manager

Methods in org.marmot.framework.message.manager that return Actor
Actor | MessageProcessor.getActor(String actorId) 根据id返回参与者对象.
Actor | MessageProcessor.getSelf() 返回当前消息参与者本人.

Methods in org.marmot.framework.message.manager with parameters of type Actor
protected void | AbstractMessageProcessor.sendMail(Message message, Actor sender, Collection receivers) 向所有消息接收者发送EMail.
void | AbstractMessageProcessor.sendMessage(Message message, Actor sender, Set receivers)
void | MessageProcessor.sendMessage(Message message, Actor sender, Set receivers) 发送消息

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.message.domain.Message

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.message.domain.Message

Packages that use Message
org.marmot.framework.message.domain | 实时消息功能相关的域模型对象.
org.marmot.framework.message.manager | 实时消息功能的的管理类和维护类.

Uses of Message in org.marmot.framework.message.domain

Methods in org.marmot.framework.message.domain that return Message
 Message MessageReceiver.getMessage()

Methods in org.marmot.framework.message.domain with parameters of type Message
 void MessageReceiver.setMessage(Message message)

Uses of Message in org.marmot.framework.message.manager

Methods in org.marmot.framework.message.manager with parameters of type Message
protected void | AbstractMessageProcessor.sendMail(Message message, Actor sender, Collection receivers) 向所有消息接收者发送EMail.
void | AbstractMessageProcessor.sendMessage(Message message, Actor sender, Set receivers)
void | MessageProcessor.sendMessage(Message message, Actor sender, Set receivers) 发送消息

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.message.domain.MessageReceiver

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.message.domain.MessageReceiver

Packages that use MessageReceiver
org.marmot.framework.message.manager 实时消息功能的的管理类和维护类.

Uses of MessageReceiver in org.marmot.framework.message.manager

Methods in org.marmot.framework.message.manager with parameters of type MessageReceiver
void | AbstractMessageProcessor.setMessageReceivedMark(MessageReceiver messageReceiver)
void | AbstractMessageProcessor.setMessageReadMark(MessageReceiver messageReceiver)
void | MessageProcessor.setMessageReceivedMark(MessageReceiver messageReceiver) 将某个消息标记为已接收.
void | MessageProcessor.setMessageReadMark(MessageReceiver messageReceiver) 将某个消息标记为已读.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.message.manager
Interfaces
MessageProcessor
Classes
AbstractMessageProcessor


org.marmot.framework.message.manager Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.message.manager

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.message.manager.AbstractMessageProcessor (implements org.marmot.framework.message.manager.MessageProcessor)

Interface Hierarchy

  • interface org.marmot.framework.message.manager.MessageProcessor


Uses of Package org.marmot.framework.message.manager

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.message.manager

Packages that use org.marmot.framework.message.manager
org.marmot.framework.message.manager 实时消息功能的的管理类和维护类.

Classes in org.marmot.framework.message.manager used by org.marmot.framework.message.manager
MessageProcessor
实时消息处理器的接口.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.message.manager.AbstractMessageProcessor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.message.manager.AbstractMessageProcessor

No usage of org.marmot.framework.message.manager.AbstractMessageProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.message.manager.MessageProcessor

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.message.manager.MessageProcessor

Packages that use MessageProcessor
org.marmot.framework.message.manager 实时消息功能的的管理类和维护类.

Uses of MessageProcessor in org.marmot.framework.message.manager

Classes in org.marmot.framework.message.manager that implement MessageProcessor
 class AbstractMessageProcessor
抽像的实时消息处理器.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.preference
Classes
PreferenceUtils


org.marmot.framework.preference Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.preference

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.preference.PreferenceUtils


Uses of Package org.marmot.framework.preference

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.preference

No usage of org.marmot.framework.preference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.preference.PreferenceUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.preference.PreferenceUtils

No usage of org.marmot.framework.preference.PreferenceUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.preference.domain
Classes
Preference
PreferenceCategory
PreferenceDefinition


org.marmot.framework.preference.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.preference.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.preference.domain.Preference (implements java.io.Serializable)
    • class org.marmot.framework.preference.domain.PreferenceCategory (implements java.io.Serializable)
    • class org.marmot.framework.preference.domain.PreferenceDefinition (implements java.io.Serializable)


Uses of Package org.marmot.framework.preference.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.preference.domain

No usage of org.marmot.framework.preference.domain

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.preference.domain.Preference

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.preference.domain.Preference

No usage of org.marmot.framework.preference.domain.Preference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.preference.domain.PreferenceCategory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.preference.domain.PreferenceCategory

No usage of org.marmot.framework.preference.domain.PreferenceCategory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.preference.domain.PreferenceDefinition

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.preference.domain.PreferenceDefinition

No usage of org.marmot.framework.preference.domain.PreferenceDefinition

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.preference.manager
Interfaces
PreferenceHandler


org.marmot.framework.preference.manager Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.preference.manager

Package Hierarchies:
All Packages

Interface Hierarchy

  • interface org.marmot.framework.preference.manager.PreferenceHandler


Uses of Package org.marmot.framework.preference.manager

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.preference.manager

Packages that use org.marmot.framework.preference.manager
org.marmot.framework.preference 系统属性功能的扩展接口及相关实现.

Classes in org.marmot.framework.preference.manager used by org.marmot.framework.preference
PreferenceHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.preference.manager.PreferenceHandler

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.preference.manager.PreferenceHandler

Packages that use PreferenceHandler
org.marmot.framework.preference 系统属性功能的扩展接口及相关实现.

Uses of PreferenceHandler in org.marmot.framework.preference

Methods in org.marmot.framework.preference with parameters of type PreferenceHandler
static void PreferenceUtils.setPreferenceHandler(PreferenceHandler handler)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.profile.domain
Classes
AutoForm
AutoFormElement
AutoFormGroup
DataTable
DataTableColumn


org.marmot.framework.profile.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.profile.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.profile.domain.AutoForm (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.AutoFormElement (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.AutoFormGroup (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.DataTable (implements java.io.Serializable)
    • class org.marmot.framework.profile.domain.DataTableColumn (implements java.io.Serializable)


Uses of Package org.marmot.framework.profile.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.profile.domain

Packages that use org.marmot.framework.profile.domain
org.marmot.framework.profile.view

Classes in org.marmot.framework.profile.domain used by org.marmot.framework.profile.view
AutoForm
AutoFormGroup
DataTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.domain.AutoForm

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.domain.AutoForm

Packages that use AutoForm
org.marmot.framework.profile.view

Uses of AutoForm in org.marmot.framework.profile.view

Methods in org.marmot.framework.profile.view that return AutoForm
AutoForm | AutoFormProfileHelper.findAutoForm(String profileKey)
protected AutoForm | AutoFormProfileHelper.getAutoForm(String userId, String profileKey)

Methods in org.marmot.framework.profile.view with parameters of type AutoForm
void | AutoFormProfileHelper.storeAutoForm(AutoForm autoForm)
protected void | AutoFormProfileHelper.saveAutoForm(String userId, AutoForm autoForm)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.domain.AutoFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.domain.AutoFormElement

No usage of org.marmot.framework.profile.domain.AutoFormElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.domain.AutoFormGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.domain.AutoFormGroup

Packages that use AutoFormGroup
org.marmot.framework.profile.view

Uses of AutoFormGroup in org.marmot.framework.profile.view

Methods in org.marmot.framework.profile.view with parameters of type AutoFormGroup
protected  void AutoFormProfileHelper.initFormGroup(com.bstek.dorado.view.ViewModel viewModel, com.bstek.dorado.view.control.autoform.AutoForm autoFormControl, com.bstek.dorado.view.control.autoform.FormGroup groupControl, AutoFormGroup group)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.domain.DataTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.domain.DataTable

Packages that use DataTable
org.marmot.framework.profile.view

Uses of DataTable in org.marmot.framework.profile.view

Methods in org.marmot.framework.profile.view that return DataTable
DataTable | DataTableProfileHelper.findDataTable(String profileKey)
protected DataTable | DataTableProfileHelper.getDataTable(String userId, String profileKey)

Methods in org.marmot.framework.profile.view with parameters of type DataTable
void | DataTableProfileHelper.storeDataTable(DataTable dataTable)
protected void | DataTableProfileHelper.saveDataTable(String userId, DataTable dataTable)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.domain.DataTableColumn

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.domain.DataTableColumn

No usage of org.marmot.framework.profile.domain.DataTableColumn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.profile.view
Classes
AutoFormProfileHelper
DataTableProfileHelper


org.marmot.framework.profile.view Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.profile.view

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.profile.view.AutoFormProfileHelper
    • class org.marmot.framework.profile.view.DataTableProfileHelper


Uses of Package org.marmot.framework.profile.view

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.profile.view

No usage of org.marmot.framework.profile.view

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.view.AutoFormProfileHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.view.AutoFormProfileHelper

No usage of org.marmot.framework.profile.view.AutoFormProfileHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.profile.view.DataTableProfileHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.profile.view.DataTableProfileHelper

No usage of org.marmot.framework.profile.view.DataTableProfileHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.query.builder
Interfaces
QueryBuilder
Classes
AbstractDynaQLQueryBuilder
AbstractDynaQueryBuilder
AbstractQLQueryBuilder
DynaAutoSQLQueryBuilder
DynaSQLQueryBuilder
HQLQueryBuilder
IBatisQueryBuilder
QL
QLUtils
SQLQueryBuilder
StandardQueryBuilder


org.marmot.framework.query.builder Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.query.builder

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.query.builder.AbstractDynaQueryBuilder (implements org.marmot.framework.query.builder.QueryBuilder)
      • class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder
        • class org.marmot.framework.query.builder.AbstractQLQueryBuilder
          • class org.marmot.framework.query.builder.HQLQueryBuilder
          • class org.marmot.framework.query.builder.IBatisQueryBuilder
        • class org.marmot.framework.query.builder.DynaSQLQueryBuilder
      • class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder
    • class org.marmot.framework.query.builder.QL
    • class org.marmot.framework.query.builder.QLUtils
    • class org.marmot.framework.query.builder.SQLQueryBuilder (implements org.marmot.framework.query.builder.QueryBuilder)
    • class org.marmot.framework.query.builder.StandardQueryBuilder (implements org.marmot.framework.query.builder.QueryBuilder)

Interface Hierarchy

  • interface org.marmot.framework.query.builder.QueryBuilder


Uses of Package org.marmot.framework.query.builder

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.query.builder

Packages that use org.marmot.framework.query.builder
org.marmot.framework.query.builder

Classes in org.marmot.framework.query.builder used by org.marmot.framework.query.builder
AbstractDynaQLQueryBuilder
AbstractDynaQueryBuilder
AbstractQLQueryBuilder
QL
QueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.AbstractDynaQLQueryBuilder

Packages that use AbstractDynaQLQueryBuilder
org.marmot.framework.query.builder

Uses of AbstractDynaQLQueryBuilder in org.marmot.framework.query.builder

Subclasses of AbstractDynaQLQueryBuilder in org.marmot.framework.query.builder
class | AbstractQLQueryBuilder
class | DynaSQLQueryBuilder
class | HQLQueryBuilder
class | IBatisQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.AbstractDynaQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.AbstractDynaQueryBuilder

Packages that use AbstractDynaQueryBuilder
org.marmot.framework.query.builder

Uses of AbstractDynaQueryBuilder in org.marmot.framework.query.builder

Subclasses of AbstractDynaQueryBuilder in org.marmot.framework.query.builder
class | AbstractDynaQLQueryBuilder
class | AbstractQLQueryBuilder
class | DynaAutoSQLQueryBuilder
class | DynaSQLQueryBuilder
class | HQLQueryBuilder
class | IBatisQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.AbstractQLQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.AbstractQLQueryBuilder

Packages that use AbstractQLQueryBuilder
org.marmot.framework.query.builder

Uses of AbstractQLQueryBuilder in org.marmot.framework.query.builder

Subclasses of AbstractQLQueryBuilder in org.marmot.framework.query.builder
class | HQLQueryBuilder
class | IBatisQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder

No usage of org.marmot.framework.query.builder.DynaAutoSQLQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.DynaSQLQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.DynaSQLQueryBuilder

No usage of org.marmot.framework.query.builder.DynaSQLQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.HQLQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.HQLQueryBuilder

No usage of org.marmot.framework.query.builder.HQLQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.IBatisQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.IBatisQueryBuilder

No usage of org.marmot.framework.query.builder.IBatisQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.QL

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.QL

Packages that use QL
org.marmot.framework.query.builder

Uses of QL in org.marmot.framework.query.builder

Methods in org.marmot.framework.query.builder that return QL
protected QL | AbstractDynaQLQueryBuilder.buildQL(com.bstek.dorado.data.Dataset dataset, Query query)
QL | AbstractQLQueryBuilder.buildQL(Query query)
protected QL | AbstractQLQueryBuilder.buildQL(com.bstek.dorado.data.Dataset dataset, Query query)

Methods in org.marmot.framework.query.builder with parameters of type QL
protected void | AbstractDynaQLQueryBuilder.buildWhereClause(QL ql, com.bstek.dorado.data.Dataset dataset, Query query)
protected void | AbstractDynaQLQueryBuilder.buildWhereClauseSection(QL ql, com.bstek.dorado.data.Dataset dataset, QueryWhere where, Object compareValue)
protected void | AbstractDynaQLQueryBuilder.getWhereClauseSection(QL ql, StringBuffer whereClause, String fieldName, String fieldType, String compareOp, Object compareValue)
protected void | AbstractDynaQLQueryBuilder.buildOrderByClause(QL ql, com.bstek.dorado.data.Dataset dataset, Query query)
void | AbstractDynaQLQueryBuilder.initParameters(QL ql, com.bstek.dorado.data.ParameterSet parameters)
protected void | IBatisQueryBuilder.getWhereClauseSection(QL ql, StringBuffer whereClause, String fieldName, String fieldType, String compareOp, Object compareValue)
static String | QLUtils.replaceClauses(String statement, QL ql)
static void | QLUtils.replaceClauses(com.bstek.dorado.data.db.SqlDataset dataset, QL ql)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.QLUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.QLUtils

No usage of org.marmot.framework.query.builder.QLUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.query.builder.QueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.query.builder.QueryBuilder

Packages that use QueryBuilder
org.marmot.framework.query.builder

Uses of QueryBuilder in org.marmot.framework.query.builder

Classes in org.marmot.framework.query.builder that implement QueryBuilder
class | AbstractDynaQLQueryBuilder
class | AbstractDynaQueryBuilder
class | AbstractQLQueryBuilder
class | DynaAutoSQLQueryBuilder
class | DynaSQLQueryBuilder
class | HQLQueryBuilder
class | IBatisQueryBuilder
class | SQLQueryBuilder
class | StandardQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.SQLQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.SQLQueryBuilder

No usage of org.marmot.framework.query.builder.SQLQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.builder.StandardQueryBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.builder.StandardQueryBuilder

No usage of org.marmot.framework.query.builder.StandardQueryBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.query.domain
Classes
Query
QueryCategory
QueryParameter
QuerySort
QuerySQL
QueryTemplateField
QueryUserCategory
QueryWhere


org.marmot.framework.query.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.query.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.query.domain.Query (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryCategory (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryParameter (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QuerySort (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QuerySQL (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryTemplateField
    • class org.marmot.framework.query.domain.QueryUserCategory (implements java.io.Serializable)
    • class org.marmot.framework.query.domain.QueryWhere (implements java.io.Serializable)


Uses of Package org.marmot.framework.query.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.query.domain

Packages that use org.marmot.framework.query.domain
org.marmot.framework.query.builder
org.marmot.framework.query.domain
org.marmot.framework.query.view

Classes in org.marmot.framework.query.domain used by org.marmot.framework.query.builder
Query
QueryWhere

Classes in org.marmot.framework.query.domain used by org.marmot.framework.query.domain
Query
QueryCategory

Classes in org.marmot.framework.query.domain used by org.marmot.framework.query.view
Query

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.Query

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.Query

Packages that use Query
org.marmot.framework.query.builder
org.marmot.framework.query.domain
org.marmot.framework.query.view

Uses of Query in org.marmot.framework.query.builder

Methods in org.marmot.framework.query.builder with parameters of type Query
protected QL | AbstractDynaQLQueryBuilder.buildQL(com.bstek.dorado.data.Dataset dataset, Query query)
protected void | AbstractDynaQLQueryBuilder.buildWhereClause(QL ql, com.bstek.dorado.data.Dataset dataset, Query query)
protected void | AbstractDynaQLQueryBuilder.buildOrderByClause(QL ql, com.bstek.dorado.data.Dataset dataset, Query query)
void | AbstractDynaQueryBuilder.execute(com.bstek.dorado.data.Dataset dataset, Query query)
protected abstract void | AbstractDynaQueryBuilder.internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | AbstractQLQueryBuilder.shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
void | AbstractQLQueryBuilder.internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
QL | AbstractQLQueryBuilder.buildQL(Query query)
protected QL | AbstractQLQueryBuilder.buildQL(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | DynaAutoSQLQueryBuilder.shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
void | DynaAutoSQLQueryBuilder.internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
protected void | DynaAutoSQLQueryBuilder.buildMatchRules(com.bstek.dorado.data.db.AutoSqlDataset dataset, Query query)
boolean | DynaSQLQueryBuilder.shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
void | DynaSQLQueryBuilder.internalExecute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | QueryBuilder.shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
void | QueryBuilder.execute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | SQLQueryBuilder.shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
void | SQLQueryBuilder.execute(com.bstek.dorado.data.Dataset dataset, Query query)
boolean | StandardQueryBuilder.shouldExecute(com.bstek.dorado.data.Dataset dataset, Query query)
void | StandardQueryBuilder.execute(com.bstek.dorado.data.Dataset dataset, Query query)

Uses of Query in org.marmot.framework.query.domain

Methods in org.marmot.framework.query.domain that return Query
Query | QueryParameter.getQuery()
Query | QuerySQL.getQuery()
Query | QuerySort.getQuery()
Query | QueryWhere.getQuery()

Methods in org.marmot.framework.query.domain with parameters of type Query
void | QueryParameter.setQuery(Query query)
void | QuerySQL.setQuery(Query query)
void | QuerySort.setQuery(Query query)
void | QueryWhere.setQuery(Query query)

Uses of Query in org.marmot.framework.query.view

Methods in org.marmot.framework.query.view that return Query
protected  Query QueryDatasetListener.parseQuery(com.bstek.dorado.data.ParameterSet parameters)

Methods in org.marmot.framework.query.view with parameters of type Query
protected  void QueryDatasetListener.applyQuery(com.bstek.dorado.data.Dataset dataset, Query query)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QueryCategory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QueryCategory

Packages that use QueryCategory
org.marmot.framework.query.domain

Uses of QueryCategory in org.marmot.framework.query.domain

Methods in org.marmot.framework.query.domain that return QueryCategory
QueryCategory | QueryTemplateField.getQueryCategory()
QueryCategory | QueryUserCategory.getCategory()

Methods in org.marmot.framework.query.domain with parameters of type QueryCategory
void | QueryTemplateField.setQueryCategory(QueryCategory queryCategory)
void | QueryUserCategory.setCategory(QueryCategory category)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QueryParameter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QueryParameter

No usage of org.marmot.framework.query.domain.QueryParameter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QuerySort

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QuerySort

No usage of org.marmot.framework.query.domain.QuerySort

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QuerySQL

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QuerySQL

No usage of org.marmot.framework.query.domain.QuerySQL

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QueryTemplateField

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QueryTemplateField

No usage of org.marmot.framework.query.domain.QueryTemplateField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QueryUserCategory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QueryUserCategory

No usage of org.marmot.framework.query.domain.QueryUserCategory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.domain.QueryWhere

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.domain.QueryWhere

Packages that use QueryWhere
org.marmot.framework.query.builder

Uses of QueryWhere in org.marmot.framework.query.builder

Methods in org.marmot.framework.query.builder with parameters of type QueryWhere
protected void | AbstractDynaQLQueryBuilder.buildWhereClauseSection(QL ql, com.bstek.dorado.data.Dataset dataset, QueryWhere where, Object compareValue)
protected int | DynaAutoSQLQueryBuilder.buildMatchRule(com.bstek.dorado.data.db.AutoSqlDataset dataset, QueryWhere where, Object compareValue, int level)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.query.view
Classes
QueryDatasetListener


org.marmot.framework.query.view Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.query.view

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.data.AbstractDatasetListener (implements com.bstek.dorado.data.DatasetListener)
      • class org.marmot.framework.query.view.QueryDatasetListener


Uses of Package org.marmot.framework.query.view

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.query.view

No usage of org.marmot.framework.query.view

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.query.view.QueryDatasetListener

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.query.view.QueryDatasetListener

No usage of org.marmot.framework.query.view.QueryDatasetListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.security
Interfaces
Authenticator
Authorizer
CurrentAccountAccessor
ListableAuthorizer
Classes
AbstractHttpAuthenticator
AbstractHttpCurrentAccountAccessor
Account
SecurityUtils


org.marmot.framework.security Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.security

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.security.AbstractHttpAuthenticator (implements org.marmot.framework.security.Authenticator)
    • class org.marmot.framework.security.AbstractHttpCurrentAccountAccessor (implements org.marmot.framework.security.CurrentAccountAccessor)
    • class org.marmot.framework.security.Account
    • class org.marmot.framework.security.SecurityUtils

Interface Hierarchy

  • interface org.marmot.framework.security.Authenticator
  • interface org.marmot.framework.security.Authorizer
  • interface org.marmot.framework.security.CurrentAccountAccessor
  • interface org.marmot.framework.security.ListableAuthorizer


Uses of Package org.marmot.framework.security

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.security

Packages that use org.marmot.framework.security
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dorado | Marmot Framework提供的Dorado扩展.
org.marmot.framework.menu.factory | 动态菜单工厂的接口及相关实现.
org.marmot.framework.preference.manager |
org.marmot.framework.security | 权限功能的扩展接口及相关实现.

Classes in org.marmot.framework.security used by org.marmot.framework.dict.factory
Account

Classes in org.marmot.framework.security used by org.marmot.framework.dorado
Account

Classes in org.marmot.framework.security used by org.marmot.framework.menu.factory
Account

Classes in org.marmot.framework.security used by org.marmot.framework.preference.manager
Account

Classes in org.marmot.framework.security used by org.marmot.framework.security
Account
Authenticator
登录功能的接口
Authorizer
权限验证器的接口.
CurrentAccountAccessor
用于获取系统当前登录信息的类的接口.
SecurityUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.security.captcha
Interfaces
CaptchaProcessor
Classes
JCaptchaImageProcessor


org.marmot.framework.security.captcha Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.security.captcha

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.security.captcha.JCaptchaImageProcessor (implements org.marmot.framework.security.captcha.CaptchaProcessor)

Interface Hierarchy

  • interface org.marmot.framework.security.captcha.CaptchaProcessor


Uses of Package org.marmot.framework.security.captcha

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.security.captcha

Packages that use org.marmot.framework.security.captcha
org.marmot.framework.security.captcha

Classes in org.marmot.framework.security.captcha used by org.marmot.framework.security.captcha
CaptchaProcessor
验证码处理器的接口.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.security.captcha.CaptchaProcessor

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.security.captcha.CaptchaProcessor

Packages that use CaptchaProcessor
org.marmot.framework.security.captcha

Uses of CaptchaProcessor in org.marmot.framework.security.captcha

Classes in org.marmot.framework.security.captcha that implement CaptchaProcessor
 class JCaptchaImageProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.security.captcha.JCaptchaImageProcessor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.security.captcha.JCaptchaImageProcessor

No usage of org.marmot.framework.security.captcha.JCaptchaImageProcessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.security.AbstractHttpAuthenticator

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.security.AbstractHttpAuthenticator

No usage of org.marmot.framework.security.AbstractHttpAuthenticator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.security.AbstractHttpCurrentAccountAccessor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.security.AbstractHttpCurrentAccountAccessor

No usage of org.marmot.framework.security.AbstractHttpCurrentAccountAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.security.Account

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.security.Account

Packages that use Account
org.marmot.framework.dict.factory | 数据字典工厂的接口及相关实现.
org.marmot.framework.dorado | Marmot Framework提供的Dorado扩展.
org.marmot.framework.menu.factory | 动态菜单工厂的接口及相关实现.
org.marmot.framework.preference.manager |
org.marmot.framework.security | 权限功能的扩展接口及相关实现.

Uses of Account in org.marmot.framework.dict.factory

Methods in org.marmot.framework.dict.factory with parameters of type Account
FieldSet | DictionaryFactory.getFieldSet(Account account, String fieldSetName) 根据帐号信息和集合名返回一个数据字典中的字段信息集合.
Field | DictionaryFactory.getFieldSet(Account account, String fieldSetName, String fieldName) 根据帐号信息、集合名及字段名返回一个数据字典中的字段描述信息对象.
FieldSet | MarmotDictionaryFactory.getFieldSet(Account account, String fieldSetName)
Field | MarmotDictionaryFactory.getFieldSet(Account account, String fieldSetName, String fieldName)

Uses of Account in org.marmot.framework.dorado

Methods in org.marmot.framework.dorado that return Account
 Account SecurityExprHandler.getCurrentAccount()

Uses of Account in org.marmot.framework.menu.factory

Methods in org.marmot.framework.menu.factory with parameters of type Account
List | MarmotMenuFactory.getFavoritiesOfAccount(Account account)
List | MenuFactory.getFavoritiesOfAccount(Account account) 根据某帐号返回其所有收藏项的集合.

Uses of Account in org.marmot.framework.preference.manager

Methods in org.marmot.framework.preference.manager with parameters of type Account
void | PreferenceHandler.clearCache(Account account)
boolean | PreferenceHandler.containsProperty(Account account, String property)
String | PreferenceHandler.getString(Account account, String property)
void | PreferenceHandler.setString(Account account, String property, String value)

Uses of Account in org.marmot.framework.security

Methods in org.marmot.framework.security that return Account
Account | CurrentAccountAccessor.getCurrentAccount() 返回系统当前登录者的帐号信息.
static Account | SecurityUtils.getCurrentAccount()

Methods in org.marmot.framework.security with parameters of type Account
boolean | Authorizer.isAuthorized(Account account, Object resource) 根据传入的帐号信息和资源项进行权限验证,并返回逻辑值表示该帐号是否有权访问这一资源.
Set | ListableAuthorizer.getAuthorizedResources(Account account, Object parentResource) 根据某父资源项返回所有已授权给指定帐号的子资源项的集合.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.security.Authenticator

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.security.Authenticator

Packages that use Authenticator
org.marmot.framework.security 权限功能的扩展接口及相关实现.

Uses of Authenticator in org.marmot.framework.security

Classes in org.marmot.framework.security that implement Authenticator
 class AbstractHttpAuthenticator
支持获取HttpServletRequest对象的Authenticator抽象实现类.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.security.Authorizer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.security.Authorizer

Packages that use Authorizer
org.marmot.framework.security 权限功能的扩展接口及相关实现.

Uses of Authorizer in org.marmot.framework.security

Methods in org.marmot.framework.security with parameters of type Authorizer
 void SecurityUtils.setAuthorizer(Authorizer authorizer)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.security.CurrentAccountAccessor

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.security.CurrentAccountAccessor

Packages that use CurrentAccountAccessor
org.marmot.framework.security 权限功能的扩展接口及相关实现.

Uses of CurrentAccountAccessor in org.marmot.framework.security

Classes in org.marmot.framework.security that implement CurrentAccountAccessor
 class AbstractHttpCurrentAccountAccessor
支持获取HttpServletRequest对象的CurrentAccountAccessor抽象实现类.

Methods in org.marmot.framework.security with parameters of type CurrentAccountAccessor
 void SecurityUtils.setCurrentAccountAccessor(CurrentAccountAccessor currentAccountAccessor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.framework.security.ListableAuthorizer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.framework.security.ListableAuthorizer

No usage of org.marmot.framework.security.ListableAuthorizer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.security.SecurityUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.security.SecurityUtils

Packages that use SecurityUtils
org.marmot.framework.security 权限功能的扩展接口及相关实现.

Uses of SecurityUtils in org.marmot.framework.security

Methods in org.marmot.framework.security that return SecurityUtils
static SecurityUtils SecurityUtils.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.framework.util
Classes
DropDownInitializor
HibernateDaoUtils


org.marmot.framework.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.framework.util

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.framework.util.DropDownInitializor
    • class org.marmot.framework.util.HibernateDaoUtils


Uses of Package org.marmot.framework.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.framework.util

No usage of org.marmot.framework.util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.util.DropDownInitializor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.util.DropDownInitializor

No usage of org.marmot.framework.util.DropDownInitializor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.framework.util.HibernateDaoUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.framework.util.HibernateDaoUtils

No usage of org.marmot.framework.util.HibernateDaoUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.cache
Interfaces
AcegiCacheManager
ResourceDetails
Classes
AcegiCacheManagerImpl
ResourceCache
SecurityResource


org.marmot.security.cache Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.cache

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.springframework.dao.support.DaoSupport (implements org.springframework.beans.factory.InitializingBean)
      • class org.springframework.orm.hibernate3.support.HibernateDaoSupport
        • class org.marmot.security.cache.AcegiCacheManagerImpl (implements org.marmot.security.cache.AcegiCacheManager)
    • class org.marmot.security.cache.ResourceCache
    • class org.marmot.security.cache.SecurityResource (implements org.marmot.security.cache.ResourceDetails)

Interface Hierarchy

  • interface org.marmot.security.cache.AcegiCacheManager
  • interface java.io.Serializable
    • interface org.marmot.security.cache.ResourceDetails


Uses of Package org.marmot.security.cache

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.cache

Packages that use org.marmot.security.cache
org.marmot.security.cache
org.marmot.security.core
org.marmot.security.definition
org.marmot.security.intercept.method
org.marmot.security.intercept.web
org.marmot.security.view

Classes in org.marmot.security.cache used by org.marmot.security.cache
AcegiCacheManager
cache管理
ResourceCache
Caches Resource objects using a Spring IoC defined EHCACHE.
ResourceDetails
提供资源信息

Classes in org.marmot.security.cache used by org.marmot.security.core
ResourceCache
Caches Resource objects using a Spring IoC defined EHCACHE.

Classes in org.marmot.security.cache used by org.marmot.security.definition
AcegiCacheManager
cache管理

Classes in org.marmot.security.cache used by org.marmot.security.intercept.method
AcegiCacheManager
cache管理

Classes in org.marmot.security.cache used by org.marmot.security.intercept.web
AcegiCacheManager
cache管理

Classes in org.marmot.security.cache used by org.marmot.security.view
AcegiCacheManager
cache管理

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.cache.AcegiCacheManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.cache.AcegiCacheManager

Packages that use AcegiCacheManager
org.marmot.security.cache
org.marmot.security.definition
org.marmot.security.intercept.method
org.marmot.security.intercept.web
org.marmot.security.view

Uses of AcegiCacheManager in org.marmot.security.cache

Classes in org.marmot.security.cache that implement AcegiCacheManager
 class AcegiCacheManagerImpl
cache管理

Uses of AcegiCacheManager in org.marmot.security.definition

Methods in org.marmot.security.definition with parameters of type AcegiCacheManager
 void ResourceDefinitionSource.setAcegiCacheManager(AcegiCacheManager acegiCacheManager)

Uses of AcegiCacheManager in org.marmot.security.intercept.method

Methods in org.marmot.security.intercept.method with parameters of type AcegiCacheManager
 void DBMethodDefinitionSource.setAcegiCacheManager(AcegiCacheManager acegiCacheManager)

Uses of AcegiCacheManager in org.marmot.security.intercept.web

Methods in org.marmot.security.intercept.web with parameters of type AcegiCacheManager
 void DBFilterInvocationDefinitionSource.setAcegiCacheManager(AcegiCacheManager acegiCacheManager)

Uses of AcegiCacheManager in org.marmot.security.view

Methods in org.marmot.security.view that return AcegiCacheManager
AcegiCacheManager | ResourceBackBean.getCacheManager()
AcegiCacheManager | UserBackBean.getCacheManager()

Methods in org.marmot.security.view with parameters of type AcegiCacheManager
void | ResourceBackBean.setCacheManager(AcegiCacheManager cacheManager)
void | UserBackBean.setCacheManager(AcegiCacheManager cacheManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.cache.AcegiCacheManagerImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.cache.AcegiCacheManagerImpl

No usage of org.marmot.security.cache.AcegiCacheManagerImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.cache.ResourceCache

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.cache.ResourceCache

Packages that use ResourceCache
org.marmot.security.cache
org.marmot.security.core

Uses of ResourceCache in org.marmot.security.cache

Methods in org.marmot.security.cache that return ResourceCache
 ResourceCache AcegiCacheManagerImpl.getResourceCache()

Methods in org.marmot.security.cache with parameters of type ResourceCache
 void AcegiCacheManagerImpl.setResourceCache(ResourceCache resourceCache)

Uses of ResourceCache in org.marmot.security.core

Methods in org.marmot.security.core that return ResourceCache
 ResourceCache MarmotAuthenticationManager.getResourceCache()

Methods in org.marmot.security.core with parameters of type ResourceCache
 void MarmotAuthenticationManager.setResourceCache(ResourceCache resourceCache)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.cache.ResourceDetails

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.cache.ResourceDetails

Packages that use ResourceDetails
org.marmot.security.cache

Uses of ResourceDetails in org.marmot.security.cache

Classes in org.marmot.security.cache that implement ResourceDetails
 class SecurityResource
ResourceDetails的实现类

Methods in org.marmot.security.cache that return ResourceDetails
ResourceDetails | AcegiCacheManager.getAuthorityFromResourceCache(String resString) 根据资源串获取可以访问该资源的ResourceDetails信息
ResourceDetails | AcegiCacheManagerImpl.getAuthorityFromResourceCache(String resString) 根据资源串获取资源
ResourceDetails | ResourceCache.getAuthorityFromCache(String resString)

Methods in org.marmot.security.cache with parameters of type ResourceDetails
 void ResourceCache.putAuthorityInCache(ResourceDetails resourceDetails)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.cache.SecurityResource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.cache.SecurityResource

No usage of org.marmot.security.cache.SecurityResource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.core
Classes
MarmotAuthenticationManager


org.marmot.security.core Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.core

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.core.MarmotAuthenticationManager


Uses of Package org.marmot.security.core

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.core

No usage of org.marmot.security.core

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.core.MarmotAuthenticationManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.core.MarmotAuthenticationManager

No usage of org.marmot.security.core.MarmotAuthenticationManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.definition
Classes
ResourceDefinitionSource


org.marmot.security.definition Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.definition

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.definition.ResourceDefinitionSource


Uses of Package org.marmot.security.definition

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.definition

Packages that use org.marmot.security.definition
org.marmot.security.core

Classes in org.marmot.security.definition used by org.marmot.security.core
ResourceDefinitionSource
在resourceCache中保存每个方法对应的ResourceDetails

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.definition.ResourceDefinitionSource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.definition.ResourceDefinitionSource

Packages that use ResourceDefinitionSource
org.marmot.security.core

Uses of ResourceDefinitionSource in org.marmot.security.core

Methods in org.marmot.security.core that return ResourceDefinitionSource
 ResourceDefinitionSource MarmotAuthenticationManager.getResourceDefinitionSource()

Methods in org.marmot.security.core with parameters of type ResourceDefinitionSource
 void MarmotAuthenticationManager.setResourceDefinitionSource(ResourceDefinitionSource resourceDefinitionSource)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.domain
Classes
ProxyUser
ResCategory
Resource
ResourceCategory
Role
RoleRes
User
UserRole


org.marmot.security.domain Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.domain

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.domain.ProxyUser (implements java.io.Serializable)
    • class org.marmot.security.domain.ResCategory (implements java.io.Serializable)
    • class org.marmot.security.domain.Resource (implements java.io.Serializable)
    • class org.marmot.security.domain.ResourceCategory (implements java.io.Serializable)
    • class org.marmot.security.domain.Role (implements java.io.Serializable)
    • class org.marmot.security.domain.RoleRes (implements java.io.Serializable)
    • class org.marmot.security.domain.User (implements java.io.Serializable)
    • class org.marmot.security.domain.UserRole (implements java.io.Serializable)


Uses of Package org.marmot.security.domain

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.domain

Packages that use org.marmot.security.domain
org.marmot.security.cache
org.marmot.security.core
org.marmot.security.domain
org.marmot.security.filter
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.util
org.marmot.security.view

Classes in org.marmot.security.domain used by org.marmot.security.cache
Resource
Resource generated by hbm2java
Role
Role generated by hbm2java
User
User generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.core
Role
Role generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.domain
Resource
Resource generated by hbm2java
ResourceCategory
RescType generated by hbm2java
Role
Role generated by hbm2java
User
User generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.filter
Resource
Resource generated by hbm2java
ResourceCategory
RescType generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.manager
ResCategory
ResPermistype generated by hbm2java
Resource
Resource generated by hbm2java
ResourceCategory
RescType generated by hbm2java
Role
Role generated by hbm2java
RoleRes
RolePermi generated by hbm2java
User
User generated by hbm2java
UserRole
UserRole generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.service
Resource
Resource generated by hbm2java
ResourceCategory
RescType generated by hbm2java
Role
Role generated by hbm2java
User
User generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.util
Role
Role generated by hbm2java
User
User generated by hbm2java

Classes in org.marmot.security.domain used by org.marmot.security.view
ResourceCategory
RescType generated by hbm2java

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.ProxyUser

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.ProxyUser

No usage of org.marmot.security.domain.ProxyUser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.ResCategory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.ResCategory

Packages that use ResCategory
org.marmot.security.manager

Uses of ResCategory in org.marmot.security.manager

Methods in org.marmot.security.manager that return ResCategory
ResCategory | CategoryManager.getResourceCategory(String cetegoryId, String resourceId)
ResCategory | DefaultCategoryManager.getResourceCategory(String cetegoryId, String resourceId)

Methods in org.marmot.security.manager with parameters of type ResCategory
void | CategoryManager.saveResourceCategory(ResCategory category)
void | DefaultCategoryManager.saveResourceCategory(ResCategory category)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.Resource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.Resource

Packages that use Resource
org.marmot.security.cache
org.marmot.security.domain
org.marmot.security.filter
org.marmot.security.manager
org.marmot.security.service

Uses of Resource in org.marmot.security.cache

Methods in org.marmot.security.cache with parameters of type Resource
void | AcegiCacheManager.modifyResourceInCache(Resource resource, String orgResourcename) 修改resource信息时,更新系统缓存中的权限资源信息
void | AcegiCacheManagerImpl.modifyResourceInCache(Resource resource, String orgResourcename) 修改Resource时更改resourceCache

Uses of Resource in org.marmot.security.domain

Methods in org.marmot.security.domain that return Resource
Resource | ResCategory.getResource()
Resource | RoleRes.getResource()

Methods in org.marmot.security.domain with parameters of type Resource
void | ResCategory.setResource(Resource resource)
void | RoleRes.setResource(Resource resource)

Constructors in org.marmot.security.domain with parameters of type Resource
ResCategory(String id, ResourceCategory category, Resource resource)

Uses of Resource in org.marmot.security.filter

Methods in org.marmot.security.filter that return Resource
 Resource FilterAccessor.initResource(ResourceCategory category, String resString, String name)

Methods in org.marmot.security.filter with parameters of type Resource
void | FilterAccessor.initResourceCategory(ResourceCategory category, Resource resource)
void | FilterUtils.initResourceCategory(ResourceCategory category, Resource resource)

Uses of Resource in org.marmot.security.manager

Methods in org.marmot.security.manager that return Resource
Resource | DefaultResourceManager.getResource(String id)
Resource | ResourceManager.getResource(String id)

Methods in org.marmot.security.manager with parameters of type Resource
void | DefaultResourceManager.deleteResource(Resource resource)
void | DefaultResourceManager.saveResource(Resource resource)
void | DefaultResourceManager.updateResource(Resource resource)
void | DefaultResourceManager.changeStatus(Resource resource)
void | ResourceManager.saveResource(Resource resource)
void | ResourceManager.updateResource(Resource resource)
void | ResourceManager.deleteResource(Resource resource)
void | ResourceManager.changeStatus(Resource resource)

Uses of Resource in org.marmot.security.service

Methods in org.marmot.security.service that return Resource
 Resource ResourceService.getResourceByResString(String resString)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.ResourceCategory

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.ResourceCategory

Packages that use ResourceCategory
org.marmot.security.domain
org.marmot.security.filter
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.view

Uses of ResourceCategory in org.marmot.security.domain

Methods in org.marmot.security.domain that return ResourceCategory
 ResourceCategory ResCategory.getCategory()

Methods in org.marmot.security.domain with parameters of type ResourceCategory
 void ResCategory.setCategory(ResourceCategory category)

Constructors in org.marmot.security.domain with parameters of type ResourceCategory
ResCategory(String id, ResourceCategory category, Resource resource)

Uses of ResourceCategory in org.marmot.security.filter

Methods in org.marmot.security.filter that return ResourceCategory
ResourceCategory | AutoFormFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | CategoryFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | DataTableFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | DatasetFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | FilterAccessor.asyncCategory(ResourceCategory category, boolean async)
ResourceCategory | FilterUtils.initCategory(String type, com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | FilterUtils.asyncCategory(ResourceCategory category, boolean async)
ResourceCategory | OutlookBarFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | SimpleFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parent, ResourceCategory viewCategory, boolean async)
ResourceCategory | TabSetFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)

Methods in org.marmot.security.filter with parameters of type ResourceCategory
ResourceCategory | AutoFormFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | CategoryFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | DataTableFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | DatasetFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
Resource | FilterAccessor.initResource(ResourceCategory category, String resString, String name)
void | FilterAccessor.initResourceCategory(ResourceCategory category, Resource resource)
void | FilterAccessor.updateCategory(ResourceCategory category)
ResourceCategory | FilterAccessor.asyncCategory(ResourceCategory category, boolean async)
ResourceCategory | FilterUtils.initCategory(String type, com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | FilterUtils.asyncCategory(ResourceCategory category, boolean async)
void | FilterUtils.initResourceCategory(ResourceCategory category, Resource resource)
ResourceCategory | OutlookBarFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)
ResourceCategory | SimpleFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parent, ResourceCategory viewCategory, boolean async)
ResourceCategory | TabSetFilter.initCategory(com.bstek.dorado.utils.xml.XmlNode node, ResourceCategory parentCategory, ResourceCategory viewCategory, boolean async)

Uses of ResourceCategory in org.marmot.security.manager

Methods in org.marmot.security.manager that return ResourceCategory
ResourceCategory | CategoryManager.getCategory(String id)
ResourceCategory | DefaultCategoryManager.getCategory(String id)

Methods in org.marmot.security.manager with parameters of type ResourceCategory
void | CategoryManager.saveCategory(ResourceCategory category)
void | CategoryManager.updateCategory(ResourceCategory category)
void | CategoryManager.deleteCategory(ResourceCategory category)
void | DefaultCategoryManager.deleteCategory(ResourceCategory category)
void | DefaultCategoryManager.saveCategory(ResourceCategory category)
void | DefaultCategoryManager.updateCategory(ResourceCategory category)
void | DefaultRoleResourceManager.removeAllWithSubItems(String roleId, ResourceCategory category)
void | DefaultRoleResourceManager.saveAllWithSubItems(String roleId, ResourceCategory category)
void | RoleResourceManager.saveAllWithSubItems(String roleId, ResourceCategory category)
void | RoleResourceManager.removeAllWithSubItems(String roleId, ResourceCategory category)

Uses of ResourceCategory in org.marmot.security.service

Methods in org.marmot.security.service that return ResourceCategory
 ResourceCategory ResourceCategoryService.getCategory(String id)

Methods in org.marmot.security.service with parameters of type ResourceCategory
void | ResourceCategoryService.save(ResourceCategory category)
void | ResourceCategoryService.update(ResourceCategory category)
void | ResourceCategoryService.delete(ResourceCategory category)

Uses of ResourceCategory in org.marmot.security.view

Methods in org.marmot.security.view with parameters of type ResourceCategory
void | CategoryAccessor.removeAllCategory(ResourceCategory category)
int | CategoryAccessor.loadView(ResourceCategory viewCategory, boolean async)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.Role

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.Role

Packages that use Role
org.marmot.security.cache
org.marmot.security.core
org.marmot.security.domain
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.util

Uses of Role in org.marmot.security.cache

Methods in org.marmot.security.cache with parameters of type Role
void | AcegiCacheManagerImpl.modifyRoleInCache(Role role, String orgRolename) 修改Role时同时修改userCache和resourceCache
void | AcegiCacheManagerImpl.authResourceInCache(Role role) Role授予资源时更改resourceCache

Uses of Role in org.marmot.security.core

Methods in org.marmot.security.core with parameters of type Role
 boolean MarmotAuthenticationManager.authentication(Role role, String resource)

Uses of Role in org.marmot.security.domain

Methods in org.marmot.security.domain that return Role
Role | ProxyUser.getRole()
Role | RoleRes.getRole()
Role | UserRole.getRole()

Methods in org.marmot.security.domain with parameters of type Role
void | ProxyUser.setRole(Role role)
void | RoleRes.setRole(Role role)
void | UserRole.setRole(Role role)

Constructors in org.marmot.security.domain with parameters of type Role
RoleRes(String id, Role role)
UserRole(String id, User user, Role role)

Uses of Role in org.marmot.security.manager

Methods in org.marmot.security.manager that return Role
Role | DefaultRoleManager.getRole(String id)
Role | RoleManager.getRole(String id)

Methods in org.marmot.security.manager with parameters of type Role
void | DefaultRoleManager.saveRole(Role role)
void | DefaultRoleManager.updateRole(Role role)
void | DefaultRoleManager.deleteRole(Role role)
void | DefaultUserRoleManager.saveRole(Role role)
void | DefaultUserRoleManager.updateRole(Role role)
void | DefaultUserRoleManager.deleteRole(Role role)
void | DefaultUserRoleManager.removeProxyUser(User user, User proxyTargetUser, Role role)
void | RoleManager.saveRole(Role role)
void | RoleManager.updateRole(Role role)
void | RoleManager.deleteRole(Role role)

Uses of Role in org.marmot.security.service

Methods in org.marmot.security.service with parameters of type Role
 List UserRoleService.getUsersByRole(Role role, boolean loadProxy)

Uses of Role in org.marmot.security.util

Methods in org.marmot.security.util with parameters of type Role
static boolean SecurityUtils.authentication(Role role, String resource)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.RoleRes

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.RoleRes

Packages that use RoleRes
org.marmot.security.manager

Uses of RoleRes in org.marmot.security.manager

Methods in org.marmot.security.manager that return RoleRes
RoleRes | DefaultRoleResourceManager.getRoleResource(String roleId, String resourceId)
RoleRes | RoleResourceManager.getRoleResource(String roleId, String resourceId)

Methods in org.marmot.security.manager with parameters of type RoleRes
void | DefaultRoleResourceManager.deleteRoleResource(RoleRes roleResc)
void | DefaultRoleResourceManager.saveRoleResource(RoleRes roleResc)
void | RoleResourceManager.saveRoleResource(RoleRes roleResc)
void | RoleResourceManager.deleteRoleResource(RoleRes roleResc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.User

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.User

Packages that use User
org.marmot.security.cache
org.marmot.security.domain
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.util

Uses of User in org.marmot.security.cache

Methods in org.marmot.security.cache with parameters of type User
void | AcegiCacheManager.modifyUserInCache(User user, String orgUsername) 修改User时更改userCache?
void | AcegiCacheManagerImpl.modifyUserInCache(User user, String orgUsername) 修改User时更改userCache
void | AcegiCacheManagerImpl.authRoleInCache(User user) User授予角色时更改userCache

Uses of User in org.marmot.security.domain

Methods in org.marmot.security.domain that return User
User | ProxyUser.getUserByUserId()
User | ProxyUser.getUserByProxyUserId()
User | UserRole.getUser()

Methods in org.marmot.security.domain with parameters of type User
void | ProxyUser.setUserByUserId(User userByUserId)
void | ProxyUser.setUserByProxyUserId(User userByProxyUserId)
void | UserRole.setUser(User user)

Constructors in org.marmot.security.domain with parameters of type User
UserRole(String id, User user, Role role)

Uses of User in org.marmot.security.manager

Methods in org.marmot.security.manager that return User
User | DefaultUserManager.getUser(String id)
User | UserManager.getUser(String id)

Methods in org.marmot.security.manager with parameters of type User
void | DefaultUserManager.saveUser(User user)
void | DefaultUserManager.updateUser(User user)
void | DefaultUserManager.deleteUser(User user)
void | DefaultUserManager.changePwd(User currentUser, String oldPwd, String newPwd)
void | DefaultUserManager.changeRoot(User user)
void | DefaultUserManager.changeStatus(User user)
List | DefaultUserRoleManager.getProxyUsers(User user)
List | DefaultUserRoleManager.getProxyRoles(User user)
List | DefaultUserRoleManager.getUnProxyUsers(User user)
List | DefaultUserRoleManager.getAllRoles(User user)
void | DefaultUserRoleManager.removeProxyUser(User user, User proxyTargetUser)
void | DefaultUserRoleManager.removeProxyUser(User user, User proxyTargetUser, Role role)
void | DefaultUserRoleManager.proxyRoles(User user, User proxyTargetUser, Collection roles, Date activeTime, Date dormantTime)
void | UserManager.saveUser(User user)
void | UserManager.updateUser(User user)
void | UserManager.deleteUser(User user)
void | UserManager.changePwd(User currentUser, String oldPwd, String newPwd)
void | UserManager.changeRoot(User user)
void | UserManager.changeStatus(User user)
List | UserRoleManager.getProxyUsers(User user)
List | UserRoleManager.getProxyRoles(User user)
List | UserRoleManager.getAllRoles(User user)
void | UserRoleManager.removeProxyUser(User currentUser, User proxyTargetUser)
void | UserRoleManager.proxyRoles(User currentUser, User proxyTargetUser, Collection roles, Date activeTime, Date dormantTime)

Uses of User in org.marmot.security.service

Methods in org.marmot.security.service that return User
 User UserService.loadSecurityUserByUsername(String username)

Methods in org.marmot.security.service with parameters of type User
List | UserRoleService.getRolesByUser(User user, boolean loadProxy)
List | UserRoleService.getProxyUsers(User user)
List | UserRoleService.getProxyRoles(User user)

Uses of User in org.marmot.security.util

Methods in org.marmot.security.util that return User
static User SecurityUtils.getCurrentUser()
返回当前已登录到权限系统的的系统账号。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.domain.UserRole

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.domain.UserRole

Packages that use UserRole
org.marmot.security.manager

Uses of UserRole in org.marmot.security.manager

Methods in org.marmot.security.manager that return UserRole
UserRole | DefaultUserRoleManager.addUserRole(String userId, String roleId)
UserRole | UserRoleManager.addUserRole(String userId, String roleId)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.dorado
Classes
MarmotSecurityViewModel
SecurityViewModel


org.marmot.security.dorado Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.dorado

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.ViewModelSupport (implements com.bstek.dorado.view.ViewModel)
      • class com.bstek.dorado.view.DefaultViewModel
        • class com.bstek.dorado.view.impl.DynaViewModel
          • class org.marmot.security.dorado.SecurityViewModel
        • class org.marmot.framework.dorado.MarmotViewModel
          • class org.marmot.security.dorado.MarmotSecurityViewModel


Uses of Package org.marmot.security.dorado

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.dorado

No usage of org.marmot.security.dorado

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.dorado.MarmotSecurityViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.dorado.MarmotSecurityViewModel

No usage of org.marmot.security.dorado.MarmotSecurityViewModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.dorado.SecurityViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.dorado.SecurityViewModel

No usage of org.marmot.security.dorado.SecurityViewModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.exception
Exceptions
MarmotMethodAccessDeniedException


org.marmot.security.exception Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.exception

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class org.springframework.core.NestedRuntimeException
            • class org.acegisecurity.AcegiSecurityException
              • class org.acegisecurity.AccessDeniedException
                • class org.marmot.security.exception.MarmotMethodAccessDeniedException


Uses of Package org.marmot.security.exception

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.exception

No usage of org.marmot.security.exception

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.exception.MarmotMethodAccessDeniedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.exception.MarmotMethodAccessDeniedException

No usage of org.marmot.security.exception.MarmotMethodAccessDeniedException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.filter
Interfaces
CategoryFilter
ControlFilter
Classes
AutoFormFilter
DatasetFilter
DataTableFilter
FilterAccessor
FilterUtils
OutlookBarFilter
PropertiesInfo
SimpleFilter
TabSetFilter


org.marmot.security.filter Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.filter

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.filter.AutoFormFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.security.filter.DatasetFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.security.filter.DataTableFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.security.filter.FilterAccessor
    • class org.marmot.security.filter.FilterUtils
    • class org.marmot.security.filter.OutlookBarFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.security.filter.PropertiesInfo
    • class org.marmot.security.filter.SimpleFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)
    • class org.marmot.security.filter.TabSetFilter (implements org.marmot.security.filter.CategoryFilter, org.marmot.security.filter.ControlFilter)

Interface Hierarchy

  • interface org.marmot.security.filter.CategoryFilter
  • interface org.marmot.security.filter.ControlFilter


Uses of Package org.marmot.security.filter

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.filter

Packages that use org.marmot.security.filter
org.marmot.security.dorado
org.marmot.security.filter
org.marmot.security.view

Classes in org.marmot.security.filter used by org.marmot.security.dorado
FilterUtils

Classes in org.marmot.security.filter used by org.marmot.security.filter
CategoryFilter
ControlFilter
FilterAccessor

Classes in org.marmot.security.filter used by org.marmot.security.view
FilterUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.AutoFormFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.AutoFormFilter

No usage of org.marmot.security.filter.AutoFormFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.filter.CategoryFilter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.filter.CategoryFilter

Packages that use CategoryFilter
org.marmot.security.filter

Uses of CategoryFilter in org.marmot.security.filter

Classes in org.marmot.security.filter that implement CategoryFilter
class | AutoFormFilter
class | DatasetFilter
class | DataTableFilter
class | OutlookBarFilter
class | SimpleFilter
class | TabSetFilter

Methods in org.marmot.security.filter that return CategoryFilter
 CategoryFilter FilterUtils.getDefaultCategoryFilter()

Methods in org.marmot.security.filter with parameters of type CategoryFilter
 void FilterUtils.setDefaultCategoryFilter(CategoryFilter defaultFilter)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.filter.ControlFilter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.filter.ControlFilter

Packages that use ControlFilter
org.marmot.security.filter

Uses of ControlFilter in org.marmot.security.filter

Classes in org.marmot.security.filter that implement ControlFilter
class | AutoFormFilter
class | DatasetFilter
class | DataTableFilter
class | OutlookBarFilter
class | SimpleFilter
class | TabSetFilter

Methods in org.marmot.security.filter that return ControlFilter
 ControlFilter FilterUtils.getDefaultControlFilter()

Methods in org.marmot.security.filter with parameters of type ControlFilter
 void FilterUtils.setDefaultControlFilter(ControlFilter defaultControlFilter)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.DatasetFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.DatasetFilter

No usage of org.marmot.security.filter.DatasetFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.DataTableFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.DataTableFilter

No usage of org.marmot.security.filter.DataTableFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.FilterAccessor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.FilterAccessor

Packages that use FilterAccessor
org.marmot.security.filter

Uses of FilterAccessor in org.marmot.security.filter

Methods in org.marmot.security.filter that return FilterAccessor
FilterAccessor | AutoFormFilter.getFilterAccessor()
FilterAccessor | DataTableFilter.getFilterAccessor()
FilterAccessor | DatasetFilter.getFilterAccessor()
FilterAccessor | FilterUtils.getFilterAccessor()
FilterAccessor | OutlookBarFilter.getFilterAccessor()
FilterAccessor | SimpleFilter.getFilterAccessor()
FilterAccessor | TabSetFilter.getFilterAccessor()

Methods in org.marmot.security.filter with parameters of type FilterAccessor
void | AutoFormFilter.setFilterAccessor(FilterAccessor categoryAccessor)
void | DataTableFilter.setFilterAccessor(FilterAccessor categoryAccessor)
void | DatasetFilter.setFilterAccessor(FilterAccessor categoryAccessor)
void | FilterUtils.setFilterAccessor(FilterAccessor categoryHelper)
void | OutlookBarFilter.setFilterAccessor(FilterAccessor categoryAccessor)
void | SimpleFilter.setFilterAccessor(FilterAccessor categoryAccessor)
void | TabSetFilter.setFilterAccessor(FilterAccessor categoryAccessor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.FilterUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.FilterUtils

Packages that use FilterUtils
org.marmot.security.dorado
org.marmot.security.view

Uses of FilterUtils in org.marmot.security.dorado

Methods in org.marmot.security.dorado that return FilterUtils
FilterUtils | MarmotSecurityViewModel.getfilterUtils()
FilterUtils | SecurityViewModel.getFilterUtils()

Uses of FilterUtils in org.marmot.security.view

Methods in org.marmot.security.view that return FilterUtils
 FilterUtils CategoryAccessor.getFilterUtils()

Methods in org.marmot.security.view with parameters of type FilterUtils
 void CategoryAccessor.setFilterUtils(FilterUtils categoryUtils)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.OutlookBarFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.OutlookBarFilter

No usage of org.marmot.security.filter.OutlookBarFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.PropertiesInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.PropertiesInfo

No usage of org.marmot.security.filter.PropertiesInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.SimpleFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.SimpleFilter

No usage of org.marmot.security.filter.SimpleFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.filter.TabSetFilter

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.filter.TabSetFilter

No usage of org.marmot.security.filter.TabSetFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.intercept.method
Classes
DBMethodDefinitionSource


org.marmot.security.intercept.method Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.intercept.method

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.intercept.method.DBMethodDefinitionSource (implements org.acegisecurity.intercept.method.MethodDefinitionSource)


Uses of Package org.marmot.security.intercept.method

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.intercept.method

No usage of org.marmot.security.intercept.method

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.intercept.method.aopalliance
Classes
MarmotMethodSecurityInterceptor


org.marmot.security.intercept.method.aopalliance Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.intercept.method.aopalliance

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.acegisecurity.intercept.AbstractSecurityInterceptor (implements org.springframework.context.ApplicationEventPublisherAware, org.springframework.beans.factory.InitializingBean, org.springframework.context.MessageSourceAware)
      • class org.acegisecurity.intercept.method.aopalliance.MethodSecurityInterceptor (implements org.aopalliance.intercept.MethodInterceptor)
        • class org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor


Uses of Package org.marmot.security.intercept.method.aopalliance

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.intercept.method.aopalliance

No usage of org.marmot.security.intercept.method.aopalliance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor

No usage of org.marmot.security.intercept.method.aopalliance.MarmotMethodSecurityInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.intercept.method.DBMethodDefinitionSource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.intercept.method.DBMethodDefinitionSource

No usage of org.marmot.security.intercept.method.DBMethodDefinitionSource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.intercept.web
Classes
DBFilterInvocationDefinitionSource
FilterSecurityInterceptor


org.marmot.security.intercept.web Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.intercept.web

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.acegisecurity.intercept.web.AbstractFilterInvocationDefinitionSource (implements org.acegisecurity.intercept.web.FilterInvocationDefinitionSource)
      • class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource
    • class org.acegisecurity.intercept.AbstractSecurityInterceptor (implements org.springframework.context.ApplicationEventPublisherAware, org.springframework.beans.factory.InitializingBean, org.springframework.context.MessageSourceAware)
      • class org.marmot.security.intercept.web.FilterSecurityInterceptor (implements javax.servlet.Filter)


Uses of Package org.marmot.security.intercept.web

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.intercept.web

No usage of org.marmot.security.intercept.web

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource

No usage of org.marmot.security.intercept.web.DBFilterInvocationDefinitionSource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.intercept.web.FilterSecurityInterceptor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.intercept.web.FilterSecurityInterceptor

No usage of org.marmot.security.intercept.web.FilterSecurityInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.manager
Interfaces
CategoryManager
ResourceManager
RoleManager
RoleResourceManager
UserManager
UserRoleManager
Classes
DefaultCategoryManager
DefaultResourceManager
DefaultRoleManager
DefaultRoleResourceManager
DefaultUserManager
DefaultUserRoleManager


org.marmot.security.manager Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.manager

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.manager.DefaultCategoryManager (implements org.marmot.security.manager.CategoryManager)
    • class org.marmot.security.manager.DefaultResourceManager (implements org.marmot.security.manager.ResourceManager)
    • class org.marmot.security.manager.DefaultRoleManager (implements org.marmot.security.manager.RoleManager)
    • class org.marmot.security.manager.DefaultRoleResourceManager (implements org.marmot.security.manager.RoleResourceManager)
    • class org.marmot.security.manager.DefaultUserManager (implements org.marmot.security.manager.UserManager)
    • class org.marmot.security.manager.DefaultUserRoleManager (implements org.marmot.security.manager.UserRoleManager)

Interface Hierarchy

  • interface org.marmot.security.manager.CategoryManager
  • interface org.marmot.security.manager.ResourceManager
  • interface org.marmot.security.manager.RoleManager
  • interface org.marmot.security.manager.RoleResourceManager
  • interface org.marmot.security.manager.UserManager
  • interface org.marmot.security.manager.UserRoleManager


Uses of Package org.marmot.security.manager

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.manager

Packages that use org.marmot.security.manager
org.marmot.security.manager
org.marmot.security.view

Classes in org.marmot.security.manager used by org.marmot.security.manager
CategoryManager
ResourceManager
RoleManager
RoleResourceManager
UserManager
UserRoleManager

Classes in org.marmot.security.manager used by org.marmot.security.view
CategoryManager
ResourceManager
RoleManager
RoleResourceManager
UserManager
UserRoleManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.manager.CategoryManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.manager.CategoryManager

Packages that use CategoryManager
org.marmot.security.manager
org.marmot.security.view

Uses of CategoryManager in org.marmot.security.manager

Classes in org.marmot.security.manager that implement CategoryManager
 class DefaultCategoryManager

Uses of CategoryManager in org.marmot.security.view

Methods in org.marmot.security.view that return CategoryManager
CategoryManager | CategoryBackBean.getCategoryManager()
CategoryManager | PermissionAccessor.getCategoryManager()
CategoryManager | PermissionBackBean.getCategoryManager()

Methods in org.marmot.security.view with parameters of type CategoryManager
void | CategoryBackBean.setCategoryManager(CategoryManager categoryManager)
void | PermissionAccessor.setCategoryManager(CategoryManager categoryManager)
void | PermissionBackBean.setCategoryManager(CategoryManager categoryManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.manager.DefaultCategoryManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.manager.DefaultCategoryManager

No usage of org.marmot.security.manager.DefaultCategoryManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.manager.DefaultResourceManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.manager.DefaultResourceManager

No usage of org.marmot.security.manager.DefaultResourceManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.manager.DefaultRoleManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.manager.DefaultRoleManager

No usage of org.marmot.security.manager.DefaultRoleManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.manager.DefaultRoleResourceManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.manager.DefaultRoleResourceManager

No usage of org.marmot.security.manager.DefaultRoleResourceManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.manager.DefaultUserManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.manager.DefaultUserManager

No usage of org.marmot.security.manager.DefaultUserManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.manager.DefaultUserRoleManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.manager.DefaultUserRoleManager

No usage of org.marmot.security.manager.DefaultUserRoleManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.manager.ResourceManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.manager.ResourceManager

Packages that use ResourceManager
org.marmot.security.manager
org.marmot.security.view

Uses of ResourceManager in org.marmot.security.manager

Classes in org.marmot.security.manager that implement ResourceManager
 class DefaultResourceManager

Uses of ResourceManager in org.marmot.security.view

Methods in org.marmot.security.view that return ResourceManager
ResourceManager | CategoryBackBean.getResourceManager()
ResourceManager | PermissionBackBean.getResourceManager()
ResourceManager | ResourceBackBean.getResourceManager()

Methods in org.marmot.security.view with parameters of type ResourceManager
void | CategoryBackBean.setResourceManager(ResourceManager resourceManager)
void | PermissionBackBean.setResourceManager(ResourceManager resourceManager)
void | ResourceBackBean.setResourceManager(ResourceManager resourceManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.manager.RoleManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.manager.RoleManager

Packages that use RoleManager
org.marmot.security.manager
org.marmot.security.view

Uses of RoleManager in org.marmot.security.manager

Classes in org.marmot.security.manager that implement RoleManager
 class DefaultRoleManager

Uses of RoleManager in org.marmot.security.view

Methods in org.marmot.security.view that return RoleManager
RoleManager | PermissionBackBean.getRoleManager()
RoleManager | RoleBackBean.getRoleManager()

Methods in org.marmot.security.view with parameters of type RoleManager
void | PermissionBackBean.setRoleManager(RoleManager roleManager)
void | RoleBackBean.setRoleManager(RoleManager roleManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.manager.RoleResourceManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.manager.RoleResourceManager

Packages that use RoleResourceManager
org.marmot.security.manager
org.marmot.security.view

Uses of RoleResourceManager in org.marmot.security.manager

Classes in org.marmot.security.manager that implement RoleResourceManager
 class DefaultRoleResourceManager

Uses of RoleResourceManager in org.marmot.security.view

Methods in org.marmot.security.view that return RoleResourceManager
RoleResourceManager | PermissionBackBean.getRoleResourceManager()
RoleResourceManager | ResourceBackBean.getRoleResourceManager()

Methods in org.marmot.security.view with parameters of type RoleResourceManager
void | PermissionBackBean.setRoleResourceManager(RoleResourceManager roleResourceManager)
void | ResourceBackBean.setRoleResourceManager(RoleResourceManager roleResourceManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.manager.UserManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.manager.UserManager

Packages that use UserManager
org.marmot.security.manager
org.marmot.security.view

Uses of UserManager in org.marmot.security.manager

Classes in org.marmot.security.manager that implement UserManager
 class DefaultUserManager

Uses of UserManager in org.marmot.security.view

Methods in org.marmot.security.view that return UserManager
UserManager | ProxyBackBean.getUserManager()
UserManager | UserBackBean.getUserManager()

Methods in org.marmot.security.view with parameters of type UserManager
void | ProxyBackBean.setUserManager(UserManager userManager)
void | UserBackBean.setUserManager(UserManager userManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.marmot.security.manager.UserRoleManager

PREV NEXT FRAMES NO FRAMES

Uses of Interface
org.marmot.security.manager.UserRoleManager

Packages that use UserRoleManager
org.marmot.security.manager
org.marmot.security.view

Uses of UserRoleManager in org.marmot.security.manager

Classes in org.marmot.security.manager that implement UserRoleManager
 class DefaultUserRoleManager

Uses of UserRoleManager in org.marmot.security.view

Methods in org.marmot.security.view that return UserRoleManager
UserRoleManager | PermissionBackBean.getUserRoleManager()
UserRoleManager | ProxyBackBean.getUserRoleManager()
UserRoleManager | RoleBackBean.getUserRoleManager()
UserRoleManager | UserBackBean.getUserRoleManager()

Methods in org.marmot.security.view with parameters of type UserRoleManager
void | PermissionBackBean.setUserRoleManager(UserRoleManager userRoleManager)
void | ProxyBackBean.setUserRoleManager(UserRoleManager userRoleManager)
void | RoleBackBean.setUserRoleManager(UserRoleManager userRoleManager)
void | UserBackBean.setUserRoleManager(UserRoleManager userRoleManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.service
Classes
PaginationSupport
ResourceCategoryService
ResourceService
ServiceUtil
UserRoleService
UserService


org.marmot.security.service Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.service

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.springframework.dao.support.DaoSupport (implements org.springframework.beans.factory.InitializingBean)
      • class org.springframework.orm.hibernate3.support.HibernateDaoSupport
        • class org.marmot.security.service.ResourceCategoryService
        • class org.marmot.security.service.ResourceService
        • class org.marmot.security.service.ServiceUtil
          • class org.marmot.security.service.UserRoleService
    • class org.marmot.security.service.PaginationSupport
    • class org.marmot.security.service.UserService (implements org.acegisecurity.userdetails.UserDetailsService)


Uses of Package org.marmot.security.service

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.service

Packages that use org.marmot.security.service
org.marmot.security.cache
org.marmot.security.core
org.marmot.security.filter
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.view

Classes in org.marmot.security.service used by org.marmot.security.cache
UserRoleService

Classes in org.marmot.security.service used by org.marmot.security.core
UserService

Classes in org.marmot.security.service used by org.marmot.security.filter
ServiceUtil

Classes in org.marmot.security.service used by org.marmot.security.manager
ResourceCategoryService
ServiceUtil
UserRoleService

Classes in org.marmot.security.service used by org.marmot.security.service
PaginationSupport
ServiceUtil
UserRoleService

Classes in org.marmot.security.service used by org.marmot.security.view
ServiceUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.service.PaginationSupport

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.service.PaginationSupport

Packages that use PaginationSupport
org.marmot.security.service

Uses of PaginationSupport in org.marmot.security.service

Methods in org.marmot.security.service that return PaginationSupport
PaginationSupport | ServiceUtil.findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria)
PaginationSupport | ServiceUtil.findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria, int startIndex)
PaginationSupport | ServiceUtil.findPageByCriteria(org.hibernate.criterion.DetachedCriteria detachedCriteria, int pageSize, int startIndex)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.service.ResourceCategoryService

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.service.ResourceCategoryService

Packages that use ResourceCategoryService
org.marmot.security.manager

Uses of ResourceCategoryService in org.marmot.security.manager

Methods in org.marmot.security.manager that return ResourceCategoryService
 ResourceCategoryService DefaultCategoryManager.getCategoryService()

Methods in org.marmot.security.manager with parameters of type ResourceCategoryService
 void DefaultCategoryManager.setCategoryService(ResourceCategoryService categoryManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.service.ResourceService

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.service.ResourceService

No usage of org.marmot.security.service.ResourceService

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.service.ServiceUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.service.ServiceUtil

Packages that use ServiceUtil
org.marmot.security.filter
org.marmot.security.manager
org.marmot.security.service
org.marmot.security.view

Uses of ServiceUtil in org.marmot.security.filter

Methods in org.marmot.security.filter that return ServiceUtil
 ServiceUtil FilterAccessor.getServiceUtil()

Methods in org.marmot.security.filter with parameters of type ServiceUtil
 void FilterAccessor.setServiceUtil(ServiceUtil daoManager)

Uses of ServiceUtil in org.marmot.security.manager

Methods in org.marmot.security.manager that return ServiceUtil
ServiceUtil | DefaultResourceManager.getServiceUtil()
ServiceUtil | DefaultRoleResourceManager.getServiceUtil()

Methods in org.marmot.security.manager with parameters of type ServiceUtil
void | DefaultResourceManager.setServiceUtil(ServiceUtil daoManager)
void | DefaultRoleResourceManager.setServiceUtil(ServiceUtil daoManager)

Uses of ServiceUtil in org.marmot.security.service

Subclasses of ServiceUtil in org.marmot.security.service
 class UserRoleService

Uses of ServiceUtil in org.marmot.security.view

Methods in org.marmot.security.view that return ServiceUtil
 ServiceUtil CategoryAccessor.getServiceUtil()

Methods in org.marmot.security.view with parameters of type ServiceUtil
 void CategoryAccessor.setServiceUtil(ServiceUtil daoManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.service.UserRoleService

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.service.UserRoleService

Packages that use UserRoleService
org.marmot.security.cache
org.marmot.security.manager
org.marmot.security.service

Uses of UserRoleService in org.marmot.security.cache

Methods in org.marmot.security.cache that return UserRoleService
 UserRoleService AcegiCacheManagerImpl.getUserRoleService()

Methods in org.marmot.security.cache with parameters of type UserRoleService
 void AcegiCacheManagerImpl.setUserRoleService(UserRoleService userRoleDao)

Uses of UserRoleService in org.marmot.security.manager

Methods in org.marmot.security.manager that return UserRoleService
UserRoleService | DefaultRoleManager.getUserRoleService()
UserRoleService | DefaultUserManager.getUserRoleService()
UserRoleService | DefaultUserRoleManager.getUserRoleService()

Methods in org.marmot.security.manager with parameters of type UserRoleService
void | DefaultRoleManager.setUserRoleService(UserRoleService userRoleDao)
void | DefaultUserManager.setUserRoleService(UserRoleService userRoleDao)
void | DefaultUserRoleManager.setUserRoleService(UserRoleService userRoleManager)

Uses of UserRoleService in org.marmot.security.service

Methods in org.marmot.security.service that return UserRoleService
 UserRoleService UserService.getUserRoleService()

Methods in org.marmot.security.service with parameters of type UserRoleService
 void UserService.setUserRoleService(UserRoleService daoManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.service.UserService

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.service.UserService

Packages that use UserService
org.marmot.security.core

Uses of UserService in org.marmot.security.core

Methods in org.marmot.security.core that return UserService
 UserService MarmotAuthenticationManager.getUserService()

Methods in org.marmot.security.core with parameters of type UserService
 void MarmotAuthenticationManager.setUserService(UserService userService)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.util
Classes
SecurityUtils


org.marmot.security.util Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.util

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.util.SecurityUtils


Uses of Package org.marmot.security.util

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.util

No usage of org.marmot.security.util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.util.SecurityUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.util.SecurityUtils

No usage of org.marmot.security.util.SecurityUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.marmot.security.view
Classes
CategoryAccessor
CategoryBackBean
Permission
PermissionAccessor
PermissionBackBean
ProxyBackBean
ResourceBackBean
RoleBackBean
UserBackBean


org.marmot.security.view Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package org.marmot.security.view

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.marmot.security.view.CategoryAccessor
    • class org.marmot.security.view.CategoryBackBean
    • class org.marmot.security.view.Permission
    • class org.marmot.security.view.PermissionAccessor
    • class org.marmot.security.view.PermissionBackBean
    • class org.marmot.security.view.ProxyBackBean
    • class org.marmot.security.view.ResourceBackBean
    • class org.marmot.security.view.RoleBackBean
    • class org.marmot.security.view.UserBackBean
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.marmot.security.view

PREV NEXT FRAMES NO FRAMES

Uses of Package
org.marmot.security.view

Packages that use org.marmot.security.view
org.marmot.security.view

Classes in org.marmot.security.view used by org.marmot.security.view
CategoryAccessor
PermissionAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.CategoryAccessor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.CategoryAccessor

Packages that use CategoryAccessor
org.marmot.security.view

Uses of CategoryAccessor in org.marmot.security.view

Methods in org.marmot.security.view that return CategoryAccessor
 CategoryAccessor CategoryBackBean.getCategoryAccessor()

Methods in org.marmot.security.view with parameters of type CategoryAccessor
 void CategoryBackBean.setCategoryAccessor(CategoryAccessor categoryHelper)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.CategoryBackBean

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.CategoryBackBean

No usage of org.marmot.security.view.CategoryBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.Permission

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.Permission

No usage of org.marmot.security.view.Permission

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.PermissionAccessor

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.PermissionAccessor

Packages that use PermissionAccessor
org.marmot.security.view

Uses of PermissionAccessor in org.marmot.security.view

Methods in org.marmot.security.view that return PermissionAccessor
 PermissionAccessor PermissionBackBean.getPermissionAccessor()

Methods in org.marmot.security.view with parameters of type PermissionAccessor
 void PermissionBackBean.setPermissionAccessor(PermissionAccessor permissionHelper)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.PermissionBackBean

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.PermissionBackBean

No usage of org.marmot.security.view.PermissionBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.ProxyBackBean

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.ProxyBackBean

No usage of org.marmot.security.view.ProxyBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.ResourceBackBean

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.ResourceBackBean

No usage of org.marmot.security.view.ResourceBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.RoleBackBean

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.RoleBackBean

No usage of org.marmot.security.view.RoleBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.marmot.security.view.UserBackBean

PREV NEXT FRAMES NO FRAMES

Uses of Class
org.marmot.security.view.UserBackBean

No usage of org.marmot.security.view.UserBackBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES