 All Classes
AccessChecker
AccessDeniedException
Action
ActionConfig
ActionException
ActionForward
ActionNotSuppertedException
ActionTarget
ActionTargetCollection
AdvanceDropDown
AggregateMode
AndOrMatchRule
AutoDBField
AutoForm
AutoSqlDataset
BaseField
BaseMatchRule
BaseRPCHandler
BaseRecord
BindingTreeLevel
Button
CachableDropDown
Calendar
CaseInsensitiveVariantSet
CheckBox
CheckBoxFormElement
ClassHelper
Column
ColumnGroup
Command
CommandQueue
CommonMatchRule
Component
ConnectionHelper
Constants
Control
ControlFormElement
Controller
ControllerConfig
ControllerManager
ControllerNotFoundException
CustomDataset
CustomDataset
CustomDropDown
CustomDropDownViewModel
CustomFormElement
CustomValidator
DBDataset
DBField
DBStatement
DODataset
DORecord
DOSet
DOUtils
DataColumn
DataColumnGroup
DataControl
DataLabel
DataListener
DataPilot
DataTable
DataTree
DataType
Dataset
DatasetAdapter
DatasetDropDown
DatasetInfo
DatasetListener
DatasetReference
DatasetSupport
DatasetWrapper
DateDropDown
DefaultModule
DefaultOutlookBarGroup
DefaultTreeNode
DefaultViewModel
DoradoContext
DoradoException
DoradoRuntimeException
DropDown
DropDownItem
DropDownViewModel
DummyField
DuplicateKeyException
DynamicDropDown
DynamicDropDownDataset
DynamicDropDownViewModel
EditableColumn
Editor
Element
Encrypt
EncryptCode
EscapeUtils
Event
EventConfig
EventHandler
EventSupported
ExprHelper
ExpressionUtils
Field
FieldLabel
FieldNotExistException
FieldSet
FileController
FileLoader
FormDataset
FormElement
FormElementFactoryImpl
FormElementRenderer
FormGroup
FormGroupGround
Frame
FrameTab
GlobalUnit
GroupBox
HttpContextFactory
HttpDoradoContext
IllegalValueException
Index
InvalidPropertyValueException
JoinTable
JspHelper
KeyNotExistException
Label
LabelFormElement
LayoutInfo
LengthValidator
ListDropDown
ListValidator
LoadDataRPCHandler
LoadXmlPropertyException
LocaleHelper
Log
LookupField
Mapping
MasterDetailLink
MatchRule
Menu
MenuBar
MenuItem
MenuItemContainer
MenuOutlookBarGroup
MessageHelper
MetaData
ModuleManager
ModuleSupport
NoCurrentRecordException
ObjectCollection
ObjectList
OutlookBar
OutlookBarGroup
PagePilot
PagingHelper
ParameterSet
PatternValidator
Placeable
PlaceableControl
PlaceableDataControl
Printf
ProgressBar
QueryCommand
RPCCommand
RPCHandler
RPCHelper
RadioGroup
RadioGroupFormElement
RangeValidator
ReadRecord
Record
RecordFilter
RecordIterator
RecordListener
RecordSet
RecordTreeNode
RecordWrapper
RecursiveTreeLevel
RequestCommand
RequestHelper
RequiredValidator
ResourceManager
ResourceManagerContextMap
ResponseUtil
SafeCode
Scope
ScopeHelper
ScrollBar
Setting
SimpleDataControl
SimpleDropDown
SimpleTreeLevel
SortRule
Span
SplitPanel
SqlDataset
SqlMatchRule
StaticColumn
StaticColumnGroup
StaticTable
StringHelper
SubUnit
SubWindow
SynchroTimer
SystemVariable
Tab
TabElement
TabSet
Table
TextEditor
TextEditorFormElement
Transaction
TransactionManager
Tree
TreeGrid
TreeLevel
TreeNode
UniqueKey
Unit
UpdateCommand
UpdateDataRPCHandler
UrlUtil
UserConfig
UserNotLoggedInException
Validator
ValidatorInfo
Variant
VariantHelper
VariantSet
ViewBaseField
ViewDataset
ViewDatasetAdapter
ViewDatasetSupport
ViewField
ViewLookupField
ViewModel
ViewModelSupport
ViewRecord
Visible
XmlBuilder
XmlConfigUtils
XmlDocument
XmlFactory
XmlNode
XmlOutputter
XmlParseException


Constant Field Values

Contents
  • com.bstek.*
com.bstek.*

com.bstek.dorado.action.Constants
public static final java.lang.String | ACTION_MESSAGE_KEY | "com.bstek.dorado.action.actionMessage"
public static final java.lang.String | CURRENT_ACTION_ATTR_KEY | "com.bstek.dorado.action.currentAction"
public static final java.lang.String | JSP_EXCEPTION_KEY | "javax.servlet.jsp.jspException"

com.bstek.dorado.action.Controller
public static final java.lang.String CACHE_ATTRIBUTE_PREFIX "com.bstek.dorado.action.Controller."

com.bstek.dorado.biz.FileController
public static final java.lang.String | CONTENT_TYPE_DISPOSITION | "content-disposition"
public static final java.lang.String | CONTENT_TYPE_HTML | "text/html"
public static final java.lang.String | CONTENT_TYPE_MS_DOWNLOAD | "application/x-msdownload"
public static final java.lang.String | CONTENT_TYPE_MS_EXCEL | "application/vnd.ms-excel"
public static final java.lang.String | CONTENT_TYPE_MS_POWERPOINT | "application/vnd.ms-powerpoint"
public static final java.lang.String | CONTENT_TYPE_MS_WORD | "application/msword"
public static final java.lang.String | CONTENT_TYPE_OCTET_STREAM | "application/octet-stream"
public static final java.lang.String | CONTENT_TYPE_PDF | "application/pdf"
public static final java.lang.String | CONTENT_TYPE_XML | "text/xml"

com.bstek.dorado.common.DoradoContext
public static final int | APPLICATION | 9
public static final int | REQUEST | 1
public static final int | SESSION | 5
public static final int | VIEW | 2

com.bstek.dorado.common.HttpContextFactory
public static final java.lang.String ATTRIBUTE_KEY "com.dorado.common.DoradoContext"

com.bstek.dorado.common.TransactionManager
public static final int | TRANSACTION_NOT_SUPPORTED | 1
public static final int | TRANSACTION_REQUIRED | 10
public static final int | TRANSACTION_REQUIRES_NEW | 20
public static final int | TRANSACTION_SUPPORTS | 5

com.bstek.dorado.common.log.Log
public static final java.lang.String LOGGER_NAME "com.bstek.dorado.common.log.Log"

com.bstek.dorado.common.scope.Scope
public static final java.lang.String | APPLICATION | "application"
public static final java.lang.String | REQUEST | "request"
public static final java.lang.String | SESSION | "session"

com.bstek.dorado.data.Dataset
public static final java.lang.String | FILTER_ALL | "all"
public static final java.lang.String | FILTER_CHANGED | "changed"
public static final java.lang.String | FILTER_DEFAULT | "default"
public static final java.lang.String | FILTER_DELETED | "deleted"
public static final java.lang.String | FILTER_MODIFIED | "modified"
public static final java.lang.String | FILTER_NEW | "new"
public static final java.lang.String | FILTER_NOT_CHANGED | "not_changed"
public static final int | STATE_INIT | 1
public static final int | STATE_LOADING | 3
public static final int | STATE_READY | 2
public static final int | STATE_RESOLVING | 4

com.bstek.dorado.data.DOSet
public static final int | STATE_DELETED | 2
public static final int | STATE_MODIFIED | 3
public static final int | STATE_NEW | 1
public static final int | STATE_NONE | 0

com.bstek.dorado.data.Record
public static final int | STATE_DELETED | 2
public static final int | STATE_MODIFIED | 3
public static final int | STATE_NEW | 1
public static final int | STATE_NONE | 0

com.bstek.dorado.data.db.AggregateMode
public static final java.lang.String | AVERAGE | "average"
public static final java.lang.String | COUNT | "count"
public static final java.lang.String | MAX | "max"
public static final java.lang.String | MIN | "min"
public static final java.lang.String | SUM | "sum"

com.bstek.dorado.data.db.AndOrMatchRule
public static final java.lang.String | AND | "and"
public static final java.lang.String | OR | "or"

com.bstek.dorado.data.db.BaseMatchRule
public static final java.lang.String | EQUALS | "="
public static final java.lang.String | GREATER | ">"
public static final java.lang.String | GREATEREQUAL | ">="
public static final java.lang.String | IN | "in"
public static final java.lang.String | LESS | "<"
public static final java.lang.String | LESSEQUAL | "<="
public static final java.lang.String | LIKE | "like"
public static final java.lang.String | NOTEQUALS | "<>"

com.bstek.dorado.data.db.DBStatement
public static final java.lang.String | DELETE | "DELETE"
public static final java.lang.String | INSERT | "INSERT"
public final java.lang.String | NULL_VALUE | "$null"
public static final java.lang.String | SELECT | "SELECT"
public static final java.lang.String | UPDATE | "UPDATE"

com.bstek.dorado.i18n.ResourceManager
public static final java.lang.String DEFAULT_LOCALE_ATTRIBUTE_KEY "com.bstek.dorado.i18n.ResourceManager.defaultLocale"

com.bstek.dorado.module.ModuleManager
public static final java.lang.String MODULES_ATTRIBUTE_KEY "com.bstek.dorado.modules"

com.bstek.dorado.security.AccessChecker
public static final java.lang.String DEFAULT_LOGIN_SESSION_KEY "com.bstek.dorado.security.AccessChecker.login"

com.bstek.dorado.utils.variant.DataType
public static final int | BIGDECIMAL | 8
public static final java.lang.String | BIGDECIMAL_NAME | "bigdecimal"
public static final int | BINARY | 20
public static final java.lang.String | BINARY_NAME | "binary"
public static final int | BOOLEAN | 9
public static final java.lang.String | BOOLEAN_NAME | "boolean"
public static final int | BYTE | 2
public static final java.lang.String | BYTE_NAME | "byte"
public static final int | DATE | 10
public static final java.lang.String | DATE_NAME | "date"
public static final int | DATETIME | 12
public static final java.lang.String | DATETIME_NAME | "datetime"
public static final int | DOUBLE | 7
public static final java.lang.String | DOUBLE_NAME | "double"
public static final int | FLOAT | 6
public static final java.lang.String | FLOAT_NAME | "float"
public static final int | INT | 4
public static final java.lang.String | INT_NAME | "int"
public static final int | LONG | 5
public static final java.lang.String | LONG_NAME | "long"
public static final int | SHORT | 3
public static final java.lang.String | SHORT_NAME | "short"
public static final int | STRING | 1
public static final java.lang.String | STRING_NAME | "string"
public static final int | TIME | 11
public static final java.lang.String | TIME_NAME | "time"
public static final int | UNKNOWN | 0
public static final java.lang.String | UNKNOWN_NAME | ""

com.bstek.dorado.view.ViewModel
public static final java.lang.String | DEFAULT_ROLE_ATTRIBUTE | "com.bstek.dorado.view.role.DefaultRole"
public static final java.lang.String | DEFAULT_SKIN_ATTRIBUTE | "com.bstek.dorado.view.ViewModel.DefaultSkin"
public static final java.lang.String | REJECT_ROLE | "$reject"
public static final int | STATE_DESIGN | 4
public static final int | STATE_SERVICE | 2
public static final int | STATE_UPDATING | 3
public static final int | STATE_VIEW | 1

com.bstek.dorado.view.control.Calendar
public static final java.lang.String | SCHEDULE | "schedule"
public static final java.lang.String | SIMPLE | "simple"

com.bstek.dorado.view.control.DataPilot
public static final java.lang.String | AUTO | "auto"
public static final java.lang.String | HIDDEN | "hidden"
public static final java.lang.String | VISIBLE | "visible"

com.bstek.dorado.view.control.MenuOutlookBarGroup
public static final java.lang.String | VIEWMODE_ICON | "icon"
public static final java.lang.String | VIEWMODE_LIST | "list"

com.bstek.dorado.view.control.PagePilot
public static final java.lang.String | TYPE_BUTTON | "button"
public static final java.lang.String | TYPE_LINK | "link"

com.bstek.dorado.view.control.ProgressBar
public static final java.lang.String | ORIENTATION_HORIZONTAL | "horizontal"
public static final java.lang.String | ORIENTATION_VERTICAL | "vertical"

com.bstek.dorado.view.control.RadioGroup
public static final java.lang.String | FLOW | "flow"
public static final java.lang.String | HORIZONTAL | "horizontal"
public static final java.lang.String | VERTICAL | "vertical"

com.bstek.dorado.view.control.ScrollBar
public static final java.lang.String | DRAGMODE_MOUSEMOVE | "mousemove"
public static final java.lang.String | DRAGMODE_MOUSEUP | "mouseup"
public static final java.lang.String | ORIENTATION_HORIZONTAL | "horizontal"
public static final java.lang.String | ORIENTATION_VERTICAL | "vertical"

com.bstek.dorado.view.control.SplitPanel
public static final java.lang.String | ORIENTATION_HORIZONTAL | "horizontal"
public static final java.lang.String | ORIENTATION_VERTICAL | "vertical"

com.bstek.dorado.view.control.SubWindow
public static final java.lang.String | HIDDEN | "hidden"
public static final java.lang.String | MAXIMIZE | "maximize"
public static final java.lang.String | MINIMIZE | "minimize"
public static final java.lang.String | NO_ACTION | "no_action"
public static final java.lang.String | NORMAL | "normal"

com.bstek.dorado.view.control.TextEditor
public static final java.lang.String | PASSWORD | "password"
public static final java.lang.String | TEXT | "text"
public static final java.lang.String | TEXTAREA | "textarea"

com.bstek.dorado.view.control.autoform.AutoForm
public static final java.lang.String | GROUPBOX | "groupbox"
public static final java.lang.String | HORIZONTAL | "horizontal"
public static final java.lang.String | SUBWINDOW | "subwindow"
public static final java.lang.String | VERTICAL | "vertical"

com.bstek.dorado.view.control.autoform.FormElement
public static final java.lang.String | AUTO | "auto"
public static final java.lang.String | HIDDEN | "hidden"
public static final java.lang.String | VISIBLE | "visible"

com.bstek.dorado.view.control.command.DatasetInfo
public static final java.lang.String | ALL | "all"
public static final java.lang.String | ALL_CHANGE | "all-change"
public static final java.lang.String | CURRENT | "current"
public static final java.lang.String | SELECTED | "selected"

com.bstek.dorado.view.control.command.Frame
public static final java.lang.String | BLANK | "_blank"
public static final java.lang.String | MODAL_DIALOG | "_modal_dialog"
public static final java.lang.String | MODELESS_DIALOG | "_modeless_dialog"
public static final java.lang.String | PARENT | "_parent"
public static final java.lang.String | SELF | "_self"
public static final java.lang.String | SUBWINDOW | "_subwindow"
public static final java.lang.String | TOP | "_top"

com.bstek.dorado.view.control.command.QueryCommand
public static final java.lang.String | FLUSH | "flush"
public static final java.lang.String | FORM_GET | "form-get"
public static final java.lang.String | FORM_POST | "form-post"

com.bstek.dorado.view.control.table.DataTable
public static final java.lang.String | SCROLLMODE_RECORD | "record"
public static final java.lang.String | SCROLLMODE_SIMPLE | "simple"

com.bstek.dorado.view.control.table.EditableColumn
public static final java.lang.String | CHECKBOX | "checkbox"
public static final java.lang.String | PASSWORD | "password"
public static final java.lang.String | TEXT | "text"
public static final java.lang.String | TEXTAREA | "textarea"

com.bstek.dorado.view.control.table.Table
public static final java.lang.String | COLUMN_TYPE_BASE | "Column"
public static final java.lang.String | COLUMN_TYPE_GROUP | "ColumnGroup"

com.bstek.dorado.view.control.tabset.TabSet
public static final java.lang.String | TABPLACEMENT_BOTTOM | "bottom"
public static final java.lang.String | TABPLACEMENT_TOP | "top"

com.bstek.dorado.view.data.validate.impl.RangeValidator
public static final java.lang.String | ALLOW_EQUALS | "allow_equals"
public static final java.lang.String | IGNORE | "ignore"
public static final java.lang.String | NOT_ALLOW_EQUALS | "not_allow_equals"

com.bstek.dorado.view.rpc.RPCHandler
public static final java.lang.String | ATTRIBUTE_KEY | "com.bstek.dorado.view.rpc.RPCHandler"
public static final java.lang.String | NO_FORWARD_ATTRIBUTE | "com.bstek.dorado.view.rpc.noForward"
public static final java.lang.String | PROCESSED_ATTRIBUTE_KEY | "com.bstek.dorado.view.rpc.processed"

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

Deprecated API

Deprecated Methods
com.bstek.dorado.view.control.tree.TreeNode.addNode()
com.bstek.dorado.view.control.tabset.TabSet.addTab(String)
com.bstek.dorado.view.control.tabset.TabSet.addTab(String, String)
com.bstek.dorado.data.db.CaseInsensitiveVariantSet.exists(String)
com.bstek.dorado.data.RecordIterator.filter()
com.bstek.dorado.data.db.CaseInsensitiveVariantSet.getVariant(String)
com.bstek.dorado.view.control.Calendar.init(DoradoContext, XmlNode)
com.bstek.dorado.view.ViewModelSupport.initControl(String, Control)
com.bstek.dorado.module.DefaultModule.initDataset(Dataset)
com.bstek.dorado.module.ModuleSupport.initDataset(Dataset)
com.bstek.dorado.data.Dataset.load(boolean)
com.bstek.dorado.module.ModuleSupport.loadData(Dataset, boolean)
com.bstek.dorado.data.db.CaseInsensitiveVariantSet.remove(String)
com.bstek.dorado.data.db.CaseInsensitiveVariantSet.setVariant(String, Variant)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help

PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Exceptions
  • Errors

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Index

Overview Package Class Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

A

ACTION_MESSAGE_KEY - Static variable in class com.bstek.dorado.action.Constants
用于在Request中保存某Action的消息集合对象的Attribute键值
ALL - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 提交Dataset中所有的记录。
ALLOW_EQUALS - Static variable in class com.bstek.dorado.view.data.validate.impl.RangeValidator
范围校验类型 - 相等
ALL_CHANGE - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 只提交Dataset中所有更改过的记录，包括新增、修改、删除的记录。
AND - Static variable in class com.bstek.dorado.data.db.AndOrMatchRule
等于
APPLICATION - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - Application.即整个应用中的所有Client都可访问。
APPLICATION - Static variable in class com.bstek.dorado.common.scope.Scope
作用域类型 - Application，即整个应用中的所有Client都可访问。
ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.common.HttpContextFactory
ATTRIBUTE_KEY
ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.view.ViewModelManager
ATTRIBUTE_KEY
ATTRIBUTE_KEY - Static variable in interface com.bstek.dorado.view.rpc.RPCHandler
ATTRIBUTE_KEY
AUTO - Static variable in class com.bstek.dorado.view.control.DataPilot
AUTO - Static variable in class com.bstek.dorado.view.control.autoform.FormElement
AVERAGE - Static variable in class com.bstek.dorado.data.db.AggregateMode
求字段的平均值
AbstractContextMap - class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap.
AbstractContextMap() - Constructor for class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
AbstractControl - class com.bstek.dorado.view.control.AbstractControl.
AbstractControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.AbstractControl
AbstractControl
AbstractDataset - class com.bstek.dorado.data.AbstractDataset.
数据集的抽象基类。
AbstractDataset() - Constructor for class com.bstek.dorado.data.AbstractDataset
AbstractDatasetListener - class com.bstek.dorado.data.AbstractDatasetListener.
AbstractDatasetListener() - Constructor for class com.bstek.dorado.data.AbstractDatasetListener
AbstractDatasetReference - class com.bstek.dorado.view.data.AbstractDatasetReference.
AbstractDatasetReference(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.AbstractDatasetReference
AbstractDoradoContext - class com.bstek.dorado.common.AbstractDoradoContext.
AbstractDoradoContext() - Constructor for class com.bstek.dorado.common.AbstractDoradoContext
AbstractField - class com.bstek.dorado.data.AbstractField.
字段
AbstractField(String) - Constructor for class com.bstek.dorado.data.AbstractField
AbstractField
AbstractModule - class com.bstek.dorado.module.AbstractModule.
Deprecated.
AbstractModule() - Constructor for class com.bstek.dorado.module.AbstractModule
Deprecated.
AbstractRPCHandler - class com.bstek.dorado.view.rpc.AbstractRPCHandler.
AbstractRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.AbstractRPCHandler
AbstractValidator - class com.bstek.dorado.view.data.validate.impl.AbstractValidator.
校验器的通用抽象基类
AbstractValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.AbstractValidator
构造器
AbstractViewDataset - class com.bstek.dorado.view.data.AbstractViewDataset.
视图数据集的抽象基类。
AbstractViewDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.AbstractViewDataset
AbstractViewModel - class com.bstek.dorado.view.AbstractViewModel.
Deprecated.
AbstractViewModel() - Constructor for class com.bstek.dorado.view.AbstractViewModel
Deprecated.
AbstractXmlBuilder - class com.bstek.dorado.utils.xml.AbstractXmlBuilder.
用于封装一部分XmlBuilder的通用操作
AbstractXmlBuilder() - Constructor for class com.bstek.dorado.utils.xml.AbstractXmlBuilder
AbstractXmlNode - class com.bstek.dorado.utils.xml.AbstractXmlNode.
实现XML节点对象的一部分基本功能。
AbstractXmlNode() - Constructor for class com.bstek.dorado.utils.xml.AbstractXmlNode
AbstractXmlOutputter - class com.bstek.dorado.utils.xml.AbstractXmlOutputter.
用于封装一部分XmlOutputter的通用操作
AbstractXmlOutputter() - Constructor for class com.bstek.dorado.utils.xml.AbstractXmlOutputter
AccessChecker - interface com.bstek.dorado.security.AccessChecker.
Dorado提供的默认的一种用户登录状态校验的类
AccessCheckerManager - class com.bstek.dorado.security.AccessCheckerManager.
AccessDeniedException - exception com.bstek.dorado.security.AccessDeniedException.
用户登录状态校验失败产生的异常
AccessDeniedException() - Constructor for class com.bstek.dorado.security.AccessDeniedException
构造器
AccessDeniedException(String) - Constructor for class com.bstek.dorado.security.AccessDeniedException
构造器
AccessDeniedException(Throwable) - Constructor for class com.bstek.dorado.security.AccessDeniedException
构造器
Action - interface com.bstek.dorado.action.Action.
Action的接口 在运行时创建的对象，当用户激活一个Action时系统会自动创建此对象。
ActionConfig - class com.bstek.dorado.action.mapping.ActionConfig.
对应一个Action的Mapping配置信息
ActionConfig(String) - Constructor for class com.bstek.dorado.action.mapping.ActionConfig
构造器
ActionConfigParser - class com.bstek.dorado.action.mapping.ActionConfigParser.
Action的Mapping配置信息的解析器
ActionException - class com.bstek.dorado.action.mapping.ActionException.
Request的跳转目标。
ActionException(String) - Constructor for class com.bstek.dorado.action.mapping.ActionException
构造器
ActionExceptionParser - class com.bstek.dorado.action.mapping.ActionExceptionParser.
ActionException的Mapping配置信息的解析器
ActionExceptionUtil - class com.bstek.dorado.action.mapping.ActionExceptionUtil.
ActionException的辅助工具类
ActionFactory - interface com.bstek.dorado.action.ActionFactory.
Action的创建工厂
ActionForward - class com.bstek.dorado.action.mapping.ActionForward.
Request的跳转目标。
ActionForward(String) - Constructor for class com.bstek.dorado.action.mapping.ActionForward
构造器
ActionForward(String, String) - Constructor for class com.bstek.dorado.action.mapping.ActionForward
构造器
ActionForward(String, String, boolean) - Constructor for class com.bstek.dorado.action.mapping.ActionForward
构造器
ActionForwardParser - class com.bstek.dorado.action.mapping.ActionForwardParser.
ActionForward的Mapping配置信息的解析器
ActionHandler - class com.bstek.dorado.action.ActionHandler.
Action的处理器。
ActionNotSuppertedException - exception com.bstek.dorado.action.ActionNotSuppertedException.
无法找到指定的Action的异常。
ActionNotSuppertedException() - Constructor for class com.bstek.dorado.action.ActionNotSuppertedException
构造器
ActionNotSuppertedException(String) - Constructor for class com.bstek.dorado.action.ActionNotSuppertedException
构造器
ActionTarget - class com.bstek.dorado.action.mapping.ActionTarget.
Request的跳转目标。
ActionTarget() - Constructor for class com.bstek.dorado.action.mapping.ActionTarget
ActionTargetCollection - interface com.bstek.dorado.action.mapping.ActionTargetCollection.
用于管理一组ActionForward和ActionException的对象
AdvanceDropDown - class com.bstek.dorado.view.control.dropdown.AdvanceDropDown.
高级下拉框对象
AdvanceDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
AggregateMode - class com.bstek.dorado.data.db.AggregateMode.
有关字段统计方式的常量.
AndOrMatchRule - class com.bstek.dorado.data.db.AndOrMatchRule.
用于描述AutoSqlDataset的WHERE片断中的and/or逻辑连接符的规则对象
AndOrMatchRule() - Constructor for class com.bstek.dorado.data.db.AndOrMatchRule
构造器
AndOrMatchRule(String) - Constructor for class com.bstek.dorado.data.db.AndOrMatchRule
构造器
AutoDBField - class com.bstek.dorado.data.db.AutoDBField.
自动SQL记录集的字段对象
AutoDBField(String) - Constructor for class com.bstek.dorado.data.db.AutoDBField
构造器
AutoDBFieldFactory - class com.bstek.dorado.data.db.AutoDBFieldFactory.
AutoSqlField创建工厂
AutoDBFieldFactory() - Constructor for class com.bstek.dorado.data.db.AutoDBFieldFactory
AutoForm - class com.bstek.dorado.view.control.autoform.AutoForm.
AutoForm对象
AutoForm(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.autoform.AutoForm
构造器
AutoSqlDataset - class com.bstek.dorado.data.db.AutoSqlDataset.
自动SQL记录集.
AutoSqlDataset() - Constructor for class com.bstek.dorado.data.db.AutoSqlDataset
构造器
activate() - Method in interface com.bstek.dorado.module.Module
Module的锐化处理
activate() - Method in class com.bstek.dorado.module.ModuleSupport
Module的锐化处理
activateObject(Object, Object) - Method in class com.bstek.dorado.module.PoolableModuleFactory
activateObject
add(Object, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
向对象列表中添加一个对象。
add(int, Object, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
向对象列表中指定的位置添加一个对象
add(Object, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
向对象列表中添加一个对象。
add(int, Object, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
向对象列表中指定的位置添加一个对象
addAction(ActionConfig) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
添加一个ActionConfig
addAndOrMatchRule(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定逻辑连接符的类型添加一个逻辑连接规则(AndOrMatchRule), 并返回新的逻辑连接规则对象.
addAttribute(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
为节点增加一个属性
addBaseMatchRule(String, String, String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定的物理字段名、比较操作符和匹配值添加一个基本匹配规则(BaseMatchRule), 并返回新的基本匹配规则对象.
addChild(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
增加一个子节点
addChild(XmlNode) - Method in interface com.bstek.dorado.utils.xml.XmlNode
增加一个子节点
addColumn(Column) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
添加一个列对象。
addColumn(String) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
添加一个指定名称的列对象。
addColumn(Column) - Method in class com.bstek.dorado.view.control.table.Table
添加一个列对象。
addColumn(String) - Method in class com.bstek.dorado.view.control.table.Table
添加一个指定名称的列对象。
addColumnByField(Field) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
根据指定的字段(Field)对象添加一个列(Colomn)对象。
addColumnByField(Field) - Method in class com.bstek.dorado.view.control.table.Table
根据指定的字段(Field)对象添加一个列(Colomn)对象。
addColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.Table
添加一个指定名称的列组(ColumnGroup)对象。
addCommand(String) - Method in class com.bstek.dorado.view.control.command.CommandQueue
添加一个命令对象
addController(ControllerConfig) - Method in class com.bstek.dorado.action.mapping.Mapping
添加一个Controller对象。
addController(ControllerConfig) - Method in class com.bstek.dorado.action.mapping.Unit
添加一个Controller对象。
addDO(Object) - Method in class com.bstek.dorado.data.DOSet
向DOSet中添加一个DO.
addDO(Object, int) - Method in class com.bstek.dorado.data.DOSet
按照指定状态的向DOSet中添加一个DO.
addDatasetInfo(String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
根据指定的数据集(Dataset)的Id，添加到一个DatasetInfo对象中。
addDatasetInfo(String, String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
根据数据集(Dataset)的Id属性和提交方式(submitScope)属性，添加到一个DatasetInfo对象中。
addDatasetListener(DatasetListener) - Method in interface com.bstek.dorado.data.Dataset
增加一个DatasetEvent的事件监听器
addDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetAdapter
增加一个DatasetEvent的事件监听器
addDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetSupport
增加一个DatasetEvent的事件监听器
addDatasetListener(DatasetListener) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
增加一个DatasetEvent的事件监听器
addDummyField(String) - Method in interface com.bstek.dorado.data.Dataset
向Dataset中添加一个虚拟Field。
addDummyField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
向Dataset中添加一个虚拟Field。
addDummyField(String) - Method in class com.bstek.dorado.data.DatasetSupport
向Dataset中添加一个虚拟Field。
addDummyField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
向Dataset中添加一个虚拟Field。
addElement(String, String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
添加一个表单元素
addEventHandler(EventHandler) - Method in interface com.bstek.dorado.view.Component
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in interface com.bstek.dorado.view.EventSupported
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.ViewModelSupport
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.control.AbstractControl
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.control.table.EditableColumn
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.control.table.EditableColumnGroup
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
添加一个事件处理对象。
addException(ActionException) - Method in class com.bstek.dorado.action.mapping.ActionConfig
添加一个ActionException子对象
addException(ActionException) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
添加一个ActionException子对象
addException(ActionException) - Method in class com.bstek.dorado.action.mapping.Unit
添加一个ActionException子对象
addField(String) - Method in interface com.bstek.dorado.data.Dataset
向Dataset中添加一个普通Field。
addField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
向Dataset中添加一个普通Field。
addField(String) - Method in class com.bstek.dorado.data.DatasetSupport
向Dataset中添加一个普通Field。
addField(Field) - Method in class com.bstek.dorado.data.FieldSet
添加一个Field。
addField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
向Dataset中添加一个普通Field。
addForward(ActionForward) - Method in class com.bstek.dorado.action.mapping.ActionConfig
添加一个ActionForward子对象
addForward(ActionForward) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
添加一个ActionForward子对象
addForward(ActionForward) - Method in class com.bstek.dorado.action.mapping.Unit
添加一个ActionForward子对象
addGroup() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
添加一个组对象
addItem(String) - Method in class com.bstek.dorado.view.control.Menu
根据指定菜单项名称添加一个菜单项(MenuItem)对象。
addItem(String, String) - Method in class com.bstek.dorado.view.control.Menu
根据指定名称、Label，添加一个菜单项(MenuItem)对象。
addItem(String) - Method in class com.bstek.dorado.view.control.MenuItem
根据指定菜单项名称添加一个菜单项(MenuItem)对象。
addItem(String, String) - Method in class com.bstek.dorado.view.control.MenuItem
根据指定名称、Label，添加一个菜单项(MenuItem)对象。
addItem(String) - Method in interface com.bstek.dorado.view.control.MenuItemContainer
根据指定菜单项名称添加一个菜单项(MenuItem)对象。
addItem(String, String) - Method in interface com.bstek.dorado.view.control.MenuItemContainer
根据指定名称、Label，添加一个菜单项(MenuItem)对象。
addItem(String) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定值添加一个静态下拉框(ListDropDown)的DropDownItem对象。
addItem(String, String) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定值和标题(Label)属性添加一个静态下拉框(ListDropDown)的DropDownItem对象。
addJoin(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据要关联的表的别名添加一个关联(JoinTable)并返回新的关联对象.
addLevel() - Method in class com.bstek.dorado.view.control.tree.DataTree
Deprecated.
addLevel(TreeLevel) - Method in class com.bstek.dorado.view.control.tree.DataTree
添加一个Level
addLookupField(String) - Method in interface com.bstek.dorado.data.Dataset
向Dataset中添加一个支持Lookup功能的Field。
addLookupField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

addLookupField(String) - Method in class com.bstek.dorado.data.DatasetSupport
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

addLookupField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

addMessage(String) - Method in interface com.bstek.dorado.action.Action
向当前的Action中追加一条消息。
addMessage(ServletRequest, String) - Static method in class com.bstek.dorado.common.MessageHelper
增加一条新的无键值消息
addMessage(ServletRequest, String, String) - Static method in class com.bstek.dorado.common.MessageHelper
在指定键值中增加一条新的消息
addMessage(DoradoContext, String) - Static method in class com.bstek.dorado.common.MessageHelper
增加一条新的无键值消息
addMessage(DoradoContext, String, String) - Static method in class com.bstek.dorado.common.MessageHelper
在指定键值中增加一条新的消息
addNode() - Method in class com.bstek.dorado.view.control.tree.TreeNode
Deprecated.
addNode(TreeNode) - Method in class com.bstek.dorado.view.control.tree.TreeNode
添加一个指定的节点,作为当前树节点(TreeNode)的子节点。
addRecordListener(RecordListener) - Method in interface com.bstek.dorado.data.Dataset
增加一个RecordtListener的事件监听器
addRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetAdapter
增加一个RecordtListener的事件监听器
addRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetSupport
增加一个RecordtListener的事件监听器
addSection(String) - Method in class com.bstek.dorado.common.rtexpr.CompiledText
addSection
addSection(Expression) - Method in class com.bstek.dorado.common.rtexpr.CompiledText
addSection
addSortRule(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.
addSqlMatchRule(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定SQL片断添加一个SQL匹配规则(SqlMatchRule), 并返回新的SQL匹配规则对象.
addSubFile(String) - Method in class com.bstek.dorado.action.mapping.GlobalUnit
添加一个全局控制子单元对象。
addTab(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
Deprecated.
addTab(String, String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
Deprecated.
addTab(TabElement) - Method in class com.bstek.dorado.view.control.tabset.TabSet
添加一个指定标签项
addTransConnectionListener(TransConnectionListener) - Method in class com.bstek.dorado.common.ds.TransConnection
addUnit(Unit) - Method in class com.bstek.dorado.action.mapping.Mapping
根据索引号设定一个子配置单元对象
addValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewBaseField
为字段添加一个校验器(Validator)。
addValidator(Validator) - Method in interface com.bstek.dorado.view.data.ViewField
为字段添加一个校验器(Validator)。
addValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewLookupField
为字段添加一个校验器(Validator)。
afterChange(ReadRecord, String) - Method in interface com.bstek.dorado.data.DataListener
在数据被修改之后被触发的事件.
afterChange(ReadRecord, String) - Method in class com.bstek.dorado.data.DatasetSupport
在数据被修改之后被触发的事件.
afterChange(Dataset, ReadRecord, String) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset中某条记录的数据被修改之后被触发的事件.
afterChange(Dataset, ReadRecord, String) - Method in class com.bstek.dorado.data._MockDatasetListener
afterChange(ReadRecord, String) - Method in class com.bstek.dorado.data._MockRecordListener
afterCreateFields(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
afterCreateFields(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset执行完自动创建所有字段之后触发的事件.即当调用Dataset.createFields()之后触发的事件.
afterDelete(Dataset, ReadRecord) - Method in interface com.bstek.dorado.data.RecordListener
从Dataset中删除一条记录之后触发的事件
afterDelete(Dataset, ReadRecord) - Method in class com.bstek.dorado.data._MockDatasetListener
afterInsert(Dataset, Record) - Method in interface com.bstek.dorado.data.RecordListener
向Dataset中插入一条记录之后触发的事件
afterInsert(Dataset, Record) - Method in class com.bstek.dorado.data._MockDatasetListener
afterLoadData(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
afterLoadData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.loadData()之后触发的事件.
afterScroll(Dataset) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset的当前记录改变之后触发的事件
afterScroll(Dataset) - Method in class com.bstek.dorado.data._MockDatasetListener
afterUpdateData(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
afterUpdateData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.update()之后触发的事件.
afterValidate(Dataset, Record) - Method in class com.bstek.dorado.data._MockDatasetListener
applyRoleConfig(List) - Method in interface com.bstek.dorado.view.Component
应用角色配置文件。
applyRoleConfig(DoradoContext, List) - Method in interface com.bstek.dorado.view.ViewModel
应用角色配置
applyRoleConfig(DoradoContext, List) - Method in class com.bstek.dorado.view.ViewModelSupport
应用角色配置
applyRoleConfig(List) - Method in class com.bstek.dorado.view.control.AbstractControl
应用角色配置文件。
applyRoleConfig(List) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
应用角色配置文件。
arrayToStringKey(Object[]) - Static method in class com.bstek.dorado.common.HashKeyUtil
arrayToStringKey
assign(VariantSet) - Method in class com.bstek.dorado.utils.variant.VariantSet
将本集合中的所有数据全部指派到给定的另一个集合中.
attributiesToBean(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的Bean当中.
attributiesToDO(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的对象当中.
attributiesToMap() - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到Map当中.
attributiesToMap(Map) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的Map当中.
attributiesToVariantSet(VariantSet) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的VariantSet当中.
autoForm - Variable in class com.bstek.dorado.view.control.autoform.FormElement
表单

B

BIGDECIMAL - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - BigDecimal型。
BIGDECIMAL_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - BigDecimal型。
BINERY - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - 二进制型。
BINERY_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - 二进制型。
BLANK - Static variable in class com.bstek.dorado.view.control.command.Frame
命令(Command)提交后在一个空白的浏览器窗口中打开新页面。
BOOLEAN - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - boolean型。
BOOLEAN_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - boolean型。
BYTE - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - byte型。
BYTE_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - byte型。
BaseExprInitializer - class com.bstek.dorado.common.rtexpr.impl.BaseExprInitializer.
BaseExprInitializer() - Constructor for class com.bstek.dorado.common.rtexpr.impl.BaseExprInitializer
BaseField - class com.bstek.dorado.data.BaseField.
最基本的Field对象。
BaseField(String) - Constructor for class com.bstek.dorado.data.BaseField
构造器
BaseMatchRule - class com.bstek.dorado.data.db.BaseMatchRule.
用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
BaseMatchRule() - Constructor for class com.bstek.dorado.data.db.BaseMatchRule
构造器
BaseMatchRule(String, String, String) - Constructor for class com.bstek.dorado.data.db.BaseMatchRule
构造器
BaseRPCHandler - class com.bstek.dorado.view.rpc.BaseRPCHandler.
基本的远程方法调用的处理类
BaseRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.BaseRPCHandler
BaseRecord - class com.bstek.dorado.data.BaseRecord.
最基本的Record对象
BaseRecord() - Constructor for class com.bstek.dorado.data.BaseRecord
Button - class com.bstek.dorado.view.control.Button.
按钮对象
Button(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Button
构造器
beforeChange(ReadRecord, String, Variant) - Method in interface com.bstek.dorado.data.DataListener
当数据将要被修改之前被触发的事件.
beforeChange(ReadRecord, String, Variant) - Method in class com.bstek.dorado.data.DatasetSupport
当数据将要被修改之前被触发的事件.
beforeChange(Dataset, ReadRecord, String, Variant) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset中某条记录的数据将要被修改之前被触发的事件.
beforeChange(Dataset, ReadRecord, String, Variant) - Method in class com.bstek.dorado.data._MockDatasetListener
beforeChange(ReadRecord, String, Variant) - Method in class com.bstek.dorado.data._MockRecordListener
beforeCreateFields(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
beforeCreateFields(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset将要自动创建所有字段之前触发的事件.即当调用Dataset.createFields()之前触发的事件.
beforeDelete(Dataset, ReadRecord) - Method in interface com.bstek.dorado.data.RecordListener
将要从Dataset中删除一条记录之前触发的事件
beforeDelete(Dataset, ReadRecord) - Method in class com.bstek.dorado.data._MockDatasetListener
beforeInsert(Dataset, Record) - Method in interface com.bstek.dorado.data.RecordListener
将要向Dataset中插入一条记录之前触发的事件
beforeInsert(Dataset, Record) - Method in class com.bstek.dorado.data._MockDatasetListener
beforeLoadData(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
beforeLoadData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset将要装载数据之前触发的事件.即当调用Dataset.loadData()之前触发的事件.
beforeScroll(Dataset) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset的当前记录改变之前触发的事件
beforeScroll(Dataset) - Method in class com.bstek.dorado.data._MockDatasetListener
beforeUpdateData(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
beforeUpdateData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset将要装载数据之前触发的事件.即当调用Dataset.update()之前触发的事件.
beginTransaction() - Method in class com.bstek.dorado.common.JDBCTransaction
beginTransaction() - Method in interface com.bstek.dorado.common.Transaction
启动一个新的事务.
build(Dataset, String) - Static method in class com.bstek.dorado.data.Index
根据给定的Dataset和字段创建并返回索引对象。
build(Dataset, String[]) - Static method in class com.bstek.dorado.data.Index
根据给定的Dataset和字段创建并返回索引对象。
buildDocument(File) - Method in class com.bstek.dorado.utils.xml.AbstractXmlBuilder
利用文件对象创建XmlDocument对象
buildDocument(String) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建XmlDocument对象
buildDocument(InputStream) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建XmlDocument对象
buildDocument(File) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
利用文件对象创建XmlDocument对象

C

CACHE_ATTRIBUTE_PREFIX - Static variable in class com.bstek.dorado.action.Controller
系统缓存Controller时使用的Attribute名的前缀
CHECKBOX - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - checkbox
COLUMN_TYPE_BASE - Static variable in class com.bstek.dorado.view.control.table.Table
COLUMN_TYPE_GROUP - Static variable in class com.bstek.dorado.view.control.table.Table
CONTENT_TYPE_DISPOSITION - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_HTML - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_DOWNLOAD - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_EXCEL - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_POWERPOINT - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_WORD - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_OCTET_STREAM - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_PDF - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_XML - Static variable in class com.bstek.dorado.biz.FileController
COUNT - Static variable in class com.bstek.dorado.data.db.AggregateMode
统计记录总数
CURRENT - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 只提交Dataset的当前记录。
CURRENT_ACTION_ATTR_KEY - Static variable in class com.bstek.dorado.action.Constants
用于在Request中保存当前Action的Attribute键值
CachableDropDown - interface com.bstek.dorado.view.control.dropdown.CachableDropDown.
下拉框缓存接口
Calendar - class com.bstek.dorado.view.control.Calendar.
Calendar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Calendar
构造器。
CheckBox - class com.bstek.dorado.view.control.CheckBox.
复选框对象
CheckBox(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.CheckBox
构造器
CheckBoxFormElement - class com.bstek.dorado.view.control.autoform.CheckBoxFormElement.
AutoForm中CheckBox元素对象
CheckBoxFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
构造器
ClassHelper - class com.bstek.dorado.utils.ClassHelper.
用于对象反射的工具类
Column - class com.bstek.dorado.view.control.table.Column.
Column(String) - Constructor for class com.bstek.dorado.view.control.table.Column
表格列对象
ColumnGroup - class com.bstek.dorado.view.control.table.ColumnGroup.
ColumnGroup(String) - Constructor for class com.bstek.dorado.view.control.table.ColumnGroup
ColumnGroup
Command - class com.bstek.dorado.view.control.Command.
命令对象
Command(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Command
构造器
CommandQueue - class com.bstek.dorado.view.control.command.CommandQueue.
管理提交命令队列的对象
CommandQueue(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.CommandQueue
构造器
CommonMatchRule - class com.bstek.dorado.data.db.CommonMatchRule.
用于描述AutoSqlDataset的WHERE片断的匹配规则抽象类.
CommonMatchRule() - Constructor for class com.bstek.dorado.data.db.CommonMatchRule
构造器
CompiledText - class com.bstek.dorado.common.rtexpr.CompiledText.
运行时变量的预编译对象
CompiledText() - Constructor for class com.bstek.dorado.common.rtexpr.CompiledText
CompiledText
Component - interface com.bstek.dorado.view.Component.
组件接口
ConnectionConfigs - class com.bstek.dorado.common.ds.ConnectionConfigs.
Dorado的数据连接池
ConnectionHelper - class com.bstek.dorado.common.ds.ConnectionHelper.
用于根据Dorado中数据连接配置获得Connection的工具类.
ConnectionHelper() - Constructor for class com.bstek.dorado.common.ds.ConnectionHelper
Console - class com.bstek.dorado.common.Console.
系统控制台
Constants - class com.bstek.dorado.Constants.
系统常量
Constants() - Constructor for class com.bstek.dorado.Constants
Constants - class com.bstek.dorado.action.Constants.
DoradoAction模块中的一些常量
Control - interface com.bstek.dorado.view.control.Control.
控件对象的接口
ControlFactory - interface com.bstek.dorado.view.control.ControlFactory.
Controller - class com.bstek.dorado.action.Controller.
在运行时的Controller对象，当用户激活一个Controller时系统会自动创建此对象。
Controller() - Constructor for class com.bstek.dorado.action.Controller
ControllerConfig - class com.bstek.dorado.action.mapping.ControllerConfig.
对应一个Controller的Mapping配置信息
ControllerConfig(String) - Constructor for class com.bstek.dorado.action.mapping.ControllerConfig
构造器
ControllerConfigParser - class com.bstek.dorado.action.mapping.ControllerConfigParser.
ControllerConfig的Mapping配置信息的解析器
ControllerFactory - interface com.bstek.dorado.action.ControllerFactory.
Controller的创建工厂
ControllerManager - class com.bstek.dorado.action.ControllerManager.
Controller管理器 用于完成创建、查找Controller等功能
ControllerManager() - Constructor for class com.bstek.dorado.action.ControllerManager
构造器
ControllerNotFoundException - exception com.bstek.dorado.action.ControllerNotFoundException.
无法找到指定的Controller的异常。
ControllerNotFoundException() - Constructor for class com.bstek.dorado.action.ControllerNotFoundException
构造器
ControllerNotFoundException(String) - Constructor for class com.bstek.dorado.action.ControllerNotFoundException
构造器
CustomDataset - class com.bstek.dorado.data.custom.CustomDataset.
用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.
CustomDataset() - Constructor for class com.bstek.dorado.data.custom.CustomDataset
CustomDataset - class com.bstek.dorado.view.data.CustomDataset.
用户自定义视图数据集对象
CustomDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.CustomDataset
构造器
CustomDropDown - class com.bstek.dorado.view.control.dropdown.CustomDropDown.
自定义下拉框对象
CustomDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.CustomDropDown
构造器
CustomDropDownViewModel - class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel.
自定义下拉框的视图模型对象
CustomDropDownViewModel() - Constructor for class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
CustomFormElement - class com.bstek.dorado.view.control.autoform.CustomFormElement.
自定义的AutoForm元素对象
CustomFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.CustomFormElement
构造器
CustomValidator - class com.bstek.dorado.view.data.validate.impl.CustomValidator.
用户自定义数据校验对象
CustomValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.CustomValidator
cacheViewModelInfo(String, ViewModel) - Static method in class com.bstek.dorado.view.ViewModelManager
cacheViewModelInfo
checkAccess(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
按系统默认的方式判断当前用户是否已登录
checkAccess(DoradoContext, Object) - Method in interface com.bstek.dorado.security.AccessChecker
校验用户登录状态的方法
checkAccess(DoradoContext) - Method in class com.bstek.dorado.view.ViewModelSupport
按系统默认的方式判断当前用户是否已登录
children() - Method in class com.bstek.dorado.view.control.tree.TreeNode
返回当前树节点(TreeNode)的所有子节点的集合对象。
clear() - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
clear() - Method in interface com.bstek.dorado.data.Dataset
清空Dataset中所有的数据。
clear() - Method in class com.bstek.dorado.data.DatasetAdapter
清空Dataset中所有的数据。
clear() - Method in class com.bstek.dorado.data.DatasetSupport
清空Dataset中所有的数据。
clear() - Method in class com.bstek.dorado.data.RecordSet
清除记录集中的数据记录
clear() - Method in class com.bstek.dorado.utils.variant.VariantSet
清除本集合中所有的数据.
clear() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
清空Dataset中所有的数据。
clearWarnings() - Method in class com.bstek.dorado.common.ds.TransConnection
clone() - Method in class com.bstek.dorado.data.BaseRecord
创建并返回本对象的一个副本。
clone() - Method in class com.bstek.dorado.data.Record
Creates and returns a copy of this object.
clone() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
Creates and returns a copy of this object.
clone() - Method in class com.bstek.dorado.utils.collection.ObjectList
clone() - Method in class com.bstek.dorado.utils.variant.Variant
Creates and returns a copy of this object.
clone() - Method in class com.bstek.dorado.utils.variant.VariantSet
Creates and returns a copy of this object.
cloneNode() - Method in interface com.bstek.dorado.utils.xml.XmlNode
克隆本节点
close() - Method in class com.bstek.dorado.common.ds.TransConnection
close() - Method in class com.bstek.dorado.data.db.DBStatement
关闭本DBStatement.
columns() - Method in class com.bstek.dorado.view.control.table.ColumnGroup
取得所有子列的集合对象。
columns() - Method in class com.bstek.dorado.view.control.table.Table
取得所有列的集合对象。
com.bstek.dorado - package com.bstek.dorado
Dorado4 Web应用开发框架。
com.bstek.dorado.action - package com.bstek.dorado.action
实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping - package com.bstek.dorado.action.mapping
Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.biz - package com.bstek.dorado.biz
为了增强dorado的可用性而特别提供给用户的一些通用类
com.bstek.dorado.common - package com.bstek.dorado.common
Dorado系统中的一些通用类
com.bstek.dorado.common.ds - package com.bstek.dorado.common.ds
一些用于获取各类数据连接(java.sql.Connection)的工具类
com.bstek.dorado.common.fileloader - package com.bstek.dorado.common.fileloader
dorado内部用于查找和读取各种配置文件的工具类
com.bstek.dorado.common.log - package com.bstek.dorado.common.log
Dorado系统日志的相关类
com.bstek.dorado.common.rtexpr - package com.bstek.dorado.common.rtexpr
用于支持运行时变量(例如: EL表达式)的工具类
com.bstek.dorado.common.rtexpr.impl - package com.bstek.dorado.common.rtexpr.impl
EL表达式相关的实现类
com.bstek.dorado.common.scope - package com.bstek.dorado.common.scope
用于支持对象的缓存和查找的工具类
com.bstek.dorado.data - package com.bstek.dorado.data
Dorado中Dataset的数据模块类。
com.bstek.dorado.data.custom - package com.bstek.dorado.data.custom
实现可自定义Dataset
com.bstek.dorado.data.db - package com.bstek.dorado.data.db
实现可直接访问数据库的Dataset
com.bstek.dorado.i18n - package com.bstek.dorado.i18n
用于支持国际化
com.bstek.dorado.module - package com.bstek.dorado.module
包含用于实现dorado的数据模块(Module)的类
com.bstek.dorado.security - package com.bstek.dorado.security
包含用于支持应用系统访问安全性的类
com.bstek.dorado.utils - package com.bstek.dorado.utils
dorado的基本工具类
com.bstek.dorado.utils.codec - package com.bstek.dorado.utils.codec
包含用于支持字符代码转换的工具类
com.bstek.dorado.utils.collection - package com.bstek.dorado.utils.collection
对象集合类
com.bstek.dorado.utils.http - package com.bstek.dorado.utils.http
一些与HTTP相关的工具类
com.bstek.dorado.utils.variant - package com.bstek.dorado.utils.variant
包含用于实现多态数据类型的类
com.bstek.dorado.utils.xml - package com.bstek.dorado.utils.xml
与XML相关的工具类
com.bstek.dorado.view - package com.bstek.dorado.view
包含视图模型(ViewModel)、视图控件和数据校验类。
com.bstek.dorado.view.control - package com.bstek.dorado.view.control
Dorado的各种视图控件类及实现。
com.bstek.dorado.view.control.advance - package com.bstek.dorado.view.control.advance
高级控件相关类
com.bstek.dorado.view.control.autoform - package com.bstek.dorado.view.control.autoform
Dorado中AutoForm控件类。
com.bstek.dorado.view.control.command - package com.bstek.dorado.view.control.command
Dorado中Command控件类。
com.bstek.dorado.view.control.dropdown - package com.bstek.dorado.view.control.dropdown
Dorado中DropDown控件类。
com.bstek.dorado.view.control.table - package com.bstek.dorado.view.control.table
Dorado中Table控件类。
com.bstek.dorado.view.control.tabset - package com.bstek.dorado.view.control.tabset
TabSet控件相关类
com.bstek.dorado.view.control.tree - package com.bstek.dorado.view.control.tree
Tree控件相关类
com.bstek.dorado.view.data - package com.bstek.dorado.view.data
Dorado视图模型中数据校验类及实现。
com.bstek.dorado.view.data.validate - package com.bstek.dorado.view.data.validate
Dorado视图模型中数据校验类。
com.bstek.dorado.view.data.validate.impl - package com.bstek.dorado.view.data.validate.impl
Dorado视图模型中数据校验类的实现。
com.bstek.dorado.view.rpc - package com.bstek.dorado.view.rpc
用于处理客户端远程过程调用的相关类
commands() - Method in class com.bstek.dorado.view.control.command.CommandQueue
取得所有命令的集合对象
commit() - Method in class com.bstek.dorado.common.JDBCTransaction
commit() - Method in interface com.bstek.dorado.common.Transaction
提交当前事务
commit() - Method in class com.bstek.dorado.common.ds.TransConnection
compile(String) - Static method in class com.bstek.dorado.common.rtexpr.CompiledText
预编译一个字符串.如果该字符串中含有运行时变量则返回一个预编译对象,否则返回null
compile(String) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
预编译一个字符串.如果该字符串中含有运行时变量则返回一个预编译对象,否则返回null
connectionClosed(TransConnection) - Method in class com.bstek.dorado.common.JDBCTransaction
connectionClosed(TransConnection) - Method in interface com.bstek.dorado.common.ds.TransConnectionListener
connections - Variable in class com.bstek.dorado.common.JDBCTransaction
constructControl(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
constructControl
constructDataset(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
constructDataset
constructDataset(String, String) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
constructDataset
containsKey(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
containsValue(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
controls - Variable in class com.bstek.dorado.view.ViewModelSupport
count() - Method in class com.bstek.dorado.utils.variant.VariantSet
返回集合中数值的总数量.
createAction(Controller) - Method in interface com.bstek.dorado.action.ActionFactory
创建并返回一个Action对象实例
createColumn(String) - Method in class com.bstek.dorado.view.control.table.DataTable
创建一个指定名称的列对象。
createColumn(String) - Method in class com.bstek.dorado.view.control.table.StaticTable
创建一个指定名称的列对象。
createColumn(String) - Method in class com.bstek.dorado.view.control.table.Table
创建一个指定名称的列对象。
createColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.DataTable
createColumnGroup
createColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.StaticTable
createColumnGroup
createColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.Table
createColumnGroup
createConfigLoader() - Static method in class com.bstek.dorado.common.fileloader.FileLoaderFactory
创建并返回一个缺省的FileLoader
createContext(DoradoContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprContextHelper
createContext
createControl(String, String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的控件类型和Id创建控件对象。
createControl(XmlNode) - Method in interface com.bstek.dorado.view.ViewModel
根据xml定义创建对应的控件对象。
createControl(XmlNode) - Method in class com.bstek.dorado.view.ViewModelSupport
根据xml定义创建对应的控件对象。
createControl(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的控件类型和Id创建控件对象。
createControl(ViewModel, String, String) - Method in interface com.bstek.dorado.view.control.ControlFactory
createControl
createController(String) - Method in interface com.bstek.dorado.action.ControllerFactory
根据Controller的别名创建并返回一个Controller对象实例
createController(HttpServletRequest, String) - Method in interface com.bstek.dorado.action.ControllerFactory
根据Modul配置对象创建并返回一个Controller对象实例
createController(String) - Static method in class com.bstek.dorado.action.ControllerManager
根据Controller的别名创建并返回一个Controller对象实例
createDataSourceConfig(XmlNode) - Static method in class com.bstek.dorado.common.ds.DataSourceConfigParser
createDataSourceConfig
createDataset(String) - Method in interface com.bstek.dorado.data.DatasetFactory
createDataset
createDataset(String, boolean, int, int, ParameterSet) - Method in class com.bstek.dorado.module.ModuleSupport
createDataset
createDataset(String, String) - Method in interface com.bstek.dorado.view.ViewModel
根据类型和Id，创建一个视图数据集。
createDataset(XmlNode) - Method in interface com.bstek.dorado.view.ViewModel
根据xml的定义创建一个视图数据集。
createDataset(XmlNode) - Method in class com.bstek.dorado.view.ViewModelSupport
根据xml的定义创建一个视图数据集。
createDataset(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据类型和Id，创建一个视图数据集。
createDataset(ViewModel, String, String) - Method in interface com.bstek.dorado.view.data.DatasetFactory
createDataset
createDummyField(String) - Method in interface com.bstek.dorado.data.FieldFactory
创建并返回 一个虚拟Field。
createDummyField(String) - Method in class com.bstek.dorado.data.db.AutoDBFieldFactory
创建并返回 一个虚拟Field。
createDummyField(String) - Method in class com.bstek.dorado.data.db.DBFieldFactory
创建并返回 一个虚拟Field。
createDummyField(String) - Method in class com.bstek.dorado.view.data.ViewFieldFactory
创建并返回 一个虚拟Field。
createField(String) - Method in interface com.bstek.dorado.data.FieldFactory
创建并返回一个普通Field。
createField(String) - Method in class com.bstek.dorado.data.db.AutoDBFieldFactory
创建并返回一个普通Field。
createField(String) - Method in class com.bstek.dorado.data.db.DBFieldFactory
创建并返回一个普通Field。
createField(String) - Method in class com.bstek.dorado.view.data.ViewFieldFactory
创建并返回一个普通Field。
createFieldByNode(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.DatasetSupport
根据一个描述字段的XML节点自动创建字段对象.
createFieldByNode(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.DatasetWrapper
根据一个描述字段的XML节点自动创建字段对象.
createFieldByNode(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
根据一个描述字段的XML节点自动创建字段对象.
createFields() - Method in interface com.bstek.dorado.data.Dataset
根据已设定的条件自动创建字段。
createFields() - Method in class com.bstek.dorado.data.DatasetAdapter
createFields() - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件自动创建字段。
createFields(ResultSet) - Method in class com.bstek.dorado.data.db.DBDataset
根据给定的ResultSet对象自动创建字段对象.
createFieldsFromObjectClazz() - Method in interface com.bstek.dorado.data.Dataset
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.
createFieldsFromObjectClazz() - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.

此方法将自动为Dataset添加字段对象.

createFieldsFromObjectClazz() - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.
createFormElement(FormGroup, String, String) - Method in interface com.bstek.dorado.view.control.autoform.FormElementFactory
createFormElement
createFormElement(FormGroup, String, String) - Method in class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl
createFormElement
createLookupField(String) - Method in interface com.bstek.dorado.data.FieldFactory
创建并返回一个支持Lookup功能的Field。
createLookupField(String) - Method in class com.bstek.dorado.data.db.AutoDBFieldFactory
创建并返回一个支持Lookup功能的Field。
createLookupField(String) - Method in class com.bstek.dorado.data.db.DBFieldFactory
创建并返回一个支持Lookup功能的Field。
createLookupField(String) - Method in class com.bstek.dorado.view.data.ViewFieldFactory
创建并返回一个支持Lookup功能的Field。
createModule(ModuleConfig) - Method in interface com.bstek.dorado.module.ModuleFactory
createModule
createRecord() - Method in interface com.bstek.dorado.data.RecordFactory
创建并返回一个Record对象
createRecord() - Method in class com.bstek.dorado.view.data.RecordReferenceFactory
createRecord() - Method in class com.bstek.dorado.view.data.ViewRecordFactory
createRecordFilter(String) - Static method in class com.bstek.dorado.data.RecordFilterFactory
createRecordFilter
createResourceLoader() - Static method in class com.bstek.dorado.common.fileloader.FileLoaderFactory
创建并返回一个ResourceFileLoader
createRootNode(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
创建根节点。
createSourceLoader() - Static method in class com.bstek.dorado.common.fileloader.FileLoaderFactory
createSourceLoader
createStatement() - Method in class com.bstek.dorado.common.ds.TransConnection
createStatement(int, int) - Method in class com.bstek.dorado.common.ds.TransConnection
createStatement(int, int, int) - Method in class com.bstek.dorado.common.ds.TransConnection
createTempForward(String) - Method in class com.bstek.dorado.action.mapping.Unit
创建一个临时的Forward对象。
createValidator(String) - Method in interface com.bstek.dorado.view.data.validate.ValidatorFactory
createValidator
createValidator(String) - Method in class com.bstek.dorado.view.data.validate.impl.DefaultValidatorFactory
createViewModel(DoradoContext, String, ViewModelConfig, String, int) - Method in interface com.bstek.dorado.view.ViewModelFactory
createViewModel
createXmlBuilder() - Static method in class com.bstek.dorado.utils.xml.XmlFactory
创建并返回一个XML构造器对象
createXmlOutputter() - Static method in class com.bstek.dorado.utils.xml.XmlFactory
创建并返回一个XML输出器对象

D

DATE - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - Date型。
DATETIME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - DateTime型。
DATETIME_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - DateTime型。
DATE_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - Date型。
DBDataset - class com.bstek.dorado.data.db.DBDataset.
基于SQL的Dataset的抽象基类
DBDataset() - Constructor for class com.bstek.dorado.data.db.DBDataset
构造器
DBField - class com.bstek.dorado.data.db.DBField.
DBDataset记录集的字段对象
DBField(String) - Constructor for class com.bstek.dorado.data.db.DBField
构造器
DBFieldFactory - class com.bstek.dorado.data.db.DBFieldFactory.
SqlField创建工厂
DBFieldFactory() - Constructor for class com.bstek.dorado.data.db.DBFieldFactory
DBStatement - class com.bstek.dorado.data.db.DBStatement.
用于方便使用SQL命令的工具类.
DBStatement() - Constructor for class com.bstek.dorado.data.db.DBStatement
构造器
DBStatement(String) - Constructor for class com.bstek.dorado.data.db.DBStatement
构造器
DBStatement(String, String) - Constructor for class com.bstek.dorado.data.db.DBStatement
构造器
DEFAULT_LOCALE_ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.i18n.ResourceManager
DEFAULT_LOCALE_ATTRIBUTE_KEY
DEFAULT_LOGIN_SESSION_KEY - Static variable in interface com.bstek.dorado.security.AccessChecker
DEFAULT_ROLE_ATTRIBUTE - Static variable in interface com.bstek.dorado.view.ViewModel
默认角色属性
DELETE - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - DELETE
DODataset - class com.bstek.dorado.view.data.DODataset.
可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
DODataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.DODataset
构造器
DOSet - class com.bstek.dorado.data.DOSet.
DO(Data Object)的集合.
DOSet() - Constructor for class com.bstek.dorado.data.DOSet
构造器
DOToRecord(Object, Record) - Static method in class com.bstek.dorado.data.DOUtils
利用反射从o参数指定的对象中读取数据并设置到给定的record中.
DOToRecord(Object, Dataset) - Static method in class com.bstek.dorado.data.DOUtils
利用反射从o参数指定的对象中读取数据, 并追加到Dataset中.
DOToVariantSet(Object, VariantSet) - Static method in class com.bstek.dorado.data.DOUtils
利用反射从o参数指定的对象中读取数据并设置到给定的变量集合中.
DOUBLE - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - double型。
DOUBLE_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - double型。
DOUtils - class com.bstek.dorado.data.DOUtils.
用于在Dataset和DO(Data Object)之间转换数据的工具类
DOWrapper - class com.bstek.dorado.data.DOWrapper.
DOWrapper(Object, int) - Constructor for class com.bstek.dorado.data.DOWrapper
DRAGMODE_MOUSEMOVE - Static variable in class com.bstek.dorado.view.control.ScrollBar
DRAGMODE_MOUSEMOVE
DRAGMODE_MOUSEUP - Static variable in class com.bstek.dorado.view.control.ScrollBar
DRAGMODE_MOUSEUP
DataColumn - class com.bstek.dorado.view.control.table.DataColumn.
DataColumn(String) - Constructor for class com.bstek.dorado.view.control.table.DataColumn
DataColumn
DataControl - class com.bstek.dorado.view.control.DataControl.
数据控件对象接口
DataControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.DataControl
构造器
DataLabel - class com.bstek.dorado.view.control.DataLabel.
数据标签对象
DataLabel(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.DataLabel
构造器
DataListener - interface com.bstek.dorado.data.DataListener.
针对Dataset中的数据的事件监听器
DataPilot - class com.bstek.dorado.view.control.DataPilot.
数据导航控件对象
DataPilot(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.DataPilot
构造器
DataSourceConfig - class com.bstek.dorado.common.ds.DataSourceConfig.
数据源配置对象的抽象基类
DataSourceConfig() - Constructor for class com.bstek.dorado.common.ds.DataSourceConfig
DataSourceConfig
DataSourceConfigParser - class com.bstek.dorado.common.ds.DataSourceConfigParser.
Dorado的datasource.xml配置文件的解析器
DataTable - class com.bstek.dorado.view.control.table.DataTable.
DataTable对象
DataTable(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.table.DataTable
构造器
DataTree - class com.bstek.dorado.view.control.tree.DataTree.
树状列表对象
DataTree(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.tree.DataTree
构造器
DataType - class com.bstek.dorado.utils.variant.DataType.
数据类型
Dataset - interface com.bstek.dorado.data.Dataset.
Dorado记录集的接口。
DatasetAdapter - class com.bstek.dorado.data.DatasetAdapter.
Dataset适配器
DatasetAdapter() - Constructor for class com.bstek.dorado.data.DatasetAdapter
构造器
DatasetAdapter(Dataset) - Constructor for class com.bstek.dorado.data.DatasetAdapter
构造器
DatasetDropDown - class com.bstek.dorado.view.control.dropdown.DatasetDropDown.
DatasetDropDown下拉框
DatasetDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DatasetDropDown
构造器
DatasetFactory - interface com.bstek.dorado.data.DatasetFactory.
DatasetFactory - interface com.bstek.dorado.view.data.DatasetFactory.
DatasetInfo - class com.bstek.dorado.view.control.command.DatasetInfo.
命令要提交的Dataset数据集
DatasetInfo() - Constructor for class com.bstek.dorado.view.control.command.DatasetInfo
DatasetListener - interface com.bstek.dorado.data.DatasetListener.
Dataset事件监听器的接口
DatasetReference - class com.bstek.dorado.view.data.DatasetReference.
数据集引用对象
DatasetReference(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.DatasetReference
构造器
DatasetSupport - class com.bstek.dorado.data.DatasetSupport.
数据集的抽象基类。
DatasetSupport() - Constructor for class com.bstek.dorado.data.DatasetSupport
构造器
DatasetWrapper - class com.bstek.dorado.view.data.DatasetWrapper.
数据集包装器.
DatasetWrapper(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.DatasetWrapper
构造器
DateDropDown - class com.bstek.dorado.view.control.dropdown.DateDropDown.
日期对象下拉框
DateDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DateDropDown
构造器
DefaultModule - class com.bstek.dorado.module.DefaultModule.
DefaultModule() - Constructor for class com.bstek.dorado.module.DefaultModule
DefaultTreeNode - class com.bstek.dorado.view.control.tree.DefaultTreeNode.
DefaultTreeNode() - Constructor for class com.bstek.dorado.view.control.tree.DefaultTreeNode
构造器
DefaultTreeNode(String) - Constructor for class com.bstek.dorado.view.control.tree.DefaultTreeNode
构造器
DefaultValidatorFactory - class com.bstek.dorado.view.data.validate.impl.DefaultValidatorFactory.
DefaultValidatorFactory() - Constructor for class com.bstek.dorado.view.data.validate.impl.DefaultValidatorFactory
DefaultValidatorFactory
DefaultViewModel - class com.bstek.dorado.view.DefaultViewModel.
DefaultViewModel() - Constructor for class com.bstek.dorado.view.DefaultViewModel
DoradoContext - class com.bstek.dorado.common.DoradoContext.
Dorado上下文对象.
DoradoContext() - Constructor for class com.bstek.dorado.common.DoradoContext
DoradoContextMap - class com.bstek.dorado.common.rtexpr.impl.DoradoContextMap.
DoradoContextMap(DoradoContext) - Constructor for class com.bstek.dorado.common.rtexpr.impl.DoradoContextMap
DoradoContextMap
DoradoException - exception com.bstek.dorado.utils.DoradoException.
所有Dorado中异常的基类
DoradoException() - Constructor for class com.bstek.dorado.utils.DoradoException
DoradoException
DoradoException(String) - Constructor for class com.bstek.dorado.utils.DoradoException
DoradoException
DoradoException(Throwable) - Constructor for class com.bstek.dorado.utils.DoradoException
DoradoException
DoradoProcess - class com.bstek.dorado.common.DoradoProcess.
DoradoProcess() - Constructor for class com.bstek.dorado.common.DoradoProcess
Process
DoradoRuntimeException - exception com.bstek.dorado.utils.DoradoRuntimeException.
所有Dorado中Runtime异常的基类
DoradoRuntimeException() - Constructor for class com.bstek.dorado.utils.DoradoRuntimeException
DoradoRuntimeException
DoradoRuntimeException(String) - Constructor for class com.bstek.dorado.utils.DoradoRuntimeException
DoradoRuntimeException
DoradoRuntimeException(Throwable) - Constructor for class com.bstek.dorado.utils.DoradoRuntimeException
DoradoRuntimeException
DropDown - class com.bstek.dorado.view.control.dropdown.DropDown.
下拉框的基类
DropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DropDown
构造器
DropDownItem - class com.bstek.dorado.view.control.dropdown.DropDownItem.
下拉框选择项对象
DropDownItem() - Constructor for class com.bstek.dorado.view.control.dropdown.DropDownItem
构造器
DropDownViewModel - class com.bstek.dorado.view.control.dropdown.DropDownViewModel.
下拉框的视图模型对象
DropDownViewModel() - Constructor for class com.bstek.dorado.view.control.dropdown.DropDownViewModel
DummyField - class com.bstek.dorado.data.DummyField.
虚拟字段
DummyField(String) - Constructor for class com.bstek.dorado.data.DummyField
构造器
DuplicateKeyException - exception com.bstek.dorado.utils.collection.DuplicateKeyException.
键值重复异常
DuplicateKeyException(Object) - Constructor for class com.bstek.dorado.utils.collection.DuplicateKeyException
DuplicateObjectKeyException
DynaDoradoContext - class com.bstek.dorado.common.DynaDoradoContext.
DynaDoradoContext() - Constructor for class com.bstek.dorado.common.DynaDoradoContext
DynamicDropDown - class com.bstek.dorado.view.control.dropdown.DynamicDropDown.
动态下拉框对象
DynamicDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DynamicDropDown
构造器
DynamicDropDownDataset - class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset.
动态下拉框数据集对象
DynamicDropDownDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset
DynamicDropDownViewModel - class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel.
动态下拉框的视图模型对象
DynamicDropDownViewModel() - Constructor for class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
dataSource - Variable in class com.bstek.dorado.data.db.DBDataset
datasetInfos() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
返回更新命令(UpdateCommand)对象的DatasetInfo集合对象。
datasetUpdateInfos - Static variable in class com.bstek.dorado.module.ModuleSupport
datasets() - Method in interface com.bstek.dorado.module.Module
取得所有datasets的集合对象
datasets() - Method in class com.bstek.dorado.module.ModuleSupport
取得所有datasets的集合对象
datasets - Variable in class com.bstek.dorado.view.ViewModelSupport
debug(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_DEBUG 的字符串记录到日志文件里。
debug(Object) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_DEBUG 的字符串记录到日志文件里。
decode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.Encrypt
解密字符串
decode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.EncryptCode
解密字符串
decode(String) - Static method in class com.bstek.dorado.utils.codec.SafeCode
对安全字符串进行解码，返回原始字符串。
deleteRecord() - Method in interface com.bstek.dorado.data.Dataset
删除当前记录。
deleteRecord(Record) - Method in interface com.bstek.dorado.data.Dataset
删除指定的记录。
deleteRecord() - Method in class com.bstek.dorado.data.DatasetAdapter
删除当前记录。
deleteRecord(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
删除指定的记录。
deleteRecord() - Method in class com.bstek.dorado.data.DatasetSupport
删除当前记录。
deleteRecord(Record) - Method in class com.bstek.dorado.data.DatasetSupport
删除指定的记录。
deleteRecord() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
删除当前记录。
deleteRecord(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
删除指定的记录。
destroyObject(Object, Object) - Method in class com.bstek.dorado.module.PoolableModuleFactory
destroyObject
detailKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的字段数组。
detailKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
detailKeyParameters
detailKeyParameters() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的参数数组。
dialect - Variable in class com.bstek.dorado.data.db.DBDataset
dispose() - Method in class com.bstek.dorado.common.JDBCTransaction
dispose() - Method in interface com.bstek.dorado.common.Transaction
废除当前的事务对象并释放所有资源.
disposeTransaction() - Static method in class com.bstek.dorado.common.TransactionManager
disposeTransaction
doAction(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
执行默认的Action。
doActivate() - Method in class com.bstek.dorado.module.ModuleSupport
doActivate
doDispatch(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
系统内部用于完成分派Action处理的方法。
doDownload(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
文件下载
doFromDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
doFromDO(Object) - Method in class com.bstek.dorado.view.data.DODataset
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
doFromDO(Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
doFromSingleDO(Object, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
doFromSingleDO(Object, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
doGet(String) - Method in class com.bstek.dorado.data.BaseRecord
返回记录中某字段的值。此方法须在派生类中实现。
doGet(String) - Method in class com.bstek.dorado.data.ReadRecord
返回记录中某字段的值。
doGet(String) - Method in class com.bstek.dorado.view.data.RecordReference
返回记录中某字段的值。此方法须在派生类中实现。
doGetCountSql() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
获得用于统计总记录数的SQL命令.
doGetCountSql() - Method in class com.bstek.dorado.data.db.DBDataset
获得用于统计总记录数的SQL命令.
doGetCountSql() - Method in class com.bstek.dorado.data.db.SqlDataset
获得用于统计总记录数的SQL命令.
doGetDialect() - Method in class com.bstek.dorado.data.db.DBDataset
获得此Dataset内部使用的数据库方言的实现类.
doGetSourceDatasetForLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
doGetSourceDatasetForLoad
doGetSourceDatasetForLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.DatasetReference
doGetSourceDatasetForLoad
doGetSourceDatasetForLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.DatasetWrapper
doGetSourceDatasetForLoad
doGetSourceDatasetForUpdate() - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
doGetSourceDatasetForUpdate
doGetSourceDatasetForUpdate() - Method in class com.bstek.dorado.view.data.DatasetReference
doGetSourceDatasetForUpdate
doGetSourceDatasetForUpdate() - Method in class com.bstek.dorado.view.data.DatasetWrapper
doGetSourceDatasetForUpdate
doGetSql(boolean) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
获得SQL命令.
doGetSql(boolean) - Method in class com.bstek.dorado.data.db.DBDataset
获得SQL命令.
doGetSql(boolean) - Method in class com.bstek.dorado.data.db.SqlDataset
获得SQL命令.
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
doGetViewModel
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
doGetViewModel
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
doGetViewModel
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
doGetViewModel
doLoad(boolean, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.data.custom.CustomDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.data.db.DBDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.CustomDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.DODataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.FormDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据已设定的条件读取外部数据.
doLoadData() - Method in class com.bstek.dorado.view.AbstractViewModel
Deprecated.
doLoadData() - Method in class com.bstek.dorado.view.ViewModelSupport
doLoadData
doOutput(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
直接把文件显示到浏览器中
doPassivate() - Method in class com.bstek.dorado.module.ModuleSupport
doPassivate
doSet(String, Object) - Method in class com.bstek.dorado.data.BaseRecord
设置当前记录中某字段的值。此方法须在派生类中实现。
doSet(String, Object) - Method in class com.bstek.dorado.data.Record
设置当前记录中某字段的值。
doSet(String, Object) - Method in class com.bstek.dorado.view.data.RecordReference
设置当前记录中某字段的值。此方法须在派生类中实现。
doSetFile(String) - Method in class com.bstek.dorado.common.fileloader.FileLoader
设置要打开的文件。
doSetFile(String) - Method in class com.bstek.dorado.common.fileloader.PathFileLoader
设置要打开的文件。
doSetFile(String) - Method in class com.bstek.dorado.common.fileloader.ResourceFileLoader
设置要打开的文件。
doToDO(Collection, String) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
doToSingleDO(Record) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的当前记录转换为对象.
doToSingleDO(Record, Object) - Method in class com.bstek.dorado.data.DatasetSupport
将给定的记录转换到给定的对象中.
doToSingleDO(Record, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
将给定的记录转换到给定的对象中.
doUpdate() - Method in class com.bstek.dorado.data.DatasetSupport
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.data.custom.CustomDataset
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.data.db.DBDataset
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate(DoradoContext, ObjectCollection) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. 当系统试图对ViewModel中的Dataset进行持久化时触发的方法。
doUpdate(ParameterSet) - Method in class com.bstek.dorado.view.AbstractViewModel
Deprecated.
doUpdate() - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.view.data.DODataset
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
把用户对Dataset中数据的操作更新到外部数据中.
doUpdateData(ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
当系统试图对ViewModel中的Dataset进行持久化时触发的方法。
doUpload(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
执行文件上传

E

EMPTY - Static variable in class com.bstek.dorado.common.HashKeyUtil
EMPTY
EQUALS - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
等于
EditableColumn - class com.bstek.dorado.view.control.table.EditableColumn.
可编辑列对象
EditableColumn(String) - Constructor for class com.bstek.dorado.view.control.table.EditableColumn
构造器
EditableColumnGroup - class com.bstek.dorado.view.control.table.EditableColumnGroup.
EditableColumnGroup(String) - Constructor for class com.bstek.dorado.view.control.table.EditableColumnGroup
Editor - class com.bstek.dorado.view.control.Editor.
编辑器的基类
Editor(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Editor
构造器
Element - interface com.bstek.dorado.view.Element.
元素接口
Encrypt - class com.bstek.dorado.utils.codec.Encrypt.
对字符串进行加密 1.
EncryptCode - class com.bstek.dorado.utils.codec.EncryptCode.
本算法只用于加密由0-9和A-Z组成的字符串，以下的提到的字符指由0-9和A-Z组成的字符；假设字符串的长度为n) 1.
EncryptCode() - Constructor for class com.bstek.dorado.utils.codec.EncryptCode
EscapeUtils - class com.bstek.dorado.utils.codec.EscapeUtils.
用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。
Event - class com.bstek.dorado.view.Event.
客户端事件的定义描述对象
Event() - Constructor for class com.bstek.dorado.view.Event
构造器
EventConfig - class com.bstek.dorado.view.EventConfig.
客户端事件定义的配置管理器
EventHandler - class com.bstek.dorado.view.EventHandler.
事件处理类
EventHandler(String) - Constructor for class com.bstek.dorado.view.EventHandler
构造器
EventHandler(String, String) - Constructor for class com.bstek.dorado.view.EventHandler
构造器
EventSupported - interface com.bstek.dorado.view.EventSupported.
可支持客户端事件的控件的接口
ExceptionHandler - interface com.bstek.dorado.action.ExceptionHandler.
ActionException的处理器
ExprContextHelper - class com.bstek.dorado.common.rtexpr.ExprContextHelper.
ExprHelper - class com.bstek.dorado.common.rtexpr.ExprHelper.
用于方便使用运行时变量功能的工具类
ExprInitializer - interface com.bstek.dorado.common.rtexpr.ExprInitializer.
EL表达式初试化器
ExpressionUtils - class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils.
EL表达式工具类,该类所具有的各个方法亦即Util表达式所支持的各项功能.
elements() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回组(Group)中所有元素的集合对象。
encode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.Encrypt
加密字符串
encode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.EncryptCode
加密字符串
encode(String) - Static method in class com.bstek.dorado.utils.codec.SafeCode
对原始字符串进行编码，返回安全字符串。
endCalling(String) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
完成远程调用方法.
endCalling(String) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
完成远程调用方法.
entrySet() - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
equals(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
equals(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
equals(Object) - Method in class com.bstek.dorado.utils.variant.Variant
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class com.bstek.dorado.utils.variant.VariantSet
Indicates whether some other object is "equal to" this one.
error(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Object, Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Object) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Throwable) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Object, Throwable) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
escape(String) - Static method in class com.bstek.dorado.utils.codec.EscapeUtils
对原始字符串进行编码，返回安全字符串。
eventHandlers() - Method in interface com.bstek.dorado.view.Component
取得所有事件处理对象的集合对象。
eventHandlers() - Method in interface com.bstek.dorado.view.EventSupported
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.ViewModelSupport
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.control.AbstractControl
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.control.table.EditableColumn
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.control.table.EditableColumnGroup
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
eventHandlers
eventHandlers() - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
取得所有事件处理对象的集合对象。
execute() - Method in class com.bstek.dorado.data.db.DBStatement
执行SQL命令.
execute() - Method in class com.bstek.dorado.utils.SynchroTimer
定时器在激活时所触发的动作
execute() - Method in class com.bstek.dorado.utils._MockSynchroTimer
execute() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
执行默认的远程调用方法.
execute() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
执行默认的远程调用方法.
execute(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
execute
exists(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
判断给定键值下是否存有数值.
extractRecordKey(ReadRecord, String[]) - Static method in class com.bstek.dorado.common.HashKeyUtil
extractRecordKey
extractVariantsKey(VariantSet, String[]) - Static method in class com.bstek.dorado.common.HashKeyUtil
extractVariantsKey

F

FILTER_ALL - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有记录
FILTER_CHANGED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有发生变化的记录(包含新添加的、被修改过的和已删除的)
FILTER_DEFAULT - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 默认的记录 在此种方式下只有标记为"已删除"的记录是不可见的
FILTER_DELETED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有已删除的记录
FILTER_MODIFIED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有被修改过的记录
FILTER_NEW - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有被新添加的记录
FILTER_NOT_CHANGED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有未发生变化的记录
FLOAT - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - float型。
FLOAT_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - float型。
FLUSH - Static variable in class com.bstek.dorado.view.control.command.QueryCommand
FLUSH
FORM_GET - Static variable in class com.bstek.dorado.view.control.command.QueryCommand
FORM_GET
FORM_POST - Static variable in class com.bstek.dorado.view.control.command.QueryCommand
FORM_POST
Field - interface com.bstek.dorado.data.Field.
字段
FieldFactory - interface com.bstek.dorado.data.FieldFactory.
Field的创建工厂
FieldLabel - class com.bstek.dorado.view.control.FieldLabel.
字段标签对象
FieldLabel(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.FieldLabel
构造器
FieldNotExistException - exception com.bstek.dorado.data.FieldNotExistException.
无法找到指定的Field对象的异常。
FieldNotExistException(String) - Constructor for class com.bstek.dorado.data.FieldNotExistException
构造器
FieldSet - class com.bstek.dorado.data.FieldSet.
字段集合对象
FieldSet() - Constructor for class com.bstek.dorado.data.FieldSet
构造器
FileController - class com.bstek.dorado.biz.FileController.
用于协助用户完成文件上传和下载的Controller.
FileController() - Constructor for class com.bstek.dorado.biz.FileController
FileLoader - class com.bstek.dorado.common.fileloader.FileLoader.
文件加载器的抽象类
FileLoader(String) - Constructor for class com.bstek.dorado.common.fileloader.FileLoader
构造器
FileLoaderFactory - class com.bstek.dorado.common.fileloader.FileLoaderFactory.
FileLoader的创建工厂
FormDataset - class com.bstek.dorado.view.data.FormDataset.
FormDataset对象 FormDataset可以自动从Request的parameter中收集数据并转换到记录集中, 利用FormDataset我们可以很方便的在网页中制作具备数据回填功能的Form表单.
FormDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.FormDataset
构造器
FormElement - class com.bstek.dorado.view.control.autoform.FormElement.
FormElement抽象类
FormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.FormElement
构造器
FormElementFactory - interface com.bstek.dorado.view.control.autoform.FormElementFactory.
FormElementFactoryImpl - class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl.
表单元素的工厂类接口
FormElementFactoryImpl() - Constructor for class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl
构造器
FormGroup - class com.bstek.dorado.view.control.autoform.FormGroup.
AutoForm中的组对象
FormGroup(AutoForm) - Constructor for class com.bstek.dorado.view.control.autoform.FormGroup
构造器
FormGroupGround - class com.bstek.dorado.view.control.autoform.FormGroupGround.
AutoForm的辅助类
FormGroupGround(int) - Constructor for class com.bstek.dorado.view.control.autoform.FormGroupGround
构造器
ForwardHandler - interface com.bstek.dorado.action.ForwardHandler.
ActionForward的处理器
Frame - class com.bstek.dorado.view.control.command.Frame.
命令提交后打开页面的目标框架
Frame() - Constructor for class com.bstek.dorado.view.control.command.Frame
构造器
FrameTab - class com.bstek.dorado.view.control.tabset.FrameTab.
FrameTab(String) - Constructor for class com.bstek.dorado.view.control.tabset.FrameTab
构造器
FrameTab(String, String) - Constructor for class com.bstek.dorado.view.control.tabset.FrameTab
构造器
fatal(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Object, Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Object) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Throwable) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Object, Throwable) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
field - Variable in class com.bstek.dorado.view.control.autoform.FormElement
字段
fieldSet() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset的Field集合对象
fieldSet() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset的Field集合对象
fieldSet() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset的Field集合对象
fieldSet() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset的Field集合对象
fillPoint(int, int) - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
fillPoint
filter() - Method in class com.bstek.dorado.data.RecordIterator
Deprecated.
finalize() - Method in class com.bstek.dorado.data.DatasetSupport
finalize() - Method in class com.bstek.dorado.module.ModuleSupport
finalize() - Method in class com.bstek.dorado.view.ViewModelSupport
find(String, Object) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回匹配的记录。
find(String[], Object[]) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回匹配的记录。
find(String, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String, Object) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(Object) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一个字段值查找一组记录。
find(Object[]) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一字段值查找一组记录。
find(String, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String[], Object[]) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
findAll(String, Object) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回所有匹配的记录。
findAll(String, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findAll(String, Object) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回所有匹配的记录。
findAll(Object) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一个字段值查找记录。
findAll(Object[]) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一组字段值查找记录。
findAll(String, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findController(HttpServletRequest, String) - Method in interface com.bstek.dorado.action.ControllerFactory
根据给定名称查找并返回一个Controller的实例。
findController(String) - Method in class com.bstek.dorado.action.mapping.Mapping
根据给定的别名查找一个Controller对象
findDefaultForward() - Method in interface com.bstek.dorado.action.Action
查找一个默认的ActionForward对象。
findDefaultForward() - Method in class com.bstek.dorado.action.mapping.ActionConfig
查找一个默认的ActionForward对象。
findException(Throwable) - Method in interface com.bstek.dorado.action.Action
根据一个给定的Throwable对象查找一个可用的ActionException对象。
findException(Throwable) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据一个给定的Throwable对象查找一个可用的ActionException对象。
findException(Throwable) - Method in class com.bstek.dorado.action.mapping.Mapping
根据给定的异常查找一个全局的ActionException对象，即在global中定义的ActionException。
findForward(String) - Method in interface com.bstek.dorado.action.Action
根据别名查找一个可用的ActionForward对象。
findForward(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据别名查找一个可用的ActionForward对象。
findForward(String) - Method in class com.bstek.dorado.action.mapping.Mapping
根据给定的别名查找一个全局的ActionForward对象，即在global中定义的ActionForward。
findForward(String) - Method in class com.bstek.dorado.action.mapping.Unit
根据别名在配置单元中查找一个ActionForward对象
findItem(String) - Method in class com.bstek.dorado.view.control.Menu
根据子菜单项的路径返回一个菜单项.
findLevel(int) - Method in class com.bstek.dorado.view.control.tree.DataTree
查找返回指定层次的TreeLevel对象。
findNext(RecordWrapper) - Method in class com.bstek.dorado.data.DatasetSupport
findNext
findObject(DoradoContext, String, String) - Static method in class com.bstek.dorado.common.scope.ScopeHelper
根据属性名从指定的资源中取得一个已被存入的对象
findPrev(RecordWrapper) - Method in class com.bstek.dorado.data.DatasetSupport
findPrev
findViewModel(String, String, String, String) - Static method in class com.bstek.dorado.view.ViewModelManager
findViewModel
findWrapper(Record) - Method in class com.bstek.dorado.data.RecordSet
寻找并返回指定记录的包装器.
fireAfterChange(ReadRecord, String) - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterChange事件
fireAfterChange(ReadRecord, String) - Method in class com.bstek.dorado.data.Record
触发AfterChange事件，该事件一般由Dataset进行监听。
fireAfterCreateFields() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterCreateFields事件
fireAfterDelete(ReadRecord) - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterDelete事件
fireAfterInsert(Record) - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterInsert事件
fireAfterLoadData() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterLoadData事件
fireAfterScroll() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterScroll事件
fireAfterScroll() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
触发AfterScroll事件
fireAfterUpdateData() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterUpdateData事件
fireBeforeChange(ReadRecord, String, Variant) - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeChange事件
fireBeforeChange(ReadRecord, String, Object) - Method in class com.bstek.dorado.data.Record
触发BeforeChange事件，该事件一般由Dataset进行监听。
fireBeforeCreateFields() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeCreateFields事件
fireBeforeDelete(ReadRecord) - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeDelete事件
fireBeforeInsert(Record) - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeInsert事件
fireBeforeLoadData() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeLoadData事件
fireBeforeScroll() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeScroll事件
fireBeforeUpdateData() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeUpdateData事件
fireConnectionClosed(TransConnection) - Method in class com.bstek.dorado.common.ds.TransConnection
fireOnInit() - Method in class com.bstek.dorado.data.DatasetSupport
触发OnInit事件
forceAdd(Object, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。
forceAdd(Object, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。
format(String, Object[]) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
fromDO(Object) - Method in interface com.bstek.dorado.data.Dataset
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
fromDO(Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromDO(Object) - Method in class com.bstek.dorado.view.data.DODataset
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromDO(Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromSingleDO(Object) - Method in interface com.bstek.dorado.data.Dataset
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.
fromSingleDO(Object, boolean) - Method in interface com.bstek.dorado.data.Dataset
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
fromSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object, boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

G

GREATER - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
大于
GREATEREQUAL - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
大于等于
GlobalUnit - class com.bstek.dorado.action.mapping.GlobalUnit.
全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。
GlobalUnit(String) - Constructor for class com.bstek.dorado.action.mapping.GlobalUnit
构造器
get(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.DoradoContextMap
get(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.RequestContextMap
get(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.ResourceBundleContextMap
get(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.ServletContextMap
get(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.SessionContextMap
get(String) - Method in class com.bstek.dorado.data.ReadRecord
直接返回记录中某字段的对应值对象
get(Object) - Method in class com.bstek.dorado.i18n.ResourceManagerContextMap
get(Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回对象列表中的一个对象。
get(int) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回对象列表中的一个对象。
get(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回对象列表中的一个对象。
get(int) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回对象列表中的一个对象。
getAccessChecker() - Static method in class com.bstek.dorado.security.AccessCheckerManager
getAccessChecker
getAccessChecker(String) - Static method in class com.bstek.dorado.security.AccessCheckerManager
getAccessChecker
getAction(int) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
根据索引号得到一个ActionConfig
getAction(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
根据给定的别名查找一个ActionConfig
getAction() - Method in class com.bstek.dorado.view.control.command.RPCCommand
getAction
getAction() - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
取得提交表单数据集命令(SubmitFormDatasetCommand)对象请求的动作(Action)值。
getActionCount() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
返回ActionConfig的个数
getActionFactory() - Static method in class com.bstek.dorado.action.ActionHandler
获得系统内部使用的Action工厂。
getAggregate() - Method in class com.bstek.dorado.data.db.AutoDBField
返回AutoSqlDataset中Field的合计模式.
getAlign() - Method in class com.bstek.dorado.view.control.table.DataColumn
取得列的水平对齐方式(Align)。
getAttribute(String) - Method in class com.bstek.dorado.common.AbstractDoradoContext
从上下文的Request作用域中获取一个属性的值.
对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Attribute).
getAttribute(String) - Method in class com.bstek.dorado.common.DoradoContext
从上下文的Request作用域中获取一个属性的值.
getAttribute(int, String) - Method in class com.bstek.dorado.common.DoradoContext
根据指定的作用域从上下文中获取一个属性的值.
getAttribute(int, String) - Method in class com.bstek.dorado.common.DynaDoradoContext
getAttribute(int, String) - Method in class com.bstek.dorado.common.HttpDoradoContext
根据指定的作用域从上下文中获取一个属性的值.
getAttribute(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回一个属性的值
getAttributeBoolean(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型返回一个属性的值
getAttributeBoolean(String, boolean) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.
getAttributeBoolean(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回一个属性的值
getAttributeBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回一个属性的值.
getAttributeDouble(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型返回一个属性的值
getAttributeDouble(String, double) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.
getAttributeDouble(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回一个属性的值
getAttributeDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回一个属性的值.
getAttributeFloat(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型返回一个属性的值
getAttributeFloat(String, float) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.
getAttributeFloat(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回一个属性的值
getAttributeFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回一个属性的值.
getAttributeInt(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回一个属性的值
getAttributeInt(String, int) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.
getAttributeInt(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回一个属性的值
getAttributeInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回一个属性的值.
getAttributeLong(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型返回一个属性的值
getAttributeLong(String, long) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.
getAttributeLong(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回一个属性的值
getAttributeLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回一个属性的值.
getAttributeNames() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回所有属性的属性属性名
getAttributeString(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按String类型返回一个属性的值.此方法总是返回一个有效地String,不会返回null.
getAttributeString(String, String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.
getAttributeString(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按String类型返回一个属性的值.此方法总是返回一个有效地String,不会返回null.
getAttributeString(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回一个属性的值.
getAutoCommit() - Method in class com.bstek.dorado.common.ds.TransConnection
getAutoForm() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得该Group所属的AutoForm对象。
getBaseHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
getBaseHandler
getBigChange() - Method in class com.bstek.dorado.view.control.ScrollBar
getBigChange
getBigDecimal(int) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(int) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.data.ReadRecord
按BigDecimal类型返回记录中某字段的值。
getBigDecimal() - Method in class com.bstek.dorado.utils.variant.Variant
按BigDecimal类型读取数据
getBigDecimal(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按BigDecimel类型读取数据
getBigDecimal(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按BigDecimal类型读取数据
getBigDecimal(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBoolean(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Boolean型的配置信息
getBoolean(String, boolean) - Static method in class com.bstek.dorado.common.Setting
读取一个Boolean型的配置信息,如何该配置不存在则返回缺省值.
getBoolean(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Boolean型的配置信息
getBoolean(String, boolean) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Boolean型的配置信息
getBoolean(int) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型返回当前记录中某字段的值。
getBoolean(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBoolean(int) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.data.ReadRecord
按boolean类型返回记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按boolean方式读取一个参数
getBoolean() - Method in class com.bstek.dorado.utils.variant.Variant
按boolean类型读取数据
getBoolean(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按boolean类型读取数据
getBoolean(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按boolean类型读取数据
getBoolean(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBuildNo() - Static method in class com.bstek.dorado.Constants
getBuildNo
getBundle(String, Locale) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源集合.
getBundle(DoradoContext, String) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源集合.
getButtonAppend() - Method in class com.bstek.dorado.view.control.DataPilot
取得“追加一条记录”(Append)按钮的显示状态。
getButtonCancel() - Method in class com.bstek.dorado.view.control.DataPilot
取得“撤销对当前记录修改”(Cancel)按钮的显示状态。
getButtonDelete() - Method in class com.bstek.dorado.view.control.DataPilot
取得“删除一条记录”(Delete)按钮的显示状态。
getButtonInsert() - Method in class com.bstek.dorado.view.control.DataPilot
返回“插入一条记录”(Insert)按钮的显示状态。
getButtonMoveFirst() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到第一条”按钮(MoveFirst)的显示状态。
getButtonMoveLast() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到最后一条”按钮(MoveLast)的显示状态。
getButtonMoveNext() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到下一条”按钮(MoveNext)的显示状态。
getButtonMovePrev() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到下一条”按钮(MovePrev)的显示状态。
getButtonNextPage() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到后一页”按钮(NextPage)的显示状态。
getButtonPost() - Method in class com.bstek.dorado.view.control.DataPilot
返回Post按钮
getButtonPrevPage() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到前一页”按钮(PrevPage)的显示状态。
getByte(int) - Method in interface com.bstek.dorado.data.Dataset
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in interface com.bstek.dorado.data.Dataset
按byte类型返回当前记录中某字段的值。
getByte(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型返回当前记录中某字段的值。
getByte(int) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.data.ReadRecord
按byte类型返回记录中某字段的值。
getByte() - Method in class com.bstek.dorado.utils.variant.Variant
按byte类型读取数据
getByte(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按byte类型读取数据
getByte(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按byte类型读取数据
getByte(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型返回当前记录中某字段的值。
getCalendarType() - Method in class com.bstek.dorado.view.control.Calendar
返回日历类型。
getCatalog() - Method in class com.bstek.dorado.common.ds.TransConnection
getCharSet(String) - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
根据数据源配置的名字返回数据库使用CharSet.
getCharSet() - Method in class com.bstek.dorado.common.ds.DataSourceConfig
getCharSet
getChild(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
根据标记名返回子节点中的第一个匹配的节点，如果无法找到匹配的节点则返回null。
getChildContent(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
返回子节点的内容
getChildContent(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回子节点的内容
getChildContentBoolean(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型返回子节点的内容
getChildContentBoolean(String, boolean) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.
getChildContentBoolean(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回子节点的内容
getChildContentBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回子节点的内容.
getChildContentDouble(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型返回子节点的内容
getChildContentDouble(String, double) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.
getChildContentDouble(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回子节点的内容
getChildContentDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回子节点的内容.
getChildContentFloat(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型返回子节点的内容
getChildContentFloat(String, float) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.
getChildContentFloat(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回子节点的内容
getChildContentFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回子节点的内容.
getChildContentInt(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回子节点的内容
getChildContentInt(String, int) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.
getChildContentInt(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回子节点的内容
getChildContentInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回子节点的内容.
getChildContentLong(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型返回子节点的内容
getChildContentLong(String, long) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.
getChildContentLong(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回子节点的内容
getChildContentLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回子节点的内容.
getChildContentString(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
返回子节点的内容.此方法总是返回一个有效地String, 不会返回null.
getChildContentString(String, String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
返回子节点的内容. 如果子节点的内容为null则返回defaultValue.
getChildContentString(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回子节点的内容.此方法总是返回一个有效地String, 不会返回null.
getChildContentString(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回子节点的内容.
getChildren() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回所有的子节点
getClazz() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的类名
getClazz() - Method in class com.bstek.dorado.view.ViewModelCacheInfo
取得视图模型实现类名称
getClazz() - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
取得校验信息的实现类名
getClientScript() - Method in interface com.bstek.dorado.view.data.validate.Validator
返回此校验器的客户端校验脚本.此函数利用返回值通知外界验证是否成功.
getClientScript() - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
返回此校验器的客户端校验脚本.此函数利用返回值通知外界验证是否成功.

其最终生成的脚本代码的框架如下. function doValidator(validator, value) {
... ... ...
... ... ...
}

注意在定义ClientScript时应直接编写脚本的内容而不要加上函数的声明部分,例如:

return ((min < value) && (value < max));

getClientScript() - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
返回此校验器的客户端校验脚本.此函数利用返回值通知外界验证是否成功.

其最终生成的脚本代码的框架如下. function doValidator(validator, value) {
... ... ...
... ... ...
}

注意在定义ClientScript时应直接编写脚本的内容而不要加上函数的声明部分,例如:

return ((min < value) && (value < max));

getClientScript() - Method in class com.bstek.dorado.view.data.validate.impl.RequiredValidator
返回此校验器的客户端校验脚本.此函数利用返回值通知外界验证是否成功.

其最终生成的脚本代码的框架如下. function doValidator(validator, value) {
... ... ...
... ... ...
}

注意在定义ClientScript时应直接编写脚本的内容而不要加上函数的声明部分,例如:

return ((min < value) && (value < max));

getClientType() - Method in interface com.bstek.dorado.view.ViewModel
返回客户端类型
getClientType() - Method in class com.bstek.dorado.view.ViewModelCacheInfo
getClientType
getClientType() - Method in class com.bstek.dorado.view.ViewModelSupport
返回客户端类型
getCol() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前列的索引值。
getColSpan() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得AutoForm的该元素(Element)的列跨度(colSpan)属性值，该属性类Table的ColSpan属性。
getColSpan() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前元素(Element)的列跨度(colSpan)属性值。
getColumn(int) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
根据索引值取得列(Column)对象。
getColumn(String) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
根据名称取得列(Column)对象。
getColumn(int) - Method in class com.bstek.dorado.view.control.table.Table
根据索引值取得列(Column)对象。
getColumn(String) - Method in class com.bstek.dorado.view.control.table.Table
根据名称取得列(Column)对象。
getColumnCount() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回该Group在页面上显示时每行要显示的列数。
getColumnCount() - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
返回AutoForm中组(Group)内每行放置元素的个数。
getColumnCount() - Method in class com.bstek.dorado.view.control.table.ColumnGroup
取得子列(Column)的个数。
getColumnCount() - Method in class com.bstek.dorado.view.control.table.Table
取得数据表格(DataTable)中列(Column)的个数。
getCommand() - Method in class com.bstek.dorado.view.control.Button
返回与按钮(Button)关联的操作命令(Command)。
getCommand() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项对应的命令对象
getConcreteValidator() - Method in class com.bstek.dorado.view.data.validate.impl.CustomValidator
取得具体的校验器格式
getConditionDataset() - Method in class com.bstek.dorado.view.control.command.QueryCommand
getConditionDatasetInstance() - Method in class com.bstek.dorado.view.control.command.QueryCommand
getConfig() - Method in interface com.bstek.dorado.action.Action
取得对应的ActionConfig
getConfig() - Method in class com.bstek.dorado.action.Controller
取得对应的ControllerConfig对象
getConfig() - Method in interface com.bstek.dorado.module.Module
取得Module的Module配置对象
getConfig() - Method in class com.bstek.dorado.module.ModuleSupport
取得Module的Module配置对象
getConfig() - Method in interface com.bstek.dorado.view.ViewModel
取得视图配置对象
getConfig() - Method in class com.bstek.dorado.view.ViewModelCacheInfo
取得配置名称
getConfig() - Method in class com.bstek.dorado.view.ViewModelSupport
取得视图配置对象
getConfigName() - Method in interface com.bstek.dorado.view.ViewModel
取得视图模型配置名
getConfigName() - Method in class com.bstek.dorado.view.ViewModelSupport
取得视图模型配置名
getConnection(String) - Method in class com.bstek.dorado.common.JDBCTransaction
getConnection(String) - Method in interface com.bstek.dorado.common.Transaction
获取一个与本事务相关的数据连接.
getConnection(String) - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
根据数据源配置的名字返回一个数据连接.
getConnection() - Method in class com.bstek.dorado.common.ds.DataSourceConfig
getConnectionFactory
getConnection() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getConnectionFactory
getConnection() - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
getConnectionFactory
getConnection() - Method in class com.bstek.dorado.common.ds.TransConnection
getContent() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回节点的内容
getContentBoolean() - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型返回节点的内容
getContentBoolean(boolean) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型返回节点的内容. 如果节点的内容为null则返回defaultValue.
getContentBoolean() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回节点的内容
getContentBoolean(boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回节点的内容.
getContentDouble() - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型返回节点的内容
getContentDouble(double) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型返回节点的内容. 如果节点的内容为null则返回defaultValue.
getContentDouble() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回节点的内容
getContentDouble(double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回节点的内容.
getContentFloat() - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型返回节点的内容
getContentFloat(float) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型返回节点的内容. 如果节点的内容为null则返回defaultValue.
getContentFloat() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回节点的内容
getContentFloat(float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回节点的内容.
getContentInt() - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回节点的内容
getContentInt(int) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型返回节点的内容. 如果节点的内容为null则返回defaultValue.
getContentInt() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回节点的内容
getContentInt(int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回节点的内容.
getContentLong() - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型返回节点的内容
getContentLong(long) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型返回节点的内容. 如果节点的内容为null则返回defaultValue.
getContentLong() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回节点的内容
getContentLong(long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回节点的内容.
getContentString() - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
返回节点的内容.此方法总是返回一个有效地String, 不会返回null.
getContentString(String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
返回节点的内容.此方法总是返回一个有效地String. 如果节点的内容为null则返回defaultValue.
getContentString() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回节点的内容.此方法总是返回一个有效地String, 不会返回null.
getContentString(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回节点的内容.此方法总是返回一个有效地String.
getContext() - Static method in class com.bstek.dorado.common.DoradoContext
获取当前线程中的context对象.
getContext(ServletRequest) - Static method in class com.bstek.dorado.common.HttpContextFactory
根据ServletRequest来获取一个DoradoContext
getContext(ServletRequest, boolean) - Static method in class com.bstek.dorado.common.HttpContextFactory
根据ServletRequest来获取一个DoradoContext, 如果目前还没有一个相应的DoradoContext, 系统将根据create参数来决定时候要产生一个.
getContextAttribute() - Method in class com.bstek.dorado.view.data.DODataset
取得与DODataset进行数据交换的上下文属性名.
getControl(String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的Id取得一个控件对象。
getControl(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的Id取得一个控件对象。
getControl() - Method in class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
取得控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.CustomFormElement
取得控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得控件对象。
getControl() - Method in class com.bstek.dorado.view.control.autoform.LabelFormElement
取得控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
取得控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.TextEditorFormElement
取得控件对象。

抽象方法，需要在子类中实现。

getControlAlign() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得AutoForm中Control控件元素的水平位置(controlAlign)属性值。
getControlId() - Method in class com.bstek.dorado.view.control.autoform.CustomFormElement
取得控件(Control)的唯一标识符(Id)。
getControlVAlign() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得AutoForm中Control控件元素的垂直位置(controlVAlign)属性值。
getController() - Method in interface com.bstek.dorado.action.Action
getController
getController(HttpServletRequest, String) - Method in interface com.bstek.dorado.action.ControllerFactory
根据给定名称从指定的资源中查找并返回一个Controller的实例。
getController(HttpServletRequest, String) - Static method in class com.bstek.dorado.action.ControllerManager
根据给定名称从指定的资源中查找并返回一个Controller的实例。
getController() - Method in class com.bstek.dorado.action.mapping.ActionConfig
取得该Action所属的Controller对象
getController(String) - Method in class com.bstek.dorado.action.mapping.Unit
根据别名查找一个Controller的配置信息
getControllerFactory() - Static method in class com.bstek.dorado.action.ControllerManager
获得系统内部使用的Controller工厂。
getControls() - Method in interface com.bstek.dorado.view.ViewModel
取得视图模型所有的控件的集合对象。
getControls() - Method in class com.bstek.dorado.view.ViewModelSupport
取得视图模型所有的控件的集合对象。
getCount() - Method in class com.bstek.dorado.data.FieldSet
取得Field的总数
getCount() - Method in class com.bstek.dorado.utils._MockSynchroTimer
getCountSql() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
取得AutoSqlDataset内部使用的用于统计总记录数的SQL命令。
getCountSql() - Method in class com.bstek.dorado.data.db.SqlDataset
返回统计总记录数的SQL命令。
getCurrent() - Method in interface com.bstek.dorado.data.Dataset
返回当前记录对象。
getCurrent() - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录对象。
getCurrent() - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录对象。
getCurrent() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录对象。
getDO() - Method in class com.bstek.dorado.data.DOSet
以java.util.List的方式返回所有DO.
getDO(int) - Method in class com.bstek.dorado.data.DOSet
以java.util.List的方式返回符合给定状态的DO.
getDO() - Method in class com.bstek.dorado.data.DOWrapper
getDataSource() - Method in class com.bstek.dorado.data.db.DBDataset
返回Dataset对应的数据源名称.
getDataSource() - Method in class com.bstek.dorado.data.db.DBStatement
取得DBStatement使用的数据源的名称.
getDataSourceConfig(String) - Static method in class com.bstek.dorado.common.ds.ConnectionConfigs
getDataSourceConfig
getDataSourceConfigs() - Static method in class com.bstek.dorado.common.ds.ConnectionConfigs
getDataSourceConfigs
getDataType() - Method in class com.bstek.dorado.data.AbstractField
取得字段的数据类型。
getDataType() - Method in interface com.bstek.dorado.data.Field
取得字段的数据类型。
getDataType() - Method in class com.bstek.dorado.data.db.BaseMatchRule
返回匹配值的数据类型.
getDataType() - Method in class com.bstek.dorado.utils.variant.Variant
getDataType
getDataType(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号返回默认数据类型
getDataType(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值返回默认数据类型
getDataType() - Method in class com.bstek.dorado.view.control.TextEditor
取得编辑器的数据类型。
getDataset() - Method in class com.bstek.dorado.data.Index
返回本索引所属的Dataset对象
getDataset() - Method in class com.bstek.dorado.data.Record
取得该记录对象所属的数据集（Dataset）对象。
getDataset() - Method in class com.bstek.dorado.data._DatasetEvent
getDataset(String, boolean) - Method in interface com.bstek.dorado.module.Module
根据指定条件取得Dataset对象
getDataset(String, boolean, ParameterSet) - Method in interface com.bstek.dorado.module.Module
根据指定条件取得Dataset对象
getDataset(String, boolean, int, int, ParameterSet) - Method in interface com.bstek.dorado.module.Module
根据指定条件取得Dataset对象
getDataset(String, boolean) - Method in class com.bstek.dorado.module.ModuleSupport
根据指定条件取得Dataset对象
getDataset(String, boolean, ParameterSet) - Method in class com.bstek.dorado.module.ModuleSupport
根据指定条件取得Dataset对象
getDataset(String, boolean, int, int, ParameterSet) - Method in class com.bstek.dorado.module.ModuleSupport
根据指定条件取得Dataset对象
getDataset(String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的Id取得一个视图数据集对象。
getDataset(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的Id取得一个视图数据集对象。
getDataset() - Method in class com.bstek.dorado.view.control.DataControl
返回数据控件(DataControl)绑定的数据集(Dataset)。
getDataset() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回命令(Command)对象提交的Dataset对象名。
getDataset() - Method in class com.bstek.dorado.view.control.command.RequestCommand
取得请求命令(RequestCommand)提交的Dataset对象。
getDataset() - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
取得提交表单数据集命令(SubmitFormDatasetCommand)对象提交的Dataset。
getDataset() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
返回一个与数据集下拉框(DatasetDropDown)关联的数据集(Dataset)对象。
getDataset() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得为TreeLevel提供数据的数据集(Dataset)。
getDatasetInstance() - Method in class com.bstek.dorado.view.control.DataControl
返回数据控件(DataControl)绑定的数据集(Dataset)实例。
getDatasetInstance() - Method in class com.bstek.dorado.view.control.command.RequestCommand
返回请求命令(RequestCommand)提交的Dataset视图实例。
getDatasetInstance() - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
返回提交表单数据集命令(SubmitFormDatasetCommand)对象提交的一个Dataset的实例。
getDatasetPool(DoradoContext, String) - Method in class com.bstek.dorado.module.ModuleSupport
getDatasets() - Method in interface com.bstek.dorado.view.ViewModel
取得所有的视图数据集的集合对象。
getDatasets() - Method in class com.bstek.dorado.view.ViewModelSupport
取得所有的视图数据集的集合对象。
getDate(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Date型的配置信息
getDate(String, Date) - Static method in class com.bstek.dorado.common.Setting
读取一个Date型的配置信息,如何该配置不存在则返回缺省值.
getDate(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Date型的配置信息
getDate(String, Date) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Date型的配置信息
getDate() - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
获取系统的当前时间 例如: ${Util.getDate()} 或 ${Util.date}
getDate(String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
按指定的日期格式获取系统的当前时间的字符串 例如: ${Util.getDate("yyyy-MM-dd")}
getDate(int) - Method in interface com.bstek.dorado.data.Dataset
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in interface com.bstek.dorado.data.Dataset
按Date类型返回当前记录中某字段的值。
getDate(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按Date类型返回当前记录中某字段的值。
getDate(int) - Method in class com.bstek.dorado.data.DatasetSupport
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.data.DatasetSupport
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.data.ReadRecord
按Date类型返回记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按Date方式读取一个参数
getDate() - Method in class com.bstek.dorado.utils.variant.Variant
按Date类型读取数据
getDate(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按Date类型读取数据
getDate(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按Date类型读取数据
getDate() - Method in class com.bstek.dorado.view.control.Calendar
返回日历默认时间。
getDate(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按Date类型返回当前记录中某字段的值。
getDbCharSet() - Method in class com.bstek.dorado.data.db.DBDataset
取得数据库的字符集编码.
getDefaultConnection() - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
返回一个默认数据连接.
getDefaultControlWidth() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中各个元素统一的缺省宽度值。
getDefaultControlWidth() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得AutoForm中各个控件对象的缺省所占的宽度。
getDefaultDialect() - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
返回默认的数据库方言实现对象.
getDefaultElementMargin() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中每个元素(Element)缺省的空白边缘(Margin)值。
getDefaultFileLoader() - Static method in class com.bstek.dorado.common.fileloader.FileLoaderFactory
getDefaultFileLoader
getDefaultLabelWidth() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm的元素(Element)的标题(Label)的缺省宽度值。
getDefaultLabelWidth() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得AutoForm中的各个元素标题(Label)的缺省宽度值。
getDefaultLocale() - Static method in class com.bstek.dorado.i18n.LocaleHelper
返回Setting.xml中指定的默认的地区与语种.
getDefaultLocale(DoradoContext) - Method in class com.bstek.dorado.i18n.ResourceManager
返回默认的地区与语种.
getDefaultValue() - Method in class com.bstek.dorado.data.AbstractField
取得字段缺省值。
getDefaultValue() - Method in interface com.bstek.dorado.data.Field
取得字段缺省值。
getDeleteSql() - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
取得需要删除记录的SQL命令。
getDescription() - Method in class com.bstek.dorado.action.mapping.ActionConfig
Action的描述信息。
getDescription() - Method in class com.bstek.dorado.action.mapping.ActionTarget
获得描述信息。
getDescription() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的描述信息。
getDescription() - Method in class com.bstek.dorado.action.mapping.Unit
Unit的描述信息。
getDetailDataset() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集
getDetailKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的字段.
getDetailKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
getDetailKeyParameters
getDetailKeyParameters() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的参数.
getDetailLinks() - Method in interface com.bstek.dorado.view.data.ViewDataset
取得所有关联关系的集合对象
getDetailLinks() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得所有关联关系的集合对象
getDetailProperty() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
getDetailRecords(String) - Method in class com.bstek.dorado.data.ReadRecord
getDetailRecords
getDialect(String) - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
根据数据源配置的名字返回数据库方言的实现对象.
getDialect() - Method in class com.bstek.dorado.common.ds.DataSourceConfig
getDialect
getDialect() - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset内部使用的数据库方言的实现类.
getDisableIcon() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项(MenuItem)失效时的链接图标(Icon)URL。
getDouble(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Double型的配置信息
getDouble(String, double) - Static method in class com.bstek.dorado.common.Setting
读取一个Double型的配置信息,如何该配置不存在则返回缺省值.
getDouble(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Double型的配置信息
getDouble(String, double) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Double型的配置信息
getDouble(int) - Method in interface com.bstek.dorado.data.Dataset
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in interface com.bstek.dorado.data.Dataset
按double类型返回当前记录中某字段的值。
getDouble(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型返回当前记录中某字段的值。
getDouble(int) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.data.ReadRecord
按double类型返回记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按double方式读取一个参数
getDouble() - Method in class com.bstek.dorado.utils.variant.Variant
按double类型读取数据
getDouble(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按double类型读取数据
getDouble(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按double类型读取数据
getDouble(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型返回当前记录中某字段的值。
getDownLoadFileName(HttpServletRequest) - Method in class com.bstek.dorado.biz.FileController
取得将要下载的文件的文件名
getDownloadFileInputStream(HttpServletRequest) - Method in class com.bstek.dorado.biz.FileController
取得将要被下载的文件的文件输入流
getDragMode() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)拖动类型。
getDriver() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getDriver
getDropDown() - Method in class com.bstek.dorado.view.control.RadioGroup
取得文本编辑器(TextEditor)相关联的下拉框(DropDown)。
getDropDown() - Method in class com.bstek.dorado.view.control.TextEditor
取得文本编辑器(TextEditor)相关联的下拉框(DropDown)。
getDropDown() - Method in class com.bstek.dorado.view.control.table.EditableColumn
取得与该列(Column)相关的用来显示的下拉框(DropDown)对象。
getDropDown() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得字段关联的下拉框对象(DropDown)。
getDropDown() - Method in interface com.bstek.dorado.view.data.ViewField
取得字段关联的下拉框对象(DropDown)。
getDropDown() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得字段关联的下拉框对象(DropDown)。
getDropDownType() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
取得下拉框的类型
getDropDownType() - Method in class com.bstek.dorado.view.control.dropdown.DropDownViewModel
取得下拉框的类型
getDropDownType() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
getDropDownType
getEditorType() - Method in class com.bstek.dorado.view.control.TextEditor
取得文本编辑器(TextEditor)的编辑器类型(EditorType)。
getEditorType() - Method in class com.bstek.dorado.view.control.table.EditableColumn
取得与列(Column)相关联的被用来显示到页面上的编辑框(Editor)对象的类型。
getEditorType() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得与该字段关联的编辑器的类型。
getEditorType() - Method in interface com.bstek.dorado.view.data.ViewField
取得与该字段关联的编辑器的类型。
getEditorType() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得与该字段关联的编辑器的类型。
getElement(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
根据指定的AutoForm元素(Element)的名称，取得一个FormElement对象。
getElement() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前的元素(Element)对象。
getElementMargin() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得AutoForm中元素各个(Element)缺省的边缘空白(Margin)属性值。
getErrorMessage() - Method in interface com.bstek.dorado.view.data.validate.Validator
返回一个错误信息(ErrorMessage)。
getErrorMessage() - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
返回一个错误信息(ErrorMessage)。
getErrorMessage() - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
返回一个对应的ErrorMessage。
getEscapeValue() - Method in class com.bstek.dorado.data.db.CommonMatchRule
取得逃逸值.
getEvent(String, String) - Static method in class com.bstek.dorado.view.EventConfig
根据控件名和事件名取得一个事件定义的描述对象
getEventHandler(String) - Method in interface com.bstek.dorado.view.Component
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in interface com.bstek.dorado.view.EventSupported
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.control.AbstractControl
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.control.table.EditableColumnGroup
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
getEventHandler
getEventHandler(String) - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
根据指定名称取得一个事件处理对象。
getEvents() - Method in class com.bstek.dorado.data._MockDatasetListener
getEvents() - Method in class com.bstek.dorado.data._MockRecordListener
getException(Throwable) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的异常得到一个ActionException子对象
getException(int) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的索引号得到一个ActionException子对象
getException(ObjectCollection, Throwable) - Static method in class com.bstek.dorado.action.mapping.ActionExceptionUtil
根据一个异常对象在一组ActionExcpetion中查找一个匹配的对象
getException(Throwable) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的异常得到一个ActionException子对象
getException(int) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的索引号得到一个ActionException子对象
getException(Throwable) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的异常得到一个ActionException子对象
getException(int) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的索引号得到一个ActionException子对象
getExceptionCount() - Method in class com.bstek.dorado.action.mapping.ActionConfig
返回ActionException的个数
getExceptionCount() - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
返回ActionException的个数
getExceptionCount() - Method in class com.bstek.dorado.action.mapping.Unit
返回ActionException的个数
getExceptionHandler() - Static method in class com.bstek.dorado.action.ActionHandler
获得系统内部使用的ActionException处理器的工厂。
getExpandLevel() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回树默认展开到的层次
getExpandLevel() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回树默认展开到的层次
getExpandedIcon() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点(TreeNode)的展开图标文件(ExpandedIcon)。
getExpandedIcon() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得TreeLevel的展开时的图标文件(ExpandedIcon)的URL。
getExpandedIconField() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得TreeLevel的展开图标字段标题(ExpandedIconField)从数据集的哪个字段获取信息。
getField(int) - Method in interface com.bstek.dorado.data.Dataset
根据Field索引号取得一个Field对象。
getField(String) - Method in interface com.bstek.dorado.data.Dataset
根据Field名称取得一个Field对象。
getField(int) - Method in class com.bstek.dorado.data.DatasetAdapter
根据Field索引号取得一个Field对象。
getField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
根据Field名称取得一个Field对象。
getField(int) - Method in class com.bstek.dorado.data.DatasetSupport
根据Field索引号取得一个Field对象。
getField(String) - Method in class com.bstek.dorado.data.DatasetSupport
根据Field名称取得一个Field对象。
getField(int) - Method in class com.bstek.dorado.data.FieldSet
根据Field索引号取得一个Field对象
getField(String) - Method in class com.bstek.dorado.data.FieldSet
根据Field名称取得一个Field对象
getField() - Method in class com.bstek.dorado.view.control.SimpleDataControl
返回Field名称。
getField() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得与该元素相关的数据来源Dataset中对应的字段(Field)。
getField() - Method in class com.bstek.dorado.view.control.table.DataColumn
取得表格列(Column)的数据来自于数据集的哪个字段(Field)。
getField(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据Field索引号取得一个Field对象。
getField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据Field名称取得一个Field对象。
getFieldCount() - Method in interface com.bstek.dorado.data.Dataset
取得Field的总数。
getFieldCount() - Method in class com.bstek.dorado.data.DatasetAdapter
取得Field的总数。
getFieldCount() - Method in class com.bstek.dorado.data.DatasetSupport
取得Field的总数。
getFieldCount() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得Field的总数。
getFieldFactory() - Method in class com.bstek.dorado.data.DatasetSupport
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.data.custom.CustomDataset
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.data.db.SqlDataset
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回Field的创建工厂.
getFieldInstance() - Method in class com.bstek.dorado.view.control.SimpleDataControl
取得一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。
getFieldLabel() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得与该元素(Element)对应的数据源(Dataset)中字段(Field)的标题。
getFieldName() - Method in class com.bstek.dorado.data._DatasetEvent
getFieldName() - Method in class com.bstek.dorado.data._RecordEvent
getFieldSet() - Method in class com.bstek.dorado.data.Record
取得该记录的所有字段的集合对象。
getFields() - Method in class com.bstek.dorado.data.Index
返回本索引对应的字段
getFilePath() - Method in class com.bstek.dorado.common.fileloader.FileLoader
文件位置的描述。
getFilterParameter() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回用于作为筛选参数的Dataset参数名.
getFinalErrorMessage() - Method in interface com.bstek.dorado.view.data.validate.Validator
返回一个最终的错误信息(FinalErrorMessage)。
getFinalErrorMessage() - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
返回一个最终的错误信息(FinalErrorMessage)。
getFirst() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的第一条记录
getFirstWrapper() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的第一条记录的包装器.
getFixedColumn() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格(DataTable)中被锁定列的个数
getFloat(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Float型的配置信息
getFloat(String, float) - Static method in class com.bstek.dorado.common.Setting
读取一个Float型的配置信息,如何该配置不存在则返回缺省值.
getFloat(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Float型的配置信息
getFloat(String, float) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Float型的配置信息
getFloat(int) - Method in interface com.bstek.dorado.data.Dataset
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in interface com.bstek.dorado.data.Dataset
按float类型返回当前记录中某字段的值。
getFloat(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型返回当前记录中某字段的值。
getFloat(int) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.data.ReadRecord
按float类型返回记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按float方式读取一个参数
getFloat() - Method in class com.bstek.dorado.utils.variant.Variant
按float类型读取数据
getFloat(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按float类型读取数据
getFloat(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按float类型读取数据
getFloat(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型返回当前记录中某字段的值。
getFooterHeight() - Method in class com.bstek.dorado.view.control.table.Table
返回合计栏位的高度
getFooterValue() - Method in class com.bstek.dorado.view.control.table.DataColumn
getFooterValue
getFormat() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得该字断相关的格式化串。
getFormat() - Method in interface com.bstek.dorado.view.data.ViewField
取得该字断相关的格式化串。
getFormat() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得该字断相关的格式化串。
getForward(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的别名得到一个ActionForward子对象
getForward(int) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的索引号得到一个ActionForward子对象
getForward(String) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的别名得到一个ActionForward子对象
getForward(int) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的索引号得到一个ActionForward子对象
getForward(String) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的别名得到一个ActionForward子对象
getForward(int) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的索引号得到一个ActionForward子对象
getForwardCount() - Method in class com.bstek.dorado.action.mapping.ActionConfig
返回ActionForward的个数
getForwardCount() - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
返回ActionForward的个数
getForwardCount() - Method in class com.bstek.dorado.action.mapping.Unit
返回ActionForward的个数
getForwardHandler() - Static method in class com.bstek.dorado.action.ActionHandler
获得系统内部使用的ActionForward处理器的工厂。
getFrame() - Method in class com.bstek.dorado.view.control.command.RequestCommand
构造器
getGlobalUnit() - Method in class com.bstek.dorado.action.mapping.Mapping
取得global配置单元对象
getGroup() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得AutoForm中的元素(Element)所属的组(Group)。
getHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
getHandler
getHeaderHeight() - Method in class com.bstek.dorado.view.control.table.Table
返回表格列标题高度
getHeight() - Method in interface com.bstek.dorado.view.control.Placeable
getHeight
getHeight() - Method in class com.bstek.dorado.view.control.PlaceableControl
getHeight
getHeight() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
getHeight
getHeight() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm的高度。
getHeight() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得组(Group)的高度值。
getHeight() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架中新页面的高度(Height)值。
getHeight() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
getHeight
getHeight() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得多页标签(Tab)的高度(Height)。
getHoldability() - Method in class com.bstek.dorado.common.ds.TransConnection
getIcon() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项(MenuItem)链接图标(Icon)URL。
getIcon() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点(TreeNode)的图标文件(Icon)。
getIcon() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得TreeLevel的图标文件(Icon)的URL。
getIconField() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得TreeLevel的图标的字段标题(IconField)。
getId() - Method in class com.bstek.dorado.common.DoradoProcess
getId
getId() - Method in interface com.bstek.dorado.data.Dataset
获得Dataset的ID
getId() - Method in class com.bstek.dorado.data.DatasetAdapter
获得Dataset的ID
getId() - Method in class com.bstek.dorado.data.DatasetSupport
获得Dataset的ID
getId() - Method in interface com.bstek.dorado.view.Component
取得组件的Id。
getId() - Method in class com.bstek.dorado.view.control.AbstractControl
取得组件的Id。
getIndex(String) - Method in interface com.bstek.dorado.data.Dataset
根据指定的字段返回一个Dataset的索引对象。
getIndex(String[]) - Method in interface com.bstek.dorado.data.Dataset
根据指定的一组字段返回一个Dataset的索引对象。
getIndex(String) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String[]) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String[]) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String[]) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getInputStream() - Method in class com.bstek.dorado.common.fileloader.FileLoader
获取文件的输入流
getInputStream() - Method in class com.bstek.dorado.common.fileloader.PathFileLoader
获取文件的输入流
getInputStream() - Method in class com.bstek.dorado.common.fileloader.ResourceFileLoader
获取文件的输入流
getInsertSql() - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
取得需要插入记录的SQL命令
getInstance() - Static method in class com.bstek.dorado.action.mapping.Mapping
取得单例对象
getInstance() - Static method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
获得单例对象
getInstance() - Static method in class com.bstek.dorado.i18n.ResourceManager
获得单例对象
getInstance(ViewModel) - Static method in class com.bstek.dorado.view.ViewModelCacheInfo
取得视图模型缓存信息
getInt(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Int型的配置信息
getInt(String, int) - Static method in class com.bstek.dorado.common.Setting
读取一个Int型的配置信息,如何该配置不存在则返回缺省值.
getInt(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Int型的配置信息
getInt(String, int) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Int型的配置信息
getInt(int) - Method in interface com.bstek.dorado.data.Dataset
按int类型返回当前记录中某字段的值。
getInt(String) - Method in interface com.bstek.dorado.data.Dataset
按int类型返回当前记录中某字段的值。
getInt(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型返回当前记录中某字段的值。
getInt(int) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.data.ReadRecord
按int类型返回记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按int方式读取一个参数
getInt() - Method in class com.bstek.dorado.utils.variant.Variant
按int类型读取数据
getInt(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按int类型读取数据
getInt(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按int类型读取数据
getInt(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型返回当前记录中某字段的值。
getInterval() - Method in class com.bstek.dorado.utils.SynchroTimer
定时器触发间隔时间
getItem(String) - Method in class com.bstek.dorado.view.control.Menu
根据名称取得一个子菜单项
getItem(String) - Method in class com.bstek.dorado.view.control.MenuItem
根据名称取得一个子菜单项
getItem(String) - Method in interface com.bstek.dorado.view.control.MenuItemContainer
根据名称取得一个子菜单项
getItem(int) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定的索引值取得静态下拉框(ListDropDown)的DropDownItem对象。
getJndiName() - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
getJndiName
getKey() - Static method in class com.bstek.dorado.utils.UniqueKey
返回一个新的VM唯一标识。
getKey(int) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回给定的索引号对应的键值。
getKey(int) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回给定的索引号对应的键值。
getKeyFields() - Method in class com.bstek.dorado.data.LookupField
Dataset与LookupDataset之间的字段匹配关系。
getKeyFields() - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset的主表的主键字段。
getKeyFields() - Method in class com.bstek.dorado.data.db.JoinTable
取得用于建立关联的关联表中的字段.
getKeyFields() - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
取得需要更新的表的主键字段，以数组形式返回。
getKind() - Method in class com.bstek.dorado.data.db.AndOrMatchRule
获得该逻辑连接符的类型.
getLabel() - Method in class com.bstek.dorado.data.AbstractField
取得字段列的标题。
getLabel() - Method in interface com.bstek.dorado.data.Field
取得字段列的标题。
getLabel() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项(MenuItem)标题。
getLabel() - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
取得下拉框(DropDown)对应的字段(Field)的标题(Label)。
getLabel() - Method in class com.bstek.dorado.view.control.table.Column
取得列(Column)的标题(Label)。
getLabel() - Method in class com.bstek.dorado.view.control.tabset.TabElement
取得多页标签(Tab)的标题(Label)。
getLabel() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点(TreeNode)的标题(Label)。
getLabelAlign() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得该元素对应的数据源Dataset中字段(Field)的标题(Label)的水平位置(labelAlign)属性值。
getLabelField() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
getLabelField
getLabelField() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得TreeLevel对应的数据集(Dataset)的字段(LabelField)。
getLabelVAlign() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得与该元素对应的数据源Dataset中字段(Field)的标题(Label)的垂直位置(labelVAlign)属性值。
getLast() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的最后一条记录
getLastModified() - Method in class com.bstek.dorado.common.fileloader.FileLoader
获取文件的最后修改日期
getLastModified() - Method in class com.bstek.dorado.common.fileloader.PathFileLoader
获取文件的最后修改日期
getLastModified() - Method in class com.bstek.dorado.common.fileloader.ResourceFileLoader
获取文件的最后修改日期
getLastWrapper() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的最后一条记录的包装器.
getLayout() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中元素的布局。
getLayoutInfos() - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
getLayoutInfos
getLeft() - Method in interface com.bstek.dorado.view.control.Placeable
getLeft
getLeft() - Method in class com.bstek.dorado.view.control.PlaceableControl
getLeft
getLeft() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
getLeft
getLeft() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架中新页面左边缘(Left)值。
getLevel() - Static method in class com.bstek.dorado.common.log.Log
返回日志记录器的日志级别。
getLevel() - Method in interface com.bstek.dorado.common.log.Logger
返回日志记录器的日志级别。
getLevel() - Method in class com.bstek.dorado.data.db.AndOrMatchRule
取得该规则对象的级数.
getLevel() - Method in class com.bstek.dorado.data.db.CommonMatchRule
取得该规则对象的级数.
getLevel() - Method in interface com.bstek.dorado.data.db.MatchRule
取得该规则对象的级数.
getLevel(int) - Method in class com.bstek.dorado.view.control.tree.DataTree
根据索引值取得树(Tree)的节点的层数(Level)。
getLevel() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点(TreeNode)的层数(Level)。
getLoadDataAction() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
getLoadDataAction() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
getLoadDataHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
getLoadDataHandler
getLocale(String, String) - Static method in class com.bstek.dorado.i18n.LocaleHelper
返回给定参数所表示的地区与语种.
getLogicCharSet() - Method in class com.bstek.dorado.data.db.DBDataset
取得逻辑代码中使用的字符集编码.
getLoginTimeout() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getLoginTimeout
getLong(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Long型的配置信息
getLong(String, long) - Static method in class com.bstek.dorado.common.Setting
读取一个Long型的配置信息,如何该配置不存在则返回缺省值.
getLong(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Long型的配置信息
getLong(String, long) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Long型的配置信息
getLong(int) - Method in interface com.bstek.dorado.data.Dataset
按long类型返回当前记录中某字段的值。
getLong(String) - Method in interface com.bstek.dorado.data.Dataset
按long类型返回当前记录中某字段的值。
getLong(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型返回当前记录中某字段的值。
getLong(int) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.data.ReadRecord
按long类型返回记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按long方式读取一个参数
getLong() - Method in class com.bstek.dorado.utils.variant.Variant
按long类型读取数据
getLong(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按long类型读取数据
getLong(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按long类型读取数据
getLong(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型返回当前记录中某字段的值。
getLookupDataset() - Method in class com.bstek.dorado.data.LookupField
作为Lookup数据来源的Dataset对象。
getLookupField() - Method in class com.bstek.dorado.data.LookupField
LookupDataset中将被作为数据返回的字段的名称。
getLookupKeyFields() - Method in class com.bstek.dorado.data.LookupField
Dataset与LookupDataset之间的字段匹配关系。
getMasterDataset() - Method in class com.bstek.dorado.view.data.MasterDetailLink
返回主记录集
getMasterKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
getMasterKeyFields
getMasterKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得主数据集中与从数据集关联的字段.
getMasterLink() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
getMasterLink() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
getMax() - Method in class com.bstek.dorado.view.control.ProgressBar
获得进度条可取最大值。
getMax() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)可滚动的最大值。
getMax() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得范围最大值
getMaxActive() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getMaxActive
getMaxIdle() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getMaxIdle
getMaxLength() - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
返回最大长度值。
getMaxLink() - Method in class com.bstek.dorado.view.control.PagePilot
取得页码导航条(PagePilot)最大连续可见页数。
getMaxMatchRule() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得最大值匹配规则
getMaxPropertyLevel() - Method in interface com.bstek.dorado.data.Dataset
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
getMaxPropertyLevel() - Method in class com.bstek.dorado.data.DatasetAdapter
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
getMaxPropertyLevel() - Method in class com.bstek.dorado.data.DatasetSupport
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
getMaxRow() - Method in class com.bstek.dorado.view.control.table.DataTable
取得数据表格(DataTable)能够显示的最大记录条数。
getMaxTotal() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getMaxTotal
getMaxWait() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getMaxWait
getMenu() - Method in class com.bstek.dorado.view.control.Button
取得与按钮(Button)绑定的菜单(Menu)。
getMenu() - Method in class com.bstek.dorado.view.control.MenuBar
取得菜单栏(MenuBar)绑定的菜单(Menu)对象。
getMenu() - Method in class com.bstek.dorado.view.control.OutlookBar
取得菜单栏(MenuBar)绑定的菜单(Menu)对象。
getMessage(ServletRequest) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条无键值消息.
getMessage(ServletRequest, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条在指定键值中消息.
getMessage(DoradoContext) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条无键值消息.
getMessage(DoradoContext, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条在指定键值中消息.
getMessage() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得本次远程调用将要返回给客户端的提示信息.
getMessage() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得本次远程调用将要返回给客户端的提示信息.
getMessages(ServletRequest) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有无键值消息
getMessages(ServletRequest, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有指定键值中消息
getMessages(DoradoContext) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有无键值消息
getMessages(DoradoContext, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有指定键值中消息
getMetaData() - Method in class com.bstek.dorado.common.ds.TransConnection
getMethod() - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的方法(Method)值。
getMethod() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
返回执行此Command时在ViewModel的实现类中触发的方法名.
getMethod() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
取得本次数据更新操作将要调用的ViewModel中的方法名.
getMin() - Method in class com.bstek.dorado.view.control.ProgressBar
获得进度条可取最小值。
getMin() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)可滚动的最小值。
getMin() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得最小值
getMinEvictableIdleTimeMillis() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getMinEvictableIdleTimeMillis
getMinIdle() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getMinIdle
getMinLength() - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
取得最小长度值。
getMinMatchRule() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得最小值匹配规则
getModifySql() - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
取得需要更新表的SQL命令。
getModule(String) - Static method in class com.bstek.dorado.module.ModuleManager
根据给定的名称取得Module对象的实例.
getModule(ModuleConfig) - Static method in class com.bstek.dorado.module.ModuleManager
根据给定的配置对象取得Module对象
getModuleConfig(String) - Static method in class com.bstek.dorado.module.ModuleManager
根据Module的名字取得配置对象
getModuleFactory() - Method in class com.bstek.dorado.module.PoolableModuleFactory
getModuleFactory
getModulePool() - Static method in class com.bstek.dorado.module.ModuleManager
取得Module的缓冲池
getName() - Method in interface com.bstek.dorado.action.Action
取得Action的别名
getName() - Method in class com.bstek.dorado.action.Controller
取得Controller的别名。
getName() - Method in class com.bstek.dorado.action.mapping.ActionConfig
Action的别名
getName() - Method in class com.bstek.dorado.action.mapping.ActionForward
此对象的别名
getName() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的别名
getName() - Method in class com.bstek.dorado.action.mapping.Unit
取得配置单元的名称
getName() - Method in class com.bstek.dorado.common.ds.DataSourceConfig
返回数据源的名称
getName() - Method in class com.bstek.dorado.common.ds.TransConnection
getName() - Method in class com.bstek.dorado.data.AbstractField
取得字段的名称。
getName() - Method in interface com.bstek.dorado.data.Field
取得字段的名称。
getName() - Method in class com.bstek.dorado.data._DatasetEvent
getName() - Method in class com.bstek.dorado.data._RecordEvent
getName() - Method in class com.bstek.dorado.data.db.JoinTable
取得关联表的别名.
getName() - Method in interface com.bstek.dorado.module.Module
取得Module的名称
getName() - Method in class com.bstek.dorado.module.ModuleSupport
取得Module的名称
getName() - Method in interface com.bstek.dorado.utils.xml.XmlNode
节点名称
getName() - Method in class com.bstek.dorado.view.Event
取得事件名
getName() - Method in class com.bstek.dorado.view.EventHandler
取得事件名
getName() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项(MenuItem)名称。
getName() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得AutoForm中的元素(Element)的名称(Name)属性。
getName() - Method in class com.bstek.dorado.view.control.table.Column
取得列(Column)名。
getName() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回多页标签(Tab)的名称(Name)。
getNamespace() - Method in interface com.bstek.dorado.view.ViewModel
取得视图配置命名空间
getNamespace() - Method in class com.bstek.dorado.view.ViewModelCacheInfo
getNamespace
getNamespace() - Method in class com.bstek.dorado.view.ViewModelSupport
getNamespace
getNewInstanceId() - Static method in class com.bstek.dorado.view.ViewModelManager
getNewInstanceId
getNext() - Method in class com.bstek.dorado.data.RecordWrapper
取得下一个记录包装器
getNodeById(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
根据ID返回一个节点，如果无法找到匹配的节点则返回null。
getNodeByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
根据XPath返回第一个匹配的节点。
getNodeByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
根据XPath返回第一个匹配的节点。
getNodesByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
根据XPath返回所有匹配的节点。
getNodesByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
根据XPath返回所有匹配的节点。
getObjectClazz() - Method in interface com.bstek.dorado.data.Dataset
返回相关的对象类型的Class名.
getObjectClazz() - Method in class com.bstek.dorado.data.DatasetAdapter
返回相关的对象类型的Class名.
getObjectClazz() - Method in class com.bstek.dorado.data.DatasetSupport
返回相关的对象类型的Class名.
getOffValue() - Method in class com.bstek.dorado.view.control.CheckBox
取得复选框(CheckBox)没有选中时表示的值。
getOldDO(Object) - Method in class com.bstek.dorado.data.DOSet
根据给定的DO取得与其相关的保存其修改之前的数据的DO.
getOldRecord(Record) - Method in interface com.bstek.dorado.data.Dataset
返回用于保存某记录的原始值的记录对象。
getOldRecord(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
返回用于保存某记录的原始值的记录对象。
getOldRecord(Record) - Method in class com.bstek.dorado.data.DatasetSupport
返回用于保存某记录的原始值的记录对象。
getOldRecord(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回用于保存某记录的原始值的记录对象。
getOnValue() - Method in class com.bstek.dorado.view.control.CheckBox
取得复选框(CheckBox)选中时表示的值。
getOperator() - Method in class com.bstek.dorado.data.db.BaseMatchRule
取得比较操作符。
getOrientation() - Method in class com.bstek.dorado.view.control.ProgressBar
获得进度条对象(ProgressBar)的类型。
getOrientation() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)类型。
getOrientation() - Method in class com.bstek.dorado.view.control.SplitPanel
返回分割栏(SplitPanel)类型。
getOriginField() - Method in class com.bstek.dorado.data.db.BaseMatchRule
返回匹配规则的原始字段。
getOriginField() - Method in class com.bstek.dorado.data.db.DBField
返回该字段来自于哪个数据库物理字段。
getOriginField() - Method in class com.bstek.dorado.data.db.SortRule
返回该排序规则对应的字段名.
getOriginTable() - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset的主表的物理表名.
getOriginTable() - Method in class com.bstek.dorado.data.db.JoinTable
取得关联表的物理表名.
getOutputContentType(HttpServletRequest) - Method in class com.bstek.dorado.biz.FileController
返回向Response输出时使用的ContentType
getOutputStream() - Method in class com.bstek.dorado.common.fileloader.FileLoader
获取文件的输出流.
getOutputStream() - Method in class com.bstek.dorado.common.fileloader.PathFileLoader
获取文件的输出流.

注意:某些FileLoader可能不支持!

getOutputStream() - Method in class com.bstek.dorado.common.fileloader.ResourceFileLoader
获取文件的输出流.

注意:某些FileLoader可能不支持!

getOutputStream(HttpServletRequest, HttpServletResponse) - Static method in class com.bstek.dorado.utils.http.ResponseUtil
getOutputStream
getOutputter(RPCHandler, String) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
getOutputter
getPadding() - Method in class com.bstek.dorado.view.control.SplitPanel
返回分割栏(SplitPanel)宽度(Padding)设置。
getPageCount() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset所对应的数据共有几页。
getPageCount() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset所对应的数据共有几页。
getPageCount() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset所对应的数据共有几页。
getPageCount() - Method in class com.bstek.dorado.data.RecordSet
返回整个结果集可能包含的页数.
getPageCount() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset所对应的数据共有几页。
getPageIndex() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset的当前行所处的页号
getPageIndex() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset的当前行所处的页号
getPageIndex() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset的当前行所处的页号
getPageIndex() - Method in class com.bstek.dorado.data.RecordSet
返回当前RecordSet对象中管理的Record在整个结果集中所处的页号.
getPageIndex() - Method in class com.bstek.dorado.data.RecordWrapper
取得当前管理的Record在整个结果集中所处的页号.
getPageIndex() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset的当前行所处的页号
getPageSize() - Method in interface com.bstek.dorado.data.Dataset
每页的行数。
getPageSize() - Method in class com.bstek.dorado.data.DatasetAdapter
每页的行数。Dataset按照多少行数对数据进行分页。
getPageSize() - Method in class com.bstek.dorado.data.DatasetSupport
每页的行数。Dataset按照多少行数对数据进行分页。
getPageSize() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)的分页信息。
getPageSize() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
每页的行数。Dataset按照多少行数对数据进行分页。
getParamFields() - Method in class com.bstek.dorado.view.control.command.RequestCommand
取得请求命令(RequestCommand)提交Dataset的参数域。
getParameter(String) - Method in class com.bstek.dorado.common.DoradoContext
从上下文中获取一个参数的值.
getParameter(String) - Method in class com.bstek.dorado.common.DynaDoradoContext
getParameter(String) - Method in class com.bstek.dorado.common.HttpDoradoContext
从上下文中获取一个参数的值.
对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Parameter).
getParameter(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
getParameter
getParameters(String) - Method in class com.bstek.dorado.common.DoradoContext
从上下文中获取一个参数的值数组.
getParameters(String) - Method in class com.bstek.dorado.common.DynaDoradoContext
getParameters(String) - Method in class com.bstek.dorado.common.HttpDoradoContext
从上下文中获取一个参数的值数组.
getParameters() - Method in class com.bstek.dorado.view.Event
取得事件参数描述
getParent() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回父节点
getParsedProperty() - Method in class com.bstek.dorado.data.AbstractField
以数组方式表现的嵌套对象属性.

例如: 设置属性名为"user.address.zipCode", 那么此方法将返回如下的数组:

{"user", "address", "zipCode"}

getParsedProperty() - Method in interface com.bstek.dorado.data.Field
以数组方式表现的嵌套对象属性.
getPassword() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getPassword
getPassword() - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
getPassword
getPath() - Method in class com.bstek.dorado.action.mapping.ActionTarget
跳转目标的路径
getPath() - Method in class com.bstek.dorado.view.control.MenuItem
取得单击菜单项(MenuItem)时要打开的URL路径。
getPath() - Method in class com.bstek.dorado.view.control.command.RequestCommand
getPath() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
取得自定义下拉框中要显示的视图的路径
getPath() - Method in class com.bstek.dorado.view.control.tabset.FrameTab
取得多页标签(Tab)切换时需要跳转的URL路径。
getPath() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得树结点对应的路径
getPathField() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
getPathField
getPattern() - Method in class com.bstek.dorado.view.control.table.StaticColumn
取得静态列的模式
getPilotType() - Method in class com.bstek.dorado.view.control.PagePilot
取得分页导航对象的类型，可取值为"link","button"。
getPool() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
{@inheritDoc}
getPopupContainer() - Method in class com.bstek.dorado.view.control.Menu
取得弹出式菜单(Menu)的容器(PopupContainer)的ID。
getPosition() - Method in class com.bstek.dorado.view.control.ProgressBar
返回进度信息。
getPosition() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)默认位置。
getPosition() - Method in class com.bstek.dorado.view.control.SplitPanel
设定分割栏(SplitPanel)的默认位置。
getPossibleCount() - Method in class com.bstek.dorado.data.RecordSet
返回整个结果集可能包含的记录数.
getPossibleRecordCount() - Method in interface com.bstek.dorado.data.Dataset
获取Dataset可能存在的总记录数。。
getPossibleRecordCount() - Method in class com.bstek.dorado.data.DatasetAdapter
获取Dataset可能存在的总记录数。。
getPossibleRecordCount() - Method in class com.bstek.dorado.data.DatasetSupport
获取Dataset可能存在的总记录数。。
getPrefix() - Method in class com.bstek.dorado.action.mapping.Unit
取得配置单元的URL前缀
getPrev() - Method in class com.bstek.dorado.data.RecordWrapper
取得上一个记录包装器
getPrevAction() - Method in interface com.bstek.dorado.action.Action
返回在本次请求中上一个被处理的Action对象
getProcess(DoradoContext, boolean) - Static method in class com.bstek.dorado.common.ProcessManager
getProcess
getProductType() - Static method in class com.bstek.dorado.Constants
getProductType
getProperties() - Method in class com.bstek.dorado.common.ds.DataSourceConfig
返回DataSource的属性集合对象
getProperty() - Method in class com.bstek.dorado.data.AbstractField
返回该字段对应的属性名.

即Bean的属性名或Map的键名.

此处可用"user.address.zipCode"这种方式来表示子对象的属性.

getProperty() - Method in interface com.bstek.dorado.data.Field
返回该字段对应的属性名.
getProperty(String) - Method in class com.bstek.dorado.utils.SystemVariable
读取系统环境变量。
getQueryDataset() - Method in class com.bstek.dorado.view.control.command.QueryCommand
getQueryDatasetInstance() - Method in class com.bstek.dorado.view.control.command.QueryCommand
getQueryMode() - Method in class com.bstek.dorado.view.control.command.QueryCommand
getReadFields() - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
取得高级下拉框(AdvanceDropDown)为目的数据集字段(WriteFields)赋值的源数据集字段(ReadFields)信息。
getReadFields() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
取得高级下拉框(AdvanceDropDown)为目的数据集字段(WriteFields)赋值的源数据集字段(ReadFields)信息。
getRealPath() - Method in class com.bstek.dorado.action.mapping.ActionTarget
返回真正可利用的Path。
getRealPath() - Method in class com.bstek.dorado.common.fileloader.FileLoader
取得文件的实际位置。
getRealPath() - Method in class com.bstek.dorado.common.fileloader.PathFileLoader
取得文件的实际位置。
getRealPath() - Method in class com.bstek.dorado.common.fileloader.ResourceFileLoader
取得文件的实际位置。
getRecord() - Method in class com.bstek.dorado.data.RecordWrapper
取得被包装的记录
getRecord() - Method in class com.bstek.dorado.data._DatasetEvent
getRecord() - Method in class com.bstek.dorado.data._RecordEvent
getRecord() - Method in class com.bstek.dorado.view.control.tree.RecordTreeNode
返回树节点(RecordTreeNode)绑定的记录对象。
getRecordFactory() - Method in class com.bstek.dorado.data.DatasetSupport
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.data.custom.CustomDataset
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.data.db.DBDataset
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回Record的创建工厂.
getRecordFilter() - Method in interface com.bstek.dorado.data.Dataset
获得Dataset内部使用的记录过滤器.
getRecordFilter() - Method in class com.bstek.dorado.data.DatasetAdapter
获得Dataset内部使用的记录过滤器.
getRecordFilter() - Method in class com.bstek.dorado.data.DatasetSupport
获得Dataset内部使用的记录过滤器.
getRecordId() - Method in class com.bstek.dorado.data.Record
取得当前记录的id.
getRecordSet() - Method in class com.bstek.dorado.data.Record
取得Dataset记录的集合对象。
getRecordState() - Method in interface com.bstek.dorado.data.Dataset
返回当前记录的状态
getRecordState() - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录的状态
getRecordState() - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录的状态
getRecordState() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录的状态
getRecursiveKeyFields() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回RecursiveKey字段,一般应用与父子递归表: RecursiveKeyFields表示将要从当前节点相关字段取出的值; RecursiveKeyParameters表示将要被判断的参数名称; 运行时，系统自动从按照RecursiveKeyFields的设置取出相关值，并通过RecursiveKeyParameters设置相关参数的值， 对绑定的记录集重新发出数据请求，并生成新的树节点。
getRecursiveKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回RecursiveKey字段,多个字段用逗号(",")隔开，一般应用与父子递归表: RecursiveKeyFields表示将要从当前节点相关字段取出的值; RecursiveKeyParameters表示将要被判断的参数名称; 运行时，系统自动从按照RecursiveKeyFields的设置取出相关值，并通过RecursiveKeyParameters设置相关参数的值， 对绑定的记录集重新发出数据请求，并生成新的树节点。
getRecursiveKeyParameters() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回RecursiveKey参数,应用与父子递归表
getRecursiveKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回RecursiveKey参数,多个参数用逗号(",")隔开，一般应用与父子递归表。
getRendererType() - Method in class com.bstek.dorado.view.control.table.EditableColumn
getRendererType
getRequeryPath() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得客户端收到调用完成指令后要重新请求的路径.(这是一个由dorado使用的内部方法)
getRequeryPath() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得客户端收到调用完成指令后要重新请求的路径.
getRequest() - Method in class com.bstek.dorado.common.HttpDoradoContext
被封装的HttpServletRequest对象
getRequest() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得当前的HttpServletRequest对象.
getRequest() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得当前的HttpServletRequest对象.
getRetrieveSql() - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
getRetrieveSql
getReturnRecords() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
取得本次数据更新操作完成后将要返回给客户端的记录的集合.
getRole() - Method in interface com.bstek.dorado.view.ViewModel
取得与视图模型相关的角色.
getRole() - Method in class com.bstek.dorado.view.ViewModelSupport
取得与视图模型相关的角色.
getRoot() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
取得树(Tree)的根节点(Root)对象。
getRoot() - Method in class com.bstek.dorado.view.control.tree.Tree
取得树(Tree)的根节点(Root)对象。
getRootNode() - Method in interface com.bstek.dorado.utils.xml.XmlDocument
获得根节点
getRow() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前行的索引值。
getRowCount() - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
getRowCount
getRowHeight() - Method in class com.bstek.dorado.view.control.table.Table
返回表格数据行的高度
getRowSpan() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得AutoForm的该元素(Element)的行跨度(rowSpan)属性值，该属性类Table的RowSpan属性。
getRowSpan() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前元素(Element)的行跨度(rolSpan)属性值。
getScope() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Model的作用域范围
getScript() - Method in class com.bstek.dorado.view.EventHandler
取得事件脚本
getScrollMode() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格(DataTable)垂直滚动条的滚动方式:
sample:默认像素定位，同时系统提示信息为像素位置提示
record:按记录定位，同时系统提示信息为记录位置提示
getShort(int) - Method in interface com.bstek.dorado.data.Dataset
按short类型返回当前记录中某字段的值。
getShort(String) - Method in interface com.bstek.dorado.data.Dataset
按short类型返回当前记录中某字段的值。
getShort(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型返回当前记录中某字段的值。
getShort(int) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.data.ReadRecord
按short类型返回记录中某字段的值。
getShort() - Method in class com.bstek.dorado.utils.variant.Variant
按short类型读取数据
getShort(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按short类型读取数据
getShort(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按short类型读取数据
getShort(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型返回当前记录中某字段的值。
getShowDraggingTip() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动栏(ScrollBar)拖动时是否显示系统提示信息。
getSkin() - Method in interface com.bstek.dorado.view.ViewModel
返回视图模型使用的皮肤
getSkin() - Method in class com.bstek.dorado.view.ViewModelSupport
返回视图模型使用的皮肤
getSmallChange() - Method in class com.bstek.dorado.view.control.ScrollBar
getSmallChange
getSourceDataset() - Method in class com.bstek.dorado.view.data.DatasetReference
取得引用的源数据集
getSourceKeyFields() - Method in class com.bstek.dorado.data.db.JoinTable
取得用于建立关联的源表中的字段.
getSourceModule() - Method in class com.bstek.dorado.view.data.DatasetReference
返回引用的源数据集模块。
getSourceTable() - Method in class com.bstek.dorado.data.db.JoinTable
取得与关联表相对应的源表.
getSql() - Method in class com.bstek.dorado.data.db.AutoDBField
返回此Field的自定义SQL。
getSql() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset内部使用的SQL命令。
getSql() - Method in class com.bstek.dorado.data.db.DBStatement
取得SBStatement内部使用的SQL命令。
getSql() - Method in class com.bstek.dorado.data.db.SqlDataset
返回SQL命令。
getSql() - Method in class com.bstek.dorado.data.db.SqlMatchRule
取得自定义SQL.
getSqlDataType() - Method in class com.bstek.dorado.data.db.DBField
取得数据库中该字段的数据类型。
getState() - Method in class com.bstek.dorado.data.DOWrapper
getState() - Method in interface com.bstek.dorado.data.Dataset
返回当前记录集的当前状态
getState() - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录集的当前状态
getState() - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录集的当前状态
getState() - Method in class com.bstek.dorado.data.ReadRecord
记录当前的状态
getState() - Method in interface com.bstek.dorado.view.ViewModel
取得当前状态
getState() - Method in class com.bstek.dorado.view.ViewModelSupport
取得当前状态
getStatus() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)状态设置。
getStoreFileName(HttpServletRequest, String, MetaData) - Method in class com.bstek.dorado.biz.FileController
取得存储上传文件的文件名
getString(String) - Static method in class com.bstek.dorado.common.Setting
读取一个String型的配置信息
getString(String, String) - Static method in class com.bstek.dorado.common.Setting
读取一个String型的配置信息.如何该配置不存在则返回缺省值.
getString(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个String型的配置信息
getString(String, String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个String型的配置信息
getString(int) - Method in interface com.bstek.dorado.data.Dataset
按String类型返回当前记录中某字段的值。
getString(String) - Method in interface com.bstek.dorado.data.Dataset
按String类型返回当前记录中某字段的值。
getString(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型返回当前记录中某字段的值。
getString(int) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.data.ReadRecord
按String类型返回记录中某字段的值。
getString(Locale, String, String, Object[]) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String, Object, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object[]) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按String方式读取一个参数 本方法回自动将字符串转化为Setting.xml中common.defaultCharsetName所指定的编码格式.
getString() - Method in class com.bstek.dorado.utils.variant.Variant
按String类型读取数据
getString(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按String类型读取数据
getString(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按String类型读取数据
getString(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型返回当前记录中某字段的值。
getStringValues(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
返回参数值数组.
getStyle() - Method in interface com.bstek.dorado.view.control.Placeable
getStyle
getStyle() - Method in class com.bstek.dorado.view.control.PlaceableControl
getStyle
getStyle() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
getStyle
getSubFile(int) - Method in class com.bstek.dorado.action.mapping.GlobalUnit
根据索引号得到一个子配置单元
getSubFileCount() - Method in class com.bstek.dorado.action.mapping.GlobalUnit
返回子配置单元的个数
getSubmitScope() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回提交Dataset对象中记录的方式，有四种方式： all - 提交Dataset中所有的记录； all-change - 只提交Dataset中所有更改过的记录； current - 只提交Dataset的当前记录； selected - 只提交Dataset中所有通过Select复选框选中的记录。
getTab(int) - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得一个指定索引位置的标签项对象。
getTab(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得一个指定名称的标签项对象。
getTabCount() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得标签项的总数
getTabIndex() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得当前多页标签(Tab)的索引值。
getTabPlacement() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得多页标签(Tab)所在的位置，有两个值：top和buttom。
getTable() - Method in class com.bstek.dorado.data.db.BaseMatchRule
返回原始字段(originField)所属的表名。
getTable() - Method in class com.bstek.dorado.data.db.DBField
返回该字段所属的数据库物理表名.
getTable() - Method in class com.bstek.dorado.data.db.SortRule
返回原始字段(originField)所属的表别名.
getTag() - Method in class com.bstek.dorado.action.mapping.ActionConfig
{@inheritDoc}
getTag() - Method in class com.bstek.dorado.action.mapping.ActionTarget
获得自定义信息。
getTag() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
用户自定义信息。
getTag() - Method in interface com.bstek.dorado.view.Element
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.ViewModelSupport
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.AbstractControl
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.MenuItem
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.table.Column
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.tabset.TabElement
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.control.tree.TreeNode
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in interface com.bstek.dorado.view.data.ViewField
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得元素(Element)的用户自定义信息(Tag)。
getTag() - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
取得元素(Element)的用户自定义信息(Tag)。
getTarget() - Method in class com.bstek.dorado.data.DatasetAdapter
返回适配器的目标Dataset
getTarget() - Method in class com.bstek.dorado.view.control.Menu
取得弹出式菜单(Menu)需要刷新的目标框架(Target)。
getTarget() - Method in class com.bstek.dorado.view.control.command.Frame
返回在哪个目标框架中打开新页面。
getTarget() - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的目标框架(Target)值。
getTarget() - Method in class com.bstek.dorado.view.control.tree.Tree
取得树(Tree)的节点切换时需要刷新的目标框架。
getTarget() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得被适配的数据集
getTemplate(String) - Static method in class com.bstek.dorado.common.VelocityHelper
getTemplate
getTemplate(String, String) - Static method in class com.bstek.dorado.common.VelocityHelper
getTemplate
getText() - Method in class com.bstek.dorado.view.control.Label
取得标题的文本内容。
getTextPattern() - Method in class com.bstek.dorado.view.control.ProgressBar
返回文本格式。
getTimeBetweenEvictionRunsMillis() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getTimeBetweenEvictionRunsMillis
getTitle() - Method in class com.bstek.dorado.view.control.SubWindow
获取字窗口(SubWindow)标题(title)。
getTitle() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回组(Group)的标题(Title)，通常为文字描述信息。
getTitleDblClickAction() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)标题栏双击Action设置。
getToolTip() - Method in class com.bstek.dorado.view.control.Button
返回按钮(Button)的弹出式提示(toolTip)。
getToolTip() - Method in class com.bstek.dorado.view.control.CheckBox
取得弹出式提示(ToolTip)。
getToolTip() - Method in class com.bstek.dorado.view.control.Editor
取得弹出式提示(ToolTip)。
getToolTip() - Method in class com.bstek.dorado.view.control.RadioGroup
取得弹出式提示(ToolTip)。
getToolTip() - Method in class com.bstek.dorado.view.control.table.Column
取得该列(Column)的弹出式提示(ToolTip)。
getToolTip() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回字段的弹出式提示信息。
getToolTip() - Method in interface com.bstek.dorado.view.data.ViewField
返回字段的弹出式提示信息。
getToolTip() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回字段的弹出式提示信息。
getTop() - Method in interface com.bstek.dorado.view.control.Placeable
getTop
getTop() - Method in class com.bstek.dorado.view.control.PlaceableControl
getTop
getTop() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
getTop
getTop() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架中新页面上部边缘(Top)值。
getTransaction() - Static method in class com.bstek.dorado.common.TransactionManager
获取当前线程中的事务.
getTransactionIsolation() - Method in class com.bstek.dorado.common.ds.TransConnection
getTransactionMode() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
getTransactionMode
getTransactionMode() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
取得本次数据更新操作的事务模式.
getTreeColumn() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回据有树展开功能的列,在该列上可以实现数展开功能
getType() - Method in class com.bstek.dorado.action.mapping.ActionException
要捕捉的异常的名称。
getType() - Method in class com.bstek.dorado.common.ds.DataSourceConfig
getType
getType() - Method in class com.bstek.dorado.view.data.CustomDataset
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.DODataset
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.DatasetReference
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.DatasetWrapper
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.FormDataset
取得视图数据集的类型。
getType() - Method in interface com.bstek.dorado.view.data.ViewDataset
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得视图数据集的类型。
getTypeClass() - Method in class com.bstek.dorado.action.mapping.ActionException
要捕捉的异常的Class类型
getTypeMap() - Method in class com.bstek.dorado.common.ds.TransConnection
getURL() - Method in class com.bstek.dorado.common.fileloader.FileLoader
取得文件的URL连接器。
getURL() - Method in class com.bstek.dorado.common.fileloader.PathFileLoader
取得文件的URL连接器。
getURL() - Method in class com.bstek.dorado.common.fileloader.ResourceFileLoader
取得文件的URL连接器。
getUnit() - Method in class com.bstek.dorado.action.mapping.ActionTarget
返回此对象所隶属的Unit。
getUnit() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
取得该Controller所属的Unit对象
getUnit(int) - Method in class com.bstek.dorado.action.mapping.Mapping
根据索引号取得一个子配置单元对象
getUnitCount() - Method in class com.bstek.dorado.action.mapping.Mapping
根据别名取得一个子配置单元对象
getUpdateDataHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
getUpdateDataHandler
getUpdateFields() - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
取得Dataset中需要更新的Field数组。
getUploadWorkDir(HttpServletRequest, MetaData) - Method in class com.bstek.dorado.biz.FileController
Deprecated.
getUploadWorkDirectory(HttpServletRequest, MetaData) - Method in class com.bstek.dorado.biz.FileController
取得存放上传文件的目标目录
getUrl() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getUrl
getUser() - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
getUser
getUser() - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
getUserName
getValue(int) - Method in interface com.bstek.dorado.data.Dataset
返回当前记录中某字段的值。
getValue(String) - Method in interface com.bstek.dorado.data.Dataset
返回当前记录中某字段的值。
getValue(int) - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录中某字段的值。
getValue(int) - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.data.ReadRecord
返回记录中某字段的值。
getValue() - Method in class com.bstek.dorado.data._DatasetEvent
getValue() - Method in class com.bstek.dorado.data._RecordEvent
getValue() - Method in class com.bstek.dorado.data.db.CommonMatchRule
返回匹配值.
getValue() - Method in class com.bstek.dorado.utils.variant.Variant
按Object类型读取数据
getValue(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按Object类型读取数据
getValue(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按Object类型读取数据
getValue() - Method in class com.bstek.dorado.view.control.Button
取得按钮(Button)的值(Value)。
getValue() - Method in class com.bstek.dorado.view.control.TextEditor
返回文本编辑器(TextEditor)的默认值
getValue() - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
取得下拉框(DropDown)当前选择项的值。
getValue(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录中某字段的值。
getValueField() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
getValueField
getValues() - Method in class com.bstek.dorado.view.data.validate.impl.ListValidator
取得校验器中的一组校验值
getVariant(String) - Method in class com.bstek.dorado.data.ParameterSet
根据键值并按Variant类型读取数据
getVariant(String) - Method in class com.bstek.dorado.data.ReadRecord
按Variant类型返回记录中某字段的值。
getVariant(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按Variant类型读取数据
getVariant(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按Variant类型读取数据
getVersion() - Static method in class com.bstek.dorado.Constants
getVersion
getViewDataset() - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
取得发送动态数据加载操作的Dataset.
getViewDataset(String) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
根据id取得一个相应的ViewModel中的Dataset
getViewModel() - Method in interface com.bstek.dorado.view.Component
取得视图模型对象。
getViewModel(String, String, String, int, String) - Static method in class com.bstek.dorado.view.ViewModelManager
getViewModel
getViewModel(String, ViewModelConfig, String, int, String) - Static method in class com.bstek.dorado.view.ViewModelManager
getViewModel
getViewModel(PageContext) - Static method in class com.bstek.dorado.view.ViewModelManager
Deprecated.
getViewModel() - Method in class com.bstek.dorado.view.control.AbstractControl
取得视图模型对象。
getViewModel() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得视图模型对象。
getViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
{@inheritDoc}
getViewModel() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得与客户端对应的ViewModel实例
getViewModel() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得与客户端对应的ViewModel实例
getViewModelInfo(String) - Static method in class com.bstek.dorado.view.ViewModelManager
getViewModelInfo
getViewProperties(DoradoContext, boolean) - Static method in class com.bstek.dorado.view.ViewPropertiesHelper
getViewProperties
getVisibility() - Method in class com.bstek.dorado.data.RecordIterator
返回迭代器的记录可见性
getVisibility() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得该元素(Element)是否在页面上可见。
getVisibleFields() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
取得动态下拉框(DynamicDropDown)中指定显示的数据列。
getVisibleFields() - Method in class com.bstek.dorado.view.control.dropdown.SimpleDropDown
取得数据集下拉框(DatasetDropDown)中指定显示的那些数据列。
getWarnings() - Method in class com.bstek.dorado.common.ds.TransConnection
getWidth() - Method in class com.bstek.dorado.view.control.DataLabel
取得标签的宽度
getWidth() - Method in interface com.bstek.dorado.view.control.Placeable
getWidth
getWidth() - Method in class com.bstek.dorado.view.control.PlaceableControl
getWidth
getWidth() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
getWidth
getWidth() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm的宽度。
getWidth() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得组(Group)的宽度值。
getWidth() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架中新页面的宽度(Width)值。
getWidth() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
getWidth
getWidth() - Method in class com.bstek.dorado.view.control.table.DataColumn
取得列(Column)显示的宽度(Width)。
getWidth() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得多页标签(Tab)的宽度(Width)。
getWrappedDataset() - Method in class com.bstek.dorado.view.data.DatasetWrapper
取得被包装的源Dataset
getWriteFields() - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
取得高级下拉框(AdvanceDropDown)从源数据集字段(ReadFields)读取值， 给目的数据集字段(WriteFields)赋值的目的数据集字段(WriteFields)信息。
getWriteFields() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
取得高级下拉框(AdvanceDropDown)从源数据集字段(ReadFields)读取值， 给目的数据集字段(WriteFields)赋值的目的数据集字段(WriteFields)信息。
getXmlDocument() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得客户端发送的XML信息
getXmlDocument() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得客户端发送的XML信息
getXmlProcessor() - Static method in class com.bstek.dorado.utils.xml.XmlFactory
getXmlProcesser
group - Variable in class com.bstek.dorado.view.control.autoform.FormElement
组
groups() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得所有组的集合对象

H

HIDDEN - Static variable in class com.bstek.dorado.view.control.DataPilot
HIDDEN - Static variable in class com.bstek.dorado.view.control.SubWindow
HIDDEN
HIDDEN - Static variable in class com.bstek.dorado.view.control.autoform.FormElement
HORIZONTAL - Static variable in class com.bstek.dorado.view.control.autoform.AutoForm
AutoForm中Group的布局方式 - 水平方式
HashKeyUtil - class com.bstek.dorado.common.HashKeyUtil.
HttpContextFactory - class com.bstek.dorado.common.HttpContextFactory.
默认的根据ServletRequest来获取DoradoContext的工厂
HttpDoradoContext - class com.bstek.dorado.common.HttpDoradoContext.
用于封装HttpRequest的上下文对象
HttpDoradoContext() - Constructor for class com.bstek.dorado.common.HttpDoradoContext
HttpExprInitializer - class com.bstek.dorado.common.rtexpr.impl.HttpExprInitializer.
HttpExprInitializer() - Constructor for class com.bstek.dorado.common.rtexpr.impl.HttpExprInitializer
handleRPC(String, ParameterSet, ParameterSet) - Method in interface com.bstek.dorado.view.ViewModel
处理一个远程过程调用操作
handleRPC(String, ParameterSet, ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
处理一个远程过程调用操作
handleUpdate(String, ParameterSet) - Method in interface com.bstek.dorado.view.ViewModel
处理一个更新操作
handleUpdate(String, ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
处理一个更新操作
hasNext() - Method in class com.bstek.dorado.data.RecordIterator
返回 true 表示是否存在下一条记录.
hashCode() - Method in class com.bstek.dorado.utils.collection.ObjectList
Returns a hash code value for the object.
hashCode() - Method in class com.bstek.dorado.utils.variant.Variant
Returns a hash code value for the object.
hashCode() - Method in class com.bstek.dorado.utils.variant.VariantSet
Returns a hash code value for the object.

I

I18NExprInitializer - class com.bstek.dorado.i18n.I18NExprInitializer.
I18NExprInitializer() - Constructor for class com.bstek.dorado.i18n.I18NExprInitializer
IGNORE - Static variable in class com.bstek.dorado.view.data.validate.impl.RangeValidator
范围校验类型 - 忽略
IN - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
在...之中
INSERT - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - INSERT
INT - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - int型。
INT_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - int型。
IllegalValueException - exception com.bstek.dorado.view.data.validate.IllegalValueException.
非法值异常。
IllegalValueException() - Constructor for class com.bstek.dorado.view.data.validate.IllegalValueException
构造器
IllegalValueException(String) - Constructor for class com.bstek.dorado.view.data.validate.IllegalValueException
构造器
IllegalValueException(Throwable) - Constructor for class com.bstek.dorado.view.data.validate.IllegalValueException
构造器
Index - class com.bstek.dorado.data.Index.
记录集的索引对象
Index(Dataset, String[]) - Constructor for class com.bstek.dorado.data.Index
构造器 根据给定的Dataset和字段创建索引
InvalidPropertyValueException - exception com.bstek.dorado.utils.InvalidPropertyValueException.
无效属性值的异常
InvalidPropertyValueException() - Constructor for class com.bstek.dorado.utils.InvalidPropertyValueException
InvalidPropertyValueException
InvalidPropertyValueException(String) - Constructor for class com.bstek.dorado.utils.InvalidPropertyValueException
InvalidPropertyValueException
InvalidPropertyValueException(String, String) - Constructor for class com.bstek.dorado.utils.InvalidPropertyValueException
InvalidPropertyValueException
id - Variable in class com.bstek.dorado.view.control.AbstractControl
inTransaction() - Method in class com.bstek.dorado.common.JDBCTransaction
inTransaction() - Method in interface com.bstek.dorado.common.Transaction
当前是否存在一个未决的事务.即是否以调用beginTransaction()启动了新的事务,且尚未调用 commit()或rollback().
indexOf(Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回给定的键值对应的索引号。
indexOf(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回给定的键值对应的索引号。
indexToName(int) - Method in class com.bstek.dorado.data.FieldSet
根据Field的索引号得到Field的名称
indexToName(int) - Method in class com.bstek.dorado.data.ParameterSet
返回给定的索引号对应的键值.
indexToName(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
返回给定的索引号对应的键值.
info(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_INFO 的字符串记录到日志文件里。
info(Object) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_INFO 的字符串记录到日志文件里。
init(ActionConfig, ServletRequest) - Method in interface com.bstek.dorado.action.Action
初始化Action对象
init() - Static method in class com.bstek.dorado.action.mapping.Mapping
初始化所有的Mapping信息。
init(Properties) - Static method in class com.bstek.dorado.common.VelocityHelper
init
init() - Static method in class com.bstek.dorado.common.ds.ConnectionConfigs
初始化连接池
init(String, String) - Static method in class com.bstek.dorado.common.fileloader.FileLoaderFactory
init
init() - Static method in class com.bstek.dorado.common.log.Log
初始化日志记录器，这个记录器将负责控制日志信息。
init(String) - Method in interface com.bstek.dorado.common.log.Logger
初始化日志记录器，这个记录器将负责控制日志信息。
init(DoradoContext, XmlNode) - Method in interface com.bstek.dorado.data.Dataset
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.DatasetAdapter
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.DatasetSupport
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.db.SqlDataset
根据一个XML节点对象自动配置本Dataset。
init() - Static method in class com.bstek.dorado.module.ModuleManager
初始化
init(DoradoContext, XmlNode) - Method in interface com.bstek.dorado.view.Component
初始化
init(int) - Method in interface com.bstek.dorado.view.ViewModel
视图模型初始化
init(int) - Method in class com.bstek.dorado.view.ViewModelSupport
视图模型初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.AbstractControl
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.Calendar
Deprecated.
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.Menu
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.FormElement
Deprecated.
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
Deprecated.
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.LabelFormElement
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.TextEditorFormElement
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.CommandQueue
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.RPCCommand
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.RequestCommand
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
初始化
init(int) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.table.Column
列初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.table.Table
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.tabset.TabSet
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.tree.DataTree
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.tree.Tree
初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.DatasetWrapper
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
根据一个XML节点对象自动配置本Dataset。
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
初试化远程方法调用的处理类
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
初试化远程方法调用的处理类
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
初试化远程方法调用的处理类
init(HttpServletRequest) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
初试化远程方法调用的处理类
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
初试化远程方法调用的处理类
initColumn(DoradoContext, Column, XmlNode) - Method in class com.bstek.dorado.view.control.table.DataTable
初始化列
initColumn(DoradoContext, Column, XmlNode) - Method in class com.bstek.dorado.view.control.table.Table
初始化列
initContext(DoradoContext, JexlContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprContextHelper
initContext
initControl(String, Control) - Method in class com.bstek.dorado.view.ViewModelSupport
initControl
initControls() - Method in class com.bstek.dorado.view.ViewModelSupport
initControls
initControls() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
initControls
initDataset(DoradoContext, String, Dataset) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. initDataset
initDataset(Dataset) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. 当Module初试化某个Dataset时触发的方法。
initDataset(DoradoContext, Dataset) - Method in class com.bstek.dorado.module.DefaultModule
{@inheritDoc}
initDataset(Dataset) - Method in class com.bstek.dorado.module.ModuleSupport
当Module初试化某个Dataset时触发的方法。
initDataset(ViewDataset) - Method in class com.bstek.dorado.view.AbstractViewModel
Deprecated.
initDataset(String, ViewDataset) - Method in class com.bstek.dorado.view.AbstractViewModel
Deprecated.
initDataset(ViewDataset) - Method in class com.bstek.dorado.view.DefaultViewModel
initDataset
initDataset(ViewDataset) - Method in class com.bstek.dorado.view.ViewModelSupport
initDataset
initDatasets() - Method in class com.bstek.dorado.view.ViewModelSupport
initDatasets
initDatasets() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
initDatasets
initFileUpload(HttpServletRequest, DiskFileUpload, MetaData) - Method in class com.bstek.dorado.biz.FileController
设定 DiskFileUpload 的相关属性.
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
AutoForm内部控件初始化
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.FormElement
AutoForm内部控件初始化
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.LabelFormElement
AutoForm内部控件初始化
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
AutoForm内部控件初始化
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.TextEditorFormElement
AutoForm内部控件初始化
initLookupFields(DoradoContext, Dataset) - Method in class com.bstek.dorado.view.ViewModelSupport
initLookupFields
initNewRecord(Record) - Method in class com.bstek.dorado.data.DatasetSupport
initNewRecord
initNewRecord(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
initNewRecord
initValidator(Validator, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
initValidator
insertRecord() - Method in interface com.bstek.dorado.data.Dataset
添加一条记录。
insertRecord(int) - Method in interface com.bstek.dorado.data.Dataset
添加一条记录并初始化新记录的状态。
insertRecord() - Method in class com.bstek.dorado.data.DatasetAdapter
添加一条记录。
insertRecord(int) - Method in class com.bstek.dorado.data.DatasetAdapter
添加一条记录并初始化新记录的状态。
insertRecord() - Method in class com.bstek.dorado.data.DatasetSupport
添加一条记录。
insertRecord(int) - Method in class com.bstek.dorado.data.DatasetSupport
添加一条记录并初始化新记录的状态。
insertRecord(Record) - Method in class com.bstek.dorado.data.RecordSet
插入一条记录
insertRecord() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
添加一条记录。
insertRecord(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
添加一条记录并初始化新记录的状态。
internalExecute() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
内部的执行方法.
internalExecute() - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
内部的执行方法.
internalExecute() - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
内部的执行方法.
internalExecute() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
内部的执行方法.
internalLoad(boolean, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
internalLoad
invokeAction(HttpServletRequest, HttpServletResponse) - Static method in class com.bstek.dorado.action.ActionHandler
根据request和response对象调用一个Action。
invokeAction(String, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
调用Controller中名为actionName的Action。
isAllowPushDown() - Method in class com.bstek.dorado.view.control.Button
返回按钮(Button)是否允许按钮被按下。
isAlwaysPerform() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
返回是否总是提交更新命令(UpdateCommand)。
isAsync() - Method in class com.bstek.dorado.view.control.command.RPCCommand
isAsync
isAsync() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否启用客户端的异步数据装载功能.
isAsync() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否启用客户端的异步数据装载功能.
isAutoCreateDiv() - Method in class com.bstek.dorado.view.control.tabset.Tab
isAutoCreateDiv
isAutoCreateFields() - Method in interface com.bstek.dorado.data.Dataset
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
isAutoCreateFields() - Method in class com.bstek.dorado.data.DatasetAdapter
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.
isAutoCreateFields() - Method in class com.bstek.dorado.data.DatasetSupport
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.
isAutoDropDown() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
返回当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。
isAutoLoadPage() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否启用客户端Dataset的自动状态数据功能。
isAutoLoadPage() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回是否启用客户端Dataset的自动状态数据功能。
isAutoLoadPage() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否启用客户端Dataset的自动状态数据功能。
isAutoSyncRecordWithDragging() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
在节点拖动时，是否允许节点所属的记录自动同步移动。
isBaseDataType(Class) - Static method in class com.bstek.dorado.utils.variant.DataType
判断一个Class类型是否是基本的dorado可以直接处理的简单类型
isCachable() - Method in interface com.bstek.dorado.view.control.dropdown.CachableDropDown
取得该下拉框(DropDown)是否支持缓存。
isCachable() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
取得该下拉框(DropDown)是否支持缓存。
isCachable() - Method in class com.bstek.dorado.view.control.tabset.FrameTab
返回是否允许缓存Frame内容
isCenter() - Method in class com.bstek.dorado.view.control.command.Frame
返回目标框架新页面是否位于中心位置。
isCheckable() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
返回树节点(TreeNode)前面是否有复选框可以被选择。
isCheckable() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
返回用户是否可以通过复选框选择节点。
isChecked() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
返回当前树节点(TreeNode)是否已经被选中。
isClearSelectionOnSuccess() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回命令(Command)提交成功后是否清除选中的Dataset记录。
isClosed() - Method in class com.bstek.dorado.common.ds.TransConnection
isConfirmCancel() - Method in class com.bstek.dorado.view.control.DataPilot
取得是否提示用户确认取消操作(ConfirmCancel)。
isConfirmCancel() - Method in class com.bstek.dorado.view.control.table.DataTable
返回用户在客户端对记录进行取消操作时是否有确认提示。
isConfirmDelete() - Method in class com.bstek.dorado.view.control.DataPilot
返回是否提示用户确认删除操作(ConfirmDelete)。
isConfirmDelete() - Method in class com.bstek.dorado.view.control.table.DataTable
返回用户在客户端删除记录时是否有确认提示。
isContextRelative() - Method in class com.bstek.dorado.action.mapping.ActionTarget
此对象的Path属性所描述的URL是否是一个相对路径，此属性的默认值是true。
isDeleteSelectionOnSuccess() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回命令(Command)对象提交成功后是否删除客户端Dataset中已经选中的记录。
isDeleted() - Method in class com.bstek.dorado.data.Record
该记录是否已被删除
isDescent() - Method in class com.bstek.dorado.data.db.SortRule
返回是否按照降序进行排序.
isDisabled() - Method in class com.bstek.dorado.view.control.Button
返回按钮是否处于不可用状态。
isDisabled() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项(MenuItem)是否无效。
isDisabled() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回当前标签项(Tab)是否被禁止，被禁止的标签项上所有的元素都无法操作。
isDown() - Method in class com.bstek.dorado.view.control.Button
返回按钮(Button)在初始化的时候是否是被压下的状态。
isDraggable() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)是否允许拖动改变位置。
isDraggable() - Method in class com.bstek.dorado.view.control.tree.Tree
返回树(Tree)的节点是否允许拖动。
isEditable() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格(DataTable)是否允许用户编辑。
isEmpty() - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
isEmpty(String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
判断字符串是否为null或为"".
isEmpty(String) - Static method in class com.bstek.dorado.utils.StringHelper
判断是否一个无效的字符串。
isEnabled() - Method in class com.bstek.dorado.data.db.CommonMatchRule
返回整个匹配规则是否有效。
isEnabled() - Method in class com.bstek.dorado.data.db.SortRule
取得该排序规则是否有效。
isEscapeEnabled() - Method in class com.bstek.dorado.data.db.CommonMatchRule
返回是否要启用本匹配规则上的可逃逸功能.
isExpanded() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
返回当在页面上初始化显示树(Tree)时，该节点是否已经被打开。
isExpanded() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
返回当在页面上显示树(Tree)时树的该层节点是否已经被打开的状态。
isFilterOnOpen() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。
isFirst() - Method in interface com.bstek.dorado.data.Dataset
当前位置是否已到达当前页的顶端。
isFirst() - Method in class com.bstek.dorado.data.DatasetAdapter
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

isFirst() - Method in class com.bstek.dorado.data.DatasetSupport
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

isFirst() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

isFirstGroupAsHeader() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
返回AutoForm的第一个组(Group)是否在页面上单独占用一行作为头行。
isFitWidth() - Method in class com.bstek.dorado.view.control.MenuBar
返回宽度是否自适应。
isFixed() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
返回是否禁止用户不通过下拉选择而直接输入。
isFlushDataOnSuccess() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回命令(Command)提交成功后是否刷新客户端Dataset中的数据。
isGroup() - Method in class com.bstek.dorado.data.db.AutoDBField
返回AutoSqlDataset查询SQL的group子句中是否包含该字段.
isHasChild() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
返回节点是否有子节点，默认为true。
isHasChild() - Method in class com.bstek.dorado.view.control.tree.TreeNode
返回当前树节点(TreeNode)是否有子节点。
isHeaderClickable() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回数据表格的该列标题是否支持单击操作。
isHeaderClickable() - Method in class com.bstek.dorado.view.control.table.EditableColumnGroup
返回数据表格的该列标题是否支持单击操作。
isHighlightSelection() - Method in class com.bstek.dorado.view.control.table.DataTable
返回通过复选框选中记录后是否将记录进行高亮显示。
isHighlightSelection() - Method in class com.bstek.dorado.view.control.tree.Tree
返回通过复选框选中记录后是否将记录进行高亮显示，默认为true。
isIgnored() - Method in interface com.bstek.dorado.view.Component
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
isIgnored() - Method in class com.bstek.dorado.view.control.AbstractControl
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
isIgnored() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
isInsertOnEmpty() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回当客户断的Dataset中没有任何记录时是否自动添加一条空记录.
isInsertOnEmpty() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效.
isLast() - Method in interface com.bstek.dorado.data.Dataset
当前位置是否已到达当前页的尾端。
isLast() - Method in class com.bstek.dorado.data.DatasetAdapter
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

isLast() - Method in class com.bstek.dorado.data.DatasetSupport
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

isLast() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

isLastGroupAsFooter() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
返回AutoForm的最后一个组是否单独占一行作为尾行。
isLoadData() - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。
isMapType(Class) - Static method in class com.bstek.dorado.data.DOUtils
判断某Class是否是java.util.Map的派生类.
isMapValue() - Method in class com.bstek.dorado.view.control.dropdown.SimpleDropDown
返回是否支持MapValue属性。
isNoClient() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否不在客户端创建记录集对象。
isNoClient() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
isNoClient
isNoWrap() - Method in class com.bstek.dorado.view.control.table.DataColumn
返回是否允许该列的内容换行显示。
isNotEmpty(String) - Static method in class com.bstek.dorado.utils.StringHelper
判断是否一个有效的字符串。
isNull(int) - Method in interface com.bstek.dorado.data.Dataset
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in interface com.bstek.dorado.data.Dataset
判断当前记录中某字段的值是否为空(null)。
isNull(int) - Method in class com.bstek.dorado.data.DatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.data.DatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNull(int) - Method in class com.bstek.dorado.data.DatasetSupport
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.data.DatasetSupport
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.data.ReadRecord
判断记录中某字段的值是否为空(null)。
isNull() - Method in class com.bstek.dorado.utils.variant.Variant
是否为空(null)
isNull(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
判断给定索引号下的数值是否为空(null)
isNull(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
判断给定键值下的数值是否为空(null)
isNull(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNullable() - Method in class com.bstek.dorado.data.AbstractField
返回字段是否为空。
isNullable() - Method in interface com.bstek.dorado.data.Field
返回字段是否为空。
isPlaceableControl(String) - Method in interface com.bstek.dorado.view.control.ControlFactory
isVisibleControl
isPointFilled(int, int) - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
isPointFilled
isReadOnly() - Method in class com.bstek.dorado.common.ds.TransConnection
isReadOnly() - Method in class com.bstek.dorado.view.control.Editor
返回编辑框(Editor)是否只读。
isReadOnly() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
返回AutoForm是否只读。
isReadOnly() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格(DataTable)是否是只读。
isReadOnly() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回列(Column)是否只读。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回该字段是否只读。
isReadOnly() - Method in interface com.bstek.dorado.view.data.ViewDataset
取得数据集的只读属性。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得数据集的只读属性。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得数据集的只读属性。
isReadOnly() - Method in interface com.bstek.dorado.view.data.ViewField
返回该字段是否只读。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回该字段是否只读。
isRecordVisible(Record) - Method in class com.bstek.dorado.data.DatasetSupport
判断指定的记录对象是不是可见记录.
isRecordVisible(Record) - Method in interface com.bstek.dorado.data.RecordFilter
判断一条记录是否可见
isRedirect() - Method in class com.bstek.dorado.action.mapping.ActionForward
是否以sendRedirect的方式转向新的path。
isResizable() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)是否允许改变大小。
isResizable() - Method in class com.bstek.dorado.view.control.command.Frame
返回目标框架页面是否可以改变窗口尺寸大小(Resizable)。
isResizable() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回是否支持客户端用户对该列进行宽度调整操作。
isRetrieveAfterUpdate() - Method in class com.bstek.dorado.data.db.DBDataset
是否需要在完成某条记录的更新后对该记录进行重新查询.
isSafe() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
返回用户访问视图页面时是否对用户身份进行检验。
isSafe() - Method in interface com.bstek.dorado.view.ViewModel
返回用户访问视图页面时是否对用户身份进行检验。
isSafe() - Method in class com.bstek.dorado.view.ViewModelSupport
返回用户访问视图页面时是否对用户身份进行检验。
isSelectAllField() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回是否检索出AutoSqlDataset对应的主表(originTable)中所有的字段。
isShowBevel() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回是否显示组(Group)的边框线，缺省为显示。
isShowBorder() - Method in class com.bstek.dorado.view.control.MenuBar
返回是否显示边框(border)。
isShowButtons() - Method in class com.bstek.dorado.view.control.SplitPanel
返回是否显示分割栏(SplitPanel)快捷按钮。
isShowCloseButton() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)是否显示窗口关闭系统按钮。
isShowColumnHeader() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
返回是否显示数据集下拉框(DatasetDropDown)中每个数据列的标题行。
isShowColumnHeader() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回是否显示动态下拉框(DynamicDropDown)中的字段列的标题。
isShowDialog() - Method in class com.bstek.dorado.view.control.command.RPCCommand
isShowDialog
isShowFooter() - Method in class com.bstek.dorado.view.control.table.Table
取得是否显示数据表格(DataTable)的汇总栏，默认是显示。
isShowFrame() - Method in class com.bstek.dorado.view.control.tabset.TabSet
返回是否显示多页标签(Tab)的外框架(Frame)。
isShowGotoButton() - Method in class com.bstek.dorado.view.control.PagePilot
返回是否显示跳转到按钮(GotoButton)。
isShowHScrollBar() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格(DataTable)数据横向宽度大于显示窗口宽度时是否显示水平滚动条
isShowHeader() - Method in class com.bstek.dorado.view.control.table.Table
返回是否显示数据表格(DataTable)的标题栏，默认是显示。
isShowIndicator() - Method in class com.bstek.dorado.view.control.table.DataTable
返回在数据表格中是否显示表格指示器箭头。
isShowLabel() - Method in class com.bstek.dorado.view.control.autoform.FormElement
返回是否显示AutoForm中与该元素(Element)对应的标题(Label)。
isShowMaximizeButton() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)是否显示窗口最大化按钮。
isShowMinimizeButton() - Method in class com.bstek.dorado.view.control.SubWindow
返回窗口(SubWindow)是否显示窗口最小化按钮。
isShowPageInfo() - Method in class com.bstek.dorado.view.control.PagePilot
返回是否显示页信息。
isShowText() - Method in class com.bstek.dorado.view.control.ProgressBar
返回是否显示文本信息。
isShowVScrollBar() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格(DataTable)数据竖向高度大于显示窗口高度时是否显示垂直滚动条
isSortable() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回是否支持客户端用户对该列进行排序操作。
isStatusbar() - Method in class com.bstek.dorado.view.control.command.Frame
返回目标框架页面的是否有状态栏(Statusbar)。
isSucceed() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得本次远程调用是否已经成功.
isSucceed() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得本次远程调用是否已经成功.
isSupportsPaging() - Method in class com.bstek.dorado.view.data.DODataset
返回是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.
isUpdatable() - Method in class com.bstek.dorado.data.db.DBField
返回该字段是否可向数据库中更新
isValueLegal(String, String) - Static method in class com.bstek.dorado.utils.StringHelper
判断一个字符串中是否未出现指定的一组无效字符
isValueProtected() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回字段是否有字段保护功能。如果有，表示用户只能往数据库中新增字段的值，不能修改数据库中已有的值。
isValueProtected() - Method in interface com.bstek.dorado.view.data.ViewField
返回字段是否有字段保护功能。
isValueProtected() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回字段是否有字段保护功能。如果有，表示用户只能往数据库中新增字段的值，不能修改数据库中已有的值。
isVisible() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项(MenuItem)是否可见。
isVisible() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回组(Group)是否可见，不可见时将不在页面上创建该对象。
isVisible() - Method in class com.bstek.dorado.view.control.table.Column
返回表格中该列是否可见
isVisible() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回标签项(Tab)是否可见。
isVisible() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回字段是否在页面上可见。
isVisible() - Method in interface com.bstek.dorado.view.data.ViewField
返回字段是否在页面上可见。
isVisible() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回字段是否在页面上可见。
items() - Method in class com.bstek.dorado.view.control.Menu
取得所有菜单项MunuItem的集合对象。
items() - Method in class com.bstek.dorado.view.control.MenuItem
取得所有菜单项MunuItem的集合对象。
items() - Method in interface com.bstek.dorado.view.control.MenuItemContainer
取得所有菜单项MunuItem的集合对象。
items() - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
取得所有静态下拉框(ListDropDown)的数据选择项(Item)的集合对象。
iterator() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回迭代器
iterator() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回迭代器

J

JDBCTransaction - class com.bstek.dorado.common.JDBCTransaction.
JDBCTransaction() - Constructor for class com.bstek.dorado.common.JDBCTransaction
JSP_EXCEPTION_KEY - Static variable in class com.bstek.dorado.action.Constants
用于在Request中保存当前的例外对象Attribute键值
JdbcDataSourceConfig - class com.bstek.dorado.common.ds.JdbcDataSourceConfig.
JDBC类型的数据源配置对象
JdbcDataSourceConfig() - Constructor for class com.bstek.dorado.common.ds.JdbcDataSourceConfig
JndiDataSourceConfig - class com.bstek.dorado.common.ds.JndiDataSourceConfig.
JNDI类型的数据源配置对象
JndiDataSourceConfig() - Constructor for class com.bstek.dorado.common.ds.JndiDataSourceConfig
JoinTable - class com.bstek.dorado.data.db.JoinTable.
用于描述AutoSqlDataset的关联表信息的对象.
JoinTable(String) - Constructor for class com.bstek.dorado.data.db.JoinTable
构造器.
joins() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset所有Join的集合对象。

K

KeyNotExistException - exception com.bstek.dorado.utils.collection.KeyNotExistException.
无效键值异常
KeyNotExistException(Object) - Constructor for class com.bstek.dorado.utils.collection.KeyNotExistException
DuplicateObjectKeyException
keyFields - Variable in class com.bstek.dorado.data.db.DBDataset
keyList() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回List
keyList() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回List
keySet() - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap

L

LESS - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
小于
LESSEQUAL - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
小于等于
LEVEL_ALL - Static variable in interface com.bstek.dorado.common.log.Logger
The ALL has the lowest possible rank and is intended to turn on all logging.
LEVEL_DEBUG - Static variable in interface com.bstek.dorado.common.log.Logger
The DEBUG Level designates fine-grained informational events that are most useful to debug an application.
LEVEL_ERROR - Static variable in interface com.bstek.dorado.common.log.Logger
The ERROR level designates error events that might still allow the application to continue running.
LEVEL_FATAL - Static variable in interface com.bstek.dorado.common.log.Logger
The FATAL level designates very severe error events that will presumably lead the application to abort.
LEVEL_INFO - Static variable in interface com.bstek.dorado.common.log.Logger
The INFO level designates informational messages that highlight the progress of the application at coarse-grained level.
LEVEL_OFF - Static variable in interface com.bstek.dorado.common.log.Logger
The OFF has the highest possible rank and is intended to turn off logging.
LEVEL_WARN - Static variable in interface com.bstek.dorado.common.log.Logger
The WARN level designates potentially harmful situations.
LIKE - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
相似
LOGGER_NAME - Static variable in class com.bstek.dorado.common.log.Log
默认的系统LOG名称
LONG - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - long型。
LONG_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - long型。
Label - class com.bstek.dorado.view.control.Label.
标签对象
Label(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Label
构造器
LabelFormElement - class com.bstek.dorado.view.control.autoform.LabelFormElement.
LabelForm元素对象
LabelFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.LabelFormElement
构造器
LayoutInfo - class com.bstek.dorado.view.control.autoform.LayoutInfo.
AutoForm布局方式类
LayoutInfo() - Constructor for class com.bstek.dorado.view.control.autoform.LayoutInfo
LengthValidator - class com.bstek.dorado.view.data.validate.impl.LengthValidator.
长度校验对象
LengthValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.LengthValidator
ListDropDown - class com.bstek.dorado.view.control.dropdown.ListDropDown.
静态下拉框对象
ListDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.ListDropDown
构造器
ListValidator - class com.bstek.dorado.view.data.validate.impl.ListValidator.
List值的校验对象
对于是否属于某一组值的校验
ListValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.ListValidator
LoadDataRPCHandler - class com.bstek.dorado.view.rpc.LoadDataRPCHandler.
用于处理客户端发送的动态数据加载操作的处理类
LoadDataRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.LoadDataRPCHandler
LoadXmlPropertyException - exception com.bstek.dorado.utils.xml.LoadXmlPropertyException.
加载XML属性时发生的异常
LoadXmlPropertyException() - Constructor for class com.bstek.dorado.utils.xml.LoadXmlPropertyException
LoadXmlPropertyException
LoadXmlPropertyException(String) - Constructor for class com.bstek.dorado.utils.xml.LoadXmlPropertyException
LoadXmlPropertyException
LoadXmlPropertyException(Throwable) - Constructor for class com.bstek.dorado.utils.xml.LoadXmlPropertyException
LoadXmlPropertyException
LocaleHelper - class com.bstek.dorado.i18n.LocaleHelper.
用于定义地区与语种的辅助工具类
Log - class com.bstek.dorado.common.log.Log.
日志记录器。
Logger - interface com.bstek.dorado.common.log.Logger.
日志记录器具体实现类的通用接口。
LookupField - class com.bstek.dorado.data.LookupField.
支持Lookup功能的Field。
LookupField(String) - Constructor for class com.bstek.dorado.data.LookupField
构造器
levels() - Method in class com.bstek.dorado.view.control.tree.DataTree
返回树(Tree)的节点层(Level)的集合对象。
load() - Static method in class com.bstek.dorado.common.Setting
装载配置文件。
load() - Static method in class com.bstek.dorado.common.UserConfig
装载配置文件。
load() - Method in interface com.bstek.dorado.data.Dataset
根据已设定的条件读取外部数据。
load(boolean) - Method in interface com.bstek.dorado.data.Dataset
Deprecated.
load() - Method in class com.bstek.dorado.data.DatasetAdapter
根据已设定的条件读取外部数据。
load(boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
根据已设定的条件读取外部数据。
load() - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件读取外部数据。
load(boolean) - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件读取外部数据。
load(ResultSet) - Method in class com.bstek.dorado.data.db.DBDataset
将ResultSet中的数据自动读取到Dataset中
loadAttributies(XmlNode, Object) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
loadAttributies(XmlNode, Object, String) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
loadAttributies(XmlNode, Object, String[]) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
loadChildNodes(XmlNode, Object) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildNodes(XmlNode, Object, String) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildNodes(XmlNode, Object, String[]) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildProperties(XmlNode, Object) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildProperties(XmlNode, Properties) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到Properties对象中。
loadData(DoradoContext, String, Dataset) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. {@inheritDoc}
loadData(Dataset, boolean) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. 当某个Dataset试图获取数据时触发的方法。
loadData(Dataset, boolean) - Method in class com.bstek.dorado.module.ModuleSupport
当某个Dataset试图获取数据时触发的方法。
loadData(String, ViewDataset) - Method in class com.bstek.dorado.view.AbstractViewModel
Deprecated.
loadEventConfig(DoradoContext) - Method in class com.bstek.dorado.view.ViewModelSupport
loadEventConfig
loadGroups(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
加载组
loadItems(DoradoContext, XmlNode, MenuItem) - Method in class com.bstek.dorado.view.control.Menu
加载菜单项
loadNodes() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
根据绑定的记录集导入树节点
loadNodes(TreeNode, int) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
loadNodes() - Method in class com.bstek.dorado.view.control.tree.DataTree
加载根节点以下的子节点。
loadNodes(TreeNode, int) - Method in class com.bstek.dorado.view.control.tree.DataTree
loadNodes(DoradoContext, XmlNode, TreeNode) - Method in class com.bstek.dorado.view.control.tree.Tree
加载树节点
loadRecursiveTreeLevelNodes(TreeNode, int, RecursiveTreeLevel) - Method in class com.bstek.dorado.view.control.tree.DataTree
loadSimpleTreeLevelNodes(TreeNode, int, SimpleTreeLevel) - Method in class com.bstek.dorado.view.control.tree.DataTree
loadedPages() - Method in class com.bstek.dorado.data.RecordSet
返回所有已加载的页的集合

M

MAJOR_VERSION - Static variable in class com.bstek.dorado.Constants
Dorado的大版本号
MAX - Static variable in class com.bstek.dorado.data.db.AggregateMode
求字段的最大值
MAXIMIZE - Static variable in class com.bstek.dorado.view.control.SubWindow
MAXIMIZE
MIN - Static variable in class com.bstek.dorado.data.db.AggregateMode
求字段的最小值
MINIMIZE - Static variable in class com.bstek.dorado.view.control.SubWindow
MINIMIZE
MINOR_VERSION - Static variable in class com.bstek.dorado.Constants
Dorado的小版本号
MODAL_DIALOG - Static variable in class com.bstek.dorado.view.control.command.Frame
命令(Command)提交后在一个模态对话框(Modal Dialog)窗口中打开新页面。
MODELESS_DIALOG - Static variable in class com.bstek.dorado.view.control.command.Frame
命令(Command)提交后在一个非模态对话框(Modeless Dialog)窗口中打开新页面。
MODE_DELETE - Static variable in class com.bstek.dorado.data.db.UpdateSqlInfo
MODE_DELETE
MODE_INSERT - Static variable in class com.bstek.dorado.data.db.UpdateSqlInfo
MODE_INSERT
MODE_MODIFY - Static variable in class com.bstek.dorado.data.db.UpdateSqlInfo
MODE_MODIFY
MODULES_ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.module.ModuleManager
Mapping - class com.bstek.dorado.action.mapping.Mapping.
用于管理所有Mapping配置信息的对象
Mapping() - Constructor for class com.bstek.dorado.action.mapping.Mapping
构造器
MasterDetailLink - class com.bstek.dorado.view.data.MasterDetailLink.
描述主从数据集连接关系的对象.
MasterDetailLink() - Constructor for class com.bstek.dorado.view.data.MasterDetailLink
构造器
MasterDetailLink(ViewDataset, String, String) - Constructor for class com.bstek.dorado.view.data.MasterDetailLink
构造器
MatchRule - interface com.bstek.dorado.data.db.MatchRule.
用于描述AutoSqlDataset的WHERE片断的规则对象的接口.
Menu - class com.bstek.dorado.view.control.Menu.
菜单对象
Menu(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Menu
构造器
MenuBar - class com.bstek.dorado.view.control.MenuBar.
菜单栏对象
MenuBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.MenuBar
构造器
MenuItem - class com.bstek.dorado.view.control.MenuItem.
菜单项对象
MenuItem(String) - Constructor for class com.bstek.dorado.view.control.MenuItem
构造器
MenuItem(String, String) - Constructor for class com.bstek.dorado.view.control.MenuItem
构造器
MenuItemContainer - interface com.bstek.dorado.view.control.MenuItemContainer.
MessageHelper - class com.bstek.dorado.common.MessageHelper.
用于处理Message的工具类.
MetaData - class com.bstek.dorado.utils.MetaData.
元数据对象集合
MetaData() - Constructor for class com.bstek.dorado.utils.MetaData
Module - interface com.bstek.dorado.module.Module.
数据坞 Module用于管理一组Dataset,以便于实现Dataset在应用系统中的重用.
ModuleFactory - interface com.bstek.dorado.module.ModuleFactory.
ModuleManager - class com.bstek.dorado.module.ModuleManager.
Module管理器.
ModuleManager() - Constructor for class com.bstek.dorado.module.ModuleManager
ModuleSupport - class com.bstek.dorado.module.ModuleSupport.
Module的基本实现
ModuleSupport() - Constructor for class com.bstek.dorado.module.ModuleSupport
ModuleSupport
makeObject(Object) - Method in class com.bstek.dorado.module.PoolableModuleFactory
makeObject
map() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回Map
map() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回Map
masterKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
masterKeyFields
masterKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得主数据集中与从数据集关联的字段数组。
matchRules() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset所有MatchRule的集合对象。
moveFirst() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到Dataset的顶端。
moveFirst() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
moveFirst() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
moveFirst() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
moveLast() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到Dataset的末端。
moveLast() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到Dataset的末端。
moveLast() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到Dataset的末端。
moveLast() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到Dataset的末端。
moveNext() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到后一条记录。
moveNext() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到后一条记录。
moveNext() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到后一条记录。
moveNext() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到后一条记录。
movePrev() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到前一条记录。
movePrev() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
movePrev() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
movePrev() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.

N

NORMAL - Static variable in class com.bstek.dorado.view.control.SubWindow
NORMAL
NOTEQUALS - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
不等于
NOT_ALLOW_EQUALS - Static variable in class com.bstek.dorado.view.data.validate.impl.RangeValidator
范围校验类型 - 不等
NO_FORWARD_ATTRIBUTE - Static variable in interface com.bstek.dorado.view.rpc.RPCHandler
NO_FORWARD_ATTRIBUTE
NULL - Static variable in class com.bstek.dorado.common.HashKeyUtil
NULL
NULL_INSTANCE - Static variable in class com.bstek.dorado.data.ParameterSet
空对象
NoCurrentRecordException - exception com.bstek.dorado.data.NoCurrentRecordException.
无当前记录异常。
NoCurrentRecordException() - Constructor for class com.bstek.dorado.data.NoCurrentRecordException
构造器
name - Variable in class com.bstek.dorado.view.control.autoform.FormElement
表单元素名称
nameToIndex(String) - Method in class com.bstek.dorado.data.FieldSet
根据Field的名称得到Field的索引号
nameToType(String) - Static method in class com.bstek.dorado.utils.variant.DataType
nameToType
nativeSQL(String) - Method in class com.bstek.dorado.common.ds.TransConnection
newDocument() - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建一个空的XmlDocument对象
newForward(String) - Method in interface com.bstek.dorado.action.Action
用给定的path创建并返回一个临时的ActionForward对象。
newForward(String, boolean) - Method in interface com.bstek.dorado.action.Action
用给定的path创建并返回一个临时的ActionForward对象。
newInstance(String) - Static method in class com.bstek.dorado.utils.ClassHelper
newInstance
newInstance(String, Class[], Object[]) - Static method in class com.bstek.dorado.utils.ClassHelper
newInstance
newInstance(Class, Class[], Object[]) - Static method in class com.bstek.dorado.utils.ClassHelper
newInstance
newNode(String) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建一个空的XmlNode对象
newProcess(DoradoContext) - Static method in class com.bstek.dorado.common.ProcessManager
newProcess
newViewProperties(DoradoContext) - Static method in class com.bstek.dorado.view.ViewPropertiesHelper
newViewProperties
next() - Method in class com.bstek.dorado.data.RecordIterator
返回下一条记录.
nextRecord() - Method in class com.bstek.dorado.data.RecordIterator
返回下一条记录.

O

OR - Static variable in class com.bstek.dorado.data.db.AndOrMatchRule
不等于
ORIENTATION_HORIZONTAL - Static variable in class com.bstek.dorado.view.control.ProgressBar
ORIENTATION_HORIZONTAL
ORIENTATION_HORIZONTAL - Static variable in class com.bstek.dorado.view.control.ScrollBar
ORIENTATION_HORIZONTAL
ORIENTATION_HORIZONTAL - Static variable in class com.bstek.dorado.view.control.SplitPanel
ORIENTATION_HORIZONTAL
ORIENTATION_VERTICAL - Static variable in class com.bstek.dorado.view.control.ProgressBar
ORIENTATION_VERTICAL
ORIENTATION_VERTICAL - Static variable in class com.bstek.dorado.view.control.ScrollBar
ORIENTATION_VERTICAL
ORIENTATION_VERTICAL - Static variable in class com.bstek.dorado.view.control.SplitPanel
ORIENTATION_VERTICAL
ObjectCollection - interface com.bstek.dorado.utils.collection.ObjectCollection.
对象列表接口,定义对象列表的基本方法。
ObjectList - class com.bstek.dorado.utils.collection.ObjectList.
对象列表的实现。
ObjectList() - Constructor for class com.bstek.dorado.utils.collection.ObjectList
ObjectList
OutlookBar - class com.bstek.dorado.view.control.OutlookBar.
OutlookBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.OutlookBar
构造器
onInit(Dataset) - Method in class com.bstek.dorado.data.AbstractDatasetListener
onInit(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset被初始化的时候触发的事件.即当调用Dataset.init()时触发的事件.
originTable - Variable in class com.bstek.dorado.data.db.DBDataset
outParameters() - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
本次远程调用将要返回给客户端的参数集合.
output(HttpServletRequest, HttpServletResponse, InputStream) - Static method in class com.bstek.dorado.utils.http.ResponseUtil
将一个InputStream中的内容输出到response
output(XmlNode, File) - Method in class com.bstek.dorado.utils.xml.AbstractXmlOutputter
输出一个XML节点
output(XmlNode, String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlOutputter
输出一个XML节点
output(XmlDocument, File) - Method in class com.bstek.dorado.utils.xml.AbstractXmlOutputter
输出整个XML
output(XmlDocument, String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlOutputter
输出整个XML
output(XmlNode, OutputStream) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlNode, Writer) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlNode, File) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlNode, String) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlDocument, OutputStream) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
output(XmlDocument, Writer) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
output(XmlDocument, File) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
output(XmlDocument, String) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
outputDownloadFile(HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
向Response对象中写入文件数据
outputNoCompress(HttpServletRequest, HttpServletResponse, InputStream) - Static method in class com.bstek.dorado.utils.http.ResponseUtil
将一个InputStream中的内容输出到response.
outputString(XmlNode) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
以String格式输出一个XML节点
outputString(XmlDocument) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
以String格式输出整个XML

P

PARENT - Static variable in class com.bstek.dorado.view.control.command.Frame
命令(Command)提交后在当前页面所处的框(frame)的直接父框架(frameset)中打开新页面。
PASSWORD - Static variable in class com.bstek.dorado.view.control.TextEditor
文本编辑器类型 - password
PASSWORD - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - password
PROCESSED_ATTRIBUTE_KEY - Static variable in interface com.bstek.dorado.view.rpc.RPCHandler
PROCESSED_ATTRIBUTE_KEY
PRODUCT_NAME - Static variable in class com.bstek.dorado.Constants
Dorado的产品名
PROPERTY_SEPARATOR - Static variable in class com.bstek.dorado.Constants
属性中的分隔符
PagePilot - class com.bstek.dorado.view.control.PagePilot.
页面导航对象
PagePilot(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.PagePilot
构造器
ParameterSet - class com.bstek.dorado.data.ParameterSet.
参数的集合类
ParameterSet() - Constructor for class com.bstek.dorado.data.ParameterSet
构造器
PathFileLoader - class com.bstek.dorado.common.fileloader.PathFileLoader.
普通Config文件加载器
PathFileLoader() - Constructor for class com.bstek.dorado.common.fileloader.PathFileLoader
PathFileLoader
PathFileLoader(String) - Constructor for class com.bstek.dorado.common.fileloader.PathFileLoader
PathFileLoader
Placeable - interface com.bstek.dorado.view.control.Placeable.
PlaceableControl - class com.bstek.dorado.view.control.PlaceableControl.
PlaceableControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.PlaceableControl
VisibleControl
PlaceableDataControl - class com.bstek.dorado.view.control.PlaceableDataControl.
PlaceableDataControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.PlaceableDataControl
PlaceableDataControl
PoolableModuleFactory - class com.bstek.dorado.module.PoolableModuleFactory.
PoolableModuleFactory() - Constructor for class com.bstek.dorado.module.PoolableModuleFactory
PoolableModuleFactory
Printf - class com.bstek.dorado.utils.Printf.
格式化输出字符串 此处的格式化方式类似C及JDK1.5中包含的格式化方式.
ProcessManager - class com.bstek.dorado.common.ProcessManager.
ProgressBar - class com.bstek.dorado.view.control.ProgressBar.
ProgressBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.ProgressBar
ProgressBar
parameters() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.data.db.DBStatement
取得所有参数的集合对象
parameters() - Method in class com.bstek.dorado.view.control.Command
返回命令(Command)对象的参数的集合对象。
parameters() - Method in class com.bstek.dorado.view.control.command.RPCCommand
返回所有参数的集合对象。
parameters() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回参数集合
parameters() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
取得客户端发送的参数集合.
parameters() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得客户端发送的参数集合.
parametersToBean(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的Bean当中.
parametersToDO(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的对象当中.
parametersToMap() - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到Map当中.
parametersToMap(Map) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的Map当中.
parametersToVariantSet(VariantSet) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的VariantSet当中.
parse(ActionConfig, XmlNode) - Static method in class com.bstek.dorado.action.mapping.ActionConfigParser
根据传入的XML节点解析Mapping配置信息，并设置好传入的ActionConfig对象。
parse(XmlNode) - Static method in class com.bstek.dorado.action.mapping.ActionExceptionParser
根据传入的XML节点解析Mapping配置信息，自动创建并返回相应的ActionException对象。
parse(XmlNode) - Static method in class com.bstek.dorado.action.mapping.ActionForwardParser
根据传入的XML节点解析Mapping配置信息，自动创建并返回相应的ActionForward对象。
parse(ControllerConfig, XmlNode) - Static method in class com.bstek.dorado.action.mapping.ControllerConfigParser
根据传入的XML节点解析Mapping配置信息，并设置好传入的ControllerConfig对象。
parse() - Static method in class com.bstek.dorado.common.ds.DataSourceConfigParser
解析配置文件并返回包含个数据源配置对象的Map.
parse(Class) - Static method in class com.bstek.dorado.utils.variant.DataType
将一个Class类型翻译为Dorado的DataType
parseBigDecimal(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseBigDecimal
parseBoolean(String) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
将一个字符串翻译成逻辑值。
parseBoolean(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseBoolean
parseByte(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseByte
parseDate(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseDate
parseDouble(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseDouble
parseFloat(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseFloat
parseFromXml(XmlNode) - Method in class com.bstek.dorado.common.ds.DataSourceConfig
解析XML节点并自动设置好DataSource的各种属性
parseFromXml(XmlNode) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
parseFromXml
parseFromXml(XmlNode) - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
解析XML节点并自动设置好DataSource的各种属性
parseGlobalUnit(Mapping, String, InputStream) - Static method in class com.bstek.dorado.action.mapping.UnitParser
根据传入的XML节点解析Mapping配置信息，自动创建并返回相应的GlobalUnit对象。
parseInt(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseInt
parseLevel(String) - Static method in class com.bstek.dorado.common.log.Log
转换日志级别名称为日志级别。
parseLong(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseLong
parseShort(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseShort
parseString(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseString
parseSubUnit(Mapping, String, InputStream) - Static method in class com.bstek.dorado.action.mapping.UnitParser
根据传入的XML节点解析Mapping配置信息，自动创建并返回相应的SubUnit对象。
parseType(String) - Static method in class com.bstek.dorado.utils.ClassHelper
parseType
passivate() - Method in interface com.bstek.dorado.module.Module
Module的钝化处理
passivate() - Method in class com.bstek.dorado.module.ModuleSupport
Module的钝化处理
passivateObject(Object, Object) - Method in class com.bstek.dorado.module.PoolableModuleFactory
passivateObject
perform(Map, DoradoContext) - Method in interface com.bstek.dorado.common.rtexpr.ExprInitializer
perform
perform(Map, DoradoContext) - Method in class com.bstek.dorado.common.rtexpr.impl.BaseExprInitializer
perform(Map, DoradoContext) - Method in class com.bstek.dorado.common.rtexpr.impl.HttpExprInitializer
perform(Map, DoradoContext) - Method in class com.bstek.dorado.i18n.I18NExprInitializer
prepareCall(String) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareCall(String, int, int) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareCall(String, int, int, int) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareData() - Method in interface com.bstek.dorado.view.ViewModel
准备为服务对象提供数据
prepareData() - Method in class com.bstek.dorado.view.ViewModelSupport
prepareData
prepareData() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
prepareData
prepareInitializers() - Static method in class com.bstek.dorado.common.rtexpr.ExprContextHelper
prepareStatement(String) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareStatement(String, int) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareStatement(String, int, int) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareStatement(String, int, int, int) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareStatement(String, int[]) - Method in class com.bstek.dorado.common.ds.TransConnection
prepareStatement(String, String[]) - Method in class com.bstek.dorado.common.ds.TransConnection
println(String) - Static method in class com.bstek.dorado.common.Console
向系统控制台输出一行信息
processDetailLookup() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
processDetailLookup
processException(Throwable, Action, HttpServletRequest, HttpServletResponse) - Static method in class com.bstek.dorado.action.Controller
处理一个在Action执行过程中发生的异常。
processException(Throwable, Action, HttpServletRequest, HttpServletResponse) - Method in interface com.bstek.dorado.action.ExceptionHandler
处理一个在Action执行过程中发生的异常。
processForward(HttpServletRequest, HttpServletResponse, ActionForward) - Method in class com.bstek.dorado.action.Controller
处理Action的转向。
processForward(ActionForward, HttpServletRequest, HttpServletResponse) - Method in interface com.bstek.dorado.action.ForwardHandler
处理一个ActionForward。
processGlobalException(Throwable, HttpServletRequest, HttpServletResponse) - Method in interface com.bstek.dorado.action.ExceptionHandler
处理一个Action之外的异常，此种异常只会被global单元中配置的ActionException接受。
processLookup() - Method in interface com.bstek.dorado.data.Dataset
处理所有的Lookup数据。
processLookup() - Method in class com.bstek.dorado.data.DatasetAdapter
处理所有的Lookup数据。
processLookup() - Method in class com.bstek.dorado.data.DatasetSupport
处理所有的Lookup数据。
processLookup() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
处理所有的Lookup数据。
properties() - Method in class com.bstek.dorado.data.AbstractField
返回所有元数据的集合对象。
properties() - Method in interface com.bstek.dorado.data.Dataset
与Dataset相关的一组属性值.
properties() - Method in class com.bstek.dorado.data.DatasetAdapter
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

properties() - Method in class com.bstek.dorado.data.DatasetSupport
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

properties() - Method in interface com.bstek.dorado.data.Field
返回所有元数据的集合对象。
properties() - Method in interface com.bstek.dorado.view.ViewModel
属性集合
properties() - Method in class com.bstek.dorado.view.ViewModelSupport
属性集合
properties() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

put(Object, Object) - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
putAll(Map) - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
putElement(FormElement) - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
putElement

Q

QueryCommand - class com.bstek.dorado.view.control.command.QueryCommand.
QueryCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.QueryCommand
构造器
query() - Method in class com.bstek.dorado.data.db.DBStatement
执行一个查询命令并返回第一条记录的值.如果本次查询没有查到任何记录将返回null.
queryForList() - Method in class com.bstek.dorado.data.db.DBStatement
执行一个查询命令并将结果集以java.util.List的形式返回.其中List中的元素是 com.bstek.dorado.utils.variant.VariantSet对象.

R

REJECT_ROLE - Static variable in interface com.bstek.dorado.view.ViewModel
REJECT_ROLE - 系统默认角色，该角色无权使用视图模型中的任何组件
REQUEST - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - Reqeust
REQUEST - Static variable in class com.bstek.dorado.common.scope.Scope
作用域类型 - Reqeust
RPCCommand - class com.bstek.dorado.view.control.command.RPCCommand.
RPCCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.RPCCommand
RPCCommand
RPCHandler - interface com.bstek.dorado.view.rpc.RPCHandler.
来自客户端的远程方法调用的处理类
RPCHelper - class com.bstek.dorado.view.rpc.RPCHelper.
RadioGroup - class com.bstek.dorado.view.control.RadioGroup.
RadioGroup(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.RadioGroup
RadioGroup
RadioGroupFormElement - class com.bstek.dorado.view.control.autoform.RadioGroupFormElement.
RadioGroupFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
构造器
RangeValidator - class com.bstek.dorado.view.data.validate.impl.RangeValidator.
范围校验对象
RangeValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.RangeValidator
ReadRecord - class com.bstek.dorado.data.ReadRecord.
只读的Record
ReadRecord() - Constructor for class com.bstek.dorado.data.ReadRecord
Record - class com.bstek.dorado.data.Record.
记录对象
Record() - Constructor for class com.bstek.dorado.data.Record
构造器
RecordFactory - interface com.bstek.dorado.data.RecordFactory.
Record的创建工厂
RecordFilter - interface com.bstek.dorado.data.RecordFilter.
记录过滤器
RecordFilterFactory - class com.bstek.dorado.data.RecordFilterFactory.
RecordFilterFactory() - Constructor for class com.bstek.dorado.data.RecordFilterFactory
RecordIterator - class com.bstek.dorado.data.RecordIterator.
记录迭代器
RecordIterator(Dataset) - Constructor for class com.bstek.dorado.data.RecordIterator
构造器
RecordListener - interface com.bstek.dorado.data.RecordListener.
Dataset中记录操作的监听器
RecordReference - class com.bstek.dorado.view.data.RecordReference.
RecordReference() - Constructor for class com.bstek.dorado.view.data.RecordReference
RecordReferenceFactory - class com.bstek.dorado.view.data.RecordReferenceFactory.
RecordReferenceFactory() - Constructor for class com.bstek.dorado.view.data.RecordReferenceFactory
RecordSet - class com.bstek.dorado.data.RecordSet.
Record集合对象
RecordSet() - Constructor for class com.bstek.dorado.data.RecordSet
构造器
RecordTreeNode - class com.bstek.dorado.view.control.tree.RecordTreeNode.
RecordTreeNode() - Constructor for class com.bstek.dorado.view.control.tree.RecordTreeNode
构造器。
RecordTreeNode(Record) - Constructor for class com.bstek.dorado.view.control.tree.RecordTreeNode
构造器。
RecordWrapper - class com.bstek.dorado.data.RecordWrapper.
RecordSet使用的记录包装器
RecordWrapper(Record) - Constructor for class com.bstek.dorado.data.RecordWrapper
构造器
RecursiveTreeLevel - class com.bstek.dorado.view.control.tree.RecursiveTreeLevel.
RecursiveTreeLevel() - Constructor for class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
RequestCommand - class com.bstek.dorado.view.control.command.RequestCommand.
RequestCommand对象
RequestCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.RequestCommand
构造器
RequestContextMap - class com.bstek.dorado.common.rtexpr.impl.RequestContextMap.
RequestContextMap(HttpServletRequest) - Constructor for class com.bstek.dorado.common.rtexpr.impl.RequestContextMap
RequestContextMap
RequestHelper - class com.bstek.dorado.utils.http.RequestHelper.
用于简化ServletRequest访问的工具类.
RequestHelper(ServletRequest) - Constructor for class com.bstek.dorado.utils.http.RequestHelper
RequestHelper
RequiredValidator - class com.bstek.dorado.view.data.validate.impl.RequiredValidator.
必需类型校验对象
RequiredValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.RequiredValidator
ResourceBundleContextMap - class com.bstek.dorado.common.rtexpr.impl.ResourceBundleContextMap.
ResourceBundleContextMap(ResourceBundle) - Constructor for class com.bstek.dorado.common.rtexpr.impl.ResourceBundleContextMap
ResourceBundleContextMap
ResourceFileLoader - class com.bstek.dorado.common.fileloader.ResourceFileLoader.
资源文件加载器
ResourceFileLoader(String) - Constructor for class com.bstek.dorado.common.fileloader.ResourceFileLoader
ResourceFileLoader
ResourceManager - class com.bstek.dorado.i18n.ResourceManager.
国际化资源的管理对象
ResourceManagerContextMap - class com.bstek.dorado.i18n.ResourceManagerContextMap.
ResourceManagerContextMap(DoradoContext, ResourceManager) - Constructor for class com.bstek.dorado.i18n.ResourceManagerContextMap
ResponseUtil - class com.bstek.dorado.utils.http.ResponseUtil.
与Response处理相关的工具类
rebuild() - Method in class com.bstek.dorado.data.Index
重建本索引
recordIterator() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset中所有Record的迭代器。
recordIterator() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

recordIterator() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

recordIterator() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

recordSet() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset的Record集合对象
recordSet() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset的Record集合对象
recordSet() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset的Record集合对象
recordSet() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset的Record集合对象
recordToDO(Record, Object) - Static method in class com.bstek.dorado.data.DOUtils
将给定的记录中包含的数据设置到给定的对象当中.
recursiveKeyFields() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回RecursiveKey字段名称数组,应用与父子递归表
recursiveKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回RecursiveKey字段名称数组，一般应用与父子递归表。
recursiveKeyParameters() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回RecursiveKey参数组,应用与父子递归表
recursiveKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回RecursiveKey参数数组，一般应用与父子递归表。
registerContext(DoradoContext) - Static method in class com.bstek.dorado.common.DoradoContext
在当前的线程中注册一个context对象
registerDetailLink(MasterDetailLink) - Method in interface com.bstek.dorado.view.data.ViewDataset
注册一个关联关系的对象。
registerDetailLink(MasterDetailLink) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
注册一个关联关系的对象。
releaseSavepoint(Savepoint) - Method in class com.bstek.dorado.common.ds.TransConnection
remove(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
remove(String) - Method in class com.bstek.dorado.data.ParameterSet
删除给定键值及其下的数值.
remove() - Method in class com.bstek.dorado.data.RecordIterator
从Dataset删除当前记录.
remove(Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
删除对象列表中的一个对象。
remove(int) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
删除对象列表中的一个对象。
remove(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
删除对象列表中的一个对象。
remove(int) - Method in class com.bstek.dorado.utils.collection.ObjectList
删除对象列表中的一个对象。
remove(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
删除给定索引号及其下的数值.
remove(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
删除给定键值及其下的数值.
removeAll() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
删除对象列表中的所有对象。
removeAll() - Method in class com.bstek.dorado.utils.collection.ObjectList
删除对象列表中的所有对象。
removeAll() - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
删除所有静态下拉框(ListDropDown)的DropDownItem对象。
removeAttribute(int, String) - Method in class com.bstek.dorado.common.DoradoContext
删除指定的作用域中的某个属性.
removeAttribute(int, String) - Method in class com.bstek.dorado.common.DynaDoradoContext
removeAttribute(int, String) - Method in class com.bstek.dorado.common.HttpDoradoContext
删除指定的作用域中的某个属性.
removeAttribute(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
删除一个属性
removeChild(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
删除一个子节点
removeChildren() - Method in interface com.bstek.dorado.utils.xml.XmlNode
删除所有的子节点
removeControl(String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的Id删除一个控件。
removeControl(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的Id删除一个控件。
removeDataset(String) - Method in interface com.bstek.dorado.view.ViewModel
根据Id删除一个指定的数据集。
removeDataset(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据Id删除一个指定的数据集。
removeDatasetListener(DatasetListener) - Method in interface com.bstek.dorado.data.Dataset
删除一个DatasetEvent的事件监听器
removeDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetAdapter
删除一个DatasetEvent的事件监听器
removeDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetSupport
删除一个DatasetEvent的事件监听器
removeDatasetListener(DatasetListener) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
删除一个DatasetEvent的事件监听器
removeEventHandler(String) - Method in interface com.bstek.dorado.view.Component
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in interface com.bstek.dorado.view.EventSupported
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.control.AbstractControl
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.control.table.EditableColumnGroup
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
removeEventHandler
removeEventHandler(String) - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
根据指定的名称删除一个事件处理对象。
removeFromParent() - Method in interface com.bstek.dorado.utils.xml.XmlNode
removeFromParent
removeItem(int) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定索引值删除静态下拉框(ListDropDown)的一个DropDownItem对象。
removeRecord(Record) - Method in class com.bstek.dorado.data.RecordSet
删除一条记录
removeRecordListener(RecordListener) - Method in interface com.bstek.dorado.data.Dataset
删除一个RecordtListener的事件监听器
removeRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetAdapter
删除一个RecordtListener的事件监听器
removeRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetSupport
删除一个RecordtListener的事件监听器
removeTransConnectionListener(TransConnectionListener) - Method in class com.bstek.dorado.common.ds.TransConnection
removeValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewBaseField
删除一个字段的校验器(Validator)。
removeValidator(Validator) - Method in interface com.bstek.dorado.view.data.ViewField
删除一个字段的校验器(Validator)。
removeValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewLookupField
删除一个字段的校验器(Validator)。
requestRef - Variable in class com.bstek.dorado.common.HttpDoradoContext
reset() - Method in class com.bstek.dorado.data._MockDatasetListener
reset() - Method in class com.bstek.dorado.data._MockRecordListener
resetRecordsState() - Method in interface com.bstek.dorado.data.Dataset
重置所有的记录状态
resetRecordsState() - Method in class com.bstek.dorado.data.DatasetAdapter
重置所有的记录状态
resetRecordsState() - Method in class com.bstek.dorado.data.DatasetSupport
重置所有的记录状态
retrieveRecord(UpdateSqlInfo, Record, PreparedStatement) - Method in class com.bstek.dorado.data.db.DBDataset
从数据库中提取一条记录的信息
rollback() - Method in class com.bstek.dorado.common.JDBCTransaction
rollback() - Method in interface com.bstek.dorado.common.Transaction
回滚当前事务
rollback() - Method in class com.bstek.dorado.common.ds.TransConnection
rollback(Savepoint) - Method in class com.bstek.dorado.common.ds.TransConnection
root - Variable in class com.bstek.dorado.common.fileloader.FileLoader
根路径.所以该FileLoader所能读取的文件都位于该路径之下.

S

SCHEDULE - Static variable in class com.bstek.dorado.view.control.Calendar
SCROLLMODE_RECORD - Static variable in class com.bstek.dorado.view.control.table.DataTable
SCROLLMODE_RECORD
SCROLLMODE_SIMPLE - Static variable in class com.bstek.dorado.view.control.table.DataTable
SCROLLMODE_SIMPLE
SELECT - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - SELECT
SELECTED - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 只提交Dataset中所有通过Select复选框选中的记录。
SELF - Static variable in class com.bstek.dorado.view.control.command.Frame
命令(Command)提交后在自身浏览器窗口中打开新页面。
SEPARATOR - Static variable in class com.bstek.dorado.common.HashKeyUtil
SEPARATOR
SESSION - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - Session
SESSION - Static variable in class com.bstek.dorado.common.scope.Scope
作用域类型 - Session
SHORT - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - short型。
SHORT_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - short型。
SIMPLE - Static variable in class com.bstek.dorado.view.control.Calendar
STATE_DELETED - Static variable in class com.bstek.dorado.data.DOSet
已删除
STATE_DELETED - Static variable in class com.bstek.dorado.data.Record
记录状态 - 已删除。
STATE_DESIGN - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为设计器服务
STATE_INIT - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 初始化
STATE_LOADING - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 加载数据
STATE_MODIFIED - Static variable in class com.bstek.dorado.data.DOSet
已更新
STATE_MODIFIED - Static variable in class com.bstek.dorado.data.Record
记录状态 - 已更新。
STATE_NEW - Static variable in class com.bstek.dorado.data.DOSet
新增
STATE_NEW - Static variable in class com.bstek.dorado.data.Record
记录状态 - 新增。
STATE_NONE - Static variable in class com.bstek.dorado.data.DOSet
无状态
STATE_NONE - Static variable in class com.bstek.dorado.data.Record
记录状态 - 无状态。
STATE_READY - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 已就绪
STATE_RESOLVING - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 更新数据
STATE_SERVICE - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为远程过程调用等服务
STATE_UPDATING - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为一个视图更新数据时服务
STATE_VIEW - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为一个视图服务
STRING - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - String型。
STRING_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称名称 - String型。
SUM - Static variable in class com.bstek.dorado.data.db.AggregateMode
对字段求和
SafeCode - class com.bstek.dorado.utils.codec.SafeCode.
用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。
SafeCode() - Constructor for class com.bstek.dorado.utils.codec.SafeCode
Scope - class com.bstek.dorado.common.scope.Scope.
对象的作用域类型
ScopeHelper - class com.bstek.dorado.common.scope.ScopeHelper.
对象的作用域类型的工具类
ScrollBar - class com.bstek.dorado.view.control.ScrollBar.
ScrollBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.ScrollBar
ScrollBar
ServletContextMap - class com.bstek.dorado.common.rtexpr.impl.ServletContextMap.
ServletContextMap(ServletContext) - Constructor for class com.bstek.dorado.common.rtexpr.impl.ServletContextMap
ServletContextMap
SessionContextMap - class com.bstek.dorado.common.rtexpr.impl.SessionContextMap.
SessionContextMap(HttpSession) - Constructor for class com.bstek.dorado.common.rtexpr.impl.SessionContextMap
SessionContextMap
Setting - class com.bstek.dorado.common.Setting.
用于保存Dorado的Server运行时属性的对象.此处的配置信息均是在dorado的home/setting.xml 中设定的.
SimpleDataControl - class com.bstek.dorado.view.control.SimpleDataControl.
简单数据控件对象
SimpleDataControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.SimpleDataControl
构造器
SimpleDropDown - class com.bstek.dorado.view.control.dropdown.SimpleDropDown.
SimpleDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.SimpleDropDown
SimpleTreeLevel - class com.bstek.dorado.view.control.tree.SimpleTreeLevel.
SimpleTreeLevel() - Constructor for class com.bstek.dorado.view.control.tree.SimpleTreeLevel
SortRule - class com.bstek.dorado.data.db.SortRule.
用于描述AutoSqlDataset的SORT BY片断的排序规则对象
SortRule(String) - Constructor for class com.bstek.dorado.data.db.SortRule
构造器 注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此对象的table属性.
Span - class com.bstek.dorado.view.control.Span.
控件的辅助类
Span(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Span
构造器
SplitPanel - class com.bstek.dorado.view.control.SplitPanel.
分割栏对象。
SplitPanel(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.SplitPanel
构造器
SqlDataset - class com.bstek.dorado.data.db.SqlDataset.
基于SQL的Dataset.
SqlDataset() - Constructor for class com.bstek.dorado.data.db.SqlDataset
构造器
SqlDataset(String) - Constructor for class com.bstek.dorado.data.db.SqlDataset
构造器
SqlDataset(String, String) - Constructor for class com.bstek.dorado.data.db.SqlDataset
构造器
SqlMatchRule - class com.bstek.dorado.data.db.SqlMatchRule.
用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.
SqlMatchRule() - Constructor for class com.bstek.dorado.data.db.SqlMatchRule
构造器
SqlMatchRule(String) - Constructor for class com.bstek.dorado.data.db.SqlMatchRule
构造器
StaticColumn - class com.bstek.dorado.view.control.table.StaticColumn.
列的辅助类
StaticColumn(String) - Constructor for class com.bstek.dorado.view.control.table.StaticColumn
构造器
StaticColumnGroup - class com.bstek.dorado.view.control.table.StaticColumnGroup.
StaticColumnGroup(String) - Constructor for class com.bstek.dorado.view.control.table.StaticColumnGroup
StaticTable - class com.bstek.dorado.view.control.table.StaticTable.
静态表格类
StaticTable(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.table.StaticTable
StringHelper - class com.bstek.dorado.utils.StringHelper.
String的一些辅助操作
SubUnit - class com.bstek.dorado.action.mapping.SubUnit.
子配置单元的Mapping配置信息。
SubUnit(String) - Constructor for class com.bstek.dorado.action.mapping.SubUnit
构造器
SubWindow - class com.bstek.dorado.view.control.SubWindow.
SubWindow(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.SubWindow
SubWindow
SubmitFormDatasetCommand - class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand.
SubmitFormDatasetCommand对象
SubmitFormDatasetCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
构造器
SynchroTimer - class com.bstek.dorado.utils.SynchroTimer.
基于线程的定时器
SynchroTimer(long) - Constructor for class com.bstek.dorado.utils.SynchroTimer
构造器
SystemVariable - class com.bstek.dorado.utils.SystemVariable.
用于读取系统环境变量。
SystemVariable() - Constructor for class com.bstek.dorado.utils.SystemVariable
创建读取系统环境变量的对象。
save() - Static method in class com.bstek.dorado.common.Setting
保存配置。
save() - Static method in class com.bstek.dorado.common.UserConfig
保存配置。
set(String, Object) - Method in class com.bstek.dorado.data.Record
set
set(int, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
设置对象列表中的一个对象
set(int, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
设置对象列表中的一个对象
setAction(String) - Method in class com.bstek.dorado.view.control.command.RPCCommand
setAction
setAction(String) - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
设定提交表单数据集命令(SubmitFormDatasetCommand)对象请求的动作(Action)值。
setAggregate(String) - Method in class com.bstek.dorado.data.db.AutoDBField
设置AutoSqlDataset中Field的合计模式.
setAlign(String) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置列的水平对齐方式(Align)。
setAllowPushDown(boolean) - Method in class com.bstek.dorado.view.control.Button
设置按钮(Button)是否允许按钮被按下。
setAlwaysPerform(boolean) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
设置是否总是提交更新命令(UpdateCommand)。
setAsync(boolean) - Method in class com.bstek.dorado.view.control.command.RPCCommand
setAsync
setAsync(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定是否启用客户端的异步数据装载功能.
setAsync(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定是否启用客户端的异步数据装载功能.
setAttribute(int, String, Object) - Method in class com.bstek.dorado.common.DoradoContext
为指定的作用域中的某个属性设定一个值.
setAttribute(int, String, Object) - Method in class com.bstek.dorado.common.DynaDoradoContext
setAttribute(int, String, Object) - Method in class com.bstek.dorado.common.HttpDoradoContext
为指定的作用域中的某个属性设定一个值.
setAttribute(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
设置一个属性的值
setAttributeBoolean(String, boolean) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型设置一个属性的值
setAttributeBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型设置一个属性的值
setAttributeDouble(String, double) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型设置一个属性的值
setAttributeDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型设置一个属性的值
setAttributeFloat(String, float) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型设置一个属性的值
setAttributeFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型设置一个属性的值
setAttributeInt(String, int) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型设置一个属性的值
setAttributeInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型设置一个属性的值
setAttributeLong(String, long) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型设置一个属性的值
setAttributeLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型设置一个属性的值
setAutoCommit(boolean) - Method in class com.bstek.dorado.common.ds.TransConnection
setAutoCreateDiv(boolean) - Method in class com.bstek.dorado.view.control.tabset.Tab
setAutoCreateDiv
setAutoCreateFields(boolean) - Method in interface com.bstek.dorado.data.Dataset
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
setAutoCreateFields(boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
setAutoCreateFields(boolean) - Method in class com.bstek.dorado.data.DatasetSupport
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
setAutoDropDown(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
设定当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。
setAutoLoadPage(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定是否启用客户端Dataset的自动状态数据功能。
setAutoLoadPage(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定是否启用客户端Dataset的自动状态数据功能。
setAutoLoadPage(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定是否启用客户端Dataset的自动状态数据功能。
setAutoSyncRecordWithDragging(boolean) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
在节点拖动时，设置是否允许节点所属的记录自动同步移动。
setBigChange(int) - Method in class com.bstek.dorado.view.control.ScrollBar
setBigChange
setBigDecimal(int, BigDecimal) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.data.Record
设定记录中某个BigDecimal类型的字段值。
setBigDecimal(BigDecimal) - Method in class com.bstek.dorado.utils.variant.Variant
设置BigDecimal类型的数据
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置BigDecimal类型的数据
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置BigDecimal类型的数据
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Static method in class com.bstek.dorado.common.Setting
设置一个Boolean型的配置信息
setBoolean(String, boolean) - Static method in class com.bstek.dorado.common.UserConfig
设置一个Boolean型的配置信息
setBoolean(int, boolean) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型设置当前记录中某字段的值。
setBoolean(int, boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型设置当前记录中某字段的值。
setBoolean(int, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.data.Record
设定记录中某个boolean类型的字段值。
setBoolean(boolean) - Method in class com.bstek.dorado.utils.variant.Variant
设置boolean类型的数据
setBoolean(int, boolean) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置boolean类型的数据
setBoolean(String, boolean) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置boolean类型的数据
setBoolean(int, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型设置当前记录中某字段的值。
setButtonAppend(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“追加一条记录”(Append)按钮的显示状态。
setButtonCancel(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“撤销对当前记录修改”(Cancel)按钮的显示状态。
setButtonDelete(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“删除一条记录”(Delete)按钮的显示状态。
setButtonInsert(String) - Method in class com.bstek.dorado.view.control.DataPilot
设置“插入一条记录”(Insert)按钮的显示状态。
setButtonMoveFirst(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到第一条”按钮(MoveFirst)的显示状态。
setButtonMoveLast(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到最后一条”按钮(MoveLast)的显示状态。
setButtonMoveNext(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到下一条”按钮(MoveNext)的显示状态。
setButtonMovePrev(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到上一条”按钮(MovePrev)的显示状态。
setButtonNextPage(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到后一页”按钮(NextPage)的显示状态。
setButtonPost(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定(Post)按钮的显示状态。
setButtonPrevPage(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到前一页”按钮(PrevPage)的显示状态。
setByte(int, byte) - Method in interface com.bstek.dorado.data.Dataset
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in interface com.bstek.dorado.data.Dataset
按byte类型设置当前记录中某字段的值。
setByte(int, byte) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型设置当前记录中某字段的值。
setByte(int, byte) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.data.Record
设定记录中某个byte类型的字段值。
setByte(byte) - Method in class com.bstek.dorado.utils.variant.Variant
设置byte类型的数据
setByte(int, byte) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置byte类型的数据
setByte(String, byte) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置byte类型的数据
setByte(int, byte) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型设置当前记录中某字段的值。
setCachable(boolean) - Method in interface com.bstek.dorado.view.control.dropdown.CachableDropDown
设置该下拉框(DropDown)是否支持缓存。
setCachable(boolean) - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
设置该下拉框(DropDown)是否支持缓存。
setCachable(boolean) - Method in class com.bstek.dorado.view.control.tabset.FrameTab
设置是否允许缓存Frame内容
setCalendarType(String) - Method in class com.bstek.dorado.view.control.Calendar
设置日历类型。
setCatalog(String) - Method in class com.bstek.dorado.common.ds.TransConnection
setCenter(boolean) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架新页面是否位于中心位置。
setCharSet(String) - Method in class com.bstek.dorado.common.ds.DataSourceConfig
setCharSet
setCheckable(boolean) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定树节点(TreeNode)前面是否有复选框可以被选择。
setCheckable(boolean) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
设定用户是否可以通过复选框选择节点。
setChecked(boolean) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点(TreeNode)是否已经被选中。
setChildContent(String, String) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
setChildContent
setChildContent(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setChildContent
setChildContentBoolean(String, boolean) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按boolean类型设置子节点的内容
setChildContentBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型设置子节点的内容
setChildContentDouble(String, double) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按double类型设置子节点的内容
setChildContentDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型设置子节点的内容
setChildContentFloat(String, float) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按float类型设置子节点的内容
setChildContentFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型设置子节点的内容
setChildContentInt(String, int) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按int类型设置子节点的内容
setChildContentInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型设置子节点的内容
setChildContentLong(String, long) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
按long类型设置子节点的内容
setChildContentLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型设置子节点的内容
setClazz(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置Controller的类名
setClazz(String) - Method in class com.bstek.dorado.view.ViewModelCacheInfo
设定视图模型实现类
setClazz(String) - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
设定校验信息的实现类名
setClearSelectionOnSuccess(boolean) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设置当命令(Command)提交成功后是否清除选中的Dataset记录。
setClientType(String) - Method in interface com.bstek.dorado.view.ViewModel
setClientType
setClientType(String) - Method in class com.bstek.dorado.view.ViewModelCacheInfo
setClientType
setClientType(String) - Method in class com.bstek.dorado.view.ViewModelSupport
setClientType
setCol(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设置指定的列为当前列。
setColSpan(int) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置AutoForm的该元素(Element)的列跨度(colSpan)属性值，该属性类Table的ColSpan属性。
setColSpan(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设置组(Group)中当前元素所占的列的跨度数。
setColumnCount(int) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置该Group在页面上显示时每行要显示的列数。
setCommand(String) - Method in class com.bstek.dorado.view.control.Button
设置按钮(Button)触发的操作命令(Command)。
setCommand(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项对应的命令对象
setConcreteValidator(String) - Method in class com.bstek.dorado.view.data.validate.impl.CustomValidator
设定具体的校验器格式
setConditionDataset(String) - Method in class com.bstek.dorado.view.control.command.QueryCommand
setConfig(ControllerConfig) - Method in class com.bstek.dorado.action.Controller
设定Controller对应的Mapping配置信息。
setConfig(ModuleConfig) - Method in interface com.bstek.dorado.module.Module
设定Module的配置对象
setConfig(ModuleConfig) - Method in class com.bstek.dorado.module.ModuleSupport
设定Module的配置对象
setConfig(ViewModelConfig) - Method in interface com.bstek.dorado.view.ViewModel
设定视图配置对象
setConfig(String) - Method in class com.bstek.dorado.view.ViewModelCacheInfo
设定配置文件名
setConfig(ViewModelConfig) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图配置对象
setConfigName(String) - Method in interface com.bstek.dorado.view.ViewModel
设定视图模型配置名
setConfigName(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图模型配置名
setConfirmCancel(boolean) - Method in class com.bstek.dorado.view.control.DataPilot
设定是否提示用户确认取消操作(ConfirmCancel)。
setConfirmCancel(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置用户在客户端对记录进行取消操作时是否有确认提示。
setConfirmDelete(boolean) - Method in class com.bstek.dorado.view.control.DataPilot
设定是否提示用户确认删除操作(ConfirmDelete)。
setConfirmDelete(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置用户在客户端删除记录时是否有确认提示。
setContent(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContent
setContentBoolean(boolean) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
setContentBoolean
setContentBoolean(boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentBoolean
setContentDouble(double) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
setContentDouble
setContentDouble(double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentDouble
setContentFloat(float) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
setContentFloat
setContentFloat(float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentFloat
setContentInt(int) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
setContentInt
setContentInt(int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentInt
setContentLong(long) - Method in class com.bstek.dorado.utils.xml.AbstractXmlNode
setContentLong
setContentLong(long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentLong
setContextAttribute(String) - Method in class com.bstek.dorado.view.data.DODataset
设置与DODataset进行数据交换的上下文属性名.
setContextRelative(boolean) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设置此对象的Path属性，所描述的URL是否是一个相对路径，此属性的默认值是true。
setControlAlign(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置AutoForm中Control控件元素的水平位置(controlAlign)属性值。
setControlId(String) - Method in class com.bstek.dorado.view.control.autoform.CustomFormElement
为控件(Control)设定一个唯一标识符(Id)。
setControlVAlign(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置AutoForm中Control控件元素的垂直位置(controlVAlign)属性值。
setController(ControllerConfig) - Method in class com.bstek.dorado.action.mapping.ActionConfig
setCount(int) - Method in class com.bstek.dorado.utils._MockSynchroTimer
setCountSql(String) - Method in class com.bstek.dorado.data.db.SqlDataset
设置统计总记录数的SQL命令。
setCurrent(Record) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录对象。
setCurrent(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录对象。
setCurrent(RecordWrapper) - Method in class com.bstek.dorado.data.DatasetSupport
{@inheritDoc}
setCurrent(Record) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录对象。
setCurrent(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录对象。
setDO(Object) - Method in class com.bstek.dorado.data.DOWrapper
setDataSource(String) - Method in class com.bstek.dorado.data.db.DBDataset
设置Dataset对应的数据源名称.
setDataSource(String) - Method in class com.bstek.dorado.data.db.DBStatement
设置DBStatement使用的数据源的名称.如果此属性未指定则表示将使用dorado的默认数据源.
setDataType(int) - Method in class com.bstek.dorado.data.AbstractField
设定字段的数据类型。
setDataType(String) - Method in class com.bstek.dorado.data.AbstractField
设定字段的数据类型。
setDataType(int) - Method in interface com.bstek.dorado.data.Field
设定字段的数据类型。
setDataType(String) - Method in interface com.bstek.dorado.data.Field
设定字段的数据类型。
setDataType(int) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置返回匹配值的数据类型.
setDataType(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置返回匹配值的数据类型.
setDataType(int) - Method in class com.bstek.dorado.utils.variant.Variant
setDataType
setDataType(String) - Method in class com.bstek.dorado.utils.variant.Variant
setDataType
setDataType(int, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置默认数据类型
setDataType(int, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置默认数据类型
setDataType(String, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置默认数据类型
setDataType(String, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置默认数据类型
setDataType(int) - Method in class com.bstek.dorado.view.control.TextEditor
设定编辑的数据类型。
setDataType(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定编辑的数据类型。
setDataset(Dataset) - Method in class com.bstek.dorado.data.Record
设定该记录（Record）对象所属的是哪个数据集（Dataset）。
setDataset(Dataset) - Method in class com.bstek.dorado.data._DatasetEvent
setDataset(String) - Method in class com.bstek.dorado.view.control.DataControl
设定数据控件(DataControl)与指定的数据集(Dataset)绑定。
setDataset(String) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设定Command对象要提交的Dataset对象。
setDataset(String) - Method in class com.bstek.dorado.view.control.command.RequestCommand
设置请求命令(RequestCommand)提交的Dataset对象。
setDataset(String) - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
设定提交表单数据集命令(SubmitFormDatasetCommand)对象提交的Dataset对象。
setDataset(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
根据指定的数据集(Dataset)名称，设定一个为数据集下拉框(DatasetDropDown)提供数据的数据集(Dataset)对象。
setDataset(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
设定为TreeLevel提供数据的数据集(Dataset)。
setDate(String, Date) - Static method in class com.bstek.dorado.common.Setting
设定一个Date型的配置信息
setDate(String, Date) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Date型的配置信息
setDate(int, Date) - Method in interface com.bstek.dorado.data.Dataset
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in interface com.bstek.dorado.data.Dataset
按date类型设置当前记录中某字段的值。
setDate(int, Date) - Method in class com.bstek.dorado.data.DatasetAdapter
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.data.DatasetAdapter
按date类型设置当前记录中某字段的值。
setDate(int, Date) - Method in class com.bstek.dorado.data.DatasetSupport
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.data.DatasetSupport
按date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.data.Record
设定记录中某个date类型的字段值。
setDate(Date) - Method in class com.bstek.dorado.utils.variant.Variant
设置Date类型的数据
setDate(int, Date) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置Date类型的数据
setDate(String, Date) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置Date类型的数据
setDate(Date) - Method in class com.bstek.dorado.view.control.Calendar
设置日历默认的时间。
setDate(int, Date) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按date类型设置当前记录中某字段的值。
setDefaultControlWidth(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中各个元素统一的缺省宽度值。
setDefaultControlWidth(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置AutoForm中各个控件对象的缺省所占的宽度。
setDefaultElementMargin(int) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中每个元素(Element)缺省的空白边缘(Margin)值。
setDefaultLabelWidth(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的元素(Element)的标题(Label)的缺省宽度值。
setDefaultLabelWidth(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置AutoForm中的各个元素标题(Label)的缺省宽度值。
setDefaultLocale(DoradoContext, Locale) - Method in class com.bstek.dorado.i18n.ResourceManager
设置当前会话的默认的地区与语种.
setDefaultLocale(DoradoContext, int, Locale) - Method in class com.bstek.dorado.i18n.ResourceManager
设置上下文对象中某一作用域的默认的地区与语种.
setDefaultValue(Object) - Method in class com.bstek.dorado.data.AbstractField
设定字段缺省值。
setDefaultValue(Object) - Method in interface com.bstek.dorado.data.Field
设定字段缺省值。
setDeleteSelectionOnSuccess(boolean) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设置命令(Command)对象提交成功后是否删除客户端Dataset中已经选中的记录。
setDeleteSql(String) - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
设置删除记录的SQL命令。
setDeleted(boolean) - Method in class com.bstek.dorado.data.Record
设置当前记录的状态为删除状态。
setDescent(boolean) - Method in class com.bstek.dorado.data.db.SortRule
设定是否按照降序进行排序.
setDescription(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
Action的描述信息。
setDescription(String) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设定描述信息。
setDescription(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的描述信息。
setDescription(String) - Method in class com.bstek.dorado.action.mapping.Unit
Unit的描述信息。
setDetailDataset(ViewDataset) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定从数据集
setDetailKeyFields(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定从数据集中与主数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
setDetailKeyParameters(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
setDetailKeyParameters
setDetailKeyParameters(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定从数据集中与主数据集关联的参数.如果此处需要描述多个参数,可以利用","分隔各参数名.
setDetailProperty(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
setDetailRecords(String, RecordSet) - Method in class com.bstek.dorado.data.Record
setDetailRecords
setDialect(String) - Method in class com.bstek.dorado.common.ds.DataSourceConfig
setDialect
setDialect(Dialect) - Method in class com.bstek.dorado.data.db.DBDataset
设置此Dataset内部使用的数据库方言的实现类.
setDisableIcon(String) - Method in class com.bstek.dorado.view.control.MenuItem
设置菜单项(MenuItem)失效时的链接图标(Icon)URL。
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.Button
设置按钮是否可用。
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项(MenuItem)是否无效。
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设置当前标签项(Tab)是否被禁止，被禁止的标签项上所有的元素都无法操作。
setDouble(String, double) - Static method in class com.bstek.dorado.common.Setting
设定一个Double型的配置信息
setDouble(String, double) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Double型的配置信息
setDouble(int, double) - Method in interface com.bstek.dorado.data.Dataset
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in interface com.bstek.dorado.data.Dataset
按double类型设置当前记录中某字段的值。
setDouble(int, double) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型设置当前记录中某字段的值。
setDouble(int, double) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.data.Record
设定记录中某个Double类型的字段值。
setDouble(double) - Method in class com.bstek.dorado.utils.variant.Variant
设置double类型的数据
setDouble(int, double) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置double类型的数据
setDouble(String, double) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置double类型的数据
setDouble(int, double) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型设置当前记录中某字段的值。
setDown(boolean) - Method in class com.bstek.dorado.view.control.Button
设定按钮(Button)在初始化的时候是否是被压下的状态。
setDragMode(String) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)的拖动类型。
setDraggable(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)是否允许拖动改变位置。
setDraggable(boolean) - Method in class com.bstek.dorado.view.control.tree.Tree
设置树(Tree)的节点是否允许拖动。
setDriver(String) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setDriver
setDropDown(String) - Method in class com.bstek.dorado.view.control.RadioGroup
设定文本编辑器(TextEditor)相关联的下拉框(DropDown)。
setDropDown(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定文本编辑器(TextEditor)相关联的下拉框(DropDown)。
setDropDown(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
根据指定的下拉框与某个列(Column)关联起来，用来显示到页面上。
setDropDown(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定字段关联的下拉框对象(DropDown)。
setDropDown(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定字段关联的下拉框对象(DropDown)。
setDropDown(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定字段关联的下拉框对象(DropDown)。
setEditable(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格(DataTable)是否允许用户编辑。
setEditorType(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定文本编辑器(TextEditor)的编辑器类型(EditorType)。
setEditorType(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定与列(Column)相关联的被用来显示到页面上的编辑框(Editor)的类型。
setEditorType(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定与该字段关联的编辑器的类型。
setEditorType(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定与该字段关联的编辑器的类型。
setEditorType(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定与该字段关联的编辑器的类型。
setElement(FormElement) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设定AutoForm对象的元素
setElementMargin(int) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置AutoForm中元素各个(Element)缺省的边缘空白(Margin)属性值。
setEnabled(boolean) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置整个匹配规则是否有效。
setEnabled(boolean) - Method in class com.bstek.dorado.data.db.SortRule
设置该排序规则是否有效.
setError(Throwable) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
设定本次远程调用将要返回给客户端的异常.
setError(Throwable) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
设定本次远程调用将要返回给客户端的异常.
setErrorMessage(String) - Method in interface com.bstek.dorado.view.data.validate.Validator
设定一个错误信息(ErrorMessage)。
setErrorMessage(String) - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
设定一个错误信息(ErrorMessage)。
setErrorMessage(String) - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
设定一个对应的ErrorMessage。
setEscapeEnabled(boolean) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置是否要启用本匹配规则上的可逃逸功能.
setEscapeValue(String) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置逃逸值.
setExpandLevel(int) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
设置树默认展开到的层次
setExpandLevel(int) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
设置树默认展开到的层次
setExpanded(boolean) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设置该节点(TreeNode)在初始化显示树(Tree)时是否被打开。
setExpanded(boolean) - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
设置当在页面上显示树(Tree)时树的该层节点是否是被打开的状态。
setExpandedIcon(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点(TreeNode)的展开图标文件(ExpandedIcon)。
setExpandedIcon(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
设定TreeLevel的展开时的图标文件(ExpandedIcon)的URL。
setExpandedIconField(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
设定TreeLevel的展开图标字段标题(ExpandedIconField)从数据集的哪个字段获取信息。
setField(String) - Method in class com.bstek.dorado.view.control.SimpleDataControl
设定一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。
setField(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置该元素与数据源Dataset中的哪个字段建立对应关系获取数据。
setField(String) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置表格列(Column)的数据来自于数据集的哪个字段(Field)。
setFieldName(String) - Method in class com.bstek.dorado.data._DatasetEvent
setFieldName(String) - Method in class com.bstek.dorado.data._RecordEvent
setFieldSet(FieldSet) - Method in interface com.bstek.dorado.data.Dataset
设置Dataset的Field集合对象
setFieldSet(FieldSet) - Method in class com.bstek.dorado.data.DatasetAdapter
设置Dataset的Field集合对象
setFieldSet(FieldSet) - Method in class com.bstek.dorado.data.DatasetSupport
设置Dataset的Field集合对象
setFieldSet(FieldSet) - Method in class com.bstek.dorado.data.Record
设定该记录的所有字段的集合对象。
setFieldSet(FieldSet) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置Dataset的Field集合对象
setFile(String) - Method in class com.bstek.dorado.common.fileloader.FileLoader
设置要打开的文件。
setFilterOnOpen(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设置是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。
setFilterParameter(String) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设置用于作为筛选参数的Dataset参数名.
setFirstGroupAsHeader(boolean) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的第一个组(Group)是否在页面上单独占用一行作为头行，而不受AutoForm布局方式(Layout)的影响。
setFitWidth(boolean) - Method in class com.bstek.dorado.view.control.MenuBar
设置宽度是否自适应。
setFixed(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
设定是否禁止用户不通过下拉选择而直接输入。
setFixedColumn(int) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格(DataTable)中被锁定列的个数
setFloat(String, float) - Static method in class com.bstek.dorado.common.Setting
设定一个Float型的配置信息
setFloat(String, float) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Float型的配置信息
setFloat(int, float) - Method in interface com.bstek.dorado.data.Dataset
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in interface com.bstek.dorado.data.Dataset
按float类型设置当前记录中某字段的值。
setFloat(int, float) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型设置当前记录中某字段的值。
setFloat(int, float) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.data.Record
设定记录中某个float类型的字段值。
setFloat(float) - Method in class com.bstek.dorado.utils.variant.Variant
设置float类型的数据
setFloat(int, float) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置float类型的数据
setFloat(String, float) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置float类型的数据
setFloat(int, float) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型设置当前记录中某字段的值。
setFlushDataOnSuccess(boolean) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设置当命令(Command)提交成功后是否刷新客户端Dataset中的数据。
setFooterHeight(int) - Method in class com.bstek.dorado.view.control.table.Table
设置合计栏位的高度
setFooterValue(String) - Method in class com.bstek.dorado.view.control.table.DataColumn
setFooterValue
setFormat(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设置该字断相关的格式化串格式。
setFormat(String) - Method in interface com.bstek.dorado.view.data.ViewField
设置该字断相关的格式化串格式。
setFormat(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设置该字断相关的格式化串格式。
setGlobalUnit(GlobalUnit) - Method in class com.bstek.dorado.action.mapping.Mapping
设定Global单元对象。
setGroup(boolean) - Method in class com.bstek.dorado.data.db.AutoDBField
设置AutoSqlDataset查询SQL的group子句中是否包含该字段.
setHasChild(boolean) - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
设定节点是否有子节点。
setHasChild(boolean) - Method in class com.bstek.dorado.view.control.tree.TreeNode
设定当前树节点(TreeNode)是否有子节点。
setHeaderClickable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设置数据表格的该列标题是否支持单击操作。
setHeaderClickable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumnGroup
设置数据表格的该列标题是否支持单击操作。
setHeaderHeight(int) - Method in class com.bstek.dorado.view.control.table.Table
设置表格列标题的高度
setHeight(String) - Method in interface com.bstek.dorado.view.control.Placeable
setHeight
setHeight(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
setHeight
setHeight(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
setHeight
setHeight(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设定AutoForm的高度。
setHeight(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组(Group)的高度值。
setHeight(int) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架中新页面的高度(Height)值。
setHeight(int) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
setHeight
setHeight(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定多页标签(Tab)的高度(Height)。
setHighlightSelection(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置通过复选框选中记录后是否将记录进行高亮显示。
setHighlightSelection(boolean) - Method in class com.bstek.dorado.view.control.tree.Tree
设置通过复选框选中记录后是否将记录进行高亮显示。
setHoldability(int) - Method in class com.bstek.dorado.common.ds.TransConnection
setIcon(String) - Method in class com.bstek.dorado.view.control.MenuItem
设置菜单项(MenuItem)链接图标(Icon)URL。
setIcon(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点(TreeNode)的图标文件(Icon)。
setIcon(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得TreeLevel的图标文件(Icon)的URL。
setIconField(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
设定TreeLevel的图标字段的标题(IconField)从数据集中的哪个字段获取文字描述信息。
setId(String) - Method in interface com.bstek.dorado.data.Dataset
设置Dataset的ID
setId(String) - Method in class com.bstek.dorado.data.DatasetAdapter
设置Dataset的ID
setId(String) - Method in class com.bstek.dorado.data.DatasetSupport
设置Dataset的ID
setIgnored(boolean) - Method in interface com.bstek.dorado.view.Component
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
setIgnored(boolean) - Method in class com.bstek.dorado.view.control.AbstractControl
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
setIgnored(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
setInsertOnEmpty(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定当客户断的Dataset中没有任何记录时是否自动添加一条空记录.
setInsertOnEmpty(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设置需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效.
setInsertSql(String) - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
设置需要插入记录的SQL命令
setInt(String, int) - Static method in class com.bstek.dorado.common.Setting
设定一个Int型的配置信息
setInt(String, int) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Int型的配置信息
setInt(int, int) - Method in interface com.bstek.dorado.data.Dataset
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in interface com.bstek.dorado.data.Dataset
按int类型设置当前记录中某字段的值。
setInt(int, int) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型设置当前记录中某字段的值。
setInt(int, int) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.data.Record
设定记录中某个int类型的字段值。
setInt(int) - Method in class com.bstek.dorado.utils.variant.Variant
设置int类型的数据
setInt(int, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置int类型的数据
setInt(String, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置int类型的数据
setInt(int, int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型设置当前记录中某字段的值。
setJndiName(String) - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
setJndiName
setKeyFields(String) - Method in class com.bstek.dorado.data.LookupField
Dataset与LookupDataset之间的字段匹配关系。
setKeyFields(String) - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset的主表的主键字段.
setKeyFields(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置用于建立关联的关联表中的字段.
setKeyFields(String[]) - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
设置需要更新的表的主键字段，以数组形式返回。
setKind(String) - Method in class com.bstek.dorado.data.db.AndOrMatchRule
设置该逻辑连接符的类型.
setLabel(String) - Method in class com.bstek.dorado.data.AbstractField
设定字段列的标题。
setLabel(String) - Method in interface com.bstek.dorado.data.Field
设定字段列的标题。
setLabel(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项(MenuItem)标题。
setLabel(String) - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
设置下拉框(DropDown)对应的字段(Field)的标题(Label)。
setLabel(String) - Method in class com.bstek.dorado.view.control.table.Column
设置列(Column)的标题(Label)。
setLabel(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定多页标签(Tab)的标题(Label)。
setLabel(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点(TreeNode)的标题(Label)。
setLabelAlign(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置与该元素对应的数据源Dataset中字段(Field)的标题(Label)的水平位置(labelAlign)属性值。
setLabelField(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
setLabelField
setLabelField(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
设定TreeLevel对应的数据集的字段(LabelField)。
setLabelVAlign(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置与该元素对应的数据源Dataset中字段(Field)的标题(Label)的垂直位置(labelVAlign)属性值。
setLastGroupAsFooter(boolean) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的最后一个组是否单独占一行作为尾行，而不受布局方式的影响。
setLayout(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中元素的布局。
setLeft(String) - Method in interface com.bstek.dorado.view.control.Placeable
setLeft
setLeft(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
setLeft
setLeft(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
setLeft
setLeft(int) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架中新页面左边缘(Left)值。
setLevel(int) - Static method in class com.bstek.dorado.common.log.Log
设置日志记录器的日志级别。
setLevel(int) - Method in interface com.bstek.dorado.common.log.Logger
设置日志记录器的日志级别。
setLevel(int) - Method in class com.bstek.dorado.data.db.AndOrMatchRule
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.
setLevel(int) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.
setLevel(int) - Method in interface com.bstek.dorado.data.db.MatchRule
设置该规则对象的级数.
setLevel(int) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点(TreeNode)的层数(Level)。
setLoadData(boolean) - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。
setLoadDataAction(String) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
setLoadDataAction(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
setLoginTimeout(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setLoginTimeout
setLong(String, long) - Static method in class com.bstek.dorado.common.Setting
设定一个Long型的配置信息
setLong(String, long) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Long型的配置信息
setLong(int, long) - Method in interface com.bstek.dorado.data.Dataset
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in interface com.bstek.dorado.data.Dataset
按long类型设置当前记录中某字段的值。
setLong(int, long) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型设置当前记录中某字段的值。
setLong(int, long) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.data.Record
设定记录中某个long类型的字段值。
setLong(long) - Method in class com.bstek.dorado.utils.variant.Variant
设置long类型的数据
setLong(int, long) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置long类型的数据
setLong(String, long) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置long类型的数据
setLong(int, long) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型设置当前记录中某字段的值。
setLookupDataset(Dataset) - Method in class com.bstek.dorado.data.LookupField
设置作为Lookup数据来源的Dataset对象。
setLookupField(String) - Method in class com.bstek.dorado.data.LookupField
设置LookupDataset中将被作为数据返回的字段的名称。
setLookupKeyFields(String) - Method in class com.bstek.dorado.data.LookupField
设定Dataset与LookupDataset之间的字段匹配关系。
setMapValue(boolean) - Method in class com.bstek.dorado.view.control.dropdown.SimpleDropDown
设定是否支持MapValue属性。
setMasterDataset(ViewDataset) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设置主记录集
setMasterKeyFields(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
setMasterKeyFields
setMasterKeyFields(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定主数据集中与从数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
setMasterLink(MasterDetailLink) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定描述该Dataset与MasterDataset之间的关联关系的对象。
setMasterLink(MasterDetailLink) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定描述该Dataset与MasterDataset之间的关联关系的对象。
setMax(int) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条最大可取值。
setMax(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)可滚动到的最大位置值。
setMax(double) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定范围最大值
setMaxActive(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setMaxActive
setMaxIdle(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setMaxIdle
setMaxLength(int) - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
设定最大长度值。
setMaxLink(int) - Method in class com.bstek.dorado.view.control.PagePilot
取得页码导航条(PagePilot)最大连续可见页数。
setMaxMatchRule(String) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定最大值匹配规则
setMaxPropertyLevel(int) - Method in interface com.bstek.dorado.data.Dataset
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
setMaxPropertyLevel(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
setMaxPropertyLevel(int) - Method in class com.bstek.dorado.data.DatasetSupport
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
setMaxRow(int) - Method in class com.bstek.dorado.view.control.table.DataTable
设定数据表格(DataTable)能够显示的最大记录条数。
setMaxTotal(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setMaxTotal
setMaxWait(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setMaxWait
setMenu(String) - Method in class com.bstek.dorado.view.control.Button
设定与按钮(Button)绑定的菜单(Menu)。
setMenu(String) - Method in class com.bstek.dorado.view.control.MenuBar
设定与菜单栏(MenuBar)绑定的菜单(Menu)对象。
setMenu(String) - Method in class com.bstek.dorado.view.control.OutlookBar
设定与菜单栏(MenuBar)绑定的菜单(Menu)对象。
setMessage(String) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
设定本次远程调用将要返回给客户端的提示信息.
setMessage(String) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
设定本次远程调用将要返回给客户端的提示信息.
setMethod(String) - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
设定提交表单数据集命令(SubmitFormDatasetCommand)对象请求的方法(Method)值。
setMethod(String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
指定执行此Command时在ViewModel的实现类中触发的方法名.
setMin(int) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条最小可取值。
setMin(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)可滚动到的最小位置值。
setMin(double) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定范围的最小值
setMinEvictableIdleTimeMillis(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setMinEvictableIdleTimeMillis
setMinIdle(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setMinIdle
setMinLength(int) - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
设定最小长度值。
setMinMatchRule(String) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定最小值匹配规则
setModifySql(String) - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
设置需要更新表的SQL命令。
setName(String) - Method in class com.bstek.dorado.action.Controller
设定Controller的别名。
setName(String) - Method in class com.bstek.dorado.common.ds.DataSourceConfig
setName
setName(String) - Method in class com.bstek.dorado.data.AbstractField
设定字段名称。
setName(String) - Method in interface com.bstek.dorado.data.Field
设定字段名称。
setName(String) - Method in class com.bstek.dorado.data._DatasetEvent
setName(String) - Method in class com.bstek.dorado.data._RecordEvent
setName(String) - Method in interface com.bstek.dorado.module.Module
设置Module的名称
setName(String) - Method in class com.bstek.dorado.module.ModuleSupport
设置Module的名称
setName(String) - Method in class com.bstek.dorado.view.Event
设置事件名
setName(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项(MenuItem)名称。
setName(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定多页标签(Tab)的名称(Name)。
setNamespace(String) - Method in interface com.bstek.dorado.view.ViewModel
设定视图配置命名空间
setNamespace(String) - Method in class com.bstek.dorado.view.ViewModelCacheInfo
setNamespace
setNamespace(String) - Method in class com.bstek.dorado.view.ViewModelSupport
setNamespace
setNext(RecordWrapper) - Method in class com.bstek.dorado.data.RecordWrapper
setNoClient(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定是否不在客户端创建记录集对象.
setNoClient(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
setNoClient
setNoWrap(boolean) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置是否允许该列的内容换行显示。
setNull(int) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值是否为空(null)。
setNull(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNull(int) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.data.Record
设置记录中某字段的值是否为空(null)。
setNull() - Method in class com.bstek.dorado.utils.variant.Variant
设置为空(null)
setNull(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
设置给定索引号下的数值为空(null)
setNull(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
设置给定键值下的数值为空(null)
setNull(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNullable(boolean) - Method in class com.bstek.dorado.data.AbstractField
设定字段是否可以为空。
setNullable(boolean) - Method in interface com.bstek.dorado.data.Field
设定字段是否可以为空。
setObjectClazz(Class) - Method in interface com.bstek.dorado.data.Dataset
设置相关的对象类型的Class名.
setObjectClazz(String) - Method in interface com.bstek.dorado.data.Dataset
设置相关的对象类型的Class名.
setObjectClazz(String) - Method in class com.bstek.dorado.data.DatasetAdapter
设置相关的对象类型的Class名.
setObjectClazz(Class) - Method in class com.bstek.dorado.data.DatasetAdapter
设置相关的对象类型的Class名.
setObjectClazz(Class) - Method in class com.bstek.dorado.data.DatasetSupport
设置相关的对象类型的Class名.
setObjectClazz(String) - Method in class com.bstek.dorado.data.DatasetSupport
设置相关的对象类型的Class名.
setOffValue(String) - Method in class com.bstek.dorado.view.control.CheckBox
设定复选框(CheckBox)没有选中时表示的值。
setOldDO(Object, Object) - Method in class com.bstek.dorado.data.DOSet
为DOSet中某个DO指定一个保存其修改之前的数据的DO.
setOnValue(String) - Method in class com.bstek.dorado.view.control.CheckBox
设定复选框(CheckBox)选中时表示的值。
setOperator(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设定比较操作符。
setOrientation(String) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条对象(ProgressBar)的类型。
setOrientation(String) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)的滚动方式。
setOrientation(String) - Method in class com.bstek.dorado.view.control.SplitPanel
设置分割栏(SplitPanel)类型。
setOriginField(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设定匹配规则的原始字段。
setOriginField(String) - Method in class com.bstek.dorado.data.db.DBField
设置该字段来自于哪个数据库物理字段。
setOriginField(String) - Method in class com.bstek.dorado.data.db.SortRule
设定该排序规则对应的字段名.
setOriginTable(String) - Method in class com.bstek.dorado.data.db.DBDataset
设置此Dataset的主表的物理表名.
setOriginTable(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置关联表的物理表名.
setPadding(int) - Method in class com.bstek.dorado.view.control.SplitPanel
设置分割栏(SplitPanel)的宽度(padding)。
setPageCount(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset所对应的数据共有几页。
setPageCount(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset所对应的数据共有几页。
setPageCount(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset所对应的数据共有几页。
setPageCount(int) - Method in class com.bstek.dorado.data.RecordSet
设置整个结果集可能包含的页数.
setPageCount(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset所对应的数据共有几页。
setPageIndex(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset的当前页号
setPageIndex(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset的当前页号
setPageIndex(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset的当前页号
setPageIndex(int) - Method in class com.bstek.dorado.data.RecordSet
设置当前RecordSet对象中管理的Record在整个结果集中所处的页号.
setPageIndex(int) - Method in class com.bstek.dorado.data.RecordWrapper
设置当前管理的Record在整个结果集中所处的页号.
setPageIndex(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset的当前页号
setPageSize(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset的每页的行数
setPageSize(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset的每页的行数
setPageSize(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset的每页的行数
setPageSize(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)的分页信息。
setPageSize(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset的每页的行数
setParamFields(String) - Method in class com.bstek.dorado.view.control.command.RequestCommand
设置请求命令(RequestCommand)提交Dataset的参数域。
setParameters(String) - Method in class com.bstek.dorado.view.Event
设置事件参数描述
setPassword(String) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setPassword
setPassword(String) - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
setPassword
setPath(String) - Method in class com.bstek.dorado.action.mapping.ActionTarget
跳转目标的路径
setPath(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定单击菜单项(MenuItem)时要打开的URL路径。
setPath(String) - Method in class com.bstek.dorado.view.control.command.RequestCommand
setPath
setPath(String) - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
设定自定义下拉框中要显示的视图的路径
setPath(String) - Method in class com.bstek.dorado.view.control.tabset.FrameTab
设定多页标签(Tab)切换时需要跳转的URL路径。
setPath(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定树结点对应的路径
setPathField(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
setPathField
setPattern(String) - Method in class com.bstek.dorado.view.control.table.StaticColumn
取得静态列的模式
setPilotType(String) - Method in class com.bstek.dorado.view.control.PagePilot
设置分页导航对象的类型，可取值为"link","button"。
setPopupContainer(String) - Method in class com.bstek.dorado.view.control.Menu
取得弹出式菜单(Menu)的容器(PopupContainer)的ID。
setPosition(int) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条进度位置。
setPosition(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)的默认所处位置值。
setPosition(String) - Method in class com.bstek.dorado.view.control.SplitPanel
setPosition
setPossibleCount(int) - Method in class com.bstek.dorado.data.RecordSet
设置整个结果集可能包含的记录数.
setPossibleRecordCount(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset可能存在的总记录数。
setPossibleRecordCount(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset可能存在的总记录数。
setPossibleRecordCount(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset可能存在的总记录数。
setPrefix(String) - Method in class com.bstek.dorado.action.mapping.Unit
设置配置单元的URL前缀
setPrev(RecordWrapper) - Method in class com.bstek.dorado.data.RecordWrapper
setProperty(String) - Method in class com.bstek.dorado.data.AbstractField
设置该字段对应的属性名.
setProperty(String) - Method in interface com.bstek.dorado.data.Field
设置该字段对应的属性名.
setQueryDataset(String) - Method in class com.bstek.dorado.view.control.command.QueryCommand
setQueryMode(String) - Method in class com.bstek.dorado.view.control.command.QueryCommand
setReadFields(String) - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
设置高级下拉框(AdvanceDropDown)为目的数据集字段(WriteFields)赋值的源数据集字段(ReadFields)信息。
setReadFields(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设置高级下拉框(AdvanceDropDown)为目的数据集字段(WriteFields)赋值的源数据集字段(ReadFields)信息。
setReadOnly(boolean) - Method in class com.bstek.dorado.common.ds.TransConnection
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.Editor
设置编辑框(Editor)是否只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的只读属性。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格(DataTable)是否是只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定列(Column)是否只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定该字段是否只读。
setReadOnly(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定数据集的只读属性。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定数据集的只读属性。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定数据集的只读属性。
setReadOnly(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设定该字段是否只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定该字段是否只读。
setRecord(ReadRecord) - Method in class com.bstek.dorado.data._DatasetEvent
setRecord(ReadRecord) - Method in class com.bstek.dorado.data._RecordEvent
setRecord(Record) - Method in class com.bstek.dorado.view.control.tree.RecordTreeNode
设置树节点(RecordTreeNode)所绑定的记录对象。
setRecordFilter(RecordFilter) - Method in interface com.bstek.dorado.data.Dataset
设置Dataset内部使用的记录过滤器.
setRecordFilter(RecordFilter) - Method in class com.bstek.dorado.data.DatasetAdapter
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

setRecordFilter(RecordFilter) - Method in class com.bstek.dorado.data.DatasetSupport
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

setRecordId(long) - Method in class com.bstek.dorado.data.Record
设置当前记录的id.此id一般是自动生成的,您不需要手工设定.
setRecordSet(RecordSet) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.data.Record
将指定的记录集合对象设定到Dataset中。
setRecordSet(RecordSet) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定Dataset的Record集合对象
setRecordState(int) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录的状态
setRecordState(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录的状态
setRecordState(int) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录的状态
setRecordState(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录的状态
setRecursiveKeyFields(String) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
设置RecursiveKey字段,应用与父子递归表
setRecursiveKeyFields(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
设置RecursiveKey字段,多个字段用逗号(",")隔开，一般应用与父子递归表。
setRecursiveKeyParameters(String) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
设置RecursiveKey参数,应用与父子递归表
setRecursiveKeyParameters(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
设置RecursiveKey参数,多个参数用逗号(",")隔开，一般应用与父子递归表。
setRedirect(boolean) - Method in class com.bstek.dorado.action.mapping.ActionForward
是否以sendRedirect的方式转向新的path。
setReferenceRecord(Record) - Method in class com.bstek.dorado.view.data.RecordReference
setReferenceRecord
setRendererType(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
setRendererType
setRequest(HttpServletRequest) - Method in class com.bstek.dorado.common.HttpDoradoContext
设置被封装的HttpServletRequest对象
setResizable(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)是否允许改变大小。
setResizable(boolean) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架页面是否可以改变窗口大小(Resizable)。
setResizable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定是否支持客户端用户对该列进行宽度调整操作。
setRetrieveAfterUpdate(boolean) - Method in class com.bstek.dorado.data.db.DBDataset
是否需要在完成某条记录的更新后对该记录进行重新查询.
setRetrieveSql(String) - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
setRetrieveSql
setRole(String) - Method in interface com.bstek.dorado.view.ViewModel
设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.
setRole(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.
setRootNode(XmlNode) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
设置根节点。
setRow(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设定某行为当前行。
setRowHeight(int) - Method in class com.bstek.dorado.view.control.table.Table
设置表格数据行的高度
setRowSpan(int) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置AutoForm的该元素(Element)的行跨度(rowSpan)属性值，该属性类Table的RowSpan属性。
setRowSpan(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设置组(Group)中当前元素所占的行的跨度数。
setSafe(boolean) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置用户访问视图页面时是否对用户身份进行检验。
setSafe(boolean) - Method in interface com.bstek.dorado.view.ViewModel
设置用户访问视图页面时是否对用户身份进行检验。
setSafe(boolean) - Method in class com.bstek.dorado.view.ViewModelSupport
设置用户访问视图页面时是否对用户身份进行检验。如果该属性设为True时，Dorado将通过 工程配置文件setting.xml文件中的accessChecker属性定义的安全检查类对用户进行安全检验， 只有符合规定的特定用户才允许访问该视图页面。
setSavepoint() - Method in class com.bstek.dorado.common.ds.TransConnection
setSavepoint(String) - Method in class com.bstek.dorado.common.ds.TransConnection
setScope(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置Model的作用域范围
setScript(String) - Method in class com.bstek.dorado.view.EventHandler
设定事件脚本
setScrollMode(String) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格(DataTable)垂直滚动条的滚动方式:
sample:默认像素定位，同时系统提示信息为像素位置提示
record:按记录定位，同时系统提示信息为记录位置提示
setSelectAllField(boolean) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
设置是否自动检索出AutoSqlDataset对应的主表(originTable)中所有的字段。
setShort(int, short) - Method in interface com.bstek.dorado.data.Dataset
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in interface com.bstek.dorado.data.Dataset
按short类型设置当前记录中某字段的值。
setShort(int, short) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型设置当前记录中某字段的值。
setShort(int, short) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.data.Record
设定记录中某个short类型的字段值。
setShort(short) - Method in class com.bstek.dorado.utils.variant.Variant
设置short类型的数据
setShort(int, short) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置short类型的数据
setShort(String, short) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置short类型的数据
setShort(int, short) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型设置当前记录中某字段的值。
setShowBevel(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置是否显示组(Group)的边框线，缺省为显示。
setShowBorder(boolean) - Method in class com.bstek.dorado.view.control.MenuBar
设置是否显示边框(border)。
setShowButtons(boolean) - Method in class com.bstek.dorado.view.control.SplitPanel
设置是否分割栏(SplitPanel)快捷按钮。
setShowCloseButton(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)是否显示窗口关闭系统按钮。
setShowColumnHeader(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设定是否显示数据集下拉框(DatasetDropDown)中每个数据列的标题行。
setShowColumnHeader(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设定是否显示动态下拉框(DynamicDropDown)中的字段列的标题。
setShowDialog(boolean) - Method in class com.bstek.dorado.view.control.command.RPCCommand
setShowDialog
setShowDraggingTip(String) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动栏(ScrollBar)拖动时是否显示系统提示信息。
setShowFooter(boolean) - Method in class com.bstek.dorado.view.control.table.Table
设定是否显示数据表格(DataTable)的汇总栏，默认是显示。
setShowFrame(boolean) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定是否显示多页标签(Tab)的外框架(Frame)。
setShowGotoButton(boolean) - Method in class com.bstek.dorado.view.control.PagePilot
设置是否显示跳转到按钮(GotoButton)。
setShowHScrollBar(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格(DataTable)数据横向宽度大于显示窗口宽度时是否显示水平滚动条
setShowHeader(boolean) - Method in class com.bstek.dorado.view.control.table.Table
设定是否显示数据表格(DataTable)的标题栏，默认是显示。
setShowIndicator(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置在数据表格中是否显示表格指示器箭头。
setShowLabel(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置是否显示AutoForm中与该元素(Element)对应的标题(Label)。
setShowMaximizeButton(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)是否显示窗口最大化按钮。
setShowMinimizeButton(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)是否显示窗口最小化按钮。
setShowPageInfo(boolean) - Method in class com.bstek.dorado.view.control.PagePilot
设置是否显示页信息。
setShowText(boolean) - Method in class com.bstek.dorado.view.control.ProgressBar
设置是否显示数据，否则只显示进度信息。
setShowVScrollBar(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格(DataTable)数据竖向高度大于显示窗口高度时是否显示垂直滚动条
setSkin(String) - Method in interface com.bstek.dorado.view.ViewModel
设定视图模型使用的皮肤
setSkin(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图模型使用的皮肤
setSmallChange(int) - Method in class com.bstek.dorado.view.control.ScrollBar
setSmallChange
setSortable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定是否支持客户端用户对该列进行排序操作。
setSourceDataset(String) - Method in class com.bstek.dorado.view.data.DatasetReference
设定引用的源数据集
setSourceKeyFields(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置用于建立关联的源表中的字段.
setSourceModule(String) - Method in class com.bstek.dorado.view.data.DatasetReference
设定从哪个源数据集模块中取得数据。
setSourceTable(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置与关联表相对应的源表.
setSql(String) - Method in class com.bstek.dorado.data.db.AutoDBField
设置此Field的自定义SQL。
setSql(String, String) - Method in class com.bstek.dorado.data.db.DBStatement
利用SQL类型和表名快速设置DBStatement的SQL命令.
setSql(String, String, String) - Method in class com.bstek.dorado.data.db.DBStatement
利用SQL类型、表名和主键字段描述快速设置DBStatement的SQL命令.
setSql(String) - Method in class com.bstek.dorado.data.db.DBStatement
直接设置SQL命令.
setSql(String) - Method in class com.bstek.dorado.data.db.SqlDataset
设置SqlDataset的SQL查询命令。
setSql(String) - Method in class com.bstek.dorado.data.db.SqlMatchRule
设置自定义SQL.
setSqlDataType(int) - Method in class com.bstek.dorado.data.db.DBField
设置该字段在数据库中的数据类型。
setState(int) - Method in class com.bstek.dorado.data.DOWrapper
setState(int) - Method in interface com.bstek.dorado.data.Dataset
更改当前记录集的当前状态
setState(int) - Method in class com.bstek.dorado.data.DatasetAdapter
更改当前记录集的当前状态
setState(int) - Method in class com.bstek.dorado.data.DatasetSupport
更改当前记录集的当前状态
setState(int) - Method in class com.bstek.dorado.data.Record
设定Record记录的状态。
setStatus(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)状态设置。
setStatusbar(boolean) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架页面的是否有状态栏(Statusbar)。
setString(String, String) - Static method in class com.bstek.dorado.common.Setting
设置一个String型的配置信息
setString(String, String) - Static method in class com.bstek.dorado.common.UserConfig
设置一个String型的配置信息
setString(int, String) - Method in interface com.bstek.dorado.data.Dataset
按String类型设置当前记录中某字段的值。
setString(String, String) - Method in interface com.bstek.dorado.data.Dataset
按String类型设置当前记录中某字段的值。
setString(int, String) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(int, String) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.data.Record
设置记录中指定的字符字段的值。
setString(String) - Method in class com.bstek.dorado.utils.variant.Variant
设置String类型的数据
setString(int, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置String类型的数据
setString(String, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置String类型的数据
setString(int, String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setStyle(String) - Method in interface com.bstek.dorado.view.control.Placeable
setStyle
setStyle(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
setStyle
setStyle(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
setStyle
setSubmitScope(String) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设定提交Dataset对象中记录的方式，有四种方式： all - 提交Dataset中所有的记录； all-change - 只提交Dataset中所有更改过的记录； current - 只提交Dataset的当前记录； selected - 只提交Dataset中所有通过Select复选框选中的记录。
setSucceed(boolean) - Method in class com.bstek.dorado.view.rpc.AbstractRPCHandler
设定本次远程调用是否已经成功.
setSucceed(boolean) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
设定本次远程调用是否已经成功.
setSupportsPaging(boolean) - Method in class com.bstek.dorado.view.data.DODataset
设置是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.
setTabIndex(int) - Method in class com.bstek.dorado.view.control.tabset.TabSet
根据索引值设定当前的多页标签(Tab)。
setTabPlacement(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定多页标签(Tab)所在的位置，有两个值：top和buttom。
setTable(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置原始字段(originField)所属的表名。
setTable(String) - Method in class com.bstek.dorado.data.db.DBField
设置该字段所属的数据库物理表名.
setTable(String) - Method in class com.bstek.dorado.data.db.SortRule
设置原始字段(originField)所属的表别名.
setTag(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
{@inheritDoc}
setTag(String) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设置自定义信息。
setTag(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
用户自定义信息。
setTag(String) - Method in interface com.bstek.dorado.view.Element
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.AbstractControl
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.table.Column
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.control.tree.TreeNode
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定元素(Element)的用户自定义信息(Tag)。
setTag(String) - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
设定元素(Element)的用户自定义信息(Tag)。
setTarget(Dataset) - Method in class com.bstek.dorado.data.DatasetAdapter
设定适配器的目标Dataset
setTarget(String) - Method in class com.bstek.dorado.view.control.Menu
设定弹出式菜单(Menu)需要刷新的目标框架(Target)。
setTarget(String) - Method in class com.bstek.dorado.view.control.command.Frame
设置在哪个目标框架中打开新页面。
setTarget(String) - Method in class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的目标框架(Target)值。
setTarget(String) - Method in class com.bstek.dorado.view.control.tree.Tree
设定树(Tree)的节点切换时需要刷新的目标框架。
setTarget(ViewDataset) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定被适配的数据集
setText(String) - Method in class com.bstek.dorado.view.control.Label
设定标题的文本内容。
setTextPattern(String) - Method in class com.bstek.dorado.view.control.ProgressBar
设置文本格式，通过设置该格式，我们可以自定义显示格式。
setTimeBetweenEvictionRunsMillis(int) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setTimeBetweenEvictionRunsMillis
setTitle(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置字窗口(SubWindow)标题(title)。
setTitle(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组(Group)的标题(Title)，通常为文字描述信息。
setTitleDblClickAction(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗口(SubWindow)标题栏双击Action设置，可选值有:SubWindow.MAXIMIZE,SubWindow.MINIMIZE,SubWindow.NORMAL,SubWindow.HIDDEN。
setToolTip(String) - Method in class com.bstek.dorado.view.control.Button
设定按钮(Button)的弹出式提示(toolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.control.CheckBox
设定弹出式提示(ToolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.control.Editor
设定弹出式提示(ToolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.control.RadioGroup
设定弹出式提示(ToolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.control.table.Column
设置该列(Column)的弹出式提示(ToolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定字段的弹出式提示信息。
setToolTip(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定字段的弹出式提示信息。
setToolTip(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定字段的弹出式提示信息。
setTop(String) - Method in interface com.bstek.dorado.view.control.Placeable
setTop
setTop(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
setTop
setTop(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
setTop
setTop(int) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架中新页面上部边缘(Top)值。
setTransactionIsolation(int) - Method in class com.bstek.dorado.common.ds.TransConnection
setTransactionMode(int) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
设定事务模式.
setTransactionMode(String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
返回事务模式.
setTreeColumn(String) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
设置具有树展开功能的列,在该列上可以实现数展开功能
setType(String) - Method in class com.bstek.dorado.common.ds.DataSourceConfig
setType
setTypeMap(Map) - Method in class com.bstek.dorado.common.ds.TransConnection
setUnit(Unit) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设定此对象所隶属的Unit。
setUnit(Unit) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置该Controller所属的Unit对象
setUp() - Method in class com.bstek.dorado.common.ds._TestJdbcDataSourceConfig
setUp() - Method in class com.bstek.dorado.common.ds._TestPool
setUp() - Method in class com.bstek.dorado.data._TestIndex
setUp() - Method in class com.bstek.dorado.data._TestRecordSet
setUp() - Method in class com.bstek.dorado.i18n._TestResourceManager
setUp() - Method in class com.bstek.dorado.utils._TestStringHelper
setUp() - Method in class com.bstek.dorado.utils._TestSynchroTimer
setUp() - Method in class com.bstek.dorado.utils._TestSystemVariable
setUp() - Method in class com.bstek.dorado.utils.codec._TestEncrypt
setUp() - Method in class com.bstek.dorado.utils.codec._TestSafeCode
setUp() - Method in class com.bstek.dorado.utils.collection._TestObjectList
setUp() - Method in class com.bstek.dorado.utils.variant._TestVariant
setUp() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
setUp() - Method in class com.bstek.dorado.utils.xml._TestXmlDocument
setUp() - Method in class com.bstek.dorado.view.data._TestMasterDetailLink
setUpdatable(boolean) - Method in class com.bstek.dorado.data.db.DBField
设置该字段是否可向数据库中更新
setUpdateFields(String[]) - Method in class com.bstek.dorado.data.db.UpdateSqlInfo
Dataset中需要更新的Field数组。
setUrl(String) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setUrl
setUser(String) - Method in class com.bstek.dorado.common.ds.JdbcDataSourceConfig
setUser
setUser(String) - Method in class com.bstek.dorado.common.ds.JndiDataSourceConfig
setUser
setValue(int, Object) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值。
setValue(String, Object) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值。
setValue(int, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值。
setValue(int, Object) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.data.Record
直接设置记录中某字段的对应值对象
setValue(Variant) - Method in class com.bstek.dorado.data._DatasetEvent
setValue(Variant) - Method in class com.bstek.dorado.data._RecordEvent
setValue(String) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置匹配值.
setValue(Object) - Method in class com.bstek.dorado.utils.variant.Variant
设置Object类型的数据
setValue(int, Object) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置Object类型的数据
setValue(String, Object) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置Object类型的数据
setValue(String) - Method in class com.bstek.dorado.view.control.Button
设置按钮(Button)的值(Value)。
setValue(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定文本编辑器(TextEditor)的默认值
setValue(String) - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
设定下拉框(DropDown)当前选择项为指定的值。
setValue(int, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值。
setValueField(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
setValueField
setValueProtected(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定字段是否有字段保护功能。如果有，表示用户只能往数据库中新增字段的值，不能修改数据库中已有的值。
setValueProtected(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设定字段是否有字段保护功能。
setValueProtected(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定字段是否有字段保护功能。如果有，表示用户只能往数据库中新增字段的值，不能修改数据库中已有的值。
setValues(String) - Method in class com.bstek.dorado.view.data.validate.impl.ListValidator
设定指定的一组校验值
setVariant(String, Variant) - Method in class com.bstek.dorado.data.ParameterSet
根据键值设置Variant类型的数据
setVariant(String, Variant) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置Variant类型的数据
setVisibility(String) - Method in class com.bstek.dorado.data.RecordIterator
设置迭代器的记录可见性
setVisibility(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设定该元素(Element)是否在页面上可见。
setVisible(boolean) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项(MenuItem)是否可见。
setVisible(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组(Group)是否可见，不可见时将不在页面上创建该对象。
setVisible(boolean) - Method in class com.bstek.dorado.view.control.table.Column
设置表格中该列是否可见
setVisible(boolean) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定标签项(Tab)是否可见。
setVisible(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设置字段是否在页面上可见。
setVisible(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设置字段是否在页面上可见。
setVisible(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
设置字段是否在页面上可见。
setVisibleFields(String) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设定动态下拉框(DynamicDropDown)中要显示的数据列。
setVisibleFields(String) - Method in class com.bstek.dorado.view.control.dropdown.SimpleDropDown
设定数据集下拉框(DatasetDropDown)中要显示的数据列。
setWidth(String) - Method in class com.bstek.dorado.view.control.DataLabel
设定标签的宽度
setWidth(String) - Method in interface com.bstek.dorado.view.control.Placeable
setWidth
setWidth(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
setWidth
setWidth(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
setWidth
setWidth(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设定AutoForm的宽度。
setWidth(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组(Group)的宽度值。
setWidth(int) - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架中新页面的宽度(Width)值。
setWidth(int) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
setWidth
setWidth(int) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置列(Column)显示的宽度(Width)。
setWidth(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定多页标签(Tab)的宽度(Width)。
setWriteFields(String) - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
设置高级下拉框(AdvanceDropDown)从源数据集字段(ReadFields)读取值， 给目的数据集字段(WriteFields)赋值的目的数据集字段(WriteFields)信息。
setWriteFields(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设置高级下拉框(AdvanceDropDown)从源数据集字段(ReadFields)读取值， 给目的数据集字段(WriteFields)赋值的目的数据集字段(WriteFields)信息。
size() - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
size() - Method in class com.bstek.dorado.data.RecordSet
取得总记录数
size() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回对象列表中的对象数量。
size() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回对象列表中的对象数量。
sortRules() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset所有SortRule的集合对象。
split(String, String) - Static method in class com.bstek.dorado.utils.StringHelper
根据指定的分割符将字符串分割成字符串数组。
start() - Method in class com.bstek.dorado.utils.SynchroTimer
启动定时器
start() - Method in class com.bstek.dorado.utils._MockSynchroTimer
state - Variable in class com.bstek.dorado.data.ReadRecord
stop() - Method in class com.bstek.dorado.utils.SynchroTimer
终止定时器
stop() - Method in class com.bstek.dorado.utils._MockSynchroTimer
storeObject(DoradoContext, String, String, Object) - Static method in class com.bstek.dorado.common.scope.ScopeHelper
根据属性名将一个对象存入相应的资源当中
storeUploadFile(HttpServletRequest, FileItem, File, MetaData) - Method in class com.bstek.dorado.biz.FileController
存储已经上传的文件
storeViewProperties(DoradoContext, MetaData) - Static method in class com.bstek.dorado.view.ViewPropertiesHelper
storeViewProperties
suite() - Static method in class com.bstek.dorado._TestAll
suite() - Static method in class com.bstek.dorado.common._TestAll
suite() - Static method in class com.bstek.dorado.common.ds._TestAll
suite() - Static method in class com.bstek.dorado.data._TestAll
suite() - Static method in class com.bstek.dorado.data.db._TestAll
suite() - Static method in class com.bstek.dorado.module._TestAll
switchValue(boolean, Object, Object) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
开关值.

T

TABPLACEMENT_BOTTOM - Static variable in class com.bstek.dorado.view.control.tabset.TabSet
标签页按钮的位置 - 下部
TABPLACEMENT_TOP - Static variable in class com.bstek.dorado.view.control.tabset.TabSet
标签页按钮的位置 - 上部
TEXT - Static variable in class com.bstek.dorado.view.control.TextEditor
文本编辑器类型 - text
TEXT - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - text
TEXTAREA - Static variable in class com.bstek.dorado.view.control.TextEditor
文本编辑器类型 - textarea
TEXTAREA - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - textarea
TIME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - Time型。
TIME_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - Time型。
TOP - Static variable in class com.bstek.dorado.view.control.command.Frame
命令(Command)提交后在当前页面所处的框(frame)的最顶部的浏览器窗口中打开新页面。
TRANSACTION_NOT_SUPPORTED - Static variable in class com.bstek.dorado.common.TransactionManager
不支持事务.
TRANSACTION_REQUIRED - Static variable in class com.bstek.dorado.common.TransactionManager
需要事务.
TRANSACTION_REQUIRES_NEW - Static variable in class com.bstek.dorado.common.TransactionManager
需要新事务.
TRANSACTION_SUPPORTS - Static variable in class com.bstek.dorado.common.TransactionManager
支持事务.
TYPE_BUTTON - Static variable in class com.bstek.dorado.view.control.PagePilot
TYPE_BUTTON
TYPE_LINK - Static variable in class com.bstek.dorado.view.control.PagePilot
TYPE_LINK
Tab - class com.bstek.dorado.view.control.tabset.Tab.
标签页对象
Tab(String) - Constructor for class com.bstek.dorado.view.control.tabset.Tab
构造器
Tab(String, String) - Constructor for class com.bstek.dorado.view.control.tabset.Tab
构造器
TabElement - class com.bstek.dorado.view.control.tabset.TabElement.
TabElement(String) - Constructor for class com.bstek.dorado.view.control.tabset.TabElement
构造器
TabElement(String, String) - Constructor for class com.bstek.dorado.view.control.tabset.TabElement
构造器
TabSet - class com.bstek.dorado.view.control.tabset.TabSet.
多行标签页对象
TabSet(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.tabset.TabSet
构造器
Table - class com.bstek.dorado.view.control.table.Table.
表格的基类
Table(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.table.Table
构造器
TextEditor - class com.bstek.dorado.view.control.TextEditor.
文本编辑器对象
TextEditor(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.TextEditor
构造器
TextEditorFormElement - class com.bstek.dorado.view.control.autoform.TextEditorFormElement.
TextEditor元素对象
TextEditorFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.TextEditorFormElement
构造器
TransConnection - class com.bstek.dorado.common.ds.TransConnection.
TransConnection(String, Connection) - Constructor for class com.bstek.dorado.common.ds.TransConnection
TransConnectionListener - interface com.bstek.dorado.common.ds.TransConnectionListener.
Transaction - interface com.bstek.dorado.common.Transaction.
Dorado事务对象的接口
TransactionManager - class com.bstek.dorado.common.TransactionManager.
Dorado事务的管理对象
Tree - class com.bstek.dorado.view.control.tree.Tree.
树状列表对象
Tree(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.tree.Tree
构造器
TreeGrid - class com.bstek.dorado.view.control.advance.TreeGrid.
TreeGrid(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.advance.TreeGrid
TreeGrid
TreeLevel - class com.bstek.dorado.view.control.tree.TreeLevel.
TreeLevel对象
TreeLevel() - Constructor for class com.bstek.dorado.view.control.tree.TreeLevel
TreeNode - class com.bstek.dorado.view.control.tree.TreeNode.
树节点对象
TreeNode() - Constructor for class com.bstek.dorado.view.control.tree.TreeNode
构造器
tabs() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得所有多页标签(Tab)的集合对象。
tearDown() - Method in class com.bstek.dorado.common.ds._TestJdbcDataSourceConfig
tearDown() - Method in class com.bstek.dorado.common.ds._TestPool
tearDown() - Method in class com.bstek.dorado.data._TestIndex
tearDown() - Method in class com.bstek.dorado.data._TestRecordSet
tearDown() - Method in class com.bstek.dorado.i18n._TestResourceManager
tearDown() - Method in class com.bstek.dorado.utils._TestStringHelper
tearDown() - Method in class com.bstek.dorado.utils._TestSynchroTimer
tearDown() - Method in class com.bstek.dorado.utils._TestSystemVariable
tearDown() - Method in class com.bstek.dorado.utils.codec._TestEncrypt
tearDown() - Method in class com.bstek.dorado.utils.codec._TestSafeCode
tearDown() - Method in class com.bstek.dorado.utils.collection._TestObjectList
tearDown() - Method in class com.bstek.dorado.utils.variant._TestVariant
tearDown() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
tearDown() - Method in class com.bstek.dorado.utils.xml._TestXmlDocument
tearDown() - Method in class com.bstek.dorado.view.data._TestMasterDetailLink
testAdd() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testBigDecimal() - Method in class com.bstek.dorado.utils.variant._TestVariant
testBoolean() - Method in class com.bstek.dorado.utils.variant._TestVariant
testByte() - Method in class com.bstek.dorado.utils.variant._TestVariant
testClear() - Method in class com.bstek.dorado.data._TestRecordSet
testCode() - Method in class com.bstek.dorado.utils.codec._TestEncrypt
testCount() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testDataType() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testDate() - Method in class com.bstek.dorado.utils.variant._TestVariant
testDouble() - Method in class com.bstek.dorado.utils.variant._TestVariant
testEncode() - Method in class com.bstek.dorado.utils.codec._TestSafeCode
testExecute() - Method in class com.bstek.dorado.utils._TestSynchroTimer
testFindWrapper() - Method in class com.bstek.dorado.data._TestRecordSet
testFloat() - Method in class com.bstek.dorado.utils.variant._TestVariant
testGet() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testGet1() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testGetConnection() - Method in class com.bstek.dorado.common.ds._TestJdbcDataSourceConfig
testGetFirst() - Method in class com.bstek.dorado.data._TestRecordSet
testGetFirstWrapper() - Method in class com.bstek.dorado.data._TestRecordSet
testGetKey() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testGetLast() - Method in class com.bstek.dorado.data._TestRecordSet
testGetLastWrapper() - Method in class com.bstek.dorado.data._TestRecordSet
testGetString() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testGetString1() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testIndexToName() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testInt() - Method in class com.bstek.dorado.utils.variant._TestVariant
testIsValid() - Method in class com.bstek.dorado.utils._TestStringHelper
testIsValueLegal() - Method in class com.bstek.dorado.utils._TestStringHelper
testIterator() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testJDBC() - Method in class com.bstek.dorado.common.ds._TestPool
testJNDI() - Method in class com.bstek.dorado.common.ds._TestPool
testLong() - Method in class com.bstek.dorado.utils.variant._TestVariant
testRebuild() - Method in class com.bstek.dorado.data._TestIndex
testRemove() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testRemove1() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testRemoveAll() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testRemoveRecord() - Method in class com.bstek.dorado.data._TestRecordSet
testSerializable() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testSetDetailKeyFields() - Method in class com.bstek.dorado.view.data._TestMasterDetailLink
testSetMasterKeyFields() - Method in class com.bstek.dorado.view.data._TestMasterDetailLink
testSetString() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testSetString1() - Method in class com.bstek.dorado.utils.variant._TestVariantSet
testShort() - Method in class com.bstek.dorado.utils.variant._TestVariant
testSize() - Method in class com.bstek.dorado.utils.collection._TestObjectList
testSplit1() - Method in class com.bstek.dorado.utils._TestStringHelper
testString() - Method in class com.bstek.dorado.utils.variant._TestVariant
testTime() - Method in class com.bstek.dorado.utils._TestStringHelper
testValidate() - Method in class com.bstek.dorado.utils._TestStringHelper
testXmlNode() - Method in class com.bstek.dorado.utils.xml._TestXmlDocument
throwException() - Method in class com.bstek.dorado.view.data.validate.impl.AbstractValidator
throwException
timestamp() - Method in interface com.bstek.dorado.data.Dataset
返回该Dataset对象的事件戳。
timestamp() - Method in class com.bstek.dorado.data.DatasetAdapter
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
timestamp() - Method in class com.bstek.dorado.data.DatasetSupport
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
timestamp() - Method in class com.bstek.dorado.data.Index
返回Index时间戳，该时间戳实质是一个整数代表此索引的最后的更新时间。
timestamp() - Method in class com.bstek.dorado.data.Record
返回该Record对象的时间戳。
timestamp() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
toDO() - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.
toDO(String) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
toDO(Collection) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.
toDO(Collection, String) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
toDO() - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(String) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection, String) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO() - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(String) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection, String) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toObject(byte) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(short) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(int) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(long) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(float) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(double) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toDouble
toObject(boolean) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toDouble
toObject(Date) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(BigDecimal) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(String) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toSingleDO() - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中给定的记录转换为对象
toSingleDO(Object) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record, Object) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中给定的记录转换为对象
toSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中给定的记录转换为对象
toSingleDO() - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中给定的记录转换为对象
toSingleDO() - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中给定的记录转换为对象
toSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record, Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中给定的记录转换为对象
toString() - Method in class com.bstek.dorado.utils.variant.Variant
Returns a string representation of the object.
toString() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
toValidString(Object) - Static method in class com.bstek.dorado.utils.StringHelper
将给定的对象转换为一个有效的字符串.
translate(DoradoContext) - Method in class com.bstek.dorado.common.rtexpr.CompiledText
translate
translate(JexlContext) - Method in class com.bstek.dorado.common.rtexpr.CompiledText
translate
translate(CompiledText, DoradoContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段预编译好的字符串翻译成最终结果
translate(String, DoradoContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.
translate(CompiledText, JexlContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.
translate(String, JexlContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段字符串翻译成最终结果
translate(String, String, String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
转换字符串的字符集.
translate(String, String, String) - Static method in class com.bstek.dorado.utils.StringHelper
将一个字符串转换为给定的编码格式.
translate(int, Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
translate
translateFromISO(String, String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
将一个iso8859-1字符串转换为给定的编码格式.
translateFromISO(String, String) - Static method in class com.bstek.dorado.utils.StringHelper
将一个iso8859-1字符串转换为给定的编码格式.
trimEndSeparator(String) - Static method in class com.bstek.dorado.utils.http.UrlUtil
移除字符串两端的URL分隔符，即移除字符串两端的'/'。
typeToName(int) - Static method in class com.bstek.dorado.utils.variant.DataType
typeToName

U

UNKNOWN - Static variable in class com.bstek.dorado.data.db.DBStatement
未知的SQL类型
UNKNOWN - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - 未知类型。
UNKNOWN_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - 未知类型。
UPDATE - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - UPDATE
UniqueKey - class com.bstek.dorado.utils.UniqueKey.
用于取得一个VM唯一标识。
Unit - class com.bstek.dorado.action.mapping.Unit.
对应一个Mapping配置文件，用于管理其中所有的配置信息
Unit(String) - Constructor for class com.bstek.dorado.action.mapping.Unit
构造器
UnitParser - class com.bstek.dorado.action.mapping.UnitParser.
配置单元的Mapping配置信息的解析器
UnknownLogLevelException - exception com.bstek.dorado.common.log.UnknownLogLevelException.
Dorado系统日志级别转换时给定参数不是合法日志级别时产生的异常。
UnknownLogLevelException() - Constructor for class com.bstek.dorado.common.log.UnknownLogLevelException
UnknownLogLevelException
UnknownLogLevelException(String) - Constructor for class com.bstek.dorado.common.log.UnknownLogLevelException
UnknownLogLevelException
UpdateCommand - class com.bstek.dorado.view.control.command.UpdateCommand.
UpdateCommand对象
UpdateCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.UpdateCommand
构造器
UpdateDataRPCHandler - class com.bstek.dorado.view.rpc.UpdateDataRPCHandler.
用于处理客户端发送的动态数据更新操作的处理类
UpdateDataRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
UpdateSqlInfo - class com.bstek.dorado.data.db.UpdateSqlInfo.
UpdateSqlInfo() - Constructor for class com.bstek.dorado.data.db.UpdateSqlInfo
UrlUtil - class com.bstek.dorado.utils.http.UrlUtil.
与处理URL相关的工具类
UserConfig - class com.bstek.dorado.common.UserConfig.
用于保存Dorado的Server运行时属性的对象
UserNotLoggedInException - exception com.bstek.dorado.security.UserNotLoggedInException.
用户没有登录的异常
UserNotLoggedInException() - Constructor for class com.bstek.dorado.security.UserNotLoggedInException
构造器
UserNotLoggedInException(String) - Constructor for class com.bstek.dorado.security.UserNotLoggedInException
构造器
UserNotLoggedInException(Throwable) - Constructor for class com.bstek.dorado.security.UserNotLoggedInException
构造器
unescape(String) - Static method in class com.bstek.dorado.utils.codec.EscapeUtils
对安全字符串进行解码，返回原始字符串。
unregisterContext() - Static method in class com.bstek.dorado.common.DoradoContext
从当前的线程中注销一个context对象
unregisterDetailLink(MasterDetailLink) - Method in interface com.bstek.dorado.view.data.ViewDataset
注销一个关联关系的对象。
unregisterDetailLink(MasterDetailLink) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
注销一个关联关系的对象。
update() - Method in interface com.bstek.dorado.data.Dataset
把用户对Dataset中数据的操作更新到外部数据中.
update() - Method in class com.bstek.dorado.data.DatasetAdapter
把用户对Dataset中数据的操作更新到外部数据中.
update() - Method in class com.bstek.dorado.data.DatasetSupport
把用户对Dataset中数据的操作更新到外部数据中.
update() - Method in class com.bstek.dorado.data.Index
检查并更新当前的Index，使其能够正确的反应Dataset中当前的数据。
update(DoradoContext, UpdateBatch) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. {@inheritDoc}
update() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
把用户对Dataset中数据的操作更新到外部数据中.
updateData(DoradoContext, String, Dataset) - Method in class com.bstek.dorado.module.AbstractModule
Deprecated. 当某个Dataset中的数据将要被持久化时触发的方法。
updateData(String, ViewDataset) - Method in class com.bstek.dorado.view.AbstractViewModel
Deprecated.
updateData(ParameterSet) - Method in interface com.bstek.dorado.view.ViewModel
对ViewModel中的Dataset进行持久化。
updateData(ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
对ViewModel中的Dataset进行持久化。
updateDataset(ViewModel, RecordInfo) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
updateDeletedRecord(UpdateSqlInfo, Record) - Method in class com.bstek.dorado.data.db.DBDataset
向数据库中更新一条删除的记录。
updateDetailDatasets() - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
updateDetailDatasets
updateDetailKeys() - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
updateDetailKeys
updateModifiedRecord(UpdateSqlInfo, Record) - Method in class com.bstek.dorado.data.db.DBDataset
向数据库中更新一条修改过的记录。
updateNewRecord(UpdateSqlInfo, Record) - Method in class com.bstek.dorado.data.db.DBDataset
向数据库中更新数据一条新增的记录。
updateRecord(Dataset, Record, int) - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
updateRecord
updateSourceDataset(Dataset) - Method in class com.bstek.dorado.view.data.AbstractDatasetReference
updateSourceDataset

V

VERTICAL - Static variable in class com.bstek.dorado.view.control.autoform.AutoForm
AutoForm中Group的布局方式 - 垂直方式
VIEW - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - View.用于访问视图模型(ViewModel)的Properties中的属性值.
VIEWPROPERTIES_CONTEXT_ATTRIBUTE - Static variable in class com.bstek.dorado.view.ViewPropertiesHelper
VISIBLE - Static variable in class com.bstek.dorado.view.control.DataPilot
VISIBLE - Static variable in class com.bstek.dorado.view.control.autoform.FormElement
Validator - interface com.bstek.dorado.view.data.validate.Validator.
校验器的基类
ValidatorFactory - interface com.bstek.dorado.view.data.validate.ValidatorFactory.
ValidatorInfo - class com.bstek.dorado.view.data.validate.impl.ValidatorInfo.
校验信息对象
ValidatorInfo() - Constructor for class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
Variant - class com.bstek.dorado.utils.variant.Variant.
可支持多种类型的对象
Variant() - Constructor for class com.bstek.dorado.utils.variant.Variant
Variant
Variant(int) - Constructor for class com.bstek.dorado.utils.variant.Variant
Variant
VariantHelper - class com.bstek.dorado.utils.variant.VariantHelper.
Variant的一些辅助操作
VariantSet - class com.bstek.dorado.utils.variant.VariantSet.
一组可支持多种类型的数据对象。
VariantSet() - Constructor for class com.bstek.dorado.utils.variant.VariantSet
构造器
VelocityHelper - class com.bstek.dorado.common.VelocityHelper.
ViewBaseField - class com.bstek.dorado.view.data.ViewBaseField.
视图模型中数据字段的基础类
ViewBaseField(String) - Constructor for class com.bstek.dorado.view.data.ViewBaseField
构造器
ViewDataset - interface com.bstek.dorado.view.data.ViewDataset.
视图模型中数据集对象的基础类
ViewDatasetAdapter - class com.bstek.dorado.view.data.ViewDatasetAdapter.
视图模型数据集适配器
ViewDatasetAdapter(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.ViewDatasetAdapter
构造器
ViewDatasetSupport - class com.bstek.dorado.view.data.ViewDatasetSupport.
视图数据集的抽象基类。
ViewDatasetSupport(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.ViewDatasetSupport
AbstractViewDataset
ViewField - interface com.bstek.dorado.view.data.ViewField.
视图模型中数据集字段对象
ViewFieldFactory - class com.bstek.dorado.view.data.ViewFieldFactory.
ViewFieldFactory() - Constructor for class com.bstek.dorado.view.data.ViewFieldFactory
ViewLookupField - class com.bstek.dorado.view.data.ViewLookupField.
视图模型中LookupField对象
ViewLookupField(String) - Constructor for class com.bstek.dorado.view.data.ViewLookupField
构造器
ViewModel - interface com.bstek.dorado.view.ViewModel.
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.
ViewModelCacheInfo - class com.bstek.dorado.view.ViewModelCacheInfo.
视图模型的缓存信息类
ViewModelCacheInfo() - Constructor for class com.bstek.dorado.view.ViewModelCacheInfo
ViewModelFactory - interface com.bstek.dorado.view.ViewModelFactory.
ViewModelManager - class com.bstek.dorado.view.ViewModelManager.
ViewModelSupport - class com.bstek.dorado.view.ViewModelSupport.
视图模型的基本实现
ViewModelSupport() - Constructor for class com.bstek.dorado.view.ViewModelSupport
ViewModelSupport
ViewPropertiesHelper - class com.bstek.dorado.view.ViewPropertiesHelper.
ViewRecord - class com.bstek.dorado.view.data.ViewRecord.
视图模型中Dataset的记录对象
ViewRecord() - Constructor for class com.bstek.dorado.view.data.ViewRecord
ViewRecordFactory - class com.bstek.dorado.view.data.ViewRecordFactory.
ViewRecordFactory() - Constructor for class com.bstek.dorado.view.data.ViewRecordFactory
Visible - interface com.bstek.dorado.view.control.Visible.
validate() - Method in class com.bstek.dorado.data.Record
检查对记录所作的修改的有效性。
validate(String) - Static method in class com.bstek.dorado.utils.StringHelper
将传入的字符串转换成一个有效的字符串
validate() - Method in class com.bstek.dorado.view.data.ViewRecord
检查对记录所作的修改的有效性。
validate(Object) - Method in interface com.bstek.dorado.view.data.validate.Validator
执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.CustomValidator
执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.ListValidator
执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.RequiredValidator
执行校验.如果校验失败将抛出IllegalValueException异常.
validateCursor() - Method in class com.bstek.dorado.data.DatasetSupport
validateCurrent
validateObject(Object, Object) - Method in class com.bstek.dorado.module.PoolableModuleFactory
validateObject
validateRecord() - Method in class com.bstek.dorado.data.DatasetSupport
{@inheritDoc}
validators() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得字段相关的所有校验器对象得集合对象(List)。
validators() - Method in interface com.bstek.dorado.view.data.ViewField
取得字段相关的所有校验器对象得集合对象(List)。
validators() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得字段相关的所有校验器对象得集合对象(List)。
values() - Method in class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
variantSetToDO(VariantSet, Object) - Static method in class com.bstek.dorado.data.DOUtils
将给定的变量集合中包含的数据设置到给定的对象当中.
viewModel - Variable in class com.bstek.dorado.view.control.AbstractControl

W

warn(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_WARN 的字符串记录到日志文件里。
warn(Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
warn(Object, Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
warn(Object) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_WARN 的字符串记录到日志文件里。
warn(Throwable) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
warn(Object, Throwable) - Method in interface com.bstek.dorado.common.log.Logger
把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。

X

XmlBuilder - interface com.bstek.dorado.utils.xml.XmlBuilder.
XML构造器的接口
XmlConfigUtils - class com.bstek.dorado.utils.xml.XmlConfigUtils.
用于辅助XML到Object解析过程的工具类。
XmlDocument - interface com.bstek.dorado.utils.xml.XmlDocument.
用于封装第三方的XML解析器中的文档对象。
XmlFactory - class com.bstek.dorado.utils.xml.XmlFactory.
XML解析对象的工厂类。
XmlNode - interface com.bstek.dorado.utils.xml.XmlNode.
用于封装第三方的XML解析器中的XML节点对象。
XmlOutputter - interface com.bstek.dorado.utils.xml.XmlOutputter.
XML输出器的接口。
XmlParseException - exception com.bstek.dorado.utils.xml.XmlParseException.
Xml解析异常
XmlParseException() - Constructor for class com.bstek.dorado.utils.xml.XmlParseException
XmlParseException
XmlParseException(String) - Constructor for class com.bstek.dorado.utils.xml.XmlParseException
XmlParseException
XmlParseException(Throwable) - Constructor for class com.bstek.dorado.utils.xml.XmlParseException
DoradoException

_

_DatasetEvent - class com.bstek.dorado.data._DatasetEvent.
_DatasetEvent() - Constructor for class com.bstek.dorado.data._DatasetEvent
_MockDatasetListener - class com.bstek.dorado.data._MockDatasetListener.
_MockDatasetListener() - Constructor for class com.bstek.dorado.data._MockDatasetListener
_MockRecordListener - class com.bstek.dorado.data._MockRecordListener.
_MockRecordListener() - Constructor for class com.bstek.dorado.data._MockRecordListener
_MockSynchroTimer - class com.bstek.dorado.utils._MockSynchroTimer.
_MockSynchroTimer(int) - Constructor for class com.bstek.dorado.utils._MockSynchroTimer
_RecordEvent - class com.bstek.dorado.data._RecordEvent.
_RecordEvent() - Constructor for class com.bstek.dorado.data._RecordEvent
_TestAll - class com.bstek.dorado._TestAll.
_TestAll(String) - Constructor for class com.bstek.dorado._TestAll
_TestAll - class com.bstek.dorado.common._TestAll.
_TestAll(String) - Constructor for class com.bstek.dorado.common._TestAll
_TestAll - class com.bstek.dorado.common.ds._TestAll.
_TestAll(String) - Constructor for class com.bstek.dorado.common.ds._TestAll
_TestAll - class com.bstek.dorado.data._TestAll.
_TestAll(String) - Constructor for class com.bstek.dorado.data._TestAll
_TestAll - class com.bstek.dorado.data.db._TestAll.
_TestAll(String) - Constructor for class com.bstek.dorado.data.db._TestAll
_TestAll - class com.bstek.dorado.module._TestAll.
_TestAll(String) - Constructor for class com.bstek.dorado.module._TestAll
_TestEncrypt - class com.bstek.dorado.utils.codec._TestEncrypt.
_TestEncrypt() - Constructor for class com.bstek.dorado.utils.codec._TestEncrypt
_TestIndex - class com.bstek.dorado.data._TestIndex.
_TestIndex() - Constructor for class com.bstek.dorado.data._TestIndex
_TestJdbcDataSourceConfig - class com.bstek.dorado.common.ds._TestJdbcDataSourceConfig.
_TestJdbcDataSourceConfig() - Constructor for class com.bstek.dorado.common.ds._TestJdbcDataSourceConfig
_TestMasterDetailLink - class com.bstek.dorado.view.data._TestMasterDetailLink.
_TestMasterDetailLink() - Constructor for class com.bstek.dorado.view.data._TestMasterDetailLink
_TestObjectList - class com.bstek.dorado.utils.collection._TestObjectList.
_TestObjectList() - Constructor for class com.bstek.dorado.utils.collection._TestObjectList
_TestPool - class com.bstek.dorado.common.ds._TestPool.
_TestPool() - Constructor for class com.bstek.dorado.common.ds._TestPool
_TestRecordSet - class com.bstek.dorado.data._TestRecordSet.
_TestRecordSet() - Constructor for class com.bstek.dorado.data._TestRecordSet
_TestResourceManager - class com.bstek.dorado.i18n._TestResourceManager.
_TestResourceManager() - Constructor for class com.bstek.dorado.i18n._TestResourceManager
_TestSafeCode - class com.bstek.dorado.utils.codec._TestSafeCode.
_TestSafeCode() - Constructor for class com.bstek.dorado.utils.codec._TestSafeCode
_TestStringHelper - class com.bstek.dorado.utils._TestStringHelper.
_TestStringHelper() - Constructor for class com.bstek.dorado.utils._TestStringHelper
_TestSynchroTimer - class com.bstek.dorado.utils._TestSynchroTimer.
_TestSynchroTimer() - Constructor for class com.bstek.dorado.utils._TestSynchroTimer
_TestSystemVariable - class com.bstek.dorado.utils._TestSystemVariable.
_TestSystemVariable() - Constructor for class com.bstek.dorado.utils._TestSystemVariable
_TestVariant - class com.bstek.dorado.utils.variant._TestVariant.
_TestVariant() - Constructor for class com.bstek.dorado.utils.variant._TestVariant
_TestVariantSet - class com.bstek.dorado.utils.variant._TestVariantSet.
_TestVariantSet() - Constructor for class com.bstek.dorado.utils.variant._TestVariantSet
_TestXmlDocument - class com.bstek.dorado.utils.xml._TestXmlDocument.
_TestXmlDocument() - Constructor for class com.bstek.dorado.utils.xml._TestXmlDocument
_children - Variable in class com.bstek.dorado.view.control.tree.TreeNode
A B C D E F G H I J K L M N O P Q R S T U V W X _
Overview Package Class Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Overview

PREV NEXT FRAMES NO FRAMES

dorado5 server api

Packages
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类
com.bstek.dorado.common | Dorado系统中的一些通用类
com.bstek.dorado.common.ds | 一些用于获取各类数据连接(java.sql.Connection)的工具类
com.bstek.dorado.common.fileloader | Dorado内部用于查找和读取各种配置文件的工具类
com.bstek.dorado.common.log | Dorado系统日志的相关类
com.bstek.dorado.common.rtexpr | 用于支持运行时变量(例如: EL表达式)的工具类
com.bstek.dorado.common.rtexpr.impl | EL表达式相关的实现类
com.bstek.dorado.common.scope | 用于支持对象的缓存和查找的工具类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.custom | 实现可自定义数据集
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.i18n | 用于支持国际化
com.bstek.dorado.module | 数据模块的相关类
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.utils | Dorado的基本工具类
com.bstek.dorado.utils.codec | 包含用于支持字符代码转换的工具类
com.bstek.dorado.utils.collection | 对象集合类
com.bstek.dorado.utils.http | 一些与HTTP相关的工具类
com.bstek.dorado.utils.variant | 包含用于实现多态数据类型的类
com.bstek.dorado.utils.xml | 与XML相关的工具类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate | 数据校验器的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Action

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action
Interface Action

public interface Action

Action的接口

在运行时创建的对象，当用户激活一个Action时系统会自动创建此对象。

Version:
4.0

Method Summary
void | addMessage(java.lang.String msg) 向当前的Action中追加一条消息。
ActionForward | findDefaultForward() 查找一个默认的ActionForward对象。
ActionException | findException(java.lang.Throwable t) 根据一个给定的Throwable对象查找一个可用的ActionException对象。
ActionForward | findForward(java.lang.String name) 根据别名查找一个可用的ActionForward对象。
ActionConfig | getConfig() 取得对应的ActionConfig
Controller | getController() getController
java.lang.String | getName() 取得Action的别名
Action | getPrevAction() 返回在本次请求中上一个被处理的Action对象
void | init(ActionConfig config, javax.servlet.ServletRequest request) 初始化Action对象
ActionForward | newForward(java.lang.String path) 用给定的path创建并返回一个临时的ActionForward对象。
ActionForward | newForward(java.lang.String path, boolean redirect) 用给定的path创建并返回一个临时的ActionForward对象。

Method Detail

init

public void init(ActionConfig config,
                 javax.servlet.ServletRequest request)
初始化Action对象

Parameters:
config - 对应的ActionConfig
request - ServletRequest

getName

public java.lang.String getName()
取得Action的别名

Returns:
String

getConfig

public ActionConfig getConfig()
取得对应的ActionConfig

Returns:
ActionCofnig

getController

public Controller getController()
getController

Returns:
Controller

getPrevAction

public Action getPrevAction()
返回在本次请求中上一个被处理的Action对象

Returns:
Action

findForward

public ActionForward findForward(java.lang.String name)
根据别名查找一个可用的ActionForward对象。此函数回首先在当前Action中查找。如果未能找到 匹配的对象，系统将继续到Action所属的Unit中去查找，继而到Global Unit中查找。

Parameters:
name - String
Returns:
ActionForward

findDefaultForward

public ActionForward findDefaultForward()
查找一个默认的ActionForward对象。此函数回首先在当前Action中查找名为success的 ActionForward。如果无法找到匹配的对象，系统将Action中定义的第一个ActionForward。

Returns:
ActionForward

findException

public ActionException findException(java.lang.Throwable t)
根据一个给定的Throwable对象查找一个可用的ActionException对象。此函数回首先在当前 Action中查找。如果未能找到匹配的对象，系统将继续到Action所属的Unit中去查找，继而到 Global Unit中查找。

Parameters:
t - Throwable
Returns:
ActionException

newForward

public ActionForward newForward(java.lang.String path)
用给定的path创建并返回一个临时的ActionForward对象。

Parameters:
path - String
Returns:
ActionForward

newForward

public ActionForward newForward(java.lang.String path,
                                boolean redirect)
用给定的path创建并返回一个临时的ActionForward对象。

Parameters:
path - String
redirect - boolean 是否以sendRedirect的方式转向新的path。
Returns:
ActionForward

addMessage

public void addMessage(java.lang.String msg)
向当前的Action中追加一条消息。

Parameters:
msg - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionNotSuppertedException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action
Class ActionNotSuppertedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by com.bstek.dorado.utils.DoradoException
                extended by com.bstek.dorado.action.ActionNotSuppertedException
All Implemented Interfaces:
java.io.Serializable
public class ActionNotSuppertedException
extends DoradoException

无法找到指定的Action的异常。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
ActionNotSuppertedException()
构造器
ActionNotSuppertedException(java.lang.String action)
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ActionNotSuppertedException

public ActionNotSuppertedException()
构造器

ActionNotSuppertedException

public ActionNotSuppertedException(java.lang.String action)
构造器

Parameters:
action - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Constants

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action
Class Constants

java.lang.Object
    extended by com.bstek.dorado.action.Constants
public class Constants
extends java.lang.Object

DoradoAction模块中的一些常量

Version:
4.0

Field Summary
static java.lang.String | ACTION_MESSAGE_KEY 用于在Request中保存某Action的消息集合对象的Attribute键值
static java.lang.String | CURRENT_ACTION_ATTR_KEY 用于在Request中保存当前Action的Attribute键值
static java.lang.String | JSP_EXCEPTION_KEY 用于在Request中保存当前的例外对象Attribute键值
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

JSP_EXCEPTION_KEY

public static final java.lang.String JSP_EXCEPTION_KEY
用于在Request中保存当前的例外对象Attribute键值

See Also:
Constant Field Values

CURRENT_ACTION_ATTR_KEY

public static final java.lang.String CURRENT_ACTION_ATTR_KEY
用于在Request中保存当前Action的Attribute键值

See Also:
Constant Field Values

ACTION_MESSAGE_KEY

public static final java.lang.String ACTION_MESSAGE_KEY
用于在Request中保存某Action的消息集合对象的Attribute键值

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Controller

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action
Class Controller

java.lang.Object
    extended by com.bstek.dorado.action.Controller
Direct Known Subclasses:
FileController
public abstract class Controller
extends java.lang.Object

在运行时的Controller对象，当用户激活一个Controller时系统会自动创建此对象。

Version:
4.0

Field Summary
static java.lang.String CACHE_ATTRIBUTE_PREFIX
系统缓存Controller时使用的Attribute名的前缀
Constructor Summary
Controller()
Method Summary
protected void | checkAccess(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 按系统默认的方式判断当前用户是否已登录
ActionForward | doAction(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 执行默认的Action。
protected ActionForward | doDispatch(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 系统内部用于完成分派Action处理的方法。
ControllerConfig | getConfig() 取得对应的ControllerConfig对象
java.lang.String | getName() 取得Controller的别名。
void | invokeAction(java.lang.String actionName, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 调用Controller中名为actionName的Action。
protected static void | processException(java.lang.Throwable t, Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 处理一个在Action执行过程中发生的异常。
protected void | processForward(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response, ActionForward forward) 处理Action的转向。
void | setConfig(ControllerConfig config) 设定Controller对应的Mapping配置信息。
void | setName(java.lang.String name) 设定Controller的别名。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CACHE_ATTRIBUTE_PREFIX

public static final java.lang.String CACHE_ATTRIBUTE_PREFIX
系统缓存Controller时使用的Attribute名的前缀

See Also:
Constant Field Values
Constructor Detail

Controller

public Controller()
Method Detail

getName

public java.lang.String getName()
取得Controller的别名。

Returns:
String

setName

public void setName(java.lang.String name)
设定Controller的别名。

Parameters:
name - String

getConfig

public ControllerConfig getConfig()
取得对应的ControllerConfig对象

Returns:
ControllerConfig

setConfig

public void setConfig(ControllerConfig config)
设定Controller对应的Mapping配置信息。

Parameters:
config - ControllerConfig

invokeAction

public void invokeAction(java.lang.String actionName,
                         javax.servlet.http.HttpServletRequest request,
                         javax.servlet.http.HttpServletResponse response)
                  throws java.lang.Throwable
调用Controller中名为actionName的Action。此方法一般由系统调用。

Parameters:
actionName - String
request - HttpServletRequest
response - HttpServletResponse
Throws:
java.lang.Throwable

doAction

public ActionForward doAction(Action action,
                              javax.servlet.http.HttpServletRequest request,
                              javax.servlet.http.HttpServletResponse response)
                       throws java.lang.Throwable
执行默认的Action。即当用户未指定要执行的Action时，系统将自动调用此方法。

Parameters:
action - Action
request - HttpServletRequest
response - HttpServletResponse
Returns:
ActionForward 返回执行完此Action之后系统将要激活的ActionForward对象
Throws:
java.lang.Throwable

doDispatch

protected ActionForward doDispatch(Action action,
                                   javax.servlet.http.HttpServletRequest request,
                                   javax.servlet.http.HttpServletResponse response)
                            throws java.lang.Throwable
系统内部用于完成分派Action处理的方法。用户可在子类中覆盖此方法以改变Controller的行为。

Parameters:
action - Action
request - HttpServletRequest
response - HttpServletResponse
Returns:
ActionForward
Throws:
java.lang.Throwable

processForward

protected void processForward(javax.servlet.http.HttpServletRequest request,
                              javax.servlet.http.HttpServletResponse response,
                              ActionForward forward)
                       throws java.lang.Throwable
处理Action的转向。

Parameters:
request - HttpServletRequest
response - HttpServletResponse
forward - ActionForward
Throws:
ServletException
IOException
java.lang.Throwable

processException

protected static void processException(java.lang.Throwable t,
                                       Action action,
                                       javax.servlet.http.HttpServletRequest request,
                                       javax.servlet.http.HttpServletResponse response)
处理一个在Action执行过程中发生的异常。

Parameters:
t - Throwable
action - Action
request - HttpServletRequest
response - HttpServletResponse

checkAccess

protected void checkAccess(Action action,
                           javax.servlet.http.HttpServletRequest request,
                           javax.servlet.http.HttpServletResponse response)
                    throws AccessDeniedException
按系统默认的方式判断当前用户是否已登录

Parameters:
action - HttpSession
request - HttpServletRequest
response - HttpServletResponse
Throws:
AccessDeniedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ControllerManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action
Class ControllerManager

java.lang.Object
    extended by com.bstek.dorado.action.ControllerManager
public class ControllerManager
extends java.lang.Object

Controller管理器

用于完成创建、查找Controller等功能

Version:
4.0

Method Summary
static Controller | getController(javax.servlet.http.HttpServletRequest request, java.lang.String name) 根据给定名称从指定的资源中查找并返回一个Controller的实例。
static com.bstek.dorado.action.ControllerFactory | getControllerFactory() 获得系统内部使用的Controller工厂。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getControllerFactory

public static com.bstek.dorado.action.ControllerFactory getControllerFactory()
                                                                      throws java.lang.Throwable
获得系统内部使用的Controller工厂。具体的工厂类应在global.map.xml进行配置。

Returns:
ControllerFactory
Throws:
java.lang.Throwable

getController

public static Controller getController(javax.servlet.http.HttpServletRequest request,
                                       java.lang.String name)
                                throws java.lang.Throwable
根据给定名称从指定的资源中查找并返回一个Controller的实例。如果无法找到则根据给定的类名创建 一个新的实例，并存入相应的资源。

Parameters:
request - HttpServletRequest
name - String
Returns:
Controller
Throws:
java.lang.Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ControllerNotFoundException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action
Class ControllerNotFoundException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by com.bstek.dorado.utils.DoradoException
                extended by com.bstek.dorado.action.ControllerNotFoundException
All Implemented Interfaces:
java.io.Serializable
public class ControllerNotFoundException
extends DoradoException

无法找到指定的Controller的异常。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
ControllerNotFoundException()
构造器
ControllerNotFoundException(java.lang.String name)
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ControllerNotFoundException

public ControllerNotFoundException()
构造器

ControllerNotFoundException

public ControllerNotFoundException(java.lang.String name)
构造器

Parameters:
name - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.action

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.action

实现Dorado的Controller部分的功能。

See:
Description

Interface Summary
Action Action的接口 在运行时创建的对象，当用户激活一个Action时系统会自动创建此对象。

Class Summary
Constants | DoradoAction模块中的一些常量
Controller | 在运行时的Controller对象，当用户激活一个Controller时系统会自动创建此对象。
ControllerManager | Controller管理器 用于完成创建、查找Controller等功能

Exception Summary
ActionNotSuppertedException | 无法找到指定的Action的异常。
ControllerNotFoundException | 无法找到指定的Controller的异常。

Package com.bstek.dorado.action Description

实现Dorado的Controller部分的功能。Controller部分用于接收和分派Client请求，配置Controller和View的关系。

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ActionConfig

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class ActionConfig

java.lang.Object
    extended by com.bstek.dorado.action.mapping.ActionConfig
All Implemented Interfaces:
ActionTargetCollection
public class ActionConfig
extends java.lang.Object
implements ActionTargetCollection

对应一个Action的Mapping配置信息

Version:
4.0

Constructor Summary
ActionConfig(java.lang.String name)
构造器
Method Summary
void | addException(ActionException exception) 添加一个ActionException子对象
void | addForward(ActionForward forward) 添加一个ActionForward子对象
ActionForward | findDefaultForward() 查找一个默认的ActionForward对象。
ActionException | findException(java.lang.Throwable t) 根据一个给定的Throwable对象查找一个可用的ActionException对象。
ActionForward | findForward(java.lang.String name) 根据别名查找一个可用的ActionForward对象。
ControllerConfig | getController() 取得该Action所属的Controller对象
java.lang.String | getDescription() Action的描述信息。
ActionException | getException(int index) 根据给定的索引号得到一个ActionException子对象
ActionException | getException(java.lang.Throwable t) 根据给定的异常得到一个ActionException子对象
int | getExceptionCount() 返回ActionException的个数
ActionForward | getForward(int index) 根据给定的索引号得到一个ActionForward子对象
ActionForward | getForward(java.lang.String name) 根据给定的别名得到一个ActionForward子对象
int | getForwardCount() 返回ActionForward的个数
java.lang.String | getName() Action的别名
java.lang.String | getTag() 取得自定义信息.此属性中的值用户可以自行解释,dorado不会做任何处理.
void | setDescription(java.lang.String description) Action的描述信息。
void | setTag(java.lang.String tag) 设定自定义信息.此属性中的值用户可以自行解释,dorado不会做任何处理.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionConfig

public ActionConfig(java.lang.String name)
构造器

Parameters:
name - String Action的别名
Method Detail

getName

public java.lang.String getName()
Action的别名

Returns:
String

getDescription

public java.lang.String getDescription()
Action的描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Returns:
String

setDescription

public void setDescription(java.lang.String description)
Action的描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Parameters:
description - String

findForward

public ActionForward findForward(java.lang.String name)
根据别名查找一个可用的ActionForward对象。此函数回首先在当前Action中查找。如果未能找到 匹配的对象，系统将继续到Action所属的Unit中去查找，继而到Global Unit中查找。

Parameters:
name - String
Returns:
ActionForward

findDefaultForward

public ActionForward findDefaultForward()
查找一个默认的ActionForward对象。此函数回首先在当前Action中查找名为success的 ActionForward。如果无法找到匹配的对象，系统将Action中定义的第一个ActionForward。

Returns:
ActionForward

findException

public ActionException findException(java.lang.Throwable t)
根据一个给定的Throwable对象查找一个可用的ActionException对象。此函数回首先在当前 Action中查找。如果未能找到匹配的对象，系统将继续到Action所属的Unit中去查找，继而到 Global Unit中查找。

Parameters:
t - Throwable
Returns:
ActionException

getController

public ControllerConfig getController()
取得该Action所属的Controller对象

Returns:
ControllerConfig

addForward

public void addForward(ActionForward forward)
添加一个ActionForward子对象

Specified by:
addForward in interface ActionTargetCollection
Parameters:
forward - ActionForward

getForward

public ActionForward getForward(java.lang.String name)
根据给定的别名得到一个ActionForward子对象

Specified by:
getForward in interface ActionTargetCollection
Parameters:
name - String ActionForward的别名
Returns:
ActionForward

getForward

public ActionForward getForward(int index)
根据给定的索引号得到一个ActionForward子对象

Specified by:
getForward in interface ActionTargetCollection
Parameters:
index - int 索引号
Returns:
ActionForward

getForwardCount

public int getForwardCount()
返回ActionForward的个数

Specified by:
getForwardCount in interface ActionTargetCollection
Returns:
int

addException

public void addException(ActionException exception)
添加一个ActionException子对象

Specified by:
addException in interface ActionTargetCollection
Parameters:
exception - ActionException

getException

public ActionException getException(java.lang.Throwable t)
根据给定的异常得到一个ActionException子对象

Specified by:
getException in interface ActionTargetCollection
Parameters:
t - Throwable 异常的类型
Returns:
ActionException

getException

public ActionException getException(int index)
根据给定的索引号得到一个ActionException子对象

Specified by:
getException in interface ActionTargetCollection
Parameters:
index - int 索引号
Returns:
ActionException

getExceptionCount

public int getExceptionCount()
返回ActionException的个数

Specified by:
getExceptionCount in interface ActionTargetCollection
Returns:
int

getTag

public java.lang.String getTag()
取得自定义信息.此属性中的值用户可以自行解释,dorado不会做任何处理.

Returns:
String

setTag

public void setTag(java.lang.String tag)
设定自定义信息.此属性中的值用户可以自行解释,dorado不会做任何处理.

Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class ActionException

java.lang.Object
    extended by com.bstek.dorado.action.mapping.ActionTarget
        extended by com.bstek.dorado.action.mapping.ActionException
public class ActionException
extends ActionTarget

Request的跳转目标。此对象专用于描述当系统在执行过程中发生异常时将要跳转的位置。

Version:
4.0

Constructor Summary
ActionException(java.lang.String clazz)
构造器
Method Summary
java.lang.String | getType() 要捕捉的异常的名称。
java.lang.Class | getTypeClass() 要捕捉的异常的Class类型
Methods inherited from class com.bstek.dorado.action.mapping.ActionTarget
getDescription, getPath, getRealPath, getTag, getUnit, isContextRelative, setContextRelative, setDescription, setPath, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionException

public ActionException(java.lang.String clazz)
                throws java.lang.ClassNotFoundException
构造器

Parameters:
clazz - String 此对象要捕捉的异常的名称。
Method Detail

getType

public java.lang.String getType()
要捕捉的异常的名称。此名称应当是异常的类名，例如：
com.bstek.dorado.control.ControllerNotFoundException
对于java.lang包中的异常可以省略包名，例如:
RuntimeException
如果此名称为空，则捕捉Throwable。

Returns:
String

getTypeClass

public java.lang.Class getTypeClass()
要捕捉的异常的Class类型

Returns:
Class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionForward

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class ActionForward

java.lang.Object
    extended by com.bstek.dorado.action.mapping.ActionTarget
        extended by com.bstek.dorado.action.mapping.ActionForward
public class ActionForward
extends ActionTarget

Request的跳转目标。此对象专用于表示当系统成功的完成操作后将要跳转的位置。

Version:
4.0

Constructor Summary
ActionForward(java.lang.String name)
构造器
ActionForward(java.lang.String name, java.lang.String path)
构造器
ActionForward(java.lang.String name, java.lang.String path, boolean redirect)
构造器
Method Summary
java.lang.String | getName() 此对象的别名
boolean | isRedirect() 是否以sendRedirect的方式转向新的path。
void | setRedirect(boolean redirect) 是否以sendRedirect的方式转向新的path。
Methods inherited from class com.bstek.dorado.action.mapping.ActionTarget
getDescription, getPath, getRealPath, getTag, getUnit, isContextRelative, setContextRelative, setDescription, setPath, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionForward

public ActionForward(java.lang.String name)
构造器

Parameters:
name - String ActionForward的别名

ActionForward

public ActionForward(java.lang.String name,
                     java.lang.String path)
构造器

Parameters:
name - String ActionForward的别名
path - String 跳转目标的路径

ActionForward

public ActionForward(java.lang.String name,
                     java.lang.String path,
                     boolean redirect)
构造器

Parameters:
name - String ActionForward的别名
path - String 跳转目标的路径
redirect - boolean
Method Detail

getName

public java.lang.String getName()
此对象的别名

Returns:
String

isRedirect

public boolean isRedirect()
是否以sendRedirect的方式转向新的path。
如果此属性的值为false，那么系统将利用request.getRequestDispatcher的方式将request 传向新的位置。
如果此属性的值为true，那么系统将利用response.sendRedirect的方式将request 传向新的位置。

Returns:
boolean

setRedirect

public void setRedirect(boolean redirect)
是否以sendRedirect的方式转向新的path。
如果此属性的值为false，那么系统将利用request.getRequestDispatcher的方式将request 传向新的位置。
如果此属性的值为true，那么系统将利用response.sendRedirect的方式将request 传向新的位置。

Parameters:
redirect - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionTarget

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class ActionTarget

java.lang.Object
    extended by com.bstek.dorado.action.mapping.ActionTarget
Direct Known Subclasses:
ActionException, ActionForward
public abstract class ActionTarget
extends java.lang.Object

Request的跳转目标。用于描述当系统完成了一个Action的处理之后将要跳转到的位置。

Version:
4.0

Constructor Summary
ActionTarget()
Method Summary
java.lang.String | getDescription() 获得描述信息。
java.lang.String | getPath() 跳转目标的路径
java.lang.String | getRealPath() 返回真正可利用的Path。
java.lang.String | getTag() 获得自定义信息。
Unit | getUnit() 返回此对象所隶属的Unit。
boolean | isContextRelative() 此对象的Path属性所描述的URL是否是一个相对路径，此属性的默认值是true。
void | setContextRelative(boolean contextRelative) 设置此对象的Path属性，所描述的URL是否是一个相对路径，此属性的默认值是true。
void | setDescription(java.lang.String description) 设定描述信息。
void | setPath(java.lang.String path) 跳转目标的路径
void | setTag(java.lang.String tag) 设置自定义信息。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionTarget

public ActionTarget()
Method Detail

getPath

public java.lang.String getPath()
跳转目标的路径

Returns:
String

setPath

public void setPath(java.lang.String path)
跳转目标的路径

Parameters:
path - String

isContextRelative

public boolean isContextRelative()
此对象的Path属性所描述的URL是否是一个相对路径，此属性的默认值是true。

Returns:
boolean

setContextRelative

public void setContextRelative(boolean contextRelative)
设置此对象的Path属性，所描述的URL是否是一个相对路径，此属性的默认值是true。

Parameters:
contextRelative - boolean

getUnit

public Unit getUnit()
返回此对象所隶属的Unit。

Returns:
Unit

getRealPath

public java.lang.String getRealPath()
返回真正可利用的Path。此Path可直接通过Forward或SendRedirect进行处理。

Returns:
String

getDescription

public java.lang.String getDescription()
获得描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Returns:
String

setDescription

public void setDescription(java.lang.String description)
设定描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Parameters:
description - String

getTag

public java.lang.String getTag()
获得自定义信息。

Returns:
String

setTag

public void setTag(java.lang.String tag)
设置自定义信息。

Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionTargetCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Interface ActionTargetCollection

All Known Implementing Classes:
ActionConfig, Unit
public interface ActionTargetCollection

用于管理一组ActionForward和ActionException的对象

Version:
4.0

Method Summary
void | addException(ActionException exception) 添加一个ActionException子对象
void | addForward(ActionForward forward) 添加一个ActionForward子对象
ActionException | getException(int index) 根据给定的索引号得到一个ActionException子对象
ActionException | getException(java.lang.Throwable t) 根据给定的异常得到一个ActionException子对象
int | getExceptionCount() 返回ActionException的个数
ActionForward | getForward(int index) 根据给定的索引号得到一个ActionForward子对象
ActionForward | getForward(java.lang.String name) 根据给定的别名得到一个ActionForward子对象
int | getForwardCount() 返回ActionForward的个数

Method Detail

addForward

public void addForward(ActionForward forward)
添加一个ActionForward子对象

Parameters:
forward - ActionForward

getForward

public ActionForward getForward(java.lang.String name)
根据给定的别名得到一个ActionForward子对象

Parameters:
name - String ActionForward的别名
Returns:
ActionForward

getForward

public ActionForward getForward(int index)
根据给定的索引号得到一个ActionForward子对象

Parameters:
index - int 索引号
Returns:
ActionForward

getForwardCount

public int getForwardCount()
返回ActionForward的个数

Returns:
int

addException

public void addException(ActionException exception)
添加一个ActionException子对象

Parameters:
exception - ActionException

getException

public ActionException getException(java.lang.Throwable t)
根据给定的异常得到一个ActionException子对象

Parameters:
t - Throwable 异常的类型
Returns:
ActionException

getException

public ActionException getException(int index)
根据给定的索引号得到一个ActionException子对象

Parameters:
index - int 索引号
Returns:
ActionException

getExceptionCount

public int getExceptionCount()
返回ActionException的个数

Returns:
int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ControllerConfig

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class ControllerConfig

java.lang.Object
    extended by com.bstek.dorado.action.mapping.ControllerConfig
public class ControllerConfig
extends java.lang.Object

对应一个Controller的Mapping配置信息

Version:
4.0

Constructor Summary
ControllerConfig(java.lang.String name)
构造器
Method Summary
void | addAction(ActionConfig action) 添加一个ActionConfig
ActionConfig | getAction(int index) 根据索引号得到一个ActionConfig
ActionConfig | getAction(java.lang.String name) 根据给定的别名查找一个ActionConfig
int | getActionCount() 返回ActionConfig的个数
java.lang.String | getClazz() Controller的类名
java.lang.String | getDescription() Controller的描述信息。
java.lang.String | getName() Controller的别名
java.lang.String | getScope() Model的作用域范围
java.lang.String | getTag() 用户自定义信息。
Unit | getUnit() 取得该Controller所属的Unit对象
boolean | isSafe() 返回用户访问视图页面时是否对用户身份进行检验。
void | setClazz(java.lang.String type) 设置Controller的类名
void | setDescription(java.lang.String description) Controller的描述信息。
void | setSafe(boolean safe) 设置用户访问视图页面时是否对用户身份进行检验。
void | setScope(java.lang.String scope) 设置Model的作用域范围
void | setTag(java.lang.String tag) 用户自定义信息。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ControllerConfig

public ControllerConfig(java.lang.String name)
构造器

Parameters:
name - String Controller的别名
Method Detail

getName

public java.lang.String getName()
Controller的别名

Returns:
String

getClazz

public java.lang.String getClazz()
Controller的类名

Returns:
String

setClazz

public void setClazz(java.lang.String type)
设置Controller的类名

Parameters:
type - String

getUnit

public Unit getUnit()
取得该Controller所属的Unit对象

Returns:
Unit

isSafe

public boolean isSafe()
返回用户访问视图页面时是否对用户身份进行检验。

Returns:
boolean

setSafe

public void setSafe(boolean safe)
设置用户访问视图页面时是否对用户身份进行检验。如果该属性设为True时，Dorado将通过 工程配置文件setting.xml文件中的accessChecker属性定义的安全检查类对用户进行安全检验， 只有符合规定的特定用户才允许访问该Controller对象。

Parameters:
safe - boolean

addAction

public void addAction(ActionConfig action)
添加一个ActionConfig

Parameters:
action - Action

getAction

public ActionConfig getAction(int index)
根据索引号得到一个ActionConfig

Parameters:
index - int
Returns:
ActionConfig

getAction

public ActionConfig getAction(java.lang.String name)
根据给定的别名查找一个ActionConfig

Parameters:
name - String
Returns:
Action

getActionCount

public int getActionCount()
返回ActionConfig的个数

Returns:
int

getScope

public java.lang.String getScope()
Model的作用域范围

Returns:
String

setScope

public void setScope(java.lang.String scope)
设置Model的作用域范围

Parameters:
scope - String

getDescription

public java.lang.String getDescription()
Controller的描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Returns:
String

setDescription

public void setDescription(java.lang.String description)
Controller的描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Parameters:
description - String

getTag

public java.lang.String getTag()
用户自定义信息。

Returns:
String

setTag

public void setTag(java.lang.String tag)
用户自定义信息。

Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GlobalUnit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class GlobalUnit

java.lang.Object
    extended by com.bstek.dorado.action.mapping.Unit
        extended by com.bstek.dorado.action.mapping.GlobalUnit
All Implemented Interfaces:
ActionTargetCollection
public class GlobalUnit
extends Unit

全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。

Version:
4.0

Constructor Summary
GlobalUnit(java.lang.String name)
构造器
Method Summary
java.lang.String | getSubFile(int index) 根据索引号得到一个子配置单元
int | getSubFileCount() 返回子配置单元的个数
Methods inherited from class com.bstek.dorado.action.mapping.Unit
addException, addForward, createTempForward, findForward, getController, getDescription, getException, getException, getExceptionCount, getForward, getForward, getForwardCount, getName, getPrefix, setDescription, setPrefix
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GlobalUnit

public GlobalUnit(java.lang.String name)
构造器

Parameters:
name - String 单元名
Method Detail

getSubFile

public java.lang.String getSubFile(int index)
根据索引号得到一个子配置单元

Parameters:
index - int
Returns:
String

getSubFileCount

public int getSubFileCount()
返回子配置单元的个数

Returns:
int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Mapping

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class Mapping

java.lang.Object
    extended by com.bstek.dorado.action.mapping.Mapping
public class Mapping
extends java.lang.Object

用于管理所有Mapping配置信息的对象

Version:
4.0

Constructor Summary
Mapping()
构造器
Method Summary
ControllerConfig | findController(java.lang.String name) 根据给定的别名查找一个Controller对象
ActionException | findException(java.lang.Throwable t) 根据给定的异常查找一个全局的ActionException对象，即在global中定义的ActionException。
ActionForward | findForward(java.lang.String name) 根据给定的别名查找一个全局的ActionForward对象，即在global中定义的ActionForward。
GlobalUnit | getGlobalUnit() 取得global配置单元对象
static Mapping | getInstance() 取得单例对象
Unit | getUnit(int index) 根据索引号取得一个子配置单元对象
int | getUnitCount() 根据别名取得一个子配置单元对象
static void | init() 初始化所有的Mapping信息。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Mapping

public Mapping()
构造器

Method Detail

init

public static void init()
                 throws XmlParseException,
                        java.io.FileNotFoundException,
                        java.io.IOException
初始化所有的Mapping信息。即解析所有的Mapping配置文件。

Throws:
XmlParseException
java.io.FileNotFoundException
java.io.IOException

getInstance

public static Mapping getInstance()
取得单例对象

Returns:
Mapping

getGlobalUnit

public GlobalUnit getGlobalUnit()
取得global配置单元对象

Returns:
GlobalUnit

getUnit

public Unit getUnit(int index)
根据索引号取得一个子配置单元对象

Parameters:
index - int
Returns:
Unit

getUnitCount

public int getUnitCount()
根据别名取得一个子配置单元对象

Returns:
int

findForward

public ActionForward findForward(java.lang.String name)
根据给定的别名查找一个全局的ActionForward对象，即在global中定义的ActionForward。

Parameters:
name - String ActionForward的别名
Returns:
ActionForward

findException

public ActionException findException(java.lang.Throwable t)
根据给定的异常查找一个全局的ActionException对象，即在global中定义的ActionException。

Parameters:
t - Throwable 异常的类型
Returns:
ActionException

findController

public ControllerConfig findController(java.lang.String name)
根据给定的别名查找一个Controller对象

Parameters:
name - String Controller的别名
Returns:
ControllerConfig
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.action.mapping

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.action.mapping

Dorado Controller的Mapping配置信息的解析和管理对象
See:
Description

Interface Summary
ActionTargetCollection 用于管理一组ActionForward和ActionException的对象

Class Summary
ActionConfig | 对应一个Action的Mapping配置信息
ActionException | Request的跳转目标。
ActionForward | Request的跳转目标。
ActionTarget | Request的跳转目标。
ControllerConfig | 对应一个Controller的Mapping配置信息
GlobalUnit | 全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。
Mapping | 用于管理所有Mapping配置信息的对象
SubUnit | 子配置单元的Mapping配置信息。
Unit | 对应一个Mapping配置文件，用于管理其中所有的配置信息

Package com.bstek.dorado.action.mapping Description

Dorado Controller的Mapping配置信息的解析和管理对象

Overview Package Class Use Tree Deprecated Index Help


SubUnit

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class SubUnit

java.lang.Object
    extended by com.bstek.dorado.action.mapping.Unit
        extended by com.bstek.dorado.action.mapping.SubUnit
All Implemented Interfaces:
ActionTargetCollection
public class SubUnit
extends Unit

子配置单元的Mapping配置信息。

Version:
4.0

Constructor Summary
SubUnit(java.lang.String name)
构造器
Methods inherited from class com.bstek.dorado.action.mapping.Unit
addException, addForward, createTempForward, findForward, getController, getDescription, getException, getException, getExceptionCount, getForward, getForward, getForwardCount, getName, getPrefix, setDescription, setPrefix
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubUnit

public SubUnit(java.lang.String name)
构造器

Parameters:
name - String 单元名
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Unit

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.action.mapping
Class Unit

java.lang.Object
    extended by com.bstek.dorado.action.mapping.Unit
All Implemented Interfaces:
ActionTargetCollection
Direct Known Subclasses:
GlobalUnit, SubUnit
public abstract class Unit
extends java.lang.Object
implements ActionTargetCollection

对应一个Mapping配置文件，用于管理其中所有的配置信息

Version:
4.0

Constructor Summary
Unit(java.lang.String name)
构造器
Method Summary
void | addException(ActionException exception) 添加一个ActionException子对象
void | addForward(ActionForward forward) 添加一个ActionForward子对象
ActionForward | createTempForward(java.lang.String path) 创建一个临时的Forward对象。
ActionForward | findForward(java.lang.String name) 根据别名在配置单元中查找一个ActionForward对象
ControllerConfig | getController(java.lang.String name) 根据别名查找一个Controller的配置信息
java.lang.String | getDescription() Unit的描述信息。
ActionException | getException(int index) 根据给定的索引号得到一个ActionException子对象
ActionException | getException(java.lang.Throwable t) 根据给定的异常得到一个ActionException子对象
int | getExceptionCount() 返回ActionException的个数
ActionForward | getForward(int index) 根据给定的索引号得到一个ActionForward子对象
ActionForward | getForward(java.lang.String name) 根据给定的别名得到一个ActionForward子对象
int | getForwardCount() 返回ActionForward的个数
java.lang.String | getName() 取得配置单元的名称
java.lang.String | getPrefix() 取得配置单元的URL前缀
void | setDescription(java.lang.String description) Unit的描述信息。
void | setPrefix(java.lang.String prefix) 设置配置单元的URL前缀
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Unit

public Unit(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getName

public java.lang.String getName()
取得配置单元的名称

Returns:
String

getPrefix

public java.lang.String getPrefix()
取得配置单元的URL前缀

Returns:
String

setPrefix

public void setPrefix(java.lang.String prefix)
设置配置单元的URL前缀

Parameters:
prefix - String

createTempForward

public ActionForward createTempForward(java.lang.String path)
创建一个临时的Forward对象。用于创建一些无法预先获知URL的forward。

Parameters:
path - String
Returns:
ActionForward

findForward

public ActionForward findForward(java.lang.String name)
根据别名在配置单元中查找一个ActionForward对象

Parameters:
name - String
Returns:
ActionForward

addForward

public void addForward(ActionForward forward)
添加一个ActionForward子对象

Specified by:
addForward in interface ActionTargetCollection
Parameters:
forward - ActionForward

getForward

public ActionForward getForward(java.lang.String name)
根据给定的别名得到一个ActionForward子对象

Specified by:
getForward in interface ActionTargetCollection
Parameters:
name - String ActionForward的别名
Returns:
ActionForward

getForward

public ActionForward getForward(int index)
根据给定的索引号得到一个ActionForward子对象

Specified by:
getForward in interface ActionTargetCollection
Parameters:
index - int 索引号
Returns:
ActionForward

getForwardCount

public int getForwardCount()
返回ActionForward的个数

Specified by:
getForwardCount in interface ActionTargetCollection
Returns:
int

addException

public void addException(ActionException exception)
添加一个ActionException子对象

Specified by:
addException in interface ActionTargetCollection
Parameters:
exception - ActionException

getException

public ActionException getException(java.lang.Throwable t)
根据给定的异常得到一个ActionException子对象

Specified by:
getException in interface ActionTargetCollection
Parameters:
t - Throwable 异常的类型
Returns:
ActionException

getException

public ActionException getException(int index)
根据给定的索引号得到一个ActionException子对象

Specified by:
getException in interface ActionTargetCollection
Parameters:
index - int 索引号
Returns:
ActionException

getExceptionCount

public int getExceptionCount()
返回ActionException的个数

Specified by:
getExceptionCount in interface ActionTargetCollection
Returns:
int

getController

public ControllerConfig getController(java.lang.String name)
根据别名查找一个Controller的配置信息

Parameters:
name - String
Returns:
ControllerConfig

getDescription

public java.lang.String getDescription()
Unit的描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Returns:
String

setDescription

public void setDescription(java.lang.String description)
Unit的描述信息。此信息对系统没有实际的意义，以用户可根据自己的需要令后定义。

Parameters:
description - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FileController

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.biz
Class FileController

java.lang.Object
    extended by com.bstek.dorado.action.Controller
        extended by com.bstek.dorado.biz.FileController
public abstract class FileController
extends Controller

用于协助用户完成文件上传和下载的Controller. 支持多文件的同时上传.

Version:
4.0

Field Summary
static java.lang.String | CONTENT_TYPE_DISPOSITION
static java.lang.String | CONTENT_TYPE_HTML
static java.lang.String | CONTENT_TYPE_MS_DOWNLOAD
static java.lang.String | CONTENT_TYPE_MS_EXCEL
static java.lang.String | CONTENT_TYPE_MS_POWERPOINT
static java.lang.String | CONTENT_TYPE_MS_WORD
static java.lang.String | CONTENT_TYPE_OCTET_STREAM
static java.lang.String | CONTENT_TYPE_PDF
static java.lang.String | CONTENT_TYPE_XML
Fields inherited from class com.bstek.dorado.action.Controller
CACHE_ATTRIBUTE_PREFIX
Constructor Summary
FileController()
Method Summary
ActionForward | doDownload(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 文件下载
ActionForward | doOutput(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 直接把文件显示到浏览器中
ActionForward | doUpload(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 执行文件上传
protected abstract java.io.InputStream | getDownloadFileInputStream(javax.servlet.http.HttpServletRequest request) 取得将要被下载的文件的文件输入流
protected abstract java.lang.String | getDownLoadFileName(javax.servlet.http.HttpServletRequest request) 取得将要下载的文件的文件名
protected java.lang.String | getOutputContentType(javax.servlet.http.HttpServletRequest request) 返回向Response输出时使用的ContentType
protected java.lang.String | getStoreFileName(javax.servlet.http.HttpServletRequest request, java.lang.String fileName, MetaData parameters) 取得存储上传文件的文件名
protected java.io.File | getUploadWorkDirectory(javax.servlet.http.HttpServletRequest request, MetaData parameters) 取得存放上传文件的工作目录
protected abstract void | initFileUpload(javax.servlet.http.HttpServletRequest request, org.apache.commons.fileupload.DiskFileUpload fileUpload) 设定 DiskFileUpload 的相关属性.
protected void | outputDownloadFile(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 向Response对象中写入文件数据
protected void | storeUploadFile(javax.servlet.http.HttpServletRequest request, org.apache.commons.fileupload.FileItem fileItem, java.io.File storeFile, MetaData parameters) 存储已经上传的文件
Methods inherited from class com.bstek.dorado.action.Controller
checkAccess, doAction, doDispatch, getConfig, getName, invokeAction, processException, processForward, setConfig, setName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CONTENT_TYPE_DISPOSITION

public static final java.lang.String CONTENT_TYPE_DISPOSITION
See Also:
Constant Field Values

CONTENT_TYPE_OCTET_STREAM

public static final java.lang.String CONTENT_TYPE_OCTET_STREAM
See Also:
Constant Field Values

CONTENT_TYPE_MS_DOWNLOAD

public static final java.lang.String CONTENT_TYPE_MS_DOWNLOAD
See Also:
Constant Field Values

CONTENT_TYPE_MS_WORD

public static final java.lang.String CONTENT_TYPE_MS_WORD
See Also:
Constant Field Values

CONTENT_TYPE_MS_EXCEL

public static final java.lang.String CONTENT_TYPE_MS_EXCEL
See Also:
Constant Field Values

CONTENT_TYPE_MS_POWERPOINT

public static final java.lang.String CONTENT_TYPE_MS_POWERPOINT
See Also:
Constant Field Values

CONTENT_TYPE_PDF

public static final java.lang.String CONTENT_TYPE_PDF
See Also:
Constant Field Values

CONTENT_TYPE_XML

public static final java.lang.String CONTENT_TYPE_XML
See Also:
Constant Field Values

CONTENT_TYPE_HTML

public static final java.lang.String CONTENT_TYPE_HTML
See Also:
Constant Field Values
Constructor Detail

FileController

public FileController()
Method Detail

getUploadWorkDirectory

protected java.io.File getUploadWorkDirectory(javax.servlet.http.HttpServletRequest request,
                                              MetaData parameters)
取得存放上传文件的工作目录

Parameters:
request - HttpServletRequest
parameters - MetaData
Returns:
File

initFileUpload

protected abstract void initFileUpload(javax.servlet.http.HttpServletRequest request,
                                       org.apache.commons.fileupload.DiskFileUpload fileUpload)
设定 DiskFileUpload 的相关属性.

关于DiskFileUpload, 可以到www.apache.org/commons查找FileUpload的文档

Parameters:
request - HttpServletRequest
fileUpload - DiskFileUpload

getStoreFileName

protected java.lang.String getStoreFileName(javax.servlet.http.HttpServletRequest request,
                                            java.lang.String fileName,
                                            MetaData parameters)
取得存储上传文件的文件名

Parameters:
request - HttpServletRequest
fileName - String 默认文件名
parameters - MetaData
Returns:
String

getDownLoadFileName

protected abstract java.lang.String getDownLoadFileName(javax.servlet.http.HttpServletRequest request)
取得将要下载的文件的文件名

Parameters:
request - HttpServletRequest
Returns:
String

doUpload

public ActionForward doUpload(Action action,
                              javax.servlet.http.HttpServletRequest request,
                              javax.servlet.http.HttpServletResponse response)
                       throws java.lang.Exception
执行文件上传

Parameters:
action - Action
request - HttpServletRequest
response - HttpServletResponse
Returns:
ActionForward
Throws:
java.lang.Exception

storeUploadFile

protected void storeUploadFile(javax.servlet.http.HttpServletRequest request,
                               org.apache.commons.fileupload.FileItem fileItem,
                               java.io.File storeFile,
                               MetaData parameters)
                        throws java.lang.Exception
存储已经上传的文件

Parameters:
request - HttpServletRequest
fileItem - FileItem
storeFile - File
parameters - MetaData
Throws:
java.lang.Exception

getDownloadFileInputStream

protected abstract java.io.InputStream getDownloadFileInputStream(javax.servlet.http.HttpServletRequest request)
                                                           throws java.lang.Exception
取得将要被下载的文件的文件输入流

Parameters:
request - HttpServletRequest
Returns:
InputStream
Throws:
java.lang.Exception

outputDownloadFile

protected void outputDownloadFile(javax.servlet.http.HttpServletRequest request,
                                  javax.servlet.http.HttpServletResponse response)
                           throws java.io.IOException,
                                  java.lang.Exception
向Response对象中写入文件数据

Parameters:
request - HttpServletRequest
response - HttpServletResponse
Throws:
java.io.IOException
java.lang.Exception

getOutputContentType

protected java.lang.String getOutputContentType(javax.servlet.http.HttpServletRequest request)
返回向Response输出时使用的ContentType

Returns:
String

doOutput

public ActionForward doOutput(Action action,
                              javax.servlet.http.HttpServletRequest request,
                              javax.servlet.http.HttpServletResponse response)
                       throws java.lang.Exception
直接把文件显示到浏览器中

Parameters:
action - Action
request - HttpServletRequest
response - HttpServletResponse
Returns:
ActionForward
Throws:
java.lang.Exception

doDownload

public ActionForward doDownload(Action action,
                                javax.servlet.http.HttpServletRequest request,
                                javax.servlet.http.HttpServletResponse response)
                         throws java.lang.Exception
文件下载

Parameters:
action - Action
request - HttpServletRequest
response - HttpServletResponse
Returns:
ActionForward
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.biz

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.biz

为了增强Dorado的可用性而特别提供给用户的一些通用类
See:
Description

Class Summary
FileController 用于协助用户完成文件上传和下载的Controller.

Package com.bstek.dorado.biz Description

为了增强Dorado的可用性而特别提供给用户的一些通用类


DoradoContext

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class DoradoContext

java.lang.Object
    extended by com.bstek.dorado.common.DoradoContext
Direct Known Subclasses:
com.bstek.dorado.common.AbstractDoradoContext
public abstract class DoradoContext
extends java.lang.Object

Dorado上下文对象.

此对象用于屏蔽用户的逻辑代码对Http的依赖, 保证代码的可移植性.

对于基于Http的应用, 我们建议您在逻辑代码中尽可能使用此对象替代对Request对象的访问.可以 使用如下代码获取DoradoContext:
DoradoContext context = DoradoContext.getContext();

注意:DoradoContext内部通过线程来标识不同的Context,以保证每个线程在调用 DoradoContext.getContext()时可以获的正确的Context对象. 该机制在绝大多数的Web应用的服务端代码中都不会有任何问题.
但是如果在一个多线程任务中使用DoradoContext.getContext()将无法获得预期的效果, 因次我们建议在启动多线程任务之前应首先将要访问的资源从Context中取出并传入到线程中.

Version:
4.0

Field Summary
static int | APPLICATION 作用域类型 - Application.即整个应用中的所有Client都可访问。
static int | REQUEST 作用域类型 - Reqeust
static int | SESSION 作用域类型 - Session
static int | VIEW 作用域类型 - View.用于访问视图模型(ViewModel)的Properties中的属性值.
Constructor Summary
DoradoContext()
Method Summary
abstract java.lang.Object | getAttribute(int scope, java.lang.String key) 根据指定的作用域从上下文中获取一个属性的值.
abstract java.lang.Object | getAttribute(java.lang.String key) 从上下文的Request作用域中获取一个属性的值.
static DoradoContext | getContext() 获取当前线程中的context对象.
abstract java.lang.String | getParameter(java.lang.String key) 从上下文中获取一个参数的值.
abstract java.lang.String[] | getParameters(java.lang.String key) 从上下文中获取一个参数的值数组.
static void | registerContext(DoradoContext context) 在当前的线程中注册一个context对象
abstract void | removeAttribute(int scope, java.lang.String key) 删除指定的作用域中的某个属性.
abstract void | setAttribute(int scope, java.lang.String key, java.lang.Object object) 为指定的作用域中的某个属性设定一个值.
static void | unregisterContext() 从当前的线程中注销一个context对象
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REQUEST

public static final int REQUEST
作用域类型 - Reqeust

See Also:
Constant Field Values

VIEW

public static final int VIEW
作用域类型 - View.用于访问视图模型(ViewModel)的Properties中的属性值.

See Also:
Constant Field Values

SESSION

public static final int SESSION
作用域类型 - Session

See Also:
Constant Field Values

APPLICATION

public static final int APPLICATION
作用域类型 - Application.即整个应用中的所有Client都可访问。

See Also:
Constant Field Values
Constructor Detail

DoradoContext

public DoradoContext()
Method Detail

registerContext

public static void registerContext(DoradoContext context)
在当前的线程中注册一个context对象

Parameters:
context - DoradoContext

getContext

public static DoradoContext getContext()
获取当前线程中的context对象.

Returns:
Transaction
Throws:
java.lang.Exception

unregisterContext

public static void unregisterContext()
从当前的线程中注销一个context对象

getParameter

public abstract java.lang.String getParameter(java.lang.String key)
从上下文中获取一个参数的值.
对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Parameter).

Parameters:
key - String
Returns:
String

getParameters

public abstract java.lang.String[] getParameters(java.lang.String key)
从上下文中获取一个参数的值数组.

Parameters:
key - String
Returns:
String[]

getAttribute

public abstract java.lang.Object getAttribute(java.lang.String key)
从上下文的Request作用域中获取一个属性的值.
对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Attribute).

Parameters:
key - String
Returns:
Object

getAttribute

public abstract java.lang.Object getAttribute(int scope,
                                              java.lang.String key)
根据指定的作用域从上下文中获取一个属性的值.

Parameters:
scope - int
key - String
Returns:
Object

setAttribute

public abstract void setAttribute(int scope,
                                  java.lang.String key,
                                  java.lang.Object object)
为指定的作用域中的某个属性设定一个值.

Parameters:
scope - int
key - String
object - Object

removeAttribute

public abstract void removeAttribute(int scope,
                                     java.lang.String key)
删除指定的作用域中的某个属性.

Parameters:
scope - int
key - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HttpContextFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class HttpContextFactory

java.lang.Object
    extended by com.bstek.dorado.common.HttpContextFactory
public final class HttpContextFactory
extends java.lang.Object

默认的根据ServletRequest来获取DoradoContext的工厂

Version:
4.0

Field Summary
static java.lang.String ATTRIBUTE_KEY
ATTRIBUTE_KEY
Method Summary
static DoradoContext | getContext(javax.servlet.ServletRequest request) 根据ServletRequest来获取一个DoradoContext
static DoradoContext | getContext(javax.servlet.ServletRequest request, boolean create) 根据ServletRequest来获取一个DoradoContext, 如果目前还没有一个相应的DoradoContext, 系统将根据create参数来决定时候要产生一个.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ATTRIBUTE_KEY

public static final java.lang.String ATTRIBUTE_KEY
ATTRIBUTE_KEY

See Also:
Constant Field Values
Method Detail

getContext

public static DoradoContext getContext(javax.servlet.ServletRequest request)
根据ServletRequest来获取一个DoradoContext

Parameters:
request - ServletRequest
Returns:
DoradoContext

getContext

public static DoradoContext getContext(javax.servlet.ServletRequest request,
                                       boolean create)
根据ServletRequest来获取一个DoradoContext, 如果目前还没有一个相应的DoradoContext, 系统将根据create参数来决定时候要产生一个.

Parameters:
request - ServletRequest
create - boolean
Returns:
DoradoContext
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HttpDoradoContext

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class HttpDoradoContext

java.lang.Object
    extended by com.bstek.dorado.common.DoradoContext
        extended by com.bstek.dorado.common.AbstractDoradoContext
            extended by com.bstek.dorado.common.HttpDoradoContext
public class HttpDoradoContext
extends com.bstek.dorado.common.AbstractDoradoContext

用于封装HttpRequest的上下文对象

Version:
4.0

Field Summary
protected  java.util.Stack reqeustStack
Fields inherited from class com.bstek.dorado.common.DoradoContext
APPLICATION, REQUEST, SESSION, VIEW
Method Summary
java.lang.Object | getAttribute(int scope, java.lang.String key) 根据指定的作用域从上下文中获取一个属性的值.
java.lang.String | getParameter(java.lang.String key) 从上下文中获取一个参数的值. 对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Parameter).
java.lang.String[] | getParameters(java.lang.String key) 从上下文中获取一个参数的值数组.
javax.servlet.http.HttpServletRequest | getRequest() 被封装的HttpServletRequest对象
void | removeAttribute(int scope, java.lang.String key) 删除指定的作用域中的某个属性.
void | setAttribute(int scope, java.lang.String key, java.lang.Object object) 为指定的作用域中的某个属性设定一个值.
void | setRequest(javax.servlet.http.HttpServletRequest request) 设置被封装的HttpServletRequest对象
Methods inherited from class com.bstek.dorado.common.AbstractDoradoContext
getAttribute
Methods inherited from class com.bstek.dorado.common.DoradoContext
getContext, registerContext, unregisterContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

reqeustStack

protected java.util.Stack reqeustStack
Method Detail

getRequest

public javax.servlet.http.HttpServletRequest getRequest()
被封装的HttpServletRequest对象

setRequest

public void setRequest(javax.servlet.http.HttpServletRequest request)
设置被封装的HttpServletRequest对象

getParameter

public java.lang.String getParameter(java.lang.String key)
从上下文中获取一个参数的值.
对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Parameter).

Specified by:
getParameter in class DoradoContext
Parameters:
key - String
Returns:
String

getParameters

public java.lang.String[] getParameters(java.lang.String key)
从上下文中获取一个参数的值数组.

Specified by:
getParameters in class DoradoContext
Parameters:
key - String
Returns:
String[]

getAttribute

public java.lang.Object getAttribute(int scope,
                                     java.lang.String key)
根据指定的作用域从上下文中获取一个属性的值.

Specified by:
getAttribute in class DoradoContext
Parameters:
scope - int
key - String
Returns:
Object

setAttribute

public void setAttribute(int scope,
                         java.lang.String key,
                         java.lang.Object object)
为指定的作用域中的某个属性设定一个值.

Specified by:
setAttribute in class DoradoContext
Parameters:
scope - int
key - String
object - Object

removeAttribute

public void removeAttribute(int scope,
                            java.lang.String key)
删除指定的作用域中的某个属性.

Specified by:
removeAttribute in class DoradoContext
Parameters:
scope - int
key - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class MessageHelper

java.lang.Object
    extended by com.bstek.dorado.common.MessageHelper
public final class MessageHelper
extends java.lang.Object

用于处理Message的工具类.

  • 对于普通的Http请求而言,利用MessageHelper设置的消息可以通过 <d:MessageIterator>和<d:Message>显示到JSP中.
  • 对于Dorado的RPC调用而言(包含Dataset的动态数据加载和数据提交的Server段逻辑代码), 利用MessageHelper设置的无键值消息将自动在RPC调用成功之后在Client端以弹出提示的方式显示给用户. 而其他其它消息会被Client端忽略.

Version:
4.0

Method Summary
static void | addMessage(DoradoContext context, java.lang.String message) 增加一条新的无键值消息
static void | addMessage(DoradoContext context, java.lang.String key, java.lang.String message) 在指定键值中增加一条新的消息
static void | addMessage(javax.servlet.ServletRequest request, java.lang.String message) 增加一条新的无键值消息
static void | addMessage(javax.servlet.ServletRequest request, java.lang.String key, java.lang.String message) 在指定键值中增加一条新的消息
static java.lang.String | getMessage(DoradoContext context) 返回一条无键值消息.
static java.lang.String | getMessage(DoradoContext context, java.lang.String key) 返回一条在指定键值中消息.
static java.lang.String | getMessage(javax.servlet.ServletRequest request) 返回一条无键值消息.
static java.lang.String | getMessage(javax.servlet.ServletRequest request, java.lang.String key) 返回一条在指定键值中消息.
static java.util.List | getMessages(DoradoContext context) 返回所有无键值消息
static java.util.List | getMessages(DoradoContext context, java.lang.String key) 返回所有指定键值中消息
static java.util.List | getMessages(javax.servlet.ServletRequest request) 返回所有无键值消息
static java.util.List | getMessages(javax.servlet.ServletRequest request, java.lang.String key) 返回所有指定键值中消息
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

addMessage

public static void addMessage(javax.servlet.ServletRequest request,
                              java.lang.String message)
增加一条新的无键值消息

Parameters:
request - ServletRequest
message - String

addMessage

public static void addMessage(javax.servlet.ServletRequest request,
                              java.lang.String key,
                              java.lang.String message)
在指定键值中增加一条新的消息

Parameters:
request - ServletRequest
key - String
message - String

getMessage

public static java.lang.String getMessage(javax.servlet.ServletRequest request)
返回一条无键值消息.
如果当前有多条无键值消息该方法将只返回第一条无键值消息.

Parameters:
request - ServletRequest
Returns:
String

getMessage

public static java.lang.String getMessage(javax.servlet.ServletRequest request,
                                          java.lang.String key)
返回一条在指定键值中消息.
如果当前在该键值中有多条消息该方法将只返回第一条消息.

Parameters:
request - ServletRequest
key - String
Returns:
String

getMessages

public static java.util.List getMessages(javax.servlet.ServletRequest request)
返回所有无键值消息

Parameters:
request - ServletRequest
Returns:
List

getMessages

public static java.util.List getMessages(javax.servlet.ServletRequest request,
                                         java.lang.String key)
返回所有指定键值中消息

Parameters:
request - ServletRequest
key - String
Returns:
List

addMessage

public static void addMessage(DoradoContext context,
                              java.lang.String message)
增加一条新的无键值消息

Parameters:
context - DoradoContext
message - String

addMessage

public static void addMessage(DoradoContext context,
                              java.lang.String key,
                              java.lang.String message)
在指定键值中增加一条新的消息

Parameters:
context - DoradoContext
key - String
message - String

getMessage

public static java.lang.String getMessage(DoradoContext context)
返回一条无键值消息.
如果当前有多条无键值消息该方法将只返回第一条无键值消息.

Parameters:
context - DoradoContext
Returns:
String

getMessage

public static java.lang.String getMessage(DoradoContext context,
                                          java.lang.String key)
返回一条在指定键值中消息.
如果当前在该键值中有多条消息该方法将只返回第一条消息.

Parameters:
context - DoradoContext
key - String
Returns:
String

getMessages

public static java.util.List getMessages(DoradoContext context)
返回所有无键值消息

Parameters:
context - DoradoContext
Returns:
List

getMessages

public static java.util.List getMessages(DoradoContext context,
                                         java.lang.String key)
返回所有指定键值中消息

Parameters:
context - DoradoContext
key - String
Returns:
List
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.common

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common

Dorado系统中的一些通用类
See:
Description

Interface Summary
Transaction Dorado事务对象的接口

Class Summary
DoradoContext | Dorado上下文对象.
HttpContextFactory | 默认的根据ServletRequest来获取DoradoContext的工厂
HttpDoradoContext | 用于封装HttpRequest的上下文对象
MessageHelper | 用于处理Message的工具类.
Setting | 用于保存Dorado的Server运行时属性的对象.此处的配置信息均是在dorado的home/setting.xml 中设定的.
TransactionManager | Dorado事务的管理对象
UserConfig | 用于保存Dorado的Server运行时属性的对象

Package com.bstek.dorado.common Description

Dorado系统中的一些通用类


Setting

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class Setting

java.lang.Object
    extended by com.bstek.dorado.common.Setting
public final class Setting
extends java.lang.Object

用于保存Dorado的Server运行时属性的对象.此处的配置信息均是在dorado的home/setting.xml 中设定的.

Version:
4.0

Method Summary
static boolean | getBoolean(java.lang.String name) 读取一个Boolean型的配置信息
static boolean | getBoolean(java.lang.String name, boolean defaultValue) 读取一个Boolean型的配置信息,如何该配置不存在则返回缺省值.
static java.util.Date | getDate(java.lang.String name) 读取一个Date型的配置信息
static java.util.Date | getDate(java.lang.String name, java.util.Date defaultValue) 读取一个Date型的配置信息,如何该配置不存在则返回缺省值.
static double | getDouble(java.lang.String name) 读取一个Double型的配置信息
static double | getDouble(java.lang.String name, double defaultValue) 读取一个Double型的配置信息,如何该配置不存在则返回缺省值.
static float | getFloat(java.lang.String name) 读取一个Float型的配置信息
static float | getFloat(java.lang.String name, float defaultValue) 读取一个Float型的配置信息,如何该配置不存在则返回缺省值.
static int | getInt(java.lang.String name) 读取一个Int型的配置信息
static int | getInt(java.lang.String name, int defaultValue) 读取一个Int型的配置信息,如何该配置不存在则返回缺省值.
static long | getLong(java.lang.String name) 读取一个Long型的配置信息
static long | getLong(java.lang.String name, long defaultValue) 读取一个Long型的配置信息,如何该配置不存在则返回缺省值.
static java.lang.String | getString(java.lang.String name) 读取一个String型的配置信息
static java.lang.String | getString(java.lang.String name, java.lang.String defaultValue) 读取一个String型的配置信息.如何该配置不存在则返回缺省值.
static void | load() 装载配置文件。
static void | save() 保存配置。
static void | setBoolean(java.lang.String name, boolean value) 设置一个Boolean型的配置信息
static void | setDate(java.lang.String name, java.util.Date value) 设定一个Date型的配置信息
static void | setDouble(java.lang.String name, double value) 设定一个Double型的配置信息
static void | setFloat(java.lang.String name, float value) 设定一个Float型的配置信息
static void | setInt(java.lang.String name, int value) 设定一个Int型的配置信息
static void | setLong(java.lang.String name, long value) 设定一个Long型的配置信息
static void | setString(java.lang.String name, java.lang.String value) 设置一个String型的配置信息
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

load

public static void load()
装载配置文件。

save

public static void save()
                 throws java.lang.Exception
保存配置。

Throws:
java.lang.Exception

getString

public static java.lang.String getString(java.lang.String name)
读取一个String型的配置信息

Parameters:
name - String 键值
Returns:
java.lang.String

getString

public static java.lang.String getString(java.lang.String name,
                                         java.lang.String defaultValue)
读取一个String型的配置信息.如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - 缺省值.
Returns:
java.lang.String

setString

public static void setString(java.lang.String name,
                             java.lang.String value)
设置一个String型的配置信息

Parameters:
name - String
value - String

getBoolean

public static boolean getBoolean(java.lang.String name)
读取一个Boolean型的配置信息

Parameters:
name - String
Returns:
boolean

getBoolean

public static boolean getBoolean(java.lang.String name,
                                 boolean defaultValue)
读取一个Boolean型的配置信息,如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - boolean 缺省值
Returns:
int

setBoolean

public static void setBoolean(java.lang.String name,
                              boolean value)
设置一个Boolean型的配置信息

Parameters:
name - String
value - boolean

getInt

public static int getInt(java.lang.String name)
读取一个Int型的配置信息

Parameters:
name - String
Returns:
int

getInt

public static int getInt(java.lang.String name,
                         int defaultValue)
读取一个Int型的配置信息,如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - int 缺省值
Returns:
int

setInt

public static void setInt(java.lang.String name,
                          int value)
设定一个Int型的配置信息

Parameters:
name - String
value - int

getLong

public static long getLong(java.lang.String name)
读取一个Long型的配置信息

Parameters:
name - String
Returns:
long

getLong

public static long getLong(java.lang.String name,
                           long defaultValue)
读取一个Long型的配置信息,如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - long 缺省值
Returns:
long

setLong

public static void setLong(java.lang.String name,
                           long value)
设定一个Long型的配置信息

Parameters:
name - String
value - long

getFloat

public static float getFloat(java.lang.String name)
读取一个Float型的配置信息

Parameters:
name - String
Returns:
float

getFloat

public static float getFloat(java.lang.String name,
                             float defaultValue)
读取一个Float型的配置信息,如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - float 缺省值
Returns:
float

setFloat

public static void setFloat(java.lang.String name,
                            float value)
设定一个Float型的配置信息

Parameters:
name - String
value - float

getDouble

public static double getDouble(java.lang.String name)
读取一个Double型的配置信息

Parameters:
name - String
Returns:
double

getDouble

public static double getDouble(java.lang.String name,
                               double defaultValue)
读取一个Double型的配置信息,如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - double 缺省值
Returns:
double

setDouble

public static void setDouble(java.lang.String name,
                             double value)
设定一个Double型的配置信息

Parameters:
name - String
value - double

getDate

public static java.util.Date getDate(java.lang.String name)
读取一个Date型的配置信息

Parameters:
name - String
Returns:
Date

getDate

public static java.util.Date getDate(java.lang.String name,
                                     java.util.Date defaultValue)
读取一个Date型的配置信息,如何该配置不存在则返回缺省值.

Parameters:
name - String
defaultValue - Date 缺省值
Returns:
Date

setDate

public static void setDate(java.lang.String name,
                           java.util.Date value)
设定一个Date型的配置信息

Parameters:
name - String
value - Date
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Transaction

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Interface Transaction

public interface Transaction

Dorado事务对象的接口

Version:
4.0

Method Summary
 void beginTransaction()
启动一个新的事务.
 void commit()
提交当前事务
 void dispose()
废除当前的事务对象并释放所有资源.
 java.sql.Connection getConnection(java.lang.String dataSource)
获取一个与本事务相关的数据连接.
 boolean inTransaction()
当前是否存在一个未决的事务.即是否以调用beginTransaction()启动了新的事务,且尚未调用 commit()或rollback().
 void rollback()
回滚当前事务

Method Detail

getConnection

public java.sql.Connection getConnection(java.lang.String dataSource)
                                  throws java.lang.Exception
获取一个与本事务相关的数据连接.

Parameters:
dataSource - String
Returns:
Connection
Throws:
java.lang.Exception

inTransaction

public boolean inTransaction()
当前是否存在一个未决的事务.即是否以调用beginTransaction()启动了新的事务,且尚未调用 commit()或rollback().

Returns:
boolean

beginTransaction

public void beginTransaction()
                      throws java.lang.Exception
启动一个新的事务.

Throws:
java.lang.Exception

commit

public void commit()
            throws java.lang.Exception
提交当前事务

Throws:
java.lang.Exception

rollback

public void rollback()
              throws java.lang.Exception
回滚当前事务

Throws:
java.lang.Exception

dispose

public void dispose()
废除当前的事务对象并释放所有资源.
注意:该方法一般有Dorado的引擎自动调用,建议您不要手工调用此方法.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TransactionManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class TransactionManager

java.lang.Object
    extended by com.bstek.dorado.common.TransactionManager
public final class TransactionManager
extends java.lang.Object

Dorado事务的管理对象

Version:
4.0

Field Summary
static int | TRANSACTION_NOT_SUPPORTED 不支持事务.
static int | TRANSACTION_REQUIRED 需要事务.
static int | TRANSACTION_REQUIRES_NEW 需要新事务.
static int | TRANSACTION_SUPPORTS 支持事务.
Method Summary
static void | disposeTransaction() disposeTransaction
static Transaction | getTransaction() 获取当前线程中的事务.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TRANSACTION_NOT_SUPPORTED

public static final int TRANSACTION_NOT_SUPPORTED
不支持事务. 如果目前的context中已经存在了一个未决的事务, 则在进行此处的处理前该事务会被自动提交.

See Also:
Constant Field Values

TRANSACTION_SUPPORTS

public static final int TRANSACTION_SUPPORTS
支持事务. 如果目前的context中已经存在了一个未决的事务, 那么此处的处理会参与到该事务当中; 否则此处的处理将不会支持事务.

See Also:
Constant Field Values

TRANSACTION_REQUIRED

public static final int TRANSACTION_REQUIRED
需要事务. 如果目前的context中已经存在了一个未决的事务, 那么此处的处理会参与到该事务当中; 否则在进行此处的处理前将自动启动一个新事务.

See Also:
Constant Field Values

TRANSACTION_REQUIRES_NEW

public static final int TRANSACTION_REQUIRES_NEW
需要新事务. 如果目前的context中已经存在了一个未决的事务, 则在进行此处的处理前该事务会被自动提交, 同时自动启动一个新事务.

See Also:
Constant Field Values
Method Detail

getTransaction

public static Transaction getTransaction()
                                  throws java.lang.Exception
获取当前线程中的事务.

Returns:
Transaction
Throws:
java.lang.Exception

disposeTransaction

public static void disposeTransaction()
disposeTransaction

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserConfig

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common
Class UserConfig

java.lang.Object
    extended by com.bstek.dorado.common.UserConfig
public final class UserConfig
extends java.lang.Object

用于保存Dorado的Server运行时属性的对象

Version:
4.0

Method Summary
static boolean | getBoolean(java.lang.String name) 读取一个Boolean型的配置信息
static boolean | getBoolean(java.lang.String name, boolean defaultValue) 读取一个Boolean型的配置信息
static java.util.Date | getDate(java.lang.String name) 读取一个Date型的配置信息
static java.util.Date | getDate(java.lang.String name, java.util.Date defaultValue) 读取一个Date型的配置信息
static double | getDouble(java.lang.String name) 读取一个Double型的配置信息
static double | getDouble(java.lang.String name, double defaultValue) 读取一个Double型的配置信息
static float | getFloat(java.lang.String name) 读取一个Float型的配置信息
static float | getFloat(java.lang.String name, float defaultValue) 读取一个Float型的配置信息
static int | getInt(java.lang.String name) 读取一个Int型的配置信息
static int | getInt(java.lang.String name, int defaultValue) 读取一个Int型的配置信息
static long | getLong(java.lang.String name) 读取一个Long型的配置信息
static long | getLong(java.lang.String name, long defaultValue) 读取一个Long型的配置信息
static java.lang.String | getString(java.lang.String name) 读取一个String型的配置信息
static java.lang.String | getString(java.lang.String name, java.lang.String defaultValue) 读取一个String型的配置信息
static void | load() 装载配置文件。
static void | save() 保存配置。
static void | setBoolean(java.lang.String name, boolean value) 设置一个Boolean型的配置信息
static void | setDate(java.lang.String name, java.util.Date value) 设定一个Date型的配置信息
static void | setDouble(java.lang.String name, double value) 设定一个Double型的配置信息
static void | setFloat(java.lang.String name, float value) 设定一个Float型的配置信息
static void | setInt(java.lang.String name, int value) 设定一个Int型的配置信息
static void | setLong(java.lang.String name, long value) 设定一个Long型的配置信息
static void | setString(java.lang.String name, java.lang.String value) 设置一个String型的配置信息
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

load

public static void load()
                 throws java.io.FileNotFoundException,
                        java.io.IOException,
                        XmlParseException,
                        LoadXmlPropertyException
装载配置文件。

Throws:
java.io.FileNotFoundException
java.io.IOException
XmlParseException
LoadXmlPropertyException

save

public static void save()
                 throws java.lang.Exception
保存配置。

Throws:
java.lang.Exception

getString

public static java.lang.String getString(java.lang.String name)
读取一个String型的配置信息

Parameters:
name - String 缺省值
Returns:
java.lang.String

getString

public static java.lang.String getString(java.lang.String name,
                                         java.lang.String defaultValue)
读取一个String型的配置信息

Parameters:
name - String
defaultValue - String
Returns:
java.lang.String
See Also:
setString

setString

public static void setString(java.lang.String name,
                             java.lang.String value)
设置一个String型的配置信息

Parameters:
name - String
value - String

getBoolean

public static boolean getBoolean(java.lang.String name)
读取一个Boolean型的配置信息

Parameters:
name - String
Returns:
boolean
See Also:
setBoolean

getBoolean

public static boolean getBoolean(java.lang.String name,
                                 boolean defaultValue)
读取一个Boolean型的配置信息

Parameters:
name - String
defaultValue - boolean 缺省值
Returns:
int
See Also:
setBoolean

setBoolean

public static void setBoolean(java.lang.String name,
                              boolean value)
设置一个Boolean型的配置信息

Parameters:
name - String
value - boolean

getInt

public static int getInt(java.lang.String name)
读取一个Int型的配置信息

Parameters:
name - String
Returns:
int
See Also:
setInt

getInt

public static int getInt(java.lang.String name,
                         int defaultValue)
读取一个Int型的配置信息

Parameters:
name - String
defaultValue - int 缺省值
Returns:
int
See Also:
setInt

setInt

public static void setInt(java.lang.String name,
                          int value)
设定一个Int型的配置信息

Parameters:
name - String
value - int

getLong

public static long getLong(java.lang.String name)
读取一个Long型的配置信息

Parameters:
name - String
Returns:
long
See Also:
getLong

getLong

public static long getLong(java.lang.String name,
                           long defaultValue)
读取一个Long型的配置信息

Parameters:
name - String
defaultValue - long 缺省值
Returns:
long
See Also:
setLong

setLong

public static void setLong(java.lang.String name,
                           long value)
设定一个Long型的配置信息

Parameters:
name - String
value - long

getFloat

public static float getFloat(java.lang.String name)
读取一个Float型的配置信息

Parameters:
name - String
Returns:
float
See Also:
setFloat

getFloat

public static float getFloat(java.lang.String name,
                             float defaultValue)
读取一个Float型的配置信息

Parameters:
name - String
defaultValue - float 缺省值
Returns:
float
See Also:
setFloat

setFloat

public static void setFloat(java.lang.String name,
                            float value)
设定一个Float型的配置信息

Parameters:
name - String
value - float

getDouble

public static double getDouble(java.lang.String name)
读取一个Double型的配置信息

Parameters:
name - String
Returns:
double
See Also:
setDouble

getDouble

public static double getDouble(java.lang.String name,
                               double defaultValue)
读取一个Double型的配置信息

Parameters:
name - String
defaultValue - double 缺省值
Returns:
double
See Also:
setDouble

setDouble

public static void setDouble(java.lang.String name,
                             double value)
设定一个Double型的配置信息

Parameters:
name - String
value - double

getDate

public static java.util.Date getDate(java.lang.String name)
读取一个Date型的配置信息

Parameters:
name - String
Returns:
Date
See Also:
setDate

getDate

public static java.util.Date getDate(java.lang.String name,
                                     java.util.Date defaultValue)
读取一个Date型的配置信息

Parameters:
name - String
defaultValue - Date 缺省值
Returns:
Date
See Also:
setDate

setDate

public static void setDate(java.lang.String name,
                           java.util.Date value)
设定一个Date型的配置信息

Parameters:
name - String
value - Date
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConnectionHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.ds
Class ConnectionHelper

java.lang.Object
    extended by com.bstek.dorado.common.ds.ConnectionHelper
public class ConnectionHelper
extends java.lang.Object

用于根据Dorado中数据连接配置获得Connection的工具类.

注意:此方法返回的连接并不会参与到Dorado的UpdateCommand等操作默认启动的事务当中.
如果您希望获得于Dorado的事务相关的连接请使用TransactionManager对象.

Version:
4.0
See Also:
TransactionManager

Constructor Summary
ConnectionHelper()
Method Summary
static java.lang.String | getCharSet(java.lang.String dataSource) 根据数据源配置的名字返回数据库使用CharSet.
static java.sql.Connection | getConnection(java.lang.String dataSource) 根据数据源配置的名字返回一个数据连接.
static java.sql.Connection | getDefaultConnection() 返回一个默认数据连接.
static com.bstek.dorado.data.db.dialect.Dialect | getDefaultDialect() 返回默认的数据库方言实现对象.
static com.bstek.dorado.data.db.dialect.Dialect | getDialect(java.lang.String dataSource) 根据数据源配置的名字返回数据库方言的实现对象.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConnectionHelper

public ConnectionHelper()
Method Detail

getDefaultConnection

public static java.sql.Connection getDefaultConnection()
                                                throws java.lang.Exception
返回一个默认数据连接.

默认数据连接的名字在Dorado配置文件(Setting.xml)的common.defaultDataSource 项中设置.

注意:此方法返回的连接使用完毕后必须调用Connection.close(),以关闭连接或将连接归还给连接池.
如果所获的的连接来自于Dorado提供的连接池,那么您在此处得到将是一个Connection的代理对象, 这并不会影响到您使用该连接的方法.不过在最终调用Connection.close()时,该代理并不会真正的关闭 内部的数据连接,而是会将其归还给连接池.

Returns:
Connection
Throws:
java.lang.Exception

getConnection

public static java.sql.Connection getConnection(java.lang.String dataSource)
                                         throws java.lang.Exception
根据数据源配置的名字返回一个数据连接.

注意:此方法返回的连接使用完毕后必须调用Connection.close(),以关闭连接或将连接归还给连接池.
如果所获的的连接来自于Dorado提供的连接池,那么您在此处得到将是一个Connection的代理对象, 这并不会影响到您使用该连接的方法.不过在最终调用Connection.close()时,该代理并不会真正的关闭 内部的数据连接,而是会将其归还给连接池.

Parameters:
dataSource - String
Returns:
Connection
Throws:
java.lang.Exception

getDefaultDialect

public static com.bstek.dorado.data.db.dialect.Dialect getDefaultDialect()
返回默认的数据库方言实现对象.

Returns:
Dialect

getDialect

public static com.bstek.dorado.data.db.dialect.Dialect getDialect(java.lang.String dataSource)
根据数据源配置的名字返回数据库方言的实现对象.

Parameters:
dataSource - String
Returns:
Dialect

getCharSet

public static java.lang.String getCharSet(java.lang.String dataSource)
根据数据源配置的名字返回数据库使用CharSet.

Parameters:
dataSource - String
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.common.ds

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common.ds

一些用于获取各类数据连接(java.sql.Connection)的工具类
See:
Description

Class Summary
ConnectionHelper 用于根据Dorado中数据连接配置获得Connection的工具类.

Package com.bstek.dorado.common.ds Description

一些用于获取各类数据连接(java.sql.Connection)的工具类


FileLoader

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.fileloader
Class FileLoader

java.lang.Object
    extended by com.bstek.dorado.common.fileloader.FileLoader
public abstract class FileLoader
extends java.lang.Object

文件加载器的抽象类

Version:
4.0

Field Summary
protected  java.lang.String root
根路径.所以该FileLoader所能读取的文件都位于该路径之下.
Constructor Summary
FileLoader(java.lang.String root)
构造器
Method Summary
protected abstract void | doSetFile(java.lang.String filepath) 设置要打开的文件。
java.lang.String | getFilePath() 文件位置的描述。
abstract java.io.InputStream | getInputStream() 获取文件的输入流
abstract long | getLastModified() 获取文件的最后修改日期
abstract java.io.OutputStream | getOutputStream() 获取文件的输出流.
abstract java.lang.String | getRealPath() 取得文件的实际位置。
java.lang.String | getRoot() 取得根路径
abstract java.net.URL | getURL() 取得文件的URL连接器。
void | setFile(java.lang.String filepath) 设置要打开的文件。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

root

protected java.lang.String root
根路径.所以该FileLoader所能读取的文件都位于该路径之下.

Constructor Detail

FileLoader

public FileLoader(java.lang.String root)
构造器

Parameters:
root - 根路径.所以该FileLoader所能读取的文件都位于该路径之下.
Method Detail

doSetFile

protected abstract void doSetFile(java.lang.String filepath)
                           throws java.io.FileNotFoundException,
                                  java.io.IOException
设置要打开的文件。

Parameters:
filepath - String 文件位置的描述。
Throws:
java.io.IOException
java.io.FileNotFoundException

setFile

public void setFile(java.lang.String filepath)
             throws java.io.FileNotFoundException,
                    java.io.IOException
设置要打开的文件。

注意:此处的文件路径应当是对应于在构造时指定的根路径的相对路径.

Parameters:
filepath - String 文件位置的描述。
Throws:
java.io.IOException
java.io.FileNotFoundException

getLastModified

public abstract long getLastModified()
                              throws java.io.IOException
获取文件的最后修改日期

Returns:
long 文件的最后修改日期
Throws:
java.io.IOException

getInputStream

public abstract java.io.InputStream getInputStream()
                                            throws java.io.IOException
获取文件的输入流

Returns:
InputStream
Throws:
java.io.IOException

getOutputStream

public abstract java.io.OutputStream getOutputStream()
                                              throws java.io.IOException
获取文件的输出流.

注意:某些FileLoader可能不支持!

Returns:
OutputStream
Throws:
java.io.IOException

getRoot

public java.lang.String getRoot()
取得根路径

Returns:
String

getFilePath

public java.lang.String getFilePath()
文件位置的描述。

Returns:
String

getRealPath

public abstract java.lang.String getRealPath()
取得文件的实际位置。

Returns:
String

getURL

public abstract java.net.URL getURL()
取得文件的URL连接器。

Returns:
URL
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.common.fileloader

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common.fileloader

Dorado内部用于查找和读取各种配置文件的工具类
See:
Description

Class Summary
FileLoader 文件加载器的抽象类

Package com.bstek.dorado.common.fileloader Description

Dorado内部用于查找和读取各种配置文件的工具类


Log

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.log
Class Log

java.lang.Object
    extended by com.bstek.dorado.common.log.Log
public final class Log
extends java.lang.Object

日志记录器。

Version:
4.0

Field Summary
static java.lang.String LOGGER_NAME
默认的系统LOG名称
Method Summary
static void | debug(java.lang.Object o) 把日志信息优先级为 LEVEL_DEBUG 的字符串记录到日志文件里。
static void | error(java.lang.Object o) 把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
static void | error(java.lang.Object o, java.lang.Throwable t) 把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
static void | error(java.lang.Throwable t) 把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
static void | fatal(java.lang.Object o) 把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
static void | fatal(java.lang.Object o, java.lang.Throwable t) 把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
static void | fatal(java.lang.Throwable t) 把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
static int | getLevel() 返回日志记录器的日志级别。
static void | info(java.lang.Object o) 把日志信息优先级为 LEVEL_INFO 的字符串记录到日志文件里。
static void | init() 初始化日志记录器，这个记录器将负责控制日志信息。
static int | parseLevel(java.lang.String name) 转换日志级别名称为日志级别。
static void | setLevel(int level) 设置日志记录器的日志级别。
static void | warn(java.lang.Object o) 把日志信息优先级为 LEVEL_WARN 的字符串记录到日志文件里。
static void | warn(java.lang.Object o, java.lang.Throwable t) 把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
static void | warn(java.lang.Throwable t) 把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOGGER_NAME

public static final java.lang.String LOGGER_NAME
默认的系统LOG名称

See Also:
Constant Field Values
Method Detail

init

public static void init()
                 throws java.lang.Exception
初始化日志记录器，这个记录器将负责控制日志信息。

Throws:
java.lang.Exception

parseLevel

public static int parseLevel(java.lang.String name)
转换日志级别名称为日志级别。

转换方式如下如下：

  • "ALL" ==> Logger.LEVEL_ALL
  • "DEBUG" ==> Logger.LEVEL_DEBUG
  • "INFO" ==> Logger.LEVEL_INFO
  • "WARN" ==> Logger.LEVEL_WARN
  • "ERROR" ==> Logger.LEVEL_ERROR
  • "FATAL" ==> Logger.LEVEL_FATAL
  • "OFF" ==> Logger.LEVEL_OFF

Parameters:
name - 日志级别名称。
Returns:
日志级别。

getLevel

public static int getLevel()
返回日志记录器的日志级别。 返回的值参看 setLevel(int)

Returns:
日志级别。

setLevel

public static void setLevel(int level)
设置日志记录器的日志级别。如果level不符合规范，系统默认为LEVEL_DEBUG。 可设定的值如下：
  • Logger.LEVEL_ALL
  • Logger.LEVEL_DEBUG
  • Logger.LEVEL_INFO
  • Logger.LEVEL_WARN
  • Logger.LEVEL_ERROR
  • Logger.LEVEL_FATAL
  • Logger.LEVEL_OFF

    • Parameters:
    level - 日志级别。

    debug

    public static void debug(java.lang.Object o)
    把日志信息优先级为 LEVEL_DEBUG 的字符串记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。

    error

    public static void error(java.lang.Object o)
    把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。

    error

    public static void error(java.lang.Throwable t)
    把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。

    Parameters:
    t - 记录到日志的Exception对象。

    error

    public static void error(java.lang.Object o,
                         java.lang.Throwable t)
    把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。
    t - 记录到日志的Exception对象。

    fatal

    public static void fatal(java.lang.Object o)
    把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。

    fatal

    public static void fatal(java.lang.Throwable t)
    把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。

    Parameters:
    t - 记录到日志的Exception对象。

    fatal

    public static void fatal(java.lang.Object o,
                         java.lang.Throwable t)
    把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。
    t - 记录到日志的Exception对象。

    info

    public static void info(java.lang.Object o)
    把日志信息优先级为 LEVEL_INFO 的字符串记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。

    warn

    public static void warn(java.lang.Object o)
    把日志信息优先级为 LEVEL_WARN 的字符串记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。

    warn

    public static void warn(java.lang.Throwable t)
    把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。

    Parameters:
    t - 记录到日志的Exception对象。

    warn

    public static void warn(java.lang.Object o,
                        java.lang.Throwable t)
    把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。

    Parameters:
    o - 记录到日志的字符串。
    t - 记录到日志的Exception对象。
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS | FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.common.log

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common.log

Dorado系统日志的相关类
See:
Description

Class Summary
Log 日志记录器。

Package com.bstek.dorado.common.log Description

Dorado系统日志的相关类


ExprHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.rtexpr
Class ExprHelper

java.lang.Object
    extended by com.bstek.dorado.common.rtexpr.ExprHelper
public final class ExprHelper
extends java.lang.Object

用于方便使用运行时变量功能的工具类

Version:
4.0

Method Summary
static com.bstek.dorado.common.rtexpr.CompiledText | compile(java.lang.String text) 预编译一个字符串.如果该字符串中含有运行时变量则返回一个预编译对象,否则返回null
static java.lang.Object | translate(com.bstek.dorado.common.rtexpr.CompiledText compiledText, DoradoContext context) 将一段预编译好的字符串翻译成最终结果
static java.lang.Object | translate(com.bstek.dorado.common.rtexpr.CompiledText compiledText, org.apache.commons.jexl.JexlContext ctx) 将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.
static java.lang.Object | translate(java.lang.String text, DoradoContext context) 将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.
static java.lang.Object | translate(java.lang.String text, org.apache.commons.jexl.JexlContext ctx) 将一段字符串翻译成最终结果
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

compile

public static com.bstek.dorado.common.rtexpr.CompiledText compile(java.lang.String text)
预编译一个字符串.如果该字符串中含有运行时变量则返回一个预编译对象,否则返回null

Parameters:
text - String
Returns:
CompiledText

translate

public static java.lang.Object translate(com.bstek.dorado.common.rtexpr.CompiledText compiledText,
                                         DoradoContext context)
将一段预编译好的字符串翻译成最终结果

Parameters:
compiledText - CompiledText
context - DoradoContext
Returns:
Object

translate

public static java.lang.Object translate(java.lang.String text,
                                         DoradoContext context)
将一段字符串翻译成最终结果

该字符串中可以包含零到多个运行时变量.

Parameters:
text - String
context - DoradoContext
Returns:
Object

translate

public static java.lang.Object translate(com.bstek.dorado.common.rtexpr.CompiledText compiledText,
                                         org.apache.commons.jexl.JexlContext ctx)
将一段字符串翻译成最终结果

该字符串中可以包含零到多个运行时变量.

Parameters:
compiledText - CompiledText
ctx - JexlContext
Returns:
Object

translate

public static java.lang.Object translate(java.lang.String text,
                                         org.apache.commons.jexl.JexlContext ctx)
将一段字符串翻译成最终结果

Parameters:
text - String
ctx - JexlContext
Returns:
Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.common.rtexpr

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common.rtexpr

用于支持运行时变量(例如: EL表达式)的工具类
See:
Description

Class Summary
ExprHelper 用于方便使用运行时变量功能的工具类

Package com.bstek.dorado.common.rtexpr Description

用于支持运行时变量(例如: EL表达式)的工具类


ExpressionUtils

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.rtexpr.impl
Class ExpressionUtils

java.lang.Object
    extended by com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
public class ExpressionUtils
extends java.lang.Object

EL表达式工具类,该类所具有的各个方法亦即Util表达式所支持的各项功能.

Version:
4.0

Method Summary
 java.util.Date getDate()
获取系统的当前时间 例如: ${Util.getDate()} 或 ${Util.date}
 java.lang.String getDate(java.lang.String format)
按指定的日期格式获取系统的当前时间的字符串 例如: ${Util.getDate("yyyy-MM-dd")}
static ExpressionUtils getInstance()
获得单例对象
 boolean isEmpty(java.lang.String s)
判断字符串是否为null或为"".
 boolean isNotEmpty(java.lang.String s)
判断字符串是否非空.
 java.lang.Object switchValue(boolean b, java.lang.Object t, java.lang.Object f)
开关值.
 void systemErr(java.lang.Object o)
systemErr
 void systemOut(java.lang.Object o)
systemOut
 java.lang.String translate(java.lang.String s, java.lang.String oldCharset, java.lang.String newCharset)
转换字符串的字符集.
 java.lang.String translateFromISO(java.lang.String s, java.lang.String charset)
将一个iso8859-1字符串转换为给定的编码格式.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getInstance

public static ExpressionUtils getInstance()
获得单例对象

Returns:
ExpressionUtils

getDate

public java.util.Date getDate()
获取系统的当前时间

例如: ${Util.getDate()} 或 ${Util.date}

Returns:
Date

getDate

public java.lang.String getDate(java.lang.String format)
按指定的日期格式获取系统的当前时间的字符串

例如: ${Util.getDate("yyyy-MM-dd")}

Parameters:
format - String
Returns:
String

switchValue

public java.lang.Object switchValue(boolean b,
                                    java.lang.Object t,
                                    java.lang.Object f)
开关值.
当参数b为true时,该方法将返回参数t所包含的值;否则将返回参数f所包含的值

例如: ${Util.switchValue((a=b), "a equals b", "a not equals b")}

Parameters:
b - boolean
t - Object
f - Object
Returns:
Object

isEmpty

public boolean isEmpty(java.lang.String s)
判断字符串是否为null或为"".

例如: ${Util.isEmpty(${Request.param1}}

Parameters:
s - String
Returns:
boolean

isNotEmpty

public boolean isNotEmpty(java.lang.String s)
判断字符串是否非空.

例如: ${Util.isNotEmpty(${Request.param1}}

Parameters:
s - String
Returns:
boolean

translate

public java.lang.String translate(java.lang.String s,
                                  java.lang.String oldCharset,
                                  java.lang.String newCharset)
                           throws java.io.UnsupportedEncodingException
转换字符串的字符集.

例如: ${Util.translate(${Request.param1}, "ISO8859-1", "GB2312"}

Parameters:
s - String
oldCharset - String
newCharset - String
Returns:
String
Throws:
java.io.UnsupportedEncodingException

translateFromISO

public java.lang.String translateFromISO(java.lang.String s,
                                         java.lang.String charset)
                                  throws java.io.UnsupportedEncodingException
将一个iso8859-1字符串转换为给定的编码格式.

例如: ${Util.translateFromISO(${Request.param1}, "GB2312"}

Parameters:
s - String
charset - String
Returns:
String
Throws:
java.io.UnsupportedEncodingException

systemOut

public void systemOut(java.lang.Object o)
systemOut

Parameters:
o - Object

systemErr

public void systemErr(java.lang.Object o)
systemErr

Parameters:
o - Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.common.rtexpr.impl

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common.rtexpr.impl

EL表达式相关的实现类
See:
Description

Class Summary
ExpressionUtils EL表达式工具类,该类所具有的各个方法亦即Util表达式所支持的各项功能.

Package com.bstek.dorado.common.rtexpr.impl Description

EL表达式相关的实现类


com.bstek.dorado.common.scope

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.common.scope

用于支持对象的缓存和查找的工具类
See:
Description

Class Summary
Scope | 对象的作用域类型
ScopeHelper | 对象的作用域类型的工具类

Package com.bstek.dorado.common.scope Description

用于支持对象的缓存和查找的工具类


Scope

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.scope
Class Scope

java.lang.Object
    extended by com.bstek.dorado.common.scope.Scope
public final class Scope
extends java.lang.Object

对象的作用域类型

Version:
4.0

Field Summary
static java.lang.String | APPLICATION 作用域类型 - Application，即整个应用中的所有Client都可访问。
static java.lang.String | REQUEST 作用域类型 - Reqeust
static java.lang.String | SESSION 作用域类型 - Session
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REQUEST

public static final java.lang.String REQUEST
作用域类型 - Reqeust

See Also:
Constant Field Values

SESSION

public static final java.lang.String SESSION
作用域类型 - Session

See Also:
Constant Field Values

APPLICATION

public static final java.lang.String APPLICATION
作用域类型 - Application，即整个应用中的所有Client都可访问。

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ScopeHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.common.scope
Class ScopeHelper

java.lang.Object
    extended by com.bstek.dorado.common.scope.ScopeHelper
public final class ScopeHelper
extends java.lang.Object

对象的作用域类型的工具类

Version:
4.0

Method Summary
static java.lang.Object | findObject(DoradoContext context, java.lang.String scope, java.lang.String attribute) 根据属性名从指定的资源中取得一个已被存入的对象
static void | storeObject(DoradoContext context, java.lang.String scope, java.lang.String attribute, java.lang.Object object) 根据属性名将一个对象存入相应的资源当中
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

storeObject

public static void storeObject(DoradoContext context,
                               java.lang.String scope,
                               java.lang.String attribute,
                               java.lang.Object object)
根据属性名将一个对象存入相应的资源当中

Parameters:
context - DoradoContext
scope - Scope
attribute - String
object - Object

findObject

public static java.lang.Object findObject(DoradoContext context,
                                          java.lang.String scope,
                                          java.lang.String attribute)
根据属性名从指定的资源中取得一个已被存入的对象

Parameters:
context - DoradoContext
scope - String
attribute - String
Returns:
Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BaseField

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class BaseField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.BaseField
All Implemented Interfaces:
Field
Direct Known Subclasses:
DBField, ViewBaseField
public class BaseField
extends com.bstek.dorado.data.AbstractField

最基本的Field对象。

Version:
4.0

Constructor Summary
BaseField(java.lang.String name)
构造器
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BaseField

public BaseField(java.lang.String name)
构造器

Parameters:
name - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BaseRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class BaseRecord

java.lang.Object
    extended by com.bstek.dorado.data.ReadRecord
        extended by com.bstek.dorado.data.Record
            extended by com.bstek.dorado.data.BaseRecord
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
Direct Known Subclasses:
DORecord
public class BaseRecord
extends Record

最基本的Record对象

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from class com.bstek.dorado.data.Record
STATE_DELETED, STATE_MODIFIED, STATE_NEW, STATE_NONE
Fields inherited from class com.bstek.dorado.data.ReadRecord
state
Constructor Summary
BaseRecord()
Method Summary
protected java.lang.Object | clone() 创建并返回本对象的一个副本。
protected java.lang.Object | doGet(java.lang.String name) 返回记录中某字段的值。此方法须在派生类中实现。
protected void | doSet(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值.此方法须在派生类中实现.
Methods inherited from class com.bstek.dorado.data.Record
fireAfterChange, fireBeforeChange, fromDO, getDataset, getFieldSet, getPropertyValue, getRecordId, isDeleted, set, setBigDecimal, setBoolean, setByte, setDate, setDetailRecords, setDouble, setFloat, setInt, setLong, setNull, setPropertyValue, setRecordId, setShort, setString, setValue, timestamp, toDO, toDO, validate
Methods inherited from class com.bstek.dorado.data.ReadRecord
get, getBigDecimal, getBoolean, getByte, getDate, getDetailRecords, getDouble, getFloat, getInt, getLong, getShort, getState, getString, getValue, getVariant, isNull
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BaseRecord

public BaseRecord()
Method Detail

doSet

protected void doSet(java.lang.String name,
                     java.lang.Object value)
设置当前记录中某字段的值.此方法须在派生类中实现.

Specified by:
doSet in class Record
Parameters:
name - String
value - Object

doGet

protected java.lang.Object doGet(java.lang.String name)
返回记录中某字段的值。此方法须在派生类中实现。

Specified by:
doGet in class ReadRecord
Parameters:
name - String
Returns:
Object

clone

protected java.lang.Object clone()
                          throws java.lang.CloneNotSupportedException
创建并返回本对象的一个副本。

Overrides:
clone in class Record
Returns:
a clone of this instance.
Throws:
java.lang.CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Interface DataListener

All Superinterfaces:
java.util.EventListener
All Known Implementing Classes:
DatasetSupport
public interface DataListener
extends java.util.EventListener

针对Dataset中的数据的事件监听器

Version:
4.0

Method Summary
void | afterChange(ReadRecord record, java.lang.String fieldName) 在数据被修改之后被触发的事件.
void | beforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 当数据将要被修改之前被触发的事件.

Method Detail

beforeChange

public void beforeChange(ReadRecord record,
                         java.lang.String fieldName,
                         Variant value)
当数据将要被修改之前被触发的事件.

Parameters:
record - 将被修改的记录
fieldName - 将被修改的字段名
value - Variant 将被设置到记录中的数值

afterChange

public void afterChange(ReadRecord record,
                        java.lang.String fieldName)
在数据被修改之后被触发的事件.

Parameters:
record - 被修改的记录
fieldName - 被修改的字段名
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Interface Dataset

All Superinterfaces:
java.io.Serializable
All Known Subinterfaces:
ViewDataset
All Known Implementing Classes:
DatasetAdapter, DatasetSupport, ViewDatasetSupport
public interface Dataset
extends java.io.Serializable

Dorado记录集的接口。

Dataset是Dorado架构的核心.Dataset用来管理一组数据,结构类似于关系型数据库中的表或视图.

  • 在标准的Dorado开发模式当中,Dataset的功能基本涵盖了对数据逻辑处理的各项要求。 开发人员可以利用Dataset来完成绝大部分的数据持久化、数据提取的操作。
  • 在以Dorado作为表现层的整合开发模式中,Dataset主要用于对从逻辑层中获得的数据进行封装.

Dataset具有当前记录的概念,这一点不同于ArrayList和Vector.只要Dataset中有可见记录当前记录就不可能是null, 此时Dataset的大多数操作都针对当前记录的操作.例如: setString、getBoolean、deleteRecord等.

Dataset也可以管理不可见的记录,例如:被标记为已删除的记录. 我们可以通过RecordIterator对象访问Dataset中的这一部分记录.

需要注意的是Dataset的isFirst和isLast并不表示Dataset的当前记录是否是第一条记录和当前记录是否是最后一条记录. 他们的概念应按下面的方式来理解.

  • isFirst表示Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true,此时Dataset的当前记录仍然是第一条记录.
  • isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true,此时Dataset的当前记录仍然是倒数第一条记录.

当用户调用了Dataset的moveFirst或moveLast之后,Dataset的isFirst或isLast将立刻变为true. 当Dataset中没有任何可见记录时,isFirst和isLast将同时为true,并且当前记录是null.

Version:
4.0

Field Summary
static java.lang.String | FILTER_ALL 过滤方式 - 所有记录
static java.lang.String | FILTER_CHANGED 过滤方式 - 所有发生变化的记录(包含新添加的、被修改过的和已删除的)
static java.lang.String | FILTER_DEFAULT 过滤方式 - 默认的记录 在此种方式下只有标记为"已删除"的记录是不可见的
static java.lang.String | FILTER_DELETED 过滤方式 - 所有已删除的记录
static java.lang.String | FILTER_MODIFIED 过滤方式 - 所有被修改过的记录
static java.lang.String | FILTER_NEW 过滤方式 - 所有被新添加的记录
static java.lang.String | FILTER_NOT_CHANGED 过滤方式 - 所有未发生变化的记录
static int | STATE_INIT Dataset状态 - 初始化
static int | STATE_LOADING Dataset状态 - 加载数据
static int | STATE_READY Dataset状态 - 已就绪
static int | STATE_RESOLVING Dataset状态 - 更新数据
Method Summary
void | addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
DummyField | addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。
BaseField | addField(java.lang.String name) 向Dataset中添加一个普通Field。
LookupField | addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。
void | addRecordListener(RecordListener l) 增加一个RecordtListener的事件监听器
void | clear() 清空Dataset中所有的数据。
void | createFields() 根据已设定的条件自动创建字段。
void | createFieldsFromObjectClazz() 自动利用反射将objectClazz中包含的属性映射成Dataset的字段.
void | deleteRecord() 删除当前记录。
void | deleteRecord(Record record) 删除指定的记录。
FieldSet | fieldSet() 返回Dataset的Field集合对象
Record | find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。
Record | find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。
Record[] | findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record[] | findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
int | fromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
Record | fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.
Record | fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
java.math.BigDecimal | getBigDecimal(int index) 按BigDecimal类型返回当前记录中某字段的值。
java.math.BigDecimal | getBigDecimal(java.lang.String name) 按BigDecimal类型返回当前记录中某字段的值。
boolean | getBoolean(int index) 按boolean类型返回当前记录中某字段的值。
boolean | getBoolean(java.lang.String name) 按boolean类型返回当前记录中某字段的值。
byte | getByte(int index) 按byte类型返回当前记录中某字段的值。
byte | getByte(java.lang.String name) 按byte类型返回当前记录中某字段的值。
Record | getCurrent() 返回当前记录对象。
java.util.Date | getDate(int index) 按Date类型返回当前记录中某字段的值。
java.util.Date | getDate(java.lang.String name) 按Date类型返回当前记录中某字段的值。
double | getDouble(int index) 按double类型返回当前记录中某字段的值。
double | getDouble(java.lang.String name) 按double类型返回当前记录中某字段的值。
Field | getField(int index) 根据Field索引号取得一个Field对象。
Field | getField(java.lang.String name) 根据Field名称取得一个Field对象。
int | getFieldCount() 取得Field的总数。
float | getFloat(int index) 按float类型返回当前记录中某字段的值。
float | getFloat(java.lang.String name) 按float类型返回当前记录中某字段的值。
java.lang.String | getId() 获得Dataset的ID
Index | getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。
Index | getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。
int | getInt(int index) 按int类型返回当前记录中某字段的值。
int | getInt(java.lang.String name) 按int类型返回当前记录中某字段的值。
long | getLong(int index) 按long类型返回当前记录中某字段的值。
long | getLong(java.lang.String name) 按long类型返回当前记录中某字段的值。
int | getMaxPropertyLevel() 获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
java.lang.Class | getObjectClazz() 返回相关的对象类型的Class名.
ReadRecord | getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
int | getPageCount() 返回Dataset所对应的数据共有几页。
int | getPageIndex() 返回Dataset的当前页号
int | getPageSize() 取得每页的行数。
int | getPossibleRecordCount() 获取Dataset可能存在的总记录数。。
RecordFilter | getRecordFilter() 获得Dataset内部使用的记录过滤器.
int | getRecordState() 返回当前记录的状态
short | getShort(int index) 按short类型返回当前记录中某字段的值。
short | getShort(java.lang.String name) 按short类型返回当前记录中某字段的值。
int | getState() 返回当前记录集的当前状态
java.lang.String | getString(int index) 按String类型返回当前记录中某字段的值。
java.lang.String | getString(java.lang.String name) 按String类型返回当前记录中某字段的值。
java.lang.Object | getValue(int index) 返回当前记录中某字段的值。
java.lang.Object | getValue(java.lang.String name) 返回当前记录中某字段的值。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
Record | insertRecord() 添加一条记录。
Record | insertRecord(int state) 添加一条记录并初始化新记录的状态。
boolean | isAutoCreateFields() 返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
boolean | isFirst() 当前位置是否已到达当前页的顶端。
boolean | isLast() 当前位置是否已到达当前页的尾端。
boolean | isNull(int index) 判断当前记录中某字段的值是否为空(null)。
boolean | isNull(java.lang.String name) 判断当前记录中某字段的值是否为空(null)。
int | load() 根据已设定的条件读取外部数据。
int | load(boolean loadData) Deprecated.
void | moveFirst() 将当前位置移动到Dataset的顶端。
void | moveLast() 将当前位置移动到Dataset的末端。
void | moveNext() 将当前位置移动到后一条记录。
void | movePrev() 将当前位置移动到前一条记录。
ParameterSet | parameters() 返回Dataset所有参数的集合对象
void | processLookup() 处理所有的Lookup数据。
MetaData | properties() 与Dataset相关的一组属性值.
RecordIterator | recordIterator() 返回Dataset中所有Record的迭代器。
RecordSet | recordSet() 返回Dataset的Record集合对象
void | removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | removeRecordListener(RecordListener l) 删除一个RecordtListener的事件监听器
void | resetRecordsState() 重置所有的记录状态
void | setAutoCreateFields(boolean autoCreateFields) 设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
void | setBigDecimal(int index, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBigDecimal(java.lang.String name, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBoolean(int index, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setBoolean(java.lang.String name, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setByte(int index, byte value) 按byte类型设置当前记录中某字段的值。
void | setByte(java.lang.String name, byte value) 按byte类型设置当前记录中某字段的值。
void | setCurrent(Record record) 设置当前记录对象。
void | setDate(int index, java.util.Date value) 按Date类型设置当前记录中某字段的值。
void | setDate(java.lang.String name, java.util.Date value) 按date类型设置当前记录中某字段的值。
void | setDouble(int index, double value) 按double类型设置当前记录中某字段的值。
void | setDouble(java.lang.String name, double value) 按double类型设置当前记录中某字段的值。
void | setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象
void | setFloat(int index, float value) 按float类型设置当前记录中某字段的值。
void | setFloat(java.lang.String name, float value) 按float类型设置当前记录中某字段的值。
void | setId(java.lang.String id) 设置Dataset的ID
void | setInt(int index, int value) 按int类型设置当前记录中某字段的值。
void | setInt(java.lang.String name, int value) 按int类型设置当前记录中某字段的值。
void | setLong(int index, long value) 按long类型设置当前记录中某字段的值。
void | setLong(java.lang.String name, long value) 按long类型设置当前记录中某字段的值。
void | setMaxPropertyLevel(int maxPropertyLevel) 设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
void | setNull(int index) 设置当前记录中某字段的值是否为空(null)。
void | setNull(java.lang.String name) 设置当前记录中某字段的值是否为空(null)。
void | setObjectClazz(java.lang.Class objectClazz) 设置相关的对象类型的Class名.
void | setObjectClazz(java.lang.String objectClazz) 设置相关的对象类型的Class名.
void | setPageCount(int pageCount) 设定Dataset所对应的数据共有几页。
void | setPageIndex(int pageIndex) 设定Dataset的当前页号
void | setPageSize(int pageSize) 设定Dataset分页时的每页记录数
void | setPossibleRecordCount(int possibleRecordCount) 设定Dataset可能存在的总记录数。
void | setRecordFilter(RecordFilter recordFilter) 设置Dataset内部使用的记录过滤器.
void | setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | setRecordState(int state) 设置当前记录的状态
void | setShort(int index, short value) 按short类型设置当前记录中某字段的值。
void | setShort(java.lang.String name, short value) 按short类型设置当前记录中某字段的值。
void | setState(int state) 更改当前记录集的当前状态
void | setString(int index, java.lang.String value) 按String类型设置当前记录中某字段的值。
void | setString(java.lang.String name, java.lang.String value) 按String类型设置当前记录中某字段的值。
void | setValue(int index, java.lang.Object value) 设置当前记录中某字段的值。
void | setValue(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值。
long | timestamp() 返回该Dataset对象的事件戳。
java.util.List | toDO() 自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.
void | toDO(java.util.Collection collection) 自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.
void | toDO(java.util.Collection collection, java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
java.util.List | toDO(java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
java.lang.Object | toSingleDO() 自动将Dataset中的当前记录转换为对象.
void | toSingleDO(java.lang.Object o) 自动将Dataset中的当前记录转换为对象.
java.lang.Object | toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
void | update() 把用户对Dataset中数据的操作更新到外部数据中.

Field Detail

STATE_INIT

public static final int STATE_INIT
Dataset状态 - 初始化

See Also:
Constant Field Values

STATE_READY

public static final int STATE_READY
Dataset状态 - 已就绪

See Also:
Constant Field Values

STATE_LOADING

public static final int STATE_LOADING
Dataset状态 - 加载数据

See Also:
Constant Field Values

STATE_RESOLVING

public static final int STATE_RESOLVING
Dataset状态 - 更新数据

See Also:
Constant Field Values

FILTER_DEFAULT

public static final java.lang.String FILTER_DEFAULT
过滤方式 - 默认的记录

在此种方式下只有标记为"已删除"的记录是不可见的

See Also:
Constant Field Values

FILTER_ALL

public static final java.lang.String FILTER_ALL
过滤方式 - 所有记录

See Also:
Constant Field Values

FILTER_CHANGED

public static final java.lang.String FILTER_CHANGED
过滤方式 - 所有发生变化的记录(包含新添加的、被修改过的和已删除的)

See Also:
Constant Field Values

FILTER_NEW

public static final java.lang.String FILTER_NEW
过滤方式 - 所有被新添加的记录

See Also:
Constant Field Values

FILTER_MODIFIED

public static final java.lang.String FILTER_MODIFIED
过滤方式 - 所有被修改过的记录

See Also:
Constant Field Values

FILTER_DELETED

public static final java.lang.String FILTER_DELETED
过滤方式 - 所有已删除的记录

See Also:
Constant Field Values

FILTER_NOT_CHANGED

public static final java.lang.String FILTER_NOT_CHANGED
过滤方式 - 所有未发生变化的记录

See Also:
Constant Field Values
Method Detail

getId

public java.lang.String getId()
获得Dataset的ID

Returns:
String

setId

public void setId(java.lang.String id)
设置Dataset的ID

Parameters:
id - String

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

addField

public BaseField addField(java.lang.String name)
向Dataset中添加一个普通Field。

Parameters:
name - String
Returns:
BaseField

addLookupField

public LookupField addLookupField(java.lang.String name)
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

Parameters:
name - String
Returns:
LookupField

addDummyField

public DummyField addDummyField(java.lang.String name)
向Dataset中添加一个虚拟Field。

Parameters:
name - String
Returns:
DummyField

getField

public Field getField(int index)
根据Field索引号取得一个Field对象。

Parameters:
index - int 从0开始的Field索引号
Returns:
Field

getField

public Field getField(java.lang.String name)
根据Field名称取得一个Field对象。

Parameters:
name - String
Returns:
Field

getFieldCount

public int getFieldCount()
取得Field的总数。

Returns:
int

createFieldsFromObjectClazz

public void createFieldsFromObjectClazz()
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.

此方法将自动为Dataset添加字段对象.

timestamp

public long timestamp()
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。

Returns:
long

getIndex

public Index getIndex(java.lang.String field)
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Parameters:
field - String
Returns:
Index

getIndex

public Index getIndex(java.lang.String[] fields)
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Parameters:
fields - String[]
Returns:
Index

find

public Record find(java.lang.String field,
                   java.lang.Object value)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Parameters:
field - String
value - Object
Returns:
Record

find

public Record find(java.lang.String[] fields,
                   java.lang.Object[] values)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Parameters:
fields - String[]
values - Object[]
Returns:
Record

findAll

public Record[] findAll(java.lang.String field,
                        java.lang.Object value)
根据指定的条件查找并返回所有匹配的记录。

Parameters:
field - String
value - Object
Returns:
Record[]

findAll

public Record[] findAll(java.lang.String[] fields,
                        java.lang.Object[] values)
根据指定的条件查找并返回所有匹配的记录。

Parameters:
fields - String[]
values - Object[]
Returns:
Record[]

getState

public int getState()
返回当前记录集的当前状态

Returns:
int

setState

public void setState(int state)
更改当前记录集的当前状态

Parameters:
state - int

isAutoCreateFields

public boolean isAutoCreateFields()
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.

Returns:
boolean

setAutoCreateFields

public void setAutoCreateFields(boolean autoCreateFields)
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.

Parameters:
autoCreateFields - boolean

getPageSize

public int getPageSize()
取得每页的行数。即Dataset按照多少行数对数据进行分页。

Returns:
int

setPageSize

public void setPageSize(int pageSize)
设定Dataset分页时的每页记录数

Parameters:
pageSize - int

getPageIndex

public int getPageIndex()
返回Dataset的当前页号

Returns:
int

setPageIndex

public void setPageIndex(int pageIndex)
设定Dataset的当前页号

Parameters:
pageIndex - int

getPageCount

public int getPageCount()
返回Dataset所对应的数据共有几页。

Returns:
int

setPageCount

public void setPageCount(int pageCount)
设定Dataset所对应的数据共有几页。

Parameters:
pageCount - int

getPossibleRecordCount

public int getPossibleRecordCount()
获取Dataset可能存在的总记录数。。

Returns:
int

setPossibleRecordCount

public void setPossibleRecordCount(int possibleRecordCount)
设定Dataset可能存在的总记录数。

Parameters:
possibleRecordCount - int

getObjectClazz

public java.lang.Class getObjectClazz()
返回相关的对象类型的Class名.

Returns:
Class

setObjectClazz

public void setObjectClazz(java.lang.Class objectClazz)
设置相关的对象类型的Class名.

Parameters:
objectClazz - Class

setObjectClazz

public void setObjectClazz(java.lang.String objectClazz)
设置相关的对象类型的Class名.

Parameters:
objectClazz - String

getMaxPropertyLevel

public int getMaxPropertyLevel()
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.

Returns:
int

setMaxPropertyLevel

public void setMaxPropertyLevel(int maxPropertyLevel)
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.

Parameters:
maxPropertyLevel - int

parameters

public ParameterSet parameters()
返回Dataset所有参数的集合对象

Returns:
Parameters

properties

public MetaData properties()
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

Returns:
MetaData

fieldSet

public FieldSet fieldSet()
返回Dataset的Field集合对象

Returns:
FieldSet

setFieldSet

public void setFieldSet(FieldSet fieldset)
设置Dataset的Field集合对象

Parameters:
fieldset - FieldSet

recordSet

public RecordSet recordSet()
返回Dataset的Record集合对象

Returns:
RecordSet

setRecordSet

public void setRecordSet(RecordSet recordset)
设定Dataset的Record集合对象

Parameters:
recordset - RecordSet

recordIterator

public RecordIterator recordIterator()
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

Returns:
RecordIterator

createFields

public void createFields()
                  throws java.lang.Exception
根据已设定的条件自动创建字段。

Throws:
java.lang.Exception

load

public int load()
         throws java.lang.Exception
根据已设定的条件读取外部数据。

Returns:
int
Throws:
java.lang.Exception

load

public int load(boolean loadData)
         throws java.lang.Exception
Deprecated.

根据已设定的条件读取外部数据。

Parameters:
loadData - 是否加载数据
Returns:
int
Throws:
java.lang.Exception

processLookup

public void processLookup()
处理所有的Lookup数据。

clear

public void clear()
清空Dataset中所有的数据。

update

public void update()
            throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Throws:
java.lang.Exception

resetRecordsState

public void resetRecordsState()
重置所有的记录状态

setRecordFilter

public void setRecordFilter(RecordFilter recordFilter)
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

Parameters:
recordFilter - RecordFilter

getRecordFilter

public RecordFilter getRecordFilter()
获得Dataset内部使用的记录过滤器.

Returns:
RecordFilter

getCurrent

public Record getCurrent()
返回当前记录对象。

Returns:
Record

setCurrent

public void setCurrent(Record record)
设置当前记录对象。

Parameters:
record - Record

isFirst

public boolean isFirst()
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

Returns:
boolean

isLast

public boolean isLast()
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

Returns:
boolean

moveFirst

public void moveFirst()
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.

movePrev

public void movePrev()
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.

moveNext

public void moveNext()
将当前位置移动到后一条记录。

moveLast

public void moveLast()
将当前位置移动到Dataset的末端。

insertRecord

public Record insertRecord()
添加一条记录。

Returns:
Record

insertRecord

public Record insertRecord(int state)
添加一条记录并初始化新记录的状态。

Parameters:
state - int
Returns:
Record

deleteRecord

public void deleteRecord()
删除当前记录。

deleteRecord

public void deleteRecord(Record record)
删除指定的记录。

Parameters:
record - Record

getRecordState

public int getRecordState()
返回当前记录的状态

Returns:
int

setRecordState

public void setRecordState(int state)
设置当前记录的状态

Parameters:
state - int

getOldRecord

public ReadRecord getOldRecord(Record record)
返回用于保存某记录的原始值的记录对象。

Parameters:
record - Record
Returns:
ReadRecord

getValue

public java.lang.Object getValue(int index)
返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(int index)
按BigDecimal类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
BigDecimal

getBoolean

public boolean getBoolean(int index)
按boolean类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Boolean

getByte

public byte getByte(int index)
按byte类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Byte

getDate

public java.util.Date getDate(int index)
按Date类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Date

getDouble

public double getDouble(int index)
按double类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Double

getFloat

public float getFloat(int index)
按float类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Float

getInt

public int getInt(int index)
按int类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Int

getLong

public long getLong(int index)
按long类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Long

getShort

public short getShort(int index)
按short类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
Short

getString

public java.lang.String getString(int index)
按String类型返回当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
Returns:
String

isNull

public boolean isNull(int index)
判断当前记录中某字段的值是否为空(null)。

Parameters:
index - int
Returns:
boolean

setValue

public void setValue(int index,
                     java.lang.Object value)
设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - Object

setBigDecimal

public void setBigDecimal(int index,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - BigDecimal

setBoolean

public void setBoolean(int index,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - boolean

setByte

public void setByte(int index,
                    byte value)
按byte类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - byte

setDate

public void setDate(int index,
                    java.util.Date value)
按Date类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - Date

setDouble

public void setDouble(int index,
                      double value)
按double类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - double

setFloat

public void setFloat(int index,
                     float value)
按float类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - float

setInt

public void setInt(int index,
                   int value)
按int类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - int

setLong

public void setLong(int index,
                    long value)
按long类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - long

setShort

public void setShort(int index,
                     short value)
按short类型设置当前记录中某字段的值。

Parameters:
index - int 从0开始的字段索引号
value - short

setString

public void setString(int index,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Parameters:
index - int 从0开始的字段索引号
value - String

setNull

public void setNull(int index)
设置当前记录中某字段的值是否为空(null)。

Parameters:
index - int

getValue

public java.lang.Object getValue(java.lang.String name)
返回当前记录中某字段的值。

Parameters:
name - String
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(java.lang.String name)
按BigDecimal类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
BigDecimal

getBoolean

public boolean getBoolean(java.lang.String name)
按boolean类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
boolean

getByte

public byte getByte(java.lang.String name)
按byte类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
byte

getDate

public java.util.Date getDate(java.lang.String name)
按Date类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
Date

getDouble

public double getDouble(java.lang.String name)
按double类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
double

getFloat

public float getFloat(java.lang.String name)
按float类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
float

getInt

public int getInt(java.lang.String name)
按int类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
int

getLong

public long getLong(java.lang.String name)
按long类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
long

getShort

public short getShort(java.lang.String name)
按short类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
short

getString

public java.lang.String getString(java.lang.String name)
按String类型返回当前记录中某字段的值。

Parameters:
name - String
Returns:
String

isNull

public boolean isNull(java.lang.String name)
判断当前记录中某字段的值是否为空(null)。

Parameters:
name - String
Returns:
boolean

setValue

public void setValue(java.lang.String name,
                     java.lang.Object value)
设置当前记录中某字段的值。

Parameters:
name - String
value - Object

setBigDecimal

public void setBigDecimal(java.lang.String name,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Parameters:
name - String
value - BigDecimal

setBoolean

public void setBoolean(java.lang.String name,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Parameters:
name - String
value - boolean

setByte

public void setByte(java.lang.String name,
                    byte value)
按byte类型设置当前记录中某字段的值。

Parameters:
name - String
value - byte

setDate

public void setDate(java.lang.String name,
                    java.util.Date value)
按date类型设置当前记录中某字段的值。

Parameters:
name - String
value - Date

setDouble

public void setDouble(java.lang.String name,
                      double value)
按double类型设置当前记录中某字段的值。

Parameters:
name - String
value - double

setFloat

public void setFloat(java.lang.String name,
                     float value)
按float类型设置当前记录中某字段的值。

Parameters:
name - String
value - float

setInt

public void setInt(java.lang.String name,
                   int value)
按int类型设置当前记录中某字段的值。

Parameters:
name - String
value - int

setLong

public void setLong(java.lang.String name,
                    long value)
按long类型设置当前记录中某字段的值。

Parameters:
name - String
value - long

setShort

public void setShort(java.lang.String name,
                     short value)
按short类型设置当前记录中某字段的值。

Parameters:
name - String
value - short

setString

public void setString(java.lang.String name,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Parameters:
name - String
value - String

setNull

public void setNull(java.lang.String name)
设置当前记录中某字段的值是否为空(null)。

Parameters:
name - String

removeRecordListener

public void removeRecordListener(RecordListener l)
删除一个RecordtListener的事件监听器

Parameters:
l - RecordtListener

addRecordListener

public void addRecordListener(RecordListener l)
增加一个RecordtListener的事件监听器

Parameters:
l - RecordtListener

removeDatasetListener

public void removeDatasetListener(DatasetListener l)
删除一个DatasetEvent的事件监听器

Parameters:
l - DatasetListener

addDatasetListener

public void addDatasetListener(DatasetListener l)
增加一个DatasetEvent的事件监听器

Parameters:
l - DatasetListener

fromDO

public int fromDO(java.lang.Object data)
           throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

Parameters:
data - Object
Returns:
int
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

Parameters:
o - Object
Returns:
Record
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o,
                           boolean newRecord)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

Parameters:
o - Object
newRecord - boolean
Returns:
Record
Throws:
java.lang.Exception

toDO

public java.util.List toDO()
                    throws java.lang.Exception
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Returns:
List
Throws:
java.lang.Exception

toDO

public java.util.List toDO(java.lang.String visibility)
                    throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Parameters:
visibility - int
Returns:
Object
Throws:
java.lang.Exception

toDO

public void toDO(java.util.Collection collection)
          throws java.lang.Exception
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Parameters:
collection - Collection
Throws:
java.lang.Exception

toDO

public void toDO(java.util.Collection collection,
                 java.lang.String visibility)
          throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Parameters:
collection - Collection
visibility - int
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO()
                            throws java.lang.Exception
自动将Dataset中的当前记录转换为对象.

Returns:
Object
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO(Record record)
                            throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Parameters:
record - Record
Returns:
Object
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中的当前记录转换为对象.

Parameters:
o - Object
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(Record record,
                       java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Parameters:
record - Record
o - Object
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetAdapter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class DatasetAdapter

java.lang.Object
    extended by com.bstek.dorado.data.DatasetAdapter
All Implemented Interfaces:
Dataset, java.io.Serializable
public class DatasetAdapter
extends java.lang.Object
implements Dataset

Dataset适配器

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DatasetAdapter()
构造器
DatasetAdapter(Dataset target)
构造器
Method Summary
void | addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
DummyField | addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。
BaseField | addField(java.lang.String name) 向Dataset中添加一个普通Field。
LookupField | addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。 Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。
void | addRecordListener(RecordListener l) 增加一个RecordtListener的事件监听器
void | clear() 清空Dataset中所有的数据。
void | createFields() 根据已设定的条件自动创建字段。
void | createFieldsFromObjectClazz() 自动利用反射将objectClazz中包含的属性映射成Dataset的字段. 此方法将自动为Dataset添加字段对象.
void | deleteRecord() 删除当前记录。
void | deleteRecord(Record record) 删除指定的记录。
FieldSet | fieldSet() 返回Dataset的Field集合对象
Record | find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record | find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record[] | findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record[] | findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
int | fromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中. 此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.
Record | fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中. 此处的data可以是单个的Bean或java.util.Map的派生类.
java.math.BigDecimal | getBigDecimal(int index) 按BigDecimal类型返回当前记录中某字段的值。
java.math.BigDecimal | getBigDecimal(java.lang.String name) 按BigDecimal类型返回当前记录中某字段的值。
boolean | getBoolean(int index) 按boolean类型返回当前记录中某字段的值。
boolean | getBoolean(java.lang.String name) 按boolean类型返回当前记录中某字段的值。
byte | getByte(int index) 按byte类型返回当前记录中某字段的值。
byte | getByte(java.lang.String name) 按byte类型返回当前记录中某字段的值。
Record | getCurrent() 返回当前记录对象。
java.util.Date | getDate(int index) 按Date类型返回当前记录中某字段的值。
java.util.Date | getDate(java.lang.String name) 按Date类型返回当前记录中某字段的值。
double | getDouble(int index) 按double类型返回当前记录中某字段的值。
double | getDouble(java.lang.String name) 按double类型返回当前记录中某字段的值。
Field | getField(int index) 根据Field索引号取得一个Field对象。
Field | getField(java.lang.String name) 根据Field名称取得一个Field对象。
int | getFieldCount() 取得Field的总数。
float | getFloat(int index) 按float类型返回当前记录中某字段的值。
float | getFloat(java.lang.String name) 按float类型返回当前记录中某字段的值。
java.lang.String | getId() 获得Dataset的ID
Index | getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
int | getInt(int index) 按int类型返回当前记录中某字段的值。
int | getInt(java.lang.String name) 按int类型返回当前记录中某字段的值。
long | getLong(int index) 按long类型返回当前记录中某字段的值。
long | getLong(java.lang.String name) 按long类型返回当前记录中某字段的值。
int | getMaxPropertyLevel() 获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
java.lang.Class | getObjectClazz() 返回相关的对象类型的Class名.
ReadRecord | getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
int | getPageCount() 返回Dataset所对应的数据共有几页。
int | getPageIndex() 返回Dataset的当前页号
int | getPageSize() 取得每页的行数。即Dataset按照多少行数对数据进行分页。
int | getPossibleRecordCount() 获取Dataset可能存在的总记录数。。
RecordFilter | getRecordFilter() 获得Dataset内部使用的记录过滤器.
int | getRecordState() 返回当前记录的状态
short | getShort(int index) 按short类型返回当前记录中某字段的值。
short | getShort(java.lang.String name) 按short类型返回当前记录中某字段的值。
int | getState() 返回当前记录集的当前状态
java.lang.String | getString(int index) 按String类型返回当前记录中某字段的值。
java.lang.String | getString(java.lang.String name) 按String类型返回当前记录中某字段的值。
Dataset | getTarget() 返回适配器的目标Dataset
java.lang.Object | getValue(int index) 返回当前记录中某字段的值。
java.lang.Object | getValue(java.lang.String name) 返回当前记录中某字段的值。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
Record | insertRecord() 添加一条记录。
Record | insertRecord(int state) 添加一条记录并初始化新记录的状态。
boolean | isAutoCreateFields() 返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field. 注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.
boolean | isFirst() 当前位置是否已到达当前页的顶端。 此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.
boolean | isLast() 当前位置是否已到达当前页的尾端。 此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.
boolean | isNull(int index) 判断当前记录中某字段的值是否为空(null)。
boolean | isNull(java.lang.String name) 判断当前记录中某字段的值是否为空(null)。
int | load() 根据已设定的条件读取外部数据。
int | load(boolean loadData) 根据已设定的条件读取外部数据。
void | moveFirst() 将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
void | moveLast() 将当前位置移动到Dataset的末端。
void | moveNext() 将当前位置移动到后一条记录。
void | movePrev() 将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
ParameterSet | parameters() 返回Dataset所有参数的集合对象
void | processLookup() 处理所有的Lookup数据。
MetaData | properties() 与Dataset相关的一组属性值. 这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.
RecordIterator | recordIterator() 返回Dataset中所有Record的迭代器。 注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。
RecordSet | recordSet() 返回Dataset的Record集合对象
void | removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | removeRecordListener(RecordListener l) 删除一个RecordtListener的事件监听器
void | resetRecordsState() 重置所有的记录状态
void | setAutoCreateFields(boolean autoCreateFields) 设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
void | setBigDecimal(int index, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBigDecimal(java.lang.String name, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBoolean(int index, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setBoolean(java.lang.String name, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setByte(int index, byte value) 按byte类型设置当前记录中某字段的值。
void | setByte(java.lang.String name, byte value) 按byte类型设置当前记录中某字段的值。
void | setCurrent(Record record) 设置当前记录对象。
void | setDate(int index, java.util.Date value) 按Date类型设置当前记录中某字段的值。
void | setDate(java.lang.String name, java.util.Date value) 按date类型设置当前记录中某字段的值。
void | setDouble(int index, double value) 按double类型设置当前记录中某字段的值。
void | setDouble(java.lang.String name, double value) 按double类型设置当前记录中某字段的值。
void | setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象
void | setFloat(int index, float value) 按float类型设置当前记录中某字段的值。
void | setFloat(java.lang.String name, float value) 按float类型设置当前记录中某字段的值。
void | setId(java.lang.String id) 设置Dataset的ID
void | setInt(int index, int value) 按int类型设置当前记录中某字段的值。
void | setInt(java.lang.String name, int value) 按int类型设置当前记录中某字段的值。
void | setLong(int index, long value) 按long类型设置当前记录中某字段的值。
void | setLong(java.lang.String name, long value) 按long类型设置当前记录中某字段的值。
void | setMaxPropertyLevel(int maxPropertyLevel) 设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
void | setNull(int index) 设置当前记录中某字段的值是否为空(null)。
void | setNull(java.lang.String name) 设置当前记录中某字段的值是否为空(null)。
void | setObjectClazz(java.lang.Class objectClazz) 设置相关的对象类型的Class名.
void | setObjectClazz(java.lang.String objectClazz) 设置相关的对象类型的Class名.
void | setPageCount(int pageCount) 设定Dataset所对应的数据共有几页。
void | setPageIndex(int pageIndex) 设定Dataset的当前页号
void | setPageSize(int pageSize) 设定Dataset分页时的每页记录数
void | setPossibleRecordCount(int possibleRecordCount) 设定Dataset可能存在的总记录数。
void | setRecordFilter(RecordFilter recordFilter) 设置Dataset内部使用的记录过滤器. 通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录
void | setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | setRecordState(int state) 设置当前记录的状态
void | setShort(int index, short value) 按short类型设置当前记录中某字段的值。
void | setShort(java.lang.String name, short value) 按short类型设置当前记录中某字段的值。
void | setState(int state) 更改当前记录集的当前状态
void | setString(int index, java.lang.String value) 按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
void | setString(java.lang.String name, java.lang.String value) 按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
void | setTarget(Dataset target) 设定适配器的目标Dataset
void | setValue(int index, java.lang.Object value) 设置当前记录中某字段的值。
void | setValue(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值。
long | timestamp() 返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
java.util.List | toDO() 自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
void | toDO(java.util.Collection collection) 自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
void | toDO(java.util.Collection collection, java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
java.util.List | toDO(java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
java.lang.Object | toSingleDO() 自动将Dataset中的当前记录转换为对象.
void | toSingleDO(java.lang.Object o) 自动将Dataset中的当前记录转换为对象.
java.lang.Object | toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
void | update() 把用户对Dataset中数据的操作更新到外部数据中.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DatasetAdapter

public DatasetAdapter()
构造器

DatasetAdapter

public DatasetAdapter(Dataset target)
构造器

Parameters:
target - Dataset
Method Detail

getTarget

public Dataset getTarget()
返回适配器的目标Dataset

Returns:
Dataset

setTarget

public void setTarget(Dataset target)
设定适配器的目标Dataset

Parameters:
target - Dataset

getId

public java.lang.String getId()
获得Dataset的ID

Specified by:
getId in interface Dataset
Returns:
String

setId

public void setId(java.lang.String id)
设置Dataset的ID

Specified by:
setId in interface Dataset
Parameters:
id - String

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

addField

public BaseField addField(java.lang.String name)
向Dataset中添加一个普通Field。

Specified by:
addField in interface Dataset
Parameters:
name - String
Returns:
BaseField

addLookupField

public LookupField addLookupField(java.lang.String name)
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

Specified by:
addLookupField in interface Dataset
Parameters:
name - String
Returns:
LookupField

addDummyField

public DummyField addDummyField(java.lang.String name)
向Dataset中添加一个虚拟Field。

Specified by:
addDummyField in interface Dataset
Parameters:
name - String
Returns:
DummyField

getField

public Field getField(int index)
根据Field索引号取得一个Field对象。

Specified by:
getField in interface Dataset
Parameters:
index - int 从0开始的Field索引号
Returns:
Field

getField

public Field getField(java.lang.String name)
根据Field名称取得一个Field对象。

Specified by:
getField in interface Dataset
Parameters:
name - String
Returns:
Field

getFieldCount

public int getFieldCount()
取得Field的总数。

Specified by:
getFieldCount in interface Dataset
Returns:
int

createFieldsFromObjectClazz

public void createFieldsFromObjectClazz()
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.

此方法将自动为Dataset添加字段对象.

Specified by:
createFieldsFromObjectClazz in interface Dataset

timestamp

public long timestamp()
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。

Specified by:
timestamp in interface Dataset
Returns:
long

getIndex

public Index getIndex(java.lang.String field)
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Specified by:
getIndex in interface Dataset
Parameters:
field - String
Returns:
Index

getIndex

public Index getIndex(java.lang.String[] fields)
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Specified by:
getIndex in interface Dataset
Parameters:
fields - String[]
Returns:
Index

find

public Record find(java.lang.String field,
                   java.lang.Object value)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Specified by:
find in interface Dataset
Parameters:
field - String
value - Object
Returns:
Record

find

public Record find(java.lang.String[] fields,
                   java.lang.Object[] values)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Specified by:
find in interface Dataset
Parameters:
fields - String[]
values - Object[]
Returns:
Record

findAll

public Record[] findAll(java.lang.String field,
                        java.lang.Object value)
根据指定的条件查找并返回所有匹配的记录。

Specified by:
findAll in interface Dataset
Parameters:
field - String
value - Object
Returns:
Record[]

findAll

public Record[] findAll(java.lang.String[] fields,
                        java.lang.Object[] values)
根据指定的条件查找并返回所有匹配的记录。

Specified by:
findAll in interface Dataset
Parameters:
fields - String[]
values - Object[]
Returns:
Record[]

getState

public int getState()
返回当前记录集的当前状态

Specified by:
getState in interface Dataset
Returns:
int

setState

public void setState(int state)
更改当前记录集的当前状态

Specified by:
setState in interface Dataset
Parameters:
state - int

isAutoCreateFields

public boolean isAutoCreateFields()
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.

Specified by:
isAutoCreateFields in interface Dataset
Returns:
boolean

setAutoCreateFields

public void setAutoCreateFields(boolean autoCreateFields)
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.

Specified by:
setAutoCreateFields in interface Dataset
Parameters:
autoCreateFields - boolean

getPageSize

public int getPageSize()
取得每页的行数。即Dataset按照多少行数对数据进行分页。

Specified by:
getPageSize in interface Dataset
Returns:
int

setPageSize

public void setPageSize(int pageSize)
设定Dataset分页时的每页记录数

Specified by:
setPageSize in interface Dataset
Parameters:
pageSize - int

getPageIndex

public int getPageIndex()
返回Dataset的当前页号

Specified by:
getPageIndex in interface Dataset
Returns:
int

setPageIndex

public void setPageIndex(int pageIndex)
设定Dataset的当前页号

Specified by:
setPageIndex in interface Dataset
Parameters:
pageIndex - int

getPageCount

public int getPageCount()
返回Dataset所对应的数据共有几页。

Specified by:
getPageCount in interface Dataset
Returns:
int

setPageCount

public void setPageCount(int pageCount)
设定Dataset所对应的数据共有几页。

Specified by:
setPageCount in interface Dataset
Parameters:
pageCount - int

getPossibleRecordCount

public int getPossibleRecordCount()
获取Dataset可能存在的总记录数。。

Specified by:
getPossibleRecordCount in interface Dataset
Returns:
int

setPossibleRecordCount

public void setPossibleRecordCount(int possibleRecordCount)
设定Dataset可能存在的总记录数。

Specified by:
setPossibleRecordCount in interface Dataset
Parameters:
possibleRecordCount - int

getObjectClazz

public java.lang.Class getObjectClazz()
返回相关的对象类型的Class名.

Specified by:
getObjectClazz in interface Dataset
Returns:
Class

setObjectClazz

public void setObjectClazz(java.lang.String objectClazz)
设置相关的对象类型的Class名.

Specified by:
setObjectClazz in interface Dataset
Parameters:
objectClazz - String

setObjectClazz

public void setObjectClazz(java.lang.Class objectClazz)
设置相关的对象类型的Class名.

Specified by:
setObjectClazz in interface Dataset
Parameters:
objectClazz - Class

getMaxPropertyLevel

public int getMaxPropertyLevel()
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.

Specified by:
getMaxPropertyLevel in interface Dataset
Returns:
int

setMaxPropertyLevel

public void setMaxPropertyLevel(int maxPropertyLevel)
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.

Specified by:
setMaxPropertyLevel in interface Dataset
Parameters:
maxPropertyLevel - int

parameters

public ParameterSet parameters()
返回Dataset所有参数的集合对象

Specified by:
parameters in interface Dataset
Returns:
Parameters

properties

public MetaData properties()
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

Specified by:
properties in interface Dataset
Returns:
MetaData

fieldSet

public FieldSet fieldSet()
返回Dataset的Field集合对象

Specified by:
fieldSet in interface Dataset
Returns:
FieldSet

setFieldSet

public void setFieldSet(FieldSet fieldset)
设置Dataset的Field集合对象

Specified by:
setFieldSet in interface Dataset
Parameters:
fieldset - FieldSet

recordSet

public RecordSet recordSet()
返回Dataset的Record集合对象

Specified by:
recordSet in interface Dataset
Returns:
RecordSet

setRecordSet

public void setRecordSet(RecordSet recordset)
设定Dataset的Record集合对象

Specified by:
setRecordSet in interface Dataset
Parameters:
recordset - RecordSet

recordIterator

public RecordIterator recordIterator()
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

Specified by:
recordIterator in interface Dataset
Returns:
RecordIterator

createFields

public void createFields()
                  throws java.lang.Exception
Description copied from interface: Dataset
根据已设定的条件自动创建字段。

Specified by:
createFields in interface Dataset
Throws:
java.lang.Exception

load

public int load()
         throws java.lang.Exception
根据已设定的条件读取外部数据。

Specified by:
load in interface Dataset
Returns:
int
Throws:
java.lang.Exception

load

public int load(boolean loadData)
         throws java.lang.Exception
根据已设定的条件读取外部数据。

Specified by:
load in interface Dataset
Parameters:
loadData - 是否加载数据
Returns:
int
Throws:
java.lang.Exception

processLookup

public void processLookup()
处理所有的Lookup数据。

Specified by:
processLookup in interface Dataset

clear

public void clear()
清空Dataset中所有的数据。

Specified by:
clear in interface Dataset

update

public void update()
            throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Specified by:
update in interface Dataset
Throws:
java.lang.Exception

resetRecordsState

public void resetRecordsState()
重置所有的记录状态

Specified by:
resetRecordsState in interface Dataset

setRecordFilter

public void setRecordFilter(RecordFilter recordFilter)
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

Specified by:
setRecordFilter in interface Dataset
Parameters:
recordFilter - RecordFilter

getRecordFilter

public RecordFilter getRecordFilter()
获得Dataset内部使用的记录过滤器.

Specified by:
getRecordFilter in interface Dataset
Returns:
RecordFilter

getCurrent

public Record getCurrent()
返回当前记录对象。

Specified by:
getCurrent in interface Dataset
Returns:
Record

setCurrent

public void setCurrent(Record record)
设置当前记录对象。

Specified by:
setCurrent in interface Dataset
Parameters:
record - Record

isFirst

public boolean isFirst()
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

Specified by:
isFirst in interface Dataset
Returns:
boolean

isLast

public boolean isLast()
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

Specified by:
isLast in interface Dataset
Returns:
boolean

moveFirst

public void moveFirst()
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.

Specified by:
moveFirst in interface Dataset

movePrev

public void movePrev()
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.

Specified by:
movePrev in interface Dataset

moveNext

public void moveNext()
将当前位置移动到后一条记录。

Specified by:
moveNext in interface Dataset

moveLast

public void moveLast()
将当前位置移动到Dataset的末端。

Specified by:
moveLast in interface Dataset

insertRecord

public Record insertRecord()
添加一条记录。

Specified by:
insertRecord in interface Dataset
Returns:
Record

insertRecord

public Record insertRecord(int state)
添加一条记录并初始化新记录的状态。

Specified by:
insertRecord in interface Dataset
Parameters:
state - int
Returns:
Record

deleteRecord

public void deleteRecord()
删除当前记录。

Specified by:
deleteRecord in interface Dataset

deleteRecord

public void deleteRecord(Record record)
删除指定的记录。

Specified by:
deleteRecord in interface Dataset
Parameters:
record - Record

getRecordState

public int getRecordState()
返回当前记录的状态

Specified by:
getRecordState in interface Dataset
Returns:
int

setRecordState

public void setRecordState(int state)
设置当前记录的状态

Specified by:
setRecordState in interface Dataset
Parameters:
state - int

getOldRecord

public ReadRecord getOldRecord(Record record)
返回用于保存某记录的原始值的记录对象。

Specified by:
getOldRecord in interface Dataset
Parameters:
record - Record
Returns:
ReadRecord

getValue

public java.lang.Object getValue(int index)
返回当前记录中某字段的值。

Specified by:
getValue in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(int index)
按BigDecimal类型返回当前记录中某字段的值。

Specified by:
getBigDecimal in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
BigDecimal

getBoolean

public boolean getBoolean(int index)
按boolean类型返回当前记录中某字段的值。

Specified by:
getBoolean in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Boolean

getByte

public byte getByte(int index)
按byte类型返回当前记录中某字段的值。

Specified by:
getByte in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Byte

getDate

public java.util.Date getDate(int index)
按Date类型返回当前记录中某字段的值。

Specified by:
getDate in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Date

getDouble

public double getDouble(int index)
按double类型返回当前记录中某字段的值。

Specified by:
getDouble in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Double

getFloat

public float getFloat(int index)
按float类型返回当前记录中某字段的值。

Specified by:
getFloat in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Float

getInt

public int getInt(int index)
按int类型返回当前记录中某字段的值。

Specified by:
getInt in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Int

getLong

public long getLong(int index)
按long类型返回当前记录中某字段的值。

Specified by:
getLong in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Long

getShort

public short getShort(int index)
按short类型返回当前记录中某字段的值。

Specified by:
getShort in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Short

getString

public java.lang.String getString(int index)
按String类型返回当前记录中某字段的值。

Specified by:
getString in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
String

isNull

public boolean isNull(int index)
判断当前记录中某字段的值是否为空(null)。

Specified by:
isNull in interface Dataset
Parameters:
index - int
Returns:
boolean

setValue

public void setValue(int index,
                     java.lang.Object value)
设置当前记录中某字段的值。

Specified by:
setValue in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - Object

setBigDecimal

public void setBigDecimal(int index,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Specified by:
setBigDecimal in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - BigDecimal

setBoolean

public void setBoolean(int index,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Specified by:
setBoolean in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - boolean

setByte

public void setByte(int index,
                    byte value)
按byte类型设置当前记录中某字段的值。

Specified by:
setByte in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - byte

setDate

public void setDate(int index,
                    java.util.Date value)
按Date类型设置当前记录中某字段的值。

Specified by:
setDate in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - Date

setDouble

public void setDouble(int index,
                      double value)
按double类型设置当前记录中某字段的值。

Specified by:
setDouble in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - double

setFloat

public void setFloat(int index,
                     float value)
按float类型设置当前记录中某字段的值。

Specified by:
setFloat in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - float

setInt

public void setInt(int index,
                   int value)
按int类型设置当前记录中某字段的值。

Specified by:
setInt in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - int

setLong

public void setLong(int index,
                    long value)
按long类型设置当前记录中某字段的值。

Specified by:
setLong in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - long

setShort

public void setShort(int index,
                     short value)
按short类型设置当前记录中某字段的值。

Specified by:
setShort in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - short

setString

public void setString(int index,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Specified by:
setString in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - String

setNull

public void setNull(int index)
设置当前记录中某字段的值是否为空(null)。

Specified by:
setNull in interface Dataset
Parameters:
index - int

getValue

public java.lang.Object getValue(java.lang.String name)
返回当前记录中某字段的值。

Specified by:
getValue in interface Dataset
Parameters:
name - String
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(java.lang.String name)
按BigDecimal类型返回当前记录中某字段的值。

Specified by:
getBigDecimal in interface Dataset
Parameters:
name - String
Returns:
BigDecimal

getBoolean

public boolean getBoolean(java.lang.String name)
按boolean类型返回当前记录中某字段的值。

Specified by:
getBoolean in interface Dataset
Parameters:
name - String
Returns:
boolean

getByte

public byte getByte(java.lang.String name)
按byte类型返回当前记录中某字段的值。

Specified by:
getByte in interface Dataset
Parameters:
name - String
Returns:
byte

getDate

public java.util.Date getDate(java.lang.String name)
按Date类型返回当前记录中某字段的值。

Specified by:
getDate in interface Dataset
Parameters:
name - String
Returns:
Date

getDouble

public double getDouble(java.lang.String name)
按double类型返回当前记录中某字段的值。

Specified by:
getDouble in interface Dataset
Parameters:
name - String
Returns:
double

getFloat

public float getFloat(java.lang.String name)
按float类型返回当前记录中某字段的值。

Specified by:
getFloat in interface Dataset
Parameters:
name - String
Returns:
float

getInt

public int getInt(java.lang.String name)
按int类型返回当前记录中某字段的值。

Specified by:
getInt in interface Dataset
Parameters:
name - String
Returns:
int

getLong

public long getLong(java.lang.String name)
按long类型返回当前记录中某字段的值。

Specified by:
getLong in interface Dataset
Parameters:
name - String
Returns:
long

getShort

public short getShort(java.lang.String name)
按short类型返回当前记录中某字段的值。

Specified by:
getShort in interface Dataset
Parameters:
name - String
Returns:
short

getString

public java.lang.String getString(java.lang.String name)
按String类型返回当前记录中某字段的值。

Specified by:
getString in interface Dataset
Parameters:
name - String
Returns:
String

isNull

public boolean isNull(java.lang.String name)
判断当前记录中某字段的值是否为空(null)。

Specified by:
isNull in interface Dataset
Parameters:
name - String
Returns:
boolean

setValue

public void setValue(java.lang.String name,
                     java.lang.Object value)
设置当前记录中某字段的值。

Specified by:
setValue in interface Dataset
Parameters:
name - String
value - Object

setBigDecimal

public void setBigDecimal(java.lang.String name,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Specified by:
setBigDecimal in interface Dataset
Parameters:
name - String
value - BigDecimal

setBoolean

public void setBoolean(java.lang.String name,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Specified by:
setBoolean in interface Dataset
Parameters:
name - String
value - boolean

setByte

public void setByte(java.lang.String name,
                    byte value)
按byte类型设置当前记录中某字段的值。

Specified by:
setByte in interface Dataset
Parameters:
name - String
value - byte

setDate

public void setDate(java.lang.String name,
                    java.util.Date value)
按date类型设置当前记录中某字段的值。

Specified by:
setDate in interface Dataset
Parameters:
name - String
value - Date

setDouble

public void setDouble(java.lang.String name,
                      double value)
按double类型设置当前记录中某字段的值。

Specified by:
setDouble in interface Dataset
Parameters:
name - String
value - double

setFloat

public void setFloat(java.lang.String name,
                     float value)
按float类型设置当前记录中某字段的值。

Specified by:
setFloat in interface Dataset
Parameters:
name - String
value - float

setInt

public void setInt(java.lang.String name,
                   int value)
按int类型设置当前记录中某字段的值。

Specified by:
setInt in interface Dataset
Parameters:
name - String
value - int

setLong

public void setLong(java.lang.String name,
                    long value)
按long类型设置当前记录中某字段的值。

Specified by:
setLong in interface Dataset
Parameters:
name - String
value - long

setShort

public void setShort(java.lang.String name,
                     short value)
按short类型设置当前记录中某字段的值。

Specified by:
setShort in interface Dataset
Parameters:
name - String
value - short

setString

public void setString(java.lang.String name,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Specified by:
setString in interface Dataset
Parameters:
name - String
value - String

setNull

public void setNull(java.lang.String name)
设置当前记录中某字段的值是否为空(null)。

Specified by:
setNull in interface Dataset
Parameters:
name - String

addRecordListener

public void addRecordListener(RecordListener l)
增加一个RecordtListener的事件监听器

Specified by:
addRecordListener in interface Dataset
Parameters:
l - RecordtListener

removeRecordListener

public void removeRecordListener(RecordListener l)
删除一个RecordtListener的事件监听器

Specified by:
removeRecordListener in interface Dataset
Parameters:
l - RecordtListener

addDatasetListener

public void addDatasetListener(DatasetListener l)
增加一个DatasetEvent的事件监听器

Specified by:
addDatasetListener in interface Dataset
Parameters:
l - DatasetListener

removeDatasetListener

public void removeDatasetListener(DatasetListener l)
删除一个DatasetEvent的事件监听器

Specified by:
removeDatasetListener in interface Dataset
Parameters:
l - DatasetListener

fromDO

public int fromDO(java.lang.Object data)
           throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

Specified by:
fromDO in interface Dataset
Parameters:
data - Object
Returns:
int
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

Specified by:
fromSingleDO in interface Dataset
Parameters:
o - Object
Returns:
Record
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o,
                           boolean newRecord)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

Specified by:
fromSingleDO in interface Dataset
Parameters:
o - Object
newRecord - boolean
Returns:
Record
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中的当前记录转换为对象.

Specified by:
toSingleDO in interface Dataset
Parameters:
o - Object
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(Record record,
                       java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Specified by:
toSingleDO in interface Dataset
Parameters:
record - Record
o - Object
Throws:
java.lang.Exception

toDO

public java.util.List toDO()
                    throws java.lang.Exception
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Returns:
List
Throws:
java.lang.Exception

toDO

public java.util.List toDO(java.lang.String visibility)
                    throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Parameters:
visibility - int
Returns:
Object
Throws:
java.lang.Exception

toDO

public void toDO(java.util.Collection collection)
          throws java.lang.Exception
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Parameters:
collection - Collection
Throws:
java.lang.Exception

toDO

public void toDO(java.util.Collection collection,
                 java.lang.String visibility)
          throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Parameters:
collection - Collection
visibility - int
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO()
                            throws java.lang.Exception
自动将Dataset中的当前记录转换为对象.

Specified by:
toSingleDO in interface Dataset
Returns:
Object
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO(Record record)
                            throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Specified by:
toSingleDO in interface Dataset
Parameters:
record - Record
Returns:
Object
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Interface DatasetListener

All Superinterfaces:
java.util.EventListener
public interface DatasetListener
extends java.util.EventListener

Dataset事件监听器的接口

Version:
4.0

Method Summary
void | afterCreateFields(Dataset dataset) 当Dataset执行完自动创建所有字段之后触发的事件.即当调用Dataset.createFields()之后触发的事件.
void | afterLoadData(Dataset dataset) 当Dataset执行完装载数据之后触发的事件.即当调用Dataset.loadData()之后触发的事件.
void | afterUpdateData(Dataset dataset) 当Dataset执行完装载数据之后触发的事件.即当调用Dataset.update()之后触发的事件.
boolean | beforeCreateFields(Dataset dataset) 当Dataset将要自动创建所有字段之前触发的事件.即当调用Dataset.createFields()之前触发的事件.
boolean | beforeLoadData(Dataset dataset) 当Dataset将要装载数据之前触发的事件.即当调用Dataset.loadData()之前触发的事件.
boolean | beforeUpdateData(Dataset dataset) 当Dataset将要装载数据之前触发的事件.即当调用Dataset.update()之前触发的事件.
void | onInit(Dataset dataset) 当Dataset被初始化的时候触发的事件.即当调用Dataset.init()时触发的事件.

Method Detail

onInit

public void onInit(Dataset dataset)
            throws java.lang.Exception
当Dataset被初始化的时候触发的事件.即当调用Dataset.init()时触发的事件.

Parameters:
dataset - Dataset
Throws:
java.lang.Exception

beforeCreateFields

public boolean beforeCreateFields(Dataset dataset)
                           throws java.lang.Exception
当Dataset将要自动创建所有字段之前触发的事件.即当调用Dataset.createFields()之前触发的事件.
此方法的返回值用于通知Dataset是否要继续标准的createFields()操作.如果您已经在此事件中为 Dataset定义好了所有的字段,那么您可以返回一个false值终止标准的createFields()操作.

Parameters:
dataset - Dataset
Returns:
boolean
Throws:
java.lang.Exception

afterCreateFields

public void afterCreateFields(Dataset dataset)
                       throws java.lang.Exception
当Dataset执行完自动创建所有字段之后触发的事件.即当调用Dataset.createFields()之后触发的事件.

Parameters:
dataset - Dataset
Throws:
java.lang.Exception

beforeLoadData

public boolean beforeLoadData(Dataset dataset)
                       throws java.lang.Exception
当Dataset将要装载数据之前触发的事件.即当调用Dataset.loadData()之前触发的事件.
此方法的返回值用于通知Dataset是否要继续标准的loadData()操作.如果您已经在此事件中为 Dataset定义好了所有的字段,那么您可以返回一个false值终止标准的loadData()操作.

Parameters:
dataset - Dataset
Returns:
boolean
Throws:
java.lang.Exception

afterLoadData

public void afterLoadData(Dataset dataset)
                   throws java.lang.Exception
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.loadData()之后触发的事件.

Parameters:
dataset - Dataset
Throws:
java.lang.Exception

beforeUpdateData

public boolean beforeUpdateData(Dataset dataset)
                         throws java.lang.Exception
当Dataset将要装载数据之前触发的事件.即当调用Dataset.update()之前触发的事件.
此方法的返回值用于通知Dataset是否要继续标准的update()操作.如果您已经在此事件中为 Dataset定义好了所有的字段,那么您可以返回一个false值终止标准的update()操作.

Parameters:
dataset - Dataset
Returns:
boolean
Throws:
java.lang.Exception

afterUpdateData

public void afterUpdateData(Dataset dataset)
                     throws java.lang.Exception
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.update()之后触发的事件.

Parameters:
dataset - Dataset
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetSupport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class DatasetSupport

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
All Implemented Interfaces:
DataListener, Dataset, java.util.EventListener, java.io.Serializable
Direct Known Subclasses:
com.bstek.dorado.data.AbstractDataset
public abstract class DatasetSupport
extends java.lang.Object
implements Dataset, DataListener

数据集的抽象基类。

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DatasetSupport()
构造器
Method Summary
void | addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
DummyField | addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。
BaseField | addField(java.lang.String name) 向Dataset中添加一个普通Field。
LookupField | addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。 Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。
void | addRecordListener(RecordListener l) 增加一个RecordtListener的事件监听器
void | afterChange(ReadRecord record, java.lang.String fieldName) 在数据被修改之后被触发的事件.
void | beforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 当数据将要被修改之前被触发的事件.
void | clear() 清空Dataset中所有的数据。
protected Field | createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
void | createFields() 根据已设定的条件自动创建字段。
void | createFieldsFromObjectClazz() 自动利用反射将objectClazz中包含的属性映射成Dataset的字段.
void | deleteRecord() 删除当前记录。
void | deleteRecord(Record record) 删除指定的记录。
protected int | doFromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
protected Record | doFromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
protected abstract void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
protected void | doToDO(java.util.Collection collection, java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
protected abstract void | doUpdate() 把用户对Dataset中数据的操作更新到外部数据中.
FieldSet | fieldSet() 返回Dataset的Field集合对象
protected void | finalize()
Record | find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record | find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record[] | findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record[] | findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
protected RecordWrapper | findNext(RecordWrapper wrapper) findNext
protected RecordWrapper | findPrev(RecordWrapper wrapper) findPrev
protected void | fireAfterChange(ReadRecord record, java.lang.String fieldName) 触发AfterChange事件
protected void | fireAfterCreateFields() 触发AfterCreateFields事件
protected void | fireAfterDelete(ReadRecord record) 触发AfterDelete事件
protected void | fireAfterInsert(Record record) 触发AfterInsert事件
protected void | fireAfterLoadData() 触发AfterLoadData事件
protected void | fireAfterScroll() 触发AfterScroll事件
protected void | fireAfterUpdateData() 触发AfterUpdateData事件
protected void | fireBeforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 触发BeforeChange事件
protected boolean | fireBeforeCreateFields() 触发BeforeCreateFields事件
protected void | fireBeforeDelete(ReadRecord record) 触发BeforeDelete事件
protected void | fireBeforeInsert(Record record) 触发BeforeInsert事件
protected boolean | fireBeforeLoadData() 触发BeforeLoadData事件
protected void | fireBeforeScroll() 触发BeforeScroll事件
protected boolean | fireBeforeUpdateData() 触发BeforeUpdateData事件
protected void | fireOnInit() 触发OnInit事件
int | fromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中. 此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.
Record | fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中. 此处的data可以是单个的Bean或java.util.Map的派生类.
java.math.BigDecimal | getBigDecimal(int index) 按BigDecimal类型返回当前记录中某字段的值。
java.math.BigDecimal | getBigDecimal(java.lang.String name) 按BigDecimal类型返回当前记录中某字段的值。
boolean | getBoolean(int index) 按boolean类型返回当前记录中某字段的值。
boolean | getBoolean(java.lang.String name) 按boolean类型返回当前记录中某字段的值。
byte | getByte(int index) 按byte类型返回当前记录中某字段的值。
byte | getByte(java.lang.String name) 按byte类型返回当前记录中某字段的值。
Record | getCurrent() 返回当前记录对象。
java.util.Date | getDate(int index) 按Date类型返回当前记录中某字段的值。
java.util.Date | getDate(java.lang.String name) 按Date类型返回当前记录中某字段的值。
double | getDouble(int index) 按double类型返回当前记录中某字段的值。
double | getDouble(java.lang.String name) 按double类型返回当前记录中某字段的值。
Field | getField(int index) 根据Field索引号取得一个Field对象。
Field | getField(java.lang.String name) 根据Field名称取得一个Field对象。
int | getFieldCount() 取得Field的总数。
protected abstract com.bstek.dorado.data.FieldFactory | getFieldFactory() 返回Field的创建工厂.
float | getFloat(int index) 按float类型返回当前记录中某字段的值。
float | getFloat(java.lang.String name) 按float类型返回当前记录中某字段的值。
java.lang.String | getId() 获得Dataset的ID
Index | getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
int | getInt(int index) 按int类型返回当前记录中某字段的值。
int | getInt(java.lang.String name) 按int类型返回当前记录中某字段的值。
long | getLong(int index) 按long类型返回当前记录中某字段的值。
long | getLong(java.lang.String name) 按long类型返回当前记录中某字段的值。
int | getMaxPropertyLevel() 获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
java.lang.Class | getObjectClazz() 返回相关的对象类型的Class名.
ReadRecord | getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
int | getPageCount() 返回Dataset所对应的数据共有几页。
int | getPageIndex() 返回Dataset的当前页号
int | getPageSize() 取得每页的行数。即Dataset按照多少行数对数据进行分页。
int | getPossibleRecordCount() 获取Dataset可能存在的总记录数。。
protected abstract com.bstek.dorado.data.RecordFactory | getRecordFactory() 返回Record的创建工厂.
RecordFilter | getRecordFilter() 获得Dataset内部使用的记录过滤器.
int | getRecordState() 返回当前记录的状态
short | getShort(int index) 按short类型返回当前记录中某字段的值。
short | getShort(java.lang.String name) 按short类型返回当前记录中某字段的值。
int | getState() 返回当前记录集的当前状态
java.lang.String | getString(int index) 按String类型返回当前记录中某字段的值。
java.lang.String | getString(java.lang.String name) 按String类型返回当前记录中某字段的值。
java.lang.Object | getValue(int index) 返回当前记录中某字段的值。
java.lang.Object | getValue(java.lang.String name) 返回当前记录中某字段的值。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected void | initListener(XmlNode node) 根据XML节点初试化监听器
protected void | initNewRecord(Record record) initNewRecord
Record | insertRecord() 添加一条记录。
Record | insertRecord(int state) 添加一条记录并初始化新记录的状态。
protected int | internalLoad(boolean createFields, boolean loadData) internalLoad
boolean | isAutoCreateFields() 返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field. 注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.
boolean | isFirst() 当前位置是否已到达当前页的顶端。 此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.
boolean | isLast() 当前位置是否已到达当前页的尾端。 此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.
boolean | isNull(int index) 判断当前记录中某字段的值是否为空(null)。
boolean | isNull(java.lang.String name) 判断当前记录中某字段的值是否为空(null)。
protected boolean | isRecordVisible(Record record) 判断指定的记录对象是不是可见记录.
int | load() 根据已设定的条件读取外部数据。
int | load(boolean loadData) 根据已设定的条件读取外部数据。
void | moveFirst() 将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
void | moveLast() 将当前位置移动到Dataset的末端。
void | moveNext() 将当前位置移动到后一条记录。
void | movePrev() 将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
ParameterSet | parameters() 返回Dataset所有参数的集合对象
void | processLookup() 处理所有的Lookup数据。
MetaData | properties() 与Dataset相关的一组属性值. 这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.
RecordIterator | recordIterator() 返回Dataset中所有Record的迭代器。 注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。
RecordSet | recordSet() 返回Dataset的Record集合对象
void | removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | removeRecordListener(RecordListener l) 删除一个RecordtListener的事件监听器
void | resetRecordsState() 重置所有的记录状态
void | setAutoCreateFields(boolean autoCreateFields) 设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
void | setBigDecimal(int index, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBigDecimal(java.lang.String name, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBoolean(int index, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setBoolean(java.lang.String name, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setByte(int index, byte value) 按byte类型设置当前记录中某字段的值。
void | setByte(java.lang.String name, byte value) 按byte类型设置当前记录中某字段的值。
void | setCurrent(Record record) 设置当前记录对象。
void | setDate(int index, java.util.Date value) 按Date类型设置当前记录中某字段的值。
void | setDate(java.lang.String name, java.util.Date value) 按date类型设置当前记录中某字段的值。
void | setDouble(int index, double value) 按double类型设置当前记录中某字段的值。
void | setDouble(java.lang.String name, double value) 按double类型设置当前记录中某字段的值。
void | setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象
void | setFloat(int index, float value) 按float类型设置当前记录中某字段的值。
void | setFloat(java.lang.String name, float value) 按float类型设置当前记录中某字段的值。
void | setId(java.lang.String id) 设置Dataset的ID
void | setInt(int index, int value) 按int类型设置当前记录中某字段的值。
void | setInt(java.lang.String name, int value) 按int类型设置当前记录中某字段的值。
void | setLong(int index, long value) 按long类型设置当前记录中某字段的值。
void | setLong(java.lang.String name, long value) 按long类型设置当前记录中某字段的值。
void | setMaxPropertyLevel(int maxPropertyLevel) 设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
void | setNull(int index) 设置当前记录中某字段的值是否为空(null)。
void | setNull(java.lang.String name) 设置当前记录中某字段的值是否为空(null)。
void | setObjectClazz(java.lang.Class objectClazz) 设置相关的对象类型的Class名.
void | setObjectClazz(java.lang.String objectClazz) 设置相关的对象类型的Class名.
void | setPageCount(int pageCount) 设定Dataset所对应的数据共有几页。
void | setPageIndex(int pageIndex) 设定Dataset的当前页号
void | setPageSize(int pageSize) 设定Dataset分页时的每页记录数
void | setPossibleRecordCount(int possibleRecordCount) 设定Dataset可能存在的总记录数。
void | setRecordFilter(RecordFilter recordFilter) 设置Dataset内部使用的记录过滤器. 通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录
void | setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | setRecordState(int state) 设置当前记录的状态
void | setShort(int index, short value) 按short类型设置当前记录中某字段的值。
void | setShort(java.lang.String name, short value) 按short类型设置当前记录中某字段的值。
void | setState(int state) 更改当前记录集的当前状态
void | setString(int index, java.lang.String value) 按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
void | setString(java.lang.String name, java.lang.String value) 按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
void | setValue(int index, java.lang.Object value) 设置当前记录中某字段的值。
void | setValue(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值。
long | timestamp() 返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
java.util.List | toDO() 自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
void | toDO(java.util.Collection collection) 自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
void | toDO(java.util.Collection collection, java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
java.util.List | toDO(java.lang.String visibility) 自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合. 集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.
java.lang.Object | toSingleDO() 自动将Dataset中的当前记录转换为对象.
void | toSingleDO(java.lang.Object o) 自动将Dataset中的当前记录转换为对象.
java.lang.Object | toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
void | update() 把用户对Dataset中数据的操作更新到外部数据中.
boolean | validateCursor() validateCurrent
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DatasetSupport

public DatasetSupport()
构造器

Method Detail

getId

public java.lang.String getId()
获得Dataset的ID

Specified by:
getId in interface Dataset
Returns:
String

setId

public void setId(java.lang.String id)
设置Dataset的ID

Specified by:
setId in interface Dataset
Parameters:
id - String

finalize

protected void finalize()
                 throws java.lang.Throwable

Throws:
java.lang.Throwable

getFieldFactory

protected abstract com.bstek.dorado.data.FieldFactory getFieldFactory()
                                                               throws java.lang.Exception
返回Field的创建工厂.

Returns:
FieldFactory
Throws:
java.lang.Exception

getRecordFactory

protected abstract com.bstek.dorado.data.RecordFactory getRecordFactory()
                                                                 throws java.lang.Exception
返回Record的创建工厂.

Returns:
RecordFactory
Throws:
java.lang.Exception

createFieldsFromObjectClazz

public void createFieldsFromObjectClazz()
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.

此方法将自动为Dataset添加字段对象.

Specified by:
createFieldsFromObjectClazz in interface Dataset

doUpdate

protected abstract void doUpdate()
                          throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Throws:
java.lang.Exception

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

initListener

protected void initListener(XmlNode node)
                     throws java.lang.InstantiationException,
                            java.lang.IllegalAccessException,
                            java.lang.ClassNotFoundException
根据XML节点初试化监听器

Parameters:
node - XmlNode
Throws:
java.lang.InstantiationException
java.lang.IllegalAccessException
java.lang.ClassNotFoundException

createFieldByNode

protected Field createFieldByNode(DoradoContext context,
                                  XmlNode node)
                           throws LoadXmlPropertyException
根据一个描述字段的XML节点自动创建字段对象.

Parameters:
context - DoradoContext
node - XmlNode
Returns:
Field
Throws:
LoadXmlPropertyException

addField

public BaseField addField(java.lang.String name)
向Dataset中添加一个普通Field。

Specified by:
addField in interface Dataset
Parameters:
name - String
Returns:
BaseField

addLookupField

public LookupField addLookupField(java.lang.String name)
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

Specified by:
addLookupField in interface Dataset
Parameters:
name - String
Returns:
LookupField

addDummyField

public DummyField addDummyField(java.lang.String name)
向Dataset中添加一个虚拟Field。

Specified by:
addDummyField in interface Dataset
Parameters:
name - String
Returns:
DummyField

getField

public Field getField(int index)
根据Field索引号取得一个Field对象。

Specified by:
getField in interface Dataset
Parameters:
index - int 从0开始的Field索引号
Returns:
Field

getField

public Field getField(java.lang.String name)
根据Field名称取得一个Field对象。

Specified by:
getField in interface Dataset
Parameters:
name - String
Returns:
Field

getFieldCount

public int getFieldCount()
取得Field的总数。

Specified by:
getFieldCount in interface Dataset
Returns:
int

timestamp

public long timestamp()
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。

Specified by:
timestamp in interface Dataset
Returns:
long

getIndex

public Index getIndex(java.lang.String field)
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Specified by:
getIndex in interface Dataset
Parameters:
field - String
Returns:
Index

getIndex

public Index getIndex(java.lang.String[] fields)
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Specified by:
getIndex in interface Dataset
Parameters:
fields - String[]
Returns:
Index

find

public Record find(java.lang.String field,
                   java.lang.Object value)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Specified by:
find in interface Dataset
Parameters:
field - String
value - Object
Returns:
Record

find

public Record find(java.lang.String[] fields,
                   java.lang.Object[] values)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Specified by:
find in interface Dataset
Parameters:
fields - String[]
values - Object[]
Returns:
Record

findAll

public Record[] findAll(java.lang.String field,
                        java.lang.Object value)
根据指定的条件查找并返回所有匹配的记录。

Specified by:
findAll in interface Dataset
Parameters:
field - String
value - Object
Returns:
Record[]

findAll

public Record[] findAll(java.lang.String[] fields,
                        java.lang.Object[] values)
根据指定的条件查找并返回所有匹配的记录。

Specified by:
findAll in interface Dataset
Parameters:
fields - String[]
values - Object[]
Returns:
Record[]

getState

public int getState()
返回当前记录集的当前状态

Specified by:
getState in interface Dataset
Returns:
int

setState

public void setState(int state)
更改当前记录集的当前状态

Specified by:
setState in interface Dataset
Parameters:
state - int

isAutoCreateFields

public boolean isAutoCreateFields()
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.

Specified by:
isAutoCreateFields in interface Dataset
Returns:
boolean

setAutoCreateFields

public void setAutoCreateFields(boolean autoCreateFields)
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.

Specified by:
setAutoCreateFields in interface Dataset
Parameters:
autoCreateFields - boolean

getPageSize

public int getPageSize()
取得每页的行数。即Dataset按照多少行数对数据进行分页。

Specified by:
getPageSize in interface Dataset
Returns:
int

setPageSize

public void setPageSize(int pageSize)
设定Dataset分页时的每页记录数

Specified by:
setPageSize in interface Dataset
Parameters:
pageSize - int

getPageIndex

public int getPageIndex()
返回Dataset的当前页号

Specified by:
getPageIndex in interface Dataset
Returns:
int

setPageIndex

public void setPageIndex(int pageIndex)
设定Dataset的当前页号

Specified by:
setPageIndex in interface Dataset
Parameters:
pageIndex - int

getPageCount

public int getPageCount()
返回Dataset所对应的数据共有几页。

Specified by:
getPageCount in interface Dataset
Returns:
int

setPageCount

public void setPageCount(int pageCount)
设定Dataset所对应的数据共有几页。

Specified by:
setPageCount in interface Dataset
Parameters:
pageCount - int

getPossibleRecordCount

public int getPossibleRecordCount()
获取Dataset可能存在的总记录数。。

Specified by:
getPossibleRecordCount in interface Dataset
Returns:
int

setPossibleRecordCount

public void setPossibleRecordCount(int possibleRecordCount)
设定Dataset可能存在的总记录数。

Specified by:
setPossibleRecordCount in interface Dataset
Parameters:
possibleRecordCount - int

getObjectClazz

public java.lang.Class getObjectClazz()
返回相关的对象类型的Class名.

Specified by:
getObjectClazz in interface Dataset
Returns:
Class

setObjectClazz

public void setObjectClazz(java.lang.Class objectClazz)
设置相关的对象类型的Class名.

Specified by:
setObjectClazz in interface Dataset
Parameters:
objectClazz - Class

setObjectClazz

public void setObjectClazz(java.lang.String objectClazz)
设置相关的对象类型的Class名.

Specified by:
setObjectClazz in interface Dataset
Parameters:
objectClazz - String

getMaxPropertyLevel

public int getMaxPropertyLevel()
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.

Specified by:
getMaxPropertyLevel in interface Dataset
Returns:
int

setMaxPropertyLevel

public void setMaxPropertyLevel(int maxPropertyLevel)
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.

Specified by:
setMaxPropertyLevel in interface Dataset
Parameters:
maxPropertyLevel - int

parameters

public ParameterSet parameters()
返回Dataset所有参数的集合对象

Specified by:
parameters in interface Dataset
Returns:
Parameters

properties

public MetaData properties()
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

Specified by:
properties in interface Dataset
Returns:
MetaData

fieldSet

public FieldSet fieldSet()
返回Dataset的Field集合对象

Specified by:
fieldSet in interface Dataset
Returns:
FieldSet

setFieldSet

public void setFieldSet(FieldSet fieldset)
设置Dataset的Field集合对象

Specified by:
setFieldSet in interface Dataset
Parameters:
fieldset - FieldSet

recordSet

public RecordSet recordSet()
返回Dataset的Record集合对象

Specified by:
recordSet in interface Dataset
Returns:
RecordSet

setRecordSet

public void setRecordSet(RecordSet recordset)
设定Dataset的Record集合对象

Specified by:
setRecordSet in interface Dataset
Parameters:
recordset - RecordSet

recordIterator

public RecordIterator recordIterator()
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

Specified by:
recordIterator in interface Dataset
Returns:
RecordIterator

doLoad

protected abstract void doLoad(boolean createFields,
                               boolean loadData)
                        throws java.lang.Exception
根据已设定的条件读取外部数据.

Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据
Throws:
java.lang.Exception

createFields

public void createFields()
                  throws java.lang.Exception
根据已设定的条件自动创建字段。

Specified by:
createFields in interface Dataset
Throws:
java.lang.Exception

load

public int load()
         throws java.lang.Exception
根据已设定的条件读取外部数据。

Specified by:
load in interface Dataset
Returns:
int
Throws:
java.lang.Exception

load

public int load(boolean loadData)
         throws java.lang.Exception
根据已设定的条件读取外部数据。

Specified by:
load in interface Dataset
Parameters:
loadData - 是否加载数据
Returns:
int
Throws:
java.lang.Exception

internalLoad

protected int internalLoad(boolean createFields,
                           boolean loadData)
                    throws java.lang.Exception
internalLoad

Parameters:
createFields - boolean
loadData - boolean
Returns:
int
Throws:
java.lang.Exception

processLookup

public void processLookup()
处理所有的Lookup数据。

Specified by:
processLookup in interface Dataset

update

public void update()
            throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Specified by:
update in interface Dataset
Throws:
java.lang.Exception

resetRecordsState

public void resetRecordsState()
重置所有的记录状态

Specified by:
resetRecordsState in interface Dataset

clear

public void clear()
清空Dataset中所有的数据。

Specified by:
clear in interface Dataset

isRecordVisible

protected boolean isRecordVisible(Record record)
判断指定的记录对象是不是可见记录.

Parameters:
record - Record
Returns:
boolean

findPrev

protected RecordWrapper findPrev(RecordWrapper wrapper)
findPrev

Parameters:
wrapper - RecordWrapper
Returns:
RecordWrapper

findNext

protected RecordWrapper findNext(RecordWrapper wrapper)
findNext

Parameters:
wrapper - RecordWrapper
Returns:
RecordWrapper

setRecordFilter

public void setRecordFilter(RecordFilter recordFilter)
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

Specified by:
setRecordFilter in interface Dataset
Parameters:
recordFilter - RecordFilter

getRecordFilter

public RecordFilter getRecordFilter()
获得Dataset内部使用的记录过滤器.

Specified by:
getRecordFilter in interface Dataset
Returns:
RecordFilter

validateCursor

public boolean validateCursor()
validateCurrent

Returns:
boolean

getCurrent

public Record getCurrent()
返回当前记录对象。

Specified by:
getCurrent in interface Dataset
Returns:
Record

setCurrent

public void setCurrent(Record record)
设置当前记录对象。

Specified by:
setCurrent in interface Dataset
Parameters:
record - Record

isFirst

public boolean isFirst()
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

Specified by:
isFirst in interface Dataset
Returns:
boolean

isLast

public boolean isLast()
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

Specified by:
isLast in interface Dataset
Returns:
boolean

moveFirst

public void moveFirst()
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.

Specified by:
moveFirst in interface Dataset

movePrev

public void movePrev()
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.

Specified by:
movePrev in interface Dataset

moveNext

public void moveNext()
将当前位置移动到后一条记录。

Specified by:
moveNext in interface Dataset

moveLast

public void moveLast()
将当前位置移动到Dataset的末端。

Specified by:
moveLast in interface Dataset

insertRecord

public Record insertRecord()
添加一条记录。

Specified by:
insertRecord in interface Dataset
Returns:
Record

insertRecord

public Record insertRecord(int state)
添加一条记录并初始化新记录的状态。

Specified by:
insertRecord in interface Dataset
Parameters:
state - int
Returns:
Record

initNewRecord

protected void initNewRecord(Record record)
initNewRecord

Parameters:
record - Record

deleteRecord

public void deleteRecord()
删除当前记录。

Specified by:
deleteRecord in interface Dataset

deleteRecord

public void deleteRecord(Record record)
删除指定的记录。

Specified by:
deleteRecord in interface Dataset
Parameters:
record - Record

getRecordState

public int getRecordState()
返回当前记录的状态

Specified by:
getRecordState in interface Dataset
Returns:
int

setRecordState

public void setRecordState(int state)
设置当前记录的状态

Specified by:
setRecordState in interface Dataset
Parameters:
state - int

getOldRecord

public ReadRecord getOldRecord(Record record)
返回用于保存某记录的原始值的记录对象。

Specified by:
getOldRecord in interface Dataset
Parameters:
record - Record
Returns:
ReadRecord

getValue

public java.lang.Object getValue(int index)
返回当前记录中某字段的值。

Specified by:
getValue in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(int index)
按BigDecimal类型返回当前记录中某字段的值。

Specified by:
getBigDecimal in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
BigDecimal

getBoolean

public boolean getBoolean(int index)
按boolean类型返回当前记录中某字段的值。

Specified by:
getBoolean in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Boolean

getByte

public byte getByte(int index)
按byte类型返回当前记录中某字段的值。

Specified by:
getByte in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Byte

getDate

public java.util.Date getDate(int index)
按Date类型返回当前记录中某字段的值。

Specified by:
getDate in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Date

getDouble

public double getDouble(int index)
按double类型返回当前记录中某字段的值。

Specified by:
getDouble in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Double

getFloat

public float getFloat(int index)
按float类型返回当前记录中某字段的值。

Specified by:
getFloat in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Float

getInt

public int getInt(int index)
按int类型返回当前记录中某字段的值。

Specified by:
getInt in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Int

getLong

public long getLong(int index)
按long类型返回当前记录中某字段的值。

Specified by:
getLong in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Long

getShort

public short getShort(int index)
按short类型返回当前记录中某字段的值。

Specified by:
getShort in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
Short

getString

public java.lang.String getString(int index)
按String类型返回当前记录中某字段的值。

Specified by:
getString in interface Dataset
Parameters:
index - int 从0开始的字段索引号
Returns:
String

isNull

public boolean isNull(int index)
判断当前记录中某字段的值是否为空(null)。

Specified by:
isNull in interface Dataset
Parameters:
index - int
Returns:
boolean

setValue

public void setValue(int index,
                     java.lang.Object value)
设置当前记录中某字段的值。

Specified by:
setValue in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - Object

setBigDecimal

public void setBigDecimal(int index,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Specified by:
setBigDecimal in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - BigDecimal

setBoolean

public void setBoolean(int index,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Specified by:
setBoolean in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - boolean

setByte

public void setByte(int index,
                    byte value)
按byte类型设置当前记录中某字段的值。

Specified by:
setByte in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - byte

setDate

public void setDate(int index,
                    java.util.Date value)
按Date类型设置当前记录中某字段的值。

Specified by:
setDate in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - Date

setDouble

public void setDouble(int index,
                      double value)
按double类型设置当前记录中某字段的值。

Specified by:
setDouble in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - double

setFloat

public void setFloat(int index,
                     float value)
按float类型设置当前记录中某字段的值。

Specified by:
setFloat in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - float

setInt

public void setInt(int index,
                   int value)
按int类型设置当前记录中某字段的值。

Specified by:
setInt in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - int

setLong

public void setLong(int index,
                    long value)
按long类型设置当前记录中某字段的值。

Specified by:
setLong in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - long

setShort

public void setShort(int index,
                     short value)
按short类型设置当前记录中某字段的值。

Specified by:
setShort in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - short

setString

public void setString(int index,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Specified by:
setString in interface Dataset
Parameters:
index - int 从0开始的字段索引号
value - String

setNull

public void setNull(int index)
设置当前记录中某字段的值是否为空(null)。

Specified by:
setNull in interface Dataset
Parameters:
index - int

getValue

public java.lang.Object getValue(java.lang.String name)
返回当前记录中某字段的值。

Specified by:
getValue in interface Dataset
Parameters:
name - String
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(java.lang.String name)
按BigDecimal类型返回当前记录中某字段的值。

Specified by:
getBigDecimal in interface Dataset
Parameters:
name - String
Returns:
BigDecimal

getBoolean

public boolean getBoolean(java.lang.String name)
按boolean类型返回当前记录中某字段的值。

Specified by:
getBoolean in interface Dataset
Parameters:
name - String
Returns:
boolean

getByte

public byte getByte(java.lang.String name)
按byte类型返回当前记录中某字段的值。

Specified by:
getByte in interface Dataset
Parameters:
name - String
Returns:
byte

getDate

public java.util.Date getDate(java.lang.String name)
按Date类型返回当前记录中某字段的值。

Specified by:
getDate in interface Dataset
Parameters:
name - String
Returns:
Date

getDouble

public double getDouble(java.lang.String name)
按double类型返回当前记录中某字段的值。

Specified by:
getDouble in interface Dataset
Parameters:
name - String
Returns:
double

getFloat

public float getFloat(java.lang.String name)
按float类型返回当前记录中某字段的值。

Specified by:
getFloat in interface Dataset
Parameters:
name - String
Returns:
float

getInt

public int getInt(java.lang.String name)
按int类型返回当前记录中某字段的值。

Specified by:
getInt in interface Dataset
Parameters:
name - String
Returns:
int

getLong

public long getLong(java.lang.String name)
按long类型返回当前记录中某字段的值。

Specified by:
getLong in interface Dataset
Parameters:
name - String
Returns:
long

getShort

public short getShort(java.lang.String name)
按short类型返回当前记录中某字段的值。

Specified by:
getShort in interface Dataset
Parameters:
name - String
Returns:
short

getString

public java.lang.String getString(java.lang.String name)
按String类型返回当前记录中某字段的值。

Specified by:
getString in interface Dataset
Parameters:
name - String
Returns:
String

isNull

public boolean isNull(java.lang.String name)
判断当前记录中某字段的值是否为空(null)。

Specified by:
isNull in interface Dataset
Parameters:
name - String
Returns:
boolean

setValue

public void setValue(java.lang.String name,
                     java.lang.Object value)
设置当前记录中某字段的值。

Specified by:
setValue in interface Dataset
Parameters:
name - String
value - Object

setBigDecimal

public void setBigDecimal(java.lang.String name,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Specified by:
setBigDecimal in interface Dataset
Parameters:
name - String
value - BigDecimal

setBoolean

public void setBoolean(java.lang.String name,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Specified by:
setBoolean in interface Dataset
Parameters:
name - String
value - boolean

setByte

public void setByte(java.lang.String name,
                    byte value)
按byte类型设置当前记录中某字段的值。

Specified by:
setByte in interface Dataset
Parameters:
name - String
value - byte

setDate

public void setDate(java.lang.String name,
                    java.util.Date value)
按date类型设置当前记录中某字段的值。

Specified by:
setDate in interface Dataset
Parameters:
name - String
value - Date

setDouble

public void setDouble(java.lang.String name,
                      double value)
按double类型设置当前记录中某字段的值。

Specified by:
setDouble in interface Dataset
Parameters:
name - String
value - double

setFloat

public void setFloat(java.lang.String name,
                     float value)
按float类型设置当前记录中某字段的值。

Specified by:
setFloat in interface Dataset
Parameters:
name - String
value - float

setInt

public void setInt(java.lang.String name,
                   int value)
按int类型设置当前记录中某字段的值。

Specified by:
setInt in interface Dataset
Parameters:
name - String
value - int

setLong

public void setLong(java.lang.String name,
                    long value)
按long类型设置当前记录中某字段的值。

Specified by:
setLong in interface Dataset
Parameters:
name - String
value - long

setShort

public void setShort(java.lang.String name,
                     short value)
按short类型设置当前记录中某字段的值。

Specified by:
setShort in interface Dataset
Parameters:
name - String
value - short

setString

public void setString(java.lang.String name,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Specified by:
setString in interface Dataset
Parameters:
name - String
value - String

setNull

public void setNull(java.lang.String name)
设置当前记录中某字段的值是否为空(null)。

Specified by:
setNull in interface Dataset
Parameters:
name - String

beforeChange

public void beforeChange(ReadRecord record,
                         java.lang.String fieldName,
                         Variant value)
当数据将要被修改之前被触发的事件.

Specified by:
beforeChange in interface DataListener
Parameters:
record - 将被修改的记录
fieldName - 将被修改的字段名
value - Variant 将被设置到记录中的数值

afterChange

public void afterChange(ReadRecord record,
                        java.lang.String fieldName)
在数据被修改之后被触发的事件.

Specified by:
afterChange in interface DataListener
Parameters:
record - 被修改的记录
fieldName - 被修改的字段名

removeRecordListener

public void removeRecordListener(RecordListener l)
删除一个RecordtListener的事件监听器

Specified by:
removeRecordListener in interface Dataset
Parameters:
l - RecordtListener

addRecordListener

public void addRecordListener(RecordListener l)
增加一个RecordtListener的事件监听器

Specified by:
addRecordListener in interface Dataset
Parameters:
l - RecordtListener

fireBeforeScroll

protected void fireBeforeScroll()
触发BeforeScroll事件

fireAfterScroll

protected void fireAfterScroll()
触发AfterScroll事件

fireBeforeInsert

protected void fireBeforeInsert(Record record)
触发BeforeInsert事件

Parameters:
record - Record

fireAfterInsert

protected void fireAfterInsert(Record record)
触发AfterInsert事件

Parameters:
record - Record

fireBeforeChange

protected void fireBeforeChange(ReadRecord record,
                                java.lang.String fieldName,
                                Variant value)
触发BeforeChange事件

Parameters:
record - ReadRecord
fieldName - String
value - Variant

fireAfterChange

protected void fireAfterChange(ReadRecord record,
                               java.lang.String fieldName)
触发AfterChange事件

Parameters:
record - ReadRecord
fieldName - String

fireBeforeDelete

protected void fireBeforeDelete(ReadRecord record)
触发BeforeDelete事件

Parameters:
record - ReadRecord

fireAfterDelete

protected void fireAfterDelete(ReadRecord record)
触发AfterDelete事件

Parameters:
record - ReadRecord

removeDatasetListener

public void removeDatasetListener(DatasetListener l)
删除一个DatasetEvent的事件监听器

Specified by:
removeDatasetListener in interface Dataset
Parameters:
l - DatasetListener

addDatasetListener

public void addDatasetListener(DatasetListener l)
增加一个DatasetEvent的事件监听器

Specified by:
addDatasetListener in interface Dataset
Parameters:
l - DatasetListener

fireOnInit

protected void fireOnInit()
                   throws java.lang.Exception
触发OnInit事件

Throws:
java.lang.Exception

fireBeforeCreateFields

protected boolean fireBeforeCreateFields()
                                  throws java.lang.Exception
触发BeforeCreateFields事件

Returns:
boolean
Throws:
java.lang.Exception

fireAfterCreateFields

protected void fireAfterCreateFields()
                              throws java.lang.Exception
触发AfterCreateFields事件

Throws:
java.lang.Exception

fireBeforeLoadData

protected boolean fireBeforeLoadData()
                              throws java.lang.Exception
触发BeforeLoadData事件

Returns:
boolean
Throws:
java.lang.Exception

fireAfterLoadData

protected void fireAfterLoadData()
                          throws java.lang.Exception
触发AfterLoadData事件

Throws:
java.lang.Exception

fireBeforeUpdateData

protected boolean fireBeforeUpdateData()
                                throws java.lang.Exception
触发BeforeUpdateData事件

Returns:
boolean
Throws:
java.lang.Exception

fireAfterUpdateData

protected void fireAfterUpdateData()
                            throws java.lang.Exception
触发AfterUpdateData事件

Throws:
java.lang.Exception

fromDO

public int fromDO(java.lang.Object data)
           throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

Specified by:
fromDO in interface Dataset
Parameters:
data - Object
Returns:
int
Throws:
java.lang.Exception

doFromDO

protected int doFromDO(java.lang.Object data)
                throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

Parameters:
data - Object
Returns:
int
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

Specified by:
fromSingleDO in interface Dataset
Parameters:
o - Object
Returns:
Record
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o,
                           boolean newRecord)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

Specified by:
fromSingleDO in interface Dataset
Parameters:
o - Object
newRecord - boolean
Returns:
Record
Throws:
java.lang.Exception

doFromSingleDO

protected Record doFromSingleDO(java.lang.Object o,
                                boolean newRecord)
                         throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

Parameters:
o - Object
newRecord - boolean
Returns:
Record
Throws:
java.lang.Exception

toDO

public java.util.List toDO()
                    throws java.lang.Exception
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Returns:
List
Throws:
java.lang.Exception

toDO

public java.util.List toDO(java.lang.String visibility)
                    throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Parameters:
visibility - int
Returns:
Object
Throws:
java.lang.Exception

toDO

public void toDO(java.util.Collection collection)
          throws java.lang.Exception
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Parameters:
collection - Collection
Throws:
java.lang.Exception

toDO

public void toDO(java.util.Collection collection,
                 java.lang.String visibility)
          throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

Specified by:
toDO in interface Dataset
Parameters:
collection - Collection
visibility - int
Throws:
java.lang.Exception

doToDO

protected void doToDO(java.util.Collection collection,
                      java.lang.String visibility)
               throws java.lang.Exception
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

Parameters:
collection - Collection
visibility - String
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO()
                            throws java.lang.Exception
自动将Dataset中的当前记录转换为对象.

Specified by:
toSingleDO in interface Dataset
Returns:
Object
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO(Record record)
                            throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Specified by:
toSingleDO in interface Dataset
Parameters:
record - Record
Returns:
Object
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中的当前记录转换为对象.

Specified by:
toSingleDO in interface Dataset
Parameters:
o - Object
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(Record record,
                       java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Specified by:
toSingleDO in interface Dataset
Parameters:
record - Record
o - Object
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DORecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class DORecord

java.lang.Object
    extended by com.bstek.dorado.data.ReadRecord
        extended by com.bstek.dorado.data.Record
            extended by com.bstek.dorado.data.BaseRecord
                extended by com.bstek.dorado.data.DORecord
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
Direct Known Subclasses:
ViewRecord
public class DORecord
extends BaseRecord

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from class com.bstek.dorado.data.Record
STATE_DELETED, STATE_MODIFIED, STATE_NEW, STATE_NONE
Fields inherited from class com.bstek.dorado.data.ReadRecord
state
Constructor Summary
DORecord()
DORecord(java.lang.Object DO)
Method Summary
protected java.lang.Object | doGet(java.lang.String name) 返回记录中某字段的值。此方法须在派生类中实现。
protected void | doSet(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值.此方法须在派生类中实现.
java.lang.Object | toDO() 转换为DataObject对象.
Methods inherited from class com.bstek.dorado.data.BaseRecord
clone
Methods inherited from class com.bstek.dorado.data.Record
fireAfterChange, fireBeforeChange, fromDO, getDataset, getFieldSet, getPropertyValue, getRecordId, isDeleted, set, setBigDecimal, setBoolean, setByte, setDate, setDetailRecords, setDouble, setFloat, setInt, setLong, setNull, setPropertyValue, setRecordId, setShort, setString, setValue, timestamp, toDO, validate
Methods inherited from class com.bstek.dorado.data.ReadRecord
get, getBigDecimal, getBoolean, getByte, getDate, getDetailRecords, getDouble, getFloat, getInt, getLong, getShort, getState, getString, getValue, getVariant, isNull
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DORecord

public DORecord()

DORecord

public DORecord(java.lang.Object DO)
Method Detail

doGet

protected java.lang.Object doGet(java.lang.String name)
返回记录中某字段的值。此方法须在派生类中实现。

Overrides:
doGet in class BaseRecord

doSet

protected void doSet(java.lang.String name,
                     java.lang.Object value)
设置当前记录中某字段的值.此方法须在派生类中实现.

Overrides:
doSet in class BaseRecord

toDO

public java.lang.Object toDO()
                      throws java.lang.Exception
转换为DataObject对象.

Overrides:
toDO in class Record
Returns:
Object
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOSet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class DOSet

java.lang.Object
    extended by com.bstek.dorado.data.DOSet
public class DOSet
extends java.lang.Object

DO(Data Object)的集合. DOSet通常被用作与Dataset进行双向的数据转换.由于DOSet中存贮的都是POJO, 因此DOSet非常适合用于dorado与各种第三方的框架或逻辑代码的整合.

注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)

Version:
4.0

Field Summary
static int | STATE_DELETED 已删除
static int | STATE_MODIFIED 已更新
static int | STATE_NEW 新增
static int | STATE_NONE 无状态
Constructor Summary
DOSet()
构造器
Method Summary
void | addDO(java.lang.Object o) 向DOSet中添加一个DO.
void | addDO(java.lang.Object o, int state) 按照指定状态的向DOSet中添加一个DO.
java.util.List | getDO() 以java.util.List的方式返回所有DO.
java.util.List | getDO(int state) 以java.util.List的方式返回符合给定状态的DO.
java.lang.Object | getOldDO(java.lang.Object o) 根据给定的DO取得与其相关的保存其修改之前的数据的DO.
void | setOldDO(java.lang.Object o, java.lang.Object oldDO) 为DOSet中某个DO指定一个保存其修改之前的数据的DO.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STATE_NONE

public static final int STATE_NONE
无状态

See Also:
Constant Field Values

STATE_NEW

public static final int STATE_NEW
新增

See Also:
Constant Field Values

STATE_DELETED

public static final int STATE_DELETED
已删除

See Also:
Constant Field Values

STATE_MODIFIED

public static final int STATE_MODIFIED
已更新

See Also:
Constant Field Values
Constructor Detail

DOSet

public DOSet()
构造器

Method Detail

addDO

public void addDO(java.lang.Object o)
向DOSet中添加一个DO.

Parameters:
o - Object

addDO

public void addDO(java.lang.Object o,
                  int state)
按照指定状态的向DOSet中添加一个DO.

state有如下几种可能的取值:

  • STATE_NONE - 无状态(默认)
  • STATE_NEW - 已删除
  • STATE_DELETED - 已更新
  • STATE_MODIFIED - 已更新

Parameters:
o - Object
state - int

getDO

public java.util.List getDO()
以java.util.List的方式返回所有DO.

Returns:
List

getDO

public java.util.List getDO(int state)
以java.util.List的方式返回符合给定状态的DO.

Parameters:
state - int
Returns:
List

setOldDO

public void setOldDO(java.lang.Object o,
                     java.lang.Object oldDO)
为DOSet中某个DO指定一个保存其修改之前的数据的DO.

由于dorado的Dataset具有OldRecord的概念.对于那些数据已经被修改掉的记录Dataset会为其保留一份原有数据的副本, 这样开发人员就可以在必要的时候获取到某一条记录的原有数据.
在DOSet中oldDO也就相当于Dataset中的OldRecord.

Parameters:
o - Object
oldDO - Object

getOldDO

public java.lang.Object getOldDO(java.lang.Object o)
根据给定的DO取得与其相关的保存其修改之前的数据的DO.

Parameters:
o - Object
Returns:
Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class DOUtils

java.lang.Object
    extended by com.bstek.dorado.data.DOUtils
public final class DOUtils
extends java.lang.Object

用于在Dataset和DO(Data Object)之间转换数据的工具类

Version:
4.0

Method Summary
static Record | DOToRecord(java.lang.Object o, Dataset dataset) 利用反射从o参数指定的对象中读取数据, 并追加到Dataset中.
static Record | DOToRecord(java.lang.Object o, Record record) 利用反射从o参数指定的对象中读取数据并设置到给定的record中.
static VariantSet | DOToVariantSet(java.lang.Object o, VariantSet variantSet) 利用反射从o参数指定的对象中读取数据并设置到给定的变量集合中.
static boolean | isMapType(java.lang.Class cl) 判断某Class是否是java.util.Map的派生类.
static java.lang.Object | recordToDO(Record record, java.lang.Object o) 将给定的记录中包含的数据设置到给定的对象当中.
static void | variantSetToDO(VariantSet variantSet, java.lang.Object o) 将给定的变量集合中包含的数据设置到给定的对象当中.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

isMapType

public static boolean isMapType(java.lang.Class cl)
判断某Class是否是java.util.Map的派生类.

Parameters:
cl - Class
Returns:
boolean

DOToRecord

public static Record DOToRecord(java.lang.Object o,
                                Record record)
                         throws java.lang.Exception
利用反射从o参数指定的对象中读取数据并设置到给定的record中.

此处的o可以是单个的Bean或java.util.Map的派生类.此方法会自行根据o的类型决定处理方式.

Parameters:
o - Object
record - Record
Returns:
Record
Throws:
java.lang.Exception

DOToRecord

public static Record DOToRecord(java.lang.Object o,
                                Dataset dataset)
                         throws java.lang.Exception
利用反射从o参数指定的对象中读取数据, 并追加到Dataset中.

此处的o可以是单个的Bean或java.util.Map的派生类.此方法会自行根据o的类型决定处理方式.

Parameters:
o - Object
dataset - Dataset
Returns:
Record
Throws:
java.lang.Exception

recordToDO

public static java.lang.Object recordToDO(Record record,
                                          java.lang.Object o)
                                   throws java.lang.Exception
将给定的记录中包含的数据设置到给定的对象当中.

Parameters:
record - Record
o - Object
Returns:
Object
Throws:
java.lang.Exception

variantSetToDO

public static void variantSetToDO(VariantSet variantSet,
                                  java.lang.Object o)
                           throws java.lang.Exception
将给定的变量集合中包含的数据设置到给定的对象当中.

Parameters:
variantSet - VariantSet
o - Object
Throws:
java.lang.Exception

DOToVariantSet

public static VariantSet DOToVariantSet(java.lang.Object o,
                                        VariantSet variantSet)
                                 throws java.lang.Exception
利用反射从o参数指定的对象中读取数据并设置到给定的变量集合中.

此处的o可以是单个的Bean或java.util.Map的派生类.此方法会自行根据o的类型决定处理方式.

Parameters:
o - Object
variantSet - VariantSet
Returns:
VariantSet
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DummyField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class DummyField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.DummyField
All Implemented Interfaces:
Field
public class DummyField
extends com.bstek.dorado.data.AbstractField

虚拟字段

Version:
4.0

Constructor Summary
DummyField(java.lang.String name)
构造器
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DummyField

public DummyField(java.lang.String name)
构造器

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Field

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Interface Field

All Known Subinterfaces:
ViewField
All Known Implementing Classes:
com.bstek.dorado.data.AbstractField, ViewBaseField, ViewLookupField
public interface Field

字段

Version:
4.0

Method Summary
int | getDataType() 取得字段的数据类型。
java.lang.Object | getDefaultValue() 取得字段缺省值。
java.lang.String | getLabel() 取得字段列的标题。
java.lang.String | getName() 取得字段的名称。
java.lang.String[] | getParsedProperty() 以数组方式表现的嵌套对象属性.
java.lang.String | getProperty() 返回该字段对应的属性名.
boolean | isNullable() 返回字段是否为空。
MetaData | properties() 返回所有元数据的集合对象。
void | setDataType(int dataType) 设定字段的数据类型。
void | setDataType(java.lang.String dataType) 设定字段的数据类型。
void | setDefaultValue(java.lang.Object defaultValue) 设定字段缺省值。
void | setLabel(java.lang.String label) 设定字段列的标题。
void | setName(java.lang.String name) 设定字段名称。
void | setNullable(boolean nullable) 设定字段是否可以为空。
void | setProperty(java.lang.String property) 设置该字段对应的属性名.

Method Detail

getName

public java.lang.String getName()
取得字段的名称。

Returns:
String

setName

public void setName(java.lang.String name)
设定字段名称。

Parameters:
name - String

getLabel

public java.lang.String getLabel()
取得字段列的标题。

Returns:
String

setLabel

public void setLabel(java.lang.String label)
设定字段列的标题。

Parameters:
label - String

getDataType

public int getDataType()
取得字段的数据类型。

Returns:
int

setDataType

public void setDataType(int dataType)
设定字段的数据类型。

Parameters:
dataType - int

setDataType

public void setDataType(java.lang.String dataType)
设定字段的数据类型。

Parameters:
dataType - int
See Also:
DataType

isNullable

public boolean isNullable()
返回字段是否为空。

Returns:
boolean

setNullable

public void setNullable(boolean nullable)
设定字段是否可以为空。

Parameters:
nullable - boolean

getDefaultValue

public java.lang.Object getDefaultValue()
取得字段缺省值。

Returns:
Object

setDefaultValue

public void setDefaultValue(java.lang.Object defaultValue)
设定字段缺省值。

Parameters:
defaultValue - Object

getProperty

public java.lang.String getProperty()
返回该字段对应的属性名.

即Bean的属性名或Map的键名.

此处可用"user.address.zipCode"这种方式来表示子对象的属性.

Returns:
String

setProperty

public void setProperty(java.lang.String property)
设置该字段对应的属性名.

Parameters:
property - String

getParsedProperty

public java.lang.String[] getParsedProperty()
以数组方式表现的嵌套对象属性.

例如: 设置属性名为"user.address.zipCode", 那么此方法将返回如下的数组:

{"user", "address", "zipCode"}

Returns:
String[]

properties

public MetaData properties()
返回所有元数据的集合对象。

Returns:
MetaData
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldNotExistException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class FieldNotExistException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.data.FieldNotExistException
All Implemented Interfaces:
java.io.Serializable
public class FieldNotExistException
extends DoradoRuntimeException

无法找到指定的Field对象的异常。当用户使用访问一个并不存在的Field时抛出。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
FieldNotExistException(java.lang.String name)
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FieldNotExistException

public FieldNotExistException(java.lang.String name)
构造器

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldSet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class FieldSet

java.lang.Object
    extended by com.bstek.dorado.data.FieldSet
All Implemented Interfaces:
java.io.Serializable
public class FieldSet
extends java.lang.Object
implements java.io.Serializable

字段集合对象

Version:
4.0
See Also:
Serialized Form

Constructor Summary
FieldSet()
构造器
Method Summary
void | addField(Field field) 添加一个Field。
int | getCount() 取得Field的总数
Field | getField(int index) 根据Field索引号取得一个Field对象
Field | getField(java.lang.String name) 根据Field名称取得一个Field对象
java.lang.String | indexToName(int index) 根据Field的索引号得到Field的名称
int | nameToIndex(java.lang.String name) 根据Field的名称得到Field的索引号
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldSet

public FieldSet()
构造器

Method Detail

addField

public void addField(Field field)
添加一个Field。

Parameters:
field - Field

getField

public Field getField(int index)
根据Field索引号取得一个Field对象

Parameters:
index - 从0开始的Field索引号
Returns:
Field

getField

public Field getField(java.lang.String name)
根据Field名称取得一个Field对象

Parameters:
name - String
Returns:
Field

getCount

public int getCount()
取得Field的总数

Returns:
int

nameToIndex

public int nameToIndex(java.lang.String name)
根据Field的名称得到Field的索引号

Parameters:
name - String
Returns:
int

indexToName

public java.lang.String indexToName(int index)
根据Field的索引号得到Field的名称

Parameters:
index - int
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Index

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class Index

java.lang.Object
    extended by com.bstek.dorado.data.Index
public class Index
extends java.lang.Object

记录集的索引对象

Version:
4.0

Constructor Summary
Index(Dataset dataset, java.lang.String[] fields)
构造器 根据给定的Dataset和字段创建索引
Method Summary
static Index | build(Dataset dataset, java.lang.String field) 根据给定的Dataset和字段创建并返回索引对象。
static Index | build(Dataset dataset, java.lang.String[] fields) 根据给定的Dataset和字段创建并返回索引对象。
Record | find(java.lang.Object value) 利用索引根据给定的一个字段值查找一组记录。
Record | find(java.lang.Object[] values) 利用索引根据给定的一字段值查找一组记录。
Record[] | findAll(java.lang.Object value) 利用索引根据给定的一个字段值查找记录。
Record[] | findAll(java.lang.Object[] values) 利用索引根据给定的一组字段值查找记录。
Dataset | getDataset() 返回本索引所属的Dataset对象
java.lang.String[] | getFields() 返回本索引对应的字段
void | rebuild() 重建本索引
long | timestamp() 返回Index时间戳，该时间戳实质是一个整数代表此索引的最后的更新时间。
void | update() 检查并更新当前的Index，使其能够正确的反应Dataset中当前的数据。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Index

public Index(Dataset dataset,
             java.lang.String[] fields)
构造器

根据给定的Dataset和字段创建索引

Parameters:
dataset - Dataset
fields - String[]
Method Detail

build

public static Index build(Dataset dataset,
                          java.lang.String field)
根据给定的Dataset和字段创建并返回索引对象。

Parameters:
dataset - Dataset
field - String
Returns:
Index

build

public static Index build(Dataset dataset,
                          java.lang.String[] fields)
根据给定的Dataset和字段创建并返回索引对象。

Parameters:
dataset - Dataset
fields - String[]
Returns:
Index

getDataset

public Dataset getDataset()
返回本索引所属的Dataset对象

Returns:
Dataset

rebuild

public void rebuild()
重建本索引

update

public void update()
检查并更新当前的Index，使其能够正确的反应Dataset中当前的数据。

findAll

public Record[] findAll(java.lang.Object value)
利用索引根据给定的一个字段值查找记录。如果找到了匹配记录将返回该记录，否则返回null。

Parameters:
value - Object
Returns:
Record[]

findAll

public Record[] findAll(java.lang.Object[] values)
利用索引根据给定的一组字段值查找记录。如果找到了匹配记录将返回该记录，否则返回null。

Parameters:
values - Object[]
Returns:
Record[]

find

public Record find(java.lang.Object value)
利用索引根据给定的一个字段值查找一组记录。

Parameters:
value - Object
Returns:
Record

find

public Record find(java.lang.Object[] values)
利用索引根据给定的一字段值查找一组记录。

Parameters:
values - Object[]
Returns:
Record

getFields

public java.lang.String[] getFields()
返回本索引对应的字段

Returns:
String[]

timestamp

public long timestamp()
返回Index时间戳，该时间戳实质是一个整数代表此索引的最后的更新时间。

Returns:
long
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LookupField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class LookupField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.LookupField
All Implemented Interfaces:
Field
Direct Known Subclasses:
ViewLookupField
public class LookupField
extends com.bstek.dorado.data.AbstractField

支持Lookup功能的Field。

Version:
4.0

Constructor Summary
LookupField(java.lang.String name)
构造器
Method Summary
java.lang.String | getKeyFields() Dataset与LookupDataset之间的字段匹配关系。
Dataset | getLookupDataset() 作为Lookup数据来源的Dataset对象。
java.lang.String | getLookupField() LookupDataset中将被作为数据返回的字段的名称。
java.lang.String | getLookupKeyFields() Dataset与LookupDataset之间的字段匹配关系。
void | setKeyFields(java.lang.String keyFields) Dataset与LookupDataset之间的字段匹配关系。
void | setLookupDataset(Dataset lookupDataset) 设置作为Lookup数据来源的Dataset对象。
void | setLookupField(java.lang.String lookupField) 设置LookupDataset中将被作为数据返回的字段的名称。
void | setLookupKeyFields(java.lang.String lookupKeyFields) 设定Dataset与LookupDataset之间的字段匹配关系。
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LookupField

public LookupField(java.lang.String name)
构造器

Method Detail

getLookupDataset

public Dataset getLookupDataset()
作为Lookup数据来源的Dataset对象。

Returns:
Dataset

setLookupDataset

public void setLookupDataset(Dataset lookupDataset)
设置作为Lookup数据来源的Dataset对象。

Parameters:
lookupDataset - Dataset

getLookupField

public java.lang.String getLookupField()
LookupDataset中将被作为数据返回的字段的名称。

Returns:
String

setLookupField

public void setLookupField(java.lang.String lookupField)
设置LookupDataset中将被作为数据返回的字段的名称。

Parameters:
lookupField - String

getLookupKeyFields

public java.lang.String getLookupKeyFields()
Dataset与LookupDataset之间的字段匹配关系。

此匹配关系用于描述Dataset通过哪些字段到LookupDataset查找匹配的记录。

Returns:
String

setLookupKeyFields

public void setLookupKeyFields(java.lang.String lookupKeyFields)
设定Dataset与LookupDataset之间的字段匹配关系。

此匹配关系用于描述Dataset通过哪些字段到LookupDataset查找匹配的记录。

Parameters:
lookupKeyFields - String

getKeyFields

public java.lang.String getKeyFields()
Dataset与LookupDataset之间的字段匹配关系。

此匹配关系用于描述Dataset通过哪些字段到LookupDataset查找匹配的记录。

Returns:
String

setKeyFields

public void setKeyFields(java.lang.String keyFields)
Dataset与LookupDataset之间的字段匹配关系。

此匹配关系用于描述Dataset通过哪些字段到LookupDataset查找匹配的记录。

Parameters:
keyFields - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoCurrentRecordException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class NoCurrentRecordException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.data.NoCurrentRecordException
All Implemented Interfaces:
java.io.Serializable
public class NoCurrentRecordException
extends DoradoRuntimeException

无当前记录异常。当所执行的操作无法在记录集中取得当前记录时抛出。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
NoCurrentRecordException()
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NoCurrentRecordException

public NoCurrentRecordException()
构造器

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.data

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.data

数据集的相关类
See:
Description

Interface Summary
DataListener | 针对Dataset中的数据的事件监听器
Dataset | Dorado记录集的接口。
DatasetListener | Dataset事件监听器的接口
Field | 字段
RecordFilter | 记录过滤器
RecordListener | Dataset中记录操作的监听器

Class Summary
BaseField | 最基本的Field对象。
BaseRecord | 最基本的Record对象
DatasetAdapter | Dataset适配器
DatasetSupport | 数据集的抽象基类。
DORecord |
DOSet | DO(Data Object)的集合.
DOUtils | 用于在Dataset和DO(Data Object)之间转换数据的工具类
DummyField | 虚拟字段
FieldSet | 字段集合对象
Index | 记录集的索引对象
LookupField | 支持Lookup功能的Field。
PagingHelper | 用户辅助数据分页计算的帮助类。
ParameterSet | 参数的集合类
ReadRecord | 只读的Record
Record | 记录对象
RecordIterator | 记录迭代器
RecordSet | Record集合对象
RecordWrapper | RecordSet使用的记录包装器

Exception Summary
FieldNotExistException | 无法找到指定的Field对象的异常。
NoCurrentRecordException | 无当前记录异常。

Package com.bstek.dorado.data Description

数据集的相关类


PagingHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class PagingHelper

java.lang.Object
    extended by com.bstek.dorado.data.PagingHelper
public class PagingHelper
extends java.lang.Object

用户辅助数据分页计算的帮助类。

实例:
List employees = query.list(); // 完整的结果集
PagingHelper paging = new PagingHelper(dataset.getPageSize(), dataset.getPageIndex(), employees.size());
List employees = employees.subList(paging.getFromIndex(), paging.getToIndex()); // 当页的记录

Version:
4.0

Constructor Summary
PagingHelper()
构造器
PagingHelper(int pageSize, int pageIndex)
构造器
PagingHelper(int pageSize, int pageIndex, int totalRow)
构造器
Method Summary
int | getFromIndex() 返回当前页记录的起始序号。
int | getPageCount() 返回总页数。
int | getPageIndex() 返回页号。
int | getPageSize() 返回每页的记录数。
int | getToIndex() 返回当前页记录的结束序号。
int | getTotalRow() 返回结果集的总记录数。
void | setPageIndex(int pageIndex) 设置页号。
void | setPageSize(int pageSize) 设置每页的记录数。
void | setTotalRow(int totalRow) 设置结果集的总记录数。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PagingHelper

public PagingHelper()
构造器

PagingHelper

public PagingHelper(int pageSize,
                    int pageIndex)
构造器

Parameters:
pageSize - int
pageIndex - int

PagingHelper

public PagingHelper(int pageSize,
                    int pageIndex,
                    int totalRow)
构造器

Parameters:
pageSize - int
pageIndex - int
totalRow - int
Method Detail

setPageIndex

public void setPageIndex(int pageIndex)
设置页号。

注意：此处的页号是从1开始计算的。

Parameters:
pageIndex - int

setPageSize

public void setPageSize(int pageSize)
设置每页的记录数。

Parameters:
pageSize - int

setTotalRow

public void setTotalRow(int totalRow)
设置结果集的总记录数。

注意：如果设置总记录数为-1则表示忽略与总记录数相关的计算，这样您将无法得到准确的总页数。

Parameters:
totalRow - int

getPageIndex

public int getPageIndex()
返回页号。

注意：此处的页号是从1开始计算的。

Returns:
int

getPageSize

public int getPageSize()
返回每页的记录数。

getTotalRow

public int getTotalRow()
返回结果集的总记录数。

Returns:
int

getFromIndex

public int getFromIndex()
返回当前页记录的起始序号。

Returns:
int

getToIndex

public int getToIndex()
返回当前页记录的结束序号。

注意：此处的结束序号的返回值等于当前页最后一条记录的序号加1。 结束序号代表的记录并不属于当前页。

Returns:
int

getPageCount

public int getPageCount()
返回总页数。

Returns:
int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterSet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class ParameterSet

java.lang.Object
    extended by com.bstek.dorado.utils.variant.VariantSet
        extended by com.bstek.dorado.data.ParameterSet
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
public class ParameterSet
extends VariantSet

参数的集合类

Version:
4.0
See Also:
Serialized Form

Field Summary
static ParameterSet NULL_INSTANCE
空对象
Constructor Summary
ParameterSet()
构造器
Method Summary
Variant | getVariant(java.lang.String name) 根据键值并按Variant类型读取数据
java.lang.String | indexToName(int index) 返回给定的索引号对应的键值.
void | remove(java.lang.String name) 删除给定键值及其下的数值.
void | setVariant(java.lang.String name, Variant v) 根据键值设置Variant类型的数据
Methods inherited from class com.bstek.dorado.utils.variant.VariantSet
assign, clear, clone, count, equals, exists, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getDataType, getDataType, getDate, getDate, getDouble, getDouble, getFloat, getFloat, getInt, getInt, getLong, getLong, getShort, getShort, getString, getString, getValue, getValue, getVariant, hashCode, isNull, isNull, remove, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setDataType, setDataType, setDataType, setDataType, setDate, setDate, setDouble, setDouble, setFloat, setFloat, setInt, setInt, setLong, setLong, setNull, setNull, setShort, setShort, setString, setString, setValue, setValue
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

NULL_INSTANCE

public static final ParameterSet NULL_INSTANCE
空对象

Constructor Detail

ParameterSet

public ParameterSet()
构造器

Method Detail

getVariant

public Variant getVariant(java.lang.String name)
根据键值并按Variant类型读取数据

Overrides:
getVariant in class VariantSet
Parameters:
name - String
Returns:
Variant

setVariant

public void setVariant(java.lang.String name,
                       Variant v)
根据键值设置Variant类型的数据

Overrides:
setVariant in class VariantSet
Parameters:
name - String
v - Variant

remove

public void remove(java.lang.String name)
删除给定键值及其下的数值.

Overrides:
remove in class VariantSet
Parameters:
name - String

indexToName

public java.lang.String indexToName(int index)
返回给定的索引号对应的键值.

Overrides:
indexToName in class VariantSet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReadRecord

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class ReadRecord

java.lang.Object
    extended by com.bstek.dorado.data.ReadRecord
Direct Known Subclasses:
Record
public abstract class ReadRecord
extends java.lang.Object

只读的Record

Version:
4.0

Field Summary
protected  int state
Constructor Summary
ReadRecord()
Method Summary
protected abstract java.lang.Object | doGet(java.lang.String name) 返回记录中某字段的值。
java.lang.Object | get(java.lang.String name) 直接返回记录中某字段的对应值对象
java.math.BigDecimal | getBigDecimal(java.lang.String name) 按BigDecimal类型返回记录中某字段的值。
boolean | getBoolean(java.lang.String name) 按boolean类型返回记录中某字段的值。
byte | getByte(java.lang.String name) 按byte类型返回记录中某字段的值。
java.util.Date | getDate(java.lang.String name) 按Date类型返回记录中某字段的值。
RecordSet | getDetailRecords(java.lang.String detailProperty) getDetailRecords
double | getDouble(java.lang.String name) 按double类型返回记录中某字段的值。
float | getFloat(java.lang.String name) 按float类型返回记录中某字段的值。
int | getInt(java.lang.String name) 按int类型返回记录中某字段的值。
long | getLong(java.lang.String name) 按long类型返回记录中某字段的值。
short | getShort(java.lang.String name) 按short类型返回记录中某字段的值。
int | getState() 记录当前的状态
java.lang.String | getString(java.lang.String name) 按String类型返回记录中某字段的值。
java.lang.Object | getValue(java.lang.String name) 返回记录中某字段的值。
Variant | getVariant(java.lang.String name) 按Variant类型返回记录中某字段的值。
boolean | isNull(java.lang.String name) 判断记录中某字段的值是否为空(null)。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

state

protected int state
Constructor Detail

ReadRecord

public ReadRecord()
Method Detail

getState

public int getState()
记录当前的状态

Returns:
int

isNull

public boolean isNull(java.lang.String name)
判断记录中某字段的值是否为空(null)。

Parameters:
name - String
Returns:
boolean

doGet

protected abstract java.lang.Object doGet(java.lang.String name)
返回记录中某字段的值。此方法须在派生类中实现。

Parameters:
name - String
Returns:
Object

getDetailRecords

public RecordSet getDetailRecords(java.lang.String detailProperty)
getDetailRecords

Parameters:
detailProperty - String
Returns:
RecordSet

get

public java.lang.Object get(java.lang.String name)
直接返回记录中某字段的对应值对象

Parameters:
name - String
Returns:
Object

getValue

public java.lang.Object getValue(java.lang.String name)
返回记录中某字段的值。

Parameters:
name - String
Returns:
Object

getString

public java.lang.String getString(java.lang.String name)
按String类型返回记录中某字段的值。

Parameters:
name - String
Returns:
String

getByte

public byte getByte(java.lang.String name)
按byte类型返回记录中某字段的值。

Parameters:
name - String
Returns:
byte

getShort

public short getShort(java.lang.String name)
按short类型返回记录中某字段的值。

Parameters:
name - String
Returns:
short

getInt

public int getInt(java.lang.String name)
按int类型返回记录中某字段的值。

Parameters:
name - String
Returns:
int

getLong

public long getLong(java.lang.String name)
按long类型返回记录中某字段的值。

Parameters:
name - String
Returns:
long

getFloat

public float getFloat(java.lang.String name)
按float类型返回记录中某字段的值。

Parameters:
name - String
Returns:
float

getDouble

public double getDouble(java.lang.String name)
按double类型返回记录中某字段的值。

Parameters:
name - String
Returns:
double

getBigDecimal

public java.math.BigDecimal getBigDecimal(java.lang.String name)
按BigDecimal类型返回记录中某字段的值。

Parameters:
name - String
Returns:
BigDecimal

getBoolean

public boolean getBoolean(java.lang.String name)
按boolean类型返回记录中某字段的值。

Parameters:
name - String
Returns:
boolean

getDate

public java.util.Date getDate(java.lang.String name)
按Date类型返回记录中某字段的值。

Parameters:
name - String
Returns:
Date

getVariant

public Variant getVariant(java.lang.String name)
按Variant类型返回记录中某字段的值。

Parameters:
name - String
Returns:
Variant
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Record

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class Record

java.lang.Object
    extended by com.bstek.dorado.data.ReadRecord
        extended by com.bstek.dorado.data.Record
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
Direct Known Subclasses:
BaseRecord
public abstract class Record
extends ReadRecord
implements java.io.Serializable, java.lang.Cloneable

记录对象

Version:
4.0
See Also:
Serialized Form

Field Summary
static int | STATE_DELETED 记录状态 - 已删除.
static int | STATE_MODIFIED 记录状态 - 已更新.
static int | STATE_NEW 记录状态 - 新增.
static int | STATE_NONE 记录状态 - 无状态.此状态为记录的默认状态.
Fields inherited from class com.bstek.dorado.data.ReadRecord
state
Constructor Summary
Record()
构造器
Method Summary
protected java.lang.Object | clone() Creates and returns a copy of this object.
protected abstract void | doSet(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值.此方法须在派生类中实现.
protected void | fireAfterChange(ReadRecord record, java.lang.String fieldName) 触发AfterChange事件,该事件一般由Dataset进行监听.
protected java.lang.Object | fireBeforeChange(ReadRecord record, java.lang.String fieldName, java.lang.Object value) 触发BeforeChange事件,该事件一般由Dataset进行监听.
void | fromDO(java.lang.Object DO) 从给定的DataObject对象中转换数据.
Dataset | getDataset() 取得该记录对象所属的数据集（Dataset）对象.
FieldSet | getFieldSet() 取得该记录的所有字段的集合对象.
static java.lang.Object | getPropertyValue(java.lang.Object o, java.lang.String[] properties)
long | getRecordId() 取得当前记录的id.
boolean | isDeleted() 该记录是否已被删除
void | set(java.lang.String name, java.lang.Object value) set
void | setBigDecimal(java.lang.String name, java.math.BigDecimal value) 设定记录中某个BigDecimal类型的字段值.
void | setBoolean(java.lang.String name, boolean value) 设定记录中某个boolean类型的字段值.
void | setByte(java.lang.String name, byte value) 设定记录中某个byte类型的字段值.
void | setDate(java.lang.String name, java.util.Date value) 设定记录中某个date类型的字段值.
void | setDetailRecords(java.lang.String detailProperty, RecordSet records) setDetailRecords
void | setDouble(java.lang.String name, double value) 设定记录中某个Double类型的字段值.
void | setFloat(java.lang.String name, float value) 设定记录中某个float类型的字段值.
void | setInt(java.lang.String name, int value) 设定记录中某个int类型的字段值.
void | setLong(java.lang.String name, long value) 设定记录中某个long类型的字段值.
void | setNull(java.lang.String name) 设置记录中某字段的值是否为空(null).
static void | setPropertyValue(java.lang.Object o, java.lang.String[] properties, java.lang.Object value)
void | setRecordId(long recordId) 设置当前记录的id.此id一般是自动生成的,您不需要手工设定.
void | setShort(java.lang.String name, short value) 设定记录中某个short类型的字段值.
void | setString(java.lang.String name, java.lang.String value) 设置记录中指定的字符字段的值.
void | setValue(java.lang.String name, java.lang.Object value) 直接设置记录中某字段的对应值对象
long | timestamp() 返回该Record对象的时间戳.该时间戳表示Record中数据最后被修改的时间.
java.lang.Object | toDO() 转换为DataObject对象.
void | toDO(java.lang.Object DO) 转换为DataObject对象.
void | validate() 检查对记录所作的修改的有效性.
Methods inherited from class com.bstek.dorado.data.ReadRecord
doGet, get, getBigDecimal, getBoolean, getByte, getDate, getDetailRecords, getDouble, getFloat, getInt, getLong, getShort, getState, getString, getValue, getVariant, isNull
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STATE_NONE

public static final int STATE_NONE
记录状态 - 无状态.此状态为记录的默认状态.

See Also:
Constant Field Values

STATE_NEW

public static final int STATE_NEW
记录状态 - 新增.

See Also:
Constant Field Values

STATE_DELETED

public static final int STATE_DELETED
记录状态 - 已删除.

See Also:
Constant Field Values

STATE_MODIFIED

public static final int STATE_MODIFIED
记录状态 - 已更新.

See Also:
Constant Field Values
Constructor Detail

Record

public Record()
构造器

Method Detail

getRecordId

public long getRecordId()
取得当前记录的id.

Returns:
long

setRecordId

public void setRecordId(long recordId)
设置当前记录的id.此id一般是自动生成的,您不需要手工设定.

Parameters:
recordId - long

timestamp

public long timestamp()
返回该Record对象的时间戳.该时间戳表示Record中数据最后被修改的时间.

Returns:
long

isDeleted

public boolean isDeleted()
该记录是否已被删除

Returns:
boolean

validate

public void validate()
检查对记录所作的修改的有效性.

doSet

protected abstract void doSet(java.lang.String name,
                              java.lang.Object value)
设置当前记录中某字段的值.此方法须在派生类中实现.

Parameters:
name - String
value - Object

setDetailRecords

public void setDetailRecords(java.lang.String detailProperty,
                             RecordSet records)
setDetailRecords

Parameters:
detailProperty - String
records - RecordSet

set

public void set(java.lang.String name,
                java.lang.Object value)
set

Parameters:
name - String
value - Object

setValue

public void setValue(java.lang.String name,
                     java.lang.Object value)
直接设置记录中某字段的对应值对象

Parameters:
name - String
value - Object

setString

public void setString(java.lang.String name,
                      java.lang.String value)
设置记录中指定的字符字段的值.

Parameters:
name - String
value - String

setByte

public void setByte(java.lang.String name,
                    byte value)
设定记录中某个byte类型的字段值.

Parameters:
name - String
value - byte

setShort

public void setShort(java.lang.String name,
                     short value)
设定记录中某个short类型的字段值.

Parameters:
name - String
value - short

setInt

public void setInt(java.lang.String name,
                   int value)
设定记录中某个int类型的字段值.

Parameters:
name - String
value - int

setLong

public void setLong(java.lang.String name,
                    long value)
设定记录中某个long类型的字段值.

Parameters:
name - String
value - long

setFloat

public void setFloat(java.lang.String name,
                     float value)
设定记录中某个float类型的字段值.

Parameters:
name - String
value - float

setDouble

public void setDouble(java.lang.String name,
                      double value)
设定记录中某个Double类型的字段值.

Parameters:
name - String
value - double

setBigDecimal

public void setBigDecimal(java.lang.String name,
                          java.math.BigDecimal value)
设定记录中某个BigDecimal类型的字段值.

Parameters:
name - String
value - BigDecimal

setBoolean

public void setBoolean(java.lang.String name,
                       boolean value)
设定记录中某个boolean类型的字段值.

Parameters:
name - String
value - boolean

setDate

public void setDate(java.lang.String name,
                    java.util.Date value)
设定记录中某个date类型的字段值.

Parameters:
name - String
value - Date

setNull

public void setNull(java.lang.String name)
设置记录中某字段的值是否为空(null).

Parameters:
name - String

fireBeforeChange

protected java.lang.Object fireBeforeChange(ReadRecord record,
                                            java.lang.String fieldName,
                                            java.lang.Object value)
触发BeforeChange事件,该事件一般由Dataset进行监听.

Parameters:
record - ReadRecord
fieldName - String
value - Object
Returns:
Object

fireAfterChange

protected void fireAfterChange(ReadRecord record,
                               java.lang.String fieldName)
触发AfterChange事件,该事件一般由Dataset进行监听.

Parameters:
record - ReadRecord
fieldName - String

getDataset

public Dataset getDataset()
取得该记录对象所属的数据集（Dataset）对象.

Returns:
Dataset

getFieldSet

public FieldSet getFieldSet()
取得该记录的所有字段的集合对象.

Returns:
FieldSet

fromDO

public void fromDO(java.lang.Object DO)
从给定的DataObject对象中转换数据.

Parameters:
DO - Object

toDO

public void toDO(java.lang.Object DO)
转换为DataObject对象.

Parameters:
DO - Object

toDO

public java.lang.Object toDO()
                      throws java.lang.Exception
转换为DataObject对象.

Returns:
Object
Throws:
java.lang.Exception

clone

protected java.lang.Object clone()
                          throws java.lang.CloneNotSupportedException
Creates and returns a copy of this object.

Returns:
a clone of this instance.
Throws:
java.lang.CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.

setPropertyValue

public static void setPropertyValue(java.lang.Object o,
                                    java.lang.String[] properties,
                                    java.lang.Object value)
                             throws java.lang.Exception
Throws:
java.lang.Exception

getPropertyValue

public static java.lang.Object getPropertyValue(java.lang.Object o,
                                                java.lang.String[] properties)
                                         throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordFilter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Interface RecordFilter

public interface RecordFilter

记录过滤器

Version:
4.0

Method Summary
 boolean isRecordVisible(Record record)
判断一条记录是否可见

Method Detail

isRecordVisible

public boolean isRecordVisible(Record record)
判断一条记录是否可见

Parameters:
record - Record
Returns:
boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordIterator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class RecordIterator

java.lang.Object
    extended by com.bstek.dorado.data.RecordIterator
All Implemented Interfaces:
java.util.Iterator
public class RecordIterator
extends java.lang.Object
implements java.util.Iterator

记录迭代器

Version:
4.0

Constructor Summary
RecordIterator(Dataset dataset)
构造器
Method Summary
ParameterSet | filter() Deprecated.
java.lang.String | getVisibility() 返回迭代器的记录可见性
boolean | hasNext() 返回 true 表示是否存在下一条记录.
java.lang.Object | next() 返回下一条记录.
Record | nextRecord() 返回下一条记录.
void | remove() 从Dataset删除当前记录.
void | setVisibility(java.lang.String visibility) 设置迭代器的记录可见性
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordIterator

public RecordIterator(Dataset dataset)
构造器

Parameters:
dataset - Dataset
Method Detail

getVisibility

public java.lang.String getVisibility()
返回迭代器的记录可见性

Returns:
String

setVisibility

public void setVisibility(java.lang.String visibility)
设置迭代器的记录可见性

Parameters:
visibility - String

filter

public ParameterSet filter()
Deprecated.

返回过滤参数的集合对象

Returns:
ParameterSet

hasNext

public boolean hasNext()
返回 true 表示是否存在下一条记录.

Specified by:
hasNext in interface java.util.Iterator
Returns:
true if the iterator has more elements.

next

public java.lang.Object next()
返回下一条记录.

Specified by:
next in interface java.util.Iterator
Returns:
the next element in the iteration.

nextRecord

public Record nextRecord()
返回下一条记录.

Returns:
Record

remove

public void remove()
从Dataset删除当前记录.

Specified by:
remove in interface java.util.Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordListener

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Interface RecordListener

All Superinterfaces:
java.util.EventListener
public interface RecordListener
extends java.util.EventListener

Dataset中记录操作的监听器

Version:
4.0

Method Summary
void | afterChange(Dataset dataset, ReadRecord record, java.lang.String fieldName) 当Dataset中某条记录的数据被修改之后被触发的事件.
void | afterDelete(Dataset dataset, ReadRecord record) 从Dataset中删除一条记录之后触发的事件
void | afterInsert(Dataset dataset, Record record) 向Dataset中插入一条记录之后触发的事件
void | afterScroll(Dataset dataset) 当Dataset的当前记录改变之后触发的事件
void | beforeChange(Dataset dataset, ReadRecord record, java.lang.String fieldName, Variant value) 当Dataset中某条记录的数据将要被修改之前被触发的事件.
void | beforeDelete(Dataset dataset, ReadRecord record) 将要从Dataset中删除一条记录之前触发的事件
void | beforeInsert(Dataset dataset, Record record) 将要向Dataset中插入一条记录之前触发的事件
void | beforeScroll(Dataset dataset) 当Dataset的当前记录改变之前触发的事件

Method Detail

beforeScroll

public void beforeScroll(Dataset dataset)
当Dataset的当前记录改变之前触发的事件

Parameters:
dataset - Dataset

afterScroll

public void afterScroll(Dataset dataset)
当Dataset的当前记录改变之后触发的事件

Parameters:
dataset - Dataset

beforeInsert

public void beforeInsert(Dataset dataset,
                         Record record)
将要向Dataset中插入一条记录之前触发的事件

Parameters:
dataset - Dataset
record - Record

afterInsert

public void afterInsert(Dataset dataset,
                        Record record)
向Dataset中插入一条记录之后触发的事件

Parameters:
dataset - DatasetEvent
record - Record

beforeChange

public void beforeChange(Dataset dataset,
                         ReadRecord record,
                         java.lang.String fieldName,
                         Variant value)
当Dataset中某条记录的数据将要被修改之前被触发的事件.

Parameters:
dataset - Dataset
record - 将被修改的记录
fieldName - 将被修改的字段名
value - 将被设置到记录中的数值

afterChange

public void afterChange(Dataset dataset,
                        ReadRecord record,
                        java.lang.String fieldName)
当Dataset中某条记录的数据被修改之后被触发的事件.

Parameters:
dataset - Dataset
record - 将被修改的记录
fieldName - 将被修改的字段名

beforeDelete

public void beforeDelete(Dataset dataset,
                         ReadRecord record)
将要从Dataset中删除一条记录之前触发的事件

Parameters:
dataset - DatasetEvent
record - ReadRecord

afterDelete

public void afterDelete(Dataset dataset,
                        ReadRecord record)
从Dataset中删除一条记录之后触发的事件

Parameters:
dataset - DatasetEvent
record - ReadRecord
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordSet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class RecordSet

java.lang.Object
    extended by com.bstek.dorado.data.RecordSet
All Implemented Interfaces:
java.io.Serializable
public class RecordSet
extends java.lang.Object
implements java.io.Serializable

Record集合对象

Version:
4.0
See Also:
Serialized Form

Constructor Summary
RecordSet()
构造器
Method Summary
void | clear() 清除记录集中的数据记录
RecordWrapper | findWrapper(Record record) 寻找并返回指定记录的包装器.
Record | getFirst() 取得记录集合中的第一条记录
RecordWrapper | getFirstWrapper() 取得记录集合中的第一条记录的包装器.
Record | getLast() 取得记录集合中的最后一条记录
RecordWrapper | getLastWrapper() 取得记录集合中的最后一条记录的包装器.
int | getPageCount() 返回整个结果集可能包含的页数.
int | getPageIndex() 返回当前RecordSet对象中管理的Record在整个结果集中所处的页号.
int | getPossibleCount() 返回整个结果集可能包含的记录数.
RecordWrapper | insertRecord(Record record) 插入一条记录
java.util.Set | loadedPages() 返回所有已加载的页的集合
void | removeRecord(Record record) 删除一条记录
void | setPageCount(int pageCount) 设置整个结果集可能包含的页数.
void | setPageIndex(int pageIndex) 设置当前RecordSet对象中管理的Record在整个结果集中所处的页号.
void | setPossibleCount(int possibleCount) 设置整个结果集可能包含的记录数.
int | size() 取得总记录数
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordSet

public RecordSet()
构造器

Method Detail

getFirstWrapper

public RecordWrapper getFirstWrapper()
取得记录集合中的第一条记录的包装器.(这是一个dorado内部使用的方法)

Returns:
RecordWrapper

getFirst

public Record getFirst()
取得记录集合中的第一条记录

Returns:
Record

getLastWrapper

public RecordWrapper getLastWrapper()
取得记录集合中的最后一条记录的包装器.(这是一个dorado内部使用的方法)

Returns:
RecordWrapper

getLast

public Record getLast()
取得记录集合中的最后一条记录

Returns:
Record

findWrapper

public RecordWrapper findWrapper(Record record)
寻找并返回指定记录的包装器.(这是一个dorado内部使用的方法)

Parameters:
record - Record
Returns:
RecordWrapper

insertRecord

public RecordWrapper insertRecord(Record record)
插入一条记录

Parameters:
record - Record
Returns:
RecordWrapper

removeRecord

public void removeRecord(Record record)
删除一条记录

Parameters:
record - Record

clear

public void clear()
清除记录集中的数据记录

size

public int size()
取得总记录数

Returns:
int

getPageCount

public int getPageCount()
返回整个结果集可能包含的页数.

注意: RecordSet对象可能只包含了整个结果集中的一部分.

Returns:
int

setPageCount

public void setPageCount(int pageCount)
设置整个结果集可能包含的页数.

Parameters:
pageCount - int

getPageIndex

public int getPageIndex()
返回当前RecordSet对象中管理的Record在整个结果集中所处的页号.

Returns:
int 从1开始计的页号.

setPageIndex

public void setPageIndex(int pageIndex)
设置当前RecordSet对象中管理的Record在整个结果集中所处的页号.

Parameters:
pageIndex - 从1开始计的页号.

getPossibleCount

public int getPossibleCount()
返回整个结果集可能包含的记录数.

Returns:
int

setPossibleCount

public void setPossibleCount(int possibleCount)
设置整个结果集可能包含的记录数.

Parameters:
possibleCount - int

loadedPages

public java.util.Set loadedPages()
返回所有已加载的页的集合

Returns:
Set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecordWrapper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data
Class RecordWrapper

java.lang.Object
    extended by com.bstek.dorado.data.RecordWrapper
public class RecordWrapper
extends java.lang.Object

RecordSet使用的记录包装器

Version:
4.0

Constructor Summary
RecordWrapper(Record record)
构造器
Method Summary
RecordWrapper | getNext() 取得下一个记录包装器
int | getPageIndex() 取得当前管理的Record在整个结果集中所处的页号.
RecordWrapper | getPrev() 取得上一个记录包装器
Record | getRecord() 取得被包装的记录
void | setPageIndex(int pageIndex) 设置当前管理的Record在整个结果集中所处的页号.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordWrapper

public RecordWrapper(Record record)
构造器

Parameters:
record - Record
Method Detail

getPrev

public RecordWrapper getPrev()
取得上一个记录包装器

Returns:
RecordWrapper

getNext

public RecordWrapper getNext()
取得下一个记录包装器

Returns:
RecordWrapper

getRecord

public Record getRecord()
取得被包装的记录

Returns:
Record

getPageIndex

public int getPageIndex()
取得当前管理的Record在整个结果集中所处的页号.

Returns:
从1开始计的页号.

setPageIndex

public void setPageIndex(int pageIndex)
设置当前管理的Record在整个结果集中所处的页号.

Parameters:
pageIndex - 从1开始计的页号.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CustomDataset

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.custom
Class CustomDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.data.custom.CustomDataset
All Implemented Interfaces:
DataListener, Dataset, java.util.EventListener, java.io.Serializable
public class CustomDataset
extends com.bstek.dorado.data.AbstractDataset

用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.
定义字段和数据的读取存储逻辑一般可利用Dataset的监听器(DatasetListener)实现.默认情况下 CustomDataset的createFields、loadData、update等方法将不会完成任何操作.

Version:
4.0
See Also:
DatasetListener, Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
CustomDataset()
Method Summary
protected void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
void | doUpdate() 把用户对Dataset中数据的操作更新到外部数据中.
protected com.bstek.dorado.data.FieldFactory | getFieldFactory() 返回Field的创建工厂.
protected com.bstek.dorado.data.RecordFactory | getRecordFactory() 返回Record的创建工厂.
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFieldByNode, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doFromDO, doFromSingleDO, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterScroll, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, fromDO, fromSingleDO, fromSingleDO, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, init, initListener, initNewRecord, insertRecord, insertRecord, internalLoad, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordSet, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomDataset

public CustomDataset()
Method Detail

getFieldFactory

protected com.bstek.dorado.data.FieldFactory getFieldFactory()
返回Field的创建工厂.

Specified by:
getFieldFactory in class DatasetSupport
Returns:
FieldFactory

getRecordFactory

protected com.bstek.dorado.data.RecordFactory getRecordFactory()
返回Record的创建工厂.

Specified by:
getRecordFactory in class DatasetSupport
Returns:
RecordFactory

doLoad

protected void doLoad(boolean createFields,
                      boolean loadData)
根据已设定的条件读取外部数据.

Specified by:
doLoad in class DatasetSupport
Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据

doUpdate

public void doUpdate()
把用户对Dataset中数据的操作更新到外部数据中.

Specified by:
doUpdate in class DatasetSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.data.custom

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.data.custom

实现可自定义数据集
See:
Description

Class Summary
CustomDataset 用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.

Package com.bstek.dorado.data.custom Description

实现可自定义数据集


AggregateMode

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class AggregateMode

java.lang.Object
    extended by com.bstek.dorado.data.db.AggregateMode
public final class AggregateMode
extends java.lang.Object

有关字段统计方式的常量.

Version:
4.0

Field Summary
static java.lang.String | AVERAGE 求字段的平均值
static java.lang.String | COUNT 统计记录总数
static java.lang.String | MAX 求字段的最大值
static java.lang.String | MIN 求字段的最小值
static java.lang.String | SUM 对字段求和
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COUNT

public static final java.lang.String COUNT
统计记录总数

See Also:
Constant Field Values

SUM

public static final java.lang.String SUM
对字段求和

See Also:
Constant Field Values

MAX

public static final java.lang.String MAX
求字段的最大值

See Also:
Constant Field Values

MIN

public static final java.lang.String MIN
求字段的最小值

See Also:
Constant Field Values

AVERAGE

public static final java.lang.String AVERAGE
求字段的平均值

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AndOrMatchRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class AndOrMatchRule

java.lang.Object
    extended by com.bstek.dorado.data.db.AndOrMatchRule
All Implemented Interfaces:
MatchRule
public class AndOrMatchRule
extends java.lang.Object
implements MatchRule

用于描述AutoSqlDataset的WHERE片断中的and/or逻辑连接符的规则对象

Version:
4.0

Field Summary
static java.lang.String | AND 等于
static java.lang.String | OR 不等于
Constructor Summary
AndOrMatchRule()
构造器
AndOrMatchRule(java.lang.String kind)
构造器
Method Summary
java.lang.String | getKind() 获得该逻辑连接符的类型.
int | getLevel() 取得该规则对象的级数.
void | setKind(java.lang.String kind) 设置该逻辑连接符的类型.
void | setLevel(int level) 设置该规则对象的级数. 该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

AND

public static final java.lang.String AND
等于

See Also:
Constant Field Values

OR

public static final java.lang.String OR
不等于

See Also:
Constant Field Values
Constructor Detail

AndOrMatchRule

public AndOrMatchRule()
构造器

AndOrMatchRule

public AndOrMatchRule(java.lang.String kind)
构造器

Parameters:
kind - 逻辑连接符的类型.
Method Detail

getLevel

public int getLevel()
取得该规则对象的级数.

Specified by:
getLevel in interface MatchRule
Returns:
int

setLevel

public void setLevel(int level)
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.

Specified by:
setLevel in interface MatchRule
Parameters:
level - int

getKind

public java.lang.String getKind()
获得该逻辑连接符的类型.

可选的类型如下:

  • and
  • or

Returns:
String

setKind

public void setKind(java.lang.String kind)
设置该逻辑连接符的类型.

Parameters:
kind - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutoDBField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class AutoDBField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.BaseField
            extended by com.bstek.dorado.data.db.DBField
                extended by com.bstek.dorado.data.db.AutoDBField
All Implemented Interfaces:
Field
public class AutoDBField
extends DBField

自动SQL记录集的字段对象

Version:
4.0

Constructor Summary
AutoDBField(java.lang.String name)
构造器
Method Summary
java.lang.String | getAggregate() 返回AutoSqlDataset中Field的合计模式.
java.lang.String | getSql() 返回此Field的自定义SQL。
boolean | isGroup() 返回AutoSqlDataset查询SQL的group子句中是否包含该字段.
void | setAggregate(java.lang.String aggregate) 设置AutoSqlDataset中Field的合计模式.
void | setGroup(boolean group) 设置AutoSqlDataset查询SQL的group子句中是否包含该字段.
void | setSql(java.lang.String sql) 设置此Field的自定义SQL。
Methods inherited from class com.bstek.dorado.data.db.DBField
getOriginField, getSqlDataType, getTable, isUpdatable, setOriginField, setSqlDataType, setTable, setUpdatable
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoDBField

public AutoDBField(java.lang.String name)
构造器

Parameters:
name - 字段名
Method Detail

getAggregate

public java.lang.String getAggregate()
返回AutoSqlDataset中Field的合计模式.
可选的合计模式如下:

Returns:
String
See Also:
AggregateMode

setAggregate

public void setAggregate(java.lang.String aggregate)
设置AutoSqlDataset中Field的合计模式. 可选的合计模式如下:

Parameters:
aggregate - String
See Also:
AggregateMode

isGroup

public boolean isGroup()
返回AutoSqlDataset查询SQL的group子句中是否包含该字段.

Returns:
boolean

setGroup

public void setGroup(boolean group)
设置AutoSqlDataset查询SQL的group子句中是否包含该字段. 如果该字段的group属性为真时,该字段将会出现在SQL语句的group子句中.

例如：如果字段a的group属性设为True后,AutoSqlDataset的SQL为:

select a,b,c from employee group by a

Parameters:
group - boolean

getSql

public java.lang.String getSql()
返回此Field的自定义SQL。 如果用户为此属性设置了值, 那么在生成SQL时AutoSqlDataset将直接使用这里定义的SQL.

Returns:
String

setSql

public void setSql(java.lang.String sql)
设置此Field的自定义SQL。

Parameters:
sql - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutoSqlDataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class AutoSqlDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.data.db.DBDataset
                extended by com.bstek.dorado.data.db.AutoSqlDataset
All Implemented Interfaces:
DataListener, Dataset, java.util.EventListener, java.io.Serializable
public class AutoSqlDataset
extends DBDataset

自动SQL记录集.

此种Dataset可自动根据属性设置和Field、MatchRule、Join、SortRule等生成用于查询和 更新的SQL.用户并不需要手工编写SQL命令,相当于使用一种面向对象化的方式来使用SQL.

AutoSqlDataset支持数据库方言机制.尽可能的使用AutoSqlDataset替代JDBC编程和SqlDataset 可以降低你的业务逻辑代码和数据库之间的耦合度,实现应用在数据库之间的平滑迁移.

AutoSqlDataset的MatchRule子对象支持的逃逸功能还可以帮助您简化复杂查询条件的定义.

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from class com.bstek.dorado.data.db.DBDataset
dataSource, dialect, keyFields, originTable
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
AutoSqlDataset()
构造器
Method Summary
AndOrMatchRule | addAndOrMatchRule(java.lang.String kind) 根据指定逻辑连接符的类型添加一个逻辑连接规则(AndOrMatchRule), 并返回新的逻辑连接规则对象.
BaseMatchRule | addBaseMatchRule(java.lang.String originField, java.lang.String operator, java.lang.String value) 根据指定的物理字段名、比较操作符和匹配值添加一个基本匹配规则(BaseMatchRule), 并返回新的基本匹配规则对象.
JoinTable | addJoin(java.lang.String name) 根据要关联的表的别名添加一个关联(JoinTable)并返回新的关联对象.
SortRule | addSortRule(java.lang.String originField) 根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.
SortRule | addSortRule(java.lang.String table, java.lang.String originField, boolean descent) 根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.
SqlMatchRule | addSqlMatchRule(java.lang.String sql) 根据指定SQL片断添加一个SQL匹配规则(SqlMatchRule), 并返回新的SQL匹配规则对象.
protected java.lang.String | doGetCountSql() 获得用于统计总记录数的SQL命令.
protected java.lang.String | doGetSql(boolean loadData) 获得SQL命令.
java.lang.String | getCountSql() 取得AutoSqlDataset内部使用的用于统计总记录数的SQL命令。
protected com.bstek.dorado.data.FieldFactory | getFieldFactory() 返回Field的创建工厂.
java.lang.String | getSql() 返回AutoSqlDataset内部使用的SQL命令。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
boolean | isDistinct() 是否是用distinct关键字执行SQL查询
boolean | isSelectAllField() 返回是否检索出AutoSqlDataset对应的主表(originTable)中所有的字段。
ObjectCollection | joins() 返回AutoSqlDataset所有Join的集合对象。
java.util.List | matchRules() 返回AutoSqlDataset所有MatchRule的集合对象。
void | setDistinct(boolean distinct) 设定是否是用distinct关键字执行SQL查询
void | setSelectAllField(boolean selectAllField) 设置是否自动检索出AutoSqlDataset对应的主表(originTable)中所有的字段。
java.util.List | sortRules() 返回AutoSqlDataset所有SortRule的集合对象。
Methods inherited from class com.bstek.dorado.data.db.DBDataset
createFields, doGetDialect, doLoad, doUpdate, getDataSource, getDbCharSet, getDialect, getKeyFields, getLogicCharSet, getOriginTable, getRecordFactory, isRetrieveAfterUpdate, load, load, retrieveRecord, setDataSource, setDialect, setKeyFields, setOriginTable, setRetrieveAfterUpdate, updateDeletedRecord, updateModifiedRecord, updateNewRecord
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFieldByNode, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doFromDO, doFromSingleDO, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterScroll, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, fromDO, fromSingleDO, fromSingleDO, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, initNewRecord, insertRecord, insertRecord, internalLoad, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordSet, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutoSqlDataset

public AutoSqlDataset()
构造器

Method Detail

getFieldFactory

protected com.bstek.dorado.data.FieldFactory getFieldFactory()
返回Field的创建工厂.

Specified by:
getFieldFactory in class DatasetSupport
Returns:
FieldFactory

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Overrides:
init in class DatasetSupport
Throws:
java.lang.Exception

addJoin

public JoinTable addJoin(java.lang.String name)
根据要关联的表的别名添加一个关联(JoinTable)并返回新的关联对象.

Parameters:
name - 要关联的表的别名
Returns:
JoinTable

addBaseMatchRule

public BaseMatchRule addBaseMatchRule(java.lang.String originField,
                                      java.lang.String operator,
                                      java.lang.String value)
根据指定的物理字段名、比较操作符和匹配值添加一个基本匹配规则(BaseMatchRule), 并返回新的基本匹配规则对象.

注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此方法返回的基本匹配规则对象的table属性.

Parameters:
originField - 物理字段名
operator - 比较操作符
value - 匹配值
Returns:
BaseMatchRule

addAndOrMatchRule

public AndOrMatchRule addAndOrMatchRule(java.lang.String kind)
根据指定逻辑连接符的类型添加一个逻辑连接规则(AndOrMatchRule), 并返回新的逻辑连接规则对象.

Parameters:
kind - 逻辑连接符的类型.
Returns:
AndOrMatchRule

addSqlMatchRule

public SqlMatchRule addSqlMatchRule(java.lang.String sql)
根据指定SQL片断添加一个SQL匹配规则(SqlMatchRule), 并返回新的SQL匹配规则对象.

Parameters:
sql - SQL片断
Returns:
SqlMatchRule

addSortRule

public SortRule addSortRule(java.lang.String originField)
根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.

注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此方法返回的排序规则对象的table属性.

Parameters:
originField - 物理字段名
Returns:
SortRule

addSortRule

public SortRule addSortRule(java.lang.String table,
                            java.lang.String originField,
                            boolean descent)
根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.

注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此方法返回的排序规则对象的table属性.

Parameters:
table - String
originField - String
descent - boolean
Returns:
SortRule

doGetSql

protected java.lang.String doGetSql(boolean loadData)
获得SQL命令.

Specified by:
doGetSql in class DBDataset
Parameters:
loadData - 是否需要装载数据
Returns:
String

doGetCountSql

protected java.lang.String doGetCountSql()
获得用于统计总记录数的SQL命令.

Specified by:
doGetCountSql in class DBDataset
Returns:
String

isSelectAllField

public boolean isSelectAllField()
返回是否检索出AutoSqlDataset对应的主表(originTable)中所有的字段。

Returns:
boolean

setSelectAllField

public void setSelectAllField(boolean selectAllField)
设置是否自动检索出AutoSqlDataset对应的主表(originTable)中所有的字段。

Parameters:
selectAllField - boolean

isDistinct

public boolean isDistinct()
是否是用distinct关键字执行SQL查询

Returns:
boolean

setDistinct

public void setDistinct(boolean distinct)
设定是否是用distinct关键字执行SQL查询

Parameters:
distinct - boolean

getSql

public java.lang.String getSql()
返回AutoSqlDataset内部使用的SQL命令。

Returns:
String

getCountSql

public java.lang.String getCountSql()
取得AutoSqlDataset内部使用的用于统计总记录数的SQL命令。

Returns:
String

joins

public ObjectCollection joins()
返回AutoSqlDataset所有Join的集合对象。

Returns:
ObjectCollection

matchRules

public java.util.List matchRules()
返回AutoSqlDataset所有MatchRule的集合对象。

Returns:
List

sortRules

public java.util.List sortRules()
返回AutoSqlDataset所有SortRule的集合对象。

Returns:
List
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BaseMatchRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class BaseMatchRule

java.lang.Object
    extended by com.bstek.dorado.data.db.CommonMatchRule
        extended by com.bstek.dorado.data.db.BaseMatchRule
All Implemented Interfaces:
MatchRule
public class BaseMatchRule
extends CommonMatchRule

用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
该对象描述WHERE片断中的一些简单的匹配条件.

Version:
4.0

Field Summary
static java.lang.String | EQUALS 等于
static java.lang.String | GREATER 大于
static java.lang.String | GREATEREQUAL 大于等于
static java.lang.String | IN 在...之中
static java.lang.String | LESS 小于
static java.lang.String | LESSEQUAL 小于等于
static java.lang.String | LIKE 相似
static java.lang.String | NOTEQUALS 不等于
Constructor Summary
BaseMatchRule()
构造器
BaseMatchRule(java.lang.String originField, java.lang.String operator, java.lang.String value)
构造器
Method Summary
int | getDataType() 返回匹配值的数据类型.
java.lang.String | getOperator() 取得比较操作符。
java.lang.String | getOriginField() 返回匹配规则的原始字段。
java.lang.String | getTable() 返回原始字段(originField)所属的表名。
boolean | isUseSqlParameter() 是否在生成SQL时使用数据库预编译参数
void | setDataType(int dataType) 设置返回匹配值的数据类型.
void | setDataType(java.lang.String dataType) 设置返回匹配值的数据类型.
void | setOperator(java.lang.String operator) 设定比较操作符。
void | setOriginField(java.lang.String originField) 设定匹配规则的原始字段。
void | setTable(java.lang.String table) 设置原始字段(originField)所属的表名。
void | setUseSqlParameter(boolean useSqlParameter) 设置是否在生成SQL时使用数据库预编译参数.默认为true.
Methods inherited from class com.bstek.dorado.data.db.CommonMatchRule
getEscapeValue, getLevel, getValue, isEnabled, isEscapeEnabled, setEnabled, setEscapeEnabled, setEscapeValue, setLevel, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EQUALS

public static final java.lang.String EQUALS
等于

See Also:
Constant Field Values

NOTEQUALS

public static final java.lang.String NOTEQUALS
不等于

See Also:
Constant Field Values

GREATER

public static final java.lang.String GREATER
大于

See Also:
Constant Field Values

LESS

public static final java.lang.String LESS
小于

See Also:
Constant Field Values

GREATEREQUAL

public static final java.lang.String GREATEREQUAL
大于等于

See Also:
Constant Field Values

LESSEQUAL

public static final java.lang.String LESSEQUAL
小于等于

See Also:
Constant Field Values

LIKE

public static final java.lang.String LIKE
相似

See Also:
Constant Field Values

IN

public static final java.lang.String IN
在...之中

See Also:
Constant Field Values
Constructor Detail

BaseMatchRule

public BaseMatchRule()
构造器

BaseMatchRule

public BaseMatchRule(java.lang.String originField,
                     java.lang.String operator,
                     java.lang.String value)
构造器

Parameters:
originField - 物理字段名
operator - 比较操作符
value - 匹配值
Method Detail

getTable

public java.lang.String getTable()
返回原始字段(originField)所属的表名。

Returns:
String

setTable

public void setTable(java.lang.String table)
设置原始字段(originField)所属的表名。

Parameters:
table - String

getOriginField

public java.lang.String getOriginField()
返回匹配规则的原始字段。

Returns:
String

setOriginField

public void setOriginField(java.lang.String originField)
设定匹配规则的原始字段。

Parameters:
originField - String

getOperator

public java.lang.String getOperator()
取得比较操作符。

Returns:
String

setOperator

public void setOperator(java.lang.String operator)
设定比较操作符。

Parameters:
operator - String

getDataType

public int getDataType()
返回匹配值的数据类型.

Returns:
int
See Also:
DataType

setDataType

public void setDataType(int dataType)
设置返回匹配值的数据类型.

Parameters:
dataType - int
See Also:
DataType

setDataType

public void setDataType(java.lang.String dataType)
设置返回匹配值的数据类型.

Parameters:
dataType - int
See Also:
DataType

isUseSqlParameter

public boolean isUseSqlParameter()
是否在生成SQL时使用数据库预编译参数

Returns:
boolean

setUseSqlParameter

public void setUseSqlParameter(boolean useSqlParameter)
设置是否在生成SQL时使用数据库预编译参数.默认为true.

在某些数据库中(例如Oracle),对于CHAR类型的字段如果在使用预编译参数时,我们必须传入已补齐尾部空格的匹配值, 否则将无法得到正确的查询结果. 为了避免这一问题的出现我们可以将对应此字段的匹配条件设为不使用数据库预编译参数.

Parameters:
useSqlParameter - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CaseInsensitiveVariantSet

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class CaseInsensitiveVariantSet

java.lang.Object
    extended by com.bstek.dorado.utils.variant.VariantSet
        extended by com.bstek.dorado.data.db.CaseInsensitiveVariantSet
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
public class CaseInsensitiveVariantSet
extends VariantSet

可支持多种类型的对象集合。其功能类似于一个功能增强了的Map。

此集合将忽略键值的大小写。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
CaseInsensitiveVariantSet()
Method Summary
boolean | exists(java.lang.String name) 判断给定键值下是否存有数值.
Variant | getVariant(java.lang.String name) 根据键值并按Variant类型读取数据
void | remove(java.lang.String name) 删除给定键值及其下的数值.
void | setVariant(java.lang.String name, Variant v) 根据键值设置Variant类型的数据
Methods inherited from class com.bstek.dorado.utils.variant.VariantSet
assign, clear, clone, count, equals, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getDataType, getDataType, getDate, getDate, getDouble, getDouble, getFloat, getFloat, getInt, getInt, getLong, getLong, getShort, getShort, getString, getString, getValue, getValue, getVariant, hashCode, indexToName, isNull, isNull, remove, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setDataType, setDataType, setDataType, setDataType, setDate, setDate, setDouble, setDouble, setFloat, setFloat, setInt, setInt, setLong, setLong, setNull, setNull, setShort, setShort, setString, setString, setValue, setValue
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CaseInsensitiveVariantSet

public CaseInsensitiveVariantSet()
Method Detail

exists

public boolean exists(java.lang.String name)
Deprecated.

Description copied from class: VariantSet
判断给定键值下是否存有数值.

Overrides:
exists in class VariantSet
Parameters:
name - name
Returns:
boolean

setVariant

public void setVariant(java.lang.String name,
                       Variant v)
Deprecated.

Description copied from class: VariantSet
根据键值设置Variant类型的数据

Overrides:
setVariant in class VariantSet
Parameters:
name - String
v - Variant

getVariant

public Variant getVariant(java.lang.String name)
Deprecated.

Description copied from class: VariantSet
根据键值并按Variant类型读取数据

Overrides:
getVariant in class VariantSet
Parameters:
name - String
Returns:
Variant

remove

public void remove(java.lang.String name)
Deprecated.

Description copied from class: VariantSet
删除给定键值及其下的数值.

Overrides:
remove in class VariantSet
Parameters:
name - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CommonMatchRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class CommonMatchRule

java.lang.Object
    extended by com.bstek.dorado.data.db.CommonMatchRule
All Implemented Interfaces:
MatchRule
Direct Known Subclasses:
BaseMatchRule, SqlMatchRule
public abstract class CommonMatchRule
extends java.lang.Object
implements MatchRule

用于描述AutoSqlDataset的WHERE片断的匹配规则抽象类.

Version:
4.0

Constructor Summary
CommonMatchRule()
构造器
Method Summary
java.lang.String | getEscapeValue() 取得逃逸值.
int | getLevel() 取得该规则对象的级数.
java.lang.String | getValue() 返回匹配值.
boolean | isEnabled() 返回整个匹配规则是否有效。
boolean | isEscapeEnabled() 返回是否要启用本匹配规则上的可逃逸功能.
void | setEnabled(boolean enabled) 设置整个匹配规则是否有效。
void | setEscapeEnabled(boolean escapeEnabled) 设置是否要启用本匹配规则上的可逃逸功能.
void | setEscapeValue(java.lang.String escapeValue) 设置逃逸值.
void | setLevel(int level) 设置该规则对象的级数. 该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.
void | setValue(java.lang.String value) 设置匹配值.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommonMatchRule

public CommonMatchRule()
构造器

Method Detail

getLevel

public int getLevel()
取得该规则对象的级数.

Specified by:
getLevel in interface MatchRule
Returns:
int

setLevel

public void setLevel(int level)
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.

Specified by:
setLevel in interface MatchRule
Parameters:
level - int

isEnabled

public boolean isEnabled()
返回整个匹配规则是否有效。

Returns:
boolean

setEnabled

public void setEnabled(boolean enabled)
设置整个匹配规则是否有效。

Parameters:
enabled - boolean

getEscapeValue

public java.lang.String getEscapeValue()
取得逃逸值.
逃逸值是一个具体的数值,当逃逸值与匹配值相等时本匹配规则将被完全忽略.

Returns:
String

setEscapeValue

public void setEscapeValue(java.lang.String escapeValue)
设置逃逸值.
逃逸值是一个具体的数值,当逃逸值与匹配值相等时本匹配规则将被完全忽略.

Parameters:
escapeValue - String

isEscapeEnabled

public boolean isEscapeEnabled()
返回是否要启用本匹配规则上的可逃逸功能.

Returns:
boolean

setEscapeEnabled

public void setEscapeEnabled(boolean escapeEnabled)
设置是否要启用本匹配规则上的可逃逸功能.

Parameters:
escapeEnabled - boolean

getValue

public java.lang.String getValue()
返回匹配值.
匹配值是一个具体的数值,当逃逸值与匹配值相等时本匹配规则将被完全忽略.

Returns:
String

setValue

public void setValue(java.lang.String value)
设置匹配值.
匹配值是一个具体的数值,当逃逸值与匹配值相等时本匹配规则将被完全忽略.

Parameters:
value - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBDataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class DBDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.data.db.DBDataset
All Implemented Interfaces:
DataListener, Dataset, java.util.EventListener, java.io.Serializable
Direct Known Subclasses:
AutoSqlDataset, SqlDataset
public abstract class DBDataset
extends com.bstek.dorado.data.AbstractDataset

基于SQL的Dataset的抽象基类

Version:
4.0
See Also:
Serialized Form

Field Summary
protected java.lang.String | dataSource
protected com.bstek.dorado.data.db.dialect.Dialect | dialect
protected java.lang.String | keyFields
protected java.lang.String | originTable
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DBDataset()
构造器
Method Summary
protected void | createFields(java.sql.ResultSet rs) 根据给定的ResultSet对象自动创建字段对象.
protected abstract java.lang.String | doGetCountSql() 获得用于统计总记录数的SQL命令.
protected com.bstek.dorado.data.db.dialect.Dialect | doGetDialect() 获得此Dataset内部使用的数据库方言的实现类.
protected abstract java.lang.String | doGetSql(boolean loadData) 获得SQL命令.
protected void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
void | doUpdate() 把用户对Dataset中数据的操作更新到外部数据中.
java.lang.String | getDataSource() 返回Dataset对应的数据源名称.
java.lang.String | getDbCharSet() 取得数据库的字符集编码.
com.bstek.dorado.data.db.dialect.Dialect | getDialect() 取得此Dataset内部使用的数据库方言的实现类.
java.lang.String | getKeyFields() 取得此Dataset的主表的主键字段。
java.lang.String | getLogicCharSet() 取得逻辑代码中使用的字符集编码.
java.lang.String | getOriginTable() 取得此Dataset的主表的物理表名.
protected com.bstek.dorado.data.RecordFactory | getRecordFactory() 返回Record的创建工厂.
boolean | isRetrieveAfterUpdate() 是否需要在完成某条记录的更新后对该记录进行重新查询.
void | load(java.sql.ResultSet rs) 将ResultSet中的数据自动读取到Dataset中.
void | load(java.sql.ResultSet rs, boolean calculatePageCount) 将ResultSet中的数据自动读取到Dataset中.
protected void | retrieveRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record, java.sql.PreparedStatement psUpdate) 从数据库中提取一条记录的信息
void | setDataSource(java.lang.String dataSource) 设置Dataset对应的数据源名称.
void | setDialect(com.bstek.dorado.data.db.dialect.Dialect dialect) 设置此Dataset内部使用的数据库方言的实现类.
void | setKeyFields(java.lang.String keyFields) 取得此Dataset的主表的主键字段.
void | setOriginTable(java.lang.String originTable) 设置此Dataset的主表的物理表名.
void | setRetrieveAfterUpdate(boolean retrieveAfterUpdate) 是否需要在完成某条记录的更新后对该记录进行重新查询.
protected void | updateDeletedRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record) 向数据库中更新一条删除的记录。
protected void | updateModifiedRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record) 向数据库中更新一条修改过的记录。
protected void | updateNewRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record) 向数据库中更新数据一条新增的记录。
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFieldByNode, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doFromDO, doFromSingleDO, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterScroll, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, fromDO, fromSingleDO, fromSingleDO, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFieldFactory, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, init, initListener, initNewRecord, insertRecord, insertRecord, internalLoad, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordSet, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

dataSource

protected java.lang.String dataSource

dialect

protected com.bstek.dorado.data.db.dialect.Dialect dialect

originTable

protected java.lang.String originTable

keyFields

protected java.lang.String keyFields
Constructor Detail

DBDataset

public DBDataset()
构造器

Method Detail

getRecordFactory

protected com.bstek.dorado.data.RecordFactory getRecordFactory()
返回Record的创建工厂.

Specified by:
getRecordFactory in class DatasetSupport
Returns:
RecordFactory

getDialect

public com.bstek.dorado.data.db.dialect.Dialect getDialect()
取得此Dataset内部使用的数据库方言的实现类.

Returns:
Dialect

setDialect

public void setDialect(com.bstek.dorado.data.db.dialect.Dialect dialect)
设置此Dataset内部使用的数据库方言的实现类.

Parameters:
dialect - Dialect

doGetDialect

protected com.bstek.dorado.data.db.dialect.Dialect doGetDialect()
获得此Dataset内部使用的数据库方言的实现类.

Returns:
Dialect

getDataSource

public java.lang.String getDataSource()
返回Dataset对应的数据源名称.

Returns:
String

setDataSource

public void setDataSource(java.lang.String dataSource)
设置Dataset对应的数据源名称.

Parameters:
dataSource - String

doGetSql

protected abstract java.lang.String doGetSql(boolean loadData)
获得SQL命令.

Parameters:
loadData - 是否需要装载数据
Returns:
String

doGetCountSql

protected abstract java.lang.String doGetCountSql()
获得用于统计总记录数的SQL命令.

Returns:
String

getOriginTable

public java.lang.String getOriginTable()
取得此Dataset的主表的物理表名.

Returns:
String

setOriginTable

public void setOriginTable(java.lang.String originTable)
设置此Dataset的主表的物理表名.
此表名一般在Dataset进行数据更新(即update()方法)时才有效. Dataset将根据此属性和keyFields结合来生成用于更新的SQL.

Parameters:
originTable - String

getKeyFields

public java.lang.String getKeyFields()
取得此Dataset的主表的主键字段。

Returns:
String

setKeyFields

public void setKeyFields(java.lang.String keyFields)
取得此Dataset的主表的主键字段.
如果存在多个主键字段,可用","对字段名进行分割. 此属性一般在Dataset进行数据更新(即update()方法)时才有效. Dataset将根据此属性和originTable结合来生成用于更新的SQL.

Parameters:
keyFields - String

isRetrieveAfterUpdate

public boolean isRetrieveAfterUpdate()
是否需要在完成某条记录的更新后对该记录进行重新查询.

Returns:
boolean

setRetrieveAfterUpdate

public void setRetrieveAfterUpdate(boolean retrieveAfterUpdate)
是否需要在完成某条记录的更新后对该记录进行重新查询. 利用此特性我们可以在记录更新后从Dataset中获得由数据库产生的部分信息. 例如:自动生成的主键值、数据库中的字段默认值、或由触发器产生的数值。

Parameters:
retrieveAfterUpdate - boolean

createFields

protected void createFields(java.sql.ResultSet rs)
                     throws java.sql.SQLException
根据给定的ResultSet对象自动创建字段对象.

Parameters:
rs - ResultSet
Throws:
java.sql.SQLException

doLoad

protected void doLoad(boolean createFields,
                      boolean loadData)
               throws java.lang.Exception
根据已设定的条件读取外部数据.

Specified by:
doLoad in class DatasetSupport
Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据
Throws:
java.lang.Exception

doUpdate

public void doUpdate()
              throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Specified by:
doUpdate in class DatasetSupport
Throws:
java.lang.Exception

updateDeletedRecord

protected void updateDeletedRecord(com.bstek.dorado.data.db.UpdateSqlInfo info,
                                   Record record)
                            throws java.lang.Exception
向数据库中更新一条删除的记录。

Parameters:
info - UpdateSqlInfo
record - Record
Throws:
java.lang.Exception

updateModifiedRecord

protected void updateModifiedRecord(com.bstek.dorado.data.db.UpdateSqlInfo info,
                                    Record record)
                             throws java.lang.Exception
向数据库中更新一条修改过的记录。

Parameters:
info - UpdateSqlInfo
record - Record
Throws:
java.lang.Exception

updateNewRecord

protected void updateNewRecord(com.bstek.dorado.data.db.UpdateSqlInfo info,
                               Record record)
                        throws java.lang.Exception
向数据库中更新数据一条新增的记录。

Parameters:
info - UpdateSqlInfo
record - Record
Throws:
java.lang.Exception

retrieveRecord

protected void retrieveRecord(com.bstek.dorado.data.db.UpdateSqlInfo info,
                              Record record,
                              java.sql.PreparedStatement psUpdate)
                       throws java.lang.Exception
从数据库中提取一条记录的信息

Parameters:
info - UpdateSqlInfo
record - Record
psUpdate - PreparedStatement
Throws:
java.lang.Exception

getDbCharSet

public java.lang.String getDbCharSet()
取得数据库的字符集编码.

Returns:
String

getLogicCharSet

public java.lang.String getLogicCharSet()
取得逻辑代码中使用的字符集编码.

Returns:
String

load

public void load(java.sql.ResultSet rs)
          throws java.io.UnsupportedEncodingException,
                 java.sql.SQLException
将ResultSet中的数据自动读取到Dataset中.
此方法将自动根据Dataset的pageIndex和pageSize属性的设置决定分页方式. 这样,最终可能只会从ResultSet中装载一部分记录,同时自动根据ResultSet计算总页数(pageCount).

Parameters:
rs - ResultSet
Throws:
java.io.UnsupportedEncodingException
java.sql.SQLException

load

public void load(java.sql.ResultSet rs,
                 boolean calculatePageCount)
          throws java.io.UnsupportedEncodingException,
                 java.sql.SQLException
将ResultSet中的数据自动读取到Dataset中.
此方法将忽略Dataset的pageIndex和pageSize属性的设置.装载ResultSet中的所有记录. 同时根据传入的rowCount来计算总页数(pageCount). 如果您并不关注结果的分页情况,也可以将rowCount设定为0.

Parameters:
rs - ResultSet
calculatePageCount - int
Throws:
java.io.UnsupportedEncodingException
java.sql.SQLException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class DBField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.BaseField
            extended by com.bstek.dorado.data.db.DBField
All Implemented Interfaces:
Field
Direct Known Subclasses:
AutoDBField
public class DBField
extends BaseField

DBDataset记录集的字段对象

Version:
4.0

Constructor Summary
DBField(java.lang.String name)
构造器
Method Summary
java.lang.String | getOriginField() 返回该字段来自于哪个数据库物理字段。
int | getSqlDataType() 取得数据库中该字段的数据类型。
java.lang.String | getTable() 返回该字段所属的数据库物理表名.
boolean | isUpdatable() 返回该字段是否可向数据库中更新
void | setOriginField(java.lang.String originField) 设置该字段来自于哪个数据库物理字段。
void | setSqlDataType(int sqlDataType) 设置该字段在数据库中的数据类型。
void | setTable(java.lang.String tableName) 设置该字段所属的数据库物理表名.
void | setUpdatable(boolean updatable) 设置该字段是否可向数据库中更新
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DBField

public DBField(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getSqlDataType

public int getSqlDataType()
取得数据库中该字段的数据类型。

Returns:
int
See Also:
Types

setSqlDataType

public void setSqlDataType(int sqlDataType)
设置该字段在数据库中的数据类型。

Parameters:
sqlDataType - int
See Also:
Types

getTable

public java.lang.String getTable()
返回该字段所属的数据库物理表名.

Returns:
String

setTable

public void setTable(java.lang.String tableName)
设置该字段所属的数据库物理表名.

Parameters:
tableName - String

getOriginField

public java.lang.String getOriginField()
返回该字段来自于哪个数据库物理字段。

Returns:
String

setOriginField

public void setOriginField(java.lang.String originField)
设置该字段来自于哪个数据库物理字段。

Parameters:
originField - String

isUpdatable

public boolean isUpdatable()
返回该字段是否可向数据库中更新

Returns:
boolean

setUpdatable

public void setUpdatable(boolean updatable)
设置该字段是否可向数据库中更新

Parameters:
updatable - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DBStatement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class DBStatement

java.lang.Object
    extended by com.bstek.dorado.data.db.DBStatement
public class DBStatement
extends java.lang.Object

用于方便使用SQL命令的工具类.

通过此工具类开发人员可以非常快速的完成通常的数据操作和数据提取. 不同于JDBC中的Statement的是DBStatement提供了可命名的参数,并且可以直接参与到dorado的当前事务当中.

注意: 由于启用了命名参数功能,对于参数化查询DBStatement使用了与JDBC不尽相同的定义方式.
例如在标准JDBC中使用以下方式定义的SQL: select * from employee where degree = ? and sex = ?
在DBStatement中我们应通过这样的方式来定义: select * from employee where degree = :degree and sex = :sex
然后我们就可以通过degree和sex而不是传统的下标值来访问statement中的参数了.

Version:
4.0

Field Summary
static java.lang.String | DELETE SQL类型 - DELETE
static java.lang.String | INSERT SQL类型 - INSERT
java.lang.String | NULL_VALUE NULL_VALUE
static java.lang.String | SELECT SQL类型 - SELECT
static java.lang.String | UNKNOWN 未知的SQL类型
static java.lang.String | UPDATE SQL类型 - UPDATE
Constructor Summary
DBStatement()
构造器
DBStatement(java.lang.String sql)
构造器
DBStatement(java.lang.String dataSource, java.lang.String sql)
构造器
Method Summary
void | close() 关闭本DBStatement.
int | execute() 执行SQL命令.
java.lang.String | getDataSource() 取得DBStatement使用的数据源的名称.
java.lang.String | getSql() 取得SBStatement内部使用的SQL命令。
ParameterSet | parameters() 取得所有参数的集合对象
VariantSet | query() 执行一个查询命令并返回第一条记录的值.如果本次查询没有查到任何记录将返回null.
java.util.List | queryForList() 执行一个查询命令并将结果集以java.util.List的形式返回.其中List中的元素是 com.bstek.dorado.utils.variant.VariantSet对象.
void | setDataSource(java.lang.String dataSource) 设置DBStatement使用的数据源的名称.如果此属性未指定则表示将使用dorado的默认数据源.
void | setSql(java.lang.String sql) 直接设置SQL命令.
void | setSql(java.lang.String type, java.lang.String table) 利用SQL类型和表名快速设置DBStatement的SQL命令.
void | setSql(java.lang.String type, java.lang.String table, java.lang.String keyFields) 利用SQL类型、表名和主键字段描述快速设置DBStatement的SQL命令.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NULL_VALUE

public final java.lang.String NULL_VALUE
NULL_VALUE

See Also:
Constant Field Values

UNKNOWN

public static final java.lang.String UNKNOWN
未知的SQL类型

SELECT

public static final java.lang.String SELECT
SQL类型 - SELECT

See Also:
Constant Field Values

INSERT

public static final java.lang.String INSERT
SQL类型 - INSERT

See Also:
Constant Field Values

UPDATE

public static final java.lang.String UPDATE
SQL类型 - UPDATE

See Also:
Constant Field Values

DELETE

public static final java.lang.String DELETE
SQL类型 - DELETE

See Also:
Constant Field Values
Constructor Detail

DBStatement

public DBStatement()
构造器

DBStatement

public DBStatement(java.lang.String sql)
构造器

Parameters:
sql - SQL命令

DBStatement

public DBStatement(java.lang.String dataSource,
                   java.lang.String sql)
构造器

Parameters:
dataSource - 在dorado中配置的数据源的名称
sql - SQL命令
Method Detail

setDataSource

public void setDataSource(java.lang.String dataSource)
设置DBStatement使用的数据源的名称.如果此属性未指定则表示将使用dorado的默认数据源.

Parameters:
dataSource - String

getDataSource

public java.lang.String getDataSource()
取得DBStatement使用的数据源的名称.

Returns:
String

setSql

public void setSql(java.lang.String type,
                   java.lang.String table)
利用SQL类型和表名快速设置DBStatement的SQL命令.

Parameters:
type - SQL类型.
table - 表名
See Also:
setSql(String, String, String)

setSql

public void setSql(java.lang.String type,
                   java.lang.String table,
                   java.lang.String keyFields)
利用SQL类型、表名和主键字段描述快速设置DBStatement的SQL命令.

SQL类型有如下几种取值:

  • SELECT - 查询类型的SQL命令.
    最终将生成类似 SELECT * FROM [table] 的SQL命令.
    对于此种类型的SQL命令,keyFields参数是没有意义的,建议您通过setSql(String type, String table) 方法来定义.
  • DELETE - 删除类型的SQL命令.
    最终将生成类似 DELETE FROM [table] WHERE [field1]=:field1 AND [field2]=:field2 的SQL命令.
    对于此种类型的SQL命令,如果您指定了keyFields参数,那么DBStatement将根据keyFields参数来生成SQL命令的WHERE子片断. 如果您没有指定keyFields参数,那么DBStatement将根据parameters中的参数来生成SQL命令的WHERE子片断. 每一个parameter将最终成为WHERE子片断中的一个条件.
  • UPDATE - 更新类型的SQL命令.
    最终将生成类似 UPDATE [table] SET [field1]=:field1, [field2]=:field2 WHERE [field3]=:field3 的SQL命令.
    对于此种类型的SQL命令keyFields是必须指定的参数.DBStatement将根据parameters中的参数配合keyFields来生成SQL命令. 利用keyFields用来生成SQL命令的WHERE子片断, 然后利用在parameters中的声明但没有在keyFields中声明的部分参数生成SQL命令的SET子片断.
  • INSERT - 插入类型的SQL命令.
    最终将生成类似 INSERT INTO [table] SET [field1]=:field1, [field2]=:field2 的SQL命令.
    对于此种类型的SQL命令,keyFields参数是没有意义的,建议您通过setSql(String type, String table) 方法来定义.最终DBStatement将根据parameters中的参数来生成SQL命令的SET子片断.

Parameters:
type - SQL类型.
table - 表名.
keyFields - 主键字段描述.如果需要描述多个主键字段可使用","分隔各字段名.

setSql

public void setSql(java.lang.String sql)
直接设置SQL命令.

Parameters:
sql - SQL命令

getSql

public java.lang.String getSql()
取得SBStatement内部使用的SQL命令。

Returns:
String

execute

public int execute()
            throws java.lang.Exception
执行SQL命令.

Returns:
如果此方法执行的SQL是INSERT, UPDATE, 或 DELETE, 将返回该命令执行时涉及到的记录数; 否则将返回0.请参考java.sql.Statement对象的executeUpdate()方法.
Throws:
java.lang.Exception

query

public VariantSet query()
                 throws java.lang.Exception
执行一个查询命令并返回第一条记录的值.如果本次查询没有查到任何记录将返回null.

Returns:
VariantSet
Throws:
java.lang.Exception

queryForList

public java.util.List queryForList()
                            throws java.lang.Exception
执行一个查询命令并将结果集以java.util.List的形式返回.其中List中的元素是 com.bstek.dorado.utils.variant.VariantSet对象.
如果本次查询没有查到任何记录将返回一个空的List.

Returns:
List
Throws:
java.lang.Exception

parameters

public ParameterSet parameters()
取得所有参数的集合对象

Returns:
ParameterSet

close

public void close()
关闭本DBStatement.
该方法在DBStatement使用完毕后必须显示的调用.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JoinTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class JoinTable

java.lang.Object
    extended by com.bstek.dorado.data.db.JoinTable
public class JoinTable
extends java.lang.Object

用于描述AutoSqlDataset的关联表信息的对象.

Version:
4.0

Constructor Summary
JoinTable(java.lang.String name)
构造器.
Method Summary
java.lang.String | getKeyFields() 取得用于建立关联的关联表中的字段.
java.lang.String | getName() 取得关联表的别名.
java.lang.String | getOriginTable() 取得关联表的物理表名.
java.lang.String | getSourceKeyFields() 取得用于建立关联的源表中的字段.
java.lang.String | getSourceTable() 取得与关联表相对应的源表.
void | setKeyFields(java.lang.String keyFields) 设置用于建立关联的关联表中的字段.
void | setOriginTable(java.lang.String originTable) 设置关联表的物理表名.
void | setSourceKeyFields(java.lang.String sourceKeyFields) 设置用于建立关联的源表中的字段.
void | setSourceTable(java.lang.String sourceTable) 设置与关联表相对应的源表.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JoinTable

public JoinTable(java.lang.String name)
构造器.

Parameters:
name - 要关联的表的别名.
Method Detail

getName

public java.lang.String getName()
取得关联表的别名.

Returns:
String

getOriginTable

public java.lang.String getOriginTable()
取得关联表的物理表名.

Returns:
String

setOriginTable

public void setOriginTable(java.lang.String originTable)
设置关联表的物理表名.

Parameters:
originTable - String

getSourceTable

public java.lang.String getSourceTable()
取得与关联表相对应的源表.

Returns:
String

setSourceTable

public void setSourceTable(java.lang.String sourceTable)
设置与关联表相对应的源表.

Parameters:
sourceTable - String

getKeyFields

public java.lang.String getKeyFields()
取得用于建立关联的关联表中的字段.

Returns:
String

setKeyFields

public void setKeyFields(java.lang.String keyFields)
设置用于建立关联的关联表中的字段. 如果关键字段中需要描述多个字段,则各字段名之间以","分隔.

Parameters:
keyFields - String

getSourceKeyFields

public java.lang.String getSourceKeyFields()
取得用于建立关联的源表中的字段.

Returns:
String

setSourceKeyFields

public void setSourceKeyFields(java.lang.String sourceKeyFields)
设置用于建立关联的源表中的字段. 如果关键字段中需要描述多个字段,则各字段名之间以","分隔.

Parameters:
sourceKeyFields - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MatchRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Interface MatchRule

All Known Implementing Classes:
AndOrMatchRule, CommonMatchRule
public interface MatchRule

用于描述AutoSqlDataset的WHERE片断的规则对象的接口.

Version:
4.0

Method Summary
int | getLevel() 取得该规则对象的级数.
void | setLevel(int level) 设置该规则对象的级数.

Method Detail

getLevel

public int getLevel()
取得该规则对象的级数.

Returns:
int

setLevel

public void setLevel(int level)
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.

Parameters:
level - int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.data.db

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.data.db

实现可直接访问数据库的数据集
See:
Description

Interface Summary
MatchRule 用于描述AutoSqlDataset的WHERE片断的规则对象的接口.

Class Summary
AggregateMode | 有关字段统计方式的常量.
AndOrMatchRule | 用于描述AutoSqlDataset的WHERE片断中的and/or逻辑连接符的规则对象
AutoDBField | 自动SQL记录集的字段对象
AutoSqlDataset | 自动SQL记录集.
BaseMatchRule | 用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
CaseInsensitiveVariantSet | 可支持多种类型的对象集合。
CommonMatchRule | 用于描述AutoSqlDataset的WHERE片断的匹配规则抽象类.
DBDataset | 基于SQL的Dataset的抽象基类
DBField | DBDataset记录集的字段对象
DBStatement | 用于方便使用SQL命令的工具类.
JoinTable | 用于描述AutoSqlDataset的关联表信息的对象.
SortRule | 用于描述AutoSqlDataset的SORT BY片断的排序规则对象
SqlDataset | 基于SQL的Dataset.
SqlMatchRule | 用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.

Package com.bstek.dorado.data.db Description

实现可直接访问数据库的数据集


SortRule

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class SortRule

java.lang.Object
    extended by com.bstek.dorado.data.db.SortRule
public class SortRule
extends java.lang.Object

用于描述AutoSqlDataset的SORT BY片断的排序规则对象

Version:
4.0

Constructor Summary
SortRule(java.lang.String originField)
构造器 注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此对象的table属性.
SortRule(java.lang.String table, java.lang.String originField, boolean descent)
构造器
Method Summary
java.lang.String | getOriginField() 返回该排序规则对应的字段名.
java.lang.String | getTable() 返回原始字段(originField)所属的表别名.
boolean | isDescent() 返回是否按照降序进行排序.
boolean | isEnabled() 取得该排序规则是否有效。
void | setDescent(boolean descent) 设定是否按照降序进行排序.
void | setEnabled(boolean enabled) 设置该排序规则是否有效.
void | setOriginField(java.lang.String originField) 设定该排序规则对应的字段名.
void | setTable(java.lang.String table) 设置原始字段(originField)所属的表别名.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SortRule

public SortRule(java.lang.String originField)
构造器

注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此对象的table属性.

Parameters:
originField - 物理字段名

SortRule

public SortRule(java.lang.String table,
                java.lang.String originField,
                boolean descent)
构造器

Parameters:
table - AutoSqlField
originField - String
descent - boolean
Method Detail

isEnabled

public boolean isEnabled()
取得该排序规则是否有效。

Returns:
boolean

setEnabled

public void setEnabled(boolean enabled)
设置该排序规则是否有效.

Parameters:
enabled - boolean

getTable

public java.lang.String getTable()
返回原始字段(originField)所属的表别名.

Returns:
String

setTable

public void setTable(java.lang.String table)
设置原始字段(originField)所属的表别名.

Parameters:
table - String

getOriginField

public java.lang.String getOriginField()
返回该排序规则对应的字段名.

Returns:
String

setOriginField

public void setOriginField(java.lang.String originField)
设定该排序规则对应的字段名.

Parameters:
originField - String

isDescent

public boolean isDescent()
返回是否按照降序进行排序.

Returns:
boolean

setDescent

public void setDescent(boolean descent)
设定是否按照降序进行排序.

Parameters:
descent - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlDataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class SqlDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.data.db.DBDataset
                extended by com.bstek.dorado.data.db.SqlDataset
All Implemented Interfaces:
DataListener, Dataset, java.util.EventListener, java.io.Serializable
public class SqlDataset
extends DBDataset

基于SQL的Dataset.

在使用此种Dataset时,如果需要对结果进行分页处理并且记录数又比较多时(500-1000条记录以上), 建议您在定义sql的同时也定义好countSql,以提高计算总记录数这一过程的性能.
例如:
sql: SELECT * FROM employee
countSql: SELECT count(*) FROM employee
如果没有定义countSql,那么SQLDataset将利用JDBC ResultSet的getRow()方法来计算总记录数. 但此种方法在记录数比较多时容易出现性能障碍.

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from class com.bstek.dorado.data.db.DBDataset
dataSource, dialect, keyFields, originTable
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
SqlDataset()
构造器
SqlDataset(java.lang.String sql)
构造器
SqlDataset(java.lang.String dataSource, java.lang.String sql)
构造器
Method Summary
protected java.lang.String | doGetCountSql() 获得用于统计总记录数的SQL命令.
protected java.lang.String | doGetSql(boolean loadData) 获得SQL命令.
java.lang.String | getCountSql() 返回统计总记录数的SQL命令。
protected com.bstek.dorado.data.FieldFactory | getFieldFactory() 返回Field的创建工厂.
java.lang.String | getSql() 返回SQL命令。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | setCountSql(java.lang.String countSql) 设置统计总记录数的SQL命令。
void | setSql(java.lang.String sql) 设置SqlDataset的SQL查询命令。
Methods inherited from class com.bstek.dorado.data.db.DBDataset
createFields, doGetDialect, doLoad, doUpdate, getDataSource, getDbCharSet, getDialect, getKeyFields, getLogicCharSet, getOriginTable, getRecordFactory, isRetrieveAfterUpdate, load, load, retrieveRecord, setDataSource, setDialect, setKeyFields, setOriginTable, setRetrieveAfterUpdate, updateDeletedRecord, updateModifiedRecord, updateNewRecord
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFieldByNode, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doFromDO, doFromSingleDO, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterScroll, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, fromDO, fromSingleDO, fromSingleDO, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, initNewRecord, insertRecord, insertRecord, internalLoad, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordSet, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SqlDataset

public SqlDataset()
构造器

SqlDataset

public SqlDataset(java.lang.String sql)
构造器

Parameters:
sql - String

SqlDataset

public SqlDataset(java.lang.String dataSource,
                  java.lang.String sql)
构造器

Parameters:
dataSource - String
sql - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Overrides:
init in class DatasetSupport
Throws:
java.lang.Exception

getFieldFactory

protected com.bstek.dorado.data.FieldFactory getFieldFactory()
返回Field的创建工厂.

Specified by:
getFieldFactory in class DatasetSupport
Returns:
FieldFactory

doGetSql

protected java.lang.String doGetSql(boolean loadData)
获得SQL命令.

Specified by:
doGetSql in class DBDataset
Parameters:
loadData - 是否需要装载数据
Returns:
String

getSql

public java.lang.String getSql()
返回SQL命令。

Returns:
String

setSql

public void setSql(java.lang.String sql)
设置SqlDataset的SQL查询命令。

Parameters:
sql - String

doGetCountSql

protected java.lang.String doGetCountSql()
获得用于统计总记录数的SQL命令.

Specified by:
doGetCountSql in class DBDataset
Returns:
String

getCountSql

public java.lang.String getCountSql()
返回统计总记录数的SQL命令。

Returns:
String

setCountSql

public void setCountSql(java.lang.String countSql)
设置统计总记录数的SQL命令。

Parameters:
countSql - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SqlMatchRule

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.data.db
Class SqlMatchRule

java.lang.Object
    extended by com.bstek.dorado.data.db.CommonMatchRule
        extended by com.bstek.dorado.data.db.SqlMatchRule
All Implemented Interfaces:
MatchRule
public class SqlMatchRule
extends CommonMatchRule

用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.

Version:
4.0

Constructor Summary
SqlMatchRule()
构造器
SqlMatchRule(java.lang.String sql)
构造器
Method Summary
java.lang.String | getSql() 取得自定义SQL.
void | setSql(java.lang.String sql) 设置自定义SQL.
Methods inherited from class com.bstek.dorado.data.db.CommonMatchRule
getEscapeValue, getLevel, getValue, isEnabled, isEscapeEnabled, setEnabled, setEscapeEnabled, setEscapeValue, setLevel, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SqlMatchRule

public SqlMatchRule()
构造器

SqlMatchRule

public SqlMatchRule(java.lang.String sql)
构造器

Parameters:
sql - String
Method Detail

getSql

public java.lang.String getSql()
取得自定义SQL.

Returns:
String

setSql

public void setSql(java.lang.String sql)
设置自定义SQL.

Parameters:
sql - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LocaleHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.i18n
Class LocaleHelper

java.lang.Object
    extended by com.bstek.dorado.i18n.LocaleHelper
public final class LocaleHelper
extends java.lang.Object

用于定义地区与语种的辅助工具类

Version:
4.0

Method Summary
static java.util.Locale | getDefaultLocale() 返回Setting.xml中指定的默认的地区与语种.
static java.util.Locale | getLocale(java.lang.String language, java.lang.String country) 返回给定参数所表示的地区与语种.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getDefaultLocale

public static java.util.Locale getDefaultLocale()
返回Setting.xml中指定的默认的地区与语种.

Returns:
Locale

getLocale

public static java.util.Locale getLocale(java.lang.String language,
                                         java.lang.String country)
返回给定参数所表示的地区与语种.

Parameters:
language - String
country - String
Returns:
Locale
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.i18n

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.i18n

用于支持国际化
See:
Description

Class Summary
LocaleHelper | 用于定义地区与语种的辅助工具类
ResourceManager | 国际化资源的管理对象
ResourceManagerContextMap |

Package com.bstek.dorado.i18n Description

用于支持国际化


ResourceManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.i18n
Class ResourceManager

java.lang.Object
    extended by com.bstek.dorado.i18n.ResourceManager
public class ResourceManager
extends java.lang.Object

国际化资源的管理对象

Version:
4.0

Field Summary
static java.lang.String DEFAULT_LOCALE_ATTRIBUTE_KEY
DEFAULT_LOCALE_ATTRIBUTE_KEY
Method Summary
java.util.ResourceBundle | getBundle(DoradoContext context, java.lang.String baseName) 按默认的地区与语种返回一个国际化资源集合.
java.util.ResourceBundle | getBundle(java.lang.String baseName, java.util.Locale locale) 按给定的地区与语种返回一个国际化资源集合.
java.util.Locale | getDefaultLocale(DoradoContext context) 返回默认的地区与语种.
static ResourceManager | getInstance() 获得单例对象
java.lang.String | getString(DoradoContext context, java.lang.String baseName, java.lang.String key) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object arg0) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object[] args) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object arg0, java.lang.Object arg1) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg2) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(java.util.Locale locale, java.lang.String baseName, java.lang.String key) 按给定的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(java.util.Locale locale, java.lang.String baseName, java.lang.String key, java.lang.Object arg0) 按给定的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(java.util.Locale locale, java.lang.String baseName, java.lang.String key, java.lang.Object[] args) 按给定的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(java.util.Locale locale, java.lang.String baseName, java.lang.String key, java.lang.Object arg0, java.lang.Object arg1) 按给定的地区与语种返回一个国际化资源字符串.
java.lang.String | getString(java.util.Locale locale, java.lang.String baseName, java.lang.String key, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg3) 按给定的地区与语种返回一个国际化资源字符串.
void | setDefaultLocale(DoradoContext context, int scope, java.util.Locale locale) 设置上下文对象中某一作用域的默认的地区与语种.
void | setDefaultLocale(DoradoContext context, java.util.Locale locale) 设置当前会话的默认的地区与语种.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_LOCALE_ATTRIBUTE_KEY

public static final java.lang.String DEFAULT_LOCALE_ATTRIBUTE_KEY
DEFAULT_LOCALE_ATTRIBUTE_KEY

See Also:
Constant Field Values
Method Detail

getInstance

public static ResourceManager getInstance()
获得单例对象

Returns:
ResourceManager

getBundle

public java.util.ResourceBundle getBundle(java.lang.String baseName,
                                          java.util.Locale locale)
按给定的地区与语种返回一个国际化资源集合.

Parameters:
baseName - String
locale - Locale
Returns:
ResourceBundle

getString

public java.lang.String getString(java.util.Locale locale,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object[] args)
按给定的地区与语种返回一个国际化资源字符串.

Parameters:
locale - Locale
baseName - String
key - String
args - Object[]
Returns:
String

getString

public java.lang.String getString(java.util.Locale locale,
                                  java.lang.String baseName,
                                  java.lang.String key)
按给定的地区与语种返回一个国际化资源字符串.

Parameters:
locale - Locale
baseName - String
key - String
Returns:
String

getString

public java.lang.String getString(java.util.Locale locale,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object arg0)
按给定的地区与语种返回一个国际化资源字符串.

Parameters:
locale - Locale
baseName - String
key - String
arg0 - Object
Returns:
String

getString

public java.lang.String getString(java.util.Locale locale,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object arg0,
                                  java.lang.Object arg1)
按给定的地区与语种返回一个国际化资源字符串.

Parameters:
locale - Locale
baseName - String
key - String
arg0 - Object
arg1 - Object
Returns:
String

getString

public java.lang.String getString(java.util.Locale locale,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object arg0,
                                  java.lang.Object arg1,
                                  java.lang.Object arg3)
按给定的地区与语种返回一个国际化资源字符串.

Parameters:
locale - Locale
baseName - String
key - String
arg0 - Object
arg1 - Object
arg3 - Object
Returns:
String

setDefaultLocale

public void setDefaultLocale(DoradoContext context,
                             java.util.Locale locale)
设置当前会话的默认的地区与语种.

Parameters:
context - DoradoContext
locale - Locale

setDefaultLocale

public void setDefaultLocale(DoradoContext context,
                             int scope,
                             java.util.Locale locale)
设置上下文对象中某一作用域的默认的地区与语种.

Parameters:
context - DoradoContext
locale - Locale

getDefaultLocale

public java.util.Locale getDefaultLocale(DoradoContext context)
返回默认的地区与语种.

Parameters:
context - DoradoContext
Returns:
Locale

getBundle

public java.util.ResourceBundle getBundle(DoradoContext context,
                                          java.lang.String baseName)
按默认的地区与语种返回一个国际化资源集合.

Parameters:
context - DoradoContext
baseName - String
Returns:
ResourceBundle

getString

public java.lang.String getString(DoradoContext context,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object[] args)
按默认的地区与语种返回一个国际化资源字符串.

Parameters:
context - DoradoContext
baseName - String
key - String
args - Object[]
Returns:
String

getString

public java.lang.String getString(DoradoContext context,
                                  java.lang.String baseName,
                                  java.lang.String key)
按默认的地区与语种返回一个国际化资源字符串.

Parameters:
context - DoradoContext
baseName - String
key - String
Returns:
String

getString

public java.lang.String getString(DoradoContext context,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object arg0)
按默认的地区与语种返回一个国际化资源字符串.

Parameters:
context - DoradoContext
baseName - String
key - String
arg0 - Object
Returns:
String

getString

public java.lang.String getString(DoradoContext context,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object arg0,
                                  java.lang.Object arg1)
按默认的地区与语种返回一个国际化资源字符串.

Parameters:
context - DoradoContext
baseName - String
key - String
arg0 - Object
arg1 - Object
Returns:
String

getString

public java.lang.String getString(DoradoContext context,
                                  java.lang.String baseName,
                                  java.lang.String key,
                                  java.lang.Object arg0,
                                  java.lang.Object arg1,
                                  java.lang.Object arg2)
按默认的地区与语种返回一个国际化资源字符串.

Parameters:
context - DoradoContext
baseName - String
key - String
arg0 - Object
arg1 - Object
arg2 - Object
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceManagerContextMap

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.i18n
Class ResourceManagerContextMap

java.lang.Object
    extended by com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
        extended by com.bstek.dorado.i18n.ResourceManagerContextMap
All Implemented Interfaces:
java.util.Map
public class ResourceManagerContextMap
extends com.bstek.dorado.common.rtexpr.impl.AbstractContextMap

Nested Class Summary
Nested classes inherited from class java.util.Map
java.util.Map.Entry
Constructor Summary
ResourceManagerContextMap(DoradoContext context, ResourceManager resource)
Method Summary
 java.lang.Object get(java.lang.Object key)
Methods inherited from class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap
clear, containsKey, containsValue, entrySet, equals, isEmpty, keySet, put, putAll, remove, size, values
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
hashCode

Constructor Detail

ResourceManagerContextMap

public ResourceManagerContextMap(DoradoContext context,
                                 ResourceManager resource)
Method Detail

get

public java.lang.Object get(java.lang.Object key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultModule

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.module
Class DefaultModule

java.lang.Object
    extended by com.bstek.dorado.module.ModuleSupport
        extended by com.bstek.dorado.module.DefaultModule
All Implemented Interfaces:
com.bstek.dorado.module.Module
public abstract class DefaultModule
extends ModuleSupport

默认的Module抽象实现类

Version:
4.0

Constructor Summary
DefaultModule()
Method Summary
protected  void initDataset(Dataset dataset)
初试化某个Dataset。
Methods inherited from class com.bstek.dorado.module.ModuleSupport
activate, createDataset, datasets, doActivate, doPassivate, finalize, getConfig, getDataset, getDataset, getDataset, getName, loadData, passivate, setConfig, setName
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultModule

public DefaultModule()
Method Detail

initDataset

protected void initDataset(Dataset dataset)
                    throws java.lang.Exception
Deprecated.

Description copied from class: ModuleSupport
初试化某个Dataset。此方法一般有系统内部调用。

Overrides:
initDataset in class ModuleSupport
Parameters:
dataset - Dataset
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Module

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.module
Interface Module

All Known Implementing Classes:
com.bstek.dorado.module.ModuleSupport
public interface Module

数据坞

Module用于管理一组Dataset,以便于实现Dataset在应用系统中的重用. 通常情况下Module不应被用来封装任何业务逻辑,我们应把它看做是MVC架构模式中的视图层对象.

Module中的Dataset通常情况下会被ViewModel中的DatasetReference(DynamicDropDown)来引用, 或为其它的Dataset(包含各种Module中的Dataset和ViewModel中的Dataset)提供Lookup服务.

Module的创建和销毁由Dorado提供的容器来管理,开发人员可以把它看做是一个Singleton对象来使用. 所以在绝大多数情况下为Module添加非Static的属性都是不正确的使用方法.

我们可以把Module中的每一个Dataset看做是Module提供给外界的一个数据服务接口. Module中的Dataset并不是Module的属性,不会随Module的创建而自动创建.Dataset也不是Singleton对象.

  • Module中Dataset的创建和销毁由Dorado提供的容器来管理, 但开发人员可以通过scope和timeout属性设置每一个Dataset的生命周期.
  • scope有request, session, application三种取值,默认值为request. 需要特别注意的是,如果我们在同一个request中连续以不同的pageIndex、pageSize、parameters配置组合去获取Module中的Dataset, 将得到多个不同的Dataset实例.
  • 如果需要考虑Dataset的缓存以提高系统效率应首先考虑将scope属性设置为application. 同时通常应在Dataset具备下列特征时考虑Dataset的缓存:
    • 该Dataset的使用频率较高. 例如在系统中的很多地方被LookupField引用.
    • Dataset中的数据量较小而不须作分页处理, 一般情况下记录数不小于1000.
    • Dataset中数据变化的频率较低. 例如应用系统中的代码表.

Version:
4.0

Method Summary
void | activate() Module的锐化处理
java.lang.String[] | datasets() 取得所有datasets的集合对象
com.bstek.dorado.module.config.ModuleConfig | getConfig() 取得Module的Module配置对象
Dataset | getDataset(java.lang.String id, boolean loadData) 根据指定条件取得Dataset对象
Dataset | getDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters) 根据指定条件取得Dataset对象
Dataset | getDataset(java.lang.String id, boolean loadData, ParameterSet parameters) 根据指定条件取得Dataset对象
java.lang.String | getName() 取得Module的名称
void | passivate() Module的钝化处理
void | setConfig(com.bstek.dorado.module.config.ModuleConfig config) 设定Module的配置对象
void | setName(java.lang.String name) 设置Module的名称

Method Detail

activate

public void activate()
              throws java.lang.Exception
Module的锐化处理

Throws:
java.lang.Exception

passivate

public void passivate()
               throws java.lang.Exception
Module的钝化处理

Throws:
java.lang.Exception

getName

public java.lang.String getName()
取得Module的名称

Returns:
String

setName

public void setName(java.lang.String name)
设置Module的名称

Parameters:
name - String

setConfig

public void setConfig(com.bstek.dorado.module.config.ModuleConfig config)
设定Module的配置对象

Parameters:
config - ModuleConfig

getConfig

public com.bstek.dorado.module.config.ModuleConfig getConfig()
取得Module的Module配置对象

Returns:
ModuleConfig

datasets

public java.lang.String[] datasets()
取得所有datasets的集合对象

Returns:
String[]

getDataset

public Dataset getDataset(java.lang.String id,
                          boolean loadData)
根据指定条件取得Dataset对象

Parameters:
id - String
loadData - boolean
Returns:
Dataset

getDataset

public Dataset getDataset(java.lang.String id,
                          boolean loadData,
                          ParameterSet parameters)
根据指定条件取得Dataset对象

Parameters:
id - String
loadData - boolean
parameters - ParameterSet
Returns:
Dataset

getDataset

public Dataset getDataset(java.lang.String id,
                          boolean loadData,
                          int pageSize,
                          int pageIndex,
                          ParameterSet parameters)
根据指定条件取得Dataset对象

Parameters:
id - String
loadData - boolean
pageSize - int
pageIndex - int
parameters - ParameterSet
Returns:
Dataset
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModuleManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.module
Class ModuleManager

java.lang.Object
    extended by com.bstek.dorado.module.ModuleManager
public class ModuleManager
extends java.lang.Object

Module管理器.

用于完成创建、查找Module等功能

Version:
4.0

Field Summary
static java.lang.String MODULES_ATTRIBUTE_KEY
Constructor Summary
ModuleManager()
Method Summary
static com.bstek.dorado.module.Module | getModule(com.bstek.dorado.module.config.ModuleConfig config) 根据给定的配置对象取得Module对象
static com.bstek.dorado.module.Module | getModule(java.lang.String moduleName) 根据给定的名称取得Module对象的实例.
static com.bstek.dorado.module.config.ModuleConfig | getModuleConfig(java.lang.String moduleName) 根据Module的名字取得配置对象
static org.apache.commons.pool.impl.GenericKeyedObjectPool | getModulePool() 取得Module的缓冲池
static void | init() 初始化
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MODULES_ATTRIBUTE_KEY

public static final java.lang.String MODULES_ATTRIBUTE_KEY
See Also:
Constant Field Values
Constructor Detail

ModuleManager

public ModuleManager()
Method Detail

init

public static void init()
初始化

getModulePool

public static org.apache.commons.pool.impl.GenericKeyedObjectPool getModulePool()
取得Module的缓冲池

Returns:
GenericKeyedObjectPool

getModuleConfig

public static com.bstek.dorado.module.config.ModuleConfig getModuleConfig(java.lang.String moduleName)
根据Module的名字取得配置对象

Parameters:
moduleName - String
Returns:
ModuleConfig

getModule

public static com.bstek.dorado.module.Module getModule(java.lang.String moduleName)
                                                throws java.lang.Exception
根据给定的名称取得Module对象的实例.

Parameters:
moduleName - String
Returns:
Module
Throws:
java.lang.Exception

getModule

public static com.bstek.dorado.module.Module getModule(com.bstek.dorado.module.config.ModuleConfig config)
                                                throws java.lang.Exception
根据给定的配置对象取得Module对象

Parameters:
config - ModuleConfig
Returns:
Module
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModuleSupport

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.module
Class ModuleSupport

java.lang.Object
    extended by com.bstek.dorado.module.ModuleSupport
All Implemented Interfaces:
com.bstek.dorado.module.Module
Direct Known Subclasses:
DefaultModule
public abstract class ModuleSupport
extends java.lang.Object
implements com.bstek.dorado.module.Module

Module的基本实现

Version:
4.0

Constructor Summary
ModuleSupport()
构造器
Method Summary
void | activate()
protected Dataset | createDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters) 根据给定的一系列参数创建并返回一个Dataset。
java.lang.String[] | datasets()
protected void | doActivate() Module的锐化处理。
protected void | doPassivate() Module的钝化处理。
protected void | finalize()
com.bstek.dorado.module.config.ModuleConfig | getConfig()
Dataset | getDataset(java.lang.String id, boolean loadData)
Dataset | getDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters)
Dataset | getDataset(java.lang.String id, boolean loadData, ParameterSet parameters)
java.lang.String | getName()
protected void | initDataset(Dataset dataset) Deprecated.
protected void | loadData(Dataset dataset, boolean loadData) Deprecated.
void | passivate()
void | setConfig(com.bstek.dorado.module.config.ModuleConfig config)
void | setName(java.lang.String name)
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ModuleSupport

public ModuleSupport()
构造器

Method Detail

finalize

protected void finalize()
                 throws java.lang.Throwable

Throws:
java.lang.Throwable

activate

public void activate()
              throws java.lang.Exception

Specified by:
activate in interface com.bstek.dorado.module.Module
Throws:
java.lang.Exception

doActivate

protected void doActivate()
                   throws java.lang.Exception
Module的锐化处理。 此方法用于提供给非派生类进行重载。

Throws:
java.lang.Exception

passivate

public void passivate()
               throws java.lang.Exception

Specified by:
passivate in interface com.bstek.dorado.module.Module
Throws:
java.lang.Exception

doPassivate

protected void doPassivate()
                    throws java.lang.Exception
Module的钝化处理。 此方法用于提供给非派生类进行重载。

Throws:
java.lang.Exception

getName

public java.lang.String getName()

Specified by:
getName in interface com.bstek.dorado.module.Module

setName

public void setName(java.lang.String name)

Specified by:
setName in interface com.bstek.dorado.module.Module

setConfig

public void setConfig(com.bstek.dorado.module.config.ModuleConfig config)

Specified by:
setConfig in interface com.bstek.dorado.module.Module

getConfig

public com.bstek.dorado.module.config.ModuleConfig getConfig()

Specified by:
getConfig in interface com.bstek.dorado.module.Module

datasets

public java.lang.String[] datasets()

Specified by:
datasets in interface com.bstek.dorado.module.Module

getDataset

public Dataset getDataset(java.lang.String id,
                          boolean loadData)

Specified by:
getDataset in interface com.bstek.dorado.module.Module

getDataset

public Dataset getDataset(java.lang.String id,
                          boolean loadData,
                          ParameterSet parameters)

Specified by:
getDataset in interface com.bstek.dorado.module.Module

getDataset

public Dataset getDataset(java.lang.String id,
                          boolean loadData,
                          int pageSize,
                          int pageIndex,
                          ParameterSet parameters)

Specified by:
getDataset in interface com.bstek.dorado.module.Module

createDataset

protected Dataset createDataset(java.lang.String id,
                                boolean loadData,
                                int pageSize,
                                int pageIndex,
                                ParameterSet parameters)
根据给定的一系列参数创建并返回一个Dataset。 由于Module中的Dataset的实例化是由对象池进行管理的， 因此此方法返回的Dataset有可能并不是一个全新的实例。

Parameters:
id - String
loadData - boolean
pageSize - int
pageIndex - int
parameters - ParameterSet
Returns:
Dataset

initDataset

protected void initDataset(Dataset dataset)
                    throws java.lang.Exception
Deprecated.

初试化某个Dataset。此方法一般有系统内部调用。

Parameters:
dataset - Dataset
Throws:
java.lang.Exception

loadData

protected void loadData(Dataset dataset,
                        boolean loadData)
                 throws java.lang.Exception
Deprecated.

为某个Dataset装载数据。此方法一般有系统内部调用。

Parameters:
dataset - Dataset
loadData - 是否要返回一个已经装载数据的Dataset。
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.module

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.module

数据模块的相关类
See:
Description

Class Summary
DefaultModule | 默认的Module抽象实现类
ModuleManager | Module管理器.
ModuleSupport | Module的基本实现

Package com.bstek.dorado.module Description

数据模块的相关类


AccessChecker

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.security
Interface AccessChecker

public interface AccessChecker

Dorado提供的默认的一种用户登录状态校验的类

Version:
4.0

Field Summary
static java.lang.String DEFAULT_LOGIN_SESSION_KEY
Method Summary
 void checkAccess(DoradoContext context, java.lang.Object accessingObject)
校验用户登录状态的方法

Field Detail

DEFAULT_LOGIN_SESSION_KEY

public static final java.lang.String DEFAULT_LOGIN_SESSION_KEY
See Also:
Constant Field Values
Method Detail

checkAccess

public void checkAccess(DoradoContext context,
                        java.lang.Object accessingObject)
                 throws AccessDeniedException
校验用户登录状态的方法

Parameters:
context - DoradoContext
accessingObject - Object
Throws:
AccessDeniedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AccessDeniedException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.security
Class AccessDeniedException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.security.AccessDeniedException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
UserNotLoggedInException
public class AccessDeniedException
extends DoradoRuntimeException

用户登录状态校验失败产生的异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
AccessDeniedException()
构造器
AccessDeniedException(java.lang.String message)
构造器
AccessDeniedException(java.lang.Throwable t)
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AccessDeniedException

public AccessDeniedException()
构造器

AccessDeniedException

public AccessDeniedException(java.lang.String message)
构造器

Parameters:
message - String 错误信息

AccessDeniedException

public AccessDeniedException(java.lang.Throwable t)
构造器

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.security

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.security

包含用于支持应用系统访问安全性的类
See:
Description

Interface Summary
AccessChecker Dorado提供的默认的一种用户登录状态校验的类

Exception Summary
AccessDeniedException | 用户登录状态校验失败产生的异常
UserNotLoggedInException | 用户没有登录的异常

Package com.bstek.dorado.security Description

包含用于支持应用系统访问安全性的类


UserNotLoggedInException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.security
Class UserNotLoggedInException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.security.AccessDeniedException
                        extended by com.bstek.dorado.security.UserNotLoggedInException
All Implemented Interfaces:
java.io.Serializable
public class UserNotLoggedInException
extends AccessDeniedException

用户没有登录的异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
UserNotLoggedInException()
构造器
UserNotLoggedInException(java.lang.String message)
构造器
UserNotLoggedInException(java.lang.Throwable t)
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

UserNotLoggedInException

public UserNotLoggedInException()
构造器

UserNotLoggedInException

public UserNotLoggedInException(java.lang.String message)
构造器

Parameters:
message - String 错误信息

UserNotLoggedInException

public UserNotLoggedInException(java.lang.Throwable t)
构造器

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ClassHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class ClassHelper

java.lang.Object
    extended by com.bstek.dorado.utils.ClassHelper
public final class ClassHelper
extends java.lang.Object

用于对象反射的工具类

Version:
4.0

Method Summary
static java.lang.Object | newInstance(java.lang.Class cl, java.lang.Class[] parameterTypes, java.lang.Object[] parameters) newInstance
static java.lang.Object | newInstance(java.lang.String clazz) newInstance
static java.lang.Object | newInstance(java.lang.String clazz, java.lang.Class[] parameterTypes, java.lang.Object[] parameters) newInstance
static java.lang.Class | parseType(java.lang.String name) parseType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

parseType

public static java.lang.Class parseType(java.lang.String name)
                                 throws java.lang.ClassNotFoundException
parseType

Parameters:
name - String
Returns:
Class
Throws:
java.lang.ClassNotFoundException

newInstance

public static java.lang.Object newInstance(java.lang.String clazz)
                                    throws java.lang.ClassNotFoundException,
                                           java.lang.IllegalAccessException,
                                           java.lang.InstantiationException
newInstance

Parameters:
clazz - String
Returns:
Object
Throws:
java.lang.ClassNotFoundException
java.lang.IllegalAccessException
java.lang.InstantiationException

newInstance

public static java.lang.Object newInstance(java.lang.String clazz,
                                           java.lang.Class[] parameterTypes,
                                           java.lang.Object[] parameters)
                                    throws java.lang.reflect.InvocationTargetException,
                                           java.lang.IllegalArgumentException,
                                           java.lang.IllegalAccessException,
                                           java.lang.InstantiationException,
                                           java.lang.SecurityException,
                                           java.lang.NoSuchMethodException,
                                           java.lang.ClassNotFoundException
newInstance

Parameters:
clazz - String
parameterTypes - Class[]
parameters - Object[]
Returns:
Object
Throws:
java.lang.reflect.InvocationTargetException
java.lang.IllegalArgumentException
java.lang.IllegalAccessException
java.lang.InstantiationException
java.lang.SecurityException
java.lang.NoSuchMethodException
java.lang.ClassNotFoundException

newInstance

public static java.lang.Object newInstance(java.lang.Class cl,
                                           java.lang.Class[] parameterTypes,
                                           java.lang.Object[] parameters)
                                    throws java.lang.reflect.InvocationTargetException,
                                           java.lang.IllegalArgumentException,
                                           java.lang.IllegalAccessException,
                                           java.lang.InstantiationException,
                                           java.lang.SecurityException,
                                           java.lang.NoSuchMethodException
newInstance

Parameters:
parameterTypes - Class[]
parameters - Object[]
cl - Class
Returns:
Object
Throws:
java.lang.reflect.InvocationTargetException
java.lang.IllegalArgumentException
java.lang.IllegalAccessException
java.lang.InstantiationException
java.lang.SecurityException
java.lang.NoSuchMethodException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DoradoException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class DoradoException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by com.bstek.dorado.utils.DoradoException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
ActionNotSuppertedException, ControllerNotFoundException, LoadXmlPropertyException, XmlParseException
public class DoradoException
extends java.lang.Exception

所有Dorado中异常的基类

Version:
4.0
See Also:
Serialized Form

Constructor Summary
DoradoException()
DoradoException
DoradoException(java.lang.String message)
DoradoException
DoradoException(java.lang.Throwable t)
DoradoException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DoradoException

public DoradoException()
DoradoException

DoradoException

public DoradoException(java.lang.String message)
DoradoException

Parameters:
message - String 错误信息

DoradoException

public DoradoException(java.lang.Throwable t)
DoradoException

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoradoRuntimeException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class DoradoRuntimeException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
All Implemented Interfaces:
java.io.Serializable
Direct Known Subclasses:
AccessDeniedException, DuplicateKeyException, FieldNotExistException, IllegalValueException, InvalidPropertyValueException, KeyNotExistException, NoCurrentRecordException
public class DoradoRuntimeException
extends java.lang.RuntimeException

所有Dorado中Runtime异常的基类

Version:
4.0
See Also:
Serialized Form

Constructor Summary
DoradoRuntimeException()
DoradoRuntimeException
DoradoRuntimeException(java.lang.String message)
DoradoRuntimeException
DoradoRuntimeException(java.lang.Throwable t)
DoradoRuntimeException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DoradoRuntimeException

public DoradoRuntimeException()
DoradoRuntimeException

DoradoRuntimeException

public DoradoRuntimeException(java.lang.String message)
DoradoRuntimeException

Parameters:
message - String 错误信息

DoradoRuntimeException

public DoradoRuntimeException(java.lang.Throwable t)
DoradoRuntimeException

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvalidPropertyValueException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class InvalidPropertyValueException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.utils.InvalidPropertyValueException
All Implemented Interfaces:
java.io.Serializable
public class InvalidPropertyValueException
extends DoradoRuntimeException

无效属性值的异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
InvalidPropertyValueException()
InvalidPropertyValueException
InvalidPropertyValueException(java.lang.String message)
InvalidPropertyValueException
InvalidPropertyValueException(java.lang.String propertyName, java.lang.String value)
InvalidPropertyValueException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidPropertyValueException

public InvalidPropertyValueException()
InvalidPropertyValueException

InvalidPropertyValueException

public InvalidPropertyValueException(java.lang.String message)
InvalidPropertyValueException

Parameters:
message - String 错误信息

InvalidPropertyValueException

public InvalidPropertyValueException(java.lang.String propertyName,
                                     java.lang.String value)
InvalidPropertyValueException

Parameters:
propertyName - String 属性名
value - String 属性值
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MetaData

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class MetaData

java.lang.Object
    extended by com.bstek.dorado.utils.variant.VariantSet
        extended by com.bstek.dorado.utils.MetaData
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
public class MetaData
extends VariantSet

元数据对象集合

Version:
4.0
See Also:
Serialized Form

Constructor Summary
MetaData()
Methods inherited from class com.bstek.dorado.utils.variant.VariantSet
assign, clear, clone, count, equals, exists, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getDataType, getDataType, getDate, getDate, getDouble, getDouble, getFloat, getFloat, getInt, getInt, getLong, getLong, getShort, getShort, getString, getString, getValue, getValue, getVariant, getVariant, hashCode, indexToName, isNull, isNull, remove, remove, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setDataType, setDataType, setDataType, setDataType, setDate, setDate, setDouble, setDouble, setFloat, setFloat, setInt, setInt, setLong, setLong, setNull, setNull, setShort, setShort, setString, setString, setValue, setValue, setVariant
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MetaData

public MetaData()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.utils

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.utils

Dorado的基本工具类
See:
Description

Class Summary
ClassHelper | 用于对象反射的工具类
MetaData | 元数据对象集合
Printf | 格式化输出字符串 此处的格式化方式类似C及JDK1.5中包含的格式化方式.
StringHelper | String的一些辅助操作
SynchroTimer | 基于线程的定时器
SystemVariable | 用于读取系统环境变量。
UniqueKey | 用于取得一个VM唯一标识。

Exception Summary
DoradoException | 所有Dorado中异常的基类
DoradoRuntimeException | 所有Dorado中Runtime异常的基类
InvalidPropertyValueException | 无效属性值的异常

Package com.bstek.dorado.utils Description

Dorado的基本工具类


Printf

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class Printf

java.lang.Object
    extended by com.bstek.dorado.utils.Printf
public final class Printf
extends java.lang.Object

格式化输出字符串

此处的格式化方式类似C及JDK1.5中包含的格式化方式. 例如:

Printf.format("My name is %s, I'm %d years old.", "Benny Bao", new Integer(28))
将返回
My name is Benny Bao, I'm 28 years old.

Version:
4.0

Method Summary
static java.lang.String | format(java.lang.String pattarn, java.lang.Object arg0) format
static java.lang.String | format(java.lang.String pattarn, java.lang.Object[] args) format
static java.lang.String | format(java.lang.String pattarn, java.lang.Object arg0, java.lang.Object arg1) format
static java.lang.String | format(java.lang.String pattarn, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg2) format
static java.lang.String | format(java.lang.String pattarn, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg2, java.lang.Object arg3) format
static java.lang.String | format(java.lang.String pattarn, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg2, java.lang.Object arg3, java.lang.Object arg4) format
static java.lang.String | format(java.lang.String pattarn, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg2, java.lang.Object arg3, java.lang.Object arg4, java.lang.Object arg5) format
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object[] args)
format

Parameters:
pattarn - String
args - Object[]
Returns:
String

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object arg0)
format

Parameters:
pattarn - String
arg0 - Object
Returns:
String

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object arg0,
                                      java.lang.Object arg1)
format

Parameters:
pattarn - String
arg0 - Object
arg1 - Object
Returns:
String

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object arg0,
                                      java.lang.Object arg1,
                                      java.lang.Object arg2)
format

Parameters:
pattarn - String
arg0 - Object
arg1 - Object
arg2 - Object
Returns:
String

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object arg0,
                                      java.lang.Object arg1,
                                      java.lang.Object arg2,
                                      java.lang.Object arg3)
format

Parameters:
pattarn - String
arg0 - Object
arg1 - Object
arg2 - Object
arg3 - Object
Returns:
String

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object arg0,
                                      java.lang.Object arg1,
                                      java.lang.Object arg2,
                                      java.lang.Object arg3,
                                      java.lang.Object arg4)
format

Parameters:
pattarn - String
arg0 - Object
arg1 - Object
arg2 - Object
arg3 - Object
arg4 - Object
Returns:
String

format

public static java.lang.String format(java.lang.String pattarn,
                                      java.lang.Object arg0,
                                      java.lang.Object arg1,
                                      java.lang.Object arg2,
                                      java.lang.Object arg3,
                                      java.lang.Object arg4,
                                      java.lang.Object arg5)
format

Parameters:
pattarn - String
arg0 - Object
arg1 - Object
arg2 - Object
arg3 - Object
arg4 - Object
arg5 - Object
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class StringHelper

java.lang.Object
    extended by com.bstek.dorado.utils.StringHelper
public final class StringHelper
extends java.lang.Object

String的一些辅助操作

Version:
4.0

Method Summary
static boolean | isEmpty(java.lang.String s) 判断是否一个无效的字符串。
static boolean | isNotEmpty(java.lang.String s) 判断是否一个有效的字符串。
static boolean | isValueLegal(java.lang.String s, java.lang.String invalidChar) 判断一个字符串中是否未出现指定的一组无效字符
static java.lang.String[] | split(java.lang.String s, java.lang.String separator) 根据指定的分割符将字符串分割成字符串数组。
static java.lang.String | toValidString(java.lang.Object o) 将给定的对象转换为一个有效的字符串.
static java.lang.String | translate(java.lang.String s, java.lang.String originCharsetName, java.lang.String charsetName) 将一个字符串转换为给定的编码格式.
static java.lang.String | translateFromISO(java.lang.String s, java.lang.String charsetName) 将一个iso8859-1字符串转换为给定的编码格式.
static java.lang.String | validate(java.lang.String s) 将传入的字符串转换成一个有效的字符串
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

translateFromISO

public static java.lang.String translateFromISO(java.lang.String s,
                                                java.lang.String charsetName)
                                         throws java.io.UnsupportedEncodingException
将一个iso8859-1字符串转换为给定的编码格式.

String utfString = StringHelper.translate(isoString, "UTF-8");

Parameters:
s - String
charsetName - String
Returns:
String
Throws:
java.io.UnsupportedEncodingException

translate

public static java.lang.String translate(java.lang.String s,
                                         java.lang.String originCharsetName,
                                         java.lang.String charsetName)
                                  throws java.io.UnsupportedEncodingException
将一个字符串转换为给定的编码格式.

String gbkString = StringHelper.translate(utfString, "UTF-8", "GBK");

Parameters:
s - String
originCharsetName - String
charsetName - String
Returns:
String
Throws:
java.io.UnsupportedEncodingException

isNotEmpty

public static boolean isNotEmpty(java.lang.String s)
判断是否一个有效的字符串。即该字符串既不是null又不是空字串

Parameters:
s - String
Returns:
boolean

isEmpty

public static boolean isEmpty(java.lang.String s)
判断是否一个无效的字符串。即该字符串是null或空字串

Parameters:
s - String
Returns:
boolean

validate

public static java.lang.String validate(java.lang.String s)
将传入的字符串转换成一个有效的字符串

Parameters:
s - String
Returns:
String

isValueLegal

public static boolean isValueLegal(java.lang.String s,
                                   java.lang.String invalidChar)
判断一个字符串中是否未出现指定的一组无效字符

Parameters:
s - String
invalidChar - String 一组无效字符
Returns:
boolean

split

public static java.lang.String[] split(java.lang.String s,
                                       java.lang.String separator)
根据指定的分割符将字符串分割成字符串数组。

Parameters:
s - 原字符串。
separator - 分割符
Returns:
字符串数组。

toValidString

public static java.lang.String toValidString(java.lang.Object o)
将给定的对象转换为一个有效的字符串. 如果给定的对象为null, 则本方法将返回"".

Parameters:
o - Object
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SynchroTimer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class SynchroTimer

java.lang.Object
    extended by com.bstek.dorado.utils.SynchroTimer
public abstract class SynchroTimer
extends java.lang.Object

基于线程的定时器

Version:
4.0

Constructor Summary
SynchroTimer(long interval)
构造器
Method Summary
protected abstract void | execute() 定时器在激活时所触发的动作
long | getInterval() 定时器触发间隔时间
protected void | start() 启动定时器
protected void | stop() 终止定时器
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SynchroTimer

public SynchroTimer(long interval)
构造器

Parameters:
interval - long 定时器触发的时间间隔
Method Detail

getInterval

public long getInterval()
定时器触发间隔时间

Returns:
int

execute

protected abstract void execute()
定时器在激活时所触发的动作

start

protected void start()
启动定时器

stop

protected void stop()
终止定时器

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SystemVariable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class SystemVariable

java.lang.Object
    extended by java.util.Dictionary
        extended by java.util.Hashtable
            extended by java.util.Properties
                extended by com.bstek.dorado.utils.SystemVariable
All Implemented Interfaces:
java.lang.Cloneable, java.util.Map, java.io.Serializable
public class SystemVariable
extends java.util.Properties

用于读取系统环境变量。使用getProperty方法返回系统环境变量的值。

Copyright: Copyright (c) 2004

Company: bstek

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.Properties
defaults
Constructor Summary
SystemVariable()
创建读取系统环境变量的对象。
Method Summary
 java.lang.String getProperty(java.lang.String key)
读取系统环境变量。
Methods inherited from class java.util.Properties
getProperty, list, list, load, propertyNames, save, setProperty, store
Methods inherited from class java.util.Hashtable
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

SystemVariable

public SystemVariable()
               throws java.io.IOException
创建读取系统环境变量的对象。

Throws:
java.io.IOException
Method Detail

getProperty

public java.lang.String getProperty(java.lang.String key)
读取系统环境变量。

Parameters:
key - String
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UniqueKey

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils
Class UniqueKey

java.lang.Object
    extended by com.bstek.dorado.utils.UniqueKey
public final class UniqueKey
extends java.lang.Object

用于取得一个VM唯一标识。

Version:
4.0

Method Summary
static java.lang.String getKey()
返回一个新的VM唯一标识。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getKey

public static java.lang.String getKey()
返回一个新的VM唯一标识。

Returns:
新的VM唯一标识。
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Encrypt

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.codec
Class Encrypt

java.lang.Object
    extended by com.bstek.dorado.utils.codec.Encrypt
public final class Encrypt
extends java.lang.Object

对字符串进行加密

1. 利用一个随机数对每个字符进行运算(a：ASC码、r：随机数、i：序号): a = (a + r) mod CHAR_SCOPE
2. 对应每个字符产生一个0到CHAR_SCOPE - 1之间的随机数，对字符进行运算并把随机数放在该字符之前(a：ASC码、r：随机数、i：序号): a = (a * r) mod 36
3. 累加字符串中所有的字符，对结果用$7FFFFF00取模，并将结果转换成8位十六进制数再拆成8个整数追加在字符串的末尾
4. 在字符串后加入0到64个随机字符并将加入的随机字符的数量存放在整个字符串的末尾
5. 利用密匙号对每个字符进行运算(a：ASC码、k：密匙号、i：序号): a = (a + round(k2 * i * k1 / 3)) mod CHAR_SCOPE

Version:
3.0

Method Summary
static java.lang.String | decode(java.lang.String encodedText, int key1, int key2) 解密字符串
static java.lang.String | encode(java.lang.String plainText, int key1, int key2) 加密字符串
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

encode

public static java.lang.String encode(java.lang.String plainText,
                                      int key1,
                                      int key2)
加密字符串

Parameters:
plainText - 无格式原始字符串
key1 - 是用于决定算法的参数
key2 - 是用于决定算法的参数
Returns:
String

decode

public static java.lang.String decode(java.lang.String encodedText,
                                      int key1,
                                      int key2)
解密字符串

Parameters:
encodedText - 已经编码的字符串
key1 - 是用于决定算法的参数
key2 - 是用于决定算法的参数
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EncryptCode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.codec
Class EncryptCode

java.lang.Object
    extended by com.bstek.dorado.utils.codec.EncryptCode
public class EncryptCode
extends java.lang.Object

本算法只用于加密由0-9和A-Z组成的字符串，以下的提到的字符指由0-9和A-Z组成的字符；假设字符串的长度为n)

1. 把字符转换成从0开始的整数。
2. 利用一个随机数对每个字符进行运算(a：ASC码、r：随机数、i：序号): a = (a + r) mod 36
3. 对应每个字符产生一个0到35之间的随机数，对字符进行运算并把随机数放在该字符之前(a：ASC码、r：随机数、i：序号): a = (a * r) mod 36
4. 累加字符串中所有的字符，对结果用$7FFFFF00取模，并将结果转换成8位十六进制数再拆成8个整数追加在字符串的末尾
5. 利用密匙号对每个字符进行运算(a：ASC码、k：密匙号、i：序号): a = (a + round(k * i * 17 / 3)) mod 36

Version:
3.0

Constructor Summary
EncryptCode()
Method Summary
static java.lang.String | decode(java.lang.String EncodedText, int Key1, int Key2) 解密字符串
static java.lang.String | encode(java.lang.String PlainText, int Key1, int Key2) 加密字符串
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EncryptCode

public EncryptCode()
Method Detail

encode

public static java.lang.String encode(java.lang.String PlainText,
                                      int Key1,
                                      int Key2)
加密字符串

Parameters:
PlainText - 无格式原始字符串
Key1 - 是用于决定算法的参数
Key2 - 是用于决定算法的参数
Returns:
String

decode

public static java.lang.String decode(java.lang.String EncodedText,
                                      int Key1,
                                      int Key2)
解密字符串

Parameters:
EncodedText - 已经编码的字符串
Key1 - 是用于决定算法的参数
Key2 - 是用于决定算法的参数
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EscapeUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.codec
Class EscapeUtils

java.lang.Object
    extended by com.bstek.dorado.utils.codec.EscapeUtils
public final class EscapeUtils
extends java.lang.Object

用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。

Version:
4.0

Method Summary
static java.lang.String | escape(java.lang.String plainText) 对原始字符串进行编码，返回安全字符串。
static java.lang.String | unescape(java.lang.String encodedText) 对安全字符串进行解码，返回原始字符串。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

escape

public static java.lang.String escape(java.lang.String plainText)
对原始字符串进行编码，返回安全字符串。

Parameters:
plainText - 原始的字符串。
Returns:
编码后的安全字符串。

unescape

public static java.lang.String unescape(java.lang.String encodedText)
对安全字符串进行解码，返回原始字符串。

Parameters:
encodedText - 编码后的安全字符串。
Returns:
原始的字符串。
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.utils.codec

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.utils.codec

包含用于支持字符代码转换的工具类
See:
Description

Class Summary
Encrypt | 对字符串进行加密 1.
EncryptCode | 本算法只用于加密由0-9和A-Z组成的字符串，以下的提到的字符指由0-9和A-Z组成的字符；假设字符串的长度为n) 1.
EscapeUtils | 用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。
SafeCode | 用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。

Package com.bstek.dorado.utils.codec Description

包含用于支持字符代码转换的工具类


SafeCode

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.codec
Class SafeCode

java.lang.Object
    extended by com.bstek.dorado.utils.codec.SafeCode
public final class SafeCode
extends java.lang.Object

用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。

Version:
4.0

Constructor Summary
SafeCode()
Method Summary
static java.lang.String | decode(java.lang.String encodedText) 对安全字符串进行解码，返回原始字符串。
static java.lang.String | encode(java.lang.String plainText) 对原始字符串进行编码，返回安全字符串。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SafeCode

public SafeCode()
Method Detail

encode

public static java.lang.String encode(java.lang.String plainText)
对原始字符串进行编码，返回安全字符串。

Parameters:
plainText - 原始的字符串。
Returns:
编码后的安全字符串。

decode

public static java.lang.String decode(java.lang.String encodedText)
对安全字符串进行解码，返回原始字符串。

Parameters:
encodedText - 编码后的安全字符串。
Returns:
原始的字符串。
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DuplicateKeyException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.collection
Class DuplicateKeyException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.utils.collection.DuplicateKeyException
All Implemented Interfaces:
java.io.Serializable
public class DuplicateKeyException
extends DoradoRuntimeException

键值重复异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
DuplicateKeyException(java.lang.Object key)
DuplicateObjectKeyException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DuplicateKeyException

public DuplicateKeyException(java.lang.Object key)
DuplicateObjectKeyException

Parameters:
key - Object 重复的键值
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


KeyNotExistException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.collection
Class KeyNotExistException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.utils.collection.KeyNotExistException
All Implemented Interfaces:
java.io.Serializable
public class KeyNotExistException
extends DoradoRuntimeException

无效键值异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
KeyNotExistException(java.lang.Object key)
DuplicateObjectKeyException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

KeyNotExistException

public KeyNotExistException(java.lang.Object key)
DuplicateObjectKeyException

Parameters:
key - Object 无效的键值
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectCollection

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.collection
Interface ObjectCollection

All Superinterfaces:
java.lang.Cloneable
All Known Implementing Classes:
ObjectList
public interface ObjectCollection
extends java.lang.Cloneable

对象列表接口,定义对象列表的基本方法。

Version:
4.0

Method Summary
void | add(int index, java.lang.Object key, java.lang.Object object) 向对象列表中指定的位置添加一个对象
void | add(java.lang.Object key, java.lang.Object object) 向对象列表中添加一个对象。
java.lang.Object | clone() Creates and returns a copy of this object.
void | forceAdd(java.lang.Object key, java.lang.Object object) 强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。
java.lang.Object | get(int index) 返回对象列表中的一个对象。
java.lang.Object | get(java.lang.Object key) 返回对象列表中的一个对象。
java.lang.Object | getKey(int index) 返回给定的索引号对应的键值。
int | indexOf(java.lang.Object key) 返回给定的键值对应的索引号。
java.util.Iterator | iterator() 返回迭代器
java.util.List | keyList() 返回List
java.util.Map | map() 返回Map
java.lang.Object | remove(int index) 删除对象列表中的一个对象。
java.lang.Object | remove(java.lang.Object key) 删除对象列表中的一个对象。
void | removeAll() 删除对象列表中的所有对象。
void | set(int index, java.lang.Object object) 设置对象列表中的一个对象
int | size() 返回对象列表中的对象数量。

Method Detail

add

public void add(java.lang.Object key,
                java.lang.Object object)
向对象列表中添加一个对象。

Parameters:
key - 对象的键值。
object - 对象。

forceAdd

public void forceAdd(java.lang.Object key,
                     java.lang.Object object)
强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。

Parameters:
key - 对象的键值。
object - 对象。

add

public void add(int index,
                java.lang.Object key,
                java.lang.Object object)
向对象列表中指定的位置添加一个对象

Parameters:
index - int
key - Object
object - Object

get

public java.lang.Object get(java.lang.Object key)
返回对象列表中的一个对象。

Parameters:
key - 对象的键值。
Returns:
相应的对象。

get

public java.lang.Object get(int index)
返回对象列表中的一个对象。

Parameters:
index - 对象的索引号。
Returns:
相应的对象。

set

public void set(int index,
                java.lang.Object object)
设置对象列表中的一个对象

Parameters:
index - int
object - Object

indexOf

public int indexOf(java.lang.Object key)
返回给定的键值对应的索引号。

Parameters:
key - 对象的键值。
Returns:
索引号。

getKey

public java.lang.Object getKey(int index)
返回给定的索引号对应的键值。

Parameters:
index - int 对象的索引号。
Returns:
键值。

remove

public java.lang.Object remove(java.lang.Object key)
删除对象列表中的一个对象。

Parameters:
key - 对象的键值。
Returns:
Object

remove

public java.lang.Object remove(int index)
删除对象列表中的一个对象。

Parameters:
index - 对象的索引号。
Returns:
Object

removeAll

public void removeAll()
删除对象列表中的所有对象。

size

public int size()
返回对象列表中的对象数量。

Returns:
对象数量。

keyList

public java.util.List keyList()
返回List

Returns:
List

map

public java.util.Map map()
返回Map

Returns:
Map

iterator

public java.util.Iterator iterator()
返回迭代器

Returns:
Iterator

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Creates and returns a copy of this object.

Returns:
a clone of this instance.
Throws:
java.lang.CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectList

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.collection
Class ObjectList

java.lang.Object
    extended by com.bstek.dorado.utils.collection.ObjectList
All Implemented Interfaces:
java.lang.Cloneable, ObjectCollection, java.io.Serializable
public class ObjectList
extends java.lang.Object
implements ObjectCollection, java.io.Serializable

对象列表的实现。此类相当于org.apache.commons.collections.map.LinkedMap 的Adapter

Version:
4.0
See Also:
Serialized Form

Constructor Summary
ObjectList()
ObjectList
Method Summary
void | add(int index, java.lang.Object key, java.lang.Object object) 向对象列表中指定的位置添加一个对象
void | add(java.lang.Object key, java.lang.Object object) 向对象列表中添加一个对象。
java.lang.Object | clone()
boolean | equals(java.lang.Object obj)
void | forceAdd(java.lang.Object key, java.lang.Object object) 强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。
java.lang.Object | get(int index) 返回对象列表中的一个对象。
java.lang.Object | get(java.lang.Object key) 返回对象列表中的一个对象。
java.lang.Object | getKey(int index) 返回给定的索引号对应的键值。
int | hashCode() Returns a hash code value for the object.
int | indexOf(java.lang.Object key) 返回给定的键值对应的索引号。
java.util.Iterator | iterator() 返回迭代器
java.util.List | keyList() 返回List
java.util.Map | map() 返回Map
java.lang.Object | remove(int index) 删除对象列表中的一个对象。
java.lang.Object | remove(java.lang.Object key) 删除对象列表中的一个对象。
void | removeAll() 删除对象列表中的所有对象。
void | set(int index, java.lang.Object object) 设置对象列表中的一个对象
int | size() 返回对象列表中的对象数量。
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectList

public ObjectList()
ObjectList

Method Detail

add

public void add(java.lang.Object key,
                java.lang.Object object)
向对象列表中添加一个对象。

Specified by:
add in interface ObjectCollection
Parameters:
key - 对象的键值。
object - 对象。

forceAdd

public void forceAdd(java.lang.Object key,
                     java.lang.Object object)
强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。

Specified by:
forceAdd in interface ObjectCollection
Parameters:
key - 对象的键值。
object - 对象。

add

public void add(int index,
                java.lang.Object key,
                java.lang.Object object)
向对象列表中指定的位置添加一个对象

Specified by:
add in interface ObjectCollection
Parameters:
index - int
key - Object
object - Object

get

public java.lang.Object get(java.lang.Object key)
返回对象列表中的一个对象。

Specified by:
get in interface ObjectCollection
Parameters:
key - 对象的键值。
Returns:
相应的对象。

get

public java.lang.Object get(int index)
返回对象列表中的一个对象。

Specified by:
get in interface ObjectCollection
Parameters:
index - 对象的索引号。
Returns:
相应的对象。

set

public void set(int index,
                java.lang.Object object)
设置对象列表中的一个对象

Specified by:
set in interface ObjectCollection
Parameters:
index - int
object - Object

indexOf

public int indexOf(java.lang.Object key)
返回给定的键值对应的索引号。

Specified by:
indexOf in interface ObjectCollection
Parameters:
key - 对象的键值。
Returns:
索引号。

getKey

public java.lang.Object getKey(int index)
返回给定的索引号对应的键值。

Specified by:
getKey in interface ObjectCollection
Parameters:
index - int 对象的索引号。
Returns:
键值。

remove

public java.lang.Object remove(java.lang.Object key)
删除对象列表中的一个对象。

Specified by:
remove in interface ObjectCollection
Parameters:
key - 对象的键值。
Returns:
Object

remove

public java.lang.Object remove(int index)
删除对象列表中的一个对象。

Specified by:
remove in interface ObjectCollection
Parameters:
index - 对象的索引号。
Returns:
Object

removeAll

public void removeAll()
删除对象列表中的所有对象。

Specified by:
removeAll in interface ObjectCollection

size

public int size()
返回对象列表中的对象数量。

Specified by:
size in interface ObjectCollection
Returns:
对象数量。

keyList

public java.util.List keyList()
返回List

Specified by:
keyList in interface ObjectCollection
Returns:
List

map

public java.util.Map map()
返回Map

Specified by:
map in interface ObjectCollection
Returns:
Map

iterator

public java.util.Iterator iterator()
返回迭代器

Specified by:
iterator in interface ObjectCollection
Returns:
Iterator

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException

Specified by:
clone in interface ObjectCollection
Throws:
java.lang.CloneNotSupportedException

equals

public boolean equals(java.lang.Object obj)

hashCode

public int hashCode()
Returns a hash code value for the object.

Returns:
a hash code value for this object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.utils.collection

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.utils.collection

对象集合类
See:
Description

Interface Summary
ObjectCollection 对象列表接口,定义对象列表的基本方法。

Class Summary
ObjectList 对象列表的实现。

Exception Summary
DuplicateKeyException | 键值重复异常
KeyNotExistException | 无效键值异常

Package com.bstek.dorado.utils.collection Description

对象集合类


com.bstek.dorado.utils.http

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.utils.http

一些与HTTP相关的工具类
See:
Description

Class Summary
RequestHelper | 用于简化ServletRequest访问的工具类.
ResponseUtil | 与Response处理相关的工具类
UrlUtil | 与处理URL相关的工具类

Package com.bstek.dorado.utils.http Description

一些与HTTP相关的工具类


RequestHelper

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.http
Class RequestHelper

java.lang.Object
    extended by com.bstek.dorado.utils.http.RequestHelper
public class RequestHelper
extends java.lang.Object

用于简化ServletRequest访问的工具类.

Version:
4.0

Constructor Summary
RequestHelper(javax.servlet.ServletRequest request)
RequestHelper
Method Summary
protected  void attributiesToBean(java.lang.Object o)
将当前Request中包含的属性(Attribute)设置到给定的Bean当中.
 void attributiesToDO(java.lang.Object o)
将当前Request中包含的属性(Attribute)设置到给定的对象当中.
 java.util.Map attributiesToMap()
将当前Request中包含的属性(Attribute)设置到Map当中.
protected  void attributiesToMap(java.util.Map map)
将当前Request中包含的属性(Attribute)设置到给定的Map当中.
protected  void attributiesToVariantSet(VariantSet variants)
将当前Request中包含的属性(Attribute)设置到给定的VariantSet当中.
 boolean getBoolean(java.lang.String name)
按boolean方式读取一个参数
 java.util.Date getDate(java.lang.String name)
按Date方式读取一个参数
 double getDouble(java.lang.String name)
按double方式读取一个参数
 float getFloat(java.lang.String name)
按float方式读取一个参数
 int getInt(java.lang.String name)
按int方式读取一个参数
 long getLong(java.lang.String name)
按long方式读取一个参数
 java.lang.String getParameter(java.lang.String name)
getParameter
 java.lang.String getString(java.lang.String name)
按String方式读取一个参数 本方法回自动将字符串转化为Setting.xml中System.getProperty("file.encoding")所指定的编码格式.
 java.lang.String[] getStringValues(java.lang.String name)
返回参数值数组.
protected  void parametersToBean(java.lang.Object o)
将当前Request中包含的参数(Parameter)设置到给定的Bean当中.
 void parametersToDO(java.lang.Object o)
将当前Request中包含的参数(Parameter)设置到给定的对象当中.
 java.util.Map parametersToMap()
将当前Request中包含的参数(Parameter)设置到Map当中.
protected  void parametersToMap(java.util.Map map)
将当前Request中包含的参数(Parameter)设置到给定的Map当中.
protected  void parametersToVariantSet(VariantSet variants)
将当前Request中包含的参数(Parameter)设置到给定的VariantSet当中.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequestHelper

public RequestHelper(javax.servlet.ServletRequest request)
RequestHelper

Parameters:
request - ServletRequest
Method Detail

getParameter

public java.lang.String getParameter(java.lang.String name)
getParameter

Parameters:
name - String
Returns:
String

getString

public java.lang.String getString(java.lang.String name)
按String方式读取一个参数

本方法回自动将字符串转化为Setting.xml中System.getProperty("file.encoding")所指定的编码格式.

Parameters:
name - String
Returns:
String

getInt

public int getInt(java.lang.String name)
按int方式读取一个参数

Parameters:
name - String
Returns:
int

getLong

public long getLong(java.lang.String name)
按long方式读取一个参数

Parameters:
name - String
Returns:
long

getFloat

public float getFloat(java.lang.String name)
按float方式读取一个参数

Parameters:
name - String
Returns:
float

getDouble

public double getDouble(java.lang.String name)
按double方式读取一个参数

Parameters:
name - String
Returns:
double

getBoolean

public boolean getBoolean(java.lang.String name)
按boolean方式读取一个参数

Parameters:
name - String
Returns:
boolean

getDate

public java.util.Date getDate(java.lang.String name)
按Date方式读取一个参数

Parameters:
name - String
Returns:
Date

getStringValues

public java.lang.String[] getStringValues(java.lang.String name)
返回参数值数组.

本方法回自动将字符串转化为Setting.xml中System.getProperty("file.encoding")所指定的编码格式.

Parameters:
name - String
Returns:
String[]

parametersToDO

public void parametersToDO(java.lang.Object o)
                    throws java.lang.Exception
将当前Request中包含的参数(Parameter)设置到给定的对象当中.

Parameters:
o - Object
Throws:
java.lang.Exception

parametersToMap

public java.util.Map parametersToMap()
将当前Request中包含的参数(Parameter)设置到Map当中.

Returns:
Map

parametersToBean

protected void parametersToBean(java.lang.Object o)
                         throws java.lang.Exception
将当前Request中包含的参数(Parameter)设置到给定的Bean当中.

Parameters:
o - Object
Throws:
java.lang.Exception

parametersToMap

protected void parametersToMap(java.util.Map map)
将当前Request中包含的参数(Parameter)设置到给定的Map当中.

Parameters:
map - Map

parametersToVariantSet

protected void parametersToVariantSet(VariantSet variants)
将当前Request中包含的参数(Parameter)设置到给定的VariantSet当中.

Parameters:
variants - VariantSet

attributiesToDO

public void attributiesToDO(java.lang.Object o)
                     throws java.lang.Exception
将当前Request中包含的属性(Attribute)设置到给定的对象当中.

Parameters:
o - Object
Throws:
java.lang.Exception

attributiesToMap

public java.util.Map attributiesToMap()
将当前Request中包含的属性(Attribute)设置到Map当中.

Returns:
Map

attributiesToBean

protected void attributiesToBean(java.lang.Object o)
                          throws java.lang.Exception
将当前Request中包含的属性(Attribute)设置到给定的Bean当中.

Parameters:
o - Object
Throws:
java.lang.Exception

attributiesToMap

protected void attributiesToMap(java.util.Map map)
将当前Request中包含的属性(Attribute)设置到给定的Map当中.

Parameters:
map - Map

attributiesToVariantSet

protected void attributiesToVariantSet(VariantSet variants)
将当前Request中包含的属性(Attribute)设置到给定的VariantSet当中.

Parameters:
variants - VariantSet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ResponseUtil

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.http
Class ResponseUtil

java.lang.Object
    extended by com.bstek.dorado.utils.http.ResponseUtil
public final class ResponseUtil
extends java.lang.Object

与Response处理相关的工具类

Version:
4.0

Method Summary
static java.io.OutputStream | getOutputStream(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) getOutputStream
static void | output(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response, java.io.InputStream in) 将一个InputStream中的内容输出到response
static void | outputNoCompress(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response, java.io.InputStream in) 将一个InputStream中的内容输出到response.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getOutputStream

public static java.io.OutputStream getOutputStream(javax.servlet.http.HttpServletRequest request,
                                                   javax.servlet.http.HttpServletResponse response)
                                            throws java.io.IOException
getOutputStream

Parameters:
request - HttpServletRequest
response - HttpServletResponse
Returns:
OutputStream
Throws:
java.io.IOException

output

public static void output(javax.servlet.http.HttpServletRequest request,
                          javax.servlet.http.HttpServletResponse response,
                          java.io.InputStream in)
                   throws java.io.IOException
将一个InputStream中的内容输出到response

Parameters:
request - HttpServletRequest
response - HttpServletResponse
in - InputStream
Throws:
java.io.IOException

outputNoCompress

public static void outputNoCompress(javax.servlet.http.HttpServletRequest request,
                                    javax.servlet.http.HttpServletResponse response,
                                    java.io.InputStream in)
                             throws java.io.IOException
将一个InputStream中的内容输出到response. 此方法不使用压缩算法。

Parameters:
request - HttpServletRequest
response - HttpServletResponse
in - InputStream
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UrlUtil

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.http
Class UrlUtil

java.lang.Object
    extended by com.bstek.dorado.utils.http.UrlUtil
public final class UrlUtil
extends java.lang.Object

与处理URL相关的工具类

Version:
4.0

Method Summary
static java.lang.String trimEndSeparator(java.lang.String s)
移除字符串两端的URL分隔符，即移除字符串两端的'/'。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

trimEndSeparator

public static java.lang.String trimEndSeparator(java.lang.String s)
移除字符串两端的URL分隔符，即移除字符串两端的'/'。

Parameters:
s - String
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DataType

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.variant
Class DataType

java.lang.Object
    extended by com.bstek.dorado.utils.variant.DataType
public final class DataType
extends java.lang.Object

数据类型

Version:
4.0

Field Summary
static int | BIGDECIMAL 数据类型 - BigDecimal型。
static java.lang.String | BIGDECIMAL_NAME 数据类型名称 - BigDecimal型。
static int | BINARY 数据类型 - 二进制型。
static java.lang.String | BINARY_NAME 数据类型名称 - 二进制型。
static int | BOOLEAN 数据类型 - boolean型。
static java.lang.String | BOOLEAN_NAME 数据类型名称 - boolean型。
static int | BYTE 数据类型 - byte型。
static java.lang.String | BYTE_NAME 数据类型名称 - byte型。
static int | DATE 数据类型 - Date型。
static java.lang.String | DATE_NAME 数据类型名称 - Date型。
static int | DATETIME 数据类型 - DateTime型。
static java.lang.String | DATETIME_NAME 数据类型名称 - DateTime型。
static int | DOUBLE 数据类型 - double型。
static java.lang.String | DOUBLE_NAME 数据类型名称 - double型。
static int | FLOAT 数据类型 - float型。
static java.lang.String | FLOAT_NAME 数据类型名称 - float型。
static int | INT 数据类型 - int型。
static java.lang.String | INT_NAME 数据类型名称 - int型。
static int | LONG 数据类型 - long型。
static java.lang.String | LONG_NAME 数据类型名称 - long型。
static int | SHORT 数据类型 - short型。
static java.lang.String | SHORT_NAME 数据类型名称 - short型。
static int | STRING 数据类型 - String型。
static java.lang.String | STRING_NAME 数据类型名称名称 - String型。
static int | TIME 数据类型 - Time型。
static java.lang.String | TIME_NAME 数据类型名称 - Time型。
static int | UNKNOWN 数据类型 - 未知类型。
static java.lang.String | UNKNOWN_NAME 数据类型名称 - 未知类型。
Method Summary
static boolean | isBaseDataType(java.lang.Class clazz) 判断一个Class类型是否是基本的dorado可以直接处理的简单类型
static int | nameToType(java.lang.String name) nameToType
static int | parse(java.lang.Class clazz) 将一个Class类型翻译为Dorado的DataType
static java.lang.String | typeToName(int type) typeToName
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNKNOWN_NAME

public static final java.lang.String UNKNOWN_NAME
数据类型名称 - 未知类型。

See Also:
Constant Field Values

UNKNOWN

public static final int UNKNOWN
数据类型 - 未知类型。

See Also:
Constant Field Values

STRING_NAME

public static final java.lang.String STRING_NAME
数据类型名称名称 - String型。

See Also:
Constant Field Values

STRING

public static final int STRING
数据类型 - String型。

See Also:
Constant Field Values

BYTE_NAME

public static final java.lang.String BYTE_NAME
数据类型名称 - byte型。

See Also:
Constant Field Values

BYTE

public static final int BYTE
数据类型 - byte型。

See Also:
Constant Field Values

SHORT_NAME

public static final java.lang.String SHORT_NAME
数据类型名称 - short型。

See Also:
Constant Field Values

SHORT

public static final int SHORT
数据类型 - short型。

See Also:
Constant Field Values

INT_NAME

public static final java.lang.String INT_NAME
数据类型名称 - int型。

See Also:
Constant Field Values

INT

public static final int INT
数据类型 - int型。

See Also:
Constant Field Values

LONG_NAME

public static final java.lang.String LONG_NAME
数据类型名称 - long型。

See Also:
Constant Field Values

LONG

public static final int LONG
数据类型 - long型。

See Also:
Constant Field Values

FLOAT_NAME

public static final java.lang.String FLOAT_NAME
数据类型名称 - float型。

See Also:
Constant Field Values

FLOAT

public static final int FLOAT
数据类型 - float型。

See Also:
Constant Field Values

DOUBLE_NAME

public static final java.lang.String DOUBLE_NAME
数据类型名称 - double型。

See Also:
Constant Field Values

DOUBLE

public static final int DOUBLE
数据类型 - double型。

See Also:
Constant Field Values

BIGDECIMAL_NAME

public static final java.lang.String BIGDECIMAL_NAME
数据类型名称 - BigDecimal型。

See Also:
Constant Field Values

BIGDECIMAL

public static final int BIGDECIMAL
数据类型 - BigDecimal型。

See Also:
Constant Field Values

BOOLEAN_NAME

public static final java.lang.String BOOLEAN_NAME
数据类型名称 - boolean型。

See Also:
Constant Field Values

BOOLEAN

public static final int BOOLEAN
数据类型 - boolean型。

See Also:
Constant Field Values

DATE_NAME

public static final java.lang.String DATE_NAME
数据类型名称 - Date型。

See Also:
Constant Field Values

DATE

public static final int DATE
数据类型 - Date型。

See Also:
Constant Field Values

TIME_NAME

public static final java.lang.String TIME_NAME
数据类型名称 - Time型。

See Also:
Constant Field Values

TIME

public static final int TIME
数据类型 - Time型。

See Also:
Constant Field Values

DATETIME_NAME

public static final java.lang.String DATETIME_NAME
数据类型名称 - DateTime型。

See Also:
Constant Field Values

DATETIME

public static final int DATETIME
数据类型 - DateTime型。

See Also:
Constant Field Values

BINARY_NAME

public static final java.lang.String BINARY_NAME
数据类型名称 - 二进制型。

See Also:
Constant Field Values

BINARY

public static final int BINARY
数据类型 - 二进制型。

See Also:
Constant Field Values
Method Detail

isBaseDataType

public static boolean isBaseDataType(java.lang.Class clazz)
判断一个Class类型是否是基本的dorado可以直接处理的简单类型

Parameters:
clazz - Class
Returns:
boolean

parse

public static int parse(java.lang.Class clazz)
将一个Class类型翻译为Dorado的DataType

Parameters:
clazz - Class
Returns:
String

nameToType

public static int nameToType(java.lang.String name)
nameToType

Parameters:
name - String
Returns:
int

typeToName

public static java.lang.String typeToName(int type)
typeToName

Parameters:
type - int
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.utils.variant

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.utils.variant

包含用于实现多态数据类型的类
See:
Description

Class Summary
DataType | 数据类型
Variant | 可支持多种类型的对象
VariantHelper | Variant的一些辅助操作
VariantSet | 可支持多种类型的对象集合。

Package com.bstek.dorado.utils.variant Description

包含用于实现多态数据类型的类


Variant

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.variant
Class Variant

java.lang.Object
    extended by com.bstek.dorado.utils.variant.Variant
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
public class Variant
extends java.lang.Object
implements java.io.Serializable, java.lang.Cloneable

可支持多种类型的对象

Version:
4.0
See Also:
Serialized Form

Constructor Summary
Variant()
Variant
Variant(int dataType)
Variant
Method Summary
protected java.lang.Object | clone() Creates and returns a copy of this object.
boolean | equals(java.lang.Object obj) Indicates whether some other object is "equal to" this one.
java.math.BigDecimal | getBigDecimal() 按BigDecimal类型读取数据
boolean | getBoolean() 按boolean类型读取数据
byte | getByte() 按byte类型读取数据
int | getDataType() getDataType
java.util.Date | getDate() 按Date类型读取数据
double | getDouble() 按double类型读取数据
float | getFloat() 按float类型读取数据
int | getInt() 按int类型读取数据
long | getLong() 按long类型读取数据
short | getShort() 按short类型读取数据
java.lang.String | getString() 按String类型读取数据
java.lang.Object | getValue() 按Object类型读取数据
int | hashCode() Returns a hash code value for the object.
boolean | isNull() 是否为空(null)
void | setBigDecimal(java.math.BigDecimal value) 设置BigDecimal类型的数据
void | setBoolean(boolean value) 设置boolean类型的数据
void | setByte(byte value) 设置byte类型的数据
void | setDataType(int dataType) setDataType
void | setDataType(java.lang.String dataType) setDataType
void | setDate(java.util.Date value) 设置Date类型的数据
void | setDouble(double value) 设置double类型的数据
void | setFloat(float value) 设置float类型的数据
void | setInt(int value) 设置int类型的数据
void | setLong(long value) 设置long类型的数据
void | setNull() 设置为空(null)
void | setShort(short value) 设置short类型的数据
void | setString(java.lang.String value) 设置String类型的数据
void | setValue(java.lang.Object value) 设置Object类型的数据
java.lang.String | toString() Returns a string representation of the object.
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

Variant

public Variant()
Variant

Variant

public Variant(int dataType)
Variant

Parameters:
dataType - int
Method Detail

getDataType

public int getDataType()
getDataType

Returns:
int

setDataType

public void setDataType(int dataType)
setDataType

Parameters:
dataType - int

setDataType

public void setDataType(java.lang.String dataType)
setDataType

Parameters:
dataType - String

getValue

public java.lang.Object getValue()
按Object类型读取数据

Returns:
Object

setValue

public void setValue(java.lang.Object value)
设置Object类型的数据

Parameters:
value - Object

getString

public java.lang.String getString()
按String类型读取数据

Returns:
Object

setString

public void setString(java.lang.String value)
设置String类型的数据

Parameters:
value - String

getByte

public byte getByte()
按byte类型读取数据

Returns:
Object

setByte

public void setByte(byte value)
设置byte类型的数据

Parameters:
value - byte

getShort

public short getShort()
按short类型读取数据

Returns:
Object

setShort

public void setShort(short value)
设置short类型的数据

Parameters:
value - short

getInt

public int getInt()
按int类型读取数据

Returns:
Object

setInt

public void setInt(int value)
设置int类型的数据

Parameters:
value - int

getLong

public long getLong()
按long类型读取数据

Returns:
Object

setLong

public void setLong(long value)
设置long类型的数据

Parameters:
value - long

getFloat

public float getFloat()
按float类型读取数据

Returns:
Object

setFloat

public void setFloat(float value)
设置float类型的数据

Parameters:
value - float

getDouble

public double getDouble()
按double类型读取数据

Returns:
Object

setDouble

public void setDouble(double value)
设置double类型的数据

Parameters:
value - double

getBigDecimal

public java.math.BigDecimal getBigDecimal()
按BigDecimal类型读取数据

Returns:
Object

setBigDecimal

public void setBigDecimal(java.math.BigDecimal value)
设置BigDecimal类型的数据

Parameters:
value - BigDecimal

getBoolean

public boolean getBoolean()
按boolean类型读取数据

Returns:
Object

setBoolean

public void setBoolean(boolean value)
设置boolean类型的数据

Parameters:
value - boolean

getDate

public java.util.Date getDate()
按Date类型读取数据

Returns:
Object

setDate

public void setDate(java.util.Date value)
设置Date类型的数据

Parameters:
value - Date

isNull

public boolean isNull()
是否为空(null)

Returns:
boolean

setNull

public void setNull()
设置为空(null)

toString

public java.lang.String toString()
Returns a string representation of the object.

Returns:
a string representation of the object.

equals

public boolean equals(java.lang.Object obj)
Indicates whether some other object is "equal to" this one.

Parameters:
obj - the reference object with which to compare.
Returns:
true if this object is the same as the obj argument; false otherwise.

hashCode

public int hashCode()
Returns a hash code value for the object.

Returns:
a hash code value for this object.

clone

protected java.lang.Object clone()
                          throws java.lang.CloneNotSupportedException
Creates and returns a copy of this object.

Returns:
a clone of this instance.
Throws:
java.lang.CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VariantHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.variant
Class VariantHelper

java.lang.Object
    extended by com.bstek.dorado.utils.variant.VariantHelper
public final class VariantHelper
extends java.lang.Object

Variant的一些辅助操作

Version:
4.0

Method Summary
static java.math.BigDecimal | parseBigDecimal(java.lang.Object o) parseBigDecimal
static boolean | parseBoolean(java.lang.Object o) parseBoolean
static boolean | parseBoolean(java.lang.String s) 将一个字符串翻译成逻辑值。
static byte | parseByte(java.lang.Object o) parseByte
static java.util.Date | parseDate(java.lang.Object o) parseDate
static double | parseDouble(java.lang.Object o) parseDouble
static float | parseFloat(java.lang.Object o) parseFloat
static int | parseInt(java.lang.Object o) parseInt
static long | parseLong(java.lang.Object o) parseLong
static short | parseShort(java.lang.Object o) parseShort
static java.lang.String | parseString(java.lang.Object o) parseString
static java.lang.Object | toObject(java.math.BigDecimal value) toObject
static java.lang.Object | toObject(boolean value) toDouble
static java.lang.Object | toObject(byte value) toObject
static java.lang.Object | toObject(java.util.Date value) toObject
static java.lang.Object | toObject(double value) toDouble
static java.lang.Object | toObject(float value) toObject
static java.lang.Object | toObject(int value) toObject
static java.lang.Object | toObject(long value) toObject
static java.lang.Object | toObject(short value) toObject
static java.lang.Object | toObject(java.lang.String value) toObject
static java.lang.Object | translate(int dataType, java.lang.Object value) translate
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

toObject

public static java.lang.Object toObject(byte value)
toObject

Parameters:
value - byte
Returns:
Object

toObject

public static java.lang.Object toObject(short value)
toObject

Parameters:
value - short
Returns:
Object

toObject

public static java.lang.Object toObject(int value)
toObject

Parameters:
value - int
Returns:
Object

toObject

public static java.lang.Object toObject(long value)
toObject

Parameters:
value - long
Returns:
Object

toObject

public static java.lang.Object toObject(float value)
toObject

Parameters:
value - float
Returns:
Object

toObject

public static java.lang.Object toObject(double value)
toDouble

Parameters:
value - double
Returns:
Object

toObject

public static java.lang.Object toObject(boolean value)
toDouble

Parameters:
value - boolean
Returns:
Object

toObject

public static java.lang.Object toObject(java.util.Date value)
toObject

Parameters:
value - Date
Returns:
Object

toObject

public static java.lang.Object toObject(java.math.BigDecimal value)
toObject

Parameters:
value - BigDecimal
Returns:
Object

toObject

public static java.lang.Object toObject(java.lang.String value)
toObject

Parameters:
value - String
Returns:
Object

parseString

public static java.lang.String parseString(java.lang.Object o)
parseString

Parameters:
o - Object
Returns:
String

parseByte

public static byte parseByte(java.lang.Object o)
parseByte

Parameters:
o - Object
Returns:
byte

parseShort

public static short parseShort(java.lang.Object o)
parseShort

Parameters:
o - Object
Returns:
short

parseInt

public static int parseInt(java.lang.Object o)
parseInt

Parameters:
o - Object
Returns:
int

parseLong

public static long parseLong(java.lang.Object o)
parseLong

Parameters:
o - Object
Returns:
long

parseFloat

public static float parseFloat(java.lang.Object o)
parseFloat

Parameters:
o - Object
Returns:
float

parseDouble

public static double parseDouble(java.lang.Object o)
parseDouble

Parameters:
o - Object
Returns:
double

parseBigDecimal

public static java.math.BigDecimal parseBigDecimal(java.lang.Object o)
parseBigDecimal

Parameters:
o - Object
Returns:
BigDecimal

parseBoolean

public static boolean parseBoolean(java.lang.String s)
将一个字符串翻译成逻辑值。在dorado中true（不区分大小写）、1、-1被认为代表逻辑true。

Parameters:
s - String
Returns:
boolean

parseBoolean

public static boolean parseBoolean(java.lang.Object o)
parseBoolean

Parameters:
o - Object
Returns:
boolean

parseDate

public static java.util.Date parseDate(java.lang.Object o)
parseDate

Parameters:
o - Object
Returns:
Date

translate

public static java.lang.Object translate(int dataType,
                                         java.lang.Object value)
translate

Parameters:
dataType - int
value - Object
Returns:
Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VariantSet

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.variant
Class VariantSet

java.lang.Object
    extended by com.bstek.dorado.utils.variant.VariantSet
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
Direct Known Subclasses:
CaseInsensitiveVariantSet, MetaData, ParameterSet
public class VariantSet
extends java.lang.Object
implements java.io.Serializable, java.lang.Cloneable

可支持多种类型的对象集合。其功能类似于一个功能增强了的Map。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
VariantSet()
构造器
Method Summary
void | assign(VariantSet variants) 将本集合中的所有数据全部指派到给定的另一个集合中.
void | clear() 清除本集合中所有的数据.
java.lang.Object | clone() Creates and returns a copy of this object.
int | count() 返回集合中数值的总数量.
boolean | equals(java.lang.Object obj) Indicates whether some other object is "equal to" this one.
boolean | exists(java.lang.String name) 判断给定键值下是否存有数值.
java.math.BigDecimal | getBigDecimal(int index) 根据索引号并按BigDecimel类型读取数据
java.math.BigDecimal | getBigDecimal(java.lang.String name) 根据键值并按BigDecimal类型读取数据
boolean | getBoolean(int index) 根据索引号并按boolean类型读取数据
boolean | getBoolean(java.lang.String name) 根据键值并按boolean类型读取数据
byte | getByte(int index) 根据索引号并按byte类型读取数据
byte | getByte(java.lang.String name) 根据键值并按byte类型读取数据
int | getDataType(int index) 根据索引号返回默认数据类型
int | getDataType(java.lang.String name) 根据键值返回默认数据类型
java.util.Date | getDate(int index) 根据索引号并按Date类型读取数据
java.util.Date | getDate(java.lang.String name) 根据键值并按Date类型读取数据
double | getDouble(int index) 根据索引号并按double类型读取数据
double | getDouble(java.lang.String name) 根据键值并按double类型读取数据
float | getFloat(int index) 根据索引号并按float类型读取数据
float | getFloat(java.lang.String name) 根据键值并按float类型读取数据
int | getInt(int index) 根据索引号并按int类型读取数据
int | getInt(java.lang.String name) 根据键值并按int类型读取数据
long | getLong(int index) 根据索引号并按long类型读取数据
long | getLong(java.lang.String name) 根据键值并按long类型读取数据
short | getShort(int index) 根据索引号并按short类型读取数据
short | getShort(java.lang.String name) 根据键值并按short类型读取数据
java.lang.String | getString(int index) 根据索引号并按String类型读取数据
java.lang.String | getString(java.lang.String name) 根据键值并按String类型读取数据
java.lang.Object | getValue(int index) 根据索引号并按Object类型读取数据
java.lang.Object | getValue(java.lang.String name) 根据键值并按Object类型读取数据
Variant | getVariant(int index) 根据索引号并按Variant类型读取数据
Variant | getVariant(java.lang.String name) 根据键值并按Variant类型读取数据
int | hashCode() Returns a hash code value for the object.
java.lang.String | indexToName(int index) 返回给定的索引号对应的键值.
boolean | isNull(int index) 判断给定索引号下的数值是否为空(null)
boolean | isNull(java.lang.String name) 判断给定键值下的数值是否为空(null)
void | remove(int index) 删除给定索引号及其下的数值.
void | remove(java.lang.String name) 删除给定键值及其下的数值.
void | setBigDecimal(int index, java.math.BigDecimal value) 根据索引号设置BigDecimal类型的数据
void | setBigDecimal(java.lang.String name, java.math.BigDecimal value) 根据键值设置BigDecimal类型的数据
void | setBoolean(int index, boolean value) 根据索引号设置boolean类型的数据
void | setBoolean(java.lang.String name, boolean value) 根据键值设置boolean类型的数据
void | setByte(int index, byte value) 根据索引号设置byte类型的数据
void | setByte(java.lang.String name, byte value) 根据键值设置byte类型的数据
void | setDataType(int index, int dataType) 根据索引号设置默认数据类型
void | setDataType(int index, java.lang.String dataType) 根据索引号设置默认数据类型
void | setDataType(java.lang.String name, int dataType) 根据键值设置默认数据类型
void | setDataType(java.lang.String name, java.lang.String dataType) 根据键值设置默认数据类型
void | setDate(int index, java.util.Date value) 根据索引号设置Date类型的数据
void | setDate(java.lang.String name, java.util.Date value) 根据键值设置Date类型的数据
void | setDouble(int index, double value) 根据索引号设置double类型的数据
void | setDouble(java.lang.String name, double value) 根据键值设置double类型的数据
void | setFloat(int index, float value) 根据索引号设置float类型的数据
void | setFloat(java.lang.String name, float value) 根据键值设置float类型的数据
void | setInt(int index, int value) 根据索引号设置int类型的数据
void | setInt(java.lang.String name, int value) 根据键值设置int类型的数据
void | setLong(int index, long value) 根据索引号设置long类型的数据
void | setLong(java.lang.String name, long value) 根据键值设置long类型的数据
void | setNull(int index) 设置给定索引号下的数值为空(null)
void | setNull(java.lang.String name) 设置给定键值下的数值为空(null)
void | setShort(int index, short value) 根据索引号设置short类型的数据
void | setShort(java.lang.String name, short value) 根据键值设置short类型的数据
void | setString(int index, java.lang.String value) 根据索引号设置String类型的数据
void | setString(java.lang.String name, java.lang.String value) 根据键值设置String类型的数据
void | setValue(int index, java.lang.Object value) 根据索引号设置Object类型的数据
void | setValue(java.lang.String name, java.lang.Object value) 根据键值设置Object类型的数据
void | setVariant(java.lang.String name, Variant v) 根据键值设置Variant类型的数据
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VariantSet

public VariantSet()
构造器

Method Detail

exists

public boolean exists(java.lang.String name)
判断给定键值下是否存有数值.

Parameters:
name - name
Returns:
boolean

assign

public void assign(VariantSet variants)
将本集合中的所有数据全部指派到给定的另一个集合中.

Parameters:
variants - VariantSet

clear

public void clear()
清除本集合中所有的数据.

getVariant

public Variant getVariant(int index)
根据索引号并按Variant类型读取数据

Parameters:
index - int
Returns:
Variant

getVariant

public Variant getVariant(java.lang.String name)
根据键值并按Variant类型读取数据

Parameters:
name - String
Returns:
Variant

getDataType

public int getDataType(int index)
根据索引号返回默认数据类型

Parameters:
index - int
Returns:
int

setDataType

public void setDataType(int index,
                        int dataType)
根据索引号设置默认数据类型

Parameters:
index - int
dataType - int

setDataType

public void setDataType(int index,
                        java.lang.String dataType)
根据索引号设置默认数据类型

Parameters:
index - int
dataType - String

getDataType

public int getDataType(java.lang.String name)
根据键值返回默认数据类型

Parameters:
name - String
Returns:
int

setDataType

public void setDataType(java.lang.String name,
                        int dataType)
根据键值设置默认数据类型

Parameters:
name - String
dataType - int

setDataType

public void setDataType(java.lang.String name,
                        java.lang.String dataType)
根据键值设置默认数据类型

Parameters:
name - String
dataType - String

getValue

public java.lang.Object getValue(int index)
根据索引号并按Object类型读取数据

Parameters:
index - String
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(int index)
根据索引号并按BigDecimel类型读取数据

Parameters:
index - String
Returns:
BigDecimel

getBoolean

public boolean getBoolean(int index)
根据索引号并按boolean类型读取数据

Parameters:
index - String
Returns:
boolean

getByte

public byte getByte(int index)
根据索引号并按byte类型读取数据

Parameters:
index - String
Returns:
byte

getDate

public java.util.Date getDate(int index)
根据索引号并按Date类型读取数据

Parameters:
index - String
Returns:
Date

getDouble

public double getDouble(int index)
根据索引号并按double类型读取数据

Parameters:
index - String
Returns:
double

getFloat

public float getFloat(int index)
根据索引号并按float类型读取数据

Parameters:
index - String
Returns:
float

getInt

public int getInt(int index)
根据索引号并按int类型读取数据

Parameters:
index - String
Returns:
int

getLong

public long getLong(int index)
根据索引号并按long类型读取数据

Parameters:
index - String
Returns:
long

getShort

public short getShort(int index)
根据索引号并按short类型读取数据

Parameters:
index - String
Returns:
short

getString

public java.lang.String getString(int index)
根据索引号并按String类型读取数据

Parameters:
index - String
Returns:
String

setValue

public void setValue(int index,
                     java.lang.Object value)
根据索引号设置Object类型的数据

Parameters:
index - int
value - Object

setBigDecimal

public void setBigDecimal(int index,
                          java.math.BigDecimal value)
根据索引号设置BigDecimal类型的数据

Parameters:
index - int
value - BigDecimal

setBoolean

public void setBoolean(int index,
                       boolean value)
根据索引号设置boolean类型的数据

Parameters:
index - int
value - boolean

setByte

public void setByte(int index,
                    byte value)
根据索引号设置byte类型的数据

Parameters:
index - int
value - byte

setDate

public void setDate(int index,
                    java.util.Date value)
根据索引号设置Date类型的数据

Parameters:
index - int
value - Date

setDouble

public void setDouble(int index,
                      double value)
根据索引号设置double类型的数据

Parameters:
index - int
value - double

setFloat

public void setFloat(int index,
                     float value)
根据索引号设置float类型的数据

Parameters:
index - int
value - float

setInt

public void setInt(int index,
                   int value)
根据索引号设置int类型的数据

Parameters:
index - int
value - int

setLong

public void setLong(int index,
                    long value)
根据索引号设置long类型的数据

Parameters:
index - int
value - long

setShort

public void setShort(int index,
                     short value)
根据索引号设置short类型的数据

Parameters:
index - int
value - short

setString

public void setString(int index,
                      java.lang.String value)
根据索引号设置String类型的数据

Parameters:
index - int
value - String

getValue

public java.lang.Object getValue(java.lang.String name)
根据键值并按Object类型读取数据

Parameters:
name - String
Returns:
Object

getBigDecimal

public java.math.BigDecimal getBigDecimal(java.lang.String name)
根据键值并按BigDecimal类型读取数据

Parameters:
name - String
Returns:
BigDecimal

getBoolean

public boolean getBoolean(java.lang.String name)
根据键值并按boolean类型读取数据

Parameters:
name - String
Returns:
boolean

getByte

public byte getByte(java.lang.String name)
根据键值并按byte类型读取数据

Parameters:
name - String
Returns:
byte

getDate

public java.util.Date getDate(java.lang.String name)
根据键值并按Date类型读取数据

Parameters:
name - String
Returns:
Date

getDouble

public double getDouble(java.lang.String name)
根据键值并按double类型读取数据

Parameters:
name - String
Returns:
double

getFloat

public float getFloat(java.lang.String name)
根据键值并按float类型读取数据

Parameters:
name - String
Returns:
float

getInt

public int getInt(java.lang.String name)
根据键值并按int类型读取数据

Parameters:
name - String
Returns:
int

getLong

public long getLong(java.lang.String name)
根据键值并按long类型读取数据

Parameters:
name - String
Returns:
long

getShort

public short getShort(java.lang.String name)
根据键值并按short类型读取数据

Parameters:
name - String
Returns:
short

getString

public java.lang.String getString(java.lang.String name)
根据键值并按String类型读取数据

Parameters:
name - String
Returns:
String

setVariant

public void setVariant(java.lang.String name,
                       Variant v)
根据键值设置Variant类型的数据

Parameters:
name - String
v - Variant

setValue

public void setValue(java.lang.String name,
                     java.lang.Object value)
根据键值设置Object类型的数据

Parameters:
name - String
value - Object

setBigDecimal

public void setBigDecimal(java.lang.String name,
                          java.math.BigDecimal value)
根据键值设置BigDecimal类型的数据

Parameters:
name - String
value - BigDecimal

setBoolean

public void setBoolean(java.lang.String name,
                       boolean value)
根据键值设置boolean类型的数据

Parameters:
name - String
value - boolean

setByte

public void setByte(java.lang.String name,
                    byte value)
根据键值设置byte类型的数据

Parameters:
name - String
value - byte

setDate

public void setDate(java.lang.String name,
                    java.util.Date value)
根据键值设置Date类型的数据

Parameters:
name - String
value - Date

setDouble

public void setDouble(java.lang.String name,
                      double value)
根据键值设置double类型的数据

Parameters:
name - String
value - double

setFloat

public void setFloat(java.lang.String name,
                     float value)
根据键值设置float类型的数据

Parameters:
name - String
value - float

setInt

public void setInt(java.lang.String name,
                   int value)
根据键值设置int类型的数据

Parameters:
name - String
value - int

setLong

public void setLong(java.lang.String name,
                    long value)
根据键值设置long类型的数据

Parameters:
name - String
value - long

setShort

public void setShort(java.lang.String name,
                     short value)
根据键值设置short类型的数据

Parameters:
name - String
value - short

setString

public void setString(java.lang.String name,
                      java.lang.String value)
根据键值设置String类型的数据

Parameters:
name - String
value - String

isNull

public boolean isNull(int index)
判断给定索引号下的数值是否为空(null)

Parameters:
index - int
Returns:
boolean

setNull

public void setNull(int index)
设置给定索引号下的数值为空(null)

Parameters:
index - int

isNull

public boolean isNull(java.lang.String name)
判断给定键值下的数值是否为空(null)

Parameters:
name - String
Returns:
boolean

setNull

public void setNull(java.lang.String name)
设置给定键值下的数值为空(null)

Parameters:
name - String

remove

public void remove(int index)
删除给定索引号及其下的数值.

Parameters:
index - int

remove

public void remove(java.lang.String name)
删除给定键值及其下的数值.

Parameters:
name - String

count

public int count()
返回集合中数值的总数量.

Returns:
int

indexToName

public java.lang.String indexToName(int index)
返回给定的索引号对应的键值.

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
Creates and returns a copy of this object.

Returns:
a clone of this instance.
Throws:
java.lang.CloneNotSupportedException - if the object's class does not support the Cloneable interface. Subclasses that override the clone method can also throw this exception to indicate that an instance cannot be cloned.

equals

public boolean equals(java.lang.Object obj)
Indicates whether some other object is "equal to" this one.

Parameters:
obj - the reference object with which to compare.
Returns:
true if this object is the same as the obj argument; false otherwise.

hashCode

public int hashCode()
Returns a hash code value for the object.

Returns:
a hash code value for this object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LoadXmlPropertyException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Class LoadXmlPropertyException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by com.bstek.dorado.utils.DoradoException
                extended by com.bstek.dorado.utils.xml.LoadXmlPropertyException
All Implemented Interfaces:
java.io.Serializable
public class LoadXmlPropertyException
extends DoradoException

加载XML属性时发生的异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
LoadXmlPropertyException()
LoadXmlPropertyException
LoadXmlPropertyException(java.lang.String message)
LoadXmlPropertyException
LoadXmlPropertyException(java.lang.Throwable t)
LoadXmlPropertyException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LoadXmlPropertyException

public LoadXmlPropertyException()
LoadXmlPropertyException

LoadXmlPropertyException

public LoadXmlPropertyException(java.lang.String message)
LoadXmlPropertyException

Parameters:
message - String

LoadXmlPropertyException

public LoadXmlPropertyException(java.lang.Throwable t)
LoadXmlPropertyException

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.utils.xml

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.utils.xml

与XML相关的工具类
See:
Description

Interface Summary
XmlBuilder | XML构造器的接口
XmlDocument | 用于封装第三方的XML解析器中的文档对象。
XmlNode | 用于封装第三方的XML解析器中的XML节点对象。
XmlOutputter | XML输出器的接口。

Class Summary
XmlConfigUtils | 用于辅助XML到Object解析过程的工具类。
XmlFactory | XML解析对象的工厂类。

Exception Summary
LoadXmlPropertyException | 加载XML属性时发生的异常
XmlParseException | Xml解析异常

Package com.bstek.dorado.utils.xml Description

与XML相关的工具类


XmlBuilder

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Interface XmlBuilder

public interface XmlBuilder

XML构造器的接口

Version:
4.0

Method Summary
XmlDocument | buildDocument(java.io.File file) 利用文件对象创建XmlDocument对象
XmlDocument | buildDocument(java.io.InputStream in) 创建XmlDocument对象
XmlDocument | buildDocument(java.lang.String s) 创建XmlDocument对象
XmlDocument | newDocument() 创建一个空的XmlDocument对象
XmlNode | newNode(java.lang.String name) 创建一个空的XmlNode对象

Method Detail

newDocument

public XmlDocument newDocument()
创建一个空的XmlDocument对象

Returns:
XmlDocument

newNode

public XmlNode newNode(java.lang.String name)
创建一个空的XmlNode对象

Parameters:
name - String
Returns:
XmlNode

buildDocument

public XmlDocument buildDocument(java.lang.String s)
                          throws java.io.IOException,
                                 XmlParseException
创建XmlDocument对象

Parameters:
s - InputStream
Returns:
XmlDocument
Throws:
java.io.IOException
XmlParseException

buildDocument

public XmlDocument buildDocument(java.io.InputStream in)
                          throws java.io.IOException,
                                 XmlParseException
创建XmlDocument对象

Parameters:
in - InputStream
Returns:
XmlDocument
Throws:
java.io.IOException
XmlParseException

buildDocument

public XmlDocument buildDocument(java.io.File file)
                          throws java.io.IOException,
                                 java.io.FileNotFoundException,
                                 XmlParseException
利用文件对象创建XmlDocument对象

Parameters:
file - File
Returns:
XmlDocument
Throws:
java.io.IOException
java.io.FileNotFoundException
XmlParseException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlConfigUtils

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Class XmlConfigUtils

java.lang.Object
    extended by com.bstek.dorado.utils.xml.XmlConfigUtils
public final class XmlConfigUtils
extends java.lang.Object

用于辅助XML到Object解析过程的工具类。

Version:
4.0

Method Summary
static void | loadAttributies(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | loadAttributies(XmlNode node, java.lang.Object o, java.lang.String except) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | loadAttributies(XmlNode node, java.lang.Object o, java.lang.String[] excepts) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | loadChildNodes(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | loadChildNodes(XmlNode node, java.lang.Object o, java.lang.String except) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | loadChildNodes(XmlNode node, java.lang.Object o, java.lang.String[] excepts) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | loadChildProperties(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | loadChildProperties(XmlNode node, java.util.Properties properties) 根据名称自动读取一个XML节点下的所有子节点中的值到Properties对象中。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

loadAttributies

public static void loadAttributies(XmlNode node,
                                   java.lang.Object o)
                            throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。

Parameters:
node - XmlNode
o - Object
Throws:
LoadXmlPropertyException

loadAttributies

public static void loadAttributies(XmlNode node,
                                   java.lang.Object o,
                                   java.lang.String except)
                            throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。 同时指定一个不必读取的属性。

Parameters:
node - XmlNode
o - Object
except - String
Throws:
LoadXmlPropertyException

loadAttributies

public static void loadAttributies(XmlNode node,
                                   java.lang.Object o,
                                   java.lang.String[] excepts)
                            throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。 同时指定一组不必读取的属性。

Parameters:
node - XmlNode
o - Object
excepts - String[]
Throws:
LoadXmlPropertyException

loadChildNodes

public static void loadChildNodes(XmlNode node,
                                  java.lang.Object o)
                           throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。

Parameters:
node - XmlNode
o - Object
Throws:
LoadXmlPropertyException

loadChildNodes

public static void loadChildNodes(XmlNode node,
                                  java.lang.Object o,
                                  java.lang.String except)
                           throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。 同时指定一个不必读取的属性。

Parameters:
node - XmlNode
o - Object
except - String
Throws:
LoadXmlPropertyException

loadChildNodes

public static void loadChildNodes(XmlNode node,
                                  java.lang.Object o,
                                  java.lang.String[] excepts)
                           throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。 同时指定一组不必读取的属性。

Parameters:
node - XmlNode
o - Object
excepts - String[]
Throws:
LoadXmlPropertyException

loadChildProperties

public static void loadChildProperties(XmlNode node,
                                       java.lang.Object o)
                                throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。 此方法专用于读取这样的节点：

Parameters:
node - XmlNode
o - Object
Throws:
LoadXmlPropertyException

loadChildProperties

public static void loadChildProperties(XmlNode node,
                                       java.util.Properties properties)
                                throws LoadXmlPropertyException
根据名称自动读取一个XML节点下的所有子节点中的值到Properties对象中。 此方法专用于读取这样的节点：

Parameters:
node - XmlNode
properties - Properties
Throws:
LoadXmlPropertyException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlDocument

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Interface XmlDocument

public interface XmlDocument

用于封装第三方的XML解析器中的文档对象。

Version:
4.0

Method Summary
XmlNode | createRootNode(java.lang.String name) 创建根节点。
XmlNode | getNodeById(java.lang.String id) 根据ID返回一个节点，如果无法找到匹配的节点则返回null。
XmlNode | getNodeByXPath(java.lang.String xpath) 根据XPath返回第一个匹配的节点。
XmlNode[] | getNodesByXPath(java.lang.String xpath) 根据XPath返回所有匹配的节点。
XmlNode | getRootNode() 获得根节点
void | setRootNode(XmlNode rootNode) 设置根节点。

Method Detail

getRootNode

public XmlNode getRootNode()
获得根节点

Returns:
XmlNode 根节点

setRootNode

public void setRootNode(XmlNode rootNode)
设置根节点。此操作将自动删除原先的根节点。

Parameters:
rootNode - XmlNode

createRootNode

public XmlNode createRootNode(java.lang.String name)
创建根节点。此操作将自动删除原先的根节点。

Parameters:
name - String
Returns:
XmlNode

getNodeById

public XmlNode getNodeById(java.lang.String id)
根据ID返回一个节点，如果无法找到匹配的节点则返回null。

Parameters:
id - String 节点ID
Returns:
XmlNode 节点

getNodeByXPath

public XmlNode getNodeByXPath(java.lang.String xpath)
根据XPath返回第一个匹配的节点。

Parameters:
xpath - String
Returns:
XmlNode

getNodesByXPath

public XmlNode[] getNodesByXPath(java.lang.String xpath)
根据XPath返回所有匹配的节点。

Parameters:
xpath - String
Returns:
XmlNode[]
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlFactory

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Class XmlFactory

java.lang.Object
    extended by com.bstek.dorado.utils.xml.XmlFactory
public final class XmlFactory
extends java.lang.Object

XML解析对象的工厂类。

Version:
4.0

Method Summary
static XmlBuilder | createXmlBuilder() 创建并返回一个XML构造器对象
static XmlOutputter | createXmlOutputter() 创建并返回一个XML输出器对象
static java.lang.String | getXmlProcessor() getXmlProcesser
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getXmlProcessor

public static java.lang.String getXmlProcessor()
getXmlProcesser

Returns:
String

createXmlBuilder

public static XmlBuilder createXmlBuilder()
创建并返回一个XML构造器对象

Returns:
XmlBuilder

createXmlOutputter

public static XmlOutputter createXmlOutputter()
创建并返回一个XML输出器对象

Returns:
XmlOutputter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Interface XmlNode

public interface XmlNode

用于封装第三方的XML解析器中的XML节点对象。

Version:
4.0

Method Summary
void | addAttribute(java.lang.String name) 为节点增加一个属性
XmlNode | addChild(java.lang.String name) 增加一个子节点
void | addChild(XmlNode node) 增加一个子节点
XmlNode | cloneNode() 克隆本节点
java.lang.String | getAttribute(java.lang.String name) 返回一个属性的值
boolean | getAttributeBoolean(java.lang.String name) 按boolean类型返回一个属性的值
boolean | getAttributeBoolean(java.lang.String name, boolean defaultValue) 按boolean类型返回一个属性的值.
double | getAttributeDouble(java.lang.String name) 按double类型返回一个属性的值
double | getAttributeDouble(java.lang.String name, double defaultValue) 按double类型返回一个属性的值.
float | getAttributeFloat(java.lang.String name) 按float类型返回一个属性的值
float | getAttributeFloat(java.lang.String name, float defaultValue) 按float类型返回一个属性的值.
int | getAttributeInt(java.lang.String name) 按int类型返回一个属性的值
int | getAttributeInt(java.lang.String name, int defaultValue) 按int类型返回一个属性的值.
long | getAttributeLong(java.lang.String name) 按long类型返回一个属性的值
long | getAttributeLong(java.lang.String name, long defaultValue) 按long类型返回一个属性的值.
java.lang.String[] | getAttributeNames() 返回所有属性的属性属性名
java.lang.String | getAttributeString(java.lang.String name) 按String类型返回一个属性的值.此方法总是返回一个有效地String,不会返回null.
java.lang.String | getAttributeString(java.lang.String name, java.lang.String defaultValue) 按int类型返回一个属性的值.
XmlNode | getChild(java.lang.String name) 根据标记名返回子节点中的第一个匹配的节点，如果无法找到匹配的节点则返回null。
java.lang.String | getChildContent(java.lang.String name) 返回子节点的内容
boolean | getChildContentBoolean(java.lang.String name) 按boolean类型返回子节点的内容
boolean | getChildContentBoolean(java.lang.String name, boolean defaultValue) 按boolean类型返回子节点的内容.
double | getChildContentDouble(java.lang.String name) 按double类型返回子节点的内容
double | getChildContentDouble(java.lang.String name, double defaultValue) 按double类型返回子节点的内容.
float | getChildContentFloat(java.lang.String name) 按float类型返回子节点的内容
float | getChildContentFloat(java.lang.String name, float defaultValue) 按float类型返回子节点的内容.
int | getChildContentInt(java.lang.String name) 按int类型返回子节点的内容
int | getChildContentInt(java.lang.String name, int defaultValue) 按int类型返回子节点的内容.
long | getChildContentLong(java.lang.String name) 按long类型返回子节点的内容
long | getChildContentLong(java.lang.String name, long defaultValue) 按long类型返回子节点的内容.
java.lang.String | getChildContentString(java.lang.String name) 返回子节点的内容.此方法总是返回一个有效地String, 不会返回null.
java.lang.String | getChildContentString(java.lang.String name, java.lang.String defaultValue) 返回子节点的内容.
XmlNode[] | getChildren() 返回所有的子节点
java.lang.String | getContent() 返回节点的内容
boolean | getContentBoolean() 按boolean类型返回节点的内容
boolean | getContentBoolean(boolean defaultValue) 按boolean类型返回节点的内容.
double | getContentDouble() 按double类型返回节点的内容
double | getContentDouble(double defaultValue) 按double类型返回节点的内容.
float | getContentFloat() 按float类型返回节点的内容
float | getContentFloat(float defaultValue) 按float类型返回节点的内容.
int | getContentInt() 按int类型返回节点的内容
int | getContentInt(int defaultValue) 按int类型返回节点的内容.
long | getContentLong() 按long类型返回节点的内容
long | getContentLong(long defaultValue) 按long类型返回节点的内容.
java.lang.String | getContentString() 返回节点的内容.此方法总是返回一个有效地String, 不会返回null.
java.lang.String | getContentString(java.lang.String defaultValue) 返回节点的内容.此方法总是返回一个有效地String.
java.lang.String | getName() 节点名称
XmlNode | getNodeByXPath(java.lang.String xpath) 根据XPath返回第一个匹配的节点。
XmlNode[] | getNodesByXPath(java.lang.String xpath) 根据XPath返回所有匹配的节点。
XmlNode | getParent() 返回父节点
void | removeAttribute(java.lang.String name) 删除一个属性
boolean | removeChild(java.lang.String name) 删除一个子节点
void | removeChildren() 删除所有的子节点
void | removeFromParent() removeFromParent
void | setAttribute(java.lang.String name, java.lang.String value) 设置一个属性的值
void | setAttributeBoolean(java.lang.String name, boolean value) 按boolean类型设置一个属性的值
void | setAttributeDouble(java.lang.String name, double value) 按double类型设置一个属性的值
void | setAttributeFloat(java.lang.String name, float value) 按float类型设置一个属性的值
void | setAttributeInt(java.lang.String name, int value) 按int类型设置一个属性的值
void | setAttributeLong(java.lang.String name, long value) 按long类型设置一个属性的值
void | setChildContent(java.lang.String name, java.lang.String value) setChildContent
void | setChildContentBoolean(java.lang.String name, boolean value) 按boolean类型设置子节点的内容
void | setChildContentDouble(java.lang.String name, double value) 按double类型设置子节点的内容
void | setChildContentFloat(java.lang.String name, float value) 按float类型设置子节点的内容
void | setChildContentInt(java.lang.String name, int value) 按int类型设置子节点的内容
void | setChildContentLong(java.lang.String name, long value) 按long类型设置子节点的内容
void | setContent(java.lang.String value) setContent
void | setContentBoolean(boolean value) setContentBoolean
void | setContentDouble(double value) setContentDouble
void | setContentFloat(float value) setContentFloat
void | setContentInt(int value) setContentInt
void | setContentLong(long value) setContentLong

Method Detail

getName

public java.lang.String getName()
节点名称

Returns:
String

addChild

public XmlNode addChild(java.lang.String name)
增加一个子节点

Parameters:
name - String 新增子节点的标记名
Returns:
XmlNode 新增的子节点

addChild

public void addChild(XmlNode node)
增加一个子节点

Parameters:
node - XmlNode

removeFromParent

public void removeFromParent()
removeFromParent

removeChild

public boolean removeChild(java.lang.String name)
删除一个子节点

Parameters:
name - String 要删除的子节点名
Returns:
boolean

removeChildren

public void removeChildren()
删除所有的子节点

getParent

public XmlNode getParent()
返回父节点

Returns:
XmlNode 父节点

getChild

public XmlNode getChild(java.lang.String name)
根据标记名返回子节点中的第一个匹配的节点，如果无法找到匹配的节点则返回null。

Parameters:
name - String 标记名
Returns:
XmlNode 子节点

getChildren

public XmlNode[] getChildren()
返回所有的子节点

Returns:
XmlNode[]

getNodeByXPath

public XmlNode getNodeByXPath(java.lang.String xpath)
根据XPath返回第一个匹配的节点。

Parameters:
xpath - String
Returns:
XmlNode

getNodesByXPath

public XmlNode[] getNodesByXPath(java.lang.String xpath)
根据XPath返回所有匹配的节点。

Parameters:
xpath - String
Returns:
XmlNode[]

getContent

public java.lang.String getContent()
返回节点的内容

Returns:
String

setContent

public void setContent(java.lang.String value)
setContent

Parameters:
value - String

getContentString

public java.lang.String getContentString()
返回节点的内容.此方法总是返回一个有效地String, 不会返回null.

Returns:
String

getContentString

public java.lang.String getContentString(java.lang.String defaultValue)
返回节点的内容.此方法总是返回一个有效地String. 如果节点的内容为null则返回defaultValue.

Parameters:
defaultValue - String
Returns:
String

getContentInt

public int getContentInt()
按int类型返回节点的内容

Returns:
int

getContentInt

public int getContentInt(int defaultValue)
按int类型返回节点的内容. 如果节点的内容为null则返回defaultValue.

Parameters:
defaultValue - int
Returns:
int

setContentInt

public void setContentInt(int value)
setContentInt

Parameters:
value - int

getContentLong

public long getContentLong()
按long类型返回节点的内容

Returns:
long

getContentLong

public long getContentLong(long defaultValue)
按long类型返回节点的内容. 如果节点的内容为null则返回defaultValue.

Parameters:
defaultValue - long
Returns:
long

setContentLong

public void setContentLong(long value)
setContentLong

Parameters:
value - long

getContentFloat

public float getContentFloat()
按float类型返回节点的内容

Returns:
float

getContentFloat

public float getContentFloat(float defaultValue)
按float类型返回节点的内容. 如果节点的内容为null则返回defaultValue.

Parameters:
defaultValue - float
Returns:
float

setContentFloat

public void setContentFloat(float value)
setContentFloat

Parameters:
value - float

getContentDouble

public double getContentDouble()
按double类型返回节点的内容

Returns:
double

getContentDouble

public double getContentDouble(double defaultValue)
按double类型返回节点的内容. 如果节点的内容为null则返回defaultValue.

Parameters:
defaultValue - double
Returns:
double

setContentDouble

public void setContentDouble(double value)
setContentDouble

Parameters:
value - double

getContentBoolean

public boolean getContentBoolean()
按boolean类型返回节点的内容

Returns:
boolean

getContentBoolean

public boolean getContentBoolean(boolean defaultValue)
按boolean类型返回节点的内容. 如果节点的内容为null则返回defaultValue.

Parameters:
defaultValue - boolean
Returns:
boolean

setContentBoolean

public void setContentBoolean(boolean value)
setContentBoolean

Parameters:
value - boolean

addAttribute

public void addAttribute(java.lang.String name)
为节点增加一个属性

Parameters:
name - String 属性名

getAttributeNames

public java.lang.String[] getAttributeNames()
返回所有属性的属性属性名

Returns:
String[]

getAttribute

public java.lang.String getAttribute(java.lang.String name)
返回一个属性的值

Parameters:
name - String
Returns:
String 属性名

setAttribute

public void setAttribute(java.lang.String name,
                         java.lang.String value)
设置一个属性的值

Parameters:
name - String
value - String

getAttributeString

public java.lang.String getAttributeString(java.lang.String name)
按String类型返回一个属性的值.此方法总是返回一个有效地String,不会返回null.

Parameters:
name - String 属性名
Returns:
String

getAttributeString

public java.lang.String getAttributeString(java.lang.String name,
                                           java.lang.String defaultValue)
按int类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.

Parameters:
name - String 属性名
defaultValue - String
Returns:
int

getAttributeInt

public int getAttributeInt(java.lang.String name)
按int类型返回一个属性的值

Parameters:
name - String 属性名
Returns:
int

getAttributeInt

public int getAttributeInt(java.lang.String name,
                           int defaultValue)
按int类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.

Parameters:
name - String 属性名
defaultValue - int
Returns:
int

setAttributeInt

public void setAttributeInt(java.lang.String name,
                            int value)
按int类型设置一个属性的值

Parameters:
name - String 属性名
value - int

getAttributeLong

public long getAttributeLong(java.lang.String name)
按long类型返回一个属性的值

Parameters:
name - String 属性名
Returns:
long

getAttributeLong

public long getAttributeLong(java.lang.String name,
                             long defaultValue)
按long类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.

Parameters:
name - String 属性名
defaultValue - long
Returns:
long

setAttributeLong

public void setAttributeLong(java.lang.String name,
                             long value)
按long类型设置一个属性的值

Parameters:
name - String 属性名
value - long

getAttributeFloat

public float getAttributeFloat(java.lang.String name)
按float类型返回一个属性的值

Parameters:
name - String 属性名
Returns:
float

getAttributeFloat

public float getAttributeFloat(java.lang.String name,
                               float defaultValue)
按float类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.

Parameters:
name - String 属性名
defaultValue - float
Returns:
float

setAttributeFloat

public void setAttributeFloat(java.lang.String name,
                              float value)
按float类型设置一个属性的值

Parameters:
name - String 属性名
value - float

getAttributeDouble

public double getAttributeDouble(java.lang.String name)
按double类型返回一个属性的值

Parameters:
name - String 属性名
Returns:
double

getAttributeDouble

public double getAttributeDouble(java.lang.String name,
                                 double defaultValue)
按double类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.

Parameters:
name - String 属性名
defaultValue - double
Returns:
double

setAttributeDouble

public void setAttributeDouble(java.lang.String name,
                               double value)
按double类型设置一个属性的值

Parameters:
name - String 属性名
value - double

getAttributeBoolean

public boolean getAttributeBoolean(java.lang.String name)
按boolean类型返回一个属性的值

Parameters:
name - String 属性名
Returns:
boolean

getAttributeBoolean

public boolean getAttributeBoolean(java.lang.String name,
                                   boolean defaultValue)
按boolean类型返回一个属性的值. 如果属性的内容为null则返回defaultValue.

Parameters:
name - String 属性名
defaultValue - boolean
Returns:
boolean

setAttributeBoolean

public void setAttributeBoolean(java.lang.String name,
                                boolean value)
按boolean类型设置一个属性的值

Parameters:
name - String 属性名
value - boolean

removeAttribute

public void removeAttribute(java.lang.String name)
删除一个属性

Parameters:
name - String 属性名

getChildContent

public java.lang.String getChildContent(java.lang.String name)
返回子节点的内容

Parameters:
name - String
Returns:
String

setChildContent

public void setChildContent(java.lang.String name,
                            java.lang.String value)
setChildContent

Parameters:
name - String
value - String

getChildContentString

public java.lang.String getChildContentString(java.lang.String name)
返回子节点的内容.此方法总是返回一个有效地String, 不会返回null.

Parameters:
name - String
Returns:
String

getChildContentString

public java.lang.String getChildContentString(java.lang.String name,
                                              java.lang.String defaultValue)
返回子节点的内容. 如果子节点的内容为null则返回defaultValue.

Parameters:
name - String
defaultValue - String
Returns:
String

getChildContentInt

public int getChildContentInt(java.lang.String name)
按int类型返回子节点的内容

Parameters:
name - String
Returns:
int

getChildContentInt

public int getChildContentInt(java.lang.String name,
                              int defaultValue)
按int类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.

Parameters:
name - String
defaultValue - int
Returns:
int

setChildContentInt

public void setChildContentInt(java.lang.String name,
                               int value)
按int类型设置子节点的内容

Parameters:
name - String
value - int

getChildContentLong

public long getChildContentLong(java.lang.String name)
按long类型返回子节点的内容

Parameters:
name - String
Returns:
long

getChildContentLong

public long getChildContentLong(java.lang.String name,
                                long defaultValue)
按long类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.

Parameters:
name - String
defaultValue - long
Returns:
long

setChildContentLong

public void setChildContentLong(java.lang.String name,
                                long value)
按long类型设置子节点的内容

Parameters:
name - String
value - long

getChildContentFloat

public float getChildContentFloat(java.lang.String name)
按float类型返回子节点的内容

Parameters:
name - String
Returns:
float

getChildContentFloat

public float getChildContentFloat(java.lang.String name,
                                  float defaultValue)
按float类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.

Parameters:
name - String
defaultValue - float
Returns:
float

setChildContentFloat

public void setChildContentFloat(java.lang.String name,
                                 float value)
按float类型设置子节点的内容

Parameters:
name - String
value - float

getChildContentDouble

public double getChildContentDouble(java.lang.String name)
按double类型返回子节点的内容

Parameters:
name - String
Returns:
double

getChildContentDouble

public double getChildContentDouble(java.lang.String name,
                                    double defaultValue)
按double类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.

Parameters:
name - String
defaultValue - double
Returns:
double

setChildContentDouble

public void setChildContentDouble(java.lang.String name,
                                  double value)
按double类型设置子节点的内容

Parameters:
name - String
value - double

getChildContentBoolean

public boolean getChildContentBoolean(java.lang.String name)
按boolean类型返回子节点的内容

Parameters:
name - String
Returns:
boolean

getChildContentBoolean

public boolean getChildContentBoolean(java.lang.String name,
                                      boolean defaultValue)
按boolean类型返回子节点的内容. 如果子节点的内容为null则返回defaultValue.

Parameters:
name - String
defaultValue - boolean
Returns:
boolean

setChildContentBoolean

public void setChildContentBoolean(java.lang.String name,
                                   boolean value)
按boolean类型设置子节点的内容

Parameters:
name - String
value - boolean

cloneNode

public XmlNode cloneNode()
                  throws java.lang.CloneNotSupportedException
克隆本节点

Returns:
XmlNode
Throws:
java.lang.CloneNotSupportedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlOutputter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Interface XmlOutputter

public interface XmlOutputter

XML输出器的接口。用于以各种方式输出XML。

Version:
4.0

Method Summary
void | output(XmlDocument xmlDocument, java.io.File file) 输出整个XML
void | output(XmlDocument xmlDocument, java.io.OutputStream out) 输出整个XML
void | output(XmlDocument xmlDocument, java.lang.String filepath) 输出整个XML
void | output(XmlDocument xmlDocument, java.io.Writer out) 输出整个XML
void | output(XmlNode xmlNode, java.io.File file) 输出一个XML节点
void | output(XmlNode xmlNode, java.io.OutputStream out) 输出一个XML节点
void | output(XmlNode xmlNode, java.lang.String filepath) 输出一个XML节点
void | output(XmlNode xmlNode, java.io.Writer out) 输出一个XML节点
java.lang.String | outputString(XmlDocument xmlDocument) 以String格式输出整个XML
java.lang.String | outputString(XmlNode xmlNode) 以String格式输出一个XML节点

Method Detail

outputString

public java.lang.String outputString(XmlNode xmlNode)
以String格式输出一个XML节点

Parameters:
xmlNode - XmlNode
Returns:
String

output

public void output(XmlNode xmlNode,
                   java.io.OutputStream out)
            throws java.io.IOException
输出一个XML节点

Parameters:
xmlNode - XmlNode
out - OutputStream
Throws:
java.io.IOException

output

public void output(XmlNode xmlNode,
                   java.io.Writer out)
            throws java.io.IOException
输出一个XML节点

Parameters:
xmlNode - XmlNode
out - Writer
Throws:
java.io.IOException

output

public void output(XmlNode xmlNode,
                   java.io.File file)
            throws java.io.IOException
输出一个XML节点

Parameters:
xmlNode - XmlNode
file - File
Throws:
java.io.IOException

output

public void output(XmlNode xmlNode,
                   java.lang.String filepath)
            throws java.io.IOException
输出一个XML节点

Parameters:
xmlNode - XmlNode
filepath - String
Throws:
java.io.IOException

outputString

public java.lang.String outputString(XmlDocument xmlDocument)
以String格式输出整个XML

Parameters:
xmlDocument - XmlDocument
Returns:
String

output

public void output(XmlDocument xmlDocument,
                   java.io.OutputStream out)
            throws java.io.IOException
输出整个XML

Parameters:
xmlDocument - XmlDocument
out - OutputStream
Throws:
java.io.IOException

output

public void output(XmlDocument xmlDocument,
                   java.io.Writer out)
            throws java.io.IOException
输出整个XML

Parameters:
xmlDocument - XmlDocument
out - Writer
Throws:
java.io.IOException

output

public void output(XmlDocument xmlDocument,
                   java.io.File file)
            throws java.io.IOException
输出整个XML

Parameters:
xmlDocument - XmlDocument
file - File
Throws:
java.io.IOException

output

public void output(XmlDocument xmlDocument,
                   java.lang.String filepath)
            throws java.io.IOException
输出整个XML

Parameters:
xmlDocument - XmlDocument
filepath - String
Throws:
java.io.IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlParseException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.utils.xml
Class XmlParseException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by com.bstek.dorado.utils.DoradoException
                extended by com.bstek.dorado.utils.xml.XmlParseException
All Implemented Interfaces:
java.io.Serializable
public class XmlParseException
extends DoradoException

Xml解析异常

Version:
4.0
See Also:
Serialized Form

Constructor Summary
XmlParseException()
XmlParseException
XmlParseException(java.lang.String message)
XmlParseException
XmlParseException(java.lang.Throwable t)
DoradoException
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XmlParseException

public XmlParseException()
XmlParseException

XmlParseException

public XmlParseException(java.lang.String message)
XmlParseException

Parameters:
message - String

XmlParseException

public XmlParseException(java.lang.Throwable t)
DoradoException

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Component

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Interface Component

All Superinterfaces:
Element, EventSupported
All Known Subinterfaces:
Control, ViewDataset
All Known Implementing Classes:
com.bstek.dorado.view.control.AbstractControl, ViewDatasetSupport
public interface Component
extends Element, EventSupported

组件接口

Version:
4.0

Method Summary
void | addEventHandler(EventHandler event) 添加一个事件处理对象。
void | applyRoleConfig() 应用角色配置文件中的配置。
java.util.Map | eventHandlers() 取得所有事件处理对象的集合对象。
EventHandler | getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
java.lang.String | getId() 取得组件的Id。
ViewModel | getViewModel() 取得视图模型对象。
void | init(DoradoContext context, XmlNode node) 跟XML配置初始化
boolean | isIgnored() 返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
void | removeEventHandler(java.lang.String name) 根据指定的名称删除一个事件处理对象。
void | setIgnored(boolean ignored) 设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag

Method Detail

getViewModel

public ViewModel getViewModel()
取得视图模型对象。

Returns:
ViewModel

getId

public java.lang.String getId()
取得组件的Id。

Returns:
String

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
跟XML配置初始化

Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

applyRoleConfig

public void applyRoleConfig()
                     throws java.lang.Exception
应用角色配置文件中的配置。

Throws:
java.lang.Exception

isIgnored

public boolean isIgnored()
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。

Returns:
boolean

setIgnored

public void setIgnored(boolean ignored)
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。

Parameters:
ignored - boolean

addEventHandler

public void addEventHandler(EventHandler event)
添加一个事件处理对象。

Specified by:
addEventHandler in interface EventSupported
Parameters:
event - EventHandler

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
根据指定名称取得一个事件处理对象。

Specified by:
getEventHandler in interface EventSupported
Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
根据指定的名称删除一个事件处理对象。

Specified by:
removeEventHandler in interface EventSupported
Parameters:
name - String

eventHandlers

public java.util.Map eventHandlers()
取得所有事件处理对象的集合对象。

Specified by:
eventHandlers in interface EventSupported
Returns:
Map
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultViewModel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class DefaultViewModel

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
        extended by com.bstek.dorado.view.DefaultViewModel
All Implemented Interfaces:
Element, EventSupported, ViewModel
Direct Known Subclasses:
DropDownViewModel
public class DefaultViewModel
extends ViewModelSupport

默认的ViewModel抽象实现类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.ViewModelSupport
controls, datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
DefaultViewModel()
Method Summary
protected  void initDataset(ViewDataset dataset)
初试化一个ViewDataset
Methods inherited from class com.bstek.dorado.view.ViewModelSupport
addEventHandler, checkAccess, constructControl, constructDataset, createControl, createControl, createDataset, createDataset, doLoadData, doUpdateData, eventHandlers, finalize, getClientType, getConfig, getConfigName, getControl, getControls, getDataset, getDatasets, getDefaultSkin, getEventHandler, getNamespace, getRole, getRoleConfigs, getSkin, getState, getTag, handleRPC, handleUpdate, init, initControl, initControls, initDatasets, initLookupFields, isControlLazyLoad, isSafe, loadEventConfig, prepareDatasets, properties, removeControl, removeDataset, removeEventHandler, setClientType, setConfig, setConfigName, setControlLazyLoad, setNamespace, setRole, setSafe, setSkin, setTag, updateData
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultViewModel

public DefaultViewModel()
Method Detail

initDataset

protected void initDataset(ViewDataset dataset)
                    throws java.lang.Exception
初试化一个ViewDataset

Overrides:
initDataset in class ViewModelSupport
Parameters:
dataset - ViewDataset
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Element

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Interface Element

All Known Subinterfaces:
Component, Control, MenuItemContainer, Validator, ViewDataset, ViewField, ViewModel
All Known Implementing Classes:
com.bstek.dorado.view.control.AbstractControl, com.bstek.dorado.view.data.validate.impl.AbstractValidator, Column, FormElement, FormGroup, Menu, MenuItem, OutlookBarGroup, TabElement, TreeNode, ViewBaseField, ViewDatasetSupport, ViewLookupField, ViewModelSupport
public interface Element

元素接口

Version:
4.0

Method Summary
java.lang.String | getTag() 取得元素的用户自定义信息。
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。

Method Detail

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Event

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class Event

java.lang.Object
    extended by com.bstek.dorado.view.Event
public class Event
extends java.lang.Object

客户端事件的定义描述对象

Version:
4.0

Constructor Summary
Event()
构造器
Method Summary
java.lang.String | getName() 取得事件名
java.lang.String | getParameters() 取得事件参数描述
void | setName(java.lang.String name) 设置事件名
void | setParameters(java.lang.String parameters) 设置事件参数描述
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Event

public Event()
构造器

Method Detail

getName

public java.lang.String getName()
取得事件名

Returns:
String

setName

public void setName(java.lang.String name)
设置事件名

Parameters:
name - String

getParameters

public java.lang.String getParameters()
取得事件参数描述

Returns:
String

setParameters

public void setParameters(java.lang.String parameters)
设置事件参数描述

Parameters:
parameters - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EventConfig

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class EventConfig

java.lang.Object
    extended by com.bstek.dorado.view.EventConfig
public final class EventConfig
extends java.lang.Object

客户端事件定义的配置管理器

Version:
4.0

Method Summary
static Event getEvent(java.lang.String control, java.lang.String event)
根据控件名和事件名取得一个事件定义的描述对象
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getEvent

public static Event getEvent(java.lang.String control,
                             java.lang.String event)
根据控件名和事件名取得一个事件定义的描述对象

Parameters:
control - String
event - String
Returns:
Event
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EventHandler

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class EventHandler

java.lang.Object
    extended by com.bstek.dorado.view.EventHandler
public class EventHandler
extends java.lang.Object

事件处理类

Version:
4.0

Constructor Summary
EventHandler(java.lang.String name)
构造器
EventHandler(java.lang.String name, java.lang.String script)
构造器
Method Summary
java.lang.String | getName() 取得事件名
java.lang.String | getScript() 取得事件脚本
void | setScript(java.lang.String script) 设定事件脚本
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EventHandler

public EventHandler(java.lang.String name)
构造器

Parameters:
name - 事件名

EventHandler

public EventHandler(java.lang.String name,
                    java.lang.String script)
构造器

Parameters:
name - 事件名
script - 事件脚本
Method Detail

getName

public java.lang.String getName()
取得事件名

Returns:
String

getScript

public java.lang.String getScript()
取得事件脚本

Returns:
String

setScript

public void setScript(java.lang.String script)
设定事件脚本

Parameters:
script - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EventSupported

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Interface EventSupported

All Known Subinterfaces:
Component, Control, Validator, ViewDataset, ViewModel
All Known Implementing Classes:
com.bstek.dorado.view.control.AbstractControl, com.bstek.dorado.view.data.validate.impl.AbstractValidator, DataColumnGroup, EditableColumn, ViewDatasetSupport, ViewModelSupport
public interface EventSupported

可支持客户端事件的控件的接口

Version:
4.0

Method Summary
void | addEventHandler(EventHandler event) 添加一个事件处理对象。
java.util.Map | eventHandlers() 取得所有事件处理对象的集合对象。
EventHandler | getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
void | removeEventHandler(java.lang.String name) 根据指定的名称删除一个事件处理对象。

Method Detail

addEventHandler

public void addEventHandler(EventHandler event)
添加一个事件处理对象。

Parameters:
event - EventHandler

eventHandlers

public java.util.Map eventHandlers()
取得所有事件处理对象的集合对象。

Returns:
Map

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
根据指定名称取得一个事件处理对象。

Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
根据指定的名称删除一个事件处理对象。

Parameters:
name - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JspHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class JspHelper

java.lang.Object
    extended by com.bstek.dorado.view.JspHelper
public final class JspHelper
extends java.lang.Object

用于辅助dorado的JSP开发的工具类

Version:
4.0

Method Summary
static ViewModel getViewModel(javax.servlet.jsp.PageContext pageContext)
根据传入JSP上下文对象的获得当前的ViewModel实例
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getViewModel

public static ViewModel getViewModel(javax.servlet.jsp.PageContext pageContext)
根据传入JSP上下文对象的获得当前的ViewModel实例

Parameters:
pageContext - PageContext
Returns:
ViewModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view

包含视图模型、视图控件和数据校验类。

See:
Description

Interface Summary
Component | 组件接口
Element | 元素接口
EventSupported | 可支持客户端事件的控件的接口
ViewModel | 视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Class Summary
DefaultViewModel | 默认的ViewModel抽象实现类
Event | 客户端事件的定义描述对象
EventConfig | 客户端事件定义的配置管理器
EventHandler | 事件处理类
JspHelper | 用于辅助dorado的JSP开发的工具类
ViewModelSupport | 视图模型的基本实现

Package com.bstek.dorado.view Description

包含视图模型、视图控件和数据校验类。


ViewModel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Interface ViewModel

All Superinterfaces:
Element, EventSupported
All Known Implementing Classes:
ViewModelSupport
public interface ViewModel
extends Element, EventSupported

视图模型

ViewModel是一种用于封装界面逻辑和操作逻辑的对象. 即视图中包含哪些数据、这些数据以什么方式展现、视图中包含哪些控件、这些控件会激发什么操作等等. ViewModel一般不用于定义各种控件最终在显示的布局,控件布局应通过其它方式进行定义.例如JSP.

ViewModel不会在服务端进行缓存.我们也可以把ViewModel看做是服务端跟客户端进行信息交换的接口. 当用户执行页面请求、局部数据刷新、远程方法调用等操作时服务端都会创建相应的ViewModel 实例. 我们可以通过其state属性来判断当前ViewModel在何种情况下被创建.state有下列几种取值:

  • ViewModel.STATE_VIEW - 打开视图状态,即用户请求一个新的视图时的状态. 在此状态下ViewModel在创建时会自动创建所有已声明的Dataset,并自动根据每个Dataset的配置来装载数据. 所有的控件(Control)将以懒装载的方式被创建.
  • ViewModel.STATE_SERVICE - 服务状态.当一个已打开的视图在执行局部数据刷新、远程方法调用等操作时的状态. 在此状态下ViewModel中所有的Dataset和控件(Control)将以懒装载的方式被创建.
  • ViewModel.STATE_DESIGN - 设计时状态.该状态只有在为dorado studio提供服务时有效. 每一个ViewModel都可以有自己的命名空间. 因此只要具有不同的命名空间我们就可以在同一个视图中使用同一个ViewModel的多个实例.

在多数情况下我们建议使用ViewModel的实现类来作为后台业务逻辑的调用接口.

Version:
4.0

Field Summary
static java.lang.String | DEFAULT_ROLE_ATTRIBUTE 默认角色属性
static java.lang.String | DEFAULT_SKIN_ATTRIBUTE 默认皮肤属性
static java.lang.String | REJECT_ROLE REJECT_ROLE - 系统默认角色，该角色无权使用视图模型中的任何组件
static int | STATE_DESIGN 视图模型的状态 - 正在为设计器服务
static int | STATE_SERVICE 视图模型的状态 - 正在为远程过程调用等服务
static int | STATE_UPDATING 视图模型的状态 - 正在为一个视图更新数据时服务
static int | STATE_VIEW 视图模型的状态 - 正在为一个视图服务
Method Summary
Control | createControl(java.lang.String type, java.lang.String id) 根据指定的控件类型和Id创建控件对象。
Control | createControl(XmlNode node) 根据xml定义创建对应的控件对象。
ViewDataset | createDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。
ViewDataset | createDataset(XmlNode node) 根据xml的定义创建一个视图数据集。
java.lang.String | getClientType() 返回客户端类型
com.bstek.dorado.view.config.ViewModelConfig | getConfig() 取得视图配置
java.lang.String | getConfigName() 取得视图模型配置名
Control | getControl(java.lang.String id) 根据指定的Id取得一个控件对象。
java.util.Map | getControls() 取得视图模型所有的控件的集合对象。
ViewDataset | getDataset(java.lang.String id) 根据指定的Id取得一个视图数据集对象。
java.util.Map | getDatasets() 取得所有的视图数据集的集合对象。
java.lang.String | getNamespace() 取得视图配置命名空间
java.lang.String | getRole() 取得与视图模型相关的角色.
java.util.List | getRoleConfigs(Component component) 返回与给定的组件相关的角色配置项
java.lang.String | getSkin() 返回视图模型使用的皮肤
int | getState() 取得当前状态
void | handleRPC(java.lang.String method, ParameterSet parameters, ParameterSet outParameters) 处理一个远程过程调用操作
void | handleUpdate(java.lang.String method, ParameterSet parameters) 处理一个更新操作
void | init(int state) 视图模型初始化
boolean | isControlLazyLoad() 返回视图模型是否支持控件的延时加载.
boolean | isSafe() 返回用户访问视图页面时是否对用户身份进行检验。
void | prepareDatasets() 为视图模型中所有的Dataset准备数据。
MetaData | properties() 属性集合
void | removeControl(java.lang.String id) 根据指定的Id删除一个控件。
void | removeDataset(java.lang.String id) 根据Id删除一个指定的数据集。
void | setClientType(java.lang.String clientType) setClientType
void | setConfig(com.bstek.dorado.view.config.ViewModelConfig config) 设定视图配置对象
void | setConfigName(java.lang.String configName) 设定视图模型配置名
void | setControlLazyLoad(boolean controlLazyLoad) 设定视图模型是否支持控件的延时加载.默认为true.
void | setNamespace(java.lang.String namespace) 设定视图配置命名空间
void | setRole(java.lang.String role) 设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.
void | setSafe(boolean safe) 设置用户访问视图页面时是否对用户身份进行检验。
void | setSkin(java.lang.String skin) 设定视图模型使用的皮肤
void | updateData(ParameterSet parameters) 对ViewModel中的Dataset进行持久化。
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag
Methods inherited from interface com.bstek.dorado.view.EventSupported
addEventHandler, eventHandlers, getEventHandler, removeEventHandler

Field Detail

STATE_VIEW

public static final int STATE_VIEW
视图模型的状态 - 正在为一个视图服务

See Also:
Constant Field Values

STATE_SERVICE

public static final int STATE_SERVICE
视图模型的状态 - 正在为远程过程调用等服务

See Also:
Constant Field Values

STATE_UPDATING

public static final int STATE_UPDATING
视图模型的状态 - 正在为一个视图更新数据时服务

See Also:
Constant Field Values

STATE_DESIGN

public static final int STATE_DESIGN
视图模型的状态 - 正在为设计器服务

See Also:
Constant Field Values

REJECT_ROLE

public static final java.lang.String REJECT_ROLE
REJECT_ROLE - 系统默认角色，该角色无权使用视图模型中的任何组件

See Also:
Constant Field Values

DEFAULT_ROLE_ATTRIBUTE

public static final java.lang.String DEFAULT_ROLE_ATTRIBUTE
默认角色属性

See Also:
Constant Field Values

DEFAULT_SKIN_ATTRIBUTE

public static final java.lang.String DEFAULT_SKIN_ATTRIBUTE
默认皮肤属性

See Also:
Constant Field Values
Method Detail

getConfigName

public java.lang.String getConfigName()
取得视图模型配置名

Returns:
String

setConfigName

public void setConfigName(java.lang.String configName)
设定视图模型配置名

Parameters:
configName - String

getConfig

public com.bstek.dorado.view.config.ViewModelConfig getConfig()
取得视图配置

Returns:
ViewModelConfig

setConfig

public void setConfig(com.bstek.dorado.view.config.ViewModelConfig config)
设定视图配置对象

Parameters:
config - ViewModelConfig

getNamespace

public java.lang.String getNamespace()
取得视图配置命名空间

Returns:
String

setNamespace

public void setNamespace(java.lang.String namespace)
设定视图配置命名空间

Parameters:
namespace - String

getClientType

public java.lang.String getClientType()
返回客户端类型

Returns:
String

setClientType

public void setClientType(java.lang.String clientType)
setClientType

Parameters:
clientType - String

getState

public int getState()
取得当前状态

Returns:
int 取值范围(@see #STATE_VIEW, @see #STATE_SERVICE, @see #STATE_UPDATING)

isSafe

public boolean isSafe()
返回用户访问视图页面时是否对用户身份进行检验。

Returns:
boolean

setSafe

public void setSafe(boolean safe)
设置用户访问视图页面时是否对用户身份进行检验。如果该属性设为True时，Dorado将通过 工程配置文件setting.xml文件中的accessChecker属性定义的安全检查类对用户进行安全检验， 只有符合规定的特定用户才允许访问该视图页面。

Parameters:
safe - boolean

getRole

public java.lang.String getRole()
取得与视图模型相关的角色.

Returns:
String

setRole

public void setRole(java.lang.String role)
设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.

Parameters:
role - String

init

public void init(int state)
          throws java.lang.Exception
视图模型初始化

Parameters:
state - int
Throws:
java.lang.Exception

getRoleConfigs

public java.util.List getRoleConfigs(Component component)
返回与给定的组件相关的角色配置项

Parameters:
component - Component
Returns:
List

getSkin

public java.lang.String getSkin()
返回视图模型使用的皮肤

Returns:
String

setSkin

public void setSkin(java.lang.String skin)
设定视图模型使用的皮肤

Parameters:
skin - String

isControlLazyLoad

public boolean isControlLazyLoad()
返回视图模型是否支持控件的延时加载.

Returns:
boolean

setControlLazyLoad

public void setControlLazyLoad(boolean controlLazyLoad)
设定视图模型是否支持控件的延时加载.默认为true.
开启控件的延时加载功能可以大幅度的提高复杂界面开启速度.

Parameters:
controlLazyLoad - boolean

createDataset

public ViewDataset createDataset(java.lang.String type,
                                 java.lang.String id)
                          throws java.lang.Exception
根据类型和Id，创建一个视图数据集。

Parameters:
type - String
id - String
Returns:
ViewDataset
Throws:
java.lang.Exception

createDataset

public ViewDataset createDataset(XmlNode node)
                          throws java.lang.Exception
根据xml的定义创建一个视图数据集。

Parameters:
node - XmlNode
Returns:
ViewDataset
Throws:
java.lang.Exception

removeDataset

public void removeDataset(java.lang.String id)
根据Id删除一个指定的数据集。

Parameters:
id - String

prepareDatasets

public void prepareDatasets()
                     throws java.lang.Exception
为视图模型中所有的Dataset准备数据。

注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。

Throws:
java.lang.Exception

getDataset

public ViewDataset getDataset(java.lang.String id)
根据指定的Id取得一个视图数据集对象。

Parameters:
id - String
Returns:
ViewDataset;

getDatasets

public java.util.Map getDatasets()
取得所有的视图数据集的集合对象。

Returns:
Map

createControl

public Control createControl(java.lang.String type,
                             java.lang.String id)
                      throws java.lang.Exception
根据指定的控件类型和Id创建控件对象。

Parameters:
type - String
id - String
Returns:
Control
Throws:
java.lang.Exception

createControl

public Control createControl(XmlNode node)
                      throws java.lang.Exception
根据xml定义创建对应的控件对象。

Parameters:
node - XmlNode
Returns:
Control
Throws:
java.lang.Exception

removeControl

public void removeControl(java.lang.String id)
根据指定的Id删除一个控件。

Parameters:
id - String

getControl

public Control getControl(java.lang.String id)
                   throws java.lang.Exception
根据指定的Id取得一个控件对象。

Parameters:
id - String
Returns:
Control
Throws:
java.lang.Exception

getControls

public java.util.Map getControls()
取得视图模型所有的控件的集合对象。

Returns:
Map

updateData

public void updateData(ParameterSet parameters)
                throws java.lang.Exception
对ViewModel中的Dataset进行持久化。

Parameters:
parameters - ParameterSet
Throws:
java.lang.Exception

handleUpdate

public void handleUpdate(java.lang.String method,
                         ParameterSet parameters)
                  throws java.lang.Exception
处理一个更新操作

Parameters:
method - String
parameters - ParameterSet
Throws:
java.lang.Exception

handleRPC

public void handleRPC(java.lang.String method,
                      ParameterSet parameters,
                      ParameterSet outParameters)
               throws java.lang.Exception
处理一个远程过程调用操作

Parameters:
method - String
parameters - ParameterSet
outParameters - ParameterSet
Throws:
java.lang.Exception

properties

public MetaData properties()
属性集合

Returns:
MetaData
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewModelManager

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class ViewModelManager

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelManager
public final class ViewModelManager
extends java.lang.Object

视图模型的管理器

Version:
4.0

Field Summary
static java.lang.String ATTRIBUTE_KEY
ATTRIBUTE_KEY
Method Summary
static void | cacheViewModelInfo(java.lang.String viewInstanceId, ViewModel viewModel) cacheViewModelInfo
static ViewModel | findViewModel(java.lang.String clazz, java.lang.String config, java.lang.String namespace, java.lang.String scope) findViewModel
static java.lang.String | getNewInstanceId() getNewInstanceId
static ViewModel | getViewModel(java.lang.String clazz, java.lang.String config, java.lang.String namespace, int state, java.lang.String scope) getViewModel
static ViewModel | getViewModel(java.lang.String clazz, com.bstek.dorado.view.config.ViewModelConfig viewConfig, java.lang.String namespace, int state, java.lang.String scope) getViewModel
static com.bstek.dorado.view.ViewModelCacheInfo | getViewModelInfo(java.lang.String viewInstanceId) getViewModelInfo
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ATTRIBUTE_KEY

public static final java.lang.String ATTRIBUTE_KEY
ATTRIBUTE_KEY

See Also:
Constant Field Values
Method Detail

getNewInstanceId

public static java.lang.String getNewInstanceId()
getNewInstanceId

Returns:
String

getViewModel

public static ViewModel getViewModel(java.lang.String clazz,
                                     java.lang.String config,
                                     java.lang.String namespace,
                                     int state,
                                     java.lang.String scope)
                              throws java.lang.Exception
getViewModel

Parameters:
clazz - String
config - String
namespace - String
state - int
scope - String
Returns:
ViewModel
Throws:
java.lang.Exception

getViewModel

public static ViewModel getViewModel(java.lang.String clazz,
                                     com.bstek.dorado.view.config.ViewModelConfig viewConfig,
                                     java.lang.String namespace,
                                     int state,
                                     java.lang.String scope)
                              throws java.lang.Exception
getViewModel

Parameters:
clazz - String
viewConfig - ViewModelConfig
namespace - String
state - int
scope - String
Returns:
ViewModel
Throws:
java.lang.Exception

findViewModel

public static ViewModel findViewModel(java.lang.String clazz,
                                      java.lang.String config,
                                      java.lang.String namespace,
                                      java.lang.String scope)
findViewModel

Parameters:
clazz - String
config - String
namespace - String
scope - String
Returns:
ViewModel

cacheViewModelInfo

public static void cacheViewModelInfo(java.lang.String viewInstanceId,
                                      ViewModel viewModel)
cacheViewModelInfo

Parameters:
viewInstanceId - String
viewModel - Class

getViewModelInfo

public static com.bstek.dorado.view.ViewModelCacheInfo getViewModelInfo(java.lang.String viewInstanceId)
getViewModelInfo

Parameters:
viewInstanceId - String
Returns:
ViewModelCacheInfo
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewModelSupport

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view
Class ViewModelSupport

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
All Implemented Interfaces:
Element, EventSupported, ViewModel
Direct Known Subclasses:
DefaultViewModel
public abstract class ViewModelSupport
extends java.lang.Object
implements ViewModel

视图模型的基本实现

Version:
4.0

Field Summary
protected ObjectCollection | controls
protected ObjectCollection | datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
ViewModelSupport()
构造器
Method Summary
void | addEventHandler(EventHandler event) 添加一个事件处理对象。
protected void | checkAccess(DoradoContext context) 按系统默认的方式判断当前用户是否已登录
protected Control | constructControl(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个控件对象。
protected ViewDataset | constructDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。
Control | createControl(java.lang.String type, java.lang.String id) 根据指定的控件类型和Id创建控件对象。
Control | createControl(XmlNode node) 根据xml定义创建对应的控件对象。
ViewDataset | createDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。
ViewDataset | createDataset(XmlNode node) 根据xml的定义创建一个视图数据集。
protected void | doLoadData() 对视图模型中所有的Dataset执行装载数据的操作。
protected void | doUpdateData(ParameterSet parameters) 当系统试图对ViewModel中的Dataset进行持久化时触发的方法。
java.util.Map | eventHandlers() 取得所有事件处理对象的集合对象。
protected void | finalize()
java.lang.String | getClientType() 返回客户端类型
com.bstek.dorado.view.config.ViewModelConfig | getConfig() 取得视图配置
java.lang.String | getConfigName() 取得视图模型配置名
Control | getControl(java.lang.String id) 根据指定的Id取得一个控件对象。
java.util.Map | getControls() 取得视图模型所有的控件的集合对象。
ViewDataset | getDataset(java.lang.String id) 根据指定的Id取得一个视图数据集对象。
java.util.Map | getDatasets() 取得所有的视图数据集的集合对象。
protected java.lang.String | getDefaultSkin(DoradoContext context) 获得默认的皮肤.
EventHandler | getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
java.lang.String | getNamespace() getNamespace
java.lang.String | getRole() 取得与视图模型相关的角色.
java.util.List | getRoleConfigs(Component component) 返回与给定的组件相关的角色配置项
java.lang.String | getSkin() 返回视图模型使用的皮肤
int | getState() 取得当前状态
java.lang.String | getTag() 取得元素的用户自定义信息。
void | handleRPC(java.lang.String method, ParameterSet parameters, ParameterSet outParameters) 处理一个远程过程调用操作
void | handleUpdate(java.lang.String method, ParameterSet parameters) 处理一个更新操作
void | init(int state) 视图模型初始化
protected void | initControl(java.lang.String id, Control control) Deprecated.
protected void | initControls() 初试化控件。
protected void | initDataset(ViewDataset dataset) 初试化一个ViewDataset
protected void | initDatasets() 初试化数据集。
protected void | initLookupFields(Dataset dataset) 初试化某个Dataset中的Lookup字段
boolean | isControlLazyLoad() 返回视图模型是否支持控件的延时加载.
boolean | isSafe() 返回用户访问视图页面时是否对用户身份进行检验。
protected void | loadEventConfig(DoradoContext context) 根据XML中的配置初试化视图模型的事件定义。
void | prepareDatasets() 为视图模型中所有的Dataset准备数据。 注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。
MetaData | properties() 属性集合
void | removeControl(java.lang.String id) 根据指定的Id删除一个控件。
void | removeDataset(java.lang.String id) 根据Id删除一个指定的数据集。
void | removeEventHandler(java.lang.String name) 根据指定的名称删除一个事件处理对象。
void | setClientType(java.lang.String clientType) setClientType
void | setConfig(com.bstek.dorado.view.config.ViewModelConfig config) 设定视图配置对象
void | setConfigName(java.lang.String configName) 设定视图模型配置名
void | setControlLazyLoad(boolean controlLazyLoad) 设定视图模型是否支持控件的延时加载.默认为true. 开启控件的延时加载功能可以大幅度的提高复杂界面开启速度.
void | setNamespace(java.lang.String namespace) setNamespace
void | setRole(java.lang.String role) 设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.
void | setSafe(boolean safe) 设置用户访问视图页面时是否对用户身份进行检验。如果该属性设为True时，Dorado将通过 工程配置文件setting.xml文件中的accessChecker属性定义的安全检查类对用户进行安全检验， 只有符合规定的特定用户才允许访问该视图页面。
void | setSkin(java.lang.String skin) 设定视图模型使用的皮肤
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | updateData(ParameterSet parameters) 对ViewModel中的Dataset进行持久化。
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

datasets

protected ObjectCollection datasets

controls

protected ObjectCollection controls
Constructor Detail

ViewModelSupport

public ViewModelSupport()
构造器

Method Detail

finalize

protected void finalize()
                 throws java.lang.Throwable

Throws:
java.lang.Throwable

getConfigName

public java.lang.String getConfigName()
取得视图模型配置名

Specified by:
getConfigName in interface ViewModel
Returns:
String

setConfigName

public void setConfigName(java.lang.String configName)
设定视图模型配置名

Specified by:
setConfigName in interface ViewModel
Parameters:
configName - String

getConfig

public com.bstek.dorado.view.config.ViewModelConfig getConfig()
取得视图配置

Specified by:
getConfig in interface ViewModel
Returns:
ViewModelConfig

setConfig

public void setConfig(com.bstek.dorado.view.config.ViewModelConfig config)
设定视图配置对象

Specified by:
setConfig in interface ViewModel
Parameters:
config - ViewModelConfig

getNamespace

public java.lang.String getNamespace()
getNamespace

Specified by:
getNamespace in interface ViewModel
Returns:
String

setNamespace

public void setNamespace(java.lang.String namespace)
setNamespace

Specified by:
setNamespace in interface ViewModel
Parameters:
namespace - String

getClientType

public java.lang.String getClientType()
返回客户端类型

Specified by:
getClientType in interface ViewModel
Returns:
String

setClientType

public void setClientType(java.lang.String clientType)
setClientType

Specified by:
setClientType in interface ViewModel
Parameters:
clientType - String

getState

public int getState()
取得当前状态

Specified by:
getState in interface ViewModel
Returns:
int 取值范围(@see #STATE_VIEW, @see #STATE_SERVICE, @see #STATE_UPDATING)

getSkin

public java.lang.String getSkin()
返回视图模型使用的皮肤

Specified by:
getSkin in interface ViewModel
Returns:
String

isControlLazyLoad

public boolean isControlLazyLoad()
返回视图模型是否支持控件的延时加载.

Specified by:
isControlLazyLoad in interface ViewModel
Returns:
boolean

setControlLazyLoad

public void setControlLazyLoad(boolean controlLazyLoad)
设定视图模型是否支持控件的延时加载.默认为true.
开启控件的延时加载功能可以大幅度的提高复杂界面开启速度.

Specified by:
setControlLazyLoad in interface ViewModel
Parameters:
controlLazyLoad - boolean

setSkin

public void setSkin(java.lang.String skin)
设定视图模型使用的皮肤

Specified by:
setSkin in interface ViewModel
Parameters:
skin - String

isSafe

public boolean isSafe()
返回用户访问视图页面时是否对用户身份进行检验。

Specified by:
isSafe in interface ViewModel
Returns:
boolean

setSafe

public void setSafe(boolean safe)
设置用户访问视图页面时是否对用户身份进行检验。如果该属性设为True时，Dorado将通过 工程配置文件setting.xml文件中的accessChecker属性定义的安全检查类对用户进行安全检验， 只有符合规定的特定用户才允许访问该视图页面。

Specified by:
setSafe in interface ViewModel
Parameters:
safe - boolean

getRole

public java.lang.String getRole()
取得与视图模型相关的角色.

Specified by:
getRole in interface ViewModel
Returns:
String

setRole

public void setRole(java.lang.String role)
设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.

Specified by:
setRole in interface ViewModel
Parameters:
role - String

init

public void init(int state)
          throws java.lang.Exception
视图模型初始化

Specified by:
init in interface ViewModel
Parameters:
state - int
Throws:
java.lang.Exception

getDefaultSkin

protected java.lang.String getDefaultSkin(DoradoContext context)
获得默认的皮肤.

Parameters:
context - DoradoContext
Returns:
String

initDatasets

protected void initDatasets()
                     throws java.lang.Exception
初试化数据集。 此方法用于提供给派生类进行重载。

Throws:
java.lang.Exception

initControls

protected void initControls()
                     throws java.lang.Exception
初试化控件。 此方法用于提供给派生类进行重载。

Throws:
java.lang.Exception

getRoleConfigs

public java.util.List getRoleConfigs(Component component)
返回与给定的组件相关的角色配置项

Specified by:
getRoleConfigs in interface ViewModel
Parameters:
component - Component
Returns:
List

loadEventConfig

protected void loadEventConfig(DoradoContext context)
根据XML中的配置初试化视图模型的事件定义。

Parameters:
context - DoradoContext

constructDataset

protected ViewDataset constructDataset(java.lang.String type,
                                       java.lang.String id)
                                throws java.lang.Exception
根据类型和Id，创建一个视图数据集。 此方法用于提供给非派生类进行重载。

Parameters:
type - String
id - String
Returns:
ViewDataset
Throws:
java.lang.Exception

createDataset

public ViewDataset createDataset(XmlNode node)
                          throws java.lang.Exception
根据xml的定义创建一个视图数据集。

Specified by:
createDataset in interface ViewModel
Parameters:
node - XmlNode
Returns:
ViewDataset
Throws:
java.lang.Exception

createDataset

public ViewDataset createDataset(java.lang.String type,
                                 java.lang.String id)
                          throws java.lang.Exception
根据类型和Id，创建一个视图数据集。

Specified by:
createDataset in interface ViewModel
Parameters:
type - String
id - String
Returns:
ViewDataset
Throws:
java.lang.Exception

initDataset

protected void initDataset(ViewDataset dataset)
                    throws java.lang.Exception
初试化一个ViewDataset

Parameters:
dataset - ViewDataset
Throws:
java.lang.Exception

prepareDatasets

public void prepareDatasets()
                     throws java.lang.Exception
为视图模型中所有的Dataset准备数据。

注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。

Specified by:
prepareDatasets in interface ViewModel
Throws:
java.lang.Exception

doLoadData

protected void doLoadData()
                   throws java.lang.Exception
对视图模型中所有的Dataset执行装载数据的操作。此方法由prepareDatasets()调用。

Throws:
java.lang.Exception

initLookupFields

protected void initLookupFields(Dataset dataset)
初试化某个Dataset中的Lookup字段

Parameters:
dataset - Dataset

removeDataset

public void removeDataset(java.lang.String id)
根据Id删除一个指定的数据集。

Specified by:
removeDataset in interface ViewModel
Parameters:
id - String

getDataset

public ViewDataset getDataset(java.lang.String id)
根据指定的Id取得一个视图数据集对象。

Specified by:
getDataset in interface ViewModel
Parameters:
id - String
Returns:
ViewDataset;

getDatasets

public java.util.Map getDatasets()
取得所有的视图数据集的集合对象。

Specified by:
getDatasets in interface ViewModel
Returns:
Map

constructControl

protected Control constructControl(java.lang.String type,
                                   java.lang.String id)
                            throws java.lang.Exception
根据类型和Id，创建一个控件对象。 此方法用于提供给非派生类进行重载。

Parameters:
type - String
id - String
Returns:
Control
Throws:
java.lang.Exception

createControl

public Control createControl(XmlNode node)
                      throws java.lang.Exception
根据xml定义创建对应的控件对象。

Specified by:
createControl in interface ViewModel
Parameters:
node - XmlNode
Returns:
Control
Throws:
java.lang.Exception

createControl

public Control createControl(java.lang.String type,
                             java.lang.String id)
                      throws java.lang.Exception
根据指定的控件类型和Id创建控件对象。

Specified by:
createControl in interface ViewModel
Parameters:
type - String
id - String
Returns:
Control
Throws:
java.lang.Exception

initControl

protected void initControl(java.lang.String id,
                           Control control)
                    throws java.lang.Exception
Deprecated.

初始化某个控件对象。

Parameters:
id - String
control - Control
Throws:
java.lang.Exception

removeControl

public void removeControl(java.lang.String id)
根据指定的Id删除一个控件。

Specified by:
removeControl in interface ViewModel
Parameters:
id - String

getControl

public Control getControl(java.lang.String id)
                   throws java.lang.Exception
根据指定的Id取得一个控件对象。

Specified by:
getControl in interface ViewModel
Parameters:
id - String
Returns:
Control
Throws:
java.lang.Exception

getControls

public java.util.Map getControls()
取得视图模型所有的控件的集合对象。

Specified by:
getControls in interface ViewModel
Returns:
Map

checkAccess

protected void checkAccess(DoradoContext context)
                    throws AccessDeniedException
按系统默认的方式判断当前用户是否已登录

Parameters:
context - HttpSession
Throws:
AccessDeniedException

doUpdateData

protected void doUpdateData(ParameterSet parameters)
                     throws java.lang.Exception
当系统试图对ViewModel中的Dataset进行持久化时触发的方法。

在处理UpdateCommand的Server端逻辑时，我们可以doUpdate看做是对应于一次提交的Server端处理。

Parameters:
parameters - ParameterSet
Throws:
java.lang.Exception

updateData

public void updateData(ParameterSet parameters)
                throws java.lang.Exception
对ViewModel中的Dataset进行持久化。

Specified by:
updateData in interface ViewModel
Parameters:
parameters - ParameterSet
Throws:
java.lang.Exception

handleUpdate

public void handleUpdate(java.lang.String method,
                         ParameterSet parameters)
                  throws java.lang.Exception
处理一个更新操作

Specified by:
handleUpdate in interface ViewModel
Parameters:
method - String
parameters - ParameterSet
Throws:
java.lang.Exception

handleRPC

public void handleRPC(java.lang.String method,
                      ParameterSet parameters,
                      ParameterSet outParameters)
               throws java.lang.Exception
处理一个远程过程调用操作

Specified by:
handleRPC in interface ViewModel
Parameters:
method - String
parameters - ParameterSet
outParameters - ParameterSet
Throws:
java.lang.Exception

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String

addEventHandler

public void addEventHandler(EventHandler event)
添加一个事件处理对象。

Specified by:
addEventHandler in interface EventSupported
Parameters:
event - EventHandler

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
根据指定名称取得一个事件处理对象。

Specified by:
getEventHandler in interface EventSupported
Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
根据指定的名称删除一个事件处理对象。

Specified by:
removeEventHandler in interface EventSupported
Parameters:
name - String

eventHandlers

public java.util.Map eventHandlers()
取得所有事件处理对象的集合对象。

Specified by:
eventHandlers in interface EventSupported
Returns:
Map

properties

public MetaData properties()
属性集合

Specified by:
properties in interface ViewModel
Returns:
MetaData
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Button

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Button

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.Button
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class Button
extends PlaceableControl
implements Visible

按钮对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Button(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getCommand() 返回与按钮关联的操作命令.
java.lang.String | getMenu() 取得与按钮绑定的菜单.
java.lang.String | getToolTip() 返回按钮的弹出式提示.
java.lang.String | getValue() 取得按钮的值.
boolean | isAllowPushDown() 返回按钮是否允许按钮被按下.
boolean | isDisabled() 返回按钮是否处于不可用状态.
boolean | isDown() 返回按钮在初始化的时候是否是被按下的状态.
void | setAllowPushDown(boolean allowPushDown) 设置按钮是否允许按钮被按下.
void | setCommand(java.lang.String command) 设置按钮触发的操作命令对象.
void | setDisabled(boolean disabled) 设置按钮是否处于不可用状态.
void | setDown(boolean down) 设定按钮在初始化的时候是否是被按下的状态.
void | setMenu(java.lang.String menu) 设定与按钮绑定的菜单.
void | setToolTip(java.lang.String toolTip) 设定按钮的弹出式提示.
void | setValue(java.lang.String value) 设置按钮的值.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

Button

public Button(ViewModel viewModel,
              java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

isDisabled

public boolean isDisabled()
返回按钮是否处于不可用状态.

Returns:
boolean

setDisabled

public void setDisabled(boolean disabled)
设置按钮是否处于不可用状态.

Parameters:
disabled - boolean

getValue

public java.lang.String getValue()
取得按钮的值.

Returns:
String

setValue

public void setValue(java.lang.String value)
设置按钮的值.

Parameters:
value - String

getCommand

public java.lang.String getCommand()
返回与按钮关联的操作命令.

Returns:
String

setCommand

public void setCommand(java.lang.String command)
设置按钮触发的操作命令对象.

Parameters:
command - String

getMenu

public java.lang.String getMenu()
取得与按钮绑定的菜单.

Returns:
String

setMenu

public void setMenu(java.lang.String menu)
设定与按钮绑定的菜单.

Parameters:
menu - String

isAllowPushDown

public boolean isAllowPushDown()
返回按钮是否允许按钮被按下.

Returns:
boolean

setAllowPushDown

public void setAllowPushDown(boolean allowPushDown)
设置按钮是否允许按钮被按下.

Parameters:
allowPushDown - boolean

isDown

public boolean isDown()
返回按钮在初始化的时候是否是被按下的状态.
当allowPushDown=true时,按钮将处于一种可选择的状态,其功能类似于CheckBox.

Returns:
boolean

setDown

public void setDown(boolean down)
设定按钮在初始化的时候是否是被按下的状态.
此属性仅在按钮的allowPushDown=true时有效.

Parameters:
down - boolean

getToolTip

public java.lang.String getToolTip()
返回按钮的弹出式提示.

Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定按钮的弹出式提示.

Parameters:
toolTip - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Calendar

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Calendar

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.Calendar
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class Calendar
extends SimpleDataControl

日历

Version:
4.0

Field Summary
static java.lang.String | SCHEDULE
static java.lang.String | SIMPLE
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Calendar(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
 java.lang.String getCalendarType()
返回日历类型.
 java.util.Date getDate()
返回日历默认时间.
 void init(DoradoContext context, XmlNode node)
跟XML配置初始化
 void setCalendarType(java.lang.String calendarType)
设置日历类型.默认可选值有 SIMPLE="simple"(简单类型) 在此种模式下日历对象以一种相对简单的模式与Dataset进行绑定.
 void setDate(java.util.Date date)
设置日历默认的时间.
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

SIMPLE

public static final java.lang.String SIMPLE
See Also:
Constant Field Values

SCHEDULE

public static final java.lang.String SCHEDULE
See Also:
Constant Field Values
Constructor Detail

Calendar

public Calendar(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
Deprecated.

Description copied from interface: Component
跟XML配置初始化

Throws:
java.lang.Exception

getDate

public java.util.Date getDate()
返回日历默认时间.

Returns:
Date

setDate

public void setDate(java.util.Date date)
设置日历默认的时间.

Parameters:
date - Date

getCalendarType

public java.lang.String getCalendarType()
返回日历类型.

Returns:
String

setCalendarType

public void setCalendarType(java.lang.String calendarType)
设置日历类型.默认可选值有
  • SIMPLE="simple"(简单类型) 在此种模式下日历对象以一种相对简单的模式与Dataset进行绑定. 日历对象将直接显示绑定字段的日期值;并且如果用户改变了日期,该日期也将立刻被更新到绑定字段当中.
  • SCHEDULE="schedule"(日程表类型) 在此种模式下日历对象的功能类似于一个日程表. 日历对象并不会直接显示数据集中的日期,而是会对数据集中所有的记录按照绑定字段中的日期进行索引. 然后我们就可以很方便的通过日历对象的getRecords方法来提取于某个日期相关的所有记录. 开发人员可以利用这一功能快速的定义出日程表类型的应用界面.

Parameters:
calendarType - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class CheckBox

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.Editor
                        extended by com.bstek.dorado.view.control.CheckBox
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class CheckBox
extends Editor

复选框

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
CheckBox(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getOffValue() 返回复选框未选中时代表的值.
java.lang.String | getOnValue() 返回复选框选中时代表的值.
java.lang.String | getToolTip() 取得弹出式提示(ToolTip)。
void | setOffValue(java.lang.String offValue) 设定复选框未选中时代表的值.
void | setOnValue(java.lang.String onValue) 设定复选框选中时代表的值.
void | setToolTip(java.lang.String toolTip) 设定弹出式提示(ToolTip)。
Methods inherited from class com.bstek.dorado.view.control.Editor
isReadOnly, setReadOnly
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

CheckBox

public CheckBox(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getOffValue

public java.lang.String getOffValue()
返回复选框未选中时代表的值.

Returns:
String

setOffValue

public void setOffValue(java.lang.String offValue)
设定复选框未选中时代表的值.

Parameters:
offValue - String

getOnValue

public java.lang.String getOnValue()
返回复选框选中时代表的值.

Returns:
String

setOnValue

public void setOnValue(java.lang.String onValue)
设定复选框选中时代表的值.

Parameters:
onValue - String

getToolTip

public java.lang.String getToolTip()
取得弹出式提示(ToolTip)。

Overrides:
getToolTip in class Editor
Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定弹出式提示(ToolTip)。

Overrides:
setToolTip in class Editor
Parameters:
toolTip - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Command

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Command

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.Command
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
CommandQueue, QueryCommand, RequestCommand, RPCCommand
public abstract class Command
extends com.bstek.dorado.view.control.AbstractControl

命令对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Command(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
 ParameterSet parameters()
返回命令(Command)对象的参数的集合对象。
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Command

public Command(ViewModel viewModel,
               java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

parameters

public ParameterSet parameters()
返回命令(Command)对象的参数的集合对象。

Returns:
ParameterSet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Control

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Interface Control

All Superinterfaces:
Component, Element, EventSupported
All Known Implementing Classes:
com.bstek.dorado.view.control.AbstractControl
public interface Control
extends Component

控件的接口

Version:
4.0

Methods inherited from interface com.bstek.dorado.view.Component
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getViewModel, init, isIgnored, removeEventHandler, setIgnored
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataControl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class DataControl

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
PlaceableDataControl
public abstract class DataControl
extends com.bstek.dorado.view.control.AbstractControl

数据控件对象接口

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DataControl(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getDataset() 返回数据控件绑定的数据集。
ViewDataset | getDatasetInstance() 返回数据控件绑定的数据集实例。
void | setDataset(java.lang.String dataset) 设定数据控件与指定的数据集(Dataset)绑定。
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataControl

public DataControl(ViewModel viewModel,
                   java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
Method Detail

getDataset

public java.lang.String getDataset()
返回数据控件绑定的数据集。

Returns:
String

getDatasetInstance

public ViewDataset getDatasetInstance()
返回数据控件绑定的数据集实例。

Returns:
ViewDataset

setDataset

public void setDataset(java.lang.String dataset)
设定数据控件与指定的数据集(Dataset)绑定。

Parameters:
dataset - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataLabel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class DataLabel

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.DataLabel
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class DataLabel
extends SimpleDataControl

数据标签对象

数据标签.一般用于显示数据集的字段内容,不用于编辑. 通过绑定数据集中的某个字段,可以实时的展示数据集中的数据. 例如表格记录滚动,数据集当前记录滚动时都会联动刷新数据标签中的内容.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DataLabel(ViewModel viewModel, java.lang.String id)
构造器
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

DataLabel

public DataLabel(ViewModel viewModel,
                 java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataPilot

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class DataPilot

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.DataPilot
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class DataPilot
extends PlaceableDataControl
implements Visible

数据导航控件对象

用于控制数据集的移动,数据下载,新增,修改维护操作等.

Version:
4.0

Field Summary
static java.lang.String | AUTO
static java.lang.String | HIDDEN
static java.lang.String | VISIBLE
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DataPilot(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getButtonAppend() 取得“追加一条记录”(AppendRecord)按钮的显示状态。
java.lang.String | getButtonCancel() 取得“撤销对当前记录修改”(CancelRecord)按钮的显示状态。
java.lang.String | getButtonDelete() 取得“删除一条记录”(DeleteRecord)按钮的显示状态。
java.lang.String | getButtonInsert() 返回“插入一条记录”(InsertRecord)按钮的显示状态。
java.lang.String | getButtonMoveFirst() 取得“移动到第一条”按钮(MoveFirst)的显示状态。
java.lang.String | getButtonMoveLast() 取得“移动到最后一条”按钮(MoveLast)的显示状态。
java.lang.String | getButtonMoveNext() 取得“移动到下一条”按钮(MoveNext)的显示状态。
java.lang.String | getButtonMovePrev() 取得“移动到下一条”按钮(MovePrev)的显示状态。
java.lang.String | getButtonNextPage() 取得“移动到后一页”按钮(NextPage)的显示状态。
java.lang.String | getButtonPost() 返回"验证"按钮(PostRecord)的显示状态。
java.lang.String | getButtonPrevPage() 取得“移动到前一页”按钮(PrevPage)的显示状态。
boolean | isConfirmCancel() 取得是否提示用户确认取消操作。
boolean | isConfirmDelete() 返回是否提示用户确认删除操作。
void | setButtonAppend(java.lang.String buttonAppend) 设定“追加一条记录”(AppendRecord)按钮的显示状态。
void | setButtonCancel(java.lang.String buttonCancel) 设定“撤销对当前记录修改”(CancelRecord)按钮的显示状态。
void | setButtonDelete(java.lang.String buttonDelete) 设定“删除一条记录”(DeleteRecord)按钮的显示状态。
void | setButtonInsert(java.lang.String buttonInsert) 设置“插入一条记录”(InsertRecord)按钮的显示状态。
void | setButtonMoveFirst(java.lang.String buttonMoveFirst) 设定“移动到第一条”按钮(MoveFirst)的显示状态。
void | setButtonMoveLast(java.lang.String buttonMoveLast) 设定“移动到最后一条”按钮(MoveLast)的显示状态。
void | setButtonMoveNext(java.lang.String buttonMoveNext) 设定“移动到下一条”按钮(MoveNext)的显示状态。
void | setButtonMovePrev(java.lang.String buttonMovePrev) 设定“移动到上一条”按钮(MovePrev)的显示状态。
void | setButtonNextPage(java.lang.String buttonNextPage) 设定“移动到后一页”按钮(NextPage)的显示状态。
void | setButtonPost(java.lang.String buttonPost) 设定"验证"按钮(PostRecord)的显示状态。
void | setButtonPrevPage(java.lang.String buttonPrevPage) 设定“移动到前一页”按钮(PrevPage)的显示状态。
void | setConfirmCancel(boolean confirmCancel) 设定是否提示用户确认取消操作。
void | setConfirmDelete(boolean confirmDelete) 设定是否提示用户确认删除操作。
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

VISIBLE

public static final java.lang.String VISIBLE
See Also:
Constant Field Values

HIDDEN

public static final java.lang.String HIDDEN
See Also:
Constant Field Values

AUTO

public static final java.lang.String AUTO
See Also:
Constant Field Values
Constructor Detail

DataPilot

public DataPilot(ViewModel viewModel,
                 java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getButtonMoveFirst

public java.lang.String getButtonMoveFirst()
取得“移动到第一条”按钮(MoveFirst)的显示状态。该状态有三种：

  • visible - 可见
  • hidden - 隐藏
  • auto - 自动

Returns:
boolean

setButtonMoveFirst

public void setButtonMoveFirst(java.lang.String buttonMoveFirst)
设定“移动到第一条”按钮(MoveFirst)的显示状态。该状态有三种：

  • visible - 可见
  • hidden - 隐藏
  • auto - 自动

Parameters:
buttonMoveFirst - boolean

getButtonMovePrev

public java.lang.String getButtonMovePrev()
取得“移动到下一条”按钮(MovePrev)的显示状态。该状态有三种：

  • visible - 可见
  • hidden - 隐藏
  • auto - 自动

Returns:
boolean

setButtonMovePrev

public void setButtonMovePrev(java.lang.String buttonMovePrev)
设定“移动到上一条”按钮(MovePrev)的显示状态。该状态有三种：

  • visible - 可见
  • hidden - 隐藏
  • auto - 自动

Parameters:
buttonMovePrev - boolean

getButtonMoveNext

public java.lang.String getButtonMoveNext()
取得“移动到下一条”按钮(MoveNext)的显示状态。

Returns:
boolean

setButtonMoveNext

public void setButtonMoveNext(java.lang.String buttonMoveNext)
设定“移动到下一条”按钮(MoveNext)的显示状态。

Parameters:
buttonMoveNext - boolean

getButtonMoveLast

public java.lang.String getButtonMoveLast()
取得“移动到最后一条”按钮(MoveLast)的显示状态。

Returns:
boolean

setButtonMoveLast

public void setButtonMoveLast(java.lang.String buttonMoveLast)
设定“移动到最后一条”按钮(MoveLast)的显示状态。

Parameters:
buttonMoveLast - boolean

getButtonPrevPage

public java.lang.String getButtonPrevPage()
取得“移动到前一页”按钮(PrevPage)的显示状态。

Returns:
boolean

setButtonPrevPage

public void setButtonPrevPage(java.lang.String buttonPrevPage)
设定“移动到前一页”按钮(PrevPage)的显示状态。

Parameters:
buttonPrevPage - boolean

getButtonNextPage

public java.lang.String getButtonNextPage()
取得“移动到后一页”按钮(NextPage)的显示状态。

Returns:
boolean

setButtonNextPage

public void setButtonNextPage(java.lang.String buttonNextPage)
设定“移动到后一页”按钮(NextPage)的显示状态。

Parameters:
buttonNextPage - boolean

getButtonInsert

public java.lang.String getButtonInsert()
返回“插入一条记录”(InsertRecord)按钮的显示状态。

Returns:
boolean

setButtonInsert

public void setButtonInsert(java.lang.String buttonInsert)
设置“插入一条记录”(InsertRecord)按钮的显示状态。

Parameters:
buttonInsert - boolean

getButtonAppend

public java.lang.String getButtonAppend()
取得“追加一条记录”(AppendRecord)按钮的显示状态。

Returns:
boolean

setButtonAppend

public void setButtonAppend(java.lang.String buttonAppend)
设定“追加一条记录”(AppendRecord)按钮的显示状态。

Parameters:
buttonAppend - boolean

getButtonDelete

public java.lang.String getButtonDelete()
取得“删除一条记录”(DeleteRecord)按钮的显示状态。

Returns:
boolean

setButtonDelete

public void setButtonDelete(java.lang.String buttonDelete)
设定“删除一条记录”(DeleteRecord)按钮的显示状态。

Parameters:
buttonDelete - boolean

getButtonPost

public java.lang.String getButtonPost()
返回"验证"按钮(PostRecord)的显示状态。

Returns:
boolean

setButtonPost

public void setButtonPost(java.lang.String buttonPost)
设定"验证"按钮(PostRecord)的显示状态。

Parameters:
buttonPost - boolean

getButtonCancel

public java.lang.String getButtonCancel()
取得“撤销对当前记录修改”(CancelRecord)按钮的显示状态。

Returns:
boolean

setButtonCancel

public void setButtonCancel(java.lang.String buttonCancel)
设定“撤销对当前记录修改”(CancelRecord)按钮的显示状态。

Parameters:
buttonCancel - boolean

isConfirmDelete

public boolean isConfirmDelete()
返回是否提示用户确认删除操作。

Returns:
boolean

setConfirmDelete

public void setConfirmDelete(boolean confirmDelete)
设定是否提示用户确认删除操作。

Parameters:
confirmDelete - boolean

isConfirmCancel

public boolean isConfirmCancel()
取得是否提示用户确认取消操作。

Returns:
boolean

setConfirmCancel

public void setConfirmCancel(boolean confirmCancel)
设定是否提示用户确认取消操作。

Parameters:
confirmCancel - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultOutlookBarGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class DefaultOutlookBarGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.OutlookBarGroup
        extended by com.bstek.dorado.view.control.DefaultOutlookBarGroup
All Implemented Interfaces:
Element
public class DefaultOutlookBarGroup
extends OutlookBarGroup

Version:
4.0

Constructor Summary
DefaultOutlookBarGroup(java.lang.String name)
DefaultOutlookBarGroup
Method Summary
java.lang.String | getIcon() getIcon
java.lang.String | getLabel() getLabel
java.lang.String | getPadding() getPadding
boolean | isDisabled() isDisabled
boolean | isVisible() isVisible
void | setDisabled(boolean disabled) setDisabled
void | setIcon(java.lang.String icon) setIcon
void | setLabel(java.lang.String label) setLabel
void | setPadding(java.lang.String padding) setPadding
void | setVisible(boolean visible) setVisible
Methods inherited from class com.bstek.dorado.view.control.OutlookBarGroup
getName, getOutlookBar, getTag, setOutlookBar, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultOutlookBarGroup

public DefaultOutlookBarGroup(java.lang.String name)
DefaultOutlookBarGroup

Parameters:
name - String
Method Detail

getLabel

public java.lang.String getLabel()
getLabel

Returns:
String

isDisabled

public boolean isDisabled()
isDisabled

Returns:
boolean

isVisible

public boolean isVisible()
isVisible

Returns:
boolean

setLabel

public void setLabel(java.lang.String label)
setLabel

Parameters:
label - String

setDisabled

public void setDisabled(boolean disabled)
setDisabled

Parameters:
disabled - boolean

setVisible

public void setVisible(boolean visible)
setVisible

Parameters:
visible - boolean

getPadding

public java.lang.String getPadding()
getPadding

Returns:
String

getIcon

public java.lang.String getIcon()
getIcon

Returns:
String

setPadding

public void setPadding(java.lang.String padding)
setPadding

Parameters:
padding - String

setIcon

public void setIcon(java.lang.String icon)
setIcon

Parameters:
icon - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Editor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Editor

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.Editor
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
Direct Known Subclasses:
CheckBox, RadioGroup, TextEditor
public abstract class Editor
extends SimpleDataControl

编辑器的基类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Editor(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getToolTip() 返回该编辑器的弹出式提示信息。
boolean | isReadOnly() 返回编辑框是否只读。
void | setReadOnly(boolean readOnly) 设置编辑框是否只读。
void | setToolTip(java.lang.String toolTip) 设定该编辑器的弹出式提示信息。
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

Editor

public Editor(ViewModel viewModel,
              java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

isReadOnly

public boolean isReadOnly()
返回编辑框是否只读。

Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设置编辑框是否只读。

Parameters:
readOnly - boolean

getToolTip

public java.lang.String getToolTip()
返回该编辑器的弹出式提示信息。

Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定该编辑器的弹出式提示信息。

Parameters:
toolTip - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldLabel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class FieldLabel

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.FieldLabel
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class FieldLabel
extends SimpleDataControl

字段标签对象。

一般用于显示数据集中字段的标题,会自动获取记录集中字段的标题属性用于显示,通过字段可实现国际化功能.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
FieldLabel(ViewModel viewModel, java.lang.String id)
构造器
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

FieldLabel

public FieldLabel(ViewModel viewModel,
                  java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GroupBox

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class GroupBox

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.GroupBox
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class GroupBox
extends PlaceableControl
implements Visible

组合框

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
GroupBox(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getTitle() 获取组合框标题.
boolean | isExpanded() 组合框是否已展开
boolean | isShowExpandButton() 是否显示展开按钮
void | setExpanded(boolean expanded) 设置组合框已展开.默认为true.
void | setShowExpandButton(boolean showExpandButton) 设置是否显示展开按钮..默认为true.
void | setTitle(java.lang.String title) 设置组合框标题.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

GroupBox

public GroupBox(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getTitle

public java.lang.String getTitle()
获取组合框标题.

Returns:
String

setTitle

public void setTitle(java.lang.String title)
设置组合框标题.

Parameters:
title - boolean

isShowExpandButton

public boolean isShowExpandButton()
是否显示展开按钮

Returns:
boolean

setShowExpandButton

public void setShowExpandButton(boolean showExpandButton)
设置是否显示展开按钮..默认为true.

Parameters:
showExpandButton - boolean

isExpanded

public boolean isExpanded()
组合框是否已展开

Returns:
boolean

setExpanded

public void setExpanded(boolean expanded)
设置组合框已展开.默认为true.

Parameters:
expanded - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Label

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Label

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.Label
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class Label
extends PlaceableControl
implements Visible

标签对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Label(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getText() 取得标题的文本内容。
boolean | isEscape() isEscape
void | setEscape(boolean escape) setEscape
void | setText(java.lang.String text) 设定标题的文本内容。
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

Label

public Label(ViewModel viewModel,
             java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getText

public java.lang.String getText()
取得标题的文本内容。

Returns:
String

setText

public void setText(java.lang.String text)
设定标题的文本内容。

Parameters:
text - String

isEscape

public boolean isEscape()
isEscape

Returns:
boolean

setEscape

public void setEscape(boolean escape)
setEscape

Parameters:
escape - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Menu

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Menu

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.Menu
All Implemented Interfaces:
Component, Control, Element, EventSupported, MenuItemContainer
public class Menu
extends com.bstek.dorado.view.control.AbstractControl
implements MenuItemContainer

菜单对象

菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见. 菜单对象可以绑定到各种dorado对象上,常用的有OutLookBar,MenuBar,Button. 另外菜单对象还支持快捷菜单功能,我们可以在各种可视化组件被右键单击时弹出该快捷菜单.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Menu(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
MenuItem | addItem(java.lang.String name) 根据指定菜单项名称添加一个菜单项对象。
MenuItem | addItem(java.lang.String name, java.lang.String label) 根据指定名称、Label，添加一个菜单项对象。
MenuItem | findItem(java.lang.String path) 根据子菜单项的路径返回一个菜单项.
MenuItem | getItem(java.lang.String name) 根据名称取得一个子菜单项
java.util.List | getItems() 取得所有菜单项MunuItem的集合对象。
java.lang.String | getPopupContainer() 取得弹出式菜单的容器的ID.
java.lang.String | getTarget() 取得弹出式菜单需要刷新的目标框架.
void | init(DoradoContext context, XmlNode node)
protected void | loadItems(DoradoContext context, XmlNode node, MenuItem menuItem) 加载菜单项
void | setPopupContainer(java.lang.String popupContainer) 取得弹出式菜单的容器的ID.
void | setTarget(java.lang.String target) 设定弹出式菜单需要刷新的目标框架.该属性一般只与菜单项中的path属性配合使用.
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag

Constructor Detail

Menu

public Menu(ViewModel viewModel,
            java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Throws:
java.lang.Exception

loadItems

protected void loadItems(DoradoContext context,
                         XmlNode node,
                         MenuItem menuItem)
                  throws LoadXmlPropertyException
加载菜单项

Parameters:
context - DoradoContext
node - XmlNode
menuItem - MenuItem
Throws:
LoadXmlPropertyException

addItem

public MenuItem addItem(java.lang.String name)
根据指定菜单项名称添加一个菜单项对象。

Specified by:
addItem in interface MenuItemContainer
Parameters:
name - String
Returns:
MenuItem

addItem

public MenuItem addItem(java.lang.String name,
                        java.lang.String label)
根据指定名称、Label，添加一个菜单项对象。

Specified by:
addItem in interface MenuItemContainer
Parameters:
name - String
label - String
Returns:
MenuItem

getItems

public java.util.List getItems()
取得所有菜单项MunuItem的集合对象。

Specified by:
getItems in interface MenuItemContainer
Returns:
List

getItem

public MenuItem getItem(java.lang.String name)
根据名称取得一个子菜单项

Specified by:
getItem in interface MenuItemContainer
Parameters:
name - String
Returns:
MenuItem

findItem

public MenuItem findItem(java.lang.String path)
根据子菜单项的路径返回一个菜单项.
菜单项的路径为如下格式(可使用/或\或.来进行分隔):

file/save file和save分别是子菜单项的名称.

Parameters:
path - String
Returns:
MenuItem

getPopupContainer

public java.lang.String getPopupContainer()
取得弹出式菜单的容器的ID. 如果有多个容器可用","分隔.

例如：document.body,datatable1

Returns:
String

setPopupContainer

public void setPopupContainer(java.lang.String popupContainer)
取得弹出式菜单的容器的ID. 如果有多个容器可用","分隔.

例如：document.body,datatable1

Parameters:
popupContainer - String

getTarget

public java.lang.String getTarget()
取得弹出式菜单需要刷新的目标框架.

Returns:
String

setTarget

public void setTarget(java.lang.String target)
设定弹出式菜单需要刷新的目标框架.该属性一般只与菜单项中的path属性配合使用.

Parameters:
target - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MenuBar

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class MenuBar

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.MenuBar
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class MenuBar
extends PlaceableControl
implements Visible

菜单工具栏. 可绑定菜单实现类似主菜单的工具栏.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
MenuBar(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getMenu() 取得菜单栏绑定的菜单对象.
boolean | isFitWidth() 返回是否自动调整菜单按钮的宽度以适应整个菜单栏的宽度.
boolean | isShowBorder() 返回是否显示菜单栏的边框.
void | setFitWidth(boolean fitWidth) 设置是否自动调整菜单按钮的宽度以适应整个菜单栏的宽度.
void | setMenu(java.lang.String menu) 设定与菜单栏绑定的菜单对象.
void | setShowBorder(boolean showBorder) 设置是否显示菜单栏的边框.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

MenuBar

public MenuBar(ViewModel viewModel,
               java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getMenu

public java.lang.String getMenu()
取得菜单栏绑定的菜单对象.

Returns:
String

setMenu

public void setMenu(java.lang.String menu)
设定与菜单栏绑定的菜单对象.

Parameters:
menu - String

isShowBorder

public boolean isShowBorder()
返回是否显示菜单栏的边框.

Returns:
boolean

setShowBorder

public void setShowBorder(boolean showBorder)
设置是否显示菜单栏的边框.

Parameters:
showBorder - boolean

isFitWidth

public boolean isFitWidth()
返回是否自动调整菜单按钮的宽度以适应整个菜单栏的宽度.

Returns:
boolean

setFitWidth

public void setFitWidth(boolean fitWidth)
设置是否自动调整菜单按钮的宽度以适应整个菜单栏的宽度.

Parameters:
fitWidth - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MenuItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class MenuItem

java.lang.Object
    extended by com.bstek.dorado.view.control.MenuItem
All Implemented Interfaces:
Element, MenuItemContainer
public class MenuItem
extends java.lang.Object
implements MenuItemContainer

菜单项

一般用于执行URL请求,当用户点击菜单项时菜单可以自动在一个指定的框架中激活该URL. 同时菜单项也支持command绑定功能或单击事件(onClick),在该事件中开发人员可以加入自己的逻辑处理代码,定制菜单项的动作.

Version:
4.0

Constructor Summary
MenuItem(java.lang.String name)
构造器
MenuItem(java.lang.String name, java.lang.String label)
构造器
Method Summary
MenuItem | addItem(java.lang.String name) 根据指定菜单项名称添加一个菜单项对象。
MenuItem | addItem(java.lang.String name, java.lang.String label) 根据指定名称、Label，添加一个菜单项对象。
java.lang.String | getCommand() 取得菜单项对应的命令对象
java.lang.String | getDisableIcon() 取得菜单项失效时的图标的URL.
java.lang.String | getIcon() 取得菜单项的图标的URL.
MenuItem | getItem(java.lang.String name) 根据名称取得一个子菜单项
java.util.List | getItems() 取得所有菜单项MunuItem的集合对象。
java.lang.String | getLabel() 取得菜单项标题.
java.lang.String | getName() 取得菜单项名称.
java.lang.String | getPath() 取得单击菜单项时要打开的URL路径.
java.lang.String | getTag() 取得元素的用户自定义信息。
boolean | isDisabled() 返回菜单项是否无效.
boolean | isVisible() 取得菜单项是否可见.
void | setCommand(java.lang.String command) 设定菜单项对应的命令对象
void | setDisabled(boolean disabled) 设定菜单项是否无效.
void | setDisableIcon(java.lang.String disableIcon) 设置菜单项失效时的图标的URL.
void | setIcon(java.lang.String icon) 设置菜单项的图标的URL.
void | setLabel(java.lang.String label) 设定菜单项标题.
void | setName(java.lang.String name) 设定菜单项名称.
void | setPath(java.lang.String path) 设定单击菜单项时要打开的URL路径.
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setVisible(boolean visible) 设定菜单项是否可见.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MenuItem

public MenuItem(java.lang.String name)
构造器

Parameters:
name - String

MenuItem

public MenuItem(java.lang.String name,
                java.lang.String label)
构造器

Parameters:
name - String
label - String
Method Detail

addItem

public MenuItem addItem(java.lang.String name)
根据指定菜单项名称添加一个菜单项对象。

Specified by:
addItem in interface MenuItemContainer
Parameters:
name - String
Returns:
MenuItem

addItem

public MenuItem addItem(java.lang.String name,
                        java.lang.String label)
根据指定名称、Label，添加一个菜单项对象。

Specified by:
addItem in interface MenuItemContainer
Parameters:
name - String
label - String
Returns:
MenuItem

getItems

public java.util.List getItems()
取得所有菜单项MunuItem的集合对象。

Specified by:
getItems in interface MenuItemContainer
Returns:
List

getItem

public MenuItem getItem(java.lang.String name)
根据名称取得一个子菜单项

Specified by:
getItem in interface MenuItemContainer
Parameters:
name - String
Returns:
MenuItem

getName

public java.lang.String getName()
取得菜单项名称.

Returns:
String

setName

public void setName(java.lang.String name)
设定菜单项名称.

Parameters:
name - String

getLabel

public java.lang.String getLabel()
取得菜单项标题.

Returns:
String

setLabel

public void setLabel(java.lang.String label)
设定菜单项标题.

Parameters:
label - String

getIcon

public java.lang.String getIcon()
取得菜单项的图标的URL.

Returns:
String

setIcon

public void setIcon(java.lang.String icon)
设置菜单项的图标的URL.

Parameters:
icon - String

getDisableIcon

public java.lang.String getDisableIcon()
取得菜单项失效时的图标的URL.

Returns:
String

setDisableIcon

public void setDisableIcon(java.lang.String disableIcon)
设置菜单项失效时的图标的URL.

Parameters:
disableIcon - String

isDisabled

public boolean isDisabled()
返回菜单项是否无效.

Returns:
boolean

setDisabled

public void setDisabled(boolean disabled)
设定菜单项是否无效.

Parameters:
disabled - boolean

isVisible

public boolean isVisible()
取得菜单项是否可见.

Returns:
boolean

setVisible

public void setVisible(boolean visible)
设定菜单项是否可见.

Parameters:
visible - boolean

getPath

public java.lang.String getPath()
取得单击菜单项时要打开的URL路径.

Returns:
String

setPath

public void setPath(java.lang.String path)
设定单击菜单项时要打开的URL路径.

Parameters:
path - String

getCommand

public java.lang.String getCommand()
取得菜单项对应的命令对象

Returns:
String

setCommand

public void setCommand(java.lang.String command)
设定菜单项对应的命令对象

Parameters:
command - String

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MenuItemContainer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Interface MenuItemContainer

All Superinterfaces:
Element
All Known Implementing Classes:
Menu, MenuItem
public interface MenuItemContainer
extends Element

菜单项容器的接口

Version:
4.0

Method Summary
MenuItem | addItem(java.lang.String name) 根据指定菜单项名称添加一个菜单项对象。
MenuItem | addItem(java.lang.String name, java.lang.String label) 根据指定名称、Label，添加一个菜单项对象。
MenuItem | getItem(java.lang.String name) 根据名称取得一个子菜单项
java.util.List | getItems() 取得所有菜单项MunuItem的集合对象。
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag

Method Detail

addItem

public MenuItem addItem(java.lang.String name)
根据指定菜单项名称添加一个菜单项对象。

Parameters:
name - String
Returns:
MenuItem

addItem

public MenuItem addItem(java.lang.String name,
                        java.lang.String label)
根据指定名称、Label，添加一个菜单项对象。

Parameters:
name - String
label - String
Returns:
MenuItem

getItems

public java.util.List getItems()
取得所有菜单项MunuItem的集合对象。

Returns:
List

getItem

public MenuItem getItem(java.lang.String name)
根据名称取得一个子菜单项

Parameters:
name - String
Returns:
MenuItem
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MenuOutlookBarGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class MenuOutlookBarGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.OutlookBarGroup
        extended by com.bstek.dorado.view.control.MenuOutlookBarGroup
All Implemented Interfaces:
Element
public class MenuOutlookBarGroup
extends OutlookBarGroup

Version:
4.0

Field Summary
static java.lang.String | VIEWMODE_ICON VIEWMODE_FLOW
static java.lang.String | VIEWMODE_LIST VIEWMODE_HORIZONTAL
Constructor Summary
MenuOutlookBarGroup(java.lang.String name)
MenuOutlookBarGroup
Method Summary
java.lang.String | getViewMode() getViewMode
void | setViewMode(java.lang.String viewMode) setViewMode
Methods inherited from class com.bstek.dorado.view.control.OutlookBarGroup
getName, getOutlookBar, getTag, setOutlookBar, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VIEWMODE_ICON

public static final java.lang.String VIEWMODE_ICON
VIEWMODE_FLOW

See Also:
Constant Field Values

VIEWMODE_LIST

public static final java.lang.String VIEWMODE_LIST
VIEWMODE_HORIZONTAL

See Also:
Constant Field Values
Constructor Detail

MenuOutlookBarGroup

public MenuOutlookBarGroup(java.lang.String name)
MenuOutlookBarGroup

Parameters:
name - String
Method Detail

getViewMode

public java.lang.String getViewMode()
getViewMode

Returns:
String

setViewMode

public void setViewMode(java.lang.String viewMode)
setViewMode

Parameters:
viewMode - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OutlookBar

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class OutlookBar

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.OutlookBar
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class OutlookBar
extends PlaceableControl
implements Visible

Outlook工具栏

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
OutlookBar(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
void | addGroup(OutlookBarGroup group) addGroup
java.lang.String | getCurrentGroup() getCurrentGroup
OutlookBarGroup | getGroup(int index) getGroup
OutlookBarGroup | getGroup(java.lang.String name) getGroup
int | getGroupCount() getGroupCount
ObjectCollection | getGroups() 取得所有多页标签的集合对象。
java.lang.String | getMenu() 取得绑定的菜单对象.
void | init(DoradoContext context, XmlNode node)
boolean | isAnimated() isAnimated
void | setAnimated(boolean animated) setAnimated
void | setCurrentGroup(java.lang.String currentGroup) setCurrentGroup
void | setMenu(java.lang.String menu) 设定绑定的菜单对象.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

OutlookBar

public OutlookBar(ViewModel viewModel,
                  java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getMenu

public java.lang.String getMenu()
取得绑定的菜单对象.

Returns:
String

setMenu

public void setMenu(java.lang.String menu)
设定绑定的菜单对象.

Parameters:
menu - String

isAnimated

public boolean isAnimated()
isAnimated

Returns:
boolean

setAnimated

public void setAnimated(boolean animated)
setAnimated

Parameters:
animated - boolean

addGroup

public void addGroup(OutlookBarGroup group)
addGroup

Parameters:
group - OutlookBarGroup

getGroupCount

public int getGroupCount()
getGroupCount

Returns:
int

getGroup

public OutlookBarGroup getGroup(int index)
getGroup

Parameters:
index - int
Returns:
OutlookBarGroup

getGroup

public OutlookBarGroup getGroup(java.lang.String name)
getGroup

Parameters:
name - String
Returns:
OutlookBarGroup

getGroups

public ObjectCollection getGroups()
取得所有多页标签的集合对象。

Returns:
ObjectCollection

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Throws:
java.lang.Exception

getCurrentGroup

public java.lang.String getCurrentGroup()
getCurrentGroup

Returns:
String

setCurrentGroup

public void setCurrentGroup(java.lang.String currentGroup)
setCurrentGroup

Parameters:
currentGroup - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OutlookBarGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class OutlookBarGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.OutlookBarGroup
All Implemented Interfaces:
Element
Direct Known Subclasses:
DefaultOutlookBarGroup, MenuOutlookBarGroup
public abstract class OutlookBarGroup
extends java.lang.Object
implements Element

Version:
4.0

Constructor Summary
OutlookBarGroup(java.lang.String name)
构造器
Method Summary
java.lang.String | getName() getName
OutlookBar | getOutlookBar() getOutlookBar
java.lang.String | getTag() getTag
void | setOutlookBar(OutlookBar outlookBar) setOutlookBar
void | setTag(java.lang.String tag) setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OutlookBarGroup

public OutlookBarGroup(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getName

public java.lang.String getName()
getName

Returns:
String

setOutlookBar

public void setOutlookBar(OutlookBar outlookBar)
setOutlookBar

Parameters:
outlookBar - OutlookBar

getOutlookBar

public OutlookBar getOutlookBar()
getOutlookBar

Returns:
OutlookBar

setTag

public void setTag(java.lang.String tag)
setTag

Specified by:
setTag in interface Element
Parameters:
tag - String

getTag

public java.lang.String getTag()
getTag

Specified by:
getTag in interface Element
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control

各种控件类及实现
See:
Description

Interface Summary
Control | 控件的接口
MenuItemContainer | 菜单项容器的接口
Placeable | 支持界面定位的控件的接口
Visible | 可见控件的接口

Class Summary
Button | 按钮对象
Calendar | 日历
CheckBox | 复选框
DataControl | 数据控件对象接口
DataLabel | 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
DataPilot | 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
DefaultOutlookBarGroup |
Editor | 编辑器的基类
FieldLabel | 字段标签对象。
GroupBox | 组合框
Label | 标签对象
Menu | 菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
MenuBar | 菜单工具栏.
MenuItem | 菜单项 一般用于执行URL请求,当用户点击菜单项时菜单可以自动在一个指定的框架中激活该URL.
MenuOutlookBarGroup |
OutlookBar | Outlook工具栏
OutlookBarGroup |
PagePilot | 分页导航条.
PlaceableControl | 支持界面定位的控件的抽象类
PlaceableDataControl | 支持界面定位的数据控件的抽象类
ProgressBar |
RadioGroup | 单选框组合.
ScrollBar | 滚动条
SimpleDataControl | 简单数据控件对象
Span | 控件的辅助类
SplitPanel | 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
SubWindow | 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
TextEditor | 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Package com.bstek.dorado.view.control Description

各种控件类及实现


PagePilot

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class PagePilot

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.PagePilot
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class PagePilot
extends PlaceableDataControl
implements Visible

分页导航条. 用于对数据集实现翻页浏览的导航条.

Version:
4.0

Field Summary
static java.lang.String | TYPE_BUTTON TYPE_BUTTON
static java.lang.String | TYPE_LINK TYPE_LINK
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
PagePilot(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
int | getMaxLink() 取得页码导航条(PagePilot)最大连续可见页数。
java.lang.String | getPilotType() 取得分页导航对象的类型，可取值为"link","button"。
boolean | isShowGotoButton() 返回是否显示跳转到按钮(GotoButton)。
boolean | isShowPageInfo() 返回是否显示页信息。
void | setMaxLink(int maxLink) 取得页码导航条(PagePilot)最大连续可见页数。
void | setPilotType(java.lang.String pilotType) 设置分页导航对象的类型，可取值为"link","button"。
void | setShowGotoButton(boolean showGotoButton) 设置是否显示跳转到按钮(GotoButton)。
void | setShowPageInfo(boolean showPageInfo) 设置是否显示页信息。
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

TYPE_LINK

public static final java.lang.String TYPE_LINK
TYPE_LINK

See Also:
Constant Field Values

TYPE_BUTTON

public static final java.lang.String TYPE_BUTTON
TYPE_BUTTON

See Also:
Constant Field Values
Constructor Detail

PagePilot

public PagePilot(ViewModel viewModel,
                 java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getPilotType

public java.lang.String getPilotType()
取得分页导航对象的类型，可取值为"link","button"。

Returns:
String

setPilotType

public void setPilotType(java.lang.String pilotType)
设置分页导航对象的类型，可取值为"link","button"。

Parameters:
pilotType - String

getMaxLink

public int getMaxLink()
取得页码导航条(PagePilot)最大连续可见页数。

Returns:
int

setMaxLink

public void setMaxLink(int maxLink)
取得页码导航条(PagePilot)最大连续可见页数。

Parameters:
maxLink - int

isShowPageInfo

public boolean isShowPageInfo()
返回是否显示页信息。如果为true,系统将自动显示"第X页/共XX页"的信息。

Returns:
boolean

setShowPageInfo

public void setShowPageInfo(boolean showPageInfo)
设置是否显示页信息。如果为true,系统将自动显示"第X页/共XX页"的信息。

Parameters:
showPageInfo - boolean

isShowGotoButton

public boolean isShowGotoButton()
返回是否显示跳转到按钮(GotoButton)。如果为true，则该对象自动提供跳转到功能。

Returns:
boolean

setShowGotoButton

public void setShowGotoButton(boolean showGotoButton)
设置是否显示跳转到按钮(GotoButton)。如果为true，则该对象自动提供跳转到功能。

Parameters:
showGotoButton - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Placeable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Interface Placeable

All Known Subinterfaces:
Visible
All Known Implementing Classes:
Button, DataPilot, GroupBox, Label, MenuBar, OutlookBar, PagePilot, PlaceableControl, PlaceableDataControl, ScrollBar, SimpleDataControl, SplitPanel, SubWindow, Table, TabSet, Tree
public interface Placeable

支持界面定位的控件的接口

Version:
4.0

Method Summary
java.lang.String | getHeight() 返回控件的高度
java.lang.String | getLeft() 返回控件距离父对象左边的距离
java.lang.String | getStyle() 设置控件的风格设置
java.lang.String | getTop() 返回控件距离父对象顶边的距离
java.lang.String | getWidth() 返回控件的宽度
void | setHeight(java.lang.String height) 设置控件的高度
void | setLeft(java.lang.String left) 设置控件距离父对象左边的距离
void | setStyle(java.lang.String style) 返回控件的风格设置
void | setTop(java.lang.String top) 设置距离父对象顶边的距离
void | setWidth(java.lang.String width) 设置控件的宽度

Method Detail

getLeft

public java.lang.String getLeft()
返回控件距离父对象左边的距离

Returns:
String

setLeft

public void setLeft(java.lang.String left)
设置控件距离父对象左边的距离

Parameters:
left - String

getTop

public java.lang.String getTop()
返回控件距离父对象顶边的距离

Returns:
String

setTop

public void setTop(java.lang.String top)
设置距离父对象顶边的距离

Parameters:
top - String

getWidth

public java.lang.String getWidth()
返回控件的宽度

Returns:
String

setWidth

public void setWidth(java.lang.String width)
设置控件的宽度

Parameters:
width - String

getHeight

public java.lang.String getHeight()
返回控件的高度

Returns:
String

setHeight

public void setHeight(java.lang.String height)
设置控件的高度

Parameters:
height - String

setStyle

public void setStyle(java.lang.String style)
返回控件的风格设置

Parameters:
style - String

getStyle

public java.lang.String getStyle()
设置控件的风格设置

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PlaceableControl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class PlaceableControl

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable
Direct Known Subclasses:
Button, GroupBox, Label, MenuBar, OutlookBar, ScrollBar, SplitPanel, SubWindow, TabSet, Tree
public abstract class PlaceableControl
extends com.bstek.dorado.view.control.AbstractControl
implements Placeable

支持界面定位的控件的抽象类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
PlaceableControl(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getHeight() 返回控件的高度
java.lang.String | getLeft() 返回控件距离父对象左边的距离
java.lang.String | getStyle() 设置控件的风格设置
java.lang.String | getTop() 返回控件距离父对象顶边的距离
java.lang.String | getWidth() 返回控件的宽度
void | setHeight(java.lang.String height) 设置控件的高度
void | setLeft(java.lang.String left) 设置控件距离父对象左边的距离
void | setStyle(java.lang.String style) 返回控件的风格设置
void | setTop(java.lang.String top) 设置距离父对象顶边的距离
void | setWidth(java.lang.String width) 设置控件的宽度
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PlaceableControl

public PlaceableControl(ViewModel viewModel,
                        java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getLeft

public java.lang.String getLeft()
返回控件距离父对象左边的距离

Specified by:
getLeft in interface Placeable
Returns:
String

setLeft

public void setLeft(java.lang.String left)
设置控件距离父对象左边的距离

Specified by:
setLeft in interface Placeable
Parameters:
left - String

getTop

public java.lang.String getTop()
返回控件距离父对象顶边的距离

Specified by:
getTop in interface Placeable
Returns:
String

setTop

public void setTop(java.lang.String top)
设置距离父对象顶边的距离

Specified by:
setTop in interface Placeable
Parameters:
top - String

getWidth

public java.lang.String getWidth()
返回控件的宽度

Specified by:
getWidth in interface Placeable
Returns:
String

setWidth

public void setWidth(java.lang.String width)
设置控件的宽度

Specified by:
setWidth in interface Placeable
Parameters:
width - String

getHeight

public java.lang.String getHeight()
返回控件的高度

Specified by:
getHeight in interface Placeable
Returns:
String

setHeight

public void setHeight(java.lang.String height)
设置控件的高度

Specified by:
setHeight in interface Placeable
Parameters:
height - String

getStyle

public java.lang.String getStyle()
设置控件的风格设置

Specified by:
getStyle in interface Placeable
Returns:
String

setStyle

public void setStyle(java.lang.String style)
返回控件的风格设置

Specified by:
setStyle in interface Placeable
Parameters:
style - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PlaceableDataControl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class PlaceableDataControl

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable
Direct Known Subclasses:
AutoForm, DataPilot, PagePilot, SimpleDataControl, Table
public abstract class PlaceableDataControl
extends DataControl
implements Placeable

支持界面定位的数据控件的抽象类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
PlaceableDataControl(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getHeight() 返回控件的高度
java.lang.String | getLeft() 返回控件距离父对象左边的距离
java.lang.String | getStyle() 设置控件的风格设置
java.lang.String | getTop() 返回控件距离父对象顶边的距离
java.lang.String | getWidth() 返回控件的宽度
void | setHeight(java.lang.String height) 设置控件的高度
void | setLeft(java.lang.String left) 设置控件距离父对象左边的距离
void | setStyle(java.lang.String style) 返回控件的风格设置
void | setTop(java.lang.String top) 设置距离父对象顶边的距离
void | setWidth(java.lang.String width) 设置控件的宽度
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PlaceableDataControl

public PlaceableDataControl(ViewModel viewModel,
                            java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getLeft

public java.lang.String getLeft()
返回控件距离父对象左边的距离

Specified by:
getLeft in interface Placeable
Returns:
String

setLeft

public void setLeft(java.lang.String left)
设置控件距离父对象左边的距离

Specified by:
setLeft in interface Placeable
Parameters:
left - String

getTop

public java.lang.String getTop()
返回控件距离父对象顶边的距离

Specified by:
getTop in interface Placeable
Returns:
String

setTop

public void setTop(java.lang.String top)
设置距离父对象顶边的距离

Specified by:
setTop in interface Placeable
Parameters:
top - String

getWidth

public java.lang.String getWidth()
返回控件的宽度

Specified by:
getWidth in interface Placeable
Returns:
String

setWidth

public void setWidth(java.lang.String width)
设置控件的宽度

Specified by:
setWidth in interface Placeable
Parameters:
width - String

getHeight

public java.lang.String getHeight()
返回控件的高度

Specified by:
getHeight in interface Placeable
Returns:
String

setHeight

public void setHeight(java.lang.String height)
设置控件的高度

Specified by:
setHeight in interface Placeable
Parameters:
height - String

getStyle

public java.lang.String getStyle()
设置控件的风格设置

Specified by:
getStyle in interface Placeable
Returns:
String

setStyle

public void setStyle(java.lang.String style)
返回控件的风格设置

Specified by:
setStyle in interface Placeable
Parameters:
style - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProgressBar

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class ProgressBar

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.ProgressBar
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class ProgressBar
extends SimpleDataControl

Version:
4.0

Field Summary
static java.lang.String | ORIENTATION_HORIZONTAL ORIENTATION_HORIZONTAL
static java.lang.String | ORIENTATION_VERTICAL ORIENTATION_VERTICAL
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
ProgressBar(ViewModel viewModel, java.lang.String id)
ProgressBar
Method Summary
int | getMax() 获得进度条可取最大值。
int | getMin() 获得进度条可取最小值。
java.lang.String | getOrientation() 获得进度条对象(ProgressBar)的类型。
int | getPosition() 返回进度信息。
java.lang.String | getTextPattern() 返回文本格式。
boolean | isShowText() 返回是否显示文本信息。
void | setMax(int max) 设置进度条最大可取值。
void | setMin(int min) 设置进度条最小可取值。
void | setOrientation(java.lang.String orientation) 设置进度条对象(ProgressBar)的类型。
void | setPosition(int position) 设置进度条进度位置。
void | setShowText(boolean showText) 设置是否显示数据，否则只显示进度信息。
void | setTextPattern(java.lang.String textPattern) 设置文本格式，通过设置该格式，我们可以自定义显示格式。
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

ORIENTATION_HORIZONTAL

public static final java.lang.String ORIENTATION_HORIZONTAL
ORIENTATION_HORIZONTAL

See Also:
Constant Field Values

ORIENTATION_VERTICAL

public static final java.lang.String ORIENTATION_VERTICAL
ORIENTATION_VERTICAL

See Also:
Constant Field Values
Constructor Detail

ProgressBar

public ProgressBar(ViewModel viewModel,
                   java.lang.String id)
ProgressBar

Parameters:
viewModel - ViewModel
id - String
Method Detail

setOrientation

public void setOrientation(java.lang.String orientation)
设置进度条对象(ProgressBar)的类型。可选值有:"horizontal","vertical"。

Parameters:
orientation - String

setMin

public void setMin(int min)
设置进度条最小可取值。

Parameters:
min - int

setMax

public void setMax(int max)
设置进度条最大可取值。

Parameters:
max - int

setPosition

public void setPosition(int position)
设置进度条进度位置。

Parameters:
position - int

getOrientation

public java.lang.String getOrientation()
获得进度条对象(ProgressBar)的类型。可选值有:"horizontal","vertical"。默认为"horizontal";

Returns:
String

getMin

public int getMin()
获得进度条可取最小值。

Returns:
int

getMax

public int getMax()
获得进度条可取最大值。

Returns:
int

getPosition

public int getPosition()
返回进度信息。

Returns:
int

isShowText

public boolean isShowText()
返回是否显示文本信息。

Returns:
boolean

getTextPattern

public java.lang.String getTextPattern()
返回文本格式。

Returns:
String

setShowText

public void setShowText(boolean showText)
设置是否显示数据，否则只显示进度信息。

Parameters:
showText - boolean

setTextPattern

public void setTextPattern(java.lang.String textPattern)
设置文本格式，通过设置该格式，我们可以自定义显示格式。如:"%d%"。

Parameters:
textPattern - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RadioGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class RadioGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.Editor
                        extended by com.bstek.dorado.view.control.RadioGroup
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class RadioGroup
extends Editor

单选框组合.

单选框组合可以自动管理一组单选框,用以实现单选操作.
单选框组合可以通过绑定一个继承自SimpleDropDown的简单类型的下拉框(如: ListDropDown或DatasetDropDown)自动的生成其中的单选框. 单选框组合会将下拉框中的每个选项自动的映射成一个单选框.

Version:
4.0

Field Summary
static java.lang.String | FLOW FLOW
static java.lang.String | HORIZONTAL HORIZONTAL
static java.lang.String | VERTICAL VERTICAL
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
RadioGroup(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getDropDown() 取得绑定的下拉框
java.lang.String | getLayout() 取得内部对象的排列方式
java.lang.String | getToolTip() 取得弹出式提示(ToolTip)。
void | setDropDown(java.lang.String dropDown) 设定绑定的下拉框
void | setLayout(java.lang.String layout) 设定内部对象的排列方式
void | setToolTip(java.lang.String toolTip) 设定弹出式提示(ToolTip)。
Methods inherited from class com.bstek.dorado.view.control.Editor
isReadOnly, setReadOnly
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

FLOW

public static final java.lang.String FLOW
FLOW

See Also:
Constant Field Values

HORIZONTAL

public static final java.lang.String HORIZONTAL
HORIZONTAL

See Also:
Constant Field Values

VERTICAL

public static final java.lang.String VERTICAL
VERTICAL

See Also:
Constant Field Values
Constructor Detail

RadioGroup

public RadioGroup(ViewModel viewModel,
                  java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getDropDown

public java.lang.String getDropDown()
取得绑定的下拉框

Returns:
String

setDropDown

public void setDropDown(java.lang.String dropDown)
设定绑定的下拉框

Parameters:
dropDown - String

getToolTip

public java.lang.String getToolTip()
取得弹出式提示(ToolTip)。

Overrides:
getToolTip in class Editor
Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定弹出式提示(ToolTip)。

Overrides:
setToolTip in class Editor
Parameters:
toolTip - String

getLayout

public java.lang.String getLayout()
取得内部对象的排列方式

Returns:
String

setLayout

public void setLayout(java.lang.String layout)
设定内部对象的排列方式

Parameters:
layout - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScrollBar

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class ScrollBar

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.ScrollBar
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class ScrollBar
extends PlaceableControl
implements Visible

滚动条

Version:
4.0

Field Summary
static java.lang.String | DRAGMODE_MOUSEMOVE 拖动方式 - 鼠标移动时即滚动
static java.lang.String | DRAGMODE_MOUSEUP 拖动方式 - 鼠标抬起时才滚动
static java.lang.String | ORIENTATION_HORIZONTAL 方向 - 水平
static java.lang.String | ORIENTATION_VERTICAL 方向 - 垂直
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
ScrollBar(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
int | getBigChange() 取得当用户点击滚动条的空白区域时引起的滚动量.
java.lang.String | getDragMode() 返回滚动条拖动类型.
int | getMax() 取得滚动条可滚动的最大值.
int | getMin() 取得滚动条可滚动的最小值.
java.lang.String | getOrientation() 返回滚动条的方向.
int | getPageSize() 取得对应的可见区域的大小.
int | getPosition() 返回滚动条默认位置.
java.lang.String | getShowDraggingTip() 返回滚动条拖动时是否显示系统提示信息.
int | getSmallChange() 取得当用户点击两个滚动按钮时引起的滚动量.
void | setBigChange(int bigChange) 设置当用户点击滚动条的空白区域时引起的滚动量.
void | setDragMode(java.lang.String dragMode) 设置滚动条的拖动类型.默认值为"mousemove".
void | setMax(int max) 设置滚动条可滚动到的最大位置值.
void | setMin(int min) 设置滚动条可滚动到的最小位置值.
void | setOrientation(java.lang.String orientation) 设置滚动条的方向.默认为"horizontal".
void | setPageSize(int pageSize) 设置对应的可见区域的大小.此属性与滚动条中滑块的大小有关.
void | setPosition(int position) 设置滚动条的默认所处位置值.
void | setShowDraggingTip(java.lang.String showDraggingTip) 设置滚动条拖动时是否显示系统提示信息.
void | setSmallChange(int smallChange) 设置当用户点击两个滚动按钮时引起的滚动量.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

ORIENTATION_HORIZONTAL

public static final java.lang.String ORIENTATION_HORIZONTAL
方向 - 水平

See Also:
Constant Field Values

ORIENTATION_VERTICAL

public static final java.lang.String ORIENTATION_VERTICAL
方向 - 垂直

See Also:
Constant Field Values

DRAGMODE_MOUSEUP

public static final java.lang.String DRAGMODE_MOUSEUP
拖动方式 - 鼠标抬起时才滚动

See Also:
Constant Field Values

DRAGMODE_MOUSEMOVE

public static final java.lang.String DRAGMODE_MOUSEMOVE
拖动方式 - 鼠标移动时即滚动

See Also:
Constant Field Values
Constructor Detail

ScrollBar

public ScrollBar(ViewModel viewModel,
                 java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

setOrientation

public void setOrientation(java.lang.String orientation)
设置滚动条的方向.默认为"horizontal".
取值范围:
  • horizontal - 水平
  • vertical - 垂直

Parameters:
orientation - String

setPosition

public void setPosition(int position)
设置滚动条的默认所处位置值.

Parameters:
position - int

setMin

public void setMin(int min)
设置滚动条可滚动到的最小位置值.

Parameters:
min - int

setMax

public void setMax(int max)
设置滚动条可滚动到的最大位置值.

Parameters:
max - int

setSmallChange

public void setSmallChange(int smallChange)
设置当用户点击两个滚动按钮时引起的滚动量.

Parameters:
smallChange - int

setBigChange

public void setBigChange(int bigChange)
设置当用户点击滚动条的空白区域时引起的滚动量.

Parameters:
bigChange - int

setPageSize

public void setPageSize(int pageSize)
设置对应的可见区域的大小.此属性与滚动条中滑块的大小有关.

Parameters:
pageSize - int

setShowDraggingTip

public void setShowDraggingTip(java.lang.String showDraggingTip)
设置滚动条拖动时是否显示系统提示信息.

Parameters:
showDraggingTip - String

setDragMode

public void setDragMode(java.lang.String dragMode)
设置滚动条的拖动类型.默认值为"mousemove".
取值范围:
  • mouseup - 鼠标抬起时才滚动
  • mousemove - 鼠标移动时即滚动

Parameters:
dragMode - String

getOrientation

public java.lang.String getOrientation()
返回滚动条的方向.

Returns:
String

getPosition

public int getPosition()
返回滚动条默认位置.

Returns:
int

getMin

public int getMin()
取得滚动条可滚动的最小值.

Returns:
int

getMax

public int getMax()
取得滚动条可滚动的最大值.

Returns:
int

getSmallChange

public int getSmallChange()
取得当用户点击两个滚动按钮时引起的滚动量.

Returns:
int

getBigChange

public int getBigChange()
取得当用户点击滚动条的空白区域时引起的滚动量.

Returns:
int

getPageSize

public int getPageSize()
取得对应的可见区域的大小.

Returns:
int

getShowDraggingTip

public java.lang.String getShowDraggingTip()
返回滚动条拖动时是否显示系统提示信息.

Returns:
String

getDragMode

public java.lang.String getDragMode()
返回滚动条拖动类型.

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleDataControl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class SimpleDataControl

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
Direct Known Subclasses:
Calendar, DataLabel, Editor, FieldLabel, ProgressBar
public abstract class SimpleDataControl
extends PlaceableDataControl
implements Visible

简单数据控件对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
SimpleDataControl(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getField() 返回Field名称。
Field | getFieldInstance() 取得一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。
void | setField(java.lang.String field) 设定一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

SimpleDataControl

public SimpleDataControl(ViewModel viewModel,
                         java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
Method Detail

getField

public java.lang.String getField()
返回Field名称。

Returns:
String

getFieldInstance

public Field getFieldInstance()
取得一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。

Returns:
Field

setField

public void setField(java.lang.String field)
设定一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。

Parameters:
field - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Span

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class Span

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.Span
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class Span
extends com.bstek.dorado.view.control.AbstractControl

控件的辅助类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Span(ViewModel viewModel, java.lang.String id)
构造器
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Span

public Span(ViewModel viewModel,
            java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SplitPanel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class SplitPanel

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.SplitPanel
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class SplitPanel
extends PlaceableControl
implements Visible

视图分割栏

用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.

Version:
4.0

Field Summary
static java.lang.String | ORIENTATION_HORIZONTAL 方向 - 水平
static java.lang.String | ORIENTATION_VERTICAL 方向 - 垂直
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
SplitPanel(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getOrientation() 返回视图分割栏方向.
int | getPadding() 返回视图分割栏四周留白的宽度.
java.lang.String | getPosition() 取得视图分割栏中滑动条的默认位置.
boolean | isDraggable() 是否允许拖动
boolean | isShowButtons() 返回是否显示视图分割栏上的快捷按钮.
void | setDraggable(boolean draggable) 设置是否允许拖动.默认为true.
void | setOrientation(java.lang.String orientation) 设置视图分割栏方向.默认为"horizontal".
void | setPadding(int padding) 设置视图分割栏四周留白的宽度.
void | setPosition(java.lang.String position) 设定视图分割栏中滑动条的默认位置.
void | setShowButtons(boolean showButtons) 设置是否视图分割栏上的快捷按钮.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

ORIENTATION_HORIZONTAL

public static final java.lang.String ORIENTATION_HORIZONTAL
方向 - 水平

See Also:
Constant Field Values

ORIENTATION_VERTICAL

public static final java.lang.String ORIENTATION_VERTICAL
方向 - 垂直

See Also:
Constant Field Values
Constructor Detail

SplitPanel

public SplitPanel(ViewModel viewModel,
                  java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getOrientation

public java.lang.String getOrientation()
返回视图分割栏方向.

Returns:
String

setOrientation

public void setOrientation(java.lang.String orientation)
设置视图分割栏方向.默认为"horizontal".
取值范围:
  • horizontal - 水平
  • vertical - 垂直

Parameters:
orientation - String

getPadding

public int getPadding()
返回视图分割栏四周留白的宽度.

Returns:
int

setPadding

public void setPadding(int padding)
设置视图分割栏四周留白的宽度.

Parameters:
padding - int

isDraggable

public boolean isDraggable()
是否允许拖动

Returns:
boolean

setDraggable

public void setDraggable(boolean draggable)
设置是否允许拖动.默认为true.

Parameters:
draggable - boolean

isShowButtons

public boolean isShowButtons()
返回是否显示视图分割栏上的快捷按钮.

Returns:
boolean

setShowButtons

public void setShowButtons(boolean showButtons)
设置是否视图分割栏上的快捷按钮.

Parameters:
showButtons - boolean

getPosition

public java.lang.String getPosition()
取得视图分割栏中滑动条的默认位置.

Returns:
String

setPosition

public void setPosition(java.lang.String position)
设定视图分割栏中滑动条的默认位置.

Parameters:
position - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubWindow

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class SubWindow

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.SubWindow
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class SubWindow
extends PlaceableControl
implements Visible

子窗体

用于将客户端的界面划分为不同的窗体,类似于protal风格. 可以实现窗体的最大化,最小化,以及窗体大小改变的功能.

Version:
4.0

Field Summary
static java.lang.String | HIDDEN 窗体状态 - 隐藏
static java.lang.String | MAXIMIZE 窗体状态 - 最大化
static java.lang.String | MINIMIZE 窗体状态 - 最小化
static java.lang.String | NO_ACTION 不操作
static java.lang.String | NORMAL 窗体状态 - 常态
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
SubWindow(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getStatus() 返回子窗体状态.
java.lang.String | getTitle() 获取子窗体标题.
java.lang.String | getTitleClickAction() 返回当用户单击窗体标题栏时执行的操作.
java.lang.String | getTitleDblClickAction() 返回当用户双击窗体标题栏时执行的操作.
boolean | isDraggable() 返回是否允许通过拖动改变位置.
boolean | isResizable() 返回是否允许改变大小.
boolean | isShowCloseButton() 返回是否显示关闭系统按钮.
boolean | isShowMaximizeButton() 返回是否显示最大化按钮.
boolean | isShowMinimizeButton() 返回是否显示最小化按钮.
void | setDraggable(boolean draggable) 设置是否允许通过拖动改变位置.
void | setResizable(boolean resizable) 设置是否允许改变大小.
void | setShowCloseButton(boolean showCloseButton) 设置是否显示关闭系统按钮.
void | setShowMaximizeButton(boolean showMaximizeButton) 设置是否显示最大化按钮.
void | setShowMinimizeButton(boolean showMinimizeButton) 设置是否显示最小化按钮.
void | setStatus(java.lang.String status) 设置窗体状态.默认值为"normal".
void | setTitle(java.lang.String title) 设置子窗体标题.
void | setTitleClickAction(java.lang.String titleClickAction) 设置当用户单击窗体标题栏时执行的操作.默认值为null(即不做动作).
void | setTitleDblClickAction(java.lang.String titleDblClickAction) 设置当用户双击窗体标题栏时执行的操作.默认值为"maximize".
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

NORMAL

public static final java.lang.String NORMAL
窗体状态 - 常态

See Also:
Constant Field Values

MINIMIZE

public static final java.lang.String MINIMIZE
窗体状态 - 最小化

See Also:
Constant Field Values

MAXIMIZE

public static final java.lang.String MAXIMIZE
窗体状态 - 最大化

See Also:
Constant Field Values

HIDDEN

public static final java.lang.String HIDDEN
窗体状态 - 隐藏

See Also:
Constant Field Values

NO_ACTION

public static final java.lang.String NO_ACTION
不操作

See Also:
Constant Field Values
Constructor Detail

SubWindow

public SubWindow(ViewModel viewModel,
                 java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getTitle

public java.lang.String getTitle()
获取子窗体标题.

Returns:
String

setTitle

public void setTitle(java.lang.String title)
设置子窗体标题.

Parameters:
title - String

isResizable

public boolean isResizable()
返回是否允许改变大小.

Returns:
boolean

setResizable

public void setResizable(boolean resizable)
设置是否允许改变大小.

Parameters:
resizable - boolean

isDraggable

public boolean isDraggable()
返回是否允许通过拖动改变位置.

Returns:
boolean

setDraggable

public void setDraggable(boolean draggable)
设置是否允许通过拖动改变位置.

Parameters:
draggable - boolean

isShowMinimizeButton

public boolean isShowMinimizeButton()
返回是否显示最小化按钮.

Returns:
boolean

setShowMinimizeButton

public void setShowMinimizeButton(boolean showMinimizeButton)
设置是否显示最小化按钮.

Parameters:
showMinimizeButton - boolean

isShowMaximizeButton

public boolean isShowMaximizeButton()
返回是否显示最大化按钮.

Returns:
boolean

setShowMaximizeButton

public void setShowMaximizeButton(boolean showMaximizeButton)
设置是否显示最大化按钮.

Parameters:
showMaximizeButton - boolean

isShowCloseButton

public boolean isShowCloseButton()
返回是否显示关闭系统按钮.

Returns:
boolean

setShowCloseButton

public void setShowCloseButton(boolean showCloseButton)
设置是否显示关闭系统按钮.

Parameters:
showCloseButton - boolean

getStatus

public java.lang.String getStatus()
返回子窗体状态.

Returns:
String

setStatus

public void setStatus(java.lang.String status)
设置窗体状态.默认值为"normal".
取值范围:
  • normal - 常态
  • minimize - 最小化
  • maximize - 最大化
  • hide - 隐藏

Parameters:
status - String

getTitleClickAction

public java.lang.String getTitleClickAction()
返回当用户单击窗体标题栏时执行的操作.

Returns:
String

setTitleClickAction

public void setTitleClickAction(java.lang.String titleClickAction)
设置当用户单击窗体标题栏时执行的操作.默认值为null(即不做动作).
其它取值范围:
  • no_action - 不做动作
  • minimize - 最小化
  • maximize - 最大化

Parameters:
titleClickAction - String

getTitleDblClickAction

public java.lang.String getTitleDblClickAction()
返回当用户双击窗体标题栏时执行的操作.

Returns:
String

setTitleDblClickAction

public void setTitleDblClickAction(java.lang.String titleDblClickAction)
设置当用户双击窗体标题栏时执行的操作.默认值为"maximize".
取值范围:
  • no_action - 不做动作
  • minimize - 最小化
  • maximize - 最大化

Parameters:
titleDblClickAction - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextEditor

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Class TextEditor

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.SimpleDataControl
                    extended by com.bstek.dorado.view.control.Editor
                        extended by com.bstek.dorado.view.control.TextEditor
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class TextEditor
extends Editor

文本编辑器

一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值. 并且用户在该编辑框中输入的数据会自动同步到数据集中. 文本编辑器拥有数据类型校验功能,例如数字类型的编辑框将禁止字符的键盘输入. 文本编辑器还提供了下拉框绑定支持,我们可以将一个设计好的下拉框绑定到文本编辑器上,从而实现更加方便的输入支持.

Version:
4.0

Field Summary
static java.lang.String | PASSWORD 文本编辑器类型 - 密码框
static java.lang.String | TEXT 文本编辑器类型 - 普通编辑框
static java.lang.String | TEXTAREA 文本编辑器类型 - 多行文本编辑器
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
TextEditor(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
int | getDataType() 取得编辑器的数据类型。
java.lang.String | getDropDown() 取得相关联的下拉框.
java.lang.String | getEditorType() 取得编辑器类型.
java.lang.String | getValue() 返回文本编辑器的默认值
void | setDataType(int dataType) 取得数据类型.
void | setDataType(java.lang.String dataType) 设定数据类型.
void | setDropDown(java.lang.String dropDown) 设定相关联的下拉框.
void | setEditorType(java.lang.String editorType) 设定编辑器类型.
void | setValue(java.lang.String value) 设定文本编辑器的默认值
Methods inherited from class com.bstek.dorado.view.control.Editor
getToolTip, isReadOnly, setReadOnly, setToolTip
Methods inherited from class com.bstek.dorado.view.control.SimpleDataControl
getField, getFieldInstance, setField
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

TEXT

public static final java.lang.String TEXT
文本编辑器类型 - 普通编辑框

See Also:
Constant Field Values

TEXTAREA

public static final java.lang.String TEXTAREA
文本编辑器类型 - 多行文本编辑器

See Also:
Constant Field Values

PASSWORD

public static final java.lang.String PASSWORD
文本编辑器类型 - 密码框

See Also:
Constant Field Values
Constructor Detail

TextEditor

public TextEditor(ViewModel viewModel,
                  java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getDataType

public int getDataType()
取得编辑器的数据类型。

Returns:
String

setDataType

public void setDataType(int dataType)
取得数据类型.

Parameters:
dataType - int

setDataType

public void setDataType(java.lang.String dataType)
设定数据类型.
取值范围：
  • string
  • boolean
  • int
  • long
  • float
  • double
  • date
  • time
  • datetime
  • byte
  • short
  • bigdecimal

Parameters:
dataType - String

getEditorType

public java.lang.String getEditorType()
取得编辑器类型.

Returns:
String

setEditorType

public void setEditorType(java.lang.String editorType)
设定编辑器类型.
取值范围:
  • text - 普通编辑框
  • textarea - 多文本编辑框
  • password - 密码框

Parameters:
editorType - String

getDropDown

public java.lang.String getDropDown()
取得相关联的下拉框.

Returns:
String

setDropDown

public void setDropDown(java.lang.String dropDown)
设定相关联的下拉框.

Parameters:
dropDown - String

getValue

public java.lang.String getValue()
返回文本编辑器的默认值

Returns:
String

setValue

public void setValue(java.lang.String value)
设定文本编辑器的默认值

Parameters:
value - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Visible

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control
Interface Visible

All Superinterfaces:
Placeable
All Known Implementing Classes:
Button, DataPilot, GroupBox, Label, MenuBar, OutlookBar, PagePilot, ScrollBar, SimpleDataControl, SplitPanel, SubWindow, Table, TabSet, Tree
public interface Visible
extends Placeable

可见控件的接口

Version:
4.0

Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.advance

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.advance

高级控件相关类
See:
Description

Class Summary
TreeGrid 树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Package com.bstek.dorado.view.control.advance Description

高级控件相关类


TreeGrid

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.advance
Class TreeGrid

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.table.Table
                    extended by com.bstek.dorado.view.control.table.DataTable
                        extended by com.bstek.dorado.view.control.advance.TreeGrid
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class TreeGrid
extends DataTable

树型表格

树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

树型表格尤其在制作项目进度表、甘特图方面有着非常广泛的应用.

recursiveKeyFields属性表示将要从父节点的哪些字段中取值; recursiveKeyParameters属性表示将要执行子节点查询时所需要的参数名称. 在运行时,系统将自动按照recursiveKeyFields的设置取出的关键值, 然后通过recursiveKeyParameters把这些值设置到数据集的参数当中, 最后利用数据集得到子节点的数据并生成新的树节点.

例如:
Dataset包含字段id, parent_id.并且已设定了一个查询参数parent_id.
此时我们可以设置RecursiveTreeLevel的属性如下:
recursiveKeyFields设置为id; recursiveKeyParameters设置为parent_id.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.table.DataTable
SCROLLMODE_RECORD, SCROLLMODE_SIMPLE
Fields inherited from class com.bstek.dorado.view.control.table.Table
COLUMN_TYPE_BASE, COLUMN_TYPE_GROUP
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
TreeGrid(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
int | getExpandLevel() 返回树默认展开到的层数
java.lang.String | getRecursiveKeyFields() 返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
java.lang.String | getRecursiveKeyParameters() 返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
TreeNode | getRoot() 取得树的根节点对象。
java.lang.String | getTreeColumn() 返回具有数据展开功能的列.
void | loadNodes() 根据绑定的记录集导入树节点
protected void | loadNodes(TreeNode parentNode, int nodeLevel)
java.lang.String[] | recursiveKeyFields() 以数组的形式recursiveKeyFields的值
java.lang.String[] | recursiveKeyParameters() 以数组的形式recursiveKeyParameters的值
void | setExpandLevel(int expandLevel) 设置树默认展开到的层数
void | setRecursiveKeyFields(java.lang.String recursiveKeyFields) 返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
void | setRecursiveKeyParameters(java.lang.String recursiveKeyParameters) 返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
void | setTreeColumn(java.lang.String treeColumn) 设置具有数据展开功能的列.
Methods inherited from class com.bstek.dorado.view.control.table.DataTable
createColumn, createColumnGroup, getFixedColumn, getMaxRow, getScrollMode, initColumn, isConfirmCancel, isConfirmDelete, isEditable, isHighlightSelection, isReadOnly, isShowHScrollBar, isShowIndicator, isShowVScrollBar, setConfirmCancel, setConfirmDelete, setEditable, setFixedColumn, setHighlightSelection, setMaxRow, setReadOnly, setScrollMode, setShowHScrollBar, setShowIndicator, setShowVScrollBar
Methods inherited from class com.bstek.dorado.view.control.table.Table
addColumn, addColumn, addColumnByField, addColumnGroup, columns, getColumn, getColumn, getColumnCount, getFooterHeight, getHeaderHeight, getRowHeight, init, isShowFooter, isShowHeader, setFooterHeight, setHeaderHeight, setRowHeight, setShowFooter, setShowHeader
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

TreeGrid

public TreeGrid(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getRoot

public TreeNode getRoot()
取得树的根节点对象。

Returns:
TreeNode

getTreeColumn

public java.lang.String getTreeColumn()
返回具有数据展开功能的列.

Returns:
String

setTreeColumn

public void setTreeColumn(java.lang.String treeColumn)
设置具有数据展开功能的列.

Parameters:
treeColumn - String

getRecursiveKeyFields

public java.lang.String getRecursiveKeyFields()
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.

Returns:
String

getRecursiveKeyParameters

public java.lang.String getRecursiveKeyParameters()
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.

Returns:
String

recursiveKeyFields

public java.lang.String[] recursiveKeyFields()
以数组的形式recursiveKeyFields的值

Returns:
String[]

recursiveKeyParameters

public java.lang.String[] recursiveKeyParameters()
以数组的形式recursiveKeyParameters的值

Returns:
String[]

setRecursiveKeyFields

public void setRecursiveKeyFields(java.lang.String recursiveKeyFields)
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数. 如果此处需要描述多个字段,可以利用","分隔各字段名.
本属性用于描述递归层中的除顶层节点之外的所有子节点.

Parameters:
recursiveKeyFields - String

setRecursiveKeyParameters

public void setRecursiveKeyParameters(java.lang.String recursiveKeyParameters)
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中. 如果此处需要描述多个字段,可以利用","分隔各字段名.
本属性用于描述递归层中的除顶层节点之外的所有子节点.

Parameters:
recursiveKeyParameters - String

getExpandLevel

public int getExpandLevel()
返回树默认展开到的层数

Returns:
int

setExpandLevel

public void setExpandLevel(int expandLevel)
设置树默认展开到的层数

Parameters:
expandLevel - int

loadNodes

public void loadNodes()
               throws java.lang.Exception
根据绑定的记录集导入树节点

Throws:
java.lang.Exception

loadNodes

protected void loadNodes(TreeNode parentNode,
                         int nodeLevel)
                  throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AutoForm

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class AutoForm

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.autoform.AutoForm
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable
public class AutoForm
extends PlaceableDataControl

自动表单

Version:
4.0

Field Summary
static java.lang.String | GROUPBOX 组的类型 - 组合框
static java.lang.String | HORIZONTAL 组的布局方式 - 水平方式
static java.lang.String | SUBWINDOW 组的类型 - 子窗体
static java.lang.String | VERTICAL 组的布局方式 - 垂直方式
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
AutoForm(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
FormGroup | addGroup(java.lang.String groupName) 添加一个组对象
java.lang.String | getDefaultControlWidth() 取得AutoForm中各个元素统一的缺省宽度值.
int | getDefaultElementMargin() 取得AutoForm中每个元素缺省的空白边缘(Margin)值.
java.lang.String | getDefaultLabelWidth() 取得AutoForm的元素的标题的缺省宽度值.
FormGroup | getGroup(java.lang.String groupName) 根据名称返回一个组对象
ObjectCollection | getGroups() 取得所有组的集合对象
java.lang.String | getGroupType() 取得AutoForm中分组的显示类型.默认为"groupbox".
java.lang.String | getHeight() 取得AutoForm的高度.
java.lang.String | getLayout() 取得AutoForm中元素的布局.该属性定义元素所在的组之间的布局方式,分为horizontal和vertical两种.
java.lang.String | getWidth() 取得AutoForm的宽度.
void | init(DoradoContext context, XmlNode node)
boolean | isFirstGroupAsHeader() 返回AutoForm的第一个组是否在页面上单独占用一行作为头行.
boolean | isLastGroupAsFooter() 返回AutoForm的最后一个组是否单独占一行作为尾行.
boolean | isReadOnly() 返回AutoForm是否只读.
protected void | loadGroups(DoradoContext context, XmlNode node) 加载组
void | setDefaultControlWidth(java.lang.String defaultControlWidth) 设置AutoForm中各个元素统一的缺省宽度值.
void | setDefaultElementMargin(int defaultElementMargin) 设置AutoForm中每个元素缺省的空白边缘(Margin)值.
void | setDefaultLabelWidth(java.lang.String defaultLabelWidth) 设置AutoForm的元素的标题的缺省宽度值.
void | setFirstGroupAsHeader(boolean firstGroupAsHeader) 设置AutoForm的第一个组是否在页面上单独占用一行作为头行,而不受AutoForm布局方式(Layout)的影响.
void | setGroupType(java.lang.String groupType) 设置AutoForm中分组的显示类型.
void | setHeight(java.lang.String height) 设定AutoForm的高度.
void | setLastGroupAsFooter(boolean lastGroupAsFooter) 设置AutoForm的最后一个组是否单独占一行作为尾行,而不受布局方式的影响.
void | setLayout(java.lang.String layout) 设置AutoForm中元素的布局.该属性定义元素所在的组之间的布局方式,分为horizontal和vertical两种.
void | setReadOnly(boolean readOnly) 设置AutoForm的只读属性.
void | setWidth(java.lang.String width) 设定AutoForm的宽度.
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getLeft, getStyle, getTop, setLeft, setStyle, setTop
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

HORIZONTAL

public static final java.lang.String HORIZONTAL
组的布局方式 - 水平方式

See Also:
Constant Field Values

VERTICAL

public static final java.lang.String VERTICAL
组的布局方式 - 垂直方式

See Also:
Constant Field Values

GROUPBOX

public static final java.lang.String GROUPBOX
组的类型 - 组合框

See Also:
Constant Field Values

SUBWINDOW

public static final java.lang.String SUBWINDOW
组的类型 - 子窗体

See Also:
Constant Field Values
Constructor Detail

AutoForm

public AutoForm(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Throws:
java.lang.Exception

loadGroups

protected void loadGroups(DoradoContext context,
                          XmlNode node)
                   throws java.lang.Exception
加载组

Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

addGroup

public FormGroup addGroup(java.lang.String groupName)
添加一个组对象

Parameters:
groupName - 组的名称
Returns:
FormGroup

getGroup

public FormGroup getGroup(java.lang.String groupName)
根据名称返回一个组对象

Parameters:
groupName - 组的名称
Returns:
FormGroup

getGroups

public ObjectCollection getGroups()
取得所有组的集合对象

Returns:
ObjectCollection

isReadOnly

public boolean isReadOnly()
返回AutoForm是否只读.

Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设置AutoForm的只读属性.

Parameters:
readOnly - boolean

getLayout

public java.lang.String getLayout()
取得AutoForm中元素的布局.该属性定义元素所在的组之间的布局方式,分为horizontal和vertical两种.

Returns:
String

setLayout

public void setLayout(java.lang.String layout)
设置AutoForm中元素的布局.该属性定义元素所在的组之间的布局方式,分为horizontal和vertical两种.
取值范围:
  • horizontal - 有组都是按照水平方式排列成一行.
  • vertical - 每组都是按照垂直方式排列成一列.

Parameters:
layout - String

getWidth

public java.lang.String getWidth()
取得AutoForm的宽度.

Specified by:
getWidth in interface Placeable
Overrides:
getWidth in class PlaceableDataControl
Returns:
String

setWidth

public void setWidth(java.lang.String width)
设定AutoForm的宽度.

Specified by:
setWidth in interface Placeable
Overrides:
setWidth in class PlaceableDataControl
Parameters:
width - String

getHeight

public java.lang.String getHeight()
取得AutoForm的高度.

Specified by:
getHeight in interface Placeable
Overrides:
getHeight in class PlaceableDataControl
Returns:
String

setHeight

public void setHeight(java.lang.String height)
设定AutoForm的高度.

Specified by:
setHeight in interface Placeable
Overrides:
setHeight in class PlaceableDataControl
Parameters:
height - String

isFirstGroupAsHeader

public boolean isFirstGroupAsHeader()
返回AutoForm的第一个组是否在页面上单独占用一行作为头行.

Returns:
boolean

setFirstGroupAsHeader

public void setFirstGroupAsHeader(boolean firstGroupAsHeader)
设置AutoForm的第一个组是否在页面上单独占用一行作为头行,而不受AutoForm布局方式(Layout)的影响.

Parameters:
firstGroupAsHeader - boolean

isLastGroupAsFooter

public boolean isLastGroupAsFooter()
返回AutoForm的最后一个组是否单独占一行作为尾行.

Returns:
boolean

setLastGroupAsFooter

public void setLastGroupAsFooter(boolean lastGroupAsFooter)
设置AutoForm的最后一个组是否单独占一行作为尾行,而不受布局方式的影响.

Parameters:
lastGroupAsFooter - boolean

getDefaultLabelWidth

public java.lang.String getDefaultLabelWidth()
取得AutoForm的元素的标题的缺省宽度值.

Returns:
String

setDefaultLabelWidth

public void setDefaultLabelWidth(java.lang.String defaultLabelWidth)
设置AutoForm的元素的标题的缺省宽度值.

Parameters:
defaultLabelWidth - String

getDefaultControlWidth

public java.lang.String getDefaultControlWidth()
取得AutoForm中各个元素统一的缺省宽度值.

Returns:
String

setDefaultControlWidth

public void setDefaultControlWidth(java.lang.String defaultControlWidth)
设置AutoForm中各个元素统一的缺省宽度值.

Parameters:
defaultControlWidth - String

getGroupType

public java.lang.String getGroupType()
取得AutoForm中分组的显示类型.默认为"groupbox".

Returns:
String

setGroupType

public void setGroupType(java.lang.String groupType)
设置AutoForm中分组的显示类型.
取值范围:
  • groupbox - 以组合框的方式显示每个分组.
  • subwindow - 以子窗体的方式显示每个分组.

Parameters:
groupType - String

getDefaultElementMargin

public int getDefaultElementMargin()
取得AutoForm中每个元素缺省的空白边缘(Margin)值.

Returns:
int

setDefaultElementMargin

public void setDefaultElementMargin(int defaultElementMargin)
设置AutoForm中每个元素缺省的空白边缘(Margin)值.

Parameters:
defaultElementMargin - int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CheckBoxFormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class CheckBoxFormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.ControlFormElement
            extended by com.bstek.dorado.view.control.autoform.CheckBoxFormElement
All Implemented Interfaces:
Element
public class CheckBoxFormElement
extends ControlFormElement

复选框型的表单元素

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
CheckBoxFormElement(FormGroup group, java.lang.String name)
构造器
Method Summary
Control | getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
void | init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
protected void | initInnerControls() 初始化自动表单的内部控件
Methods inherited from class com.bstek.dorado.view.control.autoform.ControlFormElement
getControlAlign, getControlVAlign, setControlAlign, setControlVAlign
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CheckBoxFormElement

public CheckBoxFormElement(FormGroup group,
                           java.lang.String name)
构造器

Parameters:
group - FormGroup
name - String
Method Detail

initInnerControls

protected void initInnerControls()
初始化自动表单的内部控件

Overrides:
initInnerControls in class FormElement

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据XML的配置初试化一个表单元素

Overrides:
init in class FormElement
Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

getControl

public Control getControl()
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

Specified by:
getControl in class ControlFormElement
Returns:
Control
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ControlFormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class ControlFormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.ControlFormElement
All Implemented Interfaces:
Element
Direct Known Subclasses:
CheckBoxFormElement, CustomFormElement, LabelFormElement, RadioGroupFormElement, TextEditorFormElement
public abstract class ControlFormElement
extends FormElement

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
ControlFormElement(FormGroup group, java.lang.String name)
Method Summary
abstract Control | getControl() 取得表单元素中的控件对象。
java.lang.String | getControlAlign() 取得控件的水平对齐方式。
java.lang.String | getControlVAlign() 取得控件的垂直对齐方式。
void | setControlAlign(java.lang.String controlAlign) 设置控件的水平对齐方式。
void | setControlVAlign(java.lang.String controlVAlign) 设置控件的垂直对齐方式。
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, init, initInnerControls, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ControlFormElement

public ControlFormElement(FormGroup group,
                          java.lang.String name)
Method Detail

getControl

public abstract Control getControl()
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

Returns:
Control

getControlAlign

public java.lang.String getControlAlign()
取得控件的水平对齐方式。

Returns:
String

setControlAlign

public void setControlAlign(java.lang.String controlAlign)
设置控件的水平对齐方式。

Parameters:
controlAlign - String

getControlVAlign

public java.lang.String getControlVAlign()
取得控件的垂直对齐方式。

Returns:
String

setControlVAlign

public void setControlVAlign(java.lang.String controlVAlign)
设置控件的垂直对齐方式。

Parameters:
controlVAlign - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomFormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class CustomFormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.ControlFormElement
            extended by com.bstek.dorado.view.control.autoform.CustomFormElement
All Implemented Interfaces:
Element
public class CustomFormElement
extends ControlFormElement

自定义的表单元素

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
CustomFormElement(FormGroup group, java.lang.String name)
构造器
Method Summary
Control | getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
java.lang.String | getControlId() 取得控件(Control)的唯一标识符(Id)。
void | setControlId(java.lang.String controlId) 为控件(Control)设定一个唯一标识符(Id)。
Methods inherited from class com.bstek.dorado.view.control.autoform.ControlFormElement
getControlAlign, getControlVAlign, setControlAlign, setControlVAlign
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, init, initInnerControls, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomFormElement

public CustomFormElement(FormGroup group,
                         java.lang.String name)
构造器

Parameters:
group - FormGroup
name - String
Method Detail

getControl

public Control getControl()
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

Specified by:
getControl in class ControlFormElement
Returns:
Control

getControlId

public java.lang.String getControlId()
取得控件(Control)的唯一标识符(Id)。

Returns:
String

setControlId

public void setControlId(java.lang.String controlId)
为控件(Control)设定一个唯一标识符(Id)。

Parameters:
controlId - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class FormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
All Implemented Interfaces:
Element
Direct Known Subclasses:
ControlFormElement, FormElementRenderer
public abstract class FormElement
extends java.lang.Object
implements Element

表单元素抽象类

Version:
4.0

Field Summary
static java.lang.String | AUTO
protected AutoForm | autoForm 表单
protected java.lang.String | field 字段
protected FormGroup | group 组
static java.lang.String | HIDDEN
protected java.lang.String | name 表单元素名称
static java.lang.String | VISIBLE
Constructor Summary
FormElement(FormGroup group, java.lang.String name)
构造器
Method Summary
int | getColSpan() 取得该元素将占用自动表单中的多少列，该属性类Table的ColSpan属性。
java.lang.String | getField() 取得该元素绑定的字段。
FieldLabel | getFieldLabel() 取得表单元素中的字段标题对象。
FormGroup | getGroup() 取得元素所属的组。
java.lang.String | getLabelAlign() 取得字段标题的水平对齐方式。
java.lang.String | getLabelVAlign() 取得字段标题的垂直对齐方式。
java.lang.String | getName() 取得元素的名称。
int | getRowSpan() 取得该元素将占用自动表单中的多少行，该属性类似Table的RowSpan属性。
java.lang.String | getTag() 取得元素的用户自定义信息。
java.lang.String | getVisibility() 取得该元素是否在页面上可见。
void | init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
protected void | initInnerControls() 初始化自动表单的内部控件
boolean | isShowLabel() 返回是否显示字段标题。
void | setColSpan(int colSpan) 设置该元素将占用自动表单中的多少列，该属性类Table的ColSpan属性。
void | setField(java.lang.String field) 设置该元素绑定的字段。
void | setLabelAlign(java.lang.String labelAlign) 设置字段标题的水平对齐方式。
void | setLabelVAlign(java.lang.String labelVAlign) 设置字段标题的垂直对齐方式。
void | setRowSpan(int rowSpan) 设置该元素将占用自动表单中的多少行，该属性类似Table的RowSpan属性。
void | setShowLabel(boolean showLabel) 设置是否显示字段标题。
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setVisibility(java.lang.String visibility) 设定该元素是否在页面上可见。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VISIBLE

public static final java.lang.String VISIBLE
See Also:
Constant Field Values

HIDDEN

public static final java.lang.String HIDDEN
See Also:
Constant Field Values

AUTO

public static final java.lang.String AUTO
See Also:
Constant Field Values

name

protected java.lang.String name
表单元素名称

field

protected java.lang.String field
字段

autoForm

protected AutoForm autoForm
表单

group

protected FormGroup group
组

Constructor Detail

FormElement

public FormElement(FormGroup group,
                   java.lang.String name)
构造器

Parameters:
group - FormGroup
name - String
Method Detail

initInnerControls

protected void initInnerControls()
初始化自动表单的内部控件

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据XML的配置初试化一个表单元素

Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

getGroup

public FormGroup getGroup()
取得元素所属的组。

Returns:
FormGroup

getName

public java.lang.String getName()
取得元素的名称。

Returns:
String

getField

public java.lang.String getField()
取得该元素绑定的字段。

Returns:
String

setField

public void setField(java.lang.String field)
设置该元素绑定的字段。

Parameters:
field - String

getFieldLabel

public FieldLabel getFieldLabel()
取得表单元素中的字段标题对象。

Returns:
FieldLabel

getLabelAlign

public java.lang.String getLabelAlign()
取得字段标题的水平对齐方式。

Returns:
String

setLabelAlign

public void setLabelAlign(java.lang.String labelAlign)
设置字段标题的水平对齐方式。

Parameters:
labelAlign - String

getLabelVAlign

public java.lang.String getLabelVAlign()
取得字段标题的垂直对齐方式。

Returns:
String

setLabelVAlign

public void setLabelVAlign(java.lang.String labelVAlign)
设置字段标题的垂直对齐方式。

Parameters:
labelVAlign - String

isShowLabel

public boolean isShowLabel()
返回是否显示字段标题。

Returns:
boolean

setShowLabel

public void setShowLabel(boolean showLabel)
设置是否显示字段标题。

Parameters:
showLabel - boolean

getRowSpan

public int getRowSpan()
取得该元素将占用自动表单中的多少行，该属性类似Table的RowSpan属性。

Returns:
int

setRowSpan

public void setRowSpan(int rowSpan)
设置该元素将占用自动表单中的多少行，该属性类似Table的RowSpan属性。

Parameters:
rowSpan - int

getColSpan

public int getColSpan()
取得该元素将占用自动表单中的多少列，该属性类Table的ColSpan属性。

Returns:
int

setColSpan

public void setColSpan(int colSpan)
设置该元素将占用自动表单中的多少列，该属性类Table的ColSpan属性。

Parameters:
colSpan - int

getVisibility

public java.lang.String getVisibility()
取得该元素是否在页面上可见。

Returns:
boolean

setVisibility

public void setVisibility(java.lang.String visibility)
设定该元素是否在页面上可见。
  • auto - 表示该元素由相关字段来决定是否显示。
  • visible - 表示该元素总是可见。
  • hidden - 表示该元素总是不可见。

    • Parameters:
    visibility - String

    getTag

    public java.lang.String getTag()
    取得元素的用户自定义信息。

    Specified by:
    getTag in interface Element
    Returns:
    String

    setTag

    public void setTag(java.lang.String tag)
    设定元素的用户自定义信息。

    Specified by:
    setTag in interface Element
    Parameters:
    tag - String
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormElementFactoryImpl

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class FormElementFactoryImpl

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElementFactoryImpl
All Implemented Interfaces:
com.bstek.dorado.view.control.autoform.FormElementFactory
public class FormElementFactoryImpl
extends java.lang.Object
implements com.bstek.dorado.view.control.autoform.FormElementFactory

表单元素的工厂类接口

Version:
1.0

Constructor Summary
FormElementFactoryImpl()
构造器
Method Summary
 FormElement createFormElement(FormGroup group, java.lang.String type, java.lang.String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormElementFactoryImpl

public FormElementFactoryImpl()
构造器

Method Detail

createFormElement

public FormElement createFormElement(FormGroup group,
                                     java.lang.String type,
                                     java.lang.String name)
                              throws java.lang.Exception

Specified by:
createFormElement in interface com.bstek.dorado.view.control.autoform.FormElementFactory
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormElementRenderer

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class FormElementRenderer

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.FormElementRenderer
All Implemented Interfaces:
Element
public class FormElementRenderer
extends FormElement

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
FormElementRenderer(FormGroup group, java.lang.String name)
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, init, initInnerControls, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormElementRenderer

public FormElementRenderer(FormGroup group,
                           java.lang.String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class FormGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormGroup
All Implemented Interfaces:
Element
public class FormGroup
extends java.lang.Object
implements Element

自动表单中的组

Version:
4.0

Constructor Summary
FormGroup(AutoForm autoForm, java.lang.String name)
构造器
Method Summary
FormElement | addElement(java.lang.String type, java.lang.String name) 添加一个表单元素
AutoForm | getAutoForm() 取得该组所属的自动表单对象。
int | getColumnCount() 返回该组在页面上显示时每行要显示的列数。
java.lang.String | getDefaultControlWidth() 取得自动表单中各个控件对象的缺省所占的宽度。
FormElement | getElement(java.lang.String name) 根据指定的表单元素的名称，取得一个表单元素对象。
int | getElementMargin() 取得自动表单中各个元素边缘空白的大小。
ObjectCollection | getElements() 返回组中所有元素的集合对象。
java.lang.String | getHeight() 取得组的高度值。
java.lang.String | getLabelWidth() 取得自动表单中的各个元素标题的宽度值。
java.lang.String | getName() getName
java.lang.String | getTag() 取得元素的用户自定义信息。
java.lang.String | getTitle() 返回组的标题，通常为文字描述信息。
java.lang.String | getWidth() 取得组的宽度值。
void | init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个组
boolean | isExpanded() 本组的内容是否已展开.
boolean | isShowBevel() 返回是否显示组的边框线，缺省为显示。
boolean | isVisible() 返回组是否可见，不可见时将不在页面上创建该对象。
void | setColumnCount(int columnCount) 设置该组在页面上显示时每行要显示的列数。
void | setDefaultControlWidth(java.lang.String defaultControlWidth) 设置自动表单中各个控件对象的缺省所占的宽度。
void | setElementMargin(int elementMargin) 设置自动表单中各个元素边缘空白的大小。
void | setExpanded(boolean expanded) 设置本组的内容是否已展开.默认只有第一个组是展开的.
void | setHeight(java.lang.String height) 设置组的高度值。
void | setLabelWidth(java.lang.String defaultLabelWidth) 设置自动表单中的各个元素标题的宽度值。
void | setShowBevel(boolean showBevel) 设置是否显示组的边框线，缺省为显示。
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setTitle(java.lang.String title) 设置组的标题，通常为文字描述信息。
void | setVisible(boolean visible) 设置组是否可见，不可见时将不在页面上创建该对象。
void | setWidth(java.lang.String width) 设置组的宽度值。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormGroup

public FormGroup(AutoForm autoForm,
                 java.lang.String name)
构造器

Parameters:
autoForm - AutoForm
name - String
Method Detail

getName

public java.lang.String getName()
getName

Returns:
String

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据XML的配置初试化一个组

Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

getAutoForm

public AutoForm getAutoForm()
取得该组所属的自动表单对象。

Returns:
AutoForm

addElement

public FormElement addElement(java.lang.String type,
                              java.lang.String name)
添加一个表单元素

Parameters:
type - Class
name - String
Returns:
FormElement

getElement

public FormElement getElement(java.lang.String name)
根据指定的表单元素的名称，取得一个表单元素对象。

Parameters:
name - String
Returns:
FormElement

getElements

public ObjectCollection getElements()
返回组中所有元素的集合对象。

Returns:
ObjectCollection

getColumnCount

public int getColumnCount()
返回该组在页面上显示时每行要显示的列数。

如：columnCount为1时，表示该组中每行只显示1列元素；columnCount为2时表示该组中每行显示2列元素。

Returns:
int

setColumnCount

public void setColumnCount(int columnCount)
设置该组在页面上显示时每行要显示的列数。

如：columnCount为1时，表示该组中每行只显示1列元素；columnCount为2时表示该组中每行显示2列元素。

Parameters:
columnCount - int

getTitle

public java.lang.String getTitle()
返回组的标题，通常为文字描述信息。

Returns:
String

setTitle

public void setTitle(java.lang.String title)
设置组的标题，通常为文字描述信息。

Parameters:
title - String

isShowBevel

public boolean isShowBevel()
返回是否显示组的边框线，缺省为显示。

Returns:
boolean

setShowBevel

public void setShowBevel(boolean showBevel)
设置是否显示组的边框线，缺省为显示。

Parameters:
showBevel - boolean

isVisible

public boolean isVisible()
返回组是否可见，不可见时将不在页面上创建该对象。缺省是可见。

Returns:
boolean See setVisible

setVisible

public void setVisible(boolean visible)
设置组是否可见，不可见时将不在页面上创建该对象。缺省是可见。

Parameters:
visible - boolean

getWidth

public java.lang.String getWidth()
取得组的宽度值。

Returns:
String

setWidth

public void setWidth(java.lang.String width)
设置组的宽度值。

Parameters:
width - String

getHeight

public java.lang.String getHeight()
取得组的高度值。

Returns:
String

setHeight

public void setHeight(java.lang.String height)
设置组的高度值。

Parameters:
height - String

getLabelWidth

public java.lang.String getLabelWidth()
取得自动表单中的各个元素标题的宽度值。

Returns:
String

setLabelWidth

public void setLabelWidth(java.lang.String defaultLabelWidth)
设置自动表单中的各个元素标题的宽度值。

Parameters:
defaultLabelWidth - String

getDefaultControlWidth

public java.lang.String getDefaultControlWidth()
取得自动表单中各个控件对象的缺省所占的宽度。

Returns:
String

setDefaultControlWidth

public void setDefaultControlWidth(java.lang.String defaultControlWidth)
设置自动表单中各个控件对象的缺省所占的宽度。

Parameters:
defaultControlWidth - String

getElementMargin

public int getElementMargin()
取得自动表单中各个元素边缘空白的大小。

Returns:
int

setElementMargin

public void setElementMargin(int elementMargin)
设置自动表单中各个元素边缘空白的大小。

Parameters:
elementMargin - int

isExpanded

public boolean isExpanded()
本组的内容是否已展开.

Returns:
boolean

setExpanded

public void setExpanded(boolean expanded)
设置本组的内容是否已展开.默认只有第一个组是展开的.

注意: 本属性只在自动表单的GroupType设为SubWindow时有效.

Parameters:
expanded - boolean

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormGroupGround

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class FormGroupGround

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormGroupGround
public class FormGroupGround
extends java.lang.Object

自动表单的辅助类

Version:
4.0

Constructor Summary
FormGroupGround(int columnCount)
构造器
Method Summary
void | fillPoint(int col, int row) fillPoint
int | getColumnCount() 返回AutoForm中组(Group)内每行放置元素的个数。
java.util.List | getLayoutInfos() getLayoutInfos
int | getRowCount() getRowCount
boolean | isPointFilled(int col, int row) isPointFilled
void | putElement(FormElement element) putElement
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormGroupGround

public FormGroupGround(int columnCount)
构造器

Parameters:
columnCount - int
Method Detail

isPointFilled

public boolean isPointFilled(int col,
                             int row)
isPointFilled

Parameters:
col - int
row - int
Returns:
boolean

fillPoint

public void fillPoint(int col,
                      int row)
fillPoint

Parameters:
col - int
row - int

getColumnCount

public int getColumnCount()
返回AutoForm中组(Group)内每行放置元素的个数。

Returns:
int

getRowCount

public int getRowCount()
getRowCount

Returns:
int

putElement

public void putElement(FormElement element)
putElement

Parameters:
element - FormElement

getLayoutInfos

public java.util.List getLayoutInfos()
getLayoutInfos

Returns:
List
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelFormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class LabelFormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.ControlFormElement
            extended by com.bstek.dorado.view.control.autoform.LabelFormElement
All Implemented Interfaces:
Element
public class LabelFormElement
extends ControlFormElement

文本标签型的表单元素

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
LabelFormElement(FormGroup group, java.lang.String name)
构造器
Method Summary
Control | getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
void | init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
protected void | initInnerControls() 初始化自动表单的内部控件
Methods inherited from class com.bstek.dorado.view.control.autoform.ControlFormElement
getControlAlign, getControlVAlign, setControlAlign, setControlVAlign
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LabelFormElement

public LabelFormElement(FormGroup group,
                        java.lang.String name)
构造器

Parameters:
group - FormGroup
name - String
Method Detail

initInnerControls

protected void initInnerControls()
初始化自动表单的内部控件

Overrides:
initInnerControls in class FormElement

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据XML的配置初试化一个表单元素

Overrides:
init in class FormElement
Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

getControl

public Control getControl()
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

Specified by:
getControl in class ControlFormElement
Returns:
Control
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LayoutInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class LayoutInfo

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.LayoutInfo
public class LayoutInfo
extends java.lang.Object

AutoForm布局方式类

Version:
1.0

Constructor Summary
LayoutInfo()
Method Summary
int | getCol() 返回当前列的索引值。
int | getColSpan() 返回当前元素(Element)的列跨度(colSpan)属性值。
FormElement | getElement() 返回当前的元素(Element)对象。
int | getRow() 返回当前行的索引值。
int | getRowSpan() 返回当前元素(Element)的行跨度(rolSpan)属性值。
void | setCol(int col) 设置指定的列为当前列。
void | setColSpan(int colSpan) 设置组(Group)中当前元素所占的列的跨度数。
void | setElement(FormElement element) 设定AutoForm对象的元素
void | setRow(int row) 设定某行为当前行。
void | setRowSpan(int rowSpan) 设置组(Group)中当前元素所占的行的跨度数。
java.lang.String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LayoutInfo

public LayoutInfo()
Method Detail

setElement

public void setElement(FormElement element)
设定AutoForm对象的元素

Parameters:
element - FormElement

setColSpan

public void setColSpan(int colSpan)
设置组(Group)中当前元素所占的列的跨度数。

Parameters:
colSpan - int

setRowSpan

public void setRowSpan(int rowSpan)
设置组(Group)中当前元素所占的行的跨度数。

Parameters:
rowSpan - int

getElement

public FormElement getElement()
返回当前的元素(Element)对象。

Returns:
FormElement

getCol

public int getCol()
返回当前列的索引值。

Returns:
int

setCol

public void setCol(int col)
设置指定的列为当前列。

Parameters:
col - int

getRow

public int getRow()
返回当前行的索引值。

Returns:
int

setRow

public void setRow(int row)
设定某行为当前行。

Parameters:
row - int

getColSpan

public int getColSpan()
返回当前元素(Element)的列跨度(colSpan)属性值。

Returns:
int

getRowSpan

public int getRowSpan()
返回当前元素(Element)的行跨度(rolSpan)属性值。

Returns:
int

toString

public java.lang.String toString()

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.autoform

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.autoform

自动表单控件的相关对象
See:
Description

Class Summary
AutoForm | 自动表单
CheckBoxFormElement | 复选框型的表单元素
ControlFormElement |
CustomFormElement | 自定义的表单元素
FormElement | 表单元素抽象类
FormElementFactoryImpl | 表单元素的工厂类接口
FormElementRenderer |
FormGroup | 自动表单中的组
FormGroupGround | 自动表单的辅助类
LabelFormElement | 文本标签型的表单元素
LayoutInfo | AutoForm布局方式类
RadioGroupFormElement | 单选框型的表单元素
TextEditorFormElement | 文本输入框型的表单元素

Package com.bstek.dorado.view.control.autoform Description

自动表单控件的相关对象


RadioGroupFormElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class RadioGroupFormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.ControlFormElement
            extended by com.bstek.dorado.view.control.autoform.RadioGroupFormElement
All Implemented Interfaces:
Element
public class RadioGroupFormElement
extends ControlFormElement

单选框型的表单元素

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
RadioGroupFormElement(FormGroup group, java.lang.String name)
构造器
Method Summary
Control | getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
void | init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
protected void | initInnerControls() 初始化自动表单的内部控件
Methods inherited from class com.bstek.dorado.view.control.autoform.ControlFormElement
getControlAlign, getControlVAlign, setControlAlign, setControlVAlign
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RadioGroupFormElement

public RadioGroupFormElement(FormGroup group,
                             java.lang.String name)
构造器

Parameters:
group - FormGroup
name - String
Method Detail

initInnerControls

protected void initInnerControls()
初始化自动表单的内部控件

Overrides:
initInnerControls in class FormElement

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据XML的配置初试化一个表单元素

Overrides:
init in class FormElement
Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

getControl

public Control getControl()
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

Specified by:
getControl in class ControlFormElement
Returns:
Control
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextEditorFormElement

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.autoform
Class TextEditorFormElement

java.lang.Object
    extended by com.bstek.dorado.view.control.autoform.FormElement
        extended by com.bstek.dorado.view.control.autoform.ControlFormElement
            extended by com.bstek.dorado.view.control.autoform.TextEditorFormElement
All Implemented Interfaces:
Element
public class TextEditorFormElement
extends ControlFormElement

文本输入框型的表单元素

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.autoform.FormElement
AUTO, autoForm, field, group, HIDDEN, name, VISIBLE
Constructor Summary
TextEditorFormElement(FormGroup group, java.lang.String name)
构造器
Method Summary
Control | getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
void | init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
protected void | initInnerControls() 初始化自动表单的内部控件
Methods inherited from class com.bstek.dorado.view.control.autoform.ControlFormElement
getControlAlign, getControlVAlign, setControlAlign, setControlVAlign
Methods inherited from class com.bstek.dorado.view.control.autoform.FormElement
getColSpan, getField, getFieldLabel, getGroup, getLabelAlign, getLabelVAlign, getName, getRowSpan, getTag, getVisibility, isShowLabel, setColSpan, setField, setLabelAlign, setLabelVAlign, setRowSpan, setShowLabel, setTag, setVisibility
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextEditorFormElement

public TextEditorFormElement(FormGroup group,
                             java.lang.String name)
构造器

Parameters:
group - FormGroup
name - String
Method Detail

initInnerControls

protected void initInnerControls()
初始化自动表单的内部控件

Overrides:
initInnerControls in class FormElement

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据XML的配置初试化一个表单元素

Overrides:
init in class FormElement
Parameters:
context - DoradoContext
node - XmlNode
Throws:
java.lang.Exception

getControl

public Control getControl()
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

Specified by:
getControl in class ControlFormElement
Returns:
Control
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Command

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class Command

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.command.Command
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
CommandQueue, QueryCommand, RequestCommand, RPCCommand
public abstract class Command
extends com.bstek.dorado.view.control.AbstractControl

命令对象的基类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Command(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
boolean | isDisabled() isDisabled
ParameterSet | parameters() 返回命令对象的参数集合。
void | setDisabled(boolean disabled) setDisabled
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Command

public Command(ViewModel viewModel,
               java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

parameters

public ParameterSet parameters()
返回命令对象的参数集合。

Returns:
ParameterSet

isDisabled

public boolean isDisabled()
isDisabled

Returns:
boolean

setDisabled

public void setDisabled(boolean disabled)
setDisabled

Parameters:
disabled - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CommandQueue

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class CommandQueue

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.command.Command
            extended by com.bstek.dorado.view.control.command.CommandQueue
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class CommandQueue
extends Command

命令队列

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
CommandQueue(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
void | addCommand(java.lang.String commandId) 添加一个子命令对象
java.util.List | getCommands() 取得所有子命令的集合对象
void | init(DoradoContext context, XmlNode node)
Methods inherited from class com.bstek.dorado.view.control.command.Command
isDisabled, parameters, setDisabled
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommandQueue

public CommandQueue(ViewModel viewModel,
                    java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Throws:
java.lang.Exception

addCommand

public void addCommand(java.lang.String commandId)
添加一个子命令对象

Parameters:
commandId - String

getCommands

public java.util.List getCommands()
取得所有子命令的集合对象

Returns:
List
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetInfo

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class DatasetInfo

java.lang.Object
    extended by com.bstek.dorado.view.control.command.DatasetInfo
public class DatasetInfo
extends java.lang.Object

用于描述提交命令(UpdateCommand)要提交的Dataset数据集的对象. 它可以描述被提交记录集的提交特征以及数据提交完成后默认的后续自动处理方法

Version:
4.0

Field Summary
static java.lang.String | ALL 数据的提交方式 - 提交Dataset中所有的记录。
static java.lang.String | ALL_CHANGE 数据的提交方式 - 只提交Dataset中所有更改过的记录，包括新增、修改、删除的记录。
static java.lang.String | CURRENT 数据的提交方式 - 只提交Dataset的当前记录。
static java.lang.String | SELECTED 数据的提交方式 - 只提交Dataset中所有通过Select复选框选中的记录。
Constructor Summary
DatasetInfo()
Method Summary
java.lang.String | getDataset() 返回要提交的Dataset的id
java.lang.String | getSubmitScope() 返回Dataset的提交方式
boolean | isClearSelectionOnSuccess() 返回提交成功后是否清除选中的Dataset记录。
boolean | isDeleteSelectionOnSuccess() 返回对象提交成功后是否删除客户端Dataset中已经选中的记录。
boolean | isFlushDataOnSuccess() 返回提交成功后是否刷新客户端Dataset中的数据。
void | setClearSelectionOnSuccess(boolean clearSelectionOnSuccess) 设置当提交成功后是否清除选中的Dataset记录。
void | setDataset(java.lang.String dataset) 设定要提交的Dataset的id
void | setDeleteSelectionOnSuccess(boolean deleteSelectionOnSuccess) 设置对象提交成功后是否删除客户端Dataset中已经选中的记录。
void | setFlushDataOnSuccess(boolean flushDataOnSuccess) 设置当提交成功后是否刷新客户端Dataset中的数据。
void | setSubmitScope(java.lang.String submitScope) 设定Dataset的提交方式,包含以下四种方式： all - 提交Dataset中所有的记录； all-change - 只提交Dataset中所有更改过的记录； current - 只提交Dataset的当前记录； selected - 只提交Dataset中所有通过Select复选框选中的记录。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ALL

public static final java.lang.String ALL
数据的提交方式 - 提交Dataset中所有的记录。

See Also:
Constant Field Values

ALL_CHANGE

public static final java.lang.String ALL_CHANGE
数据的提交方式 - 只提交Dataset中所有更改过的记录，包括新增、修改、删除的记录。

See Also:
Constant Field Values

CURRENT

public static final java.lang.String CURRENT
数据的提交方式 - 只提交Dataset的当前记录。

See Also:
Constant Field Values

SELECTED

public static final java.lang.String SELECTED
数据的提交方式 - 只提交Dataset中所有通过Select复选框选中的记录。

See Also:
Constant Field Values
Constructor Detail

DatasetInfo

public DatasetInfo()
Method Detail

getDataset

public java.lang.String getDataset()
返回要提交的Dataset的id

Returns:
String

setDataset

public void setDataset(java.lang.String dataset)
设定要提交的Dataset的id

Parameters:
dataset - String

getSubmitScope

public java.lang.String getSubmitScope()
返回Dataset的提交方式

Returns:
String

setSubmitScope

public void setSubmitScope(java.lang.String submitScope)
设定Dataset的提交方式,包含以下四种方式：
  • all - 提交Dataset中所有的记录；
  • all-change - 只提交Dataset中所有更改过的记录；
  • current - 只提交Dataset的当前记录；
  • selected - 只提交Dataset中所有通过Select复选框选中的记录。

Parameters:
submitScope - String

isFlushDataOnSuccess

public boolean isFlushDataOnSuccess()
返回提交成功后是否刷新客户端Dataset中的数据。

Returns:
boolean

setFlushDataOnSuccess

public void setFlushDataOnSuccess(boolean flushDataOnSuccess)
设置当提交成功后是否刷新客户端Dataset中的数据。

Parameters:
flushDataOnSuccess - boolean

isClearSelectionOnSuccess

public boolean isClearSelectionOnSuccess()
返回提交成功后是否清除选中的Dataset记录。

Returns:
boolean

setClearSelectionOnSuccess

public void setClearSelectionOnSuccess(boolean clearSelectionOnSuccess)
设置当提交成功后是否清除选中的Dataset记录。

Parameters:
clearSelectionOnSuccess - boolean

isDeleteSelectionOnSuccess

public boolean isDeleteSelectionOnSuccess()
返回对象提交成功后是否删除客户端Dataset中已经选中的记录。

Returns:
boolean

setDeleteSelectionOnSuccess

public void setDeleteSelectionOnSuccess(boolean deleteSelectionOnSuccess)
设置对象提交成功后是否删除客户端Dataset中已经选中的记录。

Parameters:
deleteSelectionOnSuccess - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Frame

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class Frame

java.lang.Object
    extended by com.bstek.dorado.view.control.command.Frame
public class Frame
extends java.lang.Object

描述请求命令的目标框架的对象

Version:
4.0

Field Summary
static java.lang.String | BLANK 在一个空白的浏览器窗口中打开新页面.
static java.lang.String | MODAL_DIALOG 在一个模态对话框窗口中打开新页面.
static java.lang.String | MODELESS_DIALOG 在一个非模态对话框窗口中打开新页面.
static java.lang.String | PARENT 在当前页面所处的框架的直接父框架中打开新页面.
static java.lang.String | SELF 在自身浏览器窗口中打开新页面.
static java.lang.String | SUBWINDOW 在一个排他式子窗体中打开新页面.
static java.lang.String | TOP 在当前页面所处的框架的最顶层的框架中打开新页面.
Constructor Summary
Frame()
构造器
Method Summary
int | getHeight() 取得目标框架的高度值.
int | getLeft() 取得目标框架左边距值.
java.lang.String | getTarget() 返回在哪个目标框架中打开新页面.
int | getTop() 取得目标框架上部边距值.
int | getWidth() 取得目标框架的宽度值.
boolean | isCenter() 返回目标框架新页面是否自动居中对齐.
boolean | isResizable() 返回新窗口是否支持用户调整窗口尺寸.
boolean | isStatusbar() 返回新窗口是否有状态栏.
void | setCenter(boolean center) 设置目标框架新页面是否自动居中对齐.
void | setHeight(int height) 设置目标框架的高度值.
void | setLeft(int left) 设置目标框架左边距值.
void | setResizable(boolean resizable) 设置新窗口是否支持用户调整窗口尺寸.
void | setStatusbar(boolean statusbar) 设置目新窗口是否有状态栏.
void | setTarget(java.lang.String target) 设置在哪个目标框架中打开新页面.
void | setTop(int top) 设置目标框架上部边距值.
void | setWidth(int width) 取得目标框架的宽度值.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SELF

public static final java.lang.String SELF
在自身浏览器窗口中打开新页面.

See Also:
Constant Field Values

BLANK

public static final java.lang.String BLANK
在一个空白的浏览器窗口中打开新页面.

See Also:
Constant Field Values

PARENT

public static final java.lang.String PARENT
在当前页面所处的框架的直接父框架中打开新页面.

See Also:
Constant Field Values

TOP

public static final java.lang.String TOP
在当前页面所处的框架的最顶层的框架中打开新页面.

See Also:
Constant Field Values

MODAL_DIALOG

public static final java.lang.String MODAL_DIALOG
在一个模态对话框窗口中打开新页面.

See Also:
Constant Field Values

MODELESS_DIALOG

public static final java.lang.String MODELESS_DIALOG
在一个非模态对话框窗口中打开新页面.

See Also:
Constant Field Values

SUBWINDOW

public static final java.lang.String SUBWINDOW
在一个排他式子窗体中打开新页面.

See Also:
Constant Field Values
Constructor Detail

Frame

public Frame()
构造器

Method Detail

getTarget

public java.lang.String getTarget()
返回在哪个目标框架中打开新页面.

Returns:
String

setTarget

public void setTarget(java.lang.String target)
设置在哪个目标框架中打开新页面.
您可以从以下值选取一个目标框架也可以直接输入实际的目标框架的名字:
  • _self - 自身浏览器窗口
  • _blank - 空白的浏览器窗口
  • _parent - 当前页面所处的框架的直接父框架
  • _top - 当前页面所处的框架的最顶层的框架
  • _modal_dialog - 模态对话框窗口
  • _modeless_dialog - 非模态对话框窗口
  • _subwindow - 排他式子窗体

Parameters:
target - String

getLeft

public int getLeft()
取得目标框架左边距值.

Returns:
int

setLeft

public void setLeft(int left)
设置目标框架左边距值.

Parameters:
left - int

getTop

public int getTop()
取得目标框架上部边距值.

Returns:
int

setTop

public void setTop(int top)
设置目标框架上部边距值.

Parameters:
top - int

getWidth

public int getWidth()
取得目标框架的宽度值.

Returns:
int

setWidth

public void setWidth(int width)
取得目标框架的宽度值.

Parameters:
width - int

getHeight

public int getHeight()
取得目标框架的高度值.

Returns:
int

setHeight

public void setHeight(int height)
设置目标框架的高度值.

Parameters:
height - int

isCenter

public boolean isCenter()
返回目标框架新页面是否自动居中对齐.

Returns:
boolean

setCenter

public void setCenter(boolean center)
设置目标框架新页面是否自动居中对齐.

Parameters:
center - boolean

isResizable

public boolean isResizable()
返回新窗口是否支持用户调整窗口尺寸.

Returns:
boolean

setResizable

public void setResizable(boolean resizable)
设置新窗口是否支持用户调整窗口尺寸.

Parameters:
resizable - boolean

isStatusbar

public boolean isStatusbar()
返回新窗口是否有状态栏.

Returns:
boolean

setStatusbar

public void setStatusbar(boolean statusbar)
设置目新窗口是否有状态栏.

Parameters:
statusbar - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.command

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.command

命令控件的相关对象
See:
Description

Class Summary
Command | 命令对象的基类
CommandQueue | 命令队列
DatasetInfo | 用于描述提交命令(UpdateCommand)要提交的Dataset数据集的对象.
Frame | 描述请求命令的目标框架的对象
QueryCommand | 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
RequestCommand | 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
RPCCommand | 远程过程调用命令
UpdateCommand | 提交命令

Package com.bstek.dorado.view.control.command Description

命令控件的相关对象


QueryCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class QueryCommand

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.command.Command
            extended by com.bstek.dorado.view.control.command.QueryCommand
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class QueryCommand
extends Command

查询命令

该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
如果是AutoSqlDataset,我们可以利用MatchRule配置实现这一个查询功能, 这也就是我们在DoradoSample中查询范例实现的方式.
对于SqlDataset类型的数据集,我们需要在服务器端的service或者实现类中利用parameters动态修改它的查询sql语句, 从而实现查询处理.

Version:
4.0

Field Summary
static java.lang.String | FLUSH 通过数据集的flushData实现查询,此种查询方式下页面不会刷新
static java.lang.String | FORM_GET 通过一个内部的FORM表单模式get方式的提交来实现查询,此种查询方式页面下将被刷新
static java.lang.String | FORM_POST 通过一个内部的FORM表单模式post方式的提交来实现查询,此种查询方式页面下将被刷新
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
QueryCommand(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getConditionDataset() 返回作为查询条件的数据集的ID
ViewDataset | getConditionDatasetInstance() 返回作为查询条件的数据集的实例
java.lang.String | getQueryDataset() 返回被查询的数据集的ID
ViewDataset | getQueryDatasetInstance() 返回被查询的数据集的实例
java.lang.String | getQueryMode() 返回查询模式
boolean | isAsync() 是否以异步方式执行远程过程调用
boolean | isShowLoadingTip() 命令执行时是否显示提示窗口
void | setAsync(boolean async) 设定是否以异步方式执行远程过程调用
void | setConditionDataset(java.lang.String conditionDataset) 设置作为查询条件的数据集
void | setQueryDataset(java.lang.String queryDataset) 设置被查询的数据集
void | setQueryMode(java.lang.String queryMode) 设置查询模式.
void | setShowLoadingTip(boolean showLoadingTip) 设置命令执行时是否显示提示窗口
Methods inherited from class com.bstek.dorado.view.control.command.Command
isDisabled, parameters, setDisabled
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FLUSH

public static final java.lang.String FLUSH
通过数据集的flushData实现查询,此种查询方式下页面不会刷新

See Also:
Constant Field Values

FORM_GET

public static final java.lang.String FORM_GET
通过一个内部的FORM表单模式get方式的提交来实现查询,此种查询方式页面下将被刷新

See Also:
Constant Field Values

FORM_POST

public static final java.lang.String FORM_POST
通过一个内部的FORM表单模式post方式的提交来实现查询,此种查询方式页面下将被刷新

See Also:
Constant Field Values
Constructor Detail

QueryCommand

public QueryCommand(ViewModel viewModel,
                    java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getConditionDataset

public java.lang.String getConditionDataset()
返回作为查询条件的数据集的ID

Returns:
String

getConditionDatasetInstance

public ViewDataset getConditionDatasetInstance()
返回作为查询条件的数据集的实例

Returns:
ViewDataset

setConditionDataset

public void setConditionDataset(java.lang.String conditionDataset)
设置作为查询条件的数据集

Parameters:
conditionDataset - 数据集的ID

getQueryDataset

public java.lang.String getQueryDataset()
返回被查询的数据集的ID

Returns:
String

getQueryDatasetInstance

public ViewDataset getQueryDatasetInstance()
返回被查询的数据集的实例

Returns:
ViewDataset

setQueryDataset

public void setQueryDataset(java.lang.String queryDataset)
设置被查询的数据集

Parameters:
queryDataset - 数据集的ID

isAsync

public boolean isAsync()
是否以异步方式执行远程过程调用

Returns:
boolean

setAsync

public void setAsync(boolean async)
设定是否以异步方式执行远程过程调用

Parameters:
async - boolean

isShowLoadingTip

public boolean isShowLoadingTip()
命令执行时是否显示提示窗口

Returns:
boolean

setShowLoadingTip

public void setShowLoadingTip(boolean showLoadingTip)
设置命令执行时是否显示提示窗口

Parameters:
showLoadingTip - boolean

getQueryMode

public java.lang.String getQueryMode()
返回查询模式

Returns:
String

setQueryMode

public void setQueryMode(java.lang.String queryMode)
设置查询模式.
取值范围:
  • flush - 通过数据集的flushData实现查询,此种查询方式下页面不会刷新
  • form-get - 通过一个内部的FORM表单模式get方式的提交来实现查询,此种查询方式页面下将被刷新
  • form-post - 通过一个内部的FORM表单模式post方式的提交来实现查询,此种查询方式页面下将被刷新

Parameters:
queryMode - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class RequestCommand

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.command.Command
            extended by com.bstek.dorado.view.control.command.RequestCommand
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class RequestCommand
extends Command

请求命令

该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
请求命令支持自动传递数据集中数据的功能.设置绑定记录集属性,并指定好parameterFields. 这样该命令在执行请求时将会自动取出数据集当前记录中的值添加到HTTP的get参数当中.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
RequestCommand(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getDataset() 返回绑定的数据集的ID
ViewDataset | getDatasetInstance() 返回绑定的数据集的实例。
Frame | getFrame() 返回用于描述目前框架的对象.
java.lang.String | getParameterFields() 返回绑定数据集中将作为参数的字段.
java.lang.String | getPath() 取得命令要激活的URL资源
void | init(DoradoContext context, XmlNode node)
void | setDataset(java.lang.String dataset) 设定绑定的数据集
void | setParameterFields(java.lang.String parameterFields) 设置绑定数据集中将作为参数的字段.
void | setPath(java.lang.String path) 设定命令要激活的URL资源
Methods inherited from class com.bstek.dorado.view.control.command.Command
isDisabled, parameters, setDisabled
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequestCommand

public RequestCommand(ViewModel viewModel,
                      java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Throws:
java.lang.Exception

getPath

public java.lang.String getPath()
取得命令要激活的URL资源

Returns:
String

setPath

public void setPath(java.lang.String path)
设定命令要激活的URL资源

Parameters:
path - String

getDataset

public java.lang.String getDataset()
返回绑定的数据集的ID

Returns:
String

getDatasetInstance

public ViewDataset getDatasetInstance()
返回绑定的数据集的实例。

Returns:
ViewDataset

setDataset

public void setDataset(java.lang.String dataset)
设定绑定的数据集

Parameters:
dataset - String

getParameterFields

public java.lang.String getParameterFields()
返回绑定数据集中将作为参数的字段.

Returns:
String

setParameterFields

public void setParameterFields(java.lang.String parameterFields)
设置绑定数据集中将作为参数的字段.
如果此处需要描述多个字段,可以利用","分隔各字段名.
如果绑定了数据集但没有定义此属性,那么系统将会传递数据集当前记录中每一个字段的数值.

Parameters:
parameterFields - String

getFrame

public Frame getFrame()
返回用于描述目前框架的对象.

Returns:
Frame
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RPCCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class RPCCommand

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.command.Command
            extended by com.bstek.dorado.view.control.command.RPCCommand
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
UpdateCommand
public class RPCCommand
extends Command

远程过程调用命令

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
RPCCommand(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getAction() 取得接收此命令的Server端服务的url。
java.lang.String | getMethod() 返回执行此命令时在ViewModel的实现类中激活的方法名.
void | init(DoradoContext context, XmlNode node)
boolean | isAsync() 是否以异步方式执行远程过程调用
boolean | isShowLoadingTip() 命令执行时是否显示提示窗口
void | setAction(java.lang.String action) 设置接收此命令的Server端服务的url。
void | setAsync(boolean async) 设定是否以异步方式执行远程过程调用
void | setMethod(java.lang.String method) 指定执行此命令时在ViewModel的实现类中激活的方法名.
void | setShowLoadingTip(boolean showLoadingTip) 设置命令执行时是否显示提示窗口
Methods inherited from class com.bstek.dorado.view.control.command.Command
isDisabled, parameters, setDisabled
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RPCCommand

public RPCCommand(ViewModel viewModel,
                  java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Throws:
java.lang.Exception

getAction

public java.lang.String getAction()
取得接收此命令的Server端服务的url。

Returns:
String

setAction

public void setAction(java.lang.String action)
设置接收此命令的Server端服务的url。

Parameters:
action - String

getMethod

public java.lang.String getMethod()
返回执行此命令时在ViewModel的实现类中激活的方法名.

Returns:
String

setMethod

public void setMethod(java.lang.String method)
指定执行此命令时在ViewModel的实现类中激活的方法名.

Parameters:
method - String

isShowLoadingTip

public boolean isShowLoadingTip()
命令执行时是否显示提示窗口

Returns:
boolean

setShowLoadingTip

public void setShowLoadingTip(boolean showLoadingTip)
设置命令执行时是否显示提示窗口

Parameters:
showLoadingTip - boolean

isAsync

public boolean isAsync()
是否以异步方式执行远程过程调用

Returns:
boolean

setAsync

public void setAsync(boolean async)
设定是否以异步方式执行远程过程调用

Parameters:
async - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubmitFormDatasetCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class SubmitFormDatasetCommand

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.Command
            extended by com.bstek.dorado.view.control.command.SubmitFormDatasetCommand
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class SubmitFormDatasetCommand
extends Command

SubmitFormDatasetCommand对象

Version:
1.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
SubmitFormDatasetCommand(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getAction() 取得提交表单数据集命令(SubmitFormDatasetCommand)对象请求的动作(Action)值。
java.lang.String | getDataset() 取得提交表单数据集命令(SubmitFormDatasetCommand)对象提交的Dataset。
ViewDataset | getDatasetInstance() 返回提交表单数据集命令(SubmitFormDatasetCommand)对象提交的一个Dataset的实例。
java.lang.String | getMethod() 返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的方法(Method)值。
java.lang.String | getTarget() 返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的目标框架(Target)值。
void | setAction(java.lang.String action) 设定提交表单数据集命令(SubmitFormDatasetCommand)对象请求的动作(Action)值。
void | setDataset(java.lang.String dataset) 设定提交表单数据集命令(SubmitFormDatasetCommand)对象提交的Dataset对象。
void | setMethod(java.lang.String method) 设定提交表单数据集命令(SubmitFormDatasetCommand)对象请求的方法(Method)值。
void | setTarget(java.lang.String target) 返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的目标框架(Target)值。
Methods inherited from class com.bstek.dorado.view.control.Command
parameters
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubmitFormDatasetCommand

public SubmitFormDatasetCommand(ViewModel viewModel,
                                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getAction

public java.lang.String getAction()
取得提交表单数据集命令(SubmitFormDatasetCommand)对象请求的动作(Action)值。

Returns:
String

setAction

public void setAction(java.lang.String action)
设定提交表单数据集命令(SubmitFormDatasetCommand)对象请求的动作(Action)值。

Parameters:
action - String

getMethod

public java.lang.String getMethod()
返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的方法(Method)值。

Returns:
String

setMethod

public void setMethod(java.lang.String method)
设定提交表单数据集命令(SubmitFormDatasetCommand)对象请求的方法(Method)值。

Parameters:
method - String

getTarget

public java.lang.String getTarget()
返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的目标框架(Target)值。

Returns:
String

setTarget

public void setTarget(java.lang.String target)
返回提交表单数据集命令(SubmitFormDatasetCommand)对象请求的目标框架(Target)值。

Parameters:
target - String

getDataset

public java.lang.String getDataset()
取得提交表单数据集命令(SubmitFormDatasetCommand)对象提交的Dataset。

Returns:
String

getDatasetInstance

public ViewDataset getDatasetInstance()
返回提交表单数据集命令(SubmitFormDatasetCommand)对象提交的一个Dataset的实例。

Returns:
ViewDataset

setDataset

public void setDataset(java.lang.String dataset)
设定提交表单数据集命令(SubmitFormDatasetCommand)对象提交的Dataset对象。

Parameters:
dataset - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpdateCommand

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.command
Class UpdateCommand

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.command.Command
            extended by com.bstek.dorado.view.control.command.RPCCommand
                extended by com.bstek.dorado.view.control.command.UpdateCommand
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class UpdateCommand
extends RPCCommand

提交命令

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
UpdateCommand(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
DatasetInfo | addDatasetInfo(java.lang.String datasetId) 添加一个需要提交的数据集并返回新增的DatasetInfo对象.
DatasetInfo | addDatasetInfo(java.lang.String datasetId, java.lang.String submitScope) 添加一个需要提交的数据集并返回新增的DatasetInfo对象.
java.util.List | getDatasetInfos() 返回所有要提交的数据集的信息.
java.lang.String | getMethod() 返回执行此命令时在ViewModel的实现类中触发的方法名.
int | getTransactionMode() 取得事务模式
void | init(DoradoContext context, XmlNode node)
boolean | isAlwaysPerform() 是否总是允许执行.即不管是否存在需要提交的数据都强行的执行提交操作.
void | setAlwaysPerform(boolean alwaysPerform) 设置是否总是允许执行.即不管是否存在需要提交的数据都强行的执行提交操作.
void | setMethod(java.lang.String method) 指定执行此命令时在ViewModel的实现类中触发的方法名.
void | setTransactionMode(int transactionMode) 设定事务模式.
void | setTransactionMode(java.lang.String transactionMode) 设定事务模式.
Methods inherited from class com.bstek.dorado.view.control.command.RPCCommand
getAction, isAsync, isShowLoadingTip, setAction, setAsync, setShowLoadingTip
Methods inherited from class com.bstek.dorado.view.control.command.Command
isDisabled, parameters, setDisabled
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UpdateCommand

public UpdateCommand(ViewModel viewModel,
                     java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Overrides:
init in class RPCCommand
Throws:
java.lang.Exception

getTransactionMode

public int getTransactionMode()
取得事务模式

Returns:
int

setTransactionMode

public void setTransactionMode(int transactionMode)
设定事务模式. 请参考 @see com.bstek.dorado.common.TransactionManager. 默认值为TransactionManager.TRANSACTION_REQUIRED

Parameters:
transactionMode - int

setTransactionMode

public void setTransactionMode(java.lang.String transactionMode)
设定事务模式.

Parameters:
transactionMode - int

getMethod

public java.lang.String getMethod()
返回执行此命令时在ViewModel的实现类中触发的方法名. 默认值为update

Overrides:
getMethod in class RPCCommand
Returns:
String

setMethod

public void setMethod(java.lang.String method)
指定执行此命令时在ViewModel的实现类中触发的方法名. 默认值为update

Overrides:
setMethod in class RPCCommand
Parameters:
method - String

addDatasetInfo

public DatasetInfo addDatasetInfo(java.lang.String datasetId)
添加一个需要提交的数据集并返回新增的DatasetInfo对象.

Parameters:
datasetId - String
Returns:
DatasetInfo

addDatasetInfo

public DatasetInfo addDatasetInfo(java.lang.String datasetId,
                                  java.lang.String submitScope)
添加一个需要提交的数据集并返回新增的DatasetInfo对象.

Parameters:
datasetId - String
submitScope - String
Returns:
DatasetInfo

getDatasetInfos

public java.util.List getDatasetInfos()
返回所有要提交的数据集的信息.

Returns:
List

isAlwaysPerform

public boolean isAlwaysPerform()
是否总是允许执行.即不管是否存在需要提交的数据都强行的执行提交操作.

Returns:
boolean

setAlwaysPerform

public void setAlwaysPerform(boolean alwaysPerform)
设置是否总是允许执行.即不管是否存在需要提交的数据都强行的执行提交操作.

Parameters:
alwaysPerform - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AdvanceDropDown

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class AdvanceDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.AdvanceDropDown
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
CustomDropDown
public abstract class AdvanceDropDown
extends DropDown

高级下拉框的抽象类

当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
例如:
readFields为"id,name",
writeFields为"employee_id,employee_name"
那么当用户选择一个一条记录后,系统会将选中记录中的id字段中的数值赋值到目标数据集的employee_id字段中, 将选中记录中的name字段中的数值赋值到目标数据集的employee_name字段中.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
AdvanceDropDown(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getReadFields() 获得下拉框中需要从下拉选择的记录中读取的字段.
java.lang.String | getWriteFields() 获得下拉框中需要为对应目标数据集赋值的字段.
void | setReadFields(java.lang.String readFields) 设置下拉框中需要从下拉选择的记录中读取的字段.
void | setWriteFields(java.lang.String writeFields) 设置下拉框中需要为对应目标数据集赋值的字段.
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AdvanceDropDown

public AdvanceDropDown(ViewModel viewModel,
                       java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getReadFields

public java.lang.String getReadFields()
获得下拉框中需要从下拉选择的记录中读取的字段.

Returns:
String

setReadFields

public void setReadFields(java.lang.String readFields)
设置下拉框中需要从下拉选择的记录中读取的字段.
当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
多个字段中间用","分割,并且每个字段的顺序要与(writeFields)中对应字段的顺序一致.

Parameters:
readFields - String

getWriteFields

public java.lang.String getWriteFields()
获得下拉框中需要为对应目标数据集赋值的字段.

Returns:
String

setWriteFields

public void setWriteFields(java.lang.String writeFields)
设置下拉框中需要为对应目标数据集赋值的字段.
当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
多个字段中间用","分割,并且每个字段的顺序要与(readFields)中对应字段的顺序一致.

Parameters:
writeFields - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CachableDropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Interface CachableDropDown

All Known Implementing Classes:
CustomDropDown, DynamicDropDown
public interface CachableDropDown

支持缓存的下拉框接口

Version:
4.0

Method Summary
boolean | isCachable() 取得该下拉框是否支持缓存。
void | setCachable(boolean cachable) 设置该下拉框是否支持缓存。

Method Detail

isCachable

public boolean isCachable()
取得该下拉框是否支持缓存。

Returns:
boolean

setCachable

public void setCachable(boolean cachable)
设置该下拉框是否支持缓存。

Parameters:
cachable - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomDropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class CustomDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.AdvanceDropDown
                extended by com.bstek.dorado.view.control.dropdown.CustomDropDown
All Implemented Interfaces:
CachableDropDown, Component, Control, Element, EventSupported
Direct Known Subclasses:
DynamicDropDown
public class CustomDropDown
extends AdvanceDropDown
implements CachableDropDown

自定义下拉框对象

自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能. 这种下拉框的扩展是通过一个path属性绑定到一个可以由用户任意定制的下拉页面上, 按照这种方式我们可以非常灵活的开发出各种类型的下拉页面并最终将其封装为一个自定义下拉框.
同时下拉框还提供了onSelect事件以及beforeOpen事件, 方便开发人员在下拉框打开以及选择的过程中人工控制系统默认的动作.例如数据处理、界面显示等等.
需要注意的是被下拉框绑定的页面需要按照一些特定的规范来开发. 它和传统dorado页面的区别很小,我们可以很快地把一个传统的dorado页面改造成自定义下拉框页面.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
CustomDropDown(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getOpenMode() 返回自定义下拉框的打开方式.
java.lang.String | getPath() 取得下拉框将要打开的url路径.
boolean | isCachable() 取得该下拉框是否支持缓存。
void | setCachable(boolean cachable) 设置该下拉框是否支持缓存。
void | setOpenMode(java.lang.String openMode) 设定自定义下拉框的打开方式.
void | setPath(java.lang.String path) 设定下拉框将要打开的url路径.即绑定的下拉页面的url.
Methods inherited from class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
getReadFields, getWriteFields, setReadFields, setWriteFields
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomDropDown

public CustomDropDown(ViewModel viewModel,
                      java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

isCachable

public boolean isCachable()
取得该下拉框是否支持缓存。

Specified by:
isCachable in interface CachableDropDown
Returns:
boolean

setCachable

public void setCachable(boolean cachable)
设置该下拉框是否支持缓存。

Specified by:
setCachable in interface CachableDropDown
Parameters:
cachable - boolean

getPath

public java.lang.String getPath()
取得下拉框将要打开的url路径.

Returns:
String

setPath

public void setPath(java.lang.String path)
设定下拉框将要打开的url路径.即绑定的下拉页面的url.

Parameters:
path - String

getOpenMode

public java.lang.String getOpenMode()
返回自定义下拉框的打开方式.

Returns:
String

setOpenMode

public void setOpenMode(java.lang.String openMode)
设定自定义下拉框的打开方式.
  • dropdown(下拉模式)
  • subwindow(子窗体模式)

Parameters:
openMode - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CustomDropDownViewModel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class CustomDropDownViewModel

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
        extended by com.bstek.dorado.view.DefaultViewModel
            extended by com.bstek.dorado.view.control.dropdown.DropDownViewModel
                extended by com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
All Implemented Interfaces:
Element, EventSupported, ViewModel
public class CustomDropDownViewModel
extends DropDownViewModel

自定义下拉框的视图模型对象

Version:
1.0

Field Summary
Fields inherited from class com.bstek.dorado.view.ViewModelSupport
controls, datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
CustomDropDownViewModel()
Method Summary
 java.lang.String getDropDownType()
取得下拉框的类型
Methods inherited from class com.bstek.dorado.view.DefaultViewModel
initDataset
Methods inherited from class com.bstek.dorado.view.ViewModelSupport
addEventHandler, checkAccess, constructControl, constructDataset, createControl, createControl, createDataset, createDataset, doLoadData, doUpdateData, eventHandlers, finalize, getClientType, getConfig, getConfigName, getControl, getControls, getDataset, getDatasets, getDefaultSkin, getEventHandler, getNamespace, getRole, getRoleConfigs, getSkin, getState, getTag, handleRPC, handleUpdate, init, initControl, initControls, initDatasets, initLookupFields, isControlLazyLoad, isSafe, loadEventConfig, prepareDatasets, properties, removeControl, removeDataset, removeEventHandler, setClientType, setConfig, setConfigName, setControlLazyLoad, setNamespace, setRole, setSafe, setSkin, setTag, updateData
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomDropDownViewModel

public CustomDropDownViewModel()
Method Detail

getDropDownType

public java.lang.String getDropDownType()
取得下拉框的类型

Specified by:
getDropDownType in class DropDownViewModel
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetDropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DatasetDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.SimpleDropDown
                extended by com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
                    extended by com.bstek.dorado.view.control.dropdown.DatasetDropDown
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class DatasetDropDown
extends com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown

Dataset类型的下拉框

数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.

当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
例如:
readFields为"id,name",
writeFields为"employee_id,employee_name"
那么当用户选择一个一条记录后,系统会将选中记录中的id字段中的数值赋值到目标数据集的employee_id字段中, 将选中记录中的name字段中的数值赋值到目标数据集的employee_name字段中.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DatasetDropDown(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getDataset() 返回一个与数据集下拉框关联的数据集对象。
java.lang.String | getLabelField() 返回作为最终显示内容的字段
java.lang.String | getReadFields() 获得下拉框中需要从下拉选择的记录中读取的字段.
java.lang.String | getValueField() 返回作为内部数值的字段
java.lang.String | getWriteFields() 获得下拉框中需要为对应目标数据集赋值的字段.
boolean | isShowColumnHeader() 返回是否显示数据集下拉框中数据列的标题行。
void | setDataset(java.lang.String dataset) 根据指定的数据集名称，设定一个为数据集下拉框提供数据的数据集对象。
void | setLabelField(java.lang.String labelField) 设定作为最终显示内容的字段
void | setReadFields(java.lang.String readFields) 设置下拉框中需要从下拉选择的记录中读取的字段.
void | setShowColumnHeader(boolean showColumnHeader) 设定是否显示数据集下拉框中数据列的标题行。
void | setValueField(java.lang.String valueField) 设定作为内部数值的字段
void | setWriteFields(java.lang.String writeFields) 设置下拉框中需要为对应目标数据集赋值的字段.
Methods inherited from class com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
getVisibleFields, isMapValue, setMapValue, setVisibleFields
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DatasetDropDown

public DatasetDropDown(ViewModel viewModel,
                       java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getDataset

public java.lang.String getDataset()
返回一个与数据集下拉框关联的数据集对象。

Returns:
String

setDataset

public void setDataset(java.lang.String dataset)
根据指定的数据集名称，设定一个为数据集下拉框提供数据的数据集对象。

Parameters:
dataset - String

getValueField

public java.lang.String getValueField()
返回作为内部数值的字段

Returns:
String

setValueField

public void setValueField(java.lang.String valueField)
设定作为内部数值的字段

Parameters:
valueField - String

getLabelField

public java.lang.String getLabelField()
返回作为最终显示内容的字段

Returns:
String

setLabelField

public void setLabelField(java.lang.String labelField)
设定作为最终显示内容的字段

Parameters:
labelField - String

getReadFields

public java.lang.String getReadFields()
获得下拉框中需要从下拉选择的记录中读取的字段.

Returns:
String

setReadFields

public void setReadFields(java.lang.String readFields)
设置下拉框中需要从下拉选择的记录中读取的字段.
当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
多个字段中间用","分割,并且每个字段的顺序要与(writeFields)中对应字段的顺序一致.

Parameters:
readFields - String

getWriteFields

public java.lang.String getWriteFields()
获得下拉框中需要为对应目标数据集赋值的字段.

Returns:
String

setWriteFields

public void setWriteFields(java.lang.String writeFields)
设置下拉框中需要为对应目标数据集赋值的字段.
当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
多个字段中间用","分割,并且每个字段的顺序要与(readFields)中对应字段的顺序一致.

Parameters:
writeFields - String

isShowColumnHeader

public boolean isShowColumnHeader()
返回是否显示数据集下拉框中数据列的标题行。

Returns:
boolean

setShowColumnHeader

public void setShowColumnHeader(boolean showColumnHeader)
设定是否显示数据集下拉框中数据列的标题行。

Parameters:
showColumnHeader - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateDropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DateDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.SimpleDropDown
                extended by com.bstek.dorado.view.control.dropdown.DateDropDown
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class DateDropDown
extends SimpleDropDown

日期对象下拉框

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DateDropDown(ViewModel viewModel, java.lang.String id)
构造器
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateDropDown

public DateDropDown(ViewModel viewModel,
                    java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
AdvanceDropDown, SimpleDropDown
public abstract class DropDown
extends com.bstek.dorado.view.control.AbstractControl

下拉框的基类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DropDown(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
int | getHeight() 返回下拉框的默认高度
int | getWidth() 返回下拉框的默认宽度
boolean | isAutoDropDown() 返回当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。
boolean | isFixed() 返回是否禁止用户不通过下拉选择而直接输入。
void | setAutoDropDown(boolean autoDropDown) 设定当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。
void | setFixed(boolean fixed) 设定是否禁止用户不通过下拉选择而直接输入。
void | setHeight(int height) 设定下拉框的默认高度
void | setWidth(int width) 设定下拉框的默认宽度
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DropDown

public DropDown(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

isAutoDropDown

public boolean isAutoDropDown()
返回当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。

Returns:
boolean

setAutoDropDown

public void setAutoDropDown(boolean autoDropDown)
设定当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。

Parameters:
autoDropDown - boolean

isFixed

public boolean isFixed()
返回是否禁止用户不通过下拉选择而直接输入。

Returns:
boolean

setFixed

public void setFixed(boolean fixed)
设定是否禁止用户不通过下拉选择而直接输入。

Parameters:
fixed - boolean

getWidth

public int getWidth()
返回下拉框的默认宽度

Returns:
int

setWidth

public void setWidth(int width)
设定下拉框的默认宽度

Parameters:
width - int

getHeight

public int getHeight()
返回下拉框的默认高度

Returns:
int

setHeight

public void setHeight(int height)
设定下拉框的默认高度

Parameters:
height - int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DropDownItem

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DropDownItem

java.lang.Object
    extended by com.bstek.dorado.view.control.dropdown.DropDownItem
public class DropDownItem
extends java.lang.Object

下拉框选择项对象

Version:
4.0

Constructor Summary
DropDownItem()
构造器
Method Summary
java.lang.String | getLabel() 取得下拉框(DropDown)对应的字段(Field)的标题(Label)。
java.lang.String | getValue() 取得下拉框(DropDown)当前选择项的值。
void | setLabel(java.lang.String label) 设置下拉框(DropDown)对应的字段(Field)的标题(Label)。
void | setValue(java.lang.String value) 设定下拉框(DropDown)当前选择项为指定的值。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DropDownItem

public DropDownItem()
构造器

Method Detail

getValue

public java.lang.String getValue()
取得下拉框(DropDown)当前选择项的值。

Returns:
String

setValue

public void setValue(java.lang.String value)
设定下拉框(DropDown)当前选择项为指定的值。

Parameters:
value - String

getLabel

public java.lang.String getLabel()
取得下拉框(DropDown)对应的字段(Field)的标题(Label)。

Returns:
String

setLabel

public void setLabel(java.lang.String label)
设置下拉框(DropDown)对应的字段(Field)的标题(Label)。

Parameters:
label - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DropDownViewModel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DropDownViewModel

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
        extended by com.bstek.dorado.view.DefaultViewModel
            extended by com.bstek.dorado.view.control.dropdown.DropDownViewModel
All Implemented Interfaces:
Element, EventSupported, ViewModel
Direct Known Subclasses:
CustomDropDownViewModel, DynamicDropDownViewModel
public abstract class DropDownViewModel
extends DefaultViewModel

下拉框的视图模型对象

Version:
1.0

Field Summary
Fields inherited from class com.bstek.dorado.view.ViewModelSupport
controls, datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
DropDownViewModel()
Method Summary
abstract  java.lang.String getDropDownType()
取得下拉框的类型
Methods inherited from class com.bstek.dorado.view.DefaultViewModel
initDataset
Methods inherited from class com.bstek.dorado.view.ViewModelSupport
addEventHandler, checkAccess, constructControl, constructDataset, createControl, createControl, createDataset, createDataset, doLoadData, doUpdateData, eventHandlers, finalize, getClientType, getConfig, getConfigName, getControl, getControls, getDataset, getDatasets, getDefaultSkin, getEventHandler, getNamespace, getRole, getRoleConfigs, getSkin, getState, getTag, handleRPC, handleUpdate, init, initControl, initControls, initDatasets, initLookupFields, isControlLazyLoad, isSafe, loadEventConfig, prepareDatasets, properties, removeControl, removeDataset, removeEventHandler, setClientType, setConfig, setConfigName, setControlLazyLoad, setNamespace, setRole, setSafe, setSkin, setTag, updateData
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DropDownViewModel

public DropDownViewModel()
Method Detail

getDropDownType

public abstract java.lang.String getDropDownType()
取得下拉框的类型

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynamicDropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DynamicDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.AdvanceDropDown
                extended by com.bstek.dorado.view.control.dropdown.CustomDropDown
                    extended by com.bstek.dorado.view.control.dropdown.DynamicDropDown
All Implemented Interfaces:
CachableDropDown, Component, Control, Element, EventSupported
public class DynamicDropDown
extends CustomDropDown
implements CachableDropDown

动态数据下拉框

动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据. 动态数据下拉框与数据下拉框(DatasetDropDown)的区别在于数据下拉框会在页面打开时将下拉数据一次性生成到客户端, 而动态数据下拉框并不会在页面打开是下载任何数据,只有用户实际打开该下拉框时才会执行的数据下载.

由于数据已提前下载数据下拉框可以提供类似mapValue这样的功能, 但是它不能很好的适应下拉数据量较大的应用场景,同时过渡使用数据下拉框也可能造成页面效率的低下. 而动态数据下拉框则可以很好的适应大数据量的性能要求, 不会影响页面初次打开的速度,同时还可以提供动态数据筛选这样的功能.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DynamicDropDown(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
java.lang.String | getFilterParameter() 返回绑定的数据集中可用于实现动态数据筛选的参数
java.lang.String | getVisibleFields() 取得动态下拉框中指定要显示的数据列。
void | init(DoradoContext context, XmlNode node)
boolean | isFilterOnOpen() 返回是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。
boolean | isShowColumnHeader() 返回是否显示数据集下拉框中数据列的标题行。
ParameterSet | parameters() 返回参数集合 注意: 此处定义的参数最终将会传入到内部使用的数据集的参数当中
void | setFilterOnOpen(boolean filterOnOpen) 设置是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。
void | setFilterParameter(java.lang.String filterParameter) 设定绑定的数据集中可用于实现动态数据筛选的参数 设置此属性之后下拉框中将出现一个筛选区域,用户可以利用这个区域实现数据动态筛选的功能.
void | setShowColumnHeader(boolean showColumnHeader) 设定是否显示数据集下拉框中数据列的标题行。
void | setVisibleFields(java.lang.String visibleFields) 设定动态下拉框中要显示的数据列。
Methods inherited from class com.bstek.dorado.view.control.dropdown.CustomDropDown
getOpenMode, getPath, isCachable, setCachable, setOpenMode, setPath
Methods inherited from class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
getReadFields, getWriteFields, setReadFields, setWriteFields
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.dropdown.CachableDropDown
isCachable, setCachable

Constructor Detail

DynamicDropDown

public DynamicDropDown(ViewModel viewModel,
                       java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Throws:
java.lang.Exception

isShowColumnHeader

public boolean isShowColumnHeader()
返回是否显示数据集下拉框中数据列的标题行。

Returns:
boolean

setShowColumnHeader

public void setShowColumnHeader(boolean showColumnHeader)
设定是否显示数据集下拉框中数据列的标题行。

Parameters:
showColumnHeader - boolean

getVisibleFields

public java.lang.String getVisibleFields()
取得动态下拉框中指定要显示的数据列。 多个列之间用","分割。

Returns:
String

setVisibleFields

public void setVisibleFields(java.lang.String visibleFields)
设定动态下拉框中要显示的数据列。 多个列之间用","分割。

Parameters:
visibleFields - String

getFilterParameter

public java.lang.String getFilterParameter()
返回绑定的数据集中可用于实现动态数据筛选的参数

Returns:
String

setFilterParameter

public void setFilterParameter(java.lang.String filterParameter)
设定绑定的数据集中可用于实现动态数据筛选的参数

设置此属性之后下拉框中将出现一个筛选区域,用户可以利用这个区域实现数据动态筛选的功能. 系统内部将使用此属性定义的参数完成数据筛选的操作.

Parameters:
filterParameter - String

isFilterOnOpen

public boolean isFilterOnOpen()
返回是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。

Returns:
boolean

setFilterOnOpen

public void setFilterOnOpen(boolean filterOnOpen)
设置是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。

Parameters:
filterOnOpen - boolean

parameters

public ParameterSet parameters()
返回参数集合

注意: 此处定义的参数最终将会传入到内部使用的数据集的参数当中

Returns:
ParameterSet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynamicDropDownDataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DynamicDropDownDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.AbstractViewDataset
                    extended by com.bstek.dorado.view.data.AbstractDatasetReference
                        extended by com.bstek.dorado.view.data.DatasetReference
                            extended by com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
public class DynamicDropDownDataset
extends DatasetReference

动态下拉框数据集对象

Version:
1.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DynamicDropDownDataset(ViewModel viewModel, java.lang.String id)
Methods inherited from class com.bstek.dorado.view.data.DatasetReference
doGetSourceDatasetForLoad, doGetSourceDatasetForUpdate, getSourceDataset, getSourceModule, getType, setSourceDataset, setSourceModule
Methods inherited from class com.bstek.dorado.view.data.AbstractDatasetReference
doLoad, doUpdate, getRecordFactory, updateDetailKeys, updateRecord, updateSourceDataset
Methods inherited from class com.bstek.dorado.view.data.AbstractViewDataset
internalLoad, updateDetailDatasets
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, createFieldByNode, doFromDO, doFromSingleDO, eventHandlers, fireAfterScroll, fromDO, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getTag, getValidatorFactory, getViewModel, init, initNewRecord, initValidator, isAsync, isAutoLoadData, isAutoLoadPage, isIgnored, isInsertOnEmpty, isNoClient, isReadOnly, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setAutoLoadPage, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setReadOnly, setRecordSet, setShowLoadingTip, setTag, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

DynamicDropDownDataset

public DynamicDropDownDataset(ViewModel viewModel,
                              java.lang.String id)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DynamicDropDownViewModel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class DynamicDropDownViewModel

java.lang.Object
    extended by com.bstek.dorado.view.ViewModelSupport
        extended by com.bstek.dorado.view.DefaultViewModel
            extended by com.bstek.dorado.view.control.dropdown.DropDownViewModel
                extended by com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
All Implemented Interfaces:
Element, EventSupported, ViewModel
public class DynamicDropDownViewModel
extends DropDownViewModel

动态下拉框的视图模型对象

Version:
1.0

Field Summary
Fields inherited from class com.bstek.dorado.view.ViewModelSupport
controls, datasets
Fields inherited from interface com.bstek.dorado.view.ViewModel
DEFAULT_ROLE_ATTRIBUTE, DEFAULT_SKIN_ATTRIBUTE, REJECT_ROLE, STATE_DESIGN, STATE_SERVICE, STATE_UPDATING, STATE_VIEW
Constructor Summary
DynamicDropDownViewModel()
Method Summary
protected ViewDataset | constructDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。 此方法用于提供给非派生类进行重载。
java.lang.String | getDropDownType() getDropDownType
void | init(int state) 视图模型初始化
protected void | initControls() 初试化控件。 此方法用于提供给派生类进行重载。
protected void | initDatasets() 初试化数据集。 此方法用于提供给派生类进行重载。
void | prepareDatasets() 为视图模型中所有的Dataset准备数据。 注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。
Methods inherited from class com.bstek.dorado.view.DefaultViewModel
initDataset
Methods inherited from class com.bstek.dorado.view.ViewModelSupport
addEventHandler, checkAccess, constructControl, createControl, createControl, createDataset, createDataset, doLoadData, doUpdateData, eventHandlers, finalize, getClientType, getConfig, getConfigName, getControl, getControls, getDataset, getDatasets, getDefaultSkin, getEventHandler, getNamespace, getRole, getRoleConfigs, getSkin, getState, getTag, handleRPC, handleUpdate, initControl, initLookupFields, isControlLazyLoad, isSafe, loadEventConfig, properties, removeControl, removeDataset, removeEventHandler, setClientType, setConfig, setConfigName, setControlLazyLoad, setNamespace, setRole, setSafe, setSkin, setTag, updateData
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DynamicDropDownViewModel

public DynamicDropDownViewModel()
Method Detail

getDropDownType

public java.lang.String getDropDownType()
getDropDownType

Specified by:
getDropDownType in class DropDownViewModel
Returns:
String

init

public void init(int state)
          throws java.lang.Exception
Description copied from class: ViewModelSupport
视图模型初始化

Specified by:
init in interface ViewModel
Overrides:
init in class ViewModelSupport
Throws:
java.lang.Exception

initDatasets

protected void initDatasets()
                     throws java.lang.Exception
初试化数据集。 此方法用于提供给派生类进行重载。

Overrides:
initDatasets in class ViewModelSupport
Throws:
java.lang.Exception

constructDataset

protected ViewDataset constructDataset(java.lang.String type,
                                       java.lang.String id)
                                throws java.lang.Exception
根据类型和Id，创建一个视图数据集。 此方法用于提供给非派生类进行重载。

Overrides:
constructDataset in class ViewModelSupport
Parameters:
type - String
id - String
Returns:
ViewDataset
Throws:
java.lang.Exception

initControls

protected void initControls()
                     throws java.lang.Exception
初试化控件。 此方法用于提供给派生类进行重载。

Overrides:
initControls in class ViewModelSupport
Throws:
java.lang.Exception

prepareDatasets

public void prepareDatasets()
                     throws java.lang.Exception
为视图模型中所有的Dataset准备数据。

注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。

Specified by:
prepareDatasets in interface ViewModel
Overrides:
prepareDatasets in class ViewModelSupport
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListDropDown

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class ListDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.SimpleDropDown
                extended by com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
                    extended by com.bstek.dorado.view.control.dropdown.ListDropDown
All Implemented Interfaces:
Component, Control, Element, EventSupported
public class ListDropDown
extends com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown

列表下拉框

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
ListDropDown(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
DropDownItem | addItem(java.lang.String value) 根据指定值添加一个静态下拉框的下拉数据项对象。
DropDownItem | addItem(java.lang.String value, java.lang.String label) 根据指定值和标题属性添加一个静态下拉框的下拉数据项对象。
DropDownItem | getItem(int index) 根据指定的索引值取得静态下拉框的下拉数据项对象。
void | init(DoradoContext context, XmlNode node)
java.util.List | items() 取得所有静态下拉框的数据选择项的集合对象。
void | removeAll() 删除所有静态下拉框的下拉数据项对象。
void | removeItem(int index) 根据指定索引值删除静态下拉框的一个下拉数据项对象。
Methods inherited from class com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
getVisibleFields, isMapValue, setMapValue, setVisibleFields
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListDropDown

public ListDropDown(ViewModel viewModel,
                    java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getItem

public DropDownItem getItem(int index)
根据指定的索引值取得静态下拉框的下拉数据项对象。

Parameters:
index - int
Returns:
DropDownItem

addItem

public DropDownItem addItem(java.lang.String value)
根据指定值添加一个静态下拉框的下拉数据项对象。

Parameters:
value - String
Returns:
DropDownItem

addItem

public DropDownItem addItem(java.lang.String value,
                            java.lang.String label)
根据指定值和标题属性添加一个静态下拉框的下拉数据项对象。

Parameters:
value - String
label - String
Returns:
DropDownItem

removeItem

public void removeItem(int index)
根据指定索引值删除静态下拉框的一个下拉数据项对象。

Parameters:
index - int

removeAll

public void removeAll()
删除所有静态下拉框的下拉数据项对象。

items

public java.util.List items()
取得所有静态下拉框的数据选择项的集合对象。

Returns:
List

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.dropdown

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.dropdown

下拉框控件的相关对象
See:
Description

Interface Summary
CachableDropDown 支持缓存的下拉框接口

Class Summary
AdvanceDropDown | 高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
CustomDropDown | 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
CustomDropDownViewModel | 自定义下拉框的视图模型对象
DatasetDropDown | Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
DateDropDown | 日期对象下拉框
DropDown | 下拉框的基类
DropDownItem | 下拉框选择项对象
DropDownViewModel | 下拉框的视图模型对象
DynamicDropDown | 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
DynamicDropDownDataset | 动态下拉框数据集对象
DynamicDropDownViewModel | 动态下拉框的视图模型对象
ListDropDown | 列表下拉框
SimpleDropDown | 简单下拉框的基类

Package com.bstek.dorado.view.control.dropdown Description

下拉框控件的相关对象


SimpleDropDown

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.dropdown
Class SimpleDropDown

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.dropdown.DropDown
            extended by com.bstek.dorado.view.control.dropdown.SimpleDropDown
All Implemented Interfaces:
Component, Control, Element, EventSupported
Direct Known Subclasses:
com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown, DateDropDown
public abstract class SimpleDropDown
extends DropDown

简单下拉框的基类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
SimpleDropDown(ViewModel viewModel, java.lang.String id)
Methods inherited from class com.bstek.dorado.view.control.dropdown.DropDown
getHeight, getWidth, isAutoDropDown, isFixed, setAutoDropDown, setFixed, setHeight, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, init, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleDropDown

public SimpleDropDown(ViewModel viewModel,
                      java.lang.String id)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Column

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class Column

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
All Implemented Interfaces:
Element
Direct Known Subclasses:
ColumnGroup, DataColumn
public abstract class Column
extends java.lang.Object
implements Element

表格列的抽象类

Version:
4.0

Constructor Summary
Column(java.lang.String name)
表格列对象
Method Summary
java.lang.String | getLabel() 取得列的标题。
java.lang.String | getName() 取得列名。
java.lang.String | getTag() 取得元素的用户自定义信息。
java.lang.String | getToolTip() 取得该列的弹出式提示。
void | init(DoradoContext context, XmlNode node) 列初始化
boolean | isVisible() 返回表格中该列是否可见
void | setLabel(java.lang.String label) 设置列的标题。
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setToolTip(java.lang.String toolTip) 设置该列的弹出式提示。
void | setVisible(boolean visible) 设置表格中该列是否可见
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Column

public Column(java.lang.String name)
表格列对象

Parameters:
name - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws LoadXmlPropertyException
列初始化

Parameters:
context - DoradoContext
node - XmlNode
Throws:
LoadXmlPropertyException

getName

public java.lang.String getName()
取得列名。

Returns:
String

getLabel

public java.lang.String getLabel()
取得列的标题。

Returns:
String

setLabel

public void setLabel(java.lang.String label)
设置列的标题。

Parameters:
label - String

getToolTip

public java.lang.String getToolTip()
取得该列的弹出式提示。该属性表示当鼠标放在表格列标题上时会弹出来的提示信息。

Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设置该列的弹出式提示。该属性表示当鼠标放在表格列标题上时会弹出来的提示信息。

Parameters:
toolTip - String

isVisible

public boolean isVisible()
返回表格中该列是否可见

Returns:
表格中该列是否可见

setVisible

public void setVisible(boolean visible)
设置表格中该列是否可见

Parameters:
visible - 表格中该列是否可见

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ColumnGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class ColumnGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.ColumnGroup
All Implemented Interfaces:
Element
Direct Known Subclasses:
DataColumnGroup, StaticColumnGroup
public abstract class ColumnGroup
extends Column

组合列的基类

Version:
4.0

Constructor Summary
ColumnGroup(java.lang.String name)
构造器
Method Summary
Column | addColumn(Column column) 添加一个列对象
Column | addColumn(java.lang.String name) 添加一个指定名称的列,并返回新创建的列对象.
Column | addColumnByField(Field field) 根据指定的字段对象添加一个列对象,并返回新创建的列对象.
ObjectCollection | columns() 取得所有子列的集合对象。
Column | getColumn(int index) 根据索引值取得列对象。
Column | getColumn(java.lang.String name) 根据名称取得列对象。
int | getColumnCount() 取得子列的个数。
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ColumnGroup

public ColumnGroup(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

addColumn

public Column addColumn(Column column)
添加一个列对象

Parameters:
column - Column
Returns:
Column

addColumn

public Column addColumn(java.lang.String name)
添加一个指定名称的列,并返回新创建的列对象.

Parameters:
name - String
Returns:
Column

addColumnByField

public Column addColumnByField(Field field)
根据指定的字段对象添加一个列对象,并返回新创建的列对象.

Parameters:
field - Field
Returns:
Column

getColumn

public Column getColumn(int index)
根据索引值取得列对象。

Parameters:
index - int
Returns:
Column

getColumn

public Column getColumn(java.lang.String name)
根据名称取得列对象。

Parameters:
name - String
Returns:
Column

getColumnCount

public int getColumnCount()
取得子列的个数。

Returns:
int

columns

public ObjectCollection columns()
取得所有子列的集合对象。

Returns:
ObjectCollection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataColumn

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class DataColumn

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.DataColumn
All Implemented Interfaces:
Element
Direct Known Subclasses:
EditableColumn, StaticColumn
public abstract class DataColumn
extends Column

数据列的抽象类

Version:
4.0

Constructor Summary
DataColumn(java.lang.String name)
构造器
Method Summary
java.lang.String | getAlign() 取得列的水平对齐方式。
java.lang.String | getField() 取得表格列的数据来自于数据集的哪个字段。
java.lang.String | getFooterValue() 返回列的列脚值.此数值最终将被显示在表格中的该列对应的列脚单元格中.
int | getWidth() 取得列显示的宽度。
boolean | isNoWrap() 返回是否允许该列的内容换行显示。
void | setAlign(java.lang.String align) 设置列的水平对齐方式。
void | setField(java.lang.String field) 设置表格列的数据来自于数据集的哪个字段。
void | setFooterValue(java.lang.String footerValue) 设置列的列脚值.此数值最终将被显示在表格中的该列对应的列脚单元格中.
void | setNoWrap(boolean noWrap) 设置是否允许该列的内容换行显示。
void | setWidth(int width) 设置列显示的宽度。
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataColumn

public DataColumn(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getField

public java.lang.String getField()
取得表格列的数据来自于数据集的哪个字段。

Returns:
String

setField

public void setField(java.lang.String field)
设置表格列的数据来自于数据集的哪个字段。

Parameters:
field - String

isNoWrap

public boolean isNoWrap()
返回是否允许该列的内容换行显示。

Returns:
boolean

setNoWrap

public void setNoWrap(boolean noWrap)
设置是否允许该列的内容换行显示。

Parameters:
noWrap - boolean

getAlign

public java.lang.String getAlign()
取得列的水平对齐方式。

Returns:
String

setAlign

public void setAlign(java.lang.String align)
设置列的水平对齐方式。

Parameters:
align - String

getWidth

public int getWidth()
取得列显示的宽度。

Returns:
int

setWidth

public void setWidth(int width)
设置列显示的宽度。

Parameters:
width - int

getFooterValue

public java.lang.String getFooterValue()
返回列的列脚值.此数值最终将被显示在表格中的该列对应的列脚单元格中.

Returns:
String

setFooterValue

public void setFooterValue(java.lang.String footerValue)
设置列的列脚值.此数值最终将被显示在表格中的该列对应的列脚单元格中.

Parameters:
footerValue - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataColumnGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class DataColumnGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.ColumnGroup
            extended by com.bstek.dorado.view.control.table.DataColumnGroup
All Implemented Interfaces:
Element, EventSupported
public class DataColumnGroup
extends ColumnGroup
implements EventSupported

数据表格中的组合列的基类

Version:
4.0

Constructor Summary
DataColumnGroup(java.lang.String name)
Method Summary
void | addEventHandler(EventHandler event) 添加一个事件处理对象。
java.util.Map | eventHandlers() 取得所有事件处理对象的集合对象。
EventHandler | getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
boolean | isHeaderClickable() 返回数据表格的该列标题是否支持单击操作。
void | removeEventHandler(java.lang.String name) 根据指定的名称删除一个事件处理对象。
void | setHeaderClickable(boolean headerClickable) 设置数据表格的该列标题是否支持单击操作。
Methods inherited from class com.bstek.dorado.view.control.table.ColumnGroup
addColumn, addColumn, addColumnByField, columns, getColumn, getColumn, getColumnCount
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DataColumnGroup

public DataColumnGroup(java.lang.String name)
Method Detail

isHeaderClickable

public boolean isHeaderClickable()
返回数据表格的该列标题是否支持单击操作。该属性表示当鼠标放到该列标题区域后，标题会高亮显示。

Returns:
boolean

setHeaderClickable

public void setHeaderClickable(boolean headerClickable)
设置数据表格的该列标题是否支持单击操作。该属性表示当鼠标放到该列标题区域后，标题会高亮显示。

Parameters:
headerClickable - boolean

addEventHandler

public void addEventHandler(EventHandler event)
添加一个事件处理对象。

Specified by:
addEventHandler in interface EventSupported
Parameters:
event - EventHandler

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
根据指定名称取得一个事件处理对象。

Specified by:
getEventHandler in interface EventSupported
Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
根据指定的名称删除一个事件处理对象。

Specified by:
removeEventHandler in interface EventSupported
Parameters:
name - String

eventHandlers

public java.util.Map eventHandlers()
取得所有事件处理对象的集合对象。

Specified by:
eventHandlers in interface EventSupported
Returns:
Map
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DataTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class DataTable

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.table.Table
                    extended by com.bstek.dorado.view.control.table.DataTable
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
Direct Known Subclasses:
TreeGrid
public class DataTable
extends Table

数据表格

数据表格是一种可以编辑的多功能表格
系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。 另外该对象还提供了数据分批下载功能，用户可以通过拖动表格中的滚动栏实现数据分页下载, 系统会自动根据用户定位的记录位置下载相关的数据.

  • 全新的表格操作方式,可支持对超大数据集的动态分批下载.让用户告别分页的浏览方式.
  • 可支持表格列的动态大小调整和列拖动.
  • 可锁定的表格标题栏和合计栏.
  • 可锁定的表格左边列. 并可通过拖拽动态改变锁定列.
  • 支持组合表头.
  • 全新定义的表格模型可支持动态增删列等高级功能.
  • 支持自定义CellRenderer和CellEditor.
  • 支持的通过键盘操作完成对表格数据的编辑.

    • Version:
    4.0

    Field Summary
static java.lang.String | SCROLLMODE_RECORD 对当前记录进行滚动.
static java.lang.String | SCROLLMODE_SIMPLE 简单的滚动方式,指对表格的可见区域进行滚动.
    Fields inherited from class com.bstek.dorado.view.control.table.Table
    COLUMN_TYPE_BASE, COLUMN_TYPE_GROUP
    Fields inherited from class com.bstek.dorado.view.control.AbstractControl
    id, viewModel
    Constructor Summary
    DataTable(ViewModel viewModel, java.lang.String id)
    构造器
    Method Summary
protected Column | createColumn(java.lang.String name) 创建一个指定名称的列对象。
protected ColumnGroup | createColumnGroup(java.lang.String name) 创建一个指定名称的组合列
int | getFixedColumn() 返回数据表格中被锁定列的个数
int | getMaxRow() 取得数据表格能够显示的最大记录条数。
java.lang.String | getScrollMode() 返回数据表格垂直滚动条的滚动方式.
protected void | initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
boolean | isConfirmCancel() 返回用户在客户端对记录进行取消操作时是否有确认提示。
boolean | isConfirmDelete() 返回用户在客户端删除记录时是否有确认提示。
boolean | isEditable() 返回数据表格是否允许用户编辑。
boolean | isHighlightSelection() 返回是否高亮显示表格中的当前记录.
boolean | isReadOnly() 返回数据表格是否是只读。
boolean | isShowHScrollBar() 返回是否显示横向滚动栏
boolean | isShowIndicator() 返回在数据表格中是否显示表格指示器箭头。
boolean | isShowVScrollBar() 返回是否显示纵向滚动栏
void | setConfirmCancel(boolean confirmCancel) 设置用户在客户端对记录进行取消操作时是否有确认提示。
void | setConfirmDelete(boolean confirmDelete) 设置用户在客户端删除记录时是否有确认提示。
void | setEditable(boolean editable) 设置数据表格是否允许用户编辑。
void | setFixedColumn(int fixedColumn) 设置数据表格中被锁定列的个数
void | setHighlightSelection(boolean highlightSelection) 设置是否高亮显示表格中的当前记录.默认将会高亮显示。
void | setMaxRow(int maxRow) 设定数据表格能够显示的最大记录条数。
void | setReadOnly(boolean readOnly) 设置数据表格是否是只读。
void | setScrollMode(java.lang.String scrollMode) 设置数据表格垂直滚动条的滚动方式.取值范围: simple - 简单的滚动方式,指对表格的可见区域进行滚动.
void | setShowHScrollBar(boolean showHScrollBar) 设置是否显示横向滚动栏,默认是显示
void | setShowIndicator(boolean showIndicator) 设置在数据表格中是否显示表格指示器箭头。
void | setShowVScrollBar(boolean showVScrollBar) 设置是否显示纵向滚动栏,默认是显示
    Methods inherited from class com.bstek.dorado.view.control.table.Table
    addColumn, addColumn, addColumnByField, addColumnGroup, columns, getColumn, getColumn, getColumnCount, getFooterHeight, getHeaderHeight, getRowHeight, init, isShowFooter, isShowHeader, setFooterHeight, setHeaderHeight, setRowHeight, setShowFooter, setShowHeader
    Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
    getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
    Methods inherited from class com.bstek.dorado.view.control.DataControl
    getDataset, getDatasetInstance, setDataset
    Methods inherited from class com.bstek.dorado.view.control.AbstractControl
    addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
    Methods inherited from class java.lang.Object
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
    Methods inherited from interface com.bstek.dorado.view.control.Placeable
    getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

    Field Detail

    SCROLLMODE_SIMPLE

    public static final java.lang.String SCROLLMODE_SIMPLE
    简单的滚动方式,指对表格的可见区域进行滚动.

    See Also:
    Constant Field Values

    SCROLLMODE_RECORD

    public static final java.lang.String SCROLLMODE_RECORD
    对当前记录进行滚动.

    See Also:
    Constant Field Values
    Constructor Detail

    DataTable

    public DataTable(ViewModel viewModel,
                 java.lang.String id)
    构造器

    Parameters:
    viewModel - ViewModel
    id - String
    Method Detail

    createColumn

    protected Column createColumn(java.lang.String name)
    创建一个指定名称的列对象。

    Specified by:
    createColumn in class Table
    Parameters:
    name - String
    Returns:
    Column

    createColumnGroup

    protected ColumnGroup createColumnGroup(java.lang.String name)
    创建一个指定名称的组合列

    Specified by:
    createColumnGroup in class Table
    Parameters:
    name - String
    Returns:
    ColumnGroup

    initColumn

    protected void initColumn(DoradoContext context,
                          Column column,
                          XmlNode columnNode)
                   throws LoadXmlPropertyException
    初始化列

    Overrides:
    initColumn in class Table
    Parameters:
    context - DoradoContext
    column - Column
    columnNode - XmlNode
    Throws:
    LoadXmlPropertyException

    isReadOnly

    public boolean isReadOnly()
    返回数据表格是否是只读。只读属性表示用户只能查看但不能增加、修改和删除数据表格信息。

    Returns:
    boolean

    setReadOnly

    public void setReadOnly(boolean readOnly)
    设置数据表格是否是只读。只读属性表示用户只能查看但不能增加、修改和删除数据表格信息。

    Parameters:
    readOnly - boolean

    isEditable

    public boolean isEditable()
    返回数据表格是否允许用户编辑。 注意: 当editable==false时删除和添加的快捷键对于表格仍然有效

    Returns:
    boolean

    setEditable

    public void setEditable(boolean editable)
    设置数据表格是否允许用户编辑。 注意: 当editable==false时删除和添加的快捷键对于表格仍然有效

    Parameters:
    editable - boolean

    isConfirmDelete

    public boolean isConfirmDelete()
    返回用户在客户端删除记录时是否有确认提示。

    Returns:
    boolean

    setConfirmDelete

    public void setConfirmDelete(boolean confirmDelete)
    设置用户在客户端删除记录时是否有确认提示。

    Parameters:
    confirmDelete - boolean

    isConfirmCancel

    public boolean isConfirmCancel()
    返回用户在客户端对记录进行取消操作时是否有确认提示。

    Returns:
    boolean

    setConfirmCancel

    public void setConfirmCancel(boolean confirmCancel)
    设置用户在客户端对记录进行取消操作时是否有确认提示。

    Parameters:
    confirmCancel - boolean

    isShowIndicator

    public boolean isShowIndicator()
    返回在数据表格中是否显示表格指示器箭头。

    Returns:
    boolean

    setShowIndicator

    public void setShowIndicator(boolean showIndicator)
    设置在数据表格中是否显示表格指示器箭头。默认将会显示。

    Parameters:
    showIndicator - boolean

    isHighlightSelection

    public boolean isHighlightSelection()
    返回是否高亮显示表格中的当前记录.

    Returns:
    boolean

    setHighlightSelection

    public void setHighlightSelection(boolean highlightSelection)
    设置是否高亮显示表格中的当前记录.默认将会高亮显示。

    Parameters:
    highlightSelection - boolean

    getMaxRow

    public int getMaxRow()
    取得数据表格能够显示的最大记录条数。

    Returns:
    int

    setMaxRow

    public void setMaxRow(int maxRow)
    设定数据表格能够显示的最大记录条数。

    Parameters:
    maxRow - int

    isShowHScrollBar

    public boolean isShowHScrollBar()
    返回是否显示横向滚动栏

    Returns:
    boolean

    setShowHScrollBar

    public void setShowHScrollBar(boolean showHScrollBar)
    设置是否显示横向滚动栏,默认是显示

    Parameters:
    showHScrollBar - boolean

    isShowVScrollBar

    public boolean isShowVScrollBar()
    返回是否显示纵向滚动栏

    Returns:
    boolean

    setShowVScrollBar

    public void setShowVScrollBar(boolean showVScrollBar)
    设置是否显示纵向滚动栏,默认是显示

    Parameters:
    showVScrollBar - boolean

    getFixedColumn

    public int getFixedColumn()
    返回数据表格中被锁定列的个数

    Returns:
    int

    setFixedColumn

    public void setFixedColumn(int fixedColumn)
    设置数据表格中被锁定列的个数

    Parameters:
    fixedColumn - int

    getScrollMode

    public java.lang.String getScrollMode()
    返回数据表格垂直滚动条的滚动方式.

    Returns:
    String

    setScrollMode

    public void setScrollMode(java.lang.String scrollMode)
    设置数据表格垂直滚动条的滚动方式.取值范围:
    • simple - 简单的滚动方式,指对表格的可见区域进行滚动.
    • record - 对当前记录进行滚动.(默认方式)

    Parameters:
    scrollMode - String
    Overview Package Class Use Tree Deprecated Index Help
    PREV CLASS NEXT CLASS FRAMES NO FRAMES
    SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EditableColumn

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class EditableColumn

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.DataColumn
            extended by com.bstek.dorado.view.control.table.EditableColumn
All Implemented Interfaces:
Element, EventSupported
public class EditableColumn
extends DataColumn
implements EventSupported

数据表格中的可编辑列

Version:
1.0

Field Summary
static java.lang.String | CHECKBOX 编辑列的表现类型 - checkbox
static java.lang.String | PASSWORD 编辑列的表现类型 - password
static java.lang.String | TEXT 编辑列的表现类型 - text
static java.lang.String | TEXTAREA 编辑列的表现类型 - textarea
Constructor Summary
EditableColumn(java.lang.String name)
构造器
Method Summary
void | addEventHandler(EventHandler event) 添加一个事件处理对象。
java.util.Map | eventHandlers() 取得所有事件处理对象的集合对象。
java.lang.String | getDropDown() 取得绑定的下拉框对象
java.lang.String | getEditorType() 取得编辑器的类型
EventHandler | getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
java.lang.String | getRendererType() 返回表格单元格渲染器的类型
boolean | isHeaderClickable() 返回数据表格的该列标题是否支持单击操作。
boolean | isReadOnly() 返回列是否只读。
boolean | isResizable() 返回是否支持客户端用户对该列进行宽度调整操作。
boolean | isSortable() 返回是否支持客户端用户对该列进行排序操作。
void | removeEventHandler(java.lang.String name) 根据指定的名称删除一个事件处理对象。
void | setDropDown(java.lang.String dropDown) 设置绑定的下拉框对象
void | setEditorType(java.lang.String editorType) 设置编辑器的类型 取值范围: text - 文本框 textarea - 多行文本框 checkbox - 复选框 radiogroup - 单选框组合 password - 口令输入框
void | setHeaderClickable(boolean headerClickable) 设置数据表格的该列标题是否支持单击操作。
void | setReadOnly(boolean readOnly) 设定列是否只读。
void | setRendererType(java.lang.String rendererType) 设置表格单元格渲染器的类型 取值范围: label - 文本标签 text - 文本框 textarea - 多行文本框 checkbox - 复选框 radiogroup - 单选框组合 password - 口令输入框
void | setResizable(boolean resizable) 设定是否支持客户端用户对该列进行宽度调整操作。
void | setSortable(boolean sortable) 设定是否支持客户端用户对该列进行排序操作。
Methods inherited from class com.bstek.dorado.view.control.table.DataColumn
getAlign, getField, getFooterValue, getWidth, isNoWrap, setAlign, setField, setFooterValue, setNoWrap, setWidth
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEXT

public static final java.lang.String TEXT
编辑列的表现类型 - text

See Also:
Constant Field Values

TEXTAREA

public static final java.lang.String TEXTAREA
编辑列的表现类型 - textarea

See Also:
Constant Field Values

CHECKBOX

public static final java.lang.String CHECKBOX
编辑列的表现类型 - checkbox

See Also:
Constant Field Values

PASSWORD

public static final java.lang.String PASSWORD
编辑列的表现类型 - password

See Also:
Constant Field Values
Constructor Detail

EditableColumn

public EditableColumn(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

isReadOnly

public boolean isReadOnly()
返回列是否只读。

Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设定列是否只读。

Parameters:
readOnly - boolean

getRendererType

public java.lang.String getRendererType()
返回表格单元格渲染器的类型

Returns:
String

setRendererType

public void setRendererType(java.lang.String rendererType)
设置表格单元格渲染器的类型
取值范围:
  • label - 文本标签
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框

Parameters:
rendererType - String

getEditorType

public java.lang.String getEditorType()
取得编辑器的类型

Returns:
String

setEditorType

public void setEditorType(java.lang.String editorType)
设置编辑器的类型
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框

Parameters:
editorType - String

getDropDown

public java.lang.String getDropDown()
取得绑定的下拉框对象

Returns:
String

setDropDown

public void setDropDown(java.lang.String dropDown)
设置绑定的下拉框对象

Parameters:
dropDown - String

isResizable

public boolean isResizable()
返回是否支持客户端用户对该列进行宽度调整操作。

Returns:
boolean

setResizable

public void setResizable(boolean resizable)
设定是否支持客户端用户对该列进行宽度调整操作。

Parameters:
resizable - boolean

isSortable

public boolean isSortable()
返回是否支持客户端用户对该列进行排序操作。

Returns:
boolean

setSortable

public void setSortable(boolean sortable)
设定是否支持客户端用户对该列进行排序操作。

Parameters:
sortable - boolean

isHeaderClickable

public boolean isHeaderClickable()
返回数据表格的该列标题是否支持单击操作。该属性表示当鼠标放到该列标题区域后，标题会高亮显示。

Returns:
boolean

setHeaderClickable

public void setHeaderClickable(boolean headerClickable)
设置数据表格的该列标题是否支持单击操作。该属性表示当鼠标放到该列标题区域后，标题会高亮显示。

Parameters:
headerClickable - boolean

addEventHandler

public void addEventHandler(EventHandler event)
添加一个事件处理对象。

Specified by:
addEventHandler in interface EventSupported
Parameters:
event - EventHandler

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
根据指定名称取得一个事件处理对象。

Specified by:
getEventHandler in interface EventSupported
Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
根据指定的名称删除一个事件处理对象。

Specified by:
removeEventHandler in interface EventSupported
Parameters:
name - String

eventHandlers

public java.util.Map eventHandlers()
取得所有事件处理对象的集合对象。

Specified by:
eventHandlers in interface EventSupported
Returns:
Map
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EditableColumnGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class EditableColumnGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.ColumnGroup
            extended by com.bstek.dorado.view.control.table.EditableColumnGroup
All Implemented Interfaces:
Element, EventSupported
public class EditableColumnGroup
extends ColumnGroup
implements EventSupported

Constructor Summary
EditableColumnGroup(java.lang.String name)
Method Summary
void | addEventHandler(EventHandler event) 添加一个事件处理对象。
java.util.Map | eventHandlers() 取得所有事件处理对象的集合对象。
EventHandler | getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
boolean | isHeaderClickable() 返回数据表格的该列标题是否支持单击操作。
void | removeEventHandler(java.lang.String name) 根据指定的名称删除一个事件处理对象。
void | setHeaderClickable(boolean headerClickable) 设置数据表格的该列标题是否支持单击操作。
Methods inherited from class com.bstek.dorado.view.control.table.ColumnGroup
addColumn, addColumn, addColumnByField, columns, getColumn, getColumn, getColumnCount
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EditableColumnGroup

public EditableColumnGroup(java.lang.String name)
Method Detail

isHeaderClickable

public boolean isHeaderClickable()
返回数据表格的该列标题是否支持单击操作。该属性表示当鼠标放到该列标题区域后，标题会高亮显示。

Returns:
boolean

setHeaderClickable

public void setHeaderClickable(boolean headerClickable)
设置数据表格的该列标题是否支持单击操作。该属性表示当鼠标放到该列标题区域后，标题会高亮显示。

Parameters:
headerClickable - boolean

addEventHandler

public void addEventHandler(EventHandler event)
添加一个事件处理对象。

Specified by:
addEventHandler in interface EventSupported
Parameters:
event - EventHandler

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
根据指定名称取得一个事件处理对象。

Specified by:
getEventHandler in interface EventSupported
Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
根据指定的名称删除一个事件处理对象。

Specified by:
removeEventHandler in interface EventSupported
Parameters:
name - String

eventHandlers

public java.util.Map eventHandlers()
取得所有事件处理对象的集合对象。

Specified by:
eventHandlers in interface EventSupported
Returns:
Map
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.table

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.table

表格控件的相关对象
See:
Description

Class Summary
Column | 表格列的抽象类
ColumnGroup | 组合列的基类
DataColumn | 数据列的抽象类
DataColumnGroup | 数据表格中的组合列的基类
DataTable | 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
EditableColumn | 数据表格中的可编辑列
StaticColumn | 静态表格列
StaticColumnGroup | 静态表格中的组合列
StaticTable | 静态表格类
Table | 表格的基类

Package com.bstek.dorado.view.control.table Description

表格控件的相关对象


StaticColumn

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class StaticColumn

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.DataColumn
            extended by com.bstek.dorado.view.control.table.StaticColumn
All Implemented Interfaces:
Element
public class StaticColumn
extends DataColumn

静态表格列

Version:
4.0

Constructor Summary
StaticColumn(java.lang.String name)
构造器
Method Summary
java.lang.String | getPattern() 取得静态列的模式
void | setPattern(java.lang.String pattern) 取得静态列的模式
Methods inherited from class com.bstek.dorado.view.control.table.DataColumn
getAlign, getField, getFooterValue, getWidth, isNoWrap, setAlign, setField, setFooterValue, setNoWrap, setWidth
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StaticColumn

public StaticColumn(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getPattern

public java.lang.String getPattern()
取得静态列的模式

Returns:
String

setPattern

public void setPattern(java.lang.String pattern)
取得静态列的模式

Parameters:
pattern - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaticColumnGroup

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class StaticColumnGroup

java.lang.Object
    extended by com.bstek.dorado.view.control.table.Column
        extended by com.bstek.dorado.view.control.table.ColumnGroup
            extended by com.bstek.dorado.view.control.table.StaticColumnGroup
All Implemented Interfaces:
Element
public class StaticColumnGroup
extends ColumnGroup

静态表格中的组合列

Version:
4.0

Constructor Summary
StaticColumnGroup(java.lang.String name)
构造器
Methods inherited from class com.bstek.dorado.view.control.table.ColumnGroup
addColumn, addColumn, addColumnByField, columns, getColumn, getColumn, getColumnCount
Methods inherited from class com.bstek.dorado.view.control.table.Column
getLabel, getName, getTag, getToolTip, init, isVisible, setLabel, setTag, setToolTip, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StaticColumnGroup

public StaticColumnGroup(java.lang.String name)
构造器

Parameters:
name - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaticTable

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class StaticTable

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.table.Table
                    extended by com.bstek.dorado.view.control.table.StaticTable
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class StaticTable
extends Table

静态表格类

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.table.Table
COLUMN_TYPE_BASE, COLUMN_TYPE_GROUP
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
StaticTable(ViewModel viewModel, java.lang.String id)
Method Summary
protected Column | createColumn(java.lang.String name) 创建一个指定名称的列对象。
protected ColumnGroup | createColumnGroup(java.lang.String name) 创建一个指定名称的组合列
Methods inherited from class com.bstek.dorado.view.control.table.Table
addColumn, addColumn, addColumnByField, addColumnGroup, columns, getColumn, getColumn, getColumnCount, getFooterHeight, getHeaderHeight, getRowHeight, init, initColumn, isShowFooter, isShowHeader, setFooterHeight, setHeaderHeight, setRowHeight, setShowFooter, setShowHeader
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

StaticTable

public StaticTable(ViewModel viewModel,
                   java.lang.String id)
Method Detail

createColumn

protected Column createColumn(java.lang.String name)
创建一个指定名称的列对象。

Specified by:
createColumn in class Table
Parameters:
name - String
Returns:
Column

createColumnGroup

protected ColumnGroup createColumnGroup(java.lang.String name)
创建一个指定名称的组合列

Specified by:
createColumnGroup in class Table
Parameters:
name - String
Returns:
ColumnGroup
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Table

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.table
Class Table

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.DataControl
            extended by com.bstek.dorado.view.control.PlaceableDataControl
                extended by com.bstek.dorado.view.control.table.Table
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
Direct Known Subclasses:
DataTable, StaticTable
public abstract class Table
extends PlaceableDataControl
implements Visible

表格的基类

Version:
1.0

Field Summary
static java.lang.String | COLUMN_TYPE_BASE
static java.lang.String | COLUMN_TYPE_GROUP
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Table(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
Column | addColumn(Column column) 添加一个列对象。
Column | addColumn(java.lang.String name) 添加一个指定名称的列。
Column | addColumnByField(Field field) 根据指定的字段对象添加一个列。
ColumnGroup | addColumnGroup(java.lang.String name) 添加一个指定名称的组合列。
ObjectCollection | columns() 取得所有列的集合对象。
protected abstract Column | createColumn(java.lang.String name) 创建一个指定名称的列对象。
protected abstract ColumnGroup | createColumnGroup(java.lang.String name) 创建一个指定名称的组合列
Column | getColumn(int index) 根据索引值取得列(Column)对象。
Column | getColumn(java.lang.String name) 根据名称取得列对象。
int | getColumnCount() 取得列的个数。
int | getFooterHeight() 返回合计栏位的高度
int | getHeaderHeight() 返回表格列标题高度
int | getRowHeight() 返回表格数据行的高度
void | init(DoradoContext context, XmlNode node)
protected void | initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
boolean | isShowFooter() 取得是否显示表格的汇总栏，默认是显示。
boolean | isShowHeader() 返回是否显示表格的标题栏，默认是显示。
void | setFooterHeight(int footerHeight) 设置合计栏位的高度
void | setHeaderHeight(int headerHeight) 设置表格列标题的高度
void | setRowHeight(int rowHeight) 设置表格数据行的高度
void | setShowFooter(boolean showFooter) 设定是否显示表格的汇总栏，默认是显示。
void | setShowHeader(boolean showHeader) 设定是否显示表格的标题栏，默认是显示。
Methods inherited from class com.bstek.dorado.view.control.PlaceableDataControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.DataControl
getDataset, getDatasetInstance, setDataset
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

COLUMN_TYPE_BASE

public static final java.lang.String COLUMN_TYPE_BASE
See Also:
Constant Field Values

COLUMN_TYPE_GROUP

public static final java.lang.String COLUMN_TYPE_GROUP
See Also:
Constant Field Values
Constructor Detail

Table

public Table(ViewModel viewModel,
             java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Throws:
java.lang.Exception

initColumn

protected void initColumn(DoradoContext context,
                          Column column,
                          XmlNode columnNode)
                   throws LoadXmlPropertyException
初始化列

Parameters:
context - DoradoContext
column - Column
columnNode - XmlNode
Throws:
LoadXmlPropertyException

addColumn

public Column addColumn(Column column)
添加一个列对象。

Parameters:
column - Column
Returns:
Column

addColumn

public Column addColumn(java.lang.String name)
添加一个指定名称的列。

Parameters:
name - String
Returns:
Column

addColumnGroup

public ColumnGroup addColumnGroup(java.lang.String name)
添加一个指定名称的组合列。

Parameters:
name - String
Returns:
ColumnGroup

createColumnGroup

protected abstract ColumnGroup createColumnGroup(java.lang.String name)
创建一个指定名称的组合列

Parameters:
name - String
Returns:
ColumnGroup

createColumn

protected abstract Column createColumn(java.lang.String name)
创建一个指定名称的列对象。

Parameters:
name - String
Returns:
Column

addColumnByField

public Column addColumnByField(Field field)
根据指定的字段对象添加一个列。

Parameters:
field - Field
Returns:
Column

getColumn

public Column getColumn(int index)
根据索引值取得列(Column)对象。

Parameters:
index - int
Returns:
Column

getColumn

public Column getColumn(java.lang.String name)
根据名称取得列对象。

Parameters:
name - String
Returns:
Column

getColumnCount

public int getColumnCount()
取得列的个数。

Returns:
int

columns

public ObjectCollection columns()
取得所有列的集合对象。

Returns:
ObjectCollection

isShowHeader

public boolean isShowHeader()
返回是否显示表格的标题栏，默认是显示。

Returns:
boolean

setShowHeader

public void setShowHeader(boolean showHeader)
设定是否显示表格的标题栏，默认是显示。

Parameters:
showHeader - boolean

isShowFooter

public boolean isShowFooter()
取得是否显示表格的汇总栏，默认是显示。

Returns:
boolean

setShowFooter

public void setShowFooter(boolean showFooter)
设定是否显示表格的汇总栏，默认是显示。

Parameters:
showFooter - boolean

getHeaderHeight

public int getHeaderHeight()
返回表格列标题高度

Returns:
int

setHeaderHeight

public void setHeaderHeight(int headerHeight)
设置表格列标题的高度

Parameters:
headerHeight - int

getRowHeight

public int getRowHeight()
返回表格数据行的高度

Returns:
int

setRowHeight

public void setRowHeight(int rowHeight)
设置表格数据行的高度

Parameters:
rowHeight - int

getFooterHeight

public int getFooterHeight()
返回合计栏位的高度

Returns:
int

setFooterHeight

public void setFooterHeight(int footerHeight)
设置合计栏位的高度

Parameters:
footerHeight - int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FrameTab

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tabset
Class FrameTab

java.lang.Object
    extended by com.bstek.dorado.view.control.tabset.TabElement
        extended by com.bstek.dorado.view.control.tabset.FrameTab
All Implemented Interfaces:
Element
public class FrameTab
extends TabElement

多页标签中的子框架标签项

子框架标签项在多页标签中用于显示指定URL资源的页面. 对于需要频繁切换的子框架标签项,我们可以设定其cache功能,便于快速的打开标签项.

Version:
4.0

Constructor Summary
FrameTab(java.lang.String name)
构造器
FrameTab(java.lang.String name, java.lang.String label)
构造器
Method Summary
java.lang.String | getPath() 取得多页标签切换时需要跳转的URL路径。
boolean | isCachable() 返回是否允许缓存Frame内容
void | setCachable(boolean cachable) 设置是否允许缓存Frame内容
void | setPath(java.lang.String path) 设定多页标签切换时需要跳转的URL路径。
Methods inherited from class com.bstek.dorado.view.control.tabset.TabElement
getLabel, getName, getPadding, getTabSet, getTag, isDisabled, isVisible, setDisabled, setLabel, setName, setPadding, setTabSet, setTag, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FrameTab

public FrameTab(java.lang.String name)
构造器

Parameters:
name - String

FrameTab

public FrameTab(java.lang.String name,
                java.lang.String label)
构造器

Parameters:
name - String
label - String
Method Detail

getPath

public java.lang.String getPath()
取得多页标签切换时需要跳转的URL路径。

Returns:
String

setPath

public void setPath(java.lang.String path)
设定多页标签切换时需要跳转的URL路径。

Parameters:
path - String

isCachable

public boolean isCachable()
返回是否允许缓存Frame内容

Returns:
boolean

setCachable

public void setCachable(boolean cachable)
设置是否允许缓存Frame内容

Parameters:
cachable - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.tabset

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.tabset

多页标签控件的相关对象
See:
Description

Class Summary
FrameTab | 多页标签中的子框架标签项 子框架标签项在多页标签中用于显示指定URL资源的页面.
Tab | 多页标签中的默认标签项
TabElement | 多页标签页中标签页的基类
TabSet | 多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Package com.bstek.dorado.view.control.tabset Description

多页标签控件的相关对象


Tab

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tabset
Class Tab

java.lang.Object
    extended by com.bstek.dorado.view.control.tabset.TabElement
        extended by com.bstek.dorado.view.control.tabset.Tab
All Implemented Interfaces:
Element
public class Tab
extends TabElement

多页标签中的默认标签项

Version:
4.0

Constructor Summary
Tab(java.lang.String name)
构造器
Tab(java.lang.String name, java.lang.String label)
构造器
Method Summary
boolean | isAutoCreateDiv() 是否自动创建与该标签页相关联的层.
boolean | isAutoScroll() isAutoScroll
void | setAutoCreateDiv(boolean autoCreateDiv) 设置是否自动创建与该标签页相关联的层.默认值为false.
void | setAutoScroll(boolean autoScroll) setAutoScroll
Methods inherited from class com.bstek.dorado.view.control.tabset.TabElement
getLabel, getName, getPadding, getTabSet, getTag, isDisabled, isVisible, setDisabled, setLabel, setName, setPadding, setTabSet, setTag, setVisible
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Tab

public Tab(java.lang.String name)
构造器

Parameters:
name - String

Tab

public Tab(java.lang.String name,
           java.lang.String label)
构造器

Parameters:
name - String
label - String
Method Detail

isAutoCreateDiv

public boolean isAutoCreateDiv()
是否自动创建与该标签页相关联的层.

Returns:
boolean

isAutoScroll

public boolean isAutoScroll()
isAutoScroll

Returns:
boolean

setAutoCreateDiv

public void setAutoCreateDiv(boolean autoCreateDiv)
设置是否自动创建与该标签页相关联的层.默认值为false.

如果设置标签页不自动创建相关联的层,那么我们也可以在页面中手工添加一个id为: tabset.id+"_"+tab.name的层.标签页将自动与这个层关联.例如:
在tabset1中有一个标签页的名字是tab1, 我们可以手工添加一个id为tabset1_tab1的层来与标签页关联.

Parameters:
autoCreateDiv - boolean

setAutoScroll

public void setAutoScroll(boolean autoScroll)
setAutoScroll

Parameters:
autoScroll - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabElement

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tabset
Class TabElement

java.lang.Object
    extended by com.bstek.dorado.view.control.tabset.TabElement
All Implemented Interfaces:
Element
Direct Known Subclasses:
FrameTab, Tab
public class TabElement
extends java.lang.Object
implements Element

多页标签页中标签页的基类

Version:
4.0

Constructor Summary
TabElement(java.lang.String name)
构造器
TabElement(java.lang.String name, java.lang.String label)
构造器
Method Summary
java.lang.String | getLabel() 取得多页标签表格的标题。
java.lang.String | getName() 返回多页标签表格的名称。
java.lang.String | getPadding() 取得标签页的边缘空白
TabSet | getTabSet() 返回标签所属的TabSet对象
java.lang.String | getTag() 取得元素的用户自定义信息。
boolean | isDisabled() 返回当前标签项表格是否被禁止，被禁止的标签项上所有的元素都无法操作。
boolean | isVisible() 返回标签项表格是否可见。
void | setDisabled(boolean disabled) 设置当前标签项表格是否被禁止，被禁止的标签项上所有的元素都无法操作。
void | setLabel(java.lang.String label) 设定多页标签表格的标题。
void | setName(java.lang.String name) 设定多页标签表格的名称。
void | setPadding(java.lang.String padding) 设置标签页的边缘空白
void | setTabSet(TabSet tabset) 设定标签所属的TabSet对象
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setVisible(boolean visible) 设定标签项表格是否可见。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TabElement

public TabElement(java.lang.String name)
构造器

Parameters:
name - String

TabElement

public TabElement(java.lang.String name,
                  java.lang.String label)
构造器

Parameters:
name - String
label - String
Method Detail

getName

public java.lang.String getName()
返回多页标签表格的名称。

Returns:
String

setName

public void setName(java.lang.String name)
设定多页标签表格的名称。

Parameters:
name - String

getLabel

public java.lang.String getLabel()
取得多页标签表格的标题。

Returns:
String

setLabel

public void setLabel(java.lang.String label)
设定多页标签表格的标题。

Parameters:
label - String

isDisabled

public boolean isDisabled()
返回当前标签项表格是否被禁止，被禁止的标签项上所有的元素都无法操作。

Returns:
boolean

setDisabled

public void setDisabled(boolean disabled)
设置当前标签项表格是否被禁止，被禁止的标签项上所有的元素都无法操作。

Parameters:
disabled - boolean

isVisible

public boolean isVisible()
返回标签项表格是否可见。

Returns:
boolean

setVisible

public void setVisible(boolean visible)
设定标签项表格是否可见。

Parameters:
visible - boolean

getPadding

public java.lang.String getPadding()
取得标签页的边缘空白

Returns:
String

setPadding

public void setPadding(java.lang.String padding)
设置标签页的边缘空白

Parameters:
padding - String

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String

getTabSet

public TabSet getTabSet()
返回标签所属的TabSet对象

Returns:
TabSet

setTabSet

public void setTabSet(TabSet tabset)
设定标签所属的TabSet对象

Parameters:
tabset - TabSet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabSet

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tabset
Class TabSet

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.tabset.TabSet
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class TabSet
extends PlaceableControl
implements Visible

多页标签

TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件. 一般情况下用于管理网页复杂信息展示时的分类管理,便于用户阅读与操作.

Version:
4.0

Field Summary
static java.lang.String | TABPLACEMENT_BOTTOM 标签页按钮的位置 - 下部
static java.lang.String | TABPLACEMENT_TOP 标签页按钮的位置 - 上部
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
TabSet(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
TabElement | addTab(java.lang.String name) Deprecated.
TabElement | addTab(java.lang.String name, java.lang.String label) Deprecated.
void | addTab(TabElement tab) 添加一个指定标签项
java.lang.String | getCurrentTab() 取得当前标签页的设置.
TabElement | getTab(int index) 取得一个指定索引位置的标签项对象。
TabElement | getTab(java.lang.String name) 取得一个指定名称的标签项对象。
int | getTabCount() 取得标签项的总数
java.lang.String | getTabPlacement() 取得多页标签所在的位置.
ObjectCollection | getTabs() 取得所有多页标签的集合对象。
void | init(DoradoContext context, XmlNode node)
boolean | isShowFrame() 返回是否显示多页标签的外框架。
void | setCurrentTab(java.lang.String currentTab) 设定当前的标签页.此处的参数可以是标签页的名字或索引值.
void | setShowFrame(boolean showFrame) 设定是否显示多页标签的外框架。
void | setTabPlacement(java.lang.String tabPlacement) 设定多页标签所在的位置.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Field Detail

TABPLACEMENT_TOP

public static final java.lang.String TABPLACEMENT_TOP
标签页按钮的位置 - 上部

See Also:
Constant Field Values

TABPLACEMENT_BOTTOM

public static final java.lang.String TABPLACEMENT_BOTTOM
标签页按钮的位置 - 下部

See Also:
Constant Field Values
Constructor Detail

TabSet

public TabSet(ViewModel viewModel,
              java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

addTab

public TabElement addTab(java.lang.String name)
Deprecated.

根据指定名称添加一个多页标签对象。

Parameters:
name - String
Returns:
TabElement

addTab

public TabElement addTab(java.lang.String name,
                         java.lang.String label)
Deprecated.

根据指定名称、标题添加一个多页标签对象。

Parameters:
name - String
label - String
Returns:
TabElement

addTab

public void addTab(TabElement tab)
添加一个指定标签项

Parameters:
tab - Tab

getTabCount

public int getTabCount()
取得标签项的总数

Returns:
int

getTab

public TabElement getTab(int index)
取得一个指定索引位置的标签项对象。

Parameters:
index - int
Returns:
TabElement

getTab

public TabElement getTab(java.lang.String name)
取得一个指定名称的标签项对象。

Parameters:
name - String
Returns:
TabElement

getTabs

public ObjectCollection getTabs()
取得所有多页标签的集合对象。

Returns:
ObjectCollection

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Throws:
java.lang.Exception

getCurrentTab

public java.lang.String getCurrentTab()
取得当前标签页的设置.

Returns:
String

setCurrentTab

public void setCurrentTab(java.lang.String currentTab)
设定当前的标签页.此处的参数可以是标签页的名字或索引值.

Parameters:
currentTab - String

getTabPlacement

public java.lang.String getTabPlacement()
取得多页标签所在的位置.

Returns:
String

setTabPlacement

public void setTabPlacement(java.lang.String tabPlacement)
设定多页标签所在的位置. 取值范围: "top", "buttom"

Parameters:
tabPlacement - String

isShowFrame

public boolean isShowFrame()
返回是否显示多页标签的外框架。

Returns:
boolean

setShowFrame

public void setShowFrame(boolean showFrame)
设定是否显示多页标签的外框架。

Parameters:
showFrame - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BandingTreeLevel

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class BandingTreeLevel

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeLevel
        extended by com.bstek.dorado.view.control.tree.BandingTreeLevel
Direct Known Subclasses:
RecursiveTreeLevel, SimpleTreeLevel
public abstract class BandingTreeLevel
extends TreeLevel

支持数据绑定的树状列表节点层的基类

Version:
4.0

Constructor Summary
BandingTreeLevel(java.lang.String name)
构造器
Method Summary
java.lang.String | getCheckedField() 取得用于获取节点的复选状态的字段名
java.lang.String | getDataset() 取得绑定的数据集
java.lang.String | getExpandedIcon() 取得节点展开图标的URL
java.lang.String | getExpandedIconField() 取得用于获取节点展开图标的URL的字段名
java.lang.String | getIcon() 取得节点图标的URL
java.lang.String | getIconField() 取得用于获取节点图标的URL的字段名
java.lang.String | getLabelField() 取得用于获取节点标题的字段名
java.lang.String | getPathField() 取得用于获取节点对应的URL的字段名
boolean | isAutoSyncRecordWithDragging() 在节点拖放后是否自动对相应的记录进行数据同步.
boolean | isCheckable() 返回该层节点是否是可复选的
void | setAutoSyncRecordWithDragging(boolean autoSyncRecordWithDragging) 设置在节点拖放后是否自动对相应的记录进行数据同步.
void | setCheckable(boolean checkable) 设定该层节点是否是可复选的
void | setCheckedField(java.lang.String checkedField) 设定用于获取节点的复选状态的字段名
void | setDataset(java.lang.String dataset) 设定绑定的数据集
void | setExpandedIcon(java.lang.String expandedIcon) 设定节点展开图标的URL
void | setExpandedIconField(java.lang.String expandedIconField) 设定用于获取节点展开图标的URL的字段名
void | setIcon(java.lang.String icon) 设定节点图标的URL
void | setIconField(java.lang.String iconField) 设定用于获取节点图标的URL的字段名
void | setLabelField(java.lang.String labelField) 设定用于获取节点标题的字段名
void | setPathField(java.lang.String pathField) 设定用于获取节点对应的URL的字段名
Methods inherited from class com.bstek.dorado.view.control.tree.TreeLevel
addTreeLevel, getName, getTreeLevel, getTreeLevels
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BandingTreeLevel

public BandingTreeLevel(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getDataset

public java.lang.String getDataset()
取得绑定的数据集

Returns:
Dataset

setDataset

public void setDataset(java.lang.String dataset)
设定绑定的数据集

Parameters:
dataset - String

getLabelField

public java.lang.String getLabelField()
取得用于获取节点标题的字段名

Returns:
String

setLabelField

public void setLabelField(java.lang.String labelField)
设定用于获取节点标题的字段名

Parameters:
labelField - String

getIcon

public java.lang.String getIcon()
取得节点图标的URL

Returns:
String

setIcon

public void setIcon(java.lang.String icon)
设定节点图标的URL

Parameters:
icon - String

getIconField

public java.lang.String getIconField()
取得用于获取节点图标的URL的字段名

Returns:
String

setIconField

public void setIconField(java.lang.String iconField)
设定用于获取节点图标的URL的字段名

Parameters:
iconField - String

getExpandedIcon

public java.lang.String getExpandedIcon()
取得节点展开图标的URL

Returns:
String

setExpandedIcon

public void setExpandedIcon(java.lang.String expandedIcon)
设定节点展开图标的URL

Parameters:
expandedIcon - String

getExpandedIconField

public java.lang.String getExpandedIconField()
取得用于获取节点展开图标的URL的字段名

Returns:
String

setExpandedIconField

public void setExpandedIconField(java.lang.String expandedIconField)
设定用于获取节点展开图标的URL的字段名

Parameters:
expandedIconField - String

isCheckable

public boolean isCheckable()
返回该层节点是否是可复选的

Returns:
boolean

setCheckable

public void setCheckable(boolean checkable)
设定该层节点是否是可复选的

Parameters:
checkable - boolean

getPathField

public java.lang.String getPathField()
取得用于获取节点对应的URL的字段名

Returns:
String

setPathField

public void setPathField(java.lang.String pathField)
设定用于获取节点对应的URL的字段名

Parameters:
pathField - String

getCheckedField

public java.lang.String getCheckedField()
取得用于获取节点的复选状态的字段名

Returns:
String

setCheckedField

public void setCheckedField(java.lang.String checkedField)
设定用于获取节点的复选状态的字段名

Parameters:
checkedField - String

isAutoSyncRecordWithDragging

public boolean isAutoSyncRecordWithDragging()
在节点拖放后是否自动对相应的记录进行数据同步. 即调整数据使其能够正确的反映节点结构的变化.

Returns:
boolean

setAutoSyncRecordWithDragging

public void setAutoSyncRecordWithDragging(boolean autoSyncRecordWithDragging)
设置在节点拖放后是否自动对相应的记录进行数据同步. 即调整数据使其能够正确的反映节点结构的变化.

Parameters:
autoSyncRecordWithDragging - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BindingTreeLevel

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class BindingTreeLevel

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeLevel
        extended by com.bstek.dorado.view.control.tree.BindingTreeLevel
Direct Known Subclasses:
RecursiveTreeLevel, SimpleTreeLevel
public abstract class BindingTreeLevel
extends TreeLevel

支持数据绑定的树状列表节点层的基类

Version:
4.0

Constructor Summary
BindingTreeLevel(java.lang.String name)
构造器
Method Summary
java.lang.String | getCheckedField() 取得用于获取节点的复选状态的字段名
java.lang.String | getDataset() 取得绑定的数据集
java.lang.String | getExpandedIcon() 取得节点展开图标的URL
java.lang.String | getExpandedIconField() 取得用于获取节点展开图标的URL的字段名
java.lang.String | getIcon() 取得节点图标的URL
java.lang.String | getIconField() 取得用于获取节点图标的URL的字段名
java.lang.String | getLabelField() 取得用于获取节点标题的字段名
java.lang.String | getPathField() 取得用于获取节点对应的URL的字段名
boolean | isAutoSyncRecordWithDragging() 在节点拖放后是否自动对相应的记录进行数据同步.
boolean | isCheckable() 返回该层节点是否是可复选的
void | setAutoSyncRecordWithDragging(boolean autoSyncRecordWithDragging) 设置在节点拖放后是否自动对相应的记录进行数据同步.
void | setCheckable(boolean checkable) 设定该层节点是否是可复选的
void | setCheckedField(java.lang.String checkedField) 设定用于获取节点的复选状态的字段名
void | setDataset(java.lang.String dataset) 设定绑定的数据集
void | setExpandedIcon(java.lang.String expandedIcon) 设定节点展开图标的URL
void | setExpandedIconField(java.lang.String expandedIconField) 设定用于获取节点展开图标的URL的字段名
void | setIcon(java.lang.String icon) 设定节点图标的URL
void | setIconField(java.lang.String iconField) 设定用于获取节点图标的URL的字段名
void | setLabelField(java.lang.String labelField) 设定用于获取节点标题的字段名
void | setPathField(java.lang.String pathField) 设定用于获取节点对应的URL的字段名
Methods inherited from class com.bstek.dorado.view.control.tree.TreeLevel
addTreeLevel, getName, getTreeLevel, getTreeLevels
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BindingTreeLevel

public BindingTreeLevel(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getDataset

public java.lang.String getDataset()
取得绑定的数据集

Returns:
Dataset

setDataset

public void setDataset(java.lang.String dataset)
设定绑定的数据集

Parameters:
dataset - String

getLabelField

public java.lang.String getLabelField()
取得用于获取节点标题的字段名

Returns:
String

setLabelField

public void setLabelField(java.lang.String labelField)
设定用于获取节点标题的字段名

Parameters:
labelField - String

getIcon

public java.lang.String getIcon()
取得节点图标的URL

Returns:
String

setIcon

public void setIcon(java.lang.String icon)
设定节点图标的URL

Parameters:
icon - String

getIconField

public java.lang.String getIconField()
取得用于获取节点图标的URL的字段名

Returns:
String

setIconField

public void setIconField(java.lang.String iconField)
设定用于获取节点图标的URL的字段名

Parameters:
iconField - String

getExpandedIcon

public java.lang.String getExpandedIcon()
取得节点展开图标的URL

Returns:
String

setExpandedIcon

public void setExpandedIcon(java.lang.String expandedIcon)
设定节点展开图标的URL

Parameters:
expandedIcon - String

getExpandedIconField

public java.lang.String getExpandedIconField()
取得用于获取节点展开图标的URL的字段名

Returns:
String

setExpandedIconField

public void setExpandedIconField(java.lang.String expandedIconField)
设定用于获取节点展开图标的URL的字段名

Parameters:
expandedIconField - String

isCheckable

public boolean isCheckable()
返回该层节点是否是可复选的

Returns:
boolean

setCheckable

public void setCheckable(boolean checkable)
设定该层节点是否是可复选的

Parameters:
checkable - boolean

getPathField

public java.lang.String getPathField()
取得用于获取节点对应的URL的字段名

Returns:
String

setPathField

public void setPathField(java.lang.String pathField)
设定用于获取节点对应的URL的字段名

Parameters:
pathField - String

getCheckedField

public java.lang.String getCheckedField()
取得用于获取节点的复选状态的字段名

Returns:
String

setCheckedField

public void setCheckedField(java.lang.String checkedField)
设定用于获取节点的复选状态的字段名

Parameters:
checkedField - String

isAutoSyncRecordWithDragging

public boolean isAutoSyncRecordWithDragging()
在节点拖放后是否自动对相应的记录进行数据同步. 即调整数据使其能够正确的反映节点结构的变化.

Returns:
boolean

setAutoSyncRecordWithDragging

public void setAutoSyncRecordWithDragging(boolean autoSyncRecordWithDragging)
设置在节点拖放后是否自动对相应的记录进行数据同步. 即调整数据使其能够正确的反映节点结构的变化.

Parameters:
autoSyncRecordWithDragging - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DataTree

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class DataTree

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.tree.Tree
                extended by com.bstek.dorado.view.control.tree.DataTree
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
public class DataTree
extends Tree

树状列表对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
DataTree(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
void | addTreeLevel(TreeLevel level) 添加一个节点层
protected TreeLevel | createTreeLevel(XmlNode node, DoradoContext context) 根据XML节点创建节点层
TreeLevel | getRootLevel() 取得树的顶节点层对象.
TreeLevel | getTreeLevel(java.lang.String name) 根据名称取得一个节点层
ObjectCollection | getTreeLevels() 返回所有节点层的集合
void | init(DoradoContext context, XmlNode node)
protected void | loadChildLevels(TreeLevel level, XmlNode node, DoradoContext context) 加载子节点层
void | loadNodes() 加载根节点以下的子节点。
protected void | loadNodes(TreeNode node, TreeLevel level)
Methods inherited from class com.bstek.dorado.view.control.tree.Tree
getRoot, getTarget, isDraggable, isHighlightSelection, loadNodes, setDraggable, setHighlightSelection, setTarget
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

DataTree

public DataTree(ViewModel viewModel,
                java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

addTreeLevel

public void addTreeLevel(TreeLevel level)
添加一个节点层

Parameters:
level - TreeLevel

getTreeLevel

public TreeLevel getTreeLevel(java.lang.String name)
根据名称取得一个节点层

Parameters:
name - String
Returns:
TreeLevel

getTreeLevels

public ObjectCollection getTreeLevels()
返回所有节点层的集合

Returns:
ObjectCollection

getRootLevel

public TreeLevel getRootLevel()
取得树的顶节点层对象. 该是一个节点层是不可见的, 节点层的子节点层才对应在树中显示的根节点.

Returns:
TreeLevel

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Overrides:
init in class Tree
Throws:
java.lang.Exception

loadChildLevels

protected void loadChildLevels(TreeLevel level,
                               XmlNode node,
                               DoradoContext context)
                        throws LoadXmlPropertyException
加载子节点层

Parameters:
level - TreeLevel
node - XmlNode
context - MenuItem
Throws:
LoadXmlPropertyException

createTreeLevel

protected TreeLevel createTreeLevel(XmlNode node,
                                    DoradoContext context)
                             throws LoadXmlPropertyException,
                                    java.lang.IllegalStateException
根据XML节点创建节点层

Parameters:
context - DoradoContext
node - XmlNode
Returns:
TreeLevel
Throws:
LoadXmlPropertyException
java.lang.IllegalStateException

loadNodes

public void loadNodes()
               throws java.lang.Exception
加载根节点以下的子节点。

Throws:
java.lang.Exception

loadNodes

protected void loadNodes(TreeNode node,
                         TreeLevel level)
                  throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultTreeNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class DefaultTreeNode

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeNode
        extended by com.bstek.dorado.view.control.tree.DefaultTreeNode
All Implemented Interfaces:
Element
public class DefaultTreeNode
extends TreeNode

默认的树节点对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.tree.TreeNode
_children
Constructor Summary
DefaultTreeNode()
构造器
DefaultTreeNode(java.lang.String label)
构造器
Method Summary
java.lang.String | getExpandedIcon() 取得当前树节点的展开图标的URL
java.lang.String | getIcon() 取得当前树节点的图标的URL
java.lang.String | getLabel() 取得当前树节点的标题
int | getLevel() 取得当前树节点的层数 树的根节点的level为1,其下一级子节点的level为2,依此类推.
java.lang.String | getPath() 取得选中该节点时要自动激活到的URL
boolean | isCheckable() 返回树节点前面是否有复选框可以被选择
boolean | isChecked() 返回当前树节点是否已经被选中
boolean | isExpanded() 返回当在页面打开时该节点是否已被自动展开
void | setCheckable(boolean checkable) 设定树节点前面是否有复选框可以被选择
void | setChecked(boolean checked) 设定当前树节点是否已经被选中
void | setExpanded(boolean expanded) 设置当在页面打开时该节点是否已被自动展开
void | setExpandedIcon(java.lang.String expandedIcon) 设定当前树节点的展开图标的URL
void | setIcon(java.lang.String icon) 设定当前树节点的图标的URL
void | setLabel(java.lang.String label) 设定当前树节点的标题
void | setPath(java.lang.String path) 设定选中该节点时要自动激活到的URL
Methods inherited from class com.bstek.dorado.view.control.tree.TreeNode
addNode, addNode, children, getTag, isHasChild, setHasChild, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultTreeNode

public DefaultTreeNode()
构造器

DefaultTreeNode

public DefaultTreeNode(java.lang.String label)
构造器

Parameters:
label - String
Method Detail

getLabel

public java.lang.String getLabel()
取得当前树节点的标题

Returns:
String

setLabel

public void setLabel(java.lang.String label)
设定当前树节点的标题

Parameters:
label - String

getLevel

public int getLevel()
取得当前树节点的层数 树的根节点的level为1,其下一级子节点的level为2,依此类推.
对于树的topNode(指顶层节点,即所有根节点的父节点)而言,其level为0.

Returns:
int

getIcon

public java.lang.String getIcon()
取得当前树节点的图标的URL

Returns:
String

setIcon

public void setIcon(java.lang.String icon)
设定当前树节点的图标的URL

Parameters:
icon - String

getExpandedIcon

public java.lang.String getExpandedIcon()
取得当前树节点的展开图标的URL

Returns:
String

setExpandedIcon

public void setExpandedIcon(java.lang.String expandedIcon)
设定当前树节点的展开图标的URL

Parameters:
expandedIcon - String

isCheckable

public boolean isCheckable()
返回树节点前面是否有复选框可以被选择

Returns:
boolean

setCheckable

public void setCheckable(boolean checkable)
设定树节点前面是否有复选框可以被选择

Parameters:
checkable - boolean

isChecked

public boolean isChecked()
返回当前树节点是否已经被选中

Returns:
boolean

setChecked

public void setChecked(boolean checked)
设定当前树节点是否已经被选中

Parameters:
checked - boolean

getPath

public java.lang.String getPath()
取得选中该节点时要自动激活到的URL

Returns:
String

setPath

public void setPath(java.lang.String path)
设定选中该节点时要自动激活到的URL

Parameters:
path - String

isExpanded

public boolean isExpanded()
返回当在页面打开时该节点是否已被自动展开

Returns:
boolean

setExpanded

public void setExpanded(boolean expanded)
设置当在页面打开时该节点是否已被自动展开

Parameters:
expanded - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.control.tree

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.control.tree

树状列表控件的相关对象

See:
Description

Class Summary
BindingTreeLevel | 支持数据绑定的树状列表节点层的基类
DataTree | 树状列表对象
DefaultTreeNode | 默认的树节点对象
RecordTreeNode | 跟记录绑定的树节点.
RecursiveTreeLevel | 数据树中的递归层的描述对象.
SimpleTreeLevel | 数据树中的简单层的描述对象.
Tree | 树状列表对象
TreeLevel | 树状列表节点层的基类
TreeNode | 树节点对象的基类

Package com.bstek.dorado.view.control.tree Description

树状列表控件的相关对象


RecordTreeNode

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class RecordTreeNode

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeNode
        extended by com.bstek.dorado.view.control.tree.RecordTreeNode
All Implemented Interfaces:
Element
public class RecordTreeNode
extends TreeNode

跟记录绑定的树节点.

一般而言对于数据树中通过数据绑定自动生成的节点都是RecordTreeNode. 我们可以很方便的通过其getRecord()方法得到相应的记录对象.

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.tree.TreeNode
_children
Constructor Summary
RecordTreeNode()
构造器.
RecordTreeNode(Record record, TreeLevel level)
构造器.
Method Summary
TreeLevel | getLevel() 返回树节点相关的节点层对象.
Record | getRecord() 返回树节点绑定的记录对象.
void | setLevel(TreeLevel level) 设置树节点相关的节点层对象.
void | setRecord(Record record) 设置树节点所绑定的记录对象.
Methods inherited from class com.bstek.dorado.view.control.tree.TreeNode
addNode, addNode, children, getTag, isHasChild, setHasChild, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecordTreeNode

public RecordTreeNode()
构造器.

RecordTreeNode

public RecordTreeNode(Record record,
                      TreeLevel level)
构造器.

Parameters:
record - Record
level - TreeLevel
Method Detail

getRecord

public Record getRecord()
返回树节点绑定的记录对象.

Returns:
Record

setRecord

public void setRecord(Record record)
设置树节点所绑定的记录对象.

Parameters:
record - Record

getLevel

public TreeLevel getLevel()
返回树节点相关的节点层对象.

Returns:
TreeLevel

setLevel

public void setLevel(TreeLevel level)
设置树节点相关的节点层对象.

Parameters:
level - TreeLevel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RecursiveTreeLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class RecursiveTreeLevel

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeLevel
        extended by com.bstek.dorado.view.control.tree.BindingTreeLevel
            extended by com.bstek.dorado.view.control.tree.RecursiveTreeLevel
public class RecursiveTreeLevel
extends BindingTreeLevel

数据树中的递归层的描述对象.

一般用于描述那些所有节点数据都存在同张数据库表中,相互间通过一个外键自关联形成的树状结构.

recursiveKeyFields属性表示将要从父节点的哪些字段中取值; recursiveKeyParameters属性表示将要执行子节点查询时所需要的参数名称. 在运行时,系统将自动按照recursiveKeyFields的设置取出的关键值, 然后通过recursiveKeyParameters把这些值设置到数据集的参数当中, 最后利用数据集得到子节点的数据并生成新的树节点.

例如:
Dataset包含字段id, parent_id.并且已设定了一个查询参数parent_id.
此时我们可以设置RecursiveTreeLevel的属性如下:
recursiveKeyFields设置为id; recursiveKeyParameters设置为parent_id.

Version:
4.0

Constructor Summary
RecursiveTreeLevel(java.lang.String name)
构造器
Method Summary
java.lang.String[] | detailKeyParameters() 以数组的形式detailKeyParameters的值
java.lang.String | getDetailKeyParameters() 返回本节点层的顶层节点对应的数据集与父节点层相关联的参数名.
int | getExpandLevel() 返回树默认展开到的层数
java.lang.String | getMasterKeyFields() 返回父节点层对应的数据集中跟本节点层的顶层节点相关联的字段名.
java.lang.String | getRecursiveKeyFields() 返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
java.lang.String | getRecursiveKeyParameters() 返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
java.lang.String[] | masterKeyFields() 以数组的形式masterKeyFields的值
java.lang.String[] | recursiveKeyFields() 以数组的形式recursiveKeyFields的值
java.lang.String[] | recursiveKeyParameters() 以数组的形式recursiveKeyParameters的值
void | setDetailKeyParameters(java.lang.String detailKeyParameters) 设置本节点层的顶层节点对应的数据集与父节点层相关联的参数名.
void | setExpandLevel(int expandLevel) 设置树默认展开到的层数
void | setMasterKeyFields(java.lang.String masterKeyFields) 设置父节点层对应的数据集中跟本节点层的顶层节点相关联的字段名.
void | setRecursiveKeyFields(java.lang.String recursiveKeyFields) 返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
void | setRecursiveKeyParameters(java.lang.String recursiveKeyParameters) 返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
Methods inherited from class com.bstek.dorado.view.control.tree.BindingTreeLevel
getCheckedField, getDataset, getExpandedIcon, getExpandedIconField, getIcon, getIconField, getLabelField, getPathField, isAutoSyncRecordWithDragging, isCheckable, setAutoSyncRecordWithDragging, setCheckable, setCheckedField, setDataset, setExpandedIcon, setExpandedIconField, setIcon, setIconField, setLabelField, setPathField
Methods inherited from class com.bstek.dorado.view.control.tree.TreeLevel
addTreeLevel, getName, getTreeLevel, getTreeLevels
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RecursiveTreeLevel

public RecursiveTreeLevel(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getMasterKeyFields

public java.lang.String getMasterKeyFields()
返回父节点层对应的数据集中跟本节点层的顶层节点相关联的字段名. 即进行顶层节点查询时要从父节点层对应的数据集中取出哪些字段的值作为查询参数.

Returns:
String

getDetailKeyParameters

public java.lang.String getDetailKeyParameters()
返回本节点层的顶层节点对应的数据集与父节点层相关联的参数名. 即进行顶层节点查询时要将从父节点层对应的数据集中取出值设置到哪些查询参数中.

Returns:
String

getRecursiveKeyFields

public java.lang.String getRecursiveKeyFields()
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.

Returns:
String

getRecursiveKeyParameters

public java.lang.String getRecursiveKeyParameters()
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.

Returns:
String

setMasterKeyFields

public void setMasterKeyFields(java.lang.String masterKeyFields)
设置父节点层对应的数据集中跟本节点层的顶层节点相关联的字段名. 即进行顶层节点查询时要从父节点层对应的数据集中取出哪些字段的值作为查询参数.
如果此处需要描述多个字段,可以利用","分隔各字段名.
本属性仅用于描述递归层中的顶层节点. 如果递归层本身就位于树的顶层或者顶层节点与父节点没有数据关联关系,那么本属性可被忽略.

Parameters:
masterKeyFields - String

setDetailKeyParameters

public void setDetailKeyParameters(java.lang.String detailKeyParameters)
设置本节点层的顶层节点对应的数据集与父节点层相关联的参数名. 即进行顶层节点查询时要将从父节点层对应的数据集中取出值设置到哪些查询参数中.
如果此处需要描述多个字段,可以利用","分隔各字段名.
本属性仅用于描述递归层中的顶层节点. 如果递归层本身就位于树的顶层或者顶层节点与父节点没有数据关联关系,那么本属性可被忽略.

Parameters:
detailKeyParameters - String

setRecursiveKeyFields

public void setRecursiveKeyFields(java.lang.String recursiveKeyFields)
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数. 如果此处需要描述多个字段,可以利用","分隔各字段名.
本属性用于描述递归层中的除顶层节点之外的所有子节点.

Parameters:
recursiveKeyFields - String

setRecursiveKeyParameters

public void setRecursiveKeyParameters(java.lang.String recursiveKeyParameters)
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中. 如果此处需要描述多个字段,可以利用","分隔各字段名.
本属性用于描述递归层中的除顶层节点之外的所有子节点.

Parameters:
recursiveKeyParameters - String

detailKeyParameters

public java.lang.String[] detailKeyParameters()
以数组的形式detailKeyParameters的值

Returns:
String[]

masterKeyFields

public java.lang.String[] masterKeyFields()
以数组的形式masterKeyFields的值

Returns:
String[]

recursiveKeyFields

public java.lang.String[] recursiveKeyFields()
以数组的形式recursiveKeyFields的值

Returns:
String[]

recursiveKeyParameters

public java.lang.String[] recursiveKeyParameters()
以数组的形式recursiveKeyParameters的值

Returns:
String[]

getExpandLevel

public int getExpandLevel()
返回树默认展开到的层数

Returns:
int

setExpandLevel

public void setExpandLevel(int expandLevel)
设置树默认展开到的层数

Parameters:
expandLevel - int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleTreeLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class SimpleTreeLevel

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeLevel
        extended by com.bstek.dorado.view.control.tree.BindingTreeLevel
            extended by com.bstek.dorado.view.control.tree.SimpleTreeLevel
public class SimpleTreeLevel
extends BindingTreeLevel

数据树中的简单层的描述对象.

SimpleTreeLevel用于描述单层节点.
如果将多个SimpleTreeLevel分别与已经建立了主从绑定关系的数据集进行关联, 那么数据树就可以自动的以树的形式来展现主从结构的数据.
如果SimpleTreeLevel与没有定义主从绑定关系的数据集进行关联,那么我们还需要设置 masterKeyFields和detailKeyParameters属性用以描述数据集直接的数据关系, 以便数据树能够以树的形式展现数据.

Version:
4.0

Constructor Summary
SimpleTreeLevel(java.lang.String name)
构造器
Method Summary
java.lang.String[] | detailKeyParameters() 以数组的形式detailKeyParameters的值
java.lang.String | getDetailKeyParameters() 返回本节点层对应的数据集与父节点层相关联的参数名.
java.lang.String | getMasterKeyFields() 返回父节点层对应的数据集中跟本节点层相关联的字段名.
boolean | isExpanded() 返回是否自动展开本层的节点
boolean | isHasChild() 返回节点是否有子节点,默认为true.
java.lang.String[] | masterKeyFields() 以数组的形式masterKeyFields的值
void | setDetailKeyParameters(java.lang.String detailKeyParameters) 设置本节点层对应的数据集与父节点层相关联的参数名.
void | setExpanded(boolean expanded) 设置是否自动展开本层的节点
void | setHasChild(boolean hasChild) 设定节点是否有子节点.
void | setMasterKeyFields(java.lang.String masterKeyFields) 设置父节点层对应的数据集中跟本节点层相关联的字段名.
Methods inherited from class com.bstek.dorado.view.control.tree.BindingTreeLevel
getCheckedField, getDataset, getExpandedIcon, getExpandedIconField, getIcon, getIconField, getLabelField, getPathField, isAutoSyncRecordWithDragging, isCheckable, setAutoSyncRecordWithDragging, setCheckable, setCheckedField, setDataset, setExpandedIcon, setExpandedIconField, setIcon, setIconField, setLabelField, setPathField
Methods inherited from class com.bstek.dorado.view.control.tree.TreeLevel
addTreeLevel, getName, getTreeLevel, getTreeLevels
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleTreeLevel

public SimpleTreeLevel(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

isHasChild

public boolean isHasChild()
返回节点是否有子节点,默认为true.

Returns:
boolean

setHasChild

public void setHasChild(boolean hasChild)
设定节点是否有子节点.

Parameters:
hasChild - boolean

isExpanded

public boolean isExpanded()
返回是否自动展开本层的节点

Returns:
boolean

setExpanded

public void setExpanded(boolean expanded)
设置是否自动展开本层的节点

Parameters:
expanded - boolean

getMasterKeyFields

public java.lang.String getMasterKeyFields()
返回父节点层对应的数据集中跟本节点层相关联的字段名. 即进行本层节点查询时要从父节点层对应的数据集中取出哪些字段的值作为查询参数.

Returns:
String

getDetailKeyParameters

public java.lang.String getDetailKeyParameters()
返回本节点层对应的数据集与父节点层相关联的参数名. 即进行本层节点查询时要将从父节点层对应的数据集中取出值设置到哪些查询参数中.

Returns:
String

setMasterKeyFields

public void setMasterKeyFields(java.lang.String masterKeyFields)
设置父节点层对应的数据集中跟本节点层相关联的字段名. 即进行本层节点查询时要从父节点层对应的数据集中取出哪些字段的值作为查询参数.
如果此处需要描述多个字段,可以利用","分隔各字段名.
注意: 如果绑定的数据集已经建立了主从绑定关系,那么此属性将被忽略.

Parameters:
masterKeyFields - String

setDetailKeyParameters

public void setDetailKeyParameters(java.lang.String detailKeyParameters)
设置本节点层对应的数据集与父节点层相关联的参数名. 即进行本层节点查询时要将从父节点层对应的数据集中取出值设置到哪些查询参数中.
如果此处需要描述多个字段,可以利用","分隔各字段名.
注意: 如果绑定的数据集已经建立了主从绑定关系,那么此属性将被忽略.

Parameters:
detailKeyParameters - String

masterKeyFields

public java.lang.String[] masterKeyFields()
以数组的形式masterKeyFields的值

Returns:
String[]

detailKeyParameters

public java.lang.String[] detailKeyParameters()
以数组的形式detailKeyParameters的值

Returns:
String[]
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Tree

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class Tree

java.lang.Object
    extended by com.bstek.dorado.view.control.AbstractControl
        extended by com.bstek.dorado.view.control.PlaceableControl
            extended by com.bstek.dorado.view.control.tree.Tree
All Implemented Interfaces:
Component, Control, Element, EventSupported, Placeable, Visible
Direct Known Subclasses:
DataTree
public class Tree
extends PlaceableControl
implements Visible

树状列表对象

Version:
4.0

Field Summary
Fields inherited from class com.bstek.dorado.view.control.AbstractControl
id, viewModel
Constructor Summary
Tree(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
TreeNode | getRoot() 取得树的顶节点对象.
java.lang.String | getTarget() 取得树状列表要刷新的目标框架.
void | init(DoradoContext context, XmlNode node)
boolean | isDraggable() 返回树状列表的节点是否允许拖动.
boolean | isHighlightSelection() 返回通过复选框选中记录后是否将记录进行高亮显示，默认为true.
protected void | loadNodes(DoradoContext context, XmlNode node, TreeNode treeNode) 加载树节点
void | setDraggable(boolean draggable) 设置树状列表的节点是否允许拖动.
void | setHighlightSelection(boolean highlightSelection) 设置通过复选框选中记录后是否将记录进行高亮显示.
void | setTarget(java.lang.String target) 设定树状列表要刷新的目标框架.
Methods inherited from class com.bstek.dorado.view.control.PlaceableControl
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth
Methods inherited from class com.bstek.dorado.view.control.AbstractControl
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getTag, getViewModel, isIgnored, removeEventHandler, setIgnored, setTag
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.control.Placeable
getHeight, getLeft, getStyle, getTop, getWidth, setHeight, setLeft, setStyle, setTop, setWidth

Constructor Detail

Tree

public Tree(ViewModel viewModel,
            java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception

Specified by:
init in interface Component
Throws:
java.lang.Exception

loadNodes

protected void loadNodes(DoradoContext context,
                         XmlNode node,
                         TreeNode treeNode)
                  throws LoadXmlPropertyException
加载树节点

Parameters:
context - DoradoContext
node - XmlNode
treeNode - TreeNode
Throws:
LoadXmlPropertyException

getRoot

public TreeNode getRoot()
取得树的顶节点对象. 该是一个节点不可见的节点, 顶节点的子节点才是在树中显示的根节点.

Returns:
TreeNode

getTarget

public java.lang.String getTarget()
取得树状列表要刷新的目标框架.

Returns:
String

setTarget

public void setTarget(java.lang.String target)
设定树状列表要刷新的目标框架.

Parameters:
target - String

isDraggable

public boolean isDraggable()
返回树状列表的节点是否允许拖动.

Returns:
boolean

setDraggable

public void setDraggable(boolean draggable)
设置树状列表的节点是否允许拖动.

Parameters:
draggable - boolean

isHighlightSelection

public boolean isHighlightSelection()
返回通过复选框选中记录后是否将记录进行高亮显示，默认为true.

Returns:
boolean

setHighlightSelection

public void setHighlightSelection(boolean highlightSelection)
设置通过复选框选中记录后是否将记录进行高亮显示.

Parameters:
highlightSelection - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeLevel

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class TreeLevel

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeLevel
Direct Known Subclasses:
BindingTreeLevel
public abstract class TreeLevel
extends java.lang.Object

树状列表节点层的基类

Version:
4.0

Constructor Summary
TreeLevel(java.lang.String name)
构造器
Method Summary
void | addTreeLevel(TreeLevel level) 添加一个子节点层
java.lang.String | getName() 取得节点层的名称
TreeLevel | getTreeLevel(java.lang.String name) 根据名称取得一个子节点层
ObjectCollection | getTreeLevels() 返回所有子节点层的集合
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TreeLevel

public TreeLevel(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

getName

public java.lang.String getName()
取得节点层的名称

Returns:
String

addTreeLevel

public void addTreeLevel(TreeLevel level)
添加一个子节点层

Parameters:
level - TreeLevel

getTreeLevel

public TreeLevel getTreeLevel(java.lang.String name)
根据名称取得一个子节点层

Parameters:
name - String
Returns:
TreeLevel

getTreeLevels

public ObjectCollection getTreeLevels()
返回所有子节点层的集合

Returns:
ObjectCollection
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeNode

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.control.tree
Class TreeNode

java.lang.Object
    extended by com.bstek.dorado.view.control.tree.TreeNode
All Implemented Interfaces:
Element
Direct Known Subclasses:
DefaultTreeNode, RecordTreeNode
public abstract class TreeNode
extends java.lang.Object
implements Element

树节点对象的基类

Version:
4.0

Field Summary
protected  java.util.Vector _children
Constructor Summary
TreeNode()
构造器
Method Summary
TreeNode | addNode() Deprecated.
void | addNode(TreeNode node) 添加一个指定的节点,作为当前树节点的子节点。
java.util.List | children() 返回当前树节点的所有子节点的集合对象。
java.lang.String | getTag() 取得元素的用户自定义信息。
boolean | isHasChild() 返回当前树节点是否有子节点。
void | setHasChild(boolean hasChild) 设定当前树节点是否有子节点。
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_children

protected java.util.Vector _children
Constructor Detail

TreeNode

public TreeNode()
构造器

Method Detail

addNode

public TreeNode addNode()
Deprecated.

添加树节点

Returns:
TreeNode

addNode

public void addNode(TreeNode node)
添加一个指定的节点,作为当前树节点的子节点。

Parameters:
node - TreeNode

children

public java.util.List children()
返回当前树节点的所有子节点的集合对象。

Returns:
List

isHasChild

public boolean isHasChild()
返回当前树节点是否有子节点。

Returns:
boolean

setHasChild

public void setHasChild(boolean hasChild)
设定当前树节点是否有子节点。

Parameters:
hasChild - boolean

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CustomDataset

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class CustomDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.AbstractViewDataset
                    extended by com.bstek.dorado.view.data.CustomDataset
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
public class CustomDataset
extends com.bstek.dorado.view.data.AbstractViewDataset

用户自定义视图数据集对象

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
CustomDataset(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
protected void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
java.lang.String | getType() 取得视图数据集的类型。
Methods inherited from class com.bstek.dorado.view.data.AbstractViewDataset
doUpdate, internalLoad, updateDetailDatasets
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, createFieldByNode, doFromDO, doFromSingleDO, eventHandlers, fireAfterScroll, fromDO, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getRecordFactory, getTag, getValidatorFactory, getViewModel, init, initNewRecord, initValidator, isAsync, isAutoLoadData, isAutoLoadPage, isIgnored, isInsertOnEmpty, isNoClient, isReadOnly, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setAutoLoadPage, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setReadOnly, setRecordSet, setShowLoadingTip, setTag, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

CustomDataset

public CustomDataset(ViewModel viewModel,
                     java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

doLoad

protected void doLoad(boolean createFields,
                      boolean loadData)
               throws java.lang.Exception
根据已设定的条件读取外部数据.

Specified by:
doLoad in class DatasetSupport
Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据
Throws:
java.lang.Exception

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DatasetReference

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class DatasetReference

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.AbstractViewDataset
                    extended by com.bstek.dorado.view.data.AbstractDatasetReference
                        extended by com.bstek.dorado.view.data.DatasetReference
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
Direct Known Subclasses:
DynamicDropDownDataset
public class DatasetReference
extends com.bstek.dorado.view.data.AbstractDatasetReference

数据集引用对象

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DatasetReference(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
protected Dataset | doGetSourceDatasetForLoad(boolean createFields, boolean loadData)
protected Dataset | doGetSourceDatasetForUpdate()
java.lang.String | getSourceDataset() 取得引用的源数据集
java.lang.String | getSourceModule() 返回引用的源数据集模块。
java.lang.String | getType() 取得视图数据集的类型。
void | setSourceDataset(java.lang.String sourceDataset) 设定引用的源数据集
void | setSourceModule(java.lang.String sourceModule) 设定从哪个源数据集模块中取得数据。
Methods inherited from class com.bstek.dorado.view.data.AbstractDatasetReference
doLoad, doUpdate, getRecordFactory, updateDetailKeys, updateRecord, updateSourceDataset
Methods inherited from class com.bstek.dorado.view.data.AbstractViewDataset
internalLoad, updateDetailDatasets
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, createFieldByNode, doFromDO, doFromSingleDO, eventHandlers, fireAfterScroll, fromDO, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getTag, getValidatorFactory, getViewModel, init, initNewRecord, initValidator, isAsync, isAutoLoadData, isAutoLoadPage, isIgnored, isInsertOnEmpty, isNoClient, isReadOnly, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setAutoLoadPage, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setReadOnly, setRecordSet, setShowLoadingTip, setTag, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

DatasetReference

public DatasetReference(ViewModel viewModel,
                        java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String

doGetSourceDatasetForLoad

protected Dataset doGetSourceDatasetForLoad(boolean createFields,
                                            boolean loadData)
                                     throws java.lang.Exception

Throws:
java.lang.Exception

doGetSourceDatasetForUpdate

protected Dataset doGetSourceDatasetForUpdate()
                                       throws java.lang.Exception

Throws:
java.lang.Exception

getSourceModule

public java.lang.String getSourceModule()
返回引用的源数据集模块。

Returns:
String

setSourceModule

public void setSourceModule(java.lang.String sourceModule)
设定从哪个源数据集模块中取得数据。

Parameters:
sourceModule - String

getSourceDataset

public java.lang.String getSourceDataset()
取得引用的源数据集

Returns:
String

setSourceDataset

public void setSourceDataset(java.lang.String sourceDataset)
设定引用的源数据集

Parameters:
sourceDataset - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatasetWrapper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class DatasetWrapper

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.AbstractViewDataset
                    extended by com.bstek.dorado.view.data.AbstractDatasetReference
                        extended by com.bstek.dorado.view.data.DatasetWrapper
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
public class DatasetWrapper
extends com.bstek.dorado.view.data.AbstractDatasetReference

数据集包装器.

dorado通过数据集包装器将那些不是继承自ViewDataset的数据集引入到ViewModel使用.

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DatasetWrapper(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
protected Field | createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
protected Dataset | doGetSourceDatasetForLoad(boolean createFields, boolean loadData)
protected Dataset | doGetSourceDatasetForUpdate()
java.lang.String | getType() 取得视图数据集的类型。
Dataset | getWrappedDataset() 取得被包装的源Dataset
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected void | initListener(XmlNode node) 根据XML节点初试化监听器
protected void | initLookupFields(Dataset dataset) 初试化某个Dataset中的Lookup字段
void | processLookup() 处理所有的Lookup数据。
Methods inherited from class com.bstek.dorado.view.data.AbstractDatasetReference
doLoad, doUpdate, getRecordFactory, updateDetailKeys, updateRecord, updateSourceDataset
Methods inherited from class com.bstek.dorado.view.data.AbstractViewDataset
internalLoad, updateDetailDatasets
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, doFromDO, doFromSingleDO, eventHandlers, fireAfterScroll, fromDO, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getTag, getValidatorFactory, getViewModel, initNewRecord, initValidator, isAsync, isAutoLoadData, isAutoLoadPage, isIgnored, isInsertOnEmpty, isNoClient, isReadOnly, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setAutoLoadPage, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setReadOnly, setRecordSet, setShowLoadingTip, setTag, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

DatasetWrapper

public DatasetWrapper(ViewModel viewModel,
                      java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String

initListener

protected void initListener(XmlNode node)
根据XML节点初试化监听器

Overrides:
initListener in class DatasetSupport
Parameters:
node - XmlNode

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Overrides:
init in class ViewDatasetSupport
Throws:
java.lang.Exception

initLookupFields

protected void initLookupFields(Dataset dataset)
初试化某个Dataset中的Lookup字段

Parameters:
dataset - Dataset

createFieldByNode

protected Field createFieldByNode(DoradoContext context,
                                  XmlNode node)
                           throws LoadXmlPropertyException
根据一个描述字段的XML节点自动创建字段对象.

Overrides:
createFieldByNode in class ViewDatasetSupport
Throws:
LoadXmlPropertyException

getWrappedDataset

public Dataset getWrappedDataset()
                          throws java.lang.Exception
取得被包装的源Dataset

Returns:
Dataset
Throws:
java.lang.Exception

processLookup

public void processLookup()
Description copied from interface: Dataset
处理所有的Lookup数据。

Specified by:
processLookup in interface Dataset
Overrides:
processLookup in class DatasetSupport

doGetSourceDatasetForLoad

protected Dataset doGetSourceDatasetForLoad(boolean createFields,
                                            boolean loadData)
                                     throws java.lang.Exception

Throws:
java.lang.Exception

doGetSourceDatasetForUpdate

protected Dataset doGetSourceDatasetForUpdate()
                                       throws java.lang.Exception

Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DODataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class DODataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.AbstractViewDataset
                    extended by com.bstek.dorado.view.data.DODataset
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
public class DODataset
extends com.bstek.dorado.view.data.AbstractViewDataset

可与DO(Data Object)进行数据交换的Dataset

注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
DODataset(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
protected int | doFromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
protected void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
void | doUpdate()
int | fromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中. 此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.
java.lang.String | getContextAttribute() 取得与DODataset进行数据交换的上下文属性名.
java.lang.String | getType() 取得视图数据集的类型。
boolean | isSupportsPaging() 返回是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.
void | setContextAttribute(java.lang.String contextAttribute) 设置与DODataset进行数据交换的上下文属性名.
void | setSupportsPaging(boolean supportsPaging) 设置是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.
Methods inherited from class com.bstek.dorado.view.data.AbstractViewDataset
internalLoad, updateDetailDatasets
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, createFieldByNode, doFromSingleDO, eventHandlers, fireAfterScroll, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getRecordFactory, getTag, getValidatorFactory, getViewModel, init, initNewRecord, initValidator, isAsync, isAutoLoadData, isAutoLoadPage, isIgnored, isInsertOnEmpty, isNoClient, isReadOnly, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setAutoLoadPage, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setReadOnly, setRecordSet, setShowLoadingTip, setTag, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

DODataset

public DODataset(ViewModel viewModel,
                 java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String

fromDO

public int fromDO(java.lang.Object data)
           throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

Specified by:
fromDO in interface Dataset
Overrides:
fromDO in class ViewDatasetSupport
Throws:
java.lang.Exception

doFromDO

protected int doFromDO(java.lang.Object data)
                throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

Overrides:
doFromDO in class ViewDatasetSupport
Throws:
java.lang.Exception

doLoad

protected void doLoad(boolean createFields,
                      boolean loadData)
               throws java.lang.Exception
根据已设定的条件读取外部数据.

Specified by:
doLoad in class DatasetSupport
Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据
Throws:
java.lang.Exception

doUpdate

public void doUpdate()
              throws java.lang.Exception

Throws:
java.lang.Exception

getContextAttribute

public java.lang.String getContextAttribute()
取得与DODataset进行数据交换的上下文属性名.

Returns:
String

setContextAttribute

public void setContextAttribute(java.lang.String contextAttribute)
设置与DODataset进行数据交换的上下文属性名.

当我们设定了此属性之后DODataset会在执行装载数据时自动到上下文对象的该属性中寻找DO类型的数据, 如果找到了相应的数据将自动尝试将其装载到DODataset中; 在执行数据更新时DODataset会自动尝试将数据更新到上下文中存贮的数据对象上.

Parameters:
contextAttribute - String

isSupportsPaging

public boolean isSupportsPaging()
返回是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.

Returns:
boolean

setSupportsPaging

public void setSupportsPaging(boolean supportsPaging)
设置是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.

Parameters:
supportsPaging - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormDataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class FormDataset

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.AbstractViewDataset
                    extended by com.bstek.dorado.view.data.FormDataset
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
public class FormDataset
extends com.bstek.dorado.view.data.AbstractViewDataset

表单型数据集

表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
FormDataset(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
protected void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
java.lang.String | getType() 取得视图数据集的类型。
Methods inherited from class com.bstek.dorado.view.data.AbstractViewDataset
doUpdate, internalLoad, updateDetailDatasets
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, createFieldByNode, doFromDO, doFromSingleDO, eventHandlers, fireAfterScroll, fromDO, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getRecordFactory, getTag, getValidatorFactory, getViewModel, init, initNewRecord, initValidator, isAsync, isAutoLoadData, isAutoLoadPage, isIgnored, isInsertOnEmpty, isNoClient, isReadOnly, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setAutoLoadPage, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setReadOnly, setRecordSet, setShowLoadingTip, setTag, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

FormDataset

public FormDataset(ViewModel viewModel,
                   java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String

doLoad

protected void doLoad(boolean createFields,
                      boolean loadData)
               throws java.lang.Exception
根据已设定的条件读取外部数据.

Specified by:
doLoad in class DatasetSupport
Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MasterDetailLink

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class MasterDetailLink

java.lang.Object
    extended by com.bstek.dorado.view.data.MasterDetailLink
public class MasterDetailLink
extends java.lang.Object

描述主从数据集连接关系的对象.

当我们为两个Datase已建立了主从绑定的关系后,从表总是会自动装载和显示与主表当前记录相对应的数据.

Version:
4.0

Constructor Summary
MasterDetailLink()
构造器
MasterDetailLink(ViewDataset masterDataset, java.lang.String masterKeyFields, java.lang.String detailParametersFields)
构造器
Method Summary
java.lang.String[] | detailKeyFields() 取得从数据集中与主数据集关联的字段数组.
java.lang.String[] | detailKeyParameters() 取得从数据集中与主数据集关联的参数数组.
ViewDataset | getDetailDataset() 取得从数据集
java.lang.String | getDetailKeyFields() 取得从数据集中与主数据集关联的字段.
java.lang.String | getDetailKeyParameters() 取得从数据集中与主数据集关联的参数.
java.lang.String | getDetailProperty() 取得主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
ViewDataset | getMasterDataset() 返回主数据集
java.lang.String | getMasterKeyFields() 取得主数据集中与从数据集关联的字段.
java.lang.String[] | masterKeyFields() 取得主数据集中与从数据集关联的字段数组.
void | setDetailDataset(ViewDataset detailDataset) 设定从数据集
void | setDetailKeyFields(java.lang.String detailKeyFields) 设定从数据集中与主数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
void | setDetailKeyParameters(java.lang.String detailKeyParameters) 设定从数据集中与主数据集关联的参数.如果此处需要描述多个参数,可以利用","分隔各参数名.
void | setDetailProperty(java.lang.String detailProperty) 设定主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
void | setMasterDataset(ViewDataset masterDataset) 设置主数据集
void | setMasterKeyFields(java.lang.String masterKeyFields) 设定主数据集中与从数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MasterDetailLink

public MasterDetailLink()
构造器

MasterDetailLink

public MasterDetailLink(ViewDataset masterDataset,
                        java.lang.String masterKeyFields,
                        java.lang.String detailParametersFields)
构造器

Parameters:
masterDataset - ViewDataset
masterKeyFields - String
detailParametersFields - String
Method Detail

getMasterDataset

public ViewDataset getMasterDataset()
返回主数据集

Returns:
ViewDataset

setMasterDataset

public void setMasterDataset(ViewDataset masterDataset)
设置主数据集

Parameters:
masterDataset - ViewDataset

getMasterKeyFields

public java.lang.String getMasterKeyFields()
取得主数据集中与从数据集关联的字段.

Returns:
String

setMasterKeyFields

public void setMasterKeyFields(java.lang.String masterKeyFields)
设定主数据集中与从数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.

Parameters:
masterKeyFields - String

getDetailDataset

public ViewDataset getDetailDataset()
取得从数据集

Returns:
ViewDataset

setDetailDataset

public void setDetailDataset(ViewDataset detailDataset)
设定从数据集

Parameters:
detailDataset - ViewDataset

getDetailProperty

public java.lang.String getDetailProperty()
取得主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.

Returns:
String

setDetailProperty

public void setDetailProperty(java.lang.String detailProperty)
设定主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
例如: Deptment对象中以employees属性表示部门中的所有员工, 此时我们可以将"employees"设定为MasterDetailLink的detailProperty.

Parameters:
detailProperty - String

getDetailKeyFields

public java.lang.String getDetailKeyFields()
取得从数据集中与主数据集关联的字段.

Returns:
String

setDetailKeyFields

public void setDetailKeyFields(java.lang.String detailKeyFields)
设定从数据集中与主数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
detailKeyFields不是必须设置的属性.

Parameters:
detailKeyFields - String

getDetailKeyParameters

public java.lang.String getDetailKeyParameters()
取得从数据集中与主数据集关联的参数.

Returns:
String

setDetailKeyParameters

public void setDetailKeyParameters(java.lang.String detailKeyParameters)
设定从数据集中与主数据集关联的参数.如果此处需要描述多个参数,可以利用","分隔各参数名.
一般来讲detailKeyParameters是必须设置的属性.从数据集将利用这些参数自动装载与主数据集相关的记录.

Parameters:
detailKeyParameters - String

masterKeyFields

public java.lang.String[] masterKeyFields()
取得主数据集中与从数据集关联的字段数组.

Returns:
String[]

detailKeyFields

public java.lang.String[] detailKeyFields()
取得从数据集中与主数据集关联的字段数组.

Returns:
String[]

detailKeyParameters

public java.lang.String[] detailKeyParameters()
取得从数据集中与主数据集关联的参数数组.

Returns:
String[]
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.data

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.data

视图数据集的相关类
See:
Description

Interface Summary
ViewDataset | 视图模型中数据集对象的基础类
ViewField | 视图模型中数据集字段对象

Class Summary
CustomDataset | 用户自定义视图数据集对象
DatasetReference | 数据集引用对象
DatasetWrapper | 数据集包装器.
DODataset | 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
FormDataset | 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
MasterDetailLink | 描述主从数据集连接关系的对象.
ViewBaseField | 视图模型中数据字段的基础类
ViewDatasetAdapter | 视图模型数据集适配器
ViewDatasetSupport | 视图数据集的抽象基类。
ViewLookupField | 视图模型中LookupField对象
ViewRecord | 视图模型中Dataset的记录对象

Package com.bstek.dorado.view.data Description

视图数据集的相关类


ViewBaseField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class ViewBaseField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.BaseField
            extended by com.bstek.dorado.view.data.ViewBaseField
All Implemented Interfaces:
Element, Field, ViewField
public class ViewBaseField
extends BaseField
implements ViewField

视图模型中数据字段的基础类

Version:
4.0

Constructor Summary
ViewBaseField(java.lang.String name)
构造器
Method Summary
 void addValidator(Validator validator)
为字段添加一个校验器。
 java.lang.String getDropDown()
取得字段关联的下拉框对象.
 java.lang.String getEditorType()
取得与该字段关联的编辑器的类型.
 java.lang.String getFormat()
取得字段数据的格式化串.
 java.lang.String getTag()
取得元素的用户自定义信息。
 java.lang.String getToolTip()
返回字段的弹出式提示信息.
 java.util.List getValidators()
取得字段相关的所有校验器对象得集合对象.
 boolean isReadOnly()
返回该字段是否只读.
 boolean isSupportsSum()
取得是否允许数据集自动在Client端统计该字段的合计值.
 boolean isValueProtected()
返回字段是否有数据保护功能
 boolean isVisible()
返回字段是否在页面上可见.
 void removeValidator(Validator validator)
删除一个字段的校验器.
 void setDropDown(java.lang.String dropDown)
设定字段关联的下拉框对象.
 void setEditorType(java.lang.String editorType)
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框
 void setFormat(java.lang.String format)
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.
 void setReadOnly(boolean readOnly)
设定该字段是否只读.
 void setSupportsSum(boolean supportsSum)
设置是否允许数据集自动在Client端统计该字段的合计值.
 void setTag(java.lang.String tag)
设定元素的用户自定义信息。
 void setToolTip(java.lang.String toolTip)
设定字段的弹出式提示信息.
 void setValueProtected(boolean valueProtected)
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

 void setVisible(boolean visible)
设置字段是否在页面上可见.
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Field
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty

Constructor Detail

ViewBaseField

public ViewBaseField(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

addValidator

public void addValidator(Validator validator)
为字段添加一个校验器。

Specified by:
addValidator in interface ViewField
Parameters:
validator - Validator

removeValidator

public void removeValidator(Validator validator)
删除一个字段的校验器.

Specified by:
removeValidator in interface ViewField
Parameters:
validator - Validator

getValidators

public java.util.List getValidators()
取得字段相关的所有校验器对象得集合对象.

Specified by:
getValidators in interface ViewField
Returns:
List

isReadOnly

public boolean isReadOnly()
返回该字段是否只读.

Specified by:
isReadOnly in interface ViewField
Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设定该字段是否只读.

Specified by:
setReadOnly in interface ViewField
Parameters:
readOnly - boolean

isValueProtected

public boolean isValueProtected()
返回字段是否有数据保护功能

Specified by:
isValueProtected in interface ViewField
Returns:
boolean

setValueProtected

public void setValueProtected(boolean valueProtected)
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

Specified by:
setValueProtected in interface ViewField
Parameters:
valueProtected - boolean

getFormat

public java.lang.String getFormat()
取得字段数据的格式化串.

Specified by:
getFormat in interface ViewField
Returns:
String

setFormat

public void setFormat(java.lang.String format)
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.

Specified by:
setFormat in interface ViewField
Parameters:
format - String

isVisible

public boolean isVisible()
返回字段是否在页面上可见.

Specified by:
isVisible in interface ViewField
Returns:
boolean

setVisible

public void setVisible(boolean visible)
设置字段是否在页面上可见.

Specified by:
setVisible in interface ViewField
Parameters:
visible - boolean

getEditorType

public java.lang.String getEditorType()
取得与该字段关联的编辑器的类型.

Specified by:
getEditorType in interface ViewField
Returns:
String

setEditorType

public void setEditorType(java.lang.String editorType)
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框

Specified by:
setEditorType in interface ViewField
Parameters:
editorType - String

getToolTip

public java.lang.String getToolTip()
返回字段的弹出式提示信息.

Specified by:
getToolTip in interface ViewField
Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定字段的弹出式提示信息.

Specified by:
setToolTip in interface ViewField
Parameters:
toolTip - String

getDropDown

public java.lang.String getDropDown()
取得字段关联的下拉框对象.

Specified by:
getDropDown in interface ViewField
Returns:
String

setDropDown

public void setDropDown(java.lang.String dropDown)
设定字段关联的下拉框对象.

Specified by:
setDropDown in interface ViewField
Parameters:
dropDown - String

setSupportsSum

public void setSupportsSum(boolean supportsSum)
设置是否允许数据集自动在Client端统计该字段的合计值.

Specified by:
setSupportsSum in interface ViewField
Parameters:
supportsSum - boolean

isSupportsSum

public boolean isSupportsSum()
取得是否允许数据集自动在Client端统计该字段的合计值.

Specified by:
isSupportsSum in interface ViewField
Returns:
boolean

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface ViewField

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface ViewField
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewDataset

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Interface ViewDataset

All Superinterfaces:
Component, Dataset, Element, EventSupported, java.io.Serializable
All Known Implementing Classes:
ViewDatasetSupport
public interface ViewDataset
extends Dataset, Component

视图模型中数据集对象的基础类

Version:
4.0

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Method Summary
java.util.List | getDetailLinks() 取得所有关联关系的集合对象
java.lang.String | getLoadDataAction() 返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
MasterDetailLink | getMasterLink() 返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
java.lang.String | getType() 取得视图数据集的类型。
boolean | isAsync() 返回是否采用异步方式执行动态数据加载.
boolean | isAutoLoadData() 返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。
boolean | isAutoLoadPage() 返回是否启用客户端Dataset的自动状态数据功能。
boolean | isInsertOnEmpty() 返回在数据集在客户端初试化时如果数据集为空是是否自动插入新记录.
boolean | isNoClient() 返回是否不在客户端创建记录集对象。
boolean | isReadOnly() 取得数据集的只读属性。
boolean | isShowLoadingTip() 执行动态数据加载时是否显示提示窗口
void | registerDetailLink(MasterDetailLink detailLink) 注册一个关联关系的对象。
void | setAsync(boolean async) 设定是否采用异步方式执行动态数据加载.
void | setAutoLoadData(boolean autoLoadData) 设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。
void | setAutoLoadPage(boolean autoLoadPage) 设定是否启用客户端Dataset的自动状态数据功能。
void | setInsertOnEmpty(boolean insertOnEmpty) 设定在数据集在客户端初试化时如果数据集为空是是否自动插入新记录.
void | setLoadDataAction(java.lang.String loadDataAction) 设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
void | setMasterLink(MasterDetailLink masterLink) 设定描述该Dataset与MasterDataset之间的关联关系的对象。
void | setNoClient(boolean noClient) 设定是否不在客户端创建记录集对象.
void | setReadOnly(boolean readOnly) 设定数据集的只读属性。
void | setShowLoadingTip(boolean showLoadingTip) 设置执行动态数据加载时是否显示提示窗口
void | unregisterDetailLink(MasterDetailLink detailLink) 注销一个关联关系的对象。
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, fromDO, fromSingleDO, fromSingleDO, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, init, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordSet, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
addEventHandler, applyRoleConfig, eventHandlers, getEventHandler, getId, getViewModel, init, isIgnored, removeEventHandler, setIgnored
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag

Method Detail

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String

getMasterLink

public MasterDetailLink getMasterLink()
返回用于描述该Dataset与MasterDataset之间的关联关系的对象。

Returns:
MasterDetailLink

setMasterLink

public void setMasterLink(MasterDetailLink masterLink)
设定描述该Dataset与MasterDataset之间的关联关系的对象。

Parameters:
masterLink - MasterDetailLink

registerDetailLink

public void registerDetailLink(MasterDetailLink detailLink)
注册一个关联关系的对象。

Parameters:
detailLink - MasterDetailLink

unregisterDetailLink

public void unregisterDetailLink(MasterDetailLink detailLink)
注销一个关联关系的对象。

Parameters:
detailLink - MasterDetailLink

getDetailLinks

public java.util.List getDetailLinks()
取得所有关联关系的集合对象

Returns:
List

isReadOnly

public boolean isReadOnly()
取得数据集的只读属性。

Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设定数据集的只读属性。

Parameters:
readOnly - boolean

isAutoLoadPage

public boolean isAutoLoadPage()
返回是否启用客户端Dataset的自动状态数据功能。

Returns:
boolean

setAutoLoadPage

public void setAutoLoadPage(boolean autoLoadPage)
设定是否启用客户端Dataset的自动状态数据功能。

Parameters:
autoLoadPage - boolean

isAutoLoadData

public boolean isAutoLoadData()
返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。

Returns:
boolean

setAutoLoadData

public void setAutoLoadData(boolean autoLoadData)
设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。

Parameters:
autoLoadData - boolean

isAsync

public boolean isAsync()
返回是否采用异步方式执行动态数据加载.

Returns:
boolean

setAsync

public void setAsync(boolean async)
设定是否采用异步方式执行动态数据加载.

Parameters:
async - boolean

isShowLoadingTip

public boolean isShowLoadingTip()
执行动态数据加载时是否显示提示窗口

Returns:
boolean

setShowLoadingTip

public void setShowLoadingTip(boolean showLoadingTip)
设置执行动态数据加载时是否显示提示窗口

Parameters:
showLoadingTip - boolean

isNoClient

public boolean isNoClient()
返回是否不在客户端创建记录集对象。

Returns:
boolean

setNoClient

public void setNoClient(boolean noClient)
设定是否不在客户端创建记录集对象.

Parameters:
noClient - boolean

getLoadDataAction

public java.lang.String getLoadDataAction()
返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.

Returns:
String

setLoadDataAction

public void setLoadDataAction(java.lang.String loadDataAction)
设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.

Parameters:
loadDataAction - String

isInsertOnEmpty

public boolean isInsertOnEmpty()
返回在数据集在客户端初试化时如果数据集为空是是否自动插入新记录.

Returns:
boolean

setInsertOnEmpty

public void setInsertOnEmpty(boolean insertOnEmpty)
设定在数据集在客户端初试化时如果数据集为空是是否自动插入新记录.

Parameters:
insertOnEmpty - boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewDatasetAdapter

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class ViewDatasetAdapter

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
                extended by com.bstek.dorado.view.data.ViewDatasetAdapter
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
public class ViewDatasetAdapter
extends ViewDatasetSupport

视图模型数据集适配器

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
ViewDatasetAdapter(ViewModel viewModel, java.lang.String id)
构造器
Method Summary
void | addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
DummyField | addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。
BaseField | addField(java.lang.String name) 向Dataset中添加一个普通Field。
LookupField | addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。 Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。
void | clear() 清空Dataset中所有的数据。
void | deleteRecord() 删除当前记录。
void | deleteRecord(Record record) 删除指定的记录。
protected void | doLoad(boolean createFields, boolean loadData) 根据已设定的条件读取外部数据.
FieldSet | fieldSet() 返回Dataset的Field集合对象
Record | find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record | find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record[] | findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record[] | findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
java.math.BigDecimal | getBigDecimal(int index) 按BigDecimal类型返回当前记录中某字段的值。
java.math.BigDecimal | getBigDecimal(java.lang.String name) 按BigDecimal类型返回当前记录中某字段的值。
boolean | getBoolean(int index) 按boolean类型返回当前记录中某字段的值。
boolean | getBoolean(java.lang.String name) 按boolean类型返回当前记录中某字段的值。
byte | getByte(int index) 按byte类型返回当前记录中某字段的值。
byte | getByte(java.lang.String name) 按byte类型返回当前记录中某字段的值。
Record | getCurrent() 返回当前记录对象。
java.util.Date | getDate(int index) 按Date类型返回当前记录中某字段的值。
java.util.Date | getDate(java.lang.String name) 按Date类型返回当前记录中某字段的值。
double | getDouble(int index) 按double类型返回当前记录中某字段的值。
double | getDouble(java.lang.String name) 按double类型返回当前记录中某字段的值。
Field | getField(int index) 根据Field索引号取得一个Field对象。
Field | getField(java.lang.String name) 根据Field名称取得一个Field对象。
int | getFieldCount() 取得Field的总数。
float | getFloat(int index) 按float类型返回当前记录中某字段的值。
float | getFloat(java.lang.String name) 按float类型返回当前记录中某字段的值。
Index | getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
int | getInt(int index) 按int类型返回当前记录中某字段的值。
int | getInt(java.lang.String name) 按int类型返回当前记录中某字段的值。
long | getLong(int index) 按long类型返回当前记录中某字段的值。
long | getLong(java.lang.String name) 按long类型返回当前记录中某字段的值。
ReadRecord | getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
int | getPageCount() 返回Dataset所对应的数据共有几页。
int | getPageIndex() 返回Dataset的当前页号
int | getPageSize() 取得每页的行数。即Dataset按照多少行数对数据进行分页。
int | getRecordState() 返回当前记录的状态
short | getShort(int index) 按short类型返回当前记录中某字段的值。
short | getShort(java.lang.String name) 按short类型返回当前记录中某字段的值。
java.lang.String | getString(int index) 按String类型返回当前记录中某字段的值。
java.lang.String | getString(java.lang.String name) 按String类型返回当前记录中某字段的值。
java.lang.String | getTag() 取得元素的用户自定义信息。
ViewDataset | getTarget() 取得被适配的数据集
java.lang.String | getType() 取得视图数据集的类型。
java.lang.Object | getValue(int index) 返回当前记录中某字段的值。
java.lang.Object | getValue(java.lang.String name) 返回当前记录中某字段的值。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
Record | insertRecord() 添加一条记录。
Record | insertRecord(int state) 添加一条记录并初始化新记录的状态。
boolean | isAutoLoadPage() 返回是否启用客户端Dataset的自动状态数据功能。
boolean | isFirst() 当前位置是否已到达当前页的顶端。 此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.
boolean | isLast() 当前位置是否已到达当前页的尾端。 此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.
boolean | isNull(int index) 判断当前记录中某字段的值是否为空(null)。
boolean | isNull(java.lang.String name) 判断当前记录中某字段的值是否为空(null)。
boolean | isReadOnly() 取得数据集的只读属性。
void | moveFirst() 将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
void | moveLast() 将当前位置移动到Dataset的末端。
void | moveNext() 将当前位置移动到后一条记录。
void | movePrev() 将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
ParameterSet | parameters() 返回Dataset所有参数的集合对象
void | processLookup() 处理所有的Lookup数据。
MetaData | properties() 与Dataset相关的一组属性值. 这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.
RecordIterator | recordIterator() 返回Dataset中所有Record的迭代器。 注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。
RecordSet | recordSet() 返回Dataset的Record集合对象
void | removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | setAutoLoadPage(boolean autoLoadPage) 设定是否启用客户端Dataset的自动状态数据功能。
void | setBigDecimal(int index, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBigDecimal(java.lang.String name, java.math.BigDecimal value) 按BigDecimal类型设置当前记录中某字段的值。
void | setBoolean(int index, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setBoolean(java.lang.String name, boolean value) 按boolean类型设置当前记录中某字段的值。
void | setByte(int index, byte value) 按byte类型设置当前记录中某字段的值。
void | setByte(java.lang.String name, byte value) 按byte类型设置当前记录中某字段的值。
void | setCurrent(Record record) 设置当前记录对象。
void | setDate(int index, java.util.Date value) 按Date类型设置当前记录中某字段的值。
void | setDate(java.lang.String name, java.util.Date value) 按date类型设置当前记录中某字段的值。
void | setDouble(int index, double value) 按double类型设置当前记录中某字段的值。
void | setDouble(java.lang.String name, double value) 按double类型设置当前记录中某字段的值。
void | setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象
void | setFloat(int index, float value) 按float类型设置当前记录中某字段的值。
void | setFloat(java.lang.String name, float value) 按float类型设置当前记录中某字段的值。
void | setInt(int index, int value) 按int类型设置当前记录中某字段的值。
void | setInt(java.lang.String name, int value) 按int类型设置当前记录中某字段的值。
void | setLong(int index, long value) 按long类型设置当前记录中某字段的值。
void | setLong(java.lang.String name, long value) 按long类型设置当前记录中某字段的值。
void | setNull(int index) 设置当前记录中某字段的值是否为空(null)。
void | setNull(java.lang.String name) 设置当前记录中某字段的值是否为空(null)。
void | setPageCount(int pageCount) 设定Dataset所对应的数据共有几页。
void | setPageIndex(int pageIndex) 设定Dataset的当前页号
void | setPageSize(int pageSize) 设定Dataset分页时的每页记录数
void | setReadOnly(boolean readOnly) 设定数据集的只读属性。
void | setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | setRecordState(int state) 设置当前记录的状态
void | setShort(int index, short value) 按short类型设置当前记录中某字段的值。
void | setShort(java.lang.String name, short value) 按short类型设置当前记录中某字段的值。
void | setString(int index, java.lang.String value) 按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
void | setString(java.lang.String name, java.lang.String value) 按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setTarget(ViewDataset target) 设定被适配的数据集
void | setValue(int index, java.lang.Object value) 设置当前记录中某字段的值。
void | setValue(java.lang.String name, java.lang.Object value) 设置当前记录中某字段的值。
long | timestamp() 返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
void | update() 把用户对Dataset中数据的操作更新到外部数据中.
Methods inherited from class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler, applyRoleConfig, createFieldByNode, doFromDO, doFromSingleDO, doUpdate, eventHandlers, fireAfterScroll, fromDO, fromSingleDO, fromSingleDO, getDetailLinks, getEventHandler, getFieldFactory, getLoadDataAction, getMasterLink, getRecordFactory, getValidatorFactory, getViewModel, initNewRecord, initValidator, isAsync, isAutoLoadData, isIgnored, isInsertOnEmpty, isNoClient, isShowLoadingTip, processDetailLookup, registerDetailLink, removeEventHandler, setAsync, setAutoLoadData, setIgnored, setInsertOnEmpty, setLoadDataAction, setMasterLink, setNoClient, setShowLoadingTip, toSingleDO, toSingleDO, unregisterDetailLink
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addRecordListener, afterChange, beforeChange, createFields, createFieldsFromObjectClazz, doToDO, finalize, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getId, getMaxPropertyLevel, getObjectClazz, getPossibleRecordCount, getRecordFilter, getState, initListener, internalLoad, isAutoCreateFields, isRecordVisible, load, load, removeRecordListener, resetRecordsState, setAutoCreateFields, setId, setMaxPropertyLevel, setObjectClazz, setObjectClazz, setPossibleRecordCount, setRecordFilter, setState, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Dataset
addRecordListener, createFields, createFieldsFromObjectClazz, getId, getMaxPropertyLevel, getObjectClazz, getPossibleRecordCount, getRecordFilter, getState, isAutoCreateFields, load, load, removeRecordListener, resetRecordsState, setAutoCreateFields, setId, setMaxPropertyLevel, setObjectClazz, setObjectClazz, setPossibleRecordCount, setRecordFilter, setState, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

ViewDatasetAdapter

public ViewDatasetAdapter(ViewModel viewModel,
                          java.lang.String id)
构造器

Parameters:
viewModel - ViewModel
id - String
Method Detail

getType

public java.lang.String getType()
取得视图数据集的类型。

Returns:
String

doLoad

protected void doLoad(boolean createFields,
                      boolean loadData)
根据已设定的条件读取外部数据.

Specified by:
doLoad in class DatasetSupport
Parameters:
createFields - 是否要执行自动创建字段的操作
loadData - 是否要装载数据

getTarget

public ViewDataset getTarget()
取得被适配的数据集

Returns:
ViewDataset

setTarget

public void setTarget(ViewDataset target)
设定被适配的数据集

Parameters:
target - ViewDataset

init

public void init(DoradoContext context,
                 XmlNode node)
          throws LoadXmlPropertyException
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Overrides:
init in class ViewDatasetSupport
Throws:
LoadXmlPropertyException

addField

public BaseField addField(java.lang.String name)
向Dataset中添加一个普通Field。

Specified by:
addField in interface Dataset
Overrides:
addField in class DatasetSupport

addLookupField

public LookupField addLookupField(java.lang.String name)
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

Specified by:
addLookupField in interface Dataset
Overrides:
addLookupField in class DatasetSupport

addDummyField

public DummyField addDummyField(java.lang.String name)
向Dataset中添加一个虚拟Field。

Specified by:
addDummyField in interface Dataset
Overrides:
addDummyField in class DatasetSupport

getField

public Field getField(int index)
根据Field索引号取得一个Field对象。

Specified by:
getField in interface Dataset
Overrides:
getField in class DatasetSupport

getField

public Field getField(java.lang.String name)
根据Field名称取得一个Field对象。

Specified by:
getField in interface Dataset
Overrides:
getField in class DatasetSupport

getFieldCount

public int getFieldCount()
取得Field的总数。

Specified by:
getFieldCount in interface Dataset
Overrides:
getFieldCount in class DatasetSupport

timestamp

public long timestamp()
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。

Specified by:
timestamp in interface Dataset
Overrides:
timestamp in class DatasetSupport

getIndex

public Index getIndex(java.lang.String field)
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Specified by:
getIndex in interface Dataset
Overrides:
getIndex in class DatasetSupport

getIndex

public Index getIndex(java.lang.String[] fields)
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Specified by:
getIndex in interface Dataset
Overrides:
getIndex in class DatasetSupport

find

public Record find(java.lang.String field,
                   java.lang.Object value)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Specified by:
find in interface Dataset
Overrides:
find in class DatasetSupport

find

public Record find(java.lang.String[] fields,
                   java.lang.Object[] values)
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。

Specified by:
find in interface Dataset
Overrides:
find in class DatasetSupport

findAll

public Record[] findAll(java.lang.String field,
                        java.lang.Object value)
根据指定的条件查找并返回所有匹配的记录。

Specified by:
findAll in interface Dataset
Overrides:
findAll in class DatasetSupport

findAll

public Record[] findAll(java.lang.String[] fields,
                        java.lang.Object[] values)
根据指定的条件查找并返回所有匹配的记录。

Specified by:
findAll in interface Dataset
Overrides:
findAll in class DatasetSupport

getPageSize

public int getPageSize()
取得每页的行数。即Dataset按照多少行数对数据进行分页。

Specified by:
getPageSize in interface Dataset
Overrides:
getPageSize in class DatasetSupport

setPageSize

public void setPageSize(int pageSize)
设定Dataset分页时的每页记录数

Specified by:
setPageSize in interface Dataset
Overrides:
setPageSize in class DatasetSupport

getPageIndex

public int getPageIndex()
返回Dataset的当前页号

Specified by:
getPageIndex in interface Dataset
Overrides:
getPageIndex in class DatasetSupport

setPageIndex

public void setPageIndex(int pageIndex)
设定Dataset的当前页号

Specified by:
setPageIndex in interface Dataset
Overrides:
setPageIndex in class DatasetSupport

getPageCount

public int getPageCount()
返回Dataset所对应的数据共有几页。

Specified by:
getPageCount in interface Dataset
Overrides:
getPageCount in class DatasetSupport

setPageCount

public void setPageCount(int pageCount)
设定Dataset所对应的数据共有几页。

Specified by:
setPageCount in interface Dataset
Overrides:
setPageCount in class DatasetSupport

parameters

public ParameterSet parameters()
返回Dataset所有参数的集合对象

Specified by:
parameters in interface Dataset
Overrides:
parameters in class DatasetSupport

properties

public MetaData properties()
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

Specified by:
properties in interface Dataset
Overrides:
properties in class DatasetSupport

fieldSet

public FieldSet fieldSet()
返回Dataset的Field集合对象

Specified by:
fieldSet in interface Dataset
Overrides:
fieldSet in class DatasetSupport

setFieldSet

public void setFieldSet(FieldSet fieldset)
设置Dataset的Field集合对象

Specified by:
setFieldSet in interface Dataset
Overrides:
setFieldSet in class DatasetSupport

recordSet

public RecordSet recordSet()
返回Dataset的Record集合对象

Specified by:
recordSet in interface Dataset
Overrides:
recordSet in class DatasetSupport

setRecordSet

public void setRecordSet(RecordSet recordset)
设定Dataset的Record集合对象

Specified by:
setRecordSet in interface Dataset
Overrides:
setRecordSet in class ViewDatasetSupport

recordIterator

public RecordIterator recordIterator()
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

Specified by:
recordIterator in interface Dataset
Overrides:
recordIterator in class DatasetSupport

processLookup

public void processLookup()
处理所有的Lookup数据。

Specified by:
processLookup in interface Dataset
Overrides:
processLookup in class DatasetSupport

clear

public void clear()
清空Dataset中所有的数据。

Specified by:
clear in interface Dataset
Overrides:
clear in class DatasetSupport

update

public void update()
            throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Specified by:
update in interface Dataset
Overrides:
update in class DatasetSupport
Throws:
java.lang.Exception

getCurrent

public Record getCurrent()
返回当前记录对象。

Specified by:
getCurrent in interface Dataset
Overrides:
getCurrent in class DatasetSupport

setCurrent

public void setCurrent(Record record)
设置当前记录对象。

Specified by:
setCurrent in interface Dataset
Overrides:
setCurrent in class DatasetSupport

isFirst

public boolean isFirst()
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

Specified by:
isFirst in interface Dataset
Overrides:
isFirst in class DatasetSupport

isLast

public boolean isLast()
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

Specified by:
isLast in interface Dataset
Overrides:
isLast in class DatasetSupport

moveFirst

public void moveFirst()
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.

Specified by:
moveFirst in interface Dataset
Overrides:
moveFirst in class DatasetSupport

movePrev

public void movePrev()
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.

Specified by:
movePrev in interface Dataset
Overrides:
movePrev in class DatasetSupport

moveNext

public void moveNext()
将当前位置移动到后一条记录。

Specified by:
moveNext in interface Dataset
Overrides:
moveNext in class DatasetSupport

moveLast

public void moveLast()
将当前位置移动到Dataset的末端。

Specified by:
moveLast in interface Dataset
Overrides:
moveLast in class DatasetSupport

insertRecord

public Record insertRecord()
添加一条记录。

Specified by:
insertRecord in interface Dataset
Overrides:
insertRecord in class DatasetSupport

insertRecord

public Record insertRecord(int state)
添加一条记录并初始化新记录的状态。

Specified by:
insertRecord in interface Dataset
Overrides:
insertRecord in class DatasetSupport

deleteRecord

public void deleteRecord()
删除当前记录。

Specified by:
deleteRecord in interface Dataset
Overrides:
deleteRecord in class DatasetSupport

deleteRecord

public void deleteRecord(Record record)
删除指定的记录。

Specified by:
deleteRecord in interface Dataset
Overrides:
deleteRecord in class DatasetSupport

getRecordState

public int getRecordState()
返回当前记录的状态

Specified by:
getRecordState in interface Dataset
Overrides:
getRecordState in class DatasetSupport

setRecordState

public void setRecordState(int state)
设置当前记录的状态

Specified by:
setRecordState in interface Dataset
Overrides:
setRecordState in class DatasetSupport

getOldRecord

public ReadRecord getOldRecord(Record record)
返回用于保存某记录的原始值的记录对象。

Specified by:
getOldRecord in interface Dataset
Overrides:
getOldRecord in class DatasetSupport

getValue

public java.lang.Object getValue(int index)
返回当前记录中某字段的值。

Specified by:
getValue in interface Dataset
Overrides:
getValue in class DatasetSupport

getBigDecimal

public java.math.BigDecimal getBigDecimal(int index)
按BigDecimal类型返回当前记录中某字段的值。

Specified by:
getBigDecimal in interface Dataset
Overrides:
getBigDecimal in class DatasetSupport

getBoolean

public boolean getBoolean(int index)
按boolean类型返回当前记录中某字段的值。

Specified by:
getBoolean in interface Dataset
Overrides:
getBoolean in class DatasetSupport

getByte

public byte getByte(int index)
按byte类型返回当前记录中某字段的值。

Specified by:
getByte in interface Dataset
Overrides:
getByte in class DatasetSupport

getDate

public java.util.Date getDate(int index)
按Date类型返回当前记录中某字段的值。

Specified by:
getDate in interface Dataset
Overrides:
getDate in class DatasetSupport

getDouble

public double getDouble(int index)
按double类型返回当前记录中某字段的值。

Specified by:
getDouble in interface Dataset
Overrides:
getDouble in class DatasetSupport

getFloat

public float getFloat(int index)
按float类型返回当前记录中某字段的值。

Specified by:
getFloat in interface Dataset
Overrides:
getFloat in class DatasetSupport

getInt

public int getInt(int index)
按int类型返回当前记录中某字段的值。

Specified by:
getInt in interface Dataset
Overrides:
getInt in class DatasetSupport

getLong

public long getLong(int index)
按long类型返回当前记录中某字段的值。

Specified by:
getLong in interface Dataset
Overrides:
getLong in class DatasetSupport

getShort

public short getShort(int index)
按short类型返回当前记录中某字段的值。

Specified by:
getShort in interface Dataset
Overrides:
getShort in class DatasetSupport

getString

public java.lang.String getString(int index)
按String类型返回当前记录中某字段的值。

Specified by:
getString in interface Dataset
Overrides:
getString in class DatasetSupport

isNull

public boolean isNull(int index)
判断当前记录中某字段的值是否为空(null)。

Specified by:
isNull in interface Dataset
Overrides:
isNull in class DatasetSupport

setValue

public void setValue(int index,
                     java.lang.Object value)
设置当前记录中某字段的值。

Specified by:
setValue in interface Dataset
Overrides:
setValue in class DatasetSupport

setBigDecimal

public void setBigDecimal(int index,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Specified by:
setBigDecimal in interface Dataset
Overrides:
setBigDecimal in class DatasetSupport

setBoolean

public void setBoolean(int index,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Specified by:
setBoolean in interface Dataset
Overrides:
setBoolean in class DatasetSupport

setByte

public void setByte(int index,
                    byte value)
按byte类型设置当前记录中某字段的值。

Specified by:
setByte in interface Dataset
Overrides:
setByte in class DatasetSupport

setDate

public void setDate(int index,
                    java.util.Date value)
按Date类型设置当前记录中某字段的值。

Specified by:
setDate in interface Dataset
Overrides:
setDate in class DatasetSupport

setDouble

public void setDouble(int index,
                      double value)
按double类型设置当前记录中某字段的值。

Specified by:
setDouble in interface Dataset
Overrides:
setDouble in class DatasetSupport

setFloat

public void setFloat(int index,
                     float value)
按float类型设置当前记录中某字段的值。

Specified by:
setFloat in interface Dataset
Overrides:
setFloat in class DatasetSupport

setInt

public void setInt(int index,
                   int value)
按int类型设置当前记录中某字段的值。

Specified by:
setInt in interface Dataset
Overrides:
setInt in class DatasetSupport

setLong

public void setLong(int index,
                    long value)
按long类型设置当前记录中某字段的值。

Specified by:
setLong in interface Dataset
Overrides:
setLong in class DatasetSupport

setShort

public void setShort(int index,
                     short value)
按short类型设置当前记录中某字段的值。

Specified by:
setShort in interface Dataset
Overrides:
setShort in class DatasetSupport

setString

public void setString(int index,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Specified by:
setString in interface Dataset
Overrides:
setString in class DatasetSupport

setNull

public void setNull(int index)
设置当前记录中某字段的值是否为空(null)。

Specified by:
setNull in interface Dataset
Overrides:
setNull in class DatasetSupport

getValue

public java.lang.Object getValue(java.lang.String name)
返回当前记录中某字段的值。

Specified by:
getValue in interface Dataset
Overrides:
getValue in class DatasetSupport

getBigDecimal

public java.math.BigDecimal getBigDecimal(java.lang.String name)
按BigDecimal类型返回当前记录中某字段的值。

Specified by:
getBigDecimal in interface Dataset
Overrides:
getBigDecimal in class DatasetSupport

getBoolean

public boolean getBoolean(java.lang.String name)
按boolean类型返回当前记录中某字段的值。

Specified by:
getBoolean in interface Dataset
Overrides:
getBoolean in class DatasetSupport

getByte

public byte getByte(java.lang.String name)
按byte类型返回当前记录中某字段的值。

Specified by:
getByte in interface Dataset
Overrides:
getByte in class DatasetSupport

getDate

public java.util.Date getDate(java.lang.String name)
按Date类型返回当前记录中某字段的值。

Specified by:
getDate in interface Dataset
Overrides:
getDate in class DatasetSupport

getDouble

public double getDouble(java.lang.String name)
按double类型返回当前记录中某字段的值。

Specified by:
getDouble in interface Dataset
Overrides:
getDouble in class DatasetSupport

getFloat

public float getFloat(java.lang.String name)
按float类型返回当前记录中某字段的值。

Specified by:
getFloat in interface Dataset
Overrides:
getFloat in class DatasetSupport

getInt

public int getInt(java.lang.String name)
按int类型返回当前记录中某字段的值。

Specified by:
getInt in interface Dataset
Overrides:
getInt in class DatasetSupport

getLong

public long getLong(java.lang.String name)
按long类型返回当前记录中某字段的值。

Specified by:
getLong in interface Dataset
Overrides:
getLong in class DatasetSupport

getShort

public short getShort(java.lang.String name)
按short类型返回当前记录中某字段的值。

Specified by:
getShort in interface Dataset
Overrides:
getShort in class DatasetSupport

getString

public java.lang.String getString(java.lang.String name)
按String类型返回当前记录中某字段的值。

Specified by:
getString in interface Dataset
Overrides:
getString in class DatasetSupport

isNull

public boolean isNull(java.lang.String name)
判断当前记录中某字段的值是否为空(null)。

Specified by:
isNull in interface Dataset
Overrides:
isNull in class DatasetSupport

setValue

public void setValue(java.lang.String name,
                     java.lang.Object value)
设置当前记录中某字段的值。

Specified by:
setValue in interface Dataset
Overrides:
setValue in class DatasetSupport

setBigDecimal

public void setBigDecimal(java.lang.String name,
                          java.math.BigDecimal value)
按BigDecimal类型设置当前记录中某字段的值。

Specified by:
setBigDecimal in interface Dataset
Overrides:
setBigDecimal in class DatasetSupport

setBoolean

public void setBoolean(java.lang.String name,
                       boolean value)
按boolean类型设置当前记录中某字段的值。

Specified by:
setBoolean in interface Dataset
Overrides:
setBoolean in class DatasetSupport

setByte

public void setByte(java.lang.String name,
                    byte value)
按byte类型设置当前记录中某字段的值。

Specified by:
setByte in interface Dataset
Overrides:
setByte in class DatasetSupport

setDate

public void setDate(java.lang.String name,
                    java.util.Date value)
按date类型设置当前记录中某字段的值。

Specified by:
setDate in interface Dataset
Overrides:
setDate in class DatasetSupport

setDouble

public void setDouble(java.lang.String name,
                      double value)
按double类型设置当前记录中某字段的值。

Specified by:
setDouble in interface Dataset
Overrides:
setDouble in class DatasetSupport

setFloat

public void setFloat(java.lang.String name,
                     float value)
按float类型设置当前记录中某字段的值。

Specified by:
setFloat in interface Dataset
Overrides:
setFloat in class DatasetSupport

setInt

public void setInt(java.lang.String name,
                   int value)
按int类型设置当前记录中某字段的值。

Specified by:
setInt in interface Dataset
Overrides:
setInt in class DatasetSupport

setLong

public void setLong(java.lang.String name,
                    long value)
按long类型设置当前记录中某字段的值。

Specified by:
setLong in interface Dataset
Overrides:
setLong in class DatasetSupport

setShort

public void setShort(java.lang.String name,
                     short value)
按short类型设置当前记录中某字段的值。

Specified by:
setShort in interface Dataset
Overrides:
setShort in class DatasetSupport

setString

public void setString(java.lang.String name,
                      java.lang.String value)
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。

Specified by:
setString in interface Dataset
Overrides:
setString in class DatasetSupport

setNull

public void setNull(java.lang.String name)
设置当前记录中某字段的值是否为空(null)。

Specified by:
setNull in interface Dataset
Overrides:
setNull in class DatasetSupport

addDatasetListener

public void addDatasetListener(DatasetListener l)
增加一个DatasetEvent的事件监听器

Specified by:
addDatasetListener in interface Dataset
Overrides:
addDatasetListener in class DatasetSupport

removeDatasetListener

public void removeDatasetListener(DatasetListener l)
删除一个DatasetEvent的事件监听器

Specified by:
removeDatasetListener in interface Dataset
Overrides:
removeDatasetListener in class DatasetSupport

isReadOnly

public boolean isReadOnly()
取得数据集的只读属性。

Specified by:
isReadOnly in interface ViewDataset
Overrides:
isReadOnly in class ViewDatasetSupport

setReadOnly

public void setReadOnly(boolean readOnly)
设定数据集的只读属性。

Specified by:
setReadOnly in interface ViewDataset
Overrides:
setReadOnly in class ViewDatasetSupport

isAutoLoadPage

public boolean isAutoLoadPage()
返回是否启用客户端Dataset的自动状态数据功能。

Specified by:
isAutoLoadPage in interface ViewDataset
Overrides:
isAutoLoadPage in class ViewDatasetSupport

setAutoLoadPage

public void setAutoLoadPage(boolean autoLoadPage)
设定是否启用客户端Dataset的自动状态数据功能。

Specified by:
setAutoLoadPage in interface ViewDataset
Overrides:
setAutoLoadPage in class ViewDatasetSupport

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Overrides:
getTag in class ViewDatasetSupport

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Overrides:
setTag in class ViewDatasetSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewDatasetSupport

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class ViewDatasetSupport

java.lang.Object
    extended by com.bstek.dorado.data.DatasetSupport
        extended by com.bstek.dorado.data.AbstractDataset
            extended by com.bstek.dorado.view.data.ViewDatasetSupport
All Implemented Interfaces:
Component, DataListener, Dataset, Element, java.util.EventListener, EventSupported, java.io.Serializable, ViewDataset
Direct Known Subclasses:
com.bstek.dorado.view.data.AbstractViewDataset, ViewDatasetAdapter
public abstract class ViewDatasetSupport
extends com.bstek.dorado.data.AbstractDataset
implements ViewDataset

视图数据集的抽象基类。

Version:
4.0
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.bstek.dorado.data.Dataset
FILTER_ALL, FILTER_CHANGED, FILTER_DEFAULT, FILTER_DELETED, FILTER_MODIFIED, FILTER_NEW, FILTER_NOT_CHANGED, STATE_INIT, STATE_LOADING, STATE_READY, STATE_RESOLVING
Constructor Summary
ViewDatasetSupport(ViewModel viewModel, java.lang.String id)
AbstractViewDataset
Method Summary
void | addEventHandler(EventHandler event) addEventHandler
void | applyRoleConfig() 应用角色配置文件中的配置。
protected Field | createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
protected int | doFromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
protected Record | doFromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
protected void | doUpdate() 把用户对Dataset中数据的操作更新到外部数据中.
java.util.Map | eventHandlers() eventHandlers
protected void | fireAfterScroll() 触发AfterScroll事件
int | fromDO(java.lang.Object data) 自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中. 此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.
Record | fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中. 此处的data可以是单个的Bean或java.util.Map的派生类.
java.util.List | getDetailLinks() 取得所有关联关系的集合对象
EventHandler | getEventHandler(java.lang.String name) getEventHandler
protected com.bstek.dorado.data.FieldFactory | getFieldFactory() 返回Field的创建工厂.
java.lang.String | getLoadDataAction() 返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
MasterDetailLink | getMasterLink() 返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
protected com.bstek.dorado.data.RecordFactory | getRecordFactory() 返回Record的创建工厂.
java.lang.String | getTag() 取得元素的用户自定义信息。
protected com.bstek.dorado.view.data.validate.ValidatorFactory | getValidatorFactory() 获得数据校验器的构造工厂
ViewModel | getViewModel() 取得视图模型对象。
void | init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected void | initNewRecord(Record record) initNewRecord
protected void | initValidator(Validator validator, XmlNode validatorNode) initValidator
boolean | isAsync() 返回是否采用异步方式执行动态数据加载.
boolean | isAutoLoadData() 返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。
boolean | isAutoLoadPage() 返回是否启用客户端Dataset的自动状态数据功能。
boolean | isIgnored() 返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
boolean | isInsertOnEmpty() 返回是否需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效.
boolean | isNoClient() isNoClient
boolean | isReadOnly() 取得数据集的只读属性。
boolean | isShowLoadingTip() 执行动态数据加载时是否显示提示窗口
protected void | processDetailLookup() processDetailLookup
void | registerDetailLink(MasterDetailLink detailLink) 注册一个关联关系的对象。
void | removeEventHandler(java.lang.String name) removeEventHandler
void | setAsync(boolean async) 设定是否采用异步方式执行动态数据加载.
void | setAutoLoadData(boolean autoLoadData) 设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。
void | setAutoLoadPage(boolean autoLoadPage) 设定是否启用客户端Dataset的自动状态数据功能。
void | setIgnored(boolean ignored) 设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
void | setInsertOnEmpty(boolean insertOnEmpty) 设置需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效.
void | setLoadDataAction(java.lang.String loadDataAction) 设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
void | setMasterLink(MasterDetailLink masterLink) 设定描述该Dataset与MasterDataset之间的关联关系的对象。
void | setNoClient(boolean noClient) setNoClient
void | setReadOnly(boolean readOnly) 设定数据集的只读属性。
void | setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | setShowLoadingTip(boolean showLoadingTip) 设置执行动态数据加载时是否显示提示窗口
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
java.lang.Object | toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
void | unregisterDetailLink(MasterDetailLink detailLink) 注销一个关联关系的对象。
Methods inherited from class com.bstek.dorado.data.DatasetSupport
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, afterChange, beforeChange, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, doLoad, doToDO, fieldSet, finalize, find, find, findAll, findAll, findNext, findPrev, fireAfterChange, fireAfterCreateFields, fireAfterDelete, fireAfterInsert, fireAfterLoadData, fireAfterUpdateData, fireBeforeChange, fireBeforeCreateFields, fireBeforeDelete, fireBeforeInsert, fireBeforeLoadData, fireBeforeScroll, fireBeforeUpdateData, fireOnInit, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, initListener, insertRecord, insertRecord, internalLoad, isAutoCreateFields, isFirst, isLast, isNull, isNull, isRecordVisible, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update, validateCursor
Methods inherited from class java.lang.Object
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.view.data.ViewDataset
getType
Methods inherited from interface com.bstek.dorado.data.Dataset
addDatasetListener, addDummyField, addField, addLookupField, addRecordListener, clear, createFields, createFieldsFromObjectClazz, deleteRecord, deleteRecord, fieldSet, find, find, findAll, findAll, getBigDecimal, getBigDecimal, getBoolean, getBoolean, getByte, getByte, getCurrent, getDate, getDate, getDouble, getDouble, getField, getField, getFieldCount, getFloat, getFloat, getId, getIndex, getIndex, getInt, getInt, getLong, getLong, getMaxPropertyLevel, getObjectClazz, getOldRecord, getPageCount, getPageIndex, getPageSize, getPossibleRecordCount, getRecordFilter, getRecordState, getShort, getShort, getState, getString, getString, getValue, getValue, insertRecord, insertRecord, isAutoCreateFields, isFirst, isLast, isNull, isNull, load, load, moveFirst, moveLast, moveNext, movePrev, parameters, processLookup, properties, recordIterator, recordSet, removeDatasetListener, removeRecordListener, resetRecordsState, setAutoCreateFields, setBigDecimal, setBigDecimal, setBoolean, setBoolean, setByte, setByte, setCurrent, setDate, setDate, setDouble, setDouble, setFieldSet, setFloat, setFloat, setId, setInt, setInt, setLong, setLong, setMaxPropertyLevel, setNull, setNull, setObjectClazz, setObjectClazz, setPageCount, setPageIndex, setPageSize, setPossibleRecordCount, setRecordFilter, setRecordState, setShort, setShort, setState, setString, setString, setValue, setValue, timestamp, toDO, toDO, toDO, toDO, toSingleDO, toSingleDO, update
Methods inherited from interface com.bstek.dorado.view.Component
getId

Constructor Detail

ViewDatasetSupport

public ViewDatasetSupport(ViewModel viewModel,
                          java.lang.String id)
AbstractViewDataset

Parameters:
viewModel - ViewModel
id - String
Method Detail

getFieldFactory

protected com.bstek.dorado.data.FieldFactory getFieldFactory()
                                                      throws java.lang.Exception
返回Field的创建工厂.

Specified by:
getFieldFactory in class DatasetSupport
Returns:
FieldFactory
Throws:
java.lang.Exception

getRecordFactory

protected com.bstek.dorado.data.RecordFactory getRecordFactory()
                                                        throws java.lang.Exception
返回Record的创建工厂.

Specified by:
getRecordFactory in class DatasetSupport
Returns:
RecordFactory
Throws:
java.lang.Exception

addEventHandler

public void addEventHandler(EventHandler event)
addEventHandler

Specified by:
addEventHandler in interface Component
Parameters:
event - EventHandler

getEventHandler

public EventHandler getEventHandler(java.lang.String name)
getEventHandler

Specified by:
getEventHandler in interface Component
Parameters:
name - String
Returns:
EventHandler

removeEventHandler

public void removeEventHandler(java.lang.String name)
removeEventHandler

Specified by:
removeEventHandler in interface Component
Parameters:
name - String

eventHandlers

public java.util.Map eventHandlers()
eventHandlers

Specified by:
eventHandlers in interface Component
Returns:
Map

getValidatorFactory

protected com.bstek.dorado.view.data.validate.ValidatorFactory getValidatorFactory()
获得数据校验器的构造工厂

Returns:
ValidatorFactory

initValidator

protected void initValidator(Validator validator,
                             XmlNode validatorNode)
                      throws LoadXmlPropertyException
initValidator

Parameters:
validator - Validator
validatorNode - XmlNode
Throws:
LoadXmlPropertyException

createFieldByNode

protected Field createFieldByNode(DoradoContext context,
                                  XmlNode node)
                           throws LoadXmlPropertyException
根据一个描述字段的XML节点自动创建字段对象.

Overrides:
createFieldByNode in class DatasetSupport
Parameters:
context - DoradoContext
node - XmlNode
Returns:
Field
Throws:
LoadXmlPropertyException

doUpdate

protected void doUpdate()
                 throws java.lang.Exception
把用户对Dataset中数据的操作更新到外部数据中.

Specified by:
doUpdate in class DatasetSupport
Throws:
java.lang.Exception

getViewModel

public ViewModel getViewModel()
取得视图模型对象。

Specified by:
getViewModel in interface Component
Returns:
ViewModel

isIgnored

public boolean isIgnored()
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。

Specified by:
isIgnored in interface Component
Returns:
boolean

setIgnored

public void setIgnored(boolean ignored)
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。

Specified by:
setIgnored in interface Component
Parameters:
ignored - boolean

init

public void init(DoradoContext context,
                 XmlNode node)
          throws java.lang.Exception
根据一个XML节点对象自动配置本Dataset。

Specified by:
init in interface Dataset
Overrides:
init in class DatasetSupport
Throws:
java.lang.Exception

applyRoleConfig

public void applyRoleConfig()
                     throws java.lang.Exception
应用角色配置文件中的配置。

Specified by:
applyRoleConfig in interface Component
Throws:
java.lang.Exception

isNoClient

public boolean isNoClient()
isNoClient

Specified by:
isNoClient in interface ViewDataset
Returns:
boolean

setNoClient

public void setNoClient(boolean noClient)
setNoClient

Specified by:
setNoClient in interface ViewDataset
Parameters:
noClient - boolean

getMasterLink

public MasterDetailLink getMasterLink()
返回用于描述该Dataset与MasterDataset之间的关联关系的对象。

Specified by:
getMasterLink in interface ViewDataset
Returns:
MasterDetailLink

setMasterLink

public void setMasterLink(MasterDetailLink masterLink)
设定描述该Dataset与MasterDataset之间的关联关系的对象。

Specified by:
setMasterLink in interface ViewDataset
Parameters:
masterLink - MasterDetailLink

initNewRecord

protected void initNewRecord(Record record)
initNewRecord

Overrides:
initNewRecord in class DatasetSupport
Parameters:
record - Record

registerDetailLink

public void registerDetailLink(MasterDetailLink detailLink)
注册一个关联关系的对象。

Specified by:
registerDetailLink in interface ViewDataset
Parameters:
detailLink - MasterDetailLink

unregisterDetailLink

public void unregisterDetailLink(MasterDetailLink detailLink)
注销一个关联关系的对象。

Specified by:
unregisterDetailLink in interface ViewDataset
Parameters:
detailLink - MasterDetailLink

getDetailLinks

public java.util.List getDetailLinks()
取得所有关联关系的集合对象

Specified by:
getDetailLinks in interface ViewDataset
Returns:
List

isReadOnly

public boolean isReadOnly()
取得数据集的只读属性。

Specified by:
isReadOnly in interface ViewDataset
Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设定数据集的只读属性。

Specified by:
setReadOnly in interface ViewDataset
Parameters:
readOnly - boolean

isAutoLoadPage

public boolean isAutoLoadPage()
返回是否启用客户端Dataset的自动状态数据功能。

Specified by:
isAutoLoadPage in interface ViewDataset
Returns:
boolean

setAutoLoadPage

public void setAutoLoadPage(boolean autoLoadPage)
设定是否启用客户端Dataset的自动状态数据功能。

Specified by:
setAutoLoadPage in interface ViewDataset
Parameters:
autoLoadPage - boolean

isAutoLoadData

public boolean isAutoLoadData()
返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。

Specified by:
isAutoLoadData in interface ViewDataset
Returns:
boolean

setAutoLoadData

public void setAutoLoadData(boolean autoLoadData)
设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。

Specified by:
setAutoLoadData in interface ViewDataset
Parameters:
autoLoadData - boolean

isAsync

public boolean isAsync()
返回是否采用异步方式执行动态数据加载.

Specified by:
isAsync in interface ViewDataset
Returns:
boolean

setAsync

public void setAsync(boolean async)
设定是否采用异步方式执行动态数据加载.

Specified by:
setAsync in interface ViewDataset
Parameters:
async - boolean

isShowLoadingTip

public boolean isShowLoadingTip()
执行动态数据加载时是否显示提示窗口

Specified by:
isShowLoadingTip in interface ViewDataset
Returns:
boolean

setShowLoadingTip

public void setShowLoadingTip(boolean showLoadingTip)
设置执行动态数据加载时是否显示提示窗口

Specified by:
setShowLoadingTip in interface ViewDataset
Parameters:
showLoadingTip - boolean

getLoadDataAction

public java.lang.String getLoadDataAction()
返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.

Specified by:
getLoadDataAction in interface ViewDataset
Returns:
String

setLoadDataAction

public void setLoadDataAction(java.lang.String loadDataAction)
设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.

Specified by:
setLoadDataAction in interface ViewDataset
Parameters:
loadDataAction - String

isInsertOnEmpty

public boolean isInsertOnEmpty()
返回是否需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效. 默认为false

Specified by:
isInsertOnEmpty in interface ViewDataset
Returns:
boolean

setInsertOnEmpty

public void setInsertOnEmpty(boolean insertOnEmpty)
设置需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效. 默认为false

Specified by:
setInsertOnEmpty in interface ViewDataset
Parameters:
insertOnEmpty - boolean

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String

setRecordSet

public void setRecordSet(RecordSet recordset)
设定Dataset的Record集合对象

Specified by:
setRecordSet in interface Dataset
Overrides:
setRecordSet in class DatasetSupport

fireAfterScroll

protected void fireAfterScroll()
触发AfterScroll事件

Overrides:
fireAfterScroll in class DatasetSupport

processDetailLookup

protected void processDetailLookup()
processDetailLookup

fromDO

public int fromDO(java.lang.Object data)
           throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

Specified by:
fromDO in interface Dataset
Overrides:
fromDO in class DatasetSupport
Throws:
java.lang.Exception

doFromDO

protected int doFromDO(java.lang.Object data)
                throws java.lang.Exception
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

Overrides:
doFromDO in class DatasetSupport
Parameters:
data - Object
Returns:
int
Throws:
java.lang.Exception

doFromSingleDO

protected Record doFromSingleDO(java.lang.Object o,
                                boolean newRecord)
                         throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

Overrides:
doFromSingleDO in class DatasetSupport
Parameters:
o - Object
newRecord - boolean
Returns:
Record
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

Specified by:
fromSingleDO in interface Dataset
Overrides:
fromSingleDO in class DatasetSupport
Throws:
java.lang.Exception

fromSingleDO

public Record fromSingleDO(java.lang.Object o,
                           boolean newRecord)
                    throws java.lang.Exception
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

Specified by:
fromSingleDO in interface Dataset
Overrides:
fromSingleDO in class DatasetSupport
Throws:
java.lang.Exception

toSingleDO

public java.lang.Object toSingleDO(Record record)
                            throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Specified by:
toSingleDO in interface Dataset
Overrides:
toSingleDO in class DatasetSupport
Throws:
java.lang.Exception

toSingleDO

public void toSingleDO(Record record,
                       java.lang.Object o)
                throws java.lang.Exception
自动将Dataset中给定的记录转换为对象

Specified by:
toSingleDO in interface Dataset
Overrides:
toSingleDO in class DatasetSupport
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Interface ViewField

All Superinterfaces:
Element, Field
All Known Implementing Classes:
ViewBaseField, ViewLookupField
public interface ViewField
extends Field, Element

视图模型中数据集字段对象

Version:
4.0

Method Summary
void | addValidator(Validator validator) 为字段添加一个校验器。
java.lang.String | getDropDown() 取得字段关联的下拉框对象.
java.lang.String | getEditorType() 取得与该字段关联的编辑器的类型.
java.lang.String | getFormat() 取得字段数据的格式化串.
java.lang.String | getTag() 取得元素的用户自定义信息。
java.lang.String | getToolTip() 返回字段的弹出式提示信息.
java.util.List | getValidators() 取得字段相关的所有校验器对象得集合对象.
boolean | isReadOnly() 返回该字段是否只读.
boolean | isSupportsSum() 取得是否允许数据集自动在Client端统计该字段的合计值.
boolean | isValueProtected() 返回字段是否有数据保护功能
boolean | isVisible() 返回字段是否在页面上可见.
void | removeValidator(Validator validator) 删除一个字段的校验器.
void | setDropDown(java.lang.String dropDown) 设定字段关联的下拉框对象.
void | setEditorType(java.lang.String editorType) 设定与该字段关联的编辑器的类型.
void | setFormat(java.lang.String format) 设置字段数据的格式化串格式.
void | setReadOnly(boolean readOnly) 设定该字段是否只读.
void | setSupportsSum(boolean supportsSum) 设置是否允许数据集自动在Client端统计该字段的合计值.
void | setTag(java.lang.String tag) 设定元素的用户自定义信息。
void | setToolTip(java.lang.String toolTip) 设定字段的弹出式提示信息.
void | setValueProtected(boolean valueProtected) 设定字段是否有数据保护功能 保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据.
void | setVisible(boolean visible) 设置字段是否在页面上可见.
Methods inherited from interface com.bstek.dorado.data.Field
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty

Method Detail

addValidator

public void addValidator(Validator validator)
为字段添加一个校验器。

Parameters:
validator - Validator

removeValidator

public void removeValidator(Validator validator)
删除一个字段的校验器.

Parameters:
validator - Validator

getValidators

public java.util.List getValidators()
取得字段相关的所有校验器对象得集合对象.

Returns:
List

isReadOnly

public boolean isReadOnly()
返回该字段是否只读.

Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设定该字段是否只读.

Parameters:
readOnly - boolean

isValueProtected

public boolean isValueProtected()
返回字段是否有数据保护功能

Returns:
boolean

setValueProtected

public void setValueProtected(boolean valueProtected)
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

Parameters:
valueProtected - boolean

getFormat

public java.lang.String getFormat()
取得字段数据的格式化串.

Returns:
String

setFormat

public void setFormat(java.lang.String format)
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.

Parameters:
format - String

isVisible

public boolean isVisible()
返回字段是否在页面上可见.

Returns:
boolean

setVisible

public void setVisible(boolean visible)
设置字段是否在页面上可见.

Parameters:
visible - boolean

getEditorType

public java.lang.String getEditorType()
取得与该字段关联的编辑器的类型.

Returns:
String

setEditorType

public void setEditorType(java.lang.String editorType)
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框

Parameters:
editorType - String

getToolTip

public java.lang.String getToolTip()
返回字段的弹出式提示信息.

Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定字段的弹出式提示信息.

Parameters:
toolTip - String

getDropDown

public java.lang.String getDropDown()
取得字段关联的下拉框对象.

Returns:
String

setDropDown

public void setDropDown(java.lang.String dropDown)
设定字段关联的下拉框对象.

Parameters:
dropDown - String

setSupportsSum

public void setSupportsSum(boolean supportsSum)
设置是否允许数据集自动在Client端统计该字段的合计值.

Parameters:
supportsSum - boolean

isSupportsSum

public boolean isSupportsSum()
取得是否允许数据集自动在Client端统计该字段的合计值.

Returns:
boolean

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface Element
Returns:
String

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface Element
Parameters:
tag - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewLookupField

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class ViewLookupField

java.lang.Object
    extended by com.bstek.dorado.data.AbstractField
        extended by com.bstek.dorado.data.LookupField
            extended by com.bstek.dorado.view.data.ViewLookupField
All Implemented Interfaces:
Element, Field, ViewField
public class ViewLookupField
extends LookupField
implements ViewField

视图模型中LookupField对象

Version:
1.0

Constructor Summary
ViewLookupField(java.lang.String name)
构造器
Method Summary
 void addValidator(Validator validator)
为字段添加一个校验器。
 java.lang.String getDropDown()
取得字段关联的下拉框对象.
 java.lang.String getEditorType()
取得与该字段关联的编辑器的类型.
 java.lang.String getFormat()
取得字段数据的格式化串.
 java.lang.String getTag()
取得元素的用户自定义信息。
 java.lang.String getToolTip()
返回字段的弹出式提示信息.
 java.util.List getValidators()
取得字段相关的所有校验器对象得集合对象.
 boolean isReadOnly()
返回该字段是否只读.
 boolean isSupportsSum()
取得是否允许数据集自动在Client端统计该字段的合计值.
 boolean isValueProtected()
返回字段是否有数据保护功能
 boolean isVisible()
返回字段是否在页面上可见.
 void removeValidator(Validator validator)
删除一个字段的校验器.
 void setDropDown(java.lang.String dropDown)
设定字段关联的下拉框对象.
 void setEditorType(java.lang.String editorType)
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框
 void setFormat(java.lang.String format)
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.
 void setReadOnly(boolean readOnly)
设定该字段是否只读.
 void setSupportsSum(boolean supportsSum)
设置是否允许数据集自动在Client端统计该字段的合计值.
 void setTag(java.lang.String tag)
设定元素的用户自定义信息。
 void setToolTip(java.lang.String toolTip)
设定字段的弹出式提示信息.
 void setValueProtected(boolean valueProtected)
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

 void setVisible(boolean visible)
设置字段是否在页面上可见.
Methods inherited from class com.bstek.dorado.data.LookupField
getKeyFields, getLookupDataset, getLookupField, getLookupKeyFields, setKeyFields, setLookupDataset, setLookupField, setLookupKeyFields
Methods inherited from class com.bstek.dorado.data.AbstractField
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.bstek.dorado.data.Field
getDataType, getDefaultValue, getLabel, getName, getParsedProperty, getProperty, isNullable, properties, setDataType, setDataType, setDefaultValue, setLabel, setName, setNullable, setProperty

Constructor Detail

ViewLookupField

public ViewLookupField(java.lang.String name)
构造器

Parameters:
name - String
Method Detail

addValidator

public void addValidator(Validator validator)
为字段添加一个校验器。

Specified by:
addValidator in interface ViewField
Parameters:
validator - Validator

removeValidator

public void removeValidator(Validator validator)
删除一个字段的校验器.

Specified by:
removeValidator in interface ViewField
Parameters:
validator - Validator

getValidators

public java.util.List getValidators()
取得字段相关的所有校验器对象得集合对象.

Specified by:
getValidators in interface ViewField
Returns:
List

isReadOnly

public boolean isReadOnly()
返回该字段是否只读.

Specified by:
isReadOnly in interface ViewField
Returns:
boolean

setReadOnly

public void setReadOnly(boolean readOnly)
设定该字段是否只读.

Specified by:
setReadOnly in interface ViewField
Parameters:
readOnly - boolean

isValueProtected

public boolean isValueProtected()
返回字段是否有数据保护功能

Specified by:
isValueProtected in interface ViewField
Returns:
boolean

setValueProtected

public void setValueProtected(boolean valueProtected)
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

Specified by:
setValueProtected in interface ViewField
Parameters:
valueProtected - boolean

getFormat

public java.lang.String getFormat()
取得字段数据的格式化串.

Specified by:
getFormat in interface ViewField
Returns:
String

setFormat

public void setFormat(java.lang.String format)
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.

Specified by:
setFormat in interface ViewField
Parameters:
format - String

isVisible

public boolean isVisible()
返回字段是否在页面上可见.

Specified by:
isVisible in interface ViewField
Returns:
boolean

setVisible

public void setVisible(boolean visible)
设置字段是否在页面上可见.

Specified by:
setVisible in interface ViewField
Parameters:
visible - boolean

getEditorType

public java.lang.String getEditorType()
取得与该字段关联的编辑器的类型.

Specified by:
getEditorType in interface ViewField
Returns:
String

setEditorType

public void setEditorType(java.lang.String editorType)
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框

Specified by:
setEditorType in interface ViewField
Parameters:
editorType - String

getToolTip

public java.lang.String getToolTip()
返回字段的弹出式提示信息.

Specified by:
getToolTip in interface ViewField
Returns:
String

setToolTip

public void setToolTip(java.lang.String toolTip)
设定字段的弹出式提示信息.

Specified by:
setToolTip in interface ViewField
Parameters:
toolTip - String

getDropDown

public java.lang.String getDropDown()
取得字段关联的下拉框对象.

Specified by:
getDropDown in interface ViewField
Returns:
String

setDropDown

public void setDropDown(java.lang.String dropDown)
设定字段关联的下拉框对象.

Specified by:
setDropDown in interface ViewField
Parameters:
dropDown - String

setSupportsSum

public void setSupportsSum(boolean supportsSum)
Description copied from interface: ViewField
设置是否允许数据集自动在Client端统计该字段的合计值.

Specified by:
setSupportsSum in interface ViewField
Parameters:
supportsSum - boolean

isSupportsSum

public boolean isSupportsSum()
Description copied from interface: ViewField
取得是否允许数据集自动在Client端统计该字段的合计值.

Specified by:
isSupportsSum in interface ViewField
Returns:
boolean

getTag

public java.lang.String getTag()
取得元素的用户自定义信息。

Specified by:
getTag in interface ViewField

setTag

public void setTag(java.lang.String tag)
设定元素的用户自定义信息。

Specified by:
setTag in interface ViewField
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ViewRecord

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data
Class ViewRecord

java.lang.Object
    extended by com.bstek.dorado.data.ReadRecord
        extended by com.bstek.dorado.data.Record
            extended by com.bstek.dorado.data.BaseRecord
                extended by com.bstek.dorado.data.DORecord
                    extended by com.bstek.dorado.view.data.ViewRecord
All Implemented Interfaces:
java.lang.Cloneable, java.io.Serializable
public class ViewRecord
extends DORecord

视图模型中Dataset的记录对象

Version:
1.0
See Also:
Serialized Form

Field Summary
Fields inherited from class com.bstek.dorado.data.Record
STATE_DELETED, STATE_MODIFIED, STATE_NEW, STATE_NONE
Fields inherited from class com.bstek.dorado.data.ReadRecord
state
Constructor Summary
ViewRecord()
Method Summary
 void validate()
检查对记录所作的修改的有效性.
Methods inherited from class com.bstek.dorado.data.DORecord
doGet, doSet, toDO
Methods inherited from class com.bstek.dorado.data.BaseRecord
clone
Methods inherited from class com.bstek.dorado.data.Record
fireAfterChange, fireBeforeChange, fromDO, getDataset, getFieldSet, getPropertyValue, getRecordId, isDeleted, set, setBigDecimal, setBoolean, setByte, setDate, setDetailRecords, setDouble, setFloat, setInt, setLong, setNull, setPropertyValue, setRecordId, setShort, setString, setValue, timestamp, toDO
Methods inherited from class com.bstek.dorado.data.ReadRecord
get, getBigDecimal, getBoolean, getByte, getDate, getDetailRecords, getDouble, getFloat, getInt, getLong, getShort, getState, getString, getValue, getVariant, isNull
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ViewRecord

public ViewRecord()
Method Detail

validate

public void validate()
检查对记录所作的修改的有效性.

Overrides:
validate in class Record
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


IllegalValueException

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate
Class IllegalValueException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by com.bstek.dorado.utils.DoradoRuntimeException
                    extended by com.bstek.dorado.view.data.validate.IllegalValueException
All Implemented Interfaces:
java.io.Serializable
public class IllegalValueException
extends DoradoRuntimeException

非法值异常。不符合校验规则的值产生的异常。

Version:
4.0
See Also:
Serialized Form

Constructor Summary
IllegalValueException()
构造器
IllegalValueException(java.lang.String message)
构造器
IllegalValueException(java.lang.Throwable t)
构造器
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalValueException

public IllegalValueException()
构造器

IllegalValueException

public IllegalValueException(java.lang.String message)
构造器

Parameters:
message - String 错误信息

IllegalValueException

public IllegalValueException(java.lang.Throwable t)
构造器

Parameters:
t - Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.data.validate

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.data.validate

数据校验器的相关类
See:
Description

Interface Summary
Validator 校验器的基类

Exception Summary
IllegalValueException 非法值异常。

Package com.bstek.dorado.view.data.validate Description

数据校验器的相关类


Validator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate
Interface Validator

All Superinterfaces:
Element, EventSupported
All Known Implementing Classes:
com.bstek.dorado.view.data.validate.impl.AbstractValidator
public interface Validator
extends Element, EventSupported

校验器的基类

Version:
4.0

Method Summary
java.lang.String | getErrorMessage() 返回一个错误信息.
java.lang.String | getFinalErrorMessage() 返回一个最终的错误信息.
void | setErrorMessage(java.lang.String errorMessage) 设定一个错误信息.
void | validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from interface com.bstek.dorado.view.Element
getTag, setTag
Methods inherited from interface com.bstek.dorado.view.EventSupported
addEventHandler, eventHandlers, getEventHandler, removeEventHandler

Method Detail

getErrorMessage

public java.lang.String getErrorMessage()
返回一个错误信息.

Returns:
String

setErrorMessage

public void setErrorMessage(java.lang.String errorMessage)
设定一个错误信息.

Parameters:
errorMessage - String

getFinalErrorMessage

public java.lang.String getFinalErrorMessage()
返回一个最终的错误信息.

由于errorMessage中可能包含类似${field}这样的参数, Validator必须在最终抛出异常将这些参数替换为真正的数值.
此方法可以返回Validator最终将要使用的错误信息.

Returns:
String

validate

public void validate(java.lang.Object value)
              throws IllegalValueException
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据
Throws:
IllegalValueException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CustomValidator

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class CustomValidator

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.AbstractValidator
        extended by com.bstek.dorado.view.data.validate.impl.CustomValidator
All Implemented Interfaces:
Element, EventSupported, Validator
public class CustomValidator
extends com.bstek.dorado.view.data.validate.impl.AbstractValidator

用户自定义数据校验对象

Version:
1.0

Constructor Summary
CustomValidator()
Method Summary
java.lang.String | getConcreteValidator() 取得具体的校验器格式
void | setConcreteValidator(java.lang.String concreteValidator) 设定具体的校验器格式
void | validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from class com.bstek.dorado.view.data.validate.impl.AbstractValidator
addEventHandler, eventHandlers, getErrorMessage, getEventHandler, getFinalErrorMessage, getTag, removeEventHandler, setErrorMessage, setTag, throwException
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CustomValidator

public CustomValidator()
Method Detail

validate

public void validate(java.lang.Object value)
              throws IllegalValueException
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据
Throws:
IllegalValueException

getConcreteValidator

public java.lang.String getConcreteValidator()
取得具体的校验器格式

Returns:
String

setConcreteValidator

public void setConcreteValidator(java.lang.String concreteValidator)
设定具体的校验器格式

Parameters:
concreteValidator - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LengthValidator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class LengthValidator

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.AbstractValidator
        extended by com.bstek.dorado.view.data.validate.impl.LengthValidator
All Implemented Interfaces:
Element, EventSupported, Validator
public class LengthValidator
extends com.bstek.dorado.view.data.validate.impl.AbstractValidator

长度校验器

用于校验一个数据(一般指字符串)的长度是否有效的校验器. 如果设定maxLength或minLength为0,则表示忽略对maxLength或minLength校验

Version:
4.0

Constructor Summary
LengthValidator()
Method Summary
int | getMaxLength() 返回最大长度值。
int | getMinLength() 取得最小长度值。
void | setMaxLength(int maxLength) 设定最大长度值。
void | setMinLength(int minLength) 设定最小长度值。
void | validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from class com.bstek.dorado.view.data.validate.impl.AbstractValidator
addEventHandler, eventHandlers, getErrorMessage, getEventHandler, getFinalErrorMessage, getTag, removeEventHandler, setErrorMessage, setTag, throwException
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LengthValidator

public LengthValidator()
Method Detail

validate

public void validate(java.lang.Object value)
              throws IllegalValueException
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据
Throws:
IllegalValueException

getMinLength

public int getMinLength()
取得最小长度值。

Returns:
int

setMinLength

public void setMinLength(int minLength)
设定最小长度值。

Parameters:
minLength - int

getMaxLength

public int getMaxLength()
返回最大长度值。

Returns:
int

setMaxLength

public void setMaxLength(int maxLength)
设定最大长度值。

Parameters:
maxLength - int
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListValidator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class ListValidator

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.AbstractValidator
        extended by com.bstek.dorado.view.data.validate.impl.ListValidator
All Implemented Interfaces:
Element, EventSupported, Validator
public class ListValidator
extends com.bstek.dorado.view.data.validate.impl.AbstractValidator

List值的校验对象
对于是否属于某一组值的校验

Version:
4.0

Constructor Summary
ListValidator()
Method Summary
java.lang.String | getValues() 取得校验器中的一组校验值
void | setValues(java.lang.String values) 设定指定的一组校验值
void | validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from class com.bstek.dorado.view.data.validate.impl.AbstractValidator
addEventHandler, eventHandlers, getErrorMessage, getEventHandler, getFinalErrorMessage, getTag, removeEventHandler, setErrorMessage, setTag, throwException
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ListValidator

public ListValidator()
Method Detail

validate

public void validate(java.lang.Object value)
              throws IllegalValueException
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据
Throws:
IllegalValueException

setValues

public void setValues(java.lang.String values)
设定指定的一组校验值

Parameters:
values - String

getValues

public java.lang.String getValues()
取得校验器中的一组校验值

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.data.validate.impl

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.data.validate.impl

数据校验器的实现 See:
Description

Class Summary
CustomValidator | 用户自定义数据校验对象
LengthValidator | 长度校验器 用于校验一个数据(一般指字符串)的长度是否有效的校验器.
ListValidator | List值的校验对象 对于是否属于某一组值的校验
PatternValidator | 基于正则表达式的校验对象
RangeValidator | 数值范围校验器 用于校验指定的数据是否在一个允许的范围内的校验器.例如可用于校验某字段中录入的内容必须在2000-10000之间.
RequiredValidator | 必需类型校验对象
ValidatorInfo | 校验信息对象

Package com.bstek.dorado.view.data.validate.impl Description

数据校验器的实现


PatternValidator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class PatternValidator

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.AbstractValidator
        extended by com.bstek.dorado.view.data.validate.impl.PatternValidator
All Implemented Interfaces:
Element, EventSupported, Validator
public class PatternValidator
extends com.bstek.dorado.view.data.validate.impl.AbstractValidator

基于正则表达式的校验对象

Version:
4.0

Constructor Summary
PatternValidator()
Method Summary
java.lang.String | getPattern() 获得正则表达式
void | setPattern(java.lang.String pattern) 设置正则表达式
void | validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from class com.bstek.dorado.view.data.validate.impl.AbstractValidator
addEventHandler, eventHandlers, getErrorMessage, getEventHandler, getFinalErrorMessage, getTag, removeEventHandler, setErrorMessage, setTag, throwException
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PatternValidator

public PatternValidator()
Method Detail

validate

public void validate(java.lang.Object value)
              throws IllegalValueException
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据
Throws:
IllegalValueException

getPattern

public java.lang.String getPattern()
获得正则表达式

Returns:
String

setPattern

public void setPattern(java.lang.String pattern)
设置正则表达式

Parameters:
pattern - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RangeValidator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class RangeValidator

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.AbstractValidator
        extended by com.bstek.dorado.view.data.validate.impl.RangeValidator
All Implemented Interfaces:
Element, EventSupported, Validator
public class RangeValidator
extends com.bstek.dorado.view.data.validate.impl.AbstractValidator

数值范围校验器

用于校验指定的数据是否在一个允许的范围内的校验器.例如可用于校验某字段中录入的内容必须在2000-10000之间.

Version:
4.0

Field Summary
static java.lang.String | ALLOW_EQUALS 范围校验类型 - 允许等于
static java.lang.String | IGNORE 范围校验类型 - 忽略
static java.lang.String | NOT_ALLOW_EQUALS 范围校验类型 - 不允许等于
Constructor Summary
RangeValidator()
Method Summary
double | getMax() 取得范围最大值
java.lang.String | getMaxMatchRule() 取得最大值匹配规则
double | getMin() 取得最小值
java.lang.String | getMinMatchRule() 取得最小值匹配规则
void | setMax(double max) 设定范围最大值
void | setMaxMatchRule(java.lang.String maxMatchRule) 设定最大值匹配规则.
void | setMin(double min) 设定范围的最小值
void | setMinMatchRule(java.lang.String minMatchRule) 设定最小值匹配规则 取值范围: ignore - 忽略 allow_equals - 允许等于 not_allow_equals - 不允许等于
void | validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from class com.bstek.dorado.view.data.validate.impl.AbstractValidator
addEventHandler, eventHandlers, getErrorMessage, getEventHandler, getFinalErrorMessage, getTag, removeEventHandler, setErrorMessage, setTag, throwException
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

IGNORE

public static final java.lang.String IGNORE
范围校验类型 - 忽略

See Also:
Constant Field Values

ALLOW_EQUALS

public static final java.lang.String ALLOW_EQUALS
范围校验类型 - 允许等于

See Also:
Constant Field Values

NOT_ALLOW_EQUALS

public static final java.lang.String NOT_ALLOW_EQUALS
范围校验类型 - 不允许等于

See Also:
Constant Field Values
Constructor Detail

RangeValidator

public RangeValidator()
Method Detail

validate

public void validate(java.lang.Object value)
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据

getMin

public double getMin()
取得最小值

Returns:
double

setMin

public void setMin(double min)
设定范围的最小值

Parameters:
min - double

getMinMatchRule

public java.lang.String getMinMatchRule()
取得最小值匹配规则

Returns:
String

setMinMatchRule

public void setMinMatchRule(java.lang.String minMatchRule)
设定最小值匹配规则
取值范围:
  • ignore - 忽略
  • allow_equals - 允许等于
  • not_allow_equals - 不允许等于

Parameters:
minMatchRule - String

getMax

public double getMax()
取得范围最大值

Returns:
double

setMax

public void setMax(double max)
设定范围最大值

Parameters:
max - double

getMaxMatchRule

public java.lang.String getMaxMatchRule()
取得最大值匹配规则

Returns:
String

setMaxMatchRule

public void setMaxMatchRule(java.lang.String maxMatchRule)
设定最大值匹配规则.
取值范围:
  • ignore - 忽略
  • allow_equals - 允许等于
  • not_allow_equals - 不允许等于

Parameters:
maxMatchRule - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredValidator

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class RequiredValidator

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.AbstractValidator
        extended by com.bstek.dorado.view.data.validate.impl.RequiredValidator
All Implemented Interfaces:
Element, EventSupported, Validator
public class RequiredValidator
extends com.bstek.dorado.view.data.validate.impl.AbstractValidator

必需类型校验对象

Version:
4.0

Constructor Summary
RequiredValidator()
Method Summary
 void validate(java.lang.Object value)
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
Methods inherited from class com.bstek.dorado.view.data.validate.impl.AbstractValidator
addEventHandler, eventHandlers, getErrorMessage, getEventHandler, getFinalErrorMessage, getTag, removeEventHandler, setErrorMessage, setTag, throwException
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequiredValidator

public RequiredValidator()
Method Detail

validate

public void validate(java.lang.Object value)
              throws IllegalValueException
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Parameters:
value - 要校验的数据
Throws:
IllegalValueException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorInfo

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.data.validate.impl
Class ValidatorInfo

java.lang.Object
    extended by com.bstek.dorado.view.data.validate.impl.ValidatorInfo
public class ValidatorInfo
extends java.lang.Object

校验信息对象

Version:
1.0

Constructor Summary
ValidatorInfo()
Method Summary
java.lang.String | getClazz() 取得校验信息的实现类名
java.lang.String | getErrorMessage() 返回一个对应的ErrorMessage。
void | setClazz(java.lang.String clazz) 设定校验信息的实现类名
void | setErrorMessage(java.lang.String errorMessage) 设定一个对应的ErrorMessage。
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidatorInfo

public ValidatorInfo()
Method Detail

getClazz

public java.lang.String getClazz()
取得校验信息的实现类名

Returns:
String

setClazz

public void setClazz(java.lang.String clazz)
设定校验信息的实现类名

Parameters:
clazz - String

getErrorMessage

public java.lang.String getErrorMessage()
返回一个对应的ErrorMessage。

Returns:
String

setErrorMessage

public void setErrorMessage(java.lang.String errorMessage)
设定一个对应的ErrorMessage。

Parameters:
errorMessage - String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BaseRPCHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.rpc
Class BaseRPCHandler

java.lang.Object
    extended by com.bstek.dorado.view.rpc.AbstractRPCHandler
        extended by com.bstek.dorado.view.rpc.BaseRPCHandler
All Implemented Interfaces:
RPCHandler
Direct Known Subclasses:
UpdateDataRPCHandler
public class BaseRPCHandler
extends com.bstek.dorado.view.rpc.AbstractRPCHandler

基本的远程方法调用的处理类

Version:
4.0

Field Summary
Fields inherited from interface com.bstek.dorado.view.rpc.RPCHandler
ATTRIBUTE_KEY, NO_FORWARD_ATTRIBUTE, PROCESSED_ATTRIBUTE_KEY
Constructor Summary
BaseRPCHandler()
Method Summary
protected ViewModel | doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
java.lang.String | getMethod() 取得本次数据更新操作将要调用的ViewModel中的方法名.
void | init(javax.servlet.http.HttpServletRequest request)
protected void | internalExecute()
ParameterSet | outParameters() 本次远程调用将要返回给客户端的参数集合.
Methods inherited from class com.bstek.dorado.view.rpc.AbstractRPCHandler
endCalling, execute, getMessage, getRequeryPath, getRequest, getViewModel, getViewModel, getXmlDocument, isExecuted, isSucceed, parameters, setError, setMessage, setSucceed
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BaseRPCHandler

public BaseRPCHandler()
Method Detail

init

public void init(javax.servlet.http.HttpServletRequest request)
          throws java.lang.Exception

Throws:
java.lang.Exception

doGetViewModel

protected ViewModel doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
                            throws java.lang.Exception

Throws:
java.lang.Exception

internalExecute

protected void internalExecute()
                        throws java.lang.Exception

Throws:
java.lang.Exception

getMethod

public java.lang.String getMethod()
取得本次数据更新操作将要调用的ViewModel中的方法名.

Returns:
String

outParameters

public ParameterSet outParameters()
本次远程调用将要返回给客户端的参数集合.

Returns:
ParameterSet
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LoadDataRPCHandler

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.rpc
Class LoadDataRPCHandler

java.lang.Object
    extended by com.bstek.dorado.view.rpc.AbstractRPCHandler
        extended by com.bstek.dorado.view.rpc.LoadDataRPCHandler
All Implemented Interfaces:
RPCHandler
public class LoadDataRPCHandler
extends com.bstek.dorado.view.rpc.AbstractRPCHandler

用于处理客户端发送的动态数据加载操作的处理类

Version:
4.0

Field Summary
Fields inherited from interface com.bstek.dorado.view.rpc.RPCHandler
ATTRIBUTE_KEY, NO_FORWARD_ATTRIBUTE, PROCESSED_ATTRIBUTE_KEY
Constructor Summary
LoadDataRPCHandler()
Method Summary
protected ViewModel | doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
ViewDataset | getViewDataset() 取得发送动态数据加载操作的Dataset.
void | init(javax.servlet.http.HttpServletRequest request)
protected void | internalExecute()
Methods inherited from class com.bstek.dorado.view.rpc.AbstractRPCHandler
endCalling, execute, getMessage, getRequeryPath, getRequest, getViewModel, getViewModel, getXmlDocument, isExecuted, isSucceed, parameters, setError, setMessage, setSucceed
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LoadDataRPCHandler

public LoadDataRPCHandler()
Method Detail

init

public void init(javax.servlet.http.HttpServletRequest request)
          throws java.lang.Exception

Throws:
java.lang.Exception

doGetViewModel

protected ViewModel doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
                            throws java.lang.Exception

Throws:
java.lang.Exception

internalExecute

protected void internalExecute()
                        throws java.lang.Exception

Throws:
java.lang.Exception

getViewDataset

public ViewDataset getViewDataset()
取得发送动态数据加载操作的Dataset.

Returns:
ViewDataset
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.bstek.dorado.view.rpc

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.bstek.dorado.view.rpc

用于处理客户端远程过程调用的相关类
See:
Description

Interface Summary
RPCHandler 来自客户端的远程方法调用的处理类

Class Summary
BaseRPCHandler | 基本的远程方法调用的处理类
LoadDataRPCHandler | 用于处理客户端发送的动态数据加载操作的处理类
RPCHelper | 远程过程调用的帮助类
UpdateDataRPCHandler | 用于处理客户端发送的动态数据更新操作的处理类

Package com.bstek.dorado.view.rpc Description

用于处理客户端远程过程调用的相关类

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


RPCHandler

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.rpc
Interface RPCHandler

All Known Implementing Classes:
com.bstek.dorado.view.rpc.AbstractRPCHandler
public interface RPCHandler

来自客户端的远程方法调用的处理类

Version:
4.0

Field Summary
static java.lang.String | ATTRIBUTE_KEY ATTRIBUTE_KEY
static java.lang.String | NO_FORWARD_ATTRIBUTE NO_FORWARD_ATTRIBUTE
static java.lang.String | PROCESSED_ATTRIBUTE_KEY PROCESSED_ATTRIBUTE_KEY
Method Summary
void | endCalling(java.lang.String qs) 完成远程调用方法.
boolean | execute() 执行默认的远程调用方法.
java.lang.String | getMessage() 取得本次远程调用将要返回给客户端的提示信息.
java.lang.String | getRequeryPath() 取得客户端收到调用完成指令后要重新请求的路径.
javax.servlet.http.HttpServletRequest | getRequest() 取得当前的HttpServletRequest对象.
ViewModel | getViewModel() 取得与客户端对应的ViewModel实例
XmlDocument | getXmlDocument() 取得客户端发送的XML信息
void | init(javax.servlet.http.HttpServletRequest request) 初试化远程方法调用的处理类
boolean | isExecuted() 此处理类是否已经执行过了
boolean | isSucceed() 取得本次远程调用是否已经成功.
ParameterSet | parameters() 取得客户端发送的参数集合.
void | setError(java.lang.Throwable t) 设定本次远程调用将要返回给客户端的异常.
void | setMessage(java.lang.String message) 设定本次远程调用将要返回给客户端的提示信息.
void | setSucceed(boolean succeed) 设定本次远程调用是否已经成功.

Field Detail

ATTRIBUTE_KEY

public static final java.lang.String ATTRIBUTE_KEY
ATTRIBUTE_KEY

See Also:
Constant Field Values

PROCESSED_ATTRIBUTE_KEY

public static final java.lang.String PROCESSED_ATTRIBUTE_KEY
PROCESSED_ATTRIBUTE_KEY

See Also:
Constant Field Values

NO_FORWARD_ATTRIBUTE

public static final java.lang.String NO_FORWARD_ATTRIBUTE
NO_FORWARD_ATTRIBUTE

See Also:
Constant Field Values
Method Detail

init

public void init(javax.servlet.http.HttpServletRequest request)
          throws java.lang.Exception
初试化远程方法调用的处理类

Parameters:
request - HttpServletRequest
Throws:
java.lang.Exception

getRequest

public javax.servlet.http.HttpServletRequest getRequest()
取得当前的HttpServletRequest对象.

Returns:
HttpServletRequest

getXmlDocument

public XmlDocument getXmlDocument()
取得客户端发送的XML信息

Returns:
XmlDocument

getViewModel

public ViewModel getViewModel()
取得与客户端对应的ViewModel实例

Returns:
ViewModel

parameters

public ParameterSet parameters()
取得客户端发送的参数集合.

Returns:
ParameterSet

execute

public boolean execute()
执行默认的远程调用方法.

Returns:
boolean

endCalling

public void endCalling(java.lang.String qs)
                throws java.lang.Exception
完成远程调用方法.

Parameters:
qs - String
Throws:
java.lang.Exception

isExecuted

public boolean isExecuted()
此处理类是否已经执行过了

Returns:
boolean

isSucceed

public boolean isSucceed()
取得本次远程调用是否已经成功.

Returns:
boolean

setSucceed

public void setSucceed(boolean succeed)
设定本次远程调用是否已经成功.

Parameters:
succeed - boolean

getMessage

public java.lang.String getMessage()
取得本次远程调用将要返回给客户端的提示信息.

Returns:
String

setMessage

public void setMessage(java.lang.String message)
设定本次远程调用将要返回给客户端的提示信息.

Parameters:
message - String

setError

public void setError(java.lang.Throwable t)
设定本次远程调用将要返回给客户端的异常.

Parameters:
t - Throwable

getRequeryPath

public java.lang.String getRequeryPath()
取得客户端收到调用完成指令后要重新请求的路径.(这是一个由dorado使用的内部方法)

Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RPCHelper

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.rpc
Class RPCHelper

java.lang.Object
    extended by com.bstek.dorado.view.rpc.RPCHelper
public final class RPCHelper
extends java.lang.Object

远程过程调用的帮助类

Version:
4.0

Method Summary
static boolean | execute(javax.servlet.http.HttpServletRequest request) 执行当前的远程过程调用的处理器
static BaseRPCHandler | getBaseHandler(javax.servlet.http.HttpServletRequest request) 获得一个基本远程过程调用的处理器
static RPCHandler | getHandler(javax.servlet.http.HttpServletRequest request) 获得一个远程过程调用的处理器
static LoadDataRPCHandler | getLoadDataHandler(javax.servlet.http.HttpServletRequest request) 获得一个动态数据加载过程的处理器
static UpdateDataRPCHandler | getUpdateDataHandler(javax.servlet.http.HttpServletRequest request) 获得一个数据提交过程的处理器
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getHandler

public static RPCHandler getHandler(javax.servlet.http.HttpServletRequest request)
                             throws java.lang.Exception
获得一个远程过程调用的处理器

Parameters:
request - HttpServletRequest
Returns:
RPCHandler
Throws:
java.lang.Exception

getBaseHandler

public static BaseRPCHandler getBaseHandler(javax.servlet.http.HttpServletRequest request)
                                     throws java.lang.Exception
获得一个基本远程过程调用的处理器

Parameters:
request - HttpServletRequest
Returns:
BaseRPCHandler
Throws:
java.lang.Exception

getUpdateDataHandler

public static UpdateDataRPCHandler getUpdateDataHandler(javax.servlet.http.HttpServletRequest request)
                                                 throws java.lang.Exception
获得一个数据提交过程的处理器

Parameters:
request - HttpServletRequest
Returns:
UpdateDataRPCHandler
Throws:
java.lang.Exception

getLoadDataHandler

public static LoadDataRPCHandler getLoadDataHandler(javax.servlet.http.HttpServletRequest request)
                                             throws java.lang.Exception
获得一个动态数据加载过程的处理器

Parameters:
request - HttpServletRequest
Returns:
LoadDataRPCHandler
Throws:
java.lang.Exception

execute

public static boolean execute(javax.servlet.http.HttpServletRequest request)
                       throws java.lang.Exception
执行当前的远程过程调用的处理器

Parameters:
request - HttpServletRequest
Returns:
boolean
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpdateDataRPCHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.bstek.dorado.view.rpc
Class UpdateDataRPCHandler

java.lang.Object
    extended by com.bstek.dorado.view.rpc.AbstractRPCHandler
        extended by com.bstek.dorado.view.rpc.BaseRPCHandler
            extended by com.bstek.dorado.view.rpc.UpdateDataRPCHandler
All Implemented Interfaces:
RPCHandler
public class UpdateDataRPCHandler
extends BaseRPCHandler

用于处理客户端发送的动态数据更新操作的处理类

Version:
4.0

Field Summary
Fields inherited from interface com.bstek.dorado.view.rpc.RPCHandler
ATTRIBUTE_KEY, NO_FORWARD_ATTRIBUTE, PROCESSED_ATTRIBUTE_KEY
Constructor Summary
UpdateDataRPCHandler()
Method Summary
protected ViewModel | doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
java.util.List | getReturnRecords() 取得本次数据更新操作完成后将要返回给客户端的记录的集合.
int | getTransactionMode() 取得本次数据更新操作的事务模式.
ViewDataset | getViewDataset(java.lang.String id) 根据id取得一个相应的ViewModel中的Dataset
void | init(javax.servlet.http.HttpServletRequest request)
protected void | internalExecute()
protected void | updateDataset(ViewModel viewModel, com.bstek.dorado.module.update.RecordInfo recordInfo)
Methods inherited from class com.bstek.dorado.view.rpc.BaseRPCHandler
getMethod, outParameters
Methods inherited from class com.bstek.dorado.view.rpc.AbstractRPCHandler
endCalling, execute, getMessage, getRequeryPath, getRequest, getViewModel, getViewModel, getXmlDocument, isExecuted, isSucceed, parameters, setError, setMessage, setSucceed
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UpdateDataRPCHandler

public UpdateDataRPCHandler()
Method Detail

init

public void init(javax.servlet.http.HttpServletRequest request)
          throws java.lang.Exception

Specified by:
init in interface RPCHandler
Overrides:
init in class BaseRPCHandler
Throws:
java.lang.Exception

doGetViewModel

protected ViewModel doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
                            throws java.lang.Exception

Overrides:
doGetViewModel in class BaseRPCHandler
Throws:
java.lang.Exception

internalExecute

protected void internalExecute()
                        throws java.lang.Exception

Overrides:
internalExecute in class BaseRPCHandler
Throws:
java.lang.Exception

updateDataset

protected void updateDataset(ViewModel viewModel,
                             com.bstek.dorado.module.update.RecordInfo recordInfo)

getTransactionMode

public int getTransactionMode()
取得本次数据更新操作的事务模式.

Returns:
int
See Also:
TransactionManager, Transaction

getViewDataset

public ViewDataset getViewDataset(java.lang.String id)
根据id取得一个相应的ViewModel中的Dataset

Parameters:
id - String
Returns:
ViewDataset

getReturnRecords

public java.util.List getReturnRecords()
取得本次数据更新操作完成后将要返回给客户端的记录的集合.

Returns:
List
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Generated Documentation (Untitled)

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Overview

All Classes

Packages
com.bstek.dorado.action
com.bstek.dorado.action.mapping
com.bstek.dorado.biz
com.bstek.dorado.common
com.bstek.dorado.common.ds
com.bstek.dorado.common.fileloader
com.bstek.dorado.common.log
com.bstek.dorado.common.rtexpr
com.bstek.dorado.common.rtexpr.impl
com.bstek.dorado.common.scope
com.bstek.dorado.data
com.bstek.dorado.data.custom
com.bstek.dorado.data.db
com.bstek.dorado.i18n
com.bstek.dorado.module
com.bstek.dorado.security
com.bstek.dorado.utils
com.bstek.dorado.utils.codec
com.bstek.dorado.utils.collection
com.bstek.dorado.utils.http
com.bstek.dorado.utils.variant
com.bstek.dorado.utils.xml
com.bstek.dorado.view
com.bstek.dorado.view.control
com.bstek.dorado.view.control.advance
com.bstek.dorado.view.control.autoform
com.bstek.dorado.view.control.command
com.bstek.dorado.view.control.dropdown
com.bstek.dorado.view.control.table
com.bstek.dorado.view.control.tabset
com.bstek.dorado.view.control.tree
com.bstek.dorado.view.data
com.bstek.dorado.view.data.validate
com.bstek.dorado.view.data.validate.impl
com.bstek.dorado.view.rpc


PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
com.bstek.dorado.action, com.bstek.dorado.action.mapping, com.bstek.dorado.biz, com.bstek.dorado.common, com.bstek.dorado.common.ds, com.bstek.dorado.common.fileloader, com.bstek.dorado.common.log, com.bstek.dorado.common.rtexpr, com.bstek.dorado.common.rtexpr.impl, com.bstek.dorado.common.scope, com.bstek.dorado.data, com.bstek.dorado.data.custom, com.bstek.dorado.data.db, com.bstek.dorado.i18n, com.bstek.dorado.module, com.bstek.dorado.security, com.bstek.dorado.utils, com.bstek.dorado.utils.codec, com.bstek.dorado.utils.collection, com.bstek.dorado.utils.http, com.bstek.dorado.utils.variant, com.bstek.dorado.utils.xml, com.bstek.dorado.view, com.bstek.dorado.view.control, com.bstek.dorado.view.control.advance, com.bstek.dorado.view.control.autoform, com.bstek.dorado.view.control.command, com.bstek.dorado.view.control.dropdown, com.bstek.dorado.view.control.table, com.bstek.dorado.view.control.tabset, com.bstek.dorado.view.control.tree, com.bstek.dorado.view.data, com.bstek.dorado.view.data.validate, com.bstek.dorado.view.data.validate.impl, com.bstek.dorado.view.rpc

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap (implements java.util.Map)
      • class com.bstek.dorado.i18n.ResourceManagerContextMap
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.command.Command
        • class com.bstek.dorado.view.control.command.CommandQueue
        • class com.bstek.dorado.view.control.command.QueryCommand
        • class com.bstek.dorado.view.control.command.RequestCommand
        • class com.bstek.dorado.view.control.command.RPCCommand
          • class com.bstek.dorado.view.control.command.UpdateCommand
      • class com.bstek.dorado.view.control.DataControl
        • class com.bstek.dorado.view.control.PlaceableDataControl (implements com.bstek.dorado.view.control.Placeable)
          • class com.bstek.dorado.view.control.autoform.AutoForm
          • class com.bstek.dorado.view.control.DataPilot (implements com.bstek.dorado.view.control.Visible)
          • class com.bstek.dorado.view.control.PagePilot (implements com.bstek.dorado.view.control.Visible)
          • class com.bstek.dorado.view.control.SimpleDataControl (implements com.bstek.dorado.view.control.Visible)
            • class com.bstek.dorado.view.control.Calendar
            • class com.bstek.dorado.view.control.DataLabel
            • class com.bstek.dorado.view.control.Editor
              • class com.bstek.dorado.view.control.CheckBox
              • class com.bstek.dorado.view.control.RadioGroup
              • class com.bstek.dorado.view.control.TextEditor
            • class com.bstek.dorado.view.control.FieldLabel
            • class com.bstek.dorado.view.control.ProgressBar
          • class com.bstek.dorado.view.control.table.Table (implements com.bstek.dorado.view.control.Visible)
            • class com.bstek.dorado.view.control.table.DataTable
              • class com.bstek.dorado.view.control.advance.TreeGrid
            • class com.bstek.dorado.view.control.table.StaticTable
      • class com.bstek.dorado.view.control.dropdown.DropDown
        • class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
          • class com.bstek.dorado.view.control.dropdown.CustomDropDown (implements com.bstek.dorado.view.control.dropdown.CachableDropDown)
            • class com.bstek.dorado.view.control.dropdown.DynamicDropDown (implements com.bstek.dorado.view.control.dropdown.CachableDropDown)
        • class com.bstek.dorado.view.control.dropdown.SimpleDropDown
          • class com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
            • class com.bstek.dorado.view.control.dropdown.DatasetDropDown
            • class com.bstek.dorado.view.control.dropdown.ListDropDown
          • class com.bstek.dorado.view.control.dropdown.DateDropDown
      • class com.bstek.dorado.view.control.Menu (implements com.bstek.dorado.view.control.MenuItemContainer)
      • class com.bstek.dorado.view.control.PlaceableControl (implements com.bstek.dorado.view.control.Placeable)
        • class com.bstek.dorado.view.control.Button (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.GroupBox (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.Label (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.MenuBar (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.OutlookBar (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.ScrollBar (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.SplitPanel (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.SubWindow (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.tabset.TabSet (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.tree.Tree (implements com.bstek.dorado.view.control.Visible)
          • class com.bstek.dorado.view.control.tree.DataTree
      • class com.bstek.dorado.view.control.Span
    • class com.bstek.dorado.data.AbstractField (implements com.bstek.dorado.data.Field)
      • class com.bstek.dorado.data.BaseField
        • class com.bstek.dorado.data.db.DBField
          • class com.bstek.dorado.data.db.AutoDBField
        • class com.bstek.dorado.view.data.ViewBaseField (implements com.bstek.dorado.view.data.ViewField)
      • class com.bstek.dorado.data.DummyField
      • class com.bstek.dorado.data.LookupField
        • class com.bstek.dorado.view.data.ViewLookupField (implements com.bstek.dorado.view.data.ViewField)
    • class com.bstek.dorado.view.rpc.AbstractRPCHandler (implements com.bstek.dorado.view.rpc.RPCHandler)
      • class com.bstek.dorado.view.rpc.BaseRPCHandler
        • class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
      • class com.bstek.dorado.view.rpc.LoadDataRPCHandler
    • class com.bstek.dorado.view.data.validate.impl.AbstractValidator (implements com.bstek.dorado.view.data.validate.Validator)
      • class com.bstek.dorado.view.data.validate.impl.CustomValidator
      • class com.bstek.dorado.view.data.validate.impl.LengthValidator
      • class com.bstek.dorado.view.data.validate.impl.ListValidator
      • class com.bstek.dorado.view.data.validate.impl.PatternValidator
      • class com.bstek.dorado.view.data.validate.impl.RangeValidator
      • class com.bstek.dorado.view.data.validate.impl.RequiredValidator
    • class com.bstek.dorado.action.mapping.ActionConfig (implements com.bstek.dorado.action.mapping.ActionTargetCollection)
    • class com.bstek.dorado.action.mapping.ActionTarget
      • class com.bstek.dorado.action.mapping.ActionException
      • class com.bstek.dorado.action.mapping.ActionForward
    • class com.bstek.dorado.data.db.AggregateMode
    • class com.bstek.dorado.data.db.AndOrMatchRule (implements com.bstek.dorado.data.db.MatchRule)
    • class com.bstek.dorado.utils.ClassHelper
    • class com.bstek.dorado.view.control.table.Column (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.table.ColumnGroup
        • class com.bstek.dorado.view.control.table.DataColumnGroup (implements com.bstek.dorado.view.EventSupported)
        • class com.bstek.dorado.view.control.table.StaticColumnGroup
      • class com.bstek.dorado.view.control.table.DataColumn
        • class com.bstek.dorado.view.control.table.EditableColumn (implements com.bstek.dorado.view.EventSupported)
        • class com.bstek.dorado.view.control.table.StaticColumn
    • class com.bstek.dorado.data.db.CommonMatchRule (implements com.bstek.dorado.data.db.MatchRule)
      • class com.bstek.dorado.data.db.BaseMatchRule
      • class com.bstek.dorado.data.db.SqlMatchRule
    • class com.bstek.dorado.common.ds.ConnectionHelper
    • class com.bstek.dorado.action.Constants
    • class com.bstek.dorado.action.Controller
      • class com.bstek.dorado.biz.FileController
    • class com.bstek.dorado.action.mapping.ControllerConfig
    • class com.bstek.dorado.action.ControllerManager
    • class com.bstek.dorado.data.DatasetAdapter (implements com.bstek.dorado.data.Dataset)
    • class com.bstek.dorado.view.control.command.DatasetInfo
    • class com.bstek.dorado.data.DatasetSupport (implements com.bstek.dorado.data.DataListener, com.bstek.dorado.data.Dataset)
      • class com.bstek.dorado.data.AbstractDataset
        • class com.bstek.dorado.data.custom.CustomDataset
        • class com.bstek.dorado.data.db.DBDataset
          • class com.bstek.dorado.data.db.AutoSqlDataset
          • class com.bstek.dorado.data.db.SqlDataset
        • class com.bstek.dorado.view.data.ViewDatasetSupport (implements com.bstek.dorado.view.data.ViewDataset)
          • class com.bstek.dorado.view.data.AbstractViewDataset
            • class com.bstek.dorado.view.data.AbstractDatasetReference
              • class com.bstek.dorado.view.data.DatasetReference
                • class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset
              • class com.bstek.dorado.view.data.DatasetWrapper
            • class com.bstek.dorado.view.data.CustomDataset
            • class com.bstek.dorado.view.data.DODataset
            • class com.bstek.dorado.view.data.FormDataset
          • class com.bstek.dorado.view.data.ViewDatasetAdapter
    • class com.bstek.dorado.utils.variant.DataType
    • class com.bstek.dorado.data.db.DBStatement
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class com.bstek.dorado.utils.SystemVariable
    • class com.bstek.dorado.common.DoradoContext
      • class com.bstek.dorado.common.AbstractDoradoContext
        • class com.bstek.dorado.common.HttpDoradoContext
    • class com.bstek.dorado.data.DOSet
    • class com.bstek.dorado.data.DOUtils
    • class com.bstek.dorado.view.control.dropdown.DropDownItem
    • class com.bstek.dorado.utils.codec.Encrypt
    • class com.bstek.dorado.utils.codec.EncryptCode
    • class com.bstek.dorado.utils.codec.EscapeUtils
    • class com.bstek.dorado.view.Event
    • class com.bstek.dorado.view.EventConfig
    • class com.bstek.dorado.view.EventHandler
    • class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
    • class com.bstek.dorado.common.rtexpr.ExprHelper
    • class com.bstek.dorado.data.FieldSet (implements java.io.Serializable)
    • class com.bstek.dorado.common.fileloader.FileLoader
    • class com.bstek.dorado.view.control.autoform.FormElement (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.autoform.ControlFormElement
        • class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
        • class com.bstek.dorado.view.control.autoform.CustomFormElement
        • class com.bstek.dorado.view.control.autoform.LabelFormElement
        • class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
        • class com.bstek.dorado.view.control.autoform.TextEditorFormElement
      • class com.bstek.dorado.view.control.autoform.FormElementRenderer
    • class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl (implements com.bstek.dorado.view.control.autoform.FormElementFactory)
    • class com.bstek.dorado.view.control.autoform.FormGroup (implements com.bstek.dorado.view.Element)
    • class com.bstek.dorado.view.control.autoform.FormGroupGround
    • class com.bstek.dorado.view.control.command.Frame
    • class com.bstek.dorado.common.HttpContextFactory
    • class com.bstek.dorado.data.Index
    • class com.bstek.dorado.data.db.JoinTable
    • class com.bstek.dorado.view.JspHelper
    • class com.bstek.dorado.view.control.autoform.LayoutInfo
    • class com.bstek.dorado.i18n.LocaleHelper
    • class com.bstek.dorado.common.log.Log
    • class com.bstek.dorado.action.mapping.Mapping
    • class com.bstek.dorado.view.data.MasterDetailLink
    • class com.bstek.dorado.view.control.MenuItem (implements com.bstek.dorado.view.control.MenuItemContainer)
    • class com.bstek.dorado.common.MessageHelper
    • class com.bstek.dorado.module.ModuleManager
    • class com.bstek.dorado.module.ModuleSupport (implements com.bstek.dorado.module.Module)
      • class com.bstek.dorado.module.DefaultModule
    • class com.bstek.dorado.utils.collection.ObjectList (implements com.bstek.dorado.utils.collection.ObjectCollection, java.io.Serializable)
    • class com.bstek.dorado.view.control.OutlookBarGroup (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.DefaultOutlookBarGroup
      • class com.bstek.dorado.view.control.MenuOutlookBarGroup
    • class com.bstek.dorado.data.PagingHelper
    • class com.bstek.dorado.utils.Printf
    • class com.bstek.dorado.data.ReadRecord
      • class com.bstek.dorado.data.Record (implements java.lang.Cloneable, java.io.Serializable)
        • class com.bstek.dorado.data.BaseRecord
          • class com.bstek.dorado.data.DORecord
            • class com.bstek.dorado.view.data.ViewRecord
    • class com.bstek.dorado.data.RecordIterator (implements java.util.Iterator)
    • class com.bstek.dorado.data.RecordSet (implements java.io.Serializable)
    • class com.bstek.dorado.data.RecordWrapper
    • class com.bstek.dorado.utils.http.RequestHelper
    • class com.bstek.dorado.i18n.ResourceManager
    • class com.bstek.dorado.utils.http.ResponseUtil
    • class com.bstek.dorado.view.rpc.RPCHelper
    • class com.bstek.dorado.utils.codec.SafeCode
    • class com.bstek.dorado.common.scope.Scope
    • class com.bstek.dorado.common.scope.ScopeHelper
    • class com.bstek.dorado.common.Setting
    • class com.bstek.dorado.data.db.SortRule
    • class com.bstek.dorado.utils.StringHelper
    • class com.bstek.dorado.utils.SynchroTimer
    • class com.bstek.dorado.view.control.tabset.TabElement (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.tabset.FrameTab
      • class com.bstek.dorado.view.control.tabset.Tab
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class com.bstek.dorado.utils.DoradoException
          • class com.bstek.dorado.action.ActionNotSuppertedException
          • class com.bstek.dorado.action.ControllerNotFoundException
          • class com.bstek.dorado.utils.xml.LoadXmlPropertyException
          • class com.bstek.dorado.utils.xml.XmlParseException
        • class java.lang.RuntimeException
          • class com.bstek.dorado.utils.DoradoRuntimeException
            • class com.bstek.dorado.security.AccessDeniedException
              • class com.bstek.dorado.security.UserNotLoggedInException
            • class com.bstek.dorado.utils.collection.DuplicateKeyException
            • class com.bstek.dorado.data.FieldNotExistException
            • class com.bstek.dorado.view.data.validate.IllegalValueException
            • class com.bstek.dorado.utils.InvalidPropertyValueException
            • class com.bstek.dorado.utils.collection.KeyNotExistException
            • class com.bstek.dorado.data.NoCurrentRecordException
    • class com.bstek.dorado.common.TransactionManager
    • class com.bstek.dorado.view.control.tree.TreeLevel
      • class com.bstek.dorado.view.control.tree.BindingTreeLevel
        • class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
        • class com.bstek.dorado.view.control.tree.SimpleTreeLevel
    • class com.bstek.dorado.view.control.tree.TreeNode (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.tree.DefaultTreeNode
      • class com.bstek.dorado.view.control.tree.RecordTreeNode
    • class com.bstek.dorado.utils.UniqueKey
    • class com.bstek.dorado.action.mapping.Unit (implements com.bstek.dorado.action.mapping.ActionTargetCollection)
      • class com.bstek.dorado.action.mapping.GlobalUnit
      • class com.bstek.dorado.action.mapping.SubUnit
    • class com.bstek.dorado.utils.http.UrlUtil
    • class com.bstek.dorado.common.UserConfig
    • class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
    • class com.bstek.dorado.utils.variant.Variant (implements java.lang.Cloneable, java.io.Serializable)
    • class com.bstek.dorado.utils.variant.VariantHelper
    • class com.bstek.dorado.utils.variant.VariantSet (implements java.lang.Cloneable, java.io.Serializable)
      • class com.bstek.dorado.data.db.CaseInsensitiveVariantSet
      • class com.bstek.dorado.utils.MetaData
      • class com.bstek.dorado.data.ParameterSet
    • class com.bstek.dorado.view.ViewModelSupport (implements com.bstek.dorado.view.ViewModel)
      • class com.bstek.dorado.view.DefaultViewModel
        • class com.bstek.dorado.view.control.dropdown.DropDownViewModel
          • class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
          • class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
    • class com.bstek.dorado.utils.xml.XmlConfigUtils
    • class com.bstek.dorado.utils.xml.XmlFactory

Interface Hierarchy

  • interface com.bstek.dorado.security.AccessChecker
  • interface com.bstek.dorado.action.Action
  • interface com.bstek.dorado.action.mapping.ActionTargetCollection
  • interface com.bstek.dorado.view.control.dropdown.CachableDropDown
  • interface java.lang.Cloneable
    • interface com.bstek.dorado.utils.collection.ObjectCollection
  • interface com.bstek.dorado.view.Element
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.EventSupported)
      • interface com.bstek.dorado.view.control.Control
      • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.data.Dataset)
    • interface com.bstek.dorado.view.control.Control
    • interface com.bstek.dorado.view.control.MenuItemContainer
    • interface com.bstek.dorado.view.data.validate.Validator (also extends com.bstek.dorado.view.EventSupported)
    • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.view.Component, com.bstek.dorado.data.Dataset)
    • interface com.bstek.dorado.view.data.ViewField (also extends com.bstek.dorado.data.Field)
    • interface com.bstek.dorado.view.ViewModel (also extends com.bstek.dorado.view.EventSupported)
  • interface java.util.EventListener
    • interface com.bstek.dorado.data.DataListener
    • interface com.bstek.dorado.data.DatasetListener
    • interface com.bstek.dorado.data.RecordListener
  • interface com.bstek.dorado.view.EventSupported
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.Element)
      • interface com.bstek.dorado.view.control.Control
      • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.data.Dataset)
    • interface com.bstek.dorado.view.control.Control
    • interface com.bstek.dorado.view.data.validate.Validator (also extends com.bstek.dorado.view.Element)
    • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.view.Component, com.bstek.dorado.data.Dataset)
    • interface com.bstek.dorado.view.ViewModel (also extends com.bstek.dorado.view.Element)
  • interface com.bstek.dorado.data.Field
    • interface com.bstek.dorado.view.data.ViewField (also extends com.bstek.dorado.view.Element)
  • interface com.bstek.dorado.data.db.MatchRule
  • interface com.bstek.dorado.view.control.Placeable
    • interface com.bstek.dorado.view.control.Visible
  • interface com.bstek.dorado.data.RecordFilter
  • interface com.bstek.dorado.view.rpc.RPCHandler
  • interface java.io.Serializable
    • interface com.bstek.dorado.data.Dataset
      • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.view.Component)
    • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.view.Component, com.bstek.dorado.data.Dataset)
  • interface com.bstek.dorado.common.Transaction
  • interface com.bstek.dorado.utils.xml.XmlBuilder
  • interface com.bstek.dorado.utils.xml.XmlDocument
  • interface com.bstek.dorado.utils.xml.XmlNode
  • interface com.bstek.dorado.utils.xml.XmlOutputter
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


The front page has been relocated.Please see:
Frame version
Non-frame version.


Serialized Form

Class com.bstek.dorado.security.AccessDeniedException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.action.ActionNotSuppertedException extends DoradoException implements Serializable

Class com.bstek.dorado.data.db.AutoSqlDataset extends DBDataset implements Serializable

Serialized Fields

_joins

ObjectCollection _joins

_matchRules

java.util.List _matchRules

_sortRules

java.util.List _sortRules

selectAllField

boolean selectAllField

distinct

boolean distinct

Class com.bstek.dorado.data.BaseRecord extends Record implements Serializable

Serialized Fields

values

java.util.Map values

Class com.bstek.dorado.data.db.CaseInsensitiveVariantSet extends VariantSet implements Serializable

Class com.bstek.dorado.action.ControllerNotFoundException extends DoradoException implements Serializable

Class com.bstek.dorado.data.custom.CustomDataset extends com.bstek.dorado.data.AbstractDataset implements Serializable

Class com.bstek.dorado.view.data.CustomDataset extends com.bstek.dorado.view.data.AbstractViewDataset implements Serializable

Class com.bstek.dorado.data.DatasetAdapter extends java.lang.Object implements Serializable

Serialized Fields

target

Dataset target

Class com.bstek.dorado.view.data.DatasetReference extends com.bstek.dorado.view.data.AbstractDatasetReference implements Serializable

Serialized Fields

sourceModule

java.lang.String sourceModule

sourceDataset

java.lang.String sourceDataset

Class com.bstek.dorado.data.DatasetSupport extends java.lang.Object implements Serializable

Serialized Fields

NULL_VALUE

java.lang.String NULL_VALUE
See Also:
Constant Field Values

id

java.lang.String id

fieldFactory

com.bstek.dorado.data.FieldFactory fieldFactory

recordFactory

com.bstek.dorado.data.RecordFactory recordFactory

oldRecords

java.util.Map oldRecords

lookupInfos

java.util.List lookupInfos

currentWrapper

RecordWrapper currentWrapper

current

Record current

isFirst

boolean isFirst

isLast

boolean isLast

recordFilter

RecordFilter recordFilter

autoCreateFields

boolean autoCreateFields

pageSize

int pageSize

state

int state

objectClazz

java.lang.Class objectClazz

maxPropertyLevel

int maxPropertyLevel

counterForLoad

int counterForLoad

fieldsCreated

boolean fieldsCreated

_fieldset

FieldSet _fieldset

_recordset

RecordSet _recordset

_parameters

ParameterSet _parameters

_properties

MetaData _properties

makingOldRecord

boolean makingOldRecord

Class com.bstek.dorado.view.data.DatasetWrapper extends com.bstek.dorado.view.data.AbstractDatasetReference implements Serializable

Serialized Fields

wrappedDataset

Dataset wrappedDataset

Class com.bstek.dorado.data.db.DBDataset extends com.bstek.dorado.data.AbstractDataset implements Serializable

Serialized Fields

dataSource

java.lang.String dataSource

dialect

com.bstek.dorado.data.db.dialect.Dialect dialect

originTable

java.lang.String originTable

keyFields

java.lang.String keyFields

retrieveAfterUpdate

boolean retrieveAfterUpdate

dbCharSet

java.lang.String dbCharSet

logicCharSet

java.lang.String logicCharSet

needToTranslateCharSet

boolean needToTranslateCharSet

psPool

org.apache.commons.pool.impl.GenericKeyedObjectPool psPool

fieldsCreated

boolean fieldsCreated

Class com.bstek.dorado.view.data.DODataset extends com.bstek.dorado.view.data.AbstractViewDataset implements Serializable

Serialized Fields

MAX_RECORD_COUNT

int MAX_RECORD_COUNT
See Also:
Constant Field Values

contextAttribute

java.lang.String contextAttribute

supportsPaging

boolean supportsPaging

Class com.bstek.dorado.utils.DoradoException extends java.lang.Exception implements Serializable

Class com.bstek.dorado.utils.DoradoRuntimeException extends java.lang.RuntimeException implements Serializable

Class com.bstek.dorado.data.DORecord extends BaseRecord implements Serializable

Serialized Fields

DO

java.lang.Object DO

Class com.bstek.dorado.utils.collection.DuplicateKeyException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset extends DatasetReference implements Serializable

Class com.bstek.dorado.data.FieldNotExistException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.data.FieldSet extends java.lang.Object implements Serializable

Serialized Fields

fields

ObjectCollection fields

Class com.bstek.dorado.view.data.FormDataset extends com.bstek.dorado.view.data.AbstractViewDataset implements Serializable

Class com.bstek.dorado.view.data.validate.IllegalValueException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.utils.InvalidPropertyValueException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.utils.collection.KeyNotExistException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.utils.xml.LoadXmlPropertyException extends DoradoException implements Serializable

Class com.bstek.dorado.utils.MetaData extends VariantSet implements Serializable

Class com.bstek.dorado.data.NoCurrentRecordException extends DoradoRuntimeException implements Serializable

Class com.bstek.dorado.utils.collection.ObjectList extends java.lang.Object implements Serializable

Serialized Fields

objects

org.apache.commons.collections.map.LinkedMap objects

Class com.bstek.dorado.data.ParameterSet extends VariantSet implements Serializable

Serialized Fields

nameMap

java.util.Map nameMap

Class com.bstek.dorado.data.Record extends ReadRecord implements Serializable

Serialized Fields

recordId

long recordId

deleted

boolean deleted

Class com.bstek.dorado.data.RecordSet extends java.lang.Object implements Serializable

Serialized Fields

_size

int _size

map

java.util.Map map

first

RecordWrapper first

last

RecordWrapper last

pageIndex

int pageIndex

pageCount

int pageCount

loadedPages

java.util.Set loadedPages

possibleCount

int possibleCount

Class com.bstek.dorado.data.db.SqlDataset extends DBDataset implements Serializable

Serialized Fields

sql

java.lang.String sql

countSql

java.lang.String countSql

Class com.bstek.dorado.utils.SystemVariable extends java.util.Properties implements Serializable

Class com.bstek.dorado.security.UserNotLoggedInException extends AccessDeniedException implements Serializable

Class com.bstek.dorado.utils.variant.Variant extends java.lang.Object implements Serializable

Serialized Fields

dataType

int dataType

value

java.lang.Object value

Class com.bstek.dorado.utils.variant.VariantSet extends java.lang.Object implements Serializable

Serialized Fields

values

ObjectCollection values

Class com.bstek.dorado.view.data.ViewDatasetAdapter extends ViewDatasetSupport implements Serializable

Serialized Fields

target

ViewDataset target

Class com.bstek.dorado.view.data.ViewDatasetSupport extends com.bstek.dorado.data.AbstractDataset implements Serializable

Serialized Fields

MAX_RECORD_COUNT

int MAX_RECORD_COUNT
See Also:
Constant Field Values

viewModel

ViewModel viewModel

_eventHandlers

java.util.Map _eventHandlers

masterLink

MasterDetailLink masterLink

ignored

boolean ignored

readOnly

boolean readOnly

autoLoadPage

boolean autoLoadPage

autoLoadData

boolean autoLoadData

async

boolean async

showLoadingTip

boolean showLoadingTip

loadDataAction

java.lang.String loadDataAction

noClient

boolean noClient

insertOnEmpty

boolean insertOnEmpty

tag

java.lang.String tag

emptyRecordSet

RecordSet emptyRecordSet

detailDOLoaded

boolean detailDOLoaded

Class com.bstek.dorado.view.data.ViewRecord extends DORecord implements Serializable

Class com.bstek.dorado.utils.xml.XmlParseException extends DoradoException implements Serializable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.action
Interfaces
Action
Classes
Constants
Controller
ControllerManager
Exceptions
ActionNotSuppertedException
ControllerNotFoundException


com.bstek.dorado.action Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.action

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.action.Constants
    • class com.bstek.dorado.action.Controller
    • class com.bstek.dorado.action.ControllerManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class com.bstek.dorado.utils.DoradoException
          • class com.bstek.dorado.action.ActionNotSuppertedException
          • class com.bstek.dorado.action.ControllerNotFoundException

Interface Hierarchy

  • interface com.bstek.dorado.action.Action
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package com.bstek.dorado.action

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.action

Packages that use com.bstek.dorado.action
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类

Classes in com.bstek.dorado.action used by com.bstek.dorado.action
Action
Action的接口 在运行时创建的对象，当用户激活一个Action时系统会自动创建此对象。
Controller
在运行时的Controller对象，当用户激活一个Controller时系统会自动创建此对象。

Classes in com.bstek.dorado.action used by com.bstek.dorado.biz
Action
Action的接口 在运行时创建的对象，当用户激活一个Action时系统会自动创建此对象。
Controller
在运行时的Controller对象，当用户激活一个Controller时系统会自动创建此对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.action.Action

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.action.Action

Packages that use Action
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类

Uses of Action in com.bstek.dorado.action

Methods in com.bstek.dorado.action that return Action
 Action Action.getPrevAction()
返回在本次请求中上一个被处理的Action对象

Methods in com.bstek.dorado.action with parameters of type Action
ActionForward | Controller.doAction(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 执行默认的Action。
protected ActionForward | Controller.doDispatch(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 系统内部用于完成分派Action处理的方法。
protected static void | Controller.processException(java.lang.Throwable t, Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 处理一个在Action执行过程中发生的异常。
protected void | Controller.checkAccess(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 按系统默认的方式判断当前用户是否已登录

Uses of Action in com.bstek.dorado.biz

Methods in com.bstek.dorado.biz with parameters of type Action
ActionForward | FileController.doUpload(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 执行文件上传
ActionForward | FileController.doOutput(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 直接把文件显示到浏览器中
ActionForward | FileController.doDownload(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 文件下载

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.ActionNotSuppertedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.ActionNotSuppertedException

No usage of com.bstek.dorado.action.ActionNotSuppertedException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.Constants

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.Constants

No usage of com.bstek.dorado.action.Constants

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.Controller

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.Controller

Packages that use Controller
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类

Uses of Controller in com.bstek.dorado.action

Methods in com.bstek.dorado.action that return Controller
Controller | Action.getController() getController
static Controller | ControllerManager.getController(javax.servlet.http.HttpServletRequest request, java.lang.String name) 根据给定名称从指定的资源中查找并返回一个Controller的实例。

Uses of Controller in com.bstek.dorado.biz

Subclasses of Controller in com.bstek.dorado.biz
 class FileController
用于协助用户完成文件上传和下载的Controller.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.ControllerManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.ControllerManager

No usage of com.bstek.dorado.action.ControllerManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.ControllerNotFoundException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.ControllerNotFoundException

No usage of com.bstek.dorado.action.ControllerNotFoundException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.action.mapping
Interfaces
ActionTargetCollection
Classes
ActionConfig
ActionException
ActionForward
ActionTarget
ControllerConfig
GlobalUnit
Mapping
SubUnit
Unit


com.bstek.dorado.action.mapping Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.action.mapping

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.action.mapping.ActionConfig (implements com.bstek.dorado.action.mapping.ActionTargetCollection)
    • class com.bstek.dorado.action.mapping.ActionTarget
      • class com.bstek.dorado.action.mapping.ActionException
      • class com.bstek.dorado.action.mapping.ActionForward
    • class com.bstek.dorado.action.mapping.ControllerConfig
    • class com.bstek.dorado.action.mapping.Mapping
    • class com.bstek.dorado.action.mapping.Unit (implements com.bstek.dorado.action.mapping.ActionTargetCollection)
      • class com.bstek.dorado.action.mapping.GlobalUnit
      • class com.bstek.dorado.action.mapping.SubUnit

Interface Hierarchy

  • interface com.bstek.dorado.action.mapping.ActionTargetCollection


Uses of Package com.bstek.dorado.action.mapping

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.action.mapping

Packages that use com.bstek.dorado.action.mapping
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类

Classes in com.bstek.dorado.action.mapping used by com.bstek.dorado.action
ActionConfig
对应一个Action的Mapping配置信息
ActionException
Request的跳转目标。
ActionForward
Request的跳转目标。
ControllerConfig
对应一个Controller的Mapping配置信息

Classes in com.bstek.dorado.action.mapping used by com.bstek.dorado.action.mapping
ActionConfig
对应一个Action的Mapping配置信息
ActionException
Request的跳转目标。
ActionForward
Request的跳转目标。
ActionTarget
Request的跳转目标。
ActionTargetCollection
用于管理一组ActionForward和ActionException的对象
ControllerConfig
对应一个Controller的Mapping配置信息
GlobalUnit
全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。
Mapping
用于管理所有Mapping配置信息的对象
Unit
对应一个Mapping配置文件，用于管理其中所有的配置信息

Classes in com.bstek.dorado.action.mapping used by com.bstek.dorado.biz
ActionForward
Request的跳转目标。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.ActionConfig

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.ActionConfig

Packages that use ActionConfig
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象

Uses of ActionConfig in com.bstek.dorado.action

Methods in com.bstek.dorado.action that return ActionConfig
 ActionConfig Action.getConfig()
取得对应的ActionConfig

Methods in com.bstek.dorado.action with parameters of type ActionConfig
 void Action.init(ActionConfig config, javax.servlet.ServletRequest request)
初始化Action对象

Uses of ActionConfig in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that return ActionConfig
ActionConfig | ControllerConfig.getAction(int index) 根据索引号得到一个ActionConfig
ActionConfig | ControllerConfig.getAction(java.lang.String name) 根据给定的别名查找一个ActionConfig

Methods in com.bstek.dorado.action.mapping with parameters of type ActionConfig
 void ControllerConfig.addAction(ActionConfig action)
添加一个ActionConfig

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.ActionException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.ActionException

Packages that use ActionException
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象

Uses of ActionException in com.bstek.dorado.action

Methods in com.bstek.dorado.action that return ActionException
 ActionException Action.findException(java.lang.Throwable t)
根据一个给定的Throwable对象查找一个可用的ActionException对象。

Uses of ActionException in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that return ActionException
ActionException | ActionConfig.findException(java.lang.Throwable t) 根据一个给定的Throwable对象查找一个可用的ActionException对象。
ActionException | ActionConfig.getException(java.lang.Throwable t) 根据给定的异常得到一个ActionException子对象
ActionException | ActionConfig.getException(int index) 根据给定的索引号得到一个ActionException子对象
ActionException | ActionTargetCollection.getException(java.lang.Throwable t) 根据给定的异常得到一个ActionException子对象
ActionException | ActionTargetCollection.getException(int index) 根据给定的索引号得到一个ActionException子对象
ActionException | Mapping.findException(java.lang.Throwable t) 根据给定的异常查找一个全局的ActionException对象，即在global中定义的ActionException。
ActionException | Unit.getException(java.lang.Throwable t) 根据给定的异常得到一个ActionException子对象
ActionException | Unit.getException(int index) 根据给定的索引号得到一个ActionException子对象

Methods in com.bstek.dorado.action.mapping with parameters of type ActionException
void | ActionConfig.addException(ActionException exception) 添加一个ActionException子对象
void | ActionTargetCollection.addException(ActionException exception) 添加一个ActionException子对象
void | Unit.addException(ActionException exception) 添加一个ActionException子对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.ActionForward

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.ActionForward

Packages that use ActionForward
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类

Uses of ActionForward in com.bstek.dorado.action

Methods in com.bstek.dorado.action that return ActionForward
ActionForward | Action.findForward(java.lang.String name) 根据别名查找一个可用的ActionForward对象。
ActionForward | Action.findDefaultForward() 查找一个默认的ActionForward对象。
ActionForward | Action.newForward(java.lang.String path) 用给定的path创建并返回一个临时的ActionForward对象。
ActionForward | Action.newForward(java.lang.String path, boolean redirect) 用给定的path创建并返回一个临时的ActionForward对象。
ActionForward | Controller.doAction(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 执行默认的Action。
protected ActionForward | Controller.doDispatch(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 系统内部用于完成分派Action处理的方法。

Methods in com.bstek.dorado.action with parameters of type ActionForward
protected  void Controller.processForward(javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response, ActionForward forward)
处理Action的转向。

Uses of ActionForward in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that return ActionForward
ActionForward | ActionConfig.findForward(java.lang.String name) 根据别名查找一个可用的ActionForward对象。
ActionForward | ActionConfig.findDefaultForward() 查找一个默认的ActionForward对象。
ActionForward | ActionConfig.getForward(java.lang.String name) 根据给定的别名得到一个ActionForward子对象
ActionForward | ActionConfig.getForward(int index) 根据给定的索引号得到一个ActionForward子对象
ActionForward | ActionTargetCollection.getForward(java.lang.String name) 根据给定的别名得到一个ActionForward子对象
ActionForward | ActionTargetCollection.getForward(int index) 根据给定的索引号得到一个ActionForward子对象
ActionForward | Mapping.findForward(java.lang.String name) 根据给定的别名查找一个全局的ActionForward对象，即在global中定义的ActionForward。
ActionForward | Unit.createTempForward(java.lang.String path) 创建一个临时的Forward对象。
ActionForward | Unit.findForward(java.lang.String name) 根据别名在配置单元中查找一个ActionForward对象
ActionForward | Unit.getForward(java.lang.String name) 根据给定的别名得到一个ActionForward子对象
ActionForward | Unit.getForward(int index) 根据给定的索引号得到一个ActionForward子对象

Methods in com.bstek.dorado.action.mapping with parameters of type ActionForward
void | ActionConfig.addForward(ActionForward forward) 添加一个ActionForward子对象
void | ActionTargetCollection.addForward(ActionForward forward) 添加一个ActionForward子对象
void | Unit.addForward(ActionForward forward) 添加一个ActionForward子对象

Uses of ActionForward in com.bstek.dorado.biz

Methods in com.bstek.dorado.biz that return ActionForward
ActionForward | FileController.doUpload(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 执行文件上传
ActionForward | FileController.doOutput(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 直接把文件显示到浏览器中
ActionForward | FileController.doDownload(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response) 文件下载

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.ActionTarget

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.ActionTarget

Packages that use ActionTarget
com.bstek.dorado.action.mapping Dorado Controller的Mapping配置信息的解析和管理对象

Uses of ActionTarget in com.bstek.dorado.action.mapping

Subclasses of ActionTarget in com.bstek.dorado.action.mapping
class | ActionException Request的跳转目标。
class | ActionForward Request的跳转目标。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.action.mapping.ActionTargetCollection

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.action.mapping.ActionTargetCollection

Packages that use ActionTargetCollection
com.bstek.dorado.action.mapping Dorado Controller的Mapping配置信息的解析和管理对象

Uses of ActionTargetCollection in com.bstek.dorado.action.mapping

Classes in com.bstek.dorado.action.mapping that implement ActionTargetCollection
class | ActionConfig 对应一个Action的Mapping配置信息
class | GlobalUnit 全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。
class | SubUnit 子配置单元的Mapping配置信息。
class | Unit 对应一个Mapping配置文件，用于管理其中所有的配置信息

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.ControllerConfig

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.ControllerConfig

Packages that use ControllerConfig
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象

Uses of ControllerConfig in com.bstek.dorado.action

Methods in com.bstek.dorado.action that return ControllerConfig
 ControllerConfig Controller.getConfig()
取得对应的ControllerConfig对象

Methods in com.bstek.dorado.action with parameters of type ControllerConfig
 void Controller.setConfig(ControllerConfig config)
设定Controller对应的Mapping配置信息。

Uses of ControllerConfig in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that return ControllerConfig
ControllerConfig | ActionConfig.getController() 取得该Action所属的Controller对象
ControllerConfig | Mapping.findController(java.lang.String name) 根据给定的别名查找一个Controller对象
ControllerConfig | Unit.getController(java.lang.String name) 根据别名查找一个Controller的配置信息

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.GlobalUnit

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.GlobalUnit

Packages that use GlobalUnit
com.bstek.dorado.action.mapping Dorado Controller的Mapping配置信息的解析和管理对象

Uses of GlobalUnit in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that return GlobalUnit
 GlobalUnit Mapping.getGlobalUnit()
取得global配置单元对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.Mapping

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.Mapping

Packages that use Mapping
com.bstek.dorado.action.mapping Dorado Controller的Mapping配置信息的解析和管理对象

Uses of Mapping in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that return Mapping
static Mapping Mapping.getInstance()
取得单例对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.SubUnit

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.SubUnit

No usage of com.bstek.dorado.action.mapping.SubUnit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.action.mapping.Unit

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.action.mapping.Unit

Packages that use Unit
com.bstek.dorado.action.mapping Dorado Controller的Mapping配置信息的解析和管理对象

Uses of Unit in com.bstek.dorado.action.mapping

Subclasses of Unit in com.bstek.dorado.action.mapping
class | GlobalUnit 全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。
class | SubUnit 子配置单元的Mapping配置信息。

Methods in com.bstek.dorado.action.mapping that return Unit
Unit | ActionTarget.getUnit() 返回此对象所隶属的Unit。
Unit | ControllerConfig.getUnit() 取得该Controller所属的Unit对象
Unit | Mapping.getUnit(int index) 根据索引号取得一个子配置单元对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.biz
Classes
FileController


com.bstek.dorado.biz Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.biz

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.action.Controller
      • class com.bstek.dorado.biz.FileController


Uses of Package com.bstek.dorado.biz

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.biz

No usage of com.bstek.dorado.biz

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.biz.FileController

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.biz.FileController

No usage of com.bstek.dorado.biz.FileController

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common
Interfaces
Transaction
Classes
DoradoContext
HttpContextFactory
HttpDoradoContext
MessageHelper
Setting
TransactionManager
UserConfig


com.bstek.dorado.common Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.DoradoContext
      • class com.bstek.dorado.common.AbstractDoradoContext
        • class com.bstek.dorado.common.HttpDoradoContext
    • class com.bstek.dorado.common.HttpContextFactory
    • class com.bstek.dorado.common.MessageHelper
    • class com.bstek.dorado.common.Setting
    • class com.bstek.dorado.common.TransactionManager
    • class com.bstek.dorado.common.UserConfig

Interface Hierarchy

  • interface com.bstek.dorado.common.Transaction


Uses of Package com.bstek.dorado.common

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common

Packages that use com.bstek.dorado.common
com.bstek.dorado.common | Dorado系统中的一些通用类
com.bstek.dorado.common.rtexpr | 用于支持运行时变量(例如: EL表达式)的工具类
com.bstek.dorado.common.scope | 用于支持对象的缓存和查找的工具类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.i18n | 用于支持国际化
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Classes in com.bstek.dorado.common used by com.bstek.dorado.common
DoradoContext
Dorado上下文对象.
Transaction
Dorado事务对象的接口

Classes in com.bstek.dorado.common used by com.bstek.dorado.common.rtexpr
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.common.scope
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.data
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.data.db
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.i18n
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.security
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control.autoform
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control.command
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control.dropdown
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control.table
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control.tabset
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.control.tree
DoradoContext
Dorado上下文对象.

Classes in com.bstek.dorado.common used by com.bstek.dorado.view.data
DoradoContext
Dorado上下文对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.DoradoContext

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.DoradoContext

Packages that use DoradoContext
com.bstek.dorado.common | Dorado系统中的一些通用类
com.bstek.dorado.common.rtexpr | 用于支持运行时变量(例如: EL表达式)的工具类
com.bstek.dorado.common.scope | 用于支持对象的缓存和查找的工具类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.i18n | 用于支持国际化
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of DoradoContext in com.bstek.dorado.common

Subclasses of DoradoContext in com.bstek.dorado.common
class | com.bstek.dorado.common.AbstractDoradoContext
class | HttpDoradoContext 用于封装HttpRequest的上下文对象

Methods in com.bstek.dorado.common that return DoradoContext
static DoradoContext | DoradoContext.getContext() 获取当前线程中的context对象.
static DoradoContext | HttpContextFactory.getContext(javax.servlet.ServletRequest request) 根据ServletRequest来获取一个DoradoContext
static DoradoContext | HttpContextFactory.getContext(javax.servlet.ServletRequest request, boolean create) 根据ServletRequest来获取一个DoradoContext, 如果目前还没有一个相应的DoradoContext, 系统将根据create参数来决定时候要产生一个.

Methods in com.bstek.dorado.common with parameters of type DoradoContext
static void | DoradoContext.registerContext(DoradoContext context) 在当前的线程中注册一个context对象
static void | MessageHelper.addMessage(DoradoContext context, java.lang.String message) 增加一条新的无键值消息
static void | MessageHelper.addMessage(DoradoContext context, java.lang.String key, java.lang.String message) 在指定键值中增加一条新的消息
static java.lang.String | MessageHelper.getMessage(DoradoContext context) 返回一条无键值消息.
static java.lang.String | MessageHelper.getMessage(DoradoContext context, java.lang.String key) 返回一条在指定键值中消息.
static java.util.List | MessageHelper.getMessages(DoradoContext context) 返回所有无键值消息
static java.util.List | MessageHelper.getMessages(DoradoContext context, java.lang.String key) 返回所有指定键值中消息

Uses of DoradoContext in com.bstek.dorado.common.rtexpr

Methods in com.bstek.dorado.common.rtexpr with parameters of type DoradoContext
static java.lang.Object | ExprHelper.translate(com.bstek.dorado.common.rtexpr.CompiledText compiledText, DoradoContext context) 将一段预编译好的字符串翻译成最终结果
static java.lang.Object | ExprHelper.translate(java.lang.String text, DoradoContext context) 将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.

Uses of DoradoContext in com.bstek.dorado.common.scope

Methods in com.bstek.dorado.common.scope with parameters of type DoradoContext
static void | ScopeHelper.storeObject(DoradoContext context, java.lang.String scope, java.lang.String attribute, java.lang.Object object) 根据属性名将一个对象存入相应的资源当中
static java.lang.Object | ScopeHelper.findObject(DoradoContext context, java.lang.String scope, java.lang.String attribute) 根据属性名从指定的资源中取得一个已被存入的对象

Uses of DoradoContext in com.bstek.dorado.data

Methods in com.bstek.dorado.data with parameters of type DoradoContext
void | Dataset.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | DatasetAdapter.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | DatasetSupport.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected Field | DatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.

Uses of DoradoContext in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db with parameters of type DoradoContext
void | AutoSqlDataset.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | SqlDataset.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。

Uses of DoradoContext in com.bstek.dorado.i18n

Methods in com.bstek.dorado.i18n with parameters of type DoradoContext
void | ResourceManager.setDefaultLocale(DoradoContext context, java.util.Locale locale) 设置当前会话的默认的地区与语种.
void | ResourceManager.setDefaultLocale(DoradoContext context, int scope, java.util.Locale locale) 设置上下文对象中某一作用域的默认的地区与语种.
java.util.Locale | ResourceManager.getDefaultLocale(DoradoContext context) 返回默认的地区与语种.
java.util.ResourceBundle | ResourceManager.getBundle(DoradoContext context, java.lang.String baseName) 按默认的地区与语种返回一个国际化资源集合.
java.lang.String | ResourceManager.getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object[] args) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | ResourceManager.getString(DoradoContext context, java.lang.String baseName, java.lang.String key) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | ResourceManager.getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object arg0) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | ResourceManager.getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object arg0, java.lang.Object arg1) 按默认的地区与语种返回一个国际化资源字符串.
java.lang.String | ResourceManager.getString(DoradoContext context, java.lang.String baseName, java.lang.String key, java.lang.Object arg0, java.lang.Object arg1, java.lang.Object arg2) 按默认的地区与语种返回一个国际化资源字符串.

Constructors in com.bstek.dorado.i18n with parameters of type DoradoContext
ResourceManagerContextMap(DoradoContext context, ResourceManager resource)

Uses of DoradoContext in com.bstek.dorado.security

Methods in com.bstek.dorado.security with parameters of type DoradoContext
 void AccessChecker.checkAccess(DoradoContext context, java.lang.Object accessingObject)
校验用户登录状态的方法

Uses of DoradoContext in com.bstek.dorado.view

Methods in com.bstek.dorado.view with parameters of type DoradoContext
void | Component.init(DoradoContext context, XmlNode node) 跟XML配置初始化
protected java.lang.String | ViewModelSupport.getDefaultSkin(DoradoContext context) 获得默认的皮肤.
protected void | ViewModelSupport.loadEventConfig(DoradoContext context) 根据XML中的配置初试化视图模型的事件定义。
protected void | ViewModelSupport.checkAccess(DoradoContext context) 按系统默认的方式判断当前用户是否已登录

Uses of DoradoContext in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control with parameters of type DoradoContext
void | Calendar.init(DoradoContext context, XmlNode node) Deprecated.
void | Menu.init(DoradoContext context, XmlNode node)
protected void | Menu.loadItems(DoradoContext context, XmlNode node, MenuItem menuItem) 加载菜单项
void | OutlookBar.init(DoradoContext context, XmlNode node)

Uses of DoradoContext in com.bstek.dorado.view.control.autoform

Methods in com.bstek.dorado.view.control.autoform with parameters of type DoradoContext
void | AutoForm.init(DoradoContext context, XmlNode node)
protected void | AutoForm.loadGroups(DoradoContext context, XmlNode node) 加载组
void | CheckBoxFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | FormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | FormGroup.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个组
void | LabelFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | RadioGroupFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | TextEditorFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素

Uses of DoradoContext in com.bstek.dorado.view.control.command

Methods in com.bstek.dorado.view.control.command with parameters of type DoradoContext
void | CommandQueue.init(DoradoContext context, XmlNode node)
void | RPCCommand.init(DoradoContext context, XmlNode node)
void | RequestCommand.init(DoradoContext context, XmlNode node)
void | UpdateCommand.init(DoradoContext context, XmlNode node)

Uses of DoradoContext in com.bstek.dorado.view.control.dropdown

Methods in com.bstek.dorado.view.control.dropdown with parameters of type DoradoContext
void | DynamicDropDown.init(DoradoContext context, XmlNode node)
void | ListDropDown.init(DoradoContext context, XmlNode node)

Uses of DoradoContext in com.bstek.dorado.view.control.table

Methods in com.bstek.dorado.view.control.table with parameters of type DoradoContext
void | Column.init(DoradoContext context, XmlNode node) 列初始化
protected void | DataTable.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
void | Table.init(DoradoContext context, XmlNode node)
protected void | Table.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列

Uses of DoradoContext in com.bstek.dorado.view.control.tabset

Methods in com.bstek.dorado.view.control.tabset with parameters of type DoradoContext
 void TabSet.init(DoradoContext context, XmlNode node)

Uses of DoradoContext in com.bstek.dorado.view.control.tree

Methods in com.bstek.dorado.view.control.tree with parameters of type DoradoContext
void | DataTree.init(DoradoContext context, XmlNode node)
protected void | DataTree.loadChildLevels(TreeLevel level, XmlNode node, DoradoContext context) 加载子节点层
protected TreeLevel | DataTree.createTreeLevel(XmlNode node, DoradoContext context) 根据XML节点创建节点层
void | Tree.init(DoradoContext context, XmlNode node)
protected void | Tree.loadNodes(DoradoContext context, XmlNode node, TreeNode treeNode) 加载树节点

Uses of DoradoContext in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data with parameters of type DoradoContext
void | DatasetWrapper.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected Field | DatasetWrapper.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
void | ViewDatasetAdapter.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected Field | ViewDatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
void | ViewDatasetSupport.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.HttpContextFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.HttpContextFactory

No usage of com.bstek.dorado.common.HttpContextFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.HttpDoradoContext

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.HttpDoradoContext

No usage of com.bstek.dorado.common.HttpDoradoContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.MessageHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.MessageHelper

No usage of com.bstek.dorado.common.MessageHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.Setting

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.Setting

No usage of com.bstek.dorado.common.Setting

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.common.Transaction

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.common.Transaction

Packages that use Transaction
com.bstek.dorado.common Dorado系统中的一些通用类

Uses of Transaction in com.bstek.dorado.common

Methods in com.bstek.dorado.common that return Transaction
static Transaction TransactionManager.getTransaction()
获取当前线程中的事务.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.TransactionManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.TransactionManager

No usage of com.bstek.dorado.common.TransactionManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.UserConfig

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.UserConfig

No usage of com.bstek.dorado.common.UserConfig

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common.ds
Classes
ConnectionHelper


com.bstek.dorado.common.ds Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common.ds

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.ds.ConnectionHelper


Uses of Package com.bstek.dorado.common.ds

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common.ds

No usage of com.bstek.dorado.common.ds

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.ds.ConnectionHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.ds.ConnectionHelper

No usage of com.bstek.dorado.common.ds.ConnectionHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common.fileloader
Classes
FileLoader


com.bstek.dorado.common.fileloader Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common.fileloader

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.fileloader.FileLoader


Uses of Package com.bstek.dorado.common.fileloader

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common.fileloader

No usage of com.bstek.dorado.common.fileloader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.fileloader.FileLoader

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.fileloader.FileLoader

No usage of com.bstek.dorado.common.fileloader.FileLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common.log
Classes
Log


com.bstek.dorado.common.log Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common.log

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.log.Log


Uses of Package com.bstek.dorado.common.log

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common.log

No usage of com.bstek.dorado.common.log

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.log.Log

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.log.Log

No usage of com.bstek.dorado.common.log.Log

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common.rtexpr
Classes
ExprHelper


com.bstek.dorado.common.rtexpr Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common.rtexpr

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.rtexpr.ExprHelper


Uses of Package com.bstek.dorado.common.rtexpr

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common.rtexpr

No usage of com.bstek.dorado.common.rtexpr

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.rtexpr.ExprHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.rtexpr.ExprHelper

No usage of com.bstek.dorado.common.rtexpr.ExprHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common.rtexpr.impl
Classes
ExpressionUtils


com.bstek.dorado.common.rtexpr.impl Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common.rtexpr.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils


Uses of Package com.bstek.dorado.common.rtexpr.impl

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common.rtexpr.impl

Packages that use com.bstek.dorado.common.rtexpr.impl
com.bstek.dorado.common.rtexpr.impl EL表达式相关的实现类

Classes in com.bstek.dorado.common.rtexpr.impl used by com.bstek.dorado.common.rtexpr.impl
ExpressionUtils
EL表达式工具类,该类所具有的各个方法亦即Util表达式所支持的各项功能.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.rtexpr.impl.ExpressionUtils

Packages that use ExpressionUtils
com.bstek.dorado.common.rtexpr.impl EL表达式相关的实现类

Uses of ExpressionUtils in com.bstek.dorado.common.rtexpr.impl

Methods in com.bstek.dorado.common.rtexpr.impl that return ExpressionUtils
static ExpressionUtils ExpressionUtils.getInstance()
获得单例对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.common.scope
Classes
Scope
ScopeHelper


com.bstek.dorado.common.scope Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.common.scope

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.scope.Scope
    • class com.bstek.dorado.common.scope.ScopeHelper


Uses of Package com.bstek.dorado.common.scope

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.common.scope

No usage of com.bstek.dorado.common.scope

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.scope.Scope

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.scope.Scope

No usage of com.bstek.dorado.common.scope.Scope

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.common.scope.ScopeHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.common.scope.ScopeHelper

No usage of com.bstek.dorado.common.scope.ScopeHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.data
Interfaces
DataListener
Dataset
DatasetListener
Field
RecordFilter
RecordListener
Classes
BaseField
BaseRecord
DatasetAdapter
DatasetSupport
DORecord
DOSet
DOUtils
DummyField
FieldSet
Index
LookupField
PagingHelper
ParameterSet
ReadRecord
Record
RecordIterator
RecordSet
RecordWrapper
Exceptions
FieldNotExistException
NoCurrentRecordException


com.bstek.dorado.data Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.data

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.data.AbstractField (implements com.bstek.dorado.data.Field)
      • class com.bstek.dorado.data.BaseField
      • class com.bstek.dorado.data.DummyField
      • class com.bstek.dorado.data.LookupField
    • class com.bstek.dorado.data.DatasetAdapter (implements com.bstek.dorado.data.Dataset)
    • class com.bstek.dorado.data.DatasetSupport (implements com.bstek.dorado.data.DataListener, com.bstek.dorado.data.Dataset)
    • class com.bstek.dorado.data.DOSet
    • class com.bstek.dorado.data.DOUtils
    • class com.bstek.dorado.data.FieldSet (implements java.io.Serializable)
    • class com.bstek.dorado.data.Index
    • class com.bstek.dorado.data.PagingHelper
    • class com.bstek.dorado.data.ReadRecord
      • class com.bstek.dorado.data.Record (implements java.lang.Cloneable, java.io.Serializable)
        • class com.bstek.dorado.data.BaseRecord
          • class com.bstek.dorado.data.DORecord
    • class com.bstek.dorado.data.RecordIterator (implements java.util.Iterator)
    • class com.bstek.dorado.data.RecordSet (implements java.io.Serializable)
    • class com.bstek.dorado.data.RecordWrapper
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class com.bstek.dorado.utils.DoradoRuntimeException
            • class com.bstek.dorado.data.FieldNotExistException
            • class com.bstek.dorado.data.NoCurrentRecordException
    • class com.bstek.dorado.utils.variant.VariantSet (implements java.lang.Cloneable, java.io.Serializable)
      • class com.bstek.dorado.data.ParameterSet

Interface Hierarchy

  • interface java.util.EventListener
    • interface com.bstek.dorado.data.DataListener
    • interface com.bstek.dorado.data.DatasetListener
    • interface com.bstek.dorado.data.RecordListener
  • interface com.bstek.dorado.data.Field
  • interface com.bstek.dorado.data.RecordFilter
  • interface java.io.Serializable
    • interface com.bstek.dorado.data.Dataset


Uses of Package com.bstek.dorado.data

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.data

Packages that use com.bstek.dorado.data
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.custom | 实现可自定义数据集
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.module | 数据模块的相关类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Classes in com.bstek.dorado.data used by com.bstek.dorado.data
BaseField
最基本的Field对象。
BaseRecord
最基本的Record对象
DataListener
针对Dataset中的数据的事件监听器
Dataset
Dorado记录集的接口。
DatasetListener
Dataset事件监听器的接口
DatasetSupport
数据集的抽象基类。
DummyField
虚拟字段
Field
字段
FieldSet
字段集合对象
Index
记录集的索引对象
LookupField
支持Lookup功能的Field。
ParameterSet
参数的集合类
ReadRecord
只读的Record
Record
记录对象
RecordFilter
记录过滤器
RecordIterator
记录迭代器
RecordListener
Dataset中记录操作的监听器
RecordSet
Record集合对象
RecordWrapper
RecordSet使用的记录包装器

Classes in com.bstek.dorado.data used by com.bstek.dorado.data.custom
DataListener
针对Dataset中的数据的事件监听器
Dataset
Dorado记录集的接口。
DatasetSupport
数据集的抽象基类。

Classes in com.bstek.dorado.data used by com.bstek.dorado.data.db
BaseField
最基本的Field对象。
DataListener
针对Dataset中的数据的事件监听器
Dataset
Dorado记录集的接口。
DatasetSupport
数据集的抽象基类。
Field
字段
ParameterSet
参数的集合类
Record
记录对象

Classes in com.bstek.dorado.data used by com.bstek.dorado.module
Dataset
Dorado记录集的接口。
ParameterSet
参数的集合类

Classes in com.bstek.dorado.data used by com.bstek.dorado.view
Dataset
Dorado记录集的接口。
ParameterSet
参数的集合类

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.control
Field
字段

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.control.command
ParameterSet
参数的集合类

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.control.dropdown
DataListener
针对Dataset中的数据的事件监听器
Dataset
Dorado记录集的接口。
DatasetSupport
数据集的抽象基类。
ParameterSet
参数的集合类

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.control.table
Field
字段

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.control.tree
Record
记录对象

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.data
BaseField
最基本的Field对象。
BaseRecord
最基本的Record对象
DataListener
针对Dataset中的数据的事件监听器
Dataset
Dorado记录集的接口。
DatasetListener
Dataset事件监听器的接口
DatasetSupport
数据集的抽象基类。
DORecord
DummyField
虚拟字段
Field
字段
FieldSet
字段集合对象
Index
记录集的索引对象
LookupField
支持Lookup功能的Field。
ParameterSet
参数的集合类
ReadRecord
只读的Record
Record
记录对象
RecordIterator
记录迭代器
RecordSet
Record集合对象

Classes in com.bstek.dorado.data used by com.bstek.dorado.view.rpc
ParameterSet
参数的集合类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.BaseField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.BaseField

Packages that use BaseField
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of BaseField in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return BaseField
BaseField | Dataset.addField(java.lang.String name) 向Dataset中添加一个普通Field。
BaseField | DatasetAdapter.addField(java.lang.String name) 向Dataset中添加一个普通Field。
BaseField | DatasetSupport.addField(java.lang.String name) 向Dataset中添加一个普通Field。

Uses of BaseField in com.bstek.dorado.data.db

Subclasses of BaseField in com.bstek.dorado.data.db
class | AutoDBField 自动SQL记录集的字段对象
class | DBField DBDataset记录集的字段对象

Uses of BaseField in com.bstek.dorado.view.data

Subclasses of BaseField in com.bstek.dorado.view.data
 class ViewBaseField
视图模型中数据字段的基础类

Methods in com.bstek.dorado.view.data that return BaseField
 BaseField ViewDatasetAdapter.addField(java.lang.String name)
向Dataset中添加一个普通Field。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.BaseRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.BaseRecord

Packages that use BaseRecord
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of BaseRecord in com.bstek.dorado.data

Subclasses of BaseRecord in com.bstek.dorado.data
 class DORecord

Uses of BaseRecord in com.bstek.dorado.view.data

Subclasses of BaseRecord in com.bstek.dorado.view.data
 class ViewRecord
视图模型中Dataset的记录对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.DataListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.DataListener

Packages that use DataListener
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.custom | 实现可自定义数据集
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of DataListener in com.bstek.dorado.data

Classes in com.bstek.dorado.data that implement DataListener
class | com.bstek.dorado.data.AbstractDataset
class | DatasetSupport 数据集的抽象基类。

Uses of DataListener in com.bstek.dorado.data.custom

Classes in com.bstek.dorado.data.custom that implement DataListener
 class CustomDataset
用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.

Uses of DataListener in com.bstek.dorado.data.db

Classes in com.bstek.dorado.data.db that implement DataListener
class | AutoSqlDataset 自动SQL记录集.
class | DBDataset 基于SQL的Dataset的抽象基类
class | SqlDataset 基于SQL的Dataset.

Uses of DataListener in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement DataListener
 class DynamicDropDownDataset
动态下拉框数据集对象

Uses of DataListener in com.bstek.dorado.view.data

Classes in com.bstek.dorado.view.data that implement DataListener
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.Dataset

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.Dataset

Packages that use Dataset
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.custom | 实现可自定义数据集
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.module | 数据模块的相关类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of Dataset in com.bstek.dorado.data

Classes in com.bstek.dorado.data that implement Dataset
class | com.bstek.dorado.data.AbstractDataset
class | DatasetAdapter Dataset适配器
class | DatasetSupport 数据集的抽象基类。

Methods in com.bstek.dorado.data that return Dataset
Dataset | DatasetAdapter.getTarget() 返回适配器的目标Dataset
Dataset | Index.getDataset() 返回本索引所属的Dataset对象
Dataset | LookupField.getLookupDataset() 作为Lookup数据来源的Dataset对象。
Dataset | Record.getDataset() 取得该记录对象所属的数据集（Dataset）对象.

Methods in com.bstek.dorado.data with parameters of type Dataset
static Record DOUtils.DOToRecord(java.lang.Object o, Dataset dataset)
利用反射从o参数指定的对象中读取数据, 并追加到Dataset中.
 void DatasetAdapter.setTarget(Dataset target)
设定适配器的目标Dataset
 void DatasetListener.onInit(Dataset dataset)
当Dataset被初始化的时候触发的事件.即当调用Dataset.init()时触发的事件.
 boolean DatasetListener.beforeCreateFields(Dataset dataset)
当Dataset将要自动创建所有字段之前触发的事件.即当调用Dataset.createFields()之前触发的事件.
 void DatasetListener.afterCreateFields(Dataset dataset)
当Dataset执行完自动创建所有字段之后触发的事件.即当调用Dataset.createFields()之后触发的事件.
 boolean DatasetListener.beforeLoadData(Dataset dataset)
当Dataset将要装载数据之前触发的事件.即当调用Dataset.loadData()之前触发的事件.
 void DatasetListener.afterLoadData(Dataset dataset)
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.loadData()之后触发的事件.
 boolean DatasetListener.beforeUpdateData(Dataset dataset)
当Dataset将要装载数据之前触发的事件.即当调用Dataset.update()之前触发的事件.
 void DatasetListener.afterUpdateData(Dataset dataset)
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.update()之后触发的事件.
static Index Index.build(Dataset dataset, java.lang.String field)
根据给定的Dataset和字段创建并返回索引对象。
static Index Index.build(Dataset dataset, java.lang.String[] fields)
根据给定的Dataset和字段创建并返回索引对象。
 void LookupField.setLookupDataset(Dataset lookupDataset)
设置作为Lookup数据来源的Dataset对象。
 void RecordListener.beforeScroll(Dataset dataset)
当Dataset的当前记录改变之前触发的事件
 void RecordListener.afterScroll(Dataset dataset)
当Dataset的当前记录改变之后触发的事件
 void RecordListener.beforeInsert(Dataset dataset, Record record)
将要向Dataset中插入一条记录之前触发的事件
 void RecordListener.afterInsert(Dataset dataset, Record record)
向Dataset中插入一条记录之后触发的事件
 void RecordListener.beforeChange(Dataset dataset, ReadRecord record, java.lang.String fieldName, Variant value)
当Dataset中某条记录的数据将要被修改之前被触发的事件.
 void RecordListener.afterChange(Dataset dataset, ReadRecord record, java.lang.String fieldName)
当Dataset中某条记录的数据被修改之后被触发的事件.
 void RecordListener.beforeDelete(Dataset dataset, ReadRecord record)
将要从Dataset中删除一条记录之前触发的事件
 void RecordListener.afterDelete(Dataset dataset, ReadRecord record)
从Dataset中删除一条记录之后触发的事件

Constructors in com.bstek.dorado.data with parameters of type Dataset
DatasetAdapter(Dataset target)
构造器
Index(Dataset dataset, java.lang.String[] fields)
构造器 根据给定的Dataset和字段创建索引
RecordIterator(Dataset dataset)
构造器

Uses of Dataset in com.bstek.dorado.data.custom

Classes in com.bstek.dorado.data.custom that implement Dataset
 class CustomDataset
用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.

Uses of Dataset in com.bstek.dorado.data.db

Classes in com.bstek.dorado.data.db that implement Dataset
class | AutoSqlDataset 自动SQL记录集.
class | DBDataset 基于SQL的Dataset的抽象基类
class | SqlDataset 基于SQL的Dataset.

Uses of Dataset in com.bstek.dorado.module

Methods in com.bstek.dorado.module that return Dataset
Dataset | ModuleSupport.getDataset(java.lang.String id, boolean loadData)
Dataset | ModuleSupport.getDataset(java.lang.String id, boolean loadData, ParameterSet parameters)
Dataset | ModuleSupport.getDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters)
protected Dataset | ModuleSupport.createDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters) 根据给定的一系列参数创建并返回一个Dataset。

Methods in com.bstek.dorado.module with parameters of type Dataset
protected void | DefaultModule.initDataset(Dataset dataset) Deprecated.
protected void | ModuleSupport.initDataset(Dataset dataset) Deprecated.
protected void | ModuleSupport.loadData(Dataset dataset, boolean loadData) Deprecated.

Uses of Dataset in com.bstek.dorado.view

Methods in com.bstek.dorado.view with parameters of type Dataset
protected  void ViewModelSupport.initLookupFields(Dataset dataset)
初试化某个Dataset中的Lookup字段

Uses of Dataset in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement Dataset
 class DynamicDropDownDataset
动态下拉框数据集对象

Uses of Dataset in com.bstek.dorado.view.data

Subinterfaces of Dataset in com.bstek.dorado.view.data
 interface ViewDataset
视图模型中数据集对象的基础类

Classes in com.bstek.dorado.view.data that implement Dataset
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。

Methods in com.bstek.dorado.view.data that return Dataset
protected Dataset | DatasetReference.doGetSourceDatasetForLoad(boolean createFields, boolean loadData)
protected Dataset | DatasetReference.doGetSourceDatasetForUpdate()
Dataset | DatasetWrapper.getWrappedDataset() 取得被包装的源Dataset
protected Dataset | DatasetWrapper.doGetSourceDatasetForLoad(boolean createFields, boolean loadData)
protected Dataset | DatasetWrapper.doGetSourceDatasetForUpdate()

Methods in com.bstek.dorado.view.data with parameters of type Dataset
protected  void DatasetWrapper.initLookupFields(Dataset dataset)
初试化某个Dataset中的Lookup字段

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.DatasetAdapter

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.DatasetAdapter

No usage of com.bstek.dorado.data.DatasetAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.DatasetListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.DatasetListener

Packages that use DatasetListener
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of DatasetListener in com.bstek.dorado.data

Methods in com.bstek.dorado.data with parameters of type DatasetListener
void | Dataset.removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | Dataset.addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
void | DatasetAdapter.addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
void | DatasetAdapter.removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | DatasetSupport.removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器
void | DatasetSupport.addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器

Uses of DatasetListener in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data with parameters of type DatasetListener
void | ViewDatasetAdapter.addDatasetListener(DatasetListener l) 增加一个DatasetEvent的事件监听器
void | ViewDatasetAdapter.removeDatasetListener(DatasetListener l) 删除一个DatasetEvent的事件监听器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.DatasetSupport

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.DatasetSupport

Packages that use DatasetSupport
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.custom | 实现可自定义数据集
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of DatasetSupport in com.bstek.dorado.data

Subclasses of DatasetSupport in com.bstek.dorado.data
 class com.bstek.dorado.data.AbstractDataset

Uses of DatasetSupport in com.bstek.dorado.data.custom

Subclasses of DatasetSupport in com.bstek.dorado.data.custom
 class CustomDataset
用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.

Uses of DatasetSupport in com.bstek.dorado.data.db

Subclasses of DatasetSupport in com.bstek.dorado.data.db
class | AutoSqlDataset 自动SQL记录集.
class | DBDataset 基于SQL的Dataset的抽象基类
class | SqlDataset 基于SQL的Dataset.

Uses of DatasetSupport in com.bstek.dorado.view.control.dropdown

Subclasses of DatasetSupport in com.bstek.dorado.view.control.dropdown
 class DynamicDropDownDataset
动态下拉框数据集对象

Uses of DatasetSupport in com.bstek.dorado.view.data

Subclasses of DatasetSupport in com.bstek.dorado.view.data
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.DORecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.DORecord

Packages that use DORecord
com.bstek.dorado.view.data 视图数据集的相关类

Uses of DORecord in com.bstek.dorado.view.data

Subclasses of DORecord in com.bstek.dorado.view.data
 class ViewRecord
视图模型中Dataset的记录对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.DOSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.DOSet

No usage of com.bstek.dorado.data.DOSet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.DOUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.DOUtils

No usage of com.bstek.dorado.data.DOUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.DummyField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.DummyField

Packages that use DummyField
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of DummyField in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return DummyField
DummyField | Dataset.addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。
DummyField | DatasetAdapter.addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。
DummyField | DatasetSupport.addDummyField(java.lang.String name) 向Dataset中添加一个虚拟Field。

Uses of DummyField in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return DummyField
 DummyField ViewDatasetAdapter.addDummyField(java.lang.String name)
向Dataset中添加一个虚拟Field。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.Field

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.Field

Packages that use Field
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of Field in com.bstek.dorado.data

Classes in com.bstek.dorado.data that implement Field
class | com.bstek.dorado.data.AbstractField
class | BaseField 最基本的Field对象。
class | DummyField 虚拟字段
class | LookupField 支持Lookup功能的Field。

Methods in com.bstek.dorado.data that return Field
Field | Dataset.getField(int index) 根据Field索引号取得一个Field对象。
Field | Dataset.getField(java.lang.String name) 根据Field名称取得一个Field对象。
Field | DatasetAdapter.getField(int index) 根据Field索引号取得一个Field对象。
Field | DatasetAdapter.getField(java.lang.String name) 根据Field名称取得一个Field对象。
protected Field | DatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
Field | DatasetSupport.getField(int index) 根据Field索引号取得一个Field对象。
Field | DatasetSupport.getField(java.lang.String name) 根据Field名称取得一个Field对象。
Field | FieldSet.getField(int index) 根据Field索引号取得一个Field对象
Field | FieldSet.getField(java.lang.String name) 根据Field名称取得一个Field对象

Methods in com.bstek.dorado.data with parameters of type Field
 void FieldSet.addField(Field field)
添加一个Field。

Uses of Field in com.bstek.dorado.data.db

Classes in com.bstek.dorado.data.db that implement Field
class | AutoDBField 自动SQL记录集的字段对象
class | DBField DBDataset记录集的字段对象

Uses of Field in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control that return Field
 Field SimpleDataControl.getFieldInstance()
取得一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。

Uses of Field in com.bstek.dorado.view.control.table

Methods in com.bstek.dorado.view.control.table with parameters of type Field
Column | ColumnGroup.addColumnByField(Field field) 根据指定的字段对象添加一个列对象,并返回新创建的列对象.
Column | Table.addColumnByField(Field field) 根据指定的字段对象添加一个列。

Uses of Field in com.bstek.dorado.view.data

Subinterfaces of Field in com.bstek.dorado.view.data
 interface ViewField
视图模型中数据集字段对象

Classes in com.bstek.dorado.view.data that implement Field
class | ViewBaseField 视图模型中数据字段的基础类
class | ViewLookupField 视图模型中LookupField对象

Methods in com.bstek.dorado.view.data that return Field
protected Field | DatasetWrapper.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
Field | ViewDatasetAdapter.getField(int index) 根据Field索引号取得一个Field对象。
Field | ViewDatasetAdapter.getField(java.lang.String name) 根据Field名称取得一个Field对象。
protected Field | ViewDatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.FieldNotExistException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.FieldNotExistException

No usage of com.bstek.dorado.data.FieldNotExistException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.FieldSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.FieldSet

Packages that use FieldSet
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of FieldSet in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return FieldSet
FieldSet | Dataset.fieldSet() 返回Dataset的Field集合对象
FieldSet | DatasetAdapter.fieldSet() 返回Dataset的Field集合对象
FieldSet | DatasetSupport.fieldSet() 返回Dataset的Field集合对象
FieldSet | Record.getFieldSet() 取得该记录的所有字段的集合对象.

Methods in com.bstek.dorado.data with parameters of type FieldSet
void | Dataset.setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象
void | DatasetAdapter.setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象
void | DatasetSupport.setFieldSet(FieldSet fieldset) 设置Dataset的Field集合对象

Uses of FieldSet in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return FieldSet
 FieldSet ViewDatasetAdapter.fieldSet()
返回Dataset的Field集合对象

Methods in com.bstek.dorado.view.data with parameters of type FieldSet
 void ViewDatasetAdapter.setFieldSet(FieldSet fieldset)
设置Dataset的Field集合对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.Index

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.Index

Packages that use Index
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of Index in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return Index
Index | Dataset.getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。
Index | Dataset.getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。
Index | DatasetAdapter.getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | DatasetAdapter.getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | DatasetSupport.getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | DatasetSupport.getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
static Index | Index.build(Dataset dataset, java.lang.String field) 根据给定的Dataset和字段创建并返回索引对象。
static Index | Index.build(Dataset dataset, java.lang.String[] fields) 根据给定的Dataset和字段创建并返回索引对象。

Uses of Index in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return Index
Index | ViewDatasetAdapter.getIndex(java.lang.String field) 根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
Index | ViewDatasetAdapter.getIndex(java.lang.String[] fields) 根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.LookupField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.LookupField

Packages that use LookupField
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of LookupField in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return LookupField
LookupField | Dataset.addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。
LookupField | DatasetAdapter.addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。 Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。
LookupField | DatasetSupport.addLookupField(java.lang.String name) 向Dataset中添加一个支持Lookup功能的Field。 Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

Uses of LookupField in com.bstek.dorado.view.data

Subclasses of LookupField in com.bstek.dorado.view.data
 class ViewLookupField
视图模型中LookupField对象

Methods in com.bstek.dorado.view.data that return LookupField
 LookupField ViewDatasetAdapter.addLookupField(java.lang.String name)
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.NoCurrentRecordException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.NoCurrentRecordException

No usage of com.bstek.dorado.data.NoCurrentRecordException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.PagingHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.PagingHelper

No usage of com.bstek.dorado.data.PagingHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.ParameterSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.ParameterSet

Packages that use ParameterSet
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.module | 数据模块的相关类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Uses of ParameterSet in com.bstek.dorado.data

Fields in com.bstek.dorado.data declared as ParameterSet
static ParameterSet ParameterSet.NULL_INSTANCE
空对象

Methods in com.bstek.dorado.data that return ParameterSet
ParameterSet | Dataset.parameters() 返回Dataset所有参数的集合对象
ParameterSet | DatasetAdapter.parameters() 返回Dataset所有参数的集合对象
ParameterSet | DatasetSupport.parameters() 返回Dataset所有参数的集合对象
ParameterSet | RecordIterator.filter() Deprecated.

Uses of ParameterSet in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return ParameterSet
 ParameterSet DBStatement.parameters()
取得所有参数的集合对象

Uses of ParameterSet in com.bstek.dorado.module

Methods in com.bstek.dorado.module with parameters of type ParameterSet
Dataset | ModuleSupport.getDataset(java.lang.String id, boolean loadData, ParameterSet parameters)
Dataset | ModuleSupport.getDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters)
protected Dataset | ModuleSupport.createDataset(java.lang.String id, boolean loadData, int pageSize, int pageIndex, ParameterSet parameters) 根据给定的一系列参数创建并返回一个Dataset。

Uses of ParameterSet in com.bstek.dorado.view

Methods in com.bstek.dorado.view with parameters of type ParameterSet
void | ViewModel.updateData(ParameterSet parameters) 对ViewModel中的Dataset进行持久化。
void | ViewModel.handleUpdate(java.lang.String method, ParameterSet parameters) 处理一个更新操作
void | ViewModel.handleRPC(java.lang.String method, ParameterSet parameters, ParameterSet outParameters) 处理一个远程过程调用操作
protected void | ViewModelSupport.doUpdateData(ParameterSet parameters) 当系统试图对ViewModel中的Dataset进行持久化时触发的方法。
void | ViewModelSupport.updateData(ParameterSet parameters) 对ViewModel中的Dataset进行持久化。
void | ViewModelSupport.handleUpdate(java.lang.String method, ParameterSet parameters) 处理一个更新操作
void | ViewModelSupport.handleRPC(java.lang.String method, ParameterSet parameters, ParameterSet outParameters) 处理一个远程过程调用操作

Uses of ParameterSet in com.bstek.dorado.view.control.command

Methods in com.bstek.dorado.view.control.command that return ParameterSet
 ParameterSet Command.parameters()
返回命令对象的参数集合。

Uses of ParameterSet in com.bstek.dorado.view.control.dropdown

Methods in com.bstek.dorado.view.control.dropdown that return ParameterSet
 ParameterSet DynamicDropDown.parameters()
返回参数集合 注意: 此处定义的参数最终将会传入到内部使用的数据集的参数当中

Uses of ParameterSet in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return ParameterSet
 ParameterSet ViewDatasetAdapter.parameters()
返回Dataset所有参数的集合对象

Uses of ParameterSet in com.bstek.dorado.view.rpc

Methods in com.bstek.dorado.view.rpc that return ParameterSet
ParameterSet | BaseRPCHandler.outParameters() 本次远程调用将要返回给客户端的参数集合.
ParameterSet | RPCHandler.parameters() 取得客户端发送的参数集合.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.ReadRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.ReadRecord

Packages that use ReadRecord
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of ReadRecord in com.bstek.dorado.data

Subclasses of ReadRecord in com.bstek.dorado.data
class | BaseRecord 最基本的Record对象
class | DORecord
class | Record 记录对象

Methods in com.bstek.dorado.data that return ReadRecord
ReadRecord | Dataset.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
ReadRecord | DatasetAdapter.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
ReadRecord | DatasetSupport.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。

Methods in com.bstek.dorado.data with parameters of type ReadRecord
void | DataListener.beforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 当数据将要被修改之前被触发的事件.
void | DataListener.afterChange(ReadRecord record, java.lang.String fieldName) 在数据被修改之后被触发的事件.
void | DatasetSupport.beforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 当数据将要被修改之前被触发的事件.
void | DatasetSupport.afterChange(ReadRecord record, java.lang.String fieldName) 在数据被修改之后被触发的事件.
protected void | DatasetSupport.fireBeforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 触发BeforeChange事件
protected void | DatasetSupport.fireAfterChange(ReadRecord record, java.lang.String fieldName) 触发AfterChange事件
protected void | DatasetSupport.fireBeforeDelete(ReadRecord record) 触发BeforeDelete事件
protected void | DatasetSupport.fireAfterDelete(ReadRecord record) 触发AfterDelete事件
protected java.lang.Object | Record.fireBeforeChange(ReadRecord record, java.lang.String fieldName, java.lang.Object value) 触发BeforeChange事件,该事件一般由Dataset进行监听.
protected void | Record.fireAfterChange(ReadRecord record, java.lang.String fieldName) 触发AfterChange事件,该事件一般由Dataset进行监听.
void | RecordListener.beforeChange(Dataset dataset, ReadRecord record, java.lang.String fieldName, Variant value) 当Dataset中某条记录的数据将要被修改之前被触发的事件.
void | RecordListener.afterChange(Dataset dataset, ReadRecord record, java.lang.String fieldName) 当Dataset中某条记录的数据被修改之后被触发的事件.
void | RecordListener.beforeDelete(Dataset dataset, ReadRecord record) 将要从Dataset中删除一条记录之前触发的事件
void | RecordListener.afterDelete(Dataset dataset, ReadRecord record) 从Dataset中删除一条记录之后触发的事件

Uses of ReadRecord in com.bstek.dorado.view.data

Subclasses of ReadRecord in com.bstek.dorado.view.data
 class ViewRecord
视图模型中Dataset的记录对象

Methods in com.bstek.dorado.view.data that return ReadRecord
 ReadRecord ViewDatasetAdapter.getOldRecord(Record record)
返回用于保存某记录的原始值的记录对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.Record

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.Record

Packages that use Record
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of Record in com.bstek.dorado.data

Subclasses of Record in com.bstek.dorado.data
class | BaseRecord 最基本的Record对象
class | DORecord

Methods in com.bstek.dorado.data that return Record
static Record | DOUtils.DOToRecord(java.lang.Object o, Record record) 利用反射从o参数指定的对象中读取数据并设置到给定的record中.
static Record | DOUtils.DOToRecord(java.lang.Object o, Dataset dataset) 利用反射从o参数指定的对象中读取数据, 并追加到Dataset中.
Record | Dataset.find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。
Record | Dataset.find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。
Record[] | Dataset.findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
Record[] | Dataset.findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record | Dataset.getCurrent() 返回当前记录对象。
Record | Dataset.insertRecord() 添加一条记录。
Record | Dataset.insertRecord(int state) 添加一条记录并初始化新记录的状态。
Record | Dataset.fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.
Record | Dataset.fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
Record | DatasetAdapter.find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record | DatasetAdapter.find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record[] | DatasetAdapter.findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
Record[] | DatasetAdapter.findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record | DatasetAdapter.getCurrent() 返回当前记录对象。
Record | DatasetAdapter.insertRecord() 添加一条记录。
Record | DatasetAdapter.insertRecord(int state) 添加一条记录并初始化新记录的状态。
Record | DatasetAdapter.fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | DatasetAdapter.fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | DatasetSupport.find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record | DatasetSupport.find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record[] | DatasetSupport.findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
Record[] | DatasetSupport.findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record | DatasetSupport.getCurrent() 返回当前记录对象。
Record | DatasetSupport.insertRecord() 添加一条记录。
Record | DatasetSupport.insertRecord(int state) 添加一条记录并初始化新记录的状态。
Record | DatasetSupport.fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | DatasetSupport.fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中. 此处的data可以是单个的Bean或java.util.Map的派生类.
protected Record | DatasetSupport.doFromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
Record[] | Index.findAll(java.lang.Object value) 利用索引根据给定的一个字段值查找记录。
Record[] | Index.findAll(java.lang.Object[] values) 利用索引根据给定的一组字段值查找记录。
Record | Index.find(java.lang.Object value) 利用索引根据给定的一个字段值查找一组记录。
Record | Index.find(java.lang.Object[] values) 利用索引根据给定的一字段值查找一组记录。
Record | RecordIterator.nextRecord() 返回下一条记录.
Record | RecordSet.getFirst() 取得记录集合中的第一条记录
Record | RecordSet.getLast() 取得记录集合中的最后一条记录
Record | RecordWrapper.getRecord() 取得被包装的记录

Methods in com.bstek.dorado.data with parameters of type Record
static Record | DOUtils.DOToRecord(java.lang.Object o, Record record) 利用反射从o参数指定的对象中读取数据并设置到给定的record中.
static java.lang.Object | DOUtils.recordToDO(Record record, java.lang.Object o) 将给定的记录中包含的数据设置到给定的对象当中.
void | Dataset.setCurrent(Record record) 设置当前记录对象。
void | Dataset.deleteRecord(Record record) 删除指定的记录。
ReadRecord | Dataset.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
java.lang.Object | Dataset.toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | Dataset.toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
void | DatasetAdapter.setCurrent(Record record) 设置当前记录对象。
void | DatasetAdapter.deleteRecord(Record record) 删除指定的记录。
ReadRecord | DatasetAdapter.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
void | DatasetAdapter.toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
java.lang.Object | DatasetAdapter.toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
protected boolean | DatasetSupport.isRecordVisible(Record record) 判断指定的记录对象是不是可见记录.
void | DatasetSupport.setCurrent(Record record) 设置当前记录对象。
protected void | DatasetSupport.initNewRecord(Record record) initNewRecord
void | DatasetSupport.deleteRecord(Record record) 删除指定的记录。
ReadRecord | DatasetSupport.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
protected void | DatasetSupport.fireBeforeInsert(Record record) 触发BeforeInsert事件
protected void | DatasetSupport.fireAfterInsert(Record record) 触发AfterInsert事件
java.lang.Object | DatasetSupport.toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | DatasetSupport.toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象
boolean | RecordFilter.isRecordVisible(Record record) 判断一条记录是否可见
void | RecordListener.beforeInsert(Dataset dataset, Record record) 将要向Dataset中插入一条记录之前触发的事件
void | RecordListener.afterInsert(Dataset dataset, Record record) 向Dataset中插入一条记录之后触发的事件
RecordWrapper | RecordSet.findWrapper(Record record) 寻找并返回指定记录的包装器.
RecordWrapper | RecordSet.insertRecord(Record record) 插入一条记录
void | RecordSet.removeRecord(Record record) 删除一条记录

Constructors in com.bstek.dorado.data with parameters of type Record
RecordWrapper(Record record)
构造器

Uses of Record in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db with parameters of type Record
protected void | DBDataset.updateDeletedRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record) 向数据库中更新一条删除的记录。
protected void | DBDataset.updateModifiedRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record) 向数据库中更新一条修改过的记录。
protected void | DBDataset.updateNewRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record) 向数据库中更新数据一条新增的记录。
protected void | DBDataset.retrieveRecord(com.bstek.dorado.data.db.UpdateSqlInfo info, Record record, java.sql.PreparedStatement psUpdate) 从数据库中提取一条记录的信息

Uses of Record in com.bstek.dorado.view.control.tree

Methods in com.bstek.dorado.view.control.tree that return Record
 Record RecordTreeNode.getRecord()
返回树节点绑定的记录对象.

Methods in com.bstek.dorado.view.control.tree with parameters of type Record
 void RecordTreeNode.setRecord(Record record)
设置树节点所绑定的记录对象.

Constructors in com.bstek.dorado.view.control.tree with parameters of type Record
RecordTreeNode(Record record, TreeLevel level)
构造器.

Uses of Record in com.bstek.dorado.view.data

Subclasses of Record in com.bstek.dorado.view.data
 class ViewRecord
视图模型中Dataset的记录对象

Methods in com.bstek.dorado.view.data that return Record
Record | ViewDatasetAdapter.find(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record | ViewDatasetAdapter.find(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
Record[] | ViewDatasetAdapter.findAll(java.lang.String field, java.lang.Object value) 根据指定的条件查找并返回所有匹配的记录。
Record[] | ViewDatasetAdapter.findAll(java.lang.String[] fields, java.lang.Object[] values) 根据指定的条件查找并返回所有匹配的记录。
Record | ViewDatasetAdapter.getCurrent() 返回当前记录对象。
Record | ViewDatasetAdapter.insertRecord() 添加一条记录。
Record | ViewDatasetAdapter.insertRecord(int state) 添加一条记录并初始化新记录的状态。
protected Record | ViewDatasetSupport.doFromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
Record | ViewDatasetSupport.fromSingleDO(java.lang.Object o) 自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录. 此处的data可以是单个的Bean或java.util.Map的派生类.
Record | ViewDatasetSupport.fromSingleDO(java.lang.Object o, boolean newRecord) 自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中. 此处的data可以是单个的Bean或java.util.Map的派生类.

Methods in com.bstek.dorado.view.data with parameters of type Record
void | ViewDatasetAdapter.setCurrent(Record record) 设置当前记录对象。
void | ViewDatasetAdapter.deleteRecord(Record record) 删除指定的记录。
ReadRecord | ViewDatasetAdapter.getOldRecord(Record record) 返回用于保存某记录的原始值的记录对象。
protected void | ViewDatasetSupport.initNewRecord(Record record) initNewRecord
java.lang.Object | ViewDatasetSupport.toSingleDO(Record record) 自动将Dataset中给定的记录转换为对象
void | ViewDatasetSupport.toSingleDO(Record record, java.lang.Object o) 自动将Dataset中给定的记录转换为对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.RecordFilter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.RecordFilter

Packages that use RecordFilter
com.bstek.dorado.data 数据集的相关类

Uses of RecordFilter in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return RecordFilter
RecordFilter | Dataset.getRecordFilter() 获得Dataset内部使用的记录过滤器.
RecordFilter | DatasetAdapter.getRecordFilter() 获得Dataset内部使用的记录过滤器.
RecordFilter | DatasetSupport.getRecordFilter() 获得Dataset内部使用的记录过滤器.

Methods in com.bstek.dorado.data with parameters of type RecordFilter
void | Dataset.setRecordFilter(RecordFilter recordFilter) 设置Dataset内部使用的记录过滤器.
void | DatasetAdapter.setRecordFilter(RecordFilter recordFilter) 设置Dataset内部使用的记录过滤器. 通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录
void | DatasetSupport.setRecordFilter(RecordFilter recordFilter) 设置Dataset内部使用的记录过滤器. 通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.RecordIterator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.RecordIterator

Packages that use RecordIterator
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of RecordIterator in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return RecordIterator
RecordIterator | Dataset.recordIterator() 返回Dataset中所有Record的迭代器。
RecordIterator | DatasetAdapter.recordIterator() 返回Dataset中所有Record的迭代器。 注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。
RecordIterator | DatasetSupport.recordIterator() 返回Dataset中所有Record的迭代器。 注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

Uses of RecordIterator in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return RecordIterator
 RecordIterator ViewDatasetAdapter.recordIterator()
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.RecordListener

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.RecordListener

Packages that use RecordListener
com.bstek.dorado.data 数据集的相关类

Uses of RecordListener in com.bstek.dorado.data

Methods in com.bstek.dorado.data with parameters of type RecordListener
void | Dataset.removeRecordListener(RecordListener l) 删除一个RecordtListener的事件监听器
void | Dataset.addRecordListener(RecordListener l) 增加一个RecordtListener的事件监听器
void | DatasetAdapter.addRecordListener(RecordListener l) 增加一个RecordtListener的事件监听器
void | DatasetAdapter.removeRecordListener(RecordListener l) 删除一个RecordtListener的事件监听器
void | DatasetSupport.removeRecordListener(RecordListener l) 删除一个RecordtListener的事件监听器
void | DatasetSupport.addRecordListener(RecordListener l) 增加一个RecordtListener的事件监听器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.RecordSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.RecordSet

Packages that use RecordSet
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of RecordSet in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return RecordSet
RecordSet | Dataset.recordSet() 返回Dataset的Record集合对象
RecordSet | DatasetAdapter.recordSet() 返回Dataset的Record集合对象
RecordSet | DatasetSupport.recordSet() 返回Dataset的Record集合对象
RecordSet | ReadRecord.getDetailRecords(java.lang.String detailProperty) getDetailRecords

Methods in com.bstek.dorado.data with parameters of type RecordSet
void | Dataset.setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | DatasetAdapter.setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | DatasetSupport.setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | Record.setDetailRecords(java.lang.String detailProperty, RecordSet records) setDetailRecords

Uses of RecordSet in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return RecordSet
 RecordSet ViewDatasetAdapter.recordSet()
返回Dataset的Record集合对象

Methods in com.bstek.dorado.view.data with parameters of type RecordSet
void | ViewDatasetAdapter.setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象
void | ViewDatasetSupport.setRecordSet(RecordSet recordset) 设定Dataset的Record集合对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.RecordWrapper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.RecordWrapper

Packages that use RecordWrapper
com.bstek.dorado.data 数据集的相关类

Uses of RecordWrapper in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return RecordWrapper
protected RecordWrapper | DatasetSupport.findPrev(RecordWrapper wrapper) findPrev
protected RecordWrapper | DatasetSupport.findNext(RecordWrapper wrapper) findNext
RecordWrapper | RecordSet.getFirstWrapper() 取得记录集合中的第一条记录的包装器.
RecordWrapper | RecordSet.getLastWrapper() 取得记录集合中的最后一条记录的包装器.
RecordWrapper | RecordSet.findWrapper(Record record) 寻找并返回指定记录的包装器.
RecordWrapper | RecordSet.insertRecord(Record record) 插入一条记录
RecordWrapper | RecordWrapper.getPrev() 取得上一个记录包装器
RecordWrapper | RecordWrapper.getNext() 取得下一个记录包装器

Methods in com.bstek.dorado.data with parameters of type RecordWrapper
protected RecordWrapper | DatasetSupport.findPrev(RecordWrapper wrapper) findPrev
protected RecordWrapper | DatasetSupport.findNext(RecordWrapper wrapper) findNext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.data.custom
Classes
CustomDataset


com.bstek.dorado.data.custom Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.data.custom

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.data.DatasetSupport (implements com.bstek.dorado.data.DataListener, com.bstek.dorado.data.Dataset)
      • class com.bstek.dorado.data.AbstractDataset
        • class com.bstek.dorado.data.custom.CustomDataset


Uses of Package com.bstek.dorado.data.custom

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.data.custom

No usage of com.bstek.dorado.data.custom

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.custom.CustomDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.custom.CustomDataset

No usage of com.bstek.dorado.data.custom.CustomDataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.data.db
Interfaces
MatchRule
Classes
AggregateMode
AndOrMatchRule
AutoDBField
AutoSqlDataset
BaseMatchRule
CaseInsensitiveVariantSet
CommonMatchRule
DBDataset
DBField
DBStatement
JoinTable
SortRule
SqlDataset
SqlMatchRule


com.bstek.dorado.data.db Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.data.db

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.data.AbstractField (implements com.bstek.dorado.data.Field)
      • class com.bstek.dorado.data.BaseField
        • class com.bstek.dorado.data.db.DBField
          • class com.bstek.dorado.data.db.AutoDBField
    • class com.bstek.dorado.data.db.AggregateMode
    • class com.bstek.dorado.data.db.AndOrMatchRule (implements com.bstek.dorado.data.db.MatchRule)
    • class com.bstek.dorado.data.db.CommonMatchRule (implements com.bstek.dorado.data.db.MatchRule)
      • class com.bstek.dorado.data.db.BaseMatchRule
      • class com.bstek.dorado.data.db.SqlMatchRule
    • class com.bstek.dorado.data.DatasetSupport (implements com.bstek.dorado.data.DataListener, com.bstek.dorado.data.Dataset)
      • class com.bstek.dorado.data.AbstractDataset
        • class com.bstek.dorado.data.db.DBDataset
          • class com.bstek.dorado.data.db.AutoSqlDataset
          • class com.bstek.dorado.data.db.SqlDataset
    • class com.bstek.dorado.data.db.DBStatement
    • class com.bstek.dorado.data.db.JoinTable
    • class com.bstek.dorado.data.db.SortRule
    • class com.bstek.dorado.utils.variant.VariantSet (implements java.lang.Cloneable, java.io.Serializable)
      • class com.bstek.dorado.data.db.CaseInsensitiveVariantSet

Interface Hierarchy

  • interface com.bstek.dorado.data.db.MatchRule


Uses of Package com.bstek.dorado.data.db

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.data.db

Packages that use com.bstek.dorado.data.db
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Classes in com.bstek.dorado.data.db used by com.bstek.dorado.data.db
AndOrMatchRule
用于描述AutoSqlDataset的WHERE片断中的and/or逻辑连接符的规则对象
BaseMatchRule
用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
CommonMatchRule
用于描述AutoSqlDataset的WHERE片断的匹配规则抽象类.
DBDataset
基于SQL的Dataset的抽象基类
DBField
DBDataset记录集的字段对象
JoinTable
用于描述AutoSqlDataset的关联表信息的对象.
MatchRule
用于描述AutoSqlDataset的WHERE片断的规则对象的接口.
SortRule
用于描述AutoSqlDataset的SORT BY片断的排序规则对象
SqlMatchRule
用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.AggregateMode

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.AggregateMode

No usage of com.bstek.dorado.data.db.AggregateMode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.AndOrMatchRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.AndOrMatchRule

Packages that use AndOrMatchRule
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of AndOrMatchRule in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return AndOrMatchRule
 AndOrMatchRule AutoSqlDataset.addAndOrMatchRule(java.lang.String kind)
根据指定逻辑连接符的类型添加一个逻辑连接规则(AndOrMatchRule), 并返回新的逻辑连接规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.AutoDBField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.AutoDBField

No usage of com.bstek.dorado.data.db.AutoDBField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.AutoSqlDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.AutoSqlDataset

No usage of com.bstek.dorado.data.db.AutoSqlDataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.BaseMatchRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.BaseMatchRule

Packages that use BaseMatchRule
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of BaseMatchRule in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return BaseMatchRule
 BaseMatchRule AutoSqlDataset.addBaseMatchRule(java.lang.String originField, java.lang.String operator, java.lang.String value)
根据指定的物理字段名、比较操作符和匹配值添加一个基本匹配规则(BaseMatchRule), 并返回新的基本匹配规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.CaseInsensitiveVariantSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.CaseInsensitiveVariantSet

No usage of com.bstek.dorado.data.db.CaseInsensitiveVariantSet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.CommonMatchRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.CommonMatchRule

Packages that use CommonMatchRule
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of CommonMatchRule in com.bstek.dorado.data.db

Subclasses of CommonMatchRule in com.bstek.dorado.data.db
class | BaseMatchRule 用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
class | SqlMatchRule 用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.DBDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.DBDataset

Packages that use DBDataset
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of DBDataset in com.bstek.dorado.data.db

Subclasses of DBDataset in com.bstek.dorado.data.db
class | AutoSqlDataset 自动SQL记录集.
class | SqlDataset 基于SQL的Dataset.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.DBField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.DBField

Packages that use DBField
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of DBField in com.bstek.dorado.data.db

Subclasses of DBField in com.bstek.dorado.data.db
 class AutoDBField
自动SQL记录集的字段对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.DBStatement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.DBStatement

No usage of com.bstek.dorado.data.db.DBStatement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.JoinTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.JoinTable

Packages that use JoinTable
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of JoinTable in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return JoinTable
 JoinTable AutoSqlDataset.addJoin(java.lang.String name)
根据要关联的表的别名添加一个关联(JoinTable)并返回新的关联对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.data.db.MatchRule

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.data.db.MatchRule

Packages that use MatchRule
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of MatchRule in com.bstek.dorado.data.db

Classes in com.bstek.dorado.data.db that implement MatchRule
class | AndOrMatchRule 用于描述AutoSqlDataset的WHERE片断中的and/or逻辑连接符的规则对象
class | BaseMatchRule 用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
class | CommonMatchRule 用于描述AutoSqlDataset的WHERE片断的匹配规则抽象类.
class | SqlMatchRule 用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.SortRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.SortRule

Packages that use SortRule
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of SortRule in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return SortRule
SortRule | AutoSqlDataset.addSortRule(java.lang.String originField) 根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.
SortRule | AutoSqlDataset.addSortRule(java.lang.String table, java.lang.String originField, boolean descent) 根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.SqlDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.SqlDataset

No usage of com.bstek.dorado.data.db.SqlDataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.data.db.SqlMatchRule

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.data.db.SqlMatchRule

Packages that use SqlMatchRule
com.bstek.dorado.data.db 实现可直接访问数据库的数据集

Uses of SqlMatchRule in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return SqlMatchRule
 SqlMatchRule AutoSqlDataset.addSqlMatchRule(java.lang.String sql)
根据指定SQL片断添加一个SQL匹配规则(SqlMatchRule), 并返回新的SQL匹配规则对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.i18n
Classes
LocaleHelper
ResourceManager
ResourceManagerContextMap


com.bstek.dorado.i18n Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.i18n

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.common.rtexpr.impl.AbstractContextMap (implements java.util.Map)
      • class com.bstek.dorado.i18n.ResourceManagerContextMap
    • class com.bstek.dorado.i18n.LocaleHelper
    • class com.bstek.dorado.i18n.ResourceManager


Uses of Package com.bstek.dorado.i18n

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.i18n

Packages that use com.bstek.dorado.i18n
com.bstek.dorado.i18n 用于支持国际化

Classes in com.bstek.dorado.i18n used by com.bstek.dorado.i18n
ResourceManager
国际化资源的管理对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.i18n.LocaleHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.i18n.LocaleHelper

No usage of com.bstek.dorado.i18n.LocaleHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.i18n.ResourceManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.i18n.ResourceManager

Packages that use ResourceManager
com.bstek.dorado.i18n 用于支持国际化

Uses of ResourceManager in com.bstek.dorado.i18n

Methods in com.bstek.dorado.i18n that return ResourceManager
static ResourceManager ResourceManager.getInstance()
获得单例对象

Constructors in com.bstek.dorado.i18n with parameters of type ResourceManager
ResourceManagerContextMap(DoradoContext context, ResourceManager resource)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.i18n.ResourceManagerContextMap

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.i18n.ResourceManagerContextMap

No usage of com.bstek.dorado.i18n.ResourceManagerContextMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.module
Classes
DefaultModule
ModuleManager
ModuleSupport


com.bstek.dorado.module Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.module

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.module.ModuleManager
    • class com.bstek.dorado.module.ModuleSupport (implements com.bstek.dorado.module.Module)
      • class com.bstek.dorado.module.DefaultModule


Uses of Package com.bstek.dorado.module

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.module

Packages that use com.bstek.dorado.module
com.bstek.dorado.module 数据模块的相关类

Classes in com.bstek.dorado.module used by com.bstek.dorado.module
ModuleSupport
Module的基本实现

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.module.DefaultModule

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.module.DefaultModule

No usage of com.bstek.dorado.module.DefaultModule

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.module.Module

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.module.Module

Packages that use Module
com.bstek.dorado.module 包含用于实现dorado的数据模块(Module)的类

Uses of Module in com.bstek.dorado.module

Classes in com.bstek.dorado.module that implement Module
class | DefaultModule
class | com.bstek.dorado.module.ModuleSupport

Methods in com.bstek.dorado.module that return Module
static Module | ModuleManager.getModule(java.lang.String moduleName) 根据给定的名称取得Module对象的实例.
static Module | ModuleManager.getModule(com.bstek.dorado.module.config.ModuleConfig config) 根据给定的配置对象取得Module对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.module.ModuleManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.module.ModuleManager

No usage of com.bstek.dorado.module.ModuleManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.module.ModuleSupport

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.module.ModuleSupport

Packages that use ModuleSupport
com.bstek.dorado.module 数据模块的相关类

Uses of ModuleSupport in com.bstek.dorado.module

Subclasses of ModuleSupport in com.bstek.dorado.module
 class DefaultModule
默认的Module抽象实现类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.security
Interfaces
AccessChecker
Exceptions
AccessDeniedException
UserNotLoggedInException


com.bstek.dorado.security Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.security

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class com.bstek.dorado.utils.DoradoRuntimeException
            • class com.bstek.dorado.security.AccessDeniedException
              • class com.bstek.dorado.security.UserNotLoggedInException

Interface Hierarchy

  • interface com.bstek.dorado.security.AccessChecker


Uses of Package com.bstek.dorado.security

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.security

Packages that use com.bstek.dorado.security
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。

Classes in com.bstek.dorado.security used by com.bstek.dorado.action
AccessDeniedException
用户登录状态校验失败产生的异常

Classes in com.bstek.dorado.security used by com.bstek.dorado.security
AccessDeniedException
用户登录状态校验失败产生的异常

Classes in com.bstek.dorado.security used by com.bstek.dorado.view
AccessDeniedException
用户登录状态校验失败产生的异常

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.security.AccessChecker

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.security.AccessChecker

No usage of com.bstek.dorado.security.AccessChecker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.security.AccessDeniedException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.security.AccessDeniedException

Packages that use AccessDeniedException
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。

Uses of AccessDeniedException in com.bstek.dorado.action

Methods in com.bstek.dorado.action that throw AccessDeniedException
protected  void Controller.checkAccess(Action action, javax.servlet.http.HttpServletRequest request, javax.servlet.http.HttpServletResponse response)
按系统默认的方式判断当前用户是否已登录

Uses of AccessDeniedException in com.bstek.dorado.security

Subclasses of AccessDeniedException in com.bstek.dorado.security
 class UserNotLoggedInException
用户没有登录的异常

Methods in com.bstek.dorado.security that throw AccessDeniedException
 void AccessChecker.checkAccess(DoradoContext context, java.lang.Object accessingObject)
校验用户登录状态的方法

Uses of AccessDeniedException in com.bstek.dorado.view

Methods in com.bstek.dorado.view that throw AccessDeniedException
protected  void ViewModelSupport.checkAccess(DoradoContext context)
按系统默认的方式判断当前用户是否已登录

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.security.UserNotLoggedInException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.security.UserNotLoggedInException

No usage of com.bstek.dorado.security.UserNotLoggedInException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.utils
Classes
ClassHelper
MetaData
Printf
StringHelper
SynchroTimer
SystemVariable
UniqueKey
Exceptions
DoradoException
DoradoRuntimeException
InvalidPropertyValueException


com.bstek.dorado.utils Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.utils

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.utils.ClassHelper
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class com.bstek.dorado.utils.SystemVariable
    • class com.bstek.dorado.utils.Printf
    • class com.bstek.dorado.utils.StringHelper
    • class com.bstek.dorado.utils.SynchroTimer
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class com.bstek.dorado.utils.DoradoException
        • class java.lang.RuntimeException
          • class com.bstek.dorado.utils.DoradoRuntimeException
            • class com.bstek.dorado.utils.InvalidPropertyValueException
    • class com.bstek.dorado.utils.UniqueKey
    • class com.bstek.dorado.utils.variant.VariantSet (implements java.lang.Cloneable, java.io.Serializable)
      • class com.bstek.dorado.utils.MetaData


Uses of Package com.bstek.dorado.utils

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.utils

Packages that use com.bstek.dorado.utils
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.utils | Dorado的基本工具类
com.bstek.dorado.utils.collection | 对象集合类
com.bstek.dorado.utils.xml | 与XML相关的工具类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate | 数据校验器的相关类

Classes in com.bstek.dorado.utils used by com.bstek.dorado.action
DoradoException
所有Dorado中异常的基类

Classes in com.bstek.dorado.utils used by com.bstek.dorado.biz
MetaData
元数据对象集合

Classes in com.bstek.dorado.utils used by com.bstek.dorado.data
DoradoRuntimeException
所有Dorado中Runtime异常的基类
MetaData
元数据对象集合

Classes in com.bstek.dorado.utils used by com.bstek.dorado.security
DoradoRuntimeException
所有Dorado中Runtime异常的基类

Classes in com.bstek.dorado.utils used by com.bstek.dorado.utils
DoradoRuntimeException
所有Dorado中Runtime异常的基类

Classes in com.bstek.dorado.utils used by com.bstek.dorado.utils.collection
DoradoRuntimeException
所有Dorado中Runtime异常的基类

Classes in com.bstek.dorado.utils used by com.bstek.dorado.utils.xml
DoradoException
所有Dorado中异常的基类

Classes in com.bstek.dorado.utils used by com.bstek.dorado.view
MetaData
元数据对象集合

Classes in com.bstek.dorado.utils used by com.bstek.dorado.view.data
MetaData
元数据对象集合

Classes in com.bstek.dorado.utils used by com.bstek.dorado.view.data.validate
DoradoRuntimeException
所有Dorado中Runtime异常的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.ClassHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.ClassHelper

No usage of com.bstek.dorado.utils.ClassHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.DoradoException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.DoradoException

Packages that use DoradoException
com.bstek.dorado.action | 实现Dorado的Controller部分的功能。
com.bstek.dorado.utils.xml | 与XML相关的工具类

Uses of DoradoException in com.bstek.dorado.action

Subclasses of DoradoException in com.bstek.dorado.action
class | ActionNotSuppertedException 无法找到指定的Action的异常。
class | ControllerNotFoundException 无法找到指定的Controller的异常。

Uses of DoradoException in com.bstek.dorado.utils.xml

Subclasses of DoradoException in com.bstek.dorado.utils.xml
class | LoadXmlPropertyException 加载XML属性时发生的异常
class | XmlParseException Xml解析异常

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.DoradoRuntimeException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.DoradoRuntimeException

Packages that use DoradoRuntimeException
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.security | 包含用于支持应用系统访问安全性的类
com.bstek.dorado.utils | Dorado的基本工具类
com.bstek.dorado.utils.collection | 对象集合类
com.bstek.dorado.view.data.validate | 数据校验器的相关类

Uses of DoradoRuntimeException in com.bstek.dorado.data

Subclasses of DoradoRuntimeException in com.bstek.dorado.data
class | FieldNotExistException 无法找到指定的Field对象的异常。
class | NoCurrentRecordException 无当前记录异常。

Uses of DoradoRuntimeException in com.bstek.dorado.security

Subclasses of DoradoRuntimeException in com.bstek.dorado.security
class | AccessDeniedException 用户登录状态校验失败产生的异常
class | UserNotLoggedInException 用户没有登录的异常

Uses of DoradoRuntimeException in com.bstek.dorado.utils

Subclasses of DoradoRuntimeException in com.bstek.dorado.utils
 class InvalidPropertyValueException
无效属性值的异常

Uses of DoradoRuntimeException in com.bstek.dorado.utils.collection

Subclasses of DoradoRuntimeException in com.bstek.dorado.utils.collection
class | DuplicateKeyException 键值重复异常
class | KeyNotExistException 无效键值异常

Uses of DoradoRuntimeException in com.bstek.dorado.view.data.validate

Subclasses of DoradoRuntimeException in com.bstek.dorado.view.data.validate
 class IllegalValueException
非法值异常。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.InvalidPropertyValueException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.InvalidPropertyValueException

No usage of com.bstek.dorado.utils.InvalidPropertyValueException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.MetaData

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.MetaData

Packages that use MetaData
com.bstek.dorado.biz | 为了增强Dorado的可用性而特别提供给用户的一些通用类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of MetaData in com.bstek.dorado.biz

Methods in com.bstek.dorado.biz with parameters of type MetaData
protected java.io.File | FileController.getUploadWorkDirectory(javax.servlet.http.HttpServletRequest request, MetaData parameters) 取得存放上传文件的工作目录
protected java.lang.String | FileController.getStoreFileName(javax.servlet.http.HttpServletRequest request, java.lang.String fileName, MetaData parameters) 取得存储上传文件的文件名
protected void | FileController.storeUploadFile(javax.servlet.http.HttpServletRequest request, org.apache.commons.fileupload.FileItem fileItem, java.io.File storeFile, MetaData parameters) 存储已经上传的文件

Uses of MetaData in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return MetaData
MetaData | Dataset.properties() 与Dataset相关的一组属性值.
MetaData | DatasetAdapter.properties() 与Dataset相关的一组属性值. 这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.
MetaData | DatasetSupport.properties() 与Dataset相关的一组属性值. 这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.
MetaData | Field.properties() 返回所有元数据的集合对象。

Uses of MetaData in com.bstek.dorado.view

Methods in com.bstek.dorado.view that return MetaData
MetaData | ViewModel.properties() 属性集合
MetaData | ViewModelSupport.properties() 属性集合

Uses of MetaData in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return MetaData
 MetaData ViewDatasetAdapter.properties()
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.Printf

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.Printf

No usage of com.bstek.dorado.utils.Printf

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.StringHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.StringHelper

No usage of com.bstek.dorado.utils.StringHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.SynchroTimer

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.SynchroTimer

No usage of com.bstek.dorado.utils.SynchroTimer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.SystemVariable

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.SystemVariable

No usage of com.bstek.dorado.utils.SystemVariable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.UniqueKey

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.UniqueKey

No usage of com.bstek.dorado.utils.UniqueKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.utils.codec
Classes
Encrypt
EncryptCode
EscapeUtils
SafeCode


com.bstek.dorado.utils.codec Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.utils.codec

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.utils.codec.Encrypt
    • class com.bstek.dorado.utils.codec.EncryptCode
    • class com.bstek.dorado.utils.codec.EscapeUtils
    • class com.bstek.dorado.utils.codec.SafeCode


Uses of Package com.bstek.dorado.utils.codec

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.utils.codec

No usage of com.bstek.dorado.utils.codec

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.codec.Encrypt

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.codec.Encrypt

No usage of com.bstek.dorado.utils.codec.Encrypt

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.codec.EncryptCode

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.codec.EncryptCode

No usage of com.bstek.dorado.utils.codec.EncryptCode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.codec.EscapeUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.codec.EscapeUtils

No usage of com.bstek.dorado.utils.codec.EscapeUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.codec.SafeCode

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.codec.SafeCode

No usage of com.bstek.dorado.utils.codec.SafeCode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.utils.collection
Interfaces
ObjectCollection
Classes
ObjectList
Exceptions
DuplicateKeyException
KeyNotExistException


com.bstek.dorado.utils.collection Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.utils.collection

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.utils.collection.ObjectList (implements com.bstek.dorado.utils.collection.ObjectCollection, java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class com.bstek.dorado.utils.DoradoRuntimeException
            • class com.bstek.dorado.utils.collection.DuplicateKeyException
            • class com.bstek.dorado.utils.collection.KeyNotExistException

Interface Hierarchy

  • interface java.lang.Cloneable
    • interface com.bstek.dorado.utils.collection.ObjectCollection


Uses of Package com.bstek.dorado.utils.collection

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.utils.collection

Packages that use com.bstek.dorado.utils.collection
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils.collection | 对象集合类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.data.db
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.utils.collection
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.view
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.view.control
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.view.control.autoform
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.view.control.table
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.view.control.tabset
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Classes in com.bstek.dorado.utils.collection used by com.bstek.dorado.view.control.tree
ObjectCollection
对象列表接口,定义对象列表的基本方法。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.collection.DuplicateKeyException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.collection.DuplicateKeyException

No usage of com.bstek.dorado.utils.collection.DuplicateKeyException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.collection.KeyNotExistException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.collection.KeyNotExistException

No usage of com.bstek.dorado.utils.collection.KeyNotExistException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.utils.collection.ObjectCollection

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.utils.collection.ObjectCollection

Packages that use ObjectCollection
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils.collection | 对象集合类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Uses of ObjectCollection in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return ObjectCollection
 ObjectCollection AutoSqlDataset.joins()
返回AutoSqlDataset所有Join的集合对象。

Uses of ObjectCollection in com.bstek.dorado.utils.collection

Classes in com.bstek.dorado.utils.collection that implement ObjectCollection
 class ObjectList
对象列表的实现。

Uses of ObjectCollection in com.bstek.dorado.view

Fields in com.bstek.dorado.view declared as ObjectCollection
protected ObjectCollection | ViewModelSupport.datasets
protected ObjectCollection | ViewModelSupport.controls

Uses of ObjectCollection in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control that return ObjectCollection
 ObjectCollection OutlookBar.getGroups()
取得所有多页标签的集合对象。

Uses of ObjectCollection in com.bstek.dorado.view.control.autoform

Methods in com.bstek.dorado.view.control.autoform that return ObjectCollection
ObjectCollection | AutoForm.getGroups() 取得所有组的集合对象
ObjectCollection | FormGroup.getElements() 返回组中所有元素的集合对象。

Uses of ObjectCollection in com.bstek.dorado.view.control.table

Methods in com.bstek.dorado.view.control.table that return ObjectCollection
ObjectCollection | ColumnGroup.columns() 取得所有子列的集合对象。
ObjectCollection | Table.columns() 取得所有列的集合对象。

Uses of ObjectCollection in com.bstek.dorado.view.control.tabset

Methods in com.bstek.dorado.view.control.tabset that return ObjectCollection
 ObjectCollection TabSet.getTabs()
取得所有多页标签的集合对象。

Uses of ObjectCollection in com.bstek.dorado.view.control.tree

Methods in com.bstek.dorado.view.control.tree that return ObjectCollection
ObjectCollection | DataTree.getTreeLevels() 返回所有节点层的集合
ObjectCollection | TreeLevel.getTreeLevels() 返回所有子节点层的集合

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.collection.ObjectList

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.collection.ObjectList

No usage of com.bstek.dorado.utils.collection.ObjectList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.utils.http
Classes
RequestHelper
ResponseUtil
UrlUtil


com.bstek.dorado.utils.http Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.utils.http

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.utils.http.RequestHelper
    • class com.bstek.dorado.utils.http.ResponseUtil
    • class com.bstek.dorado.utils.http.UrlUtil


Uses of Package com.bstek.dorado.utils.http

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.utils.http

No usage of com.bstek.dorado.utils.http

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.http.RequestHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.http.RequestHelper

No usage of com.bstek.dorado.utils.http.RequestHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.http.ResponseUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.http.ResponseUtil

No usage of com.bstek.dorado.utils.http.ResponseUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.http.UrlUtil

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.http.UrlUtil

No usage of com.bstek.dorado.utils.http.UrlUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.utils.variant
Classes
DataType
Variant
VariantHelper
VariantSet


com.bstek.dorado.utils.variant Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.utils.variant

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.utils.variant.DataType
    • class com.bstek.dorado.utils.variant.Variant (implements java.lang.Cloneable, java.io.Serializable)
    • class com.bstek.dorado.utils.variant.VariantHelper
    • class com.bstek.dorado.utils.variant.VariantSet (implements java.lang.Cloneable, java.io.Serializable)


Uses of Package com.bstek.dorado.utils.variant

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.utils.variant

Packages that use com.bstek.dorado.utils.variant
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils | Dorado的基本工具类
com.bstek.dorado.utils.http | 一些与HTTP相关的工具类
com.bstek.dorado.utils.variant | 包含用于实现多态数据类型的类

Classes in com.bstek.dorado.utils.variant used by com.bstek.dorado.data
Variant
可支持多种类型的对象
VariantSet
可支持多种类型的对象集合。

Classes in com.bstek.dorado.utils.variant used by com.bstek.dorado.data.db
Variant
可支持多种类型的对象
VariantSet
可支持多种类型的对象集合。

Classes in com.bstek.dorado.utils.variant used by com.bstek.dorado.utils
VariantSet
可支持多种类型的对象集合。

Classes in com.bstek.dorado.utils.variant used by com.bstek.dorado.utils.http
VariantSet
可支持多种类型的对象集合。

Classes in com.bstek.dorado.utils.variant used by com.bstek.dorado.utils.variant
Variant
可支持多种类型的对象
VariantSet
可支持多种类型的对象集合。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.variant.DataType

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.variant.DataType

No usage of com.bstek.dorado.utils.variant.DataType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.variant.Variant

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.variant.Variant

Packages that use Variant
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils.variant | 包含用于实现多态数据类型的类

Uses of Variant in com.bstek.dorado.data

Methods in com.bstek.dorado.data that return Variant
Variant | ParameterSet.getVariant(java.lang.String name) 根据键值并按Variant类型读取数据
Variant | ReadRecord.getVariant(java.lang.String name) 按Variant类型返回记录中某字段的值。

Methods in com.bstek.dorado.data with parameters of type Variant
void | DataListener.beforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 当数据将要被修改之前被触发的事件.
void | DatasetSupport.beforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 当数据将要被修改之前被触发的事件.
protected void | DatasetSupport.fireBeforeChange(ReadRecord record, java.lang.String fieldName, Variant value) 触发BeforeChange事件
void | ParameterSet.setVariant(java.lang.String name, Variant v) 根据键值设置Variant类型的数据
void | RecordListener.beforeChange(Dataset dataset, ReadRecord record, java.lang.String fieldName, Variant value) 当Dataset中某条记录的数据将要被修改之前被触发的事件.

Uses of Variant in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db that return Variant
 Variant CaseInsensitiveVariantSet.getVariant(java.lang.String name)
Deprecated.

Methods in com.bstek.dorado.data.db with parameters of type Variant
 void CaseInsensitiveVariantSet.setVariant(java.lang.String name, Variant v)
Deprecated.

Uses of Variant in com.bstek.dorado.utils.variant

Methods in com.bstek.dorado.utils.variant that return Variant
Variant | VariantSet.getVariant(int index) 根据索引号并按Variant类型读取数据
Variant | VariantSet.getVariant(java.lang.String name) 根据键值并按Variant类型读取数据

Methods in com.bstek.dorado.utils.variant with parameters of type Variant
 void VariantSet.setVariant(java.lang.String name, Variant v)
根据键值设置Variant类型的数据

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.variant.VariantHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.variant.VariantHelper

No usage of com.bstek.dorado.utils.variant.VariantHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.variant.VariantSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.variant.VariantSet

Packages that use VariantSet
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils | Dorado的基本工具类
com.bstek.dorado.utils.http | 一些与HTTP相关的工具类
com.bstek.dorado.utils.variant | 包含用于实现多态数据类型的类

Uses of VariantSet in com.bstek.dorado.data

Subclasses of VariantSet in com.bstek.dorado.data
 class ParameterSet
参数的集合类

Methods in com.bstek.dorado.data that return VariantSet
static VariantSet DOUtils.DOToVariantSet(java.lang.Object o, VariantSet variantSet)
利用反射从o参数指定的对象中读取数据并设置到给定的变量集合中.

Methods in com.bstek.dorado.data with parameters of type VariantSet
static void | DOUtils.variantSetToDO(VariantSet variantSet, java.lang.Object o) 将给定的变量集合中包含的数据设置到给定的对象当中.
static VariantSet | DOUtils.DOToVariantSet(java.lang.Object o, VariantSet variantSet) 利用反射从o参数指定的对象中读取数据并设置到给定的变量集合中.

Uses of VariantSet in com.bstek.dorado.data.db

Subclasses of VariantSet in com.bstek.dorado.data.db
 class CaseInsensitiveVariantSet
可支持多种类型的对象集合。

Methods in com.bstek.dorado.data.db that return VariantSet
 VariantSet DBStatement.query()
执行一个查询命令并返回第一条记录的值.如果本次查询没有查到任何记录将返回null.

Uses of VariantSet in com.bstek.dorado.utils

Subclasses of VariantSet in com.bstek.dorado.utils
 class MetaData
元数据对象集合

Uses of VariantSet in com.bstek.dorado.utils.http

Methods in com.bstek.dorado.utils.http with parameters of type VariantSet
protected void | RequestHelper.parametersToVariantSet(VariantSet variants) 将当前Request中包含的参数(Parameter)设置到给定的VariantSet当中.
protected void | RequestHelper.attributiesToVariantSet(VariantSet variants) 将当前Request中包含的属性(Attribute)设置到给定的VariantSet当中.

Uses of VariantSet in com.bstek.dorado.utils.variant

Methods in com.bstek.dorado.utils.variant with parameters of type VariantSet
 void VariantSet.assign(VariantSet variants)
将本集合中的所有数据全部指派到给定的另一个集合中.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.utils.xml
Interfaces
XmlBuilder
XmlDocument
XmlNode
XmlOutputter
Classes
XmlConfigUtils
XmlFactory
Exceptions
LoadXmlPropertyException
XmlParseException


com.bstek.dorado.utils.xml Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.utils.xml

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class com.bstek.dorado.utils.DoradoException
          • class com.bstek.dorado.utils.xml.LoadXmlPropertyException
          • class com.bstek.dorado.utils.xml.XmlParseException
    • class com.bstek.dorado.utils.xml.XmlConfigUtils
    • class com.bstek.dorado.utils.xml.XmlFactory

Interface Hierarchy

  • interface com.bstek.dorado.utils.xml.XmlBuilder
  • interface com.bstek.dorado.utils.xml.XmlDocument
  • interface com.bstek.dorado.utils.xml.XmlNode
  • interface com.bstek.dorado.utils.xml.XmlOutputter


Uses of Package com.bstek.dorado.utils.xml

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.utils.xml

Packages that use com.bstek.dorado.utils.xml
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.common | Dorado系统中的一些通用类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils.xml | 与XML相关的工具类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.action.mapping
XmlParseException
Xml解析异常

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.common
LoadXmlPropertyException
加载XML属性时发生的异常
XmlParseException
Xml解析异常

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.data
LoadXmlPropertyException
加载XML属性时发生的异常
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.data.db
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.utils.xml
LoadXmlPropertyException
加载XML属性时发生的异常
XmlBuilder
XML构造器的接口
XmlDocument
用于封装第三方的XML解析器中的文档对象。
XmlNode
用于封装第三方的XML解析器中的XML节点对象。
XmlOutputter
XML输出器的接口。
XmlParseException
Xml解析异常

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control
LoadXmlPropertyException
加载XML属性时发生的异常
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control.autoform
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control.command
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control.dropdown
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control.table
LoadXmlPropertyException
加载XML属性时发生的异常
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control.tabset
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.control.tree
LoadXmlPropertyException
加载XML属性时发生的异常
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.data
LoadXmlPropertyException
加载XML属性时发生的异常
XmlNode
用于封装第三方的XML解析器中的XML节点对象。

Classes in com.bstek.dorado.utils.xml used by com.bstek.dorado.view.rpc
XmlDocument
用于封装第三方的XML解析器中的文档对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.xml.LoadXmlPropertyException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.xml.LoadXmlPropertyException

Packages that use LoadXmlPropertyException
com.bstek.dorado.common | Dorado系统中的一些通用类
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.utils.xml | 与XML相关的工具类
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of LoadXmlPropertyException in com.bstek.dorado.common

Methods in com.bstek.dorado.common that throw LoadXmlPropertyException
static void UserConfig.load()
装载配置文件。

Uses of LoadXmlPropertyException in com.bstek.dorado.data

Methods in com.bstek.dorado.data that throw LoadXmlPropertyException
protected  Field DatasetSupport.createFieldByNode(DoradoContext context, XmlNode node)
根据一个描述字段的XML节点自动创建字段对象.

Uses of LoadXmlPropertyException in com.bstek.dorado.utils.xml

Methods in com.bstek.dorado.utils.xml that throw LoadXmlPropertyException
static void | XmlConfigUtils.loadAttributies(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | XmlConfigUtils.loadAttributies(XmlNode node, java.lang.Object o, java.lang.String except) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | XmlConfigUtils.loadAttributies(XmlNode node, java.lang.Object o, java.lang.String[] excepts) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | XmlConfigUtils.loadChildNodes(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildNodes(XmlNode node, java.lang.Object o, java.lang.String except) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildNodes(XmlNode node, java.lang.Object o, java.lang.String[] excepts) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildProperties(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildProperties(XmlNode node, java.util.Properties properties) 根据名称自动读取一个XML节点下的所有子节点中的值到Properties对象中。

Uses of LoadXmlPropertyException in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control that throw LoadXmlPropertyException
protected  void Menu.loadItems(DoradoContext context, XmlNode node, MenuItem menuItem)
加载菜单项

Uses of LoadXmlPropertyException in com.bstek.dorado.view.control.table

Methods in com.bstek.dorado.view.control.table that throw LoadXmlPropertyException
void | Column.init(DoradoContext context, XmlNode node) 列初始化
protected void | DataTable.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
protected void | Table.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列

Uses of LoadXmlPropertyException in com.bstek.dorado.view.control.tree

Methods in com.bstek.dorado.view.control.tree that throw LoadXmlPropertyException
protected void | DataTree.loadChildLevels(TreeLevel level, XmlNode node, DoradoContext context) 加载子节点层
protected TreeLevel | DataTree.createTreeLevel(XmlNode node, DoradoContext context) 根据XML节点创建节点层
protected void | Tree.loadNodes(DoradoContext context, XmlNode node, TreeNode treeNode) 加载树节点

Uses of LoadXmlPropertyException in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that throw LoadXmlPropertyException
protected Field | DatasetWrapper.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
void | ViewDatasetAdapter.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected void | ViewDatasetSupport.initValidator(Validator validator, XmlNode validatorNode) initValidator
protected Field | ViewDatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.utils.xml.XmlBuilder

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.utils.xml.XmlBuilder

Packages that use XmlBuilder
com.bstek.dorado.utils.xml 与XML相关的工具类

Uses of XmlBuilder in com.bstek.dorado.utils.xml

Methods in com.bstek.dorado.utils.xml that return XmlBuilder
static XmlBuilder XmlFactory.createXmlBuilder()
创建并返回一个XML构造器对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.xml.XmlConfigUtils

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.xml.XmlConfigUtils

No usage of com.bstek.dorado.utils.xml.XmlConfigUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.utils.xml.XmlDocument

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.utils.xml.XmlDocument

Packages that use XmlDocument
com.bstek.dorado.utils.xml | 与XML相关的工具类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Uses of XmlDocument in com.bstek.dorado.utils.xml

Methods in com.bstek.dorado.utils.xml that return XmlDocument
XmlDocument | XmlBuilder.newDocument() 创建一个空的XmlDocument对象
XmlDocument | XmlBuilder.buildDocument(java.lang.String s) 创建XmlDocument对象
XmlDocument | XmlBuilder.buildDocument(java.io.InputStream in) 创建XmlDocument对象
XmlDocument | XmlBuilder.buildDocument(java.io.File file) 利用文件对象创建XmlDocument对象

Methods in com.bstek.dorado.utils.xml with parameters of type XmlDocument
java.lang.String | XmlOutputter.outputString(XmlDocument xmlDocument) 以String格式输出整个XML
void | XmlOutputter.output(XmlDocument xmlDocument, java.io.OutputStream out) 输出整个XML
void | XmlOutputter.output(XmlDocument xmlDocument, java.io.Writer out) 输出整个XML
void | XmlOutputter.output(XmlDocument xmlDocument, java.io.File file) 输出整个XML
void | XmlOutputter.output(XmlDocument xmlDocument, java.lang.String filepath) 输出整个XML

Uses of XmlDocument in com.bstek.dorado.view.rpc

Methods in com.bstek.dorado.view.rpc that return XmlDocument
 XmlDocument RPCHandler.getXmlDocument()
取得客户端发送的XML信息

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.xml.XmlFactory

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.xml.XmlFactory

No usage of com.bstek.dorado.utils.xml.XmlFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.utils.xml.XmlNode

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.utils.xml.XmlNode

Packages that use XmlNode
com.bstek.dorado.data | 数据集的相关类
com.bstek.dorado.data.db | 实现可直接访问数据库的数据集
com.bstek.dorado.utils.xml | 与XML相关的工具类
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of XmlNode in com.bstek.dorado.data

Methods in com.bstek.dorado.data with parameters of type XmlNode
void | Dataset.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | DatasetAdapter.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | DatasetSupport.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected void | DatasetSupport.initListener(XmlNode node) 根据XML节点初试化监听器
protected Field | DatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.

Uses of XmlNode in com.bstek.dorado.data.db

Methods in com.bstek.dorado.data.db with parameters of type XmlNode
void | AutoSqlDataset.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
void | SqlDataset.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。

Uses of XmlNode in com.bstek.dorado.utils.xml

Methods in com.bstek.dorado.utils.xml that return XmlNode
XmlNode | XmlBuilder.newNode(java.lang.String name) 创建一个空的XmlNode对象
XmlNode | XmlDocument.getRootNode() 获得根节点
XmlNode | XmlDocument.createRootNode(java.lang.String name) 创建根节点。
XmlNode | XmlDocument.getNodeById(java.lang.String id) 根据ID返回一个节点，如果无法找到匹配的节点则返回null。
XmlNode | XmlDocument.getNodeByXPath(java.lang.String xpath) 根据XPath返回第一个匹配的节点。
XmlNode[] | XmlDocument.getNodesByXPath(java.lang.String xpath) 根据XPath返回所有匹配的节点。
XmlNode | XmlNode.addChild(java.lang.String name) 增加一个子节点
XmlNode | XmlNode.getParent() 返回父节点
XmlNode | XmlNode.getChild(java.lang.String name) 根据标记名返回子节点中的第一个匹配的节点，如果无法找到匹配的节点则返回null。
XmlNode[] | XmlNode.getChildren() 返回所有的子节点
XmlNode | XmlNode.getNodeByXPath(java.lang.String xpath) 根据XPath返回第一个匹配的节点。
XmlNode[] | XmlNode.getNodesByXPath(java.lang.String xpath) 根据XPath返回所有匹配的节点。
XmlNode | XmlNode.cloneNode() 克隆本节点

Methods in com.bstek.dorado.utils.xml with parameters of type XmlNode
static void | XmlConfigUtils.loadAttributies(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | XmlConfigUtils.loadAttributies(XmlNode node, java.lang.Object o, java.lang.String except) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | XmlConfigUtils.loadAttributies(XmlNode node, java.lang.Object o, java.lang.String[] excepts) 根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
static void | XmlConfigUtils.loadChildNodes(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildNodes(XmlNode node, java.lang.Object o, java.lang.String except) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildNodes(XmlNode node, java.lang.Object o, java.lang.String[] excepts) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildProperties(XmlNode node, java.lang.Object o) 根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
static void | XmlConfigUtils.loadChildProperties(XmlNode node, java.util.Properties properties) 根据名称自动读取一个XML节点下的所有子节点中的值到Properties对象中。
void | XmlDocument.setRootNode(XmlNode rootNode) 设置根节点。
void | XmlNode.addChild(XmlNode node) 增加一个子节点
java.lang.String | XmlOutputter.outputString(XmlNode xmlNode) 以String格式输出一个XML节点
void | XmlOutputter.output(XmlNode xmlNode, java.io.OutputStream out) 输出一个XML节点
void | XmlOutputter.output(XmlNode xmlNode, java.io.Writer out) 输出一个XML节点
void | XmlOutputter.output(XmlNode xmlNode, java.io.File file) 输出一个XML节点
void | XmlOutputter.output(XmlNode xmlNode, java.lang.String filepath) 输出一个XML节点

Uses of XmlNode in com.bstek.dorado.view

Methods in com.bstek.dorado.view with parameters of type XmlNode
void | Component.init(DoradoContext context, XmlNode node) 跟XML配置初始化
ViewDataset | ViewModel.createDataset(XmlNode node) 根据xml的定义创建一个视图数据集。
Control | ViewModel.createControl(XmlNode node) 根据xml定义创建对应的控件对象。
ViewDataset | ViewModelSupport.createDataset(XmlNode node) 根据xml的定义创建一个视图数据集。
Control | ViewModelSupport.createControl(XmlNode node) 根据xml定义创建对应的控件对象。

Uses of XmlNode in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control with parameters of type XmlNode
void | Calendar.init(DoradoContext context, XmlNode node) Deprecated.
void | Menu.init(DoradoContext context, XmlNode node)
protected void | Menu.loadItems(DoradoContext context, XmlNode node, MenuItem menuItem) 加载菜单项
void | OutlookBar.init(DoradoContext context, XmlNode node)

Uses of XmlNode in com.bstek.dorado.view.control.autoform

Methods in com.bstek.dorado.view.control.autoform with parameters of type XmlNode
void | AutoForm.init(DoradoContext context, XmlNode node)
protected void | AutoForm.loadGroups(DoradoContext context, XmlNode node) 加载组
void | CheckBoxFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | FormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | FormGroup.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个组
void | LabelFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | RadioGroupFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素
void | TextEditorFormElement.init(DoradoContext context, XmlNode node) 根据XML的配置初试化一个表单元素

Uses of XmlNode in com.bstek.dorado.view.control.command

Methods in com.bstek.dorado.view.control.command with parameters of type XmlNode
void | CommandQueue.init(DoradoContext context, XmlNode node)
void | RPCCommand.init(DoradoContext context, XmlNode node)
void | RequestCommand.init(DoradoContext context, XmlNode node)
void | UpdateCommand.init(DoradoContext context, XmlNode node)

Uses of XmlNode in com.bstek.dorado.view.control.dropdown

Methods in com.bstek.dorado.view.control.dropdown with parameters of type XmlNode
void | DynamicDropDown.init(DoradoContext context, XmlNode node)
void | ListDropDown.init(DoradoContext context, XmlNode node)

Uses of XmlNode in com.bstek.dorado.view.control.table

Methods in com.bstek.dorado.view.control.table with parameters of type XmlNode
void | Column.init(DoradoContext context, XmlNode node) 列初始化
protected void | DataTable.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
void | Table.init(DoradoContext context, XmlNode node)
protected void | Table.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列

Uses of XmlNode in com.bstek.dorado.view.control.tabset

Methods in com.bstek.dorado.view.control.tabset with parameters of type XmlNode
 void TabSet.init(DoradoContext context, XmlNode node)

Uses of XmlNode in com.bstek.dorado.view.control.tree

Methods in com.bstek.dorado.view.control.tree with parameters of type XmlNode
void | DataTree.init(DoradoContext context, XmlNode node)
protected void | DataTree.loadChildLevels(TreeLevel level, XmlNode node, DoradoContext context) 加载子节点层
protected TreeLevel | DataTree.createTreeLevel(XmlNode node, DoradoContext context) 根据XML节点创建节点层
void | Tree.init(DoradoContext context, XmlNode node)
protected void | Tree.loadNodes(DoradoContext context, XmlNode node, TreeNode treeNode) 加载树节点

Uses of XmlNode in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data with parameters of type XmlNode
protected void | DatasetWrapper.initListener(XmlNode node) 根据XML节点初试化监听器
void | DatasetWrapper.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected Field | DatasetWrapper.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
void | ViewDatasetAdapter.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。
protected void | ViewDatasetSupport.initValidator(Validator validator, XmlNode validatorNode) initValidator
protected Field | ViewDatasetSupport.createFieldByNode(DoradoContext context, XmlNode node) 根据一个描述字段的XML节点自动创建字段对象.
void | ViewDatasetSupport.init(DoradoContext context, XmlNode node) 根据一个XML节点对象自动配置本Dataset。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.utils.xml.XmlOutputter

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.utils.xml.XmlOutputter

Packages that use XmlOutputter
com.bstek.dorado.utils.xml 与XML相关的工具类

Uses of XmlOutputter in com.bstek.dorado.utils.xml

Methods in com.bstek.dorado.utils.xml that return XmlOutputter
static XmlOutputter XmlFactory.createXmlOutputter()
创建并返回一个XML输出器对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.utils.xml.XmlParseException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.utils.xml.XmlParseException

Packages that use XmlParseException
com.bstek.dorado.action.mapping | Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.common | Dorado系统中的一些通用类
com.bstek.dorado.utils.xml | 与XML相关的工具类

Uses of XmlParseException in com.bstek.dorado.action.mapping

Methods in com.bstek.dorado.action.mapping that throw XmlParseException
static void Mapping.init()
初始化所有的Mapping信息。

Uses of XmlParseException in com.bstek.dorado.common

Methods in com.bstek.dorado.common that throw XmlParseException
static void UserConfig.load()
装载配置文件。

Uses of XmlParseException in com.bstek.dorado.utils.xml

Methods in com.bstek.dorado.utils.xml that throw XmlParseException
XmlDocument | XmlBuilder.buildDocument(java.lang.String s) 创建XmlDocument对象
XmlDocument | XmlBuilder.buildDocument(java.io.InputStream in) 创建XmlDocument对象
XmlDocument | XmlBuilder.buildDocument(java.io.File file) 利用文件对象创建XmlDocument对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view
Interfaces
Component
Element
EventSupported
ViewModel
Classes
DefaultViewModel
Event
EventConfig
EventHandler
JspHelper
ViewModelSupport


com.bstek.dorado.view Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.Event
    • class com.bstek.dorado.view.EventConfig
    • class com.bstek.dorado.view.EventHandler
    • class com.bstek.dorado.view.JspHelper
    • class com.bstek.dorado.view.ViewModelSupport (implements com.bstek.dorado.view.ViewModel)
      • class com.bstek.dorado.view.DefaultViewModel

Interface Hierarchy

  • interface com.bstek.dorado.view.Element
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.EventSupported)
    • interface com.bstek.dorado.view.ViewModel (also extends com.bstek.dorado.view.EventSupported)
  • interface com.bstek.dorado.view.EventSupported
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.Element)
    • interface com.bstek.dorado.view.ViewModel (also extends com.bstek.dorado.view.Element)


Uses of Package com.bstek.dorado.view

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view

Packages that use com.bstek.dorado.view
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate | 数据校验器的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Classes in com.bstek.dorado.view used by com.bstek.dorado.view
Component
组件接口
Element
元素接口
Event
客户端事件的定义描述对象
EventHandler
事件处理类
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.
ViewModelSupport
视图模型的基本实现

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control
Component
组件接口
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.advance
Component
组件接口
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.autoform
Component
组件接口
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.command
Component
组件接口
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.dropdown
Component
组件接口
DefaultViewModel
默认的ViewModel抽象实现类
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.
ViewModelSupport
视图模型的基本实现

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.table
Component
组件接口
Element
元素接口
EventHandler
事件处理类
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.tabset
Component
组件接口
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.control.tree
Component
组件接口
Element
元素接口
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.data
Component
组件接口
Element
元素接口
EventHandler
事件处理类
EventSupported
可支持客户端事件的控件的接口
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.data.validate
Element
元素接口
EventSupported
可支持客户端事件的控件的接口

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.data.validate.impl
Element
元素接口
EventSupported
可支持客户端事件的控件的接口

Classes in com.bstek.dorado.view used by com.bstek.dorado.view.rpc
ViewModel
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.Component

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.Component

Packages that use Component
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of Component in com.bstek.dorado.view

Methods in com.bstek.dorado.view with parameters of type Component
java.util.List | ViewModel.getRoleConfigs(Component component) 返回与给定的组件相关的角色配置项
java.util.List | ViewModelSupport.getRoleConfigs(Component component) 返回与给定的组件相关的角色配置项

Uses of Component in com.bstek.dorado.view.control

Subinterfaces of Component in com.bstek.dorado.view.control
 interface Control
控件的接口

Classes in com.bstek.dorado.view.control that implement Component
class | com.bstek.dorado.view.control.AbstractControl
class | Button 按钮对象
class | Calendar 日历
class | CheckBox 复选框
class | DataControl 数据控件对象接口
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | GroupBox 组合框
class | Label 标签对象
class | Menu 菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
class | MenuBar 菜单工具栏.
class | OutlookBar Outlook工具栏
class | PagePilot 分页导航条.
class | PlaceableControl 支持界面定位的控件的抽象类
class | PlaceableDataControl 支持界面定位的数据控件的抽象类
class | ProgressBar
class | RadioGroup 单选框组合.
class | ScrollBar 滚动条
class | SimpleDataControl 简单数据控件对象
class | Span 控件的辅助类
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of Component in com.bstek.dorado.view.control.advance

Classes in com.bstek.dorado.view.control.advance that implement Component
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of Component in com.bstek.dorado.view.control.autoform

Classes in com.bstek.dorado.view.control.autoform that implement Component
 class AutoForm
自动表单

Uses of Component in com.bstek.dorado.view.control.command

Classes in com.bstek.dorado.view.control.command that implement Component
class | Command 命令对象的基类
class | CommandQueue 命令队列
class | QueryCommand 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
class | RequestCommand 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
class | RPCCommand 远程过程调用命令
class | UpdateCommand 提交命令

Uses of Component in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement Component
class | com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
class | AdvanceDropDown 高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | DatasetDropDown Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
class | DateDropDown 日期对象下拉框
class | DropDown 下拉框的基类
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
class | DynamicDropDownDataset 动态下拉框数据集对象
class | ListDropDown 列表下拉框
class | SimpleDropDown 简单下拉框的基类

Uses of Component in com.bstek.dorado.view.control.table

Classes in com.bstek.dorado.view.control.table that implement Component
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类
class | Table 表格的基类

Uses of Component in com.bstek.dorado.view.control.tabset

Classes in com.bstek.dorado.view.control.tabset that implement Component
 class TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of Component in com.bstek.dorado.view.control.tree

Classes in com.bstek.dorado.view.control.tree that implement Component
class | DataTree 树状列表对象
class | Tree 树状列表对象

Uses of Component in com.bstek.dorado.view.data

Subinterfaces of Component in com.bstek.dorado.view.data
 interface ViewDataset
视图模型中数据集对象的基础类

Classes in com.bstek.dorado.view.data that implement Component
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | CustomDataset 用户自定义视图数据集对象
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.DefaultViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.DefaultViewModel

Packages that use DefaultViewModel
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of DefaultViewModel in com.bstek.dorado.view.control.dropdown

Subclasses of DefaultViewModel in com.bstek.dorado.view.control.dropdown
class | CustomDropDownViewModel 自定义下拉框的视图模型对象
class | DropDownViewModel 下拉框的视图模型对象
class | DynamicDropDownViewModel 动态下拉框的视图模型对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.Element

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.Element

Packages that use Element
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate | 数据校验器的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现

Uses of Element in com.bstek.dorado.view

Subinterfaces of Element in com.bstek.dorado.view
interface | Component 组件接口
interface | ViewModel 视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view that implement Element
class | DefaultViewModel 默认的ViewModel抽象实现类
class | ViewModelSupport 视图模型的基本实现

Uses of Element in com.bstek.dorado.view.control

Subinterfaces of Element in com.bstek.dorado.view.control
interface | Control 控件的接口
interface | MenuItemContainer 菜单项容器的接口

Classes in com.bstek.dorado.view.control that implement Element
class | com.bstek.dorado.view.control.AbstractControl
class | Button 按钮对象
class | Calendar 日历
class | CheckBox 复选框
class | DataControl 数据控件对象接口
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | DefaultOutlookBarGroup
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | GroupBox 组合框
class | Label 标签对象
class | Menu 菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
class | MenuBar 菜单工具栏.
class | MenuItem 菜单项 一般用于执行URL请求,当用户点击菜单项时菜单可以自动在一个指定的框架中激活该URL.
class | MenuOutlookBarGroup
class | OutlookBar Outlook工具栏
class | OutlookBarGroup
class | PagePilot 分页导航条.
class | PlaceableControl 支持界面定位的控件的抽象类
class | PlaceableDataControl 支持界面定位的数据控件的抽象类
class | ProgressBar
class | RadioGroup 单选框组合.
class | ScrollBar 滚动条
class | SimpleDataControl 简单数据控件对象
class | Span 控件的辅助类
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of Element in com.bstek.dorado.view.control.advance

Classes in com.bstek.dorado.view.control.advance that implement Element
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of Element in com.bstek.dorado.view.control.autoform

Classes in com.bstek.dorado.view.control.autoform that implement Element
class | AutoForm 自动表单
class | CheckBoxFormElement 复选框型的表单元素
class | ControlFormElement
class | CustomFormElement 自定义的表单元素
class | FormElement 表单元素抽象类
class | FormElementRenderer
class | FormGroup 自动表单中的组
class | LabelFormElement 文本标签型的表单元素
class | RadioGroupFormElement 单选框型的表单元素
class | TextEditorFormElement 文本输入框型的表单元素

Uses of Element in com.bstek.dorado.view.control.command

Classes in com.bstek.dorado.view.control.command that implement Element
class | Command 命令对象的基类
class | CommandQueue 命令队列
class | QueryCommand 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
class | RequestCommand 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
class | RPCCommand 远程过程调用命令
class | UpdateCommand 提交命令

Uses of Element in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement Element
class | com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
class | AdvanceDropDown 高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | CustomDropDownViewModel 自定义下拉框的视图模型对象
class | DatasetDropDown Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
class | DateDropDown 日期对象下拉框
class | DropDown 下拉框的基类
class | DropDownViewModel 下拉框的视图模型对象
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
class | DynamicDropDownDataset 动态下拉框数据集对象
class | DynamicDropDownViewModel 动态下拉框的视图模型对象
class | ListDropDown 列表下拉框
class | SimpleDropDown 简单下拉框的基类

Uses of Element in com.bstek.dorado.view.control.table

Classes in com.bstek.dorado.view.control.table that implement Element
class | Column 表格列的抽象类
class | ColumnGroup 组合列的基类
class | DataColumn 数据列的抽象类
class | DataColumnGroup 数据表格中的组合列的基类
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | EditableColumn 数据表格中的可编辑列
class | StaticColumn 静态表格列
class | StaticColumnGroup 静态表格中的组合列
class | StaticTable 静态表格类
class | Table 表格的基类

Uses of Element in com.bstek.dorado.view.control.tabset

Classes in com.bstek.dorado.view.control.tabset that implement Element
class | FrameTab 多页标签中的子框架标签项 子框架标签项在多页标签中用于显示指定URL资源的页面.
class | Tab 多页标签中的默认标签项
class | TabElement 多页标签页中标签页的基类
class | TabSet 多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of Element in com.bstek.dorado.view.control.tree

Classes in com.bstek.dorado.view.control.tree that implement Element
class | DataTree 树状列表对象
class | DefaultTreeNode 默认的树节点对象
class | RecordTreeNode 跟记录绑定的树节点.
class | Tree 树状列表对象
class | TreeNode 树节点对象的基类

Uses of Element in com.bstek.dorado.view.data

Subinterfaces of Element in com.bstek.dorado.view.data
interface | ViewDataset 视图模型中数据集对象的基础类
interface | ViewField 视图模型中数据集字段对象

Classes in com.bstek.dorado.view.data that implement Element
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | CustomDataset 用户自定义视图数据集对象
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewBaseField 视图模型中数据字段的基础类
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。
class | ViewLookupField 视图模型中LookupField对象

Uses of Element in com.bstek.dorado.view.data.validate

Subinterfaces of Element in com.bstek.dorado.view.data.validate
 interface Validator
校验器的基类

Uses of Element in com.bstek.dorado.view.data.validate.impl

Classes in com.bstek.dorado.view.data.validate.impl that implement Element
class | com.bstek.dorado.view.data.validate.impl.AbstractValidator
class | CustomValidator 用户自定义数据校验对象
class | LengthValidator 长度校验器 用于校验一个数据(一般指字符串)的长度是否有效的校验器.
class | ListValidator List值的校验对象 对于是否属于某一组值的校验
class | PatternValidator 基于正则表达式的校验对象
class | RangeValidator 数值范围校验器 用于校验指定的数据是否在一个允许的范围内的校验器.例如可用于校验某字段中录入的内容必须在2000-10000之间.
class | RequiredValidator 必需类型校验对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.Event

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.Event

Packages that use Event
com.bstek.dorado.view 包含视图模型、视图控件和数据校验类。

Uses of Event in com.bstek.dorado.view

Methods in com.bstek.dorado.view that return Event
static Event EventConfig.getEvent(java.lang.String control, java.lang.String event)
根据控件名和事件名取得一个事件定义的描述对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.EventConfig

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.EventConfig

No usage of com.bstek.dorado.view.EventConfig

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.EventHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.EventHandler

Packages that use EventHandler
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of EventHandler in com.bstek.dorado.view

Methods in com.bstek.dorado.view that return EventHandler
EventHandler | Component.getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
EventHandler | EventSupported.getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
EventHandler | ViewModelSupport.getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。

Methods in com.bstek.dorado.view with parameters of type EventHandler
void | Component.addEventHandler(EventHandler event) 添加一个事件处理对象。
void | EventSupported.addEventHandler(EventHandler event) 添加一个事件处理对象。
void | ViewModelSupport.addEventHandler(EventHandler event) 添加一个事件处理对象。

Uses of EventHandler in com.bstek.dorado.view.control.table

Methods in com.bstek.dorado.view.control.table that return EventHandler
EventHandler | DataColumnGroup.getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。
EventHandler | EditableColumn.getEventHandler(java.lang.String name) 根据指定名称取得一个事件处理对象。

Methods in com.bstek.dorado.view.control.table with parameters of type EventHandler
void | DataColumnGroup.addEventHandler(EventHandler event) 添加一个事件处理对象。
void | EditableColumn.addEventHandler(EventHandler event) 添加一个事件处理对象。

Uses of EventHandler in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return EventHandler
 EventHandler ViewDatasetSupport.getEventHandler(java.lang.String name)
getEventHandler

Methods in com.bstek.dorado.view.data with parameters of type EventHandler
 void ViewDatasetSupport.addEventHandler(EventHandler event)
addEventHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.EventSupported

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.EventSupported

Packages that use EventSupported
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate | 数据校验器的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现

Uses of EventSupported in com.bstek.dorado.view

Subinterfaces of EventSupported in com.bstek.dorado.view
interface | Component 组件接口
interface | ViewModel 视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.

Classes in com.bstek.dorado.view that implement EventSupported
class | DefaultViewModel 默认的ViewModel抽象实现类
class | ViewModelSupport 视图模型的基本实现

Uses of EventSupported in com.bstek.dorado.view.control

Subinterfaces of EventSupported in com.bstek.dorado.view.control
 interface Control
控件的接口

Classes in com.bstek.dorado.view.control that implement EventSupported
class | com.bstek.dorado.view.control.AbstractControl
class | Button 按钮对象
class | Calendar 日历
class | CheckBox 复选框
class | DataControl 数据控件对象接口
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | GroupBox 组合框
class | Label 标签对象
class | Menu 菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
class | MenuBar 菜单工具栏.
class | OutlookBar Outlook工具栏
class | PagePilot 分页导航条.
class | PlaceableControl 支持界面定位的控件的抽象类
class | PlaceableDataControl 支持界面定位的数据控件的抽象类
class | ProgressBar
class | RadioGroup 单选框组合.
class | ScrollBar 滚动条
class | SimpleDataControl 简单数据控件对象
class | Span 控件的辅助类
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of EventSupported in com.bstek.dorado.view.control.advance

Classes in com.bstek.dorado.view.control.advance that implement EventSupported
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of EventSupported in com.bstek.dorado.view.control.autoform

Classes in com.bstek.dorado.view.control.autoform that implement EventSupported
 class AutoForm
自动表单

Uses of EventSupported in com.bstek.dorado.view.control.command

Classes in com.bstek.dorado.view.control.command that implement EventSupported
class | Command 命令对象的基类
class | CommandQueue 命令队列
class | QueryCommand 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
class | RequestCommand 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
class | RPCCommand 远程过程调用命令
class | UpdateCommand 提交命令

Uses of EventSupported in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement EventSupported
class | com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
class | AdvanceDropDown 高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | CustomDropDownViewModel 自定义下拉框的视图模型对象
class | DatasetDropDown Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
class | DateDropDown 日期对象下拉框
class | DropDown 下拉框的基类
class | DropDownViewModel 下拉框的视图模型对象
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
class | DynamicDropDownDataset 动态下拉框数据集对象
class | DynamicDropDownViewModel 动态下拉框的视图模型对象
class | ListDropDown 列表下拉框
class | SimpleDropDown 简单下拉框的基类

Uses of EventSupported in com.bstek.dorado.view.control.table

Classes in com.bstek.dorado.view.control.table that implement EventSupported
class | DataColumnGroup 数据表格中的组合列的基类
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | EditableColumn 数据表格中的可编辑列
class | StaticTable 静态表格类
class | Table 表格的基类

Uses of EventSupported in com.bstek.dorado.view.control.tabset

Classes in com.bstek.dorado.view.control.tabset that implement EventSupported
 class TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of EventSupported in com.bstek.dorado.view.control.tree

Classes in com.bstek.dorado.view.control.tree that implement EventSupported
class | DataTree 树状列表对象
class | Tree 树状列表对象

Uses of EventSupported in com.bstek.dorado.view.data

Subinterfaces of EventSupported in com.bstek.dorado.view.data
 interface ViewDataset
视图模型中数据集对象的基础类

Classes in com.bstek.dorado.view.data that implement EventSupported
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | CustomDataset 用户自定义视图数据集对象
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。

Uses of EventSupported in com.bstek.dorado.view.data.validate

Subinterfaces of EventSupported in com.bstek.dorado.view.data.validate
 interface Validator
校验器的基类

Uses of EventSupported in com.bstek.dorado.view.data.validate.impl

Classes in com.bstek.dorado.view.data.validate.impl that implement EventSupported
class | com.bstek.dorado.view.data.validate.impl.AbstractValidator
class | CustomValidator 用户自定义数据校验对象
class | LengthValidator 长度校验器 用于校验一个数据(一般指字符串)的长度是否有效的校验器.
class | ListValidator List值的校验对象 对于是否属于某一组值的校验
class | PatternValidator 基于正则表达式的校验对象
class | RangeValidator 数值范围校验器 用于校验指定的数据是否在一个允许的范围内的校验器.例如可用于校验某字段中录入的内容必须在2000-10000之间.
class | RequiredValidator 必需类型校验对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.JspHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.JspHelper

No usage of com.bstek.dorado.view.JspHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.ViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.ViewModel

Packages that use ViewModel
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Uses of ViewModel in com.bstek.dorado.view

Classes in com.bstek.dorado.view that implement ViewModel
class | DefaultViewModel 默认的ViewModel抽象实现类
class | ViewModelSupport 视图模型的基本实现

Methods in com.bstek.dorado.view that return ViewModel
ViewModel | Component.getViewModel() 取得视图模型对象。
static ViewModel | JspHelper.getViewModel(javax.servlet.jsp.PageContext pageContext) 根据传入JSP上下文对象的获得当前的ViewModel实例

Uses of ViewModel in com.bstek.dorado.view.control

Constructors in com.bstek.dorado.view.control with parameters of type ViewModel
Button(ViewModel viewModel, java.lang.String id)
构造器
Calendar(ViewModel viewModel, java.lang.String id)
构造器
CheckBox(ViewModel viewModel, java.lang.String id)
构造器
DataControl(ViewModel viewModel, java.lang.String id)
构造器
DataLabel(ViewModel viewModel, java.lang.String id)
构造器
DataPilot(ViewModel viewModel, java.lang.String id)
构造器
Editor(ViewModel viewModel, java.lang.String id)
构造器
FieldLabel(ViewModel viewModel, java.lang.String id)
构造器
GroupBox(ViewModel viewModel, java.lang.String id)
构造器
Label(ViewModel viewModel, java.lang.String id)
构造器
Menu(ViewModel viewModel, java.lang.String id)
构造器
MenuBar(ViewModel viewModel, java.lang.String id)
构造器
OutlookBar(ViewModel viewModel, java.lang.String id)
构造器
PagePilot(ViewModel viewModel, java.lang.String id)
构造器
PlaceableControl(ViewModel viewModel, java.lang.String id)
构造器
PlaceableDataControl(ViewModel viewModel, java.lang.String id)
构造器
ProgressBar(ViewModel viewModel, java.lang.String id)
ProgressBar
RadioGroup(ViewModel viewModel, java.lang.String id)
构造器
ScrollBar(ViewModel viewModel, java.lang.String id)
构造器
SimpleDataControl(ViewModel viewModel, java.lang.String id)
构造器
Span(ViewModel viewModel, java.lang.String id)
构造器
SplitPanel(ViewModel viewModel, java.lang.String id)
构造器
SubWindow(ViewModel viewModel, java.lang.String id)
构造器
TextEditor(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.control.advance

Constructors in com.bstek.dorado.view.control.advance with parameters of type ViewModel
TreeGrid(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.control.autoform

Constructors in com.bstek.dorado.view.control.autoform with parameters of type ViewModel
AutoForm(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.control.command

Constructors in com.bstek.dorado.view.control.command with parameters of type ViewModel
Command(ViewModel viewModel, java.lang.String id)
构造器
CommandQueue(ViewModel viewModel, java.lang.String id)
构造器
QueryCommand(ViewModel viewModel, java.lang.String id)
构造器
RPCCommand(ViewModel viewModel, java.lang.String id)
构造器
RequestCommand(ViewModel viewModel, java.lang.String id)
构造器
UpdateCommand(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement ViewModel
class | CustomDropDownViewModel 自定义下拉框的视图模型对象
class | DropDownViewModel 下拉框的视图模型对象
class | DynamicDropDownViewModel 动态下拉框的视图模型对象

Constructors in com.bstek.dorado.view.control.dropdown with parameters of type ViewModel
AdvanceDropDown(ViewModel viewModel, java.lang.String id)
构造器
CustomDropDown(ViewModel viewModel, java.lang.String id)
构造器
DatasetDropDown(ViewModel viewModel, java.lang.String id)
构造器
DateDropDown(ViewModel viewModel, java.lang.String id)
构造器
DropDown(ViewModel viewModel, java.lang.String id)
构造器
DynamicDropDown(ViewModel viewModel, java.lang.String id)
构造器
DynamicDropDownDataset(ViewModel viewModel, java.lang.String id)
ListDropDown(ViewModel viewModel, java.lang.String id)
构造器
SimpleDropDown(ViewModel viewModel, java.lang.String id)

Uses of ViewModel in com.bstek.dorado.view.control.table

Constructors in com.bstek.dorado.view.control.table with parameters of type ViewModel
DataTable(ViewModel viewModel, java.lang.String id)
构造器
StaticTable(ViewModel viewModel, java.lang.String id)
Table(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.control.tabset

Constructors in com.bstek.dorado.view.control.tabset with parameters of type ViewModel
TabSet(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.control.tree

Constructors in com.bstek.dorado.view.control.tree with parameters of type ViewModel
DataTree(ViewModel viewModel, java.lang.String id)
构造器
Tree(ViewModel viewModel, java.lang.String id)
构造器

Uses of ViewModel in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return ViewModel
 ViewModel ViewDatasetSupport.getViewModel()
取得视图模型对象。

Constructors in com.bstek.dorado.view.data with parameters of type ViewModel
CustomDataset(ViewModel viewModel, java.lang.String id)
构造器
DODataset(ViewModel viewModel, java.lang.String id)
构造器
DatasetReference(ViewModel viewModel, java.lang.String id)
构造器
DatasetWrapper(ViewModel viewModel, java.lang.String id)
构造器
FormDataset(ViewModel viewModel, java.lang.String id)
构造器
ViewDatasetAdapter(ViewModel viewModel, java.lang.String id)
构造器
ViewDatasetSupport(ViewModel viewModel, java.lang.String id)
AbstractViewDataset

Uses of ViewModel in com.bstek.dorado.view.rpc

Methods in com.bstek.dorado.view.rpc that return ViewModel
protected ViewModel | BaseRPCHandler.doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
protected ViewModel | LoadDataRPCHandler.doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)
ViewModel | RPCHandler.getViewModel() 取得与客户端对应的ViewModel实例
protected ViewModel | UpdateDataRPCHandler.doGetViewModel(com.bstek.dorado.view.ViewModelCacheInfo info)

Methods in com.bstek.dorado.view.rpc with parameters of type ViewModel
protected  void UpdateDataRPCHandler.updateDataset(ViewModel viewModel, com.bstek.dorado.module.update.RecordInfo recordInfo)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.ViewModelManager

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.ViewModelManager

No usage of com.bstek.dorado.view.ViewModelManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.ViewModelSupport

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.ViewModelSupport

Packages that use ViewModelSupport
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象

Uses of ViewModelSupport in com.bstek.dorado.view

Subclasses of ViewModelSupport in com.bstek.dorado.view
 class DefaultViewModel
默认的ViewModel抽象实现类

Uses of ViewModelSupport in com.bstek.dorado.view.control.dropdown

Subclasses of ViewModelSupport in com.bstek.dorado.view.control.dropdown
class | CustomDropDownViewModel 自定义下拉框的视图模型对象
class | DropDownViewModel 下拉框的视图模型对象
class | DynamicDropDownViewModel 动态下拉框的视图模型对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control
Interfaces
Control
MenuItemContainer
Placeable
Visible
Classes
Button
Calendar
CheckBox
DataControl
DataLabel
DataPilot
DefaultOutlookBarGroup
Editor
FieldLabel
GroupBox
Label
Menu
MenuBar
MenuItem
MenuOutlookBarGroup
OutlookBar
OutlookBarGroup
PagePilot
PlaceableControl
PlaceableDataControl
ProgressBar
RadioGroup
ScrollBar
SimpleDataControl
Span
SplitPanel
SubWindow
TextEditor


com.bstek.dorado.view.control Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.DataControl
        • class com.bstek.dorado.view.control.PlaceableDataControl (implements com.bstek.dorado.view.control.Placeable)
          • class com.bstek.dorado.view.control.DataPilot (implements com.bstek.dorado.view.control.Visible)
          • class com.bstek.dorado.view.control.PagePilot (implements com.bstek.dorado.view.control.Visible)
          • class com.bstek.dorado.view.control.SimpleDataControl (implements com.bstek.dorado.view.control.Visible)
            • class com.bstek.dorado.view.control.Calendar
            • class com.bstek.dorado.view.control.DataLabel
            • class com.bstek.dorado.view.control.Editor
              • class com.bstek.dorado.view.control.CheckBox
              • class com.bstek.dorado.view.control.RadioGroup
              • class com.bstek.dorado.view.control.TextEditor
            • class com.bstek.dorado.view.control.FieldLabel
            • class com.bstek.dorado.view.control.ProgressBar
      • class com.bstek.dorado.view.control.Menu (implements com.bstek.dorado.view.control.MenuItemContainer)
      • class com.bstek.dorado.view.control.PlaceableControl (implements com.bstek.dorado.view.control.Placeable)
        • class com.bstek.dorado.view.control.Button (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.GroupBox (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.Label (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.MenuBar (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.OutlookBar (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.ScrollBar (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.SplitPanel (implements com.bstek.dorado.view.control.Visible)
        • class com.bstek.dorado.view.control.SubWindow (implements com.bstek.dorado.view.control.Visible)
      • class com.bstek.dorado.view.control.Span
    • class com.bstek.dorado.view.control.MenuItem (implements com.bstek.dorado.view.control.MenuItemContainer)
    • class com.bstek.dorado.view.control.OutlookBarGroup (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.DefaultOutlookBarGroup
      • class com.bstek.dorado.view.control.MenuOutlookBarGroup

Interface Hierarchy

  • interface com.bstek.dorado.view.Element
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.EventSupported)
      • interface com.bstek.dorado.view.control.Control
    • interface com.bstek.dorado.view.control.MenuItemContainer
  • interface com.bstek.dorado.view.EventSupported
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.Element)
      • interface com.bstek.dorado.view.control.Control
  • interface com.bstek.dorado.view.control.Placeable
    • interface com.bstek.dorado.view.control.Visible


Uses of Package com.bstek.dorado.view.control

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control

Packages that use com.bstek.dorado.view.control
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view
Control
控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control
Control
控件的接口
DataControl
数据控件对象接口
Editor
编辑器的基类
MenuItem
菜单项 一般用于执行URL请求,当用户点击菜单项时菜单可以自动在一个指定的框架中激活该URL.
MenuItemContainer
菜单项容器的接口
OutlookBar
Outlook工具栏
OutlookBarGroup
Placeable
支持界面定位的控件的接口
PlaceableControl
支持界面定位的控件的抽象类
PlaceableDataControl
支持界面定位的数据控件的抽象类
SimpleDataControl
简单数据控件对象
Visible
可见控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.advance
Control
控件的接口
DataControl
数据控件对象接口
Placeable
支持界面定位的控件的接口
PlaceableDataControl
支持界面定位的数据控件的抽象类
Visible
可见控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.autoform
Control
控件的接口
DataControl
数据控件对象接口
FieldLabel
字段标签对象。
Placeable
支持界面定位的控件的接口
PlaceableDataControl
支持界面定位的数据控件的抽象类

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.command
Control
控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.dropdown
Control
控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.table
Control
控件的接口
DataControl
数据控件对象接口
Placeable
支持界面定位的控件的接口
PlaceableDataControl
支持界面定位的数据控件的抽象类
Visible
可见控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.tabset
Control
控件的接口
Placeable
支持界面定位的控件的接口
PlaceableControl
支持界面定位的控件的抽象类
Visible
可见控件的接口

Classes in com.bstek.dorado.view.control used by com.bstek.dorado.view.control.tree
Control
控件的接口
Placeable
支持界面定位的控件的接口
PlaceableControl
支持界面定位的控件的抽象类
Visible
可见控件的接口

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.advance
Classes
TreeGrid


com.bstek.dorado.view.control.advance Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.advance

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.DataControl
        • class com.bstek.dorado.view.control.PlaceableDataControl (implements com.bstek.dorado.view.control.Placeable)
          • class com.bstek.dorado.view.control.table.Table (implements com.bstek.dorado.view.control.Visible)
            • class com.bstek.dorado.view.control.table.DataTable
              • class com.bstek.dorado.view.control.advance.TreeGrid


Uses of Package com.bstek.dorado.view.control.advance

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.advance

No usage of com.bstek.dorado.view.control.advance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.advance.TreeGrid

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.advance.TreeGrid

No usage of com.bstek.dorado.view.control.advance.TreeGrid

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.autoform
Classes
AutoForm
CheckBoxFormElement
ControlFormElement
CustomFormElement
FormElement
FormElementFactoryImpl
FormElementRenderer
FormGroup
FormGroupGround
LabelFormElement
LayoutInfo
RadioGroupFormElement
TextEditorFormElement


com.bstek.dorado.view.control.autoform Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.autoform

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.DataControl
        • class com.bstek.dorado.view.control.PlaceableDataControl (implements com.bstek.dorado.view.control.Placeable)
          • class com.bstek.dorado.view.control.autoform.AutoForm
    • class com.bstek.dorado.view.control.autoform.FormElement (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.autoform.ControlFormElement
        • class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
        • class com.bstek.dorado.view.control.autoform.CustomFormElement
        • class com.bstek.dorado.view.control.autoform.LabelFormElement
        • class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
        • class com.bstek.dorado.view.control.autoform.TextEditorFormElement
      • class com.bstek.dorado.view.control.autoform.FormElementRenderer
    • class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl (implements com.bstek.dorado.view.control.autoform.FormElementFactory)
    • class com.bstek.dorado.view.control.autoform.FormGroup (implements com.bstek.dorado.view.Element)
    • class com.bstek.dorado.view.control.autoform.FormGroupGround
    • class com.bstek.dorado.view.control.autoform.LayoutInfo


Uses of Package com.bstek.dorado.view.control.autoform

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.autoform

Packages that use com.bstek.dorado.view.control.autoform
com.bstek.dorado.view.control.autoform 自动表单控件的相关对象

Classes in com.bstek.dorado.view.control.autoform used by com.bstek.dorado.view.control.autoform
AutoForm
自动表单
ControlFormElement
FormElement
表单元素抽象类
FormGroup
自动表单中的组

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.AutoForm

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.AutoForm

Packages that use AutoForm
com.bstek.dorado.view.control.autoform 自动表单控件的相关对象

Uses of AutoForm in com.bstek.dorado.view.control.autoform

Fields in com.bstek.dorado.view.control.autoform declared as AutoForm
protected  AutoForm FormElement.autoForm
表单

Methods in com.bstek.dorado.view.control.autoform that return AutoForm
 AutoForm FormGroup.getAutoForm()
取得该组所属的自动表单对象。

Constructors in com.bstek.dorado.view.control.autoform with parameters of type AutoForm
FormGroup(AutoForm autoForm, java.lang.String name)
构造器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.CheckBoxFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.CheckBoxFormElement

No usage of com.bstek.dorado.view.control.autoform.CheckBoxFormElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.ControlFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.ControlFormElement

Packages that use ControlFormElement
com.bstek.dorado.view.control.autoform 自动表单控件的相关对象

Uses of ControlFormElement in com.bstek.dorado.view.control.autoform

Subclasses of ControlFormElement in com.bstek.dorado.view.control.autoform
class | CheckBoxFormElement 复选框型的表单元素
class | CustomFormElement 自定义的表单元素
class | LabelFormElement 文本标签型的表单元素
class | RadioGroupFormElement 单选框型的表单元素
class | TextEditorFormElement 文本输入框型的表单元素

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.CustomFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.CustomFormElement

No usage of com.bstek.dorado.view.control.autoform.CustomFormElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.FormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.FormElement

Packages that use FormElement
com.bstek.dorado.view.control.autoform 自动表单控件的相关对象

Uses of FormElement in com.bstek.dorado.view.control.autoform

Subclasses of FormElement in com.bstek.dorado.view.control.autoform
class | CheckBoxFormElement 复选框型的表单元素
class | ControlFormElement
class | CustomFormElement 自定义的表单元素
class | FormElementRenderer
class | LabelFormElement 文本标签型的表单元素
class | RadioGroupFormElement 单选框型的表单元素
class | TextEditorFormElement 文本输入框型的表单元素

Methods in com.bstek.dorado.view.control.autoform that return FormElement
FormElement | FormElementFactoryImpl.createFormElement(FormGroup group, java.lang.String type, java.lang.String name)
FormElement | FormGroup.addElement(java.lang.String type, java.lang.String name) 添加一个表单元素
FormElement | FormGroup.getElement(java.lang.String name) 根据指定的表单元素的名称，取得一个表单元素对象。
FormElement | LayoutInfo.getElement() 返回当前的元素(Element)对象。

Methods in com.bstek.dorado.view.control.autoform with parameters of type FormElement
void | FormGroupGround.putElement(FormElement element) putElement
void | LayoutInfo.setElement(FormElement element) 设定AutoForm对象的元素

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.FormElementFactoryImpl

No usage of com.bstek.dorado.view.control.autoform.FormElementFactoryImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.FormElementRenderer

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.FormElementRenderer

No usage of com.bstek.dorado.view.control.autoform.FormElementRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.FormGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.FormGroup

Packages that use FormGroup
com.bstek.dorado.view.control.autoform 自动表单控件的相关对象

Uses of FormGroup in com.bstek.dorado.view.control.autoform

Fields in com.bstek.dorado.view.control.autoform declared as FormGroup
protected  FormGroup FormElement.group
组

Methods in com.bstek.dorado.view.control.autoform that return FormGroup
FormGroup | AutoForm.addGroup(java.lang.String groupName) 添加一个组对象
FormGroup | AutoForm.getGroup(java.lang.String groupName) 根据名称返回一个组对象
FormGroup | FormElement.getGroup() 取得元素所属的组。

Methods in com.bstek.dorado.view.control.autoform with parameters of type FormGroup
 FormElement FormElementFactoryImpl.createFormElement(FormGroup group, java.lang.String type, java.lang.String name)

Constructors in com.bstek.dorado.view.control.autoform with parameters of type FormGroup
CheckBoxFormElement(FormGroup group, java.lang.String name)
构造器
ControlFormElement(FormGroup group, java.lang.String name)
CustomFormElement(FormGroup group, java.lang.String name)
构造器
FormElement(FormGroup group, java.lang.String name)
构造器
FormElementRenderer(FormGroup group, java.lang.String name)
LabelFormElement(FormGroup group, java.lang.String name)
构造器
RadioGroupFormElement(FormGroup group, java.lang.String name)
构造器
TextEditorFormElement(FormGroup group, java.lang.String name)
构造器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.FormGroupGround

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.FormGroupGround

No usage of com.bstek.dorado.view.control.autoform.FormGroupGround

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.LabelFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.LabelFormElement

No usage of com.bstek.dorado.view.control.autoform.LabelFormElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.LayoutInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.LayoutInfo

No usage of com.bstek.dorado.view.control.autoform.LayoutInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.RadioGroupFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.RadioGroupFormElement

No usage of com.bstek.dorado.view.control.autoform.RadioGroupFormElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.autoform.TextEditorFormElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.autoform.TextEditorFormElement

No usage of com.bstek.dorado.view.control.autoform.TextEditorFormElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Button

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Button

No usage of com.bstek.dorado.view.control.Button

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Calendar

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Calendar

No usage of com.bstek.dorado.view.control.Calendar

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.CheckBox

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.CheckBox

No usage of com.bstek.dorado.view.control.CheckBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Command

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Command

Packages that use Command
com.bstek.dorado.view.control.command Dorado中Command控件类。

Uses of Command in com.bstek.dorado.view.control.command

Subclasses of Command in com.bstek.dorado.view.control.command
class | CommandQueue 管理提交命令队列的对象
class | QueryCommand 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
class | RequestCommand 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
class | RPCCommand
class | UpdateCommand 提交命令

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.control.Control

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.control.Control

Packages that use Control
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Uses of Control in com.bstek.dorado.view

Methods in com.bstek.dorado.view that return Control
Control | ViewModel.createControl(java.lang.String type, java.lang.String id) 根据指定的控件类型和Id创建控件对象。
Control | ViewModel.createControl(XmlNode node) 根据xml定义创建对应的控件对象。
Control | ViewModel.getControl(java.lang.String id) 根据指定的Id取得一个控件对象。
protected Control | ViewModelSupport.constructControl(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个控件对象。
Control | ViewModelSupport.createControl(XmlNode node) 根据xml定义创建对应的控件对象。
Control | ViewModelSupport.createControl(java.lang.String type, java.lang.String id) 根据指定的控件类型和Id创建控件对象。
Control | ViewModelSupport.getControl(java.lang.String id) 根据指定的Id取得一个控件对象。

Methods in com.bstek.dorado.view with parameters of type Control
protected  void ViewModelSupport.initControl(java.lang.String id, Control control)
Deprecated.

Uses of Control in com.bstek.dorado.view.control

Classes in com.bstek.dorado.view.control that implement Control
class | com.bstek.dorado.view.control.AbstractControl
class | Button 按钮对象
class | Calendar 日历
class | CheckBox 复选框
class | DataControl 数据控件对象接口
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | GroupBox 组合框
class | Label 标签对象
class | Menu 菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
class | MenuBar 菜单工具栏.
class | OutlookBar Outlook工具栏
class | PagePilot 分页导航条.
class | PlaceableControl 支持界面定位的控件的抽象类
class | PlaceableDataControl 支持界面定位的数据控件的抽象类
class | ProgressBar
class | RadioGroup 单选框组合.
class | ScrollBar 滚动条
class | SimpleDataControl 简单数据控件对象
class | Span 控件的辅助类
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of Control in com.bstek.dorado.view.control.advance

Classes in com.bstek.dorado.view.control.advance that implement Control
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of Control in com.bstek.dorado.view.control.autoform

Classes in com.bstek.dorado.view.control.autoform that implement Control
 class AutoForm
自动表单

Methods in com.bstek.dorado.view.control.autoform that return Control
Control | CheckBoxFormElement.getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
abstract Control | ControlFormElement.getControl() 取得表单元素中的控件对象。
Control | CustomFormElement.getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
Control | LabelFormElement.getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
Control | RadioGroupFormElement.getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。
Control | TextEditorFormElement.getControl() 取得表单元素中的控件对象。 抽象方法，需要在子类中实现。

Uses of Control in com.bstek.dorado.view.control.command

Classes in com.bstek.dorado.view.control.command that implement Control
class | Command 命令对象的基类
class | CommandQueue 命令队列
class | QueryCommand 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
class | RequestCommand 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
class | RPCCommand 远程过程调用命令
class | UpdateCommand 提交命令

Uses of Control in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement Control
class | com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
class | AdvanceDropDown 高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | DatasetDropDown Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
class | DateDropDown 日期对象下拉框
class | DropDown 下拉框的基类
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
class | ListDropDown 列表下拉框
class | SimpleDropDown 简单下拉框的基类

Uses of Control in com.bstek.dorado.view.control.table

Classes in com.bstek.dorado.view.control.table that implement Control
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类
class | Table 表格的基类

Uses of Control in com.bstek.dorado.view.control.tabset

Classes in com.bstek.dorado.view.control.tabset that implement Control
 class TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of Control in com.bstek.dorado.view.control.tree

Classes in com.bstek.dorado.view.control.tree that implement Control
class | DataTree 树状列表对象
class | Tree 树状列表对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.DataControl

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.DataControl

Packages that use DataControl
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象

Uses of DataControl in com.bstek.dorado.view.control

Subclasses of DataControl in com.bstek.dorado.view.control
class | Calendar 日历
class | CheckBox 复选框
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | PagePilot 分页导航条.
class | PlaceableDataControl 支持界面定位的数据控件的抽象类
class | ProgressBar
class | RadioGroup 单选框组合.
class | SimpleDataControl 简单数据控件对象
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of DataControl in com.bstek.dorado.view.control.advance

Subclasses of DataControl in com.bstek.dorado.view.control.advance
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of DataControl in com.bstek.dorado.view.control.autoform

Subclasses of DataControl in com.bstek.dorado.view.control.autoform
 class AutoForm
自动表单

Uses of DataControl in com.bstek.dorado.view.control.table

Subclasses of DataControl in com.bstek.dorado.view.control.table
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类
class | Table 表格的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.DataLabel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.DataLabel

No usage of com.bstek.dorado.view.control.DataLabel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.DataPilot

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.DataPilot

No usage of com.bstek.dorado.view.control.DataPilot

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.DefaultOutlookBarGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.DefaultOutlookBarGroup

No usage of com.bstek.dorado.view.control.DefaultOutlookBarGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Editor

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Editor

Packages that use Editor
com.bstek.dorado.view.control 各种控件类及实现

Uses of Editor in com.bstek.dorado.view.control

Subclasses of Editor in com.bstek.dorado.view.control
class | CheckBox 复选框
class | RadioGroup 单选框组合.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.FieldLabel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.FieldLabel

Packages that use FieldLabel
com.bstek.dorado.view.control.autoform 自动表单控件的相关对象

Uses of FieldLabel in com.bstek.dorado.view.control.autoform

Methods in com.bstek.dorado.view.control.autoform that return FieldLabel
 FieldLabel FormElement.getFieldLabel()
取得表单元素中的字段标题对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.GroupBox

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.GroupBox

No usage of com.bstek.dorado.view.control.GroupBox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Label

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Label

No usage of com.bstek.dorado.view.control.Label

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Menu

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Menu

No usage of com.bstek.dorado.view.control.Menu

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.MenuBar

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.MenuBar

No usage of com.bstek.dorado.view.control.MenuBar

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.MenuItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.MenuItem

Packages that use MenuItem
com.bstek.dorado.view.control 各种控件类及实现

Uses of MenuItem in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control that return MenuItem
MenuItem | Menu.addItem(java.lang.String name) 根据指定菜单项名称添加一个菜单项对象。
MenuItem | Menu.addItem(java.lang.String name, java.lang.String label) 根据指定名称、Label，添加一个菜单项对象。
MenuItem | Menu.getItem(java.lang.String name) 根据名称取得一个子菜单项
MenuItem | Menu.findItem(java.lang.String path) 根据子菜单项的路径返回一个菜单项.
MenuItem | MenuItem.addItem(java.lang.String name) 根据指定菜单项名称添加一个菜单项对象。
MenuItem | MenuItem.addItem(java.lang.String name, java.lang.String label) 根据指定名称、Label，添加一个菜单项对象。
MenuItem | MenuItem.getItem(java.lang.String name) 根据名称取得一个子菜单项
MenuItem | MenuItemContainer.addItem(java.lang.String name) 根据指定菜单项名称添加一个菜单项对象。
MenuItem | MenuItemContainer.addItem(java.lang.String name, java.lang.String label) 根据指定名称、Label，添加一个菜单项对象。
MenuItem | MenuItemContainer.getItem(java.lang.String name) 根据名称取得一个子菜单项

Methods in com.bstek.dorado.view.control with parameters of type MenuItem
protected  void Menu.loadItems(DoradoContext context, XmlNode node, MenuItem menuItem)
加载菜单项

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.control.MenuItemContainer

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.control.MenuItemContainer

Packages that use MenuItemContainer
com.bstek.dorado.view.control 各种控件类及实现

Uses of MenuItemContainer in com.bstek.dorado.view.control

Classes in com.bstek.dorado.view.control that implement MenuItemContainer
class | Menu 菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
class | MenuItem 菜单项 一般用于执行URL请求,当用户点击菜单项时菜单可以自动在一个指定的框架中激活该URL.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.MenuOutlookBarGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.MenuOutlookBarGroup

No usage of com.bstek.dorado.view.control.MenuOutlookBarGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.OutlookBar

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.OutlookBar

Packages that use OutlookBar
com.bstek.dorado.view.control 各种控件类及实现

Uses of OutlookBar in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control that return OutlookBar
 OutlookBar OutlookBarGroup.getOutlookBar()
getOutlookBar

Methods in com.bstek.dorado.view.control with parameters of type OutlookBar
 void OutlookBarGroup.setOutlookBar(OutlookBar outlookBar)
setOutlookBar

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.OutlookBarGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.OutlookBarGroup

Packages that use OutlookBarGroup
com.bstek.dorado.view.control 各种控件类及实现

Uses of OutlookBarGroup in com.bstek.dorado.view.control

Subclasses of OutlookBarGroup in com.bstek.dorado.view.control
class | DefaultOutlookBarGroup
class | MenuOutlookBarGroup

Methods in com.bstek.dorado.view.control that return OutlookBarGroup
OutlookBarGroup | OutlookBar.getGroup(int index) getGroup
OutlookBarGroup | OutlookBar.getGroup(java.lang.String name) getGroup

Methods in com.bstek.dorado.view.control with parameters of type OutlookBarGroup
 void OutlookBar.addGroup(OutlookBarGroup group)
addGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.PagePilot

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.PagePilot

No usage of com.bstek.dorado.view.control.PagePilot

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.control.Placeable

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.control.Placeable

Packages that use Placeable
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Uses of Placeable in com.bstek.dorado.view.control

Subinterfaces of Placeable in com.bstek.dorado.view.control
 interface Visible
可见控件的接口

Classes in com.bstek.dorado.view.control that implement Placeable
class | Button 按钮对象
class | Calendar 日历
class | CheckBox 复选框
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | GroupBox 组合框
class | Label 标签对象
class | MenuBar 菜单工具栏.
class | OutlookBar Outlook工具栏
class | PagePilot 分页导航条.
class | PlaceableControl 支持界面定位的控件的抽象类
class | PlaceableDataControl 支持界面定位的数据控件的抽象类
class | ProgressBar
class | RadioGroup 单选框组合.
class | ScrollBar 滚动条
class | SimpleDataControl 简单数据控件对象
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of Placeable in com.bstek.dorado.view.control.advance

Classes in com.bstek.dorado.view.control.advance that implement Placeable
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of Placeable in com.bstek.dorado.view.control.autoform

Classes in com.bstek.dorado.view.control.autoform that implement Placeable
 class AutoForm
自动表单

Uses of Placeable in com.bstek.dorado.view.control.table

Classes in com.bstek.dorado.view.control.table that implement Placeable
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类
class | Table 表格的基类

Uses of Placeable in com.bstek.dorado.view.control.tabset

Classes in com.bstek.dorado.view.control.tabset that implement Placeable
 class TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of Placeable in com.bstek.dorado.view.control.tree

Classes in com.bstek.dorado.view.control.tree that implement Placeable
class | DataTree 树状列表对象
class | Tree 树状列表对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.PlaceableControl

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.PlaceableControl

Packages that use PlaceableControl
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Uses of PlaceableControl in com.bstek.dorado.view.control

Subclasses of PlaceableControl in com.bstek.dorado.view.control
class | Button 按钮对象
class | GroupBox 组合框
class | Label 标签对象
class | MenuBar 菜单工具栏.
class | OutlookBar Outlook工具栏
class | ScrollBar 滚动条
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.

Uses of PlaceableControl in com.bstek.dorado.view.control.tabset

Subclasses of PlaceableControl in com.bstek.dorado.view.control.tabset
 class TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of PlaceableControl in com.bstek.dorado.view.control.tree

Subclasses of PlaceableControl in com.bstek.dorado.view.control.tree
class | DataTree 树状列表对象
class | Tree 树状列表对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.PlaceableDataControl

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.PlaceableDataControl

Packages that use PlaceableDataControl
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.autoform | 自动表单控件的相关对象
com.bstek.dorado.view.control.table | 表格控件的相关对象

Uses of PlaceableDataControl in com.bstek.dorado.view.control

Subclasses of PlaceableDataControl in com.bstek.dorado.view.control
class | Calendar 日历
class | CheckBox 复选框
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | PagePilot 分页导航条.
class | ProgressBar
class | RadioGroup 单选框组合.
class | SimpleDataControl 简单数据控件对象
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of PlaceableDataControl in com.bstek.dorado.view.control.advance

Subclasses of PlaceableDataControl in com.bstek.dorado.view.control.advance
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of PlaceableDataControl in com.bstek.dorado.view.control.autoform

Subclasses of PlaceableDataControl in com.bstek.dorado.view.control.autoform
 class AutoForm
自动表单

Uses of PlaceableDataControl in com.bstek.dorado.view.control.table

Subclasses of PlaceableDataControl in com.bstek.dorado.view.control.table
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类
class | Table 表格的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.ProgressBar

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.ProgressBar

No usage of com.bstek.dorado.view.control.ProgressBar

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.RadioGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.RadioGroup

No usage of com.bstek.dorado.view.control.RadioGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.ScrollBar

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.ScrollBar

No usage of com.bstek.dorado.view.control.ScrollBar

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.SimpleDataControl

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.SimpleDataControl

Packages that use SimpleDataControl
com.bstek.dorado.view.control 各种控件类及实现

Uses of SimpleDataControl in com.bstek.dorado.view.control

Subclasses of SimpleDataControl in com.bstek.dorado.view.control
class | Calendar 日历
class | CheckBox 复选框
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | ProgressBar
class | RadioGroup 单选框组合.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.Span

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.Span

No usage of com.bstek.dorado.view.control.Span

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.SplitPanel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.SplitPanel

No usage of com.bstek.dorado.view.control.SplitPanel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.SubWindow

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.SubWindow

No usage of com.bstek.dorado.view.control.SubWindow

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.TextEditor

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.TextEditor

No usage of com.bstek.dorado.view.control.TextEditor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.control.Visible

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.control.Visible

Packages that use Visible
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.table | 表格控件的相关对象
com.bstek.dorado.view.control.tabset | 多页标签控件的相关对象
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Uses of Visible in com.bstek.dorado.view.control

Classes in com.bstek.dorado.view.control that implement Visible
class | Button 按钮对象
class | Calendar 日历
class | CheckBox 复选框
class | DataLabel 数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
class | DataPilot 数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
class | Editor 编辑器的基类
class | FieldLabel 字段标签对象。
class | GroupBox 组合框
class | Label 标签对象
class | MenuBar 菜单工具栏.
class | OutlookBar Outlook工具栏
class | PagePilot 分页导航条.
class | ProgressBar
class | RadioGroup 单选框组合.
class | ScrollBar 滚动条
class | SimpleDataControl 简单数据控件对象
class | SplitPanel 视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
class | SubWindow 子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
class | TextEditor 文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.

Uses of Visible in com.bstek.dorado.view.control.advance

Classes in com.bstek.dorado.view.control.advance that implement Visible
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of Visible in com.bstek.dorado.view.control.table

Classes in com.bstek.dorado.view.control.table that implement Visible
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类
class | Table 表格的基类

Uses of Visible in com.bstek.dorado.view.control.tabset

Classes in com.bstek.dorado.view.control.tabset that implement Visible
 class TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Uses of Visible in com.bstek.dorado.view.control.tree

Classes in com.bstek.dorado.view.control.tree that implement Visible
class | DataTree 树状列表对象
class | Tree 树状列表对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.command
Classes
Command
CommandQueue
DatasetInfo
Frame
QueryCommand
RequestCommand
RPCCommand
UpdateCommand


com.bstek.dorado.view.control.command Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.command

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.command.Command
        • class com.bstek.dorado.view.control.command.CommandQueue
        • class com.bstek.dorado.view.control.command.QueryCommand
        • class com.bstek.dorado.view.control.command.RequestCommand
        • class com.bstek.dorado.view.control.command.RPCCommand
          • class com.bstek.dorado.view.control.command.UpdateCommand
    • class com.bstek.dorado.view.control.command.DatasetInfo
    • class com.bstek.dorado.view.control.command.Frame


Uses of Package com.bstek.dorado.view.control.command

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.command

Packages that use com.bstek.dorado.view.control.command
com.bstek.dorado.view.control.command 命令控件的相关对象

Classes in com.bstek.dorado.view.control.command used by com.bstek.dorado.view.control.command
Command
命令对象的基类
DatasetInfo
用于描述提交命令(UpdateCommand)要提交的Dataset数据集的对象.
Frame
描述请求命令的目标框架的对象
RPCCommand
远程过程调用命令

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.Command

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.Command

Packages that use Command
com.bstek.dorado.view.control.command 命令控件的相关对象

Uses of Command in com.bstek.dorado.view.control.command

Subclasses of Command in com.bstek.dorado.view.control.command
class | CommandQueue 命令队列
class | QueryCommand 查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
class | RequestCommand 请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
class | RPCCommand 远程过程调用命令
class | UpdateCommand 提交命令

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.CommandQueue

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.CommandQueue

No usage of com.bstek.dorado.view.control.command.CommandQueue

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.DatasetInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.DatasetInfo

Packages that use DatasetInfo
com.bstek.dorado.view.control.command 命令控件的相关对象

Uses of DatasetInfo in com.bstek.dorado.view.control.command

Methods in com.bstek.dorado.view.control.command that return DatasetInfo
DatasetInfo | UpdateCommand.addDatasetInfo(java.lang.String datasetId) 添加一个需要提交的数据集并返回新增的DatasetInfo对象.
DatasetInfo | UpdateCommand.addDatasetInfo(java.lang.String datasetId, java.lang.String submitScope) 添加一个需要提交的数据集并返回新增的DatasetInfo对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.Frame

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.Frame

Packages that use Frame
com.bstek.dorado.view.control.command 命令控件的相关对象

Uses of Frame in com.bstek.dorado.view.control.command

Methods in com.bstek.dorado.view.control.command that return Frame
 Frame RequestCommand.getFrame()
返回用于描述目前框架的对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.QueryCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.QueryCommand

No usage of com.bstek.dorado.view.control.command.QueryCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.RequestCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.RequestCommand

No usage of com.bstek.dorado.view.control.command.RequestCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.RPCCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.RPCCommand

Packages that use RPCCommand
com.bstek.dorado.view.control.command 命令控件的相关对象

Uses of RPCCommand in com.bstek.dorado.view.control.command

Subclasses of RPCCommand in com.bstek.dorado.view.control.command
 class UpdateCommand
提交命令

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.SubmitFormDatasetCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.SubmitFormDatasetCommand

No usage of com.bstek.dorado.view.control.command.SubmitFormDatasetCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.command.UpdateCommand

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.command.UpdateCommand

No usage of com.bstek.dorado.view.control.command.UpdateCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.dropdown
Interfaces
CachableDropDown
Classes
AdvanceDropDown
CustomDropDown
CustomDropDownViewModel
DatasetDropDown
DateDropDown
DropDown
DropDownItem
DropDownViewModel
DynamicDropDown
DynamicDropDownDataset
DynamicDropDownViewModel
ListDropDown
SimpleDropDown


com.bstek.dorado.view.control.dropdown Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.dropdown

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.dropdown.DropDown
        • class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
          • class com.bstek.dorado.view.control.dropdown.CustomDropDown (implements com.bstek.dorado.view.control.dropdown.CachableDropDown)
            • class com.bstek.dorado.view.control.dropdown.DynamicDropDown (implements com.bstek.dorado.view.control.dropdown.CachableDropDown)
        • class com.bstek.dorado.view.control.dropdown.SimpleDropDown
          • class com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
            • class com.bstek.dorado.view.control.dropdown.DatasetDropDown
            • class com.bstek.dorado.view.control.dropdown.ListDropDown
          • class com.bstek.dorado.view.control.dropdown.DateDropDown
    • class com.bstek.dorado.data.DatasetSupport (implements com.bstek.dorado.data.DataListener, com.bstek.dorado.data.Dataset)
      • class com.bstek.dorado.data.AbstractDataset
        • class com.bstek.dorado.view.data.ViewDatasetSupport (implements com.bstek.dorado.view.data.ViewDataset)
          • class com.bstek.dorado.view.data.AbstractViewDataset
            • class com.bstek.dorado.view.data.AbstractDatasetReference
              • class com.bstek.dorado.view.data.DatasetReference
                • class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset
    • class com.bstek.dorado.view.control.dropdown.DropDownItem
    • class com.bstek.dorado.view.ViewModelSupport (implements com.bstek.dorado.view.ViewModel)
      • class com.bstek.dorado.view.DefaultViewModel
        • class com.bstek.dorado.view.control.dropdown.DropDownViewModel
          • class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
          • class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel

Interface Hierarchy

  • interface com.bstek.dorado.view.control.dropdown.CachableDropDown


Uses of Package com.bstek.dorado.view.control.dropdown

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.dropdown

Packages that use com.bstek.dorado.view.control.dropdown
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Classes in com.bstek.dorado.view.control.dropdown used by com.bstek.dorado.view.control.dropdown
AdvanceDropDown
高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
CachableDropDown
支持缓存的下拉框接口
CustomDropDown
自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
DropDown
下拉框的基类
DropDownItem
下拉框选择项对象
DropDownViewModel
下拉框的视图模型对象
SimpleDropDown
简单下拉框的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.AdvanceDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.AdvanceDropDown

Packages that use AdvanceDropDown
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of AdvanceDropDown in com.bstek.dorado.view.control.dropdown

Subclasses of AdvanceDropDown in com.bstek.dorado.view.control.dropdown
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.control.dropdown.CachableDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.control.dropdown.CachableDropDown

Packages that use CachableDropDown
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of CachableDropDown in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement CachableDropDown
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.CustomDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.CustomDropDown

Packages that use CustomDropDown
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of CustomDropDown in com.bstek.dorado.view.control.dropdown

Subclasses of CustomDropDown in com.bstek.dorado.view.control.dropdown
 class DynamicDropDown
动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel

No usage of com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DatasetDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DatasetDropDown

No usage of com.bstek.dorado.view.control.dropdown.DatasetDropDown

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DateDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DateDropDown

No usage of com.bstek.dorado.view.control.dropdown.DateDropDown

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DropDown

Packages that use DropDown
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of DropDown in com.bstek.dorado.view.control.dropdown

Subclasses of DropDown in com.bstek.dorado.view.control.dropdown
class | com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
class | AdvanceDropDown 高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
class | CustomDropDown 自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
class | DatasetDropDown Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
class | DateDropDown 日期对象下拉框
class | DynamicDropDown 动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
class | ListDropDown 列表下拉框
class | SimpleDropDown 简单下拉框的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DropDownItem

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DropDownItem

Packages that use DropDownItem
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of DropDownItem in com.bstek.dorado.view.control.dropdown

Methods in com.bstek.dorado.view.control.dropdown that return DropDownItem
DropDownItem | ListDropDown.getItem(int index) 根据指定的索引值取得静态下拉框的下拉数据项对象。
DropDownItem | ListDropDown.addItem(java.lang.String value) 根据指定值添加一个静态下拉框的下拉数据项对象。
DropDownItem | ListDropDown.addItem(java.lang.String value, java.lang.String label) 根据指定值和标题属性添加一个静态下拉框的下拉数据项对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DropDownViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DropDownViewModel

Packages that use DropDownViewModel
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of DropDownViewModel in com.bstek.dorado.view.control.dropdown

Subclasses of DropDownViewModel in com.bstek.dorado.view.control.dropdown
class | CustomDropDownViewModel 自定义下拉框的视图模型对象
class | DynamicDropDownViewModel 动态下拉框的视图模型对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DynamicDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DynamicDropDown

No usage of com.bstek.dorado.view.control.dropdown.DynamicDropDown

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset

No usage of com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel

No usage of com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.ListDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.ListDropDown

No usage of com.bstek.dorado.view.control.dropdown.ListDropDown

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.dropdown.SimpleDropDown

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.dropdown.SimpleDropDown

Packages that use SimpleDropDown
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of SimpleDropDown in com.bstek.dorado.view.control.dropdown

Subclasses of SimpleDropDown in com.bstek.dorado.view.control.dropdown
class | com.bstek.dorado.view.control.dropdown.AbstractDatasetDropDown
class | DatasetDropDown Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
class | DateDropDown 日期对象下拉框
class | ListDropDown 列表下拉框

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.table
Classes
Column
ColumnGroup
DataColumn
DataColumnGroup
DataTable
EditableColumn
StaticColumn
StaticColumnGroup
StaticTable
Table


com.bstek.dorado.view.control.table Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.table

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.DataControl
        • class com.bstek.dorado.view.control.PlaceableDataControl (implements com.bstek.dorado.view.control.Placeable)
          • class com.bstek.dorado.view.control.table.Table (implements com.bstek.dorado.view.control.Visible)
            • class com.bstek.dorado.view.control.table.DataTable
            • class com.bstek.dorado.view.control.table.StaticTable
    • class com.bstek.dorado.view.control.table.Column (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.table.ColumnGroup
        • class com.bstek.dorado.view.control.table.DataColumnGroup (implements com.bstek.dorado.view.EventSupported)
        • class com.bstek.dorado.view.control.table.StaticColumnGroup
      • class com.bstek.dorado.view.control.table.DataColumn
        • class com.bstek.dorado.view.control.table.EditableColumn (implements com.bstek.dorado.view.EventSupported)
        • class com.bstek.dorado.view.control.table.StaticColumn


Uses of Package com.bstek.dorado.view.control.table

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.table

Packages that use com.bstek.dorado.view.control.table
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.table | 表格控件的相关对象

Classes in com.bstek.dorado.view.control.table used by com.bstek.dorado.view.control.advance
DataTable
数据表格 数据表格是一种可以编辑的多功能表格
系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
Table
表格的基类

Classes in com.bstek.dorado.view.control.table used by com.bstek.dorado.view.control.table
Column
表格列的抽象类
ColumnGroup
组合列的基类
DataColumn
数据列的抽象类
Table
表格的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.Column

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.Column

Packages that use Column
com.bstek.dorado.view.control.table 表格控件的相关对象

Uses of Column in com.bstek.dorado.view.control.table

Subclasses of Column in com.bstek.dorado.view.control.table
class | ColumnGroup 组合列的基类
class | DataColumn 数据列的抽象类
class | DataColumnGroup 数据表格中的组合列的基类
class | EditableColumn 数据表格中的可编辑列
class | StaticColumn 静态表格列
class | StaticColumnGroup 静态表格中的组合列

Methods in com.bstek.dorado.view.control.table that return Column
Column | ColumnGroup.addColumn(Column column) 添加一个列对象
Column | ColumnGroup.addColumn(java.lang.String name) 添加一个指定名称的列,并返回新创建的列对象.
Column | ColumnGroup.addColumnByField(Field field) 根据指定的字段对象添加一个列对象,并返回新创建的列对象.
Column | ColumnGroup.getColumn(int index) 根据索引值取得列对象。
Column | ColumnGroup.getColumn(java.lang.String name) 根据名称取得列对象。
protected Column | DataTable.createColumn(java.lang.String name) 创建一个指定名称的列对象。
protected Column | StaticTable.createColumn(java.lang.String name) 创建一个指定名称的列对象。
Column | Table.addColumn(Column column) 添加一个列对象。
Column | Table.addColumn(java.lang.String name) 添加一个指定名称的列。
protected abstract Column | Table.createColumn(java.lang.String name) 创建一个指定名称的列对象。
Column | Table.addColumnByField(Field field) 根据指定的字段对象添加一个列。
Column | Table.getColumn(int index) 根据索引值取得列(Column)对象。
Column | Table.getColumn(java.lang.String name) 根据名称取得列对象。

Methods in com.bstek.dorado.view.control.table with parameters of type Column
Column | ColumnGroup.addColumn(Column column) 添加一个列对象
protected void | DataTable.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
protected void | Table.initColumn(DoradoContext context, Column column, XmlNode columnNode) 初始化列
Column | Table.addColumn(Column column) 添加一个列对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.ColumnGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.ColumnGroup

Packages that use ColumnGroup
com.bstek.dorado.view.control.table 表格控件的相关对象

Uses of ColumnGroup in com.bstek.dorado.view.control.table

Subclasses of ColumnGroup in com.bstek.dorado.view.control.table
class | DataColumnGroup 数据表格中的组合列的基类
class | StaticColumnGroup 静态表格中的组合列

Methods in com.bstek.dorado.view.control.table that return ColumnGroup
protected ColumnGroup | DataTable.createColumnGroup(java.lang.String name) 创建一个指定名称的组合列
protected ColumnGroup | StaticTable.createColumnGroup(java.lang.String name) 创建一个指定名称的组合列
ColumnGroup | Table.addColumnGroup(java.lang.String name) 添加一个指定名称的组合列。
protected abstract ColumnGroup | Table.createColumnGroup(java.lang.String name) 创建一个指定名称的组合列

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.DataColumn

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.DataColumn

Packages that use DataColumn
com.bstek.dorado.view.control.table 表格控件的相关对象

Uses of DataColumn in com.bstek.dorado.view.control.table

Subclasses of DataColumn in com.bstek.dorado.view.control.table
class | EditableColumn 数据表格中的可编辑列
class | StaticColumn 静态表格列

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.DataColumnGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.DataColumnGroup

No usage of com.bstek.dorado.view.control.table.DataColumnGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.DataTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.DataTable

Packages that use DataTable
com.bstek.dorado.view.control.advance 高级控件相关类

Uses of DataTable in com.bstek.dorado.view.control.advance

Subclasses of DataTable in com.bstek.dorado.view.control.advance
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.EditableColumn

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.EditableColumn

No usage of com.bstek.dorado.view.control.table.EditableColumn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.EditableColumnGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.EditableColumnGroup

No usage of com.bstek.dorado.view.control.table.EditableColumnGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.StaticColumn

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.StaticColumn

No usage of com.bstek.dorado.view.control.table.StaticColumn

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.StaticColumnGroup

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.StaticColumnGroup

No usage of com.bstek.dorado.view.control.table.StaticColumnGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.StaticTable

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.StaticTable

No usage of com.bstek.dorado.view.control.table.StaticTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.table.Table

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.table.Table

Packages that use Table
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.table | 表格控件的相关对象

Uses of Table in com.bstek.dorado.view.control.advance

Subclasses of Table in com.bstek.dorado.view.control.advance
 class TreeGrid
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.

Uses of Table in com.bstek.dorado.view.control.table

Subclasses of Table in com.bstek.dorado.view.control.table
class | DataTable 数据表格 数据表格是一种可以编辑的多功能表格 系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
class | StaticTable 静态表格类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.tabset
Classes
FrameTab
Tab
TabElement
TabSet


com.bstek.dorado.view.control.tabset Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.tabset

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.PlaceableControl (implements com.bstek.dorado.view.control.Placeable)
        • class com.bstek.dorado.view.control.tabset.TabSet (implements com.bstek.dorado.view.control.Visible)
    • class com.bstek.dorado.view.control.tabset.TabElement (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.tabset.FrameTab
      • class com.bstek.dorado.view.control.tabset.Tab


Uses of Package com.bstek.dorado.view.control.tabset

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.tabset

Packages that use com.bstek.dorado.view.control.tabset
com.bstek.dorado.view.control.tabset 多页标签控件的相关对象

Classes in com.bstek.dorado.view.control.tabset used by com.bstek.dorado.view.control.tabset
TabElement
多页标签页中标签页的基类
TabSet
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tabset.FrameTab

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tabset.FrameTab

No usage of com.bstek.dorado.view.control.tabset.FrameTab

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tabset.Tab

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tabset.Tab

No usage of com.bstek.dorado.view.control.tabset.Tab

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tabset.TabElement

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tabset.TabElement

Packages that use TabElement
com.bstek.dorado.view.control.tabset 多页标签控件的相关对象

Uses of TabElement in com.bstek.dorado.view.control.tabset

Subclasses of TabElement in com.bstek.dorado.view.control.tabset
class | FrameTab 多页标签中的子框架标签项 子框架标签项在多页标签中用于显示指定URL资源的页面.
class | Tab 多页标签中的默认标签项

Methods in com.bstek.dorado.view.control.tabset that return TabElement
TabElement | TabSet.addTab(java.lang.String name) Deprecated.
TabElement | TabSet.addTab(java.lang.String name, java.lang.String label) Deprecated.
TabElement | TabSet.getTab(int index) 取得一个指定索引位置的标签项对象。
TabElement | TabSet.getTab(java.lang.String name) 取得一个指定名称的标签项对象。

Methods in com.bstek.dorado.view.control.tabset with parameters of type TabElement
 void TabSet.addTab(TabElement tab)
添加一个指定标签项

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tabset.TabSet

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tabset.TabSet

Packages that use TabSet
com.bstek.dorado.view.control.tabset 多页标签控件的相关对象

Uses of TabSet in com.bstek.dorado.view.control.tabset

Methods in com.bstek.dorado.view.control.tabset that return TabSet
 TabSet TabElement.getTabSet()
返回标签所属的TabSet对象

Methods in com.bstek.dorado.view.control.tabset with parameters of type TabSet
 void TabElement.setTabSet(TabSet tabset)
设定标签所属的TabSet对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.control.tree
Classes
BindingTreeLevel
DataTree
DefaultTreeNode
RecordTreeNode
RecursiveTreeLevel
SimpleTreeLevel
Tree
TreeLevel
TreeNode


com.bstek.dorado.view.control.tree Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.control.tree

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.control.AbstractControl (implements com.bstek.dorado.view.control.Control)
      • class com.bstek.dorado.view.control.PlaceableControl (implements com.bstek.dorado.view.control.Placeable)
        • class com.bstek.dorado.view.control.tree.Tree (implements com.bstek.dorado.view.control.Visible)
          • class com.bstek.dorado.view.control.tree.DataTree
    • class com.bstek.dorado.view.control.tree.TreeLevel
      • class com.bstek.dorado.view.control.tree.BindingTreeLevel
        • class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
        • class com.bstek.dorado.view.control.tree.SimpleTreeLevel
    • class com.bstek.dorado.view.control.tree.TreeNode (implements com.bstek.dorado.view.Element)
      • class com.bstek.dorado.view.control.tree.DefaultTreeNode
      • class com.bstek.dorado.view.control.tree.RecordTreeNode


Uses of Package com.bstek.dorado.view.control.tree

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.control.tree

Packages that use com.bstek.dorado.view.control.tree
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Classes in com.bstek.dorado.view.control.tree used by com.bstek.dorado.view.control.advance
TreeNode
树节点对象的基类

Classes in com.bstek.dorado.view.control.tree used by com.bstek.dorado.view.control.tree
BindingTreeLevel
支持数据绑定的树状列表节点层的基类
Tree
树状列表对象
TreeLevel
树状列表节点层的基类
TreeNode
树节点对象的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.BandingTreeLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.BandingTreeLevel

Packages that use BandingTreeLevel
com.bstek.dorado.view.control.tree 树状列表控件的相关对象

Uses of BandingTreeLevel in com.bstek.dorado.view.control.tree

Subclasses of BandingTreeLevel in com.bstek.dorado.view.control.tree
class | RecursiveTreeLevel 数据树中的递归层的描述对象.
class | SimpleTreeLevel 数据树中的简单层的描述对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.BindingTreeLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.BindingTreeLevel

Packages that use BindingTreeLevel
com.bstek.dorado.view.control.tree 树状列表控件的相关对象

Uses of BindingTreeLevel in com.bstek.dorado.view.control.tree

Subclasses of BindingTreeLevel in com.bstek.dorado.view.control.tree
class | RecursiveTreeLevel 数据树中的递归层的描述对象.
class | SimpleTreeLevel 数据树中的简单层的描述对象.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.DataTree

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.DataTree

No usage of com.bstek.dorado.view.control.tree.DataTree

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.DefaultTreeNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.DefaultTreeNode

No usage of com.bstek.dorado.view.control.tree.DefaultTreeNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.RecordTreeNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.RecordTreeNode

No usage of com.bstek.dorado.view.control.tree.RecordTreeNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.RecursiveTreeLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.RecursiveTreeLevel

No usage of com.bstek.dorado.view.control.tree.RecursiveTreeLevel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.SimpleTreeLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.SimpleTreeLevel

No usage of com.bstek.dorado.view.control.tree.SimpleTreeLevel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.Tree

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.Tree

Packages that use Tree
com.bstek.dorado.view.control.tree 树状列表控件的相关对象

Uses of Tree in com.bstek.dorado.view.control.tree

Subclasses of Tree in com.bstek.dorado.view.control.tree
 class DataTree
树状列表对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.TreeLevel

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.TreeLevel

Packages that use TreeLevel
com.bstek.dorado.view.control.tree 树状列表控件的相关对象

Uses of TreeLevel in com.bstek.dorado.view.control.tree

Subclasses of TreeLevel in com.bstek.dorado.view.control.tree
class | BindingTreeLevel 支持数据绑定的树状列表节点层的基类
class | RecursiveTreeLevel 数据树中的递归层的描述对象.
class | SimpleTreeLevel 数据树中的简单层的描述对象.

Methods in com.bstek.dorado.view.control.tree that return TreeLevel
TreeLevel | DataTree.getTreeLevel(java.lang.String name) 根据名称取得一个节点层
TreeLevel | DataTree.getRootLevel() 取得树的顶节点层对象.
protected TreeLevel | DataTree.createTreeLevel(XmlNode node, DoradoContext context) 根据XML节点创建节点层
TreeLevel | RecordTreeNode.getLevel() 返回树节点相关的节点层对象.
TreeLevel | TreeLevel.getTreeLevel(java.lang.String name) 根据名称取得一个子节点层

Methods in com.bstek.dorado.view.control.tree with parameters of type TreeLevel
void | DataTree.addTreeLevel(TreeLevel level) 添加一个节点层
protected void | DataTree.loadChildLevels(TreeLevel level, XmlNode node, DoradoContext context) 加载子节点层
protected void | DataTree.loadNodes(TreeNode node, TreeLevel level)
void | RecordTreeNode.setLevel(TreeLevel level) 设置树节点相关的节点层对象.
void | TreeLevel.addTreeLevel(TreeLevel level) 添加一个子节点层

Constructors in com.bstek.dorado.view.control.tree with parameters of type TreeLevel
RecordTreeNode(Record record, TreeLevel level)
构造器.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.control.tree.TreeNode

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.control.tree.TreeNode

Packages that use TreeNode
com.bstek.dorado.view.control.advance | 高级控件相关类
com.bstek.dorado.view.control.tree | 树状列表控件的相关对象

Uses of TreeNode in com.bstek.dorado.view.control.advance

Methods in com.bstek.dorado.view.control.advance that return TreeNode
 TreeNode TreeGrid.getRoot()
取得树的根节点对象。

Methods in com.bstek.dorado.view.control.advance with parameters of type TreeNode
protected  void TreeGrid.loadNodes(TreeNode parentNode, int nodeLevel)

Uses of TreeNode in com.bstek.dorado.view.control.tree

Subclasses of TreeNode in com.bstek.dorado.view.control.tree
class | DefaultTreeNode 默认的树节点对象
class | RecordTreeNode 跟记录绑定的树节点.

Methods in com.bstek.dorado.view.control.tree that return TreeNode
TreeNode | Tree.getRoot() 取得树的顶节点对象.
TreeNode | TreeNode.addNode() Deprecated.

Methods in com.bstek.dorado.view.control.tree with parameters of type TreeNode
protected void | DataTree.loadNodes(TreeNode node, TreeLevel level)
protected void | Tree.loadNodes(DoradoContext context, XmlNode node, TreeNode treeNode) 加载树节点
void | TreeNode.addNode(TreeNode node) 添加一个指定的节点,作为当前树节点的子节点。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.data
Interfaces
ViewDataset
ViewField
Classes
CustomDataset
DatasetReference
DatasetWrapper
DODataset
FormDataset
MasterDetailLink
ViewBaseField
ViewDatasetAdapter
ViewDatasetSupport
ViewLookupField
ViewRecord


com.bstek.dorado.view.data Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.data

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.data.AbstractField (implements com.bstek.dorado.data.Field)
      • class com.bstek.dorado.data.BaseField
        • class com.bstek.dorado.view.data.ViewBaseField (implements com.bstek.dorado.view.data.ViewField)
      • class com.bstek.dorado.data.LookupField
        • class com.bstek.dorado.view.data.ViewLookupField (implements com.bstek.dorado.view.data.ViewField)
    • class com.bstek.dorado.data.DatasetSupport (implements com.bstek.dorado.data.DataListener, com.bstek.dorado.data.Dataset)
      • class com.bstek.dorado.data.AbstractDataset
        • class com.bstek.dorado.view.data.ViewDatasetSupport (implements com.bstek.dorado.view.data.ViewDataset)
          • class com.bstek.dorado.view.data.AbstractViewDataset
            • class com.bstek.dorado.view.data.AbstractDatasetReference
              • class com.bstek.dorado.view.data.DatasetReference
              • class com.bstek.dorado.view.data.DatasetWrapper
            • class com.bstek.dorado.view.data.CustomDataset
            • class com.bstek.dorado.view.data.DODataset
            • class com.bstek.dorado.view.data.FormDataset
          • class com.bstek.dorado.view.data.ViewDatasetAdapter
    • class com.bstek.dorado.view.data.MasterDetailLink
    • class com.bstek.dorado.data.ReadRecord
      • class com.bstek.dorado.data.Record (implements java.lang.Cloneable, java.io.Serializable)
        • class com.bstek.dorado.data.BaseRecord
          • class com.bstek.dorado.data.DORecord
            • class com.bstek.dorado.view.data.ViewRecord

Interface Hierarchy

  • interface com.bstek.dorado.view.Element
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.EventSupported)
      • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.data.Dataset)
    • interface com.bstek.dorado.view.data.ViewField (also extends com.bstek.dorado.data.Field)
  • interface com.bstek.dorado.view.EventSupported
    • interface com.bstek.dorado.view.Component (also extends com.bstek.dorado.view.Element)
      • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.data.Dataset)
  • interface com.bstek.dorado.data.Field
    • interface com.bstek.dorado.view.data.ViewField (also extends com.bstek.dorado.view.Element)
  • interface java.io.Serializable
    • interface com.bstek.dorado.data.Dataset
      • interface com.bstek.dorado.view.data.ViewDataset (also extends com.bstek.dorado.view.Component)


Uses of Package com.bstek.dorado.view.data

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.data

Packages that use com.bstek.dorado.view.data
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Classes in com.bstek.dorado.view.data used by com.bstek.dorado.view
ViewDataset
视图模型中数据集对象的基础类

Classes in com.bstek.dorado.view.data used by com.bstek.dorado.view.control
ViewDataset
视图模型中数据集对象的基础类

Classes in com.bstek.dorado.view.data used by com.bstek.dorado.view.control.command
ViewDataset
视图模型中数据集对象的基础类

Classes in com.bstek.dorado.view.data used by com.bstek.dorado.view.control.dropdown
DatasetReference
数据集引用对象
ViewDataset
视图模型中数据集对象的基础类
ViewDatasetSupport
视图数据集的抽象基类。

Classes in com.bstek.dorado.view.data used by com.bstek.dorado.view.data
MasterDetailLink
描述主从数据集连接关系的对象.
ViewDataset
视图模型中数据集对象的基础类
ViewDatasetSupport
视图数据集的抽象基类。
ViewField
视图模型中数据集字段对象

Classes in com.bstek.dorado.view.data used by com.bstek.dorado.view.rpc
ViewDataset
视图模型中数据集对象的基础类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.CustomDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.CustomDataset

No usage of com.bstek.dorado.view.data.CustomDataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.DatasetReference

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.DatasetReference

Packages that use DatasetReference
com.bstek.dorado.view.control.dropdown 下拉框控件的相关对象

Uses of DatasetReference in com.bstek.dorado.view.control.dropdown

Subclasses of DatasetReference in com.bstek.dorado.view.control.dropdown
 class DynamicDropDownDataset
动态下拉框数据集对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.DatasetWrapper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.DatasetWrapper

No usage of com.bstek.dorado.view.data.DatasetWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.DODataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.DODataset

No usage of com.bstek.dorado.view.data.DODataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.FormDataset

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.FormDataset

No usage of com.bstek.dorado.view.data.FormDataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.MasterDetailLink

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.MasterDetailLink

Packages that use MasterDetailLink
com.bstek.dorado.view.data 视图数据集的相关类

Uses of MasterDetailLink in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data that return MasterDetailLink
MasterDetailLink | ViewDataset.getMasterLink() 返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
MasterDetailLink | ViewDatasetSupport.getMasterLink() 返回用于描述该Dataset与MasterDataset之间的关联关系的对象。

Methods in com.bstek.dorado.view.data with parameters of type MasterDetailLink
void | ViewDataset.setMasterLink(MasterDetailLink masterLink) 设定描述该Dataset与MasterDataset之间的关联关系的对象。
void | ViewDataset.registerDetailLink(MasterDetailLink detailLink) 注册一个关联关系的对象。
void | ViewDataset.unregisterDetailLink(MasterDetailLink detailLink) 注销一个关联关系的对象。
void | ViewDatasetSupport.setMasterLink(MasterDetailLink masterLink) 设定描述该Dataset与MasterDataset之间的关联关系的对象。
void | ViewDatasetSupport.registerDetailLink(MasterDetailLink detailLink) 注册一个关联关系的对象。
void | ViewDatasetSupport.unregisterDetailLink(MasterDetailLink detailLink) 注销一个关联关系的对象。

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.ViewBaseField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.ViewBaseField

No usage of com.bstek.dorado.view.data.ViewBaseField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.data.ViewDataset

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.data.ViewDataset

Packages that use ViewDataset
com.bstek.dorado.view | 包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control | 各种控件类及实现
com.bstek.dorado.view.control.command | 命令控件的相关对象
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.rpc | 用于处理客户端远程过程调用的相关类

Uses of ViewDataset in com.bstek.dorado.view

Methods in com.bstek.dorado.view that return ViewDataset
ViewDataset | ViewModel.createDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。
ViewDataset | ViewModel.createDataset(XmlNode node) 根据xml的定义创建一个视图数据集。
ViewDataset | ViewModel.getDataset(java.lang.String id) 根据指定的Id取得一个视图数据集对象。
protected ViewDataset | ViewModelSupport.constructDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。
ViewDataset | ViewModelSupport.createDataset(XmlNode node) 根据xml的定义创建一个视图数据集。
ViewDataset | ViewModelSupport.createDataset(java.lang.String type, java.lang.String id) 根据类型和Id，创建一个视图数据集。
ViewDataset | ViewModelSupport.getDataset(java.lang.String id) 根据指定的Id取得一个视图数据集对象。

Methods in com.bstek.dorado.view with parameters of type ViewDataset
protected void | DefaultViewModel.initDataset(ViewDataset dataset) 初试化一个ViewDataset
protected void | ViewModelSupport.initDataset(ViewDataset dataset) 初试化一个ViewDataset

Uses of ViewDataset in com.bstek.dorado.view.control

Methods in com.bstek.dorado.view.control that return ViewDataset
 ViewDataset DataControl.getDatasetInstance()
返回数据控件绑定的数据集实例。

Uses of ViewDataset in com.bstek.dorado.view.control.command

Methods in com.bstek.dorado.view.control.command that return ViewDataset
ViewDataset | QueryCommand.getConditionDatasetInstance() 返回作为查询条件的数据集的实例
ViewDataset | QueryCommand.getQueryDatasetInstance() 返回被查询的数据集的实例
ViewDataset | RequestCommand.getDatasetInstance() 返回绑定的数据集的实例。

Uses of ViewDataset in com.bstek.dorado.view.control.dropdown

Classes in com.bstek.dorado.view.control.dropdown that implement ViewDataset
 class DynamicDropDownDataset
动态下拉框数据集对象

Methods in com.bstek.dorado.view.control.dropdown that return ViewDataset
protected  ViewDataset DynamicDropDownViewModel.constructDataset(java.lang.String type, java.lang.String id)
根据类型和Id，创建一个视图数据集。 此方法用于提供给非派生类进行重载。

Uses of ViewDataset in com.bstek.dorado.view.data

Classes in com.bstek.dorado.view.data that implement ViewDataset
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | CustomDataset 用户自定义视图数据集对象
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器
class | ViewDatasetSupport 视图数据集的抽象基类。

Methods in com.bstek.dorado.view.data that return ViewDataset
ViewDataset | MasterDetailLink.getMasterDataset() 返回主数据集
ViewDataset | MasterDetailLink.getDetailDataset() 取得从数据集
ViewDataset | ViewDatasetAdapter.getTarget() 取得被适配的数据集

Methods in com.bstek.dorado.view.data with parameters of type ViewDataset
void | MasterDetailLink.setMasterDataset(ViewDataset masterDataset) 设置主数据集
void | MasterDetailLink.setDetailDataset(ViewDataset detailDataset) 设定从数据集
void | ViewDatasetAdapter.setTarget(ViewDataset target) 设定被适配的数据集

Constructors in com.bstek.dorado.view.data with parameters of type ViewDataset
MasterDetailLink(ViewDataset masterDataset, java.lang.String masterKeyFields, java.lang.String detailParametersFields)
构造器

Uses of ViewDataset in com.bstek.dorado.view.rpc

Methods in com.bstek.dorado.view.rpc that return ViewDataset
ViewDataset | LoadDataRPCHandler.getViewDataset() 取得发送动态数据加载操作的Dataset.
ViewDataset | UpdateDataRPCHandler.getViewDataset(java.lang.String id) 根据id取得一个相应的ViewModel中的Dataset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.ViewDatasetAdapter

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.ViewDatasetAdapter

No usage of com.bstek.dorado.view.data.ViewDatasetAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.ViewDatasetSupport

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.ViewDatasetSupport

Packages that use ViewDatasetSupport
com.bstek.dorado.view.control.dropdown | 下拉框控件的相关对象
com.bstek.dorado.view.data | 视图数据集的相关类

Uses of ViewDatasetSupport in com.bstek.dorado.view.control.dropdown

Subclasses of ViewDatasetSupport in com.bstek.dorado.view.control.dropdown
 class DynamicDropDownDataset
动态下拉框数据集对象

Uses of ViewDatasetSupport in com.bstek.dorado.view.data

Subclasses of ViewDatasetSupport in com.bstek.dorado.view.data
class | com.bstek.dorado.view.data.AbstractDatasetReference
class | com.bstek.dorado.view.data.AbstractViewDataset
class | CustomDataset 用户自定义视图数据集对象
class | DatasetReference 数据集引用对象
class | DatasetWrapper 数据集包装器.
class | DODataset 可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
class | FormDataset 表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
class | ViewDatasetAdapter 视图模型数据集适配器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.data.ViewField

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.data.ViewField

Packages that use ViewField
com.bstek.dorado.view.data 视图数据集的相关类

Uses of ViewField in com.bstek.dorado.view.data

Classes in com.bstek.dorado.view.data that implement ViewField
class | ViewBaseField 视图模型中数据字段的基础类
class | ViewLookupField 视图模型中LookupField对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.ViewLookupField

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.ViewLookupField

No usage of com.bstek.dorado.view.data.ViewLookupField

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.ViewRecord

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.ViewRecord

No usage of com.bstek.dorado.view.data.ViewRecord

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.data.validate
Interfaces
Validator
Exceptions
IllegalValueException


com.bstek.dorado.view.data.validate Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.data.validate

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class com.bstek.dorado.utils.DoradoRuntimeException
            • class com.bstek.dorado.view.data.validate.IllegalValueException

Interface Hierarchy

  • interface com.bstek.dorado.view.Element
    • interface com.bstek.dorado.view.data.validate.Validator (also extends com.bstek.dorado.view.EventSupported)
  • interface com.bstek.dorado.view.EventSupported
    • interface com.bstek.dorado.view.data.validate.Validator (also extends com.bstek.dorado.view.Element)


Uses of Package com.bstek.dorado.view.data.validate

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.data.validate

Packages that use com.bstek.dorado.view.data.validate
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate | 数据校验器的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现

Classes in com.bstek.dorado.view.data.validate used by com.bstek.dorado.view.data
Validator
校验器的基类

Classes in com.bstek.dorado.view.data.validate used by com.bstek.dorado.view.data.validate
IllegalValueException
非法值异常。

Classes in com.bstek.dorado.view.data.validate used by com.bstek.dorado.view.data.validate.impl
IllegalValueException
非法值异常。
Validator
校验器的基类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.IllegalValueException

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.IllegalValueException

Packages that use IllegalValueException
com.bstek.dorado.view.data.validate | 数据校验器的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现

Uses of IllegalValueException in com.bstek.dorado.view.data.validate

Methods in com.bstek.dorado.view.data.validate that throw IllegalValueException
 void Validator.validate(java.lang.Object value)
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Uses of IllegalValueException in com.bstek.dorado.view.data.validate.impl

Methods in com.bstek.dorado.view.data.validate.impl that throw IllegalValueException
void | CustomValidator.validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
void | LengthValidator.validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
void | ListValidator.validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
void | PatternValidator.validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
void | RequiredValidator.validate(java.lang.Object value) 对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.data.validate.Validator

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.data.validate.Validator

Packages that use Validator
com.bstek.dorado.view.data | 视图数据集的相关类
com.bstek.dorado.view.data.validate.impl | 数据校验器的实现

Uses of Validator in com.bstek.dorado.view.data

Methods in com.bstek.dorado.view.data with parameters of type Validator
void | ViewBaseField.addValidator(Validator validator) 为字段添加一个校验器。
void | ViewBaseField.removeValidator(Validator validator) 删除一个字段的校验器.
protected void | ViewDatasetSupport.initValidator(Validator validator, XmlNode validatorNode) initValidator
void | ViewField.addValidator(Validator validator) 为字段添加一个校验器。
void | ViewField.removeValidator(Validator validator) 删除一个字段的校验器.
void | ViewLookupField.addValidator(Validator validator) 为字段添加一个校验器。
void | ViewLookupField.removeValidator(Validator validator) 删除一个字段的校验器.

Uses of Validator in com.bstek.dorado.view.data.validate.impl

Classes in com.bstek.dorado.view.data.validate.impl that implement Validator
class | com.bstek.dorado.view.data.validate.impl.AbstractValidator
class | CustomValidator 用户自定义数据校验对象
class | LengthValidator 长度校验器 用于校验一个数据(一般指字符串)的长度是否有效的校验器.
class | ListValidator List值的校验对象 对于是否属于某一组值的校验
class | PatternValidator 基于正则表达式的校验对象
class | RangeValidator 数值范围校验器 用于校验指定的数据是否在一个允许的范围内的校验器.例如可用于校验某字段中录入的内容必须在2000-10000之间.
class | RequiredValidator 必需类型校验对象

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.data.validate.impl
Classes
CustomValidator
LengthValidator
ListValidator
PatternValidator
RangeValidator
RequiredValidator
ValidatorInfo


com.bstek.dorado.view.data.validate.impl Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.data.validate.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.data.validate.impl.AbstractValidator (implements com.bstek.dorado.view.data.validate.Validator)
      • class com.bstek.dorado.view.data.validate.impl.CustomValidator
      • class com.bstek.dorado.view.data.validate.impl.LengthValidator
      • class com.bstek.dorado.view.data.validate.impl.ListValidator
      • class com.bstek.dorado.view.data.validate.impl.PatternValidator
      • class com.bstek.dorado.view.data.validate.impl.RangeValidator
      • class com.bstek.dorado.view.data.validate.impl.RequiredValidator
    • class com.bstek.dorado.view.data.validate.impl.ValidatorInfo


Uses of Package com.bstek.dorado.view.data.validate.impl

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.data.validate.impl

No usage of com.bstek.dorado.view.data.validate.impl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.CustomValidator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.CustomValidator

No usage of com.bstek.dorado.view.data.validate.impl.CustomValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.LengthValidator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.LengthValidator

No usage of com.bstek.dorado.view.data.validate.impl.LengthValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.ListValidator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.ListValidator

No usage of com.bstek.dorado.view.data.validate.impl.ListValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.PatternValidator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.PatternValidator

No usage of com.bstek.dorado.view.data.validate.impl.PatternValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.RangeValidator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.RangeValidator

No usage of com.bstek.dorado.view.data.validate.impl.RangeValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.RequiredValidator

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.RequiredValidator

No usage of com.bstek.dorado.view.data.validate.impl.RequiredValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.data.validate.impl.ValidatorInfo

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.data.validate.impl.ValidatorInfo

No usage of com.bstek.dorado.view.data.validate.impl.ValidatorInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 com.bstek.dorado.view.rpc
Interfaces
RPCHandler
Classes
BaseRPCHandler
LoadDataRPCHandler
RPCHelper
UpdateDataRPCHandler


com.bstek.dorado.view.rpc Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package com.bstek.dorado.view.rpc

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class com.bstek.dorado.view.rpc.AbstractRPCHandler (implements com.bstek.dorado.view.rpc.RPCHandler)
      • class com.bstek.dorado.view.rpc.BaseRPCHandler
        • class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
      • class com.bstek.dorado.view.rpc.LoadDataRPCHandler
    • class com.bstek.dorado.view.rpc.RPCHelper

Interface Hierarchy

  • interface com.bstek.dorado.view.rpc.RPCHandler
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package com.bstek.dorado.view.rpc

PREV NEXT FRAMES NO FRAMES

Uses of Package
com.bstek.dorado.view.rpc

Packages that use com.bstek.dorado.view.rpc
com.bstek.dorado.view.rpc 用于处理客户端远程过程调用的相关类

Classes in com.bstek.dorado.view.rpc used by com.bstek.dorado.view.rpc
BaseRPCHandler
基本的远程方法调用的处理类
LoadDataRPCHandler
用于处理客户端发送的动态数据加载操作的处理类
RPCHandler
来自客户端的远程方法调用的处理类
UpdateDataRPCHandler
用于处理客户端发送的动态数据更新操作的处理类

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.rpc.BaseRPCHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.rpc.BaseRPCHandler

Packages that use BaseRPCHandler
com.bstek.dorado.view.rpc 用于处理客户端远程过程调用的相关类

Uses of BaseRPCHandler in com.bstek.dorado.view.rpc

Subclasses of BaseRPCHandler in com.bstek.dorado.view.rpc
 class UpdateDataRPCHandler
用于处理客户端发送的动态数据更新操作的处理类

Methods in com.bstek.dorado.view.rpc that return BaseRPCHandler
static BaseRPCHandler RPCHelper.getBaseHandler(javax.servlet.http.HttpServletRequest request)
获得一个基本远程过程调用的处理器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.rpc.LoadDataRPCHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.rpc.LoadDataRPCHandler

Packages that use LoadDataRPCHandler
com.bstek.dorado.view.rpc 用于处理客户端远程过程调用的相关类

Uses of LoadDataRPCHandler in com.bstek.dorado.view.rpc

Methods in com.bstek.dorado.view.rpc that return LoadDataRPCHandler
static LoadDataRPCHandler RPCHelper.getLoadDataHandler(javax.servlet.http.HttpServletRequest request)
获得一个动态数据加载过程的处理器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.bstek.dorado.view.rpc.RPCHandler

PREV NEXT FRAMES NO FRAMES

Uses of Interface
com.bstek.dorado.view.rpc.RPCHandler

Packages that use RPCHandler
com.bstek.dorado.view.rpc 用于处理客户端远程过程调用的相关类

Uses of RPCHandler in com.bstek.dorado.view.rpc

Classes in com.bstek.dorado.view.rpc that implement RPCHandler
class | com.bstek.dorado.view.rpc.AbstractRPCHandler
class | BaseRPCHandler 基本的远程方法调用的处理类
class | LoadDataRPCHandler 用于处理客户端发送的动态数据加载操作的处理类
class | UpdateDataRPCHandler 用于处理客户端发送的动态数据更新操作的处理类

Methods in com.bstek.dorado.view.rpc that return RPCHandler
static RPCHandler RPCHelper.getHandler(javax.servlet.http.HttpServletRequest request)
获得一个远程过程调用的处理器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.rpc.RPCHelper

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.rpc.RPCHelper

No usage of com.bstek.dorado.view.rpc.RPCHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.bstek.dorado.view.rpc.UpdateDataRPCHandler

PREV NEXT FRAMES NO FRAMES

Uses of Class
com.bstek.dorado.view.rpc.UpdateDataRPCHandler

Packages that use UpdateDataRPCHandler
com.bstek.dorado.view.rpc 用于处理客户端远程过程调用的相关类

Uses of UpdateDataRPCHandler in com.bstek.dorado.view.rpc

Methods in com.bstek.dorado.view.rpc that return UpdateDataRPCHandler
static UpdateDataRPCHandler RPCHelper.getUpdateDataHandler(javax.servlet.http.HttpServletRequest request)
获得一个数据提交过程的处理器

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


A-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

A

ACTION_MESSAGE_KEY - Static variable in class com.bstek.dorado.action.Constants
用于在Request中保存某Action的消息集合对象的Attribute键值
ALL - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 提交Dataset中所有的记录。
ALLOW_EQUALS - Static variable in class com.bstek.dorado.view.data.validate.impl.RangeValidator
范围校验类型 - 允许等于
ALL_CHANGE - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 只提交Dataset中所有更改过的记录，包括新增、修改、删除的记录。
AND - Static variable in class com.bstek.dorado.data.db.AndOrMatchRule
等于
APPLICATION - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - Application.即整个应用中的所有Client都可访问。
APPLICATION - Static variable in class com.bstek.dorado.common.scope.Scope
作用域类型 - Application，即整个应用中的所有Client都可访问。
ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.common.HttpContextFactory
ATTRIBUTE_KEY
ATTRIBUTE_KEY - Static variable in interface com.bstek.dorado.view.rpc.RPCHandler
ATTRIBUTE_KEY
AUTO - Static variable in class com.bstek.dorado.view.control.DataPilot
AUTO - Static variable in class com.bstek.dorado.view.control.autoform.FormElement
AVERAGE - Static variable in class com.bstek.dorado.data.db.AggregateMode
求字段的平均值
AccessChecker - interface com.bstek.dorado.security.AccessChecker.
Dorado提供的默认的一种用户登录状态校验的类
AccessDeniedException - exception com.bstek.dorado.security.AccessDeniedException.
用户登录状态校验失败产生的异常
AccessDeniedException() - Constructor for class com.bstek.dorado.security.AccessDeniedException
构造器
AccessDeniedException(String) - Constructor for class com.bstek.dorado.security.AccessDeniedException
构造器
AccessDeniedException(Throwable) - Constructor for class com.bstek.dorado.security.AccessDeniedException
构造器
Action - interface com.bstek.dorado.action.Action.
Action的接口 在运行时创建的对象，当用户激活一个Action时系统会自动创建此对象。
ActionConfig - class com.bstek.dorado.action.mapping.ActionConfig.
对应一个Action的Mapping配置信息
ActionConfig(String) - Constructor for class com.bstek.dorado.action.mapping.ActionConfig
构造器
ActionException - class com.bstek.dorado.action.mapping.ActionException.
Request的跳转目标。
ActionException(String) - Constructor for class com.bstek.dorado.action.mapping.ActionException
构造器
ActionForward - class com.bstek.dorado.action.mapping.ActionForward.
Request的跳转目标。
ActionForward(String) - Constructor for class com.bstek.dorado.action.mapping.ActionForward
构造器
ActionForward(String, String) - Constructor for class com.bstek.dorado.action.mapping.ActionForward
构造器
ActionForward(String, String, boolean) - Constructor for class com.bstek.dorado.action.mapping.ActionForward
构造器
ActionNotSuppertedException - exception com.bstek.dorado.action.ActionNotSuppertedException.
无法找到指定的Action的异常。
ActionNotSuppertedException() - Constructor for class com.bstek.dorado.action.ActionNotSuppertedException
构造器
ActionNotSuppertedException(String) - Constructor for class com.bstek.dorado.action.ActionNotSuppertedException
构造器
ActionTarget - class com.bstek.dorado.action.mapping.ActionTarget.
Request的跳转目标。
ActionTarget() - Constructor for class com.bstek.dorado.action.mapping.ActionTarget
ActionTargetCollection - interface com.bstek.dorado.action.mapping.ActionTargetCollection.
用于管理一组ActionForward和ActionException的对象
AdvanceDropDown - class com.bstek.dorado.view.control.dropdown.AdvanceDropDown.
高级下拉框的抽象类 当用户在下拉框中选择了一条记录后,系统将自动根据readFields和writeFields的设置将该记录中的 数据赋值到目标数据集中.此处目标数据集是指与下拉框对应的编辑框所绑定的数据集.
AdvanceDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
构造器
AggregateMode - class com.bstek.dorado.data.db.AggregateMode.
有关字段统计方式的常量.
AndOrMatchRule - class com.bstek.dorado.data.db.AndOrMatchRule.
用于描述AutoSqlDataset的WHERE片断中的and/or逻辑连接符的规则对象
AndOrMatchRule() - Constructor for class com.bstek.dorado.data.db.AndOrMatchRule
构造器
AndOrMatchRule(String) - Constructor for class com.bstek.dorado.data.db.AndOrMatchRule
构造器
AutoDBField - class com.bstek.dorado.data.db.AutoDBField.
自动SQL记录集的字段对象
AutoDBField(String) - Constructor for class com.bstek.dorado.data.db.AutoDBField
构造器
AutoForm - class com.bstek.dorado.view.control.autoform.AutoForm.
自动表单
AutoForm(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.autoform.AutoForm
构造器
AutoSqlDataset - class com.bstek.dorado.data.db.AutoSqlDataset.
自动SQL记录集.
AutoSqlDataset() - Constructor for class com.bstek.dorado.data.db.AutoSqlDataset
构造器
activate() - Method in class com.bstek.dorado.module.ModuleSupport
add(Object, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
向对象列表中添加一个对象。
add(int, Object, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
向对象列表中指定的位置添加一个对象
add(Object, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
向对象列表中添加一个对象。
add(int, Object, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
向对象列表中指定的位置添加一个对象
addAction(ActionConfig) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
添加一个ActionConfig
addAndOrMatchRule(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定逻辑连接符的类型添加一个逻辑连接规则(AndOrMatchRule), 并返回新的逻辑连接规则对象.
addAttribute(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
为节点增加一个属性
addBaseMatchRule(String, String, String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定的物理字段名、比较操作符和匹配值添加一个基本匹配规则(BaseMatchRule), 并返回新的基本匹配规则对象.
addChild(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
增加一个子节点
addChild(XmlNode) - Method in interface com.bstek.dorado.utils.xml.XmlNode
增加一个子节点
addColumn(Column) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
添加一个列对象
addColumn(String) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
添加一个指定名称的列,并返回新创建的列对象.
addColumn(Column) - Method in class com.bstek.dorado.view.control.table.Table
添加一个列对象。
addColumn(String) - Method in class com.bstek.dorado.view.control.table.Table
添加一个指定名称的列。
addColumnByField(Field) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
根据指定的字段对象添加一个列对象,并返回新创建的列对象.
addColumnByField(Field) - Method in class com.bstek.dorado.view.control.table.Table
根据指定的字段对象添加一个列。
addColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.Table
添加一个指定名称的组合列。
addCommand(String) - Method in class com.bstek.dorado.view.control.command.CommandQueue
添加一个子命令对象
addDO(Object) - Method in class com.bstek.dorado.data.DOSet
向DOSet中添加一个DO.
addDO(Object, int) - Method in class com.bstek.dorado.data.DOSet
按照指定状态的向DOSet中添加一个DO.
addDatasetInfo(String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
添加一个需要提交的数据集并返回新增的DatasetInfo对象.
addDatasetInfo(String, String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
添加一个需要提交的数据集并返回新增的DatasetInfo对象.
addDatasetListener(DatasetListener) - Method in interface com.bstek.dorado.data.Dataset
增加一个DatasetEvent的事件监听器
addDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetAdapter
增加一个DatasetEvent的事件监听器
addDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetSupport
增加一个DatasetEvent的事件监听器
addDatasetListener(DatasetListener) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
增加一个DatasetEvent的事件监听器
addDummyField(String) - Method in interface com.bstek.dorado.data.Dataset
向Dataset中添加一个虚拟Field。
addDummyField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
向Dataset中添加一个虚拟Field。
addDummyField(String) - Method in class com.bstek.dorado.data.DatasetSupport
向Dataset中添加一个虚拟Field。
addDummyField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
向Dataset中添加一个虚拟Field。
addElement(String, String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
添加一个表单元素
addEventHandler(EventHandler) - Method in interface com.bstek.dorado.view.Component
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in interface com.bstek.dorado.view.EventSupported
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.ViewModelSupport
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.control.table.DataColumnGroup
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.control.table.EditableColumn
添加一个事件处理对象。
addEventHandler(EventHandler) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
addEventHandler
addException(ActionException) - Method in class com.bstek.dorado.action.mapping.ActionConfig
添加一个ActionException子对象
addException(ActionException) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
添加一个ActionException子对象
addException(ActionException) - Method in class com.bstek.dorado.action.mapping.Unit
添加一个ActionException子对象
addField(String) - Method in interface com.bstek.dorado.data.Dataset
向Dataset中添加一个普通Field。
addField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
向Dataset中添加一个普通Field。
addField(String) - Method in class com.bstek.dorado.data.DatasetSupport
向Dataset中添加一个普通Field。
addField(Field) - Method in class com.bstek.dorado.data.FieldSet
添加一个Field。
addField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
向Dataset中添加一个普通Field。
addForward(ActionForward) - Method in class com.bstek.dorado.action.mapping.ActionConfig
添加一个ActionForward子对象
addForward(ActionForward) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
添加一个ActionForward子对象
addForward(ActionForward) - Method in class com.bstek.dorado.action.mapping.Unit
添加一个ActionForward子对象
addGroup(OutlookBarGroup) - Method in class com.bstek.dorado.view.control.OutlookBar
addGroup
addGroup(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
添加一个组对象
addItem(String) - Method in class com.bstek.dorado.view.control.Menu
根据指定菜单项名称添加一个菜单项对象。
addItem(String, String) - Method in class com.bstek.dorado.view.control.Menu
根据指定名称、Label，添加一个菜单项对象。
addItem(String) - Method in class com.bstek.dorado.view.control.MenuItem
根据指定菜单项名称添加一个菜单项对象。
addItem(String, String) - Method in class com.bstek.dorado.view.control.MenuItem
根据指定名称、Label，添加一个菜单项对象。
addItem(String) - Method in interface com.bstek.dorado.view.control.MenuItemContainer
根据指定菜单项名称添加一个菜单项对象。
addItem(String, String) - Method in interface com.bstek.dorado.view.control.MenuItemContainer
根据指定名称、Label，添加一个菜单项对象。
addItem(String) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定值添加一个静态下拉框的下拉数据项对象。
addItem(String, String) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定值和标题属性添加一个静态下拉框的下拉数据项对象。
addJoin(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据要关联的表的别名添加一个关联(JoinTable)并返回新的关联对象.
addLookupField(String) - Method in interface com.bstek.dorado.data.Dataset
向Dataset中添加一个支持Lookup功能的Field。
addLookupField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

addLookupField(String) - Method in class com.bstek.dorado.data.DatasetSupport
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

addLookupField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
向Dataset中添加一个支持Lookup功能的Field。

Dataset中该字段的值来自于LookupField.lookupDataset属性所指定的Dataset。Dataset将 利用LookupField.keyFields属性所指定的字段匹配关系到lookupDataset中查找匹配的记录，并 读取其中的LookupField.lookupField所指定的字段的值作为本Field的值。

addMessage(String) - Method in interface com.bstek.dorado.action.Action
向当前的Action中追加一条消息。
addMessage(ServletRequest, String) - Static method in class com.bstek.dorado.common.MessageHelper
增加一条新的无键值消息
addMessage(ServletRequest, String, String) - Static method in class com.bstek.dorado.common.MessageHelper
在指定键值中增加一条新的消息
addMessage(DoradoContext, String) - Static method in class com.bstek.dorado.common.MessageHelper
增加一条新的无键值消息
addMessage(DoradoContext, String, String) - Static method in class com.bstek.dorado.common.MessageHelper
在指定键值中增加一条新的消息
addNode() - Method in class com.bstek.dorado.view.control.tree.TreeNode
Deprecated.
addNode(TreeNode) - Method in class com.bstek.dorado.view.control.tree.TreeNode
添加一个指定的节点,作为当前树节点的子节点。
addRecordListener(RecordListener) - Method in interface com.bstek.dorado.data.Dataset
增加一个RecordtListener的事件监听器
addRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetAdapter
增加一个RecordtListener的事件监听器
addRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetSupport
增加一个RecordtListener的事件监听器
addSortRule(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.
addSortRule(String, String, boolean) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定的物理字段名(originField)添加一个排序规则, 并返回新的排序规则对象.
addSqlMatchRule(String) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据指定SQL片断添加一个SQL匹配规则(SqlMatchRule), 并返回新的SQL匹配规则对象.
addTab(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
Deprecated.
addTab(String, String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
Deprecated.
addTab(TabElement) - Method in class com.bstek.dorado.view.control.tabset.TabSet
添加一个指定标签项
addTreeLevel(TreeLevel) - Method in class com.bstek.dorado.view.control.tree.DataTree
添加一个节点层
addTreeLevel(TreeLevel) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
添加一个子节点层
addValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewBaseField
为字段添加一个校验器。
addValidator(Validator) - Method in interface com.bstek.dorado.view.data.ViewField
为字段添加一个校验器。
addValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewLookupField
为字段添加一个校验器。
afterChange(ReadRecord, String) - Method in interface com.bstek.dorado.data.DataListener
在数据被修改之后被触发的事件.
afterChange(ReadRecord, String) - Method in class com.bstek.dorado.data.DatasetSupport
在数据被修改之后被触发的事件.
afterChange(Dataset, ReadRecord, String) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset中某条记录的数据被修改之后被触发的事件.
afterCreateFields(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset执行完自动创建所有字段之后触发的事件.即当调用Dataset.createFields()之后触发的事件.
afterDelete(Dataset, ReadRecord) - Method in interface com.bstek.dorado.data.RecordListener
从Dataset中删除一条记录之后触发的事件
afterInsert(Dataset, Record) - Method in interface com.bstek.dorado.data.RecordListener
向Dataset中插入一条记录之后触发的事件
afterLoadData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.loadData()之后触发的事件.
afterScroll(Dataset) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset的当前记录改变之后触发的事件
afterUpdateData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset执行完装载数据之后触发的事件.即当调用Dataset.update()之后触发的事件.
applyRoleConfig() - Method in interface com.bstek.dorado.view.Component
应用角色配置文件中的配置。
applyRoleConfig() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
应用角色配置文件中的配置。
assign(VariantSet) - Method in class com.bstek.dorado.utils.variant.VariantSet
将本集合中的所有数据全部指派到给定的另一个集合中.
attributiesToBean(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的Bean当中.
attributiesToDO(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的对象当中.
attributiesToMap() - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到Map当中.
attributiesToMap(Map) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的Map当中.
attributiesToVariantSet(VariantSet) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的属性(Attribute)设置到给定的VariantSet当中.
autoForm - Variable in class com.bstek.dorado.view.control.autoform.FormElement
表单
Overview Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _


B-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

B

BIGDECIMAL - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - BigDecimal型。
BIGDECIMAL_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - BigDecimal型。
BINARY - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - 二进制型。
BINARY_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - 二进制型。
BLANK - Static variable in class com.bstek.dorado.view.control.command.Frame
在一个空白的浏览器窗口中打开新页面.
BOOLEAN - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - boolean型。
BOOLEAN_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - boolean型。
BYTE - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - byte型。
BYTE_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - byte型。
BaseField - class com.bstek.dorado.data.BaseField.
最基本的Field对象。
BaseField(String) - Constructor for class com.bstek.dorado.data.BaseField
构造器
BaseMatchRule - class com.bstek.dorado.data.db.BaseMatchRule.
用于描述AutoSqlDataset的WHERE片断的基本匹配规则对象.
BaseMatchRule() - Constructor for class com.bstek.dorado.data.db.BaseMatchRule
构造器
BaseMatchRule(String, String, String) - Constructor for class com.bstek.dorado.data.db.BaseMatchRule
构造器
BaseRPCHandler - class com.bstek.dorado.view.rpc.BaseRPCHandler.
基本的远程方法调用的处理类
BaseRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.BaseRPCHandler
BaseRecord - class com.bstek.dorado.data.BaseRecord.
最基本的Record对象
BaseRecord() - Constructor for class com.bstek.dorado.data.BaseRecord
BindingTreeLevel - class com.bstek.dorado.view.control.tree.BindingTreeLevel.
支持数据绑定的树状列表节点层的基类
BindingTreeLevel(String) - Constructor for class com.bstek.dorado.view.control.tree.BindingTreeLevel
构造器
Button - class com.bstek.dorado.view.control.Button.
按钮对象
Button(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Button
构造器
beforeChange(ReadRecord, String, Variant) - Method in interface com.bstek.dorado.data.DataListener
当数据将要被修改之前被触发的事件.
beforeChange(ReadRecord, String, Variant) - Method in class com.bstek.dorado.data.DatasetSupport
当数据将要被修改之前被触发的事件.
beforeChange(Dataset, ReadRecord, String, Variant) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset中某条记录的数据将要被修改之前被触发的事件.
beforeCreateFields(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset将要自动创建所有字段之前触发的事件.即当调用Dataset.createFields()之前触发的事件.
beforeDelete(Dataset, ReadRecord) - Method in interface com.bstek.dorado.data.RecordListener
将要从Dataset中删除一条记录之前触发的事件
beforeInsert(Dataset, Record) - Method in interface com.bstek.dorado.data.RecordListener
将要向Dataset中插入一条记录之前触发的事件
beforeLoadData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset将要装载数据之前触发的事件.即当调用Dataset.loadData()之前触发的事件.
beforeScroll(Dataset) - Method in interface com.bstek.dorado.data.RecordListener
当Dataset的当前记录改变之前触发的事件
beforeUpdateData(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset将要装载数据之前触发的事件.即当调用Dataset.update()之前触发的事件.
beginTransaction() - Method in interface com.bstek.dorado.common.Transaction
启动一个新的事务.
build(Dataset, String) - Static method in class com.bstek.dorado.data.Index
根据给定的Dataset和字段创建并返回索引对象。
build(Dataset, String[]) - Static method in class com.bstek.dorado.data.Index
根据给定的Dataset和字段创建并返回索引对象。
buildDocument(String) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建XmlDocument对象
buildDocument(InputStream) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建XmlDocument对象
buildDocument(File) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
利用文件对象创建XmlDocument对象
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


C-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

C

CACHE_ATTRIBUTE_PREFIX - Static variable in class com.bstek.dorado.action.Controller
系统缓存Controller时使用的Attribute名的前缀
CHECKBOX - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - checkbox
COLUMN_TYPE_BASE - Static variable in class com.bstek.dorado.view.control.table.Table
COLUMN_TYPE_GROUP - Static variable in class com.bstek.dorado.view.control.table.Table
CONTENT_TYPE_DISPOSITION - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_HTML - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_DOWNLOAD - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_EXCEL - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_POWERPOINT - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_MS_WORD - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_OCTET_STREAM - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_PDF - Static variable in class com.bstek.dorado.biz.FileController
CONTENT_TYPE_XML - Static variable in class com.bstek.dorado.biz.FileController
COUNT - Static variable in class com.bstek.dorado.data.db.AggregateMode
统计记录总数
CURRENT - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 只提交Dataset的当前记录。
CURRENT_ACTION_ATTR_KEY - Static variable in class com.bstek.dorado.action.Constants
用于在Request中保存当前Action的Attribute键值
CachableDropDown - interface com.bstek.dorado.view.control.dropdown.CachableDropDown.
支持缓存的下拉框接口
Calendar - class com.bstek.dorado.view.control.Calendar.
日历
Calendar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Calendar
构造器
CaseInsensitiveVariantSet - class com.bstek.dorado.data.db.CaseInsensitiveVariantSet.
可支持多种类型的对象集合。
CaseInsensitiveVariantSet() - Constructor for class com.bstek.dorado.data.db.CaseInsensitiveVariantSet
CheckBox - class com.bstek.dorado.view.control.CheckBox.
复选框
CheckBox(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.CheckBox
构造器
CheckBoxFormElement - class com.bstek.dorado.view.control.autoform.CheckBoxFormElement.
复选框型的表单元素
CheckBoxFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
构造器
ClassHelper - class com.bstek.dorado.utils.ClassHelper.
用于对象反射的工具类
Column - class com.bstek.dorado.view.control.table.Column.
表格列的抽象类
Column(String) - Constructor for class com.bstek.dorado.view.control.table.Column
表格列对象
ColumnGroup - class com.bstek.dorado.view.control.table.ColumnGroup.
组合列的基类
ColumnGroup(String) - Constructor for class com.bstek.dorado.view.control.table.ColumnGroup
构造器
Command - class com.bstek.dorado.view.control.command.Command.
命令对象的基类
Command(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.Command
构造器
CommandQueue - class com.bstek.dorado.view.control.command.CommandQueue.
命令队列
CommandQueue(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.CommandQueue
构造器
CommonMatchRule - class com.bstek.dorado.data.db.CommonMatchRule.
用于描述AutoSqlDataset的WHERE片断的匹配规则抽象类.
CommonMatchRule() - Constructor for class com.bstek.dorado.data.db.CommonMatchRule
构造器
Component - interface com.bstek.dorado.view.Component.
组件接口
ConnectionHelper - class com.bstek.dorado.common.ds.ConnectionHelper.
用于根据Dorado中数据连接配置获得Connection的工具类.
ConnectionHelper() - Constructor for class com.bstek.dorado.common.ds.ConnectionHelper
Constants - class com.bstek.dorado.action.Constants.
DoradoAction模块中的一些常量
Control - interface com.bstek.dorado.view.control.Control.
控件的接口
ControlFormElement - class com.bstek.dorado.view.control.autoform.ControlFormElement.
ControlFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.ControlFormElement
Controller - class com.bstek.dorado.action.Controller.
在运行时的Controller对象，当用户激活一个Controller时系统会自动创建此对象。
Controller() - Constructor for class com.bstek.dorado.action.Controller
ControllerConfig - class com.bstek.dorado.action.mapping.ControllerConfig.
对应一个Controller的Mapping配置信息
ControllerConfig(String) - Constructor for class com.bstek.dorado.action.mapping.ControllerConfig
构造器
ControllerManager - class com.bstek.dorado.action.ControllerManager.
Controller管理器 用于完成创建、查找Controller等功能
ControllerNotFoundException - exception com.bstek.dorado.action.ControllerNotFoundException.
无法找到指定的Controller的异常。
ControllerNotFoundException() - Constructor for class com.bstek.dorado.action.ControllerNotFoundException
构造器
ControllerNotFoundException(String) - Constructor for class com.bstek.dorado.action.ControllerNotFoundException
构造器
CustomDataset - class com.bstek.dorado.data.custom.CustomDataset.
用户自定义Dataset.此Dataset包含有最基本的功能,用户可完全自定义其中的字段和数据的读取存储逻辑.
CustomDataset() - Constructor for class com.bstek.dorado.data.custom.CustomDataset
CustomDataset - class com.bstek.dorado.view.data.CustomDataset.
用户自定义视图数据集对象
CustomDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.CustomDataset
构造器
CustomDropDown - class com.bstek.dorado.view.control.dropdown.CustomDropDown.
自定义下拉框对象 自定义下拉框支持用户扩展自己的下拉框,实现dorado中默认提供的各种下拉框所不具有的功能.
CustomDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.CustomDropDown
构造器
CustomDropDownViewModel - class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel.
自定义下拉框的视图模型对象
CustomDropDownViewModel() - Constructor for class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
CustomFormElement - class com.bstek.dorado.view.control.autoform.CustomFormElement.
自定义的表单元素
CustomFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.CustomFormElement
构造器
CustomValidator - class com.bstek.dorado.view.data.validate.impl.CustomValidator.
用户自定义数据校验对象
CustomValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.CustomValidator
checkAccess(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
按系统默认的方式判断当前用户是否已登录
checkAccess(DoradoContext, Object) - Method in interface com.bstek.dorado.security.AccessChecker
校验用户登录状态的方法
checkAccess(DoradoContext) - Method in class com.bstek.dorado.view.ViewModelSupport
按系统默认的方式判断当前用户是否已登录
children() - Method in class com.bstek.dorado.view.control.tree.TreeNode
返回当前树节点的所有子节点的集合对象。
clear() - Method in interface com.bstek.dorado.data.Dataset
清空Dataset中所有的数据。
clear() - Method in class com.bstek.dorado.data.DatasetAdapter
清空Dataset中所有的数据。
clear() - Method in class com.bstek.dorado.data.DatasetSupport
清空Dataset中所有的数据。
clear() - Method in class com.bstek.dorado.data.RecordSet
清除记录集中的数据记录
clear() - Method in class com.bstek.dorado.utils.variant.VariantSet
清除本集合中所有的数据.
clear() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
清空Dataset中所有的数据。
clone() - Method in class com.bstek.dorado.data.BaseRecord
创建并返回本对象的一个副本。
clone() - Method in class com.bstek.dorado.data.Record
Creates and returns a copy of this object.
clone() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
Creates and returns a copy of this object.
clone() - Method in class com.bstek.dorado.utils.collection.ObjectList
clone() - Method in class com.bstek.dorado.utils.variant.Variant
Creates and returns a copy of this object.
clone() - Method in class com.bstek.dorado.utils.variant.VariantSet
Creates and returns a copy of this object.
cloneNode() - Method in interface com.bstek.dorado.utils.xml.XmlNode
克隆本节点
close() - Method in class com.bstek.dorado.data.db.DBStatement
关闭本DBStatement.
columns() - Method in class com.bstek.dorado.view.control.table.ColumnGroup
取得所有子列的集合对象。
columns() - Method in class com.bstek.dorado.view.control.table.Table
取得所有列的集合对象。
com.bstek.dorado.action - package com.bstek.dorado.action
实现Dorado的Controller部分的功能。
com.bstek.dorado.action.mapping - package com.bstek.dorado.action.mapping
Dorado Controller的Mapping配置信息的解析和管理对象
com.bstek.dorado.biz - package com.bstek.dorado.biz
为了增强Dorado的可用性而特别提供给用户的一些通用类
com.bstek.dorado.common - package com.bstek.dorado.common
Dorado系统中的一些通用类
com.bstek.dorado.common.ds - package com.bstek.dorado.common.ds
一些用于获取各类数据连接(java.sql.Connection)的工具类
com.bstek.dorado.common.fileloader - package com.bstek.dorado.common.fileloader
Dorado内部用于查找和读取各种配置文件的工具类
com.bstek.dorado.common.log - package com.bstek.dorado.common.log
Dorado系统日志的相关类
com.bstek.dorado.common.rtexpr - package com.bstek.dorado.common.rtexpr
用于支持运行时变量(例如: EL表达式)的工具类
com.bstek.dorado.common.rtexpr.impl - package com.bstek.dorado.common.rtexpr.impl
EL表达式相关的实现类
com.bstek.dorado.common.scope - package com.bstek.dorado.common.scope
用于支持对象的缓存和查找的工具类
com.bstek.dorado.data - package com.bstek.dorado.data
数据集的相关类
com.bstek.dorado.data.custom - package com.bstek.dorado.data.custom
实现可自定义数据集
com.bstek.dorado.data.db - package com.bstek.dorado.data.db
实现可直接访问数据库的数据集
com.bstek.dorado.i18n - package com.bstek.dorado.i18n
用于支持国际化
com.bstek.dorado.module - package com.bstek.dorado.module
数据模块的相关类
com.bstek.dorado.security - package com.bstek.dorado.security
包含用于支持应用系统访问安全性的类
com.bstek.dorado.utils - package com.bstek.dorado.utils
Dorado的基本工具类
com.bstek.dorado.utils.codec - package com.bstek.dorado.utils.codec
包含用于支持字符代码转换的工具类
com.bstek.dorado.utils.collection - package com.bstek.dorado.utils.collection
对象集合类
com.bstek.dorado.utils.http - package com.bstek.dorado.utils.http
一些与HTTP相关的工具类
com.bstek.dorado.utils.variant - package com.bstek.dorado.utils.variant
包含用于实现多态数据类型的类
com.bstek.dorado.utils.xml - package com.bstek.dorado.utils.xml
与XML相关的工具类
com.bstek.dorado.view - package com.bstek.dorado.view
包含视图模型、视图控件和数据校验类。
com.bstek.dorado.view.control - package com.bstek.dorado.view.control
各种控件类及实现
com.bstek.dorado.view.control.advance - package com.bstek.dorado.view.control.advance
高级控件相关类
com.bstek.dorado.view.control.autoform - package com.bstek.dorado.view.control.autoform
自动表单控件的相关对象
com.bstek.dorado.view.control.command - package com.bstek.dorado.view.control.command
命令控件的相关对象
com.bstek.dorado.view.control.dropdown - package com.bstek.dorado.view.control.dropdown
下拉框控件的相关对象
com.bstek.dorado.view.control.table - package com.bstek.dorado.view.control.table
表格控件的相关对象
com.bstek.dorado.view.control.tabset - package com.bstek.dorado.view.control.tabset
多页标签控件的相关对象
com.bstek.dorado.view.control.tree - package com.bstek.dorado.view.control.tree
树状列表控件的相关对象
com.bstek.dorado.view.data - package com.bstek.dorado.view.data
视图数据集的相关类
com.bstek.dorado.view.data.validate - package com.bstek.dorado.view.data.validate
数据校验器的相关类
com.bstek.dorado.view.data.validate.impl - package com.bstek.dorado.view.data.validate.impl
数据校验器的实现 com.bstek.dorado.view.rpc - package com.bstek.dorado.view.rpc
用于处理客户端远程过程调用的相关类
commit() - Method in interface com.bstek.dorado.common.Transaction
提交当前事务
compile(String) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
预编译一个字符串.如果该字符串中含有运行时变量则返回一个预编译对象,否则返回null
constructControl(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据类型和Id，创建一个控件对象。
constructDataset(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据类型和Id，创建一个视图数据集。
constructDataset(String, String) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
根据类型和Id，创建一个视图数据集。 此方法用于提供给非派生类进行重载。
controls - Variable in class com.bstek.dorado.view.ViewModelSupport
count() - Method in class com.bstek.dorado.utils.variant.VariantSet
返回集合中数值的总数量.
createColumn(String) - Method in class com.bstek.dorado.view.control.table.DataTable
创建一个指定名称的列对象。
createColumn(String) - Method in class com.bstek.dorado.view.control.table.StaticTable
创建一个指定名称的列对象。
createColumn(String) - Method in class com.bstek.dorado.view.control.table.Table
创建一个指定名称的列对象。
createColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.DataTable
创建一个指定名称的组合列
createColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.StaticTable
创建一个指定名称的组合列
createColumnGroup(String) - Method in class com.bstek.dorado.view.control.table.Table
创建一个指定名称的组合列
createControl(String, String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的控件类型和Id创建控件对象。
createControl(XmlNode) - Method in interface com.bstek.dorado.view.ViewModel
根据xml定义创建对应的控件对象。
createControl(XmlNode) - Method in class com.bstek.dorado.view.ViewModelSupport
根据xml定义创建对应的控件对象。
createControl(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的控件类型和Id创建控件对象。
createDataset(String, boolean, int, int, ParameterSet) - Method in class com.bstek.dorado.module.ModuleSupport
根据给定的一系列参数创建并返回一个Dataset。
createDataset(String, String) - Method in interface com.bstek.dorado.view.ViewModel
根据类型和Id，创建一个视图数据集。
createDataset(XmlNode) - Method in interface com.bstek.dorado.view.ViewModel
根据xml的定义创建一个视图数据集。
createDataset(XmlNode) - Method in class com.bstek.dorado.view.ViewModelSupport
根据xml的定义创建一个视图数据集。
createDataset(String, String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据类型和Id，创建一个视图数据集。
createFieldByNode(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.DatasetSupport
根据一个描述字段的XML节点自动创建字段对象.
createFieldByNode(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.DatasetWrapper
根据一个描述字段的XML节点自动创建字段对象.
createFieldByNode(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
根据一个描述字段的XML节点自动创建字段对象.
createFields() - Method in interface com.bstek.dorado.data.Dataset
根据已设定的条件自动创建字段。
createFields() - Method in class com.bstek.dorado.data.DatasetAdapter
createFields() - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件自动创建字段。
createFields(ResultSet) - Method in class com.bstek.dorado.data.db.DBDataset
根据给定的ResultSet对象自动创建字段对象.
createFieldsFromObjectClazz() - Method in interface com.bstek.dorado.data.Dataset
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.
createFieldsFromObjectClazz() - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.

此方法将自动为Dataset添加字段对象.

createFieldsFromObjectClazz() - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射将objectClazz中包含的属性映射成Dataset的字段.
createFormElement(FormGroup, String, String) - Method in class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl
createRootNode(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
创建根节点。
createTempForward(String) - Method in class com.bstek.dorado.action.mapping.Unit
创建一个临时的Forward对象。
createTreeLevel(XmlNode, DoradoContext) - Method in class com.bstek.dorado.view.control.tree.DataTree
根据XML节点创建节点层
createXmlBuilder() - Static method in class com.bstek.dorado.utils.xml.XmlFactory
创建并返回一个XML构造器对象
createXmlOutputter() - Static method in class com.bstek.dorado.utils.xml.XmlFactory
创建并返回一个XML输出器对象
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


D-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

D

DATE - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - Date型。
DATETIME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - DateTime型。
DATETIME_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - DateTime型。
DATE_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - Date型。
DBDataset - class com.bstek.dorado.data.db.DBDataset.
基于SQL的Dataset的抽象基类
DBDataset() - Constructor for class com.bstek.dorado.data.db.DBDataset
构造器
DBField - class com.bstek.dorado.data.db.DBField.
DBDataset记录集的字段对象
DBField(String) - Constructor for class com.bstek.dorado.data.db.DBField
构造器
DBStatement - class com.bstek.dorado.data.db.DBStatement.
用于方便使用SQL命令的工具类.
DBStatement() - Constructor for class com.bstek.dorado.data.db.DBStatement
构造器
DBStatement(String) - Constructor for class com.bstek.dorado.data.db.DBStatement
构造器
DBStatement(String, String) - Constructor for class com.bstek.dorado.data.db.DBStatement
构造器
DEFAULT_LOCALE_ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.i18n.ResourceManager
DEFAULT_LOCALE_ATTRIBUTE_KEY
DEFAULT_LOGIN_SESSION_KEY - Static variable in interface com.bstek.dorado.security.AccessChecker
DEFAULT_ROLE_ATTRIBUTE - Static variable in interface com.bstek.dorado.view.ViewModel
默认角色属性
DEFAULT_SKIN_ATTRIBUTE - Static variable in interface com.bstek.dorado.view.ViewModel
默认皮肤属性
DELETE - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - DELETE
DODataset - class com.bstek.dorado.view.data.DODataset.
可与DO(Data Object)进行数据交换的Dataset 注意: 此处的DO也常被称作VO(Value Object)或DTO(Data Transfer Object)
DODataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.DODataset
构造器
DORecord - class com.bstek.dorado.data.DORecord.
DORecord() - Constructor for class com.bstek.dorado.data.DORecord
DORecord(Object) - Constructor for class com.bstek.dorado.data.DORecord
DOSet - class com.bstek.dorado.data.DOSet.
DO(Data Object)的集合.
DOSet() - Constructor for class com.bstek.dorado.data.DOSet
构造器
DOToRecord(Object, Record) - Static method in class com.bstek.dorado.data.DOUtils
利用反射从o参数指定的对象中读取数据并设置到给定的record中.
DOToRecord(Object, Dataset) - Static method in class com.bstek.dorado.data.DOUtils
利用反射从o参数指定的对象中读取数据, 并追加到Dataset中.
DOToVariantSet(Object, VariantSet) - Static method in class com.bstek.dorado.data.DOUtils
利用反射从o参数指定的对象中读取数据并设置到给定的变量集合中.
DOUBLE - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - double型。
DOUBLE_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - double型。
DOUtils - class com.bstek.dorado.data.DOUtils.
用于在Dataset和DO(Data Object)之间转换数据的工具类
DRAGMODE_MOUSEMOVE - Static variable in class com.bstek.dorado.view.control.ScrollBar
拖动方式 - 鼠标移动时即滚动
DRAGMODE_MOUSEUP - Static variable in class com.bstek.dorado.view.control.ScrollBar
拖动方式 - 鼠标抬起时才滚动
DataColumn - class com.bstek.dorado.view.control.table.DataColumn.
数据列的抽象类
DataColumn(String) - Constructor for class com.bstek.dorado.view.control.table.DataColumn
构造器
DataColumnGroup - class com.bstek.dorado.view.control.table.DataColumnGroup.
数据表格中的组合列的基类
DataColumnGroup(String) - Constructor for class com.bstek.dorado.view.control.table.DataColumnGroup
DataControl - class com.bstek.dorado.view.control.DataControl.
数据控件对象接口
DataControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.DataControl
构造器
DataLabel - class com.bstek.dorado.view.control.DataLabel.
数据标签对象 数据标签.一般用于显示数据集的字段内容,不用于编辑.
DataLabel(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.DataLabel
构造器
DataListener - interface com.bstek.dorado.data.DataListener.
针对Dataset中的数据的事件监听器
DataPilot - class com.bstek.dorado.view.control.DataPilot.
数据导航控件对象 用于控制数据集的移动,数据下载,新增,修改维护操作等.
DataPilot(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.DataPilot
构造器
DataTable - class com.bstek.dorado.view.control.table.DataTable.
数据表格 数据表格是一种可以编辑的多功能表格
系统可以用该对象实现对数据库数据的插入、删除以及修改功能， 或则通过调用Module提供的相关服务实现Modulec层的对象新增修改删除功能， 在一种简单应用下我们可能只会用该对象进行数据展现，如展现一个查询结果集。
DataTable(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.table.DataTable
构造器
DataTree - class com.bstek.dorado.view.control.tree.DataTree.
树状列表对象
DataTree(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.tree.DataTree
构造器
DataType - class com.bstek.dorado.utils.variant.DataType.
数据类型
Dataset - interface com.bstek.dorado.data.Dataset.
Dorado记录集的接口。
DatasetAdapter - class com.bstek.dorado.data.DatasetAdapter.
Dataset适配器
DatasetAdapter() - Constructor for class com.bstek.dorado.data.DatasetAdapter
构造器
DatasetAdapter(Dataset) - Constructor for class com.bstek.dorado.data.DatasetAdapter
构造器
DatasetDropDown - class com.bstek.dorado.view.control.dropdown.DatasetDropDown.
Dataset类型的下拉框 数据集类型的下拉列表可以自动根据绑定数据集中的数据显示下拉列表, 同时利用mapValue属性它也可以帮助我们完成将代码数值翻译为显示内容的功能.
DatasetDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DatasetDropDown
构造器
DatasetInfo - class com.bstek.dorado.view.control.command.DatasetInfo.
用于描述提交命令(UpdateCommand)要提交的Dataset数据集的对象.
DatasetInfo() - Constructor for class com.bstek.dorado.view.control.command.DatasetInfo
DatasetListener - interface com.bstek.dorado.data.DatasetListener.
Dataset事件监听器的接口
DatasetReference - class com.bstek.dorado.view.data.DatasetReference.
数据集引用对象
DatasetReference(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.DatasetReference
构造器
DatasetSupport - class com.bstek.dorado.data.DatasetSupport.
数据集的抽象基类。
DatasetSupport() - Constructor for class com.bstek.dorado.data.DatasetSupport
构造器
DatasetWrapper - class com.bstek.dorado.view.data.DatasetWrapper.
数据集包装器.
DatasetWrapper(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.DatasetWrapper
构造器
DateDropDown - class com.bstek.dorado.view.control.dropdown.DateDropDown.
日期对象下拉框
DateDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DateDropDown
构造器
DefaultModule - class com.bstek.dorado.module.DefaultModule.
默认的Module抽象实现类
DefaultModule() - Constructor for class com.bstek.dorado.module.DefaultModule
DefaultOutlookBarGroup - class com.bstek.dorado.view.control.DefaultOutlookBarGroup.
DefaultOutlookBarGroup(String) - Constructor for class com.bstek.dorado.view.control.DefaultOutlookBarGroup
DefaultOutlookBarGroup
DefaultTreeNode - class com.bstek.dorado.view.control.tree.DefaultTreeNode.
默认的树节点对象
DefaultTreeNode() - Constructor for class com.bstek.dorado.view.control.tree.DefaultTreeNode
构造器
DefaultTreeNode(String) - Constructor for class com.bstek.dorado.view.control.tree.DefaultTreeNode
构造器
DefaultViewModel - class com.bstek.dorado.view.DefaultViewModel.
默认的ViewModel抽象实现类
DefaultViewModel() - Constructor for class com.bstek.dorado.view.DefaultViewModel
DoradoContext - class com.bstek.dorado.common.DoradoContext.
Dorado上下文对象.
DoradoContext() - Constructor for class com.bstek.dorado.common.DoradoContext
DoradoException - exception com.bstek.dorado.utils.DoradoException.
所有Dorado中异常的基类
DoradoException() - Constructor for class com.bstek.dorado.utils.DoradoException
DoradoException
DoradoException(String) - Constructor for class com.bstek.dorado.utils.DoradoException
DoradoException
DoradoException(Throwable) - Constructor for class com.bstek.dorado.utils.DoradoException
DoradoException
DoradoRuntimeException - exception com.bstek.dorado.utils.DoradoRuntimeException.
所有Dorado中Runtime异常的基类
DoradoRuntimeException() - Constructor for class com.bstek.dorado.utils.DoradoRuntimeException
DoradoRuntimeException
DoradoRuntimeException(String) - Constructor for class com.bstek.dorado.utils.DoradoRuntimeException
DoradoRuntimeException
DoradoRuntimeException(Throwable) - Constructor for class com.bstek.dorado.utils.DoradoRuntimeException
DoradoRuntimeException
DropDown - class com.bstek.dorado.view.control.dropdown.DropDown.
下拉框的基类
DropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DropDown
构造器
DropDownItem - class com.bstek.dorado.view.control.dropdown.DropDownItem.
下拉框选择项对象
DropDownItem() - Constructor for class com.bstek.dorado.view.control.dropdown.DropDownItem
构造器
DropDownViewModel - class com.bstek.dorado.view.control.dropdown.DropDownViewModel.
下拉框的视图模型对象
DropDownViewModel() - Constructor for class com.bstek.dorado.view.control.dropdown.DropDownViewModel
DummyField - class com.bstek.dorado.data.DummyField.
虚拟字段
DummyField(String) - Constructor for class com.bstek.dorado.data.DummyField
构造器
DuplicateKeyException - exception com.bstek.dorado.utils.collection.DuplicateKeyException.
键值重复异常
DuplicateKeyException(Object) - Constructor for class com.bstek.dorado.utils.collection.DuplicateKeyException
DuplicateObjectKeyException
DynamicDropDown - class com.bstek.dorado.view.control.dropdown.DynamicDropDown.
动态数据下拉框 动态数据下拉框.动态数据下拉框通过直接引用一个Server端的数据集构造下拉框中的数据.
DynamicDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DynamicDropDown
构造器
DynamicDropDownDataset - class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset.
动态下拉框数据集对象
DynamicDropDownDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.DynamicDropDownDataset
DynamicDropDownViewModel - class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel.
动态下拉框的视图模型对象
DynamicDropDownViewModel() - Constructor for class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
dataSource - Variable in class com.bstek.dorado.data.db.DBDataset
datasets() - Method in class com.bstek.dorado.module.ModuleSupport
datasets - Variable in class com.bstek.dorado.view.ViewModelSupport
debug(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_DEBUG 的字符串记录到日志文件里。
decode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.Encrypt
解密字符串
decode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.EncryptCode
解密字符串
decode(String) - Static method in class com.bstek.dorado.utils.codec.SafeCode
对安全字符串进行解码，返回原始字符串。
deleteRecord() - Method in interface com.bstek.dorado.data.Dataset
删除当前记录。
deleteRecord(Record) - Method in interface com.bstek.dorado.data.Dataset
删除指定的记录。
deleteRecord() - Method in class com.bstek.dorado.data.DatasetAdapter
删除当前记录。
deleteRecord(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
删除指定的记录。
deleteRecord() - Method in class com.bstek.dorado.data.DatasetSupport
删除当前记录。
deleteRecord(Record) - Method in class com.bstek.dorado.data.DatasetSupport
删除指定的记录。
deleteRecord() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
删除当前记录。
deleteRecord(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
删除指定的记录。
detailKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的字段数组.
detailKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
以数组的形式detailKeyParameters的值
detailKeyParameters() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
以数组的形式detailKeyParameters的值
detailKeyParameters() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的参数数组.
dialect - Variable in class com.bstek.dorado.data.db.DBDataset
dispose() - Method in interface com.bstek.dorado.common.Transaction
废除当前的事务对象并释放所有资源.
disposeTransaction() - Static method in class com.bstek.dorado.common.TransactionManager
disposeTransaction
doAction(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
执行默认的Action。
doActivate() - Method in class com.bstek.dorado.module.ModuleSupport
Module的锐化处理。
doDispatch(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
系统内部用于完成分派Action处理的方法。
doDownload(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
文件下载
doFromDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
doFromDO(Object) - Method in class com.bstek.dorado.view.data.DODataset
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
doFromDO(Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
doFromSingleDO(Object, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
doFromSingleDO(Object, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
doGet(String) - Method in class com.bstek.dorado.data.BaseRecord
返回记录中某字段的值。此方法须在派生类中实现。
doGet(String) - Method in class com.bstek.dorado.data.DORecord
返回记录中某字段的值。此方法须在派生类中实现。
doGet(String) - Method in class com.bstek.dorado.data.ReadRecord
返回记录中某字段的值。
doGetCountSql() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
获得用于统计总记录数的SQL命令.
doGetCountSql() - Method in class com.bstek.dorado.data.db.DBDataset
获得用于统计总记录数的SQL命令.
doGetCountSql() - Method in class com.bstek.dorado.data.db.SqlDataset
获得用于统计总记录数的SQL命令.
doGetDialect() - Method in class com.bstek.dorado.data.db.DBDataset
获得此Dataset内部使用的数据库方言的实现类.
doGetSourceDatasetForLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.DatasetReference
doGetSourceDatasetForLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.DatasetWrapper
doGetSourceDatasetForUpdate() - Method in class com.bstek.dorado.view.data.DatasetReference
doGetSourceDatasetForUpdate() - Method in class com.bstek.dorado.view.data.DatasetWrapper
doGetSql(boolean) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
获得SQL命令.
doGetSql(boolean) - Method in class com.bstek.dorado.data.db.DBDataset
获得SQL命令.
doGetSql(boolean) - Method in class com.bstek.dorado.data.db.SqlDataset
获得SQL命令.
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
doGetViewModel(ViewModelCacheInfo) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
doLoad(boolean, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.data.custom.CustomDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.data.db.DBDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.CustomDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.DODataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.FormDataset
根据已设定的条件读取外部数据.
doLoad(boolean, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据已设定的条件读取外部数据.
doLoadData() - Method in class com.bstek.dorado.view.ViewModelSupport
对视图模型中所有的Dataset执行装载数据的操作。
doOutput(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
直接把文件显示到浏览器中
doPassivate() - Method in class com.bstek.dorado.module.ModuleSupport
Module的钝化处理。
doSet(String, Object) - Method in class com.bstek.dorado.data.BaseRecord
设置当前记录中某字段的值.此方法须在派生类中实现.
doSet(String, Object) - Method in class com.bstek.dorado.data.DORecord
设置当前记录中某字段的值.此方法须在派生类中实现.
doSet(String, Object) - Method in class com.bstek.dorado.data.Record
设置当前记录中某字段的值.此方法须在派生类中实现.
doSetFile(String) - Method in class com.bstek.dorado.common.fileloader.FileLoader
设置要打开的文件。
doToDO(Collection, String) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
doUpdate() - Method in class com.bstek.dorado.data.DatasetSupport
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.data.custom.CustomDataset
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.data.db.DBDataset
把用户对Dataset中数据的操作更新到外部数据中.
doUpdate() - Method in class com.bstek.dorado.view.data.DODataset
doUpdate() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
把用户对Dataset中数据的操作更新到外部数据中.
doUpdateData(ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
当系统试图对ViewModel中的Dataset进行持久化时触发的方法。
doUpload(Action, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
执行文件上传
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


E-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

E

EQUALS - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
等于
EditableColumn - class com.bstek.dorado.view.control.table.EditableColumn.
数据表格中的可编辑列
EditableColumn(String) - Constructor for class com.bstek.dorado.view.control.table.EditableColumn
构造器
Editor - class com.bstek.dorado.view.control.Editor.
编辑器的基类
Editor(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Editor
构造器
Element - interface com.bstek.dorado.view.Element.
元素接口
Encrypt - class com.bstek.dorado.utils.codec.Encrypt.
对字符串进行加密 1.
EncryptCode - class com.bstek.dorado.utils.codec.EncryptCode.
本算法只用于加密由0-9和A-Z组成的字符串，以下的提到的字符指由0-9和A-Z组成的字符；假设字符串的长度为n) 1.
EncryptCode() - Constructor for class com.bstek.dorado.utils.codec.EncryptCode
EscapeUtils - class com.bstek.dorado.utils.codec.EscapeUtils.
用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。
Event - class com.bstek.dorado.view.Event.
客户端事件的定义描述对象
Event() - Constructor for class com.bstek.dorado.view.Event
构造器
EventConfig - class com.bstek.dorado.view.EventConfig.
客户端事件定义的配置管理器
EventHandler - class com.bstek.dorado.view.EventHandler.
事件处理类
EventHandler(String) - Constructor for class com.bstek.dorado.view.EventHandler
构造器
EventHandler(String, String) - Constructor for class com.bstek.dorado.view.EventHandler
构造器
EventSupported - interface com.bstek.dorado.view.EventSupported.
可支持客户端事件的控件的接口
ExprHelper - class com.bstek.dorado.common.rtexpr.ExprHelper.
用于方便使用运行时变量功能的工具类
ExpressionUtils - class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils.
EL表达式工具类,该类所具有的各个方法亦即Util表达式所支持的各项功能.
encode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.Encrypt
加密字符串
encode(String, int, int) - Static method in class com.bstek.dorado.utils.codec.EncryptCode
加密字符串
encode(String) - Static method in class com.bstek.dorado.utils.codec.SafeCode
对原始字符串进行编码，返回安全字符串。
endCalling(String) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
完成远程调用方法.
equals(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
equals(Object) - Method in class com.bstek.dorado.utils.variant.Variant
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class com.bstek.dorado.utils.variant.VariantSet
Indicates whether some other object is "equal to" this one.
error(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
error(Object, Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_ERROR 的错误信息记录到日志文件里。
escape(String) - Static method in class com.bstek.dorado.utils.codec.EscapeUtils
对原始字符串进行编码，返回安全字符串。
eventHandlers() - Method in interface com.bstek.dorado.view.Component
取得所有事件处理对象的集合对象。
eventHandlers() - Method in interface com.bstek.dorado.view.EventSupported
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.ViewModelSupport
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.control.table.DataColumnGroup
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.control.table.EditableColumn
取得所有事件处理对象的集合对象。
eventHandlers() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
eventHandlers
execute() - Method in class com.bstek.dorado.data.db.DBStatement
执行SQL命令.
execute() - Method in class com.bstek.dorado.utils.SynchroTimer
定时器在激活时所触发的动作
execute() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
执行默认的远程调用方法.
execute(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
执行当前的远程过程调用的处理器
exists(String) - Method in class com.bstek.dorado.data.db.CaseInsensitiveVariantSet
Deprecated.
exists(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
判断给定键值下是否存有数值.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


F-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

F

FILTER_ALL - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有记录
FILTER_CHANGED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有发生变化的记录(包含新添加的、被修改过的和已删除的)
FILTER_DEFAULT - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 默认的记录 在此种方式下只有标记为"已删除"的记录是不可见的
FILTER_DELETED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有已删除的记录
FILTER_MODIFIED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有被修改过的记录
FILTER_NEW - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有被新添加的记录
FILTER_NOT_CHANGED - Static variable in interface com.bstek.dorado.data.Dataset
过滤方式 - 所有未发生变化的记录
FLOAT - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - float型。
FLOAT_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - float型。
FLOW - Static variable in class com.bstek.dorado.view.control.RadioGroup
FLOW
FLUSH - Static variable in class com.bstek.dorado.view.control.command.QueryCommand
通过数据集的flushData实现查询,此种查询方式下页面不会刷新
FORM_GET - Static variable in class com.bstek.dorado.view.control.command.QueryCommand
通过一个内部的FORM表单模式get方式的提交来实现查询,此种查询方式页面下将被刷新
FORM_POST - Static variable in class com.bstek.dorado.view.control.command.QueryCommand
通过一个内部的FORM表单模式post方式的提交来实现查询,此种查询方式页面下将被刷新
Field - interface com.bstek.dorado.data.Field.
字段
FieldLabel - class com.bstek.dorado.view.control.FieldLabel.
字段标签对象。
FieldLabel(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.FieldLabel
构造器
FieldNotExistException - exception com.bstek.dorado.data.FieldNotExistException.
无法找到指定的Field对象的异常。
FieldNotExistException(String) - Constructor for class com.bstek.dorado.data.FieldNotExistException
构造器
FieldSet - class com.bstek.dorado.data.FieldSet.
字段集合对象
FieldSet() - Constructor for class com.bstek.dorado.data.FieldSet
构造器
FileController - class com.bstek.dorado.biz.FileController.
用于协助用户完成文件上传和下载的Controller.
FileController() - Constructor for class com.bstek.dorado.biz.FileController
FileLoader - class com.bstek.dorado.common.fileloader.FileLoader.
文件加载器的抽象类
FileLoader(String) - Constructor for class com.bstek.dorado.common.fileloader.FileLoader
构造器
FormDataset - class com.bstek.dorado.view.data.FormDataset.
表单型数据集 表单型数据集可以自动从Request的parameter中收集数据并转换到记录集中, 利用表单型数据集我们可以很方便的在网页中制作具备数据回填功能的Form表单.
FormDataset(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.FormDataset
构造器
FormElement - class com.bstek.dorado.view.control.autoform.FormElement.
表单元素抽象类
FormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.FormElement
构造器
FormElementFactoryImpl - class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl.
表单元素的工厂类接口
FormElementFactoryImpl() - Constructor for class com.bstek.dorado.view.control.autoform.FormElementFactoryImpl
构造器
FormElementRenderer - class com.bstek.dorado.view.control.autoform.FormElementRenderer.
FormElementRenderer(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.FormElementRenderer
FormGroup - class com.bstek.dorado.view.control.autoform.FormGroup.
自动表单中的组
FormGroup(AutoForm, String) - Constructor for class com.bstek.dorado.view.control.autoform.FormGroup
构造器
FormGroupGround - class com.bstek.dorado.view.control.autoform.FormGroupGround.
自动表单的辅助类
FormGroupGround(int) - Constructor for class com.bstek.dorado.view.control.autoform.FormGroupGround
构造器
Frame - class com.bstek.dorado.view.control.command.Frame.
描述请求命令的目标框架的对象
Frame() - Constructor for class com.bstek.dorado.view.control.command.Frame
构造器
FrameTab - class com.bstek.dorado.view.control.tabset.FrameTab.
多页标签中的子框架标签项 子框架标签项在多页标签中用于显示指定URL资源的页面.
FrameTab(String) - Constructor for class com.bstek.dorado.view.control.tabset.FrameTab
构造器
FrameTab(String, String) - Constructor for class com.bstek.dorado.view.control.tabset.FrameTab
构造器
fatal(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
fatal(Object, Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_FATAL 的错误信息记录到日志文件里。
field - Variable in class com.bstek.dorado.view.control.autoform.FormElement
字段
fieldSet() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset的Field集合对象
fieldSet() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset的Field集合对象
fieldSet() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset的Field集合对象
fieldSet() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset的Field集合对象
fillPoint(int, int) - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
fillPoint
filter() - Method in class com.bstek.dorado.data.RecordIterator
Deprecated.
finalize() - Method in class com.bstek.dorado.data.DatasetSupport
finalize() - Method in class com.bstek.dorado.module.ModuleSupport
finalize() - Method in class com.bstek.dorado.view.ViewModelSupport
find(String, Object) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回匹配的记录。
find(String[], Object[]) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回匹配的记录。
find(String, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String, Object) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(Object) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一个字段值查找一组记录。
find(Object[]) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一字段值查找一组记录。
find(String, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
find(String[], Object[]) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回匹配的记录。如果无法找到匹配记录则返回null。
findAll(String, Object) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in interface com.bstek.dorado.data.Dataset
根据指定的条件查找并返回所有匹配的记录。
findAll(String, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findAll(String, Object) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的条件查找并返回所有匹配的记录。
findAll(Object) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一个字段值查找记录。
findAll(Object[]) - Method in class com.bstek.dorado.data.Index
利用索引根据给定的一组字段值查找记录。
findAll(String, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findAll(String[], Object[]) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的条件查找并返回所有匹配的记录。
findController(String) - Method in class com.bstek.dorado.action.mapping.Mapping
根据给定的别名查找一个Controller对象
findDefaultForward() - Method in interface com.bstek.dorado.action.Action
查找一个默认的ActionForward对象。
findDefaultForward() - Method in class com.bstek.dorado.action.mapping.ActionConfig
查找一个默认的ActionForward对象。
findException(Throwable) - Method in interface com.bstek.dorado.action.Action
根据一个给定的Throwable对象查找一个可用的ActionException对象。
findException(Throwable) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据一个给定的Throwable对象查找一个可用的ActionException对象。
findException(Throwable) - Method in class com.bstek.dorado.action.mapping.Mapping
根据给定的异常查找一个全局的ActionException对象，即在global中定义的ActionException。
findForward(String) - Method in interface com.bstek.dorado.action.Action
根据别名查找一个可用的ActionForward对象。
findForward(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据别名查找一个可用的ActionForward对象。
findForward(String) - Method in class com.bstek.dorado.action.mapping.Mapping
根据给定的别名查找一个全局的ActionForward对象，即在global中定义的ActionForward。
findForward(String) - Method in class com.bstek.dorado.action.mapping.Unit
根据别名在配置单元中查找一个ActionForward对象
findItem(String) - Method in class com.bstek.dorado.view.control.Menu
根据子菜单项的路径返回一个菜单项.
findNext(RecordWrapper) - Method in class com.bstek.dorado.data.DatasetSupport
findNext
findObject(DoradoContext, String, String) - Static method in class com.bstek.dorado.common.scope.ScopeHelper
根据属性名从指定的资源中取得一个已被存入的对象
findPrev(RecordWrapper) - Method in class com.bstek.dorado.data.DatasetSupport
findPrev
findWrapper(Record) - Method in class com.bstek.dorado.data.RecordSet
寻找并返回指定记录的包装器.
fireAfterChange(ReadRecord, String) - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterChange事件
fireAfterChange(ReadRecord, String) - Method in class com.bstek.dorado.data.Record
触发AfterChange事件,该事件一般由Dataset进行监听.
fireAfterCreateFields() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterCreateFields事件
fireAfterDelete(ReadRecord) - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterDelete事件
fireAfterInsert(Record) - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterInsert事件
fireAfterLoadData() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterLoadData事件
fireAfterScroll() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterScroll事件
fireAfterScroll() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
触发AfterScroll事件
fireAfterUpdateData() - Method in class com.bstek.dorado.data.DatasetSupport
触发AfterUpdateData事件
fireBeforeChange(ReadRecord, String, Variant) - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeChange事件
fireBeforeChange(ReadRecord, String, Object) - Method in class com.bstek.dorado.data.Record
触发BeforeChange事件,该事件一般由Dataset进行监听.
fireBeforeCreateFields() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeCreateFields事件
fireBeforeDelete(ReadRecord) - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeDelete事件
fireBeforeInsert(Record) - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeInsert事件
fireBeforeLoadData() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeLoadData事件
fireBeforeScroll() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeScroll事件
fireBeforeUpdateData() - Method in class com.bstek.dorado.data.DatasetSupport
触发BeforeUpdateData事件
fireOnInit() - Method in class com.bstek.dorado.data.DatasetSupport
触发OnInit事件
forceAdd(Object, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。
forceAdd(Object, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
强行向对象列表中添加一个对象，如果发现重复的键值则覆盖该对象。
format(String, Object[]) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
format(String, Object, Object, Object, Object, Object, Object) - Static method in class com.bstek.dorado.utils.Printf
format
fromDO(Object) - Method in interface com.bstek.dorado.data.Dataset
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.
fromDO(Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromDO(Object) - Method in class com.bstek.dorado.data.Record
从给定的DataObject对象中转换数据.
fromDO(Object) - Method in class com.bstek.dorado.view.data.DODataset
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromDO(Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从data参数指定的对象中读取数据, 并追加到Dataset中.

此处的data可以是单个的Bean、java.util.Map的派生类、java.util.Collection的派生类 或对象数组.此方法会自行根据data的类型决定处理方式.

fromSingleDO(Object) - Method in interface com.bstek.dorado.data.Dataset
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.
fromSingleDO(Object, boolean) - Method in interface com.bstek.dorado.data.Dataset
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.
fromSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object, boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从单个的数据对象中读取数据, 并利用这些数据修改Dataset中的当前记录.

此处的data可以是单个的Bean或java.util.Map的派生类.

fromSingleDO(Object, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动利用反射从单个的数据对象中读取数据, 并追加一条记录到Dataset中.

此处的data可以是单个的Bean或java.util.Map的派生类.

Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


G-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

G

GREATER - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
大于
GREATEREQUAL - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
大于等于
GROUPBOX - Static variable in class com.bstek.dorado.view.control.autoform.AutoForm
组的类型 - 组合框
GlobalUnit - class com.bstek.dorado.action.mapping.GlobalUnit.
全局的Mapping配置单元，该单元对应的配置文件应是global.map.xml。
GlobalUnit(String) - Constructor for class com.bstek.dorado.action.mapping.GlobalUnit
构造器
GroupBox - class com.bstek.dorado.view.control.GroupBox.
组合框
GroupBox(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.GroupBox
构造器
get(String) - Method in class com.bstek.dorado.data.ReadRecord
直接返回记录中某字段的对应值对象
get(Object) - Method in class com.bstek.dorado.i18n.ResourceManagerContextMap
get(Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回对象列表中的一个对象。
get(int) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回对象列表中的一个对象。
get(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回对象列表中的一个对象。
get(int) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回对象列表中的一个对象。
getAction(int) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
根据索引号得到一个ActionConfig
getAction(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
根据给定的别名查找一个ActionConfig
getAction() - Method in class com.bstek.dorado.view.control.command.RPCCommand
取得接收此命令的Server端服务的url。
getActionCount() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
返回ActionConfig的个数
getAggregate() - Method in class com.bstek.dorado.data.db.AutoDBField
返回AutoSqlDataset中Field的合计模式.
getAlign() - Method in class com.bstek.dorado.view.control.table.DataColumn
取得列的水平对齐方式。
getAttribute(String) - Method in class com.bstek.dorado.common.DoradoContext
从上下文的Request作用域中获取一个属性的值.
getAttribute(int, String) - Method in class com.bstek.dorado.common.DoradoContext
根据指定的作用域从上下文中获取一个属性的值.
getAttribute(int, String) - Method in class com.bstek.dorado.common.HttpDoradoContext
根据指定的作用域从上下文中获取一个属性的值.
getAttribute(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回一个属性的值
getAttributeBoolean(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回一个属性的值
getAttributeBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回一个属性的值.
getAttributeDouble(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回一个属性的值
getAttributeDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回一个属性的值.
getAttributeFloat(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回一个属性的值
getAttributeFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回一个属性的值.
getAttributeInt(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回一个属性的值
getAttributeInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回一个属性的值.
getAttributeLong(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回一个属性的值
getAttributeLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回一个属性的值.
getAttributeNames() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回所有属性的属性属性名
getAttributeString(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按String类型返回一个属性的值.此方法总是返回一个有效地String,不会返回null.
getAttributeString(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回一个属性的值.
getAutoForm() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得该组所属的自动表单对象。
getBaseHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
获得一个基本远程过程调用的处理器
getBigChange() - Method in class com.bstek.dorado.view.control.ScrollBar
取得当用户点击滚动条的空白区域时引起的滚动量.
getBigDecimal(int) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(int) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.data.ReadRecord
按BigDecimal类型返回记录中某字段的值。
getBigDecimal() - Method in class com.bstek.dorado.utils.variant.Variant
按BigDecimal类型读取数据
getBigDecimal(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按BigDecimel类型读取数据
getBigDecimal(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按BigDecimal类型读取数据
getBigDecimal(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBigDecimal(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型返回当前记录中某字段的值。
getBoolean(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Boolean型的配置信息
getBoolean(String, boolean) - Static method in class com.bstek.dorado.common.Setting
读取一个Boolean型的配置信息,如何该配置不存在则返回缺省值.
getBoolean(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Boolean型的配置信息
getBoolean(String, boolean) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Boolean型的配置信息
getBoolean(int) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型返回当前记录中某字段的值。
getBoolean(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBoolean(int) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.data.ReadRecord
按boolean类型返回记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按boolean方式读取一个参数
getBoolean() - Method in class com.bstek.dorado.utils.variant.Variant
按boolean类型读取数据
getBoolean(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按boolean类型读取数据
getBoolean(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按boolean类型读取数据
getBoolean(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBoolean(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型返回当前记录中某字段的值。
getBundle(String, Locale) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源集合.
getBundle(DoradoContext, String) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源集合.
getButtonAppend() - Method in class com.bstek.dorado.view.control.DataPilot
取得“追加一条记录”(AppendRecord)按钮的显示状态。
getButtonCancel() - Method in class com.bstek.dorado.view.control.DataPilot
取得“撤销对当前记录修改”(CancelRecord)按钮的显示状态。
getButtonDelete() - Method in class com.bstek.dorado.view.control.DataPilot
取得“删除一条记录”(DeleteRecord)按钮的显示状态。
getButtonInsert() - Method in class com.bstek.dorado.view.control.DataPilot
返回“插入一条记录”(InsertRecord)按钮的显示状态。
getButtonMoveFirst() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到第一条”按钮(MoveFirst)的显示状态。
getButtonMoveLast() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到最后一条”按钮(MoveLast)的显示状态。
getButtonMoveNext() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到下一条”按钮(MoveNext)的显示状态。
getButtonMovePrev() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到下一条”按钮(MovePrev)的显示状态。
getButtonNextPage() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到后一页”按钮(NextPage)的显示状态。
getButtonPost() - Method in class com.bstek.dorado.view.control.DataPilot
返回"验证"按钮(PostRecord)的显示状态。
getButtonPrevPage() - Method in class com.bstek.dorado.view.control.DataPilot
取得“移动到前一页”按钮(PrevPage)的显示状态。
getByte(int) - Method in interface com.bstek.dorado.data.Dataset
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in interface com.bstek.dorado.data.Dataset
按byte类型返回当前记录中某字段的值。
getByte(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型返回当前记录中某字段的值。
getByte(int) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.data.ReadRecord
按byte类型返回记录中某字段的值。
getByte() - Method in class com.bstek.dorado.utils.variant.Variant
按byte类型读取数据
getByte(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按byte类型读取数据
getByte(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按byte类型读取数据
getByte(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型返回当前记录中某字段的值。
getByte(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型返回当前记录中某字段的值。
getCalendarType() - Method in class com.bstek.dorado.view.control.Calendar
返回日历类型.
getCharSet(String) - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
根据数据源配置的名字返回数据库使用CharSet.
getCheckedField() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得用于获取节点的复选状态的字段名
getChild(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
根据标记名返回子节点中的第一个匹配的节点，如果无法找到匹配的节点则返回null。
getChildContent(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回子节点的内容
getChildContentBoolean(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回子节点的内容
getChildContentBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回子节点的内容.
getChildContentDouble(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回子节点的内容
getChildContentDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回子节点的内容.
getChildContentFloat(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回子节点的内容
getChildContentFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回子节点的内容.
getChildContentInt(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回子节点的内容
getChildContentInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回子节点的内容.
getChildContentLong(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回子节点的内容
getChildContentLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回子节点的内容.
getChildContentString(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回子节点的内容.此方法总是返回一个有效地String, 不会返回null.
getChildContentString(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回子节点的内容.
getChildren() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回所有的子节点
getClazz() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的类名
getClazz() - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
取得校验信息的实现类名
getClientType() - Method in interface com.bstek.dorado.view.ViewModel
返回客户端类型
getClientType() - Method in class com.bstek.dorado.view.ViewModelSupport
返回客户端类型
getCol() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前列的索引值。
getColSpan() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得该元素将占用自动表单中的多少列，该属性类Table的ColSpan属性。
getColSpan() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前元素(Element)的列跨度(colSpan)属性值。
getColumn(int) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
根据索引值取得列对象。
getColumn(String) - Method in class com.bstek.dorado.view.control.table.ColumnGroup
根据名称取得列对象。
getColumn(int) - Method in class com.bstek.dorado.view.control.table.Table
根据索引值取得列(Column)对象。
getColumn(String) - Method in class com.bstek.dorado.view.control.table.Table
根据名称取得列对象。
getColumnCount() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回该组在页面上显示时每行要显示的列数。
getColumnCount() - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
返回AutoForm中组(Group)内每行放置元素的个数。
getColumnCount() - Method in class com.bstek.dorado.view.control.table.ColumnGroup
取得子列的个数。
getColumnCount() - Method in class com.bstek.dorado.view.control.table.Table
取得列的个数。
getCommand() - Method in class com.bstek.dorado.view.control.Button
返回与按钮关联的操作命令.
getCommand() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项对应的命令对象
getCommands() - Method in class com.bstek.dorado.view.control.command.CommandQueue
取得所有子命令的集合对象
getConcreteValidator() - Method in class com.bstek.dorado.view.data.validate.impl.CustomValidator
取得具体的校验器格式
getConditionDataset() - Method in class com.bstek.dorado.view.control.command.QueryCommand
返回作为查询条件的数据集的ID
getConditionDatasetInstance() - Method in class com.bstek.dorado.view.control.command.QueryCommand
返回作为查询条件的数据集的实例
getConfig() - Method in interface com.bstek.dorado.action.Action
取得对应的ActionConfig
getConfig() - Method in class com.bstek.dorado.action.Controller
取得对应的ControllerConfig对象
getConfig() - Method in class com.bstek.dorado.module.ModuleSupport
getConfig() - Method in interface com.bstek.dorado.view.ViewModel
取得视图配置
getConfig() - Method in class com.bstek.dorado.view.ViewModelSupport
取得视图配置
getConfigName() - Method in interface com.bstek.dorado.view.ViewModel
取得视图模型配置名
getConfigName() - Method in class com.bstek.dorado.view.ViewModelSupport
取得视图模型配置名
getConnection(String) - Method in interface com.bstek.dorado.common.Transaction
获取一个与本事务相关的数据连接.
getConnection(String) - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
根据数据源配置的名字返回一个数据连接.
getContent() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回节点的内容
getContentBoolean() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回节点的内容
getContentBoolean(boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型返回节点的内容.
getContentDouble() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回节点的内容
getContentDouble(double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型返回节点的内容.
getContentFloat() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回节点的内容
getContentFloat(float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型返回节点的内容.
getContentInt() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回节点的内容
getContentInt(int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型返回节点的内容.
getContentLong() - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回节点的内容
getContentLong(long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型返回节点的内容.
getContentString() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回节点的内容.此方法总是返回一个有效地String, 不会返回null.
getContentString(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回节点的内容.此方法总是返回一个有效地String.
getContext() - Static method in class com.bstek.dorado.common.DoradoContext
获取当前线程中的context对象.
getContext(ServletRequest) - Static method in class com.bstek.dorado.common.HttpContextFactory
根据ServletRequest来获取一个DoradoContext
getContext(ServletRequest, boolean) - Static method in class com.bstek.dorado.common.HttpContextFactory
根据ServletRequest来获取一个DoradoContext, 如果目前还没有一个相应的DoradoContext, 系统将根据create参数来决定时候要产生一个.
getContextAttribute() - Method in class com.bstek.dorado.view.data.DODataset
取得与DODataset进行数据交换的上下文属性名.
getControl(String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的Id取得一个控件对象。
getControl(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的Id取得一个控件对象。
getControl() - Method in class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.ControlFormElement
取得表单元素中的控件对象。
getControl() - Method in class com.bstek.dorado.view.control.autoform.CustomFormElement
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.LabelFormElement
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

getControl() - Method in class com.bstek.dorado.view.control.autoform.TextEditorFormElement
取得表单元素中的控件对象。

抽象方法，需要在子类中实现。

getControlAlign() - Method in class com.bstek.dorado.view.control.autoform.ControlFormElement
取得控件的水平对齐方式。
getControlId() - Method in class com.bstek.dorado.view.control.autoform.CustomFormElement
取得控件(Control)的唯一标识符(Id)。
getControlVAlign() - Method in class com.bstek.dorado.view.control.autoform.ControlFormElement
取得控件的垂直对齐方式。
getController() - Method in interface com.bstek.dorado.action.Action
getController
getController(HttpServletRequest, String) - Static method in class com.bstek.dorado.action.ControllerManager
根据给定名称从指定的资源中查找并返回一个Controller的实例。
getController() - Method in class com.bstek.dorado.action.mapping.ActionConfig
取得该Action所属的Controller对象
getController(String) - Method in class com.bstek.dorado.action.mapping.Unit
根据别名查找一个Controller的配置信息
getControllerFactory() - Static method in class com.bstek.dorado.action.ControllerManager
获得系统内部使用的Controller工厂。
getControls() - Method in interface com.bstek.dorado.view.ViewModel
取得视图模型所有的控件的集合对象。
getControls() - Method in class com.bstek.dorado.view.ViewModelSupport
取得视图模型所有的控件的集合对象。
getCount() - Method in class com.bstek.dorado.data.FieldSet
取得Field的总数
getCountSql() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
取得AutoSqlDataset内部使用的用于统计总记录数的SQL命令。
getCountSql() - Method in class com.bstek.dorado.data.db.SqlDataset
返回统计总记录数的SQL命令。
getCurrent() - Method in interface com.bstek.dorado.data.Dataset
返回当前记录对象。
getCurrent() - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录对象。
getCurrent() - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录对象。
getCurrent() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录对象。
getCurrentGroup() - Method in class com.bstek.dorado.view.control.OutlookBar
getCurrentGroup
getCurrentTab() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得当前标签页的设置.
getDO() - Method in class com.bstek.dorado.data.DOSet
以java.util.List的方式返回所有DO.
getDO(int) - Method in class com.bstek.dorado.data.DOSet
以java.util.List的方式返回符合给定状态的DO.
getDataSource() - Method in class com.bstek.dorado.data.db.DBDataset
返回Dataset对应的数据源名称.
getDataSource() - Method in class com.bstek.dorado.data.db.DBStatement
取得DBStatement使用的数据源的名称.
getDataType() - Method in interface com.bstek.dorado.data.Field
取得字段的数据类型。
getDataType() - Method in class com.bstek.dorado.data.db.BaseMatchRule
返回匹配值的数据类型.
getDataType() - Method in class com.bstek.dorado.utils.variant.Variant
getDataType
getDataType(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号返回默认数据类型
getDataType(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值返回默认数据类型
getDataType() - Method in class com.bstek.dorado.view.control.TextEditor
取得编辑器的数据类型。
getDataset() - Method in class com.bstek.dorado.data.Index
返回本索引所属的Dataset对象
getDataset() - Method in class com.bstek.dorado.data.Record
取得该记录对象所属的数据集（Dataset）对象.
getDataset(String, boolean) - Method in class com.bstek.dorado.module.ModuleSupport
getDataset(String, boolean, ParameterSet) - Method in class com.bstek.dorado.module.ModuleSupport
getDataset(String, boolean, int, int, ParameterSet) - Method in class com.bstek.dorado.module.ModuleSupport
getDataset(String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的Id取得一个视图数据集对象。
getDataset(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的Id取得一个视图数据集对象。
getDataset() - Method in class com.bstek.dorado.view.control.DataControl
返回数据控件绑定的数据集。
getDataset() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回要提交的Dataset的id
getDataset() - Method in class com.bstek.dorado.view.control.command.RequestCommand
返回绑定的数据集的ID
getDataset() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
返回一个与数据集下拉框关联的数据集对象。
getDataset() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得绑定的数据集
getDatasetInfos() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
返回所有要提交的数据集的信息.
getDatasetInstance() - Method in class com.bstek.dorado.view.control.DataControl
返回数据控件绑定的数据集实例。
getDatasetInstance() - Method in class com.bstek.dorado.view.control.command.RequestCommand
返回绑定的数据集的实例。
getDatasets() - Method in interface com.bstek.dorado.view.ViewModel
取得所有的视图数据集的集合对象。
getDatasets() - Method in class com.bstek.dorado.view.ViewModelSupport
取得所有的视图数据集的集合对象。
getDate(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Date型的配置信息
getDate(String, Date) - Static method in class com.bstek.dorado.common.Setting
读取一个Date型的配置信息,如何该配置不存在则返回缺省值.
getDate(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Date型的配置信息
getDate(String, Date) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Date型的配置信息
getDate() - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
获取系统的当前时间 例如: ${Util.getDate()} 或 ${Util.date}
getDate(String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
按指定的日期格式获取系统的当前时间的字符串 例如: ${Util.getDate("yyyy-MM-dd")}
getDate(int) - Method in interface com.bstek.dorado.data.Dataset
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in interface com.bstek.dorado.data.Dataset
按Date类型返回当前记录中某字段的值。
getDate(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按Date类型返回当前记录中某字段的值。
getDate(int) - Method in class com.bstek.dorado.data.DatasetSupport
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.data.DatasetSupport
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.data.ReadRecord
按Date类型返回记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按Date方式读取一个参数
getDate() - Method in class com.bstek.dorado.utils.variant.Variant
按Date类型读取数据
getDate(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按Date类型读取数据
getDate(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按Date类型读取数据
getDate() - Method in class com.bstek.dorado.view.control.Calendar
返回日历默认时间.
getDate(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按Date类型返回当前记录中某字段的值。
getDate(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按Date类型返回当前记录中某字段的值。
getDbCharSet() - Method in class com.bstek.dorado.data.db.DBDataset
取得数据库的字符集编码.
getDefaultConnection() - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
返回一个默认数据连接.
getDefaultControlWidth() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中各个元素统一的缺省宽度值.
getDefaultControlWidth() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得自动表单中各个控件对象的缺省所占的宽度。
getDefaultDialect() - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
返回默认的数据库方言实现对象.
getDefaultElementMargin() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中每个元素缺省的空白边缘(Margin)值.
getDefaultLabelWidth() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm的元素的标题的缺省宽度值.
getDefaultLocale() - Static method in class com.bstek.dorado.i18n.LocaleHelper
返回Setting.xml中指定的默认的地区与语种.
getDefaultLocale(DoradoContext) - Method in class com.bstek.dorado.i18n.ResourceManager
返回默认的地区与语种.
getDefaultSkin(DoradoContext) - Method in class com.bstek.dorado.view.ViewModelSupport
获得默认的皮肤.
getDefaultValue() - Method in interface com.bstek.dorado.data.Field
取得字段缺省值。
getDescription() - Method in class com.bstek.dorado.action.mapping.ActionConfig
Action的描述信息。
getDescription() - Method in class com.bstek.dorado.action.mapping.ActionTarget
获得描述信息。
getDescription() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的描述信息。
getDescription() - Method in class com.bstek.dorado.action.mapping.Unit
Unit的描述信息。
getDetailDataset() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集
getDetailKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的字段.
getDetailKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回本节点层的顶层节点对应的数据集与父节点层相关联的参数名.
getDetailKeyParameters() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
返回本节点层对应的数据集与父节点层相关联的参数名.
getDetailKeyParameters() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得从数据集中与主数据集关联的参数.
getDetailLinks() - Method in interface com.bstek.dorado.view.data.ViewDataset
取得所有关联关系的集合对象
getDetailLinks() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得所有关联关系的集合对象
getDetailProperty() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
getDetailRecords(String) - Method in class com.bstek.dorado.data.ReadRecord
getDetailRecords
getDialect(String) - Static method in class com.bstek.dorado.common.ds.ConnectionHelper
根据数据源配置的名字返回数据库方言的实现对象.
getDialect() - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset内部使用的数据库方言的实现类.
getDisableIcon() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项失效时的图标的URL.
getDouble(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Double型的配置信息
getDouble(String, double) - Static method in class com.bstek.dorado.common.Setting
读取一个Double型的配置信息,如何该配置不存在则返回缺省值.
getDouble(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Double型的配置信息
getDouble(String, double) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Double型的配置信息
getDouble(int) - Method in interface com.bstek.dorado.data.Dataset
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in interface com.bstek.dorado.data.Dataset
按double类型返回当前记录中某字段的值。
getDouble(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型返回当前记录中某字段的值。
getDouble(int) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.data.ReadRecord
按double类型返回记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按double方式读取一个参数
getDouble() - Method in class com.bstek.dorado.utils.variant.Variant
按double类型读取数据
getDouble(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按double类型读取数据
getDouble(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按double类型读取数据
getDouble(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型返回当前记录中某字段的值。
getDouble(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型返回当前记录中某字段的值。
getDownLoadFileName(HttpServletRequest) - Method in class com.bstek.dorado.biz.FileController
取得将要下载的文件的文件名
getDownloadFileInputStream(HttpServletRequest) - Method in class com.bstek.dorado.biz.FileController
取得将要被下载的文件的文件输入流
getDragMode() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动条拖动类型.
getDropDown() - Method in class com.bstek.dorado.view.control.RadioGroup
取得绑定的下拉框
getDropDown() - Method in class com.bstek.dorado.view.control.TextEditor
取得相关联的下拉框.
getDropDown() - Method in class com.bstek.dorado.view.control.table.EditableColumn
取得绑定的下拉框对象
getDropDown() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得字段关联的下拉框对象.
getDropDown() - Method in interface com.bstek.dorado.view.data.ViewField
取得字段关联的下拉框对象.
getDropDown() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得字段关联的下拉框对象.
getDropDownType() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDownViewModel
取得下拉框的类型
getDropDownType() - Method in class com.bstek.dorado.view.control.dropdown.DropDownViewModel
取得下拉框的类型
getDropDownType() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
getDropDownType
getEditorType() - Method in class com.bstek.dorado.view.control.TextEditor
取得编辑器类型.
getEditorType() - Method in class com.bstek.dorado.view.control.table.EditableColumn
取得编辑器的类型
getEditorType() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得与该字段关联的编辑器的类型.
getEditorType() - Method in interface com.bstek.dorado.view.data.ViewField
取得与该字段关联的编辑器的类型.
getEditorType() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得与该字段关联的编辑器的类型.
getElement(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
根据指定的表单元素的名称，取得一个表单元素对象。
getElement() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前的元素(Element)对象。
getElementMargin() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得自动表单中各个元素边缘空白的大小。
getElements() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回组中所有元素的集合对象。
getErrorMessage() - Method in interface com.bstek.dorado.view.data.validate.Validator
返回一个错误信息.
getErrorMessage() - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
返回一个对应的ErrorMessage。
getEscapeValue() - Method in class com.bstek.dorado.data.db.CommonMatchRule
取得逃逸值.
getEvent(String, String) - Static method in class com.bstek.dorado.view.EventConfig
根据控件名和事件名取得一个事件定义的描述对象
getEventHandler(String) - Method in interface com.bstek.dorado.view.Component
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in interface com.bstek.dorado.view.EventSupported
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.control.table.DataColumnGroup
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
根据指定名称取得一个事件处理对象。
getEventHandler(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
getEventHandler
getException(Throwable) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的异常得到一个ActionException子对象
getException(int) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的索引号得到一个ActionException子对象
getException(Throwable) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的异常得到一个ActionException子对象
getException(int) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的索引号得到一个ActionException子对象
getException(Throwable) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的异常得到一个ActionException子对象
getException(int) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的索引号得到一个ActionException子对象
getExceptionCount() - Method in class com.bstek.dorado.action.mapping.ActionConfig
返回ActionException的个数
getExceptionCount() - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
返回ActionException的个数
getExceptionCount() - Method in class com.bstek.dorado.action.mapping.Unit
返回ActionException的个数
getExpandLevel() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回树默认展开到的层数
getExpandLevel() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回树默认展开到的层数
getExpandedIcon() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得节点展开图标的URL
getExpandedIcon() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点的展开图标的URL
getExpandedIconField() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得用于获取节点展开图标的URL的字段名
getField(int) - Method in interface com.bstek.dorado.data.Dataset
根据Field索引号取得一个Field对象。
getField(String) - Method in interface com.bstek.dorado.data.Dataset
根据Field名称取得一个Field对象。
getField(int) - Method in class com.bstek.dorado.data.DatasetAdapter
根据Field索引号取得一个Field对象。
getField(String) - Method in class com.bstek.dorado.data.DatasetAdapter
根据Field名称取得一个Field对象。
getField(int) - Method in class com.bstek.dorado.data.DatasetSupport
根据Field索引号取得一个Field对象。
getField(String) - Method in class com.bstek.dorado.data.DatasetSupport
根据Field名称取得一个Field对象。
getField(int) - Method in class com.bstek.dorado.data.FieldSet
根据Field索引号取得一个Field对象
getField(String) - Method in class com.bstek.dorado.data.FieldSet
根据Field名称取得一个Field对象
getField() - Method in class com.bstek.dorado.view.control.SimpleDataControl
返回Field名称。
getField() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得该元素绑定的字段。
getField() - Method in class com.bstek.dorado.view.control.table.DataColumn
取得表格列的数据来自于数据集的哪个字段。
getField(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据Field索引号取得一个Field对象。
getField(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据Field名称取得一个Field对象。
getFieldCount() - Method in interface com.bstek.dorado.data.Dataset
取得Field的总数。
getFieldCount() - Method in class com.bstek.dorado.data.DatasetAdapter
取得Field的总数。
getFieldCount() - Method in class com.bstek.dorado.data.DatasetSupport
取得Field的总数。
getFieldCount() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得Field的总数。
getFieldFactory() - Method in class com.bstek.dorado.data.DatasetSupport
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.data.custom.CustomDataset
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.data.db.SqlDataset
返回Field的创建工厂.
getFieldFactory() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回Field的创建工厂.
getFieldInstance() - Method in class com.bstek.dorado.view.control.SimpleDataControl
取得一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。
getFieldLabel() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得表单元素中的字段标题对象。
getFieldSet() - Method in class com.bstek.dorado.data.Record
取得该记录的所有字段的集合对象.
getFields() - Method in class com.bstek.dorado.data.Index
返回本索引对应的字段
getFilePath() - Method in class com.bstek.dorado.common.fileloader.FileLoader
文件位置的描述。
getFilterParameter() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回绑定的数据集中可用于实现动态数据筛选的参数
getFinalErrorMessage() - Method in interface com.bstek.dorado.view.data.validate.Validator
返回一个最终的错误信息.
getFirst() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的第一条记录
getFirstWrapper() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的第一条记录的包装器.
getFixedColumn() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格中被锁定列的个数
getFloat(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Float型的配置信息
getFloat(String, float) - Static method in class com.bstek.dorado.common.Setting
读取一个Float型的配置信息,如何该配置不存在则返回缺省值.
getFloat(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Float型的配置信息
getFloat(String, float) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Float型的配置信息
getFloat(int) - Method in interface com.bstek.dorado.data.Dataset
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in interface com.bstek.dorado.data.Dataset
按float类型返回当前记录中某字段的值。
getFloat(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型返回当前记录中某字段的值。
getFloat(int) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.data.ReadRecord
按float类型返回记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按float方式读取一个参数
getFloat() - Method in class com.bstek.dorado.utils.variant.Variant
按float类型读取数据
getFloat(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按float类型读取数据
getFloat(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按float类型读取数据
getFloat(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型返回当前记录中某字段的值。
getFloat(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型返回当前记录中某字段的值。
getFooterHeight() - Method in class com.bstek.dorado.view.control.table.Table
返回合计栏位的高度
getFooterValue() - Method in class com.bstek.dorado.view.control.table.DataColumn
返回列的列脚值.此数值最终将被显示在表格中的该列对应的列脚单元格中.
getFormat() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得字段数据的格式化串.
getFormat() - Method in interface com.bstek.dorado.view.data.ViewField
取得字段数据的格式化串.
getFormat() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得字段数据的格式化串.
getForward(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的别名得到一个ActionForward子对象
getForward(int) - Method in class com.bstek.dorado.action.mapping.ActionConfig
根据给定的索引号得到一个ActionForward子对象
getForward(String) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的别名得到一个ActionForward子对象
getForward(int) - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
根据给定的索引号得到一个ActionForward子对象
getForward(String) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的别名得到一个ActionForward子对象
getForward(int) - Method in class com.bstek.dorado.action.mapping.Unit
根据给定的索引号得到一个ActionForward子对象
getForwardCount() - Method in class com.bstek.dorado.action.mapping.ActionConfig
返回ActionForward的个数
getForwardCount() - Method in interface com.bstek.dorado.action.mapping.ActionTargetCollection
返回ActionForward的个数
getForwardCount() - Method in class com.bstek.dorado.action.mapping.Unit
返回ActionForward的个数
getFrame() - Method in class com.bstek.dorado.view.control.command.RequestCommand
返回用于描述目前框架的对象.
getFromIndex() - Method in class com.bstek.dorado.data.PagingHelper
返回当前页记录的起始序号。
getGlobalUnit() - Method in class com.bstek.dorado.action.mapping.Mapping
取得global配置单元对象
getGroup(int) - Method in class com.bstek.dorado.view.control.OutlookBar
getGroup
getGroup(String) - Method in class com.bstek.dorado.view.control.OutlookBar
getGroup
getGroup(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
根据名称返回一个组对象
getGroup() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得元素所属的组。
getGroupCount() - Method in class com.bstek.dorado.view.control.OutlookBar
getGroupCount
getGroupType() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中分组的显示类型.默认为"groupbox".
getGroups() - Method in class com.bstek.dorado.view.control.OutlookBar
取得所有多页标签的集合对象。
getGroups() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得所有组的集合对象
getHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
获得一个远程过程调用的处理器
getHeaderHeight() - Method in class com.bstek.dorado.view.control.table.Table
返回表格列标题高度
getHeight() - Method in interface com.bstek.dorado.view.control.Placeable
返回控件的高度
getHeight() - Method in class com.bstek.dorado.view.control.PlaceableControl
返回控件的高度
getHeight() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
返回控件的高度
getHeight() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm的高度.
getHeight() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得组的高度值。
getHeight() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架的高度值.
getHeight() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
返回下拉框的默认高度
getIcon() - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
getIcon
getIcon() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项的图标的URL.
getIcon() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得节点图标的URL
getIcon() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点的图标的URL
getIconField() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得用于获取节点图标的URL的字段名
getId() - Method in interface com.bstek.dorado.data.Dataset
获得Dataset的ID
getId() - Method in class com.bstek.dorado.data.DatasetAdapter
获得Dataset的ID
getId() - Method in class com.bstek.dorado.data.DatasetSupport
获得Dataset的ID
getId() - Method in interface com.bstek.dorado.view.Component
取得组件的Id。
getIndex(String) - Method in interface com.bstek.dorado.data.Dataset
根据指定的字段返回一个Dataset的索引对象。
getIndex(String[]) - Method in interface com.bstek.dorado.data.Dataset
根据指定的一组字段返回一个Dataset的索引对象。
getIndex(String) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String[]) - Method in class com.bstek.dorado.data.DatasetAdapter
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String[]) - Method in class com.bstek.dorado.data.DatasetSupport
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getIndex(String[]) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据指定的一组字段返回一个Dataset的索引对象。如何该索引尚不存在则在内存中建立索引。
getInputStream() - Method in class com.bstek.dorado.common.fileloader.FileLoader
获取文件的输入流
getInstance() - Static method in class com.bstek.dorado.action.mapping.Mapping
取得单例对象
getInstance() - Static method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
获得单例对象
getInstance() - Static method in class com.bstek.dorado.i18n.ResourceManager
获得单例对象
getInt(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Int型的配置信息
getInt(String, int) - Static method in class com.bstek.dorado.common.Setting
读取一个Int型的配置信息,如何该配置不存在则返回缺省值.
getInt(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Int型的配置信息
getInt(String, int) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Int型的配置信息
getInt(int) - Method in interface com.bstek.dorado.data.Dataset
按int类型返回当前记录中某字段的值。
getInt(String) - Method in interface com.bstek.dorado.data.Dataset
按int类型返回当前记录中某字段的值。
getInt(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型返回当前记录中某字段的值。
getInt(int) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.data.ReadRecord
按int类型返回记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按int方式读取一个参数
getInt() - Method in class com.bstek.dorado.utils.variant.Variant
按int类型读取数据
getInt(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按int类型读取数据
getInt(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按int类型读取数据
getInt(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型返回当前记录中某字段的值。
getInt(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型返回当前记录中某字段的值。
getInterval() - Method in class com.bstek.dorado.utils.SynchroTimer
定时器触发间隔时间
getItem(String) - Method in class com.bstek.dorado.view.control.Menu
根据名称取得一个子菜单项
getItem(String) - Method in class com.bstek.dorado.view.control.MenuItem
根据名称取得一个子菜单项
getItem(String) - Method in interface com.bstek.dorado.view.control.MenuItemContainer
根据名称取得一个子菜单项
getItem(int) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定的索引值取得静态下拉框的下拉数据项对象。
getItems() - Method in class com.bstek.dorado.view.control.Menu
取得所有菜单项MunuItem的集合对象。
getItems() - Method in class com.bstek.dorado.view.control.MenuItem
取得所有菜单项MunuItem的集合对象。
getItems() - Method in interface com.bstek.dorado.view.control.MenuItemContainer
取得所有菜单项MunuItem的集合对象。
getKey() - Static method in class com.bstek.dorado.utils.UniqueKey
返回一个新的VM唯一标识。
getKey(int) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回给定的索引号对应的键值。
getKey(int) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回给定的索引号对应的键值。
getKeyFields() - Method in class com.bstek.dorado.data.LookupField
Dataset与LookupDataset之间的字段匹配关系。
getKeyFields() - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset的主表的主键字段。
getKeyFields() - Method in class com.bstek.dorado.data.db.JoinTable
取得用于建立关联的关联表中的字段.
getKind() - Method in class com.bstek.dorado.data.db.AndOrMatchRule
获得该逻辑连接符的类型.
getLabel() - Method in interface com.bstek.dorado.data.Field
取得字段列的标题。
getLabel() - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
getLabel
getLabel() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项标题.
getLabel() - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
取得下拉框(DropDown)对应的字段(Field)的标题(Label)。
getLabel() - Method in class com.bstek.dorado.view.control.table.Column
取得列的标题。
getLabel() - Method in class com.bstek.dorado.view.control.tabset.TabElement
取得多页标签表格的标题。
getLabel() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点的标题
getLabelAlign() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得字段标题的水平对齐方式。
getLabelField() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
返回作为最终显示内容的字段
getLabelField() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得用于获取节点标题的字段名
getLabelVAlign() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得字段标题的垂直对齐方式。
getLabelWidth() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得自动表单中的各个元素标题的宽度值。
getLast() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的最后一条记录
getLastModified() - Method in class com.bstek.dorado.common.fileloader.FileLoader
获取文件的最后修改日期
getLastWrapper() - Method in class com.bstek.dorado.data.RecordSet
取得记录集合中的最后一条记录的包装器.
getLayout() - Method in class com.bstek.dorado.view.control.RadioGroup
取得内部对象的排列方式
getLayout() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm中元素的布局.该属性定义元素所在的组之间的布局方式,分为horizontal和vertical两种.
getLayoutInfos() - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
getLayoutInfos
getLeft() - Method in interface com.bstek.dorado.view.control.Placeable
返回控件距离父对象左边的距离
getLeft() - Method in class com.bstek.dorado.view.control.PlaceableControl
返回控件距离父对象左边的距离
getLeft() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
返回控件距离父对象左边的距离
getLeft() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架左边距值.
getLevel() - Static method in class com.bstek.dorado.common.log.Log
返回日志记录器的日志级别。
getLevel() - Method in class com.bstek.dorado.data.db.AndOrMatchRule
取得该规则对象的级数.
getLevel() - Method in class com.bstek.dorado.data.db.CommonMatchRule
取得该规则对象的级数.
getLevel() - Method in interface com.bstek.dorado.data.db.MatchRule
取得该规则对象的级数.
getLevel() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得当前树节点的层数 树的根节点的level为1,其下一级子节点的level为2,依此类推.
getLevel() - Method in class com.bstek.dorado.view.control.tree.RecordTreeNode
返回树节点相关的节点层对象.
getLoadDataAction() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
getLoadDataAction() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
getLoadDataHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
获得一个动态数据加载过程的处理器
getLocale(String, String) - Static method in class com.bstek.dorado.i18n.LocaleHelper
返回给定参数所表示的地区与语种.
getLogicCharSet() - Method in class com.bstek.dorado.data.db.DBDataset
取得逻辑代码中使用的字符集编码.
getLong(String) - Static method in class com.bstek.dorado.common.Setting
读取一个Long型的配置信息
getLong(String, long) - Static method in class com.bstek.dorado.common.Setting
读取一个Long型的配置信息,如何该配置不存在则返回缺省值.
getLong(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Long型的配置信息
getLong(String, long) - Static method in class com.bstek.dorado.common.UserConfig
读取一个Long型的配置信息
getLong(int) - Method in interface com.bstek.dorado.data.Dataset
按long类型返回当前记录中某字段的值。
getLong(String) - Method in interface com.bstek.dorado.data.Dataset
按long类型返回当前记录中某字段的值。
getLong(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型返回当前记录中某字段的值。
getLong(int) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.data.ReadRecord
按long类型返回记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按long方式读取一个参数
getLong() - Method in class com.bstek.dorado.utils.variant.Variant
按long类型读取数据
getLong(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按long类型读取数据
getLong(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按long类型读取数据
getLong(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型返回当前记录中某字段的值。
getLong(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型返回当前记录中某字段的值。
getLookupDataset() - Method in class com.bstek.dorado.data.LookupField
作为Lookup数据来源的Dataset对象。
getLookupField() - Method in class com.bstek.dorado.data.LookupField
LookupDataset中将被作为数据返回的字段的名称。
getLookupKeyFields() - Method in class com.bstek.dorado.data.LookupField
Dataset与LookupDataset之间的字段匹配关系。
getMasterDataset() - Method in class com.bstek.dorado.view.data.MasterDetailLink
返回主数据集
getMasterKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回父节点层对应的数据集中跟本节点层的顶层节点相关联的字段名.
getMasterKeyFields() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
返回父节点层对应的数据集中跟本节点层相关联的字段名.
getMasterKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得主数据集中与从数据集关联的字段.
getMasterLink() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
getMasterLink() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回用于描述该Dataset与MasterDataset之间的关联关系的对象。
getMax() - Method in class com.bstek.dorado.view.control.ProgressBar
获得进度条可取最大值。
getMax() - Method in class com.bstek.dorado.view.control.ScrollBar
取得滚动条可滚动的最大值.
getMax() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得范围最大值
getMaxLength() - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
返回最大长度值。
getMaxLink() - Method in class com.bstek.dorado.view.control.PagePilot
取得页码导航条(PagePilot)最大连续可见页数。
getMaxMatchRule() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得最大值匹配规则
getMaxPropertyLevel() - Method in interface com.bstek.dorado.data.Dataset
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
getMaxPropertyLevel() - Method in class com.bstek.dorado.data.DatasetAdapter
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
getMaxPropertyLevel() - Method in class com.bstek.dorado.data.DatasetSupport
获取当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
getMaxRow() - Method in class com.bstek.dorado.view.control.table.DataTable
取得数据表格能够显示的最大记录条数。
getMenu() - Method in class com.bstek.dorado.view.control.Button
取得与按钮绑定的菜单.
getMenu() - Method in class com.bstek.dorado.view.control.MenuBar
取得菜单栏绑定的菜单对象.
getMenu() - Method in class com.bstek.dorado.view.control.OutlookBar
取得绑定的菜单对象.
getMessage(ServletRequest) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条无键值消息.
getMessage(ServletRequest, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条在指定键值中消息.
getMessage(DoradoContext) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条无键值消息.
getMessage(DoradoContext, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回一条在指定键值中消息.
getMessage() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得本次远程调用将要返回给客户端的提示信息.
getMessages(ServletRequest) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有无键值消息
getMessages(ServletRequest, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有指定键值中消息
getMessages(DoradoContext) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有无键值消息
getMessages(DoradoContext, String) - Static method in class com.bstek.dorado.common.MessageHelper
返回所有指定键值中消息
getMethod() - Method in class com.bstek.dorado.view.control.command.RPCCommand
返回执行此命令时在ViewModel的实现类中激活的方法名.
getMethod() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
返回执行此命令时在ViewModel的实现类中触发的方法名.
getMethod() - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
取得本次数据更新操作将要调用的ViewModel中的方法名.
getMin() - Method in class com.bstek.dorado.view.control.ProgressBar
获得进度条可取最小值。
getMin() - Method in class com.bstek.dorado.view.control.ScrollBar
取得滚动条可滚动的最小值.
getMin() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得最小值
getMinLength() - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
取得最小长度值。
getMinMatchRule() - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
取得最小值匹配规则
getModule(String) - Static method in class com.bstek.dorado.module.ModuleManager
根据给定的名称取得Module对象的实例.
getModule(ModuleConfig) - Static method in class com.bstek.dorado.module.ModuleManager
根据给定的配置对象取得Module对象
getModuleConfig(String) - Static method in class com.bstek.dorado.module.ModuleManager
根据Module的名字取得配置对象
getModulePool() - Static method in class com.bstek.dorado.module.ModuleManager
取得Module的缓冲池
getName() - Method in interface com.bstek.dorado.action.Action
取得Action的别名
getName() - Method in class com.bstek.dorado.action.Controller
取得Controller的别名。
getName() - Method in class com.bstek.dorado.action.mapping.ActionConfig
Action的别名
getName() - Method in class com.bstek.dorado.action.mapping.ActionForward
此对象的别名
getName() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的别名
getName() - Method in class com.bstek.dorado.action.mapping.Unit
取得配置单元的名称
getName() - Method in interface com.bstek.dorado.data.Field
取得字段的名称。
getName() - Method in class com.bstek.dorado.data.db.JoinTable
取得关联表的别名.
getName() - Method in class com.bstek.dorado.module.ModuleSupport
getName() - Method in interface com.bstek.dorado.utils.xml.XmlNode
节点名称
getName() - Method in class com.bstek.dorado.view.Event
取得事件名
getName() - Method in class com.bstek.dorado.view.EventHandler
取得事件名
getName() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项名称.
getName() - Method in class com.bstek.dorado.view.control.OutlookBarGroup
getName
getName() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得元素的名称。
getName() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
getName
getName() - Method in class com.bstek.dorado.view.control.table.Column
取得列名。
getName() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回多页标签表格的名称。
getName() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
取得节点层的名称
getNamespace() - Method in interface com.bstek.dorado.view.ViewModel
取得视图配置命名空间
getNamespace() - Method in class com.bstek.dorado.view.ViewModelSupport
getNamespace
getNext() - Method in class com.bstek.dorado.data.RecordWrapper
取得下一个记录包装器
getNodeById(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
根据ID返回一个节点，如果无法找到匹配的节点则返回null。
getNodeByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
根据XPath返回第一个匹配的节点。
getNodeByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
根据XPath返回第一个匹配的节点。
getNodesByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
根据XPath返回所有匹配的节点。
getNodesByXPath(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
根据XPath返回所有匹配的节点。
getObjectClazz() - Method in interface com.bstek.dorado.data.Dataset
返回相关的对象类型的Class名.
getObjectClazz() - Method in class com.bstek.dorado.data.DatasetAdapter
返回相关的对象类型的Class名.
getObjectClazz() - Method in class com.bstek.dorado.data.DatasetSupport
返回相关的对象类型的Class名.
getOffValue() - Method in class com.bstek.dorado.view.control.CheckBox
返回复选框未选中时代表的值.
getOldDO(Object) - Method in class com.bstek.dorado.data.DOSet
根据给定的DO取得与其相关的保存其修改之前的数据的DO.
getOldRecord(Record) - Method in interface com.bstek.dorado.data.Dataset
返回用于保存某记录的原始值的记录对象。
getOldRecord(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
返回用于保存某记录的原始值的记录对象。
getOldRecord(Record) - Method in class com.bstek.dorado.data.DatasetSupport
返回用于保存某记录的原始值的记录对象。
getOldRecord(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回用于保存某记录的原始值的记录对象。
getOnValue() - Method in class com.bstek.dorado.view.control.CheckBox
返回复选框选中时代表的值.
getOpenMode() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
返回自定义下拉框的打开方式.
getOperator() - Method in class com.bstek.dorado.data.db.BaseMatchRule
取得比较操作符。
getOrientation() - Method in class com.bstek.dorado.view.control.ProgressBar
获得进度条对象(ProgressBar)的类型。
getOrientation() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动条的方向.
getOrientation() - Method in class com.bstek.dorado.view.control.SplitPanel
返回视图分割栏方向.
getOriginField() - Method in class com.bstek.dorado.data.db.BaseMatchRule
返回匹配规则的原始字段。
getOriginField() - Method in class com.bstek.dorado.data.db.DBField
返回该字段来自于哪个数据库物理字段。
getOriginField() - Method in class com.bstek.dorado.data.db.SortRule
返回该排序规则对应的字段名.
getOriginTable() - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset的主表的物理表名.
getOriginTable() - Method in class com.bstek.dorado.data.db.JoinTable
取得关联表的物理表名.
getOutlookBar() - Method in class com.bstek.dorado.view.control.OutlookBarGroup
getOutlookBar
getOutputContentType(HttpServletRequest) - Method in class com.bstek.dorado.biz.FileController
返回向Response输出时使用的ContentType
getOutputStream() - Method in class com.bstek.dorado.common.fileloader.FileLoader
获取文件的输出流.
getOutputStream(HttpServletRequest, HttpServletResponse) - Static method in class com.bstek.dorado.utils.http.ResponseUtil
getOutputStream
getPadding() - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
getPadding
getPadding() - Method in class com.bstek.dorado.view.control.SplitPanel
返回视图分割栏四周留白的宽度.
getPadding() - Method in class com.bstek.dorado.view.control.tabset.TabElement
取得标签页的边缘空白
getPageCount() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset所对应的数据共有几页。
getPageCount() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset所对应的数据共有几页。
getPageCount() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset所对应的数据共有几页。
getPageCount() - Method in class com.bstek.dorado.data.PagingHelper
返回总页数。
getPageCount() - Method in class com.bstek.dorado.data.RecordSet
返回整个结果集可能包含的页数.
getPageCount() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset所对应的数据共有几页。
getPageIndex() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset的当前页号
getPageIndex() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset的当前页号
getPageIndex() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset的当前页号
getPageIndex() - Method in class com.bstek.dorado.data.PagingHelper
返回页号。
getPageIndex() - Method in class com.bstek.dorado.data.RecordSet
返回当前RecordSet对象中管理的Record在整个结果集中所处的页号.
getPageIndex() - Method in class com.bstek.dorado.data.RecordWrapper
取得当前管理的Record在整个结果集中所处的页号.
getPageIndex() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset的当前页号
getPageSize() - Method in interface com.bstek.dorado.data.Dataset
取得每页的行数。
getPageSize() - Method in class com.bstek.dorado.data.DatasetAdapter
取得每页的行数。即Dataset按照多少行数对数据进行分页。
getPageSize() - Method in class com.bstek.dorado.data.DatasetSupport
取得每页的行数。即Dataset按照多少行数对数据进行分页。
getPageSize() - Method in class com.bstek.dorado.data.PagingHelper
返回每页的记录数。
getPageSize() - Method in class com.bstek.dorado.view.control.ScrollBar
取得对应的可见区域的大小.
getPageSize() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得每页的行数。即Dataset按照多少行数对数据进行分页。
getParameter(String) - Method in class com.bstek.dorado.common.DoradoContext
从上下文中获取一个参数的值.
getParameter(String) - Method in class com.bstek.dorado.common.HttpDoradoContext
从上下文中获取一个参数的值.
对于基于Http的应用而言, 可以通过此方法来获取HttpServletRequest中的参数(Parameter).
getParameter(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
getParameter
getParameterFields() - Method in class com.bstek.dorado.view.control.command.RequestCommand
返回绑定数据集中将作为参数的字段.
getParameters(String) - Method in class com.bstek.dorado.common.DoradoContext
从上下文中获取一个参数的值数组.
getParameters(String) - Method in class com.bstek.dorado.common.HttpDoradoContext
从上下文中获取一个参数的值数组.
getParameters() - Method in class com.bstek.dorado.view.Event
取得事件参数描述
getParent() - Method in interface com.bstek.dorado.utils.xml.XmlNode
返回父节点
getParsedProperty() - Method in interface com.bstek.dorado.data.Field
以数组方式表现的嵌套对象属性.
getPath() - Method in class com.bstek.dorado.action.mapping.ActionTarget
跳转目标的路径
getPath() - Method in class com.bstek.dorado.view.control.MenuItem
取得单击菜单项时要打开的URL路径.
getPath() - Method in class com.bstek.dorado.view.control.command.RequestCommand
取得命令要激活的URL资源
getPath() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
取得下拉框将要打开的url路径.
getPath() - Method in class com.bstek.dorado.view.control.tabset.FrameTab
取得多页标签切换时需要跳转的URL路径。
getPath() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
取得选中该节点时要自动激活到的URL
getPathField() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
取得用于获取节点对应的URL的字段名
getPattern() - Method in class com.bstek.dorado.view.control.table.StaticColumn
取得静态列的模式
getPattern() - Method in class com.bstek.dorado.view.data.validate.impl.PatternValidator
获得正则表达式
getPilotType() - Method in class com.bstek.dorado.view.control.PagePilot
取得分页导航对象的类型，可取值为"link","button"。
getPopupContainer() - Method in class com.bstek.dorado.view.control.Menu
取得弹出式菜单的容器的ID.
getPosition() - Method in class com.bstek.dorado.view.control.ProgressBar
返回进度信息。
getPosition() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动条默认位置.
getPosition() - Method in class com.bstek.dorado.view.control.SplitPanel
取得视图分割栏中滑动条的默认位置.
getPossibleCount() - Method in class com.bstek.dorado.data.RecordSet
返回整个结果集可能包含的记录数.
getPossibleRecordCount() - Method in interface com.bstek.dorado.data.Dataset
获取Dataset可能存在的总记录数。。
getPossibleRecordCount() - Method in class com.bstek.dorado.data.DatasetAdapter
获取Dataset可能存在的总记录数。。
getPossibleRecordCount() - Method in class com.bstek.dorado.data.DatasetSupport
获取Dataset可能存在的总记录数。。
getPrefix() - Method in class com.bstek.dorado.action.mapping.Unit
取得配置单元的URL前缀
getPrev() - Method in class com.bstek.dorado.data.RecordWrapper
取得上一个记录包装器
getPrevAction() - Method in interface com.bstek.dorado.action.Action
返回在本次请求中上一个被处理的Action对象
getProperty() - Method in interface com.bstek.dorado.data.Field
返回该字段对应的属性名.
getProperty(String) - Method in class com.bstek.dorado.utils.SystemVariable
读取系统环境变量。
getPropertyValue(Object, String[]) - Static method in class com.bstek.dorado.data.Record
getQueryDataset() - Method in class com.bstek.dorado.view.control.command.QueryCommand
返回被查询的数据集的ID
getQueryDatasetInstance() - Method in class com.bstek.dorado.view.control.command.QueryCommand
返回被查询的数据集的实例
getQueryMode() - Method in class com.bstek.dorado.view.control.command.QueryCommand
返回查询模式
getReadFields() - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
获得下拉框中需要从下拉选择的记录中读取的字段.
getReadFields() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
获得下拉框中需要从下拉选择的记录中读取的字段.
getRealPath() - Method in class com.bstek.dorado.action.mapping.ActionTarget
返回真正可利用的Path。
getRealPath() - Method in class com.bstek.dorado.common.fileloader.FileLoader
取得文件的实际位置。
getRecord() - Method in class com.bstek.dorado.data.RecordWrapper
取得被包装的记录
getRecord() - Method in class com.bstek.dorado.view.control.tree.RecordTreeNode
返回树节点绑定的记录对象.
getRecordFactory() - Method in class com.bstek.dorado.data.DatasetSupport
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.data.custom.CustomDataset
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.data.db.DBDataset
返回Record的创建工厂.
getRecordFactory() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回Record的创建工厂.
getRecordFilter() - Method in interface com.bstek.dorado.data.Dataset
获得Dataset内部使用的记录过滤器.
getRecordFilter() - Method in class com.bstek.dorado.data.DatasetAdapter
获得Dataset内部使用的记录过滤器.
getRecordFilter() - Method in class com.bstek.dorado.data.DatasetSupport
获得Dataset内部使用的记录过滤器.
getRecordId() - Method in class com.bstek.dorado.data.Record
取得当前记录的id.
getRecordState() - Method in interface com.bstek.dorado.data.Dataset
返回当前记录的状态
getRecordState() - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录的状态
getRecordState() - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录的状态
getRecordState() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录的状态
getRecursiveKeyFields() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
getRecursiveKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
getRecursiveKeyParameters() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
getRecursiveKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
getRendererType() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回表格单元格渲染器的类型
getRequeryPath() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得客户端收到调用完成指令后要重新请求的路径.
getRequest() - Method in class com.bstek.dorado.common.HttpDoradoContext
被封装的HttpServletRequest对象
getRequest() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得当前的HttpServletRequest对象.
getReturnRecords() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
取得本次数据更新操作完成后将要返回给客户端的记录的集合.
getRole() - Method in interface com.bstek.dorado.view.ViewModel
取得与视图模型相关的角色.
getRole() - Method in class com.bstek.dorado.view.ViewModelSupport
取得与视图模型相关的角色.
getRoleConfigs(Component) - Method in interface com.bstek.dorado.view.ViewModel
返回与给定的组件相关的角色配置项
getRoleConfigs(Component) - Method in class com.bstek.dorado.view.ViewModelSupport
返回与给定的组件相关的角色配置项
getRoot() - Method in class com.bstek.dorado.common.fileloader.FileLoader
取得根路径
getRoot() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
取得树的根节点对象。
getRoot() - Method in class com.bstek.dorado.view.control.tree.Tree
取得树的顶节点对象.
getRootLevel() - Method in class com.bstek.dorado.view.control.tree.DataTree
取得树的顶节点层对象.
getRootNode() - Method in interface com.bstek.dorado.utils.xml.XmlDocument
获得根节点
getRow() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前行的索引值。
getRowCount() - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
getRowCount
getRowHeight() - Method in class com.bstek.dorado.view.control.table.Table
返回表格数据行的高度
getRowSpan() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得该元素将占用自动表单中的多少行，该属性类似Table的RowSpan属性。
getRowSpan() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
返回当前元素(Element)的行跨度(rolSpan)属性值。
getScope() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Model的作用域范围
getScript() - Method in class com.bstek.dorado.view.EventHandler
取得事件脚本
getScrollMode() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格垂直滚动条的滚动方式.
getShort(int) - Method in interface com.bstek.dorado.data.Dataset
按short类型返回当前记录中某字段的值。
getShort(String) - Method in interface com.bstek.dorado.data.Dataset
按short类型返回当前记录中某字段的值。
getShort(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型返回当前记录中某字段的值。
getShort(int) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.data.ReadRecord
按short类型返回记录中某字段的值。
getShort() - Method in class com.bstek.dorado.utils.variant.Variant
按short类型读取数据
getShort(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按short类型读取数据
getShort(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按short类型读取数据
getShort(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型返回当前记录中某字段的值。
getShort(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型返回当前记录中某字段的值。
getShowDraggingTip() - Method in class com.bstek.dorado.view.control.ScrollBar
返回滚动条拖动时是否显示系统提示信息.
getSkin() - Method in interface com.bstek.dorado.view.ViewModel
返回视图模型使用的皮肤
getSkin() - Method in class com.bstek.dorado.view.ViewModelSupport
返回视图模型使用的皮肤
getSmallChange() - Method in class com.bstek.dorado.view.control.ScrollBar
取得当用户点击两个滚动按钮时引起的滚动量.
getSourceDataset() - Method in class com.bstek.dorado.view.data.DatasetReference
取得引用的源数据集
getSourceKeyFields() - Method in class com.bstek.dorado.data.db.JoinTable
取得用于建立关联的源表中的字段.
getSourceModule() - Method in class com.bstek.dorado.view.data.DatasetReference
返回引用的源数据集模块。
getSourceTable() - Method in class com.bstek.dorado.data.db.JoinTable
取得与关联表相对应的源表.
getSql() - Method in class com.bstek.dorado.data.db.AutoDBField
返回此Field的自定义SQL。
getSql() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset内部使用的SQL命令。
getSql() - Method in class com.bstek.dorado.data.db.DBStatement
取得SBStatement内部使用的SQL命令。
getSql() - Method in class com.bstek.dorado.data.db.SqlDataset
返回SQL命令。
getSql() - Method in class com.bstek.dorado.data.db.SqlMatchRule
取得自定义SQL.
getSqlDataType() - Method in class com.bstek.dorado.data.db.DBField
取得数据库中该字段的数据类型。
getState() - Method in interface com.bstek.dorado.data.Dataset
返回当前记录集的当前状态
getState() - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录集的当前状态
getState() - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录集的当前状态
getState() - Method in class com.bstek.dorado.data.ReadRecord
记录当前的状态
getState() - Method in interface com.bstek.dorado.view.ViewModel
取得当前状态
getState() - Method in class com.bstek.dorado.view.ViewModelSupport
取得当前状态
getStatus() - Method in class com.bstek.dorado.view.control.SubWindow
返回子窗体状态.
getStoreFileName(HttpServletRequest, String, MetaData) - Method in class com.bstek.dorado.biz.FileController
取得存储上传文件的文件名
getString(String) - Static method in class com.bstek.dorado.common.Setting
读取一个String型的配置信息
getString(String, String) - Static method in class com.bstek.dorado.common.Setting
读取一个String型的配置信息.如何该配置不存在则返回缺省值.
getString(String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个String型的配置信息
getString(String, String) - Static method in class com.bstek.dorado.common.UserConfig
读取一个String型的配置信息
getString(int) - Method in interface com.bstek.dorado.data.Dataset
按String类型返回当前记录中某字段的值。
getString(String) - Method in interface com.bstek.dorado.data.Dataset
按String类型返回当前记录中某字段的值。
getString(int) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型返回当前记录中某字段的值。
getString(int) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.data.ReadRecord
按String类型返回记录中某字段的值。
getString(Locale, String, String, Object[]) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(Locale, String, String, Object, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按给定的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object[]) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(DoradoContext, String, String, Object, Object, Object) - Method in class com.bstek.dorado.i18n.ResourceManager
按默认的地区与语种返回一个国际化资源字符串.
getString(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
按String方式读取一个参数 本方法回自动将字符串转化为Setting.xml中System.getProperty("file.encoding")所指定的编码格式.
getString() - Method in class com.bstek.dorado.utils.variant.Variant
按String类型读取数据
getString(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按String类型读取数据
getString(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按String类型读取数据
getString(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型返回当前记录中某字段的值。
getString(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型返回当前记录中某字段的值。
getStringValues(String) - Method in class com.bstek.dorado.utils.http.RequestHelper
返回参数值数组.
getStyle() - Method in interface com.bstek.dorado.view.control.Placeable
设置控件的风格设置
getStyle() - Method in class com.bstek.dorado.view.control.PlaceableControl
设置控件的风格设置
getStyle() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
设置控件的风格设置
getSubFile(int) - Method in class com.bstek.dorado.action.mapping.GlobalUnit
根据索引号得到一个子配置单元
getSubFileCount() - Method in class com.bstek.dorado.action.mapping.GlobalUnit
返回子配置单元的个数
getSubmitScope() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回Dataset的提交方式
getTab(int) - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得一个指定索引位置的标签项对象。
getTab(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得一个指定名称的标签项对象。
getTabCount() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得标签项的总数
getTabPlacement() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得多页标签所在的位置.
getTabSet() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回标签所属的TabSet对象
getTable() - Method in class com.bstek.dorado.data.db.BaseMatchRule
返回原始字段(originField)所属的表名。
getTable() - Method in class com.bstek.dorado.data.db.DBField
返回该字段所属的数据库物理表名.
getTable() - Method in class com.bstek.dorado.data.db.SortRule
返回原始字段(originField)所属的表别名.
getTabs() - Method in class com.bstek.dorado.view.control.tabset.TabSet
取得所有多页标签的集合对象。
getTag() - Method in class com.bstek.dorado.action.mapping.ActionConfig
取得自定义信息.此属性中的值用户可以自行解释,dorado不会做任何处理.
getTag() - Method in class com.bstek.dorado.action.mapping.ActionTarget
获得自定义信息。
getTag() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
用户自定义信息。
getTag() - Method in interface com.bstek.dorado.view.Element
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.ViewModelSupport
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.control.MenuItem
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.control.OutlookBarGroup
getTag
getTag() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.control.table.Column
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.control.tabset.TabElement
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.control.tree.TreeNode
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得元素的用户自定义信息。
getTag() - Method in interface com.bstek.dorado.view.data.ViewField
取得元素的用户自定义信息。
getTag() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得元素的用户自定义信息。
getTarget() - Method in class com.bstek.dorado.data.DatasetAdapter
返回适配器的目标Dataset
getTarget() - Method in class com.bstek.dorado.view.control.Menu
取得弹出式菜单需要刷新的目标框架.
getTarget() - Method in class com.bstek.dorado.view.control.command.Frame
返回在哪个目标框架中打开新页面.
getTarget() - Method in class com.bstek.dorado.view.control.tree.Tree
取得树状列表要刷新的目标框架.
getTarget() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得被适配的数据集
getText() - Method in class com.bstek.dorado.view.control.Label
取得标题的文本内容。
getTextPattern() - Method in class com.bstek.dorado.view.control.ProgressBar
返回文本格式。
getTitle() - Method in class com.bstek.dorado.view.control.GroupBox
获取组合框标题.
getTitle() - Method in class com.bstek.dorado.view.control.SubWindow
获取子窗体标题.
getTitle() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回组的标题，通常为文字描述信息。
getTitleClickAction() - Method in class com.bstek.dorado.view.control.SubWindow
返回当用户单击窗体标题栏时执行的操作.
getTitleDblClickAction() - Method in class com.bstek.dorado.view.control.SubWindow
返回当用户双击窗体标题栏时执行的操作.
getToIndex() - Method in class com.bstek.dorado.data.PagingHelper
返回当前页记录的结束序号。
getToolTip() - Method in class com.bstek.dorado.view.control.Button
返回按钮的弹出式提示.
getToolTip() - Method in class com.bstek.dorado.view.control.CheckBox
取得弹出式提示(ToolTip)。
getToolTip() - Method in class com.bstek.dorado.view.control.Editor
返回该编辑器的弹出式提示信息。
getToolTip() - Method in class com.bstek.dorado.view.control.RadioGroup
取得弹出式提示(ToolTip)。
getToolTip() - Method in class com.bstek.dorado.view.control.table.Column
取得该列的弹出式提示。
getToolTip() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回字段的弹出式提示信息.
getToolTip() - Method in interface com.bstek.dorado.view.data.ViewField
返回字段的弹出式提示信息.
getToolTip() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回字段的弹出式提示信息.
getTop() - Method in interface com.bstek.dorado.view.control.Placeable
返回控件距离父对象顶边的距离
getTop() - Method in class com.bstek.dorado.view.control.PlaceableControl
返回控件距离父对象顶边的距离
getTop() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
返回控件距离父对象顶边的距离
getTop() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架上部边距值.
getTotalRow() - Method in class com.bstek.dorado.data.PagingHelper
返回结果集的总记录数。
getTransaction() - Static method in class com.bstek.dorado.common.TransactionManager
获取当前线程中的事务.
getTransactionMode() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
取得事务模式
getTransactionMode() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
取得本次数据更新操作的事务模式.
getTreeColumn() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回具有数据展开功能的列.
getTreeLevel(String) - Method in class com.bstek.dorado.view.control.tree.DataTree
根据名称取得一个节点层
getTreeLevel(String) - Method in class com.bstek.dorado.view.control.tree.TreeLevel
根据名称取得一个子节点层
getTreeLevels() - Method in class com.bstek.dorado.view.control.tree.DataTree
返回所有节点层的集合
getTreeLevels() - Method in class com.bstek.dorado.view.control.tree.TreeLevel
返回所有子节点层的集合
getType() - Method in class com.bstek.dorado.action.mapping.ActionException
要捕捉的异常的名称。
getType() - Method in class com.bstek.dorado.view.data.CustomDataset
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.DODataset
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.DatasetReference
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.DatasetWrapper
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.FormDataset
取得视图数据集的类型。
getType() - Method in interface com.bstek.dorado.view.data.ViewDataset
取得视图数据集的类型。
getType() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得视图数据集的类型。
getTypeClass() - Method in class com.bstek.dorado.action.mapping.ActionException
要捕捉的异常的Class类型
getURL() - Method in class com.bstek.dorado.common.fileloader.FileLoader
取得文件的URL连接器。
getUnit() - Method in class com.bstek.dorado.action.mapping.ActionTarget
返回此对象所隶属的Unit。
getUnit() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
取得该Controller所属的Unit对象
getUnit(int) - Method in class com.bstek.dorado.action.mapping.Mapping
根据索引号取得一个子配置单元对象
getUnitCount() - Method in class com.bstek.dorado.action.mapping.Mapping
根据别名取得一个子配置单元对象
getUpdateDataHandler(HttpServletRequest) - Static method in class com.bstek.dorado.view.rpc.RPCHelper
获得一个数据提交过程的处理器
getUploadWorkDirectory(HttpServletRequest, MetaData) - Method in class com.bstek.dorado.biz.FileController
取得存放上传文件的工作目录
getValidatorFactory() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
获得数据校验器的构造工厂
getValidators() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得字段相关的所有校验器对象得集合对象.
getValidators() - Method in interface com.bstek.dorado.view.data.ViewField
取得字段相关的所有校验器对象得集合对象.
getValidators() - Method in class com.bstek.dorado.view.data.ViewLookupField
取得字段相关的所有校验器对象得集合对象.
getValue(int) - Method in interface com.bstek.dorado.data.Dataset
返回当前记录中某字段的值。
getValue(String) - Method in interface com.bstek.dorado.data.Dataset
返回当前记录中某字段的值。
getValue(int) - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.data.DatasetAdapter
返回当前记录中某字段的值。
getValue(int) - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.data.DatasetSupport
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.data.ReadRecord
返回记录中某字段的值。
getValue() - Method in class com.bstek.dorado.data.db.CommonMatchRule
返回匹配值.
getValue() - Method in class com.bstek.dorado.utils.variant.Variant
按Object类型读取数据
getValue(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按Object类型读取数据
getValue(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按Object类型读取数据
getValue() - Method in class com.bstek.dorado.view.control.Button
取得按钮的值.
getValue() - Method in class com.bstek.dorado.view.control.TextEditor
返回文本编辑器的默认值
getValue() - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
取得下拉框(DropDown)当前选择项的值。
getValue(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录中某字段的值。
getValue(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回当前记录中某字段的值。
getValueField() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
返回作为内部数值的字段
getValues() - Method in class com.bstek.dorado.view.data.validate.impl.ListValidator
取得校验器中的一组校验值
getVariant(String) - Method in class com.bstek.dorado.data.ParameterSet
根据键值并按Variant类型读取数据
getVariant(String) - Method in class com.bstek.dorado.data.ReadRecord
按Variant类型返回记录中某字段的值。
getVariant(String) - Method in class com.bstek.dorado.data.db.CaseInsensitiveVariantSet
Deprecated.
getVariant(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号并按Variant类型读取数据
getVariant(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值并按Variant类型读取数据
getViewDataset() - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
取得发送动态数据加载操作的Dataset.
getViewDataset(String) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
根据id取得一个相应的ViewModel中的Dataset
getViewMode() - Method in class com.bstek.dorado.view.control.MenuOutlookBarGroup
getViewMode
getViewModel() - Method in interface com.bstek.dorado.view.Component
取得视图模型对象。
getViewModel(PageContext) - Static method in class com.bstek.dorado.view.JspHelper
根据传入JSP上下文对象的获得当前的ViewModel实例
getViewModel() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得视图模型对象。
getViewModel() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得与客户端对应的ViewModel实例
getVisibility() - Method in class com.bstek.dorado.data.RecordIterator
返回迭代器的记录可见性
getVisibility() - Method in class com.bstek.dorado.view.control.autoform.FormElement
取得该元素是否在页面上可见。
getVisibleFields() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
取得动态下拉框中指定要显示的数据列。
getWidth() - Method in interface com.bstek.dorado.view.control.Placeable
返回控件的宽度
getWidth() - Method in class com.bstek.dorado.view.control.PlaceableControl
返回控件的宽度
getWidth() - Method in class com.bstek.dorado.view.control.PlaceableDataControl
返回控件的宽度
getWidth() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
取得AutoForm的宽度.
getWidth() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
取得组的宽度值。
getWidth() - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架的宽度值.
getWidth() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
返回下拉框的默认宽度
getWidth() - Method in class com.bstek.dorado.view.control.table.DataColumn
取得列显示的宽度。
getWrappedDataset() - Method in class com.bstek.dorado.view.data.DatasetWrapper
取得被包装的源Dataset
getWriteFields() - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
获得下拉框中需要为对应目标数据集赋值的字段.
getWriteFields() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
获得下拉框中需要为对应目标数据集赋值的字段.
getXmlDocument() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得客户端发送的XML信息
getXmlProcessor() - Static method in class com.bstek.dorado.utils.xml.XmlFactory
getXmlProcesser
group - Variable in class com.bstek.dorado.view.control.autoform.FormElement
组
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


H-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

H

HIDDEN - Static variable in class com.bstek.dorado.view.control.DataPilot
HIDDEN - Static variable in class com.bstek.dorado.view.control.SubWindow
窗体状态 - 隐藏
HIDDEN - Static variable in class com.bstek.dorado.view.control.autoform.FormElement
HORIZONTAL - Static variable in class com.bstek.dorado.view.control.RadioGroup
HORIZONTAL
HORIZONTAL - Static variable in class com.bstek.dorado.view.control.autoform.AutoForm
组的布局方式 - 水平方式
HttpContextFactory - class com.bstek.dorado.common.HttpContextFactory.
默认的根据ServletRequest来获取DoradoContext的工厂
HttpDoradoContext - class com.bstek.dorado.common.HttpDoradoContext.
用于封装HttpRequest的上下文对象
handleRPC(String, ParameterSet, ParameterSet) - Method in interface com.bstek.dorado.view.ViewModel
处理一个远程过程调用操作
handleRPC(String, ParameterSet, ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
处理一个远程过程调用操作
handleUpdate(String, ParameterSet) - Method in interface com.bstek.dorado.view.ViewModel
处理一个更新操作
handleUpdate(String, ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
处理一个更新操作
hasNext() - Method in class com.bstek.dorado.data.RecordIterator
返回 true 表示是否存在下一条记录.
hashCode() - Method in class com.bstek.dorado.utils.collection.ObjectList
Returns a hash code value for the object.
hashCode() - Method in class com.bstek.dorado.utils.variant.Variant
Returns a hash code value for the object.
hashCode() - Method in class com.bstek.dorado.utils.variant.VariantSet
Returns a hash code value for the object.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


I-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

I

IGNORE - Static variable in class com.bstek.dorado.view.data.validate.impl.RangeValidator
范围校验类型 - 忽略
IN - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
在...之中
INSERT - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - INSERT
INT - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - int型。
INT_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - int型。
IllegalValueException - exception com.bstek.dorado.view.data.validate.IllegalValueException.
非法值异常。
IllegalValueException() - Constructor for class com.bstek.dorado.view.data.validate.IllegalValueException
构造器
IllegalValueException(String) - Constructor for class com.bstek.dorado.view.data.validate.IllegalValueException
构造器
IllegalValueException(Throwable) - Constructor for class com.bstek.dorado.view.data.validate.IllegalValueException
构造器
Index - class com.bstek.dorado.data.Index.
记录集的索引对象
Index(Dataset, String[]) - Constructor for class com.bstek.dorado.data.Index
构造器 根据给定的Dataset和字段创建索引
InvalidPropertyValueException - exception com.bstek.dorado.utils.InvalidPropertyValueException.
无效属性值的异常
InvalidPropertyValueException() - Constructor for class com.bstek.dorado.utils.InvalidPropertyValueException
InvalidPropertyValueException
InvalidPropertyValueException(String) - Constructor for class com.bstek.dorado.utils.InvalidPropertyValueException
InvalidPropertyValueException
InvalidPropertyValueException(String, String) - Constructor for class com.bstek.dorado.utils.InvalidPropertyValueException
InvalidPropertyValueException
inTransaction() - Method in interface com.bstek.dorado.common.Transaction
当前是否存在一个未决的事务.即是否以调用beginTransaction()启动了新的事务,且尚未调用 commit()或rollback().
indexOf(Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回给定的键值对应的索引号。
indexOf(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
返回给定的键值对应的索引号。
indexToName(int) - Method in class com.bstek.dorado.data.FieldSet
根据Field的索引号得到Field的名称
indexToName(int) - Method in class com.bstek.dorado.data.ParameterSet
返回给定的索引号对应的键值.
indexToName(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
返回给定的索引号对应的键值.
info(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_INFO 的字符串记录到日志文件里。
init(ActionConfig, ServletRequest) - Method in interface com.bstek.dorado.action.Action
初始化Action对象
init() - Static method in class com.bstek.dorado.action.mapping.Mapping
初始化所有的Mapping信息。
init() - Static method in class com.bstek.dorado.common.log.Log
初始化日志记录器，这个记录器将负责控制日志信息。
init(DoradoContext, XmlNode) - Method in interface com.bstek.dorado.data.Dataset
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.DatasetAdapter
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.DatasetSupport
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.data.db.SqlDataset
根据一个XML节点对象自动配置本Dataset。
init() - Static method in class com.bstek.dorado.module.ModuleManager
初始化
init(DoradoContext, XmlNode) - Method in interface com.bstek.dorado.view.Component
跟XML配置初始化
init(int) - Method in interface com.bstek.dorado.view.ViewModel
视图模型初始化
init(int) - Method in class com.bstek.dorado.view.ViewModelSupport
视图模型初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.Calendar
Deprecated.
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.Menu
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.OutlookBar
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
根据XML的配置初试化一个表单元素
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.FormElement
根据XML的配置初试化一个表单元素
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
根据XML的配置初试化一个组
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.LabelFormElement
根据XML的配置初试化一个表单元素
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
根据XML的配置初试化一个表单元素
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.TextEditorFormElement
根据XML的配置初试化一个表单元素
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.CommandQueue
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.RPCCommand
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.RequestCommand
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
init(int) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.table.Column
列初始化
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.table.Table
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.tabset.TabSet
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.tree.DataTree
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.tree.Tree
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.DatasetWrapper
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
根据一个XML节点对象自动配置本Dataset。
init(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
根据一个XML节点对象自动配置本Dataset。
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
init(HttpServletRequest) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
初试化远程方法调用的处理类
init(HttpServletRequest) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
initColumn(DoradoContext, Column, XmlNode) - Method in class com.bstek.dorado.view.control.table.DataTable
初始化列
initColumn(DoradoContext, Column, XmlNode) - Method in class com.bstek.dorado.view.control.table.Table
初始化列
initControl(String, Control) - Method in class com.bstek.dorado.view.ViewModelSupport
Deprecated.
initControls() - Method in class com.bstek.dorado.view.ViewModelSupport
初试化控件。
initControls() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
初试化控件。 此方法用于提供给派生类进行重载。
initDataset(Dataset) - Method in class com.bstek.dorado.module.DefaultModule
Deprecated.
initDataset(Dataset) - Method in class com.bstek.dorado.module.ModuleSupport
Deprecated.
initDataset(ViewDataset) - Method in class com.bstek.dorado.view.DefaultViewModel
初试化一个ViewDataset
initDataset(ViewDataset) - Method in class com.bstek.dorado.view.ViewModelSupport
初试化一个ViewDataset
initDatasets() - Method in class com.bstek.dorado.view.ViewModelSupport
初试化数据集。
initDatasets() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
初试化数据集。 此方法用于提供给派生类进行重载。
initFileUpload(HttpServletRequest, DiskFileUpload) - Method in class com.bstek.dorado.biz.FileController
设定 DiskFileUpload 的相关属性.
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.CheckBoxFormElement
初始化自动表单的内部控件
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.FormElement
初始化自动表单的内部控件
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.LabelFormElement
初始化自动表单的内部控件
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
初始化自动表单的内部控件
initInnerControls() - Method in class com.bstek.dorado.view.control.autoform.TextEditorFormElement
初始化自动表单的内部控件
initListener(XmlNode) - Method in class com.bstek.dorado.data.DatasetSupport
根据XML节点初试化监听器
initListener(XmlNode) - Method in class com.bstek.dorado.view.data.DatasetWrapper
根据XML节点初试化监听器
initLookupFields(Dataset) - Method in class com.bstek.dorado.view.ViewModelSupport
初试化某个Dataset中的Lookup字段
initLookupFields(Dataset) - Method in class com.bstek.dorado.view.data.DatasetWrapper
初试化某个Dataset中的Lookup字段
initNewRecord(Record) - Method in class com.bstek.dorado.data.DatasetSupport
initNewRecord
initNewRecord(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
initNewRecord
initValidator(Validator, XmlNode) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
initValidator
insertRecord() - Method in interface com.bstek.dorado.data.Dataset
添加一条记录。
insertRecord(int) - Method in interface com.bstek.dorado.data.Dataset
添加一条记录并初始化新记录的状态。
insertRecord() - Method in class com.bstek.dorado.data.DatasetAdapter
添加一条记录。
insertRecord(int) - Method in class com.bstek.dorado.data.DatasetAdapter
添加一条记录并初始化新记录的状态。
insertRecord() - Method in class com.bstek.dorado.data.DatasetSupport
添加一条记录。
insertRecord(int) - Method in class com.bstek.dorado.data.DatasetSupport
添加一条记录并初始化新记录的状态。
insertRecord(Record) - Method in class com.bstek.dorado.data.RecordSet
插入一条记录
insertRecord() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
添加一条记录。
insertRecord(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
添加一条记录并初始化新记录的状态。
internalExecute() - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
internalExecute() - Method in class com.bstek.dorado.view.rpc.LoadDataRPCHandler
internalExecute() - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
internalLoad(boolean, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
internalLoad
invokeAction(String, HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.action.Controller
调用Controller中名为actionName的Action。
isAllowPushDown() - Method in class com.bstek.dorado.view.control.Button
返回按钮是否允许按钮被按下.
isAlwaysPerform() - Method in class com.bstek.dorado.view.control.command.UpdateCommand
是否总是允许执行.即不管是否存在需要提交的数据都强行的执行提交操作.
isAnimated() - Method in class com.bstek.dorado.view.control.OutlookBar
isAnimated
isAsync() - Method in class com.bstek.dorado.view.control.command.QueryCommand
是否以异步方式执行远程过程调用
isAsync() - Method in class com.bstek.dorado.view.control.command.RPCCommand
是否以异步方式执行远程过程调用
isAsync() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否采用异步方式执行动态数据加载.
isAsync() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否采用异步方式执行动态数据加载.
isAutoCreateDiv() - Method in class com.bstek.dorado.view.control.tabset.Tab
是否自动创建与该标签页相关联的层.
isAutoCreateFields() - Method in interface com.bstek.dorado.data.Dataset
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
isAutoCreateFields() - Method in class com.bstek.dorado.data.DatasetAdapter
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.
isAutoCreateFields() - Method in class com.bstek.dorado.data.DatasetSupport
返回是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
注意: 如果Dataset中尚未定义任何Field, 不论此属性如何设置Dataset总是会尝试自动创建Field.
isAutoDropDown() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
返回当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。
isAutoLoadData() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。
isAutoLoadData() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。
isAutoLoadPage() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否启用客户端Dataset的自动状态数据功能。
isAutoLoadPage() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回是否启用客户端Dataset的自动状态数据功能。
isAutoLoadPage() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否启用客户端Dataset的自动状态数据功能。
isAutoScroll() - Method in class com.bstek.dorado.view.control.tabset.Tab
isAutoScroll
isAutoSyncRecordWithDragging() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
在节点拖放后是否自动对相应的记录进行数据同步.
isBaseDataType(Class) - Static method in class com.bstek.dorado.utils.variant.DataType
判断一个Class类型是否是基本的dorado可以直接处理的简单类型
isCachable() - Method in interface com.bstek.dorado.view.control.dropdown.CachableDropDown
取得该下拉框是否支持缓存。
isCachable() - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
取得该下拉框是否支持缓存。
isCachable() - Method in class com.bstek.dorado.view.control.tabset.FrameTab
返回是否允许缓存Frame内容
isCenter() - Method in class com.bstek.dorado.view.control.command.Frame
返回目标框架新页面是否自动居中对齐.
isCheckable() - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
返回该层节点是否是可复选的
isCheckable() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
返回树节点前面是否有复选框可以被选择
isChecked() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
返回当前树节点是否已经被选中
isClearSelectionOnSuccess() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回提交成功后是否清除选中的Dataset记录。
isConfirmCancel() - Method in class com.bstek.dorado.view.control.DataPilot
取得是否提示用户确认取消操作。
isConfirmCancel() - Method in class com.bstek.dorado.view.control.table.DataTable
返回用户在客户端对记录进行取消操作时是否有确认提示。
isConfirmDelete() - Method in class com.bstek.dorado.view.control.DataPilot
返回是否提示用户确认删除操作。
isConfirmDelete() - Method in class com.bstek.dorado.view.control.table.DataTable
返回用户在客户端删除记录时是否有确认提示。
isContextRelative() - Method in class com.bstek.dorado.action.mapping.ActionTarget
此对象的Path属性所描述的URL是否是一个相对路径，此属性的默认值是true。
isControlLazyLoad() - Method in interface com.bstek.dorado.view.ViewModel
返回视图模型是否支持控件的延时加载.
isControlLazyLoad() - Method in class com.bstek.dorado.view.ViewModelSupport
返回视图模型是否支持控件的延时加载.
isDeleteSelectionOnSuccess() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回对象提交成功后是否删除客户端Dataset中已经选中的记录。
isDeleted() - Method in class com.bstek.dorado.data.Record
该记录是否已被删除
isDescent() - Method in class com.bstek.dorado.data.db.SortRule
返回是否按照降序进行排序.
isDisabled() - Method in class com.bstek.dorado.view.control.Button
返回按钮是否处于不可用状态.
isDisabled() - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
isDisabled
isDisabled() - Method in class com.bstek.dorado.view.control.MenuItem
返回菜单项是否无效.
isDisabled() - Method in class com.bstek.dorado.view.control.command.Command
isDisabled
isDisabled() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回当前标签项表格是否被禁止，被禁止的标签项上所有的元素都无法操作。
isDistinct() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
是否是用distinct关键字执行SQL查询
isDown() - Method in class com.bstek.dorado.view.control.Button
返回按钮在初始化的时候是否是被按下的状态.
isDraggable() - Method in class com.bstek.dorado.view.control.SplitPanel
是否允许拖动
isDraggable() - Method in class com.bstek.dorado.view.control.SubWindow
返回是否允许通过拖动改变位置.
isDraggable() - Method in class com.bstek.dorado.view.control.tree.Tree
返回树状列表的节点是否允许拖动.
isEditable() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格是否允许用户编辑。
isEmpty(String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
判断字符串是否为null或为"".
isEmpty(String) - Static method in class com.bstek.dorado.utils.StringHelper
判断是否一个无效的字符串。
isEnabled() - Method in class com.bstek.dorado.data.db.CommonMatchRule
返回整个匹配规则是否有效。
isEnabled() - Method in class com.bstek.dorado.data.db.SortRule
取得该排序规则是否有效。
isEscape() - Method in class com.bstek.dorado.view.control.Label
isEscape
isEscapeEnabled() - Method in class com.bstek.dorado.data.db.CommonMatchRule
返回是否要启用本匹配规则上的可逃逸功能.
isExecuted() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
此处理类是否已经执行过了
isExpanded() - Method in class com.bstek.dorado.view.control.GroupBox
组合框是否已展开
isExpanded() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
本组的内容是否已展开.
isExpanded() - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
返回当在页面打开时该节点是否已被自动展开
isExpanded() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
返回是否自动展开本层的节点
isFilterOnOpen() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。
isFirst() - Method in interface com.bstek.dorado.data.Dataset
当前位置是否已到达当前页的顶端。
isFirst() - Method in class com.bstek.dorado.data.DatasetAdapter
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

isFirst() - Method in class com.bstek.dorado.data.DatasetSupport
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

isFirst() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
当前位置是否已到达当前页的顶端。

此时Dataset已经在试图继续向前移动当前记录的过程失败. 亦即当Dataset的当前记录从第二条记录转到第一条记录时isFirst仍然是false, 只有当Dataset试图继续向前移动当前记录后isFirst才会变为true, 此时Dataset的当前记录仍然是第一条记录.

isFirstGroupAsHeader() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
返回AutoForm的第一个组是否在页面上单独占用一行作为头行.
isFitWidth() - Method in class com.bstek.dorado.view.control.MenuBar
返回是否自动调整菜单按钮的宽度以适应整个菜单栏的宽度.
isFixed() - Method in class com.bstek.dorado.view.control.dropdown.DropDown
返回是否禁止用户不通过下拉选择而直接输入。
isFlushDataOnSuccess() - Method in class com.bstek.dorado.view.control.command.DatasetInfo
返回提交成功后是否刷新客户端Dataset中的数据。
isGroup() - Method in class com.bstek.dorado.data.db.AutoDBField
返回AutoSqlDataset查询SQL的group子句中是否包含该字段.
isHasChild() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
返回节点是否有子节点,默认为true.
isHasChild() - Method in class com.bstek.dorado.view.control.tree.TreeNode
返回当前树节点是否有子节点。
isHeaderClickable() - Method in class com.bstek.dorado.view.control.table.DataColumnGroup
返回数据表格的该列标题是否支持单击操作。
isHeaderClickable() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回数据表格的该列标题是否支持单击操作。
isHighlightSelection() - Method in class com.bstek.dorado.view.control.table.DataTable
返回是否高亮显示表格中的当前记录.
isHighlightSelection() - Method in class com.bstek.dorado.view.control.tree.Tree
返回通过复选框选中记录后是否将记录进行高亮显示，默认为true.
isIgnored() - Method in interface com.bstek.dorado.view.Component
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
isIgnored() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否忽略该控件对象，如果为True则不在页面上生成该控件。
isInsertOnEmpty() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回在数据集在客户端初试化时如果数据集为空是是否自动插入新记录.
isInsertOnEmpty() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
返回是否需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效.
isLast() - Method in interface com.bstek.dorado.data.Dataset
当前位置是否已到达当前页的尾端。
isLast() - Method in class com.bstek.dorado.data.DatasetAdapter
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

isLast() - Method in class com.bstek.dorado.data.DatasetSupport
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

isLast() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
当前位置是否已到达当前页的尾端。

此时isLast表示Dataset已经在试图继续向后移动当前记录的过程失败. 亦即当Dataset的当前记录从倒数第二条记录转到倒数第一条记录时isLast仍然是false, 只有当Dataset试图继续向后移动当前记录后isLast才会变为true, 此时Dataset的当前记录仍然是倒数第一条记录.

isLastGroupAsFooter() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
返回AutoForm的最后一个组是否单独占一行作为尾行.
isMapType(Class) - Static method in class com.bstek.dorado.data.DOUtils
判断某Class是否是java.util.Map的派生类.
isNoClient() - Method in interface com.bstek.dorado.view.data.ViewDataset
返回是否不在客户端创建记录集对象。
isNoClient() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
isNoClient
isNoWrap() - Method in class com.bstek.dorado.view.control.table.DataColumn
返回是否允许该列的内容换行显示。
isNotEmpty(String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
判断字符串是否非空.
isNotEmpty(String) - Static method in class com.bstek.dorado.utils.StringHelper
判断是否一个有效的字符串。
isNull(int) - Method in interface com.bstek.dorado.data.Dataset
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in interface com.bstek.dorado.data.Dataset
判断当前记录中某字段的值是否为空(null)。
isNull(int) - Method in class com.bstek.dorado.data.DatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.data.DatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNull(int) - Method in class com.bstek.dorado.data.DatasetSupport
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.data.DatasetSupport
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.data.ReadRecord
判断记录中某字段的值是否为空(null)。
isNull() - Method in class com.bstek.dorado.utils.variant.Variant
是否为空(null)
isNull(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
判断给定索引号下的数值是否为空(null)
isNull(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
判断给定键值下的数值是否为空(null)
isNull(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNull(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
判断当前记录中某字段的值是否为空(null)。
isNullable() - Method in interface com.bstek.dorado.data.Field
返回字段是否为空。
isPointFilled(int, int) - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
isPointFilled
isReadOnly() - Method in class com.bstek.dorado.view.control.Editor
返回编辑框是否只读。
isReadOnly() - Method in class com.bstek.dorado.view.control.autoform.AutoForm
返回AutoForm是否只读.
isReadOnly() - Method in class com.bstek.dorado.view.control.table.DataTable
返回数据表格是否是只读。
isReadOnly() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回列是否只读。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回该字段是否只读.
isReadOnly() - Method in interface com.bstek.dorado.view.data.ViewDataset
取得数据集的只读属性。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
取得数据集的只读属性。
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
取得数据集的只读属性。
isReadOnly() - Method in interface com.bstek.dorado.view.data.ViewField
返回该字段是否只读.
isReadOnly() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回该字段是否只读.
isRecordVisible(Record) - Method in class com.bstek.dorado.data.DatasetSupport
判断指定的记录对象是不是可见记录.
isRecordVisible(Record) - Method in interface com.bstek.dorado.data.RecordFilter
判断一条记录是否可见
isRedirect() - Method in class com.bstek.dorado.action.mapping.ActionForward
是否以sendRedirect的方式转向新的path。
isResizable() - Method in class com.bstek.dorado.view.control.SubWindow
返回是否允许改变大小.
isResizable() - Method in class com.bstek.dorado.view.control.command.Frame
返回新窗口是否支持用户调整窗口尺寸.
isResizable() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回是否支持客户端用户对该列进行宽度调整操作。
isRetrieveAfterUpdate() - Method in class com.bstek.dorado.data.db.DBDataset
是否需要在完成某条记录的更新后对该记录进行重新查询.
isSafe() - Method in class com.bstek.dorado.action.mapping.ControllerConfig
返回用户访问视图页面时是否对用户身份进行检验。
isSafe() - Method in interface com.bstek.dorado.view.ViewModel
返回用户访问视图页面时是否对用户身份进行检验。
isSafe() - Method in class com.bstek.dorado.view.ViewModelSupport
返回用户访问视图页面时是否对用户身份进行检验。
isSelectAllField() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回是否检索出AutoSqlDataset对应的主表(originTable)中所有的字段。
isShowBevel() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回是否显示组的边框线，缺省为显示。
isShowBorder() - Method in class com.bstek.dorado.view.control.MenuBar
返回是否显示菜单栏的边框.
isShowButtons() - Method in class com.bstek.dorado.view.control.SplitPanel
返回是否显示视图分割栏上的快捷按钮.
isShowCloseButton() - Method in class com.bstek.dorado.view.control.SubWindow
返回是否显示关闭系统按钮.
isShowColumnHeader() - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
返回是否显示数据集下拉框中数据列的标题行。
isShowColumnHeader() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回是否显示数据集下拉框中数据列的标题行。
isShowExpandButton() - Method in class com.bstek.dorado.view.control.GroupBox
是否显示展开按钮
isShowFooter() - Method in class com.bstek.dorado.view.control.table.Table
取得是否显示表格的汇总栏，默认是显示。
isShowFrame() - Method in class com.bstek.dorado.view.control.tabset.TabSet
返回是否显示多页标签的外框架。
isShowGotoButton() - Method in class com.bstek.dorado.view.control.PagePilot
返回是否显示跳转到按钮(GotoButton)。
isShowHScrollBar() - Method in class com.bstek.dorado.view.control.table.DataTable
返回是否显示横向滚动栏
isShowHeader() - Method in class com.bstek.dorado.view.control.table.Table
返回是否显示表格的标题栏，默认是显示。
isShowIndicator() - Method in class com.bstek.dorado.view.control.table.DataTable
返回在数据表格中是否显示表格指示器箭头。
isShowLabel() - Method in class com.bstek.dorado.view.control.autoform.FormElement
返回是否显示字段标题。
isShowLoadingTip() - Method in class com.bstek.dorado.view.control.command.QueryCommand
命令执行时是否显示提示窗口
isShowLoadingTip() - Method in class com.bstek.dorado.view.control.command.RPCCommand
命令执行时是否显示提示窗口
isShowLoadingTip() - Method in interface com.bstek.dorado.view.data.ViewDataset
执行动态数据加载时是否显示提示窗口
isShowLoadingTip() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
执行动态数据加载时是否显示提示窗口
isShowMaximizeButton() - Method in class com.bstek.dorado.view.control.SubWindow
返回是否显示最大化按钮.
isShowMinimizeButton() - Method in class com.bstek.dorado.view.control.SubWindow
返回是否显示最小化按钮.
isShowPageInfo() - Method in class com.bstek.dorado.view.control.PagePilot
返回是否显示页信息。
isShowText() - Method in class com.bstek.dorado.view.control.ProgressBar
返回是否显示文本信息。
isShowVScrollBar() - Method in class com.bstek.dorado.view.control.table.DataTable
返回是否显示纵向滚动栏
isSortable() - Method in class com.bstek.dorado.view.control.table.EditableColumn
返回是否支持客户端用户对该列进行排序操作。
isStatusbar() - Method in class com.bstek.dorado.view.control.command.Frame
返回新窗口是否有状态栏.
isSucceed() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得本次远程调用是否已经成功.
isSupportsPaging() - Method in class com.bstek.dorado.view.data.DODataset
返回是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.
isSupportsSum() - Method in class com.bstek.dorado.view.data.ViewBaseField
取得是否允许数据集自动在Client端统计该字段的合计值.
isSupportsSum() - Method in interface com.bstek.dorado.view.data.ViewField
取得是否允许数据集自动在Client端统计该字段的合计值.
isSupportsSum() - Method in class com.bstek.dorado.view.data.ViewLookupField
isUpdatable() - Method in class com.bstek.dorado.data.db.DBField
返回该字段是否可向数据库中更新
isUseSqlParameter() - Method in class com.bstek.dorado.data.db.BaseMatchRule
是否在生成SQL时使用数据库预编译参数
isValueLegal(String, String) - Static method in class com.bstek.dorado.utils.StringHelper
判断一个字符串中是否未出现指定的一组无效字符
isValueProtected() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回字段是否有数据保护功能
isValueProtected() - Method in interface com.bstek.dorado.view.data.ViewField
返回字段是否有数据保护功能
isValueProtected() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回字段是否有数据保护功能
isVisible() - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
isVisible
isVisible() - Method in class com.bstek.dorado.view.control.MenuItem
取得菜单项是否可见.
isVisible() - Method in class com.bstek.dorado.view.control.autoform.FormGroup
返回组是否可见，不可见时将不在页面上创建该对象。
isVisible() - Method in class com.bstek.dorado.view.control.table.Column
返回表格中该列是否可见
isVisible() - Method in class com.bstek.dorado.view.control.tabset.TabElement
返回标签项表格是否可见。
isVisible() - Method in class com.bstek.dorado.view.data.ViewBaseField
返回字段是否在页面上可见.
isVisible() - Method in interface com.bstek.dorado.view.data.ViewField
返回字段是否在页面上可见.
isVisible() - Method in class com.bstek.dorado.view.data.ViewLookupField
返回字段是否在页面上可见.
items() - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
取得所有静态下拉框的数据选择项的集合对象。
iterator() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回迭代器
iterator() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回迭代器
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


J-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

J

JSP_EXCEPTION_KEY - Static variable in class com.bstek.dorado.action.Constants
用于在Request中保存当前的例外对象Attribute键值
JoinTable - class com.bstek.dorado.data.db.JoinTable.
用于描述AutoSqlDataset的关联表信息的对象.
JoinTable(String) - Constructor for class com.bstek.dorado.data.db.JoinTable
构造器.
JspHelper - class com.bstek.dorado.view.JspHelper.
用于辅助dorado的JSP开发的工具类
joins() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset所有Join的集合对象。
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


K-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

K

KeyNotExistException - exception com.bstek.dorado.utils.collection.KeyNotExistException.
无效键值异常
KeyNotExistException(Object) - Constructor for class com.bstek.dorado.utils.collection.KeyNotExistException
DuplicateObjectKeyException
keyFields - Variable in class com.bstek.dorado.data.db.DBDataset
keyList() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回List
keyList() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回List
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


L-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

L

LESS - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
小于
LESSEQUAL - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
小于等于
LIKE - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
相似
LOGGER_NAME - Static variable in class com.bstek.dorado.common.log.Log
默认的系统LOG名称
LONG - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - long型。
LONG_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - long型。
Label - class com.bstek.dorado.view.control.Label.
标签对象
Label(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Label
构造器
LabelFormElement - class com.bstek.dorado.view.control.autoform.LabelFormElement.
文本标签型的表单元素
LabelFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.LabelFormElement
构造器
LayoutInfo - class com.bstek.dorado.view.control.autoform.LayoutInfo.
AutoForm布局方式类
LayoutInfo() - Constructor for class com.bstek.dorado.view.control.autoform.LayoutInfo
LengthValidator - class com.bstek.dorado.view.data.validate.impl.LengthValidator.
长度校验器 用于校验一个数据(一般指字符串)的长度是否有效的校验器.
LengthValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.LengthValidator
ListDropDown - class com.bstek.dorado.view.control.dropdown.ListDropDown.
列表下拉框
ListDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.ListDropDown
构造器
ListValidator - class com.bstek.dorado.view.data.validate.impl.ListValidator.
List值的校验对象
对于是否属于某一组值的校验
ListValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.ListValidator
LoadDataRPCHandler - class com.bstek.dorado.view.rpc.LoadDataRPCHandler.
用于处理客户端发送的动态数据加载操作的处理类
LoadDataRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.LoadDataRPCHandler
LoadXmlPropertyException - exception com.bstek.dorado.utils.xml.LoadXmlPropertyException.
加载XML属性时发生的异常
LoadXmlPropertyException() - Constructor for class com.bstek.dorado.utils.xml.LoadXmlPropertyException
LoadXmlPropertyException
LoadXmlPropertyException(String) - Constructor for class com.bstek.dorado.utils.xml.LoadXmlPropertyException
LoadXmlPropertyException
LoadXmlPropertyException(Throwable) - Constructor for class com.bstek.dorado.utils.xml.LoadXmlPropertyException
LoadXmlPropertyException
LocaleHelper - class com.bstek.dorado.i18n.LocaleHelper.
用于定义地区与语种的辅助工具类
Log - class com.bstek.dorado.common.log.Log.
日志记录器。
LookupField - class com.bstek.dorado.data.LookupField.
支持Lookup功能的Field。
LookupField(String) - Constructor for class com.bstek.dorado.data.LookupField
构造器
load() - Static method in class com.bstek.dorado.common.Setting
装载配置文件。
load() - Static method in class com.bstek.dorado.common.UserConfig
装载配置文件。
load() - Method in interface com.bstek.dorado.data.Dataset
根据已设定的条件读取外部数据。
load(boolean) - Method in interface com.bstek.dorado.data.Dataset
Deprecated.
load() - Method in class com.bstek.dorado.data.DatasetAdapter
根据已设定的条件读取外部数据。
load(boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
根据已设定的条件读取外部数据。
load() - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件读取外部数据。
load(boolean) - Method in class com.bstek.dorado.data.DatasetSupport
根据已设定的条件读取外部数据。
load(ResultSet) - Method in class com.bstek.dorado.data.db.DBDataset
将ResultSet中的数据自动读取到Dataset中.
load(ResultSet, boolean) - Method in class com.bstek.dorado.data.db.DBDataset
将ResultSet中的数据自动读取到Dataset中.
loadAttributies(XmlNode, Object) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
loadAttributies(XmlNode, Object, String) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
loadAttributies(XmlNode, Object, String[]) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有attribute中的值到对象的属性中。
loadChildLevels(TreeLevel, XmlNode, DoradoContext) - Method in class com.bstek.dorado.view.control.tree.DataTree
加载子节点层
loadChildNodes(XmlNode, Object) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildNodes(XmlNode, Object, String) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildNodes(XmlNode, Object, String[]) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildProperties(XmlNode, Object) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到对象的属性中。
loadChildProperties(XmlNode, Properties) - Static method in class com.bstek.dorado.utils.xml.XmlConfigUtils
根据名称自动读取一个XML节点下的所有子节点中的值到Properties对象中。
loadData(Dataset, boolean) - Method in class com.bstek.dorado.module.ModuleSupport
Deprecated.
loadEventConfig(DoradoContext) - Method in class com.bstek.dorado.view.ViewModelSupport
根据XML中的配置初试化视图模型的事件定义。
loadGroups(DoradoContext, XmlNode) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
加载组
loadItems(DoradoContext, XmlNode, MenuItem) - Method in class com.bstek.dorado.view.control.Menu
加载菜单项
loadNodes() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
根据绑定的记录集导入树节点
loadNodes(TreeNode, int) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
loadNodes() - Method in class com.bstek.dorado.view.control.tree.DataTree
加载根节点以下的子节点。
loadNodes(TreeNode, TreeLevel) - Method in class com.bstek.dorado.view.control.tree.DataTree
loadNodes(DoradoContext, XmlNode, TreeNode) - Method in class com.bstek.dorado.view.control.tree.Tree
加载树节点
loadedPages() - Method in class com.bstek.dorado.data.RecordSet
返回所有已加载的页的集合
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


M-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

M

MAX - Static variable in class com.bstek.dorado.data.db.AggregateMode
求字段的最大值
MAXIMIZE - Static variable in class com.bstek.dorado.view.control.SubWindow
窗体状态 - 最大化
MIN - Static variable in class com.bstek.dorado.data.db.AggregateMode
求字段的最小值
MINIMIZE - Static variable in class com.bstek.dorado.view.control.SubWindow
窗体状态 - 最小化
MODAL_DIALOG - Static variable in class com.bstek.dorado.view.control.command.Frame
在一个模态对话框窗口中打开新页面.
MODELESS_DIALOG - Static variable in class com.bstek.dorado.view.control.command.Frame
在一个非模态对话框窗口中打开新页面.
MODULES_ATTRIBUTE_KEY - Static variable in class com.bstek.dorado.module.ModuleManager
Mapping - class com.bstek.dorado.action.mapping.Mapping.
用于管理所有Mapping配置信息的对象
Mapping() - Constructor for class com.bstek.dorado.action.mapping.Mapping
构造器
MasterDetailLink - class com.bstek.dorado.view.data.MasterDetailLink.
描述主从数据集连接关系的对象.
MasterDetailLink() - Constructor for class com.bstek.dorado.view.data.MasterDetailLink
构造器
MasterDetailLink(ViewDataset, String, String) - Constructor for class com.bstek.dorado.view.data.MasterDetailLink
构造器
MatchRule - interface com.bstek.dorado.data.db.MatchRule.
用于描述AutoSqlDataset的WHERE片断的规则对象的接口.
Menu - class com.bstek.dorado.view.control.Menu.
菜单对象 菜单对象并不是直接可见的对象,它需要被绑定在各种菜单容器中方能可见.
Menu(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Menu
构造器
MenuBar - class com.bstek.dorado.view.control.MenuBar.
菜单工具栏.
MenuBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.MenuBar
构造器
MenuItem - class com.bstek.dorado.view.control.MenuItem.
菜单项 一般用于执行URL请求,当用户点击菜单项时菜单可以自动在一个指定的框架中激活该URL.
MenuItem(String) - Constructor for class com.bstek.dorado.view.control.MenuItem
构造器
MenuItem(String, String) - Constructor for class com.bstek.dorado.view.control.MenuItem
构造器
MenuItemContainer - interface com.bstek.dorado.view.control.MenuItemContainer.
菜单项容器的接口
MenuOutlookBarGroup - class com.bstek.dorado.view.control.MenuOutlookBarGroup.
MenuOutlookBarGroup(String) - Constructor for class com.bstek.dorado.view.control.MenuOutlookBarGroup
MenuOutlookBarGroup
MessageHelper - class com.bstek.dorado.common.MessageHelper.
用于处理Message的工具类.
MetaData - class com.bstek.dorado.utils.MetaData.
元数据对象集合
MetaData() - Constructor for class com.bstek.dorado.utils.MetaData
ModuleManager - class com.bstek.dorado.module.ModuleManager.
Module管理器.
ModuleManager() - Constructor for class com.bstek.dorado.module.ModuleManager
ModuleSupport - class com.bstek.dorado.module.ModuleSupport.
Module的基本实现
ModuleSupport() - Constructor for class com.bstek.dorado.module.ModuleSupport
构造器
map() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回Map
map() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回Map
masterKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
以数组的形式masterKeyFields的值
masterKeyFields() - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
以数组的形式masterKeyFields的值
masterKeyFields() - Method in class com.bstek.dorado.view.data.MasterDetailLink
取得主数据集中与从数据集关联的字段数组.
matchRules() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset所有MatchRule的集合对象。
moveFirst() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到Dataset的顶端。
moveFirst() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
moveFirst() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
moveFirst() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到Dataset的顶端。此调用完成后isFirst()将返回true.
moveLast() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到Dataset的末端。
moveLast() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到Dataset的末端。
moveLast() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到Dataset的末端。
moveLast() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到Dataset的末端。
moveNext() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到后一条记录。
moveNext() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到后一条记录。
moveNext() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到后一条记录。
moveNext() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到后一条记录。
movePrev() - Method in interface com.bstek.dorado.data.Dataset
将当前位置移动到前一条记录。
movePrev() - Method in class com.bstek.dorado.data.DatasetAdapter
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
movePrev() - Method in class com.bstek.dorado.data.DatasetSupport
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
movePrev() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
将当前位置移动到前一条记录。此调用完成后isLast()将返回true.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


N-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

N

NORMAL - Static variable in class com.bstek.dorado.view.control.SubWindow
窗体状态 - 常态
NOTEQUALS - Static variable in class com.bstek.dorado.data.db.BaseMatchRule
不等于
NOT_ALLOW_EQUALS - Static variable in class com.bstek.dorado.view.data.validate.impl.RangeValidator
范围校验类型 - 不允许等于
NO_ACTION - Static variable in class com.bstek.dorado.view.control.SubWindow
不操作
NO_FORWARD_ATTRIBUTE - Static variable in interface com.bstek.dorado.view.rpc.RPCHandler
NO_FORWARD_ATTRIBUTE
NULL_INSTANCE - Static variable in class com.bstek.dorado.data.ParameterSet
空对象
NULL_VALUE - Variable in class com.bstek.dorado.data.db.DBStatement
NULL_VALUE
NoCurrentRecordException - exception com.bstek.dorado.data.NoCurrentRecordException.
无当前记录异常。
NoCurrentRecordException() - Constructor for class com.bstek.dorado.data.NoCurrentRecordException
构造器
name - Variable in class com.bstek.dorado.view.control.autoform.FormElement
表单元素名称
nameToIndex(String) - Method in class com.bstek.dorado.data.FieldSet
根据Field的名称得到Field的索引号
nameToType(String) - Static method in class com.bstek.dorado.utils.variant.DataType
nameToType
newDocument() - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建一个空的XmlDocument对象
newForward(String) - Method in interface com.bstek.dorado.action.Action
用给定的path创建并返回一个临时的ActionForward对象。
newForward(String, boolean) - Method in interface com.bstek.dorado.action.Action
用给定的path创建并返回一个临时的ActionForward对象。
newInstance(String) - Static method in class com.bstek.dorado.utils.ClassHelper
newInstance
newInstance(String, Class[], Object[]) - Static method in class com.bstek.dorado.utils.ClassHelper
newInstance
newInstance(Class, Class[], Object[]) - Static method in class com.bstek.dorado.utils.ClassHelper
newInstance
newNode(String) - Method in interface com.bstek.dorado.utils.xml.XmlBuilder
创建一个空的XmlNode对象
next() - Method in class com.bstek.dorado.data.RecordIterator
返回下一条记录.
nextRecord() - Method in class com.bstek.dorado.data.RecordIterator
返回下一条记录.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


O-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

O

OR - Static variable in class com.bstek.dorado.data.db.AndOrMatchRule
不等于
ORIENTATION_HORIZONTAL - Static variable in class com.bstek.dorado.view.control.ProgressBar
ORIENTATION_HORIZONTAL
ORIENTATION_HORIZONTAL - Static variable in class com.bstek.dorado.view.control.ScrollBar
方向 - 水平
ORIENTATION_HORIZONTAL - Static variable in class com.bstek.dorado.view.control.SplitPanel
方向 - 水平
ORIENTATION_VERTICAL - Static variable in class com.bstek.dorado.view.control.ProgressBar
ORIENTATION_VERTICAL
ORIENTATION_VERTICAL - Static variable in class com.bstek.dorado.view.control.ScrollBar
方向 - 垂直
ORIENTATION_VERTICAL - Static variable in class com.bstek.dorado.view.control.SplitPanel
方向 - 垂直
ObjectCollection - interface com.bstek.dorado.utils.collection.ObjectCollection.
对象列表接口,定义对象列表的基本方法。
ObjectList - class com.bstek.dorado.utils.collection.ObjectList.
对象列表的实现。
ObjectList() - Constructor for class com.bstek.dorado.utils.collection.ObjectList
ObjectList
OutlookBar - class com.bstek.dorado.view.control.OutlookBar.
Outlook工具栏
OutlookBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.OutlookBar
构造器
OutlookBarGroup - class com.bstek.dorado.view.control.OutlookBarGroup.
OutlookBarGroup(String) - Constructor for class com.bstek.dorado.view.control.OutlookBarGroup
构造器
onInit(Dataset) - Method in interface com.bstek.dorado.data.DatasetListener
当Dataset被初始化的时候触发的事件.即当调用Dataset.init()时触发的事件.
originTable - Variable in class com.bstek.dorado.data.db.DBDataset
outParameters() - Method in class com.bstek.dorado.view.rpc.BaseRPCHandler
本次远程调用将要返回给客户端的参数集合.
output(HttpServletRequest, HttpServletResponse, InputStream) - Static method in class com.bstek.dorado.utils.http.ResponseUtil
将一个InputStream中的内容输出到response
output(XmlNode, OutputStream) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlNode, Writer) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlNode, File) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlNode, String) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出一个XML节点
output(XmlDocument, OutputStream) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
output(XmlDocument, Writer) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
output(XmlDocument, File) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
output(XmlDocument, String) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
输出整个XML
outputDownloadFile(HttpServletRequest, HttpServletResponse) - Method in class com.bstek.dorado.biz.FileController
向Response对象中写入文件数据
outputNoCompress(HttpServletRequest, HttpServletResponse, InputStream) - Static method in class com.bstek.dorado.utils.http.ResponseUtil
将一个InputStream中的内容输出到response.
outputString(XmlNode) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
以String格式输出一个XML节点
outputString(XmlDocument) - Method in interface com.bstek.dorado.utils.xml.XmlOutputter
以String格式输出整个XML
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


P-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

P

PARENT - Static variable in class com.bstek.dorado.view.control.command.Frame
在当前页面所处的框架的直接父框架中打开新页面.
PASSWORD - Static variable in class com.bstek.dorado.view.control.TextEditor
文本编辑器类型 - 密码框
PASSWORD - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - password
PROCESSED_ATTRIBUTE_KEY - Static variable in interface com.bstek.dorado.view.rpc.RPCHandler
PROCESSED_ATTRIBUTE_KEY
PagePilot - class com.bstek.dorado.view.control.PagePilot.
分页导航条.
PagePilot(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.PagePilot
构造器
PagingHelper - class com.bstek.dorado.data.PagingHelper.
用户辅助数据分页计算的帮助类。
PagingHelper() - Constructor for class com.bstek.dorado.data.PagingHelper
构造器
PagingHelper(int, int) - Constructor for class com.bstek.dorado.data.PagingHelper
构造器
PagingHelper(int, int, int) - Constructor for class com.bstek.dorado.data.PagingHelper
构造器
ParameterSet - class com.bstek.dorado.data.ParameterSet.
参数的集合类
ParameterSet() - Constructor for class com.bstek.dorado.data.ParameterSet
构造器
PatternValidator - class com.bstek.dorado.view.data.validate.impl.PatternValidator.
基于正则表达式的校验对象
PatternValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.PatternValidator
Placeable - interface com.bstek.dorado.view.control.Placeable.
支持界面定位的控件的接口
PlaceableControl - class com.bstek.dorado.view.control.PlaceableControl.
支持界面定位的控件的抽象类
PlaceableControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.PlaceableControl
构造器
PlaceableDataControl - class com.bstek.dorado.view.control.PlaceableDataControl.
支持界面定位的数据控件的抽象类
PlaceableDataControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.PlaceableDataControl
构造器
Printf - class com.bstek.dorado.utils.Printf.
格式化输出字符串 此处的格式化方式类似C及JDK1.5中包含的格式化方式.
ProgressBar - class com.bstek.dorado.view.control.ProgressBar.
ProgressBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.ProgressBar
ProgressBar
parameters() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset所有参数的集合对象
parameters() - Method in class com.bstek.dorado.data.db.DBStatement
取得所有参数的集合对象
parameters() - Method in class com.bstek.dorado.view.control.command.Command
返回命令对象的参数集合。
parameters() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
返回参数集合 注意: 此处定义的参数最终将会传入到内部使用的数据集的参数当中
parameters() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset所有参数的集合对象
parameters() - Method in interface com.bstek.dorado.view.rpc.RPCHandler
取得客户端发送的参数集合.
parametersToBean(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的Bean当中.
parametersToDO(Object) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的对象当中.
parametersToMap() - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到Map当中.
parametersToMap(Map) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的Map当中.
parametersToVariantSet(VariantSet) - Method in class com.bstek.dorado.utils.http.RequestHelper
将当前Request中包含的参数(Parameter)设置到给定的VariantSet当中.
parse(Class) - Static method in class com.bstek.dorado.utils.variant.DataType
将一个Class类型翻译为Dorado的DataType
parseBigDecimal(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseBigDecimal
parseBoolean(String) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
将一个字符串翻译成逻辑值。
parseBoolean(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseBoolean
parseByte(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseByte
parseDate(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseDate
parseDouble(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseDouble
parseFloat(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseFloat
parseInt(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseInt
parseLevel(String) - Static method in class com.bstek.dorado.common.log.Log
转换日志级别名称为日志级别。
parseLong(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseLong
parseShort(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseShort
parseString(Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
parseString
parseType(String) - Static method in class com.bstek.dorado.utils.ClassHelper
parseType
passivate() - Method in class com.bstek.dorado.module.ModuleSupport
prepareDatasets() - Method in interface com.bstek.dorado.view.ViewModel
为视图模型中所有的Dataset准备数据。
prepareDatasets() - Method in class com.bstek.dorado.view.ViewModelSupport
为视图模型中所有的Dataset准备数据。

注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。

prepareDatasets() - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDownViewModel
为视图模型中所有的Dataset准备数据。

注意：如果此时视图模型的状态不是STATE_VIEW或STATE_SERVICE， 那么系统事实上并不会通知Dataset去装载数据，而只会通知Dataset初试化其中的字段信息。

processDetailLookup() - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
processDetailLookup
processException(Throwable, Action, HttpServletRequest, HttpServletResponse) - Static method in class com.bstek.dorado.action.Controller
处理一个在Action执行过程中发生的异常。
processForward(HttpServletRequest, HttpServletResponse, ActionForward) - Method in class com.bstek.dorado.action.Controller
处理Action的转向。
processLookup() - Method in interface com.bstek.dorado.data.Dataset
处理所有的Lookup数据。
processLookup() - Method in class com.bstek.dorado.data.DatasetAdapter
处理所有的Lookup数据。
processLookup() - Method in class com.bstek.dorado.data.DatasetSupport
处理所有的Lookup数据。
processLookup() - Method in class com.bstek.dorado.view.data.DatasetWrapper
processLookup() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
处理所有的Lookup数据。
properties() - Method in interface com.bstek.dorado.data.Dataset
与Dataset相关的一组属性值.
properties() - Method in class com.bstek.dorado.data.DatasetAdapter
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

properties() - Method in class com.bstek.dorado.data.DatasetSupport
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

properties() - Method in interface com.bstek.dorado.data.Field
返回所有元数据的集合对象。
properties() - Method in interface com.bstek.dorado.view.ViewModel
属性集合
properties() - Method in class com.bstek.dorado.view.ViewModelSupport
属性集合
properties() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
与Dataset相关的一组属性值.

这里的属性值可由用户自行设置与维护, Dataset本身并不处理这些属性值.

putElement(FormElement) - Method in class com.bstek.dorado.view.control.autoform.FormGroupGround
putElement
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


Q-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

Q

QueryCommand - class com.bstek.dorado.view.control.command.QueryCommand.
查询命令 该命令通常用于实现页面无刷新特征的数据查询,通过设定该命令的查询条件数据集(conditionDataset), 以及查询数据集(queryDataset)设置,该命令执行时会自动将查询条件数据集中的当前记录的信息作为查询结果集的parameters, 发出AJAX请求,由服务器端的services接受该请求, 并利用查询数据集中包含的parameters信息以及pageIndex,pageSize信息获得用户需要的数据并保存到数据集中, 从而实现页面数据的刷新.
QueryCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.QueryCommand
构造器
query() - Method in class com.bstek.dorado.data.db.DBStatement
执行一个查询命令并返回第一条记录的值.如果本次查询没有查到任何记录将返回null.
queryForList() - Method in class com.bstek.dorado.data.db.DBStatement
执行一个查询命令并将结果集以java.util.List的形式返回.其中List中的元素是 com.bstek.dorado.utils.variant.VariantSet对象.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


R-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

R

REJECT_ROLE - Static variable in interface com.bstek.dorado.view.ViewModel
REJECT_ROLE - 系统默认角色，该角色无权使用视图模型中的任何组件
REQUEST - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - Reqeust
REQUEST - Static variable in class com.bstek.dorado.common.scope.Scope
作用域类型 - Reqeust
RPCCommand - class com.bstek.dorado.view.control.command.RPCCommand.
远程过程调用命令
RPCCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.RPCCommand
构造器
RPCHandler - interface com.bstek.dorado.view.rpc.RPCHandler.
来自客户端的远程方法调用的处理类
RPCHelper - class com.bstek.dorado.view.rpc.RPCHelper.
远程过程调用的帮助类
RadioGroup - class com.bstek.dorado.view.control.RadioGroup.
单选框组合.
RadioGroup(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.RadioGroup
构造器
RadioGroupFormElement - class com.bstek.dorado.view.control.autoform.RadioGroupFormElement.
单选框型的表单元素
RadioGroupFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.RadioGroupFormElement
构造器
RangeValidator - class com.bstek.dorado.view.data.validate.impl.RangeValidator.
数值范围校验器 用于校验指定的数据是否在一个允许的范围内的校验器.例如可用于校验某字段中录入的内容必须在2000-10000之间.
RangeValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.RangeValidator
ReadRecord - class com.bstek.dorado.data.ReadRecord.
只读的Record
ReadRecord() - Constructor for class com.bstek.dorado.data.ReadRecord
Record - class com.bstek.dorado.data.Record.
记录对象
Record() - Constructor for class com.bstek.dorado.data.Record
构造器
RecordFilter - interface com.bstek.dorado.data.RecordFilter.
记录过滤器
RecordIterator - class com.bstek.dorado.data.RecordIterator.
记录迭代器
RecordIterator(Dataset) - Constructor for class com.bstek.dorado.data.RecordIterator
构造器
RecordListener - interface com.bstek.dorado.data.RecordListener.
Dataset中记录操作的监听器
RecordSet - class com.bstek.dorado.data.RecordSet.
Record集合对象
RecordSet() - Constructor for class com.bstek.dorado.data.RecordSet
构造器
RecordTreeNode - class com.bstek.dorado.view.control.tree.RecordTreeNode.
跟记录绑定的树节点.
RecordTreeNode() - Constructor for class com.bstek.dorado.view.control.tree.RecordTreeNode
构造器.
RecordTreeNode(Record, TreeLevel) - Constructor for class com.bstek.dorado.view.control.tree.RecordTreeNode
构造器.
RecordWrapper - class com.bstek.dorado.data.RecordWrapper.
RecordSet使用的记录包装器
RecordWrapper(Record) - Constructor for class com.bstek.dorado.data.RecordWrapper
构造器
RecursiveTreeLevel - class com.bstek.dorado.view.control.tree.RecursiveTreeLevel.
数据树中的递归层的描述对象.
RecursiveTreeLevel(String) - Constructor for class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
构造器
RequestCommand - class com.bstek.dorado.view.control.command.RequestCommand.
请求命令 该命令用于新URL请求，可替代open, showModelDialog等JavaScript操作.
RequestCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.RequestCommand
构造器
RequestHelper - class com.bstek.dorado.utils.http.RequestHelper.
用于简化ServletRequest访问的工具类.
RequestHelper(ServletRequest) - Constructor for class com.bstek.dorado.utils.http.RequestHelper
RequestHelper
RequiredValidator - class com.bstek.dorado.view.data.validate.impl.RequiredValidator.
必需类型校验对象
RequiredValidator() - Constructor for class com.bstek.dorado.view.data.validate.impl.RequiredValidator
ResourceManager - class com.bstek.dorado.i18n.ResourceManager.
国际化资源的管理对象
ResourceManagerContextMap - class com.bstek.dorado.i18n.ResourceManagerContextMap.
ResourceManagerContextMap(DoradoContext, ResourceManager) - Constructor for class com.bstek.dorado.i18n.ResourceManagerContextMap
ResponseUtil - class com.bstek.dorado.utils.http.ResponseUtil.
与Response处理相关的工具类
rebuild() - Method in class com.bstek.dorado.data.Index
重建本索引
recordIterator() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset中所有Record的迭代器。
recordIterator() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

recordIterator() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

recordIterator() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset中所有Record的迭代器。

注意：此迭代器遍历的将是与Visibility属性匹配的那一部分Record。

recordSet() - Method in interface com.bstek.dorado.data.Dataset
返回Dataset的Record集合对象
recordSet() - Method in class com.bstek.dorado.data.DatasetAdapter
返回Dataset的Record集合对象
recordSet() - Method in class com.bstek.dorado.data.DatasetSupport
返回Dataset的Record集合对象
recordSet() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回Dataset的Record集合对象
recordToDO(Record, Object) - Static method in class com.bstek.dorado.data.DOUtils
将给定的记录中包含的数据设置到给定的对象当中.
recursiveKeyFields() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
以数组的形式recursiveKeyFields的值
recursiveKeyFields() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
以数组的形式recursiveKeyFields的值
recursiveKeyParameters() - Method in class com.bstek.dorado.view.control.advance.TreeGrid
以数组的形式recursiveKeyParameters的值
recursiveKeyParameters() - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
以数组的形式recursiveKeyParameters的值
registerContext(DoradoContext) - Static method in class com.bstek.dorado.common.DoradoContext
在当前的线程中注册一个context对象
registerDetailLink(MasterDetailLink) - Method in interface com.bstek.dorado.view.data.ViewDataset
注册一个关联关系的对象。
registerDetailLink(MasterDetailLink) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
注册一个关联关系的对象。
remove(String) - Method in class com.bstek.dorado.data.ParameterSet
删除给定键值及其下的数值.
remove() - Method in class com.bstek.dorado.data.RecordIterator
从Dataset删除当前记录.
remove(String) - Method in class com.bstek.dorado.data.db.CaseInsensitiveVariantSet
Deprecated.
remove(Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
删除对象列表中的一个对象。
remove(int) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
删除对象列表中的一个对象。
remove(Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
删除对象列表中的一个对象。
remove(int) - Method in class com.bstek.dorado.utils.collection.ObjectList
删除对象列表中的一个对象。
remove(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
删除给定索引号及其下的数值.
remove(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
删除给定键值及其下的数值.
removeAll() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
删除对象列表中的所有对象。
removeAll() - Method in class com.bstek.dorado.utils.collection.ObjectList
删除对象列表中的所有对象。
removeAll() - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
删除所有静态下拉框的下拉数据项对象。
removeAttribute(int, String) - Method in class com.bstek.dorado.common.DoradoContext
删除指定的作用域中的某个属性.
removeAttribute(int, String) - Method in class com.bstek.dorado.common.HttpDoradoContext
删除指定的作用域中的某个属性.
removeAttribute(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
删除一个属性
removeChild(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
删除一个子节点
removeChildren() - Method in interface com.bstek.dorado.utils.xml.XmlNode
删除所有的子节点
removeControl(String) - Method in interface com.bstek.dorado.view.ViewModel
根据指定的Id删除一个控件。
removeControl(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的Id删除一个控件。
removeDataset(String) - Method in interface com.bstek.dorado.view.ViewModel
根据Id删除一个指定的数据集。
removeDataset(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据Id删除一个指定的数据集。
removeDatasetListener(DatasetListener) - Method in interface com.bstek.dorado.data.Dataset
删除一个DatasetEvent的事件监听器
removeDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetAdapter
删除一个DatasetEvent的事件监听器
removeDatasetListener(DatasetListener) - Method in class com.bstek.dorado.data.DatasetSupport
删除一个DatasetEvent的事件监听器
removeDatasetListener(DatasetListener) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
删除一个DatasetEvent的事件监听器
removeEventHandler(String) - Method in interface com.bstek.dorado.view.Component
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in interface com.bstek.dorado.view.EventSupported
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.ViewModelSupport
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.control.table.DataColumnGroup
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
根据指定的名称删除一个事件处理对象。
removeEventHandler(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
removeEventHandler
removeFromParent() - Method in interface com.bstek.dorado.utils.xml.XmlNode
removeFromParent
removeItem(int) - Method in class com.bstek.dorado.view.control.dropdown.ListDropDown
根据指定索引值删除静态下拉框的一个下拉数据项对象。
removeRecord(Record) - Method in class com.bstek.dorado.data.RecordSet
删除一条记录
removeRecordListener(RecordListener) - Method in interface com.bstek.dorado.data.Dataset
删除一个RecordtListener的事件监听器
removeRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetAdapter
删除一个RecordtListener的事件监听器
removeRecordListener(RecordListener) - Method in class com.bstek.dorado.data.DatasetSupport
删除一个RecordtListener的事件监听器
removeValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewBaseField
删除一个字段的校验器.
removeValidator(Validator) - Method in interface com.bstek.dorado.view.data.ViewField
删除一个字段的校验器.
removeValidator(Validator) - Method in class com.bstek.dorado.view.data.ViewLookupField
删除一个字段的校验器.
reqeustStack - Variable in class com.bstek.dorado.common.HttpDoradoContext
resetRecordsState() - Method in interface com.bstek.dorado.data.Dataset
重置所有的记录状态
resetRecordsState() - Method in class com.bstek.dorado.data.DatasetAdapter
重置所有的记录状态
resetRecordsState() - Method in class com.bstek.dorado.data.DatasetSupport
重置所有的记录状态
retrieveRecord(UpdateSqlInfo, Record, PreparedStatement) - Method in class com.bstek.dorado.data.db.DBDataset
从数据库中提取一条记录的信息
rollback() - Method in interface com.bstek.dorado.common.Transaction
回滚当前事务
root - Variable in class com.bstek.dorado.common.fileloader.FileLoader
根路径.所以该FileLoader所能读取的文件都位于该路径之下.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


S-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

S

SCHEDULE - Static variable in class com.bstek.dorado.view.control.Calendar
SCROLLMODE_RECORD - Static variable in class com.bstek.dorado.view.control.table.DataTable
对当前记录进行滚动.
SCROLLMODE_SIMPLE - Static variable in class com.bstek.dorado.view.control.table.DataTable
简单的滚动方式,指对表格的可见区域进行滚动.
SELECT - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - SELECT
SELECTED - Static variable in class com.bstek.dorado.view.control.command.DatasetInfo
数据的提交方式 - 只提交Dataset中所有通过Select复选框选中的记录。
SELF - Static variable in class com.bstek.dorado.view.control.command.Frame
在自身浏览器窗口中打开新页面.
SESSION - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - Session
SESSION - Static variable in class com.bstek.dorado.common.scope.Scope
作用域类型 - Session
SHORT - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - short型。
SHORT_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - short型。
SIMPLE - Static variable in class com.bstek.dorado.view.control.Calendar
STATE_DELETED - Static variable in class com.bstek.dorado.data.DOSet
已删除
STATE_DELETED - Static variable in class com.bstek.dorado.data.Record
记录状态 - 已删除.
STATE_DESIGN - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为设计器服务
STATE_INIT - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 初始化
STATE_LOADING - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 加载数据
STATE_MODIFIED - Static variable in class com.bstek.dorado.data.DOSet
已更新
STATE_MODIFIED - Static variable in class com.bstek.dorado.data.Record
记录状态 - 已更新.
STATE_NEW - Static variable in class com.bstek.dorado.data.DOSet
新增
STATE_NEW - Static variable in class com.bstek.dorado.data.Record
记录状态 - 新增.
STATE_NONE - Static variable in class com.bstek.dorado.data.DOSet
无状态
STATE_NONE - Static variable in class com.bstek.dorado.data.Record
记录状态 - 无状态.此状态为记录的默认状态.
STATE_READY - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 已就绪
STATE_RESOLVING - Static variable in interface com.bstek.dorado.data.Dataset
Dataset状态 - 更新数据
STATE_SERVICE - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为远程过程调用等服务
STATE_UPDATING - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为一个视图更新数据时服务
STATE_VIEW - Static variable in interface com.bstek.dorado.view.ViewModel
视图模型的状态 - 正在为一个视图服务
STRING - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - String型。
STRING_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称名称 - String型。
SUBWINDOW - Static variable in class com.bstek.dorado.view.control.autoform.AutoForm
组的类型 - 子窗体
SUBWINDOW - Static variable in class com.bstek.dorado.view.control.command.Frame
在一个排他式子窗体中打开新页面.
SUM - Static variable in class com.bstek.dorado.data.db.AggregateMode
对字段求和
SafeCode - class com.bstek.dorado.utils.codec.SafeCode.
用于编码和解码字符串中的不安全字符，使之可以在各种网络环境中安全的传输。
SafeCode() - Constructor for class com.bstek.dorado.utils.codec.SafeCode
Scope - class com.bstek.dorado.common.scope.Scope.
对象的作用域类型
ScopeHelper - class com.bstek.dorado.common.scope.ScopeHelper.
对象的作用域类型的工具类
ScrollBar - class com.bstek.dorado.view.control.ScrollBar.
滚动条
ScrollBar(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.ScrollBar
构造器
Setting - class com.bstek.dorado.common.Setting.
用于保存Dorado的Server运行时属性的对象.此处的配置信息均是在dorado的home/setting.xml 中设定的.
SimpleDataControl - class com.bstek.dorado.view.control.SimpleDataControl.
简单数据控件对象
SimpleDataControl(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.SimpleDataControl
构造器
SimpleDropDown - class com.bstek.dorado.view.control.dropdown.SimpleDropDown.
简单下拉框的基类
SimpleDropDown(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.dropdown.SimpleDropDown
SimpleTreeLevel - class com.bstek.dorado.view.control.tree.SimpleTreeLevel.
数据树中的简单层的描述对象.
SimpleTreeLevel(String) - Constructor for class com.bstek.dorado.view.control.tree.SimpleTreeLevel
构造器
SortRule - class com.bstek.dorado.data.db.SortRule.
用于描述AutoSqlDataset的SORT BY片断的排序规则对象
SortRule(String) - Constructor for class com.bstek.dorado.data.db.SortRule
构造器 注意: 此方法默认指定的物理字段来自于AutoSqlDataset对应的主表.如果你要设定的字段不是来自于 主表的,那么您还需要设置此对象的table属性.
SortRule(String, String, boolean) - Constructor for class com.bstek.dorado.data.db.SortRule
构造器
Span - class com.bstek.dorado.view.control.Span.
控件的辅助类
Span(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.Span
构造器
SplitPanel - class com.bstek.dorado.view.control.SplitPanel.
视图分割栏 用于将客户端的页面划分为不同区域,SplitPanel可以支持动态拖动,从而改变页面的布局, 实现更佳的页面显示效果,改善用户体验.
SplitPanel(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.SplitPanel
构造器
SqlDataset - class com.bstek.dorado.data.db.SqlDataset.
基于SQL的Dataset.
SqlDataset() - Constructor for class com.bstek.dorado.data.db.SqlDataset
构造器
SqlDataset(String) - Constructor for class com.bstek.dorado.data.db.SqlDataset
构造器
SqlDataset(String, String) - Constructor for class com.bstek.dorado.data.db.SqlDataset
构造器
SqlMatchRule - class com.bstek.dorado.data.db.SqlMatchRule.
用于描述AutoSqlDataset的WHERE片断的SQL匹配规则对象.
SqlMatchRule() - Constructor for class com.bstek.dorado.data.db.SqlMatchRule
构造器
SqlMatchRule(String) - Constructor for class com.bstek.dorado.data.db.SqlMatchRule
构造器
StaticColumn - class com.bstek.dorado.view.control.table.StaticColumn.
静态表格列
StaticColumn(String) - Constructor for class com.bstek.dorado.view.control.table.StaticColumn
构造器
StaticColumnGroup - class com.bstek.dorado.view.control.table.StaticColumnGroup.
静态表格中的组合列
StaticColumnGroup(String) - Constructor for class com.bstek.dorado.view.control.table.StaticColumnGroup
构造器
StaticTable - class com.bstek.dorado.view.control.table.StaticTable.
静态表格类
StaticTable(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.table.StaticTable
StringHelper - class com.bstek.dorado.utils.StringHelper.
String的一些辅助操作
SubUnit - class com.bstek.dorado.action.mapping.SubUnit.
子配置单元的Mapping配置信息。
SubUnit(String) - Constructor for class com.bstek.dorado.action.mapping.SubUnit
构造器
SubWindow - class com.bstek.dorado.view.control.SubWindow.
子窗体 用于将客户端的界面划分为不同的窗体,类似于protal风格.
SubWindow(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.SubWindow
构造器
SynchroTimer - class com.bstek.dorado.utils.SynchroTimer.
基于线程的定时器
SynchroTimer(long) - Constructor for class com.bstek.dorado.utils.SynchroTimer
构造器
SystemVariable - class com.bstek.dorado.utils.SystemVariable.
用于读取系统环境变量。
SystemVariable() - Constructor for class com.bstek.dorado.utils.SystemVariable
创建读取系统环境变量的对象。
save() - Static method in class com.bstek.dorado.common.Setting
保存配置。
save() - Static method in class com.bstek.dorado.common.UserConfig
保存配置。
set(String, Object) - Method in class com.bstek.dorado.data.Record
set
set(int, Object) - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
设置对象列表中的一个对象
set(int, Object) - Method in class com.bstek.dorado.utils.collection.ObjectList
设置对象列表中的一个对象
setAction(String) - Method in class com.bstek.dorado.view.control.command.RPCCommand
设置接收此命令的Server端服务的url。
setAggregate(String) - Method in class com.bstek.dorado.data.db.AutoDBField
设置AutoSqlDataset中Field的合计模式.
setAlign(String) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置列的水平对齐方式。
setAllowPushDown(boolean) - Method in class com.bstek.dorado.view.control.Button
设置按钮是否允许按钮被按下.
setAlwaysPerform(boolean) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
设置是否总是允许执行.即不管是否存在需要提交的数据都强行的执行提交操作.
setAnimated(boolean) - Method in class com.bstek.dorado.view.control.OutlookBar
setAnimated
setAsync(boolean) - Method in class com.bstek.dorado.view.control.command.QueryCommand
设定是否以异步方式执行远程过程调用
setAsync(boolean) - Method in class com.bstek.dorado.view.control.command.RPCCommand
设定是否以异步方式执行远程过程调用
setAsync(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定是否采用异步方式执行动态数据加载.
setAsync(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定是否采用异步方式执行动态数据加载.
setAttribute(int, String, Object) - Method in class com.bstek.dorado.common.DoradoContext
为指定的作用域中的某个属性设定一个值.
setAttribute(int, String, Object) - Method in class com.bstek.dorado.common.HttpDoradoContext
为指定的作用域中的某个属性设定一个值.
setAttribute(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
设置一个属性的值
setAttributeBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型设置一个属性的值
setAttributeDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型设置一个属性的值
setAttributeFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型设置一个属性的值
setAttributeInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型设置一个属性的值
setAttributeLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型设置一个属性的值
setAutoCreateDiv(boolean) - Method in class com.bstek.dorado.view.control.tabset.Tab
设置是否自动创建与该标签页相关联的层.默认值为false.
setAutoCreateFields(boolean) - Method in interface com.bstek.dorado.data.Dataset
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
setAutoCreateFields(boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
setAutoCreateFields(boolean) - Method in class com.bstek.dorado.data.DatasetSupport
设置是否在执行load()时自动根据外部数据来创建Dataset中尚未存在的Field.
setAutoDropDown(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
设定当下拉框获得焦点后是否自动打开，而不是需要用户使用鼠标或快捷键方式打开。
setAutoLoadData(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。
setAutoLoadData(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设置是否需要装载数据，不装载数据时只会创建一份Dataset结构。默认值为true。
setAutoLoadPage(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定是否启用客户端Dataset的自动状态数据功能。
setAutoLoadPage(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定是否启用客户端Dataset的自动状态数据功能。
setAutoLoadPage(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定是否启用客户端Dataset的自动状态数据功能。
setAutoScroll(boolean) - Method in class com.bstek.dorado.view.control.tabset.Tab
setAutoScroll
setAutoSyncRecordWithDragging(boolean) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设置在节点拖放后是否自动对相应的记录进行数据同步.
setBigChange(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置当用户点击滚动条的空白区域时引起的滚动量.
setBigDecimal(int, BigDecimal) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in interface com.bstek.dorado.data.Dataset
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.data.DatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.data.DatasetSupport
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.data.Record
设定记录中某个BigDecimal类型的字段值.
setBigDecimal(BigDecimal) - Method in class com.bstek.dorado.utils.variant.Variant
设置BigDecimal类型的数据
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置BigDecimal类型的数据
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置BigDecimal类型的数据
setBigDecimal(int, BigDecimal) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBigDecimal(String, BigDecimal) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按BigDecimal类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Static method in class com.bstek.dorado.common.Setting
设置一个Boolean型的配置信息
setBoolean(String, boolean) - Static method in class com.bstek.dorado.common.UserConfig
设置一个Boolean型的配置信息
setBoolean(int, boolean) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in interface com.bstek.dorado.data.Dataset
按boolean类型设置当前记录中某字段的值。
setBoolean(int, boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.data.DatasetAdapter
按boolean类型设置当前记录中某字段的值。
setBoolean(int, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.data.DatasetSupport
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.data.Record
设定记录中某个boolean类型的字段值.
setBoolean(boolean) - Method in class com.bstek.dorado.utils.variant.Variant
设置boolean类型的数据
setBoolean(int, boolean) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置boolean类型的数据
setBoolean(String, boolean) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置boolean类型的数据
setBoolean(int, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型设置当前记录中某字段的值。
setBoolean(String, boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按boolean类型设置当前记录中某字段的值。
setButtonAppend(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“追加一条记录”(AppendRecord)按钮的显示状态。
setButtonCancel(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“撤销对当前记录修改”(CancelRecord)按钮的显示状态。
setButtonDelete(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“删除一条记录”(DeleteRecord)按钮的显示状态。
setButtonInsert(String) - Method in class com.bstek.dorado.view.control.DataPilot
设置“插入一条记录”(InsertRecord)按钮的显示状态。
setButtonMoveFirst(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到第一条”按钮(MoveFirst)的显示状态。
setButtonMoveLast(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到最后一条”按钮(MoveLast)的显示状态。
setButtonMoveNext(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到下一条”按钮(MoveNext)的显示状态。
setButtonMovePrev(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到上一条”按钮(MovePrev)的显示状态。
setButtonNextPage(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到后一页”按钮(NextPage)的显示状态。
setButtonPost(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定"验证"按钮(PostRecord)的显示状态。
setButtonPrevPage(String) - Method in class com.bstek.dorado.view.control.DataPilot
设定“移动到前一页”按钮(PrevPage)的显示状态。
setByte(int, byte) - Method in interface com.bstek.dorado.data.Dataset
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in interface com.bstek.dorado.data.Dataset
按byte类型设置当前记录中某字段的值。
setByte(int, byte) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.data.DatasetAdapter
按byte类型设置当前记录中某字段的值。
setByte(int, byte) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.data.DatasetSupport
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.data.Record
设定记录中某个byte类型的字段值.
setByte(byte) - Method in class com.bstek.dorado.utils.variant.Variant
设置byte类型的数据
setByte(int, byte) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置byte类型的数据
setByte(String, byte) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置byte类型的数据
setByte(int, byte) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型设置当前记录中某字段的值。
setByte(String, byte) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按byte类型设置当前记录中某字段的值。
setCachable(boolean) - Method in interface com.bstek.dorado.view.control.dropdown.CachableDropDown
设置该下拉框是否支持缓存。
setCachable(boolean) - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
设置该下拉框是否支持缓存。
setCachable(boolean) - Method in class com.bstek.dorado.view.control.tabset.FrameTab
设置是否允许缓存Frame内容
setCalendarType(String) - Method in class com.bstek.dorado.view.control.Calendar
设置日历类型.默认可选值有 SIMPLE="simple"(简单类型) 在此种模式下日历对象以一种相对简单的模式与Dataset进行绑定.
setCenter(boolean) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架新页面是否自动居中对齐.
setCheckable(boolean) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定该层节点是否是可复选的
setCheckable(boolean) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定树节点前面是否有复选框可以被选择
setChecked(boolean) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点是否已经被选中
setCheckedField(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定用于获取节点的复选状态的字段名
setChildContent(String, String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setChildContent
setChildContentBoolean(String, boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按boolean类型设置子节点的内容
setChildContentDouble(String, double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按double类型设置子节点的内容
setChildContentFloat(String, float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按float类型设置子节点的内容
setChildContentInt(String, int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按int类型设置子节点的内容
setChildContentLong(String, long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
按long类型设置子节点的内容
setClazz(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置Controller的类名
setClazz(String) - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
设定校验信息的实现类名
setClearSelectionOnSuccess(boolean) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设置当提交成功后是否清除选中的Dataset记录。
setClientType(String) - Method in interface com.bstek.dorado.view.ViewModel
setClientType
setClientType(String) - Method in class com.bstek.dorado.view.ViewModelSupport
setClientType
setCol(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设置指定的列为当前列。
setColSpan(int) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置该元素将占用自动表单中的多少列，该属性类Table的ColSpan属性。
setColSpan(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设置组(Group)中当前元素所占的列的跨度数。
setColumnCount(int) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置该组在页面上显示时每行要显示的列数。
setCommand(String) - Method in class com.bstek.dorado.view.control.Button
设置按钮触发的操作命令对象.
setCommand(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项对应的命令对象
setConcreteValidator(String) - Method in class com.bstek.dorado.view.data.validate.impl.CustomValidator
设定具体的校验器格式
setConditionDataset(String) - Method in class com.bstek.dorado.view.control.command.QueryCommand
设置作为查询条件的数据集
setConfig(ControllerConfig) - Method in class com.bstek.dorado.action.Controller
设定Controller对应的Mapping配置信息。
setConfig(ModuleConfig) - Method in class com.bstek.dorado.module.ModuleSupport
setConfig(ViewModelConfig) - Method in interface com.bstek.dorado.view.ViewModel
设定视图配置对象
setConfig(ViewModelConfig) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图配置对象
setConfigName(String) - Method in interface com.bstek.dorado.view.ViewModel
设定视图模型配置名
setConfigName(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图模型配置名
setConfirmCancel(boolean) - Method in class com.bstek.dorado.view.control.DataPilot
设定是否提示用户确认取消操作。
setConfirmCancel(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置用户在客户端对记录进行取消操作时是否有确认提示。
setConfirmDelete(boolean) - Method in class com.bstek.dorado.view.control.DataPilot
设定是否提示用户确认删除操作。
setConfirmDelete(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置用户在客户端删除记录时是否有确认提示。
setContent(String) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContent
setContentBoolean(boolean) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentBoolean
setContentDouble(double) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentDouble
setContentFloat(float) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentFloat
setContentInt(int) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentInt
setContentLong(long) - Method in interface com.bstek.dorado.utils.xml.XmlNode
setContentLong
setContextAttribute(String) - Method in class com.bstek.dorado.view.data.DODataset
设置与DODataset进行数据交换的上下文属性名.
setContextRelative(boolean) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设置此对象的Path属性，所描述的URL是否是一个相对路径，此属性的默认值是true。
setControlAlign(String) - Method in class com.bstek.dorado.view.control.autoform.ControlFormElement
设置控件的水平对齐方式。
setControlId(String) - Method in class com.bstek.dorado.view.control.autoform.CustomFormElement
为控件(Control)设定一个唯一标识符(Id)。
setControlLazyLoad(boolean) - Method in interface com.bstek.dorado.view.ViewModel
设定视图模型是否支持控件的延时加载.默认为true.
setControlLazyLoad(boolean) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图模型是否支持控件的延时加载.默认为true.
开启控件的延时加载功能可以大幅度的提高复杂界面开启速度.
setControlVAlign(String) - Method in class com.bstek.dorado.view.control.autoform.ControlFormElement
设置控件的垂直对齐方式。
setCountSql(String) - Method in class com.bstek.dorado.data.db.SqlDataset
设置统计总记录数的SQL命令。
setCurrent(Record) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录对象。
setCurrent(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录对象。
setCurrent(Record) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录对象。
setCurrent(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录对象。
setCurrentGroup(String) - Method in class com.bstek.dorado.view.control.OutlookBar
setCurrentGroup
setCurrentTab(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定当前的标签页.此处的参数可以是标签页的名字或索引值.
setDataSource(String) - Method in class com.bstek.dorado.data.db.DBDataset
设置Dataset对应的数据源名称.
setDataSource(String) - Method in class com.bstek.dorado.data.db.DBStatement
设置DBStatement使用的数据源的名称.如果此属性未指定则表示将使用dorado的默认数据源.
setDataType(int) - Method in interface com.bstek.dorado.data.Field
设定字段的数据类型。
setDataType(String) - Method in interface com.bstek.dorado.data.Field
设定字段的数据类型。
setDataType(int) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置返回匹配值的数据类型.
setDataType(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置返回匹配值的数据类型.
setDataType(int) - Method in class com.bstek.dorado.utils.variant.Variant
setDataType
setDataType(String) - Method in class com.bstek.dorado.utils.variant.Variant
setDataType
setDataType(int, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置默认数据类型
setDataType(int, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置默认数据类型
setDataType(String, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置默认数据类型
setDataType(String, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置默认数据类型
setDataType(int) - Method in class com.bstek.dorado.view.control.TextEditor
取得数据类型.
setDataType(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定数据类型.
setDataset(String) - Method in class com.bstek.dorado.view.control.DataControl
设定数据控件与指定的数据集(Dataset)绑定。
setDataset(String) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设定要提交的Dataset的id
setDataset(String) - Method in class com.bstek.dorado.view.control.command.RequestCommand
设定绑定的数据集
setDataset(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
根据指定的数据集名称，设定一个为数据集下拉框提供数据的数据集对象。
setDataset(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定绑定的数据集
setDate(String, Date) - Static method in class com.bstek.dorado.common.Setting
设定一个Date型的配置信息
setDate(String, Date) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Date型的配置信息
setDate(int, Date) - Method in interface com.bstek.dorado.data.Dataset
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in interface com.bstek.dorado.data.Dataset
按date类型设置当前记录中某字段的值。
setDate(int, Date) - Method in class com.bstek.dorado.data.DatasetAdapter
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.data.DatasetAdapter
按date类型设置当前记录中某字段的值。
setDate(int, Date) - Method in class com.bstek.dorado.data.DatasetSupport
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.data.DatasetSupport
按date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.data.Record
设定记录中某个date类型的字段值.
setDate(Date) - Method in class com.bstek.dorado.utils.variant.Variant
设置Date类型的数据
setDate(int, Date) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置Date类型的数据
setDate(String, Date) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置Date类型的数据
setDate(Date) - Method in class com.bstek.dorado.view.control.Calendar
设置日历默认的时间.
setDate(int, Date) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按Date类型设置当前记录中某字段的值。
setDate(String, Date) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按date类型设置当前记录中某字段的值。
setDefaultControlWidth(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中各个元素统一的缺省宽度值.
setDefaultControlWidth(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置自动表单中各个控件对象的缺省所占的宽度。
setDefaultElementMargin(int) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中每个元素缺省的空白边缘(Margin)值.
setDefaultLabelWidth(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的元素的标题的缺省宽度值.
setDefaultLocale(DoradoContext, Locale) - Method in class com.bstek.dorado.i18n.ResourceManager
设置当前会话的默认的地区与语种.
setDefaultLocale(DoradoContext, int, Locale) - Method in class com.bstek.dorado.i18n.ResourceManager
设置上下文对象中某一作用域的默认的地区与语种.
setDefaultValue(Object) - Method in interface com.bstek.dorado.data.Field
设定字段缺省值。
setDeleteSelectionOnSuccess(boolean) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设置对象提交成功后是否删除客户端Dataset中已经选中的记录。
setDescent(boolean) - Method in class com.bstek.dorado.data.db.SortRule
设定是否按照降序进行排序.
setDescription(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
Action的描述信息。
setDescription(String) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设定描述信息。
setDescription(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
Controller的描述信息。
setDescription(String) - Method in class com.bstek.dorado.action.mapping.Unit
Unit的描述信息。
setDetailDataset(ViewDataset) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定从数据集
setDetailKeyFields(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定从数据集中与主数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
setDetailKeyParameters(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
设置本节点层的顶层节点对应的数据集与父节点层相关联的参数名.
setDetailKeyParameters(String) - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
设置本节点层对应的数据集与父节点层相关联的参数名.
setDetailKeyParameters(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定从数据集中与主数据集关联的参数.如果此处需要描述多个参数,可以利用","分隔各参数名.
setDetailProperty(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定主数据集对应的数据对象中用于表示从数据对象的属性名.该属性一般只在主数据集与DO进行数据交换时才有效.
setDetailRecords(String, RecordSet) - Method in class com.bstek.dorado.data.Record
setDetailRecords
setDialect(Dialect) - Method in class com.bstek.dorado.data.db.DBDataset
设置此Dataset内部使用的数据库方言的实现类.
setDisableIcon(String) - Method in class com.bstek.dorado.view.control.MenuItem
设置菜单项失效时的图标的URL.
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.Button
设置按钮是否处于不可用状态.
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
setDisabled
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项是否无效.
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.command.Command
setDisabled
setDisabled(boolean) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设置当前标签项表格是否被禁止，被禁止的标签项上所有的元素都无法操作。
setDistinct(boolean) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
设定是否是用distinct关键字执行SQL查询
setDouble(String, double) - Static method in class com.bstek.dorado.common.Setting
设定一个Double型的配置信息
setDouble(String, double) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Double型的配置信息
setDouble(int, double) - Method in interface com.bstek.dorado.data.Dataset
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in interface com.bstek.dorado.data.Dataset
按double类型设置当前记录中某字段的值。
setDouble(int, double) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.data.DatasetAdapter
按double类型设置当前记录中某字段的值。
setDouble(int, double) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.data.DatasetSupport
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.data.Record
设定记录中某个Double类型的字段值.
setDouble(double) - Method in class com.bstek.dorado.utils.variant.Variant
设置double类型的数据
setDouble(int, double) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置double类型的数据
setDouble(String, double) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置double类型的数据
setDouble(int, double) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型设置当前记录中某字段的值。
setDouble(String, double) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按double类型设置当前记录中某字段的值。
setDown(boolean) - Method in class com.bstek.dorado.view.control.Button
设定按钮在初始化的时候是否是被按下的状态.
setDragMode(String) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动条的拖动类型.默认值为"mousemove".
setDraggable(boolean) - Method in class com.bstek.dorado.view.control.SplitPanel
设置是否允许拖动.默认为true.
setDraggable(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置是否允许通过拖动改变位置.
setDraggable(boolean) - Method in class com.bstek.dorado.view.control.tree.Tree
设置树状列表的节点是否允许拖动.
setDropDown(String) - Method in class com.bstek.dorado.view.control.RadioGroup
设定绑定的下拉框
setDropDown(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定相关联的下拉框.
setDropDown(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设置绑定的下拉框对象
setDropDown(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定字段关联的下拉框对象.
setDropDown(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定字段关联的下拉框对象.
setDropDown(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定字段关联的下拉框对象.
setEditable(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格是否允许用户编辑。
setEditorType(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定编辑器类型.
setEditorType(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设置编辑器的类型
取值范围: text - 文本框 textarea - 多行文本框 checkbox - 复选框 radiogroup - 单选框组合 password - 口令输入框
setEditorType(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框
setEditorType(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定与该字段关联的编辑器的类型.
setEditorType(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定与该字段关联的编辑器的类型.
取值范围:
  • text - 文本框
  • textarea - 多行文本框
  • checkbox - 复选框
  • radiogroup - 单选框组合
  • password - 口令输入框
setElement(FormElement) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设定AutoForm对象的元素
setElementMargin(int) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置自动表单中各个元素边缘空白的大小。
setEnabled(boolean) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置整个匹配规则是否有效。
setEnabled(boolean) - Method in class com.bstek.dorado.data.db.SortRule
设置该排序规则是否有效.
setError(Throwable) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
设定本次远程调用将要返回给客户端的异常.
setErrorMessage(String) - Method in interface com.bstek.dorado.view.data.validate.Validator
设定一个错误信息.
setErrorMessage(String) - Method in class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
设定一个对应的ErrorMessage。
setEscape(boolean) - Method in class com.bstek.dorado.view.control.Label
setEscape
setEscapeEnabled(boolean) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置是否要启用本匹配规则上的可逃逸功能.
setEscapeValue(String) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置逃逸值.
setExpandLevel(int) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
设置树默认展开到的层数
setExpandLevel(int) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
设置树默认展开到的层数
setExpanded(boolean) - Method in class com.bstek.dorado.view.control.GroupBox
设置组合框已展开.默认为true.
setExpanded(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置本组的内容是否已展开.默认只有第一个组是展开的.
setExpanded(boolean) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设置当在页面打开时该节点是否已被自动展开
setExpanded(boolean) - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
设置是否自动展开本层的节点
setExpandedIcon(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定节点展开图标的URL
setExpandedIcon(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点的展开图标的URL
setExpandedIconField(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定用于获取节点展开图标的URL的字段名
setField(String) - Method in class com.bstek.dorado.view.control.SimpleDataControl
设定一个简单数据控件(SimpleDataControl)关联的字段(Field)对象实例。
setField(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置该元素绑定的字段。
setField(String) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置表格列的数据来自于数据集的哪个字段。
setFieldSet(FieldSet) - Method in interface com.bstek.dorado.data.Dataset
设置Dataset的Field集合对象
setFieldSet(FieldSet) - Method in class com.bstek.dorado.data.DatasetAdapter
设置Dataset的Field集合对象
setFieldSet(FieldSet) - Method in class com.bstek.dorado.data.DatasetSupport
设置Dataset的Field集合对象
setFieldSet(FieldSet) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置Dataset的Field集合对象
setFile(String) - Method in class com.bstek.dorado.common.fileloader.FileLoader
设置要打开的文件。
setFilterOnOpen(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设置是否需要在每次打开时自动根据编辑框中的数据进行数据筛选。
setFilterParameter(String) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设定绑定的数据集中可用于实现动态数据筛选的参数 设置此属性之后下拉框中将出现一个筛选区域,用户可以利用这个区域实现数据动态筛选的功能.
setFirstGroupAsHeader(boolean) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的第一个组是否在页面上单独占用一行作为头行,而不受AutoForm布局方式(Layout)的影响.
setFitWidth(boolean) - Method in class com.bstek.dorado.view.control.MenuBar
设置是否自动调整菜单按钮的宽度以适应整个菜单栏的宽度.
setFixed(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
设定是否禁止用户不通过下拉选择而直接输入。
setFixedColumn(int) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格中被锁定列的个数
setFloat(String, float) - Static method in class com.bstek.dorado.common.Setting
设定一个Float型的配置信息
setFloat(String, float) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Float型的配置信息
setFloat(int, float) - Method in interface com.bstek.dorado.data.Dataset
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in interface com.bstek.dorado.data.Dataset
按float类型设置当前记录中某字段的值。
setFloat(int, float) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.data.DatasetAdapter
按float类型设置当前记录中某字段的值。
setFloat(int, float) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.data.DatasetSupport
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.data.Record
设定记录中某个float类型的字段值.
setFloat(float) - Method in class com.bstek.dorado.utils.variant.Variant
设置float类型的数据
setFloat(int, float) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置float类型的数据
setFloat(String, float) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置float类型的数据
setFloat(int, float) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型设置当前记录中某字段的值。
setFloat(String, float) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按float类型设置当前记录中某字段的值。
setFlushDataOnSuccess(boolean) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设置当提交成功后是否刷新客户端Dataset中的数据。
setFooterHeight(int) - Method in class com.bstek.dorado.view.control.table.Table
设置合计栏位的高度
setFooterValue(String) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置列的列脚值.此数值最终将被显示在表格中的该列对应的列脚单元格中.
setFormat(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.
setFormat(String) - Method in interface com.bstek.dorado.view.data.ViewField
设置字段数据的格式化串格式.
setFormat(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设置字段数据的格式化串格式. 此属性目前只对数值类型和日期类型的字段有效.
setGroup(boolean) - Method in class com.bstek.dorado.data.db.AutoDBField
设置AutoSqlDataset查询SQL的group子句中是否包含该字段.
setGroupType(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中分组的显示类型.
setHasChild(boolean) - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
设定节点是否有子节点.
setHasChild(boolean) - Method in class com.bstek.dorado.view.control.tree.TreeNode
设定当前树节点是否有子节点。
setHeaderClickable(boolean) - Method in class com.bstek.dorado.view.control.table.DataColumnGroup
设置数据表格的该列标题是否支持单击操作。
setHeaderClickable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设置数据表格的该列标题是否支持单击操作。
setHeaderHeight(int) - Method in class com.bstek.dorado.view.control.table.Table
设置表格列标题的高度
setHeight(String) - Method in interface com.bstek.dorado.view.control.Placeable
设置控件的高度
setHeight(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
设置控件的高度
setHeight(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
设置控件的高度
setHeight(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设定AutoForm的高度.
setHeight(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组的高度值。
setHeight(int) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架的高度值.
setHeight(int) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
设定下拉框的默认高度
setHighlightSelection(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置是否高亮显示表格中的当前记录.默认将会高亮显示。
setHighlightSelection(boolean) - Method in class com.bstek.dorado.view.control.tree.Tree
设置通过复选框选中记录后是否将记录进行高亮显示.
setIcon(String) - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
setIcon
setIcon(String) - Method in class com.bstek.dorado.view.control.MenuItem
设置菜单项的图标的URL.
setIcon(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定节点图标的URL
setIcon(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点的图标的URL
setIconField(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定用于获取节点图标的URL的字段名
setId(String) - Method in interface com.bstek.dorado.data.Dataset
设置Dataset的ID
setId(String) - Method in class com.bstek.dorado.data.DatasetAdapter
设置Dataset的ID
setId(String) - Method in class com.bstek.dorado.data.DatasetSupport
设置Dataset的ID
setIgnored(boolean) - Method in interface com.bstek.dorado.view.Component
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
setIgnored(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设置是否忽略该控件对象，如果为True则不在页面上生成该控件。
setInsertOnEmpty(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定在数据集在客户端初试化时如果数据集为空是是否自动插入新记录.
setInsertOnEmpty(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设置需要在Dataset为空时自动插入新的记录, 该属性只在Dataset第一次在Client端创建时生效.
setInt(String, int) - Static method in class com.bstek.dorado.common.Setting
设定一个Int型的配置信息
setInt(String, int) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Int型的配置信息
setInt(int, int) - Method in interface com.bstek.dorado.data.Dataset
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in interface com.bstek.dorado.data.Dataset
按int类型设置当前记录中某字段的值。
setInt(int, int) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.data.DatasetAdapter
按int类型设置当前记录中某字段的值。
setInt(int, int) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.data.DatasetSupport
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.data.Record
设定记录中某个int类型的字段值.
setInt(int) - Method in class com.bstek.dorado.utils.variant.Variant
设置int类型的数据
setInt(int, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置int类型的数据
setInt(String, int) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置int类型的数据
setInt(int, int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型设置当前记录中某字段的值。
setInt(String, int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按int类型设置当前记录中某字段的值。
setKeyFields(String) - Method in class com.bstek.dorado.data.LookupField
Dataset与LookupDataset之间的字段匹配关系。
setKeyFields(String) - Method in class com.bstek.dorado.data.db.DBDataset
取得此Dataset的主表的主键字段.
setKeyFields(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置用于建立关联的关联表中的字段.
setKind(String) - Method in class com.bstek.dorado.data.db.AndOrMatchRule
设置该逻辑连接符的类型.
setLabel(String) - Method in interface com.bstek.dorado.data.Field
设定字段列的标题。
setLabel(String) - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
setLabel
setLabel(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项标题.
setLabel(String) - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
设置下拉框(DropDown)对应的字段(Field)的标题(Label)。
setLabel(String) - Method in class com.bstek.dorado.view.control.table.Column
设置列的标题。
setLabel(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定多页标签表格的标题。
setLabel(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定当前树节点的标题
setLabelAlign(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置字段标题的水平对齐方式。
setLabelField(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设定作为最终显示内容的字段
setLabelField(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定用于获取节点标题的字段名
setLabelVAlign(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置字段标题的垂直对齐方式。
setLabelWidth(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置自动表单中的各个元素标题的宽度值。
setLastGroupAsFooter(boolean) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的最后一个组是否单独占一行作为尾行,而不受布局方式的影响.
setLayout(String) - Method in class com.bstek.dorado.view.control.RadioGroup
设定内部对象的排列方式
setLayout(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm中元素的布局.该属性定义元素所在的组之间的布局方式,分为horizontal和vertical两种.
setLeft(String) - Method in interface com.bstek.dorado.view.control.Placeable
设置控件距离父对象左边的距离
setLeft(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
设置控件距离父对象左边的距离
setLeft(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
设置控件距离父对象左边的距离
setLeft(int) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架左边距值.
setLevel(int) - Static method in class com.bstek.dorado.common.log.Log
设置日志记录器的日志级别。
setLevel(int) - Method in class com.bstek.dorado.data.db.AndOrMatchRule
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.
setLevel(int) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置该规则对象的级数.
该级数的默认值为1.级数的设定与WHERE片断中的括号生成相关. 当某几个规则对象的级数高于周围的其它规则对象时,AutoSqlDataset会在生成WHERE片断时自动在这几个规则对象的两端生成一对括号.
setLevel(int) - Method in interface com.bstek.dorado.data.db.MatchRule
设置该规则对象的级数.
setLevel(TreeLevel) - Method in class com.bstek.dorado.view.control.tree.RecordTreeNode
设置树节点相关的节点层对象.
setLoadDataAction(String) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
setLoadDataAction(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定dataset在进行动态数据下载时应将XMLHTTP请求发往何处.
setLong(String, long) - Static method in class com.bstek.dorado.common.Setting
设定一个Long型的配置信息
setLong(String, long) - Static method in class com.bstek.dorado.common.UserConfig
设定一个Long型的配置信息
setLong(int, long) - Method in interface com.bstek.dorado.data.Dataset
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in interface com.bstek.dorado.data.Dataset
按long类型设置当前记录中某字段的值。
setLong(int, long) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.data.DatasetAdapter
按long类型设置当前记录中某字段的值。
setLong(int, long) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.data.DatasetSupport
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.data.Record
设定记录中某个long类型的字段值.
setLong(long) - Method in class com.bstek.dorado.utils.variant.Variant
设置long类型的数据
setLong(int, long) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置long类型的数据
setLong(String, long) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置long类型的数据
setLong(int, long) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型设置当前记录中某字段的值。
setLong(String, long) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按long类型设置当前记录中某字段的值。
setLookupDataset(Dataset) - Method in class com.bstek.dorado.data.LookupField
设置作为Lookup数据来源的Dataset对象。
setLookupField(String) - Method in class com.bstek.dorado.data.LookupField
设置LookupDataset中将被作为数据返回的字段的名称。
setLookupKeyFields(String) - Method in class com.bstek.dorado.data.LookupField
设定Dataset与LookupDataset之间的字段匹配关系。
setMasterDataset(ViewDataset) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设置主数据集
setMasterKeyFields(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
设置父节点层对应的数据集中跟本节点层的顶层节点相关联的字段名.
setMasterKeyFields(String) - Method in class com.bstek.dorado.view.control.tree.SimpleTreeLevel
设置父节点层对应的数据集中跟本节点层相关联的字段名.
setMasterKeyFields(String) - Method in class com.bstek.dorado.view.data.MasterDetailLink
设定主数据集中与从数据集关联的字段.如果此处需要描述多个字段,可以利用","分隔各字段名.
setMasterLink(MasterDetailLink) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定描述该Dataset与MasterDataset之间的关联关系的对象。
setMasterLink(MasterDetailLink) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定描述该Dataset与MasterDataset之间的关联关系的对象。
setMax(int) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条最大可取值。
setMax(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动条可滚动到的最大位置值.
setMax(double) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定范围最大值
setMaxLength(int) - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
设定最大长度值。
setMaxLink(int) - Method in class com.bstek.dorado.view.control.PagePilot
取得页码导航条(PagePilot)最大连续可见页数。
setMaxMatchRule(String) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定最大值匹配规则.
setMaxPropertyLevel(int) - Method in interface com.bstek.dorado.data.Dataset
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
setMaxPropertyLevel(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
setMaxPropertyLevel(int) - Method in class com.bstek.dorado.data.DatasetSupport
设置当Dataset试图根据objectClazz属性的设置自动利用反射机制创建Field时,遍历对象属性的深度.
setMaxRow(int) - Method in class com.bstek.dorado.view.control.table.DataTable
设定数据表格能够显示的最大记录条数。
setMenu(String) - Method in class com.bstek.dorado.view.control.Button
设定与按钮绑定的菜单.
setMenu(String) - Method in class com.bstek.dorado.view.control.MenuBar
设定与菜单栏绑定的菜单对象.
setMenu(String) - Method in class com.bstek.dorado.view.control.OutlookBar
设定绑定的菜单对象.
setMessage(String) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
设定本次远程调用将要返回给客户端的提示信息.
setMethod(String) - Method in class com.bstek.dorado.view.control.command.RPCCommand
指定执行此命令时在ViewModel的实现类中激活的方法名.
setMethod(String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
指定执行此命令时在ViewModel的实现类中触发的方法名.
setMin(int) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条最小可取值。
setMin(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动条可滚动到的最小位置值.
setMin(double) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定范围的最小值
setMinLength(int) - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
设定最小长度值。
setMinMatchRule(String) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
设定最小值匹配规则
取值范围: ignore - 忽略 allow_equals - 允许等于 not_allow_equals - 不允许等于
setName(String) - Method in class com.bstek.dorado.action.Controller
设定Controller的别名。
setName(String) - Method in interface com.bstek.dorado.data.Field
设定字段名称。
setName(String) - Method in class com.bstek.dorado.module.ModuleSupport
setName(String) - Method in class com.bstek.dorado.view.Event
设置事件名
setName(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项名称.
setName(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定多页标签表格的名称。
setNamespace(String) - Method in interface com.bstek.dorado.view.ViewModel
设定视图配置命名空间
setNamespace(String) - Method in class com.bstek.dorado.view.ViewModelSupport
setNamespace
setNoClient(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定是否不在客户端创建记录集对象.
setNoClient(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
setNoClient
setNoWrap(boolean) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置是否允许该列的内容换行显示。
setNull(int) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值是否为空(null)。
setNull(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNull(int) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.data.Record
设置记录中某字段的值是否为空(null).
setNull() - Method in class com.bstek.dorado.utils.variant.Variant
设置为空(null)
setNull(int) - Method in class com.bstek.dorado.utils.variant.VariantSet
设置给定索引号下的数值为空(null)
setNull(String) - Method in class com.bstek.dorado.utils.variant.VariantSet
设置给定键值下的数值为空(null)
setNull(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNull(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值是否为空(null)。
setNullable(boolean) - Method in interface com.bstek.dorado.data.Field
设定字段是否可以为空。
setObjectClazz(Class) - Method in interface com.bstek.dorado.data.Dataset
设置相关的对象类型的Class名.
setObjectClazz(String) - Method in interface com.bstek.dorado.data.Dataset
设置相关的对象类型的Class名.
setObjectClazz(String) - Method in class com.bstek.dorado.data.DatasetAdapter
设置相关的对象类型的Class名.
setObjectClazz(Class) - Method in class com.bstek.dorado.data.DatasetAdapter
设置相关的对象类型的Class名.
setObjectClazz(Class) - Method in class com.bstek.dorado.data.DatasetSupport
设置相关的对象类型的Class名.
setObjectClazz(String) - Method in class com.bstek.dorado.data.DatasetSupport
设置相关的对象类型的Class名.
setOffValue(String) - Method in class com.bstek.dorado.view.control.CheckBox
设定复选框未选中时代表的值.
setOldDO(Object, Object) - Method in class com.bstek.dorado.data.DOSet
为DOSet中某个DO指定一个保存其修改之前的数据的DO.
setOnValue(String) - Method in class com.bstek.dorado.view.control.CheckBox
设定复选框选中时代表的值.
setOpenMode(String) - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
设定自定义下拉框的打开方式.
setOperator(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设定比较操作符。
setOrientation(String) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条对象(ProgressBar)的类型。
setOrientation(String) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动条的方向.默认为"horizontal".
setOrientation(String) - Method in class com.bstek.dorado.view.control.SplitPanel
设置视图分割栏方向.默认为"horizontal".
setOriginField(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设定匹配规则的原始字段。
setOriginField(String) - Method in class com.bstek.dorado.data.db.DBField
设置该字段来自于哪个数据库物理字段。
setOriginField(String) - Method in class com.bstek.dorado.data.db.SortRule
设定该排序规则对应的字段名.
setOriginTable(String) - Method in class com.bstek.dorado.data.db.DBDataset
设置此Dataset的主表的物理表名.
setOriginTable(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置关联表的物理表名.
setOutlookBar(OutlookBar) - Method in class com.bstek.dorado.view.control.OutlookBarGroup
setOutlookBar
setPadding(String) - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
setPadding
setPadding(int) - Method in class com.bstek.dorado.view.control.SplitPanel
设置视图分割栏四周留白的宽度.
setPadding(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设置标签页的边缘空白
setPageCount(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset所对应的数据共有几页。
setPageCount(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset所对应的数据共有几页。
setPageCount(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset所对应的数据共有几页。
setPageCount(int) - Method in class com.bstek.dorado.data.RecordSet
设置整个结果集可能包含的页数.
setPageCount(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset所对应的数据共有几页。
setPageIndex(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset的当前页号
setPageIndex(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset的当前页号
setPageIndex(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset的当前页号
setPageIndex(int) - Method in class com.bstek.dorado.data.PagingHelper
设置页号。
setPageIndex(int) - Method in class com.bstek.dorado.data.RecordSet
设置当前RecordSet对象中管理的Record在整个结果集中所处的页号.
setPageIndex(int) - Method in class com.bstek.dorado.data.RecordWrapper
设置当前管理的Record在整个结果集中所处的页号.
setPageIndex(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset的当前页号
setPageSize(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset分页时的每页记录数
setPageSize(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset分页时的每页记录数
setPageSize(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset分页时的每页记录数
setPageSize(int) - Method in class com.bstek.dorado.data.PagingHelper
设置每页的记录数。
setPageSize(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置对应的可见区域的大小.此属性与滚动条中滑块的大小有关.
setPageSize(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset分页时的每页记录数
setParameterFields(String) - Method in class com.bstek.dorado.view.control.command.RequestCommand
设置绑定数据集中将作为参数的字段.
setParameters(String) - Method in class com.bstek.dorado.view.Event
设置事件参数描述
setPath(String) - Method in class com.bstek.dorado.action.mapping.ActionTarget
跳转目标的路径
setPath(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定单击菜单项时要打开的URL路径.
setPath(String) - Method in class com.bstek.dorado.view.control.command.RequestCommand
设定命令要激活的URL资源
setPath(String) - Method in class com.bstek.dorado.view.control.dropdown.CustomDropDown
设定下拉框将要打开的url路径.即绑定的下拉页面的url.
setPath(String) - Method in class com.bstek.dorado.view.control.tabset.FrameTab
设定多页标签切换时需要跳转的URL路径。
setPath(String) - Method in class com.bstek.dorado.view.control.tree.DefaultTreeNode
设定选中该节点时要自动激活到的URL
setPathField(String) - Method in class com.bstek.dorado.view.control.tree.BindingTreeLevel
设定用于获取节点对应的URL的字段名
setPattern(String) - Method in class com.bstek.dorado.view.control.table.StaticColumn
取得静态列的模式
setPattern(String) - Method in class com.bstek.dorado.view.data.validate.impl.PatternValidator
设置正则表达式
setPilotType(String) - Method in class com.bstek.dorado.view.control.PagePilot
设置分页导航对象的类型，可取值为"link","button"。
setPopupContainer(String) - Method in class com.bstek.dorado.view.control.Menu
取得弹出式菜单的容器的ID.
setPosition(int) - Method in class com.bstek.dorado.view.control.ProgressBar
设置进度条进度位置。
setPosition(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动条的默认所处位置值.
setPosition(String) - Method in class com.bstek.dorado.view.control.SplitPanel
设定视图分割栏中滑动条的默认位置.
setPossibleCount(int) - Method in class com.bstek.dorado.data.RecordSet
设置整个结果集可能包含的记录数.
setPossibleRecordCount(int) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset可能存在的总记录数。
setPossibleRecordCount(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset可能存在的总记录数。
setPossibleRecordCount(int) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset可能存在的总记录数。
setPrefix(String) - Method in class com.bstek.dorado.action.mapping.Unit
设置配置单元的URL前缀
setProperty(String) - Method in interface com.bstek.dorado.data.Field
设置该字段对应的属性名.
setPropertyValue(Object, String[], Object) - Static method in class com.bstek.dorado.data.Record
setQueryDataset(String) - Method in class com.bstek.dorado.view.control.command.QueryCommand
设置被查询的数据集
setQueryMode(String) - Method in class com.bstek.dorado.view.control.command.QueryCommand
设置查询模式.
setReadFields(String) - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
设置下拉框中需要从下拉选择的记录中读取的字段.
setReadFields(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设置下拉框中需要从下拉选择的记录中读取的字段.
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.Editor
设置编辑框是否只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设置AutoForm的只读属性.
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格是否是只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定列是否只读。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定该字段是否只读.
setReadOnly(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设定数据集的只读属性。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定数据集的只读属性。
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定数据集的只读属性。
setReadOnly(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设定该字段是否只读.
setReadOnly(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定该字段是否只读.
setRecord(Record) - Method in class com.bstek.dorado.view.control.tree.RecordTreeNode
设置树节点所绑定的记录对象.
setRecordFilter(RecordFilter) - Method in interface com.bstek.dorado.data.Dataset
设置Dataset内部使用的记录过滤器.
setRecordFilter(RecordFilter) - Method in class com.bstek.dorado.data.DatasetAdapter
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

setRecordFilter(RecordFilter) - Method in class com.bstek.dorado.data.DatasetSupport
设置Dataset内部使用的记录过滤器.

通过调用此方法我们可以改变Dataset中可见的记录. 例如我们可以设定一个特定的记录过滤器以便使被标记为已删除的记录成为可见的记录

setRecordId(long) - Method in class com.bstek.dorado.data.Record
设置当前记录的id.此id一般是自动生成的,您不需要手工设定.
setRecordSet(RecordSet) - Method in interface com.bstek.dorado.data.Dataset
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.data.DatasetAdapter
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.data.DatasetSupport
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定Dataset的Record集合对象
setRecordSet(RecordSet) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定Dataset的Record集合对象
setRecordState(int) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录的状态
setRecordState(int) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录的状态
setRecordState(int) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录的状态
setRecordState(int) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录的状态
setRecursiveKeyFields(String) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
setRecursiveKeyFields(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回进行子节点数据查询时要从数据集中取出哪些字段的值作为查询参数.
setRecursiveKeyParameters(String) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
setRecursiveKeyParameters(String) - Method in class com.bstek.dorado.view.control.tree.RecursiveTreeLevel
返回进行子节点数据查询时要将从数据集中取出值设置到哪些查询参数中.
setRedirect(boolean) - Method in class com.bstek.dorado.action.mapping.ActionForward
是否以sendRedirect的方式转向新的path。
setRendererType(String) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设置表格单元格渲染器的类型
取值范围: label - 文本标签 text - 文本框 textarea - 多行文本框 checkbox - 复选框 radiogroup - 单选框组合 password - 口令输入框
setRequest(HttpServletRequest) - Method in class com.bstek.dorado.common.HttpDoradoContext
设置被封装的HttpServletRequest对象
setResizable(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置是否允许改变大小.
setResizable(boolean) - Method in class com.bstek.dorado.view.control.command.Frame
设置新窗口是否支持用户调整窗口尺寸.
setResizable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定是否支持客户端用户对该列进行宽度调整操作。
setRetrieveAfterUpdate(boolean) - Method in class com.bstek.dorado.data.db.DBDataset
是否需要在完成某条记录的更新后对该记录进行重新查询.
setRole(String) - Method in interface com.bstek.dorado.view.ViewModel
设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.
setRole(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设置与视图模型相关的角色.如果此处需要描述多个角色,可以使用","分隔各角色名.
setRootNode(XmlNode) - Method in interface com.bstek.dorado.utils.xml.XmlDocument
设置根节点。
setRow(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设定某行为当前行。
setRowHeight(int) - Method in class com.bstek.dorado.view.control.table.Table
设置表格数据行的高度
setRowSpan(int) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置该元素将占用自动表单中的多少行，该属性类似Table的RowSpan属性。
setRowSpan(int) - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
设置组(Group)中当前元素所占的行的跨度数。
setSafe(boolean) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置用户访问视图页面时是否对用户身份进行检验。
setSafe(boolean) - Method in interface com.bstek.dorado.view.ViewModel
设置用户访问视图页面时是否对用户身份进行检验。
setSafe(boolean) - Method in class com.bstek.dorado.view.ViewModelSupport
设置用户访问视图页面时是否对用户身份进行检验。如果该属性设为True时，Dorado将通过 工程配置文件setting.xml文件中的accessChecker属性定义的安全检查类对用户进行安全检验， 只有符合规定的特定用户才允许访问该视图页面。
setScope(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
设置Model的作用域范围
setScript(String) - Method in class com.bstek.dorado.view.EventHandler
设定事件脚本
setScrollMode(String) - Method in class com.bstek.dorado.view.control.table.DataTable
设置数据表格垂直滚动条的滚动方式.取值范围: simple - 简单的滚动方式,指对表格的可见区域进行滚动.
setSelectAllField(boolean) - Method in class com.bstek.dorado.data.db.AutoSqlDataset
设置是否自动检索出AutoSqlDataset对应的主表(originTable)中所有的字段。
setShort(int, short) - Method in interface com.bstek.dorado.data.Dataset
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in interface com.bstek.dorado.data.Dataset
按short类型设置当前记录中某字段的值。
setShort(int, short) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.data.DatasetAdapter
按short类型设置当前记录中某字段的值。
setShort(int, short) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.data.DatasetSupport
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.data.Record
设定记录中某个short类型的字段值.
setShort(short) - Method in class com.bstek.dorado.utils.variant.Variant
设置short类型的数据
setShort(int, short) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置short类型的数据
setShort(String, short) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置short类型的数据
setShort(int, short) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型设置当前记录中某字段的值。
setShort(String, short) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按short类型设置当前记录中某字段的值。
setShowBevel(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置是否显示组的边框线，缺省为显示。
setShowBorder(boolean) - Method in class com.bstek.dorado.view.control.MenuBar
设置是否显示菜单栏的边框.
setShowButtons(boolean) - Method in class com.bstek.dorado.view.control.SplitPanel
设置是否视图分割栏上的快捷按钮.
setShowCloseButton(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置是否显示关闭系统按钮.
setShowColumnHeader(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设定是否显示数据集下拉框中数据列的标题行。
setShowColumnHeader(boolean) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设定是否显示数据集下拉框中数据列的标题行。
setShowDraggingTip(String) - Method in class com.bstek.dorado.view.control.ScrollBar
设置滚动条拖动时是否显示系统提示信息.
setShowExpandButton(boolean) - Method in class com.bstek.dorado.view.control.GroupBox
设置是否显示展开按钮..默认为true.
setShowFooter(boolean) - Method in class com.bstek.dorado.view.control.table.Table
设定是否显示表格的汇总栏，默认是显示。
setShowFrame(boolean) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定是否显示多页标签的外框架。
setShowGotoButton(boolean) - Method in class com.bstek.dorado.view.control.PagePilot
设置是否显示跳转到按钮(GotoButton)。
setShowHScrollBar(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置是否显示横向滚动栏,默认是显示
setShowHeader(boolean) - Method in class com.bstek.dorado.view.control.table.Table
设定是否显示表格的标题栏，默认是显示。
setShowIndicator(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置在数据表格中是否显示表格指示器箭头。
setShowLabel(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设置是否显示字段标题。
setShowLoadingTip(boolean) - Method in class com.bstek.dorado.view.control.command.QueryCommand
设置命令执行时是否显示提示窗口
setShowLoadingTip(boolean) - Method in class com.bstek.dorado.view.control.command.RPCCommand
设置命令执行时是否显示提示窗口
setShowLoadingTip(boolean) - Method in interface com.bstek.dorado.view.data.ViewDataset
设置执行动态数据加载时是否显示提示窗口
setShowLoadingTip(boolean) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设置执行动态数据加载时是否显示提示窗口
setShowMaximizeButton(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置是否显示最大化按钮.
setShowMinimizeButton(boolean) - Method in class com.bstek.dorado.view.control.SubWindow
设置是否显示最小化按钮.
setShowPageInfo(boolean) - Method in class com.bstek.dorado.view.control.PagePilot
设置是否显示页信息。
setShowText(boolean) - Method in class com.bstek.dorado.view.control.ProgressBar
设置是否显示数据，否则只显示进度信息。
setShowVScrollBar(boolean) - Method in class com.bstek.dorado.view.control.table.DataTable
设置是否显示纵向滚动栏,默认是显示
setSkin(String) - Method in interface com.bstek.dorado.view.ViewModel
设定视图模型使用的皮肤
setSkin(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设定视图模型使用的皮肤
setSmallChange(int) - Method in class com.bstek.dorado.view.control.ScrollBar
设置当用户点击两个滚动按钮时引起的滚动量.
setSortable(boolean) - Method in class com.bstek.dorado.view.control.table.EditableColumn
设定是否支持客户端用户对该列进行排序操作。
setSourceDataset(String) - Method in class com.bstek.dorado.view.data.DatasetReference
设定引用的源数据集
setSourceKeyFields(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置用于建立关联的源表中的字段.
setSourceModule(String) - Method in class com.bstek.dorado.view.data.DatasetReference
设定从哪个源数据集模块中取得数据。
setSourceTable(String) - Method in class com.bstek.dorado.data.db.JoinTable
设置与关联表相对应的源表.
setSql(String) - Method in class com.bstek.dorado.data.db.AutoDBField
设置此Field的自定义SQL。
setSql(String, String) - Method in class com.bstek.dorado.data.db.DBStatement
利用SQL类型和表名快速设置DBStatement的SQL命令.
setSql(String, String, String) - Method in class com.bstek.dorado.data.db.DBStatement
利用SQL类型、表名和主键字段描述快速设置DBStatement的SQL命令.
setSql(String) - Method in class com.bstek.dorado.data.db.DBStatement
直接设置SQL命令.
setSql(String) - Method in class com.bstek.dorado.data.db.SqlDataset
设置SqlDataset的SQL查询命令。
setSql(String) - Method in class com.bstek.dorado.data.db.SqlMatchRule
设置自定义SQL.
setSqlDataType(int) - Method in class com.bstek.dorado.data.db.DBField
设置该字段在数据库中的数据类型。
setState(int) - Method in interface com.bstek.dorado.data.Dataset
更改当前记录集的当前状态
setState(int) - Method in class com.bstek.dorado.data.DatasetAdapter
更改当前记录集的当前状态
setState(int) - Method in class com.bstek.dorado.data.DatasetSupport
更改当前记录集的当前状态
setStatus(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置窗体状态.默认值为"normal".
setStatusbar(boolean) - Method in class com.bstek.dorado.view.control.command.Frame
设置目新窗口是否有状态栏.
setString(String, String) - Static method in class com.bstek.dorado.common.Setting
设置一个String型的配置信息
setString(String, String) - Static method in class com.bstek.dorado.common.UserConfig
设置一个String型的配置信息
setString(int, String) - Method in interface com.bstek.dorado.data.Dataset
按String类型设置当前记录中某字段的值。
setString(String, String) - Method in interface com.bstek.dorado.data.Dataset
按String类型设置当前记录中某字段的值。
setString(int, String) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.data.DatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(int, String) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.data.DatasetSupport
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.data.Record
设置记录中指定的字符字段的值.
setString(String) - Method in class com.bstek.dorado.utils.variant.Variant
设置String类型的数据
setString(int, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置String类型的数据
setString(String, String) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置String类型的数据
setString(int, String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setString(String, String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
按String类型设置当前记录中某字段的值。 如果该字段的值不是一个有效的String值，该方法将返回""而非null。
setStyle(String) - Method in interface com.bstek.dorado.view.control.Placeable
返回控件的风格设置
setStyle(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
返回控件的风格设置
setStyle(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
返回控件的风格设置
setSubmitScope(String) - Method in class com.bstek.dorado.view.control.command.DatasetInfo
设定Dataset的提交方式,包含以下四种方式： all - 提交Dataset中所有的记录； all-change - 只提交Dataset中所有更改过的记录； current - 只提交Dataset的当前记录； selected - 只提交Dataset中所有通过Select复选框选中的记录。
setSucceed(boolean) - Method in interface com.bstek.dorado.view.rpc.RPCHandler
设定本次远程调用是否已经成功.
setSupportsPaging(boolean) - Method in class com.bstek.dorado.view.data.DODataset
设置是否支持自动根据pageSize和pageIndex属性的值确定数据的分页方式.默认值为false.
setSupportsSum(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设置是否允许数据集自动在Client端统计该字段的合计值.
setSupportsSum(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设置是否允许数据集自动在Client端统计该字段的合计值.
setSupportsSum(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
setTabPlacement(String) - Method in class com.bstek.dorado.view.control.tabset.TabSet
设定多页标签所在的位置.
setTabSet(TabSet) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定标签所属的TabSet对象
setTable(String) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置原始字段(originField)所属的表名。
setTable(String) - Method in class com.bstek.dorado.data.db.DBField
设置该字段所属的数据库物理表名.
setTable(String) - Method in class com.bstek.dorado.data.db.SortRule
设置原始字段(originField)所属的表别名.
setTag(String) - Method in class com.bstek.dorado.action.mapping.ActionConfig
设定自定义信息.此属性中的值用户可以自行解释,dorado不会做任何处理.
setTag(String) - Method in class com.bstek.dorado.action.mapping.ActionTarget
设置自定义信息。
setTag(String) - Method in class com.bstek.dorado.action.mapping.ControllerConfig
用户自定义信息。
setTag(String) - Method in interface com.bstek.dorado.view.Element
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.ViewModelSupport
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.control.MenuItem
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.control.OutlookBarGroup
setTag
setTag(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.control.table.Column
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.control.tree.TreeNode
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
设定元素的用户自定义信息。
setTag(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定元素的用户自定义信息。
setTag(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定元素的用户自定义信息。
setTarget(Dataset) - Method in class com.bstek.dorado.data.DatasetAdapter
设定适配器的目标Dataset
setTarget(String) - Method in class com.bstek.dorado.view.control.Menu
设定弹出式菜单需要刷新的目标框架.该属性一般只与菜单项中的path属性配合使用.
setTarget(String) - Method in class com.bstek.dorado.view.control.command.Frame
设置在哪个目标框架中打开新页面.
setTarget(String) - Method in class com.bstek.dorado.view.control.tree.Tree
设定树状列表要刷新的目标框架.
setTarget(ViewDataset) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设定被适配的数据集
setText(String) - Method in class com.bstek.dorado.view.control.Label
设定标题的文本内容。
setTextPattern(String) - Method in class com.bstek.dorado.view.control.ProgressBar
设置文本格式，通过设置该格式，我们可以自定义显示格式。
setTitle(String) - Method in class com.bstek.dorado.view.control.GroupBox
设置组合框标题.
setTitle(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置子窗体标题.
setTitle(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组的标题，通常为文字描述信息。
setTitleClickAction(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置当用户单击窗体标题栏时执行的操作.默认值为null(即不做动作).
setTitleDblClickAction(String) - Method in class com.bstek.dorado.view.control.SubWindow
设置当用户双击窗体标题栏时执行的操作.默认值为"maximize".
setToolTip(String) - Method in class com.bstek.dorado.view.control.Button
设定按钮的弹出式提示.
setToolTip(String) - Method in class com.bstek.dorado.view.control.CheckBox
设定弹出式提示(ToolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.control.Editor
设定该编辑器的弹出式提示信息。
setToolTip(String) - Method in class com.bstek.dorado.view.control.RadioGroup
设定弹出式提示(ToolTip)。
setToolTip(String) - Method in class com.bstek.dorado.view.control.table.Column
设置该列的弹出式提示。
setToolTip(String) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定字段的弹出式提示信息.
setToolTip(String) - Method in interface com.bstek.dorado.view.data.ViewField
设定字段的弹出式提示信息.
setToolTip(String) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定字段的弹出式提示信息.
setTop(String) - Method in interface com.bstek.dorado.view.control.Placeable
设置距离父对象顶边的距离
setTop(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
设置距离父对象顶边的距离
setTop(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
设置距离父对象顶边的距离
setTop(int) - Method in class com.bstek.dorado.view.control.command.Frame
设置目标框架上部边距值.
setTotalRow(int) - Method in class com.bstek.dorado.data.PagingHelper
设置结果集的总记录数。
setTransactionMode(int) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
设定事务模式.
setTransactionMode(String) - Method in class com.bstek.dorado.view.control.command.UpdateCommand
设定事务模式.
setTreeColumn(String) - Method in class com.bstek.dorado.view.control.advance.TreeGrid
设置具有数据展开功能的列.
setUpdatable(boolean) - Method in class com.bstek.dorado.data.db.DBField
设置该字段是否可向数据库中更新
setUseSqlParameter(boolean) - Method in class com.bstek.dorado.data.db.BaseMatchRule
设置是否在生成SQL时使用数据库预编译参数.默认为true.
setValue(int, Object) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值。
setValue(String, Object) - Method in interface com.bstek.dorado.data.Dataset
设置当前记录中某字段的值。
setValue(int, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
设置当前记录中某字段的值。
setValue(int, Object) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.data.DatasetSupport
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.data.Record
直接设置记录中某字段的对应值对象
setValue(String) - Method in class com.bstek.dorado.data.db.CommonMatchRule
设置匹配值.
setValue(Object) - Method in class com.bstek.dorado.utils.variant.Variant
设置Object类型的数据
setValue(int, Object) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据索引号设置Object类型的数据
setValue(String, Object) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置Object类型的数据
setValue(String) - Method in class com.bstek.dorado.view.control.Button
设置按钮的值.
setValue(String) - Method in class com.bstek.dorado.view.control.TextEditor
设定文本编辑器的默认值
setValue(String) - Method in class com.bstek.dorado.view.control.dropdown.DropDownItem
设定下拉框(DropDown)当前选择项为指定的值。
setValue(int, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值。
setValue(String, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
设置当前记录中某字段的值。
setValueField(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设定作为内部数值的字段
setValueProtected(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

setValueProtected(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设定字段是否有数据保护功能 保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据.
setValueProtected(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
设定字段是否有数据保护功能

保护功能表示用户只能新增记录时编辑该字段中的数值,而不能修改已经存在于数据集中的数据. 例如: 我们可以将保护功能使用在合同单号字段上,因为合同一旦保存往往不能再修改单号.

setValues(String) - Method in class com.bstek.dorado.view.data.validate.impl.ListValidator
设定指定的一组校验值
setVariant(String, Variant) - Method in class com.bstek.dorado.data.ParameterSet
根据键值设置Variant类型的数据
setVariant(String, Variant) - Method in class com.bstek.dorado.data.db.CaseInsensitiveVariantSet
Deprecated.
setVariant(String, Variant) - Method in class com.bstek.dorado.utils.variant.VariantSet
根据键值设置Variant类型的数据
setViewMode(String) - Method in class com.bstek.dorado.view.control.MenuOutlookBarGroup
setViewMode
setVisibility(String) - Method in class com.bstek.dorado.data.RecordIterator
设置迭代器的记录可见性
setVisibility(String) - Method in class com.bstek.dorado.view.control.autoform.FormElement
设定该元素是否在页面上可见。
setVisible(boolean) - Method in class com.bstek.dorado.view.control.DefaultOutlookBarGroup
setVisible
setVisible(boolean) - Method in class com.bstek.dorado.view.control.MenuItem
设定菜单项是否可见.
setVisible(boolean) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组是否可见，不可见时将不在页面上创建该对象。
setVisible(boolean) - Method in class com.bstek.dorado.view.control.table.Column
设置表格中该列是否可见
setVisible(boolean) - Method in class com.bstek.dorado.view.control.tabset.TabElement
设定标签项表格是否可见。
setVisible(boolean) - Method in class com.bstek.dorado.view.data.ViewBaseField
设置字段是否在页面上可见.
setVisible(boolean) - Method in interface com.bstek.dorado.view.data.ViewField
设置字段是否在页面上可见.
setVisible(boolean) - Method in class com.bstek.dorado.view.data.ViewLookupField
设置字段是否在页面上可见.
setVisibleFields(String) - Method in class com.bstek.dorado.view.control.dropdown.DynamicDropDown
设定动态下拉框中要显示的数据列。
setWidth(String) - Method in interface com.bstek.dorado.view.control.Placeable
设置控件的宽度
setWidth(String) - Method in class com.bstek.dorado.view.control.PlaceableControl
设置控件的宽度
setWidth(String) - Method in class com.bstek.dorado.view.control.PlaceableDataControl
设置控件的宽度
setWidth(String) - Method in class com.bstek.dorado.view.control.autoform.AutoForm
设定AutoForm的宽度.
setWidth(String) - Method in class com.bstek.dorado.view.control.autoform.FormGroup
设置组的宽度值。
setWidth(int) - Method in class com.bstek.dorado.view.control.command.Frame
取得目标框架的宽度值.
setWidth(int) - Method in class com.bstek.dorado.view.control.dropdown.DropDown
设定下拉框的默认宽度
setWidth(int) - Method in class com.bstek.dorado.view.control.table.DataColumn
设置列显示的宽度。
setWriteFields(String) - Method in class com.bstek.dorado.view.control.dropdown.AdvanceDropDown
设置下拉框中需要为对应目标数据集赋值的字段.
setWriteFields(String) - Method in class com.bstek.dorado.view.control.dropdown.DatasetDropDown
设置下拉框中需要为对应目标数据集赋值的字段.
size() - Method in class com.bstek.dorado.data.RecordSet
取得总记录数
size() - Method in interface com.bstek.dorado.utils.collection.ObjectCollection
返回对象列表中的对象数量。
size() - Method in class com.bstek.dorado.utils.collection.ObjectList
返回对象列表中的对象数量。
sortRules() - Method in class com.bstek.dorado.data.db.AutoSqlDataset
返回AutoSqlDataset所有SortRule的集合对象。
split(String, String) - Static method in class com.bstek.dorado.utils.StringHelper
根据指定的分割符将字符串分割成字符串数组。
start() - Method in class com.bstek.dorado.utils.SynchroTimer
启动定时器
state - Variable in class com.bstek.dorado.data.ReadRecord
stop() - Method in class com.bstek.dorado.utils.SynchroTimer
终止定时器
storeObject(DoradoContext, String, String, Object) - Static method in class com.bstek.dorado.common.scope.ScopeHelper
根据属性名将一个对象存入相应的资源当中
storeUploadFile(HttpServletRequest, FileItem, File, MetaData) - Method in class com.bstek.dorado.biz.FileController
存储已经上传的文件
switchValue(boolean, Object, Object) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
开关值.
systemErr(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
systemErr
systemOut(Object) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
systemOut
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


T-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

T

TABPLACEMENT_BOTTOM - Static variable in class com.bstek.dorado.view.control.tabset.TabSet
标签页按钮的位置 - 下部
TABPLACEMENT_TOP - Static variable in class com.bstek.dorado.view.control.tabset.TabSet
标签页按钮的位置 - 上部
TEXT - Static variable in class com.bstek.dorado.view.control.TextEditor
文本编辑器类型 - 普通编辑框
TEXT - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - text
TEXTAREA - Static variable in class com.bstek.dorado.view.control.TextEditor
文本编辑器类型 - 多行文本编辑器
TEXTAREA - Static variable in class com.bstek.dorado.view.control.table.EditableColumn
编辑列的表现类型 - textarea
TIME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - Time型。
TIME_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - Time型。
TOP - Static variable in class com.bstek.dorado.view.control.command.Frame
在当前页面所处的框架的最顶层的框架中打开新页面.
TRANSACTION_NOT_SUPPORTED - Static variable in class com.bstek.dorado.common.TransactionManager
不支持事务.
TRANSACTION_REQUIRED - Static variable in class com.bstek.dorado.common.TransactionManager
需要事务.
TRANSACTION_REQUIRES_NEW - Static variable in class com.bstek.dorado.common.TransactionManager
需要新事务.
TRANSACTION_SUPPORTS - Static variable in class com.bstek.dorado.common.TransactionManager
支持事务.
TYPE_BUTTON - Static variable in class com.bstek.dorado.view.control.PagePilot
TYPE_BUTTON
TYPE_LINK - Static variable in class com.bstek.dorado.view.control.PagePilot
TYPE_LINK
Tab - class com.bstek.dorado.view.control.tabset.Tab.
多页标签中的默认标签项
Tab(String) - Constructor for class com.bstek.dorado.view.control.tabset.Tab
构造器
Tab(String, String) - Constructor for class com.bstek.dorado.view.control.tabset.Tab
构造器
TabElement - class com.bstek.dorado.view.control.tabset.TabElement.
多页标签页中标签页的基类
TabElement(String) - Constructor for class com.bstek.dorado.view.control.tabset.TabElement
构造器
TabElement(String, String) - Constructor for class com.bstek.dorado.view.control.tabset.TabElement
构造器
TabSet - class com.bstek.dorado.view.control.tabset.TabSet.
多页标签 TabSet用于将网页上的内容区域管理,通过标签项的切换,动态显示网页上的部分控件.
TabSet(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.tabset.TabSet
构造器
Table - class com.bstek.dorado.view.control.table.Table.
表格的基类
Table(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.table.Table
构造器
TextEditor - class com.bstek.dorado.view.control.TextEditor.
文本编辑器 一般用于绑定数据集的字段,绑定后文本编辑器将会自动显示数据集当前记录中绑定字段的值.
TextEditor(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.TextEditor
构造器
TextEditorFormElement - class com.bstek.dorado.view.control.autoform.TextEditorFormElement.
文本输入框型的表单元素
TextEditorFormElement(FormGroup, String) - Constructor for class com.bstek.dorado.view.control.autoform.TextEditorFormElement
构造器
Transaction - interface com.bstek.dorado.common.Transaction.
Dorado事务对象的接口
TransactionManager - class com.bstek.dorado.common.TransactionManager.
Dorado事务的管理对象
Tree - class com.bstek.dorado.view.control.tree.Tree.
树状列表对象
Tree(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.tree.Tree
构造器
TreeGrid - class com.bstek.dorado.view.control.advance.TreeGrid.
树型表格 树型表格是一种树状列表和可编辑表格的结合体, 能够是用户以更加有效的方式浏览和编辑数据.
TreeGrid(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.advance.TreeGrid
构造器
TreeLevel - class com.bstek.dorado.view.control.tree.TreeLevel.
树状列表节点层的基类
TreeLevel(String) - Constructor for class com.bstek.dorado.view.control.tree.TreeLevel
构造器
TreeNode - class com.bstek.dorado.view.control.tree.TreeNode.
树节点对象的基类
TreeNode() - Constructor for class com.bstek.dorado.view.control.tree.TreeNode
构造器
timestamp() - Method in interface com.bstek.dorado.data.Dataset
返回该Dataset对象的事件戳。
timestamp() - Method in class com.bstek.dorado.data.DatasetAdapter
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
timestamp() - Method in class com.bstek.dorado.data.DatasetSupport
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
timestamp() - Method in class com.bstek.dorado.data.Index
返回Index时间戳，该时间戳实质是一个整数代表此索引的最后的更新时间。
timestamp() - Method in class com.bstek.dorado.data.Record
返回该Record对象的时间戳.该时间戳表示Record中数据最后被修改的时间.
timestamp() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
返回该Dataset对象的事件戳。该事件戳表示Dataset中数据最后被修改的时间。
toDO() - Method in class com.bstek.dorado.data.DORecord
转换为DataObject对象.
toDO() - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.
toDO(String) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
toDO(Collection) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.
toDO(Collection, String) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.
toDO() - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(String) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection, String) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO() - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(String) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的所有记录(包含被标记为"已删除"的记录)转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Collection, String) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的符合visibility指定的可见性的记录转换为对象集合.

集合中的单个对象的类型可能是Bean或java.util.HashMap, 具体由Dataset的objectClazz属性决定.

toDO(Object) - Method in class com.bstek.dorado.data.Record
转换为DataObject对象.
toDO() - Method in class com.bstek.dorado.data.Record
转换为DataObject对象.
toObject(byte) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(short) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(int) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(long) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(float) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(double) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toDouble
toObject(boolean) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toDouble
toObject(Date) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(BigDecimal) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toObject(String) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
toObject
toSingleDO() - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中给定的记录转换为对象
toSingleDO(Object) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record, Object) - Method in interface com.bstek.dorado.data.Dataset
自动将Dataset中给定的记录转换为对象
toSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record, Object) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中给定的记录转换为对象
toSingleDO() - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record) - Method in class com.bstek.dorado.data.DatasetAdapter
自动将Dataset中给定的记录转换为对象
toSingleDO() - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中给定的记录转换为对象
toSingleDO(Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中的当前记录转换为对象.
toSingleDO(Record, Object) - Method in class com.bstek.dorado.data.DatasetSupport
自动将Dataset中给定的记录转换为对象
toSingleDO(Record) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动将Dataset中给定的记录转换为对象
toSingleDO(Record, Object) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
自动将Dataset中给定的记录转换为对象
toString() - Method in class com.bstek.dorado.utils.variant.Variant
Returns a string representation of the object.
toString() - Method in class com.bstek.dorado.view.control.autoform.LayoutInfo
toValidString(Object) - Static method in class com.bstek.dorado.utils.StringHelper
将给定的对象转换为一个有效的字符串.
translate(CompiledText, DoradoContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段预编译好的字符串翻译成最终结果
translate(String, DoradoContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.
translate(CompiledText, JexlContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段字符串翻译成最终结果 该字符串中可以包含零到多个运行时变量.
translate(String, JexlContext) - Static method in class com.bstek.dorado.common.rtexpr.ExprHelper
将一段字符串翻译成最终结果
translate(String, String, String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
转换字符串的字符集.
translate(String, String, String) - Static method in class com.bstek.dorado.utils.StringHelper
将一个字符串转换为给定的编码格式.
translate(int, Object) - Static method in class com.bstek.dorado.utils.variant.VariantHelper
translate
translateFromISO(String, String) - Method in class com.bstek.dorado.common.rtexpr.impl.ExpressionUtils
将一个iso8859-1字符串转换为给定的编码格式.
translateFromISO(String, String) - Static method in class com.bstek.dorado.utils.StringHelper
将一个iso8859-1字符串转换为给定的编码格式.
trimEndSeparator(String) - Static method in class com.bstek.dorado.utils.http.UrlUtil
移除字符串两端的URL分隔符，即移除字符串两端的'/'。
typeToName(int) - Static method in class com.bstek.dorado.utils.variant.DataType
typeToName
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


U-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

U

UNKNOWN - Static variable in class com.bstek.dorado.data.db.DBStatement
未知的SQL类型
UNKNOWN - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型 - 未知类型。
UNKNOWN_NAME - Static variable in class com.bstek.dorado.utils.variant.DataType
数据类型名称 - 未知类型。
UPDATE - Static variable in class com.bstek.dorado.data.db.DBStatement
SQL类型 - UPDATE
UniqueKey - class com.bstek.dorado.utils.UniqueKey.
用于取得一个VM唯一标识。
Unit - class com.bstek.dorado.action.mapping.Unit.
对应一个Mapping配置文件，用于管理其中所有的配置信息
Unit(String) - Constructor for class com.bstek.dorado.action.mapping.Unit
构造器
UpdateCommand - class com.bstek.dorado.view.control.command.UpdateCommand.
提交命令
UpdateCommand(ViewModel, String) - Constructor for class com.bstek.dorado.view.control.command.UpdateCommand
构造器
UpdateDataRPCHandler - class com.bstek.dorado.view.rpc.UpdateDataRPCHandler.
用于处理客户端发送的动态数据更新操作的处理类
UpdateDataRPCHandler() - Constructor for class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
UrlUtil - class com.bstek.dorado.utils.http.UrlUtil.
与处理URL相关的工具类
UserConfig - class com.bstek.dorado.common.UserConfig.
用于保存Dorado的Server运行时属性的对象
UserNotLoggedInException - exception com.bstek.dorado.security.UserNotLoggedInException.
用户没有登录的异常
UserNotLoggedInException() - Constructor for class com.bstek.dorado.security.UserNotLoggedInException
构造器
UserNotLoggedInException(String) - Constructor for class com.bstek.dorado.security.UserNotLoggedInException
构造器
UserNotLoggedInException(Throwable) - Constructor for class com.bstek.dorado.security.UserNotLoggedInException
构造器
unescape(String) - Static method in class com.bstek.dorado.utils.codec.EscapeUtils
对安全字符串进行解码，返回原始字符串。
unregisterContext() - Static method in class com.bstek.dorado.common.DoradoContext
从当前的线程中注销一个context对象
unregisterDetailLink(MasterDetailLink) - Method in interface com.bstek.dorado.view.data.ViewDataset
注销一个关联关系的对象。
unregisterDetailLink(MasterDetailLink) - Method in class com.bstek.dorado.view.data.ViewDatasetSupport
注销一个关联关系的对象。
update() - Method in interface com.bstek.dorado.data.Dataset
把用户对Dataset中数据的操作更新到外部数据中.
update() - Method in class com.bstek.dorado.data.DatasetAdapter
把用户对Dataset中数据的操作更新到外部数据中.
update() - Method in class com.bstek.dorado.data.DatasetSupport
把用户对Dataset中数据的操作更新到外部数据中.
update() - Method in class com.bstek.dorado.data.Index
检查并更新当前的Index，使其能够正确的反应Dataset中当前的数据。
update() - Method in class com.bstek.dorado.view.data.ViewDatasetAdapter
把用户对Dataset中数据的操作更新到外部数据中.
updateData(ParameterSet) - Method in interface com.bstek.dorado.view.ViewModel
对ViewModel中的Dataset进行持久化。
updateData(ParameterSet) - Method in class com.bstek.dorado.view.ViewModelSupport
对ViewModel中的Dataset进行持久化。
updateDataset(ViewModel, RecordInfo) - Method in class com.bstek.dorado.view.rpc.UpdateDataRPCHandler
updateDeletedRecord(UpdateSqlInfo, Record) - Method in class com.bstek.dorado.data.db.DBDataset
向数据库中更新一条删除的记录。
updateModifiedRecord(UpdateSqlInfo, Record) - Method in class com.bstek.dorado.data.db.DBDataset
向数据库中更新一条修改过的记录。
updateNewRecord(UpdateSqlInfo, Record) - Method in class com.bstek.dorado.data.db.DBDataset
向数据库中更新数据一条新增的记录。
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


V-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

V

VERTICAL - Static variable in class com.bstek.dorado.view.control.RadioGroup
VERTICAL
VERTICAL - Static variable in class com.bstek.dorado.view.control.autoform.AutoForm
组的布局方式 - 垂直方式
VIEW - Static variable in class com.bstek.dorado.common.DoradoContext
作用域类型 - View.用于访问视图模型(ViewModel)的Properties中的属性值.
VIEWMODE_ICON - Static variable in class com.bstek.dorado.view.control.MenuOutlookBarGroup
VIEWMODE_FLOW
VIEWMODE_LIST - Static variable in class com.bstek.dorado.view.control.MenuOutlookBarGroup
VIEWMODE_HORIZONTAL
VISIBLE - Static variable in class com.bstek.dorado.view.control.DataPilot
VISIBLE - Static variable in class com.bstek.dorado.view.control.autoform.FormElement
Validator - interface com.bstek.dorado.view.data.validate.Validator.
校验器的基类
ValidatorInfo - class com.bstek.dorado.view.data.validate.impl.ValidatorInfo.
校验信息对象
ValidatorInfo() - Constructor for class com.bstek.dorado.view.data.validate.impl.ValidatorInfo
Variant - class com.bstek.dorado.utils.variant.Variant.
可支持多种类型的对象
Variant() - Constructor for class com.bstek.dorado.utils.variant.Variant
Variant
Variant(int) - Constructor for class com.bstek.dorado.utils.variant.Variant
Variant
VariantHelper - class com.bstek.dorado.utils.variant.VariantHelper.
Variant的一些辅助操作
VariantSet - class com.bstek.dorado.utils.variant.VariantSet.
可支持多种类型的对象集合。
VariantSet() - Constructor for class com.bstek.dorado.utils.variant.VariantSet
构造器
ViewBaseField - class com.bstek.dorado.view.data.ViewBaseField.
视图模型中数据字段的基础类
ViewBaseField(String) - Constructor for class com.bstek.dorado.view.data.ViewBaseField
构造器
ViewDataset - interface com.bstek.dorado.view.data.ViewDataset.
视图模型中数据集对象的基础类
ViewDatasetAdapter - class com.bstek.dorado.view.data.ViewDatasetAdapter.
视图模型数据集适配器
ViewDatasetAdapter(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.ViewDatasetAdapter
构造器
ViewDatasetSupport - class com.bstek.dorado.view.data.ViewDatasetSupport.
视图数据集的抽象基类。
ViewDatasetSupport(ViewModel, String) - Constructor for class com.bstek.dorado.view.data.ViewDatasetSupport
AbstractViewDataset
ViewField - interface com.bstek.dorado.view.data.ViewField.
视图模型中数据集字段对象
ViewLookupField - class com.bstek.dorado.view.data.ViewLookupField.
视图模型中LookupField对象
ViewLookupField(String) - Constructor for class com.bstek.dorado.view.data.ViewLookupField
构造器
ViewModel - interface com.bstek.dorado.view.ViewModel.
视图模型 ViewModel是一种用于封装界面逻辑和操作逻辑的对象.
ViewModelSupport - class com.bstek.dorado.view.ViewModelSupport.
视图模型的基本实现
ViewModelSupport() - Constructor for class com.bstek.dorado.view.ViewModelSupport
构造器
ViewRecord - class com.bstek.dorado.view.data.ViewRecord.
视图模型中Dataset的记录对象
ViewRecord() - Constructor for class com.bstek.dorado.view.data.ViewRecord
Visible - interface com.bstek.dorado.view.control.Visible.
可见控件的接口
validate() - Method in class com.bstek.dorado.data.Record
检查对记录所作的修改的有效性.
validate(String) - Static method in class com.bstek.dorado.utils.StringHelper
将传入的字符串转换成一个有效的字符串
validate() - Method in class com.bstek.dorado.view.data.ViewRecord
检查对记录所作的修改的有效性.
validate(Object) - Method in interface com.bstek.dorado.view.data.validate.Validator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.CustomValidator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.LengthValidator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.ListValidator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.PatternValidator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.RangeValidator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validate(Object) - Method in class com.bstek.dorado.view.data.validate.impl.RequiredValidator
对传入的数据执行校验.如果校验失败将抛出IllegalValueException异常.
validateCursor() - Method in class com.bstek.dorado.data.DatasetSupport
validateCurrent
variantSetToDO(VariantSet, Object) - Static method in class com.bstek.dorado.data.DOUtils
将给定的变量集合中包含的数据设置到给定的对象当中.
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


W-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

W

warn(Object) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_WARN 的字符串记录到日志文件里。
warn(Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
warn(Object, Throwable) - Static method in class com.bstek.dorado.common.log.Log
把日志信息优先级为 LEVEL_WARN 的信息记录到日志文件里。
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


X-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

X

XmlBuilder - interface com.bstek.dorado.utils.xml.XmlBuilder.
XML构造器的接口
XmlConfigUtils - class com.bstek.dorado.utils.xml.XmlConfigUtils.
用于辅助XML到Object解析过程的工具类。
XmlDocument - interface com.bstek.dorado.utils.xml.XmlDocument.
用于封装第三方的XML解析器中的文档对象。
XmlFactory - class com.bstek.dorado.utils.xml.XmlFactory.
XML解析对象的工厂类。
XmlNode - interface com.bstek.dorado.utils.xml.XmlNode.
用于封装第三方的XML解析器中的XML节点对象。
XmlOutputter - interface com.bstek.dorado.utils.xml.XmlOutputter.
XML输出器的接口。
XmlParseException - exception com.bstek.dorado.utils.xml.XmlParseException.
Xml解析异常
XmlParseException() - Constructor for class com.bstek.dorado.utils.xml.XmlParseException
XmlParseException
XmlParseException(String) - Constructor for class com.bstek.dorado.utils.xml.XmlParseException
XmlParseException
XmlParseException(Throwable) - Constructor for class com.bstek.dorado.utils.xml.XmlParseException
DoradoException
Overview Package Class Use Tree Deprecated Index Help
A B C D E F G H I J K L M N O P Q R S T U V W X _


_-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _

_

_children - Variable in class com.bstek.dorado.view.control.tree.TreeNode
Overview Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
A B C D E F G H I J K L M N O P Q R S T U V W X _